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Analyzing, Measuring, and Comparing Objects: Overview
Analyzing, Comparing, and Measuring Objects describes analytic, comparison, and measurement features that are available in many workbenches. These include the ability to: • • • analyze -- distance and band analysis, 2D drawings, 3D geometry, cross sectioning, and clash: interference compare products measure various distances, angles, radii, thicknesses, and create geometry from measures, associate measures and inertia

As well as the ability to export some of these analyses.
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What's New?
Enhanced Functionalities
Measure Tools
Exact maximum orthogonal distance Using the Measure Between and Measure Item commands, you can now calculate the exact maximum orthogonal distance on G-1/surface/volume reconverged from approximate mode measures. Measure Between You can now obtain approximate maximum distance for wireframe Updating Measures The update error mechanism is now available when working on a Part document The update is not automatic at Product opening.

Customizing Settings
DMU Sectioning The Allow measures on a section created with a simple plane checkbox is cleared by default
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Getting Started
Sectioning
This task shows you how to create a section plane on the minimum distance. 1. Select Distance.1 (i.e. the minimum distance you measured in the previous tasks) in the geometry area. icon in the DMU Space Analysis toolbar. The section plane 2. Click the Sectioning is created on the minimum distance. The Sectioning Definition dialog box appears.

The Section viewer, showing the generated section, is automatically tiled vertically alongside the document window. The section view is a filled view.

3. Click the Positioning tab, then the Edit Position and Dimensions icon to change parameters defining the current plane position. The Edit Position and Dimensions dialog box appears. The U-axis of the section plane is positioned along the minimum distance.
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4. 5. Click the +Ru and -Ru buttons (Rotations box) to rotate the plane around the minimum distance. 6. Click Close in the Edit Position and Dimensions dialog box when done.

7. Click the Result tab in the Sectioning Definition dialog box to access commands specific to the Section viewer.

6

Getting Started

8. Select the Grid icon

to display a 2D grid.

9. Select Analyze -> Graphic Messages -> Coordinate from the menu bar to activate the coordinates option.

10. Move the mouse over the geometry in the results window to display the coordinates of the point selected.

11. Deselect the coordinates option. 7
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12. In the Definition tab, click the Volume Cut icon to obtain a 3D section cut. The material in the negative direction along the normal vector of the plane (W-axis) is cut away. The cavity within the product is exposed:

13. Re-click the Volume Cut icon to restore the representation. 14. Click OK in the Sectioning Definition dialog box when done to exit the sectioning command.

Detecting Clashes
This task shows you how to detect contacts and clashes between all the components in your document. 1. Click the Clash icon dialog box appears. in the DMU Space Analysis toolbar. The Check Clash

Contact + Clash checks whether two products occupy the same space zone as well as whether they are in contact. Between all components is the default value for the second Type drop-down list. 2. Click Apply to run the analysis:

8
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The Check Clash dialog box expands to show the global results. 21 interferences have been detected. The first conflict is selected by default: a contact.

3. Select the first clash conflict in the list: the penetration depth is given.

A Preview window also appears showing the products in the selected conflict. The clash is identified by red intersection curves, the value of the penetration depth is given and the direction of extraction indicated.
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4. Click OK when done.

Measuring Distances between Geometrical Entities ()
The Measure Between command lets you measure distance between geometrical entities. You can measure: • • Minimum distance and, if applicable angles, between points, surfaces, edges, vertices and entire products Or, Maximum distance between two surfaces, two volumes or a surface and a volume.

This section deals with the following topics:

•

•

Measuring minimum distance and angles o Dialog box options o Accessing other measure commands o Defining measure types o Defining selection 1 & selection 2 modes o Defining the calculation mode o Sectioning measure results Measuring maximum distance o About maximum distance o Between two G-1 continuous surfaces

10

Getting Started o Between Wire frame entities o Step-by-step scenario Measuring distances in a local axis system Customizing measure between Editing measures Creating geometry from measure results Exact measures on CGRs and in visualization mode Measuring angles Updating measures Using measures in knowledgeware Measure cursors Restrictions

• • • • • • • • • •

Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, NOZZLE1.model, NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and VALVE.model. They are to be found in the online documentation file tree in the common functionalities sample folder cfysm samples.

Measuring Minimum Distance and Angles
This task explains how to measure minimum and, if applicable, angles between geometrical entities (points, surfaces, edges, vertices and entire products). 1. Click the Measure Between icon . In DMU, you can also select Analyze-> Measure Between from the menu bar. The Measure Between dialog box appears:

11
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By default, minimum distances and if applicable, angles are measured. By default, measures made on active products are done with respect to the product axis system. Measures made on active parts are done with respect to the part axis system. Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service Pack 1 where all measures are made with respect to the absolute axis system.

Dialog box options
o Other Axis check box: when selected, lets you measure distances and angles with respect to a local V5 axis system. Keep Measure check box: when selected, lets you keep the current and subsequent measures as features. This is useful if you want to keep the measures as annotations for example.

o

o Some measures kept as features are associative and can be used to valuate parameters or in

12

Getting Started formulas.

Note that in the Drafting and Advanced Meshing Tools workbenches, measures are done on-the-fly and are therefore not persistent nor associative and cannot be used as parameters. 2. Create Geometry button: lets you create the points and line corresponding to the minimum distance result. 3. Customize... button: lets you customize display of measure results.

Accessing other measure commands
• The Measure Item command is accessible from the Measure Between dialog box. In DMU, the Measure Thickness command is also accessible from the Measure Between dialog box. For more informati

•
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analyzing on, see the DMU Space Analysis User's Guide. Select the desired measure type. Notice that the image in the dialog box changes depending on the measure type selected.

Set the desired mode in the Selection 1 and Selection 2 mode drop-down list boxes. Set the desired calculation mode in the Calculation mode drop-down list box. Click to select a surface, edge or vertex, or an entire product (selection 1). Notes: • • The appearance of the cursor has changed to assist you. Dynamic highlighting of geometrical entities helps you locate items to click on.

Click to select another surface, edge or vertex, or an entire product (selection 2). A line representing the minimum distance vector is drawn between the selected items in the geometry area. Appropriate distance values are displayed in the dialog box. Note: For reasons of legibility, angles between lines and/or curves of less than 0.02 radians (1.146 degrees) are not displayed in the geometry area.
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By default, the overall minimum distance and angle, if any, between the selected items are given in the Measure Between dialog box. Select another selection and, if desired, selection mode. Set the Measure type to Fan to fix the first selection so that you can always measure from this item. Select the second item.

15
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Select another item. Click Ok when done.

Defining measure types

• • •

Between (default type): measures distance and, if applicable, angle between selected items. Chain: lets you chain measures with the last selected item becoming the first selection in the next measure. Fan: fixes the first selection as the reference so that you always measure from this item.

Defining selection 1 & selection 2 modes
• Any geometry: measures distances and, if applicable, angles between defined geometrical entities (points, edges, surfaces, etc.). By default, Any geometry option is selected Note: The Arc center mode is activated in this selection mode. This mode recognizes the axis of cylinders and lets you measure the distance between two cylinder axes for example. Selecting an axis system in the specification tree makes the distance measure from the axis system origin. You can select sub-entities of V5 axis systems in the geometry area only. For V4 axis systems, distances are always measured from the origin.

16
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•

Any geometry, infinite: measures distances and, if applicable, angles between the infinite geometry (plane, line or curve) on which the selected geometrical entities lie. Curves are extended by tangency at curve ends. Line Plane Curve

The Arc center mode is activated and this mode also recognizes cylinder axes. For all other selections, the measure mode is the same as any geometry. Any geometry, infinite

Any geometry

17
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•

Picking point: measures distances between points selected on defined geometrical entities. Notes: o The picking point is selected on visualization mode geometry and depends on the sag value used. It may not correspond to the exact geometry. The resulting measure will always be non associative.

o

In the DMU section viewer, selecting two picking points on a curve gives the distance along the curve between points (curve length or CL) as well as the minimum distance between points. Notes: • • Both points must be located on the same curve element. The minimum distance option must be set in the Measure Between Customization dialog box.

18
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• •

• •

Point only: measures distances between points. Dynamic highlighting is limited to points. Edge only, Surface only: measures distances and, if applicable, angles between edges and surfaces respectively. Dynamic highlighting is limited to edges or surfaces and is thus simplified compared to the Any geometry mode. All types of edge are supported. Product only: measures distances between products. Products can be specified by selecting product geometry, for example an edge or surface, in the geometry area or the specification tree. Picking axis: measures distances and, if applicable, angles between an entity and an infinite line perpendicular to the screen. Simply click to create infinite line perpendicular to the screen. Note: The resulting measure will always be approximate and non associative.

•

Intersection: measures distances between points of intersection between two lines/curves/edges or a line/curve/edge and a surface. In this case, two selections are necessary to define selection 1 and selection 2 items. Geometrical entities (planar surfaces, lines and curves) are extended to infinity to determine the point of intersection. Curves are extended by tangency at curve ends. Curve-plane

Line-plane 19

analyzing

Customizing Measure Between
Customizing lets you choose what distance you want to measure:

• • •

Minimum distance (and angle if applicable) Maximum distance Maximum distance from 1 to 2.

Note: These options are mutually exclusive. Each time you change option, you must m By default, minimum distances and if applicable, angles are measured. You can also choose to display components and the coordinates of the two points (point 1 and poi distance is measured. What you set in the dialog box determines the display of the results in both the geometry area an

Measuring Maximum Distance

20
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About Maximum Distance

You can measure the maximum distance between two G-1 surfaces, two volumes or a surface and

Distance is measured normal to the selection and is always approximate. Two choices are availabl

•

Maximum distance from 1 to 2: gives the maximum distance of all distances measured from Note: This distance is, in general, not symmetrical.

•

Maximum distance: gives the highest maximum distance between the maximum distance m and the maximum distance measured from selection 2.

Note: All selection 1 (or 2) normals intersecting selection 1 (or 2) are ignored. •
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Between two G-1 continuous surfaces on a part in Design mode (result is exact)
You can now calculate the maximum distance between two G1 (continuous at the tangency level) The resulting measure is exact.

Note: G-1 stands for geometric tangency, it basically means: surfaces which are continuous a

Between Wire frame entities

You can now calculate the maximum perpendicular deviation between point, lineic and surfacic ele surface/surface which uses max perpendicular distance see table below) The table below lists the possible wire frame selections for measuring maximum distance:

Entity Surface Curve Point

surface

Curve

Point

No Yes Yes

Yes Yes Yes

Yes Yes MIN
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Step-by-Step Scenario

1. Click Customize... and check the appropriate maximum distance option in the Measure Betw box, then click OK. 2. Make your measure: o o o o Select the desired measure type Set the desired selection modes Set the desired calculation mode Click to select two surfaces, two volumes or a surface and a volume.

3. Click OK when done.

Measuring Distances in a Local Axis System
The Other Axis option in the dialog box lets you measure distance in a local axis system.

This type of measure is associative: if you move the axis system, the measure is impacted and ca You need a V5 axis system to carry out this scenario
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1. Select the Other Axis check box in the dialog box. 2. Select a V5 axis system in the specification tree or geometry area. 3. Make your measure.

In the examples below, the measure is a minimum distance measure and the coordina between which the distance is measured are shown. Same measure made with respect to absolute axis system:

Note: All subsequent measures are made with respect to the selected axis system. 4. To change the axis system, click the Other Axis field and select another axis system. 5. To return to the absolute axis system, click to clear the Other Axis check box 6. Click OK when done.

Restrictions
• • • • Neither Visualization Mode nor cgr files permit selection of individual vertices.

is not accessible. In the No Show space, the Measure Between command Measures performed on sheet metal features provide wrong results. In unfolded view, volu into account when measuring Part Bodies.

Measures are not associative when switching between folded view and unfolded view (using
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Getting Started in the Sheet Metal toolbar).

Measuring Minimum Distances between Products
This task shows you how to measure minimum distances between products. 1. Click the Distance and Band Analysis icon in the DMU Space Analysis toolbar. The Edit Distance and Band Analysis dialog box appears.

2. Select a product, for example the Regulation_Command. 3. Click the second Type drop-down list box and select Between two selections. 4. Select two other products, for example both nozzles.
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5. Click Apply to calculate the distance between selected products. A Preview window appears visualizing selected products and the minimum distance (represented by a line, two arrows and a value).

The Edit Distance and Band Analysis dialog box expands to show the results and the minimum distance is also visualized in the geometry area.

26
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6. Click OK in the Edit Distance and Band Analysis dialog box.

Reporting Measurements and Attributes
This task demonstrates how to use the Geometry Reporter to obtain volume and attribute information for solids in a large model. In the model below, we will use the Geometry Reporter to export solids that have the Review dictionary's attribute package Schematic Design Review attached.

27
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1. Double click on the Product or Part you want to be the root of the extraction: it becomes the active object. 2. Make sure objects you want to export do not have their Hide/Show property set to Hide; make sure objects you do not want to export do not have their Hide/Show property set to Show. 3. Make sure the current dictionary is set to Review and the current attribute package is set to Schematic Design Review.

4. Make sure the current units for the magnitude Volume is set to the units you want in the report. In this case, we want Cubic meter (m3).
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Getting Started 5. If you choose an existing file to write the extraction to, make sure it is not open or Quantity Extraction will not export to it.

1. Select

from

The Quantity Extraction dialog box appears:

2. We shall choose the following options:

This will search all the solids underneath our active object that have the

29

analyzing Schematic Design Review package attached to them. Then based on the solids found, the Geometry Reporter will report the name of the part containing each solid and each solid's feature name, volume, and attribute values for Schematic Design Review. We have specified in the Export File box that we want the report written to the file C:\attributeExtraction.csv. 3. Click OK to complete the export. 4. The exported file is in CSV (Comma Separated Values) format. Open the file in a spreadsheet application for easy viewing.

For more detailed information about measurement and attribute reports, see Generating Custom Quantity Reports.
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Basic Tasks
Sectioning
Sectioning
About sectioning: Gives general information about the Sectioning command. Create section planes: Click the Sectioning icon. Change section graphic properties: Gives information about changing line segment color, linetype, and thickness, as well as plane color. Create section slices: Create a section plane then click the Section Slice icon in the Sectioning Definition dialog box. Create section boxes: Create a section plane then click the Section Box icon in the Sectioning Definition dialog box. More about the Section viewer: Create a section plane. Create 3D section cuts: Create a section plane then click the Volume Cut icon. Manipulate planes directly: Create a section plane, drag plane edges to redimension, drag plane to move it along the normal vector, press and hold left and middle mouse buttons down to move plane in U,V plane of local axis system or drag plane axis to rotate plane. Position planes using the Edit Position and Dimensions command: Create a section plane, click the Edit Position icon and enter parameters defining the plane position in the dialog box. Position planes on a geometric target: Create a section plane, click the Geometrical Target icon and point to the target of interest. Snap boxes to planes: Create a section box, click the Geometrical Target icon and select two or three planes. Snap planes to points and/or lines: Create a section plane, click the Positioning by 2/3 Selections icon and make your selections. Export section results: Generate section results then click the Export As icon to export to a V4 model, V5 CATPart, IGES or VRML document. Capture section results: Generate section results then select Tools ->Image ->Capture Annotate generated sections: Gives information about annotating using generic measure tools and 3D and 2D annotation tools. Manage the update of section results: Generate section results, then select appropriate option in Behavior tab and exit command. More about the contextual menu: Right-click the section feature or section in geometry area and select the command from the menu.

About Sectioning

31

analyzing

Using cutting planes, you can create sections, section slices, section boxes as well as 3D section cu your products automatically.

• • • • •

Section Plane Manipulating the Plane Section Results 3D Section Cut P1 and P2 Capabilities o Creating Groups of products

Creating section slices and section boxes are DMU-P2 functionalities.

Section Plane

The section plane is created parallel to absolute coordinates Y, Z. The center of the plane is located the center of the bounding sphere around the products in the selection you defined.

•

Line segments represent the intersection of the plane with all surfaces and volumes in the selection. By default, line segments are the same color as the products sectioned.

•

Points represent the intersection of the plane with any wireframe elements in the selection, are visible in both the document window and the Section viewer.
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Notes: • • Any surfaces or wireframe elements in the same plane as the section plane are not visible. If no selection is made before entering the command, the plane sections all products.

A plane has limits and its own local axis system. The letters U, V and W represent the axes. The W is the normal vector of the plane.

You can customize settings to locate the center and orient the normal vector of the plane as well a activate the default setting taking wireframe elements into account. This is done using the Tools ->Options..., Digital Mockup ->DMU Space Analysis command (DMU Sectioning tab).

Manipulating the Plane

Sectioning is dynamic (moving the plane gives immediate results). You can manipulate the cutting in a variety of ways: • • •

Directly Position it with respect to a geometrical target, by selecting points and/or lines Change its current position, move and rotate it using the Edit Position and Dimensions com

Section Results
Results differ depending on the sag value used. Using default value (0.2mm): Using a higher value:
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Sag: corresponds to the fixed sag value for calculating tessellation on objects (3D fixed accuracy) the Performance tab of Tools -> Options -> General -> Display. By default, this value is set to 0.2 mm.

In Visualization mode, you can dynamically change the sag value for selected objects using the T > Modify SAG command.

3D Section Cut

3D section cuts cut away the material from the cutting plane to expose the cavity within the produ beyond the slice or outside the box.

P1 and P2Capabilities
In DMU-P1, you cannot select products to be sectioned: the plane sections all products.

Creating Groups of Products
In DMU-P2, prior to creating your section plane, you can create a group containing the product(s) interest using the Group bar.

icon in the DMU Space Analysis toolbar or Insert -> Group... in the m

Groups created are identified in the specification tree and can be selected from there for sectioning one group per selection can be defined
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Changing Section Graphic Properties
To make it easier to read your result, you can: • • Specify different properties (color, linetype and thickness) for section line segments. By default line segments are the same color as the products sectioned. Change the plane color of the current feature.
You can change... Via Properties command - Graphic tab Via Graphic Properties toolbar3

Visibl

Line segment: Color Linetype Thickness Plane: Color • Yes1 (Lines and Curves) Yes1 (Lines and Curves) Yes1 (Lines and Curves) Yes2 (Fill Color) No Yes Yes Yes

3D documen window Yes Yes Yes Yes

Legend: (1) To change the line segment color, linetype and thickness, right-click the section in the geometr select Properties (2) To change the plane color, right-click the specification tree feature and select Properties (3) To return to the initial colors, select No color.

Section Planes
Manipulating Planes Directly
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You can re-dimension, move and rotate section planes, or the master plane in the case of section s and boxes, directly. As you move the cursor over the plane, the plane edge or the local axis system appearance changes and arrows appear to help you.

Sectioning results are updated in the Section viewer as you manipulate the plane.

To change this setting and have results updated when you release the mouse button only, de-activ the appropriate setting in the DMU Sectioning tab (Tools ->Options..., Digital Mockup ->DMU Space Analysis). This task illustrates how to manipulate section planes directly. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples.

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar and create a section plane. A Section viewer showing the generated section is automatically tiled vertically alongside t document window. The generated section is automatically updated to reflect any changes to the section plane.You can re-dimension the section plane: 2. Click and drag plane edges to re-dimension plane:
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Note: A dynamic plane dimension is indicated as you drag the plane edge. You can view and edit plane dimensions in the Edit Position and Dimensions command. Th plane height corresponds to its dimension along the local U-axis and the width to its dime along the local V-axis.You can move the section plane along the normal vector of the plan

3. Move the cursor over the plane, click and drag to move the plane to the desired location.Y can move the section plane in the U,V plane of the local axis system:

4. Press and hold down the left mouse button, then the middle mouse button and drag (still holding both buttons down) to move the plane to the desired location. You can rotate the s plane around its axes:

5. Move the cursor over the desired plane axis system axis, click and drag to rotate the plane around the selected axis.
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6. (Optional) Click the Reset Position icon in the Positioning tab of the Sectioning Definit dialog box to restore the center of the plane to its original position. 7. Click OK in the Sectioning Definition dialog box when done. Note: You cannot re-dimension, move or rotate the plane via the contextual menu command Hide/Show the plane representation. 8.

Positioning Planes Using the Edit Position and Dimensions Command

In addition to manipulating the plane directly in the geometry area, you can position the section pl more precisely using the Edit Position and Dimensions command. You can move the plane to a new location as well as rotate the plane. You can also re-dimension the section plane.

In the case of section slices and boxes, it is the master plane that controls how the slice or box wil positioned.

This task illustrates how to position and re-dimension the section plane using the Edit Position and Dimensions command. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon Analysis toolbar and create a section plane. in the DMU

A Section viewer showing the generated section is automatically tiled vertically alongside t document window. The generated section is automatically updated to reflect any changes m to the section plane. The Sectioning Definition dialog box is also displayed. 2. Click the Positioning tab in the Sectioning Definition dialog box.
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3. Click the Edit Position and Dimensions icon plane.

to enter parameters defining the position of

The Edit Position and Dimensions dialog box appears.

4.

5. Enter values in Origin X, Y or Z boxes to position the center of the plane with respect to the absolute system coordinates entered. By default, the center of the plane coincides with the center of the bounding sphere aroun products in the current selection. Notes: o Using the Tools -> Options... command (DMU Sectioning tab under Digital Mockup >DMU Space Analysis), you can customize settings for both the normal vector and origin of the plane Units are current units set using Tools -> Options.

o

6. Enter the translation step directly in the Translation spin box or use spin box arrows to scro new value, then click -Tu, +Tu, -Tv, +Tv, -Tw, +Tw, to move the plane along the selected a by the defined step.

Note: Units are current units set using Tools-> Options (Units tab under General-> Parame and Measure).

7. Change the translation step to 25mm and click +Tw for example. The plane is translated 25 in the positive direction along the local W-axis.
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You can rotate the section plane. Rotations are made with respect to the local plane axis sy

You can move the section plane to a new location. Translations are made with respect to th local plane axis system.

8. Enter the rotation step directly in the Rotation spin box or use spin box arrows to scroll to a value, then click -Ru, +Ru, -Rv, +Rv, -Rw, +Rw, to rotate the plane around the selected ax the defined step.

With a rotation step of 45 degrees, click +Rv for example to rotate the plane by the specifi amount in the positive direction around the local V-axis.
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You can edit plane dimensions. The plane height corresponds to its dimension along the loc axis and the width to its dimension along the local V-axis. You can also edit slice or box thickness.

9. Enter new width, height and/or thickness values in the Dimensions box to re-dimension the plane. The plane is re-sized accordingly. 10. Click Close in the Edit Position and Dimensions dialog box when satisfied. 11. Click OK in the Sectioning Definition dialog box when done. • • • Use Undo and Redo icons in the Edit Position and Dimensions dialog box to cancel the last or recover the last action undone respectively.

in the Positioning tab of the Sectioning Definition dialog box Use the Reset Position icon restore the section plane to its original position. You can also view and edit plane dimensions in the Properties dialog box (Edit -> Properties via the contextual menu). This command is not available when using the sectioning command.

•
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Positioning Planes On a Geometric Target

You can position section planes, section slices and section boxes with respect to a geometrical targ face, edge, reference plane or cylinder axis). In the case of section slices and boxes, it is the mast plane that controls how the slice or box will be positioned. This task illustrates how to position a section plane with respect to a geometrical target. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation file tree in the common functionalities sample fo cfysm/samples.

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar and create a section plane. The Sectioning Definition dialog box app

A Section viewer showing the generated section is automatically tiled vertically alongs the document window. The generated section is automatically updated to reflect any changes made to the sec plane. 2. Click the Positioning tab in the Sectioning Definition dialog box.

3. Click the Geometrical Target icon 4. Point to the target of interest:

to position the plane with respect to a geometrical ta

A rectangle and vector representing the plane and the normal vector of the plane appe the geometry area to assist you position the section plane. It moves as you move the cursor.
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5. When satisfied, click to position the section plane on the target.

Notes: o o

To position planes orthogonal to edges, simply click the desired edge. A smart mode recognizes cylinders and snaps the plane directly to the cylinder This lets you, for example, make a section cut normal to a hole centerline. To d activate this mode, use the Ctrl key.

o

o

Selecting the Automatically reframe option in the DMU Sectioning tab (Tools -> Options -> Digital Mockup -> DMU Space Analysis), reframes the Section viewe locates the point at the center of the target at the center of the Section viewer Zooming in lets you pinpoint the selected point. This is particularly useful when using snap capabilities in a complex DMU sessio containing a large number of objects.
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o

6. (Optional) Click the Reset Position icon position.

to restore the center of the plane to its origina

7. Click OK in the Sectioning Definition dialog box when done.
P2 Functionality

In DMU-P2, you can move the plane along a curve, edge or surface: 1. Point to the target of interest 2. Press and hold down the Ctrl key

3. Still holding down the Ctrl key, move the cursor along the target. The plane is positioned ta to the small target plane 4. As you move the cursor, the plane moves along the curve or edge.

Creating Section Planes
This task shows how to create section planes and orient the normal vector of the plane. • Section Planes
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Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr. They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

Section Planes
The plane is created parallel to absolute coordinates Y,Z. The center of the plane is located at the center of the bounding sphere around the products in the selection you defined. • • Line segments represent the intersection of the plane with all surfaces and volumes in the selection. By default, line segments are the same color as the products sectioned. Points represent the intersection of the plane with any wireframe elements in the selection.

A section plane has limits and its own local axis system. U, V and W represent the axes. The W-axis is the normal vector of the plane. The contour of the plane is red. You can dynamically re-dimension and reposition the section plane. For more information, see Manipulating Section Planes Directly. Using the Tools ->Options... command (DMU Sectioning tab under Digital Mockup >DMU Space Analysis, you can change the following default settings:

• • •

Location of the center of the plane Orientation of the normal vector of the plane Sectioning of wireframe elements.

Step-by-Step Scenario
1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar to generate a section plane.
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The section plane is automatically created. If no selection is made before entering the command, the plane sections all products. If products are selected, the plane sections selected products.
P1 Functionality

In DMU-P1, you cannot select products to be sectioned: the plane sections all products. 2. Click the Selection box to activate it. 3. Click products of interest to make your selection, for example the TRIGGER and BODY1.Products selected are highlighted in the specification tree and geometry area. Note: Simply continue clicking to select as many products as you want. Products will be placed in the active selection. To de-select products, reselect them in the specification tree or in the geometry area. The plane now sections only selected products.
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You can change the current position of the section plane with respect to the absolute axis system of the document: 4. Click the Positioning tab in the Sectioning Definition dialog box.

5. Select X, Y or Z radio buttons to position the normal vector (W-axis) of the plane along the selected absolute system axis. Select Z for example. The plane is positioned perpendicular to the Z-axis.
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6. Double-click the normal vector of the plane (W-axis) or click the Invert Normal icon to invert it.

7. Click OK when done. The section plane definition and results are kept as a specification tree feature.

8. Click Close By default, the plane is hidden when exiting the command. Use the Tools>Options, Digital Mockup-> DMU Space Analysis command (DMU Sectioning
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Basic Tasks tab) to change this setting. o To show the plane, select Hide/Show the plane representation in the contextual menu. Note: In this case, you cannot edit the plane. To edit the plane again, double-click the specification tree feature.

o

9.

Results Window
A Section viewer is automatically tiled vertically alongside the document window. It displays a front view of the generated section and is by default, locked in a 2D view. Notice that the section view is a filled view. This is the default option. The fill capability generates surfaces for display and measurement purposes (area, center of gravity, etc.).

Sectioning Definition Dialog Box
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The Sectioning Definition dialog box appears. This dialog box contains a wide variety of tools letting you position, move and rotate the section plane as well as create slices, boxes and section cuts. For more information, see Positioning Planes with respect to a Geometrical Target, Positioning Planes Using the Edit Position Command, Creating Section Slices, Creating Section Boxes and Creating 3D Section Cuts.

P2 Functionalities
In DMU-P2, you can create as many independent section planes as you like. Creating section slices and section boxes are DMU-P2 functionalities.

Snapping Planes to Points and/or Lines
You can position section planes by selecting three points, two lines, or combination of the two. This task illustrates how to snap a section plane to a selection consisting of lines and/or points. No sample document is provided.

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning in the DMU Space Analysis toolbar and create a section plane. icon The Sectioning Definition dialog box appears.
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A Section viewer showing the generated section is automatically tiled vertically alongside the document window. 2. Click the Positioning tab of the Sectioning Definition dialog box. 3. Click the Positioning by 2/3 Selections icon hidden. 4. Make your selection of lines and/or points. o o The current selection is highlighted in red. The cursor changes to assist you make your selection. It identifies the type of item (point, line, cylinder, cone, etc.) beneath it. .The section plane is

A plane passing through the selection is computed and the section plane automatically snapped to this plane.

5. Click OK in the Sectioning Definition dialog box when done.

Creating Section Slices

This task explains how to create section slices. To do so, you must first create the master section p

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZ TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold
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1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU plane is automatically created. If no selection is made, the plane sections all products. If pr

This plane is the master plane and controls all operations on the section slice. The Sectioning Definition dialog box is displayed.

This dialog box contains a wide variety of tools letting you position, move and rotate th with respect to a Geometrical Target, and Positioning Planes Using the Edit Position Co A Section viewer is automatically tiled vertically alongside the document window. It dis locked in a 2D view.
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2. In the Definition tab of the Sectioning Definition dialog box, click the Section Slice drop-dow

A second plane, parallel to the first, is created. Together both planes define a section s The Section viewer is automatically updated.

3. Adjust the thickness of the section slice: position the cursor over one of the slave plane edg direction.

Note: As you move the cursor over plane edges, the cursor changes appearance and a defined appear. The thickness of the slice is also indicated as you drag.
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4. Click OK when done.

Section Boxes
Creating Section Boxes

This task explains how to create section boxes. To do so, you must first create the master section plane. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr. They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar to generate a section plane. The section plane is automatically created. If no selection is made before entering the command, the plane sections all products. If products are selected, the plane sections selected products.
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This plane is the master plane and controls all operations on the section box. The Sectioning Definition dialog box is displayed. This dialog box contains a wide variety of tools letting you position, move and rotate the master plane. For more information, see Positioning Planes with respect to a Geometrical Target, and Positioning Planes Using the Edit Position Command. A Section viewer is automatically tiled vertically alongside the document window. It displays a front view of the generated section and is by default, locked in a 2D view.
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2. 3. In the Definition tab, click the Section Box section box: drop-down icon to create a

A sectioning box is created. The contours of box planes are red. The Section viewer is automatically updated. 4. Adjust the thickness of the section box: position the cursor over one of the slave box plane edges, click then drag to translate the plane in the desired direction.

Notes: o As you move the cursor over box edges, the cursor changes appearance and arrows identifying the directions along which box thickness is defined appear. Box thickness is also indicated as you drag.

o o

You can also re-size the box by clicking and dragging one of the box sides. Arrows likewise appear to help you. Use the Geometrical Target boxes to planes. icon in the Positioning tab to snap
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5. Click OK when done. You can create boxes around the various areas of your product and then, using the Volume Cut command isolate the area on which you want to work.

Snapping Section Boxes to Planes

You can snap section boxes to two planes. The first target positions the master plane, the second defines a rotation (if needed) and adjusts box dimensions. This task illustrates how to snap a section box to two planes. No sample document is provided. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar and create a section box.

The Sectioning Definition dialog box appears. A Section viewer showing the generated section is automatically tiled vertically alongside the document window. 2. Click the Positioning tab, then the Geometrical Target icon the box to planes. to snap
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3. Point to the first plane of interest. The Geometrical Target command recognizes that it is a section box. A rectangle and vector representing a plane and the normal vector of the plane appear in the geometry area as well as the figure 1 to assist you. It moves as you move the cursor.

4. When satisfied, click to position the master plane of the section box on the first target.

Note that the visual aid now displays the figure 2. 5. Select a second plane.This plane adjusts box dimensions, and if required, rotates the box. The section box is totally constrained to selected planes. The two selected planes are parallel: box thickness is modified
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The two selected planes are perpendicular: box height is modified

6. Click OK in the Sectioning Definition dialog box when done.

More About the Section Viewer
This task illustrates how to make the most of section viewer capabilities:

• •

Accessing the Section viewer capabilities Step-by-Step Scenario o Section Viewer
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•

Accessing the Section viewer capabilities

Most of the commands described in this task are to be found in the Result tab of the Sectionin Definition dialog box or in the Section viewer contextual menu.

Step-by-Step Scenario

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sampl folder cfysm/samples.

icon in the D 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning Space Analysis toolbar and create the desired section plane, slice or box and correspon section.

Section Viewer

The Section viewer is automatically tiled vertically alongside the document window. It displays front view of the section, and is by default, locked in a 2D view. Points representing the inters of the section plane with any wire frame elements are also visible in the Section viewer.

Notice that the section view is a filled view. This is the default option. The fill capability genera surfaces for display and measurement purposes (area, center of gravity, etc.). To obtain a cor filled view, the section plane must completely envelop the product. Note: The filled view is not available when the plane sections surfaces.
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To obtain an unfilled view, de-activate the Section Fill Definition dialog box.

icon in the Result tab of the Section

• •

In the Section viewer, the appearance of the cursor changes to attract your attention t existence of the contextual menu. You can change the default settings for this window using Tools ->Options... command Sectioning tab under Digital Mockup ->DMU Space Analysis).

Orienting the Section

2. Orient the generated section.Flip and Rotate commands are to be found in the contextu menu. Right-click in the Section viewer and: o o or Flip Horizontal Select Flip Vertical horizontally 180 degrees. Select Rotate Right degrees. or Rotate Left

to flip the section vertically or

to rotate the section right or left
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Orienting the section using Flip and Rotate commands is not persistent. If you exit section viewer, any flip and rotate settings are lost.

Working with the 2D Grid
3. Click the Result tab in the Sectioning Definition dialog box, then select the Grid icon under Options to display a 2D grid. By default, grid dimensions are those of the generated section. Moving the secti plane re-sizes the grid to results. To size the grid to the section plane, clear the Automatic grid re-sizing check box in the DMU Sectioning tab (Tools -> Options..., Mockup -> DMU Space Analysis).

You can edit the grid step, style and mode using the Edit Grid command.
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4. Select the Edit Grid icon to adjust grid parameters: The Edit Grid dialog box appea the above example, the grid mode is absolute and the style is set to lines.

In the absolute mode, grid coordinates are set with respect to the absolute axis system the document.

The grid step is set to the default value of 100. The arrows let you scroll through a dis set of logarithmically calculated values. You can also enter a grid step manually.

Units are current units set using Tools-> Options (Units tab under General-> Paramete and Measure).

5. Scroll through grid width and height and set the grid step to 10 x 10.

6. Click the Relative mode option button: In the relative mode, the center of the grid is pl on the center of section plane. 7. Click the Crosses style option button.

63

analyzing

Grid parameters are persistent: any changes to default parameters are kept and applie next time you open the viewer or re-edit the section.

8. Click the Automatic filtering checkbox to adjust the level of detail of grid display when y zoom in and out. 9. Right-click the grid then select Coordinates to display the coordinates at selected intersections of grid lines. The Clean All command removes displayed grid coordinates.

Note: o

o 64

You can customize both grid and Section viewer settings using the Tools -> Options... command (DMU Sectioning tab under Digital Mockup ->DMU Spa Analysis). Alternatively, select Analyze ->Graphic Messages ->Coordinate to display t

Basic Tasks

o

coordinates of points, and/or Name to identify products as your cursor mo over them. Clicking turns the temporary markers into 3D annotations.

10. Click OK in the Edit Grid dialog box when done.

Working with a 3D View
By default, the Section viewer is locked in a 2D view. De-activating the 2D view lets you: • • Work in a 3D view and gives you access to 3D viewing tools Set the same viewpoint in the Section viewer as in the document window.

Returning to a 2D view snaps the viewpoint to the nearest orthogonal view defined in the Sect viewer. 11. Right-click in the Section viewer and select the 2D Lock command from the contextual The Import Viewpoint command becomes available. 12. Manipulate the section plane.

13. Right-click in the Section viewer and select the Import Viewpoint command from the contextual menu. The viewpoint in the Section viewer is set to that of the document wi

14. Continue manipulating the section plane.
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15. Return to a locked 2D view.

The viewpoint in the Section viewer snaps to the nearest orthogonal viewpoint in this v and not to the viewpoint defined by the local axis system of the plane in the document window.

You can also save sectioning results in a variety of different formats using the Export A command in the Result tab of the Sectioning Definition dialog box or the Capture comm (Tools ->Image ->Capture).

16. Click OK in the Sectioning Definition dialog box when done. If you exit the Sectioning command with the Section viewer still active, this window is not closed and filled sectio remain visible.

P2 Functionality - Detecting Collisions
In DMU-P2, You can detect collisions between 2D sections. To do so, click the Clash Detection icon in the Result tab of the Sectioning Definition dialog box.
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Clashes detected are highlighted in the Section viewer.

Collision detection is dynamic: move the section plane and watch the Section viewer display b updated.

Note: Clash detection is not authorized when in the Section Freeze mode.

Creating 3D Section Cuts

3D section cuts cut away the material from the plane, beyond the slice or outside the box to expos cavity within the product. This task explains how to create 3D section cuts:

• • • •

Step-by-Step Scenario 3D Section Cut Display P2 Functionality 3D Section Cut in DMU Review

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.
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They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples.

Step-by-Step Scenario
1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Analysis toolbar and create a section plane. The Sectioning Definition dialog box appears.

2. In the Definition tab, click the Volume Cut icon

to obtain a section cut:

The material in the negative direction along the normal vector of the plane (W-axis) is cut exposing the cavity within the product.

Note: In some cases, the normal vector of the plane is inverted to give you the best view o cut. 68
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3. Double-click the normal vector of the plane to invert it, or click the Invert Normal icon in the Positioning tab of the Sectioning Definition dialog box.

4. Re-click the icon to restore the material cut away. 5. Click OK when done.

3D Section Cut Display
The 3D section cut display is different when the sectioning tool is a plane. To obtain the same display as for slices and boxes (see illustrations below) and make measures on the generated wireframe cut: • • Select the Allow measures on a section created with a simple plane option in the DMU Sectioning tab (Tools -> Options, Digitial Mockup -> DMU Space Analysis) Then, create your section cut based on a plane.

When the Sectioning Tool is a Slice:

When the Sectioning Tool is a Box:
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P2 Functionality
In DMU-P2, you can turn up to six independent section planes into clipping planes using the Volume Cut command to focus on the part of the product that interests you most.

3D Section Cuts in DMU Review
Section cuts created during DMU Reviews are not persistent and are only valid for the duration of the review. If you exit the DMU Review, the section cut is lost.
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For more information about DMU Review, refer to DMU Navigator User's Guide

Managing the Update of Section Results

A number of options are provided to let you manage section update once you have exited the Sect command. This is particularly useful, for example, if you run a fitting simulation or kinematics oper moves products affecting the section result. These options are to be found in the Behavior tab of the Sectioning Definition dialog box. This task shows how to manage the update of section results.

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZ REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples.
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1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Analysis toolbar and create a section plane. The Sectioning Definition dialog box appears.

2. Click the Behavior tab in the Sectioning Definition dialog box. Three options are available i o o o Manual update (default value) Automatic update Section freeze

By default, after exiting the command, the generated section is not updated when you m products affecting the section result (manual update). This, for example, will improve perf fitting simulation and kinematics operations.

Section results that are not up-to-date are identified by the section icon and the update sy in the specification tree.
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3. Click Automatic update to update the section automatically, after exiting the command, wh move products for example. In the example below, after exiting the Sectioning command, a product using the 3D compass. The product was moved along the Y-axis such that it con intersect the section plane. Automatic update turned on: Automatic update turned off:

4. Select Section freeze option button to freeze section results. Notes: o o

This command takes effect immediately: section results will not be updated if you move the plane, or move products affecting the result. Frozen section results are identified in the specification tree by the section icon plu

5. Move the section plane:

Note that the section result in neither the document window nor the Section viewer is upd You can in this way create a history of sectioning operations.
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Frozen section results are identified in the specification tree by the section icon plus a lock

6. Reset the default option in the Behavior tab, and click OK in the Sectioning Definition dialo done.
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More About the Contextual Menu

The following commands are available in the contextual menu when you have exited the command. 1. Unless specified otherwise, simply right-click the specification tree feature or the section in the geometry area, select Section.1 object and then the command of interest from the menu.

o o

o

Definition...: lets you modify the selected section object. Update the section: locally updates the selected section. Note: In scene contexts, this command is labelled 'Force update the section' and updates both the scene and the geometry area to reflect modifications made to the scene. Behavior: lets you manage section update. These are the same options as those found in the Behavior tab of the Sectioning Definition dialog box. The grayed out option is the current option and by default, is the one set in the dialog box before exiting the command.

o

o

Activate the section result manual update: the generated section is not updated when you move products affecting the section result. Activate the section result automatic update: the generated
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analyzing section is automatically updated when you move products affecting the result. Freeze the section result: the generated section is not updated if you resize or move the plane, or move products affecting the result. Activate/Deactivate the section cut: turns the Volume Cut command on or off. Activate/Deactivate the section fill: turns the fill capability on or off. Hide/Show the plane representation: turns the section plane on or off. Note: You cannot re-dimension, move or rotate the plane. o Export the section(s): lets you save section results in CATPart, IGES, model, STEP, VRML formats. Notes: If you want to save results as a CATDrawing, use the Export As command in the Sectioning Definition dialog box. Multiple selection tools are available for all these contextual menu commands. You can, for example, export a multiple selection of section results to a CATPart document.

o

o o o

o

Select the product(s): highlights products in the specification tree associated with selected sections: Select a section or Ctrl-click to select sections in the geometry area of the document window or in the Results window. Right-click to access the contextual menu and choose Select the product(s). Associated product(s) are highlighted in the specification tree.
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o

2.

Comparing Products
Comparing Products

This task explains how to compare two parts or two products to detect differences between them a identify where material has been added and/or removed.

This is useful when comparing assemblies or products at different stages in the design process or w considering internal and external (client) changes to the same product. Two comparison modes are available, read the following procedures: Making a Visual Comparison (default value) Visual Comparison Options • Setting Comparison accuracy • Setting Option buttons The comparison is entirely visual. A single view shows the results. Visual comparison offers faster and finer comparison than geometric: • Computation time is proportional to the size of the Visual Comparison viewer.
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Making a Geometric comparison Geometric Comparison Options • Setting Computation accuracy • Setting Display accuracy • Defining Type

differences between assemblies or products are represented by cubes with separate views sho added and removed material.

In both modes, you can compare assemblies or products with respect to the absolute axis system i document (default value), or Local axis systems. • Using Local axis systems • Saving Results (P2 only)

Combining the Compare Products command with other DMU Space Analysis and DMU Nav toolbar commands

Insert the PEDALV1.model and PEDALV2.model documents in the DMU Space Analysis samples fold spaug/samples. Products or parts you want to compare must be in the same CATProduct document.

Making a Visual Comparison
1. Click the Compare Products icon dialog box appears. in the DMU Space Analysis toolbar. The Compare Prod
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By default, Visual Comparison option is selected. 2. Select one of the products you want to compare (old version), PEDALV1 for example.

3. Select the other product (new version), PEDALV2 for example. The spatial coordinates of PE and PEDALV2 are defined with respect to the absolute axis system of the document and are same. Note: Multi-selection capabilities are not available in this command. 4. Click Preview to run the visual comparison. A Visual Comparison viewer opens showing the results:

o o o

Yellow: common material Red: added material Green: removed material.

You can re-size the viewer if desired.
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Visual Comparison Options
Setting Comparison Accuracy

Comparison accuracy corresponds to the minimum distance between two products bey which products are considered different. A higher value gives a cleaner image.

As you can see, the green area is no longer detected at the higher setting: it is no long considered different.

The default value (0.4 mm) is twice the default sag value for calculating tessellation on Sag (3D fixed accuracy) is set in the Performances tab of Tools -> Options -> General Display. The default comparison accuracy is the recommended value for visual comparison
Setting Options buttons

o o o

Both Versions: common material and both versions of the product. Old Only: common material and the old version of the product. New Only: common material and the new version of the product.

Note: You cannot save the results in visual comparison mode.
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Making a Geometric Comparison
You will run a geometric comparison on the same two products (PEDALV1 and PEDALV2). 6. Repeat Step 2-3 7. Select the Geometric comparison check box.

Geometric Comparison Options
Setting Computation Accuracy

The computation accuracy determines the size of the cubes used to represent the mate added and/or removed. A lower setting results in slower computation time, but a more calculation of differences.
Setting Display Accuracy

Independently of the computation accuracy, you can set the display accuracy to a coar display of the computation results to give a better graphics display performance. By default, the display accuracy is set to the same value as the computation accuracy.
Defining Type

o o o o

Added: Computes differences where material has been added only. Removed: Computes differences where material has been removed only. Added + removed: Computes differences where material has been both added a removed. Differences are displayed in separate views and saved in different files Changed: Computes differences where material has been both added and remov displaying all changes in both views and letting you save changes in the same fi

8. Set the computation accuracy by entering a value. In our example, we will keep the default 5mm. 9. Move the slider to the right to set the display accuracy to 20mm for example.

10. Select the type of comparison you want to run from the Type drop-down list, Added + remo example.

11. Click Preview to run the geometric comparison: A progress bar is displayed letting you mon if necessary, interrupt (Cancel option) the calculation.A dedicated viewer appears showing results. Differences are represented by cubes. Added material is shown in red; removed ma green.
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12. Repeat the comparison adjusting the display accuracy to the same value as the computation accuracy (5mm):
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13. Repeat the comparison adjusting the computation accuracy to 2mm.
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Using Local Axis Systems
You will now run a visual comparison using local axis systems.

This option, available in both visual and geometric comparison modes, lets you compare two produ defined with respect to local axis systems, irrespective of the position of products in the document

14. Insert the PEDAL.CATProduct document in the DMU Space Analysis samples folder and click Compare Products icon again.

15. Select the old version: select PEDALV1 again. The product and its axis system are highlighte green. 16. Select the New version: PEDALV3. The product and its axis system are highlighted in red.
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Spatial coordinates of PEDALV1 and PEDALV3 are different when defined with respect t absolute axis system in the document but are the same when defined with respect to lo systems. 17. Set the comparison accuracy as desired. 18. Select the Use local axis systems check box:

Local axes of the two products are superimposed in the main document window. The o axis system is the reference axis system.

19. Click Preview to view results in the Visual Comparison viewer. A progress bar is displayed le monitor and, if necessary, interrupt (Cancel option) the calculation. Notice that you get the results as you did when comparing PEDALV1 and PEDALV2: for the purposes of this task, PE a copy of PEDALV2 that has been positioned differently in the document. 20. Click Close when done.

Saving Results

In DMU-P2, you can save the displayed results (cubes) in 3dmap format (.3DMap), as a cgr file (. Virtual Reality Modeling Language (VRML) document (.wrl) or a V4 model (.model).
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The 3dmap format can be inserted into a product and other DMU Space Analysis (Clash or Section DMU Navigator (Proximity Query) commands run to evaluate the impact of modifications. Colors assigned to added (red) and removed (green) material will also be saved making changes visible when re-inserted into a document. The Save As dialog box is proposed when you click Save in the Compare Products dialog box: • • • Specify the location of the document to be saved and, if necessary, enter a file name. Click the Save as type drop-down list and select the desired format. Click Save to save the results in a file in the desired format.

Combining the Compare Products command with other DMU Space Analysis and D Navigator toolbar commands

• •

You can use the Measure Between command to make measures, for example between two the Visual Comparison viewer. You can generate a section in the main document window: added and removed material is v the generated section.

•

You can run a query for products immediately surrounding the added material (Proximity Q command in the DMU Data Navigation toolbar) and then analyze for clashes (Clash comman offers the advantage of letting you, for example, focus on a part of an engine rather than a the whole engine and then having to sift through the results to find those relevant.
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Using a Macro to Batch Process Product Comparison
If you perform a task repeatedly, you can take advantage of a macro to automate it. A macro is a series of functions, written in a scripting language, that you group in a single command to perform the requested task automatically. You can in this way run a macro automating the geometric comparison of hundred of products to detect differences between them. You can compare .model, .CATPart and .cgr documents. A sample macro, ComparisonMacro.CATScript, is supplied. It can be found in the DMU Space Analysis samples folder spaug/samples. This task explains how to automate geometric comparison. 1. Open and edit the sample macro, ComparisonMacro.CATScript, from the sample folder with a Text editor. Appropriate comments have been added to the sample to help you edit it. Language="VBSCRIPT" ''========================================== '' MinDiff = Difference limit, '' if (difference percent > MinDiff) '' then products are considered different ''================================= Dim MinDiff As Double MinDiff = 0.3 ''========================= '' Difference percentages : ''========================= '' added : Added Material /Material in Version1 '' removed : Removed Material /Material in Version1 Dim added As Double Dim removed As Double ''=============== '' Program Start ''=============== Sub CATMain() Dim documents1 As Documents Set documents1 = CATIA.Documents ''====================== '' New Product Creation ''====================== Dim productDocument1 As Document Set productDocument1 = documents1.Add("Product")
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Dim product1 As Product Set product1 = productDocument1.Product Dim products1 As Products Set products1 = product1.Products ''====================================== '' Names of the two products to compare ''====================================== Dim arrayOfVariantOfBSTR1(1) ''arrayOfVariantOfBSTR1(0) = "path ' ' arrayOfVariantOfBSTR1(1) = "path name_of_document" name_of_document"

''====================== '' Insertion of products ''====================== products1.AddComponentsFromFiles arrayOfVariantOfBSTR1, "*" Dim optimizerWorkBench1 As Workbench Set optimizerWorkBench1 = productDocument1.GetWorkbench("OptimizerWorkBench") ''====================================== '' Products to compare ''======================================= Dim product2 As Product Set product2 = products1.Item(1) Dim product3 As Product Set product3 = products1.Item(2) ''===================================== '' Comparison ''===================================== Dim partComps1 As PartComps Set partComps1 = optimizerWorkBench1.PartComps Dim partComp1 As PartComp ''Set partComp1 = partComps1.GeometricComparison(product2, product3, 2.000000, 2.000000, 2, added, removed) ''====================================== '' Start Comparison '' Parameters : '' product2 : first product to compare (Old Version) '' product3 : second product to compare (New Version) '' 2.000000 : computation accuracy (mm)
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Basic Tasks '' 2.000000 : display accuracy (mm) '' 2 : computation type : 0=Added, 1=Removed, 2=Added+Removed ''======================================== Set partComp1 = partComps1.Add(product2, product3, 2.000000, 2.000000, 2) ''===================================== '' Read computation results ''===================================== '' Retrieve the percent of added material (value is between 0.0 and 1.0) Dim PercentAdded As Double PercentAdded = partComps1.AddedMaterialPercentage '' Retrieve the percent of removed material (value is between 0.0 and 1.0) Dim PercentRemoved As Double PercentRemoved = partComps1.RemovedMaterialPercentage '' Retrieve the volume of added material (mm3) Dim VolumeAdded As Double VolumeAdded = partComps1.AddedMaterialVolume '' Retrieve the volume of removed material (mm3) Dim VolumeRemoved As Double VolumeRemoved = partComps1.RemovedMaterialVolume ''==================================== '' Typical comparison result management ''==================================== If PercentAdded > MinDifference Then msgbox "Difference detected : Added = " & Cstr(PercentAdded) & " , Removed = " & Cstr(PercentRemoved) & " VolumeAdded = " & Cstr (VolumeAdded) & " VolumeRemoved = " & Cstr(VolumeRemoved) ''======================================= '' Save of added and removed Material ''======================================= Dim document1 As Document Set document1 = documents1.Item("AddedMaterial.3dmap") document1.Activate document1.SaveAs "E: users sbc DemoSMT Comparison AddedMaterial.3dmap"

Dim document2 As Document Set document2 = documents1.Item("RemovedMaterial.3dmap") document2.Activate document2.SaveAs "E: users sbc DemoSMT Comparison RemovedMaterial.3dmap"

document2.Close document1.Close
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'' ======================================================= '' Import AddedMaterial Only '' ======================================================= Dim var11 ( 0 ) var11 ( 0 ) = "E: users sbc DemoSMT Comparison products1.AddComponentsFromFiles var11, "*" AddedMaterial.3dmap"

'' ======================================================= '' Definition du view point '' ======================================================= CATIA.ActiveWindow.ActiveViewer.Viewpoint3D.PutSightDirection Array(1, 1, 0) CATIA.ActiveWindow.ActiveViewer.Viewpoint3D.PutUpDirection Array(0, 0, 1) CATIA.ActiveWindow.ActiveViewer.Reframe CATIA.ActiveWindow.ActiveViewer.ZoomIn() CATIA.ActiveWindow.ActiveViewer.ZoomIn() '' ======================================================= '' Save image As .jpg '' ======================================================= CATIA.ActiveWindow.ActiveViewer.CaptureToFile catCaptureFormatJPEG , "E: users sbc DemoSMT Comparison MyImage.jpg"

Else msgbox "No difference detected between products" End If productDocument1.Activate End Sub 2. Run the macro in batch mode from Windows or your UNIX workstation. For information on editing and running macros, read the appropriate section in the Infrastructure User's Guide.

Sectioning & Visual Comparison
90

Basic Tasks You can section your visual comparison results and browse the section in the Section viewer. Comparison colors identifying common, added and/or removed material are kept in the Section viewer. This task illustrates the integration between Compare Products and Sectioning commands. No sample document is provided. 1. Click the Compare Products icon and run a visual comparison. The Visual Comparison viewer opens showing the results.

2. Click the Sectioning icon . Sectioning tools are available in the main document window: you can manipulate the plane directly, create a 3D section cut and position the plane on a target.
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The Section viewer is automatically tiled vertically alongside the other windows and is locked in a 2D view. 3. Manipulate the section plane in the document window and browse results in the Section viewer. Note: Comparison colors identifying common, added and/or removed material are kept in the Section viewer: o o o Yellow: common material Red: added material Green: removed material.

4.
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Measuring Tools
Measure Tools
About measure tools: Gives general information on the various commands available.

Arc through Three Points
Measure arc sections: Click the Arc through Three Points icon, then select three points along a curve or an arc.

Measure Between
Measure distances and angles between geometrical entities: Click the Measure Between icon, set the measure type and mode in the Measure Between dialog box, then select two entities.

Measure Item
Measure properties: Click the Measure Item icon, then select an item.

Measure Thickness
Measure thickness: Click the Measure Item icon, then the Measure Thickness icon and select an item.

Measure Inertia
Measure inertia: Click the Measure Inertia icon, then select an item.

2D Measure
Measure distance, angle and radius on 2D documents: Click the 2D Measure icon, calibrate, then make your measure.

Measuring Distances between Geometrical Entities

()

The Measure Between command lets you measure distance between geometrical entities. You can measure: • • Minimum distance and, if applicable angles, between points, surfaces, edges, vertices and entire products Or, Maximum distance between two surfaces, two volumes or a surface and a volume.

This section deals with the following topics:

•

Measuring minimum distance and angles
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analyzing o Dialog box options o Accessing other measure commands o Defining measure types o Defining selection 1 & selection 2 modes o Defining the calculation mode o Sectioning measure results Measuring maximum distance o About maximum distance o Between two G-1 continuous surfaces o Between Wire frame entities o Step-by-step scenario Measuring distances in a local axis system Customizing measure between Editing measures Creating geometry from measure results Exact measures on CGRs and in visualization mode Measuring angles Updating measures Using measures in knowledgeware Measure cursors Restrictions

•

• • • • • • • • • •

Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, NOZZLE1.model, NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and VALVE.model. They are to be found in the online documentation file tree in the common functionalities sample folder cfysm samples.

Measuring Minimum Distance and Angles
This task explains how to measure minimum and, if applicable, angles between geometrical entities (points, surfaces, edges, vertices and entire products). 1. Click the Measure Between icon . In DMU, you can also select Analyze-> Measure Between from the menu bar. The Measure Between dialog box appears:
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By default, minimum distances and if applicable, angles are measured. By default, measures made on active products are done with respect to the product axis system. Measures made on active parts are done with respect to the part axis system. Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service Pack 1 where all measures are made with respect to the absolute axis system.

Dialog box options
o Other Axis check box: when selected, lets you measure distances and angles with respect to a local V5 axis system. Keep Measure check box: when selected, lets you keep the current and subsequent measures as features. This is useful if you want to keep the measures as annotations for example.

o

o Some measures kept as features are associative and can be used to valuate parameters or in

95

analyzing formulas.

Note that in the Drafting and Advanced Meshing Tools workbenches, measures are done on-the-fly and are therefore not persistent nor associative and cannot be used as parameters. 2. Create Geometry button: lets you create the points and line corresponding to the minimum distance result. 3. Customize... button: lets you customize display of measure results.

Accessing other measure commands
• The Measure Item command is accessibl e from the Measure Between dialog box. In DMU, the Measure Thickness command is also accessibl e from the Measure Between dialog box. For more

•
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Set the desired mode in the Selection 1 and Selection 2 mode drop-down list boxes. Set the desired calculation mode in the Calculation mode drop-down list box. Click to select a surface, edge or vertex, or an entire product (selection 1). Notes: • • The appearance of the cursor has changed to assist you. Dynamic highlighting of geometrical entities helps you locate items to click on.

Click to select another surface, edge or vertex, or an entire product (selection 2). A line representing the minimum distance vector is drawn between the selected items in the geometry area. Appropriate distance values are displayed in the dialog box. Note: For reasons of legibility, angles between lines and/or curves of less than 0.02 radians (1.146 degrees) are not displayed in the geometry area.
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By default, the overall minimum distance and angle, if any, between the selected items are given in the Measure Between dialog box. Select another selection and, if desired, selection mode. Set the Measure type to Fan to fix the first selection so that you can always measure from this item. Select the second item.
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Select another item. Click Ok when done.

Defining measure types
• • • Between (default type): measures distance and, if applicable, angle between selected items. Chain: lets you chain measures with the last selected item becoming the first selection in the next measure. Fan: fixes the first selection as the reference so that you always measure from this item.

Defining selection 1 & selection 2 modes
• Any geometry: measures distances and, if applicable, angles between defined geometrical entities (points, edges, surfaces, etc.). By default, Any geometry option is selected Note: The Arc center mode is activated in this selection mode. This mode recognizes the axis of cylinders and lets you measure the distance between two cylinder axes for example. Selecting an axis system in the specification tree makes the distance measure from the axis system origin. You can select sub-entities of V5 axis systems in the geometry area only. For V4 axis systems, distances are always measured from the origin.
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•

Any geometry, infinite: measures distances and, if applicable, angles between the infinite geometry (plane, line or curve) on which the selected geometrical entities lie. Curves are extended by tangency at curve ends. Line Plane Curve

The Arc center mode is activated and this mode also recognizes cylinder axes. For all other selections, the measure mode is the same as any geometry. Any geometry, infinite

Any geometry
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•

Picking point: measures distances between points selected on defined geometrical entities. Notes: o The picking point is selected on visualization mode geometry and depends on the sag value used. It may not correspond to the exact geometry. The resulting measure will always be non associative.

o

In the DMU section viewer, selecting two picking points on a curve gives the distance along the curve between points (curve length or CL) as well as the minimum distance between points. Notes: • • Both points must be located on the same curve element. The minimum distance option must be set in the Measure Between Customization dialog box.
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• •

• •

Point only: measures distances between points. Dynamic highlighting is limited to points. Edge only, Surface only: measures distances and, if applicable, angles between edges and surfaces respectively. Dynamic highlighting is limited to edges or surfaces and is thus simplified compared to the Any geometry mode. All types of edge are supported. Product only: measures distances between products. Products can be specified by selecting product geometry, for example an edge or surface, in the geometry area or the specification tree. Picking axis: measures distances and, if applicable, angles between an entity and an infinite line perpendicular to the screen. Simply click to create infinite line perpendicular to the screen. Note: The resulting measure will always be approximate and non associative.

•

Intersection: measures distances between points of intersection between two lines/curves/edges or a line/curve/edge and a surface. In this case, two selections are necessary to define selection 1 and selection 2 items. Geometrical entities (planar surfaces, lines and curves) are extended to infinity to determine the point of intersection. Curves are extended by tangency at curve ends. Curve-plane
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Customizing Measure Between
Customizing lets you choose what distance you want to measure:

• • •

Minimum distance (and angle if applicable) Maximum distance Maximum distance from 1 to 2.

Note: These options are mutually exclusive. Each time you change option, you must m By default, minimum distances and if applicable, angles are measured. You can also choose to display components and the coordinates of the two points (point 1 and poi distance is measured. What you set in the dialog box determines the display of the results in both the geometry area an

Measuring Maximum Distance
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About Maximum Distance

You can measure the maximum distance between two G-1 surfaces, two volumes or a surface and

Distance is measured normal to the selection and is always approximate. Two choices are availabl

•

Maximum distance from 1 to 2: gives the maximum distance of all distances measured from Note: This distance is, in general, not symmetrical.

•

Maximum distance: gives the highest maximum distance between the maximum distance m and the maximum distance measured from selection 2.

Note: All selection 1 (or 2) normals intersecting selection 1 (or 2) are ignored. •
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Between two G-1 continuous surfaces on a part in Design mode (result is exact)
You can now calculate the maximum distance between two G1 (continuous at the tangency level) The resulting measure is exact.

Note: G-1 stands for geometric tangency, it basically means: surfaces which are continuous a

Between Wire frame entities

You can now calculate the maximum perpendicular deviation between point, lineic and surfacic ele surface/surface which uses max perpendicular distance see table below) The table below lists the possible wire frame selections for measuring maximum distance:

Entity Surface Curve Point

surface No Yes Yes

Curve Yes Yes Yes

Point Yes Yes MIN
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Step-by-Step Scenario

1. Click Customize... and check the appropriate maximum distance option in the Measure Betw box, then click OK. 2. Make your measure: o o o o Select the desired measure type Set the desired selection modes Set the desired calculation mode Click to select two surfaces, two volumes or a surface and a volume.

3. Click OK when done.

Measuring Distances in a Local Axis System
The Other Axis option in the dialog box lets you measure distance in a local axis system.

This type of measure is associative: if you move the axis system, the measure is impacted and ca You need a V5 axis system to carry out this scenario

106

Basic Tasks

1. Select the Other Axis check box in the dialog box. 2. Select a V5 axis system in the specification tree or geometry area. 3. Make your measure.

In the examples below, the measure is a minimum distance measure and the coordina between which the distance is measured are shown. Same measure made with respect to absolute axis system:

Note: All subsequent measures are made with respect to the selected axis system. 4. To change the axis system, click the Other Axis field and select another axis system. 5. To return to the absolute axis system, click to clear the Other Axis check box 6. Click OK when done.

Restrictions
• • • • Neither Visualization Mode nor cgr files permit selection of individual vertices.

In the No Show space, the Measure Between command is not accessible. Measures performed on sheet metal features provide wrong results. In unfolded view, volu into account when measuring Part Bodies.

Measures are not associative when switching between folded view and unfolded view (using
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Measuring Angles
The following section describes: • • Exact angles Complementary angles

Exact Angles
The Measure Between command lets you measure exact angles between the following geometrica entities that have (at least) one common point. Two lines (even if not in the same plane): A line and a curve:

Two curves:

Note: In the above three cases, if entities intersect more than once, the measure is made at t point of intersection nearest the point at which selection 1 is made. A curve and a surface:
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Note: If the curve and surface intersect more than once, the measure is made at the point of intersection nearest the point of the selection on the curve.

A line and a surface:

A line and a plane:

Two surfaces: You can also measure the angle between two surfaces provided both surfaces are planar.

Complementary Angles
You can obtain the complementary angle (360 - the initial angle measured) when measuring between two curves: drag the angle line to show the complementary angle.
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Note: The dialog box and knowledge parameters are refreshed. The value of the complement angle is stored along with the measure.

Measure Cursors

The appearance of the Measure Between and Measure Item cursor changes as you move it over ite reflect the measure command you are in and to help you identify the selection. Dynamic highlighti surfaces, points, and vertices, etc. also helps you locate items to click on.
Measure Between Measure Item Geometry

Surface Planar surface Line Curve Point Circle Sphere Cylinder Volume

In Measure Between, a number (1 for selection 1 and 2 for selection 2) ide where you are in your measure.
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Measuring Properties ()
The Measure Item command lets you measure the properties associated to a selected item (points, edges, surfaces and entire products). This section deals with the following topics:

• • • • • • • • • •

Measuring properties Measuring in a local axis system Customizing the display Editing measures Create Geometry from measure results Exact measures on CGRs and in visualization mode Updating measures Using measures in knowledgeware also read Measures and Knowledge Measure cursors Restrictions

Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, NOZZLE1.model, NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and VALVE.model. They are to be found in the online documentation file tree in the common functionalities sample folder cfysm/samples.

Measuring Properties
This task explains how to measure the properties associated to a selected item. 1. Switch to Design Mode (Edit ->Representations ->Design Mode). 2. Set View -> Render Style to Shading with Edges. You cannot use this command, if Shading only is selected 3. Click the Measure Item icon . In DMU, you can also select Analyze -> Measure Item from the menu bar. The Measure Item dialog box appears.
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By default, properties of active products are measured with respect to the product axis system. Properties of active parts are measured with respect to the part axis system. Note: This distinction is not valid for measures made prior to Version 5 Release 8 Service Pack 1 where all measures are made with respect to the absolute axis system.

Dialog box options
o o Other Axis check box: when selected, lets you measure properties with respect to a local V5 axis system. Keep Measure check box: when selected, lets you keep current and subsequent measures as features. This is useful if you want to keep measures as annotations for example. o Some measures kept as features are associative and can be used to valuate parameters or in formulas.

In the Drafting and Advanced Meshing Tools workbenches, measures are done on-the-fly. They are not persistent. This means that they are not associative and cannot be used as parameters. 4. Create Geometry button: lets you create you create the center of gravity from measure results. 5. Customize... button: lets you customize display of measure results.
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Accessing other measure commands
• • The Measure Between command is accessible from the Measure Item dialog box. Simply click one of the Measure Between icons in the Definition box to switch commands. In DMU, the Measure Thickness command is also accessible from the Measure Item dialog box. For more information, see the appropriate task in the DMU Space Analysis User's Guide.

Set the desired measure mode in the Selection 1 mode drop-down list box. Set the desired calculation mode in the Calculation mode drop-down list box. Click to select the desired item. Note: The appearance of the cursor has changed to assist you.
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The dialog box gives information about the selected item, in our case a surface and indicates whether the result is an exact or approximate value. The surface area is also displayed in the geometry area. The number of decimal places, the display of trailing zeros and limits for exponential notation is controlled by the Units tab in the Options dialog box (Tools-> Options, General-> Parameters and Measure). For more information, see the Infrastructure User's Guide. Try selecting other items to measure associated properties. Note: For reasons of legibility, angles measured by Angle by 3 points or on an arc of circle of less than 0.02 radians (1.146 degrees) are not displayed in the geometry area.

Click OK when done.
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Or like this, if properties were those of the active part.

Note: If the product is active, any measures made on the active part are placed in No Show. Some measures kept as features are associative. In Design Mode, if you modify a part or move a part in a product structure context and the measure is impacted, it will be identified as not up-to-date in the specification tree. You can then update it locally have it updated automatically. When measures are used to valuate parameters, an associative link between the measure and parameter is created. Measures can also be used in formulas.

Defining the Selection 1 Mode
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• • • •

Any geometry (default mode): measures the properties of the selected item (point, edge, surface or entire product). Point only: measures the properties of points. Dynamic highlighting is limited to points. Edge only: measures the properties of edges. All types of edge are supported. Surface only: measures the properties of surfaces. In the last three modes, dynamic highlighting is limited to points, edges or surfaces depending on the mode selected, and is thus simplified compared to the Any geometry mode. Product only: measures the properties products. Products can be specified by selecting product geometry, for example an edge or surface, in the geometry area or the specification tree. Angle by 3 points: measures the angle between two lines themselves defined by three points. To define lines: o Select three existing points in the geometry area or in the specification tree. Note: You cannot select picking points. Smart selection is offered. This means that a sphere or circle, for example, are seen as points. The resulting angle is always positive. It is measured in a counterclockwise direction and depends on the order in which points were selected as well as your viewpoint (the normal to the plane is oriented towards you).

• •

o
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You can drag the angle line to show the complementary angle (360 angle measured).

- the initial

You can also obtain the complementary angle when measuring the angle on arcs. Note: The dialog box and knowledge parameters are refreshed. The value of the complementary angle is stored along with the measure.

•

Thickness (DMU only): measures the thickness of an item. For more information, see the appropriate task in the DMU Space Analysis User's Guide.

The Measure Item command: • • • lets you access the radius of an exact cylinder or sphere. recognizes ellipse-type conic sections. Using the Other Selection... command in the contextual menu, you can access the axis of a cylinder as well as the center of a sphere to, for example, measure between two cylinder axes.
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•

Defining the Calculation Mode

• •

•

Exact else approximate (default mode): measures access exact data and wherever possible true values are given. If exact values cannot be measured, approximate values are given (identified by a ~ sign). Exact: measures access exact data and true values are given. Note that you can only select exact items in the geometry area or specification tree. In certain cases, in particular if products are selected, a warning dialog box informs you that the exact measure could not be made. Approximate: measures are made on tessellated objects and approximate values are given (identified by a ~ sign). In design mode, the canonical type of surfaces (plane, cylinder, etc.) is not recognized.

Note: You can hide the ~ sign using the Tools -> Options command (General >Parameters and Measure ->Measure Tools).

P1-Only Functionality
In P1, the Measure Tools toolbar appears. This toolbar has two icons:

• •

Measure Dialogs Exit Measure hidden.

: lets you show or hide the associated dialog box. : lets you exit the measure. This is useful when the dialog box is
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Customizing the Display
Customizing lets you choose the properties you want to see displayed in both the geometry area and the dialog box. 1. Click Customize... in the Measure Item dialog box to see the properties the system can detect for the various types of item you can select. By default, you obtain:

Edges
The system detects whether the edge is a line, curve or arc, taking model accuracy into account and displays the properties as set in the Measure Item Customization dialog box.

Notes: o If the angle of an arc is less than 0.125 degrees, only the arc length is displayed in the geometry area. The angle and radius are not displayed. The system arbitrarily assigns end points 1 and 2, however, once assigned, these points are persistent. The direction is oriented from point 1 to point 2.

o

Surfaces
o Center of gravity: The center of gravity of surfaces is visualized by a point. In the case of non planar surfaces, the center of gravity is
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o

attached to the surface over the minimum distance. Plane: gives the equation of a planar face. The equation of a plane is: Ax + By + Cz + D=0.

Note that there is an infinite number of equations possible (and an infinite number of solutions for values ABC and D). The result given by Measure Item does not necessarily correspond to that in the feature specification. This is because the measure is based on topology and does not know the feature specification associated with the measured item. o Perimeter: Visualization mode does not permit the measure of surface perimeter.

o 2. Set the properties you want the system to detect, then click Apply or Close. The Measure Item dialog box is updated if you request more properties of the item you have just selected. 3. Select other items to measure associated properties.

Measuring Properties in a Local Axis System
An Other Axis option in the dialog box lets you measure properties in a local axis system. This type of measure is associative: if you move the axis system, the measure is impacted and can be updated. You will need a V5 axis system.
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1. Select the Other Axis check box in the Measure Item dialog box. 2. Select a V5 axis system in the specification tree or geometry area. 3. Make your measure. Measure made with respect to local axis system:

Same measure made with respect to absolute axis system:

Note: All subsequent measures are made with respect to the selected axis system. 4. To change the axis system, click the Other Axis field and select another axis system. 5. To return to the main axis system, click to clear the Other Axis check box. 6. Click OK when done.

Measures and Knowledge
When performing a measure operation, Knowledge parameters are created along with the calculated values. You customize their display in the Measure customization dialog box. Note: No knowledge parameters are created for the equation of a plane. Also read Using measures in knowledgeware

121

analyzing

Restrictions

• • • •

Neither Visualization Mode nor cgr files permit selection of individual vertices. In the No Show space, the Measure Item command is not accessible. Measures performed on sheet metal features provide wrong results. In unfolded view, volume elements are not taken into account when measuring Part Bodies. Measures are not associative when switching between folded view and unfolded view (using the Fold/Unfold icon in the Sheet Metal toolbar).

Measuring Thickness
This task explains how to measure the thickness of a selected item along the normal to the surface at the picking point. Important: This measure is approximate. It is not associative and therefore cannot be updated. This command can be accessed from the Measure Item and Measure Between commands. Insert the following sample model files: ATOMIZER.model, BODY1.model, BODY2.model, LOCK.model, NOZZLE1.model, NOZZLE2.model, REGULATION_COMMAND.model, REGULATOR.model, TRIGGER.model and VALVE.model. They are to be found in the online documentation file tree in the common functionalities samples folder cfysm/samples. 1. Switch to Design Mode (Edit -> Representations -> Design Mode). 2. Set View -> Render Style to Shading with Edges. Note: You cannot use this command, if Shading only is selected. 3. Click the Measure Item icon .The Measure Item dialog box appears.
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o

o

For more information on measuring other properties of selected items (points, edges, surfaces and entire products), see Measuring Properties. The Keep Measure option lets you keep current and subsequent measures as features.

in the dialog box or set the measure mode 4. Click the Thickness icon in the Selection 1 mode drop down list box to Thickness.

5. Make your measure. Notes: o o A dynamic feedback exits as you move your cursor over the item. Thickness is measured along the normal to the surface at the picking point. An approximate value is given.
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6. Click OK when done. If you selected the Keep Measure check box in the dialog box, your measure is kept as a feature. This measure is not associative and therefore cannot be updated. This is identified in the specification tree by the measure icon plus a lock.

The Properties command (Graphics tab) lets you change the fill color and transparency as well as the color, line type and thickness of measure lines. Note: You cannot vary transparency properties, the current object is either the selected color or transparent 7.
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Creating Geometry from Measure Results
This task explains how to create geometry from the results of measures made using: • • • Measure Between Measure Item Measure Inertia

All geometry is created under the Open_body of a new or existing part.

The part containing the measure geometry must remain in the same position with respect to the do must not be re-ordered.

Associativity
• CATProduct

In a CATProduct, the geometry you create can be either associative or non associative with the me create associative geometry, check the Keep link with selected object option in Tools -> Options -> Part Infrastructure, General tab • CATPart

In a CATPart, the geometry you create is associative. Note: In both cases, associative geometry can only be created if your measure is associative.

1. Make your measure using the appropriate measure command (Measure between or Measure The Create Geometry button becomes available in the measure dialog box.

2. Click Create Geometry and follow instructions depending on whether you are in a product o If you are in a... Product Then... the Geometry Creation dialog box appears letting you choose where geometry created.

125

analyzing

Select one of the two options below, then click OK: o o

A new CATPart In which case a CATPart is inserted under the active product. An existing CATPart In which case, click the option and select the CATPart in the s

Part

the geometry is automatically created in an existing open_body or a does not exist.

3.

The Creation of Geometry dialog box appears. The example below shows the dialog box for a measure made using the Measure Between c

4. Are you in a product? o o Notes: o o o

If yes, select the appropriate associativity option depending on whether or not you w geometry to the measure. If no, read on.

In a part, the geometry you create is associative. In both a product and a part, associative geometry can only be created if your meas If Associative geometry is selected, the Keep Measure option is checked to ensure th created is based on measure results.

5. Select options in the Creation of Geometry dialog box to create geometry desired.
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If you made your measure using... Measure Between

Then you can create... o o

o Measure Item Measure Inertia o o o

First point Second point These are the two points between which the min measured Line: the line representing the minimum distanc Center of gravity Center of gravity Axis system (for the principal axes).

6. Click OK in the Creation of Geometry dialog box when done.

Geometry is created in the geometry area and is added to the specification tree under the O an existing part. In the Measure Between example below, created geometry is non-associative. This is identif accompanying the point entry in the tree.

7. Click OK in the Measure dialog box when done.

Exact Measures on CGRs and in Visualization Mode
Measure Between and Measure Item commands permit exact measures on inserted CGR files (created from CATIA V4 models, CATParts) as well as on Visualization mode geometry. This lets you make measures in Visualization mode without having to load the part. For more information, see the table below: the red cells indicate where an exact measure is not possible.

Measure Item
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Point Line Arc except length

Curve Plane

Cylinder/Cone Sphere Surface Surface Volume Assembly revolution except except area, except area, center of area, center gravity center of of gravity gravity

Exact measure

Measure Between
Point Line Center of arc Point Line Center of arc Curve Infinite plane Axis cylinder Center of sphere Surface Don't forget to set the selection mode correctly. To make a measure with respect to an infinite plane means you must set the selection mode to Any geometry, infinite. Curve Infinite plane Axis cylinder/ Cone Center of Surface (plane, sphere cylinder, sphere, any)

Updating Measures
If you modify a part in a part document, or modify, move, delete, etc. a part in a product document and the measure is impacted, it will be identified as not up-to-date in the specification tree. This section deals with:

• •

Step-by-Step Scenario (Local Update) Automatic Update
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Enhancements
The update error mechanism is now available when working on a Part document The measure update is not automatic at product opening. Design Mode measures and, in Visualization Mode, measures on products selected in the specification tree only are associative.

Step-by-Step Scenario
Open the AssociativeMeasures.CATPart from the cfysm/samples folder. In ENOVIA DMU, insert the CATPart. This step-by-step scenario consists in updating a Measure Item measure following a a modification in part radius
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1. Measure the properties of a part. Click the Measure item icon 2. Select the Keep Measure checkbox in the Measure dialog box to keep measures as features in the specification tree. The Keep Measure option is available in the Measure Between, Measure Item and Measure Inertia commands.

3. Modify the part, for example decrease the value of the radius. Note: You cannot modify parts in ENOVIA DMU, move the part instead. The measure icon in the specification tree changes to indicate that the measure is not up-to-date and requires updating.

4. Update the measure. The measure is updated to reflect modifications to the part.

Notes: o In Measure Between and Measure Item commands, moving the cursor over the measure in the geometry area or the specification tree dynamically highlights all related items in both the geometry area and
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o

o

specification tree. In a part document, you can update either an individual measure or the Measure entry. To do so, right-click in the specification tree and select Local update from the contextual menu Selecting the Measure entry in the specification tree lets you update all measures needing updating in one go.

o o

In a product document, right-click the measure and select Measure object -> Measure Update from the contextual menu. If the measure is considered up-to-date, a Force Measure Update entry appears instead in the contextual menu. The Force Measure Update command is also available in the DMU scene context.

Automatic Update
To have your measures updated automatically in a part or a product document, select the appropriate check box in Tools -> Options -> General -> Parameters and Measure, Measure Tools tab.

By default, these check boxes are cleared.
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Notes: • In a part document, you must also select the Automatic Update option button in Tools -> Options -> Infrastructure -> Part Infrastructure -> General.

•

In a product document, if you edit a part, any measures will be automatically updated when you activate the product.

When you open a product document, measures are not automatically updated even if the Automatic update in product check box is selected in Tools -> Options >Parameters and Measure, Measure Tools tab. For example, if you save a document in which measures are not up-to-date and then re-open the document, measures remain in the not up-to-date status even if you selected the automatic update check box in Tools-> Options. Step-by-Step Scenario 1. Select Automatic Update in product check box in Tools -> Options >Parameters and Measure-> Measure Tools.

2. Open the Update_Measure.CATProduct 3. The measure is to be updated, a tornado is displayed.
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4. Activate a product in the specification tree 5. The measure update operation is launched. The tornado is no longer displayed. 6. When done, close your product without saving changes. Notes: o o The update works on associative measures only. (For instance, in visualization mode, only when 'product only' option is selected) In Part context, you cannot update measures when geometry is modified, you must switch to Product context to update measures

7.

In a part, Measure Between, Measure Item and Measure Inertia measures are now integrated into the Part Design Update mechanism. An Update Diagnosis message is displayed if during Part update operation, a relatedmeasure problem is identified. This message lets you solve the problem editing or deleting the measure

Notes: • • After the measure modification, if the Automatic option button is selected in Tools->Options->Infrastructure->Part infrastructure->General, the whole part is updated. For more detailed information, read Updating Parts section in Part Design User's Guide

Invalid Measures
Measures are no longer valid if links are not resolved. This happens if: • • You delete an item on which a measure is made You switch to visualization mode or open a document in visualization mode. For example, your measure is made on a face in design mode, you save the
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Deleting Measures
In a part document, Measure Between, Measure Item and Measure Inertia measures are integrated into the parent-child mechanism. If you delete items on which measures are made, the Delete dialog box appears letting you delete measures at the same time. Associated measures are highlighted in the specification tree.

Similarly, if you delete measures, the Delete dialog box lets you delete the measured items provided they are exclusively used for the measures (Delete exclusive parents option). Notes: • In a product document, measures are not integrated into the product Delete mechanism. When you delete a product on which a measure is made, the measure is no longer valid and links to the geometry are also deleted.

Restrictions
• Measures made prior to Version 5 Release 6 are not associative and therefore cannot be updated. These measures are identified in the specification tree by . the measure icon plus a lock, for example Visualization Mode measures and measures on cgr files made in the geometry area are not associative and therefore cannot be updated. These measures . are identified as above: Only products selected in the specification tree in Visualization Mode can be

•
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Basic Tasks updated. Measures made in Picking point, Picking axis, Intersection and Center of 3 points selection modes are not associative. Inertia measures made on a multiple selection of items are not associative. In the Drafting, Generative Structural Analysis and Advanced Meshing Tools workbenches, measures are done on-the-fly and are not persistent. This means that they are not associative.

• • •
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Editing Measures
You can adjust the presentation of the measure, edit the measure itself and: • Change one of the selections on which it was based. You can also change selections that no longer exist because they were deleted. • Replace selections using the replace mechanism (In a part)

This section describes the following editing operations:

• • •

Changing selections Replacing selections in a Part Editing the presentation of your measure

Changing selections
You can change selections on which your measure is based in Measure Between and Measure Item commands. This is particularly useful in design mode where you no longer have to redo your measure. 1. Double-click the measure in the specification tree or geometry area. 2. Make new selections. Notes: o In Measure Between, you can change selection modes when making new selections. For invalid measures where one selection has been deleted, you only have to replace the deleted selection. For all other measures, repeat all selections. In Measure Item, you cannot change the selection 1 mode. If you selected a curve, you must make a selection of the same type, i.e. another curve.

o o

3. Click OK when done.
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Replacing selections in a Part
In a part, you can change selections using the Replace mechanism in Measure Between, Measure Item and Measure Inertia commands. Note: In a product, measures are not integrated into the Replace mechanism. When you replace a product on which a measure is made, the measure is no longer valid and links to the geometry are deleted. Special case: If your measure was made on a product in the specification tree, the measure is identified as not up-to-date after you replace the product.
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1. Make your measure using the appropriate measure command. Important: Selecting features in the specification tree rather than selecting items in the geometry area is highly recommended. Some items selected in the geometry area may no longer exist as such if you modify the geometry and, in this case, the measure will be invalid ( ).

2. Right-click the selection you want to replace and select Replace... from the contextual menu. The Replace dialog box appears.

Note: Replacing a selection impacts all items or entities linked to the selection. 3. Make a new selection. 4. Click OK in the Replace dialog box.The measure is identified as not up-todate. 5. Right-click the measure in the specification tree and select Local update from the contextual menu to update your measure.
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6.
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Editing the presentation of your measure
To adjust the presentation of Measure Between and Measure Item measures, you can move: • • the lines and text of the measure.

The Properties command (Graphics tab) lets you change the fill color and transparency as well as the color, line type and thickness of measure lines. Note: You cannot vary transparency properties, the current object is either the selected color or transparent.

Using Measures in Knowledgeware
Measures can be used in formulas. A set of results (length, angle, etc.) is associated to each measure feature in the specification tree. Each piece of information can be used to create parameters in formulas or to create geometry. To read more, see specifying measures in formulas. Measures can also be used to valuate parameters. When doing so, an associative link between the measure and parameter is created. This task explains how to create a point on the measured center of gravity of a part. Have completed the task on associative measures. In ENOVIA DMU, you need a Part Design license to complete this task.
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1. Create a point using the Point command. The Point Definition dialog box appears for you to enter point coordinates. 2. Right-click the X= field and select Edit formula... from the contextual menu.

The Formula Editor dialog box appears letting you define the x coordinate by a formula.

3. Select the measured X coordinate in the specification tree, then click OK.

The Point Definition dialog box is updated. 4. Repeat for Y and Z coordinates.
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5. Click OK in the Point Definition dialog box to create the point at the measured center of gravity of the part.

6. (Optional) Create a line on the point using the Line command, then move the object using the 3D compass and see everything update automatically.

Annotating
These tasks are documented in the DMU Navigator User's Guide where more information on annotating can be found. Add 3D annotations: Click the 3D Annotation icon, then click where you want to place the text, enter the text in the Annotation Text dialog box and click OK. Create annotated views: Click the Create an Annotated View icon, then annotate the active view using commands in the DMU 2D Marker toolbar. Manage annotated views: Click the Manage Annotated Views icon, then double-click the desired 2D view in the dialog box to recover it.
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Measuring Minimum Distances
This task explains how to measure minimum distance between products. Open the AnalyzingAssembly01.CATProduct document. 1.

Click the Distance and Band Analysis

icon to calculate distances.

The Edit Distance and Band Analysis dialog box appears.

Three computation types are available: inside one selection: (default type): within any one selection, tests each product of the selection against all other products in the same selection. Between two selections: tests each product in the first selection against all products in the second selection. Selection against all: tests each product in the defined selection against all other products in the document. 2. 3. Select Between two selections. Select CRIC_TOP (CRIC_TOP.1) to define Selection 1.
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4.

Click Selection 2 field and multi-select CRIC_BRANCH_3 (CRIC_BRANCH_3.1) and CRIC_JOIN (CRIC_JOIN.1)

You can select as many products as you want. Products will be placed in the active selection. To de-select products, reselect them in the specification tree or the geometry area. 5. Click Apply to calculate the distance. A Preview window appears visualizing selected products and the minimum distance (represented by a line, two arrows and a value). The Edit Distance dialog box expands to show the results.

If necessary, pan, zoom and/or rotate in the Preview window to visualize the results better.
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Minimum distance and other information identifying all distance components is given in the expanded dialog box. X, Y, Z coordinates of start and end points on products selected for the distance calculation as well as products themselves are identified. 6. Click OK to close the dialog boxes.

Measuring Inertia
Measuring Inertia ()

145

analyzing The Measure Inertia command lets you measure: • • 3D inertia properties of surfaces and volumes (explained below) 2D inertia properties of plane surfaces.

This section deals with the following topics:

• • • • • • • • • • • • • • •

Measuring 3D inertia Measuring 2D inertia Customizing your measure Exporting measure inertia results Creating geometry from measure results Notations used Inertia equivalents Principal axes Inertia matrix with respect to the origin O Inertia matrix with respect to a point P Inertia matrix with respect to an axis system Moment of inertia about an axis Updating measures Using measures in knowledgeware Restrictions

Measuring 3D Inertia
This task explains how to measure the 3D inertia properties of an object.

You can measure the 3D inertia properties of both surfaces and volumes, as well as retrieve the de model type documents. You can also retrieve inertia equivalents set in Knowledgeware formulas. The area, density, mass and volume (volumes only) of the object are also calculated.

Insert the Valve.cgr document from the samples folder. It is to be found in the online documentatio folder cfysm samples.

. In DMU, you 1. Click the Measure Inertia icon the menu bar. The Measure Inertia dialog box ap
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By default, 3D inertia properties are measu The Measure 2D Inertia icon lets you measu

Dialog box options

o

o o o

A Keep Measure option in the dialog b measures as features in the specifica associative and can be used as param A Create Geometry option lets you cr for principal axes in a part from inert An Export option lets you write result A Customize... option lets you define dialog box.

In the Drafting workbench, the Keep Measur the-fly. They are not persistent. This means as parameters. Note: When you move the cursor over the g

changes to reflect the measure command yo

3. Click to select the desired item in the specificatio

Selecting Items

In the geometry area, you can select individ Visualization mode.

To... make a multiple selection

Then

ShiftCtrl-c add other items to the initial selection tree select items using the bounding Drag outline make your multiple selection.(P2 only) Use t Notes: o o

Only items of the same type can be in outline; you cannot mix volumes and Inertia measures made on a multiple
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Dialog Box

The Dialog Box expands to display the result

The measure is made on the selection, geom of individual sub-products making up an ass window, you must select the desired sub-pro

In our example, the item selected has no su

The dialog box identifies the selected item a approximate:

o

o

In Design mode, measures access ex given. Note that it is possible to obta mode. In Visualization mode, measures are
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In addition to the center of gravity G, the pr inertia calculated with respect to the center volume (volumes only), density and mass of

You can also compute and display the princip appropriate option in the Measure Inertia Cu

The density is that of the material, if any, ap o

o

If no density is found, a default value surfaces) is displayed. You can, if desired, edit this value to display them in the dialog box. Note: measure feature. If sub-products or part bodies have d displayed.

To make sure, you retrieve the density on an you must select the item (part or part body) area. Notes:

o o

You can access the density of parts s mode. This functionality is available i To do so: Select the Save density in cgr >Options ->Infrastructure ->P Open a part to which material The density is stored in the CG

o

o o

Important: The material must be app part bodies, no density is saved. Close the Part document. Open the CGR file or switch to DMU S then measure the inertia.

4. You must be in design mode to access the d have been applied. 5. Unless specified otherwise, material inherita 6. Density is a measure of an item's mass per u density is a measure of an item's mass per u
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The number of decimal places, the display of trailing zeros and limits for exponential notation is controlled by the Units tab in the Options dialog box (Tools ->Options, General ->Parameters and Measure).

Geometry area
In the Geometry Area, axes of inertia are highlighted and a bounding box parallel to the axes and bounding the selected item also appears. Color coding of axes: • • • Red: axis corresponding to the first moment M1 Green: axis corresponding to the second moment M2 Blue: axis corresponding to third moment M3.
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Click Customize... to customize the inertia computation and define what will be exported to the text file. Click OK when done. If you checked the Keep Measure option in the Measure Inertia dialog box, your measures are kept as features and your specification tree will look something like this.

Some measures kept as features are associative and can be used as parameters.

You can write a macro script to automate your task. See Space Analysis on the Automation Documentation Home Page.

Customizing Your Measure
1. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box opens.
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Notes: o o The inertia properties check boxes selected here are also the properties exported to a text file. You can, at any time, define what will be computed and displayed in the Measure Inertia dialog box.

2. Click the appropriate options to compute and display in appropriate tabs of the Measure Inertia dialog box the: o o o o o o Inertia equivalents Principal axes Inertia matrix with respect to the origin O Inertia matrix with respect to a point P Inertia matrix with respect to an axis system Moment of inertia about an axis

3. Click Apply or OK in the Measure Inertia Customization dialog box when done.

Restrictions
• In the Drafting workbench, the Keep Measure option is not available. Measures are done on-the-fly. They are not persistent. This means that they are not associative and cannot be used as parameters.
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Advanced Tasks • You cannot measure inertia properties of either wire frame or infinite elements. For examples showing 3D inertia properties measured on surfaces. To find out more about notations used. is not In the No Show space, the Measure Inertia command accessible. Measures performed on sheet metal features provide wrong results. In unfolded view, volume elements are not taken into account when measuring Part Bodies. Measures are not associative when switching between folded view and unfolded view (using the Fold/Unfold icon toolbar). in the Sheet Metal

• • •

Measuring 2D Inertia
This task explains how to measure the inertia properties of plane 2D surfaces. You can measure the area, center of gravity, principal moments, inertia matrix as well as the principal axes. You can measure the inertia properties of plane surfaces including DMU sections. The area of the surface is also calculated.

• •

Step-by-Step Scenario Customizing Your Measure

Notes: You cannot measure inertia properties of either wireframe or infinite elements.

Step-by-Step Scenario
No sample document provided. . In DMU, you can also select 1. Click the Measure Inertia icon Analyze -> Measure Inertia from the menu bar. The Measure Inertia dialog box appears. 2. Click the Measure 2D Inertia icon .
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Dialog box options
o A Keep Measure option in the dialog box lets you keep current and subsequent measures as features. Some measures kept as features are associative and can be used as parameters. Note: This option is not available in the Drafting workbench. An Export option lets you write results to a text file. A Customize... option lets you define what will be computed and displayed in the dialog box.

o o

3. Click to select a plane 2D surface in the geometry area or the specification tree. The Dialog Box expands to display the results for the selected item.
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The dialog box identifies the selected item, in our case a DMU section, and indicates whether the calculation is exact or approximate: o In Design mode, measures access exact data and wherever possible true values are given. Note that it is possible to obtain an exact measure for most items in design mode. In Visualization mode, measures are made on tessellated items and approximate values are given.

o

In addition to the center of gravity G, the principal moments of inertia M and the matrix of inertia, the dialog box also gives the area of the selected item. The center of gravity G is computed with respect to the document axis system. The matrix of inertia is expressed in an axis system whose origin is the center of gravity and whose vectors are the axes of inertia. Notes: o o The matrix of inertia and the principal moments do not take density into account. You can also compute and display the principal axes A. To do so, you must first activate the appropriate option in the Measure Inertia Customization dialog box.

The number of decimal places, the display of trailing zeros and limits for exponential notation is controlled by the Units tab in the Options dialog box (Tools ->Options, General >Parameters and Measure). To find out more about notations used

In the Geometry Area
The axes of inertia are highlighted and a bounding box parallel to the axes and bounding the selected item also appears.
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Color coding of axes: o o Red: axis corresponding to the first moment M1 Green: axis corresponding to the second moment M2

When you move the cursor over the geometry or specification tree, its appearance changes to reflect the measure command you are in. 4. Click OK in the Measure Inertia dialog box. If you checked the Keep Measure option in the Measure Inertia dialog box, your measures are kept as features.

Customizing Your Measure
You can, at any time, define what will be computed and displayed in the tabs of the Measure Inertia dialog box. When measuring 2D plane surfaces, in addition to the properties computed by default, you can compute and display the principal axes. 1. Click Customize... in the Measure Inertia dialog box.The Measure Inertia Customization dialog box opens.
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Note: The inertia properties checked here are also the properties exported to a text file. 2. Click the appropriate options: o Principal axes

3. Click Apply or OK in the Measure Inertia Customization dialog box when done.

Notations Used for Inertia Matrices
This section will help you read the information given in the Measure Inertia dialog box for Inertia Matrix / G, Inertia Matrix / O, Inertia Matrix / P and Inertia Matrix / Axis System A.

• • • •

Moments and Products of 3D Inertia Moments and Products of 2D Inertia Matrix of Inertia Additional Notation Used in Measure Inertia Command

Moments and Products of 3D Inertia
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Ioy

Ioz

Product of inertia of the object about axes ox and oy: Pxz Product of inertia of the object about axes ox and oz: Pyz Product of inertia of the object about axes oy and oz: (where M is the mass of the object; units: kg.m2)

Pxy

Moments and Products of 2D Inertia
Moment of inertia of the surface about the ox axis: Ioy Moment of inertia of the surface about the oy axis: Pxy Product of inertia of the surface about axes ox and oy: (where A is the surface; units: m4) Iox

Matrix of Inertia
3D Inertia: 2D Inertia:

where I is the matrix of inertia of the object with respect to orthonormal basis Oxyz

Expression in Any Axis System:
I is the matrix of inertia with respect to orthonormal basis Oxyz. Huygen's theorem is used to transform the matrix of inertia:
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M = {u,v,w}: transformation matrix from basis (Pxyz) to basis (Puvw) TM is the transposed matrix of matrix M. J is the matrix of inertia with respect to an orthonormal basis Puvw: J = TM.I'.M

Additional Notation Used in Measure Inertia Command
Ixy = (-Pxy) Ixz = (-Pxz) Iyz = (-Pyz) Note: Since entries for the opposite of the product are symmetrical, they are given only once in the dialog box. IoxG Moment of inertia of the object about the ox axis with respect to the system Gxyz, where G is the center of gravity. IoxO Moment of inertia of the object about the ox axis with respect to the system Oxyz, where O is the origin of the document. IoxP Moment of inertia of the object about the ox axis with respect to the system Pxyz, where P is a selected point. IoxA Moment of inertia of the object about the ox axis with respect to the system Axyz, where A is a selected axis system. etc.

Inertia Equivalents
This section deals with the following procedures:

• • •

Understanding Inertia Equivalents Displaying Inertia Equivalents in the Measure Inertia dialog box Importing Inertia Equivalents
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Understanding Inertia Equivalents
Equivalents are user parameters set using the Knowledgeware formula command under parts or products and imported from text (*txt) or Excel (*xls) files. If your document contains inertia equivalents set using Knowledgeware capabilities, then the Inertia command will not calculate the inertia properties of the selected geometry but return the equivalent values. The Equivalent box of the Measure Inertia dialog box indicates whether or not equivalents have been used:

• •

0: the measure is made on the selection, geometry or assembly 1 or more: One or more inertia equivalents are taken into account.

Displaying Inertia Equivalents in the Measure Inertia dialog box
1. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box appears. 2. Select Equivalent checkbox in the Measure Inertia Customization dialog box. 3. Click Apply.

Sets of equivalent parameters must be valid to be taken into account. To be valid, all the p below must be listed.

An example of a text file follows. In text files, the name of the property and the value are s Equivalent_IsSurface false Equivalent_IsVolume true Equivalent_Area 6m2 Equivalent_Volume 1m3 Equivalent_Mass 1000kg Equivalent_COGx 75mm Equivalent_COGy -10mm Equivalent_COGz -25mm Equivalent_MatGxx 50000gxmm2 Equivalent_MatGyy 50000gxmm2 Equivalent_MatGzz 50000gxmm2 Equivalent_MatGxy 0gxmm2 Equivalent_MatGxz 0gxmm2
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Importing Inertia Equivalents
1. Select the product to which you want to associate inertia equivalents. 2. Click the formula icon .

3. Click Import... in the Formulas dialog box. Parameters to be imported are listed

4. Select the text or Excel file containing the inertia equivalents in the file selection dialog box

5. Click OK to import all the parameters listed into the document. Imported parameters are now displayed in the Formulas dialog box.

6. Click OK in the Formulas dialog box. You are now ready to run your inertia calculation. • •

Having imported inertia equivalents, you no longer need the representations of the product de-activate them (Edit ->Representations). De-activated representations are unloaded. Thi improves system response time. To display parameters in the specification tree, select the Parameters checkbox Display in S tab of the Options dialog box (Tools-> Options-> Infrastructure-> Part Infrastructure).

Measuring the Principal Axes A about which Inertia is Calculated
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1. Select the Measure Inertia icon

.

2. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box is displayed. 3. In the Measure Inertia Customization dialog box, select Principal axes check box 4. Click Apply. The Inertia / G tab in the Measure Inertia dialog box becomes available. 5. Click the Inertia / G tab to display the principal axes about which inertia is calculated.

Note: If you checked the Keep Measure option, bounding box values are also displayed in the specification tree 6. You can create the axis system corresponding to the principal axes.

Measuring the Inertia Matrix with respect to the Origin O of the Document
1. Select the Measure Inertia icon . 2. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box is displayed. 3. In the Measure Inertia Customization dialog box, click Inertia matrix / O. 4. Click Apply. The Inertia / O tab in the Measure Inertia dialog box becomes available. Entries for the inertia matrix appear in the specification tree. 5. Click the Inertia / O tab to display the inertia matrix of selected items with respect to the origin O of the document.

6.
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Measuring the Inertia Matrix with respect to a Point P
Insert or open the InertiaVolume.CATPart from the common functionalities sample folder cfysm/samples. 1. Select the Measure Inertia icon .

2. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box opens 3. In the Measure Inertia Customization dialog box, select Inertia matrix / P checkbox. 4. Click Apply. The Inertia / P tab in the Measure Inertia dialog box becomes available. 5. Click the Inertia / P tab.

6. Select the Select Point checkbox. 7. Select a point in the geometry area: The coordinates of the point and the inertia matrix are given in the dialog box.

Note: Once you select a point in the geometry area, the Select Point check box is cleared.

Note: Only points created in the Part Design workbench are valid. 8. Selecting another item calculates the inertia matrix of the selected item with
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9.

Measuring the Matrix of Inertia with respect to an Axis System
Insert or open the InertiaVolume.CATPart from the common functionalities sample folder cfysm/sa
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1. Select the Measure Inertia icon

.

2. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dia

3. In the Measure Inertia Customization dialog box, Select Inertia matrix / Axis System check 5. Click the Inertia / Axis System tab. 6. Select the Select Axis system check box.

4. Click Apply. The Inertia / Axis System tab in the Measure Inertia dialog box becomes availa

7. Select an axis system in the specification tree: Note: You must select the axis system in the specification tree.

The name of the axis system as well as the origin O, (U, V, W) -vectors and the matrix axis system are given in the dialog box. Entries for the matrix of inertia appear in the s

Note: Only axis systems created in the Part Design workbench (Axis System command are valid.

8. Selecting another item measures inertia properties of the selected item with respect to the To change axis system, click the Select Axis System check box again, then select another ax
T T T T T T

If you checked the Keep Measure option in the Measure Inertia dialog box, your matrix 165 features and, if made with respect to a V5 axis system, are associative. 9.
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Measuring the Moment of Inertia about an Axis
Insert or open the InertiaVolume.CATPart from the common functionalities sample folder cfysm/samples. 1. Select the Measure Inertia icon .

2. Click Customize... in the Measure Inertia dialog box. The Measure Inertia Customization dialog box opens 3. In the Measure Inertia Customization dialog box, select Moment / axis checkbox to measure inertia with respect to an axis. 4. Click Apply. The Inertia / Axis tab in the Measure Inertia dialog box becomes available. 5. Click the Inertia / Axis tab. 6. Select the Select Axis checkbox.

7. Select an axis in the geometry area: The equation and direction vector of the axis as well as the moment of inertia Ma about the axis and the radius of gyration are given in the dialog box.
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Note: Only axes created in the Part Design workbench are valid. 8. Selecting another item measures the inertia of the selected item about the same axis. To change axis, click the Select axis checkbox again, then select another axis.

3D Inertia Properties of a Surface
You can measure 3D inertia properties on exact and tessellated surfaces. Examples showing a surf and a DMU section are given below. Insert or open the InertiaVolume.CATPart from the common functionalities sample folder cfysm/samples.

The DMU section is a tessellated surface.
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Analyzing Project/Product Structure
Analyzing Constraints
This task shows you how to analyze the constraints of an active component. All the items displayed in the Constraint Analysis dialog box are editable according to their respective behavior (Copy, Cut, Paste, Delete, etc). Open the AnalyzingAssembly02.CATProduct document. 1. Select Analyze -> Constraints. The Constraint Analysis dialog box is displayed. The Constraints tab displays the status of the constraints of the selected component:
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The Constraints tab displays the status of the constraints of the selected component: • • • • Active Component displays the name of the active component. Component displays the number of child components contained in the active component. Not constrained displays the number of child components not constrained in the active component. Status displays the status of the constraints: o Verified displays the number of verified constraints. o Impossible displays the number of impossible constraints. "Impossible" means that the geometry is not compatible with the constraint. For example, a contact constraint between two cylinders whose diameter is different is impossible. The yellow unresolved symbol is displayed in the specification o tree on the constraint type icon: Not updated displays the number of constraints to be updated. The application has integrated new specifications, which affect constraints. The update symbol is displayed in the specification tree on the constraint type icon: Broken displays the number of broken constraints. A reference element is missing in the definition of these constraints. It may have been deleted for example. You can then reconnect this constraint (see Reconnecting Constraints).

o
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The yellow unresolved symbol is displayed in the specification o tree on the constraint type icon: Deactivated displays the number of deactivated constraints (see Deactivating or Activating Constraints). The deactivated symbol is displayed in the specification tree. It . precedes the constraint type icon: Measure Mode displays the number of constraints in measure mode. Fixed Together displays the number of fix together operations. Total displays the total number of constraints of the active component.

o o o

In our scenario, the command displays the status of all constraints defined in AnalyzingAssembly product. The command Analyze -> Constraints. displays the status of constraints defined for sub-assemblies too. What you have to do is set the combo box on top of the dialog box to the sub-assembly name of your choice. In addition to the Constraints tab, the Broken tab and the Deactivated tab provide the name of the broken and deactivated constraints already indicated in the Broken and Deactivated fields. The constraints are clearly identified in these tabs and you can select them. Once selected, they are highlighted both in the tree and in the geometry area.
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Additional tabs may be displayed if one of these constraint status exists: • • • Impossible. Not updated. Measure Mode.

The tab Degrees of freedom also displays if all constraints of a given component are valid. To redefine the colors of the different type of constraints, see Customizing Constraint Appearance. This capability does not show overconstrained systems. The application detects them when performing update operations. For more information, see Inconsistent or Over-constrained Assemblies. You can also use the command Analyze -> Dependence, see Analyzing Dependences. 2. Click OK to exit and delete the following constraints to perform the rest of the scenario: Coincidence.12, Parallelism.15 and Line Contact.16. The document now contains only seven constraints. They all are verified. 3. Select Analyze -> Constraints again. The Constraints Analysis dialog box no longer contains the tabs Broken and Deactivated. 4. Click the Degrees of freedom tab.
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The application displays this tab only if all constraints are verified. The tab displays the components affected by constraints and the number of degrees of freedom remaining for each of them. 5. Double-click CRIC_TOP.1. The Degrees of Freedom Analysis dialog box is displayed.

One rotation as well as one translation remain possible for CRIC_TOP.1. For more information, please refer to Analyzing Degrees of Freedom.

6. Click Close then OK to exit.

Analyzing Dependences
This task shows you how to see the relationships between components using a tree. Open the AnalyzingAssembly03.CATProduct document. 1. Select the component CRIC_BRANCH_3.1.
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You can analyze the dependencies of your assembly by selecting the root of the tree too. 2. Select Analyze -> Dependencies... command. The Assembly Dependencies Tree dialog box appears.

3. Right-click CRIC_BRANCH3.1 and select the Expand node command from the contextual menu.
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The constraints defined for this component then appear:

4. Right-click CRIC_BRANCH3.1 and select the Expand all command from the contextual menu. Now, the constraints and components related to the component you have selected are displayed:

You can notice that there are: • • • • • a coincidence constraint between CRIC_BRANCH_3.1 and CRIC_BRANCH_1.1: Coincidence.4 a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_FRAME.1: Surface contact.5 a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_AXIS.1: Surface contact.9 a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_BRANCH_1.1: Surface contact.6 a coincidence constraint between CRIC_BRANCH_3.1 and CRIC_FRAME.1: Coincidence.7

5. Checking the different options available in the Elements frame. You can display the following: • • Constraints: by default, this option is activated Associativity: shows components edited in Assembly Design context, see Designing in Assembly Design Context. Contextual components are linked to support components by green lines in the graph. Relations: shows formulas. For more information, please refer to Knowledge Advisor User's Guide.

•
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6. You can also display the relationships by filtering the components you wish to see. Either check the Child option to take the children of the component into account or check Leaf to hide them. Contextual commands are available: • • • Expand all: lets you see the whole relationship. Note that doubleclicking produces the same result. Expand node: lets you see the relationship under the node. Set as new root: sets the selected component as the component whose relationships are to be examined.

Zooming in and zooming out in the tree is allowed. 7. Click OK to close the dialog box.

Flexible Sub-Assemblies
In the product structure from earlier versions you could only move rigid components in the parent assembly. Now, in addition to this behavior, you can dissociate the mechanical structure of an assembly from the product structure, and this within the same CATProduct document. As a consequence, you can move the components of a sub-assembly in the parent assembly. In a first time, this task recalls the behavior of rigid assemblies, then illustrates how to make sub-assemblies flexible and how constraints defined in the reference document affect them. Eventually you learn how to analyze the mechanical definition of an assembly whenever this assembly includes flexible sub-assemblies (and components attached together, see Fixing Components Together). • • When a sub-assembly is flexible, you can apply updates to it, move it when constrained and set constraints to it. What you need to keep in mind is that rigid sub-assemblies are always synchronous with the original product, whatever mechanical modification you perform. Flexible sub-assemblies can be moved individually, without considering the position in the original product. Since Release 7, you can edit the constraints defined for flexible subassemblies. The changes made to these constraints do not affect the constraints defined for the original product contained in the reference document. You can edit the following attributes: o values o orientation o driving/driven properties Set of constraints in a rigid sub-assembly will be removed when you

•

•
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make it flexible. Open the Articulation.CATProduct and chain.CATProduct documents. The product Articulation includes one CATProduct and two CATPart documents as follows:

1. Drag and drop the compass onto link (link.1), then select link (link.1) and drag it. The whole chain -and not link.1 only- is moved.

2. Undo this action to return to the initial state. 3. To make chain (chain.1) flexible, right-click it and select the chain.1 object -> Flexible/Rigid Sub-Assembly contextual command. Alternatively, click the Flexible Sub-Assembly icon .

You can notice that the little wheel to the left corner of the chain icon has turned purple. This identifies a flexible sub-assembly.
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4. You can now move link (link.1) independently from link (link.2). For example drag and drop the compass onto link (link.1) and move it in the direction of your choice.

5. Copy and paste chain (chain.1) within Articulation.CATProduct. You can notice that the property "flexible" is copied too.

6. To make chain (chain.2) rigid, right-click it and select the chain.2 object -> Flexible/Rigid Sub-Assembly contextual command. A message window appears.
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7. Drag and drop chain (chain.2) to clearly see both instances of chain.CATProduct.

8. In chain.CATProduct, move link (link.1) using the compass.

You can notice that because chain (chain.2) is rigid, it inherits the new position of the original chain.CATProduct. Conversely, chain (chain.1) remains unchanged.

What you need to keep in mind is that rigid sub-assemblies are always synchronous with the original product, whatever mechanical modification you perform. Flexible sub-assemblies can be moved individually, without considering the position in the original product. Since Release 7, you can edit the constraints defined for flexible sub-
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assemblies. The changes made to these constraints do not affect the constraints defined for the original product contained in the reference document. You can edit the following attributes: • • • values orientation driving/driven properties

9. Set an angular constraint between Link 1 and Link 2 in chain.CATProduct. For example, set 80 as the angle value.

You can notice that both instances, chain (chain.2) and chain (chain.1) inherit this constraint.

10. Edit the value of the angle constraint for chain (chain.1). Enter 100 for example. This new value is specific to chain (chain.1). Because chain (chain.1) is a flexible sub-assembly, this value can no longer be affected by changes to the value set in the reference document.
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11. Edit the value of the angle constraint set in chain.CATProduct. For example, enter 50 as the new value: because chain (chain.2) is a rigid sub-assembly, and as the constraint value for chain (chain.1) has been already redefined, chain (chain.2) is the only sub-assembly to inherit this new value.

Mechanical Structure
12. Select the Analyze -> Mechanical Structure... command to display the mechanical structure of Articulation.CATProduct. This mechanical structure looks different from the product structure. In Mechanical Structure Tree dialog box, chain.2 is displayed because it is a rigid sub-assembly. Conversely, chain.1 is not displayed since it is a flexible sub-assembly.
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This display is merely informative. Note that you can use the Reframe graph contextual command and the zoom capability to improve the visualization, but also the Print whole contextual command to obtain a paper document. For information on printing, please refer to Printing Documents.

Analyzing 3d Geometry
Checking Connections Between Surfaces
182
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This task shows how to analyze how two surfaces are connected, following a blend, match, or fill operation for example. Three types of analyses are available. • Distance: the values are expressed in millimeters

When the minimal distance between two vertexes is inferior to 1 micron, the vertexes are merged and the surface is considered as continuous in point. • Tangency: the values are expressed in degrees When the angle between two surfaces is inferior to 0.5 degree, the surface is considered as continuous in tangency. • Curvature: the values are expressed in percentage. Open the FreeStyle_08.CATPart document. 1. Select both surfaces to be analyzed. 2. Click the Connect Checker icon in the Shape Analysis toolbar.

The Connect Checker dialog box is displayed as well as another dialog box showing the color scale and identifying the maximum and minimum values for the analysis type.

183

analyzing

The Auto Min Max button enables to automatically update the minimum and maximum values (and consequently all values between) each time they are modified.

Check the Internal edges option if you want to analyze the internal connections. By default, the check box is unchecked. Two cases are available: • Surfaces are isolated. Only geometrical connections are checked, that is all pairs of neighboring surface edges within the tolerance given by the Maximum gap.
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Advanced Tasks Depending on the Maximum gap value, interference connections may be detected, for instance when surfaces have a size smaller the Maximum gap. In this case, you must decrease the Maximum gap value or join the surfaces to be analyzed (see next point) Surfaces are joined (using the Join command for instance) and the Internal edges option is checked. Topological connections are checked first, that is all edges shared by two topological surfaces. Then, the corresponding pairs of surface edges are checked to detect any geometrical connections within the tolerance given by the Maximum gap.

•

3. Choose the analysis type to be performed: Distance, Tangency or Curvature. 4. Set the Maximum gap above which no analysis will be performed. All elements apart from a greater value than specified in this field are considered as not being connected, therefore do not need to be analyzed. Be careful not to set a Maximum gap greater than the size of the smallest surface present in the document. In the color scale, the Auto Min Max button enables to automatically update the minimum and maximum values (and consequently all values between) each time they are modified.

•

You can right-click on a color in the color scale to display the contextual menu:
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- Edit: it allows you to modify the values in the color range to highlight specific areas of the selected surface. The Color dialog box is displayed allowing the user to modify the color range.

- Unfreeze: it allows you to perform a linear interpolation between non defined colors. The unfreezed values are no longer highlighted in green. - No Color: it can be used to simplify the analysis, because it limits the number of displayed colors in the color scale. In this case, the selected color is hidden, and the section of the analysis on which that color was applied takes on the neighboring color. • You can also right-click on the value to display the contextual menu:

- Edit: it allows you to modify the edition values. The Value Edition dialog box is displayed: enter a new value (negative values are allowed) to redefine the color scale, or use the slider to position the distance value within the allowed range, and click OK. The value is then frozen, and displayed in a green rectangle.
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- Use Max/Use Min : it allows you to evenly distribute the color/value interpolation between the current limit values, on the top/bottom values respectively, rather than keeping it within default values that may not correspond to the scale of the geometry being analyzed. Therefore, these limit values are set at a given time, and when the geometry is modified after setting them, these limit values are not dynamically updated. The Use Max contextual item is only possible if the maximum value is higher or equal to the medium value. If not, you first need to unfreeze the medium value. Only the linear interpolation is allowed, meaning that between two set (or frozen) colors/values, the distribution is done progressively and evenly. The color scale settings (colors and values) are saved when exiting the command, meaning the same values will be set next time you edit a given draft analysis capability. However, new settings are available with each new draft analysis. 5. Check the analysis results on the geometry. Here we are analyzing the distance between the surfaces. Each color section indicates on the geometry the distance between the surfaces.

There may be a tangency discontinuity while a curvature continuity exists. This may appear for instance in the case of two non tangent planar surfaces. From the Connect Checker dialog box, you can choose a number of visualization and computation options: • the comb: that is the spikes corresponding to the distance in each point
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Finally, the scaling option lets you define the visualization of the comb. In automatic mode the comb size is zoom-independent and always visible on the screen, otherwise you can define a coefficient multiplying the comb exact value. 6. Check the Information button: Two texts are displayed on the geometry localizing the minimum and maximum values of the analysis as given in the Connect Checker dialog box.

You can also choose the discretization, that is the numbers of spikes in the comb (check the Comb option to see the difference). The number of spikes corresponds to the number of points used for the computation: • Light: 5 spikes are displayed. This mode enables to obtain consistent results with the visualization of sharp edges. An edge is considered as sharp if its tangency deviation is higher than 0.5 degree. To only detect tangency deviations on sharp edges, specify a deviation of 0.5 degree minimum. To visualize sharp edges, make sure the View -> Render Style -> Shading with Edges and Hidden Edges option is checked. • Coarse: 15 spikes are displayed • Medium: 30 spikes are displayed • Fine: 45 spikes are displayed

188

Advanced Tasks

The Full result is only available with the Generative Shape Design 2 product. The number of selected elements and the number of detected connections are displayed below the color range. 7. Click the Quick... button to obtain a simplified analysis taking into account tolerances. The comb is no longer displayed. The Connect Checker dialog box changes to this dialog box. The Maximum gap and information are retained from the full analysis. The maximum deviation value is also displayed on the geometry.

You can use the check button to select one or several analyses (up to three). As a consequence, the colorful area displaying the deviation tolerance between the surfaces shows the continuity whose value is the lowest. In the case you select several types of continuity, the Information button is grayed out. • You can check the Overlapping button to highlight where, on the common boundary, the two surfaces overlap. In this case the other analysis types are deactivated. • You can check the Information button to display the minimum

189

analyzing and maximum values in the 3D geometry, or uncheck it to hide the values. In P1 mode, only the quick analysis is available. 8. Use the spinners to define the deviation tolerances. For example, the red area indicates all points that are distant of more than 0.1 mm. The maximum deviation values on the current geometry are displayed to the right of the dialog box.

9. Click OK to create the analysis. The analysis (identified as Surface Connection Analysis.x) is added to the specification tree (P2 only). This allows the automatic update of the analysis when you modify any of the surfaces, using the control points for example. If you do not wish to create the analysis, simply click Cancel. • • • • You can edit the color range in both dialog boxes by double-clicking the color range manipulators (Connect Checker) or color areas (Quick Violation Analysis) to display the Color chooser. If you wish to edit the Connection Analysis, simply double-click it from the specification tree. If you no longer need the Connection Analysis, right-click Connection Analysis in the specification tree, and choose Delete. The curvature difference is calculated with the following formula: (|C2 - C1|) / ((|C1 + C2|) / 2) The result of this formula is between 0% et 200%. In the case of a curvature analysis type, the result is not guaranteed if a tangency discontinuity exists. • You can analyze internal edges of a surface element, such as a Join for
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•

You can create an analysis on an entire geometrical set simply by selecting it in the specification tree.

Checking Connections Between Curves
This task shows how to analyze how two curves are connected, following a blend, or match operation for example. Four types of analyses are available. • Distance: the values are expressed in millimeters

When the minimal distance between two vertexes is inferior to 1 micron, the vertexes are merged and the curve is considered as continuous in point. • Tangency: the values are expressed in degrees When the angle between two curves is inferior to 0.5 degree, the curve is considered as continuous in tangency. • Curvature: the values are expressed in percentage • Overlapping: the system detects overlapping curves Open the FreeStyle_09.CATPart document. 1. Select both curves to be analyzed. 2. Click the Curve Connect Checker icon The Connect Checker dialog box is displayed. in the Shape Analysis toolbar.
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At the same time a text is displayed on the geometry, indicating the value of the connection deviation. You can choose the type of analysis to be performed using the combo: distance, tangency or curvature.

In P1 mode, only this mode is available (no quick mode available). This step is P2 only for Wireframe and Surface. 3. Press the Quick button. The dialog box changes along with the text on the geometry.. With our example, the text in the geometry disappears because the distance between the two curves is smaller than the set Distance value.

4. Check the Tangency button: A text is displayed on a green background (as defined by default for the Tangency criterion) to indicate that the Tangency criterion is not respected, because the first text displayed is the one for which the set tolerance is not complied with. You can then increase the Tangency value, or modify the geometry to comply with your needs.
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5. Similarly, if you check the Curvature value, the displayed text indicates that the curvature between the two analyzed curves is greater than the set value. 6. Modify the tolerance values, or the geometry to comply with the tolerances. For example, if you modify the Tangency value to set it to 16 degrees, the geometry instantly reflects the compliance with the new value.

The maximum deviation values on the current geometry are displayed to the right of the dialog box. 7. Click OK to create the analysis. The analysis (identified as Curve Connection Analysis.x) is added to the specification tree. This allows the automatic update of the analysis when you modify any of the curves, using the control points for example (see Editing Curves Using Control Points). If you do not wish to create the analysis, simply click Cancel. • Double-click the Curve Connection Analysis from the specification tree to edit it. You can analyze internal edges of a element, such as a Join for example, by selecting only one of the initial elements:

•

•

Use the Overlapping mode to highlight where, on the common boundary, the two curves overlap. When the Overlapping button is checked, other analysis types are deactivated.
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•

The curve connection checking analysis is permanent in P2 mode only, i.e. it is retained in the specification tree for later edition and on the geometry till you reset or delete it, whereas in P1 mode, it is present at a time, but not retained when exiting the command.

Performing a Curvature Analysis
This task shows how to analyze the curvature of curves, or surface boundaries. Open the FreeStyle_10.CATPart document. When analyzing surface boundaries: • if you select the surface, the analysis is performed on all its boundaries

•

if you select a specific boundary, the analysis is performed only on this boundary.

Make sure the "Geometrical Element Filter" selection mode is active from the User Selection Filter toolbar. This mode lets you select sub- elements.

1. Click the Porcupine Curvature Analysis icon 2. Select the curve.

.
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Automatically the curvature comb is displayed on the selected curve:

3. Define the analysis parameters in the Curvature Analysis dialog box. • Use the Project on Plane checkbox to analyze the projected curve in the selected plane referenced by the compass. • If you uncheck the Project On Plane option, the analysis is performed according to the curve orientation. This is the default option.

4. Use the spinners to adjust the number of strikes and modify the density. 5. You can also decide to halve the number of spikes in the comb clicking as many times as wished the /2 button. This option is particularly useful when the geometry is too dense to be read but the resulting curve may not be smooth enough for your analysis needs. You could just as well double the number of spikes using the X2 button.
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6. Similarly, click the /2 button to fine-tune the amplitude (size) of the spikes, and re-compute the analysis curve accordingly.

7. Click Curvilinear to switch from the Parametric discretization mode to the Curvilinear analysis. You will get something like this:

8. Check the Automatic option optimizes the spikes length so that even when zooming in or out, the spikes are always visible. 9. Check the Logarithm option to display the logarithmic values in the 3D geometry.
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Displaying these values does not modify the analysis. 10. Click Reverse, you will get something like this: That is the analysis opposite to what was initially displayed. This is useful when from the current viewpoint, you do not know how the curve is oriented.

11. Use the Particular checkbox to display at anytime the minimum and the maximum points.
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Inflection points are displayed only if the Project on Plane and Particular checkboxes are checked. 12. The Inverse Value checkbox displays the inverse value in Radius, if Curvature option is selected, or in Curvature, if Radius option is selected. You can right-click on any of the spikes and select Keep this Point to keep the current point at this location. A Point.xxx appears in the specification tree. If you check the Particular option, you have more options:

• • • • •

Keep all inflection points Keep local minimum (corresponds to the absolute minimum under the running point) Keep local maximum (corresponds to the absolute maximum under running point) Keep global minimum (in case there are two curves, the point will be found on one or other of the curves) Keep global maximum (in case there are two curves, the point will be found on one or other of the curves)

This option is only available in P2 mode in FreeStyle Shaper, Optimizer, and Profiler.
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13. Finally, click the

icon to display the curvature graph:

The curvature profile and amplitude of the analyzed curve is represented in this diagram. When analyzing a surface or several curves, i.e. when there are several curvature analyses on elements that are not necessarily of the same size for example, you can use different options to view the analyses. For example, when analyzing a surface, by default you obtain this diagram, where the curves color match the ones on the geometry.

•

: all curves are displayed according to the same vertical Same vertical length length, regardless of the scale
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•

Same origin : all curves are displayed according to a common origin point on the Amplitude scale

•

Vertical logarithm scale : all curves are displayed according to a logarithm scale for the Amplitude, and a linear scale for the Curve parameter.
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Depending on the chosen option, values displayed in the diagram are updated. The last icon is used to reframe the diagram within the window, as you may move and zoom it within the window. 14. Right-click a curve and choose one of the following options from the contextual menu:

• • •

Remove: removes the curve Drop marker: adds Points.xxx in the specification tree Change color: displays the Color selector dialog box that enables you to change the color of the curve.

15. Slide the pointer over the diagram to display the amplitude at a given point of the curve. You can slide the pointer over the diagram and the 3D analysis. Click the x in the top right corner to close the diagram. 16. Click OK in the Curvature Analysis dialog box once you are satisfied with the performed analysis. The analysis (identified as Curvature Analysis.x) is added to the specification tree. In case of clipping, you may want to temporarily modify the Depth Effects' Far and Near Limits. See Setting Depth Effects in CATIA Infrastructure User Guide.

Analyzing Distances Between Two Sets of Elements
This task shows how to analyze the distance between any two geometric elements, or between two sets of elements.
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Open the DistanceAnalysis1.CATPart document. 1. Select an element, or set of elements. 2. Click the Distance Analysis icon in the Shape Analysis toolbar. The Distance dialog box is displayed.

3. Click Second set and select a second element, or set.

The distance analysis is computed. Each color identifies all discretization points located at a distance between two values, as defined in the Color Scale dialog box.

•

•

When computing the distance between two curves, there is no negative values possible as opposed to when analyzing the distance between a surface and another element. Indeed, surfaces present an orientation in all three space directions whereas, in the case of planar curves for example, only two directions are defined. Therefore the distance is always expressed with a positive value when analyzing the distance between two curves. The element which dimension is the smallest (0 for points,1 for curves, 2 for surfaces for example) is automatically discretized, if needed. When selecting a set of element, the system compares the greatest dimension of all elements in each set, and discretizes the one with the smallest dimension.
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In some cases, when inverting the computation direction does not make sense, when one of the elements is a plane for example, the Invert Analysis button is grayed. • If you check the Running point option, you need to move the pointer over the discretized element to display more precise distance value between the point below the pointer and the other set of elements. The projection is visualized and the value is displayed in the geometry area.

Note that the analyzed point is not necessarily a discretized point in this case. This is obvious when a low discretization value is set, as shown here. Two analysis modes are available, with corresponding color ramps, provided the Color scale checkbox is checked.

a. Full (P2 only): activated by the Full color range icon, it provides a complete analysis based on the chosen color range. This allows you to see exactly how the evolution of the distance is performed on the selected element.
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b. Limited: activated by the Limited color range , it provides a simplified analysis, with only three values and four colors.

Whichever mode you choose the use of the color scale is identical: it lets you define colors in relation to distance values. You can define each of the values and color blocks, therefore attributing a color to all elements which distance falls into to given values. • The Auto Min Max button enables to automatically update the minimum and maximum values (and consequently all values between) each time they are modified. • You can right-click on a color in the color scale to display the contextual menu:

- Edit: it allows you to modify the values in the color range to highlight specific areas of the selected surface. The Color dialog box is displayed allowing the user to modify the color range.

- Unfreeze: it allows you to perform a linear interpolation between non defined colors. The unfreezed values are no longer highlighted in green.
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- No Color: it can be used to simplify the analysis, because it limits the number of displayed colors in the color scale. In this case, the selected color is hidden, and the section of the analysis on which that color was applied takes on the neighboring color. • You can also right-click on the value to display the contextual menu:

- Edit: it allows you to modify the edition values. The Value Edition dialog box is displayed: enter a new value (negative values are allowed) to redefine the color scale, or use the slider to position the distance value within the allowed range, and click OK. The value is then frozen, and displayed in a green rectangle. - Use Max/Use Min : it allows you to evenly distribute the color/value interpolation between the current limit values, on the top/bottom values respectively, rather than keeping it within default values that may not correspond to the scale of the geometry being analyzed. Therefore, these limit values are set at a given time, and when the geometry is modified after setting them, these limit values are not dynamically updated. The Use Max contextual item is only possible if the maximum value is higher or equal to the medium value. If not, you first need to unfreeze the medium value. Only the linear interpolation is allowed, meaning that between two set (or frozen) colors/values, the distribution is done progressively and evenly. The color scale settings (colors and values) are saved when exiting the command, meaning the same values will be set next time you edit a given distance analysis capability. However, new settings are available with each new distance analysis. 5. Set the distance analysis type (we checked the Auto Scale button and unchecked the Min/Max values button):
Projection Space

The Projection Space area helps you define the preprocessing of the input elements used for the computation.
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•

,Y , or Z axis: the computation Projection according to the X is done between the projection of selected elements. : the Projection according to the compass current orientation computation is done between the projection of selected elements.

•

•

: the Planar distance distance is computed between a curve and the intersection of the plane containing that curve.

Measurement Direction

The Measurement Direction area provides options to define how set the direction used for the distance computation.

•

: the Normal distance distance is computed according to the normal to the other set of elements.

•

Direction according to the X ,Y , or Z
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axis. • Direction according to the compass current orientation .

icon to display the 2D diagram distance analysis window. 6. Click the The latter allows to visualize the distance evolution.

Drawing modes: • • : to draw the curves in a linear horizontal scale Vertical Inverse Scale and and inverse vertical scale. Reframe : to reframe the frame
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7. Click More>> in the Distance dialog box to see, and choose further display and discretization options:

•

Color scale: to display the Color Scale dialog box whether the full or the limited color range. Statistical distribution: to display the percentage of points between two values.

•

This option is only available if the Color Scale checkbox is checked.

•

Min/Max values: to display the minimum and maximum distance values and locations on the geometry.
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•

Points: to see the distance analysis in the shape of points only on the geometry (The Spikes button is unchecked)

•

Spikes: to see the distance analysis in the shape of spikes on the geometry. You can further choose to: o set a ratio for the spike size o choose an automatic optimized spike size (Auto scale) o invert the spike visualization on the geometry o display the envelope, that is the curve connecting all spikes together

•

Use the Texture option to check the analysis using color distribution. This option is only available with surfacic elements in at least one set, providing this set is discretized. The distance is computed from this discretized set to the other set. The texture mapping is computed on the discretized surface. It is not advised to use it with planar surfaces or ruled surfaces. Statistical distribution, Min/Max values, and Points cannot be visualized when using the Texture option. The visualization mode should be set to Shading with Texture and Edges, and the discretization option should be set to a maximum (in CATIA Infrastructure User Guide,

•

•

•
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analyzing see Improving Performances, the 3D Accuracy -> Fixed option should be set to 0.01). Check the Material option in the View -> Render Style -> Customize View command to be able to see the analysis results on the selected element. Otherwise a warning is issued. • Use the Curve Limits option to relimit the discretized curve. Two manipulators appear at both extremities of the curve: they let you define new start and end points on the curve.

Start and end points are defined by a ratio of curve length between 0 and 1. If you extend the curve for instance, this ratio is kept.

•

Use the Max Distance option to relimit the distance: for example, set the value to 150mm. The maximum value is displayed accordingly on the geometry.

• •

Use the Discretization option to reduce or increase the number of points of the second set of elements taken into account when computing the distance. Automatic trap: to delimit the second set of points to be taken into account for the computation, in the case of a large cloud of points, thus improving the performances. Be careful when using the Automatic trap option with certain cloud configurations, such as spiralling clouds of points for example, as the automatic trap may remove too many points to generate consistent results. In this case, it is best to deactivate the check button.
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8. Click OK to exit the analysis while retaining it. The analysis (identified as Distance Analysis.x) is added to the specification tree. • Even though you exit the analysis, the color scale is retained till you explicitly close is. This is like a shortcut allowing you to modify one of the analyzed elements, which leads to a dynamic update of the distance analysis, while viewing the set values/colors at all times and without having to edit the distance analysis. When analyzing clouds of points, in normal projection type, the distances are computed as the normal projection of each point of the first cloud onto the triangle made by the three points closest to that projection onto the second cloud. As it is a projection, using the Invert Analysis button does not necessarily gives symmetrical results. When you select the geometrical set as an input in the specification tree, all the elements included in this geometrical set are automatically selected too.

•

•

The auto detection capability is available from the FreeStyle Dashboard. You can calculate the minimum distance between two curves along a direction using the Knowledge Expert product. For further information, refer to the Knowledge Expert's User's Guide, Reference, Functions Package, Measures chapter.

Performing a Draft Analysis

•

This command is not available with the Generative Shape Design 1 product.

configuration mode. • Used in Part Design workbench, this command requires the This task shows how to analyze the draft angle on a surface. The Draft Analysis command enables you to detect if the part you drafted will be easily removed. This type of analysis is performed based on color ranges identifying zones on the analyzed element where the deviation from the draft direction at any point, corresponds to specified values. These values are expressed in the unit as specified in Tools -> Options -> General -> Parameters -> Unit tab. You can modify them by clicking on their corresponding arrow or by entering a value directly in the field. Open the FreeStyle_12.CATPart document. • The visualization mode should be set to Shading With Edges in the View -> Render Style
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analyzing command The discretization option should be set to a maximum: in Tools -> Options -> Display -> Performances, set the 3D Accuracy -> Fixed option to 0.01. Check the Material option in the View -> Render Style -> Customize View command to be able to see the analysis results on the selected element. Otherwise a warning is issued. Uncheck the Highlight faces and edges option in Tools -> Options -> Display -> Navigation to disable the highlight of the geometry selection.

• • •

1. Select a surface. It is highlighted. 2. Click the (Feature) Draft Analysis icon .

The Draft Analysis dialog box is displayed. It gives information on the display (color scale), the draft direction and the direction values. The Draft Analysis.1 dialog box showing the color scale and identifying the maximum and minimum values for the analysis is displayed too.

Mode option
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Advanced Tasks The mode option lets you choose between a quick and a full analysis mode. These two modes are completely independent. The default mode is the quick mode. It simplifies the analysis in that it displays only three color ranges.

Quick mode

Full mode

In P1 mode, only the quick mode is available. • You can double click on a color in the color scale to display the Color dialog box in order to modify the color range:

•

You can also double-click on the value to display the Value Edition dialog box:

Enter a new value (negative values are allowed) to redefine the color scale, or use the slider to position the distance value within the allowed range, and click OK. The value is then frozen, and displayed in a green rectangle.
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The color scale settings (colors and values) are saved when exiting the command, meaning the same values will be set next time you edit a given draft analysis capability. However, new settings are available with each new draft analysis.
Display option

•

Uncheck the Color Scale checkbox to remove the Draft Analysis.1 dialog box.

This dialog box only appears in edition mode. • Activate the On the fly checkbox and move the pointer over the surface. This option enables you to perform a local analysis. Arrows are displayed under the pointer, identifying the normal to the surface at the pointer location (green arrow), the draft direction (red arrow), and the tangent (blue arrow). As you move the pointer over the surface, the display is dynamically updated.

Furthermore, circles are displayed indicating the plane tangent to the surface at this point. The displayed value indicates the angle between the draft direction and the tangent to the surface at the current point. It is expressed in the units set in using the Tools -> Options -> General -> Parameters -> Units tab. The On the fly analysis can only be performed on the elements of the current part. Note that you can activate the On the fly option even when not visualizing the materials. It gives you the tangent plane and the deviation value. • Click the Inverse button to automatically reverse the draft direction:
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When several elements are selected for analysis, the draft direction is inverted for each element when the button is clicked.

In case of an obviously inconsistent result, do not forget to invert locally the normal direction via the Inverse button. The manipulator on the draft direction allows you to materialize the cone showing the angle around the direction.

Direction in the cone •

Direction out of the cone

Right-click the cone angle to display the Angle Tuner dialog box. When you modify the angle using the up and down arrows, the value is automatically updated in the color scale and in the geometry.

Note that you cannot modify the angle below the minimum value or beyond the maximum value.
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Full mode

Quick mode

• • • • • •

Right-click the Direction vector to display the contextual menu. It allows you to: hide / show the cone hide / show the angle hide / show the tangent lock / unlock the analysis position keep the point at this location A Point.xxx appears in the specification tree.
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In P1 mode, the Keep Point option is not available.
Direction

By default the analysis is locked, meaning it is done according to a specified direction: the compass w axis. In P1 mode, the default analysis direction is the general document axis-system's z axis. • , and select a direction (a line, a plane or planar face Click the Locked direction icon which normal is used), or use the compass manipulators, when available.

Using the compass manipulators •

Selecting a specific direction

to define the new current draft direction. Click the Compass icon The compass lets you define the pulling direction that will be used from removing the part.

You can display the control points by clicking the Control Points icon, yet the draft analysis is still visible, then allowing you to check the impact of any modification to the surface on the draft analysis.
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3. Once you have finished analyzing the surface, click OK in the Draft Analysis dialog box. The analysis (identified as Draft Analysis.x) is added to the specification tree. This capability is not available in P1 mode. • • • • Note that settings are saved when exiting the command, and redisplayed when you select the Draft Analysis icon again. Be careful, when selecting the direction, not to deselect the analyzed element. A draft analysis can be performed just as well on a set of surfaces. If an element belongs to an analysis, it cannot be selected simultaneously for another analysis, you need to remove the current analysis by deselecting the element to be able to use it again. In some cases, even though the rendering style is properly set, it may happen that the analysis results are not visible. Check that the geometry is up-to-date, or perform an update on the involved geometric element(s). The analysis results depend of the current object. May you want to change the scope of analysis, use the Define in Work object contextual command.

• •

Displaying Geometric Information On Elements
This task shows you how to display or hide geometric information on geometrical elements, such as any curve, or surface, either as a stand-alone element, or taking part in the composition of another element (intersection
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Advanced Tasks curve, cylinder axis, face of a pad, and so forth). Only geometry of topological cells is analyzed, therefore elements such as Cloud of points, for example, are not analyzed. Open the FreeStyle_15.CATPart document, or any .CATPart document containing geometrical elements. 1. Click the Geometric Information icon .

2. Select the element for which you want to display information either in the geometric area or in the specification tree. The Geometric Analysis dialog box is displayed.

Information, such as: • • • • the element type (Nurbs surface or curve, Pline, planes, etc.) whether the element has been trimmed, or not the number of segments (components) in both U & V direction (where applicable) the order of the element in both U & V direction (where applicable)

is displayed in the dialog box. Moreover, a vector representing the element's orientation (U for a curve, and U & V for a surface) is displayed on the geometrical element itself.

In the case of a 3D curve created using the Control Points type, the maximum order is 6. • • Uncheck the Geometric Information icon to exit the command, or simply click another icon. You cannot select an element from the specification tree as the selected element might be too complex (i.e. be composed of more than one cell) and the system cannot determine which element is to be analyzed. You can stack this command on top of the current command, i.e. that

•
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analyzing you editing an element using its control points, you can activate the Geometric Information icon. The current command is frozen, and when you exit the information command, you are back into the initial command.

The geometry type is categorized as follows: Displayed Type What is it ? NupbsCurve NupbsSurface NurbsCurve NurbsSurface PNupbs PNurbs PSpline PLine Line Plane Cylinder Helix FilletSurface SweepSurface Tabulated Cylinder IntCurve Non Uniform polynomial BSpline Curve Non Uniform polynomial BSpline Surface Non Uniform Rational BSpline Curve Non Uniform Rational BSpline Surface Parametric non rational curve on a surface Rational parametric curve Parametric curve on a surface Isoparametric curve on a surface Line or line segment Plane or planar face Cylinder Helix Procedural Fillet surface Procedural Sweep surface Procedural Extrude surface Intersection curve, that is resulting from the intersection of two surfaces
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MergedCurve

The aggregate of two curves with different limits or parameterizations

Displaying Geometric Information On Elements
This task shows you how to display or hide geometric information on geometrical elements, such as any curve, or surface, either as a stand-alone element, or taking part in the composition of another element (intersection curve, cylinder axis, face of a pad, and so forth). Only geometry of topological cells is analyzed, therefore elements such as Cloud of points, for example, are not analyzed. Open the FreeStyle_15.CATPart document, or any .CATPart document containing geometrical elements. 1. Click the Geometric Information icon .

2. Select the element for which you want to display information either in the geometric area or in the specification tree. The Geometric Analysis dialog box is displayed.

Information, such as: • • • • the element type (Nurbs surface or curve, Pline, planes, etc.) whether the element has been trimmed, or not the number of segments (components) in both U & V direction (where applicable) the order of the element in both U & V direction (where applicable)

is displayed in the dialog box. Moreover, a vector representing the element's orientation (U for a curve, and U & V for a surface) is displayed on the geometrical element itself.
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In the case of a 3D curve created using the Control Points type, the maximum order is 6. • • Uncheck the Geometric Information icon to exit the command, or simply click another icon. You cannot select an element from the specification tree as the selected element might be too complex (i.e. be composed of more than one cell) and the system cannot determine which element is to be analyzed. You can stack this command on top of the current command, i.e. that you editing an element using its control points, you can activate the Geometric Information icon. The current command is frozen, and when you exit the information command, you are back into the initial command.

•

The geometry type is categorized as follows: Displayed Type What is it ? NupbsCurve NupbsSurface NurbsCurve NurbsSurface PNupbs PNurbs PSpline Non Uniform polynomial BSpline Curve Non Uniform polynomial BSpline Surface Non Uniform Rational BSpline Curve Non Uniform Rational BSpline Surface Parametric non rational curve on a surface Rational parametric curve Parametric curve on a
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surface PLine Line Plane Cylinder Helix FilletSurface SweepSurface Tabulated Cylinder IntCurve Isoparametric curve on a surface Line or line segment Plane or planar face Cylinder Helix Procedural Fillet surface Procedural Sweep surface Procedural Extrude surface Intersection curve, that is resulting from the intersection of two surfaces The aggregate of two curves with different limits or parameterizations

MergedCurve

Analyzing 2D Drawings
Comparing Drawings
The Digital Mock-up 2D workshop lets you run a 2D comparison on the following: • • • • • cgm format (CATIA, ENOVIA-DMU Navigator and DMU Viewer) CATDrawing format (ENOVIA-DMU Navigator only) V4 model (ENOVIA-DMU Navigator only) dxf/dwg format (ENOVIA-DMU Navigator only) raster formats (bmp, jpg, tiff, rgb, pcx, etc.)

This task explains how to compare two versions of the same drawing to highlight the differences and check for changes.

You can now compare and calibrate raster drawings. You can now compare vectorial drawings using resizing and offset values. You can now also compare raster drawings using resizing and offset values. You can now modify the colors used when comparing vectorial drawings. Open the Comparedrawings1.cgm from the samples folder.
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1. Select File ->Open and open Comparedrawings1.cgm. The Digital Mock-up 2D workshop is opened and displays the selected drawing. This is the reference to which the second drawing will be compared.

2. Click the Compare Drawing icon in the DMU 2D Tools toolbar. The Select Drawing dialog box appears letting you choose the drawing you want to compare with the reference drawing. 3. Select the drawing you want to compare, for example Comparedrawings2.cgm and click Open. The second drawing is opened and compared to the first. The Compare Drawing dialog box appears. Selected drawings are identified in the dialog box.

224

Advanced Tasks

Color coding: • • • Elements in drawing 1 only appear in red Elements in drawing 2 only appear in green Elements common to both drawings appear in blue

These colors can be modified: • • click the corresponding selection button of the color you wish to modify choose a color from the proposed list

Note: Colors cannot be modified for raster format drawings.

4. Click appropriate options in the dialog box to visualize drawing 1 or drawing 2 only, or to compare drawings. 5. (Optional) Click Calibrate to align drawings for easier comparison. In our example, this is not necessary. Note: You need to return to the Compare Drawing option before calibrating. The Calibrate dialog box appears.
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To calibrate by superimposing: • • • • • Click the Calibration by superimposing radio button. Select a reference line or axis in one of the drawings. Select a line or axis in the other drawing that you want aligned to the reference. Click Reverse to change the direction. Click OK.

The two drawings are aligned as defined.
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To calibrate by resizing: • • • Click the Calibration by resizing radio button. Modify the width and height of the drawings as desired. Click OK.

The two drawings are resized as defined.
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To calibrate by offset: • • • Click the Calibration by resizing radio button. Enter offset values for the X-axis and the Y-axis. Click OK.

Drawing 2 is offset as designated.
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6. Click Close in the Compare Drawing dialog box when done.

Measuring Distance, Angle and Radius on 2D Documents
This task explains how to measure distances, angles and radii on 2D documents of both vector and pixel type. Note: In the No Show space, this command is not accessible. No sample document is provided. 1. Select File -> Open and open a 2D document. The Digital Mock-Up 2D workshop is opened and displays the selected document. You can measure distance, angle and radius on documents in vector formats such as cgm, hpgl as well as in raster formats such as jpeg, bmp. For more information on: • • 2. 2D documents you can open, see Inserting Components in the DMU Navigator User's Guide. DMU 2D workshop, see the DMU Navigator User's Guide.

Click the 2D Measure

icon in the DMU 2D Tools toolbar.
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analyzing The 2D Measure dialog box appears. An automatic calibration, based on the width of the drawing, is proposed for vector type documents. The dialog box opens directly in the Measure mode. Click Calibration to visualize the reference distance (green arrow) and adjust the calibration if necessary. All measures will be made with respect to this reference. For pixel type documents, calibrating is necessary to make measures and the dialog box opens in the Calibration mode. • To calibrate, click two points to define the reference, then enter a distance in the Calibration field. Click the Measure check box to make your measure.

•

Note: The appearance of the cursor has changed to assist you. A number also helps you identify where you are in your measure or calibration. Calibration and distance measure cursor: Angle and arc measure cursor:

3.

Set the desired Measure type in the Measure type drop-down list box.
Defining Measure Types

• • •

Distance: measures the distance between two points. Angle: measures the angle defined by three points. Arc: measures the angle and radius of an arc fitted through three points.
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4.

Click to define the points between which the measure is made. The cursor snaps to vector elements in vector-type documents. The dialog box is updated and gives the appropriate information depending on the type of measure made.

5.

Click Close when done. The calibration value and reference distance are stored in memory and are re-proposed if you enter the command again whilst in the same document.

Collaboration
Sectioning
Exporting Section Results

You can save section results in a variety of different formats using: • • The Export As command. This command is particularly useful for exporting results to CATIA V4. The Capture command.
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Also read: • • More About the CATPart Working with a Cache System

This task illustrates how to export sectioning results in a number of different formats using the Export As command. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr. They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning in the DMU Space Analysis toolbar and create the desired icon section plane, slice or box and corresponding section.

2. Click the Result tab in the Sectioning Definition dialog box. 3. Click the Export As icon .The Save As dialog box appears.

4. Specify the location of the document to be saved and, if necessary, enter a file name. 5. Click the Save as type drop-down list and select the desired format. You can save sectioning results as: o o o a V4 model (.model) a V5 CATPart (.CATPart) a V5 CATDrawing (.CATDrawing) In this case, polylines are generated. Note also that the axis system corresponds to that of the section plane. DXF and DWG formats (.dxf/.dwg) a STEP document (.stp) an IGES document (.igs) a Virtual Reality Modeling Language (VRML) document (.wrl).

o o o o
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6. Click Save to save the results in a file in the desired format. Note: If you set the DLName document environment (Tools -> Options > General -> Document) as your current environment, clicking Export As will open the DLName dialog box instead of the usual Save As dialog box. The DLName document environment lets you restrict the access to specific folders referenced by logical names referred to as 'DLNames'. Each folder is assigned a logical name. In this mode, you can only access documents in folders referenced by DLNames. For more information on the DLName document environment, see the Infrastructure User's Guide. 7. Exit the Sectioning command when done.
More About the CATPart

For each element sectioned, a topologically correct spline is generated under the Open_body. Each spline is obtained by interpolating all the points making up the element sectioned. The resulting spline may not be smooth.

These curves can then be used, for example, to create features: • • • Select the Update icon to update your CATPart document Create a sketch from your curve using the Project 3D Elements command in the Sketcher workbench Create your feature, for example a pad.

Note: Section result colors are exported when section results are saved as CATPart documents.
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Working with a Cache System

If you are working with a cache system, you must select the Save lineic elements in cgr check box to be able to properly save your section result in V4 model, V5 CATPart, STEP, IGES, and VRML formats. This will save wireframe section results. If you do not do so, the document will be empty. • Save lineic elements in cgr option is located in the General box of the Cgr Management tab, Tools->Options->Infrastructure->Product Structure

Capturing Section Results
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Advanced Tasks This task illustrates how to export sectioning results to a CGM document using the Capture command. For more information on this command, see the Infrastructure User's Guide. 1. Generate your section. 2. In the active viewer, select Tools ->Image ->Capture. 3. Click the Vector Mode icon 4. Click the Save As icon Save As dialog box in the Capture toolbar. . Different CGM types are proposed in the

The CGM file can then be opened (File ->Open) in the DMU Mockup 2D workbench and used for comparison purposes. For more information on 2D comparison functionalities, see the DMU Navigator's User Guide.

Annotating Generated Sections
You can use generic measure tools, keeping measures as annotations, as well as 2D and 3D annotation tools to annotate generated sections in the Section viewer.

Create the desired section plane and corresponding section. To... Measure distances at item level Select... Measure Between You can measure minimum distances between edge primitives or between sections of elements (solid of a model, body of a CATPart). You can also measure distances between points representing the intersection of the plane with any wireframe elements present and other sectioned items, however, you cannot make measures with respect to grid elements.

235

analyzing Note: The Measure Between result is different depending on whether or not the section view is a filled view. If the section view is filled, the result obtained is the minimum distance between sections of selected elements. If the section view is unfilled, the result obtained is the minimum distance between edge primitives. For more information, see Measuring distances and angles between geometrical elements, and Measuring minimum distance in the Section viewer. Measure properties Measure Item You can measure properties on generated sections. For more information, see Measuring properties. Measure distances at product level Distance and Band Analysis in DMU Space Analysis

You can measure minimum distance between the sections of selected products (model, CATPart, etc.). For more information, see Measuring minimum distances and distances along X, Y, Z, and Measuring minimum distance in the Section viewer. Add 3D text 3D Annotation in DMU Space Analysis

For more information on 3D annotation, see the DMU Navigator User's Guide. Create and annote 2D views Creating Annotated Views in DMU Space Analysis

The Creating Annotated Views command lets you create and annotate a 2D view of your section using the arrows, lines, text, etc. provided in the DMU 2D Marker toolbar. 2D views are identified in the specification tree and can be recovered using the Managing Annotated Views icon.

For more information on 2D annotation, see the DMU Navigator User's Guide.
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Exporting Measure Inertia Results
This task shows you how to export both 3D and 2D inertia results to a text file. Insert the Body1.cgr and the Body2.cgr documents. They are to be found in the online documentation file tree in the common functionalities samples folder cfysm/samples
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1. Select the root product and click the Measure Inertia icon. The dialog box expands to display the results for the selected item. 2. Click Export to write the results to a text (*.txt) file. Results shown in the Measure Inertia dialog box only are exported. Exported results are given in current units. 3. Identify the file name and location in the Export Results dialog box that appears, then click Save. Notes: o The examples given below concern 3D inertia results.

o

If an assembly comprises sub-products or a part comprises part bodies, individual results for all sub-products or part bodies are also exported and written to the text file.

4. If the principal axes A are exported, bounding box values are also exported.

where BBOx,y,z defines the origin and BBLx,y,z the length along the corresponding axis.
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Note: When importing the text file into an Excel spreadsheet, do not forget to identify the pipe character (|) used as separator in the Text Import Wizard dialog box. 5.
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Working with CGRs in DMU
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This section provides information on working with CGRs in a DMU context. This is the default docum used for DMU sessions when working in Visualization mode and with the cache system. This format for design. CGR stands for CATIA Graphical Representation. CGR files always have a .cgr extension. All MULTICAx Plug-in products convert native part data into CGR format.

When using CGRs, a representation of the geometry only is available; the geometry is not available

Advantages:
• • • Requires less memory Documents are lighter Considerably reduces the time required to load your data For example, with the following CATProduct document, you can easily check the difference between the .Model document and the corresponding CGR file: With .Model: 6,708 MB

With CGR: 670KB

This may be useful when dealing with complex products or assemblies involving large amounts of d

Drawbacks:
• •

No design possible Relations between objects cannot be established because they are based on design features in DMU Kinematics, you cannot create joints because joints are built on design constraints.

In DMU:
• •

CGR documents can be inserted directly into DMU sessions They are generated automatically from exact geometry ( V4 Models, CATParts...) when wor
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•

cache system You can also generate CGR representations in certain DMU applications and save them as C example DMU Optimizer

Definitions:

Cache system concept: Two different modes are available when a component (V4 model, V5 CAT CATProduct, etc.) is inserted into a DMU Navigator CATProduct document

• •

Design mode Visualization mode

Using a cache system considerably reduces the time required to load your data. The cache system into two parts:

Local cache: a read/write directory located locally on your machine and used to store cgr files. Th component is inserted, it is tesselated. This means that the corresponding cgr file is computed and local cache as well as displayed in the document window. The next time this component is required which already exists (and not the original document) is automatically loaded from the local cache. normally responsible for the local cache.

Released cache: a read-only cache that can be located anywhere on your network. Several directories can be defined for the released cache. If a cgr file cannot be found in the local c software browses the released cache directories in their listed order to see if the cgr file is located If the cgr file is still not found, the component is tesselated and the resulting cgr file is saved in the The site administrator is normally responsible for the released cache.

A timestamp enables the verification that no modifications have been made to a document since th of the corresponding cgr file found in either of the above caches:

Timestamp: the date and hour at which the origin document was last modified. If you activate the timestamp button, then before a cgr file is loaded into a viewer, its timestamp will be checked to v modifications have been made to the document since the generation of the cgr file. If you do not a Check timestamp button, then a cgr file of a document will be loaded without any verification of its coherence with the document. The process used for loading data using the caches is as follows:
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Please refer to Customizing Cache Settings in Customizing for DMU Navigator section (DMU Naviga Guide)

Design mode: A working mode in which the exact geometry is available and documents (V4 mode CATParts, V5 CATProducts, etc.) are inserted as is.

Tessellation: The generation of a triangular mesh representation of an object from a solid or surfa Visualization mode: A working mode in which a representation of the geometry only is available corresponding cgr file, if it exists, is inserted from the data cache.

Cache System & multi-processors: You can choose the creation of cache files in multi-process for this, select the Multi-Process Visuali with local cache checkbox in Tools->Options->Infrastructure->Product Structure->Product visuali You also need to customize multi-process settings

For more detailed information please read Customizing Product Visualization Settings and Customiz Process settings

DMU Applications

The following table lets you see at a glance what you can do with CGRs in the various DMU applicat in particular any restrictions to working with CGRs in a DMU context. Note: in DMU kinematics context, you cannot work on cgrs.

243

analyzing

DMU Space Analysis

Commands Clash Sectioning Distance and band analysis Compare Products 2D Measure Arc through 3 points Measure Between Measure Item Measure Thickness Measure Inertia

Insert CGRs and Run... Yes Yes Yes Yes No Yes Yes, except for measure between points (1) (2) Yes, except for measure properties of points (1) (2) Yes Yes

Save Results as CGR... No No Band Analysis Results only No No No No No No No

(1) Points in edge limits, arc center and picking point selection modes are taken into account (2) Exact / approximate measures on CGRs: exact measures can only be obtained on canonical elements in Measure Between and Measure Item commands; all other measures are approximate.
DMU Optimizer

Commands Silhouette Wrapping Thickness Offset Swept Volume Free Space Simplification Result of a merging 244

Insert CGRs and Run... Yes Yes Yes Yes Yes Yes Yes Yes

Save Results as CGR... Yes Yes Yes Yes Yes Yes Yes Yes

Advanced Tasks operation 3D Cut
DMU Navigator

Yes

Yes

Commands Annotated View Camera 3D Annotation Hyperlink Group Scene Symmetry Translation or Rotation Axis System Creation Point Creation Line Creation Plane Creation Cumulative Snap Modify Sag Spatial Query Current Selection Publish Reset Position Init Position Track Color Action Visibility Action

Insert CGRs and Run... Yes Yes Yes Yes Yes Yes Yes Yes Yes, except selecting a sub-element Yes, except selecting a sub-element Yes, except selecting a sub-element Yes, except selecting a sub-element Yes No, requires the part document Yes Yes Yes Yes Yes Yes Yes Yes

Save Results as CGR... No Not Applicable No Not Applicable Not Applicable Yes Yes Yes Yes Yes Yes Yes Yes No Not Applicable Not Applicable Not Applicable Yes Yes No No No 245
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Sequence Clash Detection Record Viewpoint Animation

Yes Yes Yes

No Not Applicable Not Applicable
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DMU Sectioning

The DMU Sectioning tab contains three categories of options: • • • Section planes Section grid Results window

Section Planes

Default color
Use the color chooser to define the default color of section planes. By default, color is as shown above.
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Normal X, Y, Z
Select the option specifying the absolute axis along which you want to orient the normal vector of the section plane (master plane in the case of slices and boxes). By default, the normal vector is oriented along X.

Origin
Select the option locating the center of the plane: • • 0,0,0: at absolute coordinates 0,0,0 Selection: at the center of the bounding sphere around the products in the selection you defined.

By default, the origin option is set to Selection.

Hide the plane
Selecting this check box hides the plane on exiting the command. If cleared, the plane is kept in the Show space on exiting the command. By default, this check box is selected.

Hide the section results in the No Show space
Selecting this check box transfers the section results to the No Show place on exiting the command. By default, this check box is cleared.

Automatic computation of the result
Selecting this check box automatically updates sectioning results while manipulating the plane. If cleared, sectioning results are computed when you release the mouse button. By default, this option is selected.

Wireframe elements cut
Selecting this check box takes wireframe elements into account and the section plane sections any wireframe elements present. Points represent the intersection of the plane with wireframe elements. If cleared, wireframe elements are not taken into account. By default, this check box is selected.
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Allow measures on a section created with a simple plane
Selecting this check box gives the same 3D section cut display for a plane as in the case of a slice or box and lets you make measures on the wireframe section cut. By default, this check box is cleared.

Section Grid

Mode
Select the option to locate the grid: • • Absolute: sets grid coordinates with respect to the absolute axis system of the document. Relative: places the center of the grid on the center of the section plane (master plane in the case of slices and boxes).

By default, the mode is set to Absolute.

Style
Select the option defining how the grid is represented: Lines or Crosses. By default, the style is set to Lines .

Steps - Automatic filtering
Selecting this check box automatically adjusts the level of detail of the grid display when you zoom in and out. By default, this check box is cleared.

Steps - Width, Height
In the Width and Height boxes, type or select a new value to specify the spacing between grid lines. Units are current units set using Tools -> Options. By default, width and height are set to 100.
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Steps - Automatic grid resizing
Selecting this check box automatically re-sizes the grid to section results when moving the section plane. If cleared, the grid has the same dimensions as the section plane. By default, this option is selected. Automatic grid resizing ON: Automatic grid resizing OFF:

Results Window

Automatically open
Selecting this check box always displays the Section viewer when in the Sectioning command. Note: If cleared, the preview window is displayed. If, in addition, you clear the Sectioning preview option in the Digital Mockup General tab (Tools -> Options -> Digital Mockup -> General), then no viewers are displayed. By default, this option is selected.
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Always 2D view
Selecting this check box locks the Section viewer in a 2D view. If cleared, you can work in a 3D view. By default, this check box is selected.

Automatically reframe
Selecting this check box automatically fits the results into the available space in both the Section viewer and preview window when manipulating the section plane in the document window. By default, this check box is cleared.

Section fill
Selecting this check box fills in the section to generate a surface for measurement and display purposes. By default, this check box is selected.
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