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Collaboration: Overview
Digital Project provides many tools to support collaboration -- the sharing of data between people and systems. This includes conferencing and the import and export of files in a variety of formats.

1

What's New?
New functionalities
3D DXF/DWG Import

Enhanced functionalities
SDNF Import Imported structure can be identified with its piece mark. When a structure with modified section or material is being re-imported, the structure in digital project is updated and is represented in a different color. When a structure with modified supporting geometry is being re-imported, a new structure is created and is represented in a different color. Reordering Applicative Data, multiple selection STEP Export and Import AP203 edition2 is supported at import and export.

Customizing Settings
STEP Export Visualization filters are now taken into account: by default, entities placed in non-visualized layers are no longer exported. STEP Export The Application Protocol option for export has been enhanced with AP203 edition2.
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Basic User Tasks
Annotating
Adding 3D Annotations
You can annotate your 3D document. Annotations are attached to the point selected to place the text. This task explains how to add 3D text. 3D Annotations now move to no-show space when the associated part is moved to no-show space. Case with one part: • • When a part with linked 3D Annotation is hidden, the annotation is also hidden. When the part is shown, the linked 3D Annotation is also shown.

Case with several parts: • • • If one of the parts is hidden, the line joining the part and the 3D Annotation will also be hidden. If all the parts linked to the annotation are hidden, the 3D Annotation is also hidden. As soon as one of the linked parts is shown, the 3D Annotation is also shown.

Insert the platform.model document from the samples folder. 1. Select Insert -> 3D Annotation from the menu bar or, in the DMU Review Creation toolbar, click the 3D Annotation icon .

2. Click an object at the point you want to place the text. (Note: You can select the object first. ) The Annotation Text dialog box and the Text Properties toolbar appear.
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Inserting symbols (Windows only)
You can insert symbols in 3D annotations. Click the arrow in Insert Symbol icon to display the Insert Symbols dialog box:

Using symbols forces the font to change to SymbC and can create problems if text will be associated to the added symbol; the only font that can be used with symbol is SymbC. 3. Enter the desired text in the 3D Text field. Note: you can now change the font size and type if desired using the Text Properties toolbar.

6

Basic User Tasks

4. Use the green manipulator to position your 3D text.

7
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5. Click OK when satisfied. The text is added at the desired position. Annotations are attached to the point selected. You can move your document: annotations remain attached to the point at which you place them. For more detailed information about moving annotations, please refer to Managing 3D annotations.

8

Basic User Tasks Note: Text annotations are identified in the specification tree.

A text's drawing properties include its color. You can change the color of text that you've already added. You can add a frame, define properties for this frame ( line type and thickness), fill it with the desired color and even change the orientation of the 3D text. 6. Right-click a text you've already added and select Properties from the contextual menu, or click the text and select Edit -> Properties from the menu bar. The Properties dialog box appears. Note: Dynamic highlighting as you move your cursor over objects helps you to locate them. 7. Click the Text Properties tab. 8. Make desired changes (e.g. add a Frame). 9. Click OK when done.
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Line thickness can only be modified for font type STROKE. For all other font types, modifying the line thickness will have no effect.

To modify text, double-click it. To delete annotation text, right-click the object and then select Delete from the contextual menu.

Managing 3D Annotations

10

Basic User Tasks This task explains how to move a 3D text. Open the Annotated_Gardena.CATProduct document. 1. Double-click text.1 in the specification tree to edit the 3D annotation. The Annotation Text dialog box appears. 2. Point the cursor over the 3D text. Green manipulators appear on the text, enabling you to move it. 3. Drag the manipulators to the desired location.

3. Click OK. 4. Right-click the 3D text in the geometry area (Component to be modified for instance), select Text.2 definition->Add link. 5. Select the component to be linked to the 3D text (for instance the valve).

6. Deactivate the Update on product move option in Tools->Options-> DMU Navigator. When done, click OK. The update will be done manually.
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7. Move components using the 3D compass and mouse, e.g. NOZZLE1. Please refer to Manipulating Objects using the Mouse and Compass in the Infrastructure User's Guide.

8. Right-click the 3D text in the geometry and select Text.1 definition>Update. The 3D text is repositioned.
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Basic User Tasks To modify text, double-click it. To delete annotation text, right-click the object and select Delete from the contextual menu.

The contextual menu enables you to do the following: • • • update on product move (contextual menu -> Update item) Note: the default mode update is automatic (See Tools->Options-> DMU Navigator...) possibility to add links to point to other components (contextual menu -> Add link item) possibility to remove links (contextual menu -> Remove link item)

Hyperlinks
Creating Hyperlinks
You can add hyperlinks to your document and then use them to jump to a variety of locations, for example to a marketing presentation, a Microsoft Excel spreadsheet or an HTML page. You can add hyperlinks to models, products and parts as well as to any constituent elements. Note that in a given context, you can only have one hyperlink pointing to a given feature (model, product, part or constituent element). This functionality is not available for users of DMU Viewer. It is only available for users of DMU Navigator. Visualization Mode does not permit selection of individual model elements. To select these elements, switch to Design Mode (Edit->Representations->Design Mode).

Prepare a document that you want to see displayed via a hyperlink. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr
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collaboration REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr 1. In the menu bar, select Insert -> Hyperlink, or, in the DMU Review Creation . toolbar, click the Hyperlink icon The Manage Hyperlink dialog box appears. 2. Select the object you want to represent the hyperlink. Note: You can also select the object first and then invoke the Hyperlink command.

3. In the Name text-entry field, enter a name for your hyperlink. 4. In the URL text-entry field, enter the path to the destination file and press Enter or click the Browse... button and select the destination file in the Link to File dialog box.

You can add more than one link. Simply enter another path or click Browse... and select another file. All links created are listed in the Link to file or URL box. To follow the link to the destination file, select a link then click Go to. To remove existing links, select a link then click Remove.

14

Basic User Tasks

5. Click OK in the Manage Hyperlink dialog box when satisfied. The hyperlink is created and is identified in the specification tree.

You can edit the Hyperlink URL, simply right-click the URL item in the specification tree and select URL object -> Hyperlink from the contextual menu to edit the link. For example:

Jumping to Hyperlinks

15

collaboration This task explains how to jump to hyperlinks. This functionality is not available for users of DMU Viewer. It is only available for users of DMU Navigator. You have already added a hyperlink to your document. There are several ways to jump to hyperlinks: 1. Double click the desired hyperlink in the specification tree. or in the DMU Click the Go to Hyperlinks icon Review Navigation toolbar, then select the object with the desired hyperlink or the desired hyperlink in the specification tree. or Select the object with the desired hyperlink or the desired hyperlink in the specification tree, then click the Go to Hyperlinks icon in the DMU Review Navigation toolbar. or Right-click the hyperlink and select URL object>Definition... from the contextual menu. Note: The activated hyperlink will be the one corresponding to the active context. If the active context does not contain a hyperlink to the selected element, then nothing will happen. Note: If more than one link has been created, the Open Hyperlink dialog box appears. 2. Select the link of interest, then click OK. The linked file is displayed.

Note: As you point the cursor over a hyperlink object in the specification tree, a

16

Basic User Tasks textual representation will be displayed indicating the URL associated to the hyperlink. You can deactivate this option at any time using Tools->Options>DMU Navigator... (see Customizing DMU Navigator, DMU Navigator).

Displaying and Editing Links
Only direct links i.e. external links directly pointed to by the active document can be displayed using the Edit->Links... command. Other links, pointed to by an inactive document can be displayed by activating the inactive document. This task shows how to display links on hyperlinks, audio markers and 2D pictures using the Edit->Links... Open an annotated document including hyperlinks, audio markers and 2D pictures. 1. Select Edit -> Links from the menu bar. The Links of document dialog box appears:
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Note: markers are displayed (pictures, audio markers, hyperlinks) in the Links of document dialog box. Under the Links tab, five (or six, depending on the type of element you opened) columns are displayed to provide link-related information: • • • "From element": the pointing element "To element": the pointed element "Pointed document": the document containing the pointed element or "In Instance": the product instance in which the pointed element has been selected (this column is displayed for products only) "Link type": the type of the link, e.g. ViewLink, Import, CCP and so on "Owner": the element to which the link belongs to "Status": the status of the link. A link may be assigned one of the following statuses: o OK o Not synchronized o Reference not found o Document not found o Document not loaded o Isolated

• • •

2. Use the Link type filter and the Owner Filter drop-down lists to filter the information to be displayed respectively in the Link type and Owner columns. By default, these lists contain the value All which means that no filter is applied and thus, all links are displayed regardless of their type and owner. 3. Click one of the lines showing the features pointing to the document you opened. This activates the Open button and provides you with file-related information below the file list:
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Basic User Tasks

The file-related information in the bottom left-hand corner of the Links dialog box indicates the Pointed document, i.e. the path and name of the document pointed to in the session. You can click the Pointed documents tab to display only the documents pointed to by the current object.

4. Select one of the displayed lines to activate the Open button:

5. Click the Open button. The Links of document dialog box disappears and the selected file valve.jpg , i.e. the file pointing to Product1.CATProduct, is displayed. 6. To view the relationships between different documents and to obtain information about their properties you might find useful to select File->Desk... Hyperlinks, audio markers and 2D pictures are supported documents.
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For more detailed information please refer to Managing Documents Links in Version 5 in the Infrastructure User's Guide.

Creating Annotated Views
You can draw straight lines, freehand lines, circles, arrows and rectangles. You can create complex annotations by combining several objects as well as include text in document views. You can even insert pictures (tiff, jpg, bmp, rgb) and audio markers. This task explains how to annotate your documents. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr
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Basic User Tasks To annotate documents, you must be in an active view. Objects drawn are associated with the active view and , by default, will no longer be visible if the view is changed via rotate (translate and zoom are not considered changes to the view and therefore they do not impact the visibility of annotations). However, there is a new option that allows you to "Unlink" the annotations of an annotated view, thereby enabling you to rotate the view without losing the associated annotations: • • Select the view in the Specification Tree Right-click and select Link / Unlink in the contextual menu.

You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible if you change viewer.

1. Click the Create an Annotated View toolbar.

icon in the DMU Review Creation

The 2D view is created and identified in the specification tree. The DMU 2D Marker toolbar is activated. You can now annotate your view.
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2. Click the appropriate icon in the DMU 2D Marker toolbar to draw straight lines, freehand lines, circles, arrows or rectangles. 3. Put the cursor where you want to start the object, then click and drag to draw the object: • • • • To draw a straight line, click at the start of the line and drag from the beginning to the end of the line. To draw a circle or a rectangle, click at the start of the object and drag diagonally across the area in which you want the object to appear. To draw an arrow, click at the start of the arrow and drag from the beginning to the end of the arrow. To draw a freehand line, click at the start of the line and drag the cursor along the path of the line.

You can move and resize 2D markers easily. All you need to do is drag the green manipulators attached to the marker selected.

4. In the Specification Tree, right-click View.1 and select View.1 object -> Link / Unlink in the contextual menu. The annotations you just created will no longer be linked to the view.
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Basic User Tasks

5. Rotate the view. The annotations you created will still be visible. 6. To link the annotations once again to the view, repeat step 4.

7. Click the Text

icon to annotate your view with text.

8. In the view, click where you want to place the text. The Annotation Text dialog box and the Text Properties toolbar appear:
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You can configure your DMU Navigator so that, when creating 2D text annotations, the Part name will automatically be the default annotation. • • • In the menu bar, select Tools -> Options and then select the DMU Navigator tab. Click the 2D Marker Part Name Recognition radio button to activate the option. icon to add a text In your DMU Navigator session, click the Text annotation and click on a Part on which you wish to place the annotation (e.g. NOZZLE_1_2(NOZZLE_1_2.1).

That Part's name will automatically be the default annotation.

24

Basic User Tasks Inserting Symbols in Annotated Views (on Windows only) You can insert symbols in annotated views. Click the arrow in Text Properties dialog box and select a symbol from those proposed:

9. Enter the desired text in the 2D text box and click Apply. 10. Change the size and style of annotation text if desired and click Apply. 11. When done click OK. The text is added at the desired position. 12. To edit existing text, simply double-click. 13. To change the Text properties, right-click the 2D text in the geometry and select Properties from the contextual menu displayed. You can add more than one line of annotation text. Double-clicking the Text icon in step 7 above will cause the first annotation text that you define to be conserved by default at each successive point at which you click. You exit from the loop by clicking the Text icon with a simple-click.
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13. Make the desired changes, e.g. add a frame or change the text orientation. Line thickness can only be modified for font type STROKE. For all other font types, modifying the line thickness will have no effect.

Rotating 2D Text Annotations Define the Angle parameter to be the number of degrees you wish to rotate the text annotation by entering the value in the Angle text-entry field or by clicking the value selection buttons. 14. When satisfied, click OK. Modifying Annotation Properties
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Basic User Tasks

15. Select the Select

icon to enter the selection mode.

16. Right-click another object you've already drawn and select Properties from the contextual menu, or click the object then select Edit -> Properties from the menu bar. The Properties dialog box appears. Note: Dynamic highlighting as you move your cursor over objects helps you locate them.

17. Click the Graphic tab to display the graphic properties of the current object. 18. Make desired changes (You can change the color, line type and line weight of the selected object.) 19. Click OK when done.

Defining the 2D default markers properties in the Tools->Options->DMU Navigator sets the selected properties as default properties and changes how new annotations will look when you create them.
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collaboration Exporting and Importing 2D Annotations in an XML file 20. To export 2D annotations, in the Specification Tree, right-click View.1 and select View.1 object -> Annotated Views file export in the contextual menu. The Annotated Views file export dialog box appears.

21. Browse to the folder in which you wish to save the xml file containing the annotations. 22. In the File name text-entry field, enter the name of the file. 23. Click the Save button. 24. To import 2D annotations, in the menu bar, select Insert -> Annotated Views file import. 28

Basic User Tasks The Annotated Views file import dialog box appears.

25. Browse to the folder from which you wish to import an xml file containing annotations. 26. Select the desired file and click the Open button. The annotated view contained in the xml file will be added to the annotated views listed in the Specification Tree. Copying an Annotated View 27. To copy an annotated view, right-click the annotated view, select Copy in the contextual menu, right-click on the object in the specification tree under which you wish to copy the annotated view and select Paste in the contextual menu. Note: The copy of the annotated view will have the same name as the original annotated view. Deleting Annotations 28. To delete all annotations in the current view, select the Delete All Annotations icon .

You can also delete individual markers by right-clicking the object and then selecting Delete from the contextual menu.

Creating Texts
This task shows you how to create an annotation text.
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Three kinds of text may be created: • • • Text with Leader Text Text parallel to screen

A text is assigned an unlimited width text frame. You can set graphic properties (anchor point, text size and justification) either before or after you create the free text. See Setting Basic Graphical Properties. You can change any text to another kind at any time. Open the Annotations_Part_04.CATPart document. 1. Activate the Projected View.2 annotation plane.

2. Click the Text with Leader icon: 3. Select the face as shown to define a location for the arrow end of the leader. This scenario illustrates the creation of a text by selecting geometry, but you can also select any Part Design or Generative Shape Design feature in the specification tree. In this case, the created annotation will not be attached to the selected feature, but to its geometrical elements at the highest level.
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If the active view is not valid, a message appears informing you that you cannot use the active view. This means that the annotation will be displayed in an annotation plane normal to the selected face. For more information, see View/Annotation Planes. The Text Editor dialog box appears.

4. Enter your text, for example "New Annotation" in the dialog box.

5. Click OK to end the text creation. You can click anywhere in the geometry area too.
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The text appears in the geometry. The text (identified as Text.xxx) is added to the specification tree. The leader is associated with the element you selected. If you move either the text or the element, the leader stretches to maintain its association with the element. Moreover, if you change the element associated with the leader, application keeps the associativity between the element and the leader. Note that using the Text Properties toolbar, you can define the anchor point, text size and justification. 6. Click the Text icon: 7. Select the face as shown.
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8. Enter your text, for example "New Annotation 2" in the dialog box and click OK. The text appears in the geometry. The text (identified as Text.xxx) is added to the specification tree.

9. Click the Text Parallel to Screen icon: 10. Select the face as shown.
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11. Enter your text, for example "New Annotation 3" in the dialog box and click OK. The text appears in the geometry.

See also Setting Annotation Parallel to Screen. The texts (identified as Text.xxx and its text between brackets) are added to the specification tree in the Notes group.
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You can move a text using either the drag capability. See Moving Annotations. Note also that you can resize the manipulators. For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.

Managing Annotated Views
This task explains how to retrieve your 2D views using the Manage Annotated Views icon. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr Create at least two views. These 2D views are identified in the specification tree.
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1. Click the Manage Annotated Views icon . The Annotated Views dialog box is displayed.

2. Double-click View.1 in the dialog box to recover your view.

36
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3. Now double-click View.2.

4. Click Cancel to exit the Annotated Views dialog box or OK to enter the view selected. You can edit the annotated view.

Adding Pictures

37

collaboration This task explains how to add a Picture as 2D marker in your annotated view. You can now insert resizable pictures from the following format list: • • • • tiff jpg bmp rgb

Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr To annotate documents, you must be in an active view. Objects drawn are associated with the active view and will no longer be visible if the view is changed. You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible if you change viewer.

1. Click the Create an Annotated View from the DMU Review Creation Toolbar. The 2D view is created and identified in the specification tree.

The DMU 2D Marker toolbar is activated. You can now annotate your view.

38
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2. Click the Insert a Picture Marker icon

in the DMU 2D Marker toolbar.

3. Put the cursor on the valve and click. The Select Picture File dialog box appears: 4. Select the valve.jpg document from the images folder.

The picture is inserted at the anchorage point selected in the annotated view.

39

collaboration You can easily resize your inserted picture. All you need to do is drag the squared manipulators in the picture corners.

An object's drawing properties include color, line type and weight. You can change drawing properties of objects that you've already drawn.

Adding Audio Markers
This task explains how to insert audio markers in an annotated document using the 2D Marker toolbar You need a microphone connected to your computer. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr To annotate documents, you must be in an active view. Objects drawn are associated with the active view and will no longer be visible if the view is
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Basic User Tasks changed. You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible if you change viewer. 1. Click the Create an Annotated View from the DMU Review Creation toolbar. The 2D view is created and identified in the specification tree.

The DMU 2D Marker toolbar is activated. You can now annotate your view.

2. Click the Create an Audio marker icon toolbar. The Select audio file dialog is displayed. 3. Select the location.

in the DMU 2D Marker

4. Give a meaningful name to the to-be recorded file and click Open. The Audio attributes dialog box and Audio Recorder dialog boxes appear:
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5. Select the audio quality and click OK, e.g. select 22050Hz, 16-bit, Mono 6. Start recording using the red button from the Audio Recorder dialog box. 7. When done, click OK. The sound is identified in the specification tree. 8. Double-click sound in the specification tree to play your audio recording (using the play button) or to edit it.

Editing Annotated Views Properties
This task explains how to edit annotated views properties. This new capability eases collaborative work as you can now add information such as user name, creation or modification dates.
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Basic User Tasks Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr Create an Annotated View (see Creating Annotated Views).

1. Right click the view you need to edit in the specification tree. 2. Select the Properties item from the contextual menu displayed. The Properties dialog appears.

43

collaboration

3. Enter the required information (creator name, comments, etc.). 4. Click OK to confirm. The next views you create will be assigned the creator name you've just defined.

Using Temporary Markers
You can visualize the names of objects as well as coordinates of points defined on objects in your document as you move your cursor over objects. Clicking turns the temporary marker into a 3D annotation.
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Basic User Tasks Using graphic messages you can apply a particular name, reference or description to a product (Definition, Nomenclature, Source, Instance Name, Description). For this: • • • Select command Tools -> Options -> Infrastructure -> Node Customization Check Customized Display Then select different options : Part number (#PN#), Revision (#RE#), Definition, Nomenclature, Source, Instance Name, Description

You can directly replace the diagram (PN, RE,...) between the two # by the term of your choice and it will appear in the specification tree and in graphic messages.

Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr 1. To activate the viewing of object names, in the menu bar, select Analyze -> Graphic Messages -> Name. 2. Move your cursor over objects in your document.
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collaboration The name of the object is displayed.

3. To de-activate the viewing of object names, re-select Analyze -> Graphic Messages -> Name. 4. To activate the viewing of point coordinates, in the menu bar, select Analyze -> Graphic Messages -> Coordinate. 5. Move your cursor over objects in your document. The coordinates of the point under the cursor are displayed. Dynamic highlighting helps you identify points of interest.

6. To de-activate the viewing of point coordinates, re-select Analyze -> Graphic Messages -> Coordinate. There is now a mechanism that enables you to transform temporary markers into persistent 3D annotations. You must do the following: 1. Activate the mechanism in the DMU Navigator Settings (see DMU Navigator). 2. Activate the viewing of object names and / or the viewing of point coordinates as above. 3. Move the cursor over objects in the geometry area and when the temporary marker that you wish to display appears, then click.
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4. In the DMU Review Creation toolbar, click the 3D Annotation icon The temporary marker will be transformed into a persistent 3D annotation at the designated point.

.

Note that if the mechanism is activated in the DMU Navigator Settings but neither viewing of object names nor viewing of point coordinates are activated in your DMU session, then when you click on the 3D Annotation icon, the insertion of a 3D annotation will be proposed as would be the case if the mechanism had not been activated in the DMU Navigator Settings.

Creating Flag Notes

You can add hyperlinks to your document and then use them to jump to a variety of locations, for example to a marketing presentation, a Microsoft Excel spreadsheet or a HTML page on the intranet. You can add hyperlinks to models, products and parts as well as to any constituent elements. This task shows you how to add hyperlinks. Open the WeldPlanner.CATProduct document (or GreenPartCATPart document) and prepare a document that you want to see displayed via a hyperlink. 1. 2. Click the Flag Note with Leader icon .

Select the object you want to represent the hyperlink. For the purposes of our example, select the face as shown:
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The Manage Hyperlink dialog box appears.

3. 4.

Enter a name for your hyperlink. For example, "marketing presentation". Enter the path to the destination file in the URL field then press Enter. Or, Click Browse... and select the destination file in the Link to File dialog box. Note: You can add more than one link. Simply enter another path or click Browse... and select another file. All links created are listed in the Link to file or URL box. • • Select a link then click Go to to follow the link to the destination file. Select a link then click Remove to remove existing links.

5.

Click OK in the Manage Hyperlink dialog box when satisfied. The hyperlink is created and is identified as Flag Note.xxx (name of the

48

Basic User Tasks

document) in the specification tree.

6.

If you wish to edit the display of the note, use the Properties contextual command.

Annotating Generated Sections
You can use generic measure tools, keeping measures as annotations, as well as 2D and 3D annotation tools to annotate generated sections in the Section viewer.

Create the desired section plane and corresponding section. To... Measure distances at item level Select... Measure Between You can measure minimum distances between edge
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collaboration primitives or between sections of elements (solid of a model, body of a CATPart). You can also measure distances between points representing the intersection of the plane with any wireframe elements present and other sectioned items, however, you cannot make measures with respect to grid elements. Note: The Measure Between result is different depending on whether or not the section view is a filled view. If the section view is filled, the result obtained is the minimum distance between sections of selected elements. If the section view is unfilled, the result obtained is the minimum distance between edge primitives. For more information, see Measuring distances and angles between geometrical elements, and Measuring minimum distance in the Section viewer. Measure properties Measure Item You can measure properties on generated sections. For more information, see Measuring properties. Measure distances at product level Distance and Band Analysis in DMU Space Analysis

You can measure minimum distance between the sections of selected products (model, CATPart, etc.). For more information, see Measuring minimum distances and distances along X, Y, Z, and Measuring minimum distance in the Section viewer. Add 3D text 3D Annotation in DMU Space Analysis

For more information on 3D annotation, see the DMU Navigator User's Guide. Create and annote 2D views Creating Annotated Views in DMU Space Analysis

The Creating Annotated Views command lets you create and annotate a 2D view of your section using the arrows, lines, text, etc. provided in the DMU 2D Marker toolbar. 2D views are identified in the specification tree and can be recovered using the Managing Annotated Views icon.

For more information on 2D annotation, see the DMU Navigator User's Guide. 50
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Managing View/Annotation Plane Associativity
This task shows you how to manage view/annotation plane associativity, by changing the definition plane of a view. When views are associative to the geometry, any modification applied to the geometry or to the axis system is reflected in the view definition. Open the Common_Tolerancing_Annotations_02 CATPart document. 1. Right-click the SectionView.1 annotation plane, and select the Manage associativity contextual command. The Manage View Associativity dialog box is displayed, indicating that the view is currently associative to User Surface.1.

2. You have two possibilities: o If you want to disassociate the view from the geometry, uncheck the Set
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view associative to geometry field. In this case, you will then be able to modify the geometry or the axis system without changing the view definition. o If you want to associate the view to another geometry, select a planar face or an axis system.

For the purpose of this scenario, select the face as shown below to associate the view to another geometry.

The Manage View Associativity dialog box is updated, indicating that the view will now be associative to User Surface.2.

3. Click OK. The Section View.1 annotation plane is now associative to the specified surface. If you move the view definition plane or modify the axis system, the view will be re-defined accordingly.
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Limitation
When extracted to 2D (using the View from 3D command in the Generative Drafting workbench), views from 3D are currently not associative to the geometry of the 3D view. So, if you modify the geometry of a 3D view, the definition of the corresponding 2D view will not be modified at the next update, even if the 3D view is associative to the geometry. This limitation should be fixed in an upcoming release.

Printing
Printing Images from the Album
This task explains how to print images. 1. Select the Tools->Image->Album... command to display the album contents:
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2. Select the image(s) to be printed. 3. Right-click then select the Print command to display the Print dialog box. Depending on the image format you select, the Print command may be grayed out. This is the case when right-clicking a MPEG or AVI file, for instance. Note that you can now print images in SVG format. For a description of this format, refer to Previewing Images in the Album.
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Images are printed the same way as any other document. Refer to Printing Documents for a full description of how to print.

Previewing Documents Prior to Printing
This task explains how to preview documents prior to printing. Open the document Print.CATProduct 1. Select the File->Print... command (or the CTRL+P keyboard shortcut) to display the Print dialog box:
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2. Select the Preview... option to display the Print Preview window:
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You can also use the Fit All In icon window, or select the Quick Print icon

and zooming commands inside the Print Preview from the Standard toolbar to print.

You can also preview the document size in real size by zooming. To zoom, press and hold down the middle mouse button in the Print Preview window, then click the left mouse button and drag (still holding the middle mouse button down). Zoom up or down to increase or decrease the document size; the percentage of the real size is displayed top right as you zoom. For example, if you want to display the document at its real size, zoom to reach 100%. The Preview window is also available to preview images: • • via the Print icon in the Tools->Image->Capture... command via the Preview icon in the Tools->Image->Album... command.

Customizing Print Settings Before Printing Your Documents
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This task explains how to print documents. You can only print a document if a default printer has been set up. On Windows, you print using the default printer declared by your Windows system administrator. However, on UNIX, you can only print a document if a default printer has been set up using the File -> Printer Setup... command, as explained in Setting Up Your Printers on UNIX and Windows. Open the document Print.CATProduct. 1. Select the File->Print... command (or the CTRL+P keyboard shortcut) to display the Print dialog box. The type of printer you choose determines the default settings in the dialog box:

The Print window is also available via the Print icon in the Tools->Image->Capture... command and the Tools->Image->Album... command.
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The area to the right is a preview area displaying a shaded rectangle representing the size of the image to be printed, using the default paper format with the default margins. The image size matches the real size of the geometry area in your document window, with respect to the selected paper format. Any changes you make to page orientation, page setup (paper format, paper margins), image scale and position are instantaneously displayed in this area. Resizing the document window resizes the image accordingly. You can also resize the image by dragging the image handles (using the left mouse button). The proportional relationship between image width and height is always maintained. Note that these handles are not available if you check the Fit in Page option (the default setting). 2. Select a printer, or check the Print to file check box and enter the name of a file. Refer to Printing To a File for more information. Note: when selecting a printer on Windows, you can use the printers provided by Dassault Syst mes, these printers being managed with dedicated plot configuration files. Dassault Syst mes Printer Manager is part of the Version 5 Windows environment, combined with the native Microsoft printer manager. To choose a printer, you can also click the Printer Name: button to search for a printer using a filter:

The list of printers that have been defined is displayed under "Printer List". By default, all the printers are highlighted. In the Filters area, enter the string to be searched for and select the driver on which you want to perform the search. You can also indicate a printer type by activating the corresponding radio button. When finished, press ENTER to run the search: the list of printers is updated and displays only the printer(s) corresponding to your search criteria. If you are not satisfied with your search, you can click the Reset button to go back to the default options. 59

collaboration When satisfied, click OK to validate and close the Printer Selection dialog box. The pulldown list of printers will be filtered according to your search criteria:

3. You can use the combo box displayed next to the Printer Name field to filter the list of printers according to groups that have been previously defined in the Printers tab. To do so, just select a group in the combo box. The printer list to the right is automatically updated and displays only the printers included in the selected group:

Note: "General" is the default value and displays all the printers set up by your administrator. 4. In case you wish to set up your printer, click the Properties... button to open the printer properties dialog box. The look of the dialog box will change according to the driver. Just modify the desired parameters then click OK to validate. In case the driver is provided by Dassault Syst mes, clicking the Properties... button will display the Printer Properties dialog box described in Adding a Printer. 5. Set the page orientation. The current page setup (page format and page size) set using the Page setup... option is displayed as a reminder. Orientation settings are: Portrait: sets portrait orientation

Landscape: sets landscape orientation

60

Basic User Tasks

Best orientation: if you resize the image beyond the page margins (displayed in red in the image to the right), Best orientation keeps the image to be printed at its original size, but automatically changes the page orientation (as displayed in the preview area on the right of the dialog box) to fit the image into the page.

6. Set the image position and size of the image to be printed. This involves changing the position of the image on the selected paper format, and scaling the image. To do so, you need to uncheck the Fit in Page option first (if it is checked) to access the position and size options. To scale the image, enter the scale percentage or use the scale spin box. Whichever method you use, the scale field and the image width and height are updated:
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You can also use the Fit in Page option which centers the image and scales it up to the largest size so that it fits into the margins. Clicking the Fit in Page option deactivates the other options in the Position and Size area, and the image resize handles are no longer available.

The No Fitting option leaves the document to be printed to its original size, i.e. a scale 1:1. The Fit to option lets you set the Scale of the image. You can specify the distance from the Left and Bottom margins as well as the image dimensions in the Width and Height fields (changing Width automatically updates Height, and inversely, in order to keep ratio constant). Note: any modification to the Scale, Width or Height automatically impacts simultaneously these three parameters.
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To position the image, you can: • • • • click the Center option (to center the image) click the Origin option (to position the image bottom left, at the origin) drag the image to the new position or enter the position of the bottom and left corner of the image, with respect to the paper margins.

7. Click the Page Setup... button to display the Page setup dialog box, and click OK when you have finished.

You can: • choose a standard paper format • reset paper margins • or reset printer defaults. Note: the "Use Image Format" option is relevant for CATDrawing documents only. Refer to Printing Multi-Documents for detailed information on this option. To set the paper format, select the format from the Name list. If you set a new format, the image of the paper format and the image to be printed are resized accordingly. If the format selected is incompatible with the printer currently selected, a message will inform you that the format should not exceed the dimension for the printer. However, this does not prevent you from setting the paper format.
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In our example, the first image uses the A4 ISO format, and the second the A3 ISO format:

The new paper format and corresponding page size are displayed in the Position and Size option box. To set the paper margins, enter values for the Left, Right, Top and Bottom margins, The example shows how the new margins (represented by dashed lines) affect the position of the image:

8. Select the image orientation: • Best Rotation: used in conjunction with the Fit in Page option, scales the image up to the largest size which still fits into the current paper format • Rotation: 90 • Rotation: 180 • Rotation: 270 .

9. Select the Print Area: • Whole Document: print the entire image • Display: print the image as seen on screen
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• Selection: prints the area selected using the button. For more information, refer to Capturing Selected Areas of Images part in this guide. • Document Area: this option is relevant for .CATDrawing documents only. Refer to Printing Multi-Documents. 10. Click the Options... button to access the Options dialog box and set the Color options determining the type of color output.

• Set the color type for the image to be printed: o Full color: true color image o Grayscale: grayscale image (produces a smaller print file) o Monochrome. The gamma factor (between 0.1 and 5.0). A gamma factor of 0.1 produces a dark image, whereas a factor of 5.0 produces a lighter image. • Activate the "Print White Vectors as Black" option if you want to print white vectors as black on the resulting printout. By default, this option is activated. • Activate the "Print Text Blanking" option if you want to print the text blanking (i.e. the white frame onto which the text is displayed). 11. Click the Banner tab and set the banner options: • if you want to show a banner on the printed output, use the banner field to print information about the current print job in the banner ; this field contains the $USER, $DATE and $TIME variables which, by default, print your username, and the current date and time in the banner at the bottom of the printed output. This field is editable: you can delete the variables if required and replace them with a text of your choice • Position: setting the position to None removes the banner ; you can also position it Top Horizontal, Bottom Horizontal, Left Vertical or Right Vertical • Insert logo: activate this option if you want to insert a graphic logo in the banner, and select the button to navigate in your file system and select the
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The banner option is also available when using the Generative Drafting application. 12. Click the Various tab and set the various options.
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Set the Rendering Mode to be used for printing: • Default: means that the output will be printed according to the rendering style defined in the Custom View Modes dialog box. However, bear in mind that if the defined style is not supported, some discrepancies may occur between the version on screen and the printed version • Wireframe: corresponds to the Wireframe rendering style • Hidden Line Removal: corresponds to the Hidden Line Removal (HLR) style you apply by selecting the Tools...->Customize... command then the Commands tab and the All Commands category. • Shading with Triangles: corresponds to the Triangles rendering style • Dynamic Hidden Line: corresponds to the Dynamic hidden line removal rendering style. Set the Rendering Quality factor which determines the quality of printed output: • • • • Low (screen): the quality of the printed output matches the screen resolution Medium High Custom: selecting this factor lets you define precisely the print quality by indicating the desired dpi value. The maximum value you can enter is 680 dpi for A4 format and 170 dpi for A0 format.

The higher the setting, the longer the print time, the larger the print file, the higher the image quality. This option does not impact print previewing. Note: You can also choose to scale or not the text to be printed by activating or deactivating the Text Scaling option. By default, this option is activated. Set the Line Width Specification: • Absolute: original linetype specifications are preserved • Scaled: the print image scale is applied to linetypes • No thickness. and Line Type Specification: Absolute or Scaled. Set the Line Cap option to choose how line ends are drawn (useful for drafting): • Flat • Square • Round. This option does not impact print previewing. You can check the Line Type Overlapping option in order to get a correct plotting when lines overlap.
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Line Type Overlapping is activated

Line Type Overlapping is deactivated

13. Check the Tiling option if you want to tile the image and print it on several pages. Once the Tiling option is checked, you can define more precisely the tiling options for your image by clicking the Define... button to open the following window.
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• Tile Count lets you specify the number of tiles to be used to cut the image horizontally or vertically (enter the desired number in the corresponding field) • Center tiles allows you to center the tile on the paper • Paper overlap enables you to define the horizontal and vertical paper overlap using the spin boxes • Position tiles lets you indicate the position of the tile on the paper by entering its coordinates in the "x" and "y" fields. You can also specify the tile size by entering its dimensions in millimeters in the "width" and "height" fields • The Tile Outline Printout checkbox enables you, when activated, to print the outline of each tile.

is activated, you can click any tile in the preview When the Selection Mode window to display the corresponding part of the document:

Note that you can use the Fit All In icon

and zooming commands inside the

preview window. The Remove Tile Mode icon lets you select the tile(s) to be removed from the printout. The selected tile(s) are then identified in the preview window by a red cross as shown below:
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Activating the Remove Tile Mode grays all the fields displayed to the left. When the tiles have been removed, click the Selection Mode icon go on defining your tiling options. to activate the fields and

14. Select OK successively in each dialog box to confirm all your print settings then in the Print Dialog box click: • Apply to print the document without closing the Print dialog box. • OK to print the document and close the Print dialog box. Each time you print a document, a log output file is generated. The traces contained in the file give you information on the printing date and time, the user name, the log file name, the printer name along with the print mode (i.e. to a file or a device). By default, this file is named Print.log and is located in a temporary directory: On Windows C: Data Documents and Settings DassaultSystemes user CATTemp Local Settings Application

On UNIX Print.log is also located in the CATTemp directory, in your home directory. However, the default location and name may be modified by your administrator using the CATPRINTLOG external variable. For instance, setting
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CATPRINTLOG='c:

test

MyPrint.log'

means that the log file named "MyPrint.log" will be located in the directory "test"... ...whereas CATPRINTLOG=NONE means that the log file will keep its default name and location. Here is a log output sample: <Start Print User: AJT Date: 04/14/2004 Time: 16:31:17 Host: MYMACHINE Printer: Document: C: Result: 1 End Print> Printer1 Manipulators3.CATPart

Printing To a File
This task explains how to print to a file. Open the document Print.CATProduct. 1. Select the File->Print... command (or the CTRL+P keyboard shortcut) to display the Print d The type of printer you choose determines the default settings in the dialog box.
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You can also print to a file via the Print icon in the Tools->Image->Capture... command and the >Album... command. 2. Select a printer name. 3. Check the Print to File check box: Note: when selecting a printer on Windows, you can use the printers provided by Dassault Syst
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4. Enter a file name, or click the File Name... button to display the Print to File dialog box:
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5. Type the name of the file in which you will store the image printout, then click the Save but and return to the Print dialog box.

The file is saved with the .prn extension (the only extension available). The information in the fil the printer you chose in the Print dialog box. Note that the More... button is relevant only when printing multiple pages. Refer to Printing Mult for detailed information.

6. When printing to a 3 PLM Printer (refer to Adding a Printer for detailed information), you ca Properties... button to access the printer properties:

7. In the Submission Scripts group box, activate the "Custom" radio button next to "Declaratio default output file name: each time you print a document, an output file is created at the lo the text field.

8. Click the Edit Script... button which is now activated. This button lets you access the Runtim below:
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9. You can use the following environment variable contained in the default script to create you

• CATOUT=C: DOCUME~1 ajt LOCALS~1 Temp catout_%CATPRT_DOC_SH indicates the location, name and number of the document to be printed where: o "C: DOCUME~1 ajt LOCALS~1 Temp

" is the location of the docum

o "catout_%CATPRT_DOC_SHEET_NUM%.out" indicates the name (stored in "catout.o number (stored in "%CATPRT_DOC_SHEET_NUM%.out") of the document. For instance, when using a PostScript printer, you can use this variable the followi set CATOUT=e: "e: temp". Temp test_ %CATPRT_DOC_SHEET_NUM%.ps

to specify that the name of the document to be printed is "test.ps" and is located i

10. Click OK to validate your modification in the script window then OK again to close the Printe box. 11. Click the Apply or OK button to save the file.
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12. To print the file, access the folder in which the file has been saved and use the copy comma copy myfile.prn LPT1 where "LPT1" is the local print port, or if the printer is on a network: copy myfile.prn servername printername

where servername is the name of the print server, and printername is the name of the printer. On UNIX, use the operating system command appropriate for your platform.

Texts created with a bold Stroke font are printed with a 0.7 mm thickness and therefore, they may if their size is small. This behavior is applicable for the Print to File option as well as for any other p Quick Print, printing without activating the Print to File option, etc.).

Printing in Batch Mode
This task describes how to use the Print Batch utility in order to print documents without running Version 5. These documents may be Version 5 files (such as .CATProduct, .CATParts documents, etc.), raster files (bmp, tiff, etc.), vector files (CGM, HPGL, HPGL2) and Version 4 models. This scenario explains how to: • • • • access the batch interface define your batch parameters run the batch directly from the command line run the batch directly from the Batch Monitor.

Provided that you have a graphic board (on Windows) or an X server (on UNIX), the rendering style (i.e. "Shading", "Shading with Edges", etc.) can be taken into account when printing in batch mode. To do so, you need to set the following variable as shown below: set PRINT_BATCH_WITH_GRAPHIC_CARD=1 (on Windows) or export PRINT_BATCH_WITH_GRAPHIC_CARD=1 (on UNIX).

Accessing the Batch Interface
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Method 1: Accessing the batch interface from the command line
1. Open an MS-DOS Window. 2. Access the following folder: C: Program Files (on Windows) or /usr/DassaultSystemes/B15/OS_a/code/command/ (on UNIX) 3. Enter the command: CATUTIL -Name PrintBatch (on Windows) or ./catstart -run "CATUTIL -Name PrintBatch" (on UNIX) The Print Batch window opens. Dassault Systemes B15 intel_a code command

Method 2: Accessing the batch interface from the Batch Monitor
You can also access the print batch interface using the Batch Monitor in a Version 5 session. In that case, some additional options are available to you.
Remote mode

You can choose whether you want to run the batch locally or on a remote computer by activating the corresponding radio button: • • Run Local: default option. When checked, the batch will be run in local on your local computer Run Remote: check this option then indicate the name of the remote computer on which the batch will be run. The remote computer will use the printers set up on your local computer. Note that: o o when using Windows printers, you can run the batch in remote mode on Windows computers only when using 3DPLM printers, you can run the batch in remote mode either on UNIX or on Windows computers.

For detailed information on running batches in remote mode, refer to Running Batches Using the Batch Monitor in this guide.
Licensing

You also have the ability to select a license using the Licensing Setup... button.
Getting Help

The batch-specific online documentation can be accessed directly from the Print Batch interface by clicking the icon in the top right corner (on Windows) or the Help button (on UNIX).
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In this scenario, we assume that the batch interface has been accessed using Method 1 detailed above. The batch interface looks as follows (click the thumbnail below to see the full-size picture):

Defining the Batch Parameters
1. Select a printer using the pulldown list displayed next to the Printer Name button. This list lets you filter the list of printers displayed to the right. You can choose either: • General: default mode. All the printers you have set up will be displayed in the printer list to the right • a printer group you defined in the Printers tab. In that case, only the printers included in the selected group will be displayed in the printer list. You can also check the "Print to file" check box and enter the name of a file. Refer to Printing To a File for more information. 2. In case you wish to set up your printer, click the Properties... button to open the printer properties dialog box. The look of the dialog box will change according to the driver. Just modify the desired parameters then click OK to validate. In case the driver is provided by Dassault Syst mes, clicking the Properties... button will display the Printer Properties dialog box described in Adding a Printer. 3. Click the icon then navigate to the file(s) you want to print then click Open to validate.

The File Selection box lets you access your CATDrawing documents more easily. To do so, select CATIADrawing in the "Files of type" field so that only CATDrawing documents are displayed. Note that if you set the DLName environment as "Current" in the Tools->Options->General->Document tab, the usual File Selection dialog box will be replaced by the following one dedicated to the DLName environment:
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The DLName document environment lets you restrict the access to specific folders referenced by logical names referred to as "DLNames" (each folder is assigned a logical name). In this mode, the different file opening and saving commands only allow end users to access documents in directories referenced by DLNames. The File Selection dialog box displayed above lets you navigate to the DLName in which the parameter file to be used is stored. You can also search for DLNames using a specific interface by clicking the icon. For detailed information on how to use this dialog box, refer to the Document task. Click OK when finished selecting your documents. The selected file names are displayed along with their path, parameters and printer:

79

collaboration

When at least one file is selected in the list, some icons are activated to let you modify the printing order: • • • moves a file up in the list moves a file down in the list deletes a file from the list.

4. Click the Default Printing Parameters button to define the parameters used by default for all printed documents in the Printing Parameters dialog box.

The Layout tab lets you define the page orientation, the image size and position, etc. and is identical to the Print dialog box accessed via the File->Print... command. 5. Click the Page Setup... button to open the Page Setup dialog box. Refer to Customizing Print Settings for detailed information. 6. Click the Options... button to access the Options dialog box. Refer to Customizing Print Settings for detailed information. The Printing Parameters dialog box also enables you to define the visualization mode used for printing by selecting the desired mode from a pulldown list in the Visualization tab:
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If you are printing CATDrawing documents, you can access the MultiDocuments tab:

• In the Range area, indicate whether you want to print All Sheets or only the Active Sheet • You may check the Clip to Sheet Format option if you want the drawing representation to be clipped to the sheet format • You may also check the Print Detail Sheet option if you intend to print sheets of type Detail. 7. In case you want to use parameters which are different from the default ones for a specific file, select the file from the list then click the Parameters... contextual command to open the Parameters dialog box:
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This dialog box enables you to apply parameters other than the default one proposed by selecting another printer, another orientation and so on. The Printing Parameters button gives you access to the above-detailed Printing Parameters dialog box except for the Visualization and MultiDocuments tabs which gives you access to more parameters: In the Visualization tab, you can click the Layer Filter... button: this opens the Visualization Filters dialog box which lets you edit or create visualization filters:

The default current filter "All visible" is applied automatically: it lets you see all the contents of the document. This filter cannot be deleted. Refer to Using Visualization Filters for detailed information.
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When printing CATDrawing documents, you can print a given number/range of sheets by checking the "Sheet Numbers" radio button then: • enter the corresponding sheet numbers in the field below • click the Sheets... button to open the Image Selection dialog box which lets you select the sheet(s) you wish to print. You can now use the MultiDocuments tab to print the drafting of Version 4 models. To do so, activate the "Sheet Numbers" option then enter the number(s) of the workspace(s) to be printed in the field below. You can also click the Sheets... button then select the desired workspace(s) in the Image Selection dialog box:

By default, all the documents are selected but you can deselect the documents you do not want to print by clicking them in the list. The Reset button lets you re-select all the elements displayed, if needed. Click OK to validate your selection and close the window. Once the parameters have been modified, the status of the customized file changes from "Default" to "Customized" in the Parameter column and the printer name (if different from default printer) is displayed in the Printer column.
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Note: if needed, you can reset the customized parameters to the default parameters by right-clicking the desired file from the list then selecting the Reset Parameters contextual command. In that case, the status of the file will change from "Customized" to "Default". 8. If you want the corresponding CATScript file to be saved in a specific location, click the CATScript Generation... button. A CATScript window displaying the content of the CATScript file: click the Save As... button then indicate the name and location of the file before clicking Save to validate. By default, the CATScript file is saved in a temporary folder. Running a batch printing using the PrintBatch command will automatically generate a file named "PrintBatchParameters.xml" and saved in a temporary folder by default. If you want to save this file under another name and in another location, just click the Print Batch Parameters Saving... button. The generated XML file can be edited manually. Refer to Editing the XML file for detailed information. You can preview the file(s) to be printed simply by selecting a file from the list then clicking the Preview contextual command. However, note that you will not be able to use zooming commands for CATDrawing, CATProduct and CATPart documents. 9. Click the RUN button to print the selected documents then the CANCEL button to close the Batch Printing window.

Editing the XML File
You can also define your print parameters directly in the "PrintBatchParameters.xml" file using your favorite text editor. Click the thumbnail below to see an example of XML file:

Should you need to modify the name of the printer to be used, this can be done very easily in the XML file by indicating the new printer name in the <PRINT_OUTPUT_PRINTER> parameter:

If you are printing CATDrawing documents, you can edit the sheet name and number in <PRINT_VISU_IMAGE_NAME> and <PRINT_VISU_IMAGE_NUM> respectively:
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Running the batch directly from the command line via the Batch Monitor

The XML file detailed above can be used later on to run the batch printing without having to access the Print Batch dialog box. To do so: 1. Access the default folder: C: Program Files Windows) or /usr/DassaultSystemes/B15/OS_a/code/command/ (on UNIX) 2. Run the following command: CATUTIL -Name PrintBatch e: or ./catstart -run "CATUTIL -Name PrintBatch /u/usr/parameters.xml" (on UNIX) where e: users or /u/usr/ is the path of the file PrintBatchParameters.xml. users parameters.xml (on Windows) Dassault Systemes B15 OS_a code bin (on

Note: bear in mind that you can only print a document on UNIX if at least one printer has been set up using the File -> Printer Setup... command.

Running the batch directly from the Batch Monitor
If you already have an XML file containing all the necessary inputs, there is no need for you to define the batch parameters and you can run the batch directly. To do so: 1. Access the Batch Monitor by selecting the Tools->Utility... command in your Version 5 session. Note that you can also access the Batch Monitor from the command line.
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2. In the Utilities tab, click "PrintBatch" then select the File->Associate a parameter file command (or right-click the batch name then select the Associate a parameter file contextual command). Note that if you set the DLName environment as "Current" in the Tools->Options->General->Document tab, the usual File Selection dialog box will be replaced by the following one dedicated to the DLName environment:

The File Selection dialog box displayed above lets you navigate to the DLName in which the parameter
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Basic User Tasks file to be used is stored. For detailed information on how to use this dialog box, refer to the Document task. 3. Navigate to the directory in which you saved the XML file then click Open to validate. 4. Access the Start tab which now displays the name and location of the XML file you associated to the batch. Note that you can associate several parameter files in order to create a list of batches that you can run later on when needed:

5. Still in the Start tab, right-click the file associated to the batch you want to run then select the Run contextual command. Note that if you run the Print Batch via the Batch Monitor, the generated report will be look slightly different. This report can be accessed by double-clicking the desired line under the Processes tab. Then, click Close to close the window and go back to the Batch Monitor. Running your batch via the Batch Monitor will also generate a file in a temporary folder. This file will be named "PrintBatchParameters" suffixed by the hour at which the batch was run (for instance, "PrintBatchParameters_14.41.25.xml" to indicate that the batch was run at 14.21.25 PM). To save this file under another name and in another location, just click the SAVE button. The generated XML file can be edited manually. Refer to Editing the XML file for detailed information.

Using the Camera
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Using Camera Capabilities
About Cameras: Gives background information on cameras. Creating and Displaying a Camera: Adjust view parameters (zoom, rotation, etc.) of the document and click the Create Camera icon then OK in the Edit Camera dialog box. Editing Camera Properties: right-click the camera to be edited. Perform changes, when satisfied, click Apply and OK. Moving a Camera: Select a camera, attach the 3D compass to the 3D camera representation, then drag parts (axis, arc, etc.) of the compass to move the camera to a new position. Selecting Standard Views: Select View ->Named Views... then double-click the desired view. Creating, Modifying and Deleting User-defined Views: Customize the selected standard view then click Add. Use other options in the Named Views dialog box to manage views.

About Cameras
Cameras let you take still shots of views or viewpoints in your document. A series of views showing different viewpoints in succession can be combined to create an animation. Cameras are identified by name in the specification tree and by a symbol in the

geometry area

.

A 3D representation helps you locate the viewpoint of interest by showing what the camera sees through a viewport:
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Cameras are moved using the 3D compass or directly using the green manipulators. You can use cameras in two different modes: perspective or parallel, to obtain either a conical or a cylindrical projection. See Editing Camera Properties.

Perspective mode

Parallel mode

Creating and Displaying Camera
This task shows how to create and display cameras. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr
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1. Adjust the view parameters (zoom, rotation, etc.) of the document to define the desired camera location. 2. Select the View -> Named View command from the menu bar. The Named Views dialog box displayed.

3. Click the Add button. A camera appears in the view list.

4. Click OK to create the camera. A camera is created at the current viewpoint. 5. Double-click Camera 1 in the specification tree.
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6. Zoom out and rotate the model to see the 3D representation.

7. Click anywhere in the geometry area to de-select the camera and see the
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camera symbol. You can create several cameras at different locations. The DMU Navigator offers you the possibility of visualizing the viewpoint of each camera in different windows. 8. Select Window -> Camera Window from the menu bar. All cameras created are listed. 9. Select the cameras of interest from the list. A new window showing the camera viewpoint is opened for each camera selected. 10. To organize the opened windows horizontally, select Window -> Tile Horizontally from the menu bar.

11. To organize the opened windows vertically, select Window -> Tile Vertically from the menu bar.
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12. To organize the opened windows so that they overlap one another, select Window -> Cascade from the menu bar.
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Editing Camera Properties
This task shows how to display and edit camera properties. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr You have created a camera.
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1. Right-click the camera in the specification tree and select the Properties item form the cont also select the camera and use the Edit->Properties command.) The Properties dialog box is displayed.

The Lens tab is active by default and enables you to edit the following: • Type (Perspective or Parallel, i.e. to obtain a conical or a cylindrical projection) Perspective

Paralle
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•

Focal length (click and drag or use the spin box)
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For more detailed information, please refer to Moving Cameras. The Feature Properties tab provides general information on the currently selected camera, e.g. its 2. Click the Position tab to define the target and origin positions. You can define the Origin and the Target position in millimeters along the X, Y and Z axes.

3. Select values for the Origin and Target distances. 4. When satisfied, click Apply.
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It is now possible to have an active camera automatically updated from the current view, exactly a Update from View each time you change the view using any combination of translates, rotations an considered "active" when it is selected or edited in a track.)

5. Click the Update camera from View radio button to have your camera automatically update

6. Click OK to confirm.

Moving a Camera
This task shows how to move the camera you have just created to the desired position. You can move cameras in four different ways: • • • • using using using using the the the the Pan, rotate, zoom commands directly in the camera window 3D compass Edit-> Properties... on Cameras Update camera from view option

For more information on the 3D compass, see the Infrastructure User's Guide. You defined a Camera.

Pan, rotate, zoom commands
1. Select Window -> Camera Window and select the camera from the list to open a separate window showing the camera viewpoint. 2. Select Window -> Tile Vertically to organize opened windows vertically.
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3. Pan, rotate and/or zoom the camera in the camera window until satisfied with the camera position. The camera position in the document window is updated.

3D Compass
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1. Select the camera to be moved in the specification tree. The 3D representation is shown in the geometry area. Note: To move the camera, you will attach the 3D compass to the 3D camera representation. If you cannot see the 3D representation, click the camera in the specification tree and select Camera object -> Hide / Show Representation from the contextual menu.

2. To attach the 3D compass to the 3D camera representation, press and hold down the left mouse button on the red square of the 3D compass, then drag the 3D compass to attach it to the camera representation. Notice that the compass changes appearance as you drag it.

Pointing to a line coming from the eye automatically snaps the compass to the eye and pointing to one of the sides of the viewport snaps the compass to the target. You can attach the 3D compass to two different positions of the camera representation as shown below: the eye and the target.
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3. Select Window -> Camera Window and select the camera from the list to open a separate window showing the camera viewpoint. 4. Select Window -> Tile Vertically to organize opened windows vertically.
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5. Click one of the translation axes of the 3D compass and drag to translate to the desired position. As you move the camera in the document window, the camera viewpoint in the camera window is updated.

6. Click one of the rotation axes of the 3D compass and drag to rotate to the desired position. 7. Continue experimenting until satisfied with the camera position. The camera viewpoint is automatically stored.
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Edit-> Properties... on Cameras
1. Right-click the Camera in the specification tree. 2. Select the Properties item from the contextual menu displayed. The Properties dialog box is displayed. The Lens tab is active.

103

collaboration .

3. If you zoom, pan, rotate the camera within the Preview window, the camera position is updated accordingly in the geometry area.
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4. Continue experimenting until satisfied with the camera position. 5. Click Apply and click OK. This is the new camera position you obtain :

Update camera from view option

1. Right-click the Camera in the specification tree. 2. Select the Properties item from the contextual menu displayed. The Properties dialog box is displayed.
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3. Select the Position tab.
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4. Click the Update camera from view radio button and click the OK button in the Properties dialog box to confirm. 5. Pan, rotate and zoom in the main window to define the view that the camera will represent. The camera is automatically updated from the view.

Selecting Standard Views
This task explains how to use standard views. Insert the platform.model document from the samples folder.
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1. Select the View->Named Views... command. The Named Views dialog box appears.

The list provides a number of standard views you can use to display the document: • • • • • • • *front *back *left *right *top *bottom *iso

2. Double-click the desired view. For example, double-clicking *front obtains the front view:

The other views are:
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Creating, Modifying and Deleting User-defined Views
This task explains how to create, modify and delete user-defined views. Note that user-defined views are stored with the document. Insert the platform.model document from the samples folder. 1. Select the View->Named Views... command and double-click the desired view.

2. Adjust the different view parameters (zoom, rotation, etc.) as desired.
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3. Click the Add button to add the view to the list. The default name of the view is Camera 1.

4. Rename the view as required and press Enter.
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You now see a 3D viewpoint representation in the geometry area. The 3D representation is a viewport that helps you to define what you want to see in the view. What you see inside the viewport can then be stored in your view.

Use the two spheres and the two squares displayed in green on the 3D representation to interactively manipulate and position the camera:
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• • • •

the source point (1) rotates the camera around its target point the target point (2) rotates the camera around its source point the source green square translates and rotates the camera around its target point the target green square translates and rotates the camera around its source point

5. Manipulate the 3D representation to define your view parameters. 6. In the Named Views dialog box, click the Properties button to access the Camera Properties dialog box.

7. Double-click anywhere on the 3D representation to apply the view parameters, and click Apply to perform the changes to your view. 8. If you want to modify any customized view you have already saved, select it, modify the view parameters again, then click the Modify button. You can delete views by selecting the view from the list and clicking the Delete button. You can view the object from the reverse angle by clicking the Reverse button.
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Publishing
Publishing Parameters
This scenario explains how to publish parameters. The scenario described below is divided into the following steps: • Add parameters to the Screw.2 document and publish its Diameter, Depth, and Volume parameters. Repeat the same operations with the second CATPart file. Create a CATProduct file and import Screw.2. In the context of the Bolt product, insert the Nut part that imports the Depth and the Diameter parameters by selecting the publication MyDepth and MyDiameter of Screw.2. In the context of the bolt, replace Screw.2 (KwrScrew.CATPart) by Screw.2 (KwrScrew2.CATPart) that doesn't have the same structure as the first one but owns the same publications. Both the parameters and the check are recomputed.

• •

•

A publication has a name and references a geometry or parameters inside the product (or one of its subproducts). The publication of parameters should be used when: • Defining an import of parameters between two parts (similar to the import of geometry). Defining relations at the assembly level between parameters (similar to constraints).

•

Before you start, make sure that the Keep link with selected object check box is checked (Tools->Options->Infrastructure->Part Infrastructure->General). 1. Open the KwrScrew.CATPart document. The following image is displayed.
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2. Add parameters to the part. icon. The Formula Editor opens. In the New parameter of type scrolling Click the list, select Volume and click the New parameter of type button. In the Edit name or value of the current parameter field, enter the name of the parameter: MyVolume. Click Apply and click the Add Formula button. The Formula Editor opens. Enter the following formula by using the Dictionary: smartVolume(PartBody Click OK, and Yes. o Pad.1 ) + smartVolume(PartBody Pad.2 ) .

o

o

o

In the New parameter of type scrolling list, select Length and click the New parameter of type button. In the Edit name or value of the current parameter field, enter the name of the parameter: MyDepth. Click Apply and click the Add Formula button. Enter the following formula: MyDepth=PartBody Pad.2 FirstLimit Length and click OK.

o

o

o

In the New parameter of type scrolling list, select Length and click the New parameter of type button. In the Edit name or value of the current parameter field, enter the name of the parameter: MyDiameter. Click Apply and click the Add Formula button. Enter the following formula:

o

o
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MyDiameter=PartBody twice.

Sketch.2

Radius.2

Radius * 2. Click OK

3. Publish the MyVolume, MyDepth, and MyDiameter parameters. To do so, select the Tools>Publication command and select the MyVolume, MyDepth, and MyDiameter parameters in the specifications tree. Click OK. The published parameters appear in the specifications tree below the Publication node. Close the file.

4. Open the KwrScrew2.CATPart and repeat the steps listed above (steps 1 to 3 included). The part should be identical to the one below. Close the file.
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5. Create a CATProduct file. Select the Insert->Existing Component... command and click the root of the specifications tree. The File selection box is displayed. Select the KwrScrew.CATPart file and click Open. The screw is imported. 6. Select the Insert->Existing Component... command, select the Kwrnut.CATPart file and click Open. The nut part is inserted.

7. Double-click the inner circle of the nut, the Hole Definition window is displayed. o Right-click the Diameter field and select the Edit formula... command. The Formula Editor opens. Select MyDiameter in the screw publications. The formula should be as follows: PartBody Hole.1 Diameter=`External Parameters

o

MyDiameter`. Click O
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o

Right-click the Depth field and select the Edit formula... command. The Formula Editor opens. Select MyDepth in the screw publications. The formula should be as follows: PartBody Parameters Hole.1 HoleLimit.1 Depth=`External

o

MyDepth`. Click OK twice.

8. Double-click, then right-click the Screw.2 component in the specifications tree and select the Components->Replace Component... command. The File Selection window opens. Select the KwrScrew2.CATPart file and click Open. 9. Click Yes when prompted to replace all instances with the same reference as the selected product. Update the nut part: the parameters are recomputed.
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Publishing Snapshots
You can publish snapshots to share the content of your viewer with the other people currently connected to the Community. 1. Click the Snapshot icon . A snapshot of your viewer content is sent to the person or group currently selected in your Community dialog box. An entry in your Document Sharing dialog box on the Export page will indicate the jpg document corresponding to the snapshot with status Dispatched.

The receiver will receive the document in the Document Sharing dialog box on the Import page with status Proposed.

2. To accept a proposed document, click the Accept button. The status of the document will change to Transferred.
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3. To open the transferred document, click the Open button. The jpg document corresponding to the snapshot will be opened in your viewer. 4. To refuse a proposed document, in the Document Sharing dialog box, click the Refuse button.

Publishing Viewpoints
You can publish viewpoints to share them with other users. 1. Click the 3D Conferencing icon . The 3D Conferencing dialog box appears. 2. Click the Publish viewpoint radio button.
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You are now a publisher of viewpoints. The other users that now choose you as the publisher whom they will follow will be able to see the viewpoint that you've published. Any modifications you make to your viewpoint will be immediately visible on the screens of those followers. 3. If you wish to remove the 3D Conferencing dialog box but to continue publishing your viewpoint, click the Keep viewpoint sharing active checkbox to activate the option and then click the Close button. 4. When you wish to stop publishing your viewpoint, deactivate the Keep viewpoint sharing active option and then click the Close button. Note: If you closed the dialog box while continuing to publish your viewpoint as in step 3 above, then of course you will have to re-invoke the viewpoint sharing function in order to deactivate the Keep viewpoint sharing active option and stop publishing your viewpoint.
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Conferencing
Initiating and Leading a Conference
Initializing a Conference on Windows using the Backbone Driver
This scenario describes how to initialize a conference on Windows using the Backbone driver. Conferencing enables people who are geographically separated to dialog and work together as if they were virtually in the same room. Audio, video or chat tools enable the conference members to dialog while whiteboard or any other application sharing capabilities enable them to share documents or even applications. Usually, one member has a leading role, he is named the host or the master member. The conferencing functionality is available on both the Windows and UNIX platforms.

Backbone is a Dassault Systèmes component which enables the creation of information channels between various applications running on various machines. Backbone must be implemented on each computer that will be used by eventual conference members and on a reference server.

Applications do not communicate directly but through local servers (CATSysDemon servers), which communicate among themselves via a Domain Manager (which is itself CATSysDemon server) As Backbone Manager, you must define the Domain that will enable the CATSysDemon servers to communicate with one another.

1. Select a machine which will be the Domain Manager (Backbone Manager), e.g. node1. 2. Create a file containing the list of machines that will be allowed to connect to the Domain, e.g. domain.lst containing the following lines: node2 node3 node4 node5 3. Launch the CATSysDemon command with the above list of machines as parameter:
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CATSysDemon -dm domain.lst 4. Export the Domain Manager host name: set CATBBDomainManager=node1 5. All members of a conference must select the same conference driver, i.e. all members must select Backbone. To select the conference driver: • • • • • In the menu bar, select Tools->Options. Click the General category in the left-hand tree. Click the General tab. In the Conferencing area, check the Backbone option. Click OK to confirm.

CATSysDemon server options

The -opendm option can also be added to enable ANY other machine to be connected. Ex: CATSysDemon -opendm -dm domain.lst You can use -dmhost <hostname> option instead, if the CATBBDomainManager environment variable is not set. Ex: CATSysDemon -dmhost nodehost The "-h" option gives you a list of the available options. For instance: -DebugL<n>, with n=1,2,3,4,10 provides information to follow communications between CATSysDemon servers. (Use it only if you encounter difficulties.) -timeout <time in seconds> enables to leave the server running more than the default 300s when no client application is connected. Ex: CATSysDemon -DebugL4 -timeout 3000

Initializing a Conference on Windows using the NetMeeting Driver
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Advanced User Tasks This scenario describes how to initialize a conference on Windows using NetMeeting as conference driver. Conferencing enables people who are geographically separated to dialog and work together as if they were virtually in the same room. Audio, video or chat tools enable the conference members to dialog while whiteboard or any other application sharing capabilities enable them to share documents or even applications. Usually, one member has a leading role, he is named the host or the master member. The conferencing functionality is available on both the Windows and UNIX platforms.

1. All members of a conference must select the same conference driver, i.e. all members must select NetMeeting. To select the conference driver: • • • • • In the menu bar, select Tools->Options. Click the General category in the left-hand tree. Click the General tab. In the Conferencing area, check the NetMeeting option. Click OK to confirm.

2. To host a conference, in the menu bar, select the Tools->Conferencing>Host. 3. To join a conference as a guest, in the menu bar, select the Tools>Conferencing->Guest. The NetMeeting and Conferencing dialog boxes appear.

If the NetMeeting interface is already on the desktop, you can use it to host a conference by selecting the Call/Host Meeting menu item, and then connect to that conference by selecting Tools->Conferencing->Host from the menu bar. Likewise, guests already in a NetMeeting conference can connect to that conference by selecting the Tools->Conferencing->Guest from the menu bar.

Launching a Conference as Host
123

collaboration The person who launches a conference is considered to be the conference host. The host, and only the host, can do the following: • • • • invite other participants to the conference start the visual conference suspend the visual conference grant requests by other participants to speak

You must have a DMU Navigator session running. You must have properly initialized the conferencing infrastructure. See: • • • Initializing a Conference on UNIX using the Backbone Driver Initializing a Conference on Windows using the Backbone Driver Initializing a Conference on Windows using the NetMeeting Driver

Each participant of the conference must have access privileges to all data that he will visualize and he must load the data manually. Information about which documents are open in the Host session is provided to all participants on the Document page. The actions replicated during a conference are the following: • • • • • • • • workbench transition object selection viewpoint modification (zoom, rotation) 3D annotations (creation, modification and deletion) 2D annotations (linked to cameras) creation, modification and deletion move products (free hand or simulation context) show/hide specification tree status (if you expand a node as the host it is replicated in the guest session)

It is now possible to use the F3 key to toggle the visibility of the specification tree. the coherence of which is maintained for all member sessions of the conference.

1. To host a conference, in the menu bar, select the Tools->Conferencing->Host.
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The Conferencing dialog box appears.

If you are using NetMeeting as driver, the NetMeeting dialog box will also appear. If the NetMeeting interface is already on the desktop, you can use it to host a conference by selecting the Call/Host Meeting menu item, and then connecting to that conference by selecting Tools->Conferencing->Host from the menu bar. Likewise, guests already in a NetMeeting conference can connect to that conference by selecting the Tools->Conferencing->Guest from the menu bar.

As much as NetMeeting functionality would enable you to perform some of the conferencing actions, they will not be described in this documentation. Note, however, that even if you manage the conference completely from the Conferencing dialog box, you must leave the NetMeeting dialog box opened as it is serving as the conference driver.
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2. The host member then invites the other participants. In the Conferencing dialog box: • enter the name or the IP address of the participant's machine • click the Call button An information box appears indicating that you are waiting for a response to your call.

When your invitation has been accepted by a given guest, that guest's identification will appear in the Other participants area of the Setup page.
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3. At any moment, click the Who I am button to edit your personal identification information. The Business card dialog box is displayed.

Starting the Visual Conference

4. Click the Start the Visual Conference button to start the visual conference. The conference status changes to In Progress. (The Start the Visual Conference button changes automatically to Suspend the Visual Conference.)
Suspending the Visual Conference

5. Click the Suspend the Visual Conference button to suspend the visual conference. The conference status changes to Suspended. (The Suspend the Visual Conference button changes automatically to Start the Visual Conference.)

Leading the Visual Conference
During the visual conference, only the participant who is the designated speaker can speak. (The Host is the designated speaker by default.) Actions or commands performed by the speaker in his /her DMU session are replicated in the DMU sessions of the other participants. The other participants cannot perform actions or commands in their DMU sessions while someone else is speaker (unless that particular participant has switched from Listen mode to Work mode); they can, however, continue to perform actions in the
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Suspending the Visual Conference

The host member can suspend the visual conference at any time. All he needs to do is click the Suspend the Visual Conference button. Performing this action allows everybody to work on their own. Only the host can suspend and start the visual conference.
Conference mode

• •

Directed: the host manages the requests to speak Free: any participant can speak at any moment

Participant mode

• • •

•

Record on / Record off: participants can record events in order to visualize all of the events that transpired while they were in a break Update: recorded events are replayed one by one Listen and Work: participants can either listen to the speaker or choose to momentarily disengage from the visual conference in order perform work not related to the conference Speak: to request to speak, a participant clicks the Speak radio button (if the Conference mode is Free, then there is of course no need to request to speak)

Managing Who Speaks in a Directed Visual Conference

In a directed conference, the Host manages all speaking requests.

1. A participant clicks the Speak radio button. The image of a person with raised hand appears, indicating the participant's request to speak. The requesting participant must now wait until the Host grants the request.
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2. The Host double-clicks the name of the participant requesting to speak.

3. As soon as the request is granted, the requesting participant's Speak
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When the speaker is performing actions in the interactive session, his / her name now appears under the arrow.

Joining a Conference as Guest
You can join a conference as a guest after having received a call from the Host inviting you to the conference. You must have a DMU Navigator session running. You must have properly initialized the conferencing infrastructure. See: • • • Initializing a Conference on UNIX using the Backbone Driver Initializing a Conference on Windows using the Backbone Driver Initializing a Conference on Windows using the NetMeeting Driver

Each participant of the conference must have access privileges to all data that he will visualize and he must load the data manually. Information about which documents are open in the Host session is provided to all participants on the Document page. The actions replicated during a conference are the following: • • • • • • • • workbench transition object selection viewpoint modification (zoom, rotation) 3D annotations (creation, modification and deletion) 2D annotations (linked to cameras) creation, modification and deletion move products (free hand or simulation context) show/hide specification tree status (if you expand a node as the host it is replicated in the guest session)

It is now possible to use the F3 key to toggle the visibility of the specification tree. the coherence of which is maintained for all member sessions of the conference. 1. To join the conference as a guest, in the menu bar, select the Tools>Conferencing->Guest. The Conferencing dialog box appears. You must now wait until you receive a call from the Host inviting you to
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If you are using NetMeeting as driver, the NetMeeting dialog box will also appear. If the NetMeeting interface is already on the desktop, you can use it to host a conference by selecting the Call/Host Meeting menu item, and then connecting DMU to that conference by selecting Tools->Conferencing->Host from the menu bar in the DMU window. Likewise, guests already in a NetMeeting conference can connect DMU to that conference by selecting the Tools->Conferencing->Guest from the menu bar in the DMU window. As much as NetMeeting functionality would enable you to perform some of the conferencing actions, they will not be described in this documentation. Note, however, that even if you manage the conference completely from the Conferencing dialog box, you must leave the NetMeeting dialog box opened as it is serving as the conference driver.

2. You must now wait until you receive a call from the Host inviting you to join the conference. 3. When you receive the invitation, click Accept in the Incoming Call dialog box.
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You are now a participant of the conference. As soon as the conference is active (i.e. at least 2 members connected), the Visual Control page is displayed. The conference is on hold. Everyone can go on working, opening documents, annotating documents, etc. 4. At any moment, you can click the Who I am button to edit your personal identification information. The Business card dialog box is displayed.

Sharing Documents with other Conference Members
The Document page enables you to manage data sharing. It indicates the documents which are opened in the host member session. Access permissions: Each conference member wants to share some of his components with some of the other members, but perhaps not with all of them. For this reason, he must be able to define access permissions (visible or invisible) per component and per conference member. In practice, the shared document (often called the "Root product") belongs to the Host member, who calls the Guest members and chooses "who sees what". Guest members will receive only those files they are allowed to see. Component insertion: Afterwards, each member can add his own components in the shared document, having previously determined the permissions of other participants.

Host -> Guest
• • The host decides to hide, show or share his/her opened documents Guests receive information about the host protected or public documents
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Guest -> Host
• • • Every member decides to hide, show or share his/her opened documents The host receives information about Guests' protected (shown) or public (shared) documents The host can download shared documents form the guests' sessions

Sharing Documents
At the bottom of the Document page, the upper line is meant to read as a sentence indicating your intention with regards to document sharing, e.g. "Set selected components visible for Jean Dupont".

1. Click Set selected components combo-selection button and select the desired mode from the proposed list. 2. Click the for combo-selection button and select the intended recipient of the share action from the proposed list. 3. Click the Share button. The selected documents will now change to status Visible for the indicated recipients.
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.

Loading Shared Documents
At the bottom of the Document page, the lower line is meant to read as a sentence indicating your intention with regards to document loading, e.g. "Set selected components to load".

1. Click Set selected components combo-selection button and select the desired mode from the proposed list. 2. Click the Load button. The selected documents change to status Loaded and are inserted into the participant's DMU session.
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Document visibility modes
• • Invisible: the local documents are in a hidden state for the other participants Visible: the documents can be downloaded by the other participants. If download is requested (Load selected components), both the document and its representation are downloaded.

Transferring Files
Files can be transferred between users during the conference. This enables you to perform conferencing on VPM data, as one member of a conference can transfer the necessary PSN file that will enable another member of the conference to visualize the same ENOVIAVPM data. Note: Both users must have access to a VPM database.
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In the Send area of the File Transfer page, the Sender: 1. Clicks on the To selection button and chooses the intended recipient from the proposed list of conference members. 2. Enters the file name in the File text-entry field or clicks the Browse button to select the file by browsing his directories. 3. Presses the Send button to send the file to the intended recipients.

In the Receive area of the File Transfer page, each Recipient: 4. In order to specify the location at which he wishes to place the sent file, he enters the directory name in the Directory: text-entry field or clicks the Browse button to select the directory by browsing his directories. 5. Presses the Accept button to accept the file at the specified location.
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Sending Messages to other Conference Participants
You can send messages to the other conference participants. 1. In the Conferencing dialog box, click the the Chat tab. The Chat page is displayed.
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2. To send a message: • type the message in the Message text-entry field • click the To selection button and select the desired recipient of your message from the proposed list

Consulting Conference History
The History page provides a list of certain actions performed throughout the conference.
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1. In the Conferencing dialog box, click the the History tab. The History page is displayed.

Leaving a Conference
Any participant (host and guests) can leave the conference at any time. If the host leaves the conference, the conference is terminated for everyone. 1. To leave a conference, in the menu bar, select Tools -> Conferencing -> Stop. The Conferencing dialog box is closed, you have left the conference.

Instant Collaboration
About Instant Collaboration
Instant Collaboration Overview Instant Collaboration enables instant collaboration between all participants across the extended enterprise to promote the sharing of data and ideas that can result in a faster time to market and an increase in overall product innovation. • • Instant collaboration from within DS products Collaboration between communities
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Accessing Instant Collaboration
Once you've accessed Instant Collaboration, the Instant Collaboration toolbar will appear in your session. This toolbar will also give you access to the Collaboration toolbar. 1. In the menu bar, select Views -> Toolbars -> Instant Collaboration. The Instant Collaboration toolbar, which consists of the Instant Collaboration icon, appears.

2. To visualize the Collaboration Toolbar, click the selection arrow. 3. To detach the Collaboration Toolbar, click the selection arrow, then click the toolbar handle and drag. The functionalities available via the Collaboration toolbar are as follows: Icon Functionality Community Instant Messaging Snapshot Sharing Document Sharing Viewpoint Sharing Collaboration Settings Search for People Note that all of the above functionality can be accessed from the Community dialog box via contextual menus.
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Creating a Business Card
Your business card serves to identify you to the other people connecting to the Community. You create your business card via the customization options. See Customizing VPM Instant Collaboration, Customizing Identification Settings.

Connecting to the Community
The Community dialog box is your Instant Collaboration central workplace. From there you will be able to access all functionality via contextual menus as well see the different people and groups currently connected to the community. 1. In the Instant Collaboration or the Collaboration toolbar, click the . Community icon The Community dialog box appears. By default, you will be connected to the Default group.

Searching for People in the Community
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collaboration You can perform a search to see who is currently connected to the Community. The search only takes into account those persons who are connected to the community. 1. Click the Search for People icon or, in the Community dialog box, right-click and select Search for People in the contextual menu. The Search for People dialog box appears.

2. In the Query text-entry field, enter a search string (the wildcard is '*'). 3. Click the Search button to launch the search.

To display all information concerning the other people that are connected to the community, check the Display all information checkbox before launching the search. You can only communicate with people that are in your group. In the Community db, you only see the content of your current group. You don't see the content of any of the other groups. (This is logical, since you can only communicate with people in your group.) Before examining group content, it is recommended to do a Refresh of your Community db by right-clicking the Community root and selecting Refresh from the contextual menu (since when a person changes group, his / her Community db is automatically refreshed, but the other people who are impacted by the change will not have their Community dbs automatically refreshed).

Groups
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Creating a Group
Groups enable people to work together. At any time, you can create new groups at any time. When you create a group, you automatically join that group. 1. In the Community dialog box, right-click the Community and select New group in the contextual menu. The New group dialog box appears.

2. In the Name text entry field, enter the group name. 3. Click the OK button.

The new group is added in the Community dialog box. You are automatically added to the new group.
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Joining a Group
At any time, you can join any of the available groups. 1. To join a group, in the Community dialog box, right-click the group you wish to join and select Join this Group from the contextual menu.
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2. To accept an invitation by another user to join his group, enter your response to the invitation in the Response text-entry field and press the Accept button.

The person inviting you to join his group will receive your response. You will now be in that person's group. 3. To refuse the invitation, enter response in the Response text-entry field and press the Refuse button. The person inviting you to join his group will receive your response. You will still be in the same group as before. 4. To ignore the invitation, press the Close button. The dialog box will be closed. If you want to join the group to which a particular person belongs, you can use Search for People to find that person's group. See Searching for People in the Community.

Inviting other People to Join a Group
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You can invite other people to join your group. 1. Perform a Search for People. 2. Select the person or persons you wish to invite to join your group, rightclick and select Invite in current group from the contextual menu.

The Invite others to current group dialog box appears. 3. In the Topic text-entry field, enter the topic or message of your invitation and press the Send button.

The invitation is sent to the designated person or people. Those people will now respond to your invitation. You will receive their responses in the Invitation response dialog box.
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Viewpoints
Receiving Viewpoints
You can follow the viewpoint of a chosen publisher in order to receive that person's viewpoint. 1. Click the 3D Conferencing icon . The 3D Conferencing dialog box appears. 2. Click the Follow the viewpoint of radio button.

147

collaboration You are now a follower of viewpoints. You will now be able to follow the viewpoint of the chosen viewpoint publisher. Any modifications that person makes to his viewpoint will be immediately visible on your screen. 3. If you wish to remove the 3D Conferencing dialog box but to continue following the viewpoint, click the Keep viewpoint sharing active checkbox to activate the option and then click the Close button. 4. When you wish to stop following the viewpoint, deactivate the Keep viewpoint sharing active option and then click the Close button. Note: If you closed the dialog box while continuing to follow the viewpoint as in step 3 above, then of course you will have to re-invoke the viewpoint sharing function in order to deactivate the Keep viewpoint sharing active option and stop following.

Publishing Viewpoints
You can publish viewpoints to share them with other users. 1. Click the 3D Conferencing icon . The 3D Conferencing dialog box appears. 2. Click the Publish viewpoint radio button.
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Advanced User Tasks You are now a publisher of viewpoints. The other users that now choose you as the publisher whom they will follow will be able to see the viewpoint that you've published. Any modifications you make to your viewpoint will be immediately visible on the screens of those followers. 3. If you wish to remove the 3D Conferencing dialog box but to continue publishing your viewpoint, click the Keep viewpoint sharing active checkbox to activate the option and then click the Close button. 4. When you wish to stop publishing your viewpoint, deactivate the Keep viewpoint sharing active option and then click the Close button. Note: If you closed the dialog box while continuing to publish your viewpoint as in step 3 above, then of course you will have to re-invoke the viewpoint sharing function in order to deactivate the Keep viewpoint sharing active option and stop publishing your viewpoint.

Document Sharing
Sharing Documents
You can share documents with other users. 1. Click the Sharing documents icon or, in the Community dialog box, rightclick and select Sharing documents in the contextual menu. The Shared documents dialog box appears. 2. Click the Export tab.

3. To add a document to export, click the Add button. The File selection dialog box appears. 4. Navigate to the file you wish to export and click OK. The selected file is added to the list of files to export.
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5. In the Community dialog box, select the person to whom you wish to send the document. If you wish to send the document to the entire group, then select the group. 6. In the Shared Documents dialog box, click the Send button. The document will now be proposed to the designated person or people. In your Shared Documents dialog box, the status of the sent document will now have status Dispatched.

Receiving Documents
You load any documents you've received via the Document Sharing dialog box.

1. Click the Document sharing icon or in the Community dialog box, rightclick The Document sharing dialog box appears. 2. Click the Import tab. A document dispatched by another user will appear with status Proposed.
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3. To accept a proposed document, click the Accept button. The status of the document will change to Transferred.

4. To open the transferred document, click the Open button. The jpg document corresponding to the snapshot will be opened in your viewer. 5. To refuse a proposed document, in the Document Sharing dialog box, click the Refuse button.

Publishing Snapshots
You can publish snapshots to share the content of your viewer with the other people currently connected to the Community. 1. Click the Snapshot icon . A snapshot of your viewer content is sent to the person or group currently selected in your Community dialog box. An entry in your Document Sharing dialog box on the Export page will indicate the jpg document corresponding to the snapshot with status Dispatched.

The receiver will receive the document in the Document Sharing dialog box on the Import page with status Proposed.
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2. To accept a proposed document, click the Accept button. The status of the document will change to Transferred.

3. To open the transferred document, click the Open button. The jpg document corresponding to the snapshot will be opened in your viewer. 4. To refuse a proposed document, in the Document Sharing dialog box, click the Refuse button.

Managing Applicative Data
Managing Applicative Data

Importing Applicative Data from an Inserted Component Importing Applicative Data from a Document in Session Reordering Applicative Data

Importing Applicative Data from an Inserted Component
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This task shows you how to insert applicative data from an inserted document. This functionality is not available for DMU Viewer. You can now choose to always create imported applicative data in a DMU Review at highest level. See Customizing DMU Navigator, DMU Navigator. When you insert a CATProduct, you can now recuperate its associated applicative data (see DMU Navigator for options to manage the insertion of applicative data). One of the three results will occur when you insert a CATProduct containing applicative data: • • • if the option to import applicative data was not chosen in the DMU Navigator Settings, then no applicative data will be inserted when you click OK to insert your document in step 5 above. if the option to import applicative data was chosen and the option to automatically insert all applicative data was chosen, then all applicative data will be inserted. if the option to import applicative data was chosen and the option to present a user prompt was chosen, then a dialog box like the following will appear:
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1. To de-select any of the applicative data subsets or items, click the appropriate checkbox. 2. Click OK to confirm. The applicative data will be inserted in the form of a Review (to manage a Review, see DMU Review). Importing applicative data at a later moment 3. Click the Cancel button in the Import applicative data dialog box. The CATProduct will be inserted, but no applicative data will be imported. 4. At a later moment, select Edit -> Import applicative data. The Import applicative data dialog box appears. You de-select the applicative data as above. 5. Click OK to confirm. The selected applicative data will be inserted in the form of a Review. For each CATProduct inserted containing applicative data, a review will be created to embed the newly inserted applicative data: • • If the inserted CATProduct contains reviews, they will be copied and linked under R1. If there is an active review when inserting the CATProduct, R1 will be created under that review. If not, R1 will be created at the review root level.
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•

The life cycle of copied applicative data is linked to the review.

The importing of applicative data is one-shot only. The imported applicative data is a simple copy of the applicative data of the inserted component. Any subsequent modifications to the applicative data of the original document will not be reflected in the applicative data imported during the insert component command.

Imported applicative data can be re-ordered. See Reordering Applicative Data. For a list of the types of applicative data that can be inserted, see About DMU Review, Applicative data that can be created in a DMU Review.

Importing Applicative Data from a Document in Session

This task shows you how to insert applicative data from a document in session. This functionality is not available for DMU Viewer. You can now choose to always create imported applicative data in a DMU Review at highest level. See Customizing DMU Navigator, DMU Navigator. 1. In the Insert menu bar, select Import Application Data. The Document selection dialog box appears.

2. Click the selection button and select the document from which you wish to import applicative data from the proposed list. The Import applicative data dialog box appears, proposing the different applicative data that can be imported.
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3. To de-select any of the applicative data subsets or items, click the appropriate checkbox. 4. Click OK to confirm. The Mapping table dialog box is displayed. All the target links that have been automatically found are displayed.
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5. You can fill in missing links or modify links by selecting the requested line and then clicking on the desired component, in the 3D or Specification Tree. Note that all applicative data selected in step 7 will be imported, even if there are missing links to the target product (i.e. you left some links unselected in the mapping table). The applicative data will be inserted in the form of a Review (to manage a Review, see DMU Review). The log file is optionally activated by clicking the Log file checkbox. You can specify the path by clicking the "..." icon and navigating to the desired directory.

Reordering Applicative Data

Reordering applicative data enables you to manually reorder applicative data entities under their respective application node in the specification tree. Applicative data reordering is applicable to the following types of applicative data: • • • • Annotated Views Hyperlinks Cameras Groups 157
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You can now select a multiple number of entities to be displaced, thus enabling you to reorder your applicative data more efficiently. Note that all multiselected entities must be contiguous. Scripts for applicative data reordering can be written using VBScript. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr 1. Create four Annotated Views (see Creating Annotated Views). 2. Expand the Applications node in the specification tree. The four annotated views are represented as follows:

3. Either select the Annotated Views category in the specification tree or any one of the annotated views (e.g. View.1) and click the Applicative Entities Reordering icon or and click the Applicative Entities Reordering icon select the Annotated Views category in the specification tree or any one of the annotated views. The Graph Tree Reordering dialog box appears.
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4. To move the View.1 entity down in the list, press the down arrow The View.1 entity is swapped with the entity that was below it, View.2 .

.

5. To move the View.4 entity up in the list, select the View.4 entity and press the up arrow .

The View.4 entity is swapped with the entity that was above it, View.3 .
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6. To move the View.3 entity to an arbitrary place in the list, select the and click on the entity under View.3 entity, press the displace arrow which the View.3 entity will now appear (e.g. View.2). The View.3 entity is placed under the View.2 entity and all the entities that will be below it are moved down one position.

7. To save the modifications you have made to the ordering of the entities, click the Apply button. 8. To change the applicative data category, click the selection button and choose the desired category from the list.
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Note that you must have saved any modifications made to the ordering as in step 7 before you change categories, otherwise you will lose your modifications. 9. To exit the dialog box without saving the modifications you have made to the ordering of the entities, click the Cancel button. 10. To save the modifications you have made to the ordering of the entities and exit the dialog box, click the OK button. Reordering DMU Reviews and their applicative data 1. Given the following configuration of DMU Reviews, double-click the DMU Review.1.1 review to activate it.

2. Click the Applicative Entities Reordering icon . The Applicative Entities Reordering dialog box appears.
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3. To reorder applicative data entities, click the selection button and choose Reviews from the proposed list. 4. You can now reorder sub-reviews of DMU Review.1.1 as in steps 4 through 7 above. 5. To reorder applicative data entities, click the selection button and choose Entities from the proposed list.
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You can now reorder entities of DMU Review.1.1 as in steps 4 through 7 above. You can only reorder one level of reviews and applicative data at a time based upon the activated review. You cannot reorder the reviews at the Product level. For a list of applicative data that can be imported, see the list of applicative data that can be inserted in a DMU Review in About DMU Review.
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Overview
Welcome to the Data Exchange Interfaces User's Guide! This guide is intended for users who need to become quickly familiar with the product. This overview provides the following information: • • • • • Data Exchange Interface in a Nutshell Before Reading this Guide Getting the Most Out of this Guide Accessing Sample Documents Conventions Used in this Guide

Data Exchange Interfaces in a Nutshell
V5 is an open system, capable of interoperating with data in all of the mostly used data format standards in the CAD/CAM/CAE Industry. For Importing and Exporting external files there are miscellaneous formats : STEP, IGES, DXF/DWG, CGM, STL, VRML, and STRIM/STYLER. These formats are used to transfer geometric data (surfaces and wireframe) between different CAD-CAM systems in following situations : • • • concurrent engineering with using several CAD-CAM systems migration of databases when changing system (example: for new V5 customers) exchanges of geometric data with clients or suppliers

Data Exchange Interfaces are : • STEP AP203 / AP214 format (Standard for the Exchange of Product model data) : the V5 - STEP AP203 Interface and theV5 - STEP AP214 Interface : allow to interactively read and write data in STEP AP203 / AP214 data formats. Its supports geometry and assembly structures and handles topology (shells, solids) on export and import. For instance, you can read a STEP file, edit its content in V5 workbenches, and save the results directly as a STEP file. IGES format is supported by the V5 - IGES Interface (IG1) product. V5 IGES Interface (IG1) helps users working in a heterogeneous CAD/CAM environment to exchange data through a neutral format. The Initial Graphic Exchange Specification (IGES) format, is the most used neutral format to transfer data between heterogeneous CAD systems. Users can perform bidirectional data exchange between dissimilar systems with direct and automated access to IGES files. IGES files containing 3D geometry are imported into CATPart documents.

•
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collaboration Their type should be "igs". IGES files containing 2D geometry and annotations are imported as CATDrawing documents. Their type should be "ig2". DXF/DWG : DXF formats are supported by the V5 - Generative Drafting Products. After creating drawings, the designers can export data in DXF/DWG formatted files and import the 2D geometric data contained in a DXF/DWG file into a CATDrawing document. CGM format is supported by the V5 - Object Manager Products. STL format is supported by the V5 - Object Manager Products. STL concerns stereolithography document (.stl). STRIM/STYLER : V5 - STRIM/STYLER To CATIA Interface 2 (STC) allows to process in CATIA V5 the Geometry from Strim and Styler Applications. It provides a unique direct Interface from Strim and Styler to CATIA, which operates on Strim and Styler Native Format Files in V5 Environment. The product features a direct access to Styler or Strim data files to convert and store them into V5 format. The product enables to retrieve an existing Styler or Strim design into V5, and proceed to further transformations in Mechanical Solutions, Potentially NC Manufacturing Solutions and Shape Design & Styling solutions. STRIM and STYLER files (with extension ".tdg") can be selected in File Open to Create and Display a part document enclosing the geometry of the files in a V5 Format. Files can be selected in the CATIA - DIGITAL MOCK-UP NAVIGATOR to be inserted as existing components in a Product.

•

• • •

The Data Exchange Interfaces User's Guide has been designed to show you how to Import and Export external files in/from Version 5.

Before Reading this Guide
Prior to reading the Data Exchange Interfaces User's Guide, you are recommended to have a look at the Infrastructure User's Guide for information on the generic capabilities common to all products.

Getting the Most Out of this Guide
For each interface, you will learn: • • • how to import data, or to export data to one of these formats, and how entities are dealt with.

then you will find chapters dealing with: • • • Trouble Shooting: this chapter provides solutions to repair eventual problems Best Practices: this chapter provides information and tips to use interfaces at their best FAQ: this chapter lists answers to frequently asked questions
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DXF-IGES-STEP Batch deals with the Batch processing of files

Accessing Sample Documents
To perform the scenarios, sample documents are provided all along this documentation. For more information about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.

CAD
STEP
Importing a STEP AP203 / AP214 File
This task shows you how to import to a CATPart or CATProduct document the data contained in a STEP AP203 / AP214 file. It is also possible to insert a STEP file as an existing component in a CATProduct. Regarding AP214, both STEP AP 214 IS and STEP AP 214 DIS files are read. The table entitled What about the elements you import ? provides information on the entities you can import. You can find further information in the Advanced Tasks: • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros.

and in the Customizing STEP Settings chapter. Statistics about each import operation can be found in the report file and the error file.

1. Click the Open icon File->Open command.

or select the

1. Insert/Existing component command. The File Selection dialog box is displayed.

The File Selection dialog box is displayed.

2. Set the .stp or .step extension in the Files of type field.
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This displays all .stp or .step files contained in the selected directory :

3. Select the .stp or .step file of your choice (MoldedPart.stp, in our example) and click Open.

A progress bar is displayed.
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You can use the Cancel button to interrupt the transfer at any time. What is then displayed depends on the contents of the STEP file. For the File/Open command: • • • • If the STEP file contains a normalized assembly structure, a CATProduct document is created. If the STEP file does not contain any geometrical and topological data, the components will be visible only in the Specification Tree. If the STEP file contains also geometrical and topological data, all the components will be present in the Geometry Space and in the Specification Tree. If the STEP file contains only geometrical and topological data, a CATPart document is created.

The geometrical elements of the faces, which could not be transferred, are created in the NO SHOW space. In the NO SHOW space, you can visualize the Surface supports and the 3D Curves).

For the Insert/Existing component command: • • if the STEP file contains no assembly information, it is converted to a CATPart, if the STEP file contains assembly information, it is converted to a CATProduct referencing several CATPart documents.

The resulting document is inserted in the current CATProduct document, and the graphic window is updated (specification tree and geometry).

•

The reference to the STEP file is lost, so any update of the STEP file will have no effect in the CATProduct. For both commands, the reference planes are hidden. A Geometrical Set is always created. It may be empty: o it will contain the valid surfaces imported, if any. o it is empty if there is no valid surfaces, e.g. when the element imported is a solid,

• •
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o

Several STEP options can be customized: • • • • Continuity optimization of curves and surfaces, to optimize curves and surfaces. Geometric Validation Properties, to check the quality of the transfer. Groups (Selection Sets), to activate/de-activate the transfer of groups mapped with Selection Sets. Detailed report, to set the level of details of the transfer log.

Report file
After the recovery of STEP files, the system generates: • • a report file (name_of_step_file.rpt) where you can find references about the quality of the transfer and an error file (name_of_step_file.err) .

These files are created in a location referenced by the CATReport variable. Its default value is • • Profiles Systemes user Local Settings Application Data Dassault

CATReport on NT (user being you logon id)

and $HOME/CATReport on UNIX.

Always check the report and error files after a conversion ! Some problems may have occurred without been visually highlighted.
Example of a report file

(Some lines have been replaced with ...)
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Legend

OK = Transferred OUT = Out Of Size KO = Not Transferred DEG = Degenerated NS = Unsupported INV = Invalid • "OUT" entities are OUT of model size. Most of the time, these entities are curves and they are out of the V5 model space. These entities are not created. • "INV" entities are Invalid entities, that is to say their description within the STEP file is invalid (STEP syntax rules are not respected,...). These entities are not created. • "DEG" entities are degenerated entities. They are solids (MANIFOLD_SOLID_BREP) or Shells (OPEN_SHELL), or Curves (LINE, CIRCLE,...). Degenerated solids are incomplete solids (at least one Face misses)

Example of error file: E: Report pm6-hc-214.err
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Input FileName : G:

Equipe_STEP

STEP

PDES-

Prostep Tr8 Prod Output FileName :

pm6-hc-214.stp

============================================ *** = Processing new independent element * = Intermediate processing !! = Independent element K.O. ! = Intermediate error -------------------------------------------<I> = Information <W> = Warning <E> = Error -------------------------------------------[0000] = Message identifier : 0000 [T=xxx] = Entity Type Step : xxx [#0000] = Entity identifier number : 0000 ============================================ Actual display level : Customer
Report messages

Here are some of the messages that may appear: • Too many cuts on face boundary. Tip : Use topological reduction option (in IGES) or curve optimization (in IGES or STEP) - see User's Guide These options are accessible via Tools/Options/Compatibility/STEP dialog boxes, in the Continuity optimization of curves and surfaces section. Select the Advanced optimization option and push the Parameters... button. For more information, click on the link on STEP above.

When the Continuity optimization of curves and surfaces/Advanced optimization option in T ools/Options/Compatibility/STEP is active, the following warning messages may appear in the report file: • • The BSpine Surface is not C1: Approximation of the surface is impossible! This is just a warning, the surface is imported but is not approximated. The deformation found of the surface approximation (which is calculated by isoparameters) is : xx millimeters. This indicates that the real deformation found is higher than the Deformation value you have entered in the Parameters box and that the approximation could not be performed. When this occurs for several entities, you will find the following information message at the end of the report file: For a better approximation of BSpline surfaces, you can use a "Curves and surfaces approximation" Deformation value of at least : xx millimeters You can enter this value in the Parameters box of the

•
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What About The Elements You Import ?
Exchanging 3D Geometry

One of the current primary uses of the AP214 Standard is to exchange geometry. The STEP Interface enables users to exchange the B-REP of exact solids. The exchange process is based on AP214. This application protocol is very similar to AP203 as it shares the same resources expressed in the PART 42.

• •

Conformance Classes 2,3,4 and 6 are supported in AP203. Conformance Classes 1 and 2 are supported in AP214 (assembly and 3D geometry / topology management).

Exchanging Visual Presentation of 3D Geometry

Another use of the AP214, AP203 edition2 or AP203 with extensions Standards is to exchange visual presentation information. The STEP interface enables users to exchange visual presentation of exchanged geometric elements. Please remember: • Units: As the unit system used in Version 5 is MKSA (radians, mm) data from all STEP files will be converted into such units. • Layers: • • • • A layer is created in your application for each layer present in the STEP file. All entities included in a layer in the STEP file are included in the corresponding layer. A layer over 999 is replaced by layer 0. Color: o Color exchange is supported. o STEP AP214: When an entity OVERRIDING_STYLE_ITEM exists in the STEP file for a given face, this color overriding is taken into account: the color of the face is overridden. Lines: o The line type is taken into account. o If the requested line thickness is defined in your environment, this

•
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STEP point style V5 point style cross, triangle plus circle square asterisk

Assemblies

STEP files containing assembly structures can be imported. STEP assemblies are mapped with the Product Structure. Geometry can be defined: • • • • in STEP in the same file, or in STEP in external files (AP 214 external references mechanism). The files referenced are STEP files. External references are supported with STEP AP214 and AP203 edition2 only. or in CATIA in external files. The files referenced are CATIA files. External references are supported with STEP AP214, but they are not with STEP AP203. or by links to CATPart, model or cgr files via PRODUCT_DEFINITION_WITH ASSOCIATED_DOCUMENT entities. Assemblies generated by V4 CATASM and referencing to .model files or cgr files are supported.

•

• • •

The physical structure of an imported assembly can be defined by one or several CATProducts (one for each node) depending of the option selected (See the Assemblies physical structure option about the import STEP files containing sub-assemblies). CATPart files are linked to the CATProducts as instances of Parts. Model files or cgr files are linked as Shapes. In the case of referenced files, those files must be in the same location than the root STEP file, or be accessible via the search order.
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The attributes of instances of products are taken into account as follows: STEP V5 Component/Instance NEXT_ASSEMBLY_USAGE_OCCURRENCE.ID name NEXT_ASSEMBLY_USAGE_OCCURRENCE.DESCRIPTIONComponent/Description

Groups
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•

STEP Part 42 Entities Imported into V5R6 and Higher

Implemented according to the standard
Shape Representation

Not yet implemented
geometrically bounded wireframe geometrically bounded surface

N/A: Not applicable
shell-based wireframe manifold surface faceted brep

edge-based wireframe

a

High Level Entities

geometric_curve_set geometric_set

edge_based_ shell_based_ shell_based_ faceted_brep manifo wireframe_model wireframe_model surface_model brep_with_voids brep

Entity
Point cartesian_point point_on_curve point_on_surface point_replica degenerate_pcurve N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

Curve

line circle ellipse hyperbola parabola polyline b_spline_curve (+ rational) b_spline_curve_with_knots uniform_curve (+rational) quasi_uniform_curve (+rational) bezier_curve trimmed_curve composite_curve composite_curve_on_surface boundary_curve outer_boundary_curve pcurve surface_curve offset_curve_3d N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A
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curve_replica

N/A

N/A

Surface plane
cylindrical_surface conical_surface spherical_surface toroidal_surface degenerate_toroidal_surface surface_of_linear_extrusion surface_of_revolution b_spline_surface b_spline_surface_with_knots uniform_surface quasi_uniform_surface bezier_surface rectangular_trimmed_surface curve_bounded_surface rectangular_composite_surface offset_surface surface_replica

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

Topology vertex_point edge_curve oriented_edge vertex_loop poly_loop edge_loop face_bound face_outer_bound face_surface advanced_face oriented_face vertex_shell wire_shell connected_edge_set open_shell oriented_open_shell closed_shell oriented_closed_shell manifold_solid_brep brep_with_voids

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A

N/A

N/A N/A N/A N/A N/A N/A

N/A N/A
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Exporting CATPart or CATProduct Data to a STEP AP203 / AP214 File
This task shows you how to save in STEP AP203 / AP214 formats the data contained in a CATPart or CATProduct document. STEP AP203 and STEP AP214 formats are used for the data exchange between the Assembly workbench and other CADCAM software products. Saving your assembly in STEP AP203 / AP214 format comes down to gathering assembly data into one file. The assembly structure and the geometry (in compliance with the STEP format) are saved. If you do not have any STEP license, you can nevertheless save the assembly structure in STEP. You can export: • CATProduct documents (resulting in STEP AP203 / AP214 files in compliance with Part 44) CATShape documents. However, if you re-import a STEP file made from a CATShape, you will create a CATPart.

•

Regarding AP 214, data are exported to STEP AP 214 IS files You can find further information in the Advanced Tasks: • • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros. and in the Customizing STEP Settings chapter.

Statistics about each import operation can be found in the report file and the error file created. The table entitled What about the elements you export ? provides information on the entities you can export. 1. Open the CATPart or CATProduct document to be saved in STEP AP203 / AP214 format.
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2. When the document is open, select the File -> Save As... command. The Save As dialog box is displayed:

3. Specify the name you want to give to the STEP file in the File name: field. 4. Set the .stp extension in the Save as type field. You will remember that the extension used in V4 was .step. In Version 5, CATPart and CATProduct documents are exported to files with the extension
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You can use the Cancel button to interrupt the transfer at any time. If you now open the .stp file you will see that the file header contains the following information: • • • the file name the date of creation (with the year expressed in four digits meaning that your STEP data will be year 2000-compliant) the V5 version used for the conversion.

Choose the Application Protocol in Tools -> Options -> Compatibility, click the STEP tab. Select AP203, AP203+ext, AP203 ed2 or AP214, and click on OK. Several export options can be customized: • • • • • • • Detailed report (not yet completely available for export) Geometric Validation Properties Groups (Selection Sets) Application Protocol (AP), to choose the AP203 or the AP214 Application Protocol, Assemblies, to use external references, thus reducing memory problems, Units, to choose the unit of the exported file, Show/NoShow, to export all entities or only visible entities.

Report File
After exporting data to STEP files, the system generates: • • and an error file (name_of_step_file.err) .

a report file (name_of_step_file.rpt) where you can find references about the quality of the tran
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These files are created in a location referenced by the CATReport variable. Its default value is • • Profiles user Local Settings Application Data Dassault Systemes

CATReport on

and $HOME/CATReport on UNIX.

You can find statistics about the quality of the transfer in those files.
Example of report file:

Example of error file:

C: Data

WINNT

Profiles

vmu

Local Settings

Application

DassaultSystemes

CATReport

03_ClosedTopology.err

Input FileName : E: users WebInterfaces Output FileName : E: users WebInterfaces ItfEnglish ItfEnglish itfug.doc itfug.doc src src samples samples

03_ClosedTopology.C

03_ClosedTopology.s

============================================ *** = Processing new independent element * = Intermediate processing !! = Independent element K.O. ! = Intermediate error -------------------------------------------<I> = Information <W> = Warning

181

collaboration <E> = Error -------------------------------------------[0000] = Message identifier : 0000 [T=xxx] = Entity Type Step : xxx [#0000] = Entity identifier number : 0000 ============================================ Actual display level : Customer

What About The Elements You export ?
Exchanging 3D Geometry

One of the current primary uses of the AP214 Standard is to exchange geometry. The STEP Interface enables users to exchange the B-REP of exact solids. The exchange process is based on AP214. This application protocol is very similar to AP203 as it shares the same resources expressed in the PART 42. Please remember: • • • You can export the bodies (volumes, shells and faces) of CATPart or CATShape documents (resulting in STEP AP203 / AP214 files in compliance with Part 42). The export of Shells occurs with no limitation and all the structure information can be recovered. When a CATProduct document is exported the geometry/topology of the CATPart or CATShape or .model documents is also stored in the .stp file.

Exchanging Visual Presentation of 3D Geometry

Another use of the AP214, AP203 edition2 or AP203 with extensions Standards is to exchange visual presentation information. The STEP interface enables users to exchange visual presentation of exchanged geometric elements. Please remember: • Layers: o Layers on exported entities are supported. o The visibility of layers is not taken into account: all layers are handled in the same way, event if filters are defined. Color: o The colors of your model are exported. o STEP AP214: When the color of a given face is different from the color of its solid, an entity OVER_RIDING_STYLE_ITEM is created in the STEP file, and the face keeps the overriding color. o STEP limitation with assemblies: since attributes can not be set on instances of components, the color of instances are not taken into account.

•
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Continuous Dotted Dashed Chain Chain double dash Dotted Chain

• •

Thickness is supported at export. Points: o Point styles are mapped as follows:

STEP point style cross, triangle plus circle square asterisk

V5 point style

Miscellaneous

Please remember: • Units:

The units used are V5 units i.e. MKSA (radians, mm). The angles are exported in radians and lengths in mm or Inch. • Wires:

If a feature contains several wires (result of a section), the wires will be exported as Composite Curves and will all have the same name (that of the feature).
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By default, hidden objects (i.e. that belong to the No Show space) are not exported. See option Show/NoShow. • Selection set (AP 214 only!):

For each selection set,an entity APPLIED_GROUP_ASSIGNMENT is created. This entity points to a GROUP entity and to a list of exported geometric entities. The attribute NAME of the entity GROUP is defined by the name of the selection set. The transfer of groups can be activated/de-activated via the Groups (Selection Sets) option. When a Body is contained in a Selection Set: • • a GROUP entity is created in the STEP file for that Selection Set, all the entities of the Body exported in STEP are put into that GROUP.

When an exported entity is contained in a Selection Set: • • a GROUP entity is created in the STEP file for that Selection Set, the entity is put into that GROUP.

Assemblies

Support of External References to STEP or CATIA files on Export: the External References functionality is available only with AP214 or AP203 ed2. For more information about the Customizing export mode, refer to Customizing STEP Settings • • Multiple Instances of a Part in an Assembly is possible: a link with the same reference is established in order to limit the number of instances. STEP limitation with assemblies: since attributes can not be set on instances of components, the color of instances are not taken into account.

You can save the structure of an assembly with links to CATParts files via PRODUCT_DEFINITION_WITH_ASSOCIATED_DOCUMENT entities. .model files referenced by a CATProduct are exported in STEP with the following settings: • • • • Application Application Application Application Protocol Protocol Protocol Protocol AP203 AP214 AP214 AP203 + Structure and Geometry in one file + Structure and Geometry in one file + STEP external references edition2 + STEP external references.

Alternative representations that can be selected using Manage Representations are not taken into account during STEP exports. The main representation is always exported.
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The attributes of products

are taken into account as follows: V5 STEP Part Number PRODUCT.ID Definition PRODUCT.NAME Description PRODUCT.DESCRIPTION Revision PRODUCT_DEFINITION_FORMATION.ID The attributes of instances of products are taken into account as follows: V5 Component/Instance STEP NEXT_ASSEMBLY_USAGE_OCCURRENCE.ID
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Component/Description NEXT_ASSEMBLY_USAGE_OCCURRENCE.DESCRIPTION

STEP Part 42 Entities Exported from V5R6 and Higher

Implemented generated by V5

Not yet implemented

Not

N/A: Not applicable according to the standard
Wire (GSM, Free Style, etc.) Not generated by V5 OpenShell (GSM, Shape Design, Free Style, etc.) manifold surface

Not

Shape Representation High Level Entities Entity Point cartesian_point point_on_curve point_on_surface point_replica degenerate_pcurve

geometrically bounded wireframe

geometrically bounded surface

edge-based wireframe

shell-based wireframe

fac

geometric_curve_set geometric_set

edge_based_ shell_based_ shell_based_ fac wireframe_model wireframe_model surface_model brep

N/A N/A N/A N/A N/A N/A N/A N/A N/A

Curve

line circle ellipse hyperbola parabola polyline b_spline_curve (+ rational)

thru edge_curve thru edge_curve thru edge_curve thru edge_curve thru edge_curve

thru edge_curve b_spline_curve_with_knots uniform_curve (+rational) quasi_uniform_curve (+rational) bezier_curve trimmed_curve composite_curve composite_curve_on_surface boundary_curve N/A outer_boundary_curve pcurve N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A
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surface_curve offset_curve_3d curve_replica

N/A

N/A

Surface

plane cylindrical_surface conical_surface spherical_surface toroidal_surface degenerate_toroidal_surface surface_of_linear_extrusion surface_of_revolution b_spline_surface

N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

b_spline_surface_with_knots uniform_surface quasi_uniform_surface bezier_surface rectangular_trimmed_surface curve_bounded_surface rectangular_composite_surface offset_surface surface_replica N/A N/A N/A N/A N/A N/A N/A N/A

Topology vertex_point edge_curve oriented_edge vertex_loop poly_loop edge_loop face_bound

N/A N/A N/A N/A N/A N/A N/A

N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

thru edge_curve thru oriented_edge thru edge_loop

N/A thru wire_shell N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A

face_outer_bound face_surface advanced_face oriented_face vertex_shell wire_shell connected_edge_set open_shell oriented_open_shell closed_shell oriented_closed_shell N/A N/A N/A N/A N/A N/A N/A N/A N/A N/A
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STEP: Trouble Shooting
Import
If you need to recover from transfer failures after importing the data contained in a STEP file into a CATPart document, please refer to the IGES: Trouble Shooting chapter because the repairing scenario is the same with IGES files. There are however some specificities for STEP data, they are detailed just below:

What you need to know

STEP files may describe assemblies that contain CATParts. The result of the conversion is a Product which contains several components.

=> If needed, each part can be analyzed and corrected individually.
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If the components have links between them (for example instantiations), the links are recreated in the product.

=> Corrections on the source part are automatically reported to instances.

You are now ready to create the topology. For more information: • • please refer to the next chapter entitled STEP: Best Practices - How to create a topology or use the application Healing Assistant for more complex cases.

STEP files with syntax errors

When a STEP file is syntactically invalid, there are error messages in the .err file describing those invalidities. Syntax errors are responsible for partial loss of STEP file data: all invalid entities and all entities pointing directly or not to invalid entities are ignored. In order to recover all the STEP entities, correct the STEP file before reading it in V5.

Export
Exporting V4 data does not provide the expected result: data placed in the NoShow in V5, or changes of colors or graphic attributes are not taken into account, e.g. if you have sent a V4 element to the NoShow, it will be kept since it is its V4 status that is taken into account. To make those changes effective, you
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STEP: FAQ
Import
• • • • Question: You successfully opened the STEP file, there is no KO faces, but the solid was not created. Answer: Try an interactive Join on the Shell Question: You successfully opened the STEP file, but the parts are not correctly placed. Answer: Edit the STEP file with a text editor and look for MAPPED_ITEM entities. Those are old entities not used anymore and not supported. Ask the provider of the STEP file to use CONTEXT_DEPENDENT_SHAPE_REPRESENTATION entities instead. Question: You successfully opened the STEP file, there is no KO faces, but there are some missing geometries. Answer: Check in the .rpt for NS (Non supported) elements, and consult STEP documentation to have a comprehensive list of Supported Entities Question : You receive a 'Low memory state' warning message and your STEP file is not totally converted.

• •

•

•

Answer : There is not enough memory to convert the file completely and all the remaining entities are skipped. We recommend that you use Windows NT4SP06 (and above) for large STEP files and with at least 1 GB of RAM and 2 GB of SWAP.

Export
• • Question: The .rpt reported that there were one or many KO Faces. Answer: The problem might be due to two sources : a bad CATPart or a bug in the STEP code. To verify the CATPart is OK, use the usual tools : Cleaner, NCGM Workbench and make sure there is no major errors. A internal check is done while exporting and a line is added to the .err to warn if the Body is invalid Question : I am losing some parts of my assembly while exporting my

•
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•

Answer : Make sure that you do not have any foreign parts included in your CATProduct like STL files or Parasolid files...etc. Those files do not contain any V5 information except the visualization information and therefore it is impossible to export them as STEP file. If you have CATIA V4 .models in your CATProduct, make sure to have them migrated to V5 before exporting to STEP.

STEP: VBScript Macros
You can automate Data exchanges between CATIA V5 and STEP using VBScript macros, either at import or export.

Import
1. Create a RunTime window (window in which all runtime variables a set) 2. Type the command: 3. cnext -macro MyMacro.CATScript where MyMacro.CATScript is the VBScript macro you want to
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You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per VBScript macro.

Example:
VBScript macro for implementing a STEP AP203 file Language="VBSCRIPT" Sub CATMain() Dim Document0 As Document ' Reading a STEP file Set Document0 = CATIA.Documents.Open( "E: ' Saving the corresponding CATPart CATIA.ActiveDocument.SaveAs "E: CATIA.Quit End Sub tmp Box" tmp Box.stp)

Export
1. Create a RunTime window (window in which all runtime variables are set): 2. Type the command:cnext - macro MyMacro.CATScript where MyMacro. CATScript is the VBScript macro you want to execute. • •

The input files must be writable (not read only). Otherwise the system will display an infor nd wait for an acknowledge. The output file must not exist in the output directory otherwise the system will ask for a co to overwrite the file and wait for an acknowledge.

Examples
VBScript macro for exporting a file to STEP AP203 Language="VBSCRIPT"
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CATIA Translators Sub CATMain() Dim PartDocument0 As Document ' Reading a CATPart file Set PartDocument0 = CATIA.Documents.Open( "E: ' Saving the part in a STEP file PartDocument0.ExportData "E: CATIA.Quit End Sub tmp tmp Box.CATPart" )

Box2", "stp"

VBScript macro for exporting a Product file to STEP AP203 Language="VBSCRIPT Sub CATMain() Dim ProductDocument0 As Document Set ProductDocument0 = CATIA.Documents.Open( "E: ProductDocument0.ExportData "E: CATIA.Quit End Sub tmp tmp Product1.CATProduct" ) Product1", "stp"

STEP: Best Practices
Import
Large Assemblies

We recommend that you import large assemblies in batch mode: • • In this mode the CATPart documents are unloaded once transferred. A maximum of the available memory is spared for the translation.

Quality of conversion

Always check the report and error files after a conversion ! Some problems may have occurred without been visually highlighted. We recommend also that you use the Geometric Validation Properties when they exist. When an error occurs in the comparison, you can locate the problem as follows : • • • An error at solid or shell level means that the geometric translation failed. An error at product level means that a sub-assembly translation failed. An error at instance level means that a component is misplaced.

Note that the error at the lowest level gives the relevant information. It is the first error that appears in the report file:
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• •

An error at solid or shell level involves an error for corresponding product. An error at product level involves an error for every product including instances of it.

How to Create a Topology

STEP files usually describe solids. It means that they contain the topology of the model. During the conversion of a part: • • If no problem, the geometry and the topology are imported and the result is a solid. If there is a geometric problem, one or several faces of the solid cannot be recreated and the solid itself is degenerated. The resulting model contains: an empty PartBody, an Geometrical set with a surface corresponding to all faces OK, an Geometrical set for each face KO.

• • •
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=> The repairing methodology is the same as faces KO in IGES. • There may also be a topological problem, when all the geometry has been converted OK but the topology could not be created. Then the resulting model contains: an empty PartBody, an Geometrical set with the surfaces that could not be joined properly.

• •

=>The repairing methodology is the same as in IGES: Best Practices - How to create a topology.
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Export
Large Assemblies

To export a large V5 Assembly in STEP, we recommend that you open it with the Work with the cache system option active (Tools/Options/Infrastructure/Product Structure/Cache Management/Work with the cache system): When this option is active, the referenced CATPart documents are loaded only during their transfer.
External references

For the exchange of large assemblies, we recommend that you use external references, using several small files instead of one large file (this will reduce memory problems). See the settings for more information.

3D IGES
Importing a 3D IGES File into a CATPart
This task shows you how to import into a CATPart document the data contained in an IGES file. Once imported, the data can be handled just as if it were created as a CATPart. The main purpose of such an import is to be able to create shells from IGES faces but you may also find it useful for re-using face contours in the Sketcher application, deforming NURBs in Generative Shape Design or using faces in other V5 applications. The table entitled What about the elements you import ? provides information on the entities you can import. You can find further information in the Advanced Tasks: • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros.

and in the Customizing 3D IGES Settings chapter. Statistics about each import operation can be found in the report file created. The function "Insert / Existing Component" for IGES files is provided by the MULTICAx IGES plug-in and requires a MultiCad license. 1. Select the File->Open command. The File Selection dialog box is displayed. 2. If the directory contains many different types of files you may wish to
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3. Select the .igs file of your choice and click Open.
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A progress bar is displayed.
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You can use the Cancel button to interrupt the transfer at any time. This creates a new document similar to a CATPart document in all respects and containing all surfaces and 3D wireframe geometry. The data is now available in your session. • Some invalid geometries may be detected. • The reference planes are hidden at import. Several 3D IGES import options can be customized: • • • • • • • Display of the Completion Dialog Box Import mode to import large files containing 308/408 entities. Join, to join surfaces in the model you import. Continuity optimization of curves and curfaces to optimize curves and surfaces. Detection of invalidity in input geometry. Representation for boundaries of faces. Import Groups to activate or de-activate the creation of Selection Sets.

Report File
After the recovery of 3D IGES files, V5 generates: • • • a report file (name_of_file.rpt) where you can find references about the quality of the transfer and an error file (name_of_file.err) . the USERPROFILE variable on NT. Its default value is Profiles\ Systemes • user \Local Settings\ Application \Data \Dassault \CATReport on NT (user being you logon id)

These files are created in a location referenced by

the HOME variable on UNIX. Its default value is $HOME/CATReport on UNIX.

Always check the report and error files after a conversion ! Some problems may have occurred without been visually highlighted. Example of a report file:
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Example of an error file:
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Report messages

Here are some of the messages that may appear: • Too many cuts on face boundary. Tip : Use topological reduction option (in IGES) or curve optimization (in IGES or STEP) - see User's Guide These options are accessible via the Tools/Options/Compatibility/IGES or Tools/Options/Compatibility/STEP dialog boxes, in the Continuity optimization of curves and surfaces section. Select the Advanced optimization option and push the Parameters... button. For more information, click on the link on IGES above.

When the Continuity optimization of curves and surfaces/Advanced optimization option in Tools/Options/Compatibility/IGES is active, the following warning messages may appear in the report file: • • The BSpine Surface is not C1: Approximation of the surface is impossible! This is just a warning, the surface is imported but is not approximated. The deformation found of the surface approximation (which is calculated by isoparameters) is : xx millimeters. This indicates that the real deformation found is higher than the Deformation value you have entered in the Parameters box and that the approximation could not be performed. When this occurs for several entities, you will find the following information message at the end of the report file: For a better approximation of BSpline surfaces, you can use a "Curves and surfaces approximation" Deformation value of at least : xx millimeters You can enter this value in the Parameters box of the Continuity optimization of curves and surfaces/Advanced optimization option in Tools/Options/Compatibility/IGES.

•

Invalidity in Input Geometry
When invalidities are detected in the input geometry, all the invalid faces (and all the elements of their geometry) are put in a specific Geometrical set named invalid Input Geometry. These faces are shown as invalid in the report file. For each invalidity detected, a specific label points to the face concerned. These labels are put in an Annotation Set.xx.
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• • •

Deleting an invalid element does not automatically delete the corresponding Annotation Set. Only one feature Annotation Set is created at the root of the specification tree, with all the invalidity descriptions. Annotation Sets are not exported to IGES, but they can be saved in the CATPart.

What about the Elements You Import?
The following points should be remembered: • • • • • The IGES standards 5.2 and 5.3 are supported. The latter is year 2000compliant. Trimmed and bounded surfaces are transformed into faces. Solids and volumes are imported as joined shells as well as text, annotations and 2D geometry are not converted. The tolerance used is the default tolerance defined in the Part Design session. Properties such as the original colors, the show status, names (if they exist) are maintained in your session.

Processing of names:

• •

•

If an IGES entity has a pointer to a "Property Name Entity", the value of this property will be assigned to the name of the V5 entity. If the IGES entity has no pointer to a "Property Name Entity" and if its "Directory Entry" field #18 is not blank the V5 name will be computed by appending field #18 and #19 of the "Directory Entry". If the entity has neither a "Property Pointer" nor a non-blank field #18 an automatic name will be generated. Product Identification for Receiver (Global Section, Field #12) will be used as

•
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Processing of Group Associativity:

The Group Associativity, in the IGES Norm, is mapped with the type 402 (ASSOCIATIVITY INSTANCE ENTITY). There are four form numbers which specify group associativities : Form 1 7 14 15 Meaning Unordered group with back pointers Unordered group without back pointers Ordered group with back pointers Ordered group without back pointers

For each Group Associativity pointing to a list of entities in the IGES file, a selection set is created. This selection set is named with the name of the pointed GROUP entity and includes all pointed entities. • • • This applies to known Group Associativity forms (Type 402 - forms 1, 7, 14 and 15) only. A Selection set pointing to another Selection set cannot be created. When a group is pointed by a second group, the entities of the first group will be pointed by a first Selection set (mapping the first group) and by a second Selection set mapping the second group (including others entities of the second group). Only logically dependant IGES entities (Status Number 3-4 = "02" in D.E. section) can be mapped in a Selection set. The Import Group option activates or de-activates the creation of Selection Sets.

• •

Processing of 308/408 IGES entities

• • •

If the Map the 308/408 IGES entities onto a Product Structure is not selected, elements contained in dittos are imported as simple elements (dittos are exploded). If the Map the 308/408 IGES entities onto a Product Structure is selected, it creates a Product Structure. In addition, when selected, it deactivates the mapping of groups to Selection Sets.
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Note

From V5R12, even indep form 0 are imported. unbounded plane 108 form 0 plane

Independent planes 108 displayed as a small squa bounded plane 108 form 1 line 110 form 0 semi-bounded line 110 form 1 unbounded line 110 form 2 parametric spline 112 curve parametric spline 114 surface point 116 ruled surface 118 surface of revolution 120 tabulated cylinder 122 direction entity 123 transformation 124 matrix rational B-spline 126 curve rational B-spline 128 surface offset curve 130 plane line line line curve surface point surface surface surface direction matrix curve surface curve, line, circle

Rational B-spline surface as planes or cylinder acc geometrical properties..
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offset surface 140

surface either included in the translation of a bounded surface, or curve, line, circle if the transfer of the bounded surface has failed either included in the translation of a trimmed surface, or curve, line, circle if the transfer of the trimmed surface has failed surface surface

boundary (of skin) 141

If the surface is not of ty continuous, only the Geo "Curve on a parametric s "Boundary" are taken int creation. 2D Parametric t ignored.

curve on parametric 142 surface

If the surface is not of ty continuous, only the Geo "Curve on a parametric s "Boundary" are taken int creation. 2D Parametric t ignored.

bounded surface (of 143 skin) trimmed 144 (parametric) surface manifold solid B-rep (consisting of shell face loop edge list vertex list) 186 form 0 (514 form 1 510 form 1 508 form 1 504 form 1 502 form 1)

joined shell

Creation of a geometrica shell. Creation of a PartBody if

plane surface entity 190 form 0-1 right circular cylindrical surface 192 form 0-1 entity right circular conical 194 form 0-1 surface entity toroidal surface 198 form 0-1 entity subfigure definition 308 (detail) color definition 314 associativity 402 forms 1,7,14,15 instance (group) singular subfigure 408 instance (ditto) see singular subfigure instance color selection set simple elements or CATParts

All the surfaces are faces they must be used with e 144 and 510.

Those surfaces are infinit

If a face, supported by o cannot be correctly impo "invalidFace" created by containing surfaces and c visualization problems on graphic representation.

See the Group Associativ

See the processing of 30

Exporting CATPart or CATProduct Data to a 3D IGES File

207

collaboration This task shows you how to save in IGES format the data contained in a CATPart, CATProduct or a CATShape document. However, if you re-import an IGES file made from a CATShape, you will create a CATPart.

IGES 5.3 (year 2000-compliant) is the standard supported. The table entitled What about the Elements You Export ? provides information on the entities you can export. You can find further information in the Advanced Tasks: • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros.

and in the Customizing 3D IGES Settings chapter. Statistics about each export operation can be found in the report file created. 1. Open the CATPart or CATProduct document to be saved in IGES format. 2. Select the File -> Save As... command. The Save As dialog box is displayed. 3. Specify the name of the document in the File name: field. 4. Set the .igs extension in the Save as type field. • • In Version 5, documents can be exported to files with the extension "igs". The name of the CATProduct is exported as the Product identification for Receiver.

•

The name of the author and of the organization can be exported to the
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You can use the Cancel button to interrupt the transfer at any time. • • • • • • • Several 3D IGES export options can be customized: Save only shown entities Curve and surface type Representation mode Name of author and Organization Export unit as Display of the Completion Dialog Box

Report File
After the exporting data to 3D IGES files, V5 generates: • • • a report file (name_of_file.rpt) where you can find references about the quality of the transfer and an error file (name_of_file.err) . the USERPROFILE variable on NT. Its default value is Profiles user Local Settings Application Data Dassault Systemes CATReport on NT (user being you logon id) • the HOME variable on UNIX. Its default value is $HOME/CATReport on UNIX.

These files are created in a location referenced by

What About the Elements You Export?
• If the representation mode is "Surface", the topology of solids and shells is lost during the export. As a consequence, you have a group of surfaces called an Geometrical
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collaboration set. If you make an Import with Join, you can get a Close Body. When a CATProduct is exported, the component .igs and .model files are not stored in the .igs file. Each component of a CATProduct document is translated by a subfigure definition / singular subfigure instance in the .igs file. You can choose the export unit. Alternative representations that can be selected using Manage Representations are not taken into account during STEP exports. The main representation is always exported. The name of the elements to export must be in ASCII format. Overridden faces colors are supported. You export the final construction object, i.e. the whole specification tree and its history up to the feature at the bottom of the specification tree and not the current feature: for example, you wish to export the specification tree up to Pocket.1 only

•

• •

• • •

In this case, although Pocket.1 is the current feature, you will export all elements of the specification tree including Copy of Pad.1.
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If you want to limit your export to Pocket.1, you have to make sure that it is the feature at the 211

collaboration bottom of the specification tree, like this:
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V5 Element

IGES Element null 0

circle

circular arc 100

However, in B-Spline mode (see options), all planes and surfaces a exported to rational B-Spline surf (128) and all curves, circles and l are exported to B-Spline curves (126)

curve, line, circle

composite curve 102

curve

conic arc - ellipse 104 form 1

However, in B-Spline mode (see options), all planes and surfaces a exported to rational B-Spline surf (128) and all curves, circles and l are exported to B-Spline curves (126)

point, curve plane plane line Semi-bounded lines Unbounded lines point surface surface surface matrix curve surface

copious data 106 form 2 unbounded plane 108 form 0 bounded plane 108 form 1 line 110 form 0 line 110 form 1 line 110 form 2 point 116 ruled surface 118 surface of revolution 120 tabulated cylinder 122 transformation matrix 124 rational B-spline curve 126 rational B-spline 128 surface In standard export mode: curve on parametric 142 surface

However, in B-Spline mode (see options), all planes and surfaces a exported to rational B-Spline surf (128) and all curves, circles and l are exported to B-Spline curves (126)

However, in B-Spline mode (see options), all planes and surfaces a exported to rational B-Spline surf (128) and all curves, circles and l are exported to B-Spline curves (126)

surface boundary

If the surface support is of B-Spli type and C2 continuous, both
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representation of boundaries are defined (2D parametric and 3D m space). Otherwise, only the 3D representation is defined.

In B-Spline mode all surfaces are exported as B-Spline surfaces (wi 2D and 3D boundary representations). Those boundari are ordered and oriented. surface Solid trimmed (parametric) 144 surface Manifold Solid B-Rep 186 form 0 Object Entity Plane Surface Entity 190 form 0

Plane Surface (support of Face) Solid (Closed) Shell

To export those entities, the Representation mode: Solid - She option must be active. It requires IGES 5.3 or higher.

Closed Shell Entity 514 form 1

Independent Shell

Open Shell Entity 514, Form 2

Face in a Shell Face Entity 510 form 1 Face Loop Loop Entity 508 form 1 List of Loop Edges List of Start/End Loop Edges Vertices Long names (more than 8 characters) Color

All those new IGES entities have been "tested" (IGES Norm 5.3) a the IGES/PDES Organization recommends that special consideration be given when implementing certain untested entities. Therefore if you do not k whether the receiver system will recognize those entities, we recommend that you do not use t option. For Loops, only the 3D Representation is exported

Edge Entity 504 form 1 Vertex Entity 502 form 1

Name Property Entity 406 form 15 color definition 314

3D IGES: Trouble Shooting
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Import
This task shows you how to recover on transfer failures or limitations after importing the data contained in an IGES file into a CATPart document. Once imported, the data can be handled just as if it were created as a CATPart. Sometimes, some entities are degenerated during the transfer and it is characterized by a loss of geometry. In this case, the missing geometry must be re-created. In this tutorial you are going to learn how to: • • Open an IGES file Repair KO Faces

The whole scenario is built up with IGES data but it can also be performed with a STEP file. And if you want to know more about STEP characteristics, see STEP: Trouble Shooting

Open the IGES file
1. Open the IGES file FaceKO.IGS into your desktop.

When you open this document, the conversion of the IGES file is progressive and you can visualize the process through this panel:

Eventually, once the transfer is completed (see Show/NoShow Completion Dialog Box for more details), a message similar to this one appears:

Click OK to continue. All the faces reported as KO are put in the geometrical set GeometryFailure . For each face KO, you will find a FaceKO.xx geometrical set under GeometryFailure.
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Repair KO faces
1. Recall FaceKO#BND_SRF1 from the NoShow and expand it if necessary. It contains the support surface and boundary curves corresponding to the face. The reason of the failure is that the inner boundary is described before the outer boundary, in contradiction with the IGES standard.

2. In Generative Shape Design (for example), select the Join icon 3. Select the curves of the outer boundary:

.
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Press OK. A Join.1 is created under FaceKO.1. 3. Repeat this step with the curves of the inner boundary:

A Join.2 is created under FaceKO.1. 3. Select the Split icon .

4. Select the surface and Join.1
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3. Push the Other side button to keep the inside of the surface.

Press OK. The surface is split by the outer boundary. Split.1 is created under FaceKO.1.
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4. Repeat this step with Join.2 and Split.1

Split.2 is created, corresponding to the repaired face.
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Before splitting the surface, as no associativity is needed, you can use the Create Datum mode by selecting the Create Datum icon.

5. If necessary, you can move the result surface Split.2 to another geometrical set: Right click the result surface and select Split.2 object-> Change geometrical set... to move the resulting surface to another geometrical set.

The following dialog box opens. Choose the destination geometrical set:

7. Delete the FaceKO#BND_SRF1 geometrical set. All these elements are
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Another possible cause of failure:
The splitting operation has kept the wrong side of the boundary. • Recreate the correct face by Fill (in datum mode)

As a result, a Surface.xx is created. You may also extract the surface boundary and untrim the surface to use Split. You are now ready to create the topology. For more information: • • please refer to the next chapter entitled IGES: Best Practices - How to create a topology or use the application Healing Assistant for more complex cases.

Export:
Exporting V4 data does not provide the expected result: data placed in the NoShow in V5, or changes of colors or graphic attributes are not taken into account, e.g. if you have sent a V4 element to the NoShow, it will be kept since it is its V4 status that is taken into account. To make those changes effective, you need to make those changes in a V4 session, save the data in V4 and re-import them to V5.

3D IGES: FAQ
Here is a non-exhaustive list of Frequently Asked Questions about the IGES export and import process. The most common problems are gathered here to help troubleshooting.

Import
• Question : the application cannot open the IGES file and returns an "invalid input file" error message, what can I do?
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•

Answer : As the error message suggests , the IGES file is indeed a poor quality IGES file that cannot be opened. The best thing to do is to contact the provider of the IGES file and ask for a more decent file.

•

Question: the application crashes when I open the IGES file with a "Run Time Exception", why ?

•

Answer : It is obviously a bug that was not fixed on the release you are using. If you do not use the latest release, you can consider upgrading or contact your local support.

•

Question : I get a 'Low memory state' warning message and my IGES file is not totally converted.
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•

Answer : there is not enough memory to convert the file completely and all the remaining entities are skipped. We recommend to use Windows NT4SP06 (and above) for big IGES files and use at least 1 GB of RAM and 2 GB of SWAP.

•

Question : I opened my IGES file successfully but I have some KO faces that were moved to the NoShow section, what was wrong?

•

Answer : there could be many reasons why KO faces are returned but it is usually due to the fact that it was not possible to recreate the geometry contained in the IGES file. To avoid those KO faces, you can try and import the IGES using a different import option for Representation for boundaries of trimmed and bounded surfaces. If you still have KO faces, you may consider repairing those faces using the methodology described in the chapter 3D IGES: Trouble Shooting
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• •

Question : all the dimensions of my IGES file were multiplied by 25.4, why ? Answer : the most common cause for this problem is a problem in the header of the IGES file which is not correct. Therefore, the application can not read correctly the dimension system used by the user and takes the 'inch' as the default system. That explains why all the dimensions are multiplied by 25.4. Then you can either modify manually the IGES file to repair it or you can ask the provider of the IGES file to provide a good quality file

•

Question : I have a KO Face: in the KO-Body, I have only Surfaces (no curve); in the .err file, I can read .

How can I repair my face ?

Answer: The Surface must be a C2 B-Spline. The reason of the problem is that there is not the 3D-representation for the curves in the IGES File. The Face type is 144. The Boundary type is 142. This Boundary should reference two Curves Representations : • • First, a 2D-Parametric Curves Representation: OK, in our case. Then, a 3D Curves Representation: Missing in our case!

CATIA V5 only uses the 2D representation if the B-Spline Surface is C2-continuous. Here, the B-Spline Surface is not C2. CATIA V5 must cut it in C2 Surfaces and cannot use the 2D Curves Representation. With Continuity Optimization of Curves and Surfaces option, B-Spline Surfaces are
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•

Question : Even with correct IGES Options, I still have a KO Face : in the KO-Body, I have only one not-cut B-Spline Surface (no curve); in the .err file, I can read .

How can I repair my face ?

Answer: The IGES File is invalid and has 2 problems: • • First, There is NO 3D Curves Representation. and the 2D Curves Representation is incorrect :

For the 2D Curves, the Entity Use Flag, in the Status Number, should be "05" for "2D-Parametric". In the IGES File, this flag is "00", which means 3D Curves! Replace the incorrect flag "00" by "05" for all 2D Curves in the IGES file.

Export
• • Question : When examining my .rpt file, I see I have some KO faces , what should I do? Answer : KO faces when exporting may be caused by a corrupted CATPart.
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•

Question : The IGES file created by my application is not correctly opened by my CAD package, what should I do? Answer : You can try to use the export with the two available options for Curve and surface type : Standard and BSpline

•

The BSpline option may give better results with some CAD systems and the Standard option give better results with others. If the result is still bad with the receiving system, you may want to investigate if the CATPart is not corrupted and use the CATDUA program to upgrade the CATPart. Finally, if the result is still not the expected one, it could be a problem with the CAD receiver system itself.

•

Question : I am losing some parts of my assembly while exporting my CATProduct to IGES, why ?
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•

Answer : Make sure that you do not have any foreign parts included in your CATProduct like STL files or Parasolid files...etc. Those files do not contain any V5 information except the visualization information and therefore it is impossible to export them as IGES file. If you have CATIA V4 .models in your CATProduct, make sure to have them migrated to V5 before exporting to IGES.

3D IGES: VBScript macros
You can automate Data exchanges with IGES using VBScript macros, either at import or at export

Import
1. Create a RunTime window (window in which all runtime variables a set) 2. Type the command:
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cnext -macro MyMacro.CATScript where MyMacro.CATScript is the VBScript macro you want to execute • • The input files must be writable (not read only). Otherwise the system will display an information box and wait for an acknowledge. The output file must not exist in the output directory otherwise the system will ask for a confirmation to overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per VBScript macro.

Example
VBScript macro for implementing a IGES file Language="VBSCRIPT" Sub CATMain() Dim Document0 As Document ' Reading an IGES file Set Document0 = CATIA.Documents.Open( "E: ' Saving the corresponding CATPart CATIA.ActiveDocument.SaveAs "E: CATIA.Quit End Sub tmp Box" tmp Box.igs" )

Export
1. Create a RunTime window (window in which all runtime variables are set): 2. Type the command: cnext -macro MyMacro.CATScript where MyMacro. CATScript is the VBScript macro you want to execute.

The input files must be writable (not read only). Otherwise the system will display an information box and wait for an acknowledge. The output file must not exist in the output directory otherwise the system will ask for a confirmation to overwrite the file and wait for an acknowledge.
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You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per VBScript macro

Example

VBScript macro for exporting a file to IGES

Language="VBSCRIPT" Sub CATMain() Dim PartDocument0 As Document ' Reading a CATPart file Set PartDocument0 = CATIA.Documents.Open ( "E: ) ' Saving the part in a IGES file PartDocument0.ExportData "E: CATIA.Quit End Sub tmp Box2", "igs" tmp Box.CATPart"

3D IGES: Best Practices
Import
Quality of conversion

Always check the report and error files after a conversion ! Some problems may have occurred without been visually highlighted. The Detection of Invalidity in Input Geometry option is used to detect: • the 3D curves of the loop boundary do not map with the support surface.
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•

the single loop (boundary of the surface) presents a hole.

•

two other cases of invalidity:
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o

•

The single boundary is open (a curve is missing). Hide the surface and recreate the missing curve. Then join all the curves and project them on the surface to split the surface.
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How to Create a Topology
This task shows you how to generate the model topology if it is not contained in the CATPart corresponding to the original IGES file you have imported. You have seen how to recover a maximum of the face geometry and individual topology, when it failed during the import of either IGES. This scenario will show you how to create solids from IGES faces and also how to join the surfaces of an IGES model into a Part. It also shows you how to improve the quality of the geometry of the solid obtained thanks to the Healing operation in Generative Shape Design. I Therefore, this methodology allows you to improve IGES data interoperability and productivity (use of features). It can also be applied to a STEP file, when the failure of the topology transfer occurs (in rare cases) and to improve geometry quality. Previously, you had 2 scenarios about the repairs of KO faces: • • Open an IGES file Repair faces KO
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Create a topology
You may open the file 01_FaceKOrepaired.CATPart.

1. Select all surfaces of GeometricalSet.1 in order to apply the Join operation upon all these elements. The Join operation allows to repair geometry whereas topological healing allows to close topology. It is better to select the surfaces in the tree (select Surface.1, then select the last surface holding the Shift key) to have them ordered by their numbers in the Join Definition dialog box.
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2. Keep merging distance = 0.001mm and deactivate the connexity Check option. The problem is not yet to check whether the surface is closed or even connex. This will be analyzed in the following step. 3. Click Preview. An error message is displayed, saying that some surfaces cannot be integrated to the join.

The solution is to withdraw these surfaces. 4. The rejected surfaces are automatically selected in the list, in the Join Definition dialog box and you can use the Remove Mode button.
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5. Click Apply. 6. Click OK. The resulting join surface includes all surfaces of GeometricalSet.1 except those that have been rejected. 7. Insert a new Geometrical set and name it SurfacesToAnalyze (for example)

8. Move the rejected surfaces to the new Geometrical set. For this, right click them in the No Show space and select the Change Geometrical set... contextual command.
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9. Hide GeometricalSet.1 and display the other geometrical set SurfacesToAnalyze.

10. Check the rejected surfaces. Usually rejected surfaces have a very sharp corner, for instance, a vertex where edges arrive tangent to each other. 11. Reframe on the first surface to recreate (Surface.321 for instance):
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12. Create its complete boundary by selecting the Boundary icon Operations toolbar.

in the

13. Disassemble the boundary in order to be able to see the curves by using the Disassemble in the Join-Healing toolbar. As a result, details about the curves icon contained in Surface.321 are displayed in the Specification tree. 14. Untrim the surface to process (Surface.321) by clicking on this icon Click OK when this message appears :

A new element is displayed : SurfaceUntrim.1
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15. Recreate the face by Split between Surface.710 and Curve.1, Curve.2 and Curve.9.
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16. Join Curve 4, 5, 6 into Join.2 17. Split the surface (in datum mode) with: • • Element to cut: Split.1. Cutting element: Join 2.
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Repeat the same operations with the other rejected surfaces. You may also recreate only two of them and use asymmetry for the other two. 19. Double click Join.1 (in GeometricalSet.1) to edit it and select the four corrected faces to add them to the list (Add Mode):
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20. Click OK. All the surfaces are now inserted into the join: the topology is complete. You can now delete SurfacesToAnalyze.

Analyze the topology
You may open the file 02_InitialTopology.CATPart. 1. Activate the Surface boundary display option: select the Tools -> Options... command, click General -> Display in the list of objects to the left of the Options dialog box. Select the Visualization tab.

The Analysis is based on the free sides of the surface. Free sides may indicate: • • • • gaps between elements missing elements (not converted or not available in original IGES file) overlaps (duplicated elements) invalid elements (with unexpected shapes)

2. Double click the join surface Join.1 in the GeometricalSet.1 to change its
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Increasing the merging distance will reduce the number of free sides due to gaps. It is a way to highlight the most important holes. 3. Click Preview, then OK. Few free sides remain: three on the top surface and two on the sides (symmetric to each other). Now you have to find the type of free side (gap, missing element, overlap, invalid shape).

242

CATIA Translators

4. Reframe on the side surface surrounded by a free side.

5. Display the No Show space to see the original surfaces. 6. Use the Connect Checker in the Analysis toolbar to measure the distance between the surface (Surface.707) and its neighbors. The maximum distance is 0. It means that the free side is not due to gap.
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7. Select the surface and send it to the visible space. Check it you see a hole instead. There is no hole, it means that this surface was duplicated. You have to delete one of the surfaces. 8. Remove the surface 707 from Join.1, then delete it.

244

CATIA Translators

9. Repeat these steps with surface 706. 10. Reframe on the area shown below and display the No Show space to see the original surfaces (Surface.526, Surface.534).

They are obviously incorrect, their shapes look strange. The shaded display is typical of a problem in the definition of the boundaries (missing boundary curves, wrong order).
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11. Remove them from Join.1 into SurfacesToAnalyze.

Then for each of the three faces to rebuild, 13. Create the full boundary of the surface. 14. Disassemble the boundary. 15. Untrim the surface.

16. Check the boundary curves and create the missing ones 17. Recreate the correct surfaces by Split (in datum mode).
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18. Add the recreated surfaces to Join.1. The surface has now no visible free side, but there might be very small holes impossible to detect visually. To make sure that the surface is closed: Select Join.1 and click the Boundary icon. If the selected surface is closed, you get an explicit message.

It means that the surface is closed within 0.1mm. You may now try to reduce the merging distance to find the minimum value that gives a closed surface. Change the merging distance to 0.01mm and check for free sides: The surface is closed within 0.01mm. Check with 0.005mm: The surface has visible free sides. Check with 0.008mm: The surface is closed within 0.008mm. This distance is a good evaluation of the model accuracy.

Healing
You may open the file 03_ClosedTopology.CATPart. At that stage, you may decide that the evaluated accuracy is good enough but you may also create a solid and use the Healing to reduce the gaps between surfaces by actually modifying (deforming) the surfaces. 1. Select the Healing icon 2. Select Join.1. 3. Give the value of the tolerance found in the previous step (Merging distance is 0.008mm in this case). .
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4. Click OK. The surface is now both topologically and geometrically closed.

Create a solid
You may open the file 04_HealedTopology.CATPart. 1. Start a Part Design workbench. 2. Select the Close Surface icon in the Surface-Based Features toolbar.

3. Select Join.1 or Healing.1. The following message confirms the operation:

4. Click OK.
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The solid is created and ready for use. The process is now completed.

Export
Large Assemblies

To export a large V5 Assembly in IGES, we recommend that you open it with the Work with the cache system option active (Tools/Options/Infrastructure/Product Structure/Cache Management/Work with the cache system): When this option is active, the referenced CATPart documents are loaded only during their transfer.

2D IGES
Importing a 2D IGES File into a CATDrawing
This task shows you how to import into a CATDrawing document the data contained in a 2D IGES file. Once imported, the data can be handled just as if it were created as a CATDrawing. The table entitled What about the elements you import ? provides information on the entities you can import. You can find further information in the Advanced Tasks: • • • • Trouble Shooting, Best Practices, FAQ, Macros
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•

and in the Customizing 2D IGES Settings chapter.

Statistics about each import operation can be found in the report file. 1. Select the File -> Open command. The File Selection dialog box is displayed. 2. If the directory contains many different types of files you may wish to set the .ig2 extension in the Files of type field. This displays all files with the extension "ig2" contained in all the selected directory. 3. Select the .ig2 file of your choice and click Open. This creates a new document similar to a CADrawing document in all respects and containing all 2D geometry and annotations. The data is now available in your session. Several 2D IGES import options can be customized: • • • • • Standards Unit of the file Destination view Create end points Convert dimensions as

Format
V5 determines systematically and automatically the most suitable format (A0 ISO, A1 ISO, etc.) for each sheet (layout) i.e. V5 chooses the smallest format in which the drawing can be totally included: • • • If the standard is ISO, V5 chooses the format among A0, A1, A2, etc. If the standard is ANSI, V5 chooses the format among A, B, C, etc. If no standard format fits the sheet, the format is set to the largest one i.e. A0 ISO and made invisible with a message "No standard format can be applied to this sheet" in the report file. If you are not satisfied with this automatic result, use the Page Setup command to modify the format.

•

Information on what has been determined automatically is written in the report file:
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For more information on Formats, see the Defining a Sheet chapter in the Generative Drafting User's Guide.

Code pages
DBCS (Double Byte Character Set) Supported Code Pages are: • • • 932 (Japanese) 936 (Simplified Chinese) 950 (Traditional Chinese)

949 (Korean) is not supported.

Fonts
Fonts are mapped with those defined by default in the standard. See the Generative Drafting User's Guide for more information.

Report File
After the recovery of 2D IGES files, the system generates: • a report file (name_of_file.rpt) where you can find references about the quality of the transfer the USERPROFILE variable on NT. Its default value is Profiles \user\ Local Settings \Application \Data \Dassault Systemes logon id) \CATReport on NT (user being you

These files are created in a location referenced by •

Always check the report file after a conversion ! Some problems may have occurred without been visually highlighted.
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What about the Elements You Import?
To make sure the elements you need to handle in your session are those you expected, here is a list presenting the IGES data supported when imported into a CATDrawing document: Element type circular pattern composite curve conic arc copious data line parametric spline curve point transformation matrix rational B-spline curve offset curve angular dimension arc length dimension diameter dimension flag note general label general note leader linear dimension point dimension radius dimension general symbol sectioned area subfigure definition (detail) associativity instance (group) drawing properties single subfigure instance (ditto) view Element number in IGES format 100 102 104 106 110 112 116 124 126 130 202 204 206 208 210 212 214 216 220 222 228 230 308 402 404 406 408 410

Exporting CATDrawing Document to an IGES 2D file
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CATIA Translators This task show you how to save in an IGES 2D file the data contained in a CATDrawing document. • IGES 5.1 is the standard used for the generation. You can find further information in the Advanced Tasks: • • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros and in the Customizing 2D IGES Settings chapter.

1. Open the CATDrawing document to be saved in IGES format. 2. Select the File -> Save As... command. The Save As dialog box is displayed. 3. Specify the name of the document in the File name: field. 4. Set the .ig2 extension in the Save as type field. 5. Click the Save button to confirm the operation. The export unit depends on the current unit of your session (see the Tools -> Options->Parameters and Measures/Units panel). • • If the current unit belongs to the metric system (millimeter, centimeter, meter, ...) the export unit is the millimeter. If the current unit belongs to the Anglo-Saxon system (inch, foot, ...) he export unit is the inch.

So select the required type of session unit to export your data in one system or the other.
Limitations in the case of a multi-sheet drawing:

•

• • •

When there are several sheets, the name of the file really created is not that entered by the user in the Save as dialog box, since it is concatenated with that of the sheet. Therefore, it is not possible to check if a file with the same name already exists and any existing file will be overwritten without warning. If one of the sheets contains no geometry, no 2D IGES file is created. The number of characters of the name of the result file is limited to 150. If the name of a sheet contains one of the following characters or blank space, the character will be replaced with _ (underscore).

For more information, please refer to the Exported Sheets option
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Report File
After exporting the data to 2D IGES files, the system generates: • a report file (name_of_file.rpt) where you can find references about the quality of the transfer. the USERPROFILE variable on NT. Its default value is Profiles\ Systemes user \Local Settings\ Application \Data\ Dassault \CATReport on NT (user being you logon id)

These files are created in a location referenced by •

What About the Elements You Export?
All export options:

If the sheet to export contains no geometry, or only non supported entities, no IG2 file is generated. The visual clipping of views is not yet supported.
Structured export option only:

•

Dimensions are exported as graphic blocks and are editable as such.

Semantic export option only:

•

Linear dimensions are exported as true dimensions and editable as such.

Linear dimensions with: • • • • • • underlined text, text with frame, numerical values and decimal values given as fractions, funnels, half-dimensions, with an arrow pointing to the dimension line

are exported as sub-figures.

• •

The texts of those dimensions (linear only) are exported with the 2D IGES corresponding font. Circular, angular and curvilinear dimensions are still exported as graphic blocks.
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Semantic and Structured export options:

•

Show/No Show:

The V5 elements placed in the No Show are not exported. The visible elements are exported. • Layers:

In Structured and Semantic modes, layers are automatically exported. The number of the 2D IGES layer is the number of the V5 layer. • Filters:

To avoid missing geometries at export, we recommend that you activate either the filter All Visible or the filter None. • • • • • Texts: All texts are exported as texts (even dimension texts in the case of dimensions exported as graphic blocks and annotations), All texts are exported and mapped automatically with the 2D IGES corresponding font. Kanji characters are exported with the 2D IGES 2001 font. The line thickness is automatically mapped, based on V5 current thickness.

The table below sets the mapping between the CATDrawing file elements and the resulting IGES 2D elements.

V5 Element Sheet Interactive view Sub-type Graphic export Structures

2D IGES

Structured and Semantic ex

One 2D IGES file per sheet (see option) The structure is not exported. The structure is not exported. Note that raster views are not supported.

Views

The structure is not exported. All th geometric entities of the view are g into a single subfigure.

Generative view

The above applies to CGR, approxim views.

Note that raster views are not supp
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Detail (Component)

Ditto (Instance) Attributes Unit Show/NoShow Pick/NoPick Line Type Line Thickness Marker type Color Font Bold, italic Underlined Space (xText attributes scale) Height Justification Flip Frame Layer Dimension Not supported Annotations

Details are retrieved through their D Detail not referenced by a Ditto is t Detail referenced by several Dittos duplicated in subfigures. The entitie in a Detail are not structured into su The graphical representation of eac exported to a subfigure

The unit of the output file depends on the session current un Only visible elements are exported NoPick ignored Automatic mapping Automatic mapping Ignored Automatic color Default mapping Not supported Exported implicitly through the Text + line graphic representation of text. Space Only the contour of characters is Height exported. Justification Flip Text + geometry Layer Structured mode:

Linear

Each graphical representation of the The geometrical basic elements is exported to a subfigure of each representation are exported. If the representation Semantic mode: includes filled areas, only the contour is exported. Linear dimensions are exported as s Structured and Semantic mode:

Circular Angular Curvilinear Axis line Center Line Thread Welding symbol

Each graphical representation of the is exported to a subfigure Line with the suitable line type

Each graphical representation of th is exported to a subfigure. If representation includes filled areas
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Coordinate dimension Balloon Datum Target Datum Feature GDT Roughness symbol Table Leader Arrow Callout Text Area fill Pattern Hatching pattern Dotting pattern Coloring pattern Curve Point Line Polyline Circle Arc Spline NURBS Ellipse Hyperbola Parabola Constraints Miscellaneous OLE link Picture (bitmap...) Not supported Not supported The geometrical elements making the hatches are gathered into a subfigure

contour is exported.

One TEXT (or several TEXTS in case attribute changes) + geometry gath subfigure (see text attributes)

Only the contour of the hatches is Only the contour of the hatches is e exported into a subfigure Geometry POINT (116) LINE (110) 2D POLYLINE (106) CIRCLE (100) ARC (100) 2D POLYLINE (106) 2D POLYLINE (106) 2D POLYLINE OR ELLIPSE (104) 2D POLYLINE (106) 2D POLYLINE (106) Not supported

2D IGES: Report File
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Import Report File
In this report file (name_of_file.rpt), you will find information about • • • the file imported, the transfer options used, the mappings used,

and messages: • • status messages about eventual transfer problems for a given element, information messages written by the support teams.

Always check the report file after a conversion ! Some problems may have occurred without been

The first line created.

Name of the Name of the

General info

List of the o
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Status mess

See the Trou chapters on

Automatic c
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Summary of

In this exam transferred

See the Bes problems.

Transcriptio

Export Report File
In this report file (name_of_file.rpt), you will find information about • the file exported,
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•

the transfer options used,

and messages: • • status messages about eventual transfer problems for a given element, information messages written by the support teams.

Always check the report file after a conversion ! Some problems may have occurred without been

The first line indicate

Name of the input file Name of the output f List of the options us

The options may be c Status messages

This section is empty

Summary of the conv

In this example, 4 V5 so on.

Transcription time.
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2D IGES: Trouble Shooting
Import:
None

Export:
None

2D IGES: FAQ
Import
• • Question: In export/import loops, the format of the model is modified at the re-import in V5. Answer: the format is modified because V5 computes the best possible format to adjust it to the model. Question: How are associative dimensions dealt with? Answer: They are not supported.

• •

Export
• • Question: How are associative dimensions dealt with? Answer: They are not supported.

2D IGES: VBScript Macros
You can automate Data exchanges with IGES using VBScript macros, either at import or export,

Import
1. Create a RunTime window (window in which all runtime variables a set) 2. Type the command: cnext -macro MyMacro.CATScript where MyMacro.CATScript is the VBScript macro you want to execute • • The input files must be writable (not read only). Otherwise the system will display an information box and wait for an acknowledge. The output file must not exist in the output directory otherwise the system will ask for a confirmation to overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per macro.
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Example

VBScript Macro for implementing a IGES file

Language="VBSCRIPT" Sub CATMain() Dim Document0 As Document ' Reading an IGES file Set Document0 = CATIA.Documents.Open ( "E: ' Saving the corresponding CATDrawing CATIA.ActiveDocument.SaveAs "E: CATIA.Quit End Sub tmp tmp Box.igs" )

Box"

Export
1. Create a RunTime window (window in which all runtime variables are set): 2. Type the command: cnext -macro MyMacro.CATScript where MyMacro. CATScript is the VBScript macro you want to execute:

• •

The input files must be writable (not read only). Otherwise the system will display an information box and wait for an acknowledge. The output file must not exist in the output directory otherwise the system will ask for a confirmation to overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per VBScript macro.

Example

VBScript macro for exporting a Part file to IGES
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Language="VBSCRIPT" Sub CATMain() Dim DrawingDocument0 As Document ' Reading a CATDrawing file Set DrawingDocument0 = CATIA.Documents.Open ( "E: tmp draw.CATDrawing" ) ' Saving the Drawing in a 2D IGES file DrawingDocument0.ExportData "E: CATIA.Quit End Sub tmp draw2", "ig2"

2D IGES: Best Practices
Import
Quality of conversion

Always check the report file after a conversion ! Some problems may have occurred without been highlighted.

Export
None

DXF/DWG
Importing a DXF/DWG file into a CATDrawing
This task lets you quickly see how to import or to insert the 2D geometric data contained in a DXF file into a CATDrawing document. Once imported, the data can be handled and edited just as if they had been created in a Drafting session using 2D geometry creation commands. The table entitled What about the elements you import ? provides information on the entities you You can find further information in the Advanced Tasks: • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros
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and in the Customizing DXF/DWG Settings chapter. Statistics about each import operation can be found in the report file created. Open your session (Open your CATDrawing document if you want to insert a DXF file.).

1. To import an existing DXF/DWG file, select the File-> Open items. The File Selection dialog box is displayed: 2. Select the.dxf/.dwg extension from the field called Files of type. All .dxf/.dwg files contained in the selected directory are now displayed. 3. Click the .dxf/.dwg file of your choice. For example, click the draw1.dxf file. 4. Click Open.

1. To insert a DXF/DWG file in an existi document, elect the Tools -> Import External Fo The File Selection dialog box is displayed:

In import mode, a CATDrawing file is created which contains all the geometry included in the DXF/DWG file. This .CATDrawing file becomes the current document.

In insertion mode, the geometry of the DXF/ in a new view of the current sheet.

Import of multiple viewports and layouts

The default behavior has been improved for better results. If the model is referenced, at least par by one or several viewports, the model is not created in a sheet of its own. Only layouts are creat They will contain eventual viewports. CATIA does not create empty viewports or layouts. Viewport with a not null twist angle (group code 51) are not correctly handled during import.

Format
V5 determines systematically and automatically the most suitable format (A0 ISO, A1 ISO, etc.)

265

collaboration

for each sheet (layout) i.e. V5 chooses the smallest format in which the drawing can be totally inc • • • •

If the standard is ISO, V5 chooses the format among A0, A1, A2, etc. If the standard is ANSI, V5 chooses the format among A, B, C, etc. If no standard format fits the sheet, the format is set to the largest one i.e. A0 ISO and made invisible with a message "No standard format can be applied to this sheet" in the rep If you are not satisfied with this automatic result, use the Page Setup command to modify

Information on what has been determined automatically is written in the report file:

For more information on Formats, s ee the Defining a Sheet chapter in the Generative Drafting User's Guide.

Code pages
DBCS (Double Byte Character Set) Supported Code Pages are: • • • 932 (Japanese) 936 (Simplified Chinese) 950 (Traditional Chinese)

949 (Korean) is not supported.

Customization
Import of a DXF/DWG file can be improved by customization: DXF/DWG specific import settings are: • Standards. The lists of attributes are not the same in V5 and AutoCAD. A DXF mapping standard file is used to come as close as possible to the AutoCAD attribute or to switch them to V5 attributes.
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• • • •

Unit of the file Papers Spaces and Model Space Create end points Convert dimensions as

The definitions of dimensions are not the same in V5 and AutoCAD. This option is used to give priority either to the graphic closeness or to the re-usability in V5.

Report File
After the recovery of DXF/DWG files, the system generates: • a report file (name_of_file.rpt) where you can find references about the quality of the transfer the CATUserSettingPath USERPROFILE variable on NT. Its default value is Profiles \Data\ logon id) • \user \Local Settings \Application Dassault Systemes CATReport on NT (user being you

This file is created in a location referenced by •

the HOME variable on UNIX. Its default value is $HOME/CATReport on UNIX.

Always check the report file after a conversion ! Some problems may have occurred without been visually highlighted.

What About The Elements You Import ?
Version 5 supports DXF/DWG formats version 12,13, 14 and Autocad2000, Autocad2000i and Autocad2002.

To make sure the elements you need to handle in your session are those you expected, here is a list presenting the DXF/DWG data supported when imported into a CATDrawing file.

DXF/DWG element point

DXF/DWG subtype

V5 element Geometry Point

Notes
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collaboration line ray xline circle arc ellipse polyline/2D polyline/ lightweight polyline Line None None Circle Arc Ellipse Polyline

non adjustable width, made of line segments non adjustable width, made of line and arc segments adjustable width fit curve

Not editable in V5

segments and arc Structure is lost with no structure Filled area (pattern) Polyline Lines NURBS none none Annotations Text Text Structure is lost

mline spline 3D face 3D solid text mtext

Structure and closing attributes are lost Not editable in V5

Changing fonts, changing attributes and ine break are not taken into account

Arc aligned text rtext dimensions aligned, linear and rotated, radius and diameter, angular, ordinate (x or y)

none none According to option: dimension or details or

See dimensions In a few "dimensions" cases, the text of the dimension can be a text with an associative link

leader

tolerance hatch

non-associative associative

geometry+texts In all "dimensions" cases, the geometry support is in No Show Line + text DXF Leaders are imported as simple lines. The arrow head and the line under the text are lost none Filled area (pattern) Filled area The contour of the hatch is (pattern) created in the No Show and the associativity is created with this hidden
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group viewport Layout (paper space) OLE frame proxy region color Line weight line type point markers

none View Sheet none none none Attributes Color Line weight Line type Point type

The details are created in a new Detail Sheet named "Imported Details". If the insert is defined with different scales, on x-axis and y-axis, no detail instance is created but only the geometry is transferred. The structure of the group is lost whereas its contents is transferred see above see above

layer

Layer

see Standards see Standards see Standards Markers may be different since V5 and AutoCAD do not have the same markers. Invisible layers are gathered in a filter named Invisible Imported Layers. Visible layers are gathered in a filter named Visible Imported Layers. see Standards Automatic mapping The value of the attribute of the block is set to a default value The value of the attribute of the layer is applied to each element imported

font Pattern BYBlock attribute BYLAYER attribute

Font Pattern Attribute

Attribute
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Exporting a CATDrawing Document Data into a DXF or DWG File
This task quickly shows you how to export the data contained in a CATDrawing document into a DXF file. • Drawing Interchange Format (DXF) files enable the interchange of drawings between Generative Drafting Version 5 and Version 4 or with other programs. DXF files correspond to ASCII format and DWG to binary format. Version 5 provides a simple method to export the data contained in a CATDrawing document either in a DXF file or in a DWG file. Version 5 supports DXF/DWG formats version 12, 13, 14 and Autocad2000.

• •

•

You can find further information in the Advanced Tasks: • • • • • Trouble Shooting, Best Practices, FAQ, VBScript Macros. and in the Customizing DXF/DWG Settings chapter.

Open a CATDrawing document. 1. Select the File, Save As item. The Save As dialog box is displayed:
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2. Change the Format type into DXF type. 3. Enter the file name. 4. Press SAVE.

The export unit depends on the current unit of your session (see the Tools -> Options->Parameters and Measures/Units panel). • • If the current unit belongs to the metric system (millimeter, centimeter, meter, ...) the export unit is the millimeter. If the current unit belongs to the Anglo-Saxon system (inch, foot, ...) the export unit is the inch.

So select the required type of session unit to export your data in one system or the other.
Limitations in the case of a multi-sheet drawing:

•

• • •

When there are several sheets, the name of the file really created is not that entered by the user in the Save as dialog box, since it is concatenated with that of the sheet. Therefore, it is not possible to check if a file with the same name already exists and any existing file will be overwritten without warning. If one of the sheets contains no geometry, no DXF file is created. The number of characters of the name of the result file is limited to 150. If the name of a sheet contains one of the following characters or a blank space, the character will be replaced with _ (underscore).

You can customize the DXF specific export options: • • exported sheets (in the case of a multi-sheet drawing) version
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Report file
After the exporting data to DXF/DWG files, the system generates: • a report file (name_of_file.rpt) where you can find references about the quality of the transfer the USERPROFILE variable on NT. Its default value is Profiles\ \Data\ Dassault Systemes on NT (user being you logon id) • user \Local Settings \Application \CATReport

This file is created in a location referenced by •

the HOME variable on UNIX. Its default value is $HOME/CATReport on UNIX.

What About the Elements You Export?
All export options:

If the sheet to export contains no geometry, or only non supported entities, no DXF/DWG file is generated. The visual clipping of views is not yet supported.
Structured export option only:

•

Dimensions are exported as graphic blocks and are editable as such.

Semantic export option only:

• • • • • • • •

Circular, linear and angular dimensions are exported as true dimensions and editable as such. The texts of those dimensions are exported with the STANDARD style and the isocp.shx font. The tolerances of dimensions are now exported. The "upper" and "down" texts are not taken into account. Dual values are not exported. Half-dimensions are exported as simple dimensions (the visibility attributes of the extension lines and arrows are not exported). Circular extension lines are not exported. Half-dimensions are exported as graphic blocks.

Semantic and Structured export options:

•

Show/No Show:

272

CATIA Translators The V5 elements placed in the No Show are not exported. The visible elements are exported. • Layers:

In Structured mode, layers are automatically exported. The name of the DXF/DWG layer derives from the number of the V5 layer. • Filters:

To avoid missing geometries at export, we recommend that you activate either the filter All Visible or the filter None. • • Texts: All texts are exported as texts (even dimension texts and annotations) with a fit justification, All texts are exported with the STANDARD style and the isocp.shx font with the exception of geometric tolerance symbols that are exported with the GDT specific style and amgdt.shx font, with the corresponding mapping. The symbols diameter the standard tags. , degree , plus/minus are inserted with

•

• •

Unicode characters are exported with the tag. You have to redefine the STANDARD style in AutoCAD to reference an unicode font.

The table below sets the mapping between the CATDrawing file elements and the resulting DXF 2D elements.

V5 Element Sub-type Graphic export

DXF/DWG Structured and Semantic exp Structures One DXF file per sheet (see option)

Sheet Interactive view Views Generative view

The graphical representation of each file is transferred to the space model The structure is not The structure is not exported. exported.

Note that raster views The structure is not exported. All the geomet are not supported. the view are gathered into a single Insert/Blo
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Detail (Component) Ditto (Instance) Unit Show/NoShow Pick/NoPick Line Type Line Thickness Marker type Color Font Bold, italic Underlined Space (xText attributes scale) Height Justification Flip Frame Layer Dimension Linear Circular Angular

representation of text. Space

Note that raster views are not supported. Details are retrieved through their Dittos. A D referenced by a Ditto is thus lost, a Detail ref several Dittos is duplicated in BLOCKS. The e in a Detail are not structured into sub-blocks The graphical representation of each Ditto is INSERT/BLOCK Attributes The unit of the output file depends on the session curren Only visible elements are exported NoPick ignored Automatic mapping Automatic mapping Ignored Automatic color Default mapping with font isocp.shx (fixed) For Kanji or unicode characters see Trouble S Not supported Exported implicitly Text + line through the graphic

Height Only the contour of characters is exported. Justification Flip Not supported Text + geometry Layer Annotations Structured mode:

Curvilinear Axis line Center Line Thread Welding symbol Coordinate dimension Balloon Datum Target Datum Feature GDT 274

Each graphical representation of the element The geometrical basic an INSERT/BLOCK elements of each representation are Semantic mode: exported Linear, angular and circular dimensions are e In both modes, each graphical representation is exported to an INSERT/BLOCK Line with the suitable line type Each graphical representation of the elemen an INSERT/BLOCK

CATIA Translators Roughness symbol Table Leader Arrow Callout Text Area fill Pattern Hatching pattern Dotting pattern Image pattern Colouring pattern Point Line Polyline Circle Arc Spline NURBS Ellipse Hyperbola Parabola The geometrical elements making the hatches are gathered into an INSERT/BLOCK Only the contour of the hatches is exported

One TEXT (or several TEXTS in case of font o changes) + geometry gathered into an INSE text attributes)

Only the contour of the hatches is exported i INSERT/BLOCK Geometry

Curve

Constraints OLE link Picture (bitmap...)

POINT LINE 2D POLYLINE CIRCLE ARC 2D POLYLINE 2D POLYLINE 2D POLYLINE OR ELLIPSE 2D POLYLINE 2D POLYLINE Not supported Miscellaneous Not supported Not supported

DXF/DWG: Report File

Import Report File
In this report file (name_of_file.rpt), you will find information about • • • the file imported, the transfer options used, the mappings used,

and messages:
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• •

status messages about eventual transfer problems for a given element, information messages written by the support teams.

Always check the report file after a conversion ! Some problems may have occurred without been

The first line in created.

Name of the in Name of the ou

List of the opti

The options ma

Status messag

See the Troubl FAQ chapters o

The syntax of those messages is the following: <E> Type "hatch" Identifier "8434" This element was not transferred Message Type Element Type Identifier Element Status/Information Text Message Type is either Error, Warning or Information. • • • Error means that there is a failure. Warning means that there may be a failure. Information informs you of the possible cause of failure.
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Element Type is the type of the DXF/DWG element processed. Element Handle is the hexadecimal number referencing the DXF/DWG element processed. Element Status/Information Text is the informative part of the message.

Automatic cho

List of the map line types and The mappings

Only those act • •

The report file does not yet indicate whether the mapping is the default one or a customize There is no information yet about an automatic Thickness/Thickness mapping.
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Summary of th

In this exampl successfully, a

See the Troubl FAQ chapters o

Transcription t

Export Report File
In this report file (name_of_file.rpt), you will find information about • • the file exported, the transfer options used,

and messages: • • status messages about eventual transfert problems for a given element, information messages written by the support teams.

Always check the report file after a conversion ! Some problems may have occurred without been
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The first line indicates

Name of the input file Name of the output file List of the options use

The options may be ch Status messages

This section is empty a

Summary of the conve In this example, 4 V5 so on.

See the Trouble Shoot

Transcription time.

DXF/DWG: Trouble Shooting
Import
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The imported file is either too small or too large. A DXF/DWG file does not contain its units. You must enter the unit used for the creation of the file to import it at the correct scale. 1. Select the Tools->Options... command. 2. Select the General category, then the Compatibility category, then click the DXF tab. 3. Enter the unit of the DXF/DWG file. For more information, see Import with Unit.

Export
When working with CATIA Version 4, if you open a DXF or DWG file created in Version 5, you need to set the curve tolerance to 0.0001 (0.1 as default). If some elements are missing, make sure that the All Visible or the None filter is activated and restart the export. Exported Kanji or unicode characters may be missing or displayed incorrectly after opening the DXF/DWG file in the receiving system. In order to visualize them, edit the the textstyle STANDARD in this system and associate the font associated to this style to an unicode font.

DXF/DWG: FAQ
Import
• • Question: In export/import loops, the format of the model is modified at the re-import in V5. Answer: the format is modified because V5 computes the best possible format to adjust it to the model. Question: How are associative dimensions dealt with? Answer: They are not supported. Question: There is some inconsistency between graphic and semantic import: Answer:There may be an inconsistency between the results of dimensions imported with the semantic preserving option and with the graphic preserving option.

• • • •
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This is generally due to an inconsistency in the DXF/DWG file itself (the aspect is different in AutoCAD14 and AutoCAD2000). This happens with files that have not been generated with AutoCAD. Usually, the graphic mode should be used, but only the author of the file can confirm it. • • Question: The R of a radius dimension is a conglomerate of a P with a small : Answer:The DXF model is probably the result of a graphic export. In this case, texts are no real texts but geometry. Question: There is a problem of alignment of DIMtext to DIMline: Answer: This occurs while opening a DXF file created with ANSI standard using an ISO standard (or vice-versa). Since V5R9, texts of dimensions without overloaded text and without tolerance are imported directly as DIMtext instead of texts with positional link, avoiding thus the problem of positioning. Since V5R14, you can select the required Drawing standard in the Settings. Question: Hatches: The result of import is a geometry instead of a filled area: Answer:The original DXF/DWG file does not contain real hatches but geometry (or old R12 hatches, i.e. blocks). Real hatches are mapped automatically. Question: Fonts: Problems with ... characters: Answer: o Use the standards and settings to map AutoCAD and the fonts you use. True Type fonts on Windows provide the same fonts in your system and AutoCAD. Question: Fonts: Texts are larger than their frame: Answer: a ratio is available in the TextFontMapping section of the DXF standard. Question: The entities visible are not those expected: Answer: All DXF/DWG invisible layers are gathered in a CATIA V5 filter named Invisible Imported Layers. All DXF/DWG visible layers are gathered in a CATIA V5 filter named Visible Imported Layers.

• • •

• • •

• •

•

• •

• • • •

If the expected entities are not visible, activate the Visible Imported Layers filter, or if too many entities are visible, activate the Invisible Imported Layers filter.
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Export
• • Question: How are associative dimensions dealt with? Answer: They are not supported.

DXF/DWG: VBScript macros
You can automate Data exchanges with DXF using VBScript macros either at import or export.

Import
1. Create a RunTime window (window in which all runtime variables a set) 2. Type the command: cnext -macro MyMacro.CATScript where MyMacro.CATScript is the VBScript macro you want to execute The input files must be writable (not read only). Otherwise the system will display an information box and wait for an acknowledge. • The output file must not exist in the output directory otherwise the system will ask for a confirmation to overwrite the file and wait for an acknowledge. You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per VBScript macro. •

Example
VBScript macro for implementing a DXF file Language="VBSCRIPT" Sub CATMain() Dim Document0 As Document ' Reading an DXF file Set Document0 = CATIA.Documents.Open ( "E: tmp Box.dxf" )
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' Saving the corresponding CATDrawing CATIA.ActiveDocument.SaveAs "E: CATIA.Quit End Sub tmp Box"

Export
1. Create a RunTime window (window in which all runtime variables are set): 2. Type the command: cnext -macro MyMacro.CATScript where MyMacro. CATScript is the VBScript macro you want to execute. The input files must be writable (not read only). Otherwise the system will display an information box and wait for an acknowledge. The output file must not exist in the output directory otherwise the system will ask for a confirmation to overwrite the file and wait for an acknowledge.

You can transfer several files within the same VBScript macro, but it is recommended to do only one transfer per VBScript macro.

Example
VBScript macro for exporting a CATDrawing file to DXF Language="VBSCRIPT" sub CATMain() Dim PartDocument0 As Document ' Reading a CATDrawing file Set PartDocument0 = CATIA.Documents.Open ( "E: tmp Box.CATDrawing" ) ' Saving the part in a DXF file PartDocument0.ExportData "E: CATIA.Quit End Sub tmp Box2", "dxf"
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DXF/DWG: Best Practices
Import
Quality of conversion

Always check the report file after a conversion ! Some problems may have occurred without been visually highlighted. When importing a DXF/DWG file, the display of small entities may depend on zoom factor. To see the complete Drawing regardless of their size: 1. Go to the Tools->Options->General->Display->Performance tab. 2. Switch the value of Level of detail/static to zero. All geometries become visible. For more information, see Performance.

Export
None

DXF-IGES-STEP Batch Processing
You will use this task to: • • recover several STEP, 3D or 2D IGES or DXF files from another system to V5, export several V5 files to STEP, 3D or 2D IGES or DXF,

in one shot.

• • • • • •

STEP files are transferred as CATPart or CATProduct, IGES files are transferred as CATPart, DXF/DWG and 2D IGES files are transferred as CATDrawing, V5 CATPart, CATProduct and CATShape files can be exported to STEP or 3D IGES, CATDrawing files are exported to DXF/DWG or 2D IGES files. Transfers are done with the options you have set (for more information, see IGES, STEP, DXF and IGES 2D settings).

• •

Remote mode is not available for the export of CATProducts to STEP or IGES format. Define output parameters before adding the input files (the type of the input files proposed depends on the choice of the output file type you
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CATIA Translators have made). You can mix import and export, and STEP, 3D or 2D IGES or DXF in one process, or send the output files in several output directories. In those cases, define the output parameters for the first batch of input files, then add those input files, and repeat those steps as many times as necessary. Only existing output directories can be selected. If the output directory no longer exist when you run the batch process, a message will warn you. You can not change the output parameters for a file once you have added it to the list. However, you can delete it from the list, define new output parameters and add the file again.

• • • • •

You need the corresponding DXF/DWG, 2D or 3D IGES and/or STEP interface licences to process DXF/DWG, 2D or 3D IGES and/or STEP files with the Batch Monitor, even though you can access the Batch Monitor and the Batch-DXF-IGES-STEP line, and save your batch parameters as a .xml file, without those licences present. If the required licences are not present when you run the process, a message will invite you to check the log file. Files with corresponding licences present will be processed, the other will not.

1. Start the Batch Monitor (see Version 5 Infrastructure User's Guide).

2. Double-click Batch-DXF-IGES-STEP. The Batch-DXF-IGES-STEP dialog box is displayed.
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3. Define the Output directory: Press the ... button and browse your computer to select the output directory. You can choose one output directory for one, several or all the input files.

4. Select the type of the output file. It can be the same for all the input files or not.
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5. Push the Add file(s) button and select one or several input files.

The file is added to the list of files to process.

To delete a file from the list, select it in the list. The Delete file(s) button becomes available. Push it to delete the file. You can also select several files using Windows selection tools. Note that the list of file extensions proposed in the Files of type field depends of the Output file type selected, in order to avoid incoherencies in the process. You may keep the same Output directory or the same Output file type for all files, or modify them before adding a new (or several) file. 6. Push the Options button. A dialog box is displayed with the options available for IGES, STEP, DXF and IGES 2D. Your changes will replace the current settings.
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7. You can: o Click the Licensing Setup... button and select a license authorizing the use of the batch you want to run. If you run a batch without previously selecting a license, the system reads the License.CATSettings file and tries to run the batch with the licenses found in this file. If you do not succeed in running the batch due to a licensing problem, click the Licensing Setup... button and select a license from the list. When you click on this button, the system searches for both nodelock licenses installed on your computer and network licenses accessible from your computer and displays the list of licenses found. The list displayed will contain the same licenses visible in the Tools->Options->Licensing tab. Then, select the appropriate license from the list. The license is only acquired temporarily for the duration of the batch execution. push the Run button to process the files immediately. Check the required option Run Local or Run Remote (in that case enter the name of the remote machine) or push the Save button to save the process as a .xml file and run it later (see Version 5 Infrastructure User's Guide), or push the Cancel button to exit the process without saving or running it.

o

o o
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8. At the end of the batch process, you can check the result in the Processes tab of the batch monitor, in the column Information (Succeeded or Batch ERROR:...) Double-click on the name of the batch process to display the corresponding log file. This file lists the name, path and type of the input file. Then either the name and path of the file created (Transfer OK - Created file :...) or the reason of the failure (e.g. Impossible to open...) and the number of failures (Number of Error(s) occurred during the Batch processing :) This process is successful:

There are errors in this process:
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CGM
Inserting a CGM file into a CATDrawing
This task will show you how to insert a cgm file into a CATDrawing document. Open your session. Open your CATDrawing document

1. Select the Tools-> Import External Format item. The Import dialog box is displayed: 2. Select the .cgm extension from the field called Files of type.

3. Click the CGM file of your choice. 4. Click Open.

If you use the command File -> Open (you must select the .cgm extension from the field called Files of type), you only browse the CGM files.
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Exporting a CGM File
This task lets you quickly see how to export the data contained in a CATDrawing document into a CGM file. Open the CATDrawing document to be exported into a CGM file. 1. Select the File -> Save As item. The Save As dialog box is displayed:

2. Change the Save as type into CGM type. 3. Enter the file name. 4. Press Save.
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Exporting CATPart Data to an STL File
This task shows you how to save your part as an STL (stereolithography) document (.stl). 1. Select the File -> Save As... command. 2. In the Save As dialog box, select the location of the document to be saved. 3. Click the Save as type: list. 4. Select the stl type from the list displayed.

5. Click Save to confirm the operation and quit the command.

STEP Plug-in
Requirements
• • • Never modify data generated in V5: information could be lost and the MULTICAD Update could result in incorrect results. Be sure you have set the option Insert existing component to MultiCAD mode in Tools->Options->General->Compatibility->STEP Part Number must be unique, all parts with the same name are considered as identical.
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The MULTICAx STEP Plug-in allows you to import STEP native data (*.stp or *.step) (part and assembly models). This import converts STEP part geometry into the CATIA Graphical Representation (CGR) or CATPart formats, which renders it readable by V5. The MULTICAx STEP Plug-in imports STEP assembly files into a V5 product structure document. You can perform this import interactively or from the command line.

Protocols and attributes
For conversions, the following protocols or attributes apply: • • The STEP part files must have the *.stp or *.step extension See the STEP import section in the Data Exchange Interfaces User's Guide for more information.

Licensing requirements
*.stp *.step extensions are not natively supported in V5, therefore, DTL licenses (ENOVIA PORTAL, CATIA) or MTP licences (DELMIA) are required to access these extensions.

Methodologies and Advice
293

collaboration This section provides information regarding supported features and limitations when using STEP data in CATIA V5, which users should be familiar with prior to configuring and using STEP Plug-in.

Output Formats
When importing Multi-CAD data within CATIA V5, a conversion is performed. Depending on the use of data you are going to have, you can choose whether to create a cgr, CATPart. With all these formats you can access to part user attributes using Edit -> Properties: • • • Move the data (cf. limitations to move due to the associative mode) Clash detection Inertia and Volume calculations

Each format has its own limitations and advantages: • • cgr (CATIA Graphical Representation) is the visualization format of CATIA V5. With this very light format, you can do approximate measurement and have access to all the basic DMU functionalities. CATPart (CATPart mode). It is a standard V5 CATPart which is locked, therefore you can use it as any other CATPart with the exception that you cannot modify it. You can just reference it.

Supported Features
• • • • • • Access to part user attributes (via Edit->Properties) Move Exact positioning - Snap command - when using CATPart Mode Clash detection Approximate measurements (or exact measurement with a CATPart) Inertia and volume calculations

Limitations
• • Approximate snap is not working in some cases. Support for filtering of blanked objects is not available, therefore all blanked objects will be converted.

Step entities that are not converted
• • Groups Layers

Using CATPart Mode versus Visu Mode
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The MULTICAx STEP Plug-in supports CATPart mode, allowing for STEP parts to be imported as CATPart data files. In this mode, STEP parts data contained in the solid body are transferred into a CATPart. As CATPart files are large and take more time to convert, the CATPart mode management is an optional feature.

CATPart Features and Limitations
The features and limitations of Multi-CAD CATParts are the same as the ones of locked V5 CATParts, which can be used as a reference but cannot be modified.

When to use the CATPart Mode
CATPart Mode is used when a user needs to perform exact positioning and exact measuring. You should be aware that CATPart files are larger than their corresponding CGR files. Therefore, it is recommended that CATPart mode is only enabled if exact positioning, exact measurement or putting constraints is required.

Initializing the Environment
• • • When installing the MultiCAx media, all the references will be made to CATIA. This is not a problem and will not affect the product behavior. But it will create shortcuts and environment with CATIA names. Activating the cache does not modify the performances of an interactive insert since the data are not generated in the cache but in the directory referenced by the setting Output Path. The cache is only useful in CATPart mode so that the CATPart generated is not loaded by default (but this does not affect the conversion performances).

Importing STEP Data
Importing Part or Assembly Files Interactively
This task shows you how to import STEP parts or assemblies into a product structure document. • A product structure document (either new or previously created) must be visible to import data interactively. • Some STEP entities are not converted to V5. Click here for more information.
General Notes

•

An alternative method to performing steps 2 and 3 is to select the product with the left mouse button, then, from the menu bar, select Insert ->
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3. Select Existing Component. A dialog box appears, such as the one shown below.

4. Set the file type to .stp or .step and navigate to the directory where the desired STEP part or assembly files are present. 5. Select the part or assembly file to be imported. Click the Open button. The selected part or assembly appears under the selected product in the product structure. In the example below, the product selected in step 2 was axel.2 (highlighted in 296
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In the example below, Product 1 was the product selected in step 2; auto.stp was the assembly selected in step 5.

• •

When a STEP assembly is described using STEP external refenreces, the generated CATPart or cgr files have the name of the corresponding STEP files. When a STEP assembly is described in a single file (which contains product structure and geometry), the CATPart/cgr file have automatic names. These names are : the name of the STEP file followed by "_NPart" and a number. Example:STEPasmFile_Npart3.CATPart
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Translating files from the Command Line

This procedure describes how to run the CATDMUUtility batch program to import STEP files from the command line. The CATDMUUtility is a batch process enabling the generation of .CATProduct, .cgr and CATPart formats from STEP files. Some STEP entities are not converted to V5. Click here for more information. The following examples show typical arguments and command switches passed to the CATDMUUtility batch:

Converting a STEP part to a V5 cgr file CATDMUUtility -f InputPartFile -cgr OutputCgrFile Converting a STEP part to a V5 CATPart file CATDMUUtility -f InputPartFile -part OutputPartFile Converting a STEP assembly to a V5 CATProduct file CATDMUUtility -f InputProductFile -product OutputCATProductFile
Options

Input and output options that can be used with CATDMUUtility are described below. Input Options -f Input file with appropriate extension. A path must follow this option. For STEPparts and assemblies, the file extension should be .prt. Output Options -cgr Output file for cgr corresponding to a part input file. -part Output file for CATPart corresponding to a part input file. -product Output file for CATProduct corresponding to the STEP assembly input file. Other options The other options available for conversion are settings which correspond to the environment. These are defined in Tools -> Options -> General -> Compatibility -> External Formats (In particular, the use of cgr or CATPart can be customized in these options) or STEP Settings.
How to run the batch

In a command prompt window, the conversion batch is launched by entering the following command: On "C: <install_dir> intel_a code bin CATDMUUtility.exe" WINDOWS -env CATIA.V5R13.B13 -direnv "C: Winnt Profiles All Users E: On UNIX 298 Application Data tmp Dassault Systemes CATEnv" -f assembly_file.stp -product

E: tmp prod1.CATProduct <install_dir>/<os>_a/code/command/catstart -env

CATIA Translators CATIA.V5R13.B13 -direnv /CATEnv -run "CATDMUUtility -f /tmp/assembly_file.stp -product /tmp/prod1.CATProduct"

Where -env ... is the default environment -direnv ... is the directory path containing this environment. CATIA.V5R13.B13 is an example of environment name, it will vary with the level of CATIA installed. Please note that this conversion will take into account the settings in Tools -> Options -> General -> Compatibility -> External Formats and STEP Settings.

Improved Associativity Support on Multi-CAD Data
This section describes the concept of associative mode and how it works. Associativity applies to the document level, not to the geometry level. If you perform a MultiCAD update, all applicative links will be broken.

How associative mode works
When the conversion batch (CATDMUUtility) is run on STEP data, STEP files are converted and stored in V5. However, the sources of the part files are not visible to the user, and the CGR files are not placed in cached memory -only the 3D view can be seen by the user. When a batch conversion is performed on an assembly, the assembly is transferred into a CATProduct file in the V5 format. Each individual part contained in the assembly is converted to a CGR or CATPart. During this conversion, the assembly structure, geometrical information and original links are all transferred into the V5 format. After the conversion, the CATProduct reproduces the 3D View of the original assembly and also stores a link to the original files. The established link will enable the Multi-CAD update batch to determine whether the imported V5 files are up to date compared with their original data. The following schema draws a parallel between the CAD system and V5. Step 3 corresponds to the modification or review of imported CAD data in V5.

From the import of CAD data to the synchronization of the V5 session
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The update batch (CATMCIReplace) is used to initiate the associative mode. This batch operates on V5 data to update the structure or geometry according to any changes made to the original data by the STEP designer. • If a STEP part file has been modified, the update batch can be run on the CATProduct so that the part file (i.e., not the whole assembly structure) is reconverted and the V5 f h STEP i l d Th l b b l
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•

The following schema illustrates the conversion and update processes of an assembly structure when importing CAD data into V5:

MultiCAD conversion and update processes

The associative mode is the default mode. Associative mode is useful when a user wants to maintain synchronization with structure and/or geometry changes If you prefer to keep your assembly as it was at the moment of
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Using the update batch to maintain associativity
This task describes how to convert STEP assemblies into V5 CATProducts, and how to maintain the associativity between modified CAD data and the converted product files in V5. 1. In a command prompt window, the conversion batch is launched by entering the following command: On "C: <install_dir> intel_a code WINDOWS CATIA.V5R13.B13 -direnv "C: Winnt Data Dassault Systemes tmp bin Profiles tmp CATDMUUtility.exe" -env All Users Application assembly_file.stp -

CATEnv" -f E:

product E:

prod1.CATProduct

On UNIX

<install_dir>/<os>_a/code/command/catstart -env CATIA.V5R13.B13 -direnv /CATEnv -run "CATDMUUtility -f /tmp/assembly_file.stp -product /tmp/prod1.CATProduct

Where -env ... is the default environment and -direnv ... is the directory path containing this environment. CATIA.V5R13.B13 is an example of environment name, it will vary with the level of CATIA installed.

Please note that this conversion will take into account the settings in Tools -> Options -> General -> Compatibility -> External Formats and STEP Settings 2. In the original CAD system, modify a STEP part contained in assembly_file.stp. 3. Launch the update batch by entering the command: On C: <install_dir> intel_a WINDOWS CATIA.V5R13.B13 -direnv "C: Data Dassault Systemes update code Winnt bin CATMCIReplace.exe" -env All Users Application tmp prod1.CATProduct -

Profiles

CATEnv" -i E:

On UNIX

<install_dir>/<os>_a/code/command/catstart -env CATIA.V5R13.B13 -direnv /CATEnv -run "CATMCIReplace -i /tmp/prod1.CATProduct -update"
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If prod1.CATProduct is opened interactively in V5, the geometry modification will be visible. For more information about the CATDMUUtility program, please refer to Running CATDMUUitlity Batch Process in the DMU Navigator's User Guide.

Snapping Imported Components
This section describes how to activate and use CATPart support interactively, with the Snap command. The Snap command projects the geometric element of a component onto another geometric element belonging to the same or to a different component. Using this command is a convenient way to position components relatively to each other. Please note that the structure of a MultiCAD assembly must never be modified. Never move parts inside the assembly! You may only position the assembly relatively to another one. 1. Click the Snap button .

Once the Snap command has been activated, axis, planes or coordinate systems can be selected. Please refer to the Snapping Components section of the DMU Navigator User's Guide for a complete description of snap functionality. 2. Select an axis on Part4 (Part4.1):
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3. Select an axis on Part3 (Part3.1):

The result is: 304

CATIA Translators

•

The CATPart files will be written out into the directory indicated by the Output path section of the Tools -> Options -> General -> Compatibility -> External Formats.

Checking and Updating the Status of Assemblies
This task shows you how to check the Update Status of elements of an assembly. • This command is available in CGR and CATPart modes. • We strongly recommend that you save all documents before launching the command! • Modified elements with a time stamp preceding that of the elements checked are not taken into account.

1. Open the Tools > Customize dialog box. Go to the Commands tab and select the All Commands category. 2. In the Commands list, select Update Status Checker and drag and drop the command into a toolbar.
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3. Push the Update Status Checker icon specification tree.

and pick a node in the

The Update Status Checker checks the status of the components at this node level. If the components are up to date, the light remains green and the message Nothing to update is displayed in the dialog box.
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If original elements have been modified and the imported elements are not up to date, the light turns red, the elements to update are listed in the dialog box (with their name, location of the original file and date of modification). A message explains how to update the elements. If you select a line in the To update list, the corresponding element is highlighted in the specification tree.
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4. Push the update button field are updated. 5. Push Close to exit the action.

. All the elements listed in the To update

You can repeat this control on different nodes of the same specification tree, i.e. at different levels of the assembly. The control will start at this level. Note that in CGR mode, as the assembly information are gathered at the root level of the assembly, any update information will refer to this root level whereas in CATPart mode the update information will refer to the actual level of the modification.

Removing MultiCAD Links
This procedure describes how to remove the MultiCAD links, i.e. to switch from the MultiCAD mode (where updates from original data are available and the data generated in V5 are in Read Only mode) to the Translator mode (where updates from original data are not available and the data generated in v5 are in Read/Write mode). This switch is not reversible! You must have the licences for the MultiCAD plug-in and the corresponding translator.
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1. Open the Tools > Customize dialog box. Go to the Commands tab and select the All Commands category. 2. In the Commands list, select RemoveMultiCADLinks and drag and drop the command into a toolbar.

3. Push the RemoveMultiCADLinks icon and select a product or a part. A dialog box is displayed that shows all the MultiCAD links to be broken.

3. Click OK to delete the links and unlock the data.
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Replacing MultiCAD Links
This procedure describes how to replace interactively broken MultiCAD links. This can also be done in batch mode, by launching the utility CATMCIReplace -i E:\path_to_product\top.CATProduct without the -update switch. It will automatically replace the broken link. Broken links can occur when : • • a MultiCAD conversion is launched in batch mode, impacting a document which is referenced by another V5 assembly. a MultiCAD update is performed on a part referenced by another assembly.

The conversion changes the unique Id of the updated part, and the referenced document which have the Id saved in the aggregating product no longer exists. Broken links also occur when a file is replaced by another one in the file system, with the same file name (but different Id). The command looks for a document in the current directory which have the same file name as the one stored in the product structure. If the search succeeds, the command replaces all references to the old part by references to the new one in the aggregating product. 1. Open the Tools > Customize dialog box. Go to the Commands tab and select the All Commands category. 2. In the Commands list, select Remove link and drag and drop the command into a toolbar.
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3. Push the Remove link icon • • Nothing appears if there is no broken link. If a broken link is found and replaced, a dialog box like this appears:

•

If a broken link is found but cannot be replaced, a dialog box like this appears:
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IGES PLug-in
Overview
Welcome to the MULTICAx IGES Plug-in User's Guide! This guide is intended for users who need to become quickly familiar with the product. This overview provides the following information: • • • • • MULTICAx IGES Plug-in in a Nutshell Before Reading this Guide Getting the Most Out of this Guide Accessing Sample Documents Conventions Used in this Guide

MULTICAx IGES Plug-in in a Nutshell
The MULTICAx IGES Plug-in allows users to import IGES native data (part models). This import converts IGES part geometry into the CATIA Graphical Representation (CGR) or CATPart formats, which renders it readable by V5.

Before Reading this Guide
Prior to reading the MULTICAx IGES Plug-in User's Guide, you are recommended to have a look at the Infrastructure User's Guide for information on the generic capabilities common to all products.

Getting the Most Out of this Guide
To make the most out of this book, we suggest that a beginning user reads the Requirements chapter first of all and the other Users Tasks to find his way around the MULTICAx IGES Plug-in.

Accessing Sample Documents
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Requirements
• • Never modify data generated in V5: information could be lost and the MULTICAD Update could result in incorrect results. Part Number must be unique, all parts with the same name are considered as identical. On Windows, make sure the files to translate are not encrypted: push the Advanced button in the Properties dialog box of the file and uncheck the Encrypt contents to secure data option.

•

The MULTICAx IGES Plug-in allows you to import IGES native data (part models). This import converts IGES part geometry into the CATIA Graphical Representation (CGR) or CATPart formats, which renders it readable by V5. You can perform this import interactively or from the command line.

Protocols and attributes
For conversions, the following protocols or attributes apply: • • The IGES part files must have the .igs extension see the IGES import section in the Data Exchange Interfaces User's Guide documentation for more information.
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Licensing requirements
*.igs extension is not natively supported in V5, therefore, the licenses DGL (ENOVIA PORTAL, CATIA) or MGP (DELMIA) are required to access this extension.

Methodologies and Advice
This section provides information regarding supported features and limitations when using IGES data in CATIA V5, which users should be familiar with prior to configuring and using IGES Plug-in.

Output Formats
When importing Multi-CAD data within CATIA V5, a conversion is performed. Depending on the use of data you are going to have, you can choose whether to create a cgr, CATPart. With all these formats you can access to part user attributes using Edit -> Properties: • • • Move the data (cf. limitations to move due to the associative mode) Clash detection Inertia and Volume calculations

Each format has its own limitations and advantages: • • cgr (CATIA Graphical Representation) is the visualization format of CATIA V5. With this very light format, you can do approximate measurement and have access to all the basic DMU functionalities. CATPart (CATPart mode). It is a standard V5 CATPart which is locked, therefore you can use it as any other CATPart with the exception that you cannot modify it. You can just reference it.

Supported Features
• • • • • • Access to part user attributes (via Edit->Properties) Move Exact positioning - Snap command - when using CATPart Mode Clash detection Approximate measurements (or exact measurement with a CATPart) Inertia and volume calculations

Limitations
• • Approximate snap is not working in some cases. Support for filtering of blanked objects is not available, therefore all blanked objects will be converted.

IGES entities that are not converted
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•

• • •

Wireframes : composites curves (type 102) , polilynes (type 106 form 11, 12,13, 63), bspline curve (type 126), circles and circular arcs (type 100), conic arcs (type 104), lines (type 110) , parametric spline curve (type 112), offset curves (type 130), and all independent curves. Copious Data Entity - Type 106 form 1,2 ,3, Associativity Instance Entities - Type 402, Layers.

Using CATPart Mode versus Visu Mode
The MULTICAx IGES Plug-in supports CATPart mode, allowing for IGES parts to be imported as CATPart data files. In this mode, IGES parts data contained in the solid body are transferred into a CATPart. As CATPart files are large and take more time to convert, the CATPart mode management is an optional feature.

CATPart Features and Limitations
The features and limitations of Multi-CAD CATParts are the same as the ones of locked V5 CATParts, which can be used as a reference but cannot be modified.

When to use the CATPart Mode
CATPart Mode is used when a user needs to perform exact positioning and exact measuring. You should be aware that the conversion to the CATPart format requires more time than only generating the CGR (faceted format). In addition, CATPart files are larger than their corresponding CGR files. Therefore, it is recommended that CATPart mode is only enabled if exact positioning, exact measurement or putting constraints is required.

Initializing the Environment
• • • When installing the MultiCAx media, all the references will be made to CATIA. This is not a problem and will not affect the product behavior. But it will create shortcuts and environment with CATIA names. Activating the cache does not modify the performances of an interactive insert since the data are not generated in the cache but in the directory referenced by the setting Output Path. The cache is only useful in CATPart mode so that the CATPart generated is not loaded by default (but this does not affect the conversion performances).
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IGES Importing
Importing Part Files Interactively
This procedure describes how to import IGES parts into a product structure document. After using this procedure, your IGES files will be imported into a product structure document. The following pages give you an example about importing IGES files interactively. Some IGES entities are not converted to V5. Click here for more information. 1. Open an empty or existing product structure document. 2. On the product structure document, use the right mouse button to select the product under which the IGES part is to be imported. A menu appears.
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3. Select Components -> Existing Component. A dialog box appears, such as the one shown below, with parts files:
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4. Navigate to the directory where the desired part files are present. 5. Select the part to be imported and click the Open button (or double-click the part). The selected file appears under the selected product in the product structure. In the example below, the product selected in step 2was Product1 (highlighted in orange); the part selected in step 4 was Cigogne.igs.

Translating Files from the Command Line
This procedure describes how to run the CATDMUUtility Batch. The CATDMUUtility is a batch process enabling the generation of .CATPart, .cgr formats from IGES. Some IGES entities are not converted to V5. Click here for more information. The following examples show typical arguments and command switches passed to the CATDMUUtility batch:
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Converting a IGES part to a V5 CATPart file

CATDMUUtility -f InputPartFile -part OutputPartFile
Options

Input and output options that can be used with CATDMUUtility are described below. Input Options -f

Input file with appropriate extension. A path must follow the option. For IGESpart, the extension file should be .igs,

Output Options -cgr

Output file for cgr corresponding to a part input file. Output file for CATPart corresponding to the part input file.

-part Other options

The other options available for conversion are the settings corresponding to the environment. They are defined in Tools -> Options -> General -> Compatibility -> External Formats and IGES. In particular, the use of cgr or CATPart can be customized in these options. For more information see Customizing External Formats in CATIA Infrastructure User's Guide and IGES Settings.

How to run the Batch

Run the following shell to start the batch process : 1. Write a shell script containing the following lines: "C: <install_dir> intel_a code Winnt bin CATDMUUtility.exe" Profiles All CATEnv" -f

-env CATIA.V5R13.B13 -direnv "C: Users Application Data inputfile -cgr outputfile1 2. Run the shell. Where -env ... is the default environment

Dassault Systemes
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-direnv ... is the directory path containing this environment. CATIA.V5R13.B13 is an example of environment name, it will vary with the level of CATIA installed.

Improved Associativity Support on Multi-CAD Data
This section describes the concepts of improved associative support on Multi-CAD data in Batch mode, and discusses the conditions under which this associativity can be guaranteed. Associativity applies to the document level, not to the geometry level. If you perform a Multi-CAD update, all applicative links will be broken.

How associative mode works
When launching the Conversion Batch on Multi-CAD data, Multi-CAD files are converted and stored but this information (source or origin of the part files) cannot be visible by the user and CGR files are not stored into Cache Memory. Only the 3D view can be seen by the user. By doing a batch conversion over an IGES part, this part is transferred into a V5 format file: a CATPart. During this transcription, all the part structure, geometrical information as well as original links are transferred. After this conversion, the CATPart reproduces the 3D View of the original part and also stores a link onto the original file. The last information will enable the Multi-CAD Update Batch to check if V5 data are up-to-date compared with their original data. The following schema draws a parallel between the CAD System and CATIA V5. Step 3 corresponds to the modification or review of Imported CAD Data in CATIA V5.
From the Import of CAD data to the Synchronization of V5 Session:
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Launching the Update Batch means using the associative mode; the Batch operates on V5 data in order to update their structure or geometry according to the changes made by the Acis designer onto the original data. Here is a schema showing the conversion and update processes of an assembly structure when importing CAD data into CATIA V5.
Multi-CAD Conversion and Update Processes:

The associative mode is the default mode. But if you do not launch the Batch, you will use what was called the non-associative mode in the previous V5 versions. Associative mode is useful when a user wants to maintain synchronization with structure and/or geometry changes. But if you prefer to keep your assembly as it was at the moment of the conversion, you do not need to launch the Batch. Therefore, in this case, you will not do any synchronization between V5 data and
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How to use the Update Batch for Multi-CAD Data
This task shows you how to convert IGES parts into V5 CATParts and how to keep associativity between the modified CAD data and the converted part files, in V5. 1. On Windows, in a Command Prompt window, you can launch the conversion Batch by entering the following command: "C: Users E: <install_dir> intel_a code Winnt tmp bin CATDMUUtility.exe" Profiles All CATEnv" -f

env CATIA.V5R13.B13 -direnv "C: Application Data tmp IGESPart.igs -part E:

Dassault Systemes

Part1.CATPart

Where -env ... is the default environment and -direnv ... is the directory path containing this environment. CATIA.V5R13.B13 is an example of environment name, it will vary with the level of CATIA installed. Please note that this conversion will take into account the settings from the Tools -> Options -> General -> Compatibility -> External Formats and IGES Settings. 2. Insert the CATPart into a CATProduct interactively in CATIA V5 using Insert > Existing Component. 3. Save the CATProduct as E: tmp prod1.CATProduct

4. Modify the IGES data in the original CAD system. 5. Launch the update Batch by entering the command: "C: Users i E: <install_dir> intel_a code Winnt bin CATMCIReplace.exe" Profiles All CATEnv" -

env CATIA.V5R13.B13 -direnv "C: Application Data tmp

Dassault Systemes

prod1.CATProduct -update

If you open prod1.CATProduct interactively in CATIA V5, you will be able to see the geometry modification.

For more information about the CATDMUUtility launching, please refer to Running CATDMUUtility Batch Process, in DMU Navigator User Guide.
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Opening a Document from STRIM or STYLER
This task shows you how to import into a CATPart document the contents of a document created in STRIM or STYLER applications. V5 provides a direct interface from STRIM or STYLER to V5, which operates on STRIM and STYLER native format files. With STRIM/STYLER to V5 Interface you can retrieve an existing STYLER or STRIM design in V5 and proceed to further transformations in mechanical solutions, NC Manufacturing solutions and Shape Design and Styling solutions,. STYLER or STRIM files are opened as CATParts in interactive mode. The suffix of the STRIM or STYLER models to process must be either .tdg or .TDG. V5 accepts any STRIM or STYLER model generated on any platform supporting STRIM or STYLER (UNIX or Windows). V5 running on UNIX accepts models from any STRIM or STYLER version, whereas V5 running on Windows accepts only models from STRIM version 4.2.1 and higher. 1. Select the File/Open... menu. Enter the path and the name of the TDG model in the file selection box and click Open. 2. The model is loaded in a new window as a document, with a CATPart format. The geometrical entities enclosed in the file are converted to V5 elements. 3. If necessary, refer to the Report file in the CATREPORT location. 4. The geometry can now be processed as any CATPart geometry: elements can be picked and processed as any CATPart element, the document can be saved as a CATPart document.
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Report file
After the recovery of TDG files, V5 generates: • a report file (name_of_file.rpt) where you can find references about the quality of the transfer. It accounts following information: o Elapsed time, o Number of Euclid STYLER entities of each type transferred, o Transfer Success indication. If some entities were too small with respect to the V5 tolerance set in the session, they are marked as degenerated (this means they are not transferred).

•

and an error file (name_of_file.err) . These files are created in a location referenced by • the USERPROFILE variable on Windows. Its default value is Profiles Systemes • user Local Settings Application Data Dassault CATReport on Windows (user being you logon id)

the HOME variable on UNIX. Its default value is $HOME/CATReport on UNIX.
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What about the elements you import
The geometry of STRIM and STYLER models retrieved in V5 is the following: • • • • Wireframe: points, curves, Surfaces: planes, patches and trimmed faces converted into single surfaces, Topology: skins (open shells) are converted into multi-surfaces, Construction elements: planes, coordinate systems.

Please note some specific translation characteristics: • • • • No approximation of the geometry representation is involved during the conversion of the models: V5 applications retrieve the exact original geometry, Geometrical entities of any degree are converted to V5 without approximation, Extremely "small" curves, small edges, "thin" patches and small faces may exist in some STRIM/STYLER models. They are ignored according to the tolerance parameters used. However, this does not affect the consistency of the model retrieved in V5. Such entities are accounted as degenerated in the transfer log synthesis. Please note that in standard cases such curves are even below the original STRIM/STYLER tolerances and are useless even for the geometrical consistency of Euclid STYLER/STRIM models. Curves and surfaces with especially high degree are not split, Original topological structures are preserved with a one-to-one mapping. The tolerance used is the default tolerance defined in the Part Design session.

• • •

Original model display services such as: • • • Layers Color Hide/show

are retrieved in the resulting CATPart. Attributes are processed as follows: • • • • Original colors are retrieved exactly, Original layers are transferred, Show/No Show attributes are taken into account, Other attributes are not taken into account, and V5 session attributes prevail.

STRIM/STYLER elements imported to V5R6 and higher
Exists in STRIM Exists in STYLER Converted in V5
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STRIM or STYLER entities

Does not exist in STYLER
Existing in STRIM Existing in STYLER Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes V5 output element

Not processed
Comments

3D modeling applications entities: Master Model Point Curve Patch Shell made of one single face Shell made of several faces STRIM solid (not created in STYLER) Geometrical Geometrical Geometrical Geometrical Geometrical Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Point Curve Surface Surface Surface Not processed Not processed Not processed Not processed Not processed Plane Not processed Coordinate System Not processed Not processed Not processed No equivalent in V5 No equivalent in V5 No equivalent in V5

3D curve - Patch/Face Logical relation Contour (group of curves) Surface (group of patches) Group Plane Transformation Coordinate system (direct trihedron) Bezier polygon Bezier polyhedron Curve by points (unsmoothed list of points) Series of curve points (for curve by smoothing) Bitangent curve Bitangent contour Graphic context (current view point) Visibility list (Show/No Show list) Entities layer Layer filter 2D Drafting Mesh elements Mesh nodes Mesh attributes Mesh points Milling point APT file Logical Logical Logical Geometrical Geometrical Geometrical Geometrical Geometrical Geometrical

3D modeling application entities: construction and diagnostics

Geometrical Logical Logical

Yes Yes Yes

Yes No No Display services

Points Not processed Not processed

Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes

Yes Yes Yes Yes No No No No No No No

Not processed Show/No Show Layer Not processed Not processed Not processed Not processed Not processed Not processed Not processed Not processed Hidden elements Elements inherit their original layer number

Drafting application Meshing application

Machining application
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CL-File Machining command file Machining instruction file Interactive journal Textures

Yes Yes Yes Yes No

No No No No Yes

Not processed Not processed Not processed Not processed Not processed

Rendering application

VRML
This tab deals with the following categories of options: • • • • import unit import options export version export options

Import: Unit

Lets you select the desired unit for the VRML file to be imported: Meter, Millimeter or Centimeter.

Import: Options

Crease angle
Impacts the generation of default normals. The following picture illustrates this:
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If the angle you defined in the Crease angle field is lower than the angle between the two geometric normals (shown in blue) of the adjacent edges, then a default and unique normal will be calculated so that the faces look smoother across the edges. If the defined angle is greater than the angle between the two normals, two normals will be calculated and the faces will look less smooth across the edges.

Export: Version

You can choose between the VRML 1.0 and the VRML 97 format. To do so, simply check the corresponding radio button. Note: when saving sections in VRML 97 format, make sure that the "Save edges" export option is checked. By default, the "VRML 97" option is activated.

Export: Options

Save normals
Lets you save normals contained in your model when converting it into VRML format. This option is relevant for VRML 97 format only. By default, this option is activated.

Save edges
Lets you save edges contained in your model when converting it into VRML format. This option is relevant for VRML 97 format only. Bear in mind that saving edges increases the file size significantly.
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By default, this option is activated.

Save textures
If this option is selected, it means that you can save your textures: • • in an external file of type .jpg directly in the VRML file. However, note that this will increase the file size considerably.

By default, this option is cleared.

Background color of generated VRML file
Lets you select the background color to be used when visualizing the generated VRML file in a standard VRML viewer (such as Cosmo Player, for instance). The default color is "black" but you can select the desired color from the list or choose the More Colors... option to access the color palette. This palette lets you define more colors or create your own colors. Note that when reopening your VRML document in Version 5, this background color will not be taken into account.

Bill of Materials
Displaying the Bill of Material (BOM)

This task shows you how to display the number and name of the components belonging to the activ as well as the properties of these components. It also shows you how to save this data. You can display the bill of material of the active component only. Open the AnalyzingAssembly01.CATProduct document. 1. Select Analyze -> Bill of Material. The Bill of Material dialog box is displayed. It is composed of two tabs: • • Bill of Material, Listing Report.

The Bill of Material tab shows the different parts and sub-assemblies of AnalyzingAssembly01 which is the active component. The Bill of Material does not show the possible representations associated to the components.

329

collaboration

There are three main sections: • • • Bill of Material: lists all parts and sub-products one after the other, Recapitulation: displays the total number of parts used in the product AnalyzingAssembly01.CATProduct, Define formats.

2. Click Save As to save this data. The Save Bill of Material As dialog box is displayed. Three d formats are available: .txt as text format, .html as html format and .xls as Excel format.

3. Select the appropriate directory and enter a name in the File name field. Note that the file g contain the date of generation. For instance, if you selected the .txt format, the document l
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4. Now click the Define formats button to customize the display of your bill of material. A new appears, indicating the default format, i.e. AP203 format.
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5. To create the format of your choice, click on Add. Format.1 then appears in the Selected Fo The Remove button is used for removing already existing formats. 6. You can display the directories used for your assembly by clicking the Search order option. the Search Order capability, please refer to CATIA- Infrastructure User's Guide Version 5.

7. Now, choose the properties you wish to display in the Bill of Material section of the Bill of Ma box. To do so, for example, select Source from the list Hidden properties and click the show icon to move Source into the Displayed properties section.

Likewise, double-clicking a property moves this property into the section opposite.

8. Repeat the operation by adding Description to the Displayed properties section of the Prope Recapitulation frame. The buttons you can use are the following: moves the selected property to the right scroll list
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moves all properties to the right scroll list

moves the selected property to the left scroll list moves all properties to the left scroll list moves the selected property within the scroll list.

9. Click OK to validate the creation of the new format. The Bill of material: Display formats dia closed. You cannot save the formats you create. Customized formats are specific to your CATIA session. The Bill of Material now looks like this:
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The Default Representation Source property is the source of the default shape document. This property allows to show the path to the file that contains the default shape associated to the product node. The Type property allows you to discriminate products according to the following condition: if they are Assemblies or nodes with no son. The Quantity property allows you to distinguish products according to the number of Instances that are contained in the Assembly. In this case the Default Representation Source of an instance of a CATPart is the CATPart document file path. Some nodes may have a default representation, others none. It can be void for nodes (assembly parts) without any attached representation, as in the example below:
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10. Click the Listing Report tab. It displays the tree of the product using indents, just like in the
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11. Check the Search Order option if you wish to display the directories where the different doc up the assembly are located.

12. To display other information in your report, select the properties of your choice in the Hidde scroll list and use the buttons as previously described to move these properties to the left. 13. To see the result, click Refresh. 15. Click OK in the Bill of Material dialog box to exit.

14. Use Save As... to save the report in the directory of your choice. Only .txt format is availabl

To know how to use your bill of material in your CATDrawing documents, please refer to Adding a G of Material in CATIA - Generative Drafting User's Guide.

Managing the Bill of Material (BOM)
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CATIA Translators This task shows you how to customize the Bill of Material window : you can change the name of the buttons, the titles and the size of the columns (number of . It also shows you how to save this data. You can modify the structure of the bill of material window in the CATAsmBom.CATNls file and the size of the columns in the CATAsmBom.CATRsc file. On NT, both files are under your CATIA installation directory : ...\DownloadofCXR6rel\intel_a\resources\msgcatalog\CATAsmBom.CATNls (on Windows NT) On UNIX, the location of these files is under your CATIA installation directory as well : ...\DownloadofCXR6rel\solaris_a\resources\msgcatalog\CATAsmBom.CATNls (for SUN) ...\DownloadofCXR6rel\irix_a\resources\msgcatalog\CATAsmBom.CATNls (for SGI) ...\DownloadofCXR6rel\aix_a\resources\msgcatalog\CATAsmBom.CATNls (for AIX) Open the AnalyzingAssembly01.CATProduct document. 1. In CATIA contextual menu, click on Analyze -> Bill of Material... : The BOM dialog box appears :
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2. Open the CATAsmBom.CATNls file in WORDPAD or NOTEPAD.
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For instance, you can replace : • the title name "Bill of Material:" by "BOM:" • the title name "Total parts:" by "TOTAL:" • the title name "Quantity" by "Number" • the button name "Define formats" by "FORMATS" Save the CATAsmBom.CATNls file with the same name and under the same directories. Close the CATIA session in order to synchronize the last modifications and re-open it. In CATIA contextual menu, click on Analyze -> Bill of Material... :
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In the BOM dialog box, you can visualize the changes :

The modifications are saved in the CATAsmBom.CATNls file and they are visible in the BOM window. 6. Open the CATAsmBom.CATRsc file.
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This file allows you to change the size of the columns (the number of characters per column) in the document (.txt document, for instance) generated by the Save as operation in the BOM window. It has no impact on the BOM window. 7. For instance, change the characters' number in the Part Number column : from 20 to 10. And reduce the size of the Type column : from 10 to 5 characters. 8. Save the CATAsmBom.CATRsc file with the same name and under the same directories. 9. Click on the Save as button in the BOM window in order to be able to read the information in a .txt document for example. 10. Open the .txt document in which the last modifications are visible :
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You can compare the size of the columns with the original document in Displaying the Bill of Material. This operation allows you to adapt the table to the length of the data and to keep the information on a single line.

Capability not to take into account a component in BOM extraction
This task shows you how to not display the number and name of the components belonging to the active component in the Bill of Material. Open the ExtractBOM.CATProduct document.
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1. Select subproduct2.CATProduct, right-click it and select the Properties contextual command. The Properties dialog box is displayed:
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2. Uncheck the option Visualize in the Bill of Material so that subproduct2 and its child, Cube1, does not appear in the Bill of Material dialog box. This option is a means to choose the objects you want to visualize in the Bill of Material dialog box (in the Bill of Material and Listing Report tabs). 3. Click in the menu bar: Analyze -> Bill of Material and the Bill of Material dialog box is displayed:
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First of all, in the Bill of Material of RootProduct, you can see subproduct1, which is normal because RootProduct has only one child. Secondly, in the Bill of Material of subproduct1, you can only see Hole1 but not Cube1 because you had decided not to visualize subproduct1 and implicitly its child, Cube1. Subproduct1 has two direct components, subproduct2 and Hole1, but only Hole1 is present in the Bill of Material. 4. Now check the option Visualize in the Bill of Material in subproduct2's properties to go back to the initial state. 5. Select Cube1, right-click it and select the Properties contextual command. Uncheck the option Visualize in the Bill of Material so that Cube1 does not appear in the BOM of subproduct2.
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First, in the Bill of Material of RootProduct, you can see subproduct1. Secondly, in the Bill of Material of subproduct1, you can only see subproduct1 and Hole1 but not Cube1 because you had decided not to visualize Cube1. Thirdly, in the Bill of Material of subproduct2, you cannot see its child, Cube1, because it was specified in the Part's properties with the unchecked option: Visualize in the Bill of Material. If you want a Product to be seen in the BOM but not its children, therefore this Product will appear in the summary list of the BOM because it becomes a Terminal Node.

StiSmartBOM
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General

SMARTEAM BOM has been designed to enable companies and suppliers to coordinate together over the BOM, utilizing email and the Internet. In the General section, you can insert your user name and e-mail address.

Export

Selecting Embed associated documents enables you to attach CATIA documents (geometry and specifications) in your briefcase. Selecting Export Briefcase enables you to export BOM as a nomad application (.exe). If you have selected this option, you can then click Browse... to access the install path. The install path is a temporary directory where the nomad application is built before being sent.

Import

The Temporary output path indicates a temporary directory where the data you import will be read. To specify this temporary directory, just click Browse... and navigate to the directory of interest.
To import the data:

1. For example, open the CATProduct document you want. 2. Save it as an .stbom file (or .exe file).
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4. Save your changes by using SmartBOM Editor (File->Save as). 5. To import a new SmartBOM Briefcase in CATIA V5, select File->Open in CATIA V5 and choose the stbom format: the new BOM is imported with the attached CATIA documents.

Capturing Section Results
This task illustrates how to export sectioning results to a CGM document using the Capture command. For more information on this command, see the Infrastructure User's Guide. 1. Generate your section. 2. In the active viewer, select Tools ->Image ->Capture. 3. Click the Vector Mode icon 4. Click the Save As icon Save As dialog box in the Capture toolbar. . Different CGM types are proposed in the

The CGM file can then be opened (File ->Open) in the DMU Mockup 2D workbench and used for comparison purposes. For more information on 2D comparison functionalities, see the DMU Navigator's User Guide.
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Exporting a CIS/2 File
This task demonstrates how to use the CIS/2 Exporter. The command is available as:

in the Structure Tools toolbar

Example Image

In this example, we shall export the children in the tree of the active product to a CIS/2 file. The exported children will be: Column A Column B Column C Column D from the Example Image above.

1. Activate the Structures Tools toolbar:

2. Double click on the product you want to be the root of the export: it becomes 349

collaboration the active object. Note: The CIS/2 translator exports with a product as the root. If the active object is a product, export starts there. If the active object is not a product, then the translator will use the immediate product ancestor of the active object. For example in the picture below, if Plate1.1 is the active object (highlighted in blue), then the immediate product ancestor would be Product2. Therefore, the export would actually begin with Product2, and any members or plates underneath this product (in this case, Plate1.1 and Member1.1) will be processed.

1. Select

.

The CIS/2 Export dialog box appears:

2. Type in the name of a file or click to browse for a file to write the report data. You can only export one CIS/2 file at a time. 3. Enter an optional project model name. 4. Select a unit from the Length Unit drop-down menu to use for exporting the
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5. Click Ok. 6. A confirmation should appear upon successful completion of the export. Click OK.

A portion of the CIS/2 file from our example opened in a simple text editor.

Exporting an SDNF File
This task demonstrates how to use the SDNF Translator export. The command is available as:
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in the Structure Tools toolbar

Example Image

In this example, we shall export the children in the tree of the active product to an SDNF. The exported children will be: Column A Column B Column C Column D from the Example Image above.

1. Activate the Structures Tools toolbar:

2. Double click on the Product you want to be the root of the export: it becomes the active object.

1. Select

.

The SDNF Export dialog box appears:
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2. Type in the name of a file or click only export one SDNF file at a time.

to browse for a file to export. You can

3. Select a unit from the drop-down menu (Units) to change the export dimensions -- used for the member units and the plate linear and thickness units. 4. Optional: You can type project information in the Project frame. (Project Designation is equivalent to the Design Code field in the SDNF Title Packet.)

The dialog filled in for our example.

5. Click OK to complete the export. The SDNF file from our example opened in a simple text editor.
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For more detailed information see About Digital Project and SDNF.

Importing SDNF File
This task demonstrates how to use the SDNF import. The command is available as:

in the Structure Tools toolbar

No documents or sample files are included with this example.
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1. Activate the Structures Tools toolbar:

2. Make sure the section catalog is correct. See Managing Project Resources. 3. Make sure the material catalog is correct. See Managing Project Resources.

To importing an SDNF file 1. Open a new product.

2. Select

command.

3. The SDNF Import dialog box appears:

to browse for a file to import. You can 4. Type in the name of a file or click only import one SDNF format file at a time. 5. Filled in dialog will be:

"C:\Columns.sdnf" file below:

355

collaboration

6. Click "OK" button on SDNF Import dialog. 7. The structures are imported under our new product as seen below. Note that if you import an SDNF in an existing project, data will be created under the active product.
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Reimporting the same SDNF file with modified section or material of a structure: 1. If the section is modified from the SDNF file ("C:\Columns.sdnf") file as below :
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2. Importing SDNF file again will update the column and highlight(in yellow) the modified structure :

358

Digital Project Translator

Reimporting the same SDNF file with modified supporting geometry : 1. If the angle is modified from the original SDNF file ("C:\Columns.sdnf") as below :
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2. Importing SDNF file again on the original import will create a new column with name suffix ("_NEW") and highlight(in blue) the newly created structure :
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Note: 1. If the SDNF File being imported has a structure with piece mark that already exists under active product then this structure will not be recreated. However if this structure has a different supporting geometry, section or material then the structure will be re-imported as mentioned in the above scenarios. 2. The dimensions for members and plates in the SDNF file will be converted to the current unit for Length in the document.

For more detailed information see About Digital Project and SDNF.
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Importing 3D DXF or DWG File
This task demonstrates how to import a .dxf or .dwg file. In Digital Project the command is available as a menu item Data-> 3D DXF DWG Translation->3D DXF or DWG Import.

No documents or sample files are included with this example.

To import a 3D DXF or DWG file as CATProduct 1. Open a new product.

2. Select

command.

3. The Import .dxf file dialog box appears:

to browse for a file to import. You can 4. Type in the name of a file or click only import one DXF or DWG format file at a time.
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5. Filled in dialog will be:

6. Click "OK" button on Import dialog. 7. The dxf file is imported under the active product :

To generate a CATPart from the imported CATProduct 1. Select command Data-> Generate CATPart from Product.... 2. This command will pop Filter a product dialog, edit part number (if required), select appropriate option
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and select OK button. 3. A new CATPart with name as specified in the above dialog box is generated.

About Digital Project and SDNF
This page describes Structural Steel Detailing Neutral File (SDNF) translation within Digital Project. • • • • • • • • • Export Use Case Import Use Case Import, Export and the Active Object Structural and Material Catalogs Supported Units Supported Packets Current Limitations Troubleshooting Related Links
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In the Structure Tools toolbar exporting from and importing into Digital Project.

, commands are available for

Digital Project complies with certain portions of the SDNF specification; see Supported Units, Supported Packets, and Current Limitations. The term "member" is equivalent to linear member in this text. "Structure" signifies member and/or plate.

Export
SDNF Export processes structural steel members and plates found within the active product. SDNF Export writes any SDNF-related information to a user-specified file. The command is: in the Structure Tools toolbar

Export Units
The unit selected for export can differ from the current unit for Length in document. This export unit will be used for • • linear units for linear members both linear units and thickness units for plates

Digital Project handles the conversion from the current unit to the export unit. See Supported Units.

Export Use Case
See the use case SDNF Export Example to step through how a simple model is exported to an SDNF.
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Import
The SDNF Import command imports an SDNF formatted file specified by the user, and uses this file to create structural members and plates. These members and plates become children of the active product. The command is: in the Structure Tools toolbar

Regarding imported SDNF fields: • When Digital project finds any information the imported file that it does not support and it has a value that is neither a null string ("") or a zero value, the value is ignored and a message is placed in the SDNF error log. If there is additional information in a record (a row) in the SDNF import file, Digital Project will add a warning to the SDNF error log and then continue processing. If a record does not contain the number of needed fields, Digital Project generates an error in the SDNF error log and stops processing the file.

•

•

Import Use Case
See the use case SDNF Import Example to step through how a simple SDNF is imported into Digital Project.

Import, Export and the Active Object
The import and export start processing from a product that has been double-clicked and therefore become the active object. If the active object is a product, import will create structures underneath and export will process any structures underneath. If the active object is not a product, the SDNF importer and exporter will use the immediate product ancestor of the active object to begin processing.
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Structural and Material Catalogs
For both members and plates, the SDNF field "Grade" indicates the needed material to Digital Project. Only for members, the SDNF field "Section Size" is used to set the section of a member. The importer uses the current directories specified in Project Resource Management to locate these structure material and member section values. If the importer cannot find the material information it needs, the plate or member may still be created but its material is not set. However, if a section cannot be found in the catalog, the entire member is not created. For more information on setting and changing these directories, see Managing Project Resources.

Supported Units
The following units are available for SDNF import and export. The case of the unit (upper-case, lower-case, or mixed-case) does not matter. • • • • • Meter(s) Centimeter(s) Millimeter(s) Foot/Feet Inch(es)

Supported Packets
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Current Limitations
Digital Project does not currently support the following fields within Packets 00, 10 and 20. During export, the fields listed in the table below need to be included in the file even though Digital Project does not support them. Therefore, Digital Project handles values the following way: • • Numeric values are set to zero. ASCII character fields are set to an empty pair of double quotes (i.e. "").

Note: Even though Digital Project does not support these fields, this does not mean they should be excluded from a record in an import file. In fact, Digital Project requires the correct number of fields be present for each record (row), and the absence of any of the fields in a record will cause processing of the file to stop.

Packet

Record

Field Not Supported

00 (Title Packet)

6 9 10

10 (Linear Members) Member Member Member Member Member Member Member

Record Record Record Record Record Record Record

Date and Time of file creation Number of Loading Records Title Packet Record 10 : Load Combinations (Existence dependent upon Number of Loading Records. Do not omit on import if Number of Loading Records is greater than zero.) 1 Status 1 Class 1 Revision Number 2 Mirror X and Y Axis 3 Start and End Cutbacks 4 X, Y Cross-section Offsets 5 X, Y, Z Start and End Offsets

Not Supported on Import, Export or Both Import Import/Export Import/Export

Import/Export Import/Export Import/Export Import/Export Import Import Import/Export
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Member Record 6 End 1 and End 2 Releases 20 (Plate Elements) Plate Record 1 Status Plate Record 1 Class Plate Record 1 Type

Import/Export Import/Export Import/Export Import/Export

Troubleshooting
If the SDNF contains a considerable number of members or plates (i.e. over 1,500), one may want to try breaking up the SDNF. Any notices, warnings or errors generated during SDNF import or export are in the file SDNFErrorLog.txt The directory of this error log depends on the environment settings for the CATTemp environment variable. Whenever there is an error on import or export, this file is recreated. If you need to save this error log, it must be renamed or copied to a different directory to avoid being overwritten.

Reading the Error Log
The SDNF error log consists of rows of errors. For each error, there are a series of columns. Please note that the columns may not align across rows of errors and should only be considered on a per row basis. For each error, the following are listed in their own columns: • • • The line number in the error log. This is the leftmost column. If there are parsing errors, the approximate line number where the error occurred. On an import error involving a member or plate, the error log attempts to list the member or plate number in the SDNF (the "Member number" or "Plate number" field in Linear Member/Plate Record 1) and/or the member or plate piece mark if it is available. If there is an export error regarding a member or plate, the alias of the part instance is used. The error description. This is the rightmost column. More details on each error's meaning and its consequences may be found in this section of the article.

•

Currently, there are three general types of errors that range in severity from smallest to greatest: Notices, Warnings and Errors. Notices are typically to inform the user and have little or no impact on the command. With Warnings, the command can continue but the user should take heed that corrections may need to be made. For Errors, the command may proceed but usually does not, and the user should definitely look into any corrections that may need to be made.
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Error Types Found in Tables Below N Notice W Warning E Error

Export Errors

ERROR MESSAGE GENERAL

ERROR TYPE

MEANING

RESULT / TIPS Processing stops and the data is not exported. Verify the directory specified for export in the dialog box exists and is writable. Processing of current member stops. Processing continues. Processing continues. Processing continues. Processing continues. Processing continues. of member of member of member of member of member

Could not open SDNF file for export. Make sure directory E exists. MEMBERS Could not get structure E member's absolute position. Could not get structure member's current set point. Could not get structure member's section name. Could not get structure member's family name. Could not get structure member's catalog name. Could not get structure member's profile type. Could not get structure member's start/end cutback. Could not get structure member's angle. W W W W W

The file that the data would be exported to could not be created or opened.

The global position of the member could not be retrieved. -

W

W

The start or end cutback Processing of member type of the structure member could not be continues. retrieved. The angle related to the Processing of member member's orientation continues. could not be retrieved.
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Could not get structure member's start/end coordinates.

W

Could not get structure member's start/end offset.

W

Could not get structure member's material.

W

Could not get structure member's reference. PLATES Could not get plate data. Could not get plate's material. Could not get plate's thickness.

W

Processing of member The start or end continues. The coordinates of the information in the SDNF structure member could for the member's start not be retrieved. or end coordinates may be incorrect. The offset for the member's start point or Processing of member the offset for the continues. member's end point could not be retrieved. Processing of member continues. The Grade field in the SDNF for this member will be empty. The reference object defining the orientation Processing of member of the member could continues. not be retrieved. The plate's data could not be retrieved. (Due to an internal error.) Processing of current plate stops.

E W E

Could not get plate vertices. Reason: Could not get plate E support.

Could not get plate's extrusion direction

E

Processing of plate continues. Processing of current plate stops. Processing of plate The vertices (X,Y,Z stops. Note: The coordinates) that make number of vertices for up the plate's sketch the plate will be listed could not be retrieved as 0 in the exported because the plate's SDNF, and no vertices support could not be will be listed for the retrieved. plate's Plate Geometry Record. Processing of plate stops. Note: The number of vertices for the plate will be listed as 0 in the exported SDNF, and no vertices will be listed for the plate's Plate Geometry Record.

Import Parsing Errors
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ERROR MESSAGE GENERAL

ERROR TYPE

MEANING There was an error determining the father product to insert members and plates under. The importer determined that there were not members or plates in the SDNF.

RESULT / TIPS

Active father object not available. Could not import E file.

The SDNF is not imported. If certain there are members and plates, verify the name of the file that was imported and make sure the format of the file follows the SDNF specification.

No linear members or plates N found in file.

(filename) : File does not exist. Could not open SDNF file.

E

E

Not supported yet - (name of what is not supported)

N

Insufficient Data

E

Extra Data

W

The file specified in the Verify the directory and dialog box to import filename are correct. could not be found. The SDNF could not be Verify the user opened to read the permissions of the file. data. The SDNF importer has come across data in the SDNF it recognizes, but Information is discarded it cannot currently use and processing continues. the data. See Current Limitations in this article for more information. Each row corresponding to the SDNF specification expects a specific number of Processing stops. values. If there are missing values, the file is determined to not meet the SDNF specification. Important Note: Even though processing Each row corresponding continues, the row of to the SDNF data is incorrect specification expects a according to the specific number of specification and can values. If there are lead to unexpected more values than results during member needed, the extra ones and plate creation. It is are discarded. important to determine what the extra values are, why they are there,
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Incorrect file : Number of load combinations gathered does not match number of W combinations listed in Record 9 of the Title Packet

and which ones are actually needed. Because load combinations are not The number of sets of currently supported, load combinations listed only a warning is output and processing in Record 10 should continues if the number match the number of load combinations listed of sets of load in Title Packet Record 9. combinations do not match the number specified in Record 9. The SDNF importer does Processing stops. Check not recognize the unit the unit in the SDNF given in Record 2 of and make sure it is one Packet 10 or there was of the supported units an internal error. See listed in the Supported the Supported Units Units section of this section of this article. article. Processing stops for Memory could not be current member and the set aside to contain member will not be member information. created. According to the SDNF specification, there should be six records Check that the linear (rows) for each linear member has the correct member. If each of number of records. these six records cannot be retrieved there is insufficient data. Check that the number of linear members listed in Record 2 of Packet 10 is correct. Verify there are the correct number of linear members.

MEMBERS

Could not compute correct linear member units from those given in file.

E

Could not create memory for new linear member. (Internal Error)

E

Error retrieving all linear member records (linear member records 1-6) for a linear member.

E

Incorrect file : Number of linear member records gathered does not match number of linear members listed in Record 2 of the Linear Member Packet (Packet 10). PLATES

E

-

Could not compute correct plate linear units from those E given in file.

Could not compute correct plate thickness units from those given in file.

E

The SDNF importer does Processing stops. Check not recognize the unit the unit in the SDNF given in Record 2 of and make sure it is one Packet 20 or there was of the supported units an internal error. See listed in the Supported the Supported Units Units section of this section of this article. article. The SDNF importer does Processing stops. Check not recognize the unit the unit in the SDNF given in Record 2 of and make sure it is one Packet 20 or there was of the supported units
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an internal error. See the Supported Units section of this article. Could not create memory for new plate member. (Internal Error) E Memory could not be set aside to contain plate information. According to the SDNF specification, there should be two records for each plate and a set number of "Plate Geometry Record" (plate record 3). There is insufficient data if the initial two plate records and all the Plate Geometry Records cannot be retrieved.

listed in the Supported Units section of this article. Processing stops for current plate and the plate will not be created. Check that the plate has Plate Records 1 and 2. Also, check that the number of Plate Geometry Records associated to the plate matches the "number of vertices" field in Plate Record 1. Check that the number of plates listed in Record 2 of Packet 20 is correct. Verify there are the correct number of plates.

Error retrieving all plate records (plate records 1-3) E for a plate.

Incorrect file : Number of plate records gathered does not match number of plates E listed in Record 2 of the Plate Member Packet (Packet 20).

-

Import Creation Errors

ERROR MESSAGE GENERAL

ERROR TYPE

MEANING

RESULT / TIPS Current member or plate material is not set. Make sure the catalog directory is correct for the section: See Managing Project Resources. Current member or plate material is not set. Current member is not created. Make sure the catalog directory is correct for the section: See Managing Project Resources.

Could not obtain structural catalog material. No material set.

W

-

Could not set member's material. MEMBERS

W

-

Unreferenced Section (SDNF Linear Member Section Size : Field 1 Record E 2) - Could not open structural catalog.

The catalog with the member's section details could not be opened

374

Digital Project Translator

Could not create member. (Internal Error)

E

Could not set linear member W start/end co-ordinate.

Could not set linear member W anchor point.

Could not set linear member W angle.

Could not perform computations to finish creation of linear member. Could not set member's section.

E

E

Ambiguous Orientation Using default orientation.

W

Could not create member reference plane.

W

Could not add linear E member's reference to tree. Could not create linear E

Current member is not created (sometimes partial creation may occur). Current member creation continues. The resulting member's start or end coordinates are likely incorrect. Current member The anchor point creation continues. The (cardinal point) could resulting member's not be set for the position and anchor member. point may be incorrect. Current member The angle related to the creation continues. The member's orientation resulting member's could not be set. orientation may be incorrect. The calculations to Current member finish creation of the partially created. member could not be Resulting member completed. should be verified. Current member The section profile could creation stops but not be assigned to the member partially member being created. created. No reference plane is The reference plane for created for the member the member could not and the orientation be created because the about the member's Orientation Vector and axis is not set. The the axis from the start default orientation is to end coordinates are used. The member's parallel. orientation may be incorrect. No reference plane is created for the member and the orientation The reference plane for about the member's the member could not axis is not set. The be created. default orientation is used. The member's orientation may be incorrect. The reference plane is A member's reference not added to the plane could not be specification tree. added to the Current member specification tree. creation continues. The geometrical set to The geometrical set and

375

collaboration

member's geometrical set.

father the member's reference plane could not be added to the specification tree.

reference plane are not added to the specification tree. Current member creation continues. Current plate creation stops. Current plate creation stops. Current plate creation stops. Current plate creation continues. The sketch should be verified. Current plate creation stops.

PLATES Could not create plate. (Internal Error) Could not create plate sketch. Could not open edition for plate's sketch. Could not close edition for plate's sketch. Could not create plate's geometrical set.

E E E W

The sketch that defines the plate could not be created. The plate's sketch could not be completed. The internal editing of the plate's sketch could not be completed. The geometrical set associated with the current plate could not be created. The plane associated with the current plate could not be added to the geometrical set associated with the current plate. Error creating current plate from sketch. The plate could not be made from the sketch. -

E

Could not append plane to open body.

E

Current plate creation stops.

Error with plate's sketch. Could not set plates support. Could not set plate's thickness.

E E

W

Could not reverse plate's extrusion direction.

W

-

Current plate creation stops. Current plate creation stops. Current plate creation continues. The resulting plate's thickness is likely incorrect. Current plate creation continues. The resulting plate's extrusion direction is likely incorrect; the plate's thickness direction will likely have to be reversed manually. Current plate partially created. Resulting plate should be verified. Creation finishes. Resulting plate should be verified.

Could not perform computations for plate.

E

Could not update plate part. E

The calculations to finish creation of the plate could not be completed. An update of the plate could not be performed after plate calculations are finished.

376

Digital Project Translator

Related Links

• • •

SDNF Export Example SDNF Import Example Managing Project Resources

For details on the SDNF specification, please consult a definitive source for this information.
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Conferencing
Customizing Conference Options
The Options page enables you to manage conference settings. 1. In the Conferencing dialog box, click the the Options tab. The Options page is displayed.

Translator
Customizing
The quality and performances of your export or import data can be improved by choosing the most suitable settings.
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1. Select the Tools -> Options command. The Options dialog box displays. 2. Choose the General category in the left-hand box, then Compatibility.

3. Use the arrow to navigate to the tab you need: • • • • DXF IGES IGES 2D STEP

4. Set options in these tabs according to your needs. 5. Click OK when done.

Administration
Administration Tasks
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Project Standards Administration tasks deal with the administration of mapping standards for the import of DXF/DWG or IGES 2D files. Administration tasks (creating, customizing, managing standards) must be performed by an administrator. Standards can be customized afterwards according to your needs but bear in mind that unless you are logged as administrator, you will not able to modify standards. For details about Drafting standards, please refer to the Interactive Drafting User's Guide.

Customizing External Formats Import

If you have the SolidWorks, SolidEdge or Acis Plug-In license, the following categories of options will be available: • • • • • • visu format unit link mode others output of generated data Ideas ProEngineer

You imported a CAD Part through the Insert ->Existing Component command.

Visu Format Unit

Millimeters per unit

This setting allows you to specify the number of millimeters per unit of the model. For instance, if you have a file in inch, you need to enter 25.4 in this field. This option is taken into account when you have the following formats: SLP, STL, OBJ, BYU, IFF and _PS. Note: For a file of type _PS, the Visu Format Unit must be set to 10.
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Link Mode

Visu

Tesselated data. By default, this option is activated.
Visu Snap

Recovery of CAD's exact geometry to generate V5 CGR. Canonical shape properties are identified. The visualization mode enables part snapping capability. After selecting this option, this message appears: "Please, restart session to take modifications into account".
CATPart

Link with a V5 CATPart. Do not modify this CATPart in CATIA V5.

Others

Save Coorsys in Cgr

Stores part coordinate systems in .cgr file. It is only supported in the indirect mode. This parameter determines whether coordinate systems present in imported ProE, UG or IDEAS parts will be imported into the resulting CGR files.

Output of generated data

Output Path

Lets you customize the Output File for generated data. It specifies the location where CGR and CATParts will be generated.

If you have the IDEAS, ProEngineer or Unigraphics Plug-In licenses, additional options will appear in the External Formats tab. With the IDEAS Plug-In license, you obtain:
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IDEAS

(direct mode)

IDI 3D Annotation (CATPart mode only)

Select this option to convert IDI 3D Annotations to V5 (requires one of the following licenses): • • • CATIA: FT1.prd or FTA.prd ENOVIA: DT1.prd DELMIA: MTR.prd or MFT.prd

ProEngineer

With the ProEngineer Plug-In license:
Quilts Read

Enables to activate the transfer of quilts surfaces inside CGR. This setting does not apply to NCGM or CATPart conversions. By default, this option is not activated.
Simplified Representation

Only part simplified representation is supported. To set the name of the part simplified representation to use before the Assembly conversion, check this box and enter the name. By default, this option is not activated.
Instance Name

When you want to import a specific instance of a generic assembly/part, check this button and specify the name of the instance of your choice. By default, this option is not activated. • • For Simplified Representation and Instance Name, only upper case names are supported with the direct converter. xpr files must be on the disk for proper support of Part Instances conversion.
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Administering Standards
About Standards in DXF/DWG or IGES 2D Interfaces
Up to R13: • • when you modified the mapping of DXF/DWG attributes with V5 attributes, the modifications were only applied to your session. setting the standard for the Drawing into which DXF/DWG or IGES 2D were imported was not really user friendly (you had to create a new Drawing before launching the import, check whether the proposed standard was the one you wanted, eventually switch to another one and finally close the Drawing to instantiate the standard).

In R14, this process is improved by the introduction of standards in the DXF/DWG and IGES 2D interfa Standards are defined by your administrator in XML (Extensible Markup Language) files and let you set default values for element properties. In the case of the DXF/DWG and IGES 2D interfaces • •

• • •

standard files apply to all the sessions using them, thus controlling the company standard at the import process. the ANSI.xml, ASME.xml, ASME_3D.xml, ISO.xml, JIS.xml files are Drafting standards that set the styles for Drawings. They are used in Drafting products or while importing DXF/DWG or IGES 2D data. They are easily selected in the settings and are taken into account without any further manipulation. the DXF.xml file is a standard that sets the default mapping between DXF/DWG and V5 elemen for the color to thickness, line types and text fonts. There is no equivalent IGES 2D file. the V5 elements used in the mappings customized in the DXF standard are those defined in the Drafting standard. This ensures the consistency between the DXF/DWG interface and the D the standard files above are delivered by default in V5. You can customize them or create new standard files to meet your needs.

For more information, please refer to the Infrastructure User's Guide Customizing Standards.

Location of Standard Files

The location of standard files is defined by two environment variables which can be set during installation or modified afterwards: Variable name Description CATCollectionStandard Indicates the name and path of the sub-directory (or sub-directories) containing the standards customized by the administrator. This means that you should save your customized standards in these su

384

Project Standards

CATDefaultCollectionStandard Indicates the name and path of the sub-directory (or sub-directories) containing the default standards provided by V5. This variable is set by installation_folder\resources\standard during the installation procedure

If you want to place all customized DXF mapping standards in a custom directory, named mydirectory for example, you need to proceed as follows (for Drafting standards, please refer to Setting Standard Parameters in the Interactive Drafting User's 1. Create a directory named as you like (mydirectory, for example). 2. Create a sub-directory under this directory, which needs to be named dxf. 3. Place the XML files containing your customized DXF mapping standards in mydirectory\dxf. If you have not yet customized your XML standard files, then proceed as follows: 1. Create a directory named as you like (mydirectory, for example). 2. Create a sub-directory under this directory, which needs to be named dxf. 3. Set the CATCollectionStandard variable to mydirectory. After you have customized the XML mapping standard file, the standard editor will then save them in mydirectory\dxf. If the CATDefaultCollectionStandard and the CATCollectionStandard variables both contain an identically-named standard, it is always the standard found in CATCollectionStandard which will be used. If two directories referenced by the CATCollectionStandard and/or CATDefaultCollectionStandard variables contain identically-named standard files, it is always the standard in the directory listed first which will be used.

Management of Standards
Administrator-controlled Access and Modification

There are two types of standards: • •

default standards provided by V5. These standards can be customized using the interactive sta Their name can not be changed. user standards which are created and managed by the administrator.

In both cases, the administrator controls the access to the standard files and can, for instance, preven to edit one or more of these files.
User Access to Standards
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and Tools/Options/General/Compatibility/IGES 2D

Setting the Standards Parameters
Before You Begin
Structure of the standard is defined by the administrator. A standard file is structured as a tree, as it appears in the Standards Editor (available via Tools -> Standards). It contains several main sections, each dealing with a specific aspect of the customization: e.g. for DXF:
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e.g. for Drafting:
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Setting Mapping Parameters
In this scenario, administrators will learn how to customize mapping parameters using an example. This scenario provides an example of Line Type mapping but the procedure is the same when customizing other parameters. The lists of attributes are not the same in V5 and AutoCAD. Mapping options are used to come as close as possible to the AutoCAD attributes, or to switch them to V5 attributes.

• •

A default mapping is available, but you can customize the mappings according to your needs, and create many new DXF mapping standard files. The V5 parameters proposed are those of the current Drafting standard file. Refer to Setting Standard Styles in the Interactive Drafting User's Guide

388

Project Standards for more details. You should be familiar with the DXF/DWG styles. Select AutoCAD colors by their number. Select AutoCAD line types by their name. Select V5 line types or thicknesses by their number. For text fonts you can: o map any DXF font with a V5 font, o associate a X scale factor to reframe a font with a different geometry (characters too wide or too narrow) to achieve the best possible alignment , o define a default font to be used when there is no mapping for a DXF font, o define a default KANJI font, other than SSS4, to be used when the BigFont DXF font is not mapped.

• • • • •

1. You need to work in administrator mode. To do this, proceed as follows: • • Set up the CATReferenceSettingPath variable. Start a V5 session using the -admin option.

For more information, refer to the Managing Environments chapter in the Infrastructure Installation Guide. 2. Set the variables CATCollectionStandard and CATDefaultCollectionStandard. If none of the conditions are respected, a warning message will appear to let you know that you will neither be able to modify nor save the XML files. 3. Select Tools -> Standards to launch the standards editor. 4. Choose the dxf category, and then open the DXF.xml file from the dropdown list. Expand the LineTypeMapping node in the editor. 5. Select the line type 1 on the left. On the right, its DXF name and CATIA type number are displayed. Use the spinner to change it to another CATIA type number.
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5. Repeat this step with the other line types. 6. Click OK to save your modifications in the current file and exit the standards editor. or Create a new mapping standard file using the File - > Save as New command. Call it DXFDoc.xml in the directory.

If you have created a new DXF mapping standard file, it is now available in the drop-down list in the DXF settings (available through Tools/Options/General/Compatibility)
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Locking Settings
For more information, please refer to the Infrastructure User's Guide Customizing Options

Management of DXF Settings
In this scenario, administrators will learn how to lock settings using DXF setting as an example. The procedure is the same when locking other settings. 1. You need to work in administrator mode. To do this, proceed as follows: • • Set up the CATReferenceSettingPath variable. Start a V5 session using the -admin option.

2. When logged as administrator, a green lock button is displayed to the left:

Clicking this green lock (which then turns ) lets you lock the default parameters for all users. As a consequence, the values of those options will be locked when
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DXF
This page deals with: • Import DXF/DWG options: o Standards, o Unit of the file, o Paper Spaces in Background, o Keep Model Space, o Create end points, o Convert dimensions as, Export DXF/DWG options: o Exported sheets, o Version, o Export mode.

•
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Import
Standards

Drafting: The element you import will be placed in a Drawing, the root document of Drafting. This Drawing uses styles defined in a pre-defined or a customized standard such as ISO, JIS, ANSI, ASME. For more details about Drafting standards, please refer to Administration Tasks in the Interactive Drafting User's Guide. Drafting Standards replace the process of the previous releases where you had to open, (eventually modify) and close a new Drawing to recover the standard you wanted to use for the data you were going to import. The standard selected in the settings is taken into account at once. DXF: DXF Standards replace the mapping options of the previous releases. Those options applied only to the current session whereas a given standard applies to all the sessions using that standard. For more information, please refer to the Infrastructure User's Guide Customizing Standards. Some AutoCAD elements do not exist in V5 and require a mapping: • • • AutoCAD color is mapped to V5 line thickness, AutoCAD line type is mapped to V5 line type, AutoCAD text font is mapped to V5 text font.

These mappings are defined in a DXF standard file. For more details about DXF standards, please refer to DXF/DWG: Administration Tasks in this User's Guide. Select the requested standards from the drop-down lists. The content of these lists depends on which standards have been created and/or customized by your administrator.

Unit of the File
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By default, the option is set to Automatic and the unit of import is determined automatically (either millimeter or inch) for the best possible resulting drawing. However, in some cases the resulting drawing is not satisfactory and requires another unit. Select this unit in the list. Then restart the import. If you have selected Scale Factor, enter the value of the scale factor between the imported file and what you want to get from the original Drawing in the fields on the right.

Paper Spaces and Model Space
The Interactive Drafting workbench provides a simple method to manipulate a sheet. A sheet contains: • • • a main view: a view which supports the geometry directly created in the sheet a background view: a view dedicated to frames and title blocks interactive or generated views.

An AutoCAD file is usually made of: • • a model space that contains the geometry, a paper space (or several in AutoCAD 2000). AutoCAD recommends that the paper space contains the title box and one or several viewports (A viewport is a window to the model space). However other configurations are possible.

Select this option to put the Paper Spaces in the Background view. The viewports will be created in the working view. By default, this option is not selected.
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Select this option to keep the entire Model Space in its own sheet. By default, this option is not selected.

Create end points

It is not easy to modify and stretch geometry of imported elements the way you can do it in a V5 native elements. A solution is to create end points when needed, but to the detriment of performances. Create end points offers you three options to fit your needs: • • • Never: it is the default option. It ensures the best performances. For few entities: creates end points only for hatch boundaries and mixed polylines. This is an intermediate choice between performances and edition capabilities. Always: creates end points for arcs, ellipses, lines, mlines, leaders and not standard polylines and splines. Use this option only when edition capabilities are required.

Information on the option selected is given in the report file:

Convert dimensions as
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Select the required option: • Dimensions:

This option preserves the semantic of AutoCAD dimensions in V5 as best as possible. • In most cases, the whole semantic of the dimension is kept. This means the position, the layout and the text are preserved. The position, color, thickness, text caption (symbol, value, tolerance, font, color) can be edited. • In some cases, text with redundant information (e.g. tolerance present both in the dimension field and in the dimension text) or dual dimension, or other unrecognized information will be dealt as a text with an associative link with the dimension. This dimension has a "fake value" that is blanked. To display the true dimension value, delete the associated text and enter the data in the properties of the dimension. Limitation for the Dimensions option: • • • • • • • Angular dimensions, problems may occur while positioning texts, Following attributes are not yet supported : suppression of one of the dimension lines (for half dimensioning), offset extension or suppression of extension lines, arrowhead choice (the V5 default arrowhead is used), automatic suppression of arrowheads if space is not sufficient. Geometry:

Select this option to keep the graphical aspect. Geometry is exploded into multiple lines, arcs, texts. (this mode increases performance when loading a model). This is the option by default • Details: dimensions are turned into details. This is an halfway notion between the previous two, in which the geometry is preserved and the dimension is easy to handle (it can be all selected at once).

See also the FAQ

Export
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Exported Sheets

Select the required option to export either all sheets or only the current sheet of a multi-sheet drawing. • The option Only current exports the data to a file with the name entered in the Save as dialog box. • The option All exports the data to several files. The name of each file is made of the name entered in the Save as dialog box and the name of the sheet (Drawing1_sheet_1.dxf, Drawing_sheet_2.dxf, ...). This is the default option.

Version

Select the required export file format from the combo box. By default, the version DXF/DWG R14 is selected. Version 5 supports DXF/DWG formats version 12, 13, 14 and Autocad2000. Autocad2000i and Autocad2002 formats are the same as Autocad 2000.

Export mode

This option offers the choice between three export modes: • Graphic: This was the only available mode up to Release 9. It is quick and reliable. It is useful if you want to export a CATDrawing to AutoCAD and print it without modifying it. It is the default mode. Structured: This mode was introduced in Release 10. The exported file can be modified. For example, in the case of a dimension exported in Structured mode, all the graphic entities representing the dimension are exported to an Insert/Block. The more complex Drafting elements are exported the same way whereas the basic geometric elements (lines, arcs, etc) are exported as isolated elements.

•
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For more information, see the What About the Elements You Export? section in the Exporting a CATDrawing Document Data into a DXF or DWG File chapter of the Data Exchange Interfaces User's Guide.

IGES
This task shows you how to customize IGES settings, that are divided in four sections: • General IGES options: o Show/NoShow dialog box

•

•

Import IGES options: o Import mode, o Join, o Continuity Optimization of Curves and Surfaces, o Detection of Invalidity in Input Geometry, o Representation for Boundaries of faces, Export IGES options: o Save only shown entities, o Curve and surface type, o Representation mode, o Name of Author, o Author's Organization, o Export Unit as.
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General
Show/NoShow Completion Dialog Box

By default, the Show Completion Dialog Box option is not selected. Select this option to display the completion dialog box at the end of the transfer.

Import
Import mode

By default, the Generate one CATPart option is selected. In this mode, the IGES file is translated into one CATPart. For large files containing a large number of 308/408 IGES entities, you can select the option Map the 308/408 IGES entities onto a Product Structure: • • if the IGES file contains 308/408 entities, a root CATProduct is created in V5, the 408 entities will be translated into CATParts or components under the root CATProduct as follows: o If the 408 entity references an intermediate 308 entity (i.e. one that contains 408 entities), a new component is created. It will contain components for each 408 of the 308 (see first case below). o If the 408 entity references a leaf 308 entity (i.e. one that does not contain any 408 entity), a CATPart will be created. It will contain the geometry contained in this 308 (see second case below).
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Names of products, components and instances are not supported.

Join

By default, this option is not selected. • Select the option Join surfaces of the model if you want to join the surfaces of your IGES model into a shell. If this option is active, the software will try to knit the surfaces from an importable file into a shell, even if the file contains Groups (402). You can edit the Tolerance which is used to join the surfaces of the model: If you know the tolerance of the system which has created the IGES file, you can use it. Otherwise, it is better to begin with a small tolerance.

•

• • • • •

If you select the join option, while importing IGES files to V5, make sure that model is constituted of one part. The Join operation may fail in specific topological configurations. This option does not apply to Manifold Solid Brep (IGES type 186): the faces are always imported into a join. The previous option Join surfaces of each group is replaced by the Map the 308/408 IGES entities onto a Product Structure above. This option enables you to create several CATParts from one IGES file. When the Map the 308/408 IGES entities onto a Product Structure option is active, the option Join surface of the model is selectable but has no effect.
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Continuity Optimization of Curves and Surfaces

V5 requires its geometry to be C2-continuous. When non C2-continuous geometry must be imported from a IGES file, this geometry (curves, surfaces) is broken down into a set of contiguous geometries, each of them being C2-continuous. This is what happens when the No Optimization option is chosen. However, this can produce an increase of the size of the resulting data, because more curves/surfaces are created. In order to limit this drawback, two other modes are optionally offered. In those modes, the IGES interface tries to limit the splitting of curves and surfaces by modifying their shape slightly, so that they become C2-continuous while remaining very close to their original shape. In order to guarantee that the deformation is not excessive, a maximum deviation (tolerance) parameter is used. When in Automatic Optimization mode, the value read from the IGES file is corrected so that it remains lower than 0.001 mm. This guarantees an optimization that remains compatible with the precision for the data that was set by the emitting system. Last, if this strategy is not enough, you can choose the Advanced Optimization mode, in which an arbitrary deviation value can be entered. By default, the Automatic Optimization is proposed: • • No approximation , thus this option does not create a significant deformation and keeps the internal BSpline structure (equations and knots). A continuity optimization is performed within the default value for deformation tolerance (0.001 mm) on: • BSpline surfaces, • all types of curves with the exception of canonical curves (3D and Pcurves when available), • The parameters box cannot be activated

This option soften the effect C2 cutting of faces and boundaries (which is mandatory in V5) without any significant geometric deformation If you select No optimization: • • No optimization is performed on BSplines (neither curves nor surfaces). Elements are cut at discontinuity points to suit the modeler (exact
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collaboration mathematic continuity). This may result in a dramatic number of faces and boundary curves, data of poor quality and poor performances in further use in V5. If you select Advanced Optimization: • • No approximation. The internal BSpline structure (equations and knots) is kept, A continuity optimization is performed on: o BSpline surfaces, o all types of curves (3D and P-curves when available), o but the deformation tolerance is set by the user (see Parameters).

•

With this option, you can enter a larger tolerance value which may enhance the optimization impact (resulting in less C2 cutting on faces). Push the Parameters button to access advanced optimization options and tolerances.

User-defined Tolerances • • • Deformation: maximum deformation (in millimeter) allowed in the optimization of curves and surfaces. Ranges between 0.0005 and 0.1 mm. Angle: angle (in degree) below which contiguous elements can be merged. Ranges between 0 and 10 degrees. Push the Default Values button to revert to the default values (respectively 0.001 and 2).

The parameters values apply to all current options User-defined Advanced Options By default, these options are not selected. • Curves and Surfaces Approximation alone:
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• • • •

BSpline surfaces and curves continuity is optimized, In addition, Bspline curves and surfaces approximation is performed, It is possible to enter a user value for Deformation, This option may change the internal structure of BSplines (equations and knots),

• This option usually results in a significant decrease in the number of faces cuttings. • Topological Reduction of Boundaries alone: • BSpline surfaces and curves continuity is optimized, • In addition, topological reduction is applied to boundaries, • The Angle value is used to select contiguous curves that can be merged into a smooth one (tangency criteria), • It is possible to edit the values for Deformation and Angle, o This combination of options usually results in a significant decrease in the number of boundary curves (especially on poor quality input data). • Curves and Surfaces Approximation and Topological Reduction of Boundaries together: • BSpline surfaces and curves continuity is optimized • In addition, BSpline curves and surfaces approximation is performed and topological reduction is applied to boundaries • It is possible to enter user values for Deformation Tolerance and tangency Angle. • This combination of options allows the utmost optimization of curves and surfaces, while keeping geometric deformation under control. It results in reducing the number of faces and boundaries and ensures better performance in downstream use of the data. You can find useful information in the report file. Please see the Report file section in the IGES Import chapter in this User's Guide.
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Detection of Invalidity in Input Geometry

You can choose to import IGES files with or without detecting discrepancies in geometry, by selecting the corresponding option. Detection enables you to enter the Tolerance value above which a geometry is considered as invalid: • • size of a hole in an open boundary, distance between the boundary loop and the surface.

By default, the Detection option is selected. The default Tolerance value is 3 mm. For more information, please see the IGES Best Practices chapter in this User's Guide.
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Representation for Boundaries of Faces

There are two type of IGES faces: types 144 and 143. The boundaries of those faces (respectively type 142 and 141) have two representations: • • 2D (parametric) 3D (spatial).

For each boundary, the IGES file contains a parameter defining the preferred representation: • • • • 3D, 2D, none, equal preference.

In the three last cases, V5 tries to import the 2D representation of the boundary. In case of failure, the 3D representation is imported. By default, the Keep File Preference option is active: • • if the preference is set, the import will respect it. If no preference is set, the 2D representation is preferred.

If you do not wish to use the 2D representation (i.e. override the preference set in the IGES file), select the Force 3D representation option. Only the 3D representation will be imported.

Import Groups

By default, this option is selected and import IGES groups (Entity Type 402, Forms 1-7-14-15: Associativity Instance) as Selection Sets. You can de-select this option for a faster import. Note that Selection Sets will not be created.

Export
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Save only shown entities

•

When selected, the Save only shown entities option allows you to save only the Part's entities which are in the Show mode. This is the default option. Click to clear it to export the whole model.

Curve and surface type

•

The default Standard option and the BSpline option allow you to select which curve and surface types you want to be generated. If you leave the default Standard option selected the curve and surface types created in the Part are kept as is. If you select the BSpline option all curves and surfaces are converted into Bsplines.

Representation mode

• •

If you select the default option Surface, solid decomposition will be identical in both the original model and the resulting file. Only the surfacic decomposition of the original model is stored. Wireframe should be used if you want 3D visualization of solid edges to be identical in both the original model and the resulting file. Only the wireframe decomposition of the original model is stored. This may be useful in cases where curves are the only form of input accepted. Solid-Shell lets you save Solids, Shells and Faces as IGES New Entities as follows:

•

V5 Solid Solid (Closed) Shell Independent Shell Face in a Shell Face Loop List of Loop Edges List of Start/End Loop Edges Vertices 406

IGES Manifold Solid B-Rep Object Entity (Type 186, Form 0) Closed Shell Entity (Type 514, Form 1) Open Shell Entity (Type 514, Form 2) Face Entity (Type 510, Form 1) Loop Entity (Type 508, Form 1) Edge Entity (type 504, Form 1) Vertex Entity (Type 502, Form 1)

Project Standards Plane Surface (support of Face) Plane Surface Entity (Type 190, Form 0)

• •

•

For Loops, only the 3D Representation is exported All those new IGES entities have not been "tested" (IGES Norm 5.3) and the IGES/PDES Organization recommends that special consideration be given when implementing certain untested entities. Therefore if you do not know whether the receiver system will recognize those entities, we recommend that you do not use this option. The representation mode Solid-Shell requires IGES version 5.3 or higher.

Author's Name and Organization

Enter here your name and the name of your organization. This information will be transferred to the Global Section of the IGES file at export.
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Export Units as
Let's you define the unit to be used for export. This unit can be different from the V5 file. The default option is Keep User Unit, the IGES file unit will be : • the unit defined in Tools -> Options -> General ->Parameters and Measure / Units tab, if the IGES Norm recognizes it,

•

the Millimeter (mm) otherwise.

Units like the one named Feet, Inch, Decimal are not recognized by IGES Norm. If such Units are selected in Parameters and Measure / Units tab and if the option selected is Keep User Unit, the IGES file unit will be the Millimeter (mm).

IGES 2D
This page deals with: • Import IGES 2D options: o Standards, o Unit of the file, o Destination view, o Create end points, o Convert dimensions as,
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•

Export IGES 2D options: o Exported sheets, o Export mode.

Import:

Standards

Drafting: The element you import will be placed in a Drawing, the root document of Drafting. This Drawing uses styles defined in a pre-defined or a customized standard such as ISO, JIS, ANSI, ASME. For more details about Drafting standards, please refer to Administration Tasks in the Interactive Drafting User's Guide. Drafting Standards replace the process of the previous releases where you had to open, (eventually modify) and close a new Drawing to recover the standard you wanted to use for the data you were going to import. The standard selected in the settings is taken into account at once.

Unit of the file

By default, the option is set to Automatic and the unit of import is determined automatically (either millimeter or inch) for the best possible resulting drawing. However, in some cases the resulting drawing is not satisfactory and requires
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another unit. Select this unit in the list. Then restart the import.

Destination view

Select the view in which you want to import the file. The default Destination view is Working views.

Create end points

It is not easy to modify and stretch geometry of imported elements the way you can do it in a V5 native elements. A solution is to create end points when needed, but to the detriment of performances. Create end points offers you three options to fit your needs: • • • Never: it is the default option. It ensures the best performances. For few entities: creates end points only for hatch boundaries and mixed polylines. This is an intermediate choice between performances and edition capabilities. Always: creates end points for arcs, ellipses, lines, mlines, leaders and not standard polylines and splines. Use this option only when edition capabilities are required.

Information on the option selected is given in the report file:
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Convert dimensions as

If you select: • Dimensions: linear, angular and circular dimensions will be preserved, others (ordinate types) will be transformed into details. This option keeps the semantic of the dimension. This means the position, the layout and the text are preserved. The position, color, thickness can be edited. The text of the dimension is a text that has an associative link with the dimension. This dimension has a "fake value" that is blanked. To display the true dimension value, delete the associated text and enter the data in the properties of the dimension.

Limitation for the Dimensions option: • • • • Linear dimensions: rotated dimensions, i.e. linear dimensions with a fixed angle other than horizontal or vertical are turned into details, Radial dimensions: problems may occur while positioning arrows, Angular dimensions, problems may occur while positioning texts, Following attributes are not yet supported : • suppression of one of the dimension lines (for half dimensioning), • offset extension or suppression of extension lines, • arrowhead choice (the V5 default arrowhead is used). • • Geometry: geometry is exploded into multiple lines, arcs, texts. Select this option to keep the graphical aspect (this mode increase performance when loading a model). Details: dimensions are turned into details. This is an halfway notion between the previous two, in which the geometry is preserved and the dimension is easy to handle (it can be all selected at once). This is the default option.

Export
Exported Sheets
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Select the required option to export either all sheets or only the current sheet of a multi-sheet drawing: • The option All exports the data to several files. The name of each file is made of the name entered in the Save as dialog box and the name of the sheet (Drawing1_sheet_1.ig2, Drawing_sheet_2.ig2, ...). This is the default option. • The option Only current exports the data to a file with the name entered in the Save as dialog box.

Export mode

This option offers now the choice between three export modes: • Graphic: This was the only available mode up to Release 11. It is quick and reliable. It is useful if you want to export a CATDrawing and print it without modifying it. It is the default mode. Structured: This mode is introduced in Release 11. The exported file can be modified. For example, in the case of a dimension exported in Structured mode, all the graphic entities representing the dimension are exported to an Insert/Block. The more complex Drafting elements are exported the same way whereas the basic geometric elements (lines, arcs, etc) are exported as isolated elements. Semantic: This mode is introduced in Release 11 and is similar to the Structured mode, with the advantage that linear dimensions are exported as true dimensions (with a default dimension style). "Default dimension style" entails that most graphic attributes (such as color, display format of the dimension value, type of arrow, space...) of the dimensions are lost.

•

•

For more information, see the What About the Elements You Export? chapter.

STEP
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This page deals with: • General STEP options: o Detailed report, o Geometric Validation Properties (GVP), o Groups (Selection Sets). Import STEP options: o Continuity optimization of curves and surfaces, o Assemblies physical structure, o Insert existing component, Export STEP options: o Application Protocol (AP), o Units, o Show/NoShow, o Header of the STEP file, o Assemblies.

•

•

General

Detailed report
By default, the report file contains a Detailed Conversion chapter. Click to clear the Detailed Report option to remove this chapter from the report file.

Geometric Validation Properties (GVP)
This functionality is available in STEP AP214 only. By default it is not selected. When the Geometric Validation Properties option is selected, the Tolerances button becomes available. It opens a dialog box where you can define the tolerances for the GVP checking. • The first tolerance is the percentage of variation of volume or area allowed. Default value: 1%. • The second tolerance is the maximum error for the center of gravity, expressed in mm. Default value: 1mm. • You can retrieve the default values (1 and 1) with the Default Values button.
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For import:

• •

Geometric validation properties are computed for each solid, shell, product or instance, and this information is written in the report file. For each solid, shell, product or instance, the report file gives the computed geometric validation properties: • Centroid: coordinates of the center of gravity (applies to solid, shell, product or instance), • Area: area of the entity (wetted area for solids) (applies to solid, shell or product), • Volume: volume of the entity (for solids only) (applies to solid or product).

• •

If the imported STEP file contains geometric validation properties, these properties are read. This information is written in the report file. For each read geometric validation properties, the report file gives the status of comparison between read and computed properties, with the following information: • Centroid deviation error (distance measure) (applies to solid, shell, product or instance), • Surface area difference value and error ratio (applies to solid, shell or product), • Volume difference value and error ratio (applies to solid or product).

•

A global status for the conversion is given, together with the maximum deviations found.

Example of report file:
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•

The status of comparison for a given solid, shell, product or instance is ok if: • ratios (Volume difference and Surface area difference) are lower than 1%. • and the centroid deviation is lower than 1 mm.

• • •

If all status are ok, the global status is ok too. The maximum deviation found for each comparison (centroid, area and volume) is given in the report file with the corresponding entities (the maximum deviations found do not necessarily apply to a single object). This functionality involves a slight performance loss, due to the properties computation cost.

For export:

•

•

The exported STEP file includes geometric validation properties for each solid, shell, product or instance, according to STEP AP214 and the CAX-IF recommended practices. For each solid, shell, product or instance, the report file gives the computed geometric validation properties: • Centroid: coordinates of the center of gravity (applies to solid, shell, product or instance), • Area: area of the entity (wetted area for solids) (applies to solid, shell or product), • Volume: volume of the entity (for solids only) (applies to solid or product).
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• • •

The unit used for geometric validation properties is the STEP length user unit. See Unit option. If the option Assemblies/Structure only is selected, the Geometric Validation Properties are not available. This functionality involves a slight performance loss, due to the properties computation cost.

Groups (Selection Sets)

By default, this option is selected: • • at import, Groups found in the STEP file are translated into Selection Sets. at export, Selection Sets found in the CATIA file are exported as Groups in the STEP file. Refer to the STEP: Export chapter for more information (Miscellaneous section).

However, importing or exporting Groups may be time consuming. Click to clear this option and de-activate the processing of Groups.

Import
Continuity optimization of curves and surfaces

By default, Automatic optimization is selected. This setting allows a better user control over the number of curves and surfaces that are created during the process of importing STEP data into V5:

V5 requires its geometry to be C2-continuous. When non C2-continuous geometry must be imported from a STEP file, this geometry (curves, surfaces) is broken down into a set of contiguous geometries, each of them being C2-continuous. This is what happens when the No Optimization option is chosen.
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However, this can produce an increase of the size of the resulting data, because more curves/surfaces are created. In order to limit this drawback, two other modes are optionally offered. In those modes, the STEP interface tries to limit the splitting of curves and surfaces by modifying their shape slightly, so that they become C2-continuous while remaining very close to their original shape. In order to guarantee that the deformation is not excessive, a maximum deviation parameter is used. When in Automatic optimization mode, this maximum deviation is read into the STEP file itself, in the STEP parameter that documents the precision of points in the file. In this mode, the value read from the STEP file is then corrected so that it remains comprised between 10E-2 and 10E-3. This guarantees an optimization that remains compatible with the precision for the data that was set by the emitting system. Last, if this strategy is not enough, you can choose the Advanced optimization mode, in which an arbitrary deviation value can be entered. You can find useful information in the report file. Please see the Report file section in the STEP Import chapter in this User's Guide. The Automatic optimization proposes: • • No approximation, thus this option does not create a significant deformation and keeps the internal BSpline structure (equations and knots). A continuity optimization is performed within the deformation tolerance used for optimizing BSplines, comprised between 0.001mm and 0.01mm (depending on the tolerance value defined within the imported STEP file) on: • BSpline surfaces, • BSpline boundary curves (3D and P-curves when available), • BSpline independent 3D curves, • The parameters box cannot be activated

This option softens the effect C2 cutting of faces and boundaries (which is mandatory in V5) without any significant geometric deformation If you select No optimization: • • No optimization is performed on BSplines (neither curves nor surfaces). Elements are cut at discontinuity points to suit the modeler (exact mathematic continuity). This may result in a dramatic number of faces and boundary curves, data of poor quality and poor performances in further use in V5.

If you select Advanced optimization: • No approximation. The internal BSpline structure (equations and knots) is kept, 417
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•

A continuity optimization is performed on: • BSpline surfaces, • BSpline boundary curves (3D and P-curves when available), • BSpline independent 3D curves,

•

but the deformation tolerance is set by the user (see Parameters).

With this option, you can enter a larger tolerance value which may enhance the optimization impact (resulting in less C2 cutting on faces). Push the Parameters button to access advanced optimization options and tolerances.

User-defined Tolerance • Deformation: maximum deformation (in millimeter) allowed in the optimization of curves and surfaces. Ranges between 0.005 and 0.1 mm. The default deformation is 0.003. Push the Default Value button to revert to the default value.

•

User-defined Advanced Option: Curves and surfaces approximation: • • • • • • By default, this option is not selected. BSpline surfaces and curves continuity is optimized, In addition, Bspline curves and surfaces approximation is performed, It is possible to enter a user value for Deformation, This option may change the internal structure of BSplines (equations and knots), This option usually results in a significant decrease in the number of faces cuttings.

Assemblies physical structure

This option enables the processing of sub-assemblies of an imported assembly.
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By default, it is not selected. A CATProduct file containing the whole assembly structure and a CATPart file for each part of the assembly are created. If you select this option, a CATProduct file containing the sub-assembly structure is created for each node of the whole assembly while a CATPart file is created for each part of the whole assembly. STEP File Assembly file containing the geometry of components One CATProduct for each product is One CATProduct for each product is not selected selected P CATProduct + N CATPart 1 CATProduct + N CATPart

Assembly file referencing STEP files containing the geometry of components

1 CATProduct + N CATPart

P CATProduct + N CATPart

Assembly file referencing native files containing the geometry of components

1 CATProduct + N native files

P CATProduct + N native files

Insert existing component

This option appears only if both the V5 - STEP AP203 Interface and the V5 - STEP
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collaboration AP214 Interface and the MULTICAx STEP Plug-in exist on the machine. By default it is not selected. Select it to activate the MultiCAD mode.

Export
Application Protocol (AP)

The default value is AP203 iso. You can switch it to AP 203 + ext or AP214 iso or AP 203 ed2. The data contained in a CATPart or CATProduct document will be saved in STEP AP203 or AP214 formats. For more information about STEP AP203, AP203 with extensions, AP203 edition 2 and STEP AP214, refer to Exporting CATPart or CATProduct Data to a STEP AP203 / AP214 File.

Units

The default value is mm (millimeter). Select the required unit to export a CATPart or a CATProduct in STEP format and in Inch or millimeter independently of the V5 Session unit.

Show/NoShow

By default, those options are not active. A CATProduct to export may contain: • • • visible entities placed in the Show space, hidden entities placed in the NoShow space. By default, they are not exported. hidden entities placed in layers that are not visualized (for more information, see Using Visualization Filters). Visualization filters are now taken into account: by default, entities placed in non-visualized layers are no longer exported.

Select the Export also NoShow entities option to export all entities belonging to both the "Show" and the "NoShow" spaces. Select the Export non-visualized layers option to export also all entities belonging to those layers.
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Note that the entities placed in the NoShow or in non-visualized layers are exported as if they were visible entities. This means that reading back a STEP file generated with the Export also NoShow entities or the Export also non-visualized layers option will make those previously hidden entities visible.

Header of the STEP file
Push the Define... push button to define the header of the STEP file: Fill in the form displayed as required. You can revert to the Default Values of the header by pushing the Default Values push button.

The header of the exported file looks like this:

Assemblies

Select the required option to select the export mode. • • One STEP file: one STEP file only containing the structure and geometry of the components. This is the option by default. Structure only: a STEP file containing structure and entities
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collaboration PRODUCT_DEFINITION_WITH_ASSOCIATED_DOCUMENT which have a link with CATPart files. STEP external references: • one STEP file containing the structure • and a STEP file for each component The STEP file names, for each component, have the same name as the components. the structure and the component STEP files are generated in one shot, in the same location. • CATIA external references: one STEP file containing the assembly structure with external links to CATPart, CATShape, model V4, .cgr, .wrl files, according to AP214 and AP203 edition 2 external references mechanism.

•

The External References functionality is available only with AP214 and AP203 edition 2. A STEP file cannot refer to a STEP assembly file. This summary table shows you all the possible combinations within the first two frames, Export : Application Protocol and Export : Assemblies. Frame Export AP --------Frame Export Assemblies One STEP file
(3)

203 and 203+ext(1) YES NO (inactive button) NO (inactive button) YES

203 edition2 YES YES YES YES

(2)

214

(2)

YES YES YES YES

STEP External References (4) CATIA External References (4) Links to CATIA (5)

(1) = reference of the Application Protocol Config Control Design (AP203) (2) = reference of the Application Protocol Core Data for Automotive Mechanical Design Processes (AP214) (3) = Export of the Structure and Geometry of a CATProduct into one file only (4) = Export of the Structure and Geometry of a CATProduct into different files (5) = Export of the Structure only of a CAProduct If you have no STEP license: • • in batch mode, you cannot export a CATProduct in Links to CATIA mode, in interactive mode, you can export a CATProduct in Links to CATIA mode.
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Project Standards Dynamic Licensing: If you release the STEP license and you access the STEP options panel, the export assemblies options may change. In this case, when you recover the STEP license, you have to go back to the STEP options panel to restore the good values.
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