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Basic Tasks
Installing and Uninstalling Digital Project
Overview of Digital Project Installation
The Digital Project software line is a suite of Product Lifecycle Management tools that allows users to design, analyze, collaborate, plan, manage building construction in 3D. A partial list of its components includes • • • Digital Project application Project Standards Comprehensive set of documentation including tutorials

You must have administrator rights to the computer you are installing To install all these components of Digital Project on a computer, you will need: • • • • Digital Project installation CD. Project Standards installation CD. Digital Project Service Pack CD Online Documentation installation CD.

NOTE: Project Standards are required to be installed to run the application. You can choose to have 1. Single client installation: Typically for single user setup or evaluation setup. This will install all the project standard files along with the application. The installation order will be: • • • Digital Project Application Select ‘Install project Standards’ option at the end of the installation. Project Standards Digital Project Service Pack

2. Shared standards installation. Typically for deployment on a project or a multiple-user environment.
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installationDeployment This allows multiple users to share resources and files related to the project from one centralized location. The installation order will be: • Project Standards – on a shared location. • Digital Project Application Select ‘Use existing standards’ option at the end of the installation. • Digital Project Service Pack The following outlines the steps required to deploy Digital Project: 1. Install the Digital Project application and Project Standards 2. Install the Service Pack 3. Obtaining, Installing, and Using Licenses. 4. Install the Online Documentation.

Installing the Digital Project Application
You must have administrator privileges to perform this task This task show you how to install Digital Project. . 1. Insert the Digital Project installation CD. Let it auto run or run the Setup.exe file in the root directory of the CD. You will see the Welcome page when "Setup.exe" is running :
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Click "Next" to begin setup. 2. Read the license agreement.

Click "Yes" to accept the license agreement and continue.
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3. In the "Choose Destination Location" dialog specify the directory to install digital project. You can keep the default directory location or select another directory by clicking "Browse" button..

Click "Next" to continue.
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4. If you already have other CATIA product installed on your system, the following "Input IDENT String" dialog will appear.

Click "Next" to continue.

5. In "License Server Name" dialog specify the license server name or license 5

installationDeployment server IP address.

Click "Next" to continue. Note : If license server name or license server IP address is not known you can still click "Next" to continue installation process and later edit the environment file to specify the license server name or license IP address. 6. Setup is now ready to install. You can make any changes if required to the previously set information before selecting "Next" button.
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Click "Next" to start installing.
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7. After installation is complete the following dialog box will pop-up :

Click on "OK" button. After setup has finished installing Digital Project you have to install the Project Standards.

The installer presents two options: o Use existing Project Standards This option is to specify to use existing Project Standards (already installed) on a central fileserver.
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Basic Tasks Select this option, and click Next. You are asked to select the location where the project standards are installed. Click OK and the setup will update your environment according to the location of the standards and exit the installation. For further details: Install Project Standard on Central Server. o Install Project Standards This option allows the user to install the project standards as part of the setup. Select this option and click Next. The installer will ask you to load the Project Standards and Catalogs CD. Insert the CD and click Next to install the project Standards. For further instructions see How to Install Project Standards. Note : You will require Project Standards CD for installation process.

•

Since you will need a license to run Digital Project, see Obtaining, Installing, and Using Licenses. There are two ways to run Digital Project: o By double-clicking on the DigitalProject icon on the Desktop

•

o

From the Start menu by selecting Programs -> Digital Project V1,R2 -> Digital Project V1,R2

Installing Project Standards for the First Time
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You must have administrato privileges to perform this task.

This task show you how to instal Project Standards and Catalogs provided with the application. The installation Wizard will guide you through the process. Please follow the instructions on the screen. 1. Insert the Digital Project Standards installation CD. Run the Setup.exe file in the root directory of the CD. You will see the Welcome page:
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Click "Next" button. 2. A window "Chose Destination Location" will pop-up, click the "Browse" button to select the "Destination Directory". If you are installing the standards and catalogs at a centralized server, click here for specific instructions after you finish the installation.

Click "Next" to continue.
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4. Different steel section catalogs are provided with the installation. If you have not purchased the STRUCTURAL STEEL product you do not need to select any of these libraries. If you want to install these section catalogs, select Yes and click Next

If you selected to install steel section catalogs then the installer will ask you to select the steel section standards that you wish to be installed.
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Select the required libraries and click Next

5. Now the installation is ready to install Digital Project Standards and the selected steel catalogs

If any changes are to be made to the setup, click Back, else click Next.

6. When the installation is complete "Finished" dialog will pop-up:
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Click on "Close" button. 7. If you have previous installations of Digital Project then remove the CATSettings located for a standard installation at C:\Documents and Settings\userID\Application Data\Gehry Technologies\CATSettings - where userID is your login name. You can also refer to CATUserSettingsPath information for finding the default settings location on your machine. For information to get a license to run Digital Project, please refer to the section Obtaining, Installing, and Using Licenses.
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Installing Project Standards on a Central Server
This task show you how to set up the environment on each client machine if you install the standards and catalogs separately on a central server You will have to perform the following set up tasks: • • Setting up catalog search paths Project resource management

Setting up catalog search paths:
To access the catalog parts, you need to add the search paths for the application. Steps: 1. Launch the application. 2. Go to Tools > Options and select the General > Document tab. 3. In the ‘Linked Document Localization’, select ‘Other Folders’ and click on ‘Configure’
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4. In the window that comes up, browse to the directory where you have installed the project standards. 5. Click ‘Add Tree’ to add the path and all its sub-folders as the search paths for the application. All the search paths can be seen in the lower window. This will rectify the broken links in the catalogs.

Project Resource Management (PRM):
This applies if you are using the Structural Steel package. The ‘Project Resource Management’ (PRM) file is setup for the AISC steel standards catalog. The customized Project_AISC.xml file is located in $(install_dir)/Project Standards/startup/ProjectData Make sure the CATDisciplinePath variable in the environment file is set to this path. If you choose to install/use other standards, you need to select the corresponding PRM file Follow these steps to use other installed standards:
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1. Start Digital Project. Go to one of the Structure Design workbench. 2. Go to Tools > Project Management > Select/Browse. 3. From the Projects tab, select ‘Project_STD’ (where STD = Standards you want to use) as the active resource. 4. Click OK. This will set up the new PRM file for use in the application.

For detailed information, refer to online documentation of ‘Designing Structures > Project Standards > Managing Project Resources’.

Details on the Digital Project Service Pack 1 Upgrade Process
A Digital Project V1,R2 SP1 installation process includes following installation steps. you or your systems administrator can create your customized batch file for upgrading Digital Project.

Installation Steps
1. Check if the Digital Project V1,R2 is already installed on your machine 2. Insert the Digital Project Service Pack 1 installation CD. Let it auto run or run the Setup.exe file in the root directory of the CD. You will see the Welcome page when "Setup.exe" is running :
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Click "Next" to begin installation. 3. Software License Agreement dialog is popped up, read the agreement and then

click "Yes" to accept the agreement. 4. Setup is now ready to install
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Click "Next" to start the installation. 5. After the installation is complete "Finished" dialog is popped-up

Click "Close" to end the setup.
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About the Environment Created on Your Computer
A Digital Project V1,R2 installation has the following impact on your computer.

Installation Folder
The software is installed (if you used the default location) in the folder: C: \Program Files V1,R2 \Gehry Technologies\ Digital Project

Shortcuts
The installation creates the following shortcuts

•

Digital project V1,R2

and Digital Project V1,R2 License

Administrator • •

on the desktop

Start->Programs->Digital Project V1,R2->Digital Project V1,R2 Start->Programs->CATIA->Tools, with access to utilities provided by CATIA

Environment File
A Digital Project global environment (not a user environment) is created. For more information about global and user environments, refer to What are global and user environments?. The environment is created in a text file located in:C: Settings\ Technologies All Users \CATEnv \Application Data \Gehry \Documents and

and the environment file name is:DigitalProject.V1R2.txt

FlexLM Host ID
The installation generates a text file HostID.txt
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in the installation directory, for example C:\Program Files\Gehry Technologies\Digital Project V1,R2\HostID.txt The text file contains the host ID which is required when requesting FlexLM license.

Environment Variables
The installation adds CATNoStartDocument with value yes into the system variables.

Please refer to Advanced Tasks section for more details of changes to the workstation.

All end users can now log onto the same computer and run a Version 5 session, because the environment created at installation is global.

Uninstalling Digital Project and Project Standards
This task explains how to uninstall • • Digital Project Project Standards

Note that you are not able to selectively uninstall a configuration or product. Anyone familiar with Windows procedures and concepts can uninstall the software without assistance You must have administrator privileges to perform this task. Before removing the software, you must remove any user environments you created after the initial installation using the tools described in Customizing Your Environment.

Uninstalling Digital Project
Uninstalling Digital Project using Start Program menu On the Windows desktop, select the Start->Programs->Digital Project>Remove Digital Project.
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Uninstalling Digital Project using control panel There are four steps to uninstall Digital Project. 1. On the Windows desktop, select the Start->Settings->Control Panel, then double-click the Add/Remove Programs control. An Add/Remove Programs dialog box appears. 2. Find Digital Project - V1R1 and select it. The program name could be different, if you specified this name in the fourth step of installation because you also have other CATIA product installed.

3. Click the Change/Remove... button. A message informs you that the folder: C:\Program Files\Gehry Technologies is going to be removed, and prompts you to confirm that you want to continue and remove all the software. 4. Click Yes to confirm. ALL the installed configurations and products will be removed. The program removes: • • • • the installation folder all desktop items: environment icon, all entries in the Start>Programs menu the last environment created all registry entries You may be prompted to kill any running processes which use the version you are uninstalling. If this is the case, click the Yes button when prompted.

Uninstalling Project Standards
Uninstalling Digital Project Standards using Start Program menu On the Windows desktop, select the Start->Programs->Digital Project
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Basic Tasks Standards->Remove Digital Project Standards. Uninstalling Digital Project Standards using control panel 1. On the Windows desktop, select the Start->Settings->Control Panel, then double-click the Add/Remove Programs control. An Add/Remove Programs dialog box appears. 2. Find Digital Project - Project Standards and select it.

3. Click the Change/Remove... button. A message informs you that the folder: Digital Project - Project Standards is going to be removed, and prompts you to confirm that you want to continue and remove all the software. 4. Click Yes to confirm.

This will remove all the installed Project Standards and Catalogs.

Starting a Session in a Language Other than English on Windows
This task explains how to start Digital Project in a language other than English on Windows.

Locales for which Digital Project delivers user interface files
Installing Digital Project installs the user interface files for the following languages: • • • • • • English (default language) French German Japanese Korean Simplified Chinese
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You then simply use the tools on your operating system to choose the language in which you want to start your session. If no language is chosen, your session will be started in English.

1. Select the Start->Settings->Control Panel command, double-click the Regional Options control, then click the General tab (if it is not displayed by default). The following dialog box appears:

In our example above, English is selected.
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2. Select the desired language from the languages available on the list. For example, selecting any of: • Chinese (PRC) • Chinese (Taiwan) will start the session in Chinese. The same applies to the other language variants.

Note that the Regional Options tab does not activate your input locale: for example, it does not activate the keyboard map for the language you selected. 3. Click the Languages tab if you want to select the input locale for your language.

.
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4. Click the Details... button then select the appropriate input locale. In our example below, you selected Chinese (Simplified):

5. Click OK twice, then start Digital Project.
Translating user interface files

You can translate user interface files in a language for which Digital Project does not deliver user interface files. For example, you can do the following: 1. Open the following file: C:\Program Files\Gehry Technologies\Digital Project V1, R2\DSB15\intel_a\reffiles\NLS\SUPPLANG Note that this file contain the following lines: *NT* ... Simplified_Chinese China 0804 936
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2. Copy the message catalog folder from the installation folder to your folder: C: C:\> cp -r "Program Files"\"Gehry Technologies"\Digital Project V1, R2\DSB15\intel_a\resources\msgcatalog "Program Files"\"Gehry Technologies"\Digital Project V1, R2\MyB15\intel_a\resources

3. Reference this new folder in the environment (update the CATMsgCatalogPath environment variable using the Environment Editor, see "Managing Environments", so that it point to the preceding folder). 4. Create a Simplified_Chinese folder in the CATMsgCatalogPath environment variable root folder: C: C:\> cd "Program Files"\"Gehry Technologies"\Digital Project V1, R2\MyB15\intel_a\resources\msgcatalog C:\> mkdir Simplified_Chinese

5. Create translated versions of user interface files in the Chinese language The General.CATNls user interface file, at least, must be translated. The files will be placed in the following folder: C:\Program Files\Gehry Technologies\Digital Project V1, R2\MyB15\intel_a\resources\msgcatalog\Portuguese

6. In the regional options (see above), choose the Simplified_Chinese language. 7. Start Digital Project.

Locales Whose Use with Digital Project has been Validated
The locales (see the General\"Your locale (location)" field in the "Control Panel"\"Regional Options" above) whose use with Digital Project has been validated are as follows: Czech Danish Dutch (Belgium) Dutch (Netherlands) English (Canadian) English (United Kingdom) English (United States) Finnish
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installationDeployment French (Belgian) French (Canadian) French (Standard) French (Switzerland) German (Austria) German (Standard) German (Switzerland) Icelandic Italian (Standard) Italian (Switzerland) Japanese Korean Norwegian (Bokmal) Polish Portuguese (Portugal) Russian Chinese (PRC) Spanish (Spain, Traditional Sort) Swedish Chinese (Taiwan)

Select a Language Other than English in Digital Project
In Digital Project, select Tools->Customize.... In the Customize dialog, select the Options tab and in the User Interface Language combo box, select the appropriate language. In this example, Simplified Chinese is selected.
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Licensing Overview
Licensing Overview
Welcome to the licensing guide. It is intended to provide the end user and license administrator the necessary information to manage Digital Project licenses. This overview will cover : • • • Introduction The license types Products and rules

Introduction
This document provides basic information about license management in Digital Project. We use FlexLM by Macrovision as the license manager. If you require more detailed information, please refer to the FlexLM End User documentation. It is located in your installation directory under Utilities.

License Types
There are three types of licenses : node lock, floating and borrowable. A node lock license is one that is restricted to a specific machine. You can only run the Digital Project product on that specific machine. It does not need a license server. This is the simplest configuration. The main software requirements are the license file(s) and Digital Project. A floating license is a shareable among a group of users and is part of a pool of licenses served by a license server. The license server consists of a FlexLM license manager and a license daemon provided by Gehry Technologies. In addition to the license file and Digital Project, a license server needs to be set up. The client machine that checks out a floating license from the server must maintain the network connection with the server. Once the network connect is lost or the application exits, the floating license is returned to the server and is available to be checked out again. We also refer to this type of floating license as dynamic license in documentation and the application user interface.
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installationDeployment A borrowable license is a special kind of floating license. Once the license is borrowed, the user can disconnect from the network and continue to use the Digtial Project for the borrow period. The borrowed license is returned to the server when the user returns it earlier or when the borrow period expires. Once the license server has been set up, the user will use an application to request and return floating/borrowable licenses. This topic is covered in Using a Floating License and Using a Borrowable License.

Products and Rules
Base Configurations
Currently, we are providing the following base configurations : • Viewer : Project portal for reviewers. This configuration allows you access geometry, attribute editing , measuring and takeoffs. This product is appropriate for project managers, estimators and on site construction personnel. Foundation : Production level configuration. This configuration is intended for doing light geometric modeling, attribute modeling, information extraction, drawing production and data coordination. Designer : This configuration provides full geometric (advanced solids, features, surfacing and wireframe geometry) and knowledge modeling capabilities for advanced architects and engineers. It also includes component instantiation capabilities and libraries of architectural objects.

•

•

These configurations are available in both local and floating formats.

Enhanced Configurations
The following configurations build on the base configurations to provide additional specialized capabilities. • • • Design for Reuse : builds on Designer and adds Knowledge Template and Knowledge Advisor. MEP Engineer : builds on Foundation and adds Systems Routing Educational: builds on Designer and adds System Routing, Structural Steel, STEP Translator, STL Translator, Knowledge Template, Knowledge Advisor and Primavera Integration. Structural Engineer : builds on Foundation and adds Structural Steel. DesignerAndStructure : builds on Designer and adds Structural Steel. DesignerAndSystemsRouting : builds on Designer and adds Systmes Routing. ViewerAndProjectManager: builds on Viewer and adds Project Manager. ViewerAndPrimaveraIntegration: builds on Viewer and adds Primavera Integration. FoundationAndPrimavera: builds on Foundation and adds Primavera Integration.

• • • • • •
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These configurations are available in both nodelock, floating and borrowable formats.

Add-Ons
The following are specific, dedicated products to enhance configurations. Unlike enhanced configurations, the add-ons are are restricted to borrowable licenses and you will be able to pick and choose from the following list of products. • Systems Routing : This add on provides modeling capabilities for schematic design of HVAC, piping and electrical systems. Please note that this requires a minimum base configuration of Foundation or Designer. Structural Steel : This add on provides structural libraries and translators to support structural engineering modeling and drawing generation, integration with 3rd party solvers and detailing software. Please note that this requires a minimum base configuration of Foundation or Designer. Step Translator : This add on provides interoperability with 3rd party products through the STEP AP214 and STEP AP203 data formats. Please note that this requires a minimum base configuration of Foundation or Designer. STL Translator : Provides the ability to import and export STL (stereolithography) files for displaying meshes and quality analysis. Please note that this requires a minimum base configuration of Foundation or Designer. Knowledge Template : Provides utilities to develop libraries of intelligent design templates for standardizing corporate practices. Please note that this requires a minimum base configuration of Designer. Knowledge Advisor : Provides real time rules and checks that can be built into intelligent component libraries developed with Knowledge Template. Please note that this requires a minimum base configuration of Designer. Project Manager : This product enables the creation and extraction of architectural, engineering and construction modeling and coordination information in the Master Model. It's an add-on to Viewer and is included in Foundation and Designer. Primavera Integration : This product provides users with means to link the 3D BIM components to Primavera™ activities and to simulate these activities in 3D (4D Navigation).

•

•

•

•

•

•

•

These products are only available as dynamic and borrowable licenses.

Nodelock Licenses
This section describes how to • • Obtain a nodelock license Install a nodelock license

Obtaining a Nodelock License
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installationDeployment To obtain a nodelock license, you need to gather the necessary information to submit to Gehry Technologies. • machine id -- After you've installed Digital Project, this is found in C:\Program Files\Gehry Technologies\Digital Project V1, R2\HostId.txt The HostId.txt file will look like

After you've gathered this information, please follow this link to request the license: http://www.gehrytechnologies.com/support-request-uncounted.html

Installing a Nodelock License
After receiving your license file, you will need to copy it into the directory specified in your Digital Project environment file. The directory for the license file is defined by the variable LM_LICENSE_FILE, the default location is: C:\Program Files\Gehry Technologies\Digital Project V1, R2\FlexLMLicense You can change this value but make sure to copy your license file(s) to that location.

NOTE:
If you run into problems, you may need to trouble shoot.
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Floating Licenses
Floating Licenses
There are two types of floating licenses: dynamic and borrowable A dynamic license is checked out when the Digital Project application is running and it is returned automatically once the application exits. During the Digital Project session, the application must maintain network connection to the license server. A borrowable license can be checked out for a specific number of days. During this time, the user does not need to be connected to the network. Once the user is finished using the license, they can return it early. If the user hasn't returned it before the expiration time, the license will automatically be returned to the pool of licenses. As for the license administrator, he/she will need to request the license(s), set up the license server, and make sure the client has properly set up their environment.

Using a Dynamic License
To use dynamic licenses you need to run the Digital Project License Administrator to select the desired licenses. Note the selected licenses are not checked out at this time. They are saved to a setting file. The Digital Project application will check out the selected licenses when it is launched.

Launching the Digital Project License Administrator
To launch the license administrator, from Windows go to : Start -> All Programs -> Digital Project V1, R2 -> Digital Project V1, R2 License Administrator Or you can activate the short cut on the desktop :

After the application has been launched, a panel will appear :
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Requesting the Desired Product
Once the Digital Project License Administrator is running, find the row with the license name you want to use and check the checkbox in the Dynamic column. Finally, press OK.
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Then run the Digital Project application, and check if the features associated to the selected licenses are available.

Using a Borrowable License
To borrow a license you need to run the Digital Project License Administrator to borrow and return the license.

Launching the Digital Project License Administrator
To launch the license administrator, from Windows go to : Start -> All Programs -> Digital Project V1, R2 -> Digital Project V1, R2 License Administrator Or you can activate the short cut on the desktop :
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After the application has been launched, a panel will appear :

Requesting the Desired Product
Once the Digital Project License Administrator is running, specify the number of days you would like to borrow and check the check box in the Borrow column and in the row of the license name you would like to borrow. If you specify 1 day, the borrowable license will expire almost 3 hours after the midnight of the current day. Finally, press OK.
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If an error occurs during checkout, a pop up window will appear to display an error message. Note: Once a license has expired, you will start receiving various error messages. In addition, the Digital Project License Administrator will no longer display the product in its list, since it only displays current and active products. To return a borrowed license, just uncheck the corresponding check box.

Administering Floating Licenses
Requesting a Floating License for Digital Project
To obtain a floating license, you need to gather the necessary information to submit to Gehry Technologies. If you have Digital Project installed on your FlexLM license server machine, please send HostID.txt with your license request. The HostID.txt file can be found at {INSTALL_DIR}\HostID.txt, for example, C:\Program Files\Gehry Technologies\Digital Project V1,R2\HostID.txt.
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After you've gathered this information, please follow this link to request the floating license: lhttp://www.gehrytechnologies.com/support-request-counted.html

Setting Up Your Network License Server
To set up your license server, you will need to • • • copy the license files to a designated directory launch the licensing server shut down the licensing server

Copying License Files
Copy the license file to the designated directory (license_directory) in the next section.

Launching the Licensing Server
38

Basic Tasks The license server consists of two executables : lmgrd.exe and gt.exe. In order to activate the license server, lmgrd needs to launched either manually or automatically each time the server computer is restarted. • • • After you have installed Digital Project on a client machine, locate lmgrd and gt. Both of these are located in the directory ..\Digital Project\GTR1\Utilities Copy these files to the server machine. We suggest that you copy them to a common directory. We'll refer to this directory as the server directory. For manual activation, you will need to o open a dos prompt o change the current directory to the server directory o in that directory you will find lmgrd. In the following, license_directory is the directory containing the license files. To execute the command, type: lmgrd -c license_directory -z

•

For automatic activation, you will need to modify the start up script for your server to automatically launch this command (lmgrd -c license_directory -z) every time you restart the server machine.

Shutting Down the Licensing Server
Periodically, you will need to shut down the license server. Please do not do a hard shut down using the task manager. Instead, use the lmdown command. If you do not do this, the borrowing mechanism will be corrupted and users who have borrowed licenses will not be able to check them back in. Please contact support if you have problems. To execute this command : • • open a dos prompt change the current directory to the server directory. If lmdown is not in that directory, you can find it in the same installation directory that you found lmgrd and gt.
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•

in response to the question Are you Sure (y/n)? type y to shut down the license server.

Upgrading Licenses
Necessary Information
Before submitting the request to upgrade a license, locate your current license file you want to upgrade. This file will contain • • host id of the server or local machine. product name

In addition, you will need to know the expiration date and the number of floating licenses.

Submitting the Request
After you have gathered all of the necessary information, go to the Gehry Technologies web-site and submit the request. http://www.gehrytechnologies.com/support.html

Trouble Shooting
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Nodelock Licenses
If, after installing the nodelock licenses, Digital Project does not incorporate your license, please check the following: That the LM_LICENSE_FILE is correctly defined in the environment variable file. That the host id of the license matches your machine id. The Expiration Date of your license is valid.

Borrowable Licenses
The user cannot return the borrowed license
The problem may be caused when the server is not properly shutdown. If this happens, please remove the registry key HKEY_CURRENT_USER\Software\FLEXlm License Manager\Borrow using the following steps: 1. Open a DOS command prompt window. 2. Type regedit

3. Find the key HKEY_CURRENT_USER\Software\FLEXlm License Manager\Borrow and select it. 4. Press the Delete key.

41

installationDeployment

Installing help Files
Installing Online Help for Digital Project
This task show you how to install online help documentation for Digital Project. There are three tasks: • • • Installing Online help for Digital Project Connecting to the online help Uninstalling Online help for Digital Project
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Installing Online Help for Digital Project
1. Insert Digital Project Documentation CD. Let it auto run or run the Setup.exe file in the root directory of the CD. You will see the Unzip dialog.

Set the folder to extract help and click documentation.

Unzip

to extract the

The default installation directory path is: C:\Program Files\Gehry Technologies\Digital Project V1,R2\GTR2\Help

Connecting to the Online Help Documentation
You can connect to the Digital Project help in one of the following ways: • If you installed the online documentation in the default location, the welcome page will be displayed immediately if you press the F1 key. When you request help using the Help>Contents, Index and Search command (or press the F1 key for contextual help), the online documentation may not be displayed. This may be because the online documentation may have been physically moved to another location. If the online documentation is not found, the following dialog box appears:
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• • •

Navigate to the folder in which you installed the documentation. Expand the tree until you can select the English folder within it. Press the OK button. You will now be able to use help within Digital Project

For more detailed information about using the Help System in Digital Project.

Administrators and experienced users may want to distribute a common CATEnv file for others to use in your project: • • If you installed the help files elsewhere on the network, you must first map the appropriate network drive before starting a session and then follow the next step. If you installed the online documentation elsewhere and it is connected to the network or on a server, you must first update the CATDocView variable in your environment to reference the environment containing the online documentation. If you do not reset the CATDocView variable, a dialog box will prompt you to specify the location.
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Basic Tasks • Doc Installation Path From Tools->Options select the General category and select the General tab. The Doc installation path field for the Digital Project Documentation Location option displays the path of the folder in which the online documentation is installed. The path is the same path you entered when you installed the online documentation. The path is the value of the CATDocView environment variable.

Uninstalling the Online Documentation

Navigate to the folder in which you installed the help documentation and delete the English folder. Since the files are read-only, you will need to allow the system to delete the read only files. Alternatively, you can change the properties of the English folder and all of its subfolders and documents from write, by making sure that the Read-only box is not checked and then by deleting the English folder.

For more detailed information about using the Help System in Digital Project.
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Software Requirements
Common Software Requirements
Digital Project runs on selected system levels of: • • Windows 2000 Windows XP

Refer to the Program Directory at www.gehrytechnologies.com/support.html.

Windows 2000 / XP
Minimum level required: Windows 2000 Professional Edition, with Service Pack 4 or higher, or Windows XP Professional Edition, with the following components: • A Microsoft implementation of OpenGL libraries, as delivered with Windows 2000 or Windows XP. For recommendations related to driver levels based on tested graphic adapters, visit:

http://www.ibm.com/solutions/plm • A localized version of the operating system may be required when selected installation differs from Latin 1.

Note: For remote access from networked clients, Terminal Server is supported by Windows 2000 Server, Windows 2000 Advanced Server and Windows XP Professional.

Access to Online Documentation
Product information is delivered on the product CDs in HTML format. An HTML browser is required to access this documentation.

Supported Browsers
On Windows, Microsoft Internet Explorer 6.0 or higher On UNIX or Windows, Mozilla 1.4 with Java Plug-ins at level 1.4 (the java level is available in the Program Directories). Although access to the online documentation might work on other HTML browsers, incidents specific to browsers other than those specified are not eligible for support.
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installationDeployment Product information is also supplied on the product CDs in Portable Document Format (PDF) form. Viewing and printing of the PDF files requires the Adobe Acrobat Reader at a minimum level of 5.0. The reader can be downloaded, at no charge, from: http://www.adobe.com/

Macro Replay Capabilities
Digital Project has built-in macro record and replay capabilities. For Windows, the interpreter is either: • Visual Basic Script (VB Script) at minimum level 5.0. It is delivered with Microsoft Internet Explorer. VB Script libraries at level 5.0.0.3715 are delivered with Microsoft Internet Explorer 5.0 or at later levels with later versions of Microsoft Internet Explorer. Use of VB Script is recommended for developing Windows/UNIX compatible macros. Microsoft Visual Basic for Applications (VBA) at minimum level 6.0. VBA is delivered and installed by default with Digital Project.

•

Printer and Plotter Support
Printers and plotters are supported through the vendor's drivers for the targeted printer of plotter relative to the targeted version of the operating system. Contact the printer or plotter vendor for requirements and support.

Batch monitoring using WebSphere(R) MQ (WMQ) (formerly MQSeries(R))
Using WMQ communication tools, some batch operations can now be launched remotely. When implemented at the batch level, this optional feature requires WMQ at minimum level 5.2. For availability of client and server components on supported platforms, visit: http://www.ibm.com/software/integration/wmq/ WMQ Client is required on systems where the transaction is initiated. WMQ Server is required on systems where remote batches are executed.

Batch Installation
Details of The Digital Project Installation Process
A Digital Project installation process includes following installation steps [by combining the details on these steps and these two topics]: • Installing the Embedded CATIA Component Using the start Command

48

Advanced Tasks • Installing the Embedded CATIA Component using the start B Command

you or your systems administrator can create your customized batch file for installing Digital Project.

Installation Steps
IN the following discussion, we refer to the current release as Rn, where n corresponds to the current release 1. Check if the Digital Project V1,Rn is already installed by reading registry key HKEY_LOCAL_MACHINE\SOFTWARE\\Gehry Technologies\Digital Project\V1Rn\DEST_FOLDER. If it is installed, stop the installation process. 2. Prompt user for the installation directory. 3. Write the registry entry KEY_LOCAL_MACHINE\SOFTWARE\\Gehry Technologies\Digital Project\V1Rn\DEST_FOLDER. 4. Check if IDENT string is needed for GT Media installation. 5. If IDENTstring is required, prompt user to input the IDENTstring and validate it. The IDENTstring should just contains uppercase letters or numbers and should not exceed 20 characters. 6. Write the registry entry KEY_LOCAL_MACHINE\SOFTWARE\Gehry Technologies\Digital Project\V1Rn\ENV_FOLDER. 7. Pops up the ready to install message. 8. Copy Digital Project files. 9. Run %CDROOT%\INTEL\StartB.exe to install GT media. 10. Run %CDROOT%\GTRn\utilities\HostID.exe to retrieve and save user's system's host ID in the file HostID.txt under the installation directory. 11. Run %CDROOT%\VBA\vba6.msi to install Visual Basic for Application. 12. Run setcatenv to create environment file for Digital Project. The env file name is DigitalProject.V1Rn setcatenv -e DigitalProject.V1Rn -p "C:\Program
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installationDeployment Files\Gehry Technologies\Digital Project\GTRn;C:\Program Files\Gehry Technologies\Digital Projects\DSB14" -a global -caa DigitalProject.exe -menu no -desktop no 13. Write the registry entry KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ Session Manager\Environment\CATNoStartDocument to yes. 14. Associate following file types to Digital Project: .CATPart, .CATProduct, .CATDrawing, .CATfct, .catalog, .CATMaterial, .CATRaster, .CATShape, .model, .session, .library. 15. Create shortcuts for Digital Project on desktop and in the Start menu. 16. Create shortcuts for Digital Project License Administrator on desktop and in the Start menu. 17. Show the installation complete message. 18. Show the dialog either to install the Digital Project Standards or to use an existing Digital Project Standards. 19. If user selects install for the Digital Project Standards, prompt for the location of the installation CD and install the Standards.

Installing the Embedded CATIA Component Using the StartB Command
The StartB batch command lets you install Version 5 without the graphical user interface. You can install all Version 5 software except online documentation in batch mode. Note that, if your Version 5 software is delivered on more than one CD-ROM, you must copy all the software to the same directory from which you run this command. You can: • • copy all the software into the same folder or, given that the software is distributed on several CDs ( 1, 2 ...), copy the contents of each CD into a separate folder for each CD, making sure that the name of each folder corresponds to the CD number ( 1, 2 ...)
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Advanced Tasks etc. To perform a batch installation: 1. Select Start->Programs->Command Prompt to open a Command Prompt window. 2. Go to the directory containing the copied software, then to the Intel folder. 3. Enter the command: StartB with the appropriate arguments.

StartB Command Syntax
-u "unload_dir": specifies the unload directory; make sure the directory path is enclosed like this: "unload dir" if the directory name contains spaces; the default unload directory is: C: Program Files Dassault Systemes B15

-ident IDENT: creates an identifier used for differentiating multiple versions of the same release installed in different locations on the same computer; the IDENT must not exceed 20 characters and must be in uppercase -newdir: creates the unload directory if it doesn't exist -D env_dir: specifies the environment directory; the default environment directory is: C: Data Documents and Settings DassaultSystemes All Users Application

CATEnv

-lic "pathname.lic": specifies the path and name of the nodelock license certificate to import -exe: runs a Version 5 session at the end of the installation -orbixport port1: specifies the Orbix daemon port number -orbixbase port2: specifies the starting port number for daemon-run servers -orbixrange: specifies the range for daemon-run servers -addUserPrivilegesForOrbix: adds required privileges for Orbix for current user if they are missing
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-backbonePorts port3 port4: specifies the ports reserved for the communication backbone - default values are 55555 and 55556 -VRPort port5: specifies the port reserved for processing events when using peripheral devices (spaceball, spacemouse, joystick); the default port for the peripheral device broker is 55557 -noSetupPorts: specifies you do not want to set up any communication ports -CatiaV5Info/-CatiaV5Path Path -CatiaV5EnvPath Path -CatiaV5EnvName EnvName: options for CATIA V5 - ENOVIA V5 LCA interoperability -CatiaV5Info/: used alone, setup takes default values for other parameters -CatiaV5Path Path: specifies CATIA V5 Installation path -CatiaV5EnvPath Path: specifies CATIA V5 Environment path -CatiaV5EnvName EnvName: specifies environment file for CATIA V5 -v: verbose mode -h: displays help. -list: lists the configurations, products and extra products on the CD-ROM -all: unloads all the configurations and the products on the CD-ROM -l "list_to_unload": specifies the list of configurations and/or products to unload. You have to type the list of configurations and/or products, which you can obtain by running the command using the "list" argument. In the list, configuration names look like this: ME2.slt., and product names look like this: KIN.prd. These are the names you must type. Separate the names using a blank. The arguments -list, -all and -l "list_to_unload" are mutually exclusive. -allextra_prd: unloads all the extra products included with the configurations and products that are already installed or to be installed from the CD-ROM. -lextra_prd "list_to_unload": specifies a list of extra products to unload. These extra products must be included with the configurations and products that are already installed or to be installed. -noLang "fr ge it jp ch ko"/-noLang all: specifies user doesn't want to install language user interface files for French, German, Italian, Japanese, Simplified Chinese, Korean -noFonts: specifies user does not want to install language-indexed fonts
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-noreboot: the system will not be restarted if needed -DLL: updates the system DLLs if needed; your computer will be rebooted if the system DLLs are updated -UpdateServices: if used without arguments, it updates the file C: WINNT system32 drivers etc services (Windows 2000) or

C: Windows system32 drivers etc services (Windows XP) with the default communication port numbers, even if the lines already exist in the file; if used with arguments, it can also be used to specify other port numbers. -noDesktopIcon: does not create a startup icon on the desktop -noStartMenuIcon: does not create a startup icon in the Start menu -noStartMenuTools: does not create an entry in the Start menu for the administration tools -Timeout: customizes the server timeout value
Error Codes

The following error codes may appear for a GA installation: 0 1 2 4 5 6 7 10 44 55 Installation OK Insufficient privilege Bad environment Bad media Bad options Allocation problem Prerequisites KO Prerequisites warning (only for 3dcom: concerns ddraw.dll) LUM server to be stopped Installation problem

Example
The following example installs Version 5 software from scratch, creating the unload directory and importing the appropriate licenses. To install the MD2 and DP2 configurations for the CATIA product line, type the following command:
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StartB -u "C:

Program Files

Dassault Systemes CATIAV5_Licenses

B15" -newdir MYCONFIG.LIC

-l "MD2.slt DP2.slt" -lic E:

Note: VBA is not installed automatically by the StartB batch. You have to install VBA6 manually after a batch installation. To do so, run the command: msiexec /q /i pathcdrom VBA VBA6.msi

Installing the Embedded CATIA Component Using the start Command
The start batch command lets you install Version 5 without the graphical user interface. Note that, if your Version 5 software is delivered on more than one CD-ROM, you must copy all the software to the same directory from which you run this command. You can: • • copy all the software into the same folder or, given that the software is distributed on several CDs ( 1, 2 ...), copy the contents of each CD into a separate folder for each CD, making sure that the name of each folder corresponds to the CD number ( 1, 2 ...) etc.

To perform a batch installation, log on as root, change directory to the appropriate directory (or CD-ROM mount point if there is only one CD-ROM) and enter the command: ./start with at least one of the arguments below.

start Command Syntax
-u "unload_dir": specifies the unload directory. The default unload directory is: /usr/DassaultSystemes/B15 -newdir: creates the unload directory if it doesn't exist -D: specifies the /CATEnv environment directory. The default environment directory is /CATENV.
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-lic "pathname.lic": specifies the path and name of the nodelock license certificate to import -env new|replace: if the environment file already exists, you can choose to replace it or create a new one • -env new: If you install the same level several times, the same environment is created each time, and using the same name, except that the name is incremented like this each time: MYPRODUCT.V5R15_1.B15.txt, MYPRODUCT.V5R15_2.B15.txt • -env replace: if you already installed Version 5, you may then have deleted the installation directory, in which case the environment remains; in this case, use the "-env replace" argument to overwrite the existing initial environment and create a new one during the installation. Note that the "replace" option does not replace existing environments that you may have created using the "new" option (or using the "Create New Environment" option when installing using the GUI), and whose name is incremented, for example: MYPRODUCT.V5R15_1.B15.txt -exe: runs a Version 5 session at the end of the installation -s: silent mode -orbixport port1: specifies the Orbix daemon port number -orbixbase port2: specifies the starting port number for daemon-run servers -orbixrange: specifies the range for daemon-run servers -CatiaV5Info/-CatiaV5Path Path -CatiaV5EnvPath Path -CatiaV5EnvName EnvName: options for CATIA V5 - ENOVIA V5 LCA interoperability -CatiaV5Info/: used alone, setup takes default values for other parameters -CatiaV5Path Path: specifies CATIA V5 Installation path -CatiaV5EnvPath Path: specifies CATIA V5 Environment path -CatiaV5EnvName EnvName: specifies environment file for CATIA V5 -orbixboot: boot Orbix daemon at restart -backbonePorts port3 port4: specifies the ports reserved for the communication backbone - default values are 55555 and 55556 -VRPort port5: specifies the port reserved for processing events when using
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installationDeployment peripheral devices (spaceball, spacemouse, joystick); the default port for the peripheral device broker is 55557 -noSetupPorts: specifies you do not want to set up any communication ports -DirCATIAV4: specifies CATIA V4 path for administrator home directory -libCATIAV4 V422-1/V423-1: specifies which version of CATIA V4 to use (V422-1 or V423-1) -DirVPM1: specifies VPM1 path for administrator home directory -v: verbose mode -h: displays help. -list: lists the configurations, products and extra products on the CD-ROM -all: unloads all the configurations and the products on the CD-ROM -l "list_to_unload": specifies the list of configurations and/or products to unload. You have to type the list of configurations and/or products, which you can obtain by running the command using the "list" argument. In the list, configuration names look like this: ME2.slt., and product names look like this: KIN.prd. These are the names you must type. Separate the names using a blank. The arguments -list, -all and -l "list_to_unload" are mutually exclusive. -allextra_prd: unloads all the extra products included with the configurations and products that are already installed or to be installed from the CD-ROM. -lextra_prd "list_to_unload": specifies a list of extra products to unload. These extra products must be included with the configurations and products that are already installed or to be installed. -noLang "fr ge it jp ch"/-noLang all : specifies user doesn't want to install language user interface files for French, German, Italian, Japanese, Simplified Chinese, Korean -noFonts : specifies user doesn't want to install language-indexed fonts -UpdateServices: if used without arguments, it updates the file /etc/services with the default communication port numbers, even if the lines already exist in the file; if used with arguments, it can also be used to specify other port numbers. -Timeout: customizes the server timeout value Reminder: if you run the command without arguments, the installation will be started using the graphical user interface.
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Error Codes

The following error codes may appear for a GA installation: 0 1 2 4 5 6 7 10 44 55 Installation OK Insufficient privilege Bad environment Bad media Bad options Allocation problem Prerequisites KO Prerequisites warning (only for 3dcom: concerns ddraw.dll) LUM server to be stopped Installation problem

Distributing Embedded CATIA Code
About Distributing Version 5 on Windows
There are several ways in which you can provide multiple end users with access to Version 5. You can: • • install the software on each computer directly from the CD-ROM install the software on each computer by mapping to another computer on which the software has been copied and is accessible. When setting up the server you can: o o copy all the software into the same folder (as illustrated above) or, given that the software is distributed on several CDs ( 1, 2 ...), copy the contents of each CD into a separate folder for each CD, making sure that the name of each folder corresponds to the CD number ( 1, 2 ...) etc.

Both solutions are ideal if you want the best level of performance, and involve installing and maintaining the software on each computer. This section explains how to: • • distribute the software from a source computer to a client computer using the StartB batch installation command on the client computer distribute the software from a source computer to a client computer
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installationDeployment using the RCMD command (part of the Windows Workstation Resource Kit) access the software installed on the server from a "light" client on which only a runtime environment is installed, but no code distribute the software in compressed form distribute a service pack from an archive file.

• • •

Code distribution scenarios based on the use of the Install Shield silent installation file mechanism are no longer supported, and are replaced by the use of the StartB batch installation command. There are two types of profile available to end users: • • local user profiles roaming profiles.

Your roaming profile is the same on every computer you use. Windows system administrators should ensure that Version 5 end users use roaming profiles. This will enable end users to log onto different computers to run Version 5 and recover their customizations. Refer to your Windows online documentation for more information about roaming profiles.

Distributing the Software To a Single Client Computer
This task explains how to distribute the software from the server to another computer. Note that the online documentation files can be distributed using the same scenario. You can copy the software into a folder on the source computer, or simply insert the Version 5 CD-ROM into the drive. Then, you can log onto another computer, the client, on which you want to install Version 5, map the drive containing the folder (or the CD-ROM drive directly) and run the StartB batch command to install Version 5 over the network, as illustrated below:
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When setting up the server you can: • • copy all the software into the same folder (as illustrated above) or, given that the software is distributed on several CDs ( 1, 2 ...), copy the contents of each CD into a separate folder for each CD, making sure that the name of each folder corresponds to the CD number ( 1, 2 ...) etc.

Note also that, if an IBM License Use Management Runtime (LUM) license server is running on the computer on which you are installing Version 5, you must stop the server before starting the installation. When you insert the CD-ROM into the source computer, the installation procedure starts automatically. The Setup program displays a message telling you that it is preparing the installation procedure. In our example, you do not need to install the software on the source computer before distributing it, so at this point, you must stop the installation procedure from starting automatically. One way of preventing the installation procedure from starting automatically after inserting the CD-ROM is to press and hold down the Shift key immediately after inserting the CD-ROM. 1. Log on as Administrator onto the remote computer on which Version 5 is to be installed. You must belong to the Administrators group, or have the privileges assigned to the Administrators group. 2. Run the Windows Explorer. You need to use the Explorer to connect over the network to the computer containing the software, and access the StartB batch program in the folder 3. Using the Explorer, select Tools->Map Network Drive...
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4. Select a Drive, then enter either the name of the folder containing the software (in our example, this would be something like Remote_Computer My_CATIAV5_Folder) or directly the CD-ROM drive, or use the Browse... button to navigate, then click the Finish button once you have made your selection. Note that if you browsed to select the folder, its name will be displayed like this in the Folder field: Remote_Computer My_CATIAV5_Folder

Once mapped, the connection to the remote computer in the Explorer window will look like this: My_CATIAV5_Folder on 'Remote_Computer' (L:) You can only map to the other folder or CD-ROM drive if they have been previously set up as shared resources. 5. Open a Command Prompt window and go to the folder on the source computer you mapped previously, and then go to the INTEL folder. 6. Run the command: StartB -h to display help if you are not familiar with the StartB command. 7. Install the Version 5 software. For example, running the command:
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StartB -u "C:

Program Files

Dassault Systemes

B15" -newdir -l

"DP2.slt MD2.slt" -lic E:

CATIAV5_Licenses

MYCONFIG.LIC

will install the DP2 and MD2 configurations (and the corresponding nodelock licenses) for the CATIA product line into the following location: C: Program Files Dassault Systemes B15

For detailed information about the StartB command, refer to Installing in Batch Mode Using the StartB Command.

Distributing the Software To a Client Using the RCMD Command

This task explains an alternative to the previous scenario: how to use the RCMD command, which i Resource Kit for your Windows platform, for distributing the software from a source computer to a inside the same domain.

The Resource Kit must be installed on both the source computer ("ravel" in our example) and the c ("chopin" in our example).

Furthermore, for the RCMD command to operate, the RCMDSVC service must be started beforehan computer. This involves installing a Remote Command server on each client computer, then startin Command server. For more information, refer to the following Windows online help topic: RCMD.EX Command Service. When setting up the server you can:
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copy all the software into the same folder (as illustrated above) or, given that the software is distributed on several CDs ( 1, 2 ...), copy the contents of eac separate folder for each CD, making sure that the name of each folder corresponds to the C 2 ...) etc.

Note also that, if an IBM License Use Management Runtime (LUM) license server is running on the which you are installing Version 5, you must stop the server before starting the installation. The software supplied by Microsoft in the Windows Workstation Resource Kit is not officially suppor (and Dassault Systemes) do not guarantee the performance of the Windows Workstation Resource response times for answering questions, or bug fixes to the tools. The software (including instructio and printed and online documentation) is provided "AS IS" without warranty of any kind. 1. Log onto the source computer using an account with Domain Administrator privileges. 2. Copy the Version 5 software into a folder on the source computer, and share the folder.

For example, the folder name could be My_CATIAV5_Folder ,and you could share the folder using t "CATIA". 3. Select Start->Programs->Windows 2000 Professional Resource Kit->Tools. 4. Double-click the Network Management Tools control, then the Remote Command Service contro A Command Prompt window is opened and you are now located in the directory: C:\Program Files\Resource Pro Kit\rcmd 5. Connect to the remote client computer using the command: rcmd \\remote_computer where "remote_computer" is the name of the remote computer. In our example, the command would be:

rcmd \\chopin 6. Once you are connected to the remote computer, map a drive on the remote computer to the sh the source computer. To do so, enter the command:

net use drive: \\Source_computer\SharedDirName DomainAdminPwd /user:DomainName\DomainA where: • • • • • •

drive is the drive letter used to map to the shared folder Source_computer is the source computer from which you are performing the installation, an shared folder containing the Version 5 software is located SharedDirName is the share name of the folder containing the Version 5 software DomainAdminPwd is the domain administrator password DomainName is the domain name DomainAdminUserName is the domain administrator username.

In our example, the command would be for example:
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net use M: \\ravel\CATIA admin /user:MyDomain\root

This command maps the M: device (the device must be available) on the remote computer "chopin folder "CATIA" on the source computer "ravel", using the domain administrator password "admin". domain name is "MyDomain" and the domain administrator username is "root". To check that the map has been successfully performed, enter the command: net use which will list the mapped resources like this: Status Local Remote Network

OK M: \\ravel\CATIA Microsoft Windows Network For more information about the net use command, refer to the Windows online help system. 7. To check that the installation folder and the StartB batch command are accessible, enter the com M:\INTEL\StartB -h to access the command help, or: M:\INTEL\StartB -list to list the configurations/products you can install. 8. Install the Version 5 software. For example, the command: StartB -u "C:\Program Files\Dassault Systemes\B15" -newdir -l "DP2.slt MD2.slt" -lic E:\CATIAV5_Licenses\MYCONFIG.LIC

will install the DP2 and MD2 configurations (and the corresponding nodelock licenses) for the CATIA into the following location on the remote computer: C:\Program Files\Dassault Systemes\B15 9. Unmap the drive on the remote computer by running the command:

net use M: /delete For detailed information about the StartB command, refer to Installing in Batch Mode Using the Sta

Note that appending the "-exe" option to the StartB command does not launch a session at the end installation on the remote computer. You can also use the System Management Server (SMS), part of the Windows BackOffice suite. SM desktop management and software distribution that significantly automates the task of upgrading s client computers.
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Accessing the Software From a Thin Client
This task explains how to set up thin clients for accessing the Version 5 software over the network. A thin client can run Windows 2000/XP. This type of scenario is sometimes referred to as a "code server" scenario. The advantages of this type of scenario are: • • you save time: the code is installed on the code server only, and not on the clients; and future upgrades and installation of service packs are easier since you only have to upgrade the software on the server, and not the clients you save disk space: code is installed on the server only, so you save disk space on the clients.

The drawbacks with this type of scenario are: • • the code is sent over the network to the client, so you will experience problems if the network is not efficient or goes down the code is executed on the client, so performance may vary depending on the power of the client computer and the amount of memory on the client.

1. Log on as administrator onto the server computer, install the Version 5 software, for example, in the following folder: C: Program Files Dassault Systemes B15

then share the disk and folders in the installation path. 2. Log on as administrator onto the client computer. 3. Run the Windows Explorer. You need to use the Explorer to connect to the server over the network and access
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the C:

Program Files folder on the server.

4. Select Tools->Map Network Drive... The Map Network Drive dialog box is displayed, and looks something like this:

5. Select a drive. 6. Select the folder Program Files on the server, and click Finish. This is the folder containing the Dassault Systemes folder in which you installed the Version 5 software. Note that selecting the folder displays the server name and folder name in the Path field: \\server\Program Files In the All Folders list in the left window of the Explorer, you will now see the connection to the server, for example: Program Files on 'server' (F:) where "server" is the server name, for example, and "F:" is the name of the drive you mapped. 7. Still on the client computer, open a Command Prompt window and go to the following directory: F:\Dassault Systemes\B15\intel_a\code\bin where, for example, "F:" is the name of the mapped drive and represents
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installationDeployment F:\Program Files. 8. Check that the system DLLs on the client are up to date. To do so, run the following command from the same directory: CATSoftwareMgtB -P which checks whether the DLLs on the client are OK or not. The screen output will inform you if the DLLs are OK. If so, proceed to the next step. If the DLLs are KO, run the command: CATSoftwareMgtB -D which provides detailed system information about prerequisite Microsoft DLLs installed and the DLL versions installed on the client. If the DLLs on the client are not up to date, you must update them. You can find the system DLLs on your product CD-ROM in the INTEL_SHARED folder. To update the DLLs on Windows: 1. Insert the product CD-ROM in the CD-ROM drive on the server. 2. On the client, map a drive to the CD-ROM drive on the server. 3. Open a Command Prompt window and go to the INTEL directory on the CDROM. 4. Enter the command: startb -DLL which will update the system DLLs if needed, and reboot your computer. You will then have to restart your computer. 9. Restart your computer if your system DLLs were updated, and open a Command Prompt window to go back to the directory where you were before, Then, run the following command using exactly the syntax indicated, depending on whether you are running CATIA, ENOVIA DMU Navigator or DELMIA: cnext /regserver -env MyEnvironment -direnv MyEnvDirectory dmu /regserver -env MyEnvironment -direnv MyEnvDirectory delmia /regserver -env MyEnvironment -direnv MyEnvDirectory where "MyEnvironment" is the name of the environment, and "MyEnvDirectory" the name of an existing folder containing the environment on the client, if you intend to create an environment on the client as described in step 11a. If you intend to use the environment on the server (step 11b), run the command: cnext /regserver dmu /regserver delmia /regserver
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This activates OLE support which ensures that double-clicking Version 5 document icons on the client will run a Version 5 session. 10. Run the following command, depending on whether you are running CATIA, ENOVIA DMU Navigator or DELMIA: setcatenv -tools -cs MyProductLine -e MyEnvironment -d MyEnvDirectory to set up the Start->Programs->MyProductLine->Tools menu containing the Batch Management V5R15, Environment Editor V5R15, Nodelock Key Management V5R15, Printers V5R15, Settings Management V5R15 and Software Management V5R15 commands. At this point, you have two possibilities: • • create the runtime environment on the client (step 11a) or access the server environment via the network, to avoid creating an environment on the client (step 11b).

11a. Create the runtime environment on the client. To do so, you have two possibilities: • from the F:\Dassault Systemes\B15\intel_a\code\bin directory, run the following command:

setcatenv -p "F:\Dassault Systemes\B15" -e MyEnvironment -d MyEnvDirectory -a global -desktop yes -cs MyProductLine where "MyEnvironment" is the name of the environment, "MyEnvDirectory" is the name of the folder containing the environment and "MyProductLine" is the name of the product line. • or, use the Start->Programs->MyProductLine->Tools->Environment Editor V5R15 command. In this case: 1. Select the Environment->New command to display the New Environment dialog box. 2. Select the Options menu, then the Set Global Storage Directory command, and set the environment storage directory to the same location you set in step 9. 3. Enter the same environment name you also set in step 9. 4. Enter the path of the shared installation folder on the server as follows: F:\Dassault Systemes\B15 5. Select Global for the Mode. 6. Select your Product Line. 7. Click OK. In both cases, a global environment is created on the client computer which can be used by all users who log onto the client.
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installationDeployment 11b. You can also access the server environment via the network. To be able to do so, the code and the runtime environment on the server must be installed in a shared location so you can map it from the client. For illustration purposes, let's suppose you installed the code in: E:\Program Files\Dassault Systemes\B15 To facilitate access to the runtime environment over the network, the environment must be located in a shared easily accessible location, and NOT in the default location in the All Users profile on the server which is: C:\%WINDIR%\Profiles\All Users\Application Data\DassaultSystemes\CATEnv For illustration purposes, let's suppose you created the runtime environment on the server in the following shared location: E:\CATEnv To access the environment over the network: 1. Map a drive to the shared folder on the server. You must choose the same drive letter on the client as the drive on which the code was installed on the server, for example "E:". 2. Open a Command Prompt window and go to the directory "E:", then to the directory: E:\Program Files\Dassault Systemes\B15\intel_a\code\bin 3. To start a session, run the command: cnext -env MyEnvironment -direnv E:\CATEnv dmu -env MyEnvironment -direnv E:\CATEnv delmia -env MyEnvironment -direnv E:\CATEnv where "MyEnvironment" is an example for the name of the runtime environment on the server. Note that this scenario will only work if the drive letter on the client and the drive letter on the server are identical. In certain cases, you may not be able to use the same drive letter on the client and the server. For example, the code is installed on "E:" on the server, but the drive "E:" on the client is not free, so you map the drive "K:". If you then try to start a session, the runtime environment will not be found because the paths referenced in the runtime environment point, for example, to "E:..." like this: ... CATInstallPath=E:\Program Files\Dassault Systemes\B15\intel_a CATDLLPath=E:\Program Files\Dassault Systemes\B15\intel_a\code\bin ... whereas on the client there is no software installed on the "E:" drive.
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To bypass this problem, create a new global environment on the server using the following command: setcatenv -e NewEnvironment -d \\servername\home\CATEnv -a global -p "\\servername\home\Program Files\Dassault Systemes\B15" -desktop no where "\\servername\home" is the UNC name of the server and shared folder, and "NewEnvironment" is the new environment name. Creating a new environment this way will create the correct UNC paths as follows: ... CATInstallPath=\\servername\home\Program Files\Dassault Systemes\B15\intel_a CATDLLPath=\\servername\home\Program Files\Dassault Systemes\B15\intel_a\code\bin ... This time, your attempt to start a session will be successful if you use the following command: cnext -env MyEnvironment -direnv \\servername\home\CATEnv dmu -env MyEnvironment -direnv \\servername\home\CATEnv delmia -env MyEnvironment -direnv \\servername\home\CATEnv Note also that if you disconnect the drive you mapped, you will have to remap it as before for the scenario to continue to work. 12. If you require extended font support, run the following command: VE0IFONT.exe -env MyEnvironment -direnv MyEnvDirectory from the directory: F:\Dassault Systemes\B15\intel_a\code\bin For more information, refer to "Using and Customizing Fonts" in your Infrastructure Users Guide. 13. If you want to record and replay macros, and Microsoft Visual Basic for Applications (VBA), Version 6.0 is not already installed on your client, you have to install VBA manually from the product CD-ROM. To install VBA6 on all Windows platforms, run the command: msiexec /q /i pathcdrom\VBA\VBA6.msi 14. If you need access to the communications backbone and peripheral device broker, the associated port numbers must be set up on the client. Used to support process interoperability (for example, between CATIA and DMU), the backbone needs to be set up on each computer running applications which need to communicate.
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To set up the ports using the default values: 1. Log on as administrator. 2. Open a Command Prompt window and go to the installation directory, for example: F:\Dassault Systemes\B15\intel_a\code\bin 3. Enter the commands: setV5Ports BBDemonService -create For more information about the communications backbone, refer to Communications Backbone Files. 15. If you created a runtime environment on the client, start a session by doubleclicking the environment icon on the desktop or by selecting the command to start the product from the Start->Programs menu. Make sure that you have set up your licenses (either network or nodelocked) before starting a session. 16. If you created an environment on the client, and want to delete this environment, run the following commands: To update the registry (deactivate OLE support): CNEXT /unregserver -direnv MyEnvDirectory -env MyEnvironment DMU /unregserver -direnv MyEnvDirectory -env MyEnvironment DELMIA /unregserver -direnv MyEnvDirectory -env MyEnvironment To delete the reference environment: delcatenv -d MyEnvDirectory -e MyEnv -a global -desktop yes -cs MyProductLine To delete the Start menu entries: delcatenv -tools -cs MyProductLine

Distributing the Software in Compressed Form
This task explains how to distribute the software in compressed form to another computer. Note that you cannot first install a GA level in compressed form, then install a service pack in normal installation mode. In this particular case, you have two solutions: • • reinstall everything in compressed form or use the CATDeltaInstall utility.
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Advanced Tasks 1. Log on as administrator onto the server computer, install the Version 5 software, for example, in the following folder: C:\Program Files\Dassault Systemes\B15 2. Compress the software using a popular compression software product (for example, WinZip), and send it to the computer on which it is to be used. 3. Log on as administrator onto the client computer on which you want to use the software. 4. Once you have retrieved the compressed package, extract it, for example, to the following folder: E: Program Files Dassault Systemes B15

5. Open a Command Prompt window and go to the following directory: E: Program Files Dassault Systemes B15 intel_a code bin

6. Check that the system DLLs on the client are up to date. To do so, run the following command from the same directory: CATSoftwareMgtB -P which checks whether the DLLs on the client are OK or not. The screen output will inform you if the DLLs are OK. If so, proceed to the next step. If the DLLs are KO, run the command: CATSoftwareMgtB -D which provides detailed system information about prerequisite Microsoft DLLs installed and the DLL versions installed on the client. If the DLLs on the client are not up to date, you must update them. You can find the system DLLs on your product CD-ROM in the INTEL_SHARED folder. To update the DLLs: 1. Insert the product CD-ROM in the CD-ROM drive on the server. 2. On the client, map a drive to the CD-ROM drive on the server. 3. Open a Command Prompt window and go to the INTEL directory on the CD-ROM. 4. Enter the command: startb -DLL which will update the system DLLs if needed, and reboot your computer. You will then have to restart your computer. 7. Restart your computer if your system DLLs were updated, and open a Command Prompt window to go back to the directory where you were before, then run the following command using exactly the syntax indicated, depending
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installationDeployment on whether you are running CATIA, ENOVIA DMU Navigator or DELMIA: cnext /regserver -env MyEnvironment -direnv MyEnvDirectory dmu /regserver -env MyEnvironment -direnv MyEnvDirectory delmia /regserver -env MyEnvironment -direnv MyEnvDirectory where "MyEnvironment" is the name of the environment, and "MyEnvDirectory" the name of the folder containing the environment, if you intend to create an environment on the client as described in step 9. This activates OLE support which ensures that double-clicking Version 5 document icons on the client will run a Version 5 session. 8. Run the following command: setcatenv -tools -cs MyProductLine to set up the Start->Programs->MyProductLine->Tools menu containing the Batch Management V5R15, Environment Editor V5R15, Nodelock Key Management V5R15, Printers V5R15, Settings Management V5R15 and Software Management V5R15 commands. 9. Create the runtime environment on the client. To do so, you have two possibilities: • from the E: Program Files Dassault Systemes B15 intel_a code

bin directory, run the following command: setcatenv -p "E: Program Files Dassault Systemes B15" -e MyEnvironment -d MyEnvDirectory -a global -desktop yes -cs MyProductLine where "MyEnvironment" is the name of the environment, "MyEnvDirectory" is the name of the folder containing the environment and "MyProductLine" is the name of the product line. • or, use the Start->Programs->MyProductLine->Tools->Environment Editor V5R15 command. In this case: 1. Select the Environment->New command to display the New Environment dialog box. 2. Select the Options menu, then the Set Global Storage Directory command, and set the environment storage directory to the same location you set in step 7. 3. Enter the same environment name you also set in step 7. 4. Enter the path of the shared installation folder on the server as follows: E:\Program Files\Dassault Systemes\B15 5. Select Global for the Mode.
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Advanced Tasks 6. Select your Product Line. 7. Click OK. In both cases, a global environment is created on the client computer which can be used by all users who log onto the client. Instead of creating an environment on the client computer, you can use access the environment on another computer via the network. For more details, refer to step 11b in Accessing the Software From a Thin Client. 10. If you require extended font support, run the following command: VE0IFONT.exe -env MyEnvironment -direnv MyEnvDirectory from the directory: E: Program Files Dassault Systemes B15 intel_a code bin

For more information, refer to "Using and Customizing Fonts" in your Infrastructure Users Guide. 11. If you want to record and replay macros, and Microsoft Visual Basic for Applications (VBA), Version 6.0 is not already installed on your client, you have to install VBA manually from the product CD-ROM. To install VBA6 on all Windows platforms, run the command: msiexec /q /i pathcdrom VBA VBA6.msi

12. If you need access to the communications backbone and peripheral device broker, the associated port numbers must be set up on the client. Used to support process interoperability (for example, between CATIA and DMU), the backbone needs to be set up on each computer running applications which need to communicate. To set up the ports using the default values: 1. Log on as administrator. 2. Open a Command Prompt window and go to the installation directory, for example: E: Program Files Dassault code bin

Systemes B15 intel_a 3. Enter the command: setV5Ports BBDemonService -create

For more information about the communications backbone, refer to Communications Backbone Files. 73

installationDeployment 13. If you intend to extract offline licenses for use on the client, and the client happens to be a laptop (as described in Enabling Concurrent Offline Licensing), you must install the LUM driver as follows: 1. Open a Command Prompt window. 2. Go to the following directory: E: Program Files Dassault Systemes B15 intel_a reffiles 3. Enter the command: lumdevdi.exe You must run this command only from the specified directory because it contains the file LUMDriver.sys required for the command to work. 14. If you created a runtime environment on the client, start a session by double-clicking the environment icon on the desktop or by selecting the command to start the product from the Start->Programs menu. Make sure that you have set up your licenses (either network or nodelocked) before starting a session. 15. If you want to delete the environment created on the client, run the following commands: To update the registry (deactivate OLE support): CNEXT /unregserver -direnv MyEnvDirectory -env MyEnvironment DMU /unregserver -direnv MyEnvDirectory -env MyEnvironment DELMIA /unregserver -direnv MyEnvDirectory -env MyEnvironment To delete the reference environment: delcatenv -d MyEnvDirectory -e MyEnv -a global -desktop yes -cs MyProductLine To delete the Start menu entries: delcatenv -tools -cs MyProductLine

Distributing a Service Pack From an Archive File on Windows
This task explains how to install a service pack from an archive file, as an alternative to the traditional methods involving installing the service pack from the CD-ROM or using the StartSPKB command.

What Is an Archive File?
An archive file is a file in compressed format on Windows built by a command provided. The compressed file contains installation files containing differences with respect to an earlier installed level of the same release of the same software configuration. A level can be either a GA or a service pack. For example, you can build an archive file containing the differences between level
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Advanced Tasks V5Rn GA and V5Rn SP2 (even if you installed V5Rn SP1 in between).

Building and Installing the Archive
You first need to install several software levels (belonging to the same release) on the source computer. In our example illustrated below, we installed levels V5Rn GA, V5Rn SP1 and V5Rn SP2, and committed the service packs. On the target computers, only the V5Rn GA level is installed. You use the CATDeltaInstall command with the appropriate arguments to build the archive. The resulting archive file can then be copied to the target computer and decompressed using platform-specific tools. For example, you need the Microsoft CabArc.exe utility which can be downloaded from: http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3b310618 The installation files from the archive file then overwrite the installation files on the target computer.

The advantages of this type of installation are: • • an archive file is smaller than a service pack on a CD-ROM, therefore the installation is more rapid you can copy an archive file to other computers on your network and
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installationDeployment automate the installation of the archive using a method of choice. Note that installing a service pack from an archive file always commits the service pack automatically. Make sure that the previously installed service packs on the target computer have been committed before installing the archive. Furthermore, you can only use this method if the configurations/products on both the source and target computers are identical. The traditional methods of service pack installation and the use of the CATDeltaInstall command are interchangeable: you can install a service pack from a CD-ROM, then install another service pack from an archive file.

Installation Procedure
1. Log on as an administrator onto the source computer. You must belong to the Administrators group, or have the privileges assigned to the Administrators group. Otherwise, you will not be able to install the different levels on the source computer. 2. Perform, for example, the following installations: • • • install V5Rn GA install V5Rn SP1 then commit the service pack install V5Rn SP2 then commit the service pack.

3. On Windows, open a Command Prompt window and go to the following directory: C: Program Files Dassault Systemes B0n intel_a code bin

where "B0n" is the level V5Rn. 4. To build an archive file based on the differences between the V5Rn GA and V5Rn SP2 levels, for example, run the CATDeltaInstall command as follows: CATDeltaInstall -s 0 -d "C: Systemes B0n The full command syntax is: CATDeltaInstall -s PreviousServicePackNumber [-d InstallationDirectory] [-l|-a ArchiveFile] [-h] • -s: previous level number: the level can be either a service pack or the GA level for the same release; 0 = GA, 1 = service pack 1, 2 = service pack 2, etc.; the default is 0. A service pack must have been correctly installed if you intend to build an archive based on the differences between this service pack and another level. For example, if you installed only the V5Rn GA and V5Rn SP2 levels, you cannot specify "-s 1" as an argument (because you did not install the V5Rn SP1 level). -d: Installation directory; when the command is run from the installation directory, this argument is not required Program Files users Dassault MyUser MyArchiveFile

intel_a" -a E:

•
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Advanced Tasks -l: only lists the files which are different between the two installation levels; this list can be used to build a different type of archive (for example, WinZip) -a: builds an archive file with the specified name (requires the CabArc utility) -h: help.

• • •

Note that there are two distinct operating modes: • • build an archive file (using the "-a" argument) only list the files which are different between the two installation levels (using the "-l" argument)

On Windows, the archive file compression is handled automatically thanks to the cabarc format. The service pack installed your computer, and used as the basis for comparison with a previous level, must be committed beforehand. If not, the CATDeltaInstall command will not operate. 5. Copy the archive file to a target computer on which you want to install the same service pack level. Keep in mind that the target computer must be running the same Version 5 configuration/products as the source computer on which the archive file was built. 6. Stop all running Version 5 processes on the target computer before proceeding. 7. Install the archive using the following command: cabarc -p -o X E: Files users MyUser B0n " MyArchiveFile "C: Program

Dassault Systemes

8. Start a session to check the service pack has been correctly installed.

Setting Up Your Printers
About Setting Up Printers on UNIX and Windows
You can only print a document (using either the File->Print... command or the Quick Print icon from the Standard toolbar) if a default printer has been set up. On Windows, you print using the default printer declared by your Windows system administrator. However, on UNIX, you will only be able to print once you have set up a printer. You can set up two types of printers: • • Windows Printers 3DPLM Printers.

77

installationDeployment Setting up a Windows printer creates a printer configuration file, needed for printing, in $HOME/CATSettings/Printers. Setting up a 3DPLM printer creates a configuration file containing the printer and the driver configuration settings in $HOME/CATSettings/Printers/PLOTxxxx.xml. If you attempt to print on UNIX before setting up a printer, the following message appears:

The objective of this section is to show you how to set up your environment to get your printer operational, which is performed by creating and customizing a file called a printer configuration file. The role of this file is to declare your printer so it is recognized by Version 5. Once at least one printer has been declared, the above message will no longer appear. We assume that • • the physical printing device has been installed and connected to the system your system administrator has already declared your printer to your UNIX operating system.

On both UNIX and Windows, the default printer is defined using the File-> Printer Setup... command which opens the Printers dialog box (note that the image below shows a Windows dialog box but the look on UNIX is more or less the same):

78

Advanced Tasks

This dialog box displays a list of available and installed printers. Note that if you are working on a UNIX workstation, you will not be able to access Windows printers. Double-clicking one of the printers displayed in the list will open the standard setup dialog box corresponding to the selected printer type. Refer to your Windows documentation for detailed information about using this dialog box. On Windows, you can also double-click Add Printer at the top of the list to open the Add Printer Wizard dialog box:
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installationDeployment This dialog box enables you to choose between: • • Windows Printer: in that case, selecting this option then OK will open the Connect to Printer dialog box in which you will select the Windows printer you wish to add 3D PLM Printer: this option lets you add printers provided by Dassault Syst mes. When clicking OK, the Printer Properties dialog box is displayed to let you define the parameters for your new printer. Refer to Adding a Printer for detailed information. Once a printer has been added, it is displayed at the end of the list and is identified by a specific icon. Refer to the following tasks in this section to learn more about adding, removing, configuring and testing a printer. Note: if you want to set another printer as the default printer, select it from the list then right-click and choose the Set As Default contextual command. The selected printer will be set as the default printer and identified by the following icon: . However, keep in mind that on Windows, the default printer you set is kept throughout your current Version 5 session but not from one session to another. As soon as you exit then restart a new session, the printer set by default is the one defined in Start>(Settings->)Control Panel->Printers.

You can also set up your printers without having to run a Version 5 session. To do so: On Windows 1. Open an MS-DOS window. 2. Change to the default folder in which you installed the product. The default folder is: C: Program Files Dassault Systemes B15intel_a code bin

3. Enter the command: CATPrinterManager On UNIX 1. Change to the directory: /usr/DassaultSystemes/B15/OS_a/code/command/ 2. Run the command
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CATPrinterManager The Printers dialog box opens:

You can then set up your printers as explained above.

Adding a Printer
This tasks explains how to set up your printer on Windows and UNIX. You can only print a document on UNIX if at least one printer has been set up using the File > Printer Setup... command. 1. Select the File->Printer setup... command to open the Printers dialog box then doubleclick Add Printer on top of the list. If you are working on Windows, an additional dialog box named Add Printer Wizard opens:
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This dialog box enables you to choose between: • Windows Printer: in that case, selecting this option then OK will open the Connect to Printer dialog box in which you will select the Windows printer you wish to add • 3D PLM Printer: this option lets you add printers provided by Dassault Syst mes. When clicking OK, the Printer Properties dialog box is displayed to let you define the parameters for your new printer. Just click OK to access the Printer Properties dialog box.

The above capture takes a 3D PLM Printer as an example. If you add a Windows printer, the properties dialog box will display standard setup parameters corresponding to the selected printer type. In that case, refer to your Windows documentation for detailed information about using this dialog box. 2. Click the black arrow next to Driver and choose the appropriate driver for the printer.
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Ask your system administrator which printers require which drivers. The list of available drivers is: • • • • • • • • • • • • PostScript HP-GL/2 RTL HP-GL HP DesignJet 1000 Series CGM Software CGM OCE Raster V5 Print Plugin Driver Windows Enhanced Metafile PDF SVG.

This list varies with your operating system. For instance, some of the abovementioned drivers are not available on UNIX. Note: • SVG (Scalable Vector Graphics) is a language used for describing twodimensional graphics in XML (Extensible Markup Language) format. Three types of graphic objects can be read in this format: vector graphic shapes, images and text. SVG files can be visualized by external applications such as ADOBE products, JASC or BATIK. For detailed information, browse the following Internet site: http://www.w3c.org • CGM Software is intended for viewing applications but bear in mind that some restrictions apply such as: pixel images are not supported, the image size is fixed, polylines are converted into polybeziers (provided that their curves can be modified).

3. In the Paper Format group box, set the desired paper format options: default and maximum paper size, margins and orientation (portrait or landscape). 4. In the Submission Scripts group box, set the desired options activated when the print job is submitted.
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This group box lets you specify: • the default output file name: each time you print a document, an output file is created at the location you specify in the text field • the default queue name: this field lets you choose which print queue to send the print job to. The Custom radio buttons let you specify the location of your own submission scripts. Clicking these buttons activates the Edit Script... buttons to let you modify the script in the Runtime Script window:

The Advanced Configuration... button lets you define advanced configuration settings for the driver. Note that once a printer has been added to the list of printers, you can also access advanced configuration settings by right-clicking the printer in the list then selecting the Configure contextual command. Refer to Configuring an Existing Printer for detailed information.
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5. Click OK to return to the Printer Setup dialog box. A printer configuration file containing all the settings you set in the Printer Properties dialog box is created in $HOME/CATSettings/Printers/PLOT0000.xml which is the default location. The numbers of additional printers created are incremented by one, as follows: PLOT0001.xml, PLOT0002.xml, etc. However, note that when printing to 3DPLM printers, you can now modify the default location of the configuration file via the Printers tab. The format of Version 4 plot configuration files is not compatible with the Version 5 format.

Removing a Printer
This tasks explains how to delete a printer. At least one printer must have been set up using the File -> Printer Setup... command. 1. Select the File->Printer setup... command to open the Printers dialog box:

2. Select the printer to be deleted from the list of printers
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3. Right-click then select the Remove command to remove the printer. The printer configuration file located in $HOME/CATSettings/Printers/PLOTxxxx.xml (the default location) is deleted. However, note that when printing to 3DPLM printers, you can modify the default location for the configuration file via the Printers tab. Note: you cannot remove Windows printers.

Configuring an Existing Printer
This tasks explains how to reconfigure an existing printer.

About Configuration Files for 3DPLM Printers
Up to V5R11

In previous releases, the driver and printer configuration files were stored apart in permanent sett customization you perform mainly using the various tabs provided by the Tools->Options... comma Permanent print settings were created by default in a location referenced in the Version 5 runtime variable: • •

C in "C: Documents and Settings user Application Data DassaultSystemes this scenario) on Windows in the CATSettings directory in your home directory (also referred to as "$HOME") on UNIX

The driver and printer configuration files were stored in two different files defined as text files: • • the printer configuration file was stored in $HOME/CATSettings/Printers/PLOT0000.plot_cfg the driver configuration file was stored in $HOME CATSettings

Print.CATSettings and

From V5R12 onwards

For the sake of convenience, a single configuration file in XML format is used to configure the print configuration file is totally independent from the Version 5 settings which means that it can be exc systems, for instance, without any problem.

By default, the configuration file will still be stored in the permanent setting files created in a locat variable. This location is: • $HOME/CATSettings/Printers/PLOT0000.xml (on Windows)
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•

$HOME

CATSettings

Printers

PLOTxxxx.xml (on UNIX).

However, you will see further in this guide that you can choose a directory other than the default o Any modification entered in the Printer Properties dialog box (detailed below) will be written in XM There are as many .xml files are they are 3DPLM Printers and the numbers of additional printers a PLOT0000.xml, PLOT0001.xml, PLOT0002.xml, etc.

Note that configurations from previous releases are also supported, which means that, if your print you will be able to translate it into XML format.

About Configuration Files for Windows Printers

As far as Windows printers are concerned, the application uses the driver and printer setting files i

Configuration Example
The following gives an example with a CGM printer. For a description of the configuration of other refer to Configuration Scenarios. At least one printer must have been set up using the File -> Printer Setup... command. 1. Select the File->Printer setup... command to open the Printers dialog box:
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You can also access the Printers dialog box using one of these two methods: • by selecting Start->Programs->CATIA->Tools->Printers V5Rn where "n" is the current release number • by accessing the directory /usr/Dassault Systemes/B0n (on UNIX) or C: Systemes B0n intel_a code Program Files

bin (on Windows) then entering the following co

CATPrinterManager 2. Select the CGM printer to be reconfigured from the list of printers.

3. If the printer you are configuring is associated to a .plot_cfg file, right-click the printer from Convert to XML contextual command:

A configuration file in XML format replaces the .plot_cfg configuration file.
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4. Right-click the printer from the list then select the Configure contextual command (or dou access the Printer Properties dialog box.

The above capture takes a 3D PLM Printer as an example. If you add a Windows printer, the prop standard setup parameters corresponding to the selected printer type. In that case, refer to you detailed information about using this dialog box. 5. Modify the necessary data in the properties dialog box. Refer to Adding a Printer for detailed information on the printer properties. 6. Click the Advanced Configuration... button to configure the CGM driver.

7. Access the Specifications tab:

• In the CGM Level area, activate the Allow CGM Version 3 Generation if you want to generat • In the CGM Profile area, select the profile to be used by checking the corresponding option
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o ISO: CGM is a graphics format defined by the International Standards Organization I o ATA (Air Transport Association): part the ATA Specification 2100. GREXCHANGE, for technical documentation of the manufacture and operation of co binary and clear text encodings at the CGM Version 3 functionality level. It is appr technical manuals, publishing applications, and visualization. IGEXCHANGE provides for the transfer of intelligence associated with graphical dat application structuring defined in CGM Amendment 2. Both profiles are developed and maintained by the ATA/AIA (Airline Transport Asso o CALS (Continuous Acquisition and Life-Cycle Support): part of the CALS family of sta U.S. Department of Defense for technical illustrations and publications. This profile the CGM Version 3 functionality level. 8. Access the Delimiters tab:

• Begin Metafile: all CGM files start with the same identifier, BEGIN METAFILE, and you can e identifier. The default is "3D PLM CGM Driver" • Begin Picture: sets the default state the CGM interpreter will return to at the beginning of e "Picture #1". 9. Access the Descriptors tab:
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• Metafile Description: enter the description text to be used for the metafile (e.g. author, dat • VDC Type: Specify the type of coordinates for the metafile, either "Real" or "Integer" • Scaling Mode: Select the mode to be used by activating the corresponding option o If you choose "Metric", you need to enter the physical size of the CGMs in millimeter o If you choose "Abstract", it means that CGMs are dimensionless (they do not have a measure in pixels, inches, etc.). In that case, Virtual Device Coordinates (VDC) are • Line Width Specification Mode o Absolute: activate this option if you want line width to be measured in VDC units o Scaled: activate this option if you want the line width on the printer to be automatic set as a scale factor to be applied to a device-dependent nominal line width. 10. Access the Graphics tab:
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In the Font Substitutions list, select a font then set the property of your choice by activating the • Discretized means that when the image suffers from a lack of points, points are distributed • Not Substituted • Substituted lets you replace the selected font by a suitable replacement font you select in t right of the radio buttons. Note that you need to define these properties for each font used in the document to be printed.

11. When finished defining your parameters, click OK to validate and close the Advanced Config close the Printer Properties dialog box. The printer configuration file ($HOME/CATSettings/Printers/PLOTxxxx.xml) is modified.

When printing to a 3DPLM printer, the default location for the configuration file (containing the c and the printer) can be modified if needed in the Printer Creation Directory area under the Printe 9. Access the printer configuration file then open it, you will see that your modifications have

In our example, we changed the paper format from "A4 ISO" to "B ANSI" and the CGM Profile fro modifications have been highlighted in red in the sample file below for greater clarity. Just click t picture:

Note that a .dtd file containing the description of the XML configuration file is provided in: • C: Program Files Dassault Systemes Bn intel_a (on Windows) • /usr/DassaultSystemes/Bn/OS_a/resources/printerDTD/printer.dtd (on UNIX) where "n" is the current release number and "OS_a" is: • • • • aix_a hpux_b irix_a solaris_a.

reso

10. Re-select the advanced configuration settings to check that your modifications have been ta
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As shown in the above screen grab, your settings have been saved and the CGM Profile is now "A

About V4 Line Types
Version 5 lets you choose between two methods for the line type print definition: • •

V5 process (the default one) which uses standards defined via the Tools->Standards... com V4-type process: in Version 5, you can create the V4LineFontType environment variable wh used in Version 4. The V4LineFontType variable is based on seven standard types detailed b

ISO/ANSI Solid Dotted Dashed Dot-Dash Phantom JIS Axis [] [1:1] [4:1:5] [7:1:1:1] [7:1:1:1:1:1] [2:1:10:1]

JIS [] [1:1] [3:1] [9:1:1:1] [15:1:1:1:1:1] [0.5:0.5] [2:1:10:1]

CATIA Version 4 [] [2:1] [8:2] [10:1:2:1] [35:1:2:1:2:1]

Small Dotted [0.5:0.5]

These data are similar to the default data contained in the LINEDEF file (a Version 4 external file the line type and the plotting). The last two types in the list are "V5 only" (they did not exist in Version 4) and are defined using

For detailed information on how to set an environment variable, refer to Customizing Your Enviro Your Environment on UNIX (depending on your operating system).
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Customizing Print Driver Plug-Ins

You can use print drivers other than those provided with Version 5. This task provides a step-bystep scenario describing how to plug-in your own print drivers in your Version 5 environment without CAA context using CATPrtDrvPlugins. A CATPrtDrvPlugin is made of one group of 10 functions and one shared data structure: • • Plug-in methods are functions you implement in the plug-in. These functions will then be called by Version 5. Their names all begin with "CATPDP_", for instance CATPDP_Begin Data structures are plug-in-specific types defined for use in the plug-in API. Their names begin with "CATPDP", for instance CATPDPParameters. All plug-in API structures and definitions are found in CATPDPluginAPI.h located in $CATStartupPath startup PrintServices PrintDriverPlugIn.

Click the thumbnail below to find a description of the structure of CATPDPParameters:

A plug-in is a native code library whose source conforms to standard C syntax. The plug-in file type depends on the platform you are working on: • • Windows: .DLL (Dynamic Link Library) files UNIX: .SO or .DSO (Shared Objects) files.

You can use the template file (CATPluginTemplate.cpp) located in $CATStartupPath startup PrintServices PrintDriverPlugIn and adapt it to your needs by implementing the plug-in methods provided by Version 5. When the code has been written, you will have to compile and build the module then declare the resulting module to the Print Driver Manager File. The file CATPDPlugin.mak provided in $CATStartupPath startup PrintServices help you build your library module. PrintDriverPlugIn BUILD WINDOWS can

1. Access the file CATPluginTemplate.cpp located in: $CATStartupPath startup PrintServices PrintDriverPlugIn
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2. Write the code corresponding to the interfaces to implement the plug-in methods that will be called by Version 5. For information about the syntax and use of C or C++ language, refer to your language documentation. The provided methods are listed in the table below. Click the desired method to access the corresponding description: Method Name CATPDPP_Begin CATPDP_End CATPDP_DefineColor CATPDP_SetDrawWidth CATPDP_MoveTo CATPDP_LineTo CATPDP_SelectFillColor CATPDP_FillArea CATPDP_DrawBitmap Description Driver initialization with parameters provided by user interface Indicates if the plug-in driver is about to be closed or removed Defines a RGB color in the palette Selects the drawing path Moves the pen without drawing Draws a line Selects the filling color for polygon primitives Fills a polygon Draws a bitmap

CATPDP_SelectDrawColor Selects the drawing color

------------------------------------------------------------------------------------------------------------------CATPDP_Begin Provide global initialization for the plug-in driver. Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_Begin(const CATPDPParameters& iParam); Parameters iParams Global structure data parameters. Various user printing options Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description This is the first call used from the V5 Printer Manager to inform the driver plug-in the the printing is started. The Printer Manager fills the CATPDPParameters according to the user choices. This structure is then passed to the plug-in by calling the CATPDP_Begin function. Back to Method summary
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------------------------------------------------------------------------------------------------------------------CATPDP_End Provide global deinitialization for the plug-in driver. Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_End(void); Parameters No parameters Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description The V5 Printer manager calls this function once the printing is done. Be sure to release allocations , instances or file I/O flushing in this function. After this call the plug-in driver is unloaded and the printing stopped. Back to Method summary ------------------------------------------------------------------------------------------------------------------CATPDP_DefineColor Defines a color in the palette Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_DefineColor(int iIndex , float iRed, float iGreen, float iBlue); Parameters iIndex Index in the color table (between 0 and 255) iRed Red color in RGB coordinates (between 0 and 1) iGreen Green color in RGB coordinates (between 0 and 1) iRed Blue color in RGB coordinates (between 0 and 1) Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Defines a color in rgb coordinates. This index is used for function CATPDP_SelectDrawColor or CATPDP_SelectFillColor.
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Back to Method summary ------------------------------------------------------------------------------------------------------------------CATPDP_SelectDrawColor Selects the drawing color Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_SelectDrawColor(int index); Parameters iIndex Index of the current drawing color (between 0 and 255) used for next drawing primitive Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Selects the current drawing color related to the index defined by the CATPDP_DefineColor. Back to Method summary ------------------------------------------------------------------------------------------------------------------CATPDP_SetDrawWidth Selects the current draw width Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_ SetDrawWidth (float iWidth); Parameters IWith Thickness in mm of the current drawing with used for next drawing primitives Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Selects the current draw width. The width is in mm. Back to Method summary
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------------------------------------------------------------------------------------------------------------------CATPDP_MoveTo Moves the pen without drawing Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_MoveTo(float iX, float iY); Parameters iX X coordinate to move iY Y coordinate to move Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Moves the pen to (x, y) in device coordinates without drawing. Coordinates are in mm. Back to Method summary ------------------------------------------------------------------------------------------------------------------CATPDP_LineTo Draws a line Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_LineTo(float iX, float iY) Parameters iX X coordinate to draw iY Y coordinate to draw Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Draws a line from the current pen position to (x, y) in device coordinates with current draw color, line type and draw width. Back to Method summary -----------------------------------------------------------------------------------------------------
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Advanced Tasks --------------CATPDP_SelectFillColor Selects the filling color Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_SelectFillColor (int iIndex ) Parameters iIndex Index of the current Fill color (between 0 and 255) used for next Fill primitive Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Selects the current filling color related to the index defined by the CATPDP_DefineColor. Back to Method summary ------------------------------------------------------------------------------------------------------------------CATPDP_FillArea Fills a polypolygon Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_FillArea(int iOutlines, const int* iCorners, const float* iCoord) Parameters IOutlines number of polygons in the polypolygon. iCorners Array of outlines integers giving the number of corners in each polygon. iCoord array of floats giving the coordinates of alls corners of each polygon Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Fills a polypolygon in device coordinates with current fill color. Back to Method summary -------------------------------------------------------------------------------------------------------------------
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CATPDP_DrawBitmap Draws a bitmap Syntax #include < CATPDPluginAPI.h > CATPDPError CATPDP_DrawBitmap(float iX, float iY, const int iTypeOfBitmap, const unsigned char* iPixels, const int iSize); Parameters iX iY iTypeOfBitmap iPixels iSize Returns • If successful, the function returns CATPDP_NO_ERROR • If unsuccessful, the plug-in the function returns an error code. Description Draws a bitmap in device coordinates at the given (x, y) position. Back to Method summary -------------------------------------------------------------------------------------------------------------------

X coordinate of the bitmaps to draw Y coordinate of the bitmaps to draw color mode of bitmap: 0 = RGB , 1 = Black and White bitmap array of pixels size in bytes of the pixel array

3. Compile and build the module. Note: you can use the file CATPDPlugin.mak provided in $CATStartupPath S. 4. startup PrintServices PrintDriverPlugIn BUILD WINDOW

In your Version 5 session, select the File->Printer Setup... command to open the Printers dialog box:
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5. Double-click Add Printer. • If you are working on Windows, an additional dialog box named Add Printer Wizard opens:

This dialog box enables you to choose between: • Windows Printer: in that case, selecting this option then OK will open the Connect to Printer dialog box in which you will select the Windows printer you wish to add • 3D PLM Printer: this option lets you add printers provided by Dassault Syst mes. When clicking OK, the Printer Properties dialog box is displayed to let you define the parameters for your new printer. Click OK to access the Printer Properties dialog box. • If you are working on UNIX, the Printer Properties dialog box opens directly:
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6. Select "V5 Print Plugin Driver" from the Driver pulldown list. 7. Click the Advanced Configuration... button to access the following dialog box:

8. In the Plugin Driver selection field, enter the path of the library module you built in step 3 or click the Plugin... button which enables you to browse your file tree. 9. Select the File->Print... command to open the Print dialog box:
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10. Indicate the name of the new custom printer in the Printer Name field. 11. Modify the desired print settings (refer to Customizing Print Settings Before Printing Your Documents for detailed information) then click OK to confirm and print your document.

Managing Environments
What Is An Environment?
What is an Environment?
An environment is a set of runtime environment variables in a text file. Each variable points to a path searched by the software when you start a session. All Version 5 product lines share the same environment management mechanism. For example, on Windows, the CATDocView environment variable is set by default to: C: Program Files Project\GTR2\Help Gehry Technologies Digital

meaning that the online documentation files are installed in the folder
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C: Program Files\Gehry Technologies Digital Project\GTR2\Help. When you want to access the online documentation, the software will look for the files in this location. The term environment also includes its graphical representation, in other words how it is represented to the user on the user's desktop. On Windows, for example, the environment is created in a text file located by default in: C: Data Documents and Settings Gehry Technologies All Users CATEnv Application

and the environment file name is: DigitalProject.V1R2.txt

Note: the environment file name does not necessarily contain a "." (dot). You can also specify during the installation procedure the location of environment files.

What are Global and User Environments?
A global environment can only be created by a Windows administrator, or the root userid on UNIX. For example, the default environment created at installation is a global environment: "global" means that it is visible to and can be used by all users on the computer on which it has been set up. Global environments can only be created, edited or deleted by a Windows administrator, or the root userid on UNIX. A user environment is visible to and can be used and manipulated (customized or deleted) only by the user who created it.

How are Environments Managed?
Environments are managed: • by the installation procedure, which creates a default global environment; the default environments created at installation on each platform are described in About the Environment Created on Windows and About the Environment Created on UNIX respectively. using the catiaenv command (Windows) or CATIAENV command (UNIX) to run the Environment Editor, a GUI-based tool which creates, edits, copies and deletes environments using the setcatenv command: this command creates and edits user and global environments (if you are administrator or root, you can edit the

• •
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Advanced Tasks default global environment) using the delcatenv command: this command deletes environments using the lscatenv command (to list the names of environments) using the chcatenv command (to edit one or more environment variables) using the readcatenv command (to read the variables of an environment).

• • • •

Please use the official tools provided to manage environments. Do not attempt to edit the environment file using a text editor.

What Does Customizing an Environment Mean?
Customizing your runtime environment means providing different values for the runtime variables in your default environment, or setting up new environments. For example, you may install the online documentation at a location different from the default location. If this is the case, you need to specify where the documentation files are located by modifying the value for the CATDocView variable. This is an example of what we mean by customizing your runtime environment. When customizing runtime environments, you can: • • • • create new environments edit existing environments copy existing environments delete environments

but you cannot rename existing variables. You can ONLY create, modify and delete LOCAL environments: the creation, modification and deletion of REMOTE environments is not supported. This means that if you customize a local environment, and the same environment exists on other computers, you have to edit the environments on all of those computers if you want the environments to be identical.

Locales Whose Use with Version 5 has been Validated
The language locales whose use with Version 5 has been validated are listed in your Infrastructure Users Guide, sections "Starting a Session in a Language Other than English on Windows" and "Starting a Session in a Language Other than English on UNIX".

List of Official Runtime Variables
The runtime environment variables for all product lines are listed in the table below: Variable Name Description Introduced in Release.. PATH Executable code search path (UNIX only) V5R1 LIBPATH Library search path (AIX) V5R1 LD_LIBRARY_PATH Library search path (Solaris) V5R1 105

installationDeployment LD_LIBRARYN32_PATH SHLIB_PATH CATInstallPath CATDLLPath CATICPath Library search path (IRIX) Library search path (HP-UX) Installation path DLL search path (internal use only) Search path for product identification (internal use) CATCommandPath Command search path CATDictionaryPath Library dictionary search path CATDocView Online documentation search path CATReffilesPath Reference file search path CATFontPath Font search path CATGalaxyPath Search path for User Galaxy online information files CATGraphicPath Graphic and icon search path CATMsgCatalogPath Application message file search path CATFeatureCatalogPath .OSM file search path CATDefaultCollectionStandard Default standard collection path CATStartupPath Sample file search path CATW3ResourcesPath ENOVIA Portal search path pointing to HTTP resources visible to ENOVIA Portal clients; set by default to CATInstallPath/docs CATReferenceSettingPath Default reference setting search path; also used to store settings locked by the administrator CATUserSettingPath Permanent user setting search path CATCollectionStandard Standard collection path CATTemp Temporary user setting search path CATMetasearchPath ENOVIA 3d com search path pointing to location where ENOVIA 3d com MetaSearch stores data required for metasearch engine operation. CATW3PublishPath ENOVIA Portal search path pointing to location for storing HTML documents created by the ENOVIA Portal Snapshot command. CATSharedWorkbookPath Points to shared workbooks for ENOVIA Portal CATErrorLog Error log search path: points to the default files error.log, SessionInfo and AbendTrace files. The syntax is, for example, on Windows: CATErrorLog=%CATTemp%\error.log The error log file will be: %CATTemp%\error.log You can deactivate the creation of error.log, SessionInfo and AbendTrace files by setting CATErrorLog to the special value OFF (UPPERCASE only) like this: 106 V5R2 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R1 V5R2 V5R9 V5R1 ENOVIA V5R4

V5R1

V5R1 V5R9 V5R1 ENOVIA V5R4

ENOVIA V5R4

ENOVIA V5R8 V5R1

Advanced Tasks CATErrorLog=OFF CATReport USER_HOME Conversion trace report location V5R2 Points to home directory of generic user ENOVIA for server-type ENOVIA LCA V5R12 environments DB2 environment variable (for servertype environments only) TNS environment variable (for servertype environments only) ORACLE environment variable (for servertype environments only); on Windows, set by the enoviadbsetup process For the DB2INSTANCE, TNS_ADMIN and ORACLE_HOME variables, in an installation using CATIA and VPM interoperability, you should create these variables using the Environment Editor, depending on which database you are using. ORACLE environment variable (for servertype environments only); on Windows, set by the enoviadbsetup process Java runtime path specified at installation ENOVIA (UNIX) V5R8

DB2INSTANCE TNS_ADMIN ORACLE_HOME

ORA_NLS33

JAVA_HOME_aix_a JAVA_HOME_hpux_a= JAVA_HOME_irix_a= JAVA_HOME_solaris_a JAVA_HOME CLASSPATH_JDBC_aix_a= JDBC classpath for ENOVIA LCA server CLASSPATH_JDBC_hpux_a= CLASSPATH_JDBC_irix_a= CLASSPATH_JDBC_solaris_a CLASSPATH LM_LICENSE_FILE It is used to define the location for floating license server information and the nodelock license files. For nodelock, specify the folder containing the license file. For license server use the @ symbol prefixed to the server name (ex: @MyLicServer) GTCMSProjectFilePath MS Project files path used to store files referred by MSProject dictionary BreakRunAtEveryPart To control placement of catalog components in Systems Routing workbench GTCExcelDataSheetFilePath Datasheets are created in the path specified by this location

ENOVIA V5R8

V1,R1

V1,R1 V1,R1

V1,R2

Customizing Your Environment

107

installationDeployment This task explains how to customize an existing environment on Windows. 1. Select the Start->Programs->MyProductLine->Tools->Environment Editor V5R15 comman where "MyProductLine" is: CATIA

The environment editor belongs to the common suite of Version 5 administration tools. the different examples in this section procedure step you through the customization of a CATIA environment, for illustration purposes. The steps are the same for customizing DELMIA, ENOVIA DMU Navigator, ENOVIA LCA and ENOVIA 3d com environments. You can also start the environment editor by running the command: \install_folder\intel_a\code\bin\catiaenv where "install_folder" is the name of the installation folder. The Environment Editor appears, and looks like this:

Note that the list of existing environments is displayed in the Environment name list. The list will c
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all the environments detected in the current environment folder. The first environment is selected default. When an environment in the list is selected, click the right mouse to display a contextual menu of environment manipulation commands. The Mode field indicates one of two possible values: • •

User: indicates that the environment was set up using your userid, is visible to you and can be accessed by you (you cannot see anybody else's user environments) Global: indicates that the environment was set up by somebody belonging to the Administra group, or who has the privileges assigned to the Administrators group (you can see all the g environments on your computer): this is what you will see after an initial installation on you computer. Only an administrator can modify global environments.

This means that you will only see in the Environment name list the names of environments created, or which are common to all users. You can only edit environments which belong to Furthermore, if you select a global environment as end user, you will be able to display an environment, but not edit it. The Last Modified field specifies the date and time the environment was last modified. The Environment storage directories area displays the current storage location for both global and environments. This setting is the location you specified during installation. 2. To reset environment storage directories, select the Options->Set User Storage Directory or the Options->Set Global Storage Directory command to display a file explorer, then explore your filetree to select the directory, and click OK. Any environments created from now on will be stored in these locations. You can use the storage directory settings to filter the list of environment names and types displayed. For example, if you created both global and user environments in the same user storage directory, selecting the user storage directory will now only display the user environments, and not the global environments.

3. To display the variables for any environment, click the environment name. For example, click the CATIA.V5R15.B15 environment which is the name of the default global environment set up at installation.

This will be the only environment name in the list after a default installation. However, once you cr new environments, these will also be displayed in the list.

109

installationDeployment

The variables and their values are displayed: • • the variable name is displayed on the left and the value (path) for the corresponding variable is displayed to the right.

4. Click a variable name in the list. The variable name and its corresponding value are highlighted:

For example, the default path for the CATDocView variable is: C: Program Files Dassault Systemes B15 intel_a doc

However, you may have installed the online documentation in a different folder.

5. If you are authorized to edit the variable, click the variable value to be able to edit it, then type new value.

For example, you would type in the new path for the variable CATDocView. The value of the variab reset in the Environment Variables field. 6. Click OK.
CSIDL Values in Environment Variable Paths
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There are a number of folders that are used frequently by applications, but may not have the same name or location on any given system. For example, the system folder is "C: XP and "C: Winnt" on Windows 2000. CSIDL values provide a unique system-independent way identify these special folders.

Windows" on Win

Consequently, CSIDL values are now part of paths pointed to by environment variables. The variab concerned are: • • • • • • CATUserSettingPath CATTemp CATReport CATErrorLog CATMetasearchPath CATW3PublishPath

What Is the DSKEY_TMPDIR Key?

The TMP and TEMP variables pointing to the current temporary file path on your computer are not necessarily activated. The DSKEY_TMPDIR key points to the current temporary file path on your computer which is obtai follows:

The software does not verify that the directory specified by the TMP or TEMP environment variable exists. The temporary file path is obtained as follows: • • • the path specified by the TMP environment variable. the path specified by the TEMP environment variable, if TMP is not defined. the Windows directory, if both TMP and TEMP are not defined.

To create an environment using the New command
This task explains how to create a new environment using the Environment Editor. 1. Select the Start->Programs->MyProductLine->Tools->Environment Editor command, where "MyProductLine" is: CATIA 2. Select the Environment->New command to display the following dialog box:
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5. If you logged on as administrator, enter the environment mode.

The type can be user or global (global is available only for administrators only). If you are logged o a normal end user, the type is set automatically to "user". 6. Set the product line by choosing your product line from the list: • • • • • • • CATIA ENOVIA ENOVIA ENOVIA ENOVIA DELMIA DELMIA

LCA 3d com V5 VPM DMU Navigator Automation.

7. Check the "Server" option if the environment is to be a server-type environment. This concerns ENOVIA LCA and ENOVIA 3d com only.

8. Check the "Add Desktop Icon" option if you want to create a desktop shortcut and an entry in th appropriate Version 5 location of the Start->Programs menu. 9. Check the "Overwrite existing environment" option to overwrite an existing environment. 10. Click OK to create the environment. The environment is created in: C: Documents and Settings User Application Data DassaultSystemes

CATEn

where "user" is "All Users" for a global environment, or "myuserid" for a user environment.

To copy an existing environment using the New from... command

This task explains how to create a new environment using the Environment Editor by copying an e environment. 1. Select the Start->Programs->MyProductLine->Tools->Environment Editor command, where "MyProductLine" is: CATIA 2. Select an environment and click Yes to confirm you want to modify it. 3. Select the Environment->New from... command to display the following dialog box:
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4. Customize the name of the environment to be created. 5. Enter the path of your installation folder. The default installation folder path is: C: Program Files Dassault Systemes B15 intel_a

6. Check "Add a new path to this environment" and specify where to insert the path (before or afte install path) using the appropriate options if required. 7. If you logged on as administrator, enter the environment mode.

The type can be user or global (global is available only for administrators only). If you are logged o a normal end user, the type is set automatically to "user". 8. Set the product line by choosing your product line from the list: • • • • • • • CATIA ENOVIA ENOVIA ENOVIA ENOVIA DELMIA DELMIA

LCA 3d com V5 VPM DMU Navigator Automation.

9. Check the "Add Desktop Icon" option if you want to create a desktop shortcut and an entry in th appropriate Version 5 location of the Start->Programs menu. 10. Check the "Overwrite existing environment" option to overwrite an existing environment. 11. Click OK to create the environment. The environment is created in: C: Documents and Settings User Application Data DassaultSystemes

CATEn
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where "user" is "All Users" for a global environment, or "myuserid" for a user environment.

Creating and deleting user-defined variables, and editing variables using the conte menu

This task explains how to create and delete user-defined variables, and edit any variable, using the contextual menu. 1. Select the Start->Programs->MyProductLine->Tools->Environment Editor V5R15 command, w "MyProductLine" is: CATIA 2. To display the variables for any environment, click the environment name and confirm that you to modify it. 3. Without selecting a variable, right-click on the variable list to see the contextual commands: • • • New Variable Delete Variable Edit Variable

4. To create a user-defined variable, select the New Variable command to display the Variable Edit dialog box:

and enter the variable name, its value, and a comment if required, then click OK.

5. To delete a user-defined variable, select the variable, then select the Delete Variable command, click Yes to delete the variable.

Note that you can delete only user-defined variables created using the New Variable command, an official variables. 6. To edit any variable, select the variable, select the Edit Variable command to display the Variab Editor dialog box:
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then enter its new value and click OK. Note that the variable name and comment field are not avai if you are modifying an official variable. However, the name, value and comment are editable if yo editing a user-defined variable only.

7. Do not forget to save your changes by selecting the Save command, also in the contextual men

To create or customize an environment using the setcatenv command

You can also customize environments using the setcatenv command. This command lets you creat user and global environments. The command is located in: install_folder intel_a code bin

where "install_folder" is the name of the installation folder. The full list of options for the command: setcatenv is as follows:

Operating Environment Options
These options specify the general operating environment: • -cs: specifies the name of the product line for which the environment is being created; The value is CATIA (default) for the CATIA product line. • • -e: environment file name; if the "-e" option is not specified, the name of the environment created will be "DefaultEnvironment" -d: specifies an existing directory in which the environment file will be created (it does not the directory if it does not exist); if you do not specify "-d", the environment will be created in: C: Documents and Settings user Application
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Data

DassaultSystemes

CATEnv

where "user" is "All Users" for a global environment, or "myuserid" for a user environment • • -p: specifies the installation folder, and is mandatory (by default, it is set to the default

•

installation folder: C: Program Files Dassault Systemes B15) -server: creates an environment suited for server type environments. The CATUserSettingP variable value differs between a server environment and an interactive environment. The "option is mandatory when specifying server environments. Furthermore, a server type environment does not have a desktop representation, and always overwrites an existing environment with the same name. Consequently, system administrator rights are required using this option -cf: specifies the name or path of an existing environment from which you create a new environment. For example, the command: setcatenv -e MyNewEnv -cf CATIA.V5R15.B15 creates the new environment MyNewEnv from a copy of CATIA.V5R15.B15. This allows you to inherit previous customizations without having to recreate them in the ne environment. For example, the CATReferenceSettingPath variable is frequently used to store settings lock the administrator, and may concatenate several different levels of settings. Copying an exis environment saves you time because you do not having to customize the new environment Note that if you do not use the "-cf" option, all the variables are set with their default value the new environment. If only the name is specified in the "-cf " option, the template enviro is searched in the default storage directories (user or global).

Behavior Options
These options determine a type of behavior: • • -v yes/no: o -v yes (default): verbose mode o -v no: non-verbose mode. -new yes/no: o yes ( default): an environment with the same name (if it exists) is overwritten o no: if an environment has the same name, this time it is not overwritten (nothing happens).

However, note that if no environment using the same name is detected, a new environmen created in both cases (whether you use "yes" or "no"). •

• •

-tools: sets up the Tools menu containing the Environment Editor V5R15, Nodelock Key Management V5R15, Settings Management V5R15, Software Management V5R15, Batch Management V5R15 and Printers V5R15 commands. This is an exclusive option: run this command once like this: setcatenv -tools -cs MyProductLine -desktop yes/no: sets up the desktop representation of the environment, if it does not alrea exist. The default is "yes". Equivalent to "-icon yes" "-menu yes". -icon yes/no: creates a startup icon on the desktop; default is "yes"
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Action Options
These options specify a particular creation or modification action: • • -a user/global: specifies whether you are creating a user or global environment. The defa value is "user". Note that you need administrator rights to create a global environment. -h: displays help.

The catenv.log log file logs environment creation and modification operations. The log file is crea the temporary folder in one of the following locations: • • • the path specified by the TMP environment variable the path specified by the TEMP environment variable, if TMP is not defined the current directory, if both TMP and TEMP are not defined.

Creating an environment using the setcatenv command sets up the following environment: • •

sets up Start->Programs->MyProductLine menu by adding the shortcut for your environme and creates the shortcut for your environment on the desktop.

If you create a new environment, you can start a session using the new environment with the command: cnext -env my_new_environment -direnv MyEnvDirectory

where "my_new_environment" is the name of the environment you created, and "MyEnvDirectory the name of the environment directory.

To delete an environment using the delcatenv command
Use the command: delcatenv • • • • -e: environment file name; if the "-e" option is not specified, the name of the environment deleted will be "DefaultEnvironment" -d: specifies the directory containing the environment; the default is

•

CSIDL_APPDATA CATEnv. -a user/global: specifies whether you are deleting a user or global environment. The defa value is "user". Note that you need administrator rights to delete a global environment. -desktop: if it exists, deletes its graphical representation, in other words, how it is represen the user on the user's desktop (desktop shortcut, shortcut in Start menu, etc.). The default "yes". -tools: deletes the Tools menu containing the Environment Editor V5R15, Nodelock Key Management V5R15, Settings Management V5R15, Software Management V5R15, Batch Management V5R15 and Printers V5R15 commands. This is an exclusive option: run this command once like this: delcatenv -tools -cs MyProductLine
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•

•

-cs [CATIA|ENOVIA_DMU_Navigator|ENOVIA_LCA|DELMIA|ENOVIA_3d_com]: specifies the product whose desktop tools you want to delete; the default is CATIA. -v yes/no: o -v yes (default): verbose mode o -v no: non-verbose mode -server: deletes an environment suited for server type environments. The CATUserSettingP variable value differs between a server environment and an interactive environment. The "option is mandatory when specifying server environments. System administrator rights are required for using this option. -h: displays help.

Keep in mind that deleting an environment using the delcatenv command deletes all the registry e

To list environments using the lscatenv command
Run the lscatenv command to list the names of all environments on your computer: lscatenv • • • -a user/global: lists user or global environments. You must specify one or the other. -d: specifies the directory containing the environment; the default is CSIDL_APPDATA -h: displays help. CATEnv.

To read environments using the readcatenv command
Run the readcatenv command to read the environment variables in a specified environment: readcatenv • • • • • -e: environment file name -d: specifies the directory containing the environment; the default is

CSIDL_APPDATA CATEnv. -a user/global: specifies user or global environment. You must specify one or the other. -var: specifies a variable whose value is to be read; if you omit "-var", all variables will be displayed -h: displays help.

To modify environments using the chcatenv command
Run the chcatenv command to edit one or more environment variables: chcatenv • • • -e: environment file name -d: specifies the directory containing the environment; the default is CSIDL_APPDATA CATEnv. -a user/global: specifies user or global environment. You must specify one or the other.
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Advanced Tasks • -var: specifies a variable whose value is to be modified. The following syntax is allowed: CATVariable = new_path CATVariable = %CATVariable%; new_path CATVariable = new_path; %CATVariable% If the path includes blanks, include the whole string in " ". • • • • -new: creates a new user-defined variable (specified by the "-var" option) with its correspo value -del: deletes a user-defined variable -comment "text": adds a comment only to variables you created; the text must be added between " " -h: displays help.

Examples
Running this command... readcatenv -e CATIA.V5R15.B15 -a global Systemes B15 Displays this: CATInstallPath=C: Program Files intel_a Program Files intel_a Program Files intel_a code

Dass

CATDLLPath=C: Systemes B15

Dassault bin

CATICPath=C: Systemes B15

Dassault code

produ

CATCommandPath=C: Systemes B15

Program Files intel_a code

Dass

comma

CATDictionaryPath=C: Files Systemes Dassault B15

Program

intel_a

code

dicti

CATDocView=C: Systemes B15

Program Files intel_a doc

Dassault

CATReffilesPath=C: Systemes etc.... B15

Program Files intel_a reffiles

Das

readcatenv -e CATIA.V5R15.B15 -a global CATInstallPath=C: var CATInstallPath Systemes B15

Program Files intel_a

Dass

readcatenv -e CATIA.V5R15.B15 -d C:\Documents and

CATInstallPath=C:

Program Files

Dass
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Settings\user\Application Data\DassaultSystemes\CATEnv -var CATInstallPath chcatenv -e CATIA.V5R15.B15 -a user -var

Systemes

B15

intel_a

CATInstallPath=C: CATInstallPath=%CATInstallPath%;C: Temp Systemes chcatenv -e CATIA.V5R15.B15 -a user -var CATInstallPath=C: CATInstallPath=C: Temp B15

Program Files intel_a;C: Temp

Dass

Temp

chcatenv -e CATIA.V5R15.B15 -a user -var NewVar=C: NewVar=C: Temp -new CATIA.V5R13.B13.txt CATIA.V5R15.B15.txt Temp

lscatenv -d C:\Documents and Settings\user\Application Data\DassaultSystemes\CATEnv

Environment creation and manipulation commands are logged in the file catenv.log.

The feedback obtained when using all the administration commands from the command line is now output to the current command prompt window.

To Set Up Two Environments With Different Licensing Settings

A situation may arise in which you have two different configurations installed on your computer, an want to use both configuration licenses.

Each time you use one of the configurations, your licensing settings are stored in the same place. T means that when you start "Configuration 1", acquire the corresponding license, then exit your ses your licensing settings are saved. When you start "Configuration 2", your previous licensing setting retrieved, so you must acquire the new license. Each time you exit, the previous licensing settings overwritten by the new licensing settings.

This means that, when you use different configurations alternately, you have to continually reacqu corresponding license each time you start.

You can avoid this problem by editing each environment. Let's assume that the two configurations installed on an Intel computer running Windows, and that you are authorized to edit each environm The two variables of interest are: • • CATReferenceSettingPath CATUserSettingPath

In the default environments created, let's assume each variable has the following values: Environment 1
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CATReferenceSettingPath CATUserSettingPath

C:

Admin_License_Settings Dassault Systemes CATSettings

%CSIDL_APPDATA%

For example, on Windows, CATUserSettingPath usually points to: C: Documents and Settings CATSettings user Application Data Dassault

Systemes

where "user" is your userid. Environment 2 CATReferenceSettingPath CATUserSettingPath C: Admin_License_Settings Dassault Systemes CATSettings

%CSIDL_APPDATA%

Note that, for the moment, the path pointed to by CATUserSettingPath is the same in both cases. Y licensing settings are saved here each time you use a configuration. 1. Select the Start->Programs->MyProductLine->Tools->Environment Editor V5R15 command, where "MyProductLine" is: CATIA 2. Edit "Environment 1" and reset the value for the CATUserSettingPath variable as follows: C: Documents and Settings CATSettings_Config1 user Application Data Dassault

Systemes

3. Edit "Environment 2" and reset the value for the CATUserSettingPath variable as follows: C: Documents and Settings CATSettings_Config2 user Application Data Dassault

Systemes

4. Start configuration 1, acquire the license and exit the session. Your license settings will now be stored in: C: Documents and Settings CATSettings_Config1 user Application Data Dassault

Systemes

5. Start configuration 2, acquire the license and exit the session.
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C:

Documents and Settings CATSettings_Config2

user

Application Data

Dassault

Systemes

You will be able to use each configuration alternately, and without having to reacquire the correspo license each time. However, you must not use the Tools->Options command.
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Managing Settings
About, Establishing, and Customizing Settings
About Settings
Version 5 creates different types of settings data: • • application data contained in the documents you create setting files which are non-editable.

There are two types of settings: • • temporary settings permanent settings.

Certain Version 5 applications also create preferences.

What Do Settings Files Contain?
Temporary settings contain settings of a temporary nature (album screen captures, roll file information,...) CATTemp contains two folders or directories: • • Album: contains screen captures created using the Tools->Image->Capture... command CNext01.roll: roll file.

Temporary settings are created in a location referenced by the CATTemp variable. Permanent setting files store customization you perform mainly using the various tabs provided by the Tools->Options... command. For example, application window customization, background colors, part and print settings, etc. Permanent setting files are identified by the suffix: *.CATSettings, and are created in a location referenced by the CATUserSettingPath variable. Deleting either types of files deletes your customization.

How Do You Set Settings?
You can specify settings: • • using the Tools->Options... command in a Version 5 session or without starting a Version 5 session.
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Specifying Settings in a Version 5 Session

You specify settings using the Tools->Options... command which displays the Options dialog box:

The left-hand column contains a list of categories used for organizing the different groups of settings. There are general settings for all configurations and products, and settings for each type of configuration installed. The category names are the same as those listed on the Start menu. To access the settings for a specific configuration, click the "+" to display the subcategories. Clicking on the subcategory displays the settings tabs for that subcategory.
Specifying Settings Without Running a Session

On Windows 1. Change to the default folder in which you installed the product. On Windows, the default folder is: C: Program Files Dassault Systemes B15 intel_a code bin

2. Enter the command: CATOptionsMgt
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If you have several runtime environments on your computer, you can select the environment by entering the following command: CATOptionsMgt -env envname where "envname" is the name of the environment. You can also access the Options dialog box using the Start->Programs->CATIA Tools menu, and running the Settings Management V5R15 command. The Options dialog box is displayed. This function is useful for administrators because it allows you to set up user settings without having to start an interactive session first.

Where Are Settings Files Located on Windows?
The location of settings files on Windows platforms is inspired by the general data and settings management requirements operating on the Windows 2000 platform, which provides an underlying infrastructure allowing you to separate user data, user settings and computer settings. The mechanism used is the CSIDL value mechanism. This implementation allows: • • your permanent settings (CATSettings) to roam as part of your user profile (CSIDL_APPDATA) your temporary settings (CATTemp, etc.) to be still stored in the user profile, but prevents them from roaming (CSIDL_LOCAL_APPDATA).

The following table will help you determine where your settings are located:
Windows 2000/Windows XP

Variable CATUserSettingPath C: Data CATTemp C:

Location Documents and Settings DassaultSystemes Documents and Settings Application CATTemp user CATReport user CATTemp Local error.log Local user CATSettings user Local Application

Settings CATCache CATReport

Data DassaultSystemes Obsolete C: Data Documents and Settings Application DassaultSystemes Documents and Settings Application DassaultSystemes

Settings CATErrorLog

C: Data

Settings
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C: Data

Documents and Settings Application DassaultSystemes Documents and Settings Application DassaultSystemes

user CATTemp user CATTemp

Local

Settings CATW3PublishPath

C: Data

Local

Settings

CSIDL Values in Environment Variable Paths

The value: C: Documents and Settings user Application Data

is the default on Windows 2000/XP for the CSIDL_APPDATA values. The value: C: Documents and Settings Data user Local Settings Application

is the default on on Windows 2000/XP for the CSIDL_LOCAL_APPDATA values.

Location of Settings Files on UNIX
Permanent settings are stored in the CATSettings directory in your home directory; temporary settings are stored in the CATTemp directory, also in your home directory.

How Settings are Concatenated and Inherited
Settings are managed in Version 5 in two ways: • • "zero administration": end users start a "standalone" session, inherit their settings values from the software defaults, and change their settings at will "administration mode": the administrator starts a session in administration mode which provides two possibilities: o specify a "starter set" of setting values which end users running the same environment can use to get started; however, end users retain the ability to modify the values explicitly o lock settings so that end users running a session with the same environment inherit those settings and cannot change them (discussed in detail in Locking Settings).

Concatenation Mechanism
Settings are based on a hierarchical concatenation mechanism.
Default Values in the Software

The Version 5 software provides default values for all settings. This enables you to
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Order of Priority

Setting files are stored in directories referenced in the Version 5 runtime environment by the CATReferenceSettingPath and CATUserSettingPath environment variables: • • CATReferenceSettingPath: points to the directory (or directories) where administrator settings are stored CATUserSettingPath: points to the directory where user settings are stored.

When a session is started, the directories pointed to by these variables are searched in the following hierarchical order: all files found first in the CATReferenceSettingPath, and then in the CATUserSettingPath will be read in this order of priority.
Concatenation Mechanism Involving One or More Administration Levels

When a session is started, if no setting file is found either in the CATReferenceSettingPath or in the CATUserSettingPath, the setting value is the default provided by the software. If settings files have been deleted, an end user will inherit the setting values set by the administrator or the default values provided by the software. If there are administrator directories pointed to by CATReferenceSettingPath, and the settings have not been locked, the value is the value written in the last administrator's file found in CATReferenceSettingPath, or in the user file found in the CATUserSettingPath. In this case, the tend user will be able to modify the settings. If there are administrator directories pointed to by CATReferenceSettingPath, and settings have been locked, the setting value is the value written in the first administrator directory where this attribute has been locked. End users will not be able to modify the settings. For full details about how to start a session in administrator mode for the purpose of locking settings, refer to Locking Settings. For a fully detailed scenario illustrating how settings are concatenated and inherited, and involving multiple administration levels, refer to Detailed Scenario Illustrating Concatenation and Inheritance Mechanisms.

What Are Preferences?
Preference files contain user preferences set by the user when using certain applications. For example, certain drafting user choices, the last height of a pad (Part Design), the list of values entered in certain editable fields, are stored as preferences, but are not settings. Preference files are a convenient means of storing and recalling user preferences from one session to another.
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Consequently, unlike settings, preferences are created by certain applications, and not via the Tools->Options... command. Preference files are identified by the suffix: *.CATPreferences, and are created in the same location as settings, referenced by the CATUserSettingPath variable. However, preferences cannot be administered, and consequently are not referenced by the CATReferenceSettingPath variable.

Creating, Maintaining and Distributing Settings
Locking Settings
This task explains how to run a session in administrator mode for the purpose of locking settings so that other users running a session with the same environment inherit those settings and cannot change them. An administrator can also take advantage of this mechanism to set default settings which, although not locked, are proposed to users as a starting point. By default, there is "zero administration" of settings: user settings are stored in the CATSettings environment as explained in About Settings. The following scenario walks you through a procedure useful for locking settings for users of the default environment created at installation. This is a useful procedure if you are interested in locking settings, but do not want to multiply environments on the same computer. The scenario described reflects the Windows platform only, but the feature is also supported on UNIX. Do not confuse running a session in administrator mode (a Version 5 concept) with logging on as administrator (a system concept).

Scenario 1: Locking Settings for the Default Global Environment
1. Log on as an administrator. You must belong to the Administrators group, or have the privileges assigned to the Administrators group. For the purposes of this particular scenario only, you need to log on as administrator because you are going to modify the default global environment (V5R15). 2. Select the Start->Programs->CATIA->Tools->Environment Editor V5R15 command to display the Environment Editor. You will see an environment with the following name: CATIA 3. Click the CATIA.V5R15.B15 environment to display the corresponding
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Project Standards environment variables. 4. Locate the following environment variable: CATReferenceSettingPath Note that the default setting for this variable is empty. 5. Reset the variable so that it points to an existing folder, for example: CATReferenceSettingPath E: users administrator LockSettings

then click Set, then OK to save and exit the environment editor. This folder will contain the setting locks you will create later. The folder access rights must be set up for read access only for end users, and read/write for the person creating the setting locks. 6. Run a session in administrator mode using the following command: cnext -env CATIA.V5R15.B15-admin or: cnext -admin The session is started using the default global environment, and a message informs you that you are running in administration mode. Click OK in the message box to proceed. If prompted by the License Manager, reserve at least one configuration license then restart a session. 7. Select the Tools->Options... command. The "Options" dialog box is displayed. Note that a lock symbol like this opposite each option in the General tab: appears
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Pointing the cursor to a lock symbol displays a message indicating the name of the folder/directory containing the lock settings. This is particularly useful for administrators who need to identify which lock settings are active when there are multiple levels of concatenated locks. 8. To set the locks, click on one of the appropriate lock symbols. For example, click the lock symbol for the User Interface Style option:

130

Project Standards

The lock symbol now looks like this:

.

Because the user interface style was set to CATIA - P2, end users running this environment will not be able to change this setting. 9. Click OK to confirm. The lock settings are stored in the folder referenced by the CATReferenceSettingPath environment variable you reset earlier. 10. Exit the session. An end user who starts a session with the normal startup commands (but not the cnext -env CATIA.V5R15.B15 -admin command) and using the same environment, will see this after selecting the Tools->Options... command:
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The lock symbol now looks like this:

.

Because the user interface style was set to "CATIA - P2", end users running this environment will not be able to change this setting to "CATIA - P1".

Scenario 2: Locking Settings for User Environments
You do not necessarily have to log on as administrator to customize an environment and set locks on settings: the lock mechanism is not limited to the global environment only. End users can customize their own user environments to store their own settings in a location referenced by the CATReferenceSettingPath environment variable, start a session using the command: cnext -env myenv -admin where "myenv" is the name of the user environment, then lock settings in the same way as described in their first scenario. Then, other end users starting a session on the same computer, with the normal startup commands and using the same environment, will inherit the locked settings.

Scenario 3: Concatenating Settings Locks
Different users may want to set different types of locks at different levels for a
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In this example: • • • • one administrator (starting in administration mode) locks settings in "Environment 1" at the site level on the same site, two administrators (also starting in administration mode) in two different workshops lock settings in "Environment 2" and "Environment 3" respectively users 1 and 2 run a Version 5 session with "Environment 2" and inherit the setting locks in "Environment 1" and "Environment 2" respectively users 3 and 4 run a Version 5 session with "Environment 3" and inherit the setting locks in "Environment 1" and "Environment 3" respectively.
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Detailed Scenario Illustrating Concatenation and Inheritance Mechanisms
This section contains a lengthy but comprehensive scenario illustrating how the setting concatenation and inheritance mechanism works. The scenario involves one end user and two administration levels, explains what happens when both administrators successively set, explicitly modify, lock and unlock settings, and describes the impact on the end user inheriting these settings and who in turn explicitly modifies and resets settings. We assume before reading this scenario that you are already familiar with the following concepts: • • • basic settings concatenation and inheritance mechanisms resetting settings locking and unlocking settings.

The scenario presents a list of tables containing settings visible to or specified by Administrators 0 and 1, and visible to or specified by the User. Legend Black: unlocked values inherited from the higher administration level, or from software defaults Blue: explicitly modified values Orange: values locked by the current administrator Red: inherited locked values (X, Y, Z) this expression represents the state of the setting where: • X represents the administration level where the value has been set: o 0 or 1 (meaning Admin 0 or Admin 1): specifies the level where the setting has been set in the administration concatenation. "0" means that the highest level administrator has set this setting. o D means Default value: this means that no one has set this setting and thus the value is the code default value. Y represents the administration level where the setting has been locked: o 0 or 1 (meaning Admin 0 or Admin 1): specifies the level where the setting has been locked in the administration concatenation. 0 means that the administrator of highest level has locked this setting. The level X and Y can be different. In this case, we have necessary X <= Y. o U is for Unlocked meaning that the parameter has not been locked Z specifies if the parameter has been explicitly modified at the current level by the logged user (or administrator):

•

•
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o o

1. The initial status of the settings after installation is: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 a1 (D, U, F) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 a1 (D, U, F) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) User a1 (D, U, F) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) The settings visible to Admin 0, Admin 1 and User are identical: they are the default values provided by the software. 2. Admin 0 explicitly changes Setting 1 to value b1: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 b1 (D, U, F) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) User b1 (D, U, F) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 and User inherit the value b1. 3. User explicitly changes Setting 2 to value b2: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 b1 (D, U, F) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) User b1 (D, U, F) b2 (D, U, T) a3 (D, U, F) a4 (D, U, F)

4. Admin 1 explicitly changes Setting 2 to value c2 and Setting 3 to value b3: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 b1 (0, U, F) c2 (D, U, T) b3 (D, U, T) a4 (D, U, F) User b1 (0, U, F) b2 (1, U, T) b3 (1, U, F) a4 (D, U, F) When the User starts a session, because the User has not yet explicitly modified Setting 3, the User inherits directly the new value b3. However, as the user has
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installationDeployment already explicitly modified Setting 2, the modification of Setting 2 made earlier by Admin 1 is not visible. 5. The User then resets the settings: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 b1 (0, U, F) c2 (D, U, T) b3 (D, U, F) a4 (D, U, F) User b1 (0, U, F) c2 (1, U, F) b3 (1, U, F) a4 (D, U, F) After the reset, the User immediately sees that the value of Setting 1 is imposed by Admin 0, whereas the values of Settings 2 and 3 are imposed by Admin 1. The main difference is that, for Setting 2, the User now inherits the value c2. 6. The User explicitly changes Setting 2 to value d2 and Setting 4 to value b4: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 b1 (0, U, F) c2 (D, U, T) b3 (D, U, T) a4 (D, U, F) User b1 (0, U, F) d2 (1, U, T) b3 (1, U, F) b4 (D, U, T)

7. Admin 1 locks Settings 1 and 2: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 b1 (0, L, F) c2 (D, L, T) b3 (D, U, F) a4 (D, U, F) User b1 (0, 1, F) c2 (1, 1, F) b3 (1, U, F) b4 (D, U, T) The User now inherits the values of Settings 1 and 2 directly: the values are locked so they cannot be modified. Note that the value locked for the Setting 1, is directly inherited from the Admin 0. The lock and value can be set at different administration levels. 8. The User resets the settings: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 c1 (0, L, F) c2 (D, L, T) b3 (D, U, F) a4 (D, U, F) User c1 (0, 1, F) c2 (1, 1, F) b3 (1, U, F) a4 (D, U, F)
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The only difference here is that the reset forces the value of Setting 4 to a4, imposed by Admin 1 which is the administration level directly above. For Setting 1 at the user level, the expression (0, 1, F) means that the Admin Level 0 is responsible of the value of the setting, but that this setting has been locked by Admin 1. 9. The User again explicitly changes the settings. This time, the User changes Setting 4 back to the value b4: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 c1 (0, L, F) c2 (D, L, T) b3 (D, U, F) a4 (D, U, F) User c1 (0, 1, F) c2 (1, 1, F) b3 (1, U, F) b4 (D, U, T)

10. Admin 1 unlocks Setting 1 and explicitly changes the value to d1: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 d1 (0, U, T) c2 (D, L, T) b3 (D, U, F) a4 (D, U, F) User d1 (1, U, F) c2 (1, 1, F) b3 (1, U, F) b4 (D, U, T) Because the User has not yet explicitly changed (and therefore has not saved) Setting 1 before Admin 1 locked it earlier, the User now inherits the new value d1 from Admin 1 when the setting is unlocked. 11. Admin 1 unlocks Setting 2 and explicitly changes the value to e2: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 d1 (0, U, T) e2 (D, U, T) b3 (D, U, F) a4 (D, U, F) User d1 (1, U, F) d2 (1, U, T) b3 (1, U, F) b4 (D, U, T) Earlier in the scenario (step 6), the User had already explicitly changed the value of Setting 2 to d2 before Admin 1 locked it. This value was saved. Consequently, because the lock is no longer present, the User does not inherit the new value e2 from Admin 1 (as in step 10). In this case, once the setting has been unlocked, the User retrieves the value set in step 6, i.e. d2. 12. The User then resets the settings again:
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Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 d1 (0, U, T) e2 (D, U, T) b3 (D, U, F) a4 (D, U, F) User d1 (1, U, F) e2 (1, U, F) b3 (1, U, F) a4 (D, U, F) The value of Setting 2 is now reset to e2, and the value of Setting 4 is back to a4. 13. The User now explicitly changes the values of all four settings like this:

• • • •

Setting Setting Setting Setting

1 2 3 4

is is is is

changed changed changed changed

to to to to

e1 f2 c3 b4

Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 b1 (D, U, T) a2 (D, U, F) a3 (D, U, F) a4 (D, U, F) Admin 1 d1 (0, U, T) e2 (D, U, T) b3 (D, U, F) a4 (D, U, F) User e1 (1, U, T) f2 (1, U, T) c3 (1, U, T) b4 (D, U, T)

14. Admin 0 explicitly changes Setting 1 to the value d1, then locks Settings 1 and 3: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 d1 (D, L, T) a2 (D, U, F) a3 (D, L, F) a4 (D, U, F) Admin 1 d1 (0, 0, F) e2 (D, U, T) a3 (D, 0, F) a4 (D, U, F) User d1 (0, 0, F) f2 (1, U, T) a3 (D, 0, F) b4 (D, U, T) Both Admin 1 and the User now inherit the locks and values of Settings 1 and 3, which can no longer be modified. 15. Admin 0 resets: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 a1 (D, L, F) a2 (D, U, F) a3 (D, L, F) a4 (D, U, F) Admin 1 a1 (D, 0, F) e2 (D, U, T) a3 (D, 0, F) a4 (D, U, F) User a1 (D, 0, F) f2 (1, U, T) a3 (D, 0, F) b4 (D, U, T)
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The locks are not removed by the reset, which works only on the values. Thus the two locks on Setting1 and 2 remain unchanged. The default value of Setting 1 is however restored. 16. The User finally resets the settings: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 a1 (D, L, F) a2 (D, U, F) a3 (D, L, F) a4 (D, U, F) Admin 1 a1 (D, 0, F) e2 (D, U, T) a3 (D, 0, F) a4 (D, U, F) User a1 (D, 0, F) e2(1, U, F) a3 (D, 0, F) a4(D, U, F) The value of Setting 2 is now e2, and the value of Setting 4 is now back to a4. 17. Admin 1 sets Setting 4 to b4: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 a1 (D, L, F) a2 (D, U, F) a3 (D, L, F) a4 (D, U, F) Admin 1 a1 (D, 0, F) e2 (D, U, T) a3 (D, 0, F) b4 (D, U, T) User a1 (D, 0, F) e2(1, U, F) a3 (D, 0, F) a4(1, U, F)

18. Admin 0 sets Setting 4 to c4: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 a1 (D, L, F) a2 (D, U, F) a3 (D, L, F) c4 (D, U, T) Admin 1 a1 (D, 0, F) e2 (D, U, T) a3 (D, 0, F) b4 (0, U, T) User a1 (D, 0, F) e2(1, U, F) a3 (D, 0, F) a4(1, U, F)

19. Admin 0 locks Setting 4: Setting Setting 1 Setting 2 Setting 3 Setting 4 /Level Default a1 a2 a3 a4 Admin 0 a1 (D, L, F) a2 (D, U, F) a3 (D, L, F) c4 (D, L, T) Admin 1 a1 (D, 0, F) e2 (D, U, T) a3 (D, 0, F) c4 (0, 0, F) User a1 (D, 0, F) e2(1, U, F) a3 (D, 0, F) c4(0, 0, F)
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Importing and Exporting Setting Files to/from XML Format
You can import and export setting files to and from XML format using the following commands: CATBatGenXMLSet CATBatImpXMLSet Certain attributes in certain settings files, when exported to XML format, cannot be converted to text. The setting files concerned are: • • • FrameConfig.CATSettings FrameGeneral.CATSettings DLNames.CATSettings (which can only be exported in any case using the CATSysDLExport tool).

This renders these settings files unusable after exporting them to XML format.

On Windows
1. Change to the default folder in which you installed the product. On Windows, the default folder is: C: Program Files Dassault Systemes B15 intel_a code bin

2. Enter the command: CATBatGenXMLSet or: CATBatImpXMLSet with the appropriate arguments.

On UNIX
1. Log on as root or end user. 2. Enter the command: /usr/DassaultSystemes/B15/OS/code/bin/CATBatGenXMLSet or: /usr/DassaultSystemes/B15/OS/code/bin/CATBatImpXMLSet
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with the appropriate arguments.

Exporting an XML Set from a Settings File
The CATBatGenXMLSet command reads any setting file and to generate an XML file from it. The syntax is: CATBatGenXMLSetOutput_directory SettingName [mode] The arguments are: • • • Output_directory: name of the directory where the XML file will be created. Example: /tmp. SettingName: name of the CATSettings file (without the .CATSettings extension) that you want to export to XML format. Example: CATStatistics. mode: optional argument, specify -admin in order to run the command in administrator mode, which has the effect of creating the resulting file in the administrator settings environment. The default mode is user mode. No extension. If you want to understand what administrator mode is and what it is used for, refer to How Settings are Concatenated and Inherited and Locking Settings. General information about settings is provided in About Settings.

Batch Output

The name of the resulting file is SettingName.xml.
Example

CATBatGenXMLSet /tmp Statistics
Example of output

Let's say we have a settings file named Example.CATSettings comprising the following attributes: Length of type float explicitly set to 17.132 Weight of type long not explicitly set (code default) Number of type integer explicitly set to [1,2,3] The resulting XML file will be as follows: <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE CATSettingRepository [ <!ELEMENT CATSettingRepository (Attribute*)> <!ATTLIST CATSettingRepository Name NMTOKEN #REQUIRED> <!ELEMENT Attribute (Value*)> <!ATTLIST Attribute Name NMTOKEN #REQUIRED Type CDATA #REQUIRED 141

installationDeployment Size NMTOKEN #REQUIRED Lock (Locked|JustLocked|Unlocked) "Unlocked"> <!ELEMENT Value (#PCDATA)> ]> <CATSettingRepository Name="Example"> <Attribute Name="Length" Type="float" Size="1"> <Value>17.132</Value> </Attribute> <Attribute Name="Weight" Type="long" Size="0"> </Attribute> <Attribute Name="Number" Type="int" Size="3"> <Value>1</Value> <Value>2</Value> <Value>3</Value> </Attribute> </CATSettingRepository> Note that a size of 0 means that the attribute has not been explicitly modified anywhere in the concatenation. Its value is also the default value of the code.

Importing an XML Set to a Setting File
The CATBatImpXMLSet command reads an XML settings set and generates the settings in the current V5 environment from it. CATBatImpXMLSetXML_File [mode] The arguments are: • • XML_File: path of the XML file to import into the current V5 environment. Example: /tmp/CATStatistics.xml. mode: optional argument, specify -admin in order to run the command in administrator mode, which has the effect of creating the resulting file in the administrator settings environment. The default mode is user mode. If you want to understand what administrator mode is and what it is used for, refer to How Settings are Concatenated and Inherited and Locking Settings. General information about settings is provided in About Settings.

Batch Output

The output is a settings file in the user settings repository of the current V5 environment, for example Statistics.CATSettings.
Example

CATBatImpXMLSet /tmp/Statistics.CATSettings
General Remarks

After either exporting or importing settings files, a message like this appears confirming the operation has succeeded:
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Setting xxx has yyy attributes successfully exported/imported depending on the case, where "xxx" is the settings file name and "yyy" is the number of attributes. If the exported file is already present, the previous file will be overwritten. Certain settings files may be empty. If you attempt to export an empty settings file, the following message is displayed: Setting xxx is empty where "xxx" is the settings file name, but the resulting XML file is still generated. We recommend that you do not edit the XML files manually, since the syntactical coherence of setting files is guaranteed by the interactive Tools>Options... command. We advise that you use this export/import facility simply as a means of capturing the state of your configuration settings at a specific point in time, for the purpose of restoring the same settings for another configuration.

Administrating Data Using the DLName Mechanism
Importing DLName Settings in Batch Mode
This section explains how to use the CATSysDLExport batch tool to implement a data storage strategy for a large number of users, based on the DLName mechanism.

How Administrators Can Exploit the DLName Mechanism
To avoid anarchy, as a data administrator you can exploit the DLName mechanism to prevent end users (on a given machine and using the same Version 5 environment) from reading and writing documents anywhere they like. To do so, you start Version 5 in administration mode, set up the DLNames, then lock them as described in Setting Up DLNames in Administrator Mode. This also means that you have to export the DLNames to a .txt file. You can then: • • if you have a small number of end users, import the .txt file containing the DLNames (but the DLNames will not be locked) or, use the CATSysDLExport batch: you can write a script using this
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Once the file containing the DLNames has been imported in batch mode, end users must first activate DLName mode by selecting the Tools->Options... command, then the Document tab in the General category, then the DLName option in the Document Environment list, and finally by clicking the Configure... button to display the Configure dialog box. Run the program: C: Program Files B15 Dassault code bin CATSysDLExport.exe

Systemes

intel_a

CATSysDLExport Command Syntax
CATSysDLExport -admin -il filename -r ReportFile to import file filename with the current DLNames, only in admin mode, and lock all the DLNames in the file (the option -il is available only in admin mode); a report file is generated to log the encountered problems CATSysDLExport [-admin] -i filename -r ReportFile to import the file filename with the current DLNames, either in user mode or in admin mode; a report file is generated to log the encountered problems CATSysDLExport -a DLName 'NTPath' UPath or: CATSysDLExport -a DLName "NTPath" UPath to add the DLName with the values NTPath and UPath for the current real UNIX and Windows path. Note that the CATSysDLExport command behaves like a standard UNIX or Windows command: names including blanks should be surrounded by single (' ') or double (" ") quotation marks. Backslashes ( ) should be doubled
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(

).

CATSysDLExport -d DLName to remove the DLName from the current settings CATSysDLExport [-admin] -e filename to export the current DLNames to the file filename, either in user mode or in admin mode. The -nocheck option avoids checking the existence of the physical paths and their possible creation. Notes • The text file must be suitable for the platform on which the import is to be performed, consequently with carriage returns followed by a line feed (CRLF) on Windows, and just line feeds (LF) on UNIX. Therefore, if you use Notepad to create it, use either Windows directly or transfer it in FTP ASCII mode to UNIX before using it. If you import a first file containing, for example, DLName1 and DLName2, then import another file containing DLName3, the additional DLName3 will be added to the settings, so you will now have three DLNames to choose from. The format of the file to be imported (exported when configuring the DLNames interactively) is like this: ... DLName1;C:\MyDLnames;/tmp; DLName2;E:\AdditionalDLNames;/tmp; ... where the first part contains the DLName, the second part contains the path on Windows, and the third part contains the path on UNIX. No previously existing DLName will be updated during the import in user mode. These DLNames in the import file will be skipped, and can be updated only in administrator mode. This means that, for example, if the first file you import contains DLName2, and the second file also contains DLName2, but the path for DLName2 is different in the second file from the value in the first file, the path for DLName2 will be updated in the settings if imported in administrator mode. If a previously existing DLName did not have a lock, but is then updated with a lock by using the -il option, , the settings will be locked. For the changes to take effect after importing a file, you have to stop

•

•

•

• •
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Migrating Documents to Use DLNames
This section explains how to use the CATDLNameMigr batch tool for migrating existing documents once you decide to implement a data storage strategy based on the DLName mechanism.

Problems Involved When Migrating to a DLName Mechanism Strategy
You may have created a large number of documents with Version 5 without using the DLName mechanism. If you created documents pointing to other documents (for example, CATProduct documents), these documents contain the path of the documents pointed to. For example, the product structure in the document: E: users ses CATProducts Product1.CATProduct

points to a part contained in the following CATPart document: E: users ses CATParts Part1.CATPart

If you open the document Product1.CATProduct and select the Edit->Links... command, you will see in the "Links" and "Pointed documents" tabs that the CATProduct document points to the correct CATPart document. For example, this is what you see in the "Pointed documents" tab:

The path:
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E:

users

ses

CATParts

Part1.CATPart

is stored physically inside the document: E: users ses CATProducts Product1.CATProduct

After creating a large number of documents in this way, you may then decide to implement a data storage strategy based on the DLName mechanism, However, it is not sufficient to simply create DLNames for all the directories where your documents are stored. Because the path of pointed documents is stored in the pointing document, you need some way of converting the pathname in the document to the corresponding DLName. The CATDLNameMigr batch tool can be used to solve this problem. The batch tool can be used in two modes: • • repair mode: the pointing documents are "repaired", in other words modified to replace the pathname by the correct DLName check mode: provides information and generates a text file containing a list of DLNames; the pointing documents are not modified.

Running the CATDLNameMigr Batch Tool
Run the program: install_root code bin CATDLNameMigr.exe

where "install_root" is the name of your installation folder which is, by default: C: Program Files Dassault Systemes B15 intel_a

CATDLNameMigr Command Syntax
CATDLNameMigr [-r] filename(s) [-p] dir -d directory [-h] • • -r filename: activates repair mode and modifies the specified file -p directory: does NOT modify the original file, but copies it to the directory specified and modifies the file in this directory only. This is useful if you do not want to modify the original file. -d directory: name of directory containing pointing documents -h: displays help.

• •

Running CATDLNameMigr in Repair Mode
For the purposes of this scenario, we are going to use the documents mentioned earlier, and on Windows. The pointing document is:

147

installationDeployment

E:

users

ses

CATProducts

Product1.CATProduct

and the documented pointed to is: E: users ses CATParts Part1.CATPart

Make sure that no DLNames have yet been created. 1. Start a Version 5 session, and create two DLNames. To do so, select the Tools->Options... command, then the Document tab in the General category. To make the DLName environment the current document environment, select "DLName" in the Document Environments column, then select successively the Allowed and Current buttons. Then, click the Configure... button and add the two DLNames. You can name them "DLName1" and "DLName2." Make DLName1 point to: E: users ses CATParts

2. Exit the session, then open a Command Prompt window and go to the installation directory, which is by default: C: Program Files Dassault Systemes B15 intel_a code bin

3. Enter the command: CATDLNameMigr -r E: users ses CATProducts Product1.CATProduct

The output displayed in the command prompt window informs you that: • • you chose to run the tool with the "-r" option, so it will attempt to save the file it analyzed the file: E: users ses CATProducts and succeeded in modifying it. Product1.CATProduct

A report is created in the directory containing the pointing document: E: users ses CATProducts Product1.CATProduct.CATDLNameMigr_report

4. Restart a Version 5 session, then open the document Product1.CATProduct. 5. Select the Edit->Links... command, then click the "Pointed documents" tab:
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The batch tool uses the first DLName it finds in the list, and replaces the path by "DLName1" so the pointed document path is now: DLName1 Part1.CATPart

Our scenario shows how to repair a single document. To repair all the documents contained in a specific directory, run the command with the "-d" option followed by the name of a directory. For example, the command: CATDLNameMigr -r -d E: users ses CATProducts ses CATProducts. The "-d"

modifies all the files found in the directory E: users option can be run in check mode without the "-r" option.

Furthermore, if you do not want to modify the original document, specify the "-p" option followed by the name of a directory. For example, the command: CATDLNameMigr -r E: E: users users ses CATProducts Product1.CATProduct -p

runs the tool in repair mode, does NOT modify the original file, but copies it to the directory E: users and modifies the file in this directory only. This is useful if you do not want to modify the original file.

Running CATDLNameMigr in Check Mode
You can also run the batch tool without having created enough DLNames, or any DLNames at all. For the purposes of this scenario, we are going to use the same documents. But this time, make sure that NO DLNames have yet been created. 1. Start a Version 5 session, and make sure that no DLNames have been created.
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3. Enter the command: CATDLNameMigr E: users ses CATProducts Product1.CATProduct

Note that this time, you do not use the "-r" option. Because you have not yet created a DLName for the path: E: users ses CATParts

the batch tool cannot replace the path by the appropriate DLName. Displaying the document using the Edit->Links... command will show that the path has not been modified. The output displayed in the command prompt window informs you that: • • • you have chosen to run the tool in check mode (because you did not specify the "r" option") it could not change the link in E: users ses CATProducts the following file has been created in: C: Documents and Settings user Product1.CATProduct Local

Settings Temp CATDLNameMigr_missing-DLNames_report.txt in which a DLName has been created. The file contains the following line: DLName1;E: users ses CATParts;/tmp; The ".txt" file can now be imported, which will allow you to run the tool again later to repair the document. A report is created in the directory containing the pointing document: E: users ses CATProducts Product1.CATProduct.CATDLNameMigr_report

informing you that the link could not be changed because there was no corresponding DLName. 4. Restart a Version 5 session and import the text file. To do so, select the Tools->Options... command, then the Document tab in the General category. To make the DLName environment the current document environment, select "DLName" in the Document Environments column, then select the Allowed button. Click the Configure... button, then the Import... button, browse to select the file:
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C:

Documents and Settings Temp

user

Local

Settings

CATDLNameMigr_missing-DLNames_report.txt

The following DLName is added: DLName1 E: users ses CATParts

Now that you have a DLName, you can run the batch tool using the "-r" option to repair the file.

Command Outputs
Running the command in any of the above modes outputs information to the command prompt window about the tasks processed. This information can also be obtained using the "-h" option.

Setting Up DLNames in Administrator Mode
This task explains how to set up and lock DLNames in administrator mode. This allows you to implement a tightly controlled data storage strategy whereby end users will be able to store data in only those directories referenced by DLNames.

A Reminder about DLNames
The Document tab, accessed via the Tools -> Options... command, lets end users choose the way in which they access their documents. They set up "document environments" which can be: • • Folder: using this environment, end users explore the file tree to read and save their documents anywhere they like and without restriction DLName: using this environment, end users can determine that their documents will be read from or saved in specific directories only; they then assign a logical name, referred to as a "DLName", to each directory. In this mode, the different file opening and saving commands only allow end users to access documents in directories referenced by DLNames. Furthermore, the list of DLNames created can be exported to a text file for further use, for example the list can be imported by another end user to save time setting up directories. The advantage for end users is that it provides rapid and convenient access to document directories, which avoids having to explore the whole filetree. This is very convenient in organizations where there is only a small number of end users. But from the point of view of the administrator of a large site, allowing users to store their documents anywhere can lead to
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Phase One: How To Set Up DLNames for Your End Users
1. Log on as an administrator. You must belong to the Administrators group, or have the privileges assigned to the Administrators group. For the purposes of this particular scenario only, you need to log on as administrator because you are going to modify the default global environment (V5R15). 2. Select the Start->Programs->CATIA ->Tools->Environment Editor V5R15 command to display the Environment Editor. You will see an environment with the following name: CATIA.V5R15.B15 3. Double-click the CATIA.V5R15.B15 environment to display the corresponding environment variables. 4. Locate the following environment variable: CATReferenceSettingPath Note that the default setting for this variable is empty. 5. Reset the variable so that it points to an existing folder, for example: CATReferenceSettingPath E: users administrator LockSettings

then save your modification, and exit the environment editor. This folder will contain the setting locks you will create later. The folder access rights must be set up for read access only for end users, and read/write for the person creating the setting locks. 6. Run a session using the following command: cnext -env CATIA.V5R15.B15 -admin or: cnext -admin A session is started using the default global environment, and a message informs you that you are running in administration mode. 7. Click OK in the message box, then select the Tools->Options... command. The "Options" dialog box is displayed.
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Setting the DLName Environment As Current
9. To make the DLName environment the current document environment, select "DLName" in the Document Environments column, then select successively the Allowed and Current buttons. DLName is now defined as your current document environment as indicated by the "Current" value in the State column:

Creating DLNames
Now that you have set the DLName environment as your current environment,
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button or right-click then select the New command once for 11. Click the each new DLName you want to create. A default name and a default folder are assigned to each new DLName as shown below:

12. To customize the DLName, click "DLName1", then click again to activate the
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When creating DLNames, you can also organize them into a logical tree using Root DLNames. For more details, refer to the section "Customizing Settings General - Document" in your Infrastructure Users Guide. 13. To customize the folders, click C: (Windows) or /tmp (UNIX) in the appropriate column, then click again to activate the editor field, type the path of the folder and press the ENTER key. Instead of typing in the editor field, you can also choose a folder by clicking in the field, and selecting the New contextual command and selecting the folder using the explorer which is displayed. Note that you can include system or user-defined variables in DLNames using the syntax $ {VARIABLE}: Example 1 C: users variable. Example 2 DLNAME2=${HOME} where ${HOME} is equivalent to c: on Windows. 14. To lock the DLName for end users, select the DLName and click the Lock icon. Locking a DLName changes its state from "Green" to "Orange" (and inversely when you unlock the DLName): ${MODEL} publish where ${MODEL} is a user-defined

The reason why you would want to lock DLNames is to restrict end user access to only those folders referenced by DLNames. End users running Version 5 using 155

installationDeployment the same environment will inherit the locks you set on DLNames, and will not be able to either modify or remove them. 15. Add another DLName and name it "CATProducts", lock it using the same procedure as above, then rename the folders:

End users will not be able to modify or remove DLNames, but will still be allowed to add DLNames. If you do not want this to happen, lock the list by clicking the green lock symbol to change it to the orange lock symbol . and will not be able to add End users will then see the red lock symbol DLNames to the list. 16. When finished adding DLNames to your list, you can then click the Export... button to save your list of DLNames as an ASCII .txt file.

This is particularly useful when you have a large number of machines. You can then import the .txt file containing the DLNames onto all the machines so that end users also inherit the same DLNames, as described in Importing DLName Settings in Batch Mode. You can make as many lists as you like. Whenever you want to use one of them, before selecting a list from the Import dialog just click the Import... button box. 17. Click OK to close the Configure dialog box 18. To force end users to use the DLName strategy only, make sure that "DLName" is still "Current", set Folder to "Not Allowed", click the lock for the Document Environments, then click OK to exit the Document tab. DLNames settings are stored in the settings file: DLNames.CATSettings.

Phase Two: What Your End Users See
This task describes the effect of setting up and locking DLNames on the end user environment. 1. Log on as an end user, and start a Version 5 session using the normal startup commands, that is, without using the "- admin" option. 2. Click the Open icon or select the File->Open... command.

Because your administrator earlier locked the access to document environment

156

Project Standards selection, and forced the DLName document environment, instead of the usual File Selection dialog box, the following panel opens:

The "Look in" pulldown list only contains the DLNames you defined in the previous steps: • • CATParts CATProducts.

3. Select the desired File name and type from the list. 4. Click OK to open the document. DLNames are also integrated in the following commands: • • • • • • • File->Save (included Save As, Save All and Save Management) File->Desk File->New from... File->Send To Edit->Links Catalogs Search order ("Other folders" option), etc.

5. Select the Tools->Options... command, then the Document tab in the General category. 6. Select the DLName option in the Document Environment list, then click the Configure... button to display the Configure dialog box:
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Note that you cannot delete, modify or rename any of the DLNames in the list.

Fonts: Using/Customizing
About Fonts
This section contains principally conceptual information about font support in general, identifies which areas of the Version 5 software are concerned by font support, and explains how you can customize fonts. The areas of the software which allow font customization are: • • • user interface: menu names, command names, tooltips, dialog box names and texts, etc. specification tree texts texts you enter in certain applications, and which reference fonts: a typical example is the text you enter in drawing documents created using the Generative Drafting product.

You will also find information about how, in certain contexts, the text you see in the geometry area may not look exactly the same when you print. And finally, if you used the CATFONT utility in CATIA Version 4 to customize your own fonts, you will also find information about how to recover the fonts for use in Version 5. Note that when using PostScript fonts on Windows operating systems, the font display may change while moving for performance and visibility reasons. How does it work? • • When static, the bitmap representation is generated using the corresponding TrueType font While moving, there are three display modes: o PostScript: the polygon is displayed o Stroke: the segment is displayed o Bounding box: the box (i.e. four segments) is displayed.
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Customizing User Interface Fonts on Windows

This task explains how to customize user interface fonts on Windows. 1. Select the Start->Settings->Control Panel command, then double-click Display and select the Appearance tab (if it is not displayed by default). The following dialog box appears:

2. Use the Item list to select an item of the user interface you want to customize, or click on a user interface item in the area in the center of the dialog box.
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For example, select the items: • Menu • Message Box • if you want to customize menu command, message box, dialog box and tooltip text fonts. 3. Select the desired font, font size and color. 4. Click Apply, then OK. 5. If you have a Version 5 session open, exit the session and restart to see the changes take effect.

Customizing Fonts for Displaying Texts
This task explains how to customize the fonts used, for example, to display: • • texts in the specification tree constraint texts in the Sketcher, Part Design, Assembly workbenches

and, in general, all 2D texts. Note that system fonts are used for displaying these types of text. This does not concern texts you enter in drawing documents created using the Generative Drafting product.

On Windows
1. Select the Start->Settings->Control Panel command, click the Display control then click the Appearance tab (if it is not displayed by default). 2. In the Item list, select the Message Box item, or click inside the Message Box item (on Message Text) in the area in the center of the dialog box. 3. Select the desired font, font size and color. 4. Click Apply, then OK. 5. If you have a Version 5 session open, exit the session and restart to see the changes take effect.
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Customizing Fonts for Displaying Geometry Area Texts
This task explains how to choose fonted texts displayed in the geometry area, for example, when using the Generative Drafting product, and lists the fonts you can choose from. You need access to the Generative Drafting product license to follow this scenario which shows you how to enter text in a drawing and choose a font for the text. The objective is to present the list of fonts supported. 1. Open a drawing you created using the Version 5 - Interactive Drafting product. 2. Click the icon, then click a point in the drawing to position the text.

The Text Editor dialog box is displayed. 3. Use the Text Editor dialog box to write the text, justify it, specify the text height and define the anchor point, then click anywhere outside the Text Editor window, but inside the main application window. The Text Editor dialog box disappears. 4. Point to the text, right-click and select the Properties command. The Properties dialog box is displayed: 5. Click the Font tab. The Font tab includes controls for setting the font, font style and size:
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Which Font Formats Are Supported?
Version 5 provides the following font formats: • • • PostScript Type 1 format CATIA Version 4 FONT format TrueType format

With respect to the PostScript Type 1 font format, note that on Windows only, if a TrueType version of the font exists or has been created, the TrueType version of the font can be used to optimize visualization quality.
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Which Fonts Are Provided?
The following fonts are supported and are installed ready for use without further customization when you install Version 5: • • • • all default stroke fonts delivered previously with CATIA Version 4 22 Bitstream Type 1 fonts an extra font (customized by Bitstream): CATIA Symbols; this font contains the symbols from Version 4 fonts TrueType fonts provided by Windows.

Note that the Bitstream fonts are delivered in several different styles (depending on the font), whereas the CATIA Version 4 fonts are delivered in regular style only. Furthermore, the 22 Bitstream fonts support ISO-8859-1 environments only. Fonts in TrueType format may be used as is, i.e. all fonts delivered will be displayed in the font list. However, you can customize this list (for instance, to keep only the fonts you use most frequently) by copying the desired fonts to your Version 5 environment in: install_root resources fonts TrueType

where "install_root" is the installation folder (Windows). For TrueType fonts, a ".ttf" file is required.

Which Bitstream Fonts Are Supported?
The Bitstream fonts are:
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Font Name Swis721 BT

Attribute

File Name Swiss.pfb SwissI.pfb SwissB.pfb SwissBI.pfb SwissCL.pfb SwissCLI.pfb SwiOuB.pfb Monos.pfb MonosI.pfb MonosB.pfb MonosBI.pfb Dutch.pfb DutchI.pfb DutchB.pfb DutchBI.pfb Coure.pfb CoureI.pfb CoureB.pfb CoureBI.pfb Mathe.pfb SymbM.pfb SymbP.pfb

roman italic bold bold italic Swis721 LtCn BT light condensed light condensed italic Swis721 BdOulBT bold outline Monospac821 BT roman italic bold bold italic Dutch801 Rm BT roman italic bold bold italic Courier10 BT roman italic bold bold italic UniversalMath1 regular BT SymbolMono BT regular SymbolProp BT regular Note that: • • • •

the Swiss 721 Bitstream font family is Bitstream's version of Helvetica the Monospace 821 Bitstream font family is Bitstream's version of Helvetica Monospaced the Dutch 801 Bitstream font family is Bitstream's version of Times Roman the CATIA Symbols font (not in the above list) contains the symbols from Version 4 fonts.

For each of the Bitstream fonts, the following files are delivered in the location referenced by the CATFontPath variable: • • in the Postscript folder or subdirectory: .pfb, .inf, .pfm, .afm in the ExtraFiles folder or subdirectory: .ttf. Note: On Windows only, installing Version 5 also installs in the ExtraFiles environment the equivalent fonts in TrueType format. The TrueType font format offers enhanced visualization quality. The installation adds the fonts (in TrueType format) to the list of system fonts you can view by selecting the Start->Settings->Control Panel command and double-clicking the Fonts control.
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Which Version 4 Fonts Are Provided?
The following Version 4 fonts are supported and are installed ready for use without further customization when you install Version 5: • • • • • SSS1.font, SSS2.font, SSS3.font, SSS4.font: 4 simplex sans serif fonts ROM1.font, ROM2.font, ROM3.font: 3 roman fonts GOTH.font: 1 Gothic font SYM1.font, SYM2.font, SYM3.font, SYM4.font: 4 symbol fonts KANJ.font: Kanji font (Japanese) Regarding the KANJ font, from now on, halfwidth Katakana characters are displayed with a smaller width than the width with which they were displayed in CATIA Version 4 • • • KOHG.font: Hangeul font (Korean) TRCH.font: Traditional Chinese font SICH.font: Simplified Chinese font.

Note that: • • • • SYM1 contains annotation and tolerance symbols, and plot markup characters SYM2 contains ISO symbols fonts SYM3 contains roughness symbols SYM4 contains graphic and mathematical symbols as well as miscellaneous technical symbols.

Adding Extra PostScript Fonts
This section explains how to add extra PostScript Type 1 fonts. A large choice of PostScript or TrueType fonts is available from Bitstream Inc. (http://bitstream.com). You can address questions about ordering Bitstream fonts to: http://catia_support@bitstream.com 1. Copy the new fonts to your Version 5 environment in: install_root resources fonts PostScript

where "install_root" is the installation folder (Windows) or directory (UNIX).
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For Type 1 fonts, the following files are required: • ".pfb" or ".pfa" font files • ".afm" and ".inf" files. To achieve enhanced font visualization (Windows only), if the associated TrueType font does not exist, you can ask the system to generate it from the PostScript files (the following file types are needed: .pfb, .afm, .inf). 2. To do so, select the Start->Settings->Control Panel command, doubleclick the Fonts control, then select the File->Install->New Font... command. 3. Select the font, and when prompted, check the three options, notably the first option in the dialog box: "Convert Type1 to TrueType", then click OK. If an agreement exists between the font supplier and Microsoft, the system will then generate the corresponding TrueType font. If not, the font will not be generated. 4. Edit the file: install_root resources fonts PostScriptRelatedTrueType

to map the PostScript file name with the full name of the TrueType equivalent. The "full name" refers to the name of the font visible when selecting the Start->Settings->Control Panel command and doubleclicking the Fonts control. If you already have the TrueType fonts, you can simply install them. To do so, select the Start->Settings->Control Panel command, doubleclick the Fonts control, then select the File->Install->New Font... command and select the fonts to be installed.

Understanding Differences Between Font Display and Printed Output
This section contains information about minor differences you may notice between the way text is displayed in the geometry area and how it looks in printed output.

Text Display
In general, there is a slight difference in how text is displayed between Windows and UNIX: on Windows, text is displayed using TrueType fonts, whereas Type 1 Postscript fonts are used on UNIX.
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Differences between Text Display and Printed Output
When printing on printers using the drivers listed below, you can expect the following results: Driver GDI Font Used for Printing On Windows TrueType Font Used for Printing On UNIX N.A. Discretization is applied to Drafting texts.

PostScriptAny differences between displayed and printed text depend on how your System Administrator set up your printer.

For 2D texts (for example, in the specification tree), if the P2 setting is active, printing the text produces a bitmap, whereas in all other cases, texts Your printer may be set up are printed using the font referenced in in one of three ways: the following resource file: • • the printer has all Install_folder/resources/msgcatalog/Print the required memory and fonts By default, the font is Helvetica. the printer does not have the fonts, but For DBCS languages, discretization is the PostScript file applied to 2D texts. contains fonts or you may have to map your printer to a specific font. For example, to view your printer properties in a Version 5 session, select the File>Print... command, click the Properties... button and view the printer properties on the Advanced tab.

•

CGM HP- N.A. GL2, HPRTL CalComp C907 Oce Graphics GPR50 Versatec: VCGL and VGS 2.0

Discretization is applied to texts.
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Help
This tab deals with the options concerning: • • technical documentation contextual priority

Technical documentation

168

Project Standards

Location
Displays the current location of the online documentation. By default, the online documentation is located in: C:\Program Files\Gehry Technologies\Digital Project V1,R2\GTR2\Help

Enter the path where the documentation is installed or click the Path selection icon to navigate to the desired location then click the directory or file to the path (displayed to the right). icon to add the selected

Once a path has been added to the list, you can select it then click the following icons to: • • • move it up in the list move it down in the list remove it from the list.

Please note the following information: • • if you install the documentation on the network, you can map a drive and enter the appropriate path in this field. UNC (Universal Naming Convention) syntax is also supported. Refer to Doc Installation Path for more details. if the online documentation is installed on a http server, the installation path must be surrounded by quotes, for instance "http://myserver/B14doc".

Note also that the Path Selection dialog box lets you select several different paths to interactively concatenate them. On Windows, you can perform the concatenation manually. In that case, the separator to be used is ; and not : . Furthermore, when you select several paths using the Path Selection dialog box, the concatenated paths are represented between " ", for example, like this: "J:\V1R1DOC\Doc";"F:\V1R2DOC\Doc" If you indicate a wrong path, an error message is displayed to inform you that the previous path will be kept.

Language
Lets you select your documentation language: "Environment language (default)" or
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