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Overview
Welcome to Rendering and Materials. This guide is intended for users who need to become quickly familiar with the Real Time Rendering products. This overview provides the following information: • • • • • Real Time Rendering in a Nutshell Before Reading this Guide Getting the Most Out of this Guide Accessing Sample Documents Conventions Used in this Guide

Real Time Rendering in a Nutshell
Real Time Rendering 1 allows you to define material specifications that will be shared across your entire product development process as well as map materials onto parts and products to produce realistic renderings. Material specifications define the characteristics of materials: • • • Physical and mechanical properties (Youngs modulus, density, thermal expansion, etc.) 3D representation: textures on geometry 2D representation: patterns for drafting purposes.

Other Version 5 products such as Analysis, Generative Drafting and Knowledge Advisor share the material specifications defined using Real Time Rendering 1. Materials are organized and managed in libraries. A default material library is provided with Real Time Rendering.
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Before Reading this Guide
All users should be familiar with basic Interacting in Digital Project concepts such as document windows, standard and view toolbars as well as the 3D compass, and other generic capabilities common to Digital Project.
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Rendering and Materials: Overview

Getting the Most Out of this Guide
To get the most out of this guide: • If you are a first time user, we suggest that you start with the Getting Started tutorial. Once you have finished, you should move on to the user task section (Basic Tasks and Advanced Tasks) in this guide. This steps you through basic procedures If you need some help in understanding tools and commands, use the on-line help. You can also take a look at the Basic Tasks sections of this guide to locate information with which you are not already familiar The Advanced Tasks section of this guide shows you how to organize and manage your own collections of materials.

• •

Project Standards contains a section which explains how to set up the options, will also certainly prove useful. For information on automation capabilities, see Real Time Rendering on the Automation Documentation Home Page. Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct access from the table of contents to the information.

Accessing Sample Documents
To perform the scenarios, you will be using sample documents contained in either this folder installDir\Digital Project\GTR1\help\English\online\mergedProjects\renderingMaterials\samples or in this folder installDir\Digital Project\GTR1\help\English\online\cfyug\samples where installDir is the directory into which you installed Digital Project For more details see Accessing Sample Documents.

Conventions Used in this Guide
To learn more about the conventions used in this guide, refer to the Conventions section.
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What's New?
No enhancements in this release.
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What You Should Know Before You Start
A default material library file is provided with Real Time Rendering. By default, this file is located: • • under Windows: $CATStartupPath startup materials Catalog.CATMaterial under UNIX: $CATStartupPath/startup/materials/Catalog.CATMaterial

Note: For languages other than English, a folder identified by the appropriate language contains the Catalog.CATMaterial. Would you need to open a specific library, you can do so interactively using the Library dialog box. See Applying a Material. The environment variable CATStartupPath concatenates start-up directories. When applying a material, the library is looked for according to the user-defined path, and if no specific path has been indicated, the first occurrence of the Catalog.CATMaterial found in the directories listed in the variable is loaded.

Applying Materials
This task shows you how to apply pre-defined materials. In this example, you will map "Aluminium" then "Honeycomb" onto a part. Open the SaltnPepper.CATProduct document. 1. Click the + sign next to "Part (Part.2)" then next to "Part" to select "Body.2" in the specification tree. 2. Click the Apply Material icon .

The Library dialog box opens, containing sample materials from which to choose:

3. Click the Metal tab. 4. Select Aluminium.
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5. Click Apply Material to map the material onto the part. To visualize the applied material, select the Shading with Material icon from the View Toolbar. 6. Click OK. The material is mapped onto the selected part and is identified in the specification tree.

7. Repeat steps 1 and 2 then click the Fabric tab and change the material to Honeycomb. 8. Click OK in the Library dialog box. 9. Click in the free space. Honeycomb is now mapped and the specification tree is updated to include the material you just applied.
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Applying a Material
This task explains how to apply a pre-defined material as well as to interactively reposition the mapped material. A material can be applied to: • a PartBody, Surface, Body or Geometrical Set (in a .CATPart document). You can apply different materials to different instances of a same CATPart. a Product (in a .CATProduct document) instances of a .model, .cgr, .CATPart (in a .CATProduct document).

• •

Materials applied to .CATPart, .CATProduct and .cgr documents can be saved in ENOVIAVPM. For detailed information on ENOVIAVPM, refer to the ENOVIAVPM User's Guide on the ENOVIAVPM Documentation CD-ROM. Keep in mind that applying materials onto elements affects the physical and mechanical properties, such as the density, of these elements.
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Within a CATProduct, you should not apply different materials to different instances of a same part because a material is part of the specific physical characteristics of a part. Therefore, this could lead to inconsistencies.

Open the ApplyMaterial.CATProduct document. To visualize the applied material, select the Shading with Material icon from the View Toolbar.

1. Select the element(s) on which the material should be applied. If you want to apply a material simultaneously to several elements, simply select the desired elements (using either the pointer or the traps) before applying the material. 2. Click the Apply Material icon .

The Library dialog box opens. It contains several pages of sample materials from which to choose. For a complete description of the families provided with the default material library, refer to "Material Sample Library" in this guide. Each page is identified either by a material family name on its tab (each material being identified by an icon) if you select the Display icons mode...

...or by a material family name in a pulldown list if you select the Display list mode:
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icon opens the File Selection dialog box Clicking the Open a material library which lets you navigate through the file tree to your own material libraries. You can, of course, use the default library (see What You Should Know Before You Start in this guide) by choosing "Default Material Catalog". The pulldown list displays the list of previously opened material libraries. When you reopen the dialog box, the last chosen material library is placed on top of the list and used by default unless you select another one. Depending on the document environments (i.e. the method to be used to access your documents) you allowed in the Tools->Options->General->Document tab, an additional window such as the one displayed below may appear simultaneously to the File Selection dialog box to let you access your documents using an alternate method:

In our example, four document environments have been allowed among which the DLName environment. If you want to access your texture files using DLNames, for instance, just click the Logical File System button: this will open a specific dialog box dedicated to the DLName environment. For detailed information on this dialog box, refer to Opening Existing Documents Using the Browse Window. 3. Select a material from any family, by a simple click. Once a material is selected, you can drag and drop or copy/paste it onto the desired element directly from the material library. Unless you select in the specification tree the desired location onto which the

11

renderingMaterials material should be mapped, dragging and dropping a material applies it onto the lowest hierarchical level (for instance, dragging and dropping onto a part in the geometry area will apply the material onto the body and not onto the part itself). However, note that a material applied onto a body has no impact on the calculation of the part physical properties (mass, density, etc.) since only the physical properties of the part, and not those of the body, will be taken into account. 4. Activate the "Link to file" checkbox if you want to map the selected material as a linked object and have it automatically updated to reflect any changes to the original material in the library. and the other without ) Two different icons (one with a white arrow identify linked and non-linked materials respectively in the specification tree. Another method is to use the Paste Special... command which lets you paste a material as a linked object. You can copy both unlinked and linked materials. For example, a linked material can be pasted onto two different elements in the same document or onto the same element in two different documents. For more information, see Copying & Pasting Using Paste Special... in this guide. When no object is selected in the specification tree, you can select the Edit>Links... command to identify the library containing the original material. You can then open this library in the Material Library workbench if desired. 5. Click Apply Material to map the material onto the element. The selected material is mapped onto the element and the specification tree is updated. In our example, the material was mapped as a non-linked object.

A yellow symbol may be displayed next to the material symbol to indicate the inheritance mode. For more information, refer to Setting Priority between Part and Product in this guide.
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Material specifications are managed in the specification tree: all mapped materials are identified. To edit materials (for more information, see Modifying Materials), simply rightclick the material and select Properties from the contextual menu (or use one of the other methods detailed in About Material Properties). 6. Click OK in the Library dialog box. The object looks the following way:

7. Right-click the material just mapped in the specification tree and choose the Properties item. The Properties dialog box is displayed:
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8. Choose the Rendering tab to edit the rendering properties you applied on the element. 9. If necessary, change the material size to adjust the scale of the material relative to the element. 10. Click OK in the Properties dialog box, when you are satisfied with the material mapping on the element. Do not forget that appropriate licenses are required to use the Analysis and Drafting tabs. 11. Use the 3D compass to interactively position the material: Note that material positioning with the 3D compass is only possible in the Real Time Rendering, Product Structure, Part Design and DMU Navigator workbenches.
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• Select the material in the specification tree:

The compass is automatically snapped and the mapping support (in this case, a cylinder) appears, showing the texture in transparency. If necessary, zoom in and out to visualize the mapping support which reflects the material size. • Pan and rotate the material until satisfied with the result. You can: o Pan along the direction of any axis (x, y or z) of the compass (drag any compass axis) o Rotate in a plane (drag an arc on the compass) o Pan in a plane (drag a plane on the compass) o Rotate freely about a point on the compass (drag the free rotation handle at the top of the compass):

• Use the mapping support handles to stretch the material texture along uand v- axes (as you can do it with the slider in the Scale U, V fields displayed in the Texture tab):

15
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For more information on manipulating objects using the 3D compass, refer to the Version 5 - Infrastructure User's Guide.

More about materials
• • • The application of a material cannot be recorded in a macro file You can run searches to find a specific material in a large assembly (for more information, see Finding Materials in this guide) or use the copy/paste or drag/drop capabilities. If you are working in "Materials" visualization mode (i.e. the "Materials" option is checked in the Custom View Modes dialog box) with no material applied to your object, this object is visualized using default parameters that only take into account the color defined in the object graphic properties. As a consequence, an object with no mapped material appears as if made of matte plastic, non-transparent and without any relief. Contrary to materials with no texture (such as "Gold"), materials with a texture (such as "Teak") are applied with an external link to their texture image. Therefore, this link is displayed when using the File->Desk, Edit->Links... or File->Send To command. In the example below, "Italian Marble" has been applied onto Chess.CATPart and the link to the corresponding .jpg image appears when displaying the Links dialog box:

•
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Finding Materials
This task explains how to use the search for materials in documents. This is useful in large assemblies where you will be able to rapidly identify materials of interest. You can then, if desired, individually edit selected materials. For more information on the Search command, see Using the Search... command (General Mode). You can also perform advanced queries and save your favorite queries using the Advanced and Favorites tab. For more information, refer to Using the Search... command (Advanced and Favorites Mode) . Open the SaltnPepper.CATProduct document.
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1. Select the Edit -> Search... command to open the Search dialog box. 2. Click the General tab.

3. Set the Workbench field to "Rendering". 4. Set the .Type field to "Material". 5. Ensure the Look box is set to "Everywhere" to search the whole product 18

User Tasks structure. 6. Click Search to start the search The search results are listed in the area in the lower half of the Search dialog box.

7. Click Select to select found items and then OK to exit the dialog box. 8. Expand all entries in the specification tree to see that all mapped materials have been selected.
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9. Select the Edit->Properties command: The Properties dialog box appears letting you edit the properties of selected materials. Click the Current selection drop-down list box and select the materials in turn to edit them. For more information on editing materials, see Modifying Material Lighting and Texture Properties. To edit other materials in your document, de-select the first material in the specification tree then select the Edit -> Properties command again.

Copying & Pasting Materials Using Paste Special...
When you use the Paste Special... command, material is pasted as a linked object. You can copy a: • Material from a library: The part will be automatically updated to reflect any changes to the original material in the library. This is also useful in large assemblies if you have material specifications that may change and that you use in more than one place. Materials can also be mapped as linked objects from libraries using the Link to file checkbox in the Library dialog box. Paste the material on a different part in the same document: The link is made from the second part to the first part. Editing the material on either part will automatically update the material on the other part Paste the material on parts in different documents: Editing the material on any part will automatically update all linked materials on all parts in all documents. You can in this way change the material specifications in all places where they appear without having to edit each individual occurrence.

• •

This tasks explains how to copy and paste materials using the Paste Special... command. Open the EditMaterial1.CATMaterial and Paste.CATProduct documents.

1. Select the material you want to copy from the EditMaterial library.
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2. Copy the material. To do so, you can either: • Click the Copy icon • Select the Edit->Copy command or • Select the Copy command in the contextual menu 3. Select the part onto which you want to map the material (Part2 in our example) 4. To paste, you can either: • Select the Edit->Paste Special... command or • Select the Paste Special... command in the contextual menu The Paste Special dialog box appears:

5. Click Material Link in the dialog box, then click OK. The material is mapped onto the selected part and the specification tree updated. A linked material icon identifies the material in the specification tree.

Note: You cannot change the material name in the Feature Properties tab of the Properties dialog box. For detailed information about the Paste Special... command, refer to Using the Paste Special... command. Simple copy and paste as well as drag and drop operations can also be performed. In both cases, the mapped material is not linked.

Managing Broken Links
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Mapping a material as a linked object sometimes leads to a broken link when the mapped material is not found. This task details in which cases this may occur. Open the EditMaterial1.CATMaterial and Pad.CATProduct documents and select the Shading with Material icon from the View toolbar.

1. Select the Edit->Links... command from the main menu to open the Links dialog box:

2. Close the Links dialog box then move the document EditMaterial1.CATMaterial to another folder. 3. Restart your session, then reopen the document Pad.CATProduct. The Open dialog box appears, explaining that the document EditMaterial1.CATMaterial could not be found:

There are several reasons why a link with a material may no longer work: • the material has been deleted. In that case, the link cannot be restored since the material has been definitely lost • the material has been moved or renamed which means that it exists but it is
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User Tasks different from the file pointed to. In that case, the pointed document will be searched in: o the current session o the directory of the loaded document o the default material library. This library is defined in the CATStartupPath variable or in the Material Libray subcategory (under the Tools>Options...->Infrastructure->Material Library category). When a link to a material is broken, the material icon is not displayed anymore in the specification tree. However, the link can still be seen when selecting the Edit>Links... or the File->Desk... command and you can then restore the link manually. To do so, follow the steps below. 4. Click the Close button then select the Edit->Links... command:

5. Click the Pointed documents tab. This activates the Find button and provides you with the path and name of the document pointed to in the session. 6. Click the Find button to open the File Selection dialog box, explore your file system to find the corresponding missing file, select it, then click Open. Once the material has been found, the broken link icon is replaced with the linked material icon in the specification tree.

The File Selection dialog box can be directly accessed from the Open dialog box (introduced in Step 3) either by double-clicking the file path inside the field or by clicking the Desk button. In both cases, the Desk opens and you just have to select the CATMaterial before 23
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7. Still in the Pointed documents tab, click the Open button. The Links dialog box disappears and EditMaterial1.CATMaterial opens. 8. If you now select the Edit->Links... command with the EditMaterial1.CATMaterial document active, the Links dialog box will indicate that the right material library has been found and loaded. For more information on managing document links, refer to the Version 5 Infrastructure User`s Guide. Use the Send To->Mail/Directory command from the File menu when you want to send a document to another person. This command enables you to check the various links existing between your documents and thus, to avoid broken links.
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Here is a non-exhaustive list of the most Frequently Asked Questions about materials.

How to display materials applied onto objects? How to improve the material display? How to prevent the texture image from disappearing? How to apply materials from a user-defined catalog? How to visualize cgr files correctly? How to save a catalog opened in read-only mode? How to modify the default environment image on reflective materials? How to repair broken links to materials? How to find the material textures? How to find the catalog a material is originated from? Where is stored the material applied onto a product?

How to display materials applied onto objects?
Select the View->Render Style->Customize View command then check the "Material" option or click the Shading with Material icon from the View Toolbar.

How to improve the material display?
Sometimes, the material you applied onto an object may look dull or without any relief. You can: • • replace the environment image by an image with more contrast or with more vivid colors. This will impact the reflection of all the materials applied onto the model or if you want to modify only one material, you can define a specific environment image for this material. To do so, access the material properties then click the ... button next to the Reflectivity slider. Bear in mind that a Real Time Rendering 2 license is required in that case or if the material has a texture, you can play with the contrast of the texture image.

•
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How to prevent the texture image from disappearing?
When increasing the material reflectivity, the texture image is no longer displayed. Standard OpenGL technology cannot visualize a texture image and a reflection image simultaneously on the same material. As a consequence, if the material reflectivity is set to a value lower than 0.2, the texture image is preferably displayed. Inversely, if the material reflectivity is higher than 0.2, then the reflection image is preferably displayed. Note that using other types of materials, such as OpenGL shaders, lets you display both effects simultaneously.

How to apply materials from a user-defined catalog?
Select Tools->Options->Infrastructure->Material Library then under the Material tab, indicate the path of the user-defined catalog you want to use in the "Default Material Catalog Path" field. This catalog will then open by default when using the Apply Material command.

How to visualize .cgr files correctly?
.cgr files included in .CATPart documents onto which materials have been applied from a user-defined catalog may not be correctly displayed after the modification of this catalog. The .cgr files have to be regenerated because they are not updated. To do so: 1. remove the existing .cgr files 2. export the NO_LOAD_CGR=1 environment variable 3. reload the model to re-create the .cgr files properly.

How to save a catalog opened in read-only mode?
When trying to save a material catalog, a message will inform you that the catalog is in read-only mode and cannot be saved. By default, any material catalog you open in your Version 5 session will open in read-only mode for performance reasons. To avoid loading a catalog in read-only mode and thus, be able to save it, select Tools->Options...->Infrastructure->Material Library then in the Material tab, check the "Applying a material opens the catalog in read/write mode" 26
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How to modify the default environment image on reflective materials?
Select Tools->Options->Infrastructure->Material Library then under the Material tab: • enter the path of the user-defined environment image in the "Environment Image File" field or click the folders to the desired location • icon to browse your

or, when working with a Real Time Rendering 2 license, click the icon to create a new environment image.

Note that you do not need to restart a Version 5 session to take the new environment image into account.

How to repair broken links to materials?
When opening a model onto which materials have been applied from a userdefined catalog, the materials cannot be found and thus, the links to these materials are broken. To correct this: 1. select Tools->Options->General and access the Document tab 2. in the Linked Document Localization area, check that the "Other folders" strategy is active (i.e. if "Yes" is displayed in the Active column). If it is not active, just click the Activate button 3. slick the Configure... button 4. in the Other Folders dialog box, select the folder containing your catalog in the "Look in" list 5. click the Add button to add it to the search order.

How to find the material textures?
Sometimes, textures used by materials saved in a material catalog or in a CATPart or a CATProduct are not found by the application. To correct this: 1. select Tools->Options->General and access the Document tab
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renderingMaterials 2. in the Linked Document Localization area, check that the "Other folders" strategy is active (i.e. if "Yes" is displayed in the Active column). If it is not active, just click the Activate button 3. click the Configure... button to open the Other Folders dialog box 4. select the folder containing your texture images in the "Look in" list 5. click the Add button to add it to the search order.

How to find the catalog a material is originated from?
When applying a material as a linked object in a CATPart or a CATProduct, you may want to find the catalog in which this material is included. To do so, use the Edit->Links... command to display the list of links between documents. As this list shows the entire path of each link, it will be easy to identify the name and location of the catalog containing the linked material.

Where is stored the material applied onto a product?
When working with several levels of products in the same document, you may sometimes wonder where the material applied onto a product is stored: the material is stored in the document of the root product. Let's take the following example:

Three different materials are applied onto three different elements: • • • "Concrete" is applied onto Product1 "Copper" is applied onto Product2 "Turf" is applied onto Part1.

Once the document has been saved, if you reopen each element individually (either using the File->Open... command or the xxx object->Open in New Window contextual command), the result will be as follows:
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• •

•

when reopening Product1, the material applied onto it, i.e. "Concrete", will be displayed when reopening Product2, no material will be displayed because the material applied onto Product2 ("Copper") is stored in the root product, i.e. Product1 in our example. However, you can store the material in Product2: to do so, first open Product2 in a new window then apply the material onto it. As a consequence, if you want to be able to see the "Copper" material, you need to open Product1 when reopening Part1, the material applied onto it, i.e. "Turf", will be displayed because the material applied onto a part is stored in the part itself.
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Opening the Material Workbench
This tasks explains how to load the Material Workbench and open a CATMaterial document. 1. Select the Start-> Infrastructure-> Material Library menu item. The Material Workbench is loaded, and a CATMaterial document is created.

By default a family and a material are in the document, ready to be renamed and edited.

31
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Material Libraries
Creating a Material Library
This tasks shows you how to add materials to a family, and create more families for your material libraries. Note that from V5R15 onwards, you cannot create several materials or material families with the same name: each name must be unique. Open a .CATMaterial document as described in Opening the Material Workbench. 1. Click the Rename Family icon The New Name dialog box is displayed. 2. Key in the new name for the family, and click OK. to give an explicit name to the default tab.

Here we called it "Wood":
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3. Click on the New Family

icon to create a new family.

A New Family tab is displayed in the document.

4. Repeat step 2 and 3 to create more families such as "Metal", "Stone", "Cloth" and so forth.

Note: You can copy and paste families.

None of the new families contain any material yet. 5. Click the Wood tab to activate the wood family. There is only the default material in this family so far.
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6. Select the material.

7. Click the Rename Material dialog box. Let's call it Bark. 8. Click the New Material

icon to rename the material via the New Name

icon to add material to this family.

You can add, and rename the Beech, Cork, Wild Cherry types of wood for example, and many more.

Now that your library is defined, you will need to modify each material to give it specific material properties. For more information on how to do so, see Modifying a Material. You can also remove a family or a material, simply by selecting the object then clicking on the Remove Family or Remove Material(s) icon respectively.

Sorting Materials Within a Family
This tasks explains how to arrange materials alphabetically within a family in ascending and descending order. Open the SortMaterial.CATMaterial document.
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1. Click the Sort Materials (A->Z)

icon.

The materials are automatically arranged in ascending alphabetical order, from left to right and top to bottom:

2. Click the Sort Materials (Z->A) icon materials:

to reverse the sort order of
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You are not obliged to sort materials alphabetically. You can click one or more materials and drag them to their new location if you wish to set them in a specific order. You can do this material by material, or use the multi-selection capabilities (Shift and Ctrl keys).

Sending Material Texture Images
This tasks explains how to send images used for material textures in the mail or to a directory or a diskette. Open the SortMaterial.CATMaterial document.
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Sending in the mail
1. Select the File->Send To->Mail command. The Send To Mail dialog box opens:
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In the upper part of the dialog box you can see a list of all the different documents linked to the document you selected for the send operation. The four columns provide information about the file name, the file type, the location and whether or not the file was found. 2. Select the files in the upper list individually and transfer them to the lower list using the icon .

If you want to select the files by type, place the cursor inside the list and right-click to display the list of file types and then select the appropriate type. (Selecting by type in this way operates of course in the lower list as well.) The OK button may be grayed out. This means that problems shown in the Problem column have not been resolved. 3. Click OK. You will now be prompted to give the name of your e-mail system.

38

Project Standards

For detailed information on using the Send To Directory command, refer to Transferring Version 5 Data To Another Directory.

Copying to a directory or diskette
1. Select the File->Send To->Directory command. The Send To Directory dialog box opens:

In the upper part of the dialog box you can see a list of all the different documents linked to the document you selected for the copy operation. The four columns provide information about the file name, the file type, the location and whether or not the file was found.
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2. Select the files in the upper list individually and use the icon transfer them to the lower list If you want to select the files by type, place the cursor inside the list and right-click to display the list of file types and then select the appropriate type. (Selecting by type in this way operates of course in the lower list as well.). It might be useful, especially if copying files to a diskette, to know the size of the documents to be copied. You will find this just above the Copy to: field. The OK button may, as in the case shown above, be grayed out. This means that problems shown in the Problem column have not been resolved.

to

3. Enter the path of the target directory in the Copy to: field using the Browse button if necessary and click OK. This field is in fact a list and contains the nine destinations last used. 4. Click OK. A progress box appears as each file is copied and when the copy has been performed, the Files Copied dialog box appears telling you the number, size and type of the files copied. For detailed information on using the Send To Mail command, refer to Sending Version 5 Data in the Mail.

Customizing Materials
Material
This tab deals with the options concerning: • • • • general options material parameters default material catalog path environment image file

Options
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Display a warning when adding properties to a material
If this option is selected, it means that whenever you wish to add properties to a material (by double-clicking it then choosing the Analysis or Drafting tab for example), a warning message is issued to let you know that the material has been modified when you accessed the Analysis or Drafting properties:

By default, this option is activated.

Use Link mode by default when applying materials
If this option is selected, it means that the selected material will be mapped as a linked object and thus, will be automatically updated to reflect any changes to the original material in the library. Note: the link mode is activated whichever method you use to apply the material: click Apply Material or use drag & drop capabilities. For more information, refer to "Applying Materials" in the Version 5 - Real Time Rendering User`s Guide. By default, this option is cleared.

Use Force mode as the default inheritance mode
If this option is selected, it means that the force inheritance mode is activated, i.e; a material is forced when it is applied onto parts, products, bodies or surfaces in order to make it visible even if a father material propagates. For more information on inheritance modes, refer to Setting Priority between Part and Product in the Version 5 - Real Time Rendering User`s Guide. By default, this option is cleared.
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Desynchronize visualization when modifying material attributes
If this option is selected, it means that the material properties will be modified independently from the visualization and thus, this will avoid visualization refresh which can take a long time when working on big models. By default, this option is cleared.

Open the catalog in read-write mode when applying a material
If this option is selected, it means that, for any applied material, you will be able to open and modify the corresponding material catalog. By default, this option is cleared.

Material Parameters

Create a material parameter when creating a part, a body or a surface
If this option is selected, it means that a material parameter will be automatically created for any part, body or surface you create (either using the File->New... or the Insert command), even if no material is mapped onto it. Activating this option also means that a parameter entitled "Material=None" (or "Material" if you decided not to activate the display of the parameter value in the Tools->Options->General->Parameters and Measure->Knowledge tab) will appear in the specification tree. By default, this option is cleared.

Create a link to the catalog when modifying a material parameter
If this option is selected, it means that a linked material will be created when modifying a mapped material using Knowledgeware capabilities. Do not forget to check the "Parameters" option in Tools->Options...>Infrastructure->Part Infrastructure->Display to visualize the Material parameter. In the two examples below, the Material parameter was selected in the specification tree then modified via the Edit Parameter dialog box (using the Material object->Definition... contextual command):
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Option "On" Material applied as a linked material

Option "Off" Material applied as a non-linked material

By default, this option is activated.

Default Material Catalog Path

This area lets you browse your file tree using the icon to select the material catalog to be used by default when applying materials. The selected material catalog will supersede the one defined in the CATStartupPath environment variable and thus, will be retrieved when selecting "Default Material Catalog" from the Library dialog box. Depending on the document environments (i.e. the method to be used to access your documents) you allowed in the Document settings, an additional window may appear simultaneously to the File Selection dialog box to let you access your documents using an alternate method:
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In our example, four document environments have been allowed among which the DLName environment. If you want to access your texture files using DLNames, for instance, just click the Logical File System button: this will open a specific dialog box dedicated to the DLName environment. For detailed information on this dialog box, refer to Opening Existing Documents Using the Browse Window.

Environment Image File

This area lets you use your own environment instead of the default one provided. To do so, enter the path to the user-defined environment or use the icon to open the File Selection dialog box which lets you browse your folders to the desired location. Note that depending on the document environments you allowed in the Document settings, the Browse window may appear simultaneously to the File Selection dialog box to let you access your documents using an alternate method. For detailed information, refer to Opening Existing Documents Using the Browse Window.

Or Click the Environment image generator icon to open the Environment Map Generator dialog box (this icon only appears when working with a Real Time Rendering 2 license):
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In the upper part of the dialog box, just click each environment wall (i.e. "Up", "Back", etc.) then navigate to the desired image using the File Selection dialog box. The resulting environment will be displayed on the environment map as shown below:
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The Image Size pulldown list lets you choose a Small, Medium or Large size for your environment image. Once the image is generated, enter its name and path in the "Save as" field or icon to open the File Selection dialog box which lets you browse your click the folders to the desired location. Note that depending on the document environments you allowed in the Document settings, the Browse window may appear simultaneously to the File Selection dialog box to let you access your documents using an alternate method. For detailed information, refer to Opening Existing Documents Using the Browse Window. Click OK to validate and go back to the Material tab.

Modifying the Mapped Material
This task shows you how to edit the material you have just mapped in the previous scenario. You will change some propertiest of the material mapped onto the part.
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1. Right-click the mapped material (Honeycomb) in the specification tree and select the Properties command from the contextual menu. The Properties dialog box is displayed:

Note: The mapping support (in this case a box support) appears in the geometry area. This will assist you later when you interactively position the material.
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2. Under the Rendering tab, click the Lighting tab if not already active. 3. Change the color of the material to green: • Click [...] opposite Color beside the Ambient, Diffuse, and Specular parameters. The Color dialog box is displayed:

• Click in the preview area to select the color you want • Click OK in the Color dialog box. The selected color is displayed in the Color field. 4. Change the material density:
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• Click the Analysis tab in the Properties dialog box • Key in a new density • Click Apply. Note: appropriate licenses are required to use these products.

5. Click OK in the Properties dialog box. 6. Right-click the mapped material in the specification tree and select the Properties item from the contextual menu to modify more material properties. For instance, you can change the material size (in the Rendering tab of the Properties dialog box) so that the texture shrinks in size relative to the part.
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Now that you have finished, let's go to taking a closer look at the Real Time Rendering application!

Modifying Material Lighting Properties
You can change the material size and mapping type as well as edit material specifications (lighting and texture parameters) of both linked and unlinked materials. This tasks explains how to edit material lighting properties. The modification of texture properties is detailed in Modifying Material Texture Properties. • • Editing materials linked to libraries modifies the original material in the library. If you want to save changes made to the original material, use the File->Save All command Editing linked materials on parts in the same document or on parts in different documents modifies all linked materials.

Open the Chess.CATProduct document. 1. Select the Italian Marble material in the specification tree. 2. Select the Edit->Properties command (or use one of the other methods detailed in About Material Properties). The Properties dialog box is displayed:
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3. Make sure the Rendering tab is active. Using this dialog box, you can edit the lighting and texture parameters of the material you are currently editing. Material specifications defined using Real Time Rendering are shared with other Version 5 products. For information on Drafting and Analysis tabs, see the Version 5 - Generative Drafting and the Version 5 - Generative Part Structural Analysis User's Guides, respectively. Appropriate licenses are required to use these products.

4. Modify the Lighting parameters: ambient, diffuse, specular, roughness, transparency, reflectivity and refraction. You can either use the slider or enter the desired value directly in the field. 5. By default, the Ambient, Diffuse, Specular and Transparency colors are set to the basic color. You can, however, click [...] opposite Color and choose the color to be used for the material texture. The Transparency color is relevant for software rendering only (i.e. Photo Studio product). The Color dialog box is displayed allowing you to choose the exact color you wish to define as a material texture:
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You can click in the preview area to choose the color, or even key in the exact value of the desired color. You can enter a value comprised between 0 and 255 for any of these fields. As you can see it in the above picture, two color system models are used: • HLS (Hue, Saturation, Luminance) model is an intuitive, easy to use tool for describing or modifying a color. Hue is the "color" of the color. It is the name by which the color is designated and is used to define the desired color. Saturation is the intensity of the color. The higher the number, the more intense the color. It is used to tune the purity of the color. Luminance is the brightness of the color, i.e. the degree to which the pure color is diluted by white or black. The larger the number, the lighter the color. It is used to adjust intensity • RGB (Red, Green, Blue) model is a more physical model. It is based on the tristimulus theory of the human perception system. This model is usually used to define, with a high precision, the three primary components of the color. When satisfied, simply click OK, and the color is applied to the shape in the Properties preview. 6. Set the other material parameters: Parameter Set to 0 (or 1 for Refraction)

Set to 1 (or 3 for Refraction, (0.5 for Transparency

Ambient: the intensity of light diffused in any direction by the object, even if not lit by any light source. The ambient light is essentially used to show objects or parts of objects that are not illuminated directly by the light source. This parameter affects the whole object, including the shadowed area. The intensity is defined by a coefficient (with a value between 0 and 1). Diffuse: the intensity of light diffused by the object when lit by light sources. Typically, a shiny metal surface would have a diffuse reflectance value close to 0, while a piece of cardboard would have a value probably above 0.9. The intensity is defined by a coefficient (with a value between 0 and 1).
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Project Standards Specular: intensity and color of light reflected in one particular direction (highlights) Set the value to a minimum to generate very sharp highlights on very shiny surfaces. Set the shininess to a higher value to generate large specular spots creating a duller effect. Typically, a polished object would have a high value for the specular reflectance coefficient, while a more mat surface would have a lower one. Roughness: dullness of an object (size of the reflecting zone) Set the value to a minimum to generate very sharp highlights on very shiny surfaces. Set the shininess to a higher value to generate large specular spots creating a duller effect on rougher surfaces. Transparency: degree of transparency of an object and color of the filter interfering with the light passing through an object. The transparency color acts like a photographic filter which modifies artificially the light rays received by an optical lens. It is generally identical to the ambient and diffuse color but when it is different, the shadows cast by the object are colored accordingly. For instance, a blue object with a red transparency color will cast slightly red shadows. The higher the value, the more transparent the object (in the example the value is 0.75), the lower the value, the more opaque the object. Refraction: degree of light passing obliquely through an object. The refraction is defined by a coefficient (value between 1 and 2). Set to 1, the transparent object will show no light distortion. As an example, water has a 1.2 coefficient. This parameter is relevant for software rendering only.
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When setting the Reflectivity parameter, you can also set advanced reflection settings if you wish to use a customized environment image for environment reflections. For more information, refer to Defining Reflection Settings in this guide. A reflecting material lets you visualize the environment image it reflects. As you can use images of various origins for your environment, here is the priority order in which they are seen: 1. material reflectivity image defined in the Advanced Reflection Settings dialog box (for Real Time Rendering 2 users only) 2. environment image defined in the Material tab in Tools->Options->Material Library 3. default environment image provided with Version 5. All values can be defined either using the scroll bar, the arrows or directly in the value field. If several values are to be modified, better skip from each value field to another using the tabulation key: in this case, the preview icon will be updated only once. 7. Click Apply to validate the material lighting definition. The material icon reflects the material as defined.

More about lighting properties
• • All lighting parameter values range from 0 to 2 Any amount of reflectivity, however small, means that you will no longer visualize the mapped texture simultaneously with the reflected scene. If you want to see the texture, make sure you set the Reflectivity parameter to 0 in the Lighting tab.

Modifying Material Texture Properties
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This tasks explains how to edit the material texture parameters of both linked and unlinked materials. • Editing materials linked to libraries modifies the original material in the library. If you want to save changes made to the original material, use the File->Save All command • Editing linked materials on parts in the same document or on parts in different documents modifies all linked materials. Open the Chess.CATProduct document. 1. Select the Italian Marble material in the specification tree. 2. Select the Edit->Properties command (or use one of the other methods detailed in About Material Properties) to open the Properties dialog box. 3. Click the Texture tab in the Properties dialog box:
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4. In the Image Name field, navigate to locate the desired image, and click OK to map it onto the preview element as the texture. In the example, we choose the italian_marble.jpg image available with the default catalog. The following image formats can be used: • • • • • • • • tif:TIFF (Tagged Image File Format) rgb: Silicon Graphics 24-bit RGB color bmp:Microsoft Windows Bitmap Format jpg:JPEG (Joint Photographic Experts Group) pic:Apple Macintosh Format psd:Photoshop Format png:Portable Network Graphics tga: Truevision Targa file format

Depending on the document environments (i.e. the method to be used to access your documents) you allowed in the Document settings, an additional window may appear simultaneously to the File Selection dialog box to let you access your documents using an alternate method:

In our example, four document environments have been allowed among which the DLName environment. If you want to access your texture files using DLNames, just click the Logical File System button: this will open a specific dialog box dedicated to the DLName environment. For detailed information on this dialog box, refer to Opening Existing Documents Using the Browse Window. The Type field indicates the type of texture you applied: • Image: identifies materials with a texture. In that case, the corresponding image name is displayed in the Image Name field • None: identifies materials with no texture such as metals. A preview area, in which different mapping types can be visualized, is also
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These different mapping types are available to let you select the most appropriate mapping for the shape of the geometry: • Planar Mapping is similar to a slide projector (a picture on a wall, for instance). You can use it for textures with two privileged directions such as Chessboard or Wall of Bricks • Spherical Mapping is similar to a painted light bulb. You can use it for textures that do not have a privileged direction such as stone or raw metal • Cylindrical Mapping is similar to placing a label on a can of food. You can use it for textures having a privileged direction such as shiny metal or marble • Cubical Mapping is similar to wrapping a box • Adaptive Mapping lets you choose between two mapping types: Automatic or Manual.

The "Automatic" adaptive mapping automatically creates a planar mapping on each object face. "Manual" adaptive mapping gathers together faces which have close normal vectors. For each group of faces, a unique planar mapping is applied. The precision value defined using the slider modifies the tolerance used during the grouping process: the lower the precision, the more faces with greatly different normal vectors will be gathered together. This "Manual" mapping enables textures to cross slightly sharpen edges, thus providing higher visual quality.
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This mapping type is especially relevant for materials with no specific orientation such as leather or wood for example. Note: as "Manual" adaptive mapping is available for Real Time Rendering 2 users only, it will automatically change to "Automatic" adaptive mapping for Real Time Rendering 1 and Photo Studio users. Manipulations are available within the preview area: zooming in and out, rotating the support, translating it. Use the within the preview area. icon to reframe the support

You can also manipulate the object (i.e. zooming in/out, etc.) directly in the geometry area while displaying the Properties dialog box either by doubleclicking the material in the specification tree or by selecting Object>Definition... from the contextual menu. 5. If necessary, change the Material size to adjust the scale of the material relative to the part. 6. Define the image repetition along U and V, as well as its scale, its position and its orientation: U and V correspond to parameters of the local parametric surface. • Repeat U, V: lets you specify whether or not you want the texture repeated ad infinitum along u- and v-axes • Scale U, V: determines how the texture is stretched along u- and vaxes • Position U, V: determines the position of the texture along u- and vaxes. By default, the image is centered • Orientation: defines the rotation of the texture on surfaces. 7. Use the Flip U, V checkboxes to invert the material texture along U and V axes. to resize U and V You can click the Link U and V scales icon proportionally. This is especially useful for square shapes, the Floor material for instance. Note that when this option is on, the Scale V field is grayed and the icon changes to .

The Inheritance tab displays information about the material inheritance mode and the checkboxes are grayed out until a material is applied. 8. Click the Analysis tab if you wish to edit the material physical properties, such as the density and so on. These data will be used for calculation purposes in the Version 5 - Generative Structural Analysis User's Guide.
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Note: appropriate licenses are required to use this tab. 9. Click the Drafting tab if you wish to set the pattern used for creating section views or section cuts:

When a material is applied onto a product, the pattern information will be used only for the part(s) contained in the product. For more information, refer to the Version 5 - Generative Drafting User's Guide.
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Note: appropriate licenses are required to use this tab. 10. Click OK (or Apply then OK) to validate the material texture definition. The material icon reflects the material as defined. There is no specific order for defining parameters. 11. Position the material interactively using the 3D compass as explained in Applying a Material.

Using Knowledge Advisor Capabilities
Material specifications defined using Real Time Rendering are shared with Knowledge Advisor. This is illustrated in the two tasks below. In our examples, you will change the material mapped onto a part or a product directly in the knowledgeware Formulas dialog box as well as write a rule using material as a parameter to, for example, change the mapped material as a function of hole diameter. For more information on Knowledge Advisor, see the Version 5 - Knowledge Advisor User's Guide. Note that to use this product you need the appropriate license.

Changing the Material Mapped onto a Part or a Product Directly in the Formulas Dialog Box
This tasks explains how to change the material mapped onto a part or a product directly in the knowledgeware Formulas dialog box. Open the ChangeMaterial.CATProduct document. 1. Click the Formula icon in the Standard toolbar.

The Formulas dialog box appears listing all the part parameters. 2. Select the Material parameter. The Edit name, value or formula fields are updated.
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3. Enter another material, Gold for example, directly in the value field The dialog box, part itself and specification tree are all updated. You have changed the material mapped onto the part directly in the dialog box.

You can only change materials mapped in the Formulas dialog box to those available in the default material library. Any material changed in this way will be mapped as linked objects and will be automatically updated to reflect any changes to the original material in the library.
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Note: The material icon in the specification tree appears with a link to indicate that the material gold is mapped as a linked object.

Writing a Rule
This task explains how to write a rule using material as a parameter to, for example, change the mapped material as a function of hole diameter. Open the WriteARule.CATProduct document. Make sure that the Shading with Material icon has been selected from the View toolbar. 1. Select Tools -> Options.... in the Infrastructure category, select the Part Infrastructure subcategory then click the Relations checkbox in the Display tab to display relations in the specification tree. 2. Select the part. 3. Select Knowledge Advisor from the Start -> Knowledgeware menu. 4. Click the Rule icon:

The Rule Editor dialog box appears.

5. Click OK to identify your rule in the Rule Editor dialog box.
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The Rule Editor : Rule 1 dialog box is displayed. You can now write your rule. 6. Write the following rule: if (PartBody Hole.1 Diameter > 60mm) Material = "Gold" else Material = "Aluminium"

For detailed information on the Knowledge Advisor rules, refer to "Using Rules" in the Version 5 - Knowledge Advisor User's Guide. 7. Click OK when done: The system checks that your syntax is valid. If it is not, you are prompted to correct it. You cannot edit or apply materials that have been incorporated as parameters into rules. You can now check your rule. 8. Select Part Design from the Start -> Mechanical Design menu
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9. Right-click the hole and select Hole1.Object -> Edit Parameters from the contextual menu 10. Double-click the hole diameter and enter a new value in the Constraint Edition dialog box, for example 70, then press Enter The material changes from aluminium to gold.
Before: After:

Note: Materials incorporated as parameters into rules are mapped as linked objects. Linked materials are identified in the specification tree by a material icon with a white arrow symbolizing the link.

Setting Priority Between a Part and a Product
This tasks explains how to set material visualization priority between the material applied to a Part and another material applied to a Product.
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1. Right-click the Alpine Fir material in the specification tree and using the Properties contextual command, display the Properties dialog box. 2. Select the Inheritance tab.
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The three available inheritance modes are the following ones: • Propagates material towards children: the material propagates towards lower levels in the hierarchy (default mode). The corresponding material icon in the specification tree is . • No propagation of material towards children: the material does not propagate. The corresponding material icon in the specification tree is . • Force material and do not accept material from father: the material is forced, i.e. it is visible even if an upper level material propagates. The corresponding material icon in the specification tree is . 3. Check the "No propagation of material towards children" option. The element visualization is instantly modified, and you can now visualize the material mapped onto the Part instance. The geometry now looks like this:

4. Click OK. If you had selected the "Force material and do not accept material from father" option, the geometry would have looked like this:
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To be able to visualize the material mapped onto the lowest element in the specification tree (the Part here) you only need to force the material on this element.
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