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AutoCAD Tutorial # 1: Creating a Footprint Map of a Community Using an Aerial Photograph

Nidhi Vaid

Introduction: AutoCAD is the world's most popular computer-aided drafting software product for the personal computer available in both DOS and windows by Autodesk, Inc. Anything that can be drawn on a drawing board can be drawn by AutoCAD. AutoCAD is an interactive drawing system designed to permit a user to construct or edit a drawing on a graphics display screen. It is similar to other word-processing programs except that in this case the thing being processed is a drawing. Each drawing is stored on a disk file, and AutoCAD is only able to edit one drawing at a time. An AutoCAD drawing is made up of entities. All the objects in the drawing space are considered entities such as lines, arcs, circles, text, and so on or blocks (which are groups of entities). The entities are defined geometrically in terms of the normal Cartesian coordinate system (right-handed system with positive X-axis to the right, positive Y-axis up the screen and positive Z-axis coming out of the screen towards the user). For example, lines are defined by their end- point coordinates (x, y and z), while circles are defined by their center coordinates and radius. Each entity also has certain attributes associated with it, such as line style, text font or color. AutoCAD organizes information in different layers like other programs like Photoshop and Illustrator. This means that any drawing entity can be assigned to any layer of the drawing. This allows separation of portions of the drawing. For example, all parcels could be assigned to one layer and all footprints to another, and so on. This allows plotting selected layers in the drawing. Examples of AutoCAD drawings:

(Source: AutoDesk Website: www.autodesk.com)
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Part I: Understanding the AutoCAD Window When you start AutoCAD, the AutoCAD window opens. The window is your design workspace. It contains elements that you use to create your designs and to receive information about them. The following illustration shows the main parts of the AutoCAD window
Menu Bar Standard toolbar Draw toolbar Modify toolbar

Command Line

Menu Bar Contains the default AutoCAD menus. Menus are defined by menu files that you can modify or design on your own. Standard Toolbar Contains frequently used buttons such as Redraw, Undo, and Zoom, as well as Microsoft Office standard buttons such as Open, Save, Print, and Spell. Buttons with small black triangles in the lower-right corner have fly outs containing tools that invoke commands related to the first tool shown. Click and hold down the first button to display the fly out. Drawing File Icon Represents a drawing file in AutoCAD. The drawing file icon is also displayed next to options in dialog boxes that are saved in the drawing, instead of in each session as in AutoCAD.
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Object Properties Toolbar Sets object properties such as color, linetype, and lineweight and manages layers. Draw and Modify Toolbars Provide access to common draw and modify commands. The Draw and Modify toolbars are displayed when you start AutoCAD. These toolbars are docked on the left side of the window. You can easily move toolbars and turn them on and off. Drawing Area Displays drawings. The drawing area size varies, depending on the size of the AutoCAD window and on the number of other elements (such as toolbars and dialog boxes) that are displayed. Crosshairs Identifies pick and drawing points within the drawing area. Use the crosshairs, which are controlled by your pointing device, to locate points and select and draw objects. User Coordinate System (UCS) Icon Shows the orientation of the drawing. AutoCAD drawings are superimposed on an invisible grid, or coordinate system. Coordinate systems are based on X, Y, and (for 3D) Z coordinates. AutoCAD has a fixed world coordinate system (WCS) and a movable user coordinate system (UCS). To help you visualize the UCS location and orientation, a UCS icon is displayed in the lower-left corner of the drawing area. Command Window Displays prompts and messages. In AutoCAD, you start commands in one of three ways:
• • •

Choose an item from a menu or a shortcut menu. Click a button on a toolbar. Enter the command on the command line.

However, even if you choose commands from menus and toolbars, AutoCAD may display command prompts and the command history in a command window.
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Draw and Modify Commands: 1. Line: draws a straight line from one point to the other. 2. Construction line: draws an infinite line 3. Multi-line: draws two paralleled lines from one point to the other. 4. Polyline: draws a line not necessary to be straight across several points. (Very important command) 5. Polygon: draws a polygon 6. Rectangle: draws a rectangle by determining 2 points on the corner. 7. Arc: draws an arc 8. Circle: draws a circle 9. Spline: draws a continued curve which may consist of several arcs or curves. 10. Ellipse: draws an ellipse 11. Insert drawing block: A block is a completed CAD drawing separated from your current working file. It comprises of grouped objects. 12. Make a block 13. Dot 14. Hatch: gives a texture to objects 15. Region: creates a region from lines. 16. Text: 17 Erase 18: Copy objects 19. Mirror: copies the object according to mirror point or lines 20. Offset: Creates concentric circles, parallel lines, and parallel curves 21. Array: Creates multiple copies of objects in a pattern 22. Move: 23. Rotate: Moves objects about a base point 24. Scale: Enlarges or reduces selected objects equally in the X, Y, and Z directions 25. Stretch: Moves or stretches objects 26. Lengthen: Lengthens an object 27. Trim: Trims objects at a cutting edge defined by other objects 28. Extend: Extends an object to meet another object 29. Break: Erases parts of objects or splits an object in two 30. Chamfer: Bevels the edges of objects 31. Fillet: Rounds and fillets the edges of objects 32. Explode: Breaks a compound object into its component objects.
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Part II: Creating a Community Map In this tutorial we will learn to create a footprint map of a community using an aerial photograph. Step I. Creating a New AutoCAD File: 1. Open AutoCAD 2000. There should be a desktop icon for the program. If you don’t see it on the desktop, go to the Start menu, and look in the programs. 2. Close the initial “AutoCAD today” window. 3. You are now in a new file, called “drawing 1.dwg” by default. Go to the “File” menu and save the drawing in your folder in qserv or on the desktop. Step II. Creating Layers: 1. In the “Format” menu, select “Layer”, or type “layer” in the command window. 2. A “Layer Properties Manager” dialog box appears. 3. Select “New” to create a new layer. 4. Type in a layer name that identifies the layer content.
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5. Select a color for the newly created layer by clicking on the color box. 6. For this tutorial, create four layers called “Aerial”, “Footprint”, “Parcel”, and “Curb”. Use different colors for the four layers. Use red, yellow and cyan for each of the layers respectively. (Leave the aerial layer white. This is because we will not draw in that layer) 7. Select the “Aerial” layer and make it your current layer. Step III. Bringing an Aerial Photo into AutoCAD: 1. In the “Insert” menu, select “Raster Image”. 2. A “Select Image File” dialog box will appear. 3. Browse to find the required image file and hit “Open”. For this tutorial, browse to “q serv” and locate a folder called “AutoCAD Tutorial”. You will find a file “Image. TIFF” in that folder.

4. An “Image” dialogue box appears now. You will find that “Specify on Screen” option for insertion point and scale are turned on by default. It is possible to uncheck these, but it is easier to scale the image after inserting it in AutoCAD. Hit “OK” in the pop up window. 5. Provide an insertion point for the image on the screen by clicking the right click of the mouse. 6. “Specify Scale Factor<1>” appears in the command line.
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7. Hit enter to retain the existing scale of the image. 8. The image now appears on the screen. Step IV. Scaling the Aerial Photo: It is recommended that you scale the image to real scale 1:1 before drawing the parcels and footprints. A scale indication, like a graphical scale can be helpful. In the case of an aerial, we will identify the scale based on known dimensions of roads, etc. 1. If the image too big and you can’t see the black screen, type “z” in the command line to zoom. Type “a” to zoom all. This will display the entire image. 2. Now type “Scale” in the command window. 3. “Select Objects” appears in the window. Notice that the crosshair changes to a box shape. 4. With the help of the mouse, select the aerial photo. This may require clicking at the edge of the photo. 5. Hit enter to end selection.

6. “Specify base point” will now appear in the command window. Click exactly on the top green square in the image.
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7. “Specify scale factor” or [Reference]:” appears. Type “r” for reference and hit enter. 8. “Specify reference length<1>”, select the same point selected previously. 9. “Specify second point” appears in the command window. Select the second green square in the image. 10. “Specify new length”, appears in the command line now. Type 66 and hit enter. 11. The drawing is now on a 1:1 scale. 12. Again type, “z” to zoom. “a” zoom all.

Step V. Drawing Curb lines, Parcels and Footprints:
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To draw the Curb lines, Parcels and building footprints, we will trace information from the aerial photograph. This can be compared to tracing an image on a drawing table. In this project, we will use AutoCAD commands to accomplish this task. Object snap mode lets you snap to exact location on an object. This will be useful in the tutorial. Go to “Tools”, and select “drafting settings”. Go to the Object snap tab in the pop up window. Select “endpoint”, “midpoint”, “perpendicular”, and “intersection” from the available options.

Step VI. Drawing Curb lines: 1. To draw curb lines and parcel lines, we will use the “rectangle” and “Pline” commands. Rectangle command can be most useful for rectilinear blocks. 2. Select “curb” layer and make it your current layer. 3. Type “rectangle” in the command window or select it from “Draw” menu. 4. “Specify first corner” will appear in the command window. Click at the corner of a block.

5. “Specify other corner”, select the diagonally opposite point of the block to the one selected in step 4. 6. Draw rectangles for the three blocks
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that are visible in the aerial. At this point switch off the “aerial” layer, so you can see the curb lines. 7. Curb lines are usually curved at the edges. To draw curves, select “Fillet” from the “Modify” menu. 8. In the command window, you will see, “Current settings: Mode=Trim, Radius=0’-0” 9. “Select first object or [Polyline/radius/trim]:” will appear in the AutoCAD command line. 10. Type “r” to specify radius. 11. “Specify fillet radius<0’-0”> appears. Specify 12 and hit enter. 12. Select “fillet” again. 13. When “Current settings: Mode =TRIM, Radius = 12.0000 Select first objects or [Polyline/Radius/Trim]” appears, select one edge of the Second line to rectangle. be selected 14. “Select second object” : select the second of as show in the First line to be screen shot. selected 15. The rectangle will have a curved edge. Repeat these steps to curve the corner of all three blocks. Step VII. Creating Parcel lines: 1. Select the “Parcel” layer and make it your current layer. 2. Repeat the steps from “Drawing curb lines” steps to draw the parcel lines. You will need to switch on the “aerial” layer to draw the parcels.
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Step VIII. Drawing Building footprints: 1. Switch current layer to “Footprint” 2. Usually we just need to simplify the building into a rectangle or a square, but some building footprints are more complex than that. We will need to use a few more commands to draw footprints. 3. Drawing regular and irregular building footprints for buildings without curved lines: a. In the command line, type “pline” for polyline and hit enter. b. “Specify start point:” now appears in the command line. c. Select the start point on one corner of the building by pressing the left button of the mouse. d. “Specify next point or [Arc/halfwidth/length/ undo/width]:” now appears. e. Select the next corner of the building. With each selection the command line will ask for the next point. f. Finish the footprint on the same point you started and type “c’ to close.

First point to be selected Last point is the same as the first selected point

Finishing up the footprint

Second point to be selected

4. Drawing regular and irregular building footprints for building with curved lines: a. We will draw the footprint of the curved building. b. Follow the steps 3. a through 3.e to draw this building. When you get to the point where the curve starts, type “a” for arc and hit enter.
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c. “Specify endpoint of arc or[Angle/Center/close/direction/Halfwidth/line/radius/second point/ undo/width]:” now appears. d. Type “s” for second point and hit enter. e. “Specify second point on arc:” now appears. f. “Specify end point of arc:” now appears in the command line. Click on the second point of the curve. g. To finish the footprint, select “pline” to continue drawing. h. Repeat the above steps to draw all the building footprints in the aerial. i. Once you have drawn all the curbs, parcel lines and building footprints, remember to switch of the “aerial” layer. j. Your final map should look like this.

Congratulations! You have now created a community map using an aerial photograph of Oak Park.
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Part III: Converting the AutoCAD map into a PDF file Converting the AutoCAD map into PDF retains the scale of the drawing. This drawing can then be placed and edited in Adobe Illustrator. Step I. Selecting the Printer: 1. 2. 3. 4. In AutoCAD, from the “File” menu, select “Plot”. A “Plot” dialog box appears. Click on the “Plot Device” tab if it is not active. Under the “Plotter Configuration”, select the PDF writer OR Acrobat Distiller.

Step II. Selecting the Print Area: 1. In the “Plot Settings”, under the “Plot area” section, click on “window” button.

First point in the window

Second point in the window
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2. In the AutoCAD command line, “specify the first point” will appear. 3. Select a point on one corner of the area to be printed. 4. The AutoCAD command line will prompt you to provide the second corner. Select the diagonally opposite corner. Step III. Setting up the Plot scale: 1. The scale at which you plot the map to a pdf file is the scale at which it will open in Illustrator. So you should decide the scale at this stage. Typically footprint maps are at a scale of 1”=20’ , 1”=50’, 1”=100’, etc. 2. In the “Plot settings” change to custom in the “Plot scale” section in the scale tab. 3. Type the desired scale. Your AutoCAD drawing is at 1:1 scale right now. 4. To print the drawing at 1”=100’, type 1 inch and type 1200 for drawing units. To print the drawing at 1”=200”, type 1 inch and 2400 for drawing units.

For this map type 1 inch = 100drawing units

Step IV. Selecting the Paper size: 1. Click on the “Plot settings” tab. Under the “paper size and paper units”, select a paper size from the available options. For this tutorial select “letter”. 2. If the required paper size is not available in the list, create a custom paper size. Step V. Selecting the orientation for the Paper and Units: 1. In the “Plot settings” tab under “Drawing orientation”, select landscape for this map. 2. Select “inches” to correspond with the drawing units.
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Step VI. Viewing the Print Preview: 1. It is always recommended that you generate a preview of the plotted drawing before printing it, so you can be sure of the end product. 1. To create a full preview, click on “full preview” at the bottom left corner of the “plot settings “tab. 2. If you are satisfied with the drawing, go ahead and save it. You can change the file name at this stage too. Hit OK and specify the file name and location. This file is now ready to be placed and edited in Adobe Illustrator.

Useful resources: For AutoCAD help, press F1 and look for the help topics. This should answer most of your questions. Online resources: http://www.fbe.unsw.edu.au/Learning/AutoCAD/ http://www.cadtutor.net/ http://www.csanet.org/inftech/tutorial.html For Sanborn Maps: http://sanborn.umi.com/
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