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Project: Overview
Welcome to the Project User's Guide! This guide is intended for users who need to become quickly familiar with the product. This overview provides the following information: • • • • • Project in a Nutshell Before Reading this Guide Getting the Most Out of this Guide Accessing Sample Documents Conventions Used in this Guide

Project in a Nutshell
The Project Workbench allows you to design assemblies using an intuitive and flexible user interface. A project contains a hierarchical arrangement of parts (CATpart) and projects (CATproduct). Projects iconsist of other projects and parts, resolving themselves at their lowest level into parts. Only parts have geometry associated with them (for example, an outlined profile, filled to form part of a plane and then extruded to form a pad, a solid). You specify geometry in the Geometry workbench sketching profiles and other 2d shapes within the Geometry workbench in the Sketcher workbench. The project workbench allows you to specify the hierarchical assembly of parts and products, that you ultimately specify in the Geometry workbench. The workbench allows component structure (Product, Part, Assembly,...) to be represented with an intuitive and flexible user interface. The system clearly identifies the components being used, making the management of the assembly much easier. You can • • • • • Copy/paste components or constraints. Add/insert a new component to the assembly structure. Load/unload missing models, replace components. Modify components properties. Associate/remove geographical representations to/from the parts.

This guide shows you how to create a project from scratch and illustrates several stages of creation you may encounter.

You have two basic choices in designing your project:
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project • Top-down - specify the hierarchical arrangement of the yet unspecified parts and products, and then resolve the parts by specifying them in the Geometry workbench. Bottom-up - define the geometry of each part and then assemble the parts to form projects, assemble the projects into larger assemblies, until finally you have specified the final assmbly -- project.

•

You can also mix the two approaches, by beginning top-down and then modifying the assembly structure as you add the parts. As a workbench that can scale, Project can cooperatively be used with other current companion products such as Drawing Generation and Interactive Drawing. The widest application portfolio in the industry is also accessible through Digital Project to support of the full product development process from initial concept to product in operation. You can also review, annotate, and check your assemblies. Interactive, variablespeed techniques such as walk-through and fly as well as other viewing tools let you navigate through large assemblies.

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 and the Interoperability between workbenches. You may also like to read Drawing Generation.

Getting the Most Out of this Guide
To get the most out of this guide, we suggest that you start reading and performing the step-by-step Getting Started tutorial. Once you have finished, you should move on to the User Tasks section, which deals with handling all the product functions. The Workbench Description section, which describes the Assembly Design workbench, and the Customizing section, which explains how to set up the options, will also certainly prove useful. Navigating in the Split View mode is recommended. This mode offers a framed layout allowing direct access from the table of contents to the information.

Accessing Sample Documents

2

Project: Overview To perform the scenarios, sample documents are provided all along this documentation. For more information about this, refer to Accessing Sample Documents.

3

What's New?
New functionalities
Overlay Settings, add a security overlay to indicate confidentiality of parts that you share with business partners

Enhanced functionalities
Browsing Enhanced Scenes using the Scenes Browser, list mode display in the scene browser
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Getting Started
Entering the Product Structure Workbench
This task shows you how to: • • • enter the Product Structure Workbench create a new document open an existing one with a Progress Bar activated by default.

Entering the Product Structure Workbench
Select Infrastructure -> Product Structure from the Start menu. The Product Structure workbench is displayed and a document like this will appear:
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Note that more toolbars may appear next to the Standard toolbar when you create a document. For more information about this CATIA window, please refer to Workbench Description.

Creating a new document
1. Select New from the File menu and a New dialog box is displayed:

8

Getting Started

2. Select a type of document (Product for instance) in the list and click OK. A new CATProduct appears:

Opening an existing Document: a Progress Bar appears
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This task consists in opening a CATProduct step by step with a progress bar, giving the number of the activated shapes out of the total shapes. This is a means for the user to get an insight in the objects' downloading time, and in the meantime the screen is not frozen. This operation is activated by default (there is no setting). Open the AnalyzingAssembly01.CATProduct document.

1. While the CATProduct is opening, there is a progress bar indicating the total shapes to be opened and the downloaded ones. In this example, 4 shapes have been downloaded out of 6.

2. When this dialog box disappears, the whole geometry (assembly) and the specification tree are displayed. 3. When you insert an existing component, this is the same method. The progress bar also appears during the downloading process.

Entering Project Design Workbench and Opening a CATProduct Document
This first task shows you how to enter Assembly Design workbench and how to open an existing product. 1. Select the Start -> Project Center -> Project command to launch the required workbench. The workbench is opened. The commands for assembling parts are available in the toolbar to the right of the application window. For information on these commands, please refer to Product Structure documentation. You will notice that Product1 is displayed in the specification tree, indicating the building block of the assembly to be created. To know how to use the commands available in the Standard and View toolbars located in the application window border, please refer to Infrastructure documentation.
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2. Before following the scenario, set the following options: • make sure the option Work with the cache system is deactivated : use the Tools -> Options command, click Infrastructure -> Product Structure to the left of the dialog box that appears and uncheck the option Work with the cache system. Do not forget to restart the application after turning off the cache. For more information, refer to Working with a Cache System. use the Tools -> Options command, click Project Center -> Project Structure to the left of the dialog box that appears, then click the Product Structure tab and uncheck the option Manual Input. For more information, refer to Customizing Product Structure Settings. use the Tools -> Options command, click Infrastructure ->Part Infrastructure to the left of the dialog box that appears, then check the option Keep link with selected Object. For more information, refer to Customizing General Settings.

•

•

Note also that the default mode for the Update capability is "manual". For the purposes of this scenario, set the automatic mode. 3. Open the Assembly_01.CATProduct document. You will start the scenario with an existing assembly. Product1 is composed of three parts created in the Part Design Workbench:
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• • •

CRIC_FRAME (in turquoise) CRIC_BRANCH_3 (in blue) CRIC_BRANCH_1 (in red)

From now on, these parts will be referred to as components

Surface and Coincidence constraints have been defined for these parts in the Assembly workbench. 4. Click the + sign to the left of the Constraints text in the tree and apply the show mode on these constraints if you wish to view them in the geometry area.

Basic Tasks
Managing Product Structure: Introduction
Here are some basic rules you should know before handling the different types of files available in the Product Structure workbench.

12

Getting Started

• •

• • • • •

No distinction is made between assemblies, subassemblies, and components in the description of the product structure. However, you can associate a geometric representation to one component only. If two instances of the same component are used in an assembly, there is only one reference component for both instances, i.e. any modifications to the reference affect every instance, except name, representation activation and design mode visualization. An assembly is contained in a unique CATProduct file. The references of components and subassemblies can be contained in the same file as the assembly or in different CATProduct files. If the reference is contained in the same file, the component can be used only in this assembly or in larger assemblies containing this assembly. If the reference is contained in a different file, the component can be used in any assembly, but this file is then dedicated to this component only. When you use a file as a representation i.e. a .model, .cgr or .ncgm document, assembly data i.e. the part number, the definition, etc. is saved in a different CATProduct file. A CATPart file contains the assembly data related to the part and the reference of this component.

Starting with Product Structure
Entering the Product Structure Workbench: Select Infrastructure -> Product Structure from the Start menu. About Modified Status when editing a CATProduct: this task shows you what can be described in the Save Management window according to the manipulation made on the Product (opening / inserting / creating / editing a Part / Product / Component,...). It depends also on which element is UI active and on the propagation "parent / son" of the modifications.

Selecting objects
Selecting Products only: Select the Select only Products icon in the Filter toolbar and a component within a CATProduct. This icon will remain active whatever other functionality you are using to transform the CATIA document but is only useful for and used by the Select command. Selection Mode: This task explains how you can alternatively select the Children (sub-products) of one or several Part Numbers or All the components in the Specification Tree or Others (other than the first selected one).

Inserting Components
Inserting a New Component: Select the product and click this icon. Inserting a New Part: Select the product, click this icon and if need be locate the part (Note: not available for the ENOVIA product line). Inserting a New Product: Select the product and click this icon.
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project Inserting Existing Components: Select the product and click this icon. Open the component you need from the dialog box that is displayed. Inserting CATPart or CATProduct documents from a Catalog: Open a catalog. Find the chapter containing the entity you want to copy into the assembly (Note: not available for the ENOVIA product line).

Loading / Unloading components
Loading Components: Select a CATPart and CATProduct and click this icon. Unloading Components: Select a CATPart and CATProduct and click this icon. Using Selective Load: Select a component and click this icon.

Selecting a Mode
Setting up the Design Mode: Select the component then the command Representations -> Design Mode. Setting up the Visualization Mode: Select the component then the command Representations -> Visualization Mode.

Activating / Deactivating Nodes
Deactivating a Node: Select the node to be masked and click this icon. Activating a Node: Select the node and click this icon. Deactivating a Terminal Node: Select the terminal node to be masked then the command Representations -> Deactivate Terminal Node. Activating a Terminal Nodes: Select the terminal node then the command Representations -> Activate Terminal Node. Managing Representations: Select the product and click this icon. Select a representation in the dialog box that appears and click on Associate, or Remove or Replace or Rename button depending on the operation you wish to perform.

Reordering components and changing their context / representation
Reordering the Tree: Select the components to be reordered and click this icon. Use the three buttons of the dialog box to move the components to the desired location in the tree. Isolating a Part: By selecting Component -> Isolate Part in the contextual menu of a part, you can isolate it in an existing assembly in order to move it independently from the other contextual parts.
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Getting Started Deactivating/Activating a Component: Right click a component xxx and select the component xxx object-> Activate/Deactivate Component contextual command, to remove a feature from the geometry. Defining Contextual Link (former command: ChangeContext): By selecting Components->Change Context in the contextual menu of a part, you can change the context of this part in an existing assembly, you can make it contextual or not.

Positioning Components
Using Flexible Sub-Products: To make a CATProduct flexible, right-click it and select the Components -> Soft/Rigid Contextual command. In a product you can move a CATPart independently from another CATPart (drag and drop the compass). Moving the components of a sub-product in the parent product: Edit its parent product to move a sub-product in a rigid structure. Applying Overload Position on Reference during "Rigidification" command: to apply an overload position first, on a Specific Instance, and finally on all the instances of a reference, right-click it and select the object -> Propagate position to reference contextual command.

Duplicating Objects
Reusing your Product Structure: this table illustrates the different ways of duplicating objects, to reuse features or bodies. Cutting, Copying and Pasting Objects: this task describes how to cut and paste or how to copy and paste Product Structure features. Paste Special: This task makes the distinction between Paste as specified in Product Structure and Paste Break Link.

Replacing a component or a specific instance
Replacing a Component: Select the component to be replaced, click this icon then select the new component in the dialog box that is displayed.

Modifying Component Properties
Editing Components: the following capabilities are available: cut, copy, paste, delete, drag and drop. Modifying Component Properties: Right-click on the component in the specification tree and select Properties from the contextual menu. Enter the information you need in the Product tab. Managing Graphic Properties in products: you will know the effects of changes on graphic properties such as Show / No Show, Colors, Layers, Transparence, etc...
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project Naming or renaming a CATPart or a CATProduct: Inserting a CATPart or a CATProduct in a document depends on unicity rules. Generating Numbers: Select the product, click this icon and number components either by checking the Integer or Letters option. Saving a CATProduct As Text: If you convert a CATProduct into the "txt" file format, with several CATParts included, the structure of the assembly is written to a txt-file, but the corresponding description of all the CATParts in the txt-file is "Product".

Managing the Bill of Material (BOM)
Displaying the Bill Of Material (BOM): Select Analyze -> Bill of Material to display the number and name of the components belonging to the active component as well as the properties of these components. Managing the Bill of Material (BOM): open the CATAsmBom.CATNls and CATAsmBom.CATRsc with Wordpad or Notepad in order to edit them. Capacity not to take into account a component in BOM extraction: not to display the number and name of the components belonging to the active component in the Bill of Material (BOM). Searching on BOM Attributes: Select an element in the CATPart or CATProduct and the Edit -> Search : Advanced command. You can use the boolean terms to make a composed query.

Managing the Resources
Managing a Resource thanks to Resource Modeler: right-click the Product and select the Properties contextual command and the Resources tab appears within the Properties dialog box. (Note: not available for the ENOVIA product line).

Managing Assemblies of Components
Getting Started
If in Sketcher and Part Design you generated parts, now will learn how to finish your design by assembling parts in Assembly Design workbench. Before we discuss the detailed instructions for using the Assembly workbench, the following scenario aims at giving you a feel for what you can do with an Assembly document. You just need to follow the instructions as you progress. The Getting Started section is composed of the following tasks:

This scenario should take about 15 minutes to complete.
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Eventually, the assembly will look like this:

Designing a Part in an Assembly Context
This task consists in designing the part you have just added to the assembly. It shows you how easy it is to access the tools required for designing components in an assembly context. 1. Double-click CRIC_JOIN in the specification tree to access the Part Design workbench. 2. Select the blue face as shown to and click the Sketch icon access the Sketcher workbench.
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project 3. Now that you are in the Sketcher, click the Normal View icon in the View toolbar and sketch a circle on the face using the Circle command .

Do not bother about positioning the circle.

4. Now to obtain the same radius value as the one used for CRIC_JOIN circular edge and to make sure that this circular edge and the circle share the same to create a axis, use the Constraints Defined in Dialog Box command coincidence constraint (select the circle -if not already done- and the circular edge, then click the Constraint Defined in Dialog Box command and check "Coincidence").
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After validating the operation, the circle is coincident with the circular edge. You must obtain this:

5.

Exit the Sketcher and use the Pad command with the "Up to Plane" option to extrude the sketched circle. Select the blue face as shown to specify the limit of the pad.

After validating the operation, you should obtain this cylinder: The part is designed.

19
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For information about Part Design and designing in context, refer to Part Design User's Guide and Designing in Assembly Context respectively.

Editing a Parameter
In this task, you are going to edit the diameter of the pocket belonging to CRIC_BRANCH_3. You will see how this edition affects the part you created in the previous task. 1. Double-click CRIC_BRANCH_3 to access the Part Design workbench. 2. Select Pocket.2 and use the Pocket.2 object -> Edit Parameters contextual command to display the associated parameters.
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Getting Started 3. Double-click D11 in the geometry area to display the Constraint Edition dialog box. 4. Enter 20 as the new diameter value and click OK to generate the new pocket.

5. Update Product1 by double-clicking on Product1 in the specification tree. The pocket is modified accordingly. The coincidence previously set between the two parts is maintained. This result is made possible thanks to the option Keep link with selected Object you set at the very beginning of the scenario.

Components
Editing a Component
This task shows you how to edit the component causing the problem.
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project 1. Double-click the brown cylinder to access the Part Design workbench. Double-click the cylinder again to edit it. The Pad definition dialog box is displayed.

2.

3. Enter 20mm to reduce the pad length and click OK.

4. The cylinder is updated and now looks like this:

Replacing a Component
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The first task, Replacing a Component by another one in Session, consists in replacing a compo showing the impacts of this action. Using the Replacement Component command means replacing component with another.

The second task, The Impacts of the Replace Command, explains what can be the impacts of re component whose Part Number is same as the replaced element, and what can be done to solve t

The third task Replacing a Specific Instance or All Instances of a Reference, shows you that you several instances. The process is the same but when a component dialog box is displayed, you se component of your choice and tick the MultiInstances box in order to replace all instances.

Within an assembly, two components can have the same Part Number and be the Instances (1 a example below) of two References only if their References are inserted in two different document assembly levels, Local References). For instance: • • occurrence 1 is an Instance of CARBODY Reference in Landing_Gear document. occurrence 2 is an Instance of CARBODY Reference in PartNumberConflicts1 document.

A Local Reference is a Reference that can only be used in its own document. This is what we call Reference in a CATProduct. For more information about Local References, please refer to Naming a product. Therefore, if the Replace All Instances functionality is applied to one of these instances (1), it wil both Instances and the behavior will be the same like the common Replace:
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For more information about this example, please refer to Inserting Existing Components.

A V4 model is not a Product, therefore it is considered as a Representation, a CATShape. A model is inserted in a product structure by means of a local Reference created in this particular model is a representation attached to this Reference. For more information, please refer to Manag Representations.

Replacing a component means that: you are replacing a Reference by another Reference and y keeping the same Instance. The Instance Name is the data of an Instance; it is not changed aft Replace operation, so that links (External References) are not broken. And you are allowed to rec links with the new Reference.

For more information about modifying Instance Name, please refer to Naming or Renaming a pro (Instance or Reference).
Replacing a Component by another one in Session

If you want to replace your CATIA documents by downloaded ones, you need to activate the follo in Tools -> Options -> General -> Document -> Document Environments - Loaded document: Allo

Open the AnalyzingAssembly02.CATProduct.

24

Getting Started

1. Right-click CRIC_SCREW (CRIC_SCREW.1) and the Replace Component contextual comma following panels are displayed:
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2. Click Cancel in the file Selection window. The Browse panel is still available. 3. Click the Loaded document icon. A Session document window appears:
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4. Select one of the downloaded documents, for instance: Subset1.CATProduct. An Impacts o window is displayed, showing you what can interfere with the other downloaded document information about the impacts on replace, please refer to the following section.

5. In the Impacts on Replace, click OK if all the replacing impacts have resolved and you obt
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The Impacts of the Replace Command

Open the ReplaceImpacts.CATProduct document.

Note: depending on the document environments you have allowed in the Document settings, an panel may appear simultaneously to let you access your documents using an alternate method. F information, refer to Opening Existing Documents Using the Browse Panel.
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1. Select PartWithImpacts (PartWithImpacts.1) and click the Replace Component icon Selection and Browse panels are displayed:

.T

2. Click Cancel in the File Selection panel; the Browse panel becomes activated. Or if you select Support1.CATPart for instance, in the File Selection panel, and click the Open button, the Browse panel disappears and, An Impacts on Replace panel appears:

Therefore, you do not need to follow the steps 3 and 4.
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3. Click the File icon and another File Selection window appears. 4. Select Support1.CATPart for instance. An Impacts on Replace panel appears:

This panel shows you the impacts of the Replace command on PartWithImpacts.CATPart. You can impacted objects (2 Publications, 1 External Reference and 1 Constraint) that can be re-connecte have access to the following information: • • • Type of the impacted objects (Publication, Contextual Design Connection) Name of the impacted objects (which is connected to PartWithImpacts.CATPart) Source or path of the impacted objects

You can interrupt the Replace operation by clicking the Cancel button. 5. There is a question in the panel:

By default, the YES option is checked. It means that all the instances will be replaced (and the number conflict panel does not appear because it is no longer needed).

If you click NO, only the selected instance will be replaced but, in the case of a Part Number co the Part Number Conflict dialog box appears. For more information about Part Number Conflict, please refer to the following scenario.
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6. Click OK and the Impacts on Replace dialog box disappears. You can visualize the impacts Geometry and in the Specification Tree.

7. Update your document and the following warning points out the impacted objects: Surface has its External Reference.
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You can however use the replace command on the objects that may be impacted. The links can b but not necessarily broken.

8. Click Close. The symbol next to the External Reference means that the part is not conn the correct External Reference. The other Publications with a broken link are represented w yellow exclamation mark meaning that the link with the root document has been lost.

32

Getting Started

About Reference / Reference link: If the replaced Reference is pointed by a Reference / Reference link, this link is not impacted nor consequence the replaced Reference will not be unloaded.

Replacing a Specific Instance or All Instances of a Reference
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This task consists in replacing All Instances of a reference and a Specific Instance.

As it was described in the previous section the user activates the Replacement Component icon one component with another. This command automatically chooses the first instance of the objec going to be replaced. Open the 16cubes.CATProduct document:

This document contains two identical CATProducts: 8 cubes (8 cubes.1) and 8 cubes (8 cubes.2). CATProducts have the same CATParts: Cube (Cube.1) and Cube (Cube.2).

34

Getting Started

1. First of all, select Cube (Cube.1) and click the Replace Component icon box is displayed, select Cube2.CATPart and click Open:

. The File Selec

2. Click Open and the Impacts on Replace dialog box appears, with the following message:
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If you choose to replace Cube(Cube1.1) with Cube2(Cube1.1), there is a Part Number conflic because both entities have the same Part Number (Cube). Therefore, if you click:

• YES, all the instances will be replaced (and the Part Number conflict panel does not appea because there is no longer any conflict). • NO, only the selected instance will be replaced but, in the case of a Part Number conflict, t following dialog box appears:

3. Select Yes and click OK and a warning tells you that the component you are inserting is re

4. Click Close.

There is no Part Number conflicts panel (no impact on Cube (Cube.1)) because the replacing component, Cube2.CATPart, does not create any conflict since all the "cube" Part Numbers have replaced:
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Wherever the element's instance is in the product, it is replaced by the new component. In our example, the Multi-Instances functionality looks for all the instances of the reference Cube (Cub in the product and replaces them in the whole document. 5. Close 16cubes.CATProduct without saving it. Re-open it. 6. Repeat the same operation: select Cube (Cube.1) in 2cubes (2 cubes.1) and click the Rep Component icon .

7. In the File Selection window, select Cube2.CATPart and click Open: the Impacts on Replac appears. 8. Click No to replace only one instance:
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9. Click OK button. And two panels appear:

• the Incident Report: it is a warning telling you that the component you are inserting is rea only. Click Close.

• the Part number conflict panel; you can Rename (or use the Automatic rename option) th instance Cube2.CATPart so that there is no longer conflict with the other Part Numbers ( do not replace):

10. Enter a new Part Number (CubeBis) and select this line (Cube) and click the Rename butto Part Number panel appears.

11. Click OK. In the Part number conflicts, you can see that the name of the Part Number is no instead of Cube (for Cube2.CATPart).
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12. Click OK and you obtain:
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As a consequence, only a Specific Instance, Cube (Cube.1), is replaced by Cube2.CATPart (wh Number is different from the one of Cube (Cube.1)) in the Specification Tree and in the Geometry Note that the last entity of Cube (Cube.1) has not been replaced by Cylinder01.CATPart because instance is not at the same level:

For more information about Part Number conflict, please refer to Insert Existing Component.
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Fixing a Component
This task shows you how to set the first constraint. This operation consists in fixing the position of a component in space so as to use this component as the base of the assembly. 1. Select CRIC_FRAME in the specification tree or in the geometry area. 2. Click the Fix Component icon in the Constraints toolbar.

The component CRIC_FRAME is immediately fixed. The application indicates this by displaying a green anchor symbol on the component.

Note also that the Constraints branch now displays the new constraint. The anchor symbol is preceded by a lock symbol, to make a distinction between "fix in space" and "fix operations". For more information, pleaser refer to Fixing a Component.
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Adding and Renaming a New Component
This task consists in adding a new component to the assembly. You will then rename this component. This component is a part created in the Part Design workbench. 1. Click Product1 and select the Part toolbar. icon in the Product Structure Tools

The New Part: Origin Point dialog box appears, presenting two possible options: Either you define the point of your choice to locate the new part, or you use the origin point of the assembly as the origin point to be used for the part. 2. Click No to use the origin point of the assembly. The new component "Part5 (Part5.1)" is now displayed in the specification tree:

If the Manual Input option is activated (see Customizing Product Structure Settings), the Part Number dialog box appears before the New Part: Origin Point dialog box and lets you enter the name of your choice. 3. Right-click Part5 (Part5.1) and select the Properties... contextual command.

42

Getting Started 4. In the Properties dialog box that appears. The options available in the Product tab let you enter the information you required.

5. Enter CRIC_JOIN.1 in the Instance name field and CRIC_JOIN in the Part Number field. 6. Click OK to validate the operation. The new names are now displayed in the specification tree:
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Inserting an Existing Component
This task shows you how to insert an existing component into the assembly. Open the AssemblyHole.CATProduct document. 1. Select Product1 in the specification tree.

2. Click the Existing Component icon: The File Selection dialog box appears. 3. Select Sub_Product1.CATProduct from the sample directory and click Open. A new component is added to the specification tree. The assembly now includes four components: three parts and a sub-assembly.

This is the component you have just imported:
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To know the different document types you can insert in a CATProduct document, refer to Product Structure documentation. However, to know how to insert .asm documents properly, refer to Opening a .asm Document.

Constraints
Setting Constraints Between Components
This task consists in setting a coincidence constraint, then a contact constraint between the component you have just inserted (Sub_Product1) and CRIC_BRANCH_1. 1. Click the Coincidence icon: A message window appears, providing information on the coincidence constraint command. If you do not want to see this dialog box appear any more, check Do not prompt in the future. 2. Select Axis publication in the specification tree.
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The application detects it once selected. The axis is now highlighted in the geometry.

3. Select one of the two inner faces of CRIC_BRANCH_1 to select the associated axis.

As the coincidence constraint is created, CRIC_SCREW and CRIC_BRANCH_1 are aligned:
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Now, you are going to set a contact constraint between CRIC_SCREW and a circular face of CRIC_BRANCH_1. 4. Click the Contact Constraint icon: 5. Select Face publication in the specification tree.

6. Select the red circular face in the direction opposite to the published face.
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As the contact constraint is created, the turquoise cylinder is located exactly on the red face.

The created constraints are automatically updated because the automatic update mode is activated. As the color defining valid constraints is green, our constraints are green. The application allows you to customize constraint colors as explained in Customizing Constraint Appearance. The assembly now looks like this:
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Moving Constrained Components Using the Compass
This task consists in manipulating the assembly to check if the components react the way we want, i.e. according to the constraints we set in the previous task. 1. Select the red patch at the center of the compass and drag it onto CRIC_SCREW. For details about how to use the compass, please refer to Infrastructure User's Guide. As the compass is snapped to the component, you can manipulate the component.

2. Now, if you press and hold down the Shift key, select v/z axis on the compass, then drag and drop the component up and down, you can see that three components are moving. This is an example of what we can get:

3. Repeat the operation as many times as you wish. The assembly reacts correctly. CRIC_FRAME does not move because it is fixed. The other three components can move. 4. Release the left mouse button before releasing the Shift key.
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5. Drag the compass away from the selected object and drop it.

Analyzing Assembly Constraints
This task shows you how to analyze the status of all assembly constraints defined for Product1. 1. Select the Analyze -> Constraints... command. The Constraints Analysis dialog box that appears displays all the information you need. The Constraints tab contains a detailed status of the assembly: the number of non-constrained components and the status of the defined constraints.

2. Click the Broken tab to see the list of broken constraints. We have only one broken constraint, a contact constraint. 3. Click on the name of the constraint. The constraint is highlighted in the specification tree.
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Reconnecting a Broken Constraint
In this task, you will learn how to reconnect the broken constraint detected by the application. 1. Double-click the broken constraint in the specification tree. Note that this broken constraint is indicated by a yellow warning symbol.

2. In the Constraint Definition dialog box that appears, click More to access additional information. 3. Click Disconnected in the Status frame, then Reconnect...
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Analyzing Assemblies
Displaying the Bill of Material
This task shows you how to access all the information available about the structure of the assembly. 1. Return to Assembly Design workbench and select the Analyze -> Bill of Material... command. The Bill of Material is displayed.

52

Getting Started

It is composed of these sections: Bill of Material: lists all parts and sub-products one after the other Recapitulation: displays the total number of parts used in the product Define formats: customizes the display of the bill of material The Listing Report tab displays the tree of the product using indents 2. If you wish, you can save this document using the html format or the txt format. Just click the Save As... button, then give a name and the appropriate extension to your file. For more information about the bill of material, refer to Displaying the Bill of Material.
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Exploding the Assembly
This last task illustrates the use of the Explode capability. Exploding the view of an assembly means separating the components of this assembly to see their relationships. 1. Make sure Product 1 is selected. 2.

Click the Explode icon

in the Move toolbar.

The Explode dialog box is displayed.

Product 1 is the assembly to be exploded. The Depth parameter lets you choose between a total (All levels) or partial (First level) exploded view. 3. Set All levels if not already set. 4. Set 3D to define the explode type. 5. Click Apply to perform the operation. The Scroll Explode field gradually displays the progress of the operation. The application assigns directions and distance. Once complete, the assembly looks like this:
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The usefulness of this operation lies in the ability of viewing all components separately. Note that you can move products within the exploded view using the 3D compass.

6.

Click OK to validate the operation and then click Yes at the prompt or click Cancel to restore the original view. Well, you have done all the tasks of the Getting Started section. Why not consult the rest of the documentation?
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Handling Parts and Products
Inserting a New Part
This task will show you how to insert a new part in an existing assembly. Open the ManagingComponents01.CATProduct document. 1. In the specification tree, select ManagingComponents01 and click the New Part icon .

If geometry exists in the assembly, the New Part: Origin Point dialog box is displayed, proposing two options to locate the part: • • Click Yes to locate the part origin point on a selected point, on another component for example. Click No to define the origin point of a component based on the origin point of the parent component.

2. For the purposes of this task, click No to locate the part origin based on the Product1 origin point. The Part (Part8.1) is created in the specification tree:
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To edit Part8 or any other sub-elements of the CATPart document, double-click on the required component in the specification tree and you will access the Part Design workbench. See CATIA - Part Design User's Guide V5 for more information. Do not mistake the Product document for the Part Design document: • • . The Product document is identified by the Product document icon The Part Design document is identified by the Part Design document icon .

If you want you can define the default part number of the part to be imported. To see how this is done refer to "Customizing Product Structure Settings".

Inserting a New Product
This task will show you how to insert a product in an existing assembly. Open the ManagingComponents01.CATProduct document. In the specification tree, select ManagingComponents01 and click the New icon. A new product is created in the specification tree: Product2 Product (Product2.1) in our example.
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If you want you can define the default part number of the product to be inserted. To see how this is done refer to "Customizing Product Structure Settings".

Inserting CATPart or CATProduct Documents from a Catalog

This task shows you how to copy CATPart or CATProduct documents from a catalog into an existin assembly. Open the ManagingComponents01.CATProduct document. 1. Open a catalog, for example the ALL FASTENERS.catalog that you created in the scenario a Catalog" in CATIA - Component Catalog Editor User's Guide. Double-click the main chapter, All FASTENERS if the entities of this chapter do not appear left-hand part of the catalog navigator. Find the chapter containing the entity you want to copy into the assembly.

2. Double-click on this chapter, SCREWS for example. The following results appear in the righ the dialog box :
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The entities contained in the selected chapter appear in the form of a table on the right side of th navigator : Two default icons are used: • • the folder icon identifies a chapter, identifies a family in another catalog.

the sheet + arrow icon

3. Click the Preview tab to visualize the listed entities:
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4. You can open an entity in either the Reference or Preview tab by clicking the contextual c Open document. If you want you can now edit the entity just like any other V5 document.
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Or:
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To narrow the selection criteria using the keywords you originally chose see "Querying a Catalog" - Component Catalog Editor User's Guide. 5. Click on the entity you wish to copy and either click the Copy icon command.

or select the Edit->

6. Select the appropriate target i.e. the main product item or any CATProduct document in th specification tree and retrieve the entity from the clipboard by clicking the Paste icon selecting the Edit->Paste command.

o

Generating CATPart from Product
This task will show you how to generate a CATPart from a product. When you are generating the CATPart: • The command will capture all geometrical representation detected in all activated nodes that are children of the selected node. Each geometrical representation found, will be created in the CATPart as an isolated body. Do not mistake the ObjectName Object -> Activate/Deactivate Component contextual command with the Representations -> Deactivate Node command. This last command deactivates the representation visualization of the component, not the component. V4 model will be processed like the standard V4 to V5 interactive translation does it (copy break link result). All positions of the geometrical representation are kept in the new CATPart relatively to the higher root product currently opened in the V5 session. In other words, the new CATPart origin is created by the command, using the root higher level of the opened CATProduct, which is not necessary the node selected by the user. Visualization Mode is taken into account: if conversion is launched on a CATProduct open in visualization mode, all CATPart and model are processed. In fact they are switched one by one from Visualization Mode to Design Mode, processed and switched back to Visualization Mode. It avoids memory peak and allows you to convert very large products. Elements in No Show are not converted. Empty Geometrical Set and Geometrical Set containing only geometrical features in No Show are not processed (no empty body after creation). For V4 model, all wireframe features are created inside one specific Geometrical Set named Wireframe. Reference planes of created CATPart are in No Show. Axis System of CATPart are not converted. Only the color of part bodies are kept. This is means that color on sub-elements and Part Design features are not kept during process.

•

• •

•

• • • • • •
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• •

•

Only one product can be selected, the multi-selection is unavailable. All processed objects are renamed with the path of instance in reference product. It allows user to understand easily from which CATPart comes each elements. Notice that it could generates very long names if the product structure is depth (or if instance name are long). An empty PartBody is already created (default body of a new part).

Open the Assembly_01.CATProduct document. 1. Select Assembly_01 in the specification tree. 2. Select Tools->Generate CATPart from Product... menu. The Generate CATPart from Product dialog box appears.

• •

The default name for the generated part is ProductName_AllCATPart. The Merge all bodies of each part in one body option allows you to merge, for each part, in one body all its part bodies through an add operation and all its Geometrical Sets through the Change Geometrical Set command. o The name of this body is the name of the instance the CATPart with its full path. o Names of all geometrical features and bodies are kept as in original CATPart. o This option is also efficient for V4 model.

3. Click OK. The Assembly_01_AllCATPart has been created.
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Naming or Renaming a product

In this page, the first section will explain you what are the renaming restrictions and the second o rename a component (CATPart or CATProduct) after its insertion into an existing Assembly and ho Renaming Rules User Interface Manual Input Part Number / File Name Differences 1st scenario: renaming the Part Number 2nd scenario: using Special Characters 3rd scenario: using the Backslash 4th scenario: unicity Managing Part Number Conflicts

Renaming Rules:
There are some situations in which the User cannot rename the Part Number: •

• •

•

Unicity: in a CATProduct, the Instance Name must be unique at one Assembly level be unique within the complete assembly (with only one exception). You cannot enter the s the existing one in the document, at the same level. o Part Number Conflict panel reveals unicity problems. Influence of the Part Number on the name of the document: By definition, the File N Part Number. And if you rename the Root's Part Number (and the document is not saved a to change the name of the file that is going to be saved. Neither these special characters "!" and ":" nor an empty name " " and blank cha string should be used in the: o Instance Name o Part Number o Publication. About special characters described in About File Names, in CATIA - Infrastructure User' them in the Part Number (except ":") but not in the File Name because: o a default name is attributed to the File,
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•

or the File Name is automatically truncated before the backslash (backslash is not a see exact list of restrictions: About File Names. Specific Language characters like and (French) for instance cannot be used error message appears when you try to save this File. o

User Interface:
These renaming rules intervene in: • •

Manual Input: for more information, please refer to Customizing Product Structure Setting Part Number Conflict panel reveals unicity problems.

Manuel Input:

1. Open a New Product in CATIA V5. The setting Manuel Input in Tools -> Options -> Infrastr Structure has been activated.

2. Enter a name in the Part Number box and you can see that the name of the file is also Cub

3. Change the Part Number of Parabola1 in the Properties contextual menu. And you can not document becomes the same as the Part Number name; it is influenced by the Part Numb
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4.

Part Number / File Name Differences:
1st scenario: renaming the Part Number

1. Save this product Parabola1 under the name Cube1: the Part Number is different from the

2nd scenario: using Special Characters

1. Change the Part Number of Parabola1 in the Properties contextual menu into: (sp you can notice that the name of the document remains Cube1 and it no longer correspond name. Special characters are not supported when saving the document as a file.

For more information about special characters when saving a document, please refer to About File Infrastructure User's Guide.

67

project

2. Open the Save Management panel (File -> Save Management): Cube1.CATProduct appear document does not correspond to the name of the Part Number containing Special charact

3rd scenario: using the Backslash

1. Create a New product and give it a name with a backslash: "Cube2\Elementary Source".

2. Save this product and you will see that all the words before the backslash, and the backsla account.
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So that the Undo functionality can work properly, a deleted CATIA document remains availa in Session.

As it is not possible to save two documents with the same name in the same directory, CAT V5 sometimes prefers to make the File name different from the Part Number.
4th scenario: unicity

1. Create a New CATProduct: Product1.CATProduct. 2. Insert 2 New Parts in this CATProduct: Part1.CATPart and Part2.CATPart.

69

project

3. Delete Part2.CATPart:

4. Insert a new part: Part3.

5. Rename Part3 into Part2 via the Properties contextual menu, you will be able to change th the Document name (Part3.CATPart). A warning appears reminding you that Part2.CATPar the assembly but it still exists in session.

6. You can also check this by clicking in the menu: File -> Save Management.
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Managing Part Number Conflicts
Open the Assembly111.CATProduct document.

1. Select Assembly in Assembly111.CATProduct and Insert Assembly222.CATProduct docume about importing a document, see Inserting Existing Components.

In both Assembly111.CATProduct and Assembly222.CATProduct, some components (Assem and Last-Component) have the same Part Number, which makes the insertion problematic because the entities' Part Number must be unique in the whole document (not only at one Assembly level). Therefore, the Part Number Conflicts dialog box is displayed:
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This table exposes the name conflicts between Assembly111.CATProduct and Assembly222.CATProduct. It provides details about: • • • • •

Part Number : the Part number of the component generating the conflict. Selected File : references of the imported document. Document generating the conflict : the position and name of the document generating the conflict. Already imported file : source already existing (with the same Part Number as the imported component) inside the root product. Status : not solved, when 2 components have the same Part number.

The Reconnect... button is activated when the imported component has the same geometr the one in the original document.

In a CATProduct, the Part number must be unique at every level in the specification tree. The Pa applied to the whole document.

2. The solution is to rename the component generating the conflict: Select a line correspondi component and click the Rename... button to display the Part Number dialog box. You can instance "AssembElements" to replace "Assembly":

Once you have renamed this component, the Part number conflicts dialog box is updated; t status of "AssembElements" (former "Assembly") is then: Renamed. Thus the Part Number conflict with Assembly in assembly222.CATProduct is resolved:
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You can do the same with the last two conflicts: Last-Component and Component3, and you will obtain for instance:

3. Click OK to validate the operation and the conflicting components does not exist anymore; are now displayed in the specification tree:
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The conflicting names are automatically changed in Assembly111.CATProduct. There is an exception:

A local reference such as HANDLE (HANDLE.1) can have several occurrences with the same Par both occurrences stand on a different assembly level. In our example, HANDLE (HANDLE.1) appe references (.model, .cgr), the unicity rule is applied to one Assembly level only.

As for the Instance Name, it must be unique at one Assembly level. You can find the same insta CATProduct, but not in an Assembly level.

4. If you try to copy the HANDLE.model and paste it into the same document Assembly111.C AssembElements, its Instance Name is automatically converted into HANDLE (HANDLE.2 However, its Part Number remains similar because it is a new instanciation of the local reference HANDLE.

It is possible for you to change again the Instance Name of this component, but you have t respect the unicity rule. For more information see Modifying Component Properties.
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5. If you try to insert HANDLE.model in Assembly111.CATProduct, the following Part number

You can either Rename or Reconnect Document generating conflict: •

Rename the Document generating conflict : if the inserted component is different fr the one in the already existing document. Therefore, you create a new local referenc the document.
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•

Reconnect the Document generating conflict : if the inserted component is the sam the one in the already existing document. As a consequence, you create a new instanciation of the existing local reference. It is the same process as when copying pasting HANDLE (HANDLE.1).

6. If you choose the Rename... button, "HANDLE" can be renamed with "AXIS".

The status of the inserted document has been modified and the Part number conflict is resolved:

You can visualize the adjustment in the Specification tree:
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7. If you click the Reconnect... button (instead of Renaming), it has the same effect as copyi .model, HANDLE (HANDLE.1), into the same document, Assembly111.CATProduct : you cr of the existing local reference.

And its Instance Name is automatically converted into HANDLE (HANDLE.2). See the Assembly111.CATProduct picture above.

The process of renaming a CATPart is the exactly the same, except that you are not allowed insert a CATProduct into a CATPart. 77
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For more information about the options for Part number definition (Manual Input), see Defining th the Component to be Imported.

Selecting Products only

This task explains how you can apply a "Filter on Products", which enables you to select Products on within a CATIA document. This Filter lets you select one or several products in a complex architecture.

It remains active whatever other functionality, except DMU commands, you are using to transform CATIA document. But is only useful for and used by the Select command. When switching to anothe workbench within the Product Structure workshop, the state of this filter will remain the same. This state is kept in memory when you exit the Product Structure workshop, and is retrieved when return to it.

When the architecture of a CATProduct is complex, this functionality allows you to select a particular Product more easily, only by selecting one of its components in the geometry. Open the Articulation.CATProduct document. 1. Click on the Select only Products icon in the Filter toolbar: When the icon is activated, it looks like this:

2. Click on a component belonging to the CATProduct of your choice. As a consequence, the wh Product is selected:
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Only the Product (and not its Children) is selected. You can use the other commands to modify the Product (Edit-Properties... or Insert a New Component) and go into another workbench without deactivating the Filter icon. However, if you open a new Product, the Filter command will not be activated by default, because a new instance of the CATProduct document is made and it can have i own filter for the Select command.

3. Put your cursor on any component of the Product and you can immediately modify the Produ properties (Graphic Colors for instance):
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4. In this case, you modify the Product's properties and not the sub-components' characteristics.

4. In order to apply the filter on several Products at the same time, click on the Select only Products icon, then select a Product of your choice and Ctrl-click on other Products to add th to your selection.

This filter can be used in many different ways, like selecting a Product and an Edge from another Product. To do so, click on the Select only Products icon, then select the Product. Click again onto th Select only Products icon: the Product is kept in the selection. Then Ctrl-click on other objects (like Edge) to add them to your selection. For more information about selecting rules, please refer to Selecting Objects: in CATIA - Infrastructure User's Guide.
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Manipulating Objects
Manipulating Objects Using the Edit... Command
This task explains how to manipulate objects precisely, using the Edit... contextual command. You can: • • • • • • reset the position of the compass (and selected object) via its manipulation handle (red square), by specifying its X, Y and Z coordinates and rotation coordinates with respect to the center of the 3D scene translate the object (or just the compass) to a new position in increments along the X, Y and Z axes rotating the object (or just the compass) about the X, Y and Z axes in increments translate over a specified distance in the direction of the privileged plane translate over the distance between two elements (line/edge/plane) you select rotate through an angle you set, or an angle between two elements (line/edge/plane) you select.

You can only use the Edit... contextual command with the same objects as those with which you can use the compass (for example, a planar patch). You need access to a Version 5 - P2 FreeStyle Shaper configuration to follow this scenario. Open the document Manipulators.CATProduct. 1. Drag and drop the compass onto the object, then point to the compass and right-click to display the 3D compass, or double-click the compass to display the contextual menu. In our example, drag and drop the compass onto the planar patch and rightclick:
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2. Select the Edit... command to display the Parameters for Compass Manipulation dialog box:

The Parameters for Compass Manipulation dialog box stays open during manipulation.
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Note that the current coordinates of the compass manipulation handle (red square), with respect to the center of the 3D scene, are displayed in the corresponding fields for the Position option. In our example, the center of the 3D scene, in this case, is the point of intersection of the 3 planes located on the pad. 3. In the Coordinates area, select the axis system with respect to which you will edit the coordinates of the compass. You can select • either the Absolute axis system: allows you to move the part with respect to the absolute axis system of the product containing the part • or the one of the Active object: allows you to move the part with respect to the object which is active. To define an object as being "active", just double-click it in the specification tree: the object will then be highlighted in blue to indicate it is active. For instance, let's suppose the active object is a part with a local axis system defined as current: in that case, choosing Active will result in displaying the coordinates of the compass with respect to the local axis system of the part. 4. Reset the X, Y and Z coordinates of the compass to zero, using the Position option, then click the "Apply" button. In our example, because you dropped the compass onto the planar patch, the compass and the planar patch are moved to the center of the 3D scene as follows:

5. To translate the compass and planar patch by increments along an individual axis (U, V or W) using the Increments options, set the translation values for an axis, then click the "up" or the "down" arrow to translate in forward or reverse direction respectively.
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6. To translate an object along a vector derived from two objects you select, click the "Distance" button in the Measures area and select the two elements. When you click the "Distance" button, all options and fields in the dialog box are grayed out. You can select any of the following: • a point • a line • or a plane. The value for the detected distance is highlighted in the appropriate fields, expressed in the units of the compass. Note that, depending on the compass orientation, some or all of the X, Y and Z coordinates may be calculated. If the first element is a line or a plane, you can then select a second element or enter a distance. For example, selecting a line implies that you want to translate the object in the direction of the line, and you can enter the distance for the translation in the Distance field. However, if you just select the two elements, the distance between the two is displayed in the Distance field, and the object will be translated over this distance and in the same direction. If the second element is a plane, the direction of translation is normal to the plane. button or the button to the right of the Then, click either the "Distance" option to translate the object in the reverse or forward direction. 7. To rotate, set the rotation angle and click the the axis about which you want to rotate. button or the button for

For example, with the object still located at the center of the 3D scene, rotating about the U axis produces this result:
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8. To rotate the object through the angle between two elements, click the Measure Angle button and select the two elements. You can select a line or a plane. The angle value is displayed in the Angle field. If the rotation axis is parallel to one of the compass axes, the value is also displayed in the appropriate Rotation increment field, the 2 other ones being reset to 0. button or the button to rotate the compass and the Then click the object around the computed rotation axis. Bear in mind that you can reset entered increments at any time simply by clicking the icon.

Once the compass is snapped to the object, you can drag its arcs to translate or rotate the object according to the increments you entered in the dialog box. When the dialog box is closed, the increments are kept for the compass and bounding box motions. When you wish to reset the compass and move it freely according to one direction, access the Parameters for Compass Manipulation dialog box and set the corresponding value to 0.

Snapping
Snapping the Compass to Selected Objects Automatically
This task explains how to snap the compass to a selected object, as an alternative to dragging and dropping the compass onto the object. Open the document Manipulators.CATProduct.

1. Point to the compass and right-click to display the contextual menu.

2. Select the command Snap automatically to selected object. 3. Select an object. In our example, select the planar patch:
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The compass is snapped automatically only onto non-constrained objects recognized by the compass. The compass keeps its current alignment. As long as the command Snap automatically to selected object remains activated, the compass will be snapped automatically. Note that if a new axis system has been created, selecting it in the geometry area or in the specification tree will make the compass disappear. To make it re-appear, simply select any other element in the geometry or in the tree.

Snapping Components
The Snap command projects the geometric element of a component onto another geometric element belonging to the same or to a different component. Using this command is a convenient way to translate or rotate components. The Snap is able to work in visualization mode, which means the positioned component and the positioning parts will no longer need to be switched into design mode. However, in order to select points, you must be working in Design mode. For DMU Navigator, this task is P1-only. The element to be snapped must belong to the active component. Open the Moving_Components_01 document. Depending on the selected elements, you will obtain different results. This table indicates what you can do: First Element Selected Second Element Selected Result
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axis system axis system axis system axis system point point point point line

axis system point line plane axis system point line plane axis system

Identical axis systems, origin and axes. The axis system origin is projected onto the point. The axis system origin is projected onto the line. The axis system origin is projected onto the plane. The point is coincident with the axis system origin. The points are coincident. The point is projected onto the line. The point is projected onto the plane. The location where you have selected the line and the axis system origin are coincident. The location where you have selected the line and the point are coincident. The line is projected onto the line. The line is projected onto the plane. The location where you have selected the plane and the axis system origin are coincident. The location where you have selected the plane and the point are coincident. The plane passes through the line. The planes are coincident.

line

point

line line plane

line plane axis system

plane

point

plane plane

line plane

Make sure you work in Design mode (use Edit->Representations->Design Mode) 1. Click the Snap icon:
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2. Select the red face as shown.

The element selected first is always the element that will move. 3. Select the blue face as shown.

The red face is projected onto the plane defined by the blue face. A green arrow is displayed on the first face you selected.
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4. Click this arrow to reverse the orientation of the face.

Snapping Planes to Points and/or Lines
You can position section planes by selecting three points, two lines, or combination of the two. This task illustrates how to snap a section plane to a selection consisting of lines and/or points. No sample document is provided.

1. Select Insert -> Sectioning from the menu bar, or click the Sectioning
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in the DMU Space Analysis toolbar and create a section plane. icon The Sectioning Definition dialog box appears.

A Section viewer showing the generated section is automatically tiled vertically alongside the document window. 2. Click the Positioning tab of the Sectioning Definition dialog box. 3. Click the Positioning by 2/3 Selections icon hidden. 4. Make your selection of lines and/or points. o o The current selection is highlighted in red. The cursor changes to assist you make your selection. It identifies the type of item (point, line, cylinder, cone, etc.) beneath it. .The section plane is

A plane passing through the selection is computed and the section plane automatically snapped to this plane.

5. Click OK in the Sectioning Definition dialog box when done.
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Snapping Section Boxes to Planes

You can snap section boxes to two planes. The first target positions the master plane, the second defines a rotation (if needed) and adjusts box dimensions. This task illustrates how to snap a section box to two planes. No sample document is provided. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar and create a section box.

The Sectioning Definition dialog box appears. A Section viewer showing the generated section is automatically tiled vertically alongside the document window. 2. Click the Positioning tab, then the Geometrical Target icon the box to planes. to snap
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3. Point to the first plane of interest. The Geometrical Target command recognizes that it is a section box. A rectangle and vector representing a plane and the normal vector of the plane appear in the geometry area as well as the figure 1 to assist you. It moves as you move the cursor.

4. When satisfied, click to position the master plane of the section box on the first target.

Note that the visual aid now displays the figure 2. 5. Select a second plane.This plane adjusts box dimensions, and if required, rotates the box. The section box is totally constrained to selected planes. The two selected planes are parallel: box thickness is modified
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The two selected planes are perpendicular: box height is modified

6. Click OK in the Sectioning Definition dialog box when done.

Using Components
Inserting Components
Inserting a New Component
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This task will show you how to insert a component into an existing assembly. This command lets you: • • create an instance from the reference component use a context-specific representation inside it (see Managing Representations).

Open the ManagingComponents01.CATProduct document. In the specification tree, select ManagingComponents01 and click the New Component icon .

The structure of your assembly now includes Product1(Product1.1).

If you want you can define the default part number of the component to be imported. To see how this is done refer to "Customizing Product Structure Settings".

Inserting an Existing Component
This task shows you how to insert an existing component into the assembly. Open the AssemblyHole.CATProduct document. 1. Select Product1 in the specification tree.

2. Click the Existing Component icon: The File Selection dialog box appears.
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3. Select Sub_Product1.CATProduct from the sample directory and click Open. A new component is added to the specification tree. The assembly now includes four components: three parts and a sub-assembly.

This is the component you have just imported:

To know the different document types you can insert in a CATProduct document, refer to Product Structure documentation. However, to know how to insert .asm documents properly, refer to Opening a .asm
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Document.

Inserting an Existing Component with Positioning
This task will show you how to insert and position a component as the same operation. This functionality is an enhancement of the Insert Existing Component command for Assembly Design workbench. The Smart Move interface will enable the easy positioning of inserted components in the assembly, at the very moment of their insertion. It will also enable the positioning by creation of constraints. If there is no geometry to position when the component is inserted, this functionality has the same behavior as the Insert Existing Component command plus a visualization. See Smart Move or Smart Move with Viewer. Open the MovingComponents01.CATProduct document.

1. Click the Existing Component with Positioning icon: 2. Select Product1 in the specification tree. 3. Select the CRIC_JOIN.CATPart document in the File Selection dialog box. The Smart Move dialog box appears.
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The Fix Component command is now available from this dialog box. 4. In this dialog box, select the axis of the part.
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The axis is displayed on the part in the geometry window.

5. In this geometry window, select the axis of the CRIC_BRANCH_3 part.

CRIC_JOIN is snapped with CRIC_BRANCH_3 part.
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6. Click OK in the Smart Move dialog box.

Inserting Existing Components
This task will show you how to import one or more components into an existing assembly: • • • • Part Number conflicts when inserting a model, Part Number conflicts when inserting a part.

If you insert a read-only document (a Part for instance) in a product, the read-only flag of during the current session. If you save this product, close it and reopen it, the read-only information on this Part is no

Open the ManagingComponents02.CATProduct document.

1. In the Specification Tree, select ManagingComponents02 and click the Insert Existing Com Existing Component dialog box is displayed.

2. Select CRIC_TOP.CATPart from the C:\Program Files\Dassault Systemes\B04doc\online\ps Open. The CRIC_TOP (CRIC_TOP.1) is created in the Specification Tree and the Part is dis
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3.

Depending on the CATIA license you have, you can insert the following components in a CATProd • CATPart (*.CATPart) • V4 session (*.session) • CATProduct (*.CATProduct) • V4 model (*.model) • V4 CATIA Assembly (*.asm) • cgr (.cgr; no specific lic • CATAnalysis (*.CATAnalysis) • wrl (.wrl; no specific lic

If the Part, Product, model or cgr you insert into an assembly has the same Part Number as the o Part Number conflict dialog box appears.

For more information about inserting and saving a component with the same name as another on Infrastructure User's Guide chapters: • •

Document: in a file-based environment, a document is identified by its name and an intern Saving Existing Documents: if both files have the same UUID (Unique Universal IDentifier) you will not be able to open the other.

If you see this warning when inserting an existing document in an assembly:

it means that the current settings, "Linked Document Localization" in Tools -> Options -> Genera insertion of this document.

To make the insertion of the existing document possible, please modify these Document Location General -> Document: Linked Document Localization) so that the next opening of the assembly e inserted document. For more information about these settings, please refer to Customizing -> Customizing Setti Document Localization in the CATIA - Infrastructure User's Guide.
Part Number conflicts when inserting a model
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1. Open PartNumberConflict1.CATProduct.

2. Insert CARBODY.model into PartNumberConflict.CATProduct. The following dialog box is di

There is a Part Number conflict because the new component you insert will be in the same docum component Body1 is not a document). CARBODY.model is directly under PartNumberConflict1.CAT This Part number conflicts panel provides information about: • the Part number generating the conflict: CARBODY
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• • •

the path of the document generating the name conflict: C:\TEMP\CARBODY.model the path of the selected source: C:\TEMP\CARBODY.model the Source already existing inside the root product: E:\www\PstEnglish\pstug.doc\src\samples\PartNumberConflict1.CATProduct

You have three solutions: •

Rename...: click the Rename button and the following dialog box is displayed. You can en

Click OK. In the Specification Tree, you can see PLANEBODY.model under PartNumberConflict.C
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With this Rename option, you create a new reference of CARBODY.model with another Part Numb •

Reconnect... : click the Reconnect button to reconnect the two entities of CARBODY.mod

Both entities (CARBODY.model) are overlapping in the geometry space. As a consequence, ther CARBODY.model in the Basic View window.
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•

Automatic rename... : click the Automatic Rename button to have the Part Number chan

104

Basic Tasks

• For our second example, close PartNumberConflict1.CATProduct without saving. 1. Reopen it. 2. Insert CARBODY.model into Landing_Gear.CATProduct. There is no Part Number conflict b different from the one of CARBODY in Body1. A new local reference has been created.
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3. For our third example, close PartNumberConflict1.CATProduct without saving. 1. Reopen it.

2. Insert CARBODY.model into Body1.CATProduct. There is a Part Number conflict because th the same document Body1.
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3.

Part Number conflicts when inserting a part

1. Open PartNumberConflict1.CATProduct.

2. Insert Landing_Gear_Piston1.CATPart into PartNumberConflict.CATProduct. The following d

The conflict is due to the presence of the same Part Number (Piston) in Piston and Landing_Gear_ the Automatic Rename option) the new instance Landing_Gear_Piston1. You have the same conflict if you insert Landing_Gear_Piston1.CATPart into PartNumberConflict1 If you want to insert the exact copy of this Part, Piston, the following panel will be displayed:

You are not allowed to open the same Part in the same document. For more information, another functionality is available in the Assembly workbench: Inserting an Positioning, in the CATIA - Assembly User's Guide.
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Replacing Components
Replacing a Component

The first task, Replacing a Component by another one in Session, consists in replacing a compo showing the impacts of this action. Using the Replacement Component command means replacing component with another.

The second task, The Impacts of the Replace Command, explains what can be the impacts of re component whose Part Number is same as the replaced element, and what can be done to solve t

The third task Replacing a Specific Instance or All Instances of a Reference, shows you that you several instances. The process is the same but when a component dialog box is displayed, you se component of your choice and tick the MultiInstances box in order to replace all instances.

Within an assembly, two components can have the same Part Number and be the Instances (1 a example below) of two References only if their References are inserted in two different document assembly levels, Local References). For instance: • • occurrence 1 is an Instance of CARBODY Reference in Landing_Gear document. occurrence 2 is an Instance of CARBODY Reference in PartNumberConflicts1 document.

A Local Reference is a Reference that can only be used in its own document. This is what we call Reference in a CATProduct. For more information about Local References, please refer to Naming a product. Therefore, if the Replace All Instances functionality is applied to one of these instances (1), it wil both Instances and the behavior will be the same like the common Replace:
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For more information about this example, please refer to Inserting Existing Components.

A V4 model is not a Product, therefore it is considered as a Representation, a CATShape. A model is inserted in a product structure by means of a local Reference created in this particular model is a representation attached to this Reference. For more information, please refer to Manag Representations.

Replacing a component means that: you are replacing a Reference by another Reference and y keeping the same Instance. The Instance Name is the data of an Instance; it is not changed aft Replace operation, so that links (External References) are not broken. And you are allowed to rec links with the new Reference.

For more information about modifying Instance Name, please refer to Naming or Renaming a pro (Instance or Reference).
Replacing a Component by another one in Session

If you want to replace your CATIA documents by downloaded ones, you need to activate the follo in Tools -> Options -> General -> Document -> Document Environments - Loaded document: Allo
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Open the AnalyzingAssembly02.CATProduct.

1. Right-click CRIC_SCREW (CRIC_SCREW.1) and the Replace Component contextual comma following panels are displayed:
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2. Click Cancel in the file Selection window. The Browse panel is still available. 3. Click the Loaded document icon. A Session document window appears:
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4. Select one of the downloaded documents, for instance: Subset1.CATProduct. An Impacts o window is displayed, showing you what can interfere with the other downloaded document information about the impacts on replace, please refer to the following section.

5. In the Impacts on Replace, click OK if all the replacing impacts have resolved and you obt
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The Impacts of the Replace Command

Open the ReplaceImpacts.CATProduct document.

Note: depending on the document environments you have allowed in the Document settings, an panel may appear simultaneously to let you access your documents using an alternate method. F information, refer to Opening Existing Documents Using the Browse Panel.
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1. Select PartWithImpacts (PartWithImpacts.1) and click the Replace Component icon Selection and Browse panels are displayed:

.T

2. Click Cancel in the File Selection panel; the Browse panel becomes activated. Or if you select Support1.CATPart for instance, in the File Selection panel, and click the Open button, the Browse panel disappears and, An Impacts on Replace panel appears:

Therefore, you do not need to follow the steps 3 and 4.
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3. Click the File icon and another File Selection window appears. 4. Select Support1.CATPart for instance. An Impacts on Replace panel appears:

This panel shows you the impacts of the Replace command on PartWithImpacts.CATPart. You can impacted objects (2 Publications, 1 External Reference and 1 Constraint) that can be re-connecte have access to the following information: • • • Type of the impacted objects (Publication, Contextual Design Connection) Name of the impacted objects (which is connected to PartWithImpacts.CATPart) Source or path of the impacted objects

You can interrupt the Replace operation by clicking the Cancel button. 5. There is a question in the panel:

By default, the YES option is checked. It means that all the instances will be replaced (and the number conflict panel does not appear because it is no longer needed).

If you click NO, only the selected instance will be replaced but, in the case of a Part Number co the Part Number Conflict dialog box appears. For more information about Part Number Conflict, please refer to the following scenario.
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6. Click OK and the Impacts on Replace dialog box disappears. You can visualize the impacts Geometry and in the Specification Tree.

7. Update your document and the following warning points out the impacted objects: Surface has its External Reference.
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You can however use the replace command on the objects that may be impacted. The links can b but not necessarily broken.

8. Click Close. The symbol next to the External Reference means that the part is not conn the correct External Reference. The other Publications with a broken link are represented w yellow exclamation mark meaning that the link with the root document has been lost.
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About Reference / Reference link: If the replaced Reference is pointed by a Reference / Reference link, this link is not impacted nor consequence the replaced Reference will not be unloaded.

Replacing a Specific Instance or All Instances of a Reference
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This task consists in replacing All Instances of a reference and a Specific Instance.

As it was described in the previous section the user activates the Replacement Component icon one component with another. This command automatically chooses the first instance of the objec going to be replaced. Open the 16cubes.CATProduct document:

This document contains two identical CATProducts: 8 cubes (8 cubes.1) and 8 cubes (8 cubes.2). CATProducts have the same CATParts: Cube (Cube.1) and Cube (Cube.2).

119

project

1. First of all, select Cube (Cube.1) and click the Replace Component icon box is displayed, select Cube2.CATPart and click Open:

. The File Selec

2. Click Open and the Impacts on Replace dialog box appears, with the following message:
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If you choose to replace Cube(Cube1.1) with Cube2(Cube1.1), there is a Part Number conflic because both entities have the same Part Number (Cube). Therefore, if you click:

• YES, all the instances will be replaced (and the Part Number conflict panel does not appea because there is no longer any conflict). • NO, only the selected instance will be replaced but, in the case of a Part Number conflict, t following dialog box appears:

3. Select Yes and click OK and a warning tells you that the component you are inserting is re

4. Click Close.

There is no Part Number conflicts panel (no impact on Cube (Cube.1)) because the replacing component, Cube2.CATPart, does not create any conflict since all the "cube" Part Numbers have replaced:
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Wherever the element's instance is in the product, it is replaced by the new component. In our example, the Multi-Instances functionality looks for all the instances of the reference Cube (Cub in the product and replaces them in the whole document. 5. Close 16cubes.CATProduct without saving it. Re-open it. 6. Repeat the same operation: select Cube (Cube.1) in 2cubes (2 cubes.1) and click the Rep Component icon .

7. In the File Selection window, select Cube2.CATPart and click Open: the Impacts on Replac appears. 8. Click No to replace only one instance:
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9. Click OK button. And two panels appear:

• the Incident Report: it is a warning telling you that the component you are inserting is rea only. Click Close.

• the Part number conflict panel; you can Rename (or use the Automatic rename option) th instance Cube2.CATPart so that there is no longer conflict with the other Part Numbers ( do not replace):

10. Enter a new Part Number (CubeBis) and select this line (Cube) and click the Rename butto Part Number panel appears.

11. Click OK. In the Part number conflicts, you can see that the name of the Part Number is no instead of Cube (for Cube2.CATPart).
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12. Click OK and you obtain:
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As a consequence, only a Specific Instance, Cube (Cube.1), is replaced by Cube2.CATPart (wh Number is different from the one of Cube (Cube.1)) in the Specification Tree and in the Geometry Note that the last entity of Cube (Cube.1) has not been replaced by Cylinder01.CATPart because instance is not at the same level:

For more information about Part Number conflict, please refer to Insert Existing Component.

125

project

Replacing a Specific Instance or All Instances of a Reference
This task consists in replacing first, a Specific Instance, and finally All Instances of a reference. As it was described in the previous section, Replacing a Component, the user activates to replace one component with another. This the Replacement Component icon command automatically chooses the first instance of the object that is going to be replaced. Open the 16cubes.CATProduct document:
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This document contains two identical CATProducts : 8 cubes (8 cubes.1) and 8 cubes (8 cubes.2). Both CATProducts have the same CATParts: Cube (Cube.1) and Cube (Cube.2).
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1. First of all, select Cube (Cube.1) and click on the Replace Component icon . The Replace Component dialog box is displayed, select Cylinder01.CATPart and click Open:

2. Click Open and the Impacts on Replace dialog box appears, with the following message:

3.
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If you choose to replace Cube(Cube1.1) with Cube2(Cube1.1), there is a Part Number conflict because both entities have the same Part Number (Cube). Therefore, if you click YES, all the instances will be replaced (and the Part number conflict panel does not appears because it is no longer needed). If you click NO, only the selected instance will be replaced but, in the case of a Part Number conflict, the following dialog box appears. For more information about this Part number conflict, please refer to: • • Replacing a Component: Replacing a Specific Instance or All Instances of a Reference. And Insert Existing Component.

You can Rename (or use the Automatic Rename option for) the new instance Cube2.CATPart.
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3. If you click No, you replace only one instance. As a consequence, a Specific Instance, Cube (Cube.1), is replaced by Cylinder01 (Cube.1) in the specification tree and in the geometry area:

Note that the last entity of Cube (Cube.1) has not been replaced by Cylinder01.CATPart because the entity's instance is not at the same level. 4. Close without saving, re-open the 16cubes.CATProduct document. 5. Repeat the same operation: Select Cube (Cube.1) and click the Replace . The Replace Component dialog box is displayed, select Component icon Cylinder01.CATPart and click Open. The Impacts on Replace dialog box appears with the following message:
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If you click Yes, all the instances of Cube (Cube.1) are replaced by Cylinder01.CATPart: the last entity of Cube (Cube.1) in the Specification Tree is also replaced by Cylinder01.CATPart.
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Wherever the element's instance is in the product, it is replaced by the new component. In our example, the MultiInstances functionality looks for all the instances of the reference Cube (Cube.1) in the product and replaces them in the whole document.

132

Basic Tasks

Replacing Components
This task shows you how to replace components into an assembly. In an assembly you may replace: A component by a component completely different (a jack by a wheel for example). A component by a component from the same family (a gearbox by another for example). Both cases the constraints reconnection is only warranted either: Component's product structure is the same. Instance's names of products in the replacing component are the same. Constraints reference the same published

elements. See Reconnecting Constraints. 1. Select a component in the specifications tree.

2. Click the Replace Component icon toolbar.

in the Product Structure Tools

Editing Components
3. Click OK. Pic1 has disappeared and it is no longer updated:
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4. If you want to save these CATProducts and CATParts, select the File -> Save Management... command:
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Basic Tasks Therefore you will be able to modify independently from the other parts. References become "Isolated":

For more information about this func refer to Isolate Part.

This task lists the ways of editing components in an existing assembly: • • • • • The Cut command removes the selected component instance and puts it in the clipboard. The Copy command puts a copy of the selected component instance into the clipboard. The Paste command creates a new component instance from the clipboard. The Delete command removes the selected component instance. For more information about the deletion of the instance of a contextual CATPart, please see below. The drag and drop capability allows you to copy or move one component to another.

For each edition operation you must select the components in the specification tree. Remember that the components you wish to move or paste may have one or more constraints. Once the component is moved or pasted, the constraints may be broken. See also Copying and Pasting Objects CATIA - Infrastructure User's Guide.

What happens when you delete the Instance of a Contextual Part
This task shows you how a contextual part can be modified by a Delete operation and it can be saved in the Save Management panel.
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And you can visualize both ChangeCtx.CATProduct and Poteaux.CATProduct:
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This symbol next to Pic1 (Pic1.1) in the Specification Tree represents a part and the green gear signifies the "original" instance of a part that is contextual (driven by another part, built with another part's data) in a CATProduct. Pic1 (Pic1.1) is a contextual part and it has been built with Upper (Upper.1) and Lower (Lower.1). Upper (Upper.1) and Lower (Lower.1) are selection instances (External References) and Pic1 (Pic1.1) depends on them, which explains why the External References file appears under Pic1 (Pic1.1) in the Specification Tree. If you modify Upper (Upper.1) and/or Lower (Lower.1), there will be some impacts on the contextual part. 1. In Masters.CATProduct, select Upper (Upper.1) and delete it. The following dialog box is displayed:

2. Click the More >> button in order to see the names of the CATIA elements affected by deletion: • Pic1\PartBody\Pad.1\ : the pad will disappear because it has lost its External References. • Pic1\External References\Surfaces.2 : Surfaces.2 is impacted because Upper.1 is an External Reference, helping to build Pic1.CATPart.
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Modifying Component Properties

This task shows you how to access and edit component properties. You can redefine and even crea any time. Open the ManagingComponents01.CATProduct document.
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1. Right-click CRIC_AXIS (CRIC_AXIS.1) in the specification tree and select Properties from th menu. You can select the component in the specification tree or in the geometry. This command is also available from the Edit menu. The Properties dialog box is displayed. Four tabs are available: • • • • Product, Graphic, Mechanical, Drafting.

2. Click the Product tab in the Properties dialog box. • This tab displays the Component properties, Link to reference, Product properties and the Define other properties... button.

•

On the right side, next to Instance Name and Part Number, you can see this symbol: .
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In a CATProduct, the Instance Name must be unique at one Assembly level. If you enter the sa Name as the existing one in the document, at the same level, there will be a red light in the Instan , with the following message : "The identifier xxx.n is already used".

Neither special characters "!" and ":" nor an empty name " " and blank character at end of should be used in the: • • • Instance Name Part Number Publication.

The Component frame displays: • Instance name, the name of the selected component • Description, the description of the selected component. The Product frame displays: • • • • • • Part Number, the name of the product Revision Definition Nomenclature Source Description.

The combo box displays the following options: • unknown, for an unknown product • made, for a product made by the user • bought, for a product bought by the user. 3. Click the Define other properties... button. The dialog box that appears lets you add the properties of your choice.
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Here is the list of the new parameters you can add: • • • • • • • • • • • • • • Real Integer String Boolean Length Angle Time Mass Volume Density Area Inertia Moment Energy Force • • • • • • • • • • • • • • Inertia Massic Flow Moment Pressure Angular Stiffness Temperature Linear Mass Linear Stiffness Volumetric Flow Frequency Electric Power Voltage Electric resistance Electric intensity

4. Select the parameter you need next to New Parameter of type. For example, select String, Parameter of type. This parameter displays in the property name frame. 5. Rename the parameter as Manufacturer in the Edit and value field. 6. Enter French Company in the value field. The dialog box now looks like this:
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Clicking Delete property deletes the selected parameter. Clicking External properties... accesses additional properties defined in a .txt or .xls file. The applic these files provided they have a tabulated format. To do this, select the desired file, trame.txt for example, in the Open File dialog box that appears:

Click Open and the information contained in trame.xls are stored in the Define other properties dia
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7. Click OK in the Define other properties dialog box to validate the creation of the property.

A new section Product: Added Properties appears in the Properties dialog box. This section display properties you have created, even those described in the .txt or .xls files.
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Once created, you can access these properties via the Bill of Material too. 8. Click the Graphic tab in the Properties dialog box.

This tab lets you display the Graphic properties of the component. To know how to apply graphic p to CATIA- Infrastructure User's Guide Version 5. 9. Click the Mechanical tab to display the mechanical properties of the selected component: • Characteristics: Volume, Mass and Surface. The fields are not editable. Note that the mass because no material has been applied. For more about materials, please refer to CATIA-R Time Rendering User's Guide. • Inertia center. The corresponding fields are not editable. • Inertia Matrix. The corresponding fields are not editable.
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10. Click the Drafting tab in the Properties dialog box. 11. Specify the properties that should be used for this component when generating views: o o o Do not use when projecting: the component will not be projected in views.

Do not cut in section views: the component will not be cut when projected in section

Represented with hidden lines: the component will be represented with hidden lines.

Note that these properties may be overloaded by editing view properties directly in the Drafting workbench.
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12. Click OK to validate the operation.

Deactivating / Activating a Component

This task will show you how to deactivate a component from an assembly. Deactivating a compon removing its geometry.
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In the same CATIA session, open the following documents: • • •

AnalyzingAssembly02.CATProduct Subset1.CATProduct Product4 that you have created by selecting File -> New... Product and by inserting the ex component, Subset1.CATProduct.

In the menu bar, select Window -> Tile Vertically in order to be able to visualize the three docum same CATIA window.

Subset1.CATProduct exists in AnalyzingAssembly02.CATProduct, Subset1.CATProduct and Produc

1. In AnalyzingAssembly02.CATProduct, select CRIC_BRANCH_1.CATProduct (in Subset1.CAT

2. Right-click it and select the CRIC_BRANCH_1.1 object -> Activate/Deactivate Component command.
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Note that all the instances of CRIC_BRANCH_1.CATProduct disappear in the geometry space and symbol is transformed into: .

CRIC_BRANCH_1.CATProduct has been deleted in AnalyzingAssembly02.CATProduct, Subset1.CAT and Product4. Its shape is deactivated and there are no traces of its specifications in the Bill Of M (Analyze -> Bill Of Material).
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Deactivating a Component means deleting its representation and instance. The operation is simul all the CATIA documents containing this element, CRIC_BRANCH_1.CATProduct, because it is the document. This operation is shared by all the instances of this part. You can apply this functionali CATProducts, CATParts and models.

This command does not free the memory and the symbol in the specification tree shows you that possible for you to reactivate it by the reverse operation:

Right click it and select the CRIC_BRANCH_1.1 object-> Activate/Deactivate Component context command.

3. In AnalyzingAssembly02.CATProduct, select Subset1.CATProduct, right click it and select t object-> Activate/Deactivate Component contextual command.
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Only one component is deactivated in AnalyzingAssembly02.CATProduct because it is not a refere instance.

Subset1.CATProduct is no longer referenced in the BOM:
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Note that this operation cannot be applied on a root product.
Comparison with closely related functionalities (illustrated by the table below):

• • • •

Hiding objects (No Show): does not free the memory; The object is no longer displayed: it transferred into the No Show space. But it is still visible in the BOM. Unloading a component: geometry disappears, only the instance is left and the reference n exists, but you have access to its information in the BOM. It frees the memory. Deactivating a Node: the representation is masked in the geometry and the specification t you can find its data in the BOM. Deactivating a Terminal Node: the representation of Terminal Nodes disappears from the specification tree and the geometry. Under a selected node, the elements of the very last masked.
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NO SHOW Hiding Components UNLOAD Unloading a Part (activated Cache, Visualization mode) UNLOAD Unloading a Product (Visualization mode) UNLOAD Unloading a Part or Product (Visualization mode) Deactivating a Node Deactivating a Terminal Node

Visualization Accessibility Effe BOM (Shape (possibility of applying aggr (Bill of Material) Representation) constraints) ob YES, you can apply NO, the constraints between icon NO YES the hidden object and propaga the other components aggregat in the Show space. YES YES YES

The ag object visible n

NO

NO

NO

Unl

NO

NO

NO YES, you can apply a constraint even if the shape is deactivated. YES

Unl

NO NO

YES YES

N

N

Deactivating a Component

NO

NO

NO

The child visibl Specific and Geo

Collaborating
Exporting Measure Inertia Results
This task shows you how to export both 3D and 2D inertia results to a text file. Insert the Body1.cgr and the Body2.cgr documents. They are to be found in the online documentation file tree in the common functionalities samples folder cfysm/samples
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1. Select the root product and click the Measure Inertia icon. The dialog box expands to display the results for the selected item. 2. Click Export to write the results to a text (*.txt) file. Results shown in the Measure Inertia dialog box only are exported. Exported results are given in current units. 3. Identify the file name and location in the Export Results dialog box that appears, then click Save. Notes: o The examples given below concern 3D inertia results.

o

If an assembly comprises sub-products or a part comprises part bodies, individual results for all sub-products or part bodies are also exported and written to the text file.

4. If the principal axes A are exported, bounding box values are also exported.

where BBOx,y,z defines the origin and BBLx,y,z the length along the corresponding axis.
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Note: When importing the text file into an Excel spreadsheet, do not forget to identify the pipe character (|) used as separator in the Text Import Wizard dialog box. 5.
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Exporting Section Results

You can save section results in a variety of different formats using: • • The Export As command. This command is particularly useful for exporting results to CATIA V4. The Capture command.

Also read: • • More About the CATPart Working with a Cache System

This task illustrates how to export sectioning results in a number of different formats using the Export As command. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr. They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning in the DMU Space Analysis toolbar and create the desired icon section plane, slice or box and corresponding section.

2. Click the Result tab in the Sectioning Definition dialog box. 3. Click the Export As icon .The Save As dialog box appears.

4. Specify the location of the document to be saved and, if necessary, enter a file name.
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5. Click the Save as type drop-down list and select the desired format. You can save sectioning results as: o o o a V4 model (.model) a V5 CATPart (.CATPart) a V5 CATDrawing (.CATDrawing) In this case, polylines are generated. Note also that the axis system corresponds to that of the section plane. DXF and DWG formats (.dxf/.dwg) a STEP document (.stp) an IGES document (.igs) a Virtual Reality Modeling Language (VRML) document (.wrl).

o o o o

6. Click Save to save the results in a file in the desired format. Note: If you set the DLName document environment (Tools -> Options > General -> Document) as your current environment, clicking Export As will open the DLName dialog box instead of the usual Save As dialog box. The DLName document environment lets you restrict the access to specific folders referenced by logical names referred to as 'DLNames'. Each folder is assigned a logical name. In this mode, you can only access documents in folders referenced by DLNames. For more information on the DLName document environment, see the Infrastructure User's Guide. 7. Exit the Sectioning command when done.

More About the CATPart
For each element sectioned, a topologically correct spline is generated under the Open_body. Each spline is obtained by interpolating all the points making up the element sectioned. The resulting spline may not be smooth.
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These curves can then be used, for example, to create features: • • • to update your CATPart document Select the Update icon Create a sketch from your curve using the Project 3D Elements command in the Sketcher workbench Create your feature, for example a pad.

Note: Section result colors are exported when section results are saved as CATPart documents.
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Working with a Cache System
If you are working with a cache system, you must select the Save lineic elements in cgr check box to be able to properly save your section result in V4 model, V5 CATPart, STEP, IGES, and VRML formats. This will save wireframe section results. If you do not do so, the document will be empty. • Save lineic elements in cgr option is located in the General box of the Cgr Management tab, Tools->Options->Infrastructure->Product Structure

Creating Annotations
Creating Annotations
Create a Text With Leader: click this icon, select a face and enter your text in the dialog box. Create a Flag Note With Leader: click this icon, select the object you want to represent the hyperlink, enter a name for the hyperlink and the path to the destination file.

Creating a Text with Leader
This task shows you how to create an annotation text with leader A text is assigned an unlimited width text frame. You can set graphic properties (anchor point, text size and justification) either before or after you create the free text. You can change any text to another kind at any time. Open the Common_Tolerancing_Annotations_01.CATPart document. • Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D Annotation.
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1. Double-click the FrontView.1 annotation plane to activate it.

2. Click the Text with Leader icon: 3. Select the face as shown to define a location for the arrow end of the leader.

If the active view is not valid, a message appears informing you that you cannot use the active view. Therefore, the application is going to display the annotation in an annotation plane normal to the selected face. For more information, see View/Annotation Planes. The Text Editor dialog box appears.
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4. Enter your text, for example "New Annotation" in the dialog box.

5. Click OK to end the text creation. You can click anywhere in the geometry area too. The text appears in the geometry. The text (identified as Text.xxx) is added to the specification tree.

The leader is associated with the element you selected. If you move either the text or the element, the leader stretches to maintain its association with the element. Moreover, if you change the element associated with the leader, application keeps the associativity between the element and the leader. Note that using the Text Properties toolbar, you can define the anchor point, text size and justification. You can move a text using either the drag capability. Note also that you can resize the manipulators For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.
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Creating a Flag Note with Leader
This task shows you how to create an annotation flag note with Leader. A flag note allows you to add links to your document and then use them to jump to a variety of locations, for example to a marketing presentation, a text document or a HTML page on the intranet. You can add links to models, products and parts as well as to any constituent elements. A flag note is assigned an unlimited width text frame. You can set graphic properties (anchor point, text size and justification) either before or after you create the free text. You can change any flag note to another kind at any time. Open the Common_Tolerancing_Annotations_01.CATPart document. • Improve the highlight of the related geometry, see Highlighting of the Related Geometry for 3D Annotation.

1. Double-click the FrontView.1 annotation plane to activate it.

2. Click the Flag Note with Leader icon: 3. Select the face as shown to define a location for the arrow end of the leader.
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If the active view is not valid, a message appears informing you that you cannot use the active view. Therefore, the application is going to display the annotation in an annotation plane normal to the selected face. For more information, see View/Annotation Planes.

The Manage Hyperlink dialog box appears. You may specify the flag note's name link in the Name field. You may specify one or several links associated with the flag note in the URL field clicking the Browse... button. In the Link to File or URL list you can see the list of links. To activate one of them, select it and click the Go to button. To remove one of them, select it and click the Remove button. To edit one of them, select it and click the Edit button.
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4. Enter your flag note name, for example "New Annotation" in the dialog box and specify a link: www.3ds.com

5. Click OK to end the flag note creation. You can click anywhere in the geometry area too. The flag note appears in the geometry.

The leader is associated with the element you selected. If you move either the text or the element, the leader stretches to maintain its association with the element. Moreover, if you change the element associated with the leader, application keeps the associativity between the element and the leader. Note that using the Text Properties toolbar, you can define the anchor point, text size and justification.
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The flag notes (identified as Flag Note.xxx and its name between brackets) are added to the specification tree in the Notes group. You can move a flag note using either the drag capability. Note also that you can resize the manipulators For more information, refer to Customizing for 3D Functional Tolerancing & Annotations.

Managing Documents
Opening Existing Documents
This task shows you how to open an existing document when Version 5 is already running. Several methods are available to open an existing document: • • • • • • • File->Open... command Insert->Existing Component... command Start->Documents command on Windows Windows Explorer or My Computer (Windows) or File Manager (UNIX) drag and drop a document icon Open in New Window contextual command Open the Pointed Document contextual command

What you should know before you start
• • Bear in mind that Dassault Syst mes guarantees upward compatibility for Version 5 data As far as downward compatibility is concerned, Version 5 data can be reused from one service pack to another, provided that they belong to the same release. If the Version 5 data do not belong to the same release, they can still be reused in case of CATPart documents but this implies the use of a specific process detailed in Using the Version 5 Compatibility Batch You will not be allowed to open a document created using Version 5 if its name contains national characters or forbidden special characters. For a reminder, refer to About Filenames When a .CATPart document containing a Sheet Metal Design feature is opened on a configuration level (i.e. P1, P2 or P3) lower than the level on which the feature was created, all the icons of all the workbenches available in your configuration are grayed out. Note that this may also occur when working with Generative Shape Design or Part Design features.

• •

If you wish to access V4 data such as V4 models, PROJECT files and library objects on Windows or UNIX or access CDMA objects on UNIX you can do so provided you purchase the
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Basic Tasks V4 Integration product. V4 models, PROJECT files or library objects residing on UNIX can be accessed from Windows using the http protocol. (Make sure beforehand that an http server has been installed on the computer where the V4 data resides. The address to be specified should look something like this: http://UNIXserver: port/V4datalocation

Using the File ->Open... Command
1. Click the Open icon keyboard shortcut). or select the File->Open... command (or the CTRL+O

The following dialog box appears:

Note: depending on the document environments you allowed in the Document settings, an additional window may appear simultaneously to let you access your documents using an alternate method. For detailed information, refer to Opening Existing Documents Using the Browse Window. 2. In the File Selection box, select the file location.
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3. Click the Files of type: list.

Check the "Show Preview" option to display a preview of the selected file (only on Microsoft Windows workstations).
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4. Select the document type. The list of document types you can open depends on the configurations/products installed and for which you have a license. Note: On UNIX workstations, the File Selection dialog box lets you sort your files by date or size. This dialog box also lets you rename or delete the selected file/folder by clicking the Rename or Delete contextual command. After clicking Delete, a confirmation dialog box appears: just click OK to delete the selected item. When renaming a file or folder, if the new name you entered is already used, the item is not renamed and a warning message is displayed. The following list contains all possible document types (in alphabetical order): • All Bitmap Files Lets you browse raster formats (more than 70 formats are supported) from within a session, without having to use another application • All CATIA V4 Files Lets you open V4 documents such as .model, .session or .library files • All CATIA V5 Files Lets you open V5 documents such as .catalog or .CATAnalysis files, for example • All CATIA CAA Files 167

project Lets you browse CAA files such as .CAABsk or .CAADoc files • All Standard Files Lets you browse files such as .igs, .wrl, .step or .stp files • All Vector Files Lets you browse files such as .cgm, .gl, .gl2 or .hpgl files • 3dmap Lets you browse 3dmap (i.e. spacemap representation) files. Note that you cannot open these files on AIX platforms • act Lets you browse process libraries which contain a number of different classes or types of activities interactively defined by the user. For more information, see "Managing a Process Document with Process Libraries" in the DELMIA - DPM Process Planner User's Guide • asm V4 Assembly Modeling document saved as an Assembly Design document i.e. CATProduct. For more information, see the Version 5 - Assembly Design User's Guide • bdf Allegro specific format. For more information, see the Version 5 - Circuit Board Design User's Guide • brd Mentor Graphics specific format • catalog Catalog documents. For more information, see the Version 5 Component Catalog Editor User's Guide • CATAnalysis Analysis document. For more information, see the Version 5 - Generative Structural Analysis User's Guide • CATDrawing Generative Drafting or Interactive Drafting document. For more information about the Generative Drafting and Interactive Drafting workbenches, see the Version 5 - Generative Drafting User's Guide and Version 5 - Interactive Drafting User's Guide • CATfct Feature Dictionary and Business Knowledge Template files. Refer to Starting the Feature Dictionary Editor and to the Version 5 - Business Process Knowledge Template User's Guide • CATMaterial Material library. For more information, see the Version 5 - Real Time Rendering User's Guide • CATPart Part Design document. For more information about the Part Design workbench, see the Version 5 - Part Design User's Guide • CATProcess Process document. For more information, see the Version 5 - Prismatic Machining User's Guide • CATProduct Assembly Design document. For more information about the Assembly workbench, see the Version 5 - Assembly Design User's Guide • CATShape Physical shape of the part. CATShape files can be exported to STEP or 3D
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Basic Tasks IGES. For more information, refer to "Managing Shapes" in the Version 5 Product Structure User's Guide CATSystem Functional system management file. For more information, refer to the Version 5 - Product Function Definition and Version 5 - Product Function Optimization User's Guides cdd CATIA-CADAM file cgm ANSI/ISO standardized platform-independent format used for the interchange of vector and bitmap data dxf/dwg Autocad DXF and DWG formats. Creates a CATDrawing document. For more information, see "Exporting a CATDrawing into a DXF/DWG File" in the Version 5 - Generative Drafting User's Guide idf Document generated by an IDF application. For more information, see the Version 5 - Circuit Board Design User's Guide ig2 2D IGES file, saved as a CATDrawing document. For more information, see "Importing a 2D IGES File into a CATDrawing" in the Version 5 Data Exchange Interface User's Guide igs IGES file saved as a Part Design document, i.e. a CATPart document. For more information, see the "2D IGES Interface" and the "3D IGES Interface" sections in the Version 5 - Data Exchange Interface User's Guide jpg Lets you browse JPEG files from within a session, without having to use another application library V4 library document storing objects such as details, symbols, NC mill and lathe tools and beam sections. For more information, see the Version 5 - V4 Integration User's Guide model V4 model document. For more information about the V4 Integration workbench, see the Version 5 - V4 Integration User's Guide pdb PDB files picture Lets you browse CATIA Version 4 picture files from within a Version 5 session ps Lets you browse PS (PostScript) and EPS (Encapsulated PostScript) documents. Before opening a .eps document, you need to rename it with the extension ".ps". Note that to be able to modify a .ps document, you need to import it in the Drafting workbench using the Tools->Import External Format... command: this converts the document to a Drafting object which can then be edited and saved as a .CATDrawing document rgb SGI format for pixel images session V4 session document containing several CATIA V4 models converted to a

•

• • •

• •

•

• •

• • • •

• •
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project CATProduct document. For more information about the V4 Integration workbench, see the Version 5 - V4 Integration User's Guide stbom Imports a SmartBOM (Bill Of Material) Briefcase in Version 5. For more information, refer to "Export SmartBOM from Version 5" in the Version 5 Product Structure User's Guide step, STEP, stp and STP Creates a CATProduct document. For more information, see "Importing a STEP AP203 Document" in the Version 5 - Data Exchange Interfaces User's Guide stl Lets you browse stereolithography documents. For more information, see the Version 5 - STL Rapid Prototyping User's Guide and to "Exporting CATPart Data to an STL File" in the Version 5 - Data Exchange Interfaces User's Guide tdg and TDG STRIM/STYLER files tif Lets you browse TIFF files from within a Version 5 session, without having to use another application wrl Lets you browse VRML (Virtual Reality Modeling Language) files. Note that you cannot open these files on AIX platforms.

•

•

•

• • •

5. If you are sure you do not intend to modify the document in any way, you may want to open the document in read-only mode. If so, activate the "Open as read-only" option. The "Open as read-only" option is intended to prevent users from overwriting a document accidentally: when this option is activated for a document, you can read this document in your Version 5 session but you cannot save it unless you change the document path (by selecting another folder or accessing another document environment) or the document name (by entering another name in the File name field). However, keep in mind that this option does not supersede access right management functionalities provided by your operating system. When opening a document pointing to other documents with the "Open as readonly" option activated, the read-only mode only applies to the selected root document. The pointed documents will be loaded in read-write mode and may be loaded independently from the root document. 6. Click Open. In case an error occurs when opening a file (e.g. unknown document name, nonsupported file format, corrupted file, etc.), an Incident Report window opens. It displays the error history and indicates for each error its type, object and description. This history is maintained throughout the whole session, the errors being classified by degree of severity.

Using the Insert ->Existing Component... Command
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This command is only available in DMU Navigator. Refer to "Setting Up Your Session" and "Inserting Components" in the Version 5 - DMU Navigator User's Guide.

Using the Start->Documents Command on Windows
This task shows you how to access an existing document without running a Version 5 session. 1. Before you open a session, click Start and select Documents. 2. Select the document you wish to open. A Version 5 session is opened and your document is displayed.

Using the Windows Explorer or My Computer (on Windows) or the File Manager (UNIX)
This task shows you how to open an existing document via a document icon when no Version 5 session is already running. 1. Before you open a session, click My Computer or run the Windows Explorer and find the location of the document you wish to open. 2. Double-click the document icon. A Version 5 session is opened and your document is displayed. On UNIX, you can use the File Manager.

Dragging and Dropping a Document Icon
This task shows you how to open an existing document via a document icon when a Version 5 session is already running. 1. If a Version 5 session is already open, drag and drop the icon in your Version 5 application window. Your document is opened for editing. Note that this method is not available on IRIX.

Using the Open in New Window Contextual Command
This task shows you how to open an existing document in a new window. 1. If a document is already open in a Version 5 session, select the item you wish to open from the specification tree.
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2. Right-click then select the xxx object-> Open in New Window contextual command. The document associated to the selected item is opened in a new window. More about the Open in New Window command

•

•

In CATIA V5, each window is associated to a document. As far as volatile documents are concerned, they cannot be opened using the Open in New Window command (an error message is issued). For instance, you cannot open in a new CATIA V5 window a Product Root Class created in ENOVIA V5 because a "PRC" is an ENOVIA V5 concept which has no equivalent in CATIA V5 If you modify a document open in a new window then decide not to save the modification when closing the new window, this does not imply that the modification will not appear in the parent window: it only means that the document will not be saved at the end of the session. The reason is that the modification you made has been loaded in memory. Therefore, after closing the new window, the only way to restore the document in the parent window is to use the Undo command.

Using the Open the Pointed Document Contextual Command
This task shows you how to open a pointed document in a new window. 1. If a document is already open in a Version 5 session, select the item pointing to a referenced document from the specification tree. Note: this command is available for geometrical external references and external parameters only. For instance, you will be able to use this command when selecting a geometry pasted "As Result With Link" in a CATPart document different from the one in which it has been copied (the geometry is identified by the following symbol: ). 2. Right-click then select the xxx object-> Open the Pointed Document contextual command. The document pointed to by the selected item is opened in a new window.

Saving Existing Documents
This task shows you how to save an existing document.
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1. Click the Save icon or select the File->Save command (or the CTRL+S keyboard shortcut). A message appears in the status bar to confirm that the document is saved. If the document you are trying to save points to parts, a window will be displayed to warn you that these parts will not be saved unless you use the File->Save All command:

If you are trying to save a document that is currently modified and saved by another user, a message will appear to warn that your modifications will be lost if you proceed. When a document is saved, it is stored in the UTF8 Unicode format. This ensures that the data contained in it can be read on both Windows and UNIX whatever the session code page used. You can choose to set an automatic save for your file using the General tab of the Tools->Options... command. For more information, see Customizing General Settings.

More about the Save command
• When saving an existing file in another directory without changing the file name (which means that you have now two files), note that you will only be able to open one of these files at a time. If one of them is already open, you will not be able to open the other. The reason is that both files have the same UUID (Unique Universal IDentifier). To avoid this, each file must have its own UUID. This can be done by means of the File->New from... command. For detailed information, refer to Creating New Documents from Existing Documents • If you open a read-only document, make no changes then try to save it, no pop-up message will be displayed to inform you that the document is read-only. On the contrary, if you modify a read-only document then try to save it, a pop-up message will be displayed to inform you that the document cannot be saved with the same name because it is a read-only document.
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Saving Documents For the First Time or Under Another Name

This task shows you how to save a docum first time or under another name.

1. Select the File->Save As... comma
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2. In the Save As dialog box, specify of the document to be saved as w name and type.

As far as STL format files are concerned they cannot be saved using the Save A command when working in Wireframe mode. The reason is that STL files are generated from the visualization tessel and tesselation triangles are not available when switch to the Wireframe mode.

The "Save as new document" option let you save an existing document under a name but this new document will be giv new UUID (Unique Universal IDentifier) the document to be saved is a new document, this option is not displayed the Save As dialog box. Moreover, the "Save as new document" option is effective only when the docum is saved in its native format, i.e. when document type (displayed in the "Save type" field) has not been modified.
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3. Click Save.

If the name you give the file already ex the following message appears:

You will not be allowed to use national characters or forbidden special characte the document name. For a reminder, re to About Filenames.

On Windows, documents cannot be sto in a folder for which delete authorizatio not set.

Note that the Save As dialog box lets y rename or delete the selected file/folde clicking the Rename or Delete contextu command. After clicking Delete, a confirmation dia box appears: just click OK to delete the selected item. When renaming a file or folder, if the n name you entered is already used, the is not renamed and a warning message displayed.

More about the Save As mechanism

When you save a file by giving it the na of another existing file, this does not m that the new file is identical to the orig one. As a matter of fact, a file is identif by its name but also by its UUID (Uniqu Universal IDentifier) which differs from file to another (except when a file is a c of another one, for instance). To illustrate this, let's suppose a CAPro containing two CATParts, Part1.CATPar Part2.CATPart:
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1. Product1 and the two parts it po to are saved using the Save As.. command then the Product1 is closed 2. A new part is created using the >New... command 3. The new part is saved as "Part2 the same folder then Part2 is clo 4. When re-opening Product1, you informed that Part2 cannot be fo

The reason is that the new document s as "Part2" has been given a new UUID using the New... command and this new UUID is different from the one assigned the original Part2. Therefore, the link between Product1 and Part2 is conside as broken, even if a Part2.CATPart document do exist, because the origina Part2 does not exist anymore. If you want to reroute the link to the ne Part2.CATPart, you need to use the Edi >Links... command then the Replace button.

Managing Document Save

7. Click OK to conf irm. The Save Management... command will automatically save impacted files as well. If there are still unsaved files left when you click OK, the following message will be displayed:
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However, do not forget that two different documents open in session cannot have the same persistent location because the system cannot have two documents with the same identification. In this case, a warning will be issued and you will not be able to save conflicting documents. This may happen, for instance, when a new document has been assigned the location of another document already loaded in session (with overwrite request) either using explicitely the Save As... button, or using implicitely the Propagate Directory button.

More about the Save As mechanism
When you save a file by giving it the name of another existing file (using the Save As... command that lets you overwrite an existing file), this does not mean that the new file is identical to the original one. As a matter of fact, a file is identified by its name but also by its UUID (Unique Universal IDentifier) which differs from one file to another (except when a file is a copy of another one, for instance). To illustrate this, let's suppose a CATProduct containing two CATParts, Part1.CATPart and Part2.CATPart: 1. Product1 and the two parts it points to are saved using the Save As... button then the Product1 is closed 2. A new part is created using the File->New... command 3. The new part is saved as "Part2" in the same folder then Part2 is closed 4. When re-opening Product1, you are informed that Part2 cannot be found. The reason is that the new document saved as "Part2" has been given a new UUID when using the New... command and this new UUID is different from the one assigned to the original Part2. Therefore, the link between Product1 and Part2 is considered as broken, even if a Part2.CATPart document do exist, because the original Part2 does not exist anymore. If you want to reroute the link to the new Part2.CATPart, you need to use the Edit->Links... command then the Replace button.
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Before you start, note the following information: • • This command is relevant for loaded documents only. For unloaded documents, use the File->Send To command. This command cannot be recorded via Tools->Macro.

1. Select the File->Save Management... command. The following dialog box appears:

The Path column indicates all document that are currently used along with their paths. The State column indicates the original state of each currently used document. For instance, if a document has been modified since last load, the corresponding state (i.e. "Modified") is displayed in the State column. The Action column enables you to check the actions you are performing on your documents (save, modification, etc.). Bear in mind that the State column will keep on displaying the document original state and will not reflect the actions you performed. Below are listed the various states that may be assigned to a document: • New: identifies a newly created document. You have to select a file name in order to save it • Open: identifies a non-modified document open in your session • Modified: identifies a document which has been modified in your session • Modified by synchronization: identifies a document modified at opening in order to be synchronized with a modified pointed document • Read Only: identifies a modified and read-only document. You have to specify a new name for this document if you want to save it. Below are listed the actions that can be displayed in the Action column:
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• Open Read Only: identifies a non-modified, read-only document open in your session • Save: identifies a document that will be saved • Save Auto: identifies a dependent document that will be saved.

Note that modifications made to a CATPart do not propagate to its CATProduct and have no impact on the state of the CATProduct. Therefore, a "dirty" CATPart is identified as "Modified" whereas the CATProduct it is linked to is identified as "Open". The "Enable independent saves" option lets you save documents independently regardless of any existing links between files, i.e. dependent documents will not be automatically saved when the document they are linked to is saved. 2. Select the file you want to save. 3. Click the Save As... button to open the following dialog box:
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4. Indicate the name and destination folder of the new created file, respectively in the File name and Save in fields. 5. Click the Save button. When using the Save As... command for a .CATProduct document containing other modified components, these components will be assigned the "Save Auto" state and will be saved when clicking OK. However, some "document-to-document" links will not be taken into account, such as links that are not design prerequisites. For instance, when saving a .CATDrawing document pointing to a modified .CATPart document, the state of the .CATDrawing document remains unchanged. 6. Once you have saved a document in a new directory, you can use the Propagate directory button to save the files linked to this document into the same directory.
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Note that new documents with the "Auto Save" status are saved in the directory of the document selected in the list when clicking Propagate directory, Save or Save As.... If we take the above capture as an example, a new document with the "Auto Save" status would be saved in "E: users" since "Car.CATProduct" is selected.

To go back the document original state, select the document then click the Reset button.

The Save Management... command lets you save all your modified documents under a new name and a new location.

Saving Images to Other Formats
This task explains how to save images in the album to other formats. 1. Select the Tools->Image->Album... command to display the album. 2. Select the image(s) to be saved to another format. The formats to which you can save depend on the format (pixel or vector) of the image you selected.
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3. Right-click then select the Save As command. Note that depending on the image format you select, the Save As command may be grayed out. This is the case when right-clicking a MPEG or AVI file, for instance.
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4. Enter a name for the file. 5. Select a format from the list. The formats you can save to depend on the format (pixel or vector) in which the image was originally saved. For pixel images, the formats are: • • • • • • • • • • • • HP/RTL (UNIX only) JPEG Fair Quality (*.jpg) JPEG Medium Quality (*.jpg) JPEG High Quality (*.jpg) TIFF True Color (*.tif) TIFF Indexed Packbit (*.tif) TIFF True Color Packbit (*.tif) TIFF Indexed (*.tif) TIFF Grey Scale Packbit (*.tif) TIFF BW Packbit (*.tif) RGB (SGI Format) Not Compressed (*.rgb) Windows Bitmap (*.bmp).

For detailed information about JPG and TIFF format, browse the following Internet sites: http://www.jpeg.org and http://www.ijg.org http://partners.adobe.com/asn/developer/pdfs/tn/TIFFphotoshop.pdf A bitmap is a set of pixels arranged in lines and columns and is fully described by its width and height, its color depth (bits per pixel) and its compression scheme. The format common format is true color (24 bits per pixel). An additional color component, called Alpha component, may be used to define the transparency of each pixel. The bitmap format generally supports compression (either lossless or lossy). Some of these bitmaps are coded on 8 bits and the pixels are indexed on a color table, called the palette. The advantage of bitmap files is that they can reproduce complex scenes (for instance photographic or photo-realistic images) that could not be reproduced using basic geometrical shapes. The following table summarizes information about bitmap files and the various formats you can use to save your images in the album:
Bit depth 1 8 16 24 Compression 32 None RLE JPEG ZLIB CCITT Max. size in pixels Comments

BMP

X

X X

X X

X X

X

X

X X

2G*2G 64K*64K

JPEG X

Standard bitmap storage on MS-Windows Very few applications support the lossless JPEG mode
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Successor of the GIF format Supported by very few applications Very popular and general format recognized by most imaging applications

PNG RGB TIFF

X X X

X X X

X X X

X X X

X X X X X X X

X

2G*2G 64K*64K X 2G*2G

For vector images, the formats are: • Windows Metafile (Windows only) • PostScript: PostScript is a page description language that supports text, vector graphics and bitmaps. It is device-independent and implements an industry standard for communicating graphic information between applications and hardware devices such as printers. For detailed information about PostScript, browse the following Internet site: http://partners.adobe.com/asn/developer/pdfs/tn/PLRM.pdf • PDF: Portable Document Format is a platform-independent page description file format designed for platform exchange. It may contain text, vector graphics and bitmaps. For detailed information about PDF, browse the following Internet site: http://partners.adobe.com/asn/pdfl/PDFS/PDFLibraryFAQ.pdf

• HP-GL/2-RTL: Hewlett-Packard Graphics Language file format is an instruction set developped for controlling plotters. HP-GL, which as been developped for pen plotters, is now obsolete. HP-GL/2-RTL is an evolution of HP-GL providing more graphic primitives (such as polygons or curves) and a support for bitmaps. Vector files contain geometrical descriptions of the image elements.These elements may be lines, dots, rectangles, circles, polygons, splines, text with font information or bitmaps (only in metafiles) and are used to reconstruct the final image. Each element has its own attributes specifying its size, its relative position in the whole image, its color and filling type. The advantage of vector files over bitmap files is that image scaling does not affect image appearance. When zooming bitmap files, pixels become visible as shown in the example below: Vector image Bitmap image
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The following CGM vector formats are supported: • • • CGM ISO CGM CALS CGM ATA.

CGM (Computer Graphics Metafile) is an ANSI/ISO standardized platformindependent format used for the interchange of vector and bitmap data. Version 5 supports the CGM Version 1 and Version 3 standards. CGM Version 3 adds vector primitives such as Bezier and Nurbs, improved font and text support as well as bitmap compression. The CGM-ATA and CGM-CALS profiles which are specific subsets of the Version 3 standard are also supported. For detailed information about CGM formats, browse the following Internet site: http://www.cgmopen.org The table below summarizes the purposes of the above mentioned formats:
Purpose Printing/Plotting Data Exchange Format HPGL/2RTL PS EPS PDF CGM

X X X X X

Note that high quality images require longer computation time. 6. Click the Save button. You do not need to open the album first to save images to other formats. The Save As icon is also available in the Capture Preview window, allowing you to save to a file directly (without saving the image in the album).

Compressing Images
Here are listed the several methods you can use to compress images: • RLE Run-length encoding is the easiest and fastest compression method. However, it cannot achieve high compression ratios like those of more sophisticated compression
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Basic Tasks algorithms. The compression ratio mainly depends on the data content. This method is suitable for images with large uniformly colored areas, typically found in computer graphics. Most bitmap files support run-length encoding (such as TIFF, BMP, etc.) JPEG lossy compression This method looses information by removing details the human eyes can hardly perceive. The reconstructed image is not identical to the original one. The loss of visible details may be minimized at the expense of the compression factor. Typically, you can compress images by a factor of 20 without losing the subjective quality. The lossless JPEG compression is also part of the JPEG file format but is supported by very few applications LZW This method is used for GIF and TIFF files and removes redundancies in the picture. The LZW algorithm and the GIF format are both patented. Note that this method is not available in Version 5. ZLIB This lossless compression method belongs to the same category as the LZW method. It is used for PNG format which is meant to be a non-patented successor of the GIF format. Note that this method is not available in Version 5. CCITT/Fax encoding CCITT Group 3 and CCITT Group 4 are lossless data compression methods for black and white (bi-level) images, which are typically scanned images with a great size. These two methods are mainly used for TIFF files.

•

•

•

•

The table below shows the most appropriate compression method for a specific image type:
Image type Computer Photographic Graphics Compression Lossy JPEG ZLIB CCITT G4 None Bi-level Typical ratio 20:1 5:1

X X

X

X X X X

15:1 1:1

You can save images in bitmap format without having to compress them. There is no loss of information but the file size is impacted, since it is bigger.

Saving All Documents

If symbolic links exist between files, for example if a .CATDrawing document has been created from a Part document, the names of each of these files will also appear and will be saved if the Part document is
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If you did not make any changes to any of the docume nts you want to save or if these docume nts are readonly files, this dialog box will not appear. 2. Click OK to open the Save All dialog box:
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3. Click the Save As... button to specify a name for each read-only or new document. The number of unsaved files is indicated at the bottom of the dialog box and a preview is displayed on the right. 4. Click OK to confirm. If all the documents modified in the session can be saved without further interaction, a warning window appears to indicate the number of documents to be saved and prompts you to confirm or not the save:

Just click Yes to save automatically all the documents or No to cancel the command. If all the documents cannot be saved, the following dialog box will appear when some of the documents are new or read-only:
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1. Select the File->Save All command. These tasks show you how to save some or all of the documents you opened and how to control their names and locations. In addition to this, the Save All command lets you save very easily all modified or read-only documents.

Saving a CATProduct As Text
This task explains what is written in the file when a Save As .txt is performed. In CATIA V5, when you convert a CATProduct into .txt, with several CATParts included, the structure of the assembly is written to a txt-file. This text file is indented according to the arborescence of the CATProduct. Open CATProduct including several CATParts. Do a "Save As" in CATIA V5 (File -> Save As) and choose the file type ".txt". You will see that the description of the CATPart in the txt-file is "Product":
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Note that if you convert a CATProduct into .txt in CATIA V5, with several CATParts included, the corresponding description of all the CATParts in the txt-file is "Product". Saving As .txt does not distinguish CATPart and CATProduct (all are of the same type "Product"), it uses the terms "Root Product" or "Product".

Multi-Instantiation
Defining a Multi-Instantiation
This task shows you how to repeat components as many times as you wish in the direction of your choice. The option "Automatic switch to Design mode" is now available for this command. For more about this option, refer to Access to geometry. Open the Multi_Instantiation.CATProduct document. 1. Select the component you wish to instantiate, that is CRIC_BRANCH_3.
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2.

Click the Define Multi-Instantiation icon: The Multi-Instantiation dialog box is displayed, indicating the name of the component to be instantiated. The shortcut Ctrl + E calls the command too.
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3.

The Parameters option lets you choose between the following categories of parameters to define: Instances & Spacing Instances & Length Spacing & Length Keep the Instances & Spacing parameters option and enter 3 as the number of instances and 90mm as the value for the spacing between each component.

4.

To define the direction of creation, check x axis. There is another way of defining a direction. You can select a line, axis or edge in the geometry. In this case, the coordinates of these elements appear in the Result field. Clicking the Reverse button reverses the direction.

The application previews the location of the new components:

5.

Make sure the option Define as Default is on. If it is so, the parameters you have just defined are saved and will be reused by the Fast MultiInstantiation command. Click OK to create the components. Three additional components are created in the x direction. The tree displays them as well.

6.
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The Apply button executes the command but the dialog box remains open so as to let you repeat the operation as may times as you wish.

Fast Multi-Instantiation
This task shows you how to repeat components using the parameters previously set in the Define Multi_Instantiation command. You will use the Fast Multi-Instantiation command to quickly repeat the component of your choice. The operation is very simple. Make sure the option Work with the cache system is deactivated (for more refer to Working with a Cache System) and open the Fast_Multi_Instantiation.CATProduct document. 1. Select the component you wish to instantiate, that is CRIC_BRANCH_3.
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2.

Click the Fast Multi-Instantiation icon The shortcut Ctrl + D calls the command too. The result is immediate. Three components are created according to the parameters defined in the Multi-Instantiation dialog box.

Specification Tree Reporter
Overview
The Tree Reporter reports products and parts in the specification tree. This tool can be accessed in the Project Workbench by: • • Data->Structure Tools->Tree Reporter (Icon) Icon in the Structure Tools Toolbar
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What is the name of the report file?

Report Fields
The following fields appear in the exported report: • • • Path : The directory the product or part is stored. This field is empty if the product or part has not been saved yet. Name : The filename of the product or part. Tree Structure : The product or part name in the specification tree.

Example
Example Tree Structure Resulting Output (Opened in a Spreadsheet Application)

Miscellaneous Notes
• • • • • The output of the Tree Reporter is in CSV (Comma Separated Values) format. To view it, open the file using a spreadsheet application. Product and part objects are reported regardless of their Hide/Show property. The tree reportere generates information an all products and parts in the tree. The tree report always starts from the root product. Part instances are not reported. The Tree Structure field mimics the specification tree hierarchy.
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Cutting, Copying and Pasting Objects
Cutting, Copying and Pasting Objects
The steps below describe how to cut and paste or how to copy and paste Product Structure features. We recommend you to use these commands when you do not need to re-specify the features you paste or if you do so, these features should not require too many specifications. The Copy / Paste purpose (Break Link or As Specified in Product Structure) is to make an accurate Copy of the Source and keep the Attributes and Applicative data. When the Source is in Visualization Mode, the Copy command needs a partial load of the Source. 1. Select the object you want to cut or copy. 2. To cut, you can either: • • • • click the Cut icon select the Edit->Cut command select the Cut command in the contextual menu, or in the geometry area or the specification tree, drag the selection (although not a graphical cut, this is equivalent to the cut operation).

This places what you cut in the clipboard. To copy, you can either: • • • • click the Copy icon select the Edit->Copy command select the Copy command in the contextual menu or in the geometry area or the specification tree, press and hold down the Ctrl key and drag the selection.

This places what you copy in the clipboard. 3. To paste, you can either: • • • • click the Paste icon select the Edit->Paste command select the Paste command in the contextual menu (or Paste Special - Paste As Specified in Product Structure) or in the geometry area or the specification
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project tree, drop what you are dragging (see above). Dragging and dropping objects (features or bodies) onto objects (products or components) is a quick way to copy objects too. Note however, that the option Enable Drag-Drop must be on to use the capability.

Paste Special

This task explains you how to use the Paste Special... command. This implies the understanding of can paste using this command as well as the various formats available for pasting these features. This document is divided into 2 parts: • • Paste Special As Specified in Product Structure, Paste Special Break Link.

Paste As Specified in Product Structure
Paste As Specified in Product Structure is the format by default (traditional Paste). If you copy / paste an object in an assembly, only the selected Source Instance is copied.

A new Instance of the Source object is created and it has the same Reference as the Source. There Source implies modifying the Copy and vice versa. And the Copy (new instance) have the same Re illustrates this behavior:

• •

Open AnalyzingAssembly02.CATProduct. Create an empty CATProduct: Product1 for example.
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1. Select CRIC_TOP for instance and copy it. 2. Select Product1, right-click the Paste Special... command and paste CRIC_TOP.

Selecting Paste Special... contextual command, you can see the Paste Special window appea
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3. Select the As specified in Product Structure line and click OK. And you obtain this result:

4. Edit the Reference of CRIC_TOP (open CRIC_TOP.CATPart). Note that if you modify this Ref are also modified: Source and Copy.
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The behavior of Paste Special As specified in Product Structure is exactly the same as a simp Paste.

Paste Break Link

Contrary to the previous format, the Source Instance and its Reference are duplicated, because a n Reference are created. The Reference of the new Instance is the Copy of the Reference, which mak the Source. The Source and the Copy are separated, that is to say if you modify the Source, there new Instance (Copy). This schema illustrates this behavior:

•

Open AnalyzingAssembly02.CATProduct.
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1. Select CRIC_TOP for instance and right-click the Paste Special... contextual command. 2. Select Product1 and paste CRIC_TOP. The Paste Special window appears.

3. Select the Break Link option. And CRIC_TOP appears in Product1. Note that the Instance na same as the one in our first example (As specified in Product Structure).

4. Edit the Reference CRIC_TOP.CATPart. Note that if you modify this Reference, the new Inst Copy) is not modified:
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In an assembly, you cannot have two References with the same Part Number within a CATIA Session. If you copy / paste Beak Link a CATPart, CATProduct or a Component, the Copy is automatically renamed like this: Copy (n) of Source (Copy (n) of Source.1). But If you copy / paste Beak Link an object in another CATProduct that does not contain the same Reference, the Copy is not renamed.
Duplicating References:

Paste Break Link duplicates the Reference of the selected object and all references of aggregated c internal reference in the document as the selected object. Here is an example:

In blue are the Source References in the Source Assembly, in pink the Reference in the T P3 is a child of copied component P2 but its Reference is in another document so it won't be duplic You copy P2.1 under Target (Copy / Paste Break Link). => Instance / Reference Link:

203

project

This symbol means that this is a Product (not associated to any document). This is an Instanc follows the same behavior as its root (first "father" having an Associated Document). This symbol means that this is a Product (Instance or Reference), the Reference of which is as The Product has its own Copy / Cut / Paste behavior.

When you use the Paste with Break Link functionality, only the Instance chain within the document instance: • if you copy / paste P1.1:

•

if you copy / paste Root1:
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When you copy / paste Break Link an Instance that has an External Reference, its Reference and it duplicated (only when the original Document has an External Reference).

Duplicating Documents:

If copying / pasting Break Link an object in a CATProduct, its Reference is also duplicated (its docu action is somewhat like Inserting a New Product.

If you duplicate in CATIA V5 an ENOVIA document via the Paste Break Link, you only obtain a docu
Limitations:

•

• •

Cut: Break Link is the unique format when applied on Components, because Components ha (only Break Link is available in the Paste Special window). However, if you want to cut a CA choice between both formats. V4 models are often inserted in the product structure using Components, therefore cutting cutting a Component, using break link format, i.e. the reference is deleted as the instance. have to be re-created at the Paste (break link) operation. Drag and Drop: only the As specified in Product Structure is available. Paste Special: o You cannot paste on two Targets at the same time o You cannot make a multi-format Paste, but it is possible to select several Sources at it at the same format.

If you copy / paste a .model As Spec (Paste Special -> As Spec) into a CATProduct in CATIA V5, th ilke doing a Add New Representation that is to say adding this model as a New Representation in t As Spec consists in transferring the solid with the Geometry and History tree.

For more information about the Copy / Paste Special -> As Spec, please refer to Copying 3D from C Version 5 in the CATIA - V4 Integration User's Guide.
Copy Semantic:

Here we review how a pair (instance, reference) is copied from the origin document to the target d
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In these scenario types, we are copying the instance (I) that is attached either to a local reference reference (ER).

Reusing your Product Structure
Capabilities
Copy and Paste

Purposes

Provides a quick way of reusing the product structure between or within an assembly. This command is to be used when you n specification or no specifications at all.

Cut and

Paste

Provides a quick way of reusing the product structure. This com when you need to rework one specification or no specifications

Drag and Drop

Provides a quick way of copying the product structure at differe

Paste Special

Makes a Copy of an Instance independently (or not) from the S using the following formats: Paste As Specified in Product Struc Link.

•

Paste as Specified in Product Structure

This format enables to duplicate the Source Instance keeping t Reference. A new Instance of the Source is created and it has t as the Source.
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•

Paste Break Link

This format leads to the duplication of the Source Instance and Reference of the New Instance is the Copy of the Reference. Th Copy are separated, that is to say if you modify the Source, th impacts on the new Instance (Copy). The Source Instance and duplicated.
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Setting Up Various Modes
Setting up the Design Mode
This task shows you how to set up the Design mode for components in Product Structure context. The Design Mode command changes the .cgr format of the component into the original editable component document. In other words, geometric data is available. This explains why most of the commands are available if Design Mode is activated. You may wish to use the other edition mode referred to as the Visualization Mode. • Make sure that the Work with the cache system setting is activated in Tools > Options -> Infrastructure -> Product Structure -> Cache Management. For more information, see Customizing Cache Setting.

•

Open the ManagingComponents01.CATProduct document.
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1. Select CRIC_AXIS.1. 2. Then select either: • • the command Edit -> Representation -> Visualization Mode in the file-menu. or select Representations -> Visualization Mode from the contextual menu or click the icon Design Mode .

•

According to the mode you have chosen, you can see differences in the Specification Tree: • Design mode:

•

Visualization mode:

Moving a CATPart document from Visualization Mode to Design Mode may lead to Part Number conflicts if you had already inserted another element with the same Part
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Number. For more information, please refer to Setting up the Visualization Mode: Managing Part number conflicts when moving a CATIA document into Design Mode.

Setting up the Visualization Mode
This task shows you how to set up the Visualization mode for components in Product Structure context and how to manage Part Number conflicts when you shift to the Design Mode: Setting up the Visualization Mode Back into Design Mode Managing Part Number conflicts when moving a CATIA document into Design Mode The Visualization Mode uses documents in .cgr format. Only the external appearance of the component is visualized. The geometry is not available, which may be useful when you deal with sophisticated assemblies with large amounts of data but only need a few components to work on. You may wish to use the other edition mode referred to as the Design Mode. • • • In Visualization Mode, the "plus" button appears at all nodes' level and tree extension is possible, which allows partial load from the graph. To accelerate the graph loading, the "plus" is displayed every time a representation is associated to the document corresponding to the node, no difference is made between a product with an associated representation and a product containing a Part. The "plus" status is updated when you click it, it means that you are allowing the partial load of the graph but only when you are in Visualization mode. If finally there is no children in the graph, for instance a document with an unloaded reference, "plus" disappears:
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• • The node's state is between Visualization Mode and Design Mode. If you click the node, the "+" disappears and square brackets [] are replaced by parenthesis.

• • Double-Click again the same node and the product is set in Design Mode ("+"
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reappears).

• For a product structure coming from a database (ENOVIA VPM or LCA), a click on the node of a Part's Instance in Visualization Mode will make the "+" sign disappear without state change. The Part Instance stays in Visualization Mode.

Setting up the Visualization Mode
• Make sure that the Work with the cache system setting is activated in Tools -> Options -> Infrastructure -> Product Structure -> Cache Management. For more information, see Customizing Cache Setting.

• • Open the ManagingComponents01.CATProduct document. You can recognize that the CATProduct is in Visualization Mode because its components before Instance Name [Document Name]. are written like this: "plus"
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Back into Design Mode
1. Select CRIC_SCREW.1 [CRIC_SCREW.CATPart]. 2. Then select either: • • the command Edit -> Representation -> Design Mode in the file-menu. or select Representations -> Design Mode from the contextual menu or click the icon Design Mode .

•

If you do not click the root Product in order to make it active, the compass does not turn green when you move and place it on any part under the product and the part cannot be manipulated. CRIC_SCREW.1 [CRIC_SCREW.CATPart] has turned into CRIC_SCREW (CRIC_SCREW.1) and the geometrical elements in CRIC_SCREW.1 can be seen, and therefore selected, in the Specification Tree because its branches are now expandable:
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You can reapply the Visualization mode by selecting the CRIC_AXIS.1 for instance and clicking the Visualization Mode icon . According to the mode you have chosen, you can see differences in the Specification Tree: • Design mode:

•

Visualization mode:

Managing Part Number conflicts when moving a CATIA document into Design
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Mode
Moving a CATPart document from Visualization Mode to Design Mode may lead to Part Number conflicts if you had already inserted another element with the same Part Number. This task shows you that you can solve this problem by renaming one of the conflicting Parts. • • Make sure that the Work with the cache system setting is activated in Tools -> Options -> Infrastructure -> Product Structure -> Cache Management. For more information, see Customizing Cache Setting.* Open the ManagingComponents01.CATProduct document.

1. Select ManagingComponents01. 2. Click the Insert Existing Component icon .

3. Choose CRIC_SCREW.CATPart and click Open and you obtain:

. A Part 5. Select CRIC_SCREW.1 [CRIC_SCREW.CATPart] and click the Design Mode Number conflict panel is displayed because both entities of CRIC_SCREW have the same Part Number:
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Renaming one of the Part Number is mandatory because the OK button is grayed out in the Part Number conflict panel. 6. Rename CRIC_SCREW.CATPart and click OK:

The Part Number is renamed and the conflict is solved:

The second Part Number, CRIC_SCREWbis.CATPart, can be inserted in ManagingComponents01.CATProduct:
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Improving Performances
As you know, you can set two different work modes prior to performing tasks in this workbench: • • The Design Mode uses the original component documents. In other words, geometric data is available. All workbench commands are available if this mode is activated. The Visualization Mode uses documents in cgr format. Only the external appearance of the component is visualized. The geometry is not available, which may be useful when you deal with sophisticated assemblies with large amounts of date but only need a few components to work on.

This task illustrates the use of the Visualization mode and more precisely one way of improving the performances of the product. • • • Make sure that the Work with the cache system option is on (by default, the cache is not activated). See Cache Management for CATProduct and CATProcess Document. Make sure that the Automatic switch to Design mode option is on. See General settings. Make sure that the Compute exact update status at open option is manual. See General settings.

1. Open the AssemblyConstraint07.CATProduct document.
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• •

Using a cache system considerably reduces the time required to load your data. When opening assembly documents in visualization mode, the is always active, because the Status Unknown icon application cannot identify whether the assembly is up-to-date or not.

Looking closer at the specification tree, you can notice that the nodes are expandable, components are displayed with the following format: Instance_Name [Document_Name] .

2. Click the nodes to expand the two components. Looking closer at the specification tree, you can notice that the nodes are not expandable, components are displayed with the following format: Product_Name (Instance_Name).

•

•

More information have been loaded from the cgr document, in this sample nothing. Information contained in the cgr document, about annotation, publication or contextual part for example, will be displayed. The assembly has performed the update status: the Update icon is grayed, the assembly is up to date.

3. Click the Offset Constraint icon between Part.5 and Blue_Part.

to define an offset constraint

According to the activated options, as you are moving your cursor onto any geometrical element of the parts in visualization mode, you can notice that an eye symbol is located next to your arrow. This indicates that the geometrical element can be constrained, but take into account that once the it will be selected, the part will loaded in session. When setting the constraint on the Part.5, the CATPart document is loaded and appears under the related component.
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Then on the Blue_Part, the CATPart document is loaded and appears under the related component.

Once the constraint is set, take a look at the tree.

The fact that the application resolves constraints while working in visualization mode is possible only if your document contains data created from Release 10, and not using previous releases. The application resolves constraints set from published elements from R11 version. Contextual parts in visualization mode remain in this mode if they are up-to-date, on contextual publication all version, on contextual geometry from R11 version.

Setting the Design or Visualization Mode
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To define a mode specific to a component, you simply need to select your component and then use the Representations -> Visualization Mode or Representations -> Visualization (or Design) Mode contextual commands.

Assembling
Modifying an Assembly
Replace Components: click this icon and select a component. Reconnect a Replaced Representation: Right-click a component and select Representations -> Manage Representations from the contextual menu. Reconnect Constraints: Double-click a constraint to edit it,

Updating an Assembly
This task will show you how to update an assembly. • • • • Updating an assembly means updating all elements affected by this functionality, see Assembly Update reference information. You can update automatically or not your assembly, see Assembly Design-Update option. You can define the update propagation in the assembly, see Assembly Design-Update propagation option. You can compute the update status when you open an assembly document or insert an assembly component, see Assembly DesignCompute exact update status at open option.

When you are opening an assembly document or inserting a component: • • In Design Mode, the update status can be determined, the Update All or the Updated icon is displayed. icon In Visualization Mode: the update status cannot be determined, the is displayed. When you click this icon, the Status Unknown icon minimal data needed to determine the update status are loaded: o If the minimal data loaded to determine the status allow the application to perform an update and if the Update option is Automatic, then the assembly is updated, the Updated icon is displayed. o If the status is not up to date, the Update All icon is
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displayed. When you click this icon, the needed data to perform the update are loaded, then the assembly is updated, the Updated icon is displayed.

To perform this task you must work in Visualization Mode, select the Tools>Options... command. In the Infrastructure category, select the Product Structure sub-category then the Cache Management tab and check the option Work with the cache system. Close and re-open the application if needed.

Open the Assembly_01.CATProduct document. is displayed because there is not The Update Status Unknown icon enough information to determine the update status of assembly's elements: the constraints reference assembly components which are in Visualization Mode.

You can keep this state and work or determine the update status. In our example, we want to determine it. 1. Click the Update Status Unknown icon: When you click this icon, the application loads the minimal data to determine the update status. This is mean that the constraints' related components may be switched to Design Mode, warning is displayed in this case. The Update Warning dialog box appears, you can:
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• •

Click OK to determine the update status. Click Cancel to keep the unknown status.

2. Click OK, a progress bar appears during the data loading. The update status has been determined: the assembly is up to date and the Updated icon is displayed: The components have been loaded and constraints have been resolved.

Using Assembly Tools
Using Assembly Tools
Manage Products in an Assembly: Select Tools -> Product Management...,modify the part number in the New part number field and replace the associated representation in the New representation field. Publish Elements: Select Tools -> Publication...,select the element to be published then rename this element. Use a Part Contained in a Parametric Standard Part Catalog: Open the catalog of your choice, navigate through the catalog, select the desired part, use the Copy then Paste commands. Modify a Parametric Standard Part Catalog

Managing Products in an Assembly
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This task consists in managing products in an assembly. Open the AssemblyTools01.CATProduct document. 1. Select Tools -> Product Management... The Product Management dialog box is displayed.

The following is displayed for each components contained in the assembly: part Number document source file status of the component associated representation. You can modify the part number in the New part number field and replace the associated representation in the New representation field of the selected product. 2. 3. Click the ... button to open the Replace Representation dialog box. Click OK to validate.

Using a Standard Part Contained in a Parametric Standard Part Catalog

224

Advanced Tasks

This task explains how to use mechanical parts contained in catalogs delivered with the product. These parts are standard parts. Dassault Syst mes does not warrant that provided data are compliant with the ISO or EN standards. For further information, please contact the AFNOR organization for ISO or EN standards (www.afnor.fr) or the ISO organization for ISO standards (www.iso.org). Catalogs containing a limited number of parts compliant with JIS and ANSI standards are available too. 1. Select the Tools -> Mechanical Standard Parts -> XX catalogs command to access the catalog of interest. You can choose between the following caralogs: EN catalogs ISO catalogs JIS catalogs US catalogs The Catalog Browser dialog box displays:

For your information, catalogs are located in these directories: ISO:../$OS/Startup/Components/MechanicalStandardParts/ISO_Standards EN: ../$OS/Startup/Components/MechanicalStandardParts/EN_Standards

2.

Navigate through the chosen catalog.
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3.

Select the desired family and within this family the part you need. For example, you can instantiate in an assembly: screws bolts nuts washers pins keys This list is not exhaustive.

4. 5. 6.

Right-click to select the Copy contextual command. Select the base of your assembly. Right-click to select the Paste contextual command. The part is copied into your assembly. Note that this part is no longer linked to the catalog.

7.

Using the Save As capability, you can save this part in the directory of your choice.

Assembly Update
This reference will describe the assembly update behaviors which are apply to Assembly Design, Weld Design and other related workbenches. When updating an assembly, you are updating the following elements: • • • • • • • Assembly constraints. Assembly features. Knowledgeware relations. Weld features. Geometry of part document. Functional Tolerancing & Annotations features. Measures.

See also Update, Update propagation and Compute exact update status at open options.

Update Status
There are three update status when you are designing an assembly, these status are computed from the current state of the assembly:

226

Advanced Tasks

The assembly is updated: all elements are up to date. The assembly is not updated: one element at least is not up to date. The assembly update status is unknown: there is not enough information to determine the update status (updated or not). This status appears when an element is contained into a component in visualization mode.

Exploding a Constrained Assembly
This task shows how to explode an assembly taking into account the assembly constraints. This Explode type is applicable only to specific cases: when the assembly is assigned coincidence constraints: • • axis/axis plane/plane

Open the Moving_Components_03.CATProduct document.

1. Click the Explode icon: The Explode dialog box appears. 2. Wheel Assembly is selected by default, keep the selection as it is. • You can also use the drag and drop capability (drag the explode icon and drop it onto the required product in the specification tree. The Depth parameter lets you choose between a total (All levels) or partial (First level) exploded view.

•

3. Keep All levels set by default. 4. Set the explode type. 3D is the default type. Keep it. 5. Click Apply to perform the operation.
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You can move products within the exploded view using the 3D compass.

In DMU Fitting Simulator only: the manipulation toolbar is also available once you move an object with the 3D Compass. The Scroll Explode field gradually displays the progression of the operation. The application assigns directions and distance. Once complete, the resulting exploded view looks like this:

You are not satisfied with this result as the nuts are not correctly positioned. The constraints are not respected. Replay the scenario selecting the constrained type. 6. Still in the Explode dialog box, set the constrained type. 7. Define a fixed product: in our example select the Rim1 either in the specification tree or in the geometry area
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8. Click Apply to perform the operation.

Once complete, the resulting exploded view looks like this:
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The nuts are correctly positioned, the exploded view corresponds more to the reality and to a technical documentation. 9. Click OK to validate the operation or click Cancel to restore the original view. If you click OK, the following warning message is displayed as the exploded view is kept when exiting the command.

The explode functionality aims at understanding better how the assembly is structured. You can use it for further purposes: creating scenes, print, keep the exploded view as archive document or generate a drawing (please refer to Create Scenes in the DMU Navigator User's Guide)

Editing
Editing a Part in an Assembly Design Context
This task shows you how to edit a Part (CATPart) in Assembly Design context. See Design in Assembly Context for more information. Open the ManagingComponents01 Product document. 1. Click on the + sign to the left of the CRIC_SCREW (CRIC_SCREW.1) component in the specification tree. The CATProduct is identified by the Product document icon. 2. Double-click on the CRIC_SCREW to open the Part Design workbench. Do not mistake the Product document (CATProduct) for the Part document (CATPart). The CATPart is identified by the Part Design document icon. If the Product document containing the Part document is set to Visualization Mode, editing the Part document switch automatically the Product document to Design Mode. This is not an Assembly Design behavior because the Design Mode is the only mode for Part document.
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The Part Design workbench is displayed. 3. Click on the + sign to the left of Part Body. 4. Double-click the feature you need to edit. For example, double-click on Pad2 to display the Pad Definition dialog box. You can then enter the parameters of your choice. For information about Part Design and the Sketcher , please refer to Part Design User's Guide and Dynamic Sketcher User's Guide respectively. 5. Once you have edited the part, double-click on ManagingComponents01 to return into Assembly Design workbench. The specification tree remains unchanged. 6. Double-click on the part CRIC_SCREW to open Part Design workbench again. 7. Select any circular face of CRIC_BRANCH1 and enter the Sketcher workbench. 8. Create a circle and set a coincidence constraint for example:

9. Exit from the Sketcher and double-click on ManagingComponents01 to return into Assembly Design workbench. Assembly Design workbench is then displayed and a green wheel is added to CRIC_SCREW in the tree to represent the contextual nature of the component: .
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Note however that this symbol is displayed only if the option Keep link with selected object is selected. For more information, please refer to Part Design User's Guide.

Contextual components are considered as the children of the components used for their creation. This means that if you delete these support components, you will need to consider if you wish to delete contextual components or not. Remember, you can choose to delete affected elements by checking the Delete all children option in the Delete dialog box.

Copy/Paste As Special command
If you wish to apply the Copy -> Paste As Special command to parts included into your assembly, remember the following: if you have already used the As Result With Link option when pasting Part.1 onto Part.2, you then cannot paste Part.2 onto Part.1 using the As Result With Link option. An error message is issued informing you that a cycle has been detected. For more about Copy -> Paste As Special command, please refer to Infrastructure User's Guide.

Editing Parameters
This task shows all the parameters that appear in green in the 3D geometry when creating or editing a feature. This command is available on the following commands: Operator Bump Type Sub- Type Parameter displayed Length, Deformation, Distance (Maximum distance along the deformation direction
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Advanced Tasks from the deformed surface) Circle Center and Radius Center and Point Two Points and Radius Bitangent and Radius Center and Tangent Corner Curve Parallel Diabolo Extrapolate Extrude Helix Length Geodesic parallel mode Point as center element Radius, Start Angle, End Angle Start Angle, End Angle Radius Radius Radius Radius Constant (Offset Distance) Draft Angle Length, Limit Type Length 1, Limit 1 Length 2, Limit 2 Taper Angle, Starting Angle Length: Pitch Length: Height Angle/Normal to Curve Point-Point Point-Direction Tangent to Curve Normal to Surface Bisecting Offset Plane Angle/Normal to Plane Offset from Plane Coordinates On Curve On Plane Support and Geometry on support selected Support selected Support selected Mono-tangent and Support selected Angle Length (Start and End)

Line

Length : Start, End Infinite Start Point: End Infinite End Point: Start Infinite: /

Support selected Offset Value Angle (Angle/Normal to Plane and Angle/Normal to Curve) Length, Offset Distance Length, X, Y, Z coordinates Length (distance on curve) Length, H, V

Point

Geodesic
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On Surface Polyline Reflect Line Revolve Rotate Shape Fillet Sphere Bi-Tangent Fillet

Length (distance on surface) Radius, Radius at point Angle Angle1, Angle2 Rotation Angle Radius Parallel Start Angle, Parallel End Angle, Meridian Start Angle, Meridian End Angle Radius, Radius End Angle

Spiral Angle and Radius Angle and Pitch Radius and Pitch Sweep Explicit Sweep Linear Sweep Two Limits With Reference Surface With Reference Curve With Draft Direction Translate Distance and Direction

Length: Length: Length: Length: Length: Length: Length: Angle

Start Radius End Radius Start Radius Pitch Start Radius End Radius Pitch

Length1, Length2 Angle, Length1, Length2 Angle, Length1, Length2 Angle, Length1, Length2 Distance

Create any of the features above. Let's take an example by performing a rotation. 1. Once you selected the inputs to create the rotated element, click Preview to display the associated parameters in the 3D geometry.
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2. Double-click the angle value in the 3D geometry. The Parameter Definition dialog box appears.

3. Use the spinners to modify the value. The display automatically updates and the object is modified accordingly. You can also modify the angle value using the Angle manipulators.

• •

To display the parameters' values, you need to click the Preview button. Otherwise, only manipulators are displayed. To edit the parameters once the feature is created, select it in the specification tree, right-click xxx.1object -> Edit Parameters from the
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Editing Measures
You can adjust the presentation of the measure, edit the measure itself and: • Change one of the selections on which it was based. You can also change selections that no longer exist because they were deleted. • Replace selections using the replace mechanism (In a part)

This section describes the following editing operations:

• • •

Changing selections Replacing selections in a Part Editing the presentation of your measure

Changing selections
You can change selections on which your measure is based in Measure Between and Measure Item commands. This is particularly useful in design mode where you no longer have to redo your measure. 1. Double-click the measure in the specification tree or geometry area. 2. Make new selections. Notes: o In Measure Between, you can change selection modes when making new selections. For invalid measures where one selection has been deleted, you only have to replace the deleted selection. For all other measures, repeat all selections. In Measure Item, you cannot change the selection 1 mode. If you selected a curve, you must make a selection of the same type, i.e. another curve.

o o
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3. Click OK when done.

Replacing selections in a Part
In a part, you can change selections using the Replace mechanism in Measure Between, Measure Item and Measure Inertia commands. Note: In a product, measures are not integrated into the Replace mechanism. When you replace a product on which a measure is made, the measure is no longer valid and links to the geometry are deleted. Special case: If your measure was made on a product in the specification tree, the measure is identified as not up-to-date after you replace the product.
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1. Make your measure using the appropriate measure command. Important: Selecting features in the specification tree rather than selecting items in the geometry area is highly recommended. Some items selected in the geometry area may no longer exist as such if you modify the geometry and, in this case, the measure will be invalid ( ).

2. Right-click the selection you want to replace and select Replace... from the contextual menu. The Replace dialog box appears.

Note: Replacing a selection impacts all items or entities linked to the selection. 3. Make a new selection. 4. Click OK in the Replace dialog box.The measure is identified as not up-todate. 5. Right-click the measure in the specification tree and select Local update from the contextual menu to update your measure.
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6.
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Editing the presentation of your measure
To adjust the presentation of Measure Between and Measure Item measures, you can move: • • the lines and text of the measure.

The Properties command (Graphics tab) lets you change the fill color and transparency as well as the color, line type and thickness of measure lines. Note: You cannot vary transparency properties, the current object is either the selected color or transparent.

Editing Document Links
This task shows you how to edit document links.

Only direct links i.e. external documents directly pointed to by the active document can be displaye Edit->Links... command. Thus, inactive documents must be activated before displaying their links. Note that you can also select an element from the graph to display its links.

Open the document Links.CATProduct.
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1. Select the Edit -> Links... command.

The Links of document dialog box appears, confirming that two links have been found to the docu CHC.CATPart and Part2.CATPart:

2. Click OK and exit your session. 3. Move the document CHC.CATPart to another folder. 4. Restart your session, then reopen the document Links.CATProduct. The Open dialog box appears, explaining that the document CHC.CATPart could not be found:

Whenever a document is opened and one or more of its links are invalid, the Open dialog box ap along with the document opened and a broken link icon appears in the specification tree. There are several reasons why a link may no longer work:

• the files could not be found which means they have been moved, renamed or deleted • or the files contain the wrong information which means they still have the same name but a content different from the files originally pointed to.
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If you click the Close button, you can select the Edit -> Links... command, the dialog box will dis the following information in the Pointed documents tab:

Just select the not found element then click the Find button to access the missing file via the File Selection dialog box. 5. Click the Desk button or double-click the file path inside the field in the Open dialog box. You can check link validity at any time using this command. The Desk window appears:

6. Click the document shown in red in the Desk window.
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7. Right-click then select the Find menu. The File Selection dialog box opens:

8. Explore your file system to find the file, select it, then click Open. The File Selection dialog box disappears and the file CHC.CATPart, i.e. the file pointed to by Links.CATProduct is now displayed in white.
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9. If you want to open the CHC.CATPart from the Desk, just select it then click Open in the con menu:

For more information on the Desk, refer to the Using the FileDesk Workbench in this guide.

10. If you now select the Edit->Links... command with the EditLinks.CATDrawing document acti dialog box will indicate that the right file has been found and loaded ("OK" Status).
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The Links tab lets you manage individually each link you select from the list:

• use the Load button to load parts (and parts only) that are not loaded. The status will chang from "Document not loaded" to "Loaded" • use the Synchronize button to update the links in your document.

For instance, suppose you have copied then pasted "As Result with link" a pad from one document to another document. You have then two pads linked together in two different documents. When you modify the original pad, the status of its copy changes to "Not Synchronized" to indicate that there is a discrepancy between the two pads. If you want the copy to be applied the changes you have made to the original, you need t the Synchronize button. The status of the copy will then change from "Not synchronized" "OK".

However, be careful when replacing elements because not all element types are compatib example, a line cannot be replaced by a circle or curve as their specifications are different the synchronization will not be allowed • use the Activate/Deactivate button to avoid or allow the synchronization of linked elements part update. A symbol in the specification tree identifies any "activated" ( ) or "deactivat ( ) element.

For instance, if you do not want a linked object to be synchronized, click the Activate/Deactivate button: the Activate status of the linked object will change to "Deacti which means that it will not be impacted by the changes made to the parent element whe performing an update. Inversely, if you want a deactivated linked element to be synchronized during a part upda click the Activate/Deactivate button: the Activate status of the linked element will change "Activated" and you will be able to synchronize it.

Note that this command is also available from the contextual menu by right-clicking the o to be activated/deactivated then selecting xxx object-> Activate or xxx object->

Deac

• use the Isolate button to remove a link. The status of the linked element will change to "Iso to indicate that the link to the pointed element is broken. This means that the pointed ele cannot be synchronized anymore.

Note that this command is also available from the contextual menu by right-clicking the o to be isolated then selecting xxx object->Isolate • use the Replace button to replace the selected link with another one. This button opens the Selection dialog box to let you navigate to the desired file. Once the element has been rep the new element name is displayed along with its status in the Links dialog box. Note that when working with .catalog documents, this functionality is relevant only for replacing a link from one catalog to another. You cannot use the Replace button to replace a link to a part pointed to by a catalog, for instance. If you want to replace the link to a part or a product pointed to by a catalog, you need to modify the catalog description. For more information, refer to "Creating a Catalog Using the Catalog Editor (paragraph entitled "Adding a Component to a Family") in the Version 5 Component Catalog Editor User's Guide.
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Depending on the document environments you allowed in the Document settings, an additional w may appear simultaneously to the File Selection dialog box to let you access your documents usi alternate methods. This additional window will allow you, for instance, to replace a link with another one pointing to element opened in your current Version 5 as you could it with the former Replace in Session butt For detailed information, refer to Opening Existing Documents Using the Browse Window.

The Refresh button lets you update the links related to the document without having to close the open the Links dialog box. This is especially useful when trying to re-access pointed documents that are not found (for insta after a network disconnection): in that case, clicking the Refresh button avoids you to re-select t Edit->Links... command to display an updated view of the links.

11. Access the Pointed documents tab which also enables you to edit links but this time, you ma documents and not a list of links:

• the Replace button lets you replace a pointed document with another one and reroute any l that may exist to this document. To do so, select the pointed document to be replaced from the list, click the Replace butto open the File Selection dialog box, navigate to the desired file then click Open: the file op and the links from all pointing documents loaded in session will be rerouted to the replaci document. Pointing documents which are not loaded in session will still point to the replac document. In case a problem occurs during the replacement, a diagnosis window will be displayed. However, bear in mind that a replacement needs to be performed under certain conditions to succeed: • • the names of the replaced document and of the replacing one should be different the links to the replacing document should allow the replacement, i.e. they can be modified to match the path of the replacing document.

It is also recommended that the replaced and replacing documents have the same internal identifier (UUID), which means that the replacing document should have been created as a
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• the Find button is relevant for broken links only: clicking it opens the File Selection dialog b let you browse your file system and find the missing file(s).

Note: depending on the document environments you allowed in the Document settings, an additi window may appear simultaneously to let you access your documents using an alternate method detailed information, refer to Opening Existing Documents using the Browse Window.

• the Load button lets you load pointed documents which have been found but not loaded in y current session • the Open button lets you open a pointed document in a new window. To do so, select the document to be opened from the list then click Open. Note that you can also open a pointed document using the xxx object->Open the Pointed Document contextual command. For detailed information on this command, refer to Opening Existing Documents. As far as temporary documents are concerned, they cannot be opened in a new window. For instance, you cannot open in a new CATIA V5 window a Product Root Class created in ENOVIA V5.

Editing Images in the Album
This task explains how to edit pixel images in the album once they have been captured. 1. Select the Tools->Image->Album... command to display the album contents.
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2. Choose the image to be displayed in the preview area in the lower left part of the dialog box the list. 3. Right-click then select the Edit command to open the image Editor window.

Note that depending on the image format you select, the Edit command may be grayed out. This when right-clicking a MPEG or AVI file, for instance.
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The icon displays general information on the image file (size, type, etc.) and memory (memo information are identical to those displayed when displaying the Image information window). 4. Click the below:

icon to adjust the color brightness, contrast and gamma using the correspondi
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After clicking OK to validate, the result is displayed in the preview area to the left. The Clears picture vertically. button removes the image display and the Flips picture

button flips th

Note: clicking the Clears picture button opens a warning window which prompts you to confirm t Click "Yes" to validate or "No" (or "Cancel") to cancel the removal and go back to the Editor. 5. Use the Effects palette to: • • • • • zoom in (the zoom ratio is 1:2)

zoom out (the zoom ratio is 1:2) resize the image to scale 1:1 (i.e. real size display), there is no pixel interpolation fit the image into the space available in the display area translate the image up, down into the display area) , to the left or to the right

(when the image do

You can also use the following keyboard shortcuts: Shortcut Page Up Page Down Ctrl + Page Up Ctrl + Page Down Left, Right, Up or Down arrow Shift + Left, Right, Up or Down arrow Action Zoom In Zoom Out Zoom Best Zoom 1:1 Smooth horizontal or vertical move Faster horizontal or vertical move
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Ctrl + Left, Right, Up or Down arrow

Move from one border to another

6. Use the

icon from the Effects palette to open the Navigator:

and icons The Navigator lets you visualize the image and zoom in or out either using the respectively, or the horizontal scrollbar. Any visualization change you have made in the Navigator simultaneously updates the image disp Editor as shown below:
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You can also pick wherever you want in the Navigator preview to set the position of the viewpoin the Editor preview:

When finished, click OK to exit the Navigator and go back to the Editor. 7. Use the Tools palette to:

• pick the color to be used for painting. To do so, just click the icon to activate the pickin then choose the painting color either from the color palette or from the image. The current color square displayed at the lower left is then modified accordingly:

In case you do not wish to use a color picked from the image, you can make your choice direct from the color palette using the mouse:

• select a paint tool: o o to draw custom brushes to draw custom airbrushes 253
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o o o o o

to draw interrupted segments to draw uninterrupted segments to draw rectangles to draw ellipses to apply a fill color. interrupted segments brush airbrush

uninterrupted segm

filled rectangle

filled ellipse

• depending on the tool you choose you can select: o a brush type from the Brushes palette if you draw brushes or segments:

o a fill mode (either outline, filled or blank) if you draw rectangles or ellipses:

icon then give a name to the image To save the edited image under another name, click the navigate to the desired location before clicking OK to confim the save. 8. Click OK to validate and go back to the album. If the image has been modified, a window appears to prompt you either to:

• overwrite the already existing image with the modified one by clicking "Yes" • or to save the image under a new name ("capture_000" by default) in TIFF format by clickin Clicking Cancel lets you exit the editor without saving the image. The image is automatically saved in the album with a name identical to the original image:
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To save the edited image under another name, right-click it then select the Save command. Then name to the image and navigate to the desired location before clicking OK to confim the save.

Note that you can also copy the desired image from the album to the clipboard by right-clicking i selecting the Copy command. For detailed information, refer to Copying Images to the Clipboard Only).

Editing View/Annotation Plane Properties
This task shows you how to rename an annotation plane and hide its frame. Open the Common_Tolerancing_Annotations_01 CATPart document. 1. Right-click the Projection View.1 annotation plane and select the Properties contextual command.
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2. Select the View tab in the Properties dialog box which is displayed. To rename the annotation plane, enter the new name in the Prefix field.

Check/uncheck the Display view frame option to show/hide the view/annotation plane frame.

3. Click OK to confirm and close the dialog box.

Analysis
Analyzing an Assembly
Compute a Clash: Select Analyze -> Compute Clash, multiselect the components and click Apply. Compute a Clearance: Select Analyze -> Compute Clash, multiselect the components, enter the clearance value and click OK. Analyze Constraints: Select Analyze -> Constraints, and select the constraints in the dialog box. Analyze Dependences: Select the component and the Analyze -> Dependency...command, check the display options of the dialog box or select elements and use the different contextual commands. Analyze Updates: Select the product or component of interest and select the Analyze -> Update command. Analyze Degrees of Freedom: Select the Analyze -> Degrees of Freedom command.

Analyzing Dependences
This task shows you how to see the relationships between components using a tree. Open the AnalyzingAssembly03.CATProduct document.
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1. Select the component CRIC_BRANCH_3.1.

You can analyze the dependencies of your assembly by selecting the root of the tree too. 2. Select Analyze -> Dependencies... command. The Assembly Dependencies Tree dialog box appears.

3. Right-click CRIC_BRANCH3.1 and select the Expand node command from the
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contextual menu. The constraints defined for this component then appear:

4. Right-click CRIC_BRANCH3.1 and select the Expand all command from the contextual menu. Now, the constraints and components related to the component you have selected are displayed:

You can notice that there are: • • • • • a coincidence constraint between CRIC_BRANCH_3.1 and CRIC_BRANCH_1.1: Coincidence.4 a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_FRAME.1: Surface contact.5 a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_AXIS.1: Surface contact.9 a surface contact constraint between CRIC_BRANCH_3.1 and CRIC_BRANCH_1.1: Surface contact.6 a coincidence constraint between CRIC_BRANCH_3.1 and CRIC_FRAME.1: Coincidence.7

5. Checking the different options available in the Elements frame. You can display the following: • • Constraints: by default, this option is activated Associativity: shows components edited in Assembly Design context, see Designing in Assembly Design Context. Contextual components are linked to support components by green lines in the graph.
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•

Relations: shows formulas. For more information, please refer to Knowledge Advisor User's Guide.

6. You can also display the relationships by filtering the components you wish to see. Either check the Child option to take the children of the component into account or check Leaf to hide them. Contextual commands are available: • • • Expand all: lets you see the whole relationship. Note that doubleclicking produces the same result. Expand node: lets you see the relationship under the node. Set as new root: sets the selected component as the component whose relationships are to be examined.

Zooming in and zooming out in the tree is allowed. 7. Click OK to close the dialog box.

Analyzing Updates
Operations such as moving components (see Moving Components) or editing constraints (see Editing Constraints) sometimes affect the integrity of the whole assembly. You then need to know what to do to restore a correct product. The application provides a tool for detecting if your assembly requires updates. This tool is particularly useful when working with large assemblies. You can update a part or a product without updating the whole assembly, using the Analyze Update command. Open the AnalyzingAssembly04 document. This scenario assumes that the Manual Update option is on. For more about this option, refer to Update. 1. Select Analysis product in the specification tree.
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2. Select the Analyze -> Update command. The Update Analysis dialog box appears.

In our example, it provides the name of the entities to be updated, i.e:
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• • • • •

name name name name name

of of of of of

the the the the the

product or component under study constraints defined on this product or component children of this product or component constraints defined on the children representations defined on the children

In some cases, it also displays the name of the representations associated to parts. 3. Select Concidence.4 from the Constraints field. The application highlights this constraint both in the specification tree and in the geometry area. 4. Set the Components to be analyzed to Analysis/Product2. Two constraints need updating.

5. Set the Components to be analyzed to Analysis. 6. Click the Update tab and multi-select Analysis/Product2.
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7. Click the Update The part is updated:

icon to the right of the dialog box.

The Update Analysis dialog changes and displays the update status for the Analysis component.
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8. Click OK to close the dialog box.

Analysis operators
• energy (Case: StaticSolution) Computes the global energy in a static case solution. misesmax (Case: StaticSolution) Computes the maximum value of the nodal VonMises stress. Example misesmax.1=misesmax("Finite Element Model • dispmax (Case: StaticSolution) Computes the nodal maximum displacement. Example length.1=dispmax("Finite Element Model • frequency (Case: FrequencySolution) Computes a given frequency. Example Frequency.1=Frequency("Finite Element Model Solution.1") • frequencies (Case: FrequenciesSolution) Computes all the frequencies. Example FrequenciesList.1=Frequencies("Finite Element Model Case Solution.1") • globalerror (Case: StaticSolution) Computes the global error percentage of a static case. Example percentage.1=globalerror("Finite Element Model Solution.1") • bucklingfactors (Case: BucklingSolution) Computes a list of buckling factors. Example Static Case Frequencies Frequency Case Static Case Solution.1") Static Case Solution.1")

•
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Bucklingfactors.1=BucklingFactors("Finite Element Model Case Solution.1") •

Buckling

dispmaxongroup (Case: AnalysisResults, Group:Group): Length Computes the nodal maximum displacement. It applies to a group of items. reaction (Entity: EntityForReaction, Case: StaticSolution, Axis:Axis System)) Computes reactions on connections or boundary conditions.

•

Sectioning
Sectioning
About Sectioning Creating Section Planes: Click the icon. Creating 3D Section Cuts: Create a section plane then click the icon. Manipulating Section Planes Directly: Create a section plane, drag plane edges to re-dimension, drag plane to move it along the normal vector, press and hold left and middle mouse buttons down to move plane in U, V plane or local axis system or drag plane axis to rotate plane. Positioning Planes on a Geometric Target: Create a section plane, click the icon then point to the target of interest. Positioning Planes Using the Edit Position and Dimensions Command: Create a section plane, click the icon and enter parameters defining the plane position in the dialog box. More About the Section Viewer: Create a section plane then click the icon.

About Sectioning

Using cutting planes, you can create sections, section slices, section boxes as well as 3D section cu your products automatically.

• • • • •

Section Plane Manipulating the Plane Section Results 3D Section Cut P1 and P2 Capabilities o Creating Groups of products

Creating section slices and section boxes are DMU-P2 functionalities.
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Section Plane

The section plane is created parallel to absolute coordinates Y, Z. The center of the plane is located the center of the bounding sphere around the products in the selection you defined.

•

Line segments represent the intersection of the plane with all surfaces and volumes in the selection. By default, line segments are the same color as the products sectioned.

•

Points represent the intersection of the plane with any wireframe elements in the selection, are visible in both the document window and the Section viewer.

Notes: • • Any surfaces or wireframe elements in the same plane as the section plane are not visible. If no selection is made before entering the command, the plane sections all products.
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A plane has limits and its own local axis system. The letters U, V and W represent the axes. The W is the normal vector of the plane.

You can customize settings to locate the center and orient the normal vector of the plane as well a activate the default setting taking wireframe elements into account. This is done using the Tools ->Options..., Digital Mockup ->DMU Space Analysis command (DMU Sectioning tab).

Manipulating the Plane

Sectioning is dynamic (moving the plane gives immediate results). You can manipulate the cutting in a variety of ways: • • • Directly Position it with respect to a geometrical target, by selecting points and/or lines Change its current position, move and rotate it using the Edit Position and Dimensions command.

Section Results
Results differ depending on the sag value used. Using default value (0.2mm):

Using a higher value:

Sag: corresponds to the fixed sag value for calculating tessellation on objects (3D fixed accuracy) the Performance tab of Tools -> Options -> General -> Display. By default, this value is set to 0.2 mm.

In Visualization mode, you can dynamically change the sag value for selected objects using the T > Modify SAG command.
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3D Section Cut

3D section cuts cut away the material from the cutting plane to expose the cavity within the produ beyond the slice or outside the box.

P1 and P2Capabilities

In DMU-P1, you cannot select products to be sectioned: the plane sections all products.
Creating Groups of Products

In DMU-P2, prior to creating your section plane, you can create a group containing the product(s) interest using the Group bar.

icon in the DMU Space Analysis toolbar or Insert -> Group... in the m

Groups created are identified in the specification tree and can be selected from there for sectioning one group per selection can be defined

Creating Section Planes
This task shows how to create section planes and orient the normal vector of the plane. • • • • • Section Planes Step-by-Step Scenario Result Windows Sectioning Definition Dialog Box P2 functionalities

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr. They are to be found in the online documentation filetree in the common functionalities sample folder cfysm/samples.

Section Planes
The plane is created parallel to absolute coordinates Y,Z. The center of the plane is located at the center of the bounding sphere around the products in the selection you defined. • Line segments represent the intersection of the plane with all surfaces and volumes in the selection. By default, line segments are the same color as the products sectioned.
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A section plane has limits and its own local axis system. U, V and W represent the axes. The W-axis is the normal vector of the plane. The contour of the plane is red. You can dynamically re-dimension and reposition the section plane. For more information, see Manipulating Section Planes Directly. Using the Tools ->Options... command (DMU Sectioning tab under Digital Mockup >DMU Space Analysis, you can change the following default settings:

• • •

Location of the center of the plane Orientation of the normal vector of the plane Sectioning of wireframe elements.

Step-by-Step Scenario
1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Space Analysis toolbar to generate a section plane.

The section plane is automatically created. If no selection is made before entering the command, the plane sections all products. If products are selected, the plane sections selected products.
P1 Functionality

In DMU-P1, you cannot select products to be sectioned: the plane sections all products. 2. Click the Selection box to activate it.
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3. Click products of interest to make your selection, for example the TRIGGER and BODY1.Products selected are highlighted in the specification tree and geometry area. Note: Simply continue clicking to select as many products as you want. Products will be placed in the active selection. To de-select products, reselect them in the specification tree or in the geometry area. The plane now sections only selected products.

You can change the current position of the section plane with respect to the absolute axis system of the document: 4. Click the Positioning tab in the Sectioning Definition dialog box.

5. Select X, Y or Z radio buttons to position the normal vector (W-axis) of the plane along the selected absolute system axis. Select Z for example. The plane is positioned perpendicular to the Z-axis.
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6. Double-click the normal vector of the plane (W-axis) or click the Invert Normal icon to invert it.

7. Click OK when done. The section plane definition and results are kept as a specification tree feature.

8. Click Close By default, the plane is hidden when exiting the command. Use the Tools>Options, Digital Mockup-> DMU Space Analysis command (DMU Sectioning
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Advanced Tasks tab) to change this setting. o To show the plane, select Hide/Show the plane representation in the contextual menu. Note: In this case, you cannot edit the plane. To edit the plane again, double-click the specification tree feature.

o

9.

Results Window
A Section viewer is automatically tiled vertically alongside the document window. It displays a front view of the generated section and is by default, locked in a 2D view. Notice that the section view is a filled view. This is the default option. The fill capability generates surfaces for display and measurement purposes (area, center of gravity, etc.).

Sectioning Definition Dialog Box
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The Sectioning Definition dialog box appears. This dialog box contains a wide variety of tools letting you position, move and rotate the section plane as well as create slices, boxes and section cuts. For more information, see Positioning Planes with respect to a Geometrical Target, Positioning Planes Using the Edit Position Command, Creating Section Slices, Creating Section Boxes and Creating 3D Section Cuts.

P2 Functionalities
In DMU-P2, you can create as many independent section planes as you like. Creating section slices and section boxes are DMU-P2 functionalities.

Creating 3D Section Cuts

3D section cuts cut away the material from the plane, beyond the slice or outside the box to expos cavity within the product. This task explains how to create 3D section cuts:

• • • •

Step-by-Step Scenario 3D Section Cut Display P2 Functionality 3D Section Cut in DMU Review

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples.

Step-by-Step Scenario
1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon in the DMU Analysis toolbar and create a section plane. The Sectioning Definition dialog box appears.
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2. In the Definition tab, click the Volume Cut icon

to obtain a section cut:

The material in the negative direction along the normal vector of the plane (W-axis) is cut exposing the cavity within the product.

Note: In some cases, the normal vector of the plane is inverted to give you the best view o cut. 3. Double-click the normal vector of the plane to invert it, or click the Invert Normal Positioning tab of the Sectioning Definition dialog box. icon
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4. Re-click the icon to restore the material cut away. 5. Click OK when done.

3D Section Cut Display

The 3D section cut display is different when the sectioning tool is a plane. To obtain the same disp for slices and boxes (see illustrations below) and make measures on the generated wireframe cut: • • Select the Allow measures on a section created with a simple plane option in the DMU Sect tab (Tools -> Options, Digitial Mockup -> DMU Space Analysis) Then, create your section cut based on a plane.

When the Sectioning Tool is a Slice:

When the Sectioning Tool is a Box:
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P2 Functionality

In DMU-P2, you can turn up to six independent section planes into clipping planes using the Volum command to focus on the part of the product that interests you most.

3D Section Cuts in DMU Review

Section cuts created during DMU Reviews are not persistent and are only valid for the duration of t review. If you exit the DMU Review, the section cut is lost.
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For more information about DMU Review, refer to DMU Navigator User's Guide

Manipulating Planes Directly

You can re-dimension, move and rotate section planes, or the master plane in the case of section s and boxes, directly. As you move the cursor over the plane, the plane edge or the local axis system appearance changes and arrows appear to help you.

Sectioning results are updated in the Section viewer as you manipulate the plane.

To change this setting and have results updated when you release the mouse button only, de-activ the appropriate setting in the DMU Sectioning tab (Tools ->Options..., Digital Mockup ->DMU Space Analysis). This task illustrates how to manipulate section planes directly. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning Space Analysis toolbar and create a section plane.

icon in the DMU
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A Section viewer showing the generated section is automatically tiled vertically alongside t document window. The generated section is automatically updated to reflect any changes to the section plane.You can re-dimension the section plane: 2. Click and drag plane edges to re-dimension plane:

Note: A dynamic plane dimension is indicated as you drag the plane edge. You can view and edit plane dimensions in the Edit Position and Dimensions command. Th plane height corresponds to its dimension along the local U-axis and the width to its dime along the local V-axis.You can move the section plane along the normal vector of the plan

3. Move the cursor over the plane, click and drag to move the plane to the desired location.Y can move the section plane in the U,V plane of the local axis system:

4. Press and hold down the left mouse button, then the middle mouse button and drag (still holding both buttons down) to move the plane to the desired location. You can rotate the s plane around its axes:

5. Move the cursor over the desired plane axis system axis, click and drag to rotate the plane around the selected axis.
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in the Positioning tab of the Sectioning Definit 6. (Optional) Click the Reset Position icon dialog box to restore the center of the plane to its original position. 7. Click OK in the Sectioning Definition dialog box when done. Note: You cannot re-dimension, move or rotate the plane via the contextual menu command Hide/Show the plane representation. 8.

Positioning Planes On a Geometric Target

You can position section planes, section slices and section boxes with respect to a geometrical targ face, edge, reference plane or cylinder axis). In the case of section slices and boxes, it is the mast plane that controls how the slice or box will be positioned. This task illustrates how to position a section plane with respect to a geometrical target. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation file tree in the common functionalities sample fo cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon

in the DMU
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Space Analysis toolbar and create a section plane. The Sectioning Definition dialog box app

A Section viewer showing the generated section is automatically tiled vertically alongs the document window. The generated section is automatically updated to reflect any changes made to the sec plane. 2. Click the Positioning tab in the Sectioning Definition dialog box.

3. Click the Geometrical Target icon 4. Point to the target of interest:

to position the plane with respect to a geometrical ta

A rectangle and vector representing the plane and the normal vector of the plane appe the geometry area to assist you position the section plane. It moves as you move the cursor.

5. When satisfied, click to position the section plane on the target.

Notes: o o

To position planes orthogonal to edges, simply click the desired edge. A smart mode recognizes cylinders and snaps the plane directly to the cylinder This lets you, for example, make a section cut normal to a hole centerline. To d
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activate this mode, use the Ctrl key.

o

o

Selecting the Automatically reframe option in the DMU Sectioning tab (Tools -> Options -> Digital Mockup -> DMU Space Analysis), reframes the Section viewe locates the point at the center of the target at the center of the Section viewer Zooming in lets you pinpoint the selected point. This is particularly useful when using snap capabilities in a complex DMU sessio containing a large number of objects.

o

6. (Optional) Click the Reset Position icon position.

to restore the center of the plane to its origina

7. Click OK in the Sectioning Definition dialog box when done.
P2 Functionality
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In DMU-P2, you can move the plane along a curve, edge or surface: 1. Point to the target of interest 2. Press and hold down the Ctrl key

3. Still holding down the Ctrl key, move the cursor along the target. The plane is positioned ta to the small target plane 4. As you move the cursor, the plane moves along the curve or edge.

Positioning Planes Using the Edit Position and Dimensions Command

In addition to manipulating the plane directly in the geometry area, you can position the section pl more precisely using the Edit Position and Dimensions command. You can move the plane to a new location as well as rotate the plane. You can also re-dimension the section plane.

In the case of section slices and boxes, it is the master plane that controls how the slice or box wil positioned.

This task illustrates how to position and re-dimension the section plane using the Edit Position and Dimensions command. Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sample fold cfysm/samples. 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning icon Analysis toolbar and create a section plane. in the DMU

A Section viewer showing the generated section is automatically tiled vertically alongside t document window. The generated section is automatically updated to reflect any changes m to the section plane. The Sectioning Definition dialog box is also displayed. 2. Click the Positioning tab in the Sectioning Definition dialog box.
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3. Click the Edit Position and Dimensions icon plane.

to enter parameters defining the position of

The Edit Position and Dimensions dialog box appears.

4.

5. Enter values in Origin X, Y or Z boxes to position the center of the plane with respect to the absolute system coordinates entered. By default, the center of the plane coincides with the center of the bounding sphere aroun products in the current selection. Notes: o Using the Tools -> Options... command (DMU Sectioning tab under Digital Mockup >DMU Space Analysis), you can customize settings for both the normal vector and origin of the plane Units are current units set using Tools -> Options.

o

6. Enter the translation step directly in the Translation spin box or use spin box arrows to scro new value, then click -Tu, +Tu, -Tv, +Tv, -Tw, +Tw, to move the plane along the selected a by the defined step.

Note: Units are current units set using Tools-> Options (Units tab under General-> Parame and Measure).

7. Change the translation step to 25mm and click +Tw for example. The plane is translated 25 in the positive direction along the local W-axis.
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You can rotate the section plane. Rotations are made with respect to the local plane axis sy

You can move the section plane to a new location. Translations are made with respect to th local plane axis system.

8. Enter the rotation step directly in the Rotation spin box or use spin box arrows to scroll to a value, then click -Ru, +Ru, -Rv, +Rv, -Rw, +Rw, to rotate the plane around the selected ax the defined step.

With a rotation step of 45 degrees, click +Rv for example to rotate the plane by the specifi amount in the positive direction around the local V-axis.
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You can edit plane dimensions. The plane height corresponds to its dimension along the loc axis and the width to its dimension along the local V-axis. You can also edit slice or box thickness.

9. Enter new width, height and/or thickness values in the Dimensions box to re-dimension the plane. The plane is re-sized accordingly. 10. Click Close in the Edit Position and Dimensions dialog box when satisfied. 11. Click OK in the Sectioning Definition dialog box when done. • • • Use Undo and Redo icons in the Edit Position and Dimensions dialog box to cancel the last or recover the last action undone respectively.

in the Positioning tab of the Sectioning Definition dialog box Use the Reset Position icon restore the section plane to its original position. You can also view and edit plane dimensions in the Properties dialog box (Edit -> Properties via the contextual menu). This command is not available when using the sectioning command.

•
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More About the Section Viewer
This task illustrates how to make the most of section viewer capabilities:

• •

•

Accessing the Section viewer capabilities Step-by-Step Scenario o Section Viewer o Orienting the section o Working with the 2D grid o Working with a 3D view Detecting collisions (P2)

Accessing the Section viewer capabilities

Most of the commands described in this task are to be found in the Result tab of the Sectionin Definition dialog box or in the Section viewer contextual menu.

Step-by-Step Scenario

Insert the following cgr files: ATOMIZER.cgr, BODY1.cgr, BODY2.cgr, LOCK.cgr, NOZZLE1.cgr, NOZZLE2.cgr, REGULATION_COMMAND.cgr, REGULATOR.cgr, TRIGGER.cgr and VALVE.cgr.

They are to be found in the online documentation filetree in the common functionalities sampl folder cfysm/samples.

icon in the D 1. Select Insert -> Sectioning from the menu bar, or click the Sectioning Space Analysis toolbar and create the desired section plane, slice or box and correspon
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Section Viewer

The Section viewer is automatically tiled vertically alongside the document window. It displays front view of the section, and is by default, locked in a 2D view. Points representing the inters of the section plane with any wire frame elements are also visible in the Section viewer.

Notice that the section view is a filled view. This is the default option. The fill capability genera surfaces for display and measurement purposes (area, center of gravity, etc.). To obtain a cor filled view, the section plane must completely envelop the product. Note: The filled view is not available when the plane sections surfaces. To obtain an unfilled view, de-activate the Section Fill Definition dialog box.

icon in the Result tab of the Section

• •

In the Section viewer, the appearance of the cursor changes to attract your attention t existence of the contextual menu. You can change the default settings for this window using Tools ->Options... command Sectioning tab under Digital Mockup ->DMU Space Analysis).

Orienting the Section
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2. Orient the generated section.Flip and Rotate commands are to be found in the contextu menu. Right-click in the Section viewer and: o o Select Flip Vertical or Flip Horizontal horizontally 180 degrees. Select Rotate Right degrees. or Rotate Left

to flip the section vertically or

to rotate the section right or left

Orienting the section using Flip and Rotate commands is not persistent. If you exit section viewer, any flip and rotate settings are lost.
Working with the 2D Grid

3. Click the Result tab in the Sectioning Definition dialog box, then select the Grid icon under Options to display a 2D grid.

By default, grid dimensions are those of the generated section. Moving the secti plane re-sizes the grid to results. To size the grid to the section plane, clear the Automatic grid re-sizing check box in the DMU Sectioning tab (Tools -> Options..., Mockup -> DMU Space Analysis).

You can edit the grid step, style and mode using the Edit Grid command.

287

project

4. Select the Edit Grid icon to adjust grid parameters: The Edit Grid dialog box appea the above example, the grid mode is absolute and the style is set to lines.

In the absolute mode, grid coordinates are set with respect to the absolute axis system the document.

The grid step is set to the default value of 100. The arrows let you scroll through a dis set of logarithmically calculated values. You can also enter a grid step manually.

Units are current units set using Tools-> Options (Units tab under General-> Paramete and Measure).

5. Scroll through grid width and height and set the grid step to 10 x 10.

6. Click the Relative mode option button: In the relative mode, the center of the grid is pl on the center of section plane. 7. Click the Crosses style option button.
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Grid parameters are persistent: any changes to default parameters are kept and applie next time you open the viewer or re-edit the section.

8. Click the Automatic filtering checkbox to adjust the level of detail of grid display when y zoom in and out. 9. Right-click the grid then select Coordinates to display the coordinates at selected intersections of grid lines. The Clean All command removes displayed grid coordinates.

Note: o

o

You can customize both grid and Section viewer settings using the Tools -> Options... command (DMU Sectioning tab under Digital Mockup ->DMU Spa Analysis). Alternatively, select Analyze ->Graphic Messages ->Coordinate to display t 289
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o

coordinates of points, and/or Name to identify products as your cursor mo over them. Clicking turns the temporary markers into 3D annotations.

10. Click OK in the Edit Grid dialog box when done.
Working with a 3D View

By default, the Section viewer is locked in a 2D view. De-activating the 2D view lets you: • • Work in a 3D view and gives you access to 3D viewing tools Set the same viewpoint in the Section viewer as in the document window.

Returning to a 2D view snaps the viewpoint to the nearest orthogonal view defined in the Sect viewer. 11. Right-click in the Section viewer and select the 2D Lock command from the contextual The Import Viewpoint command becomes available. 12. Manipulate the section plane.

13. Right-click in the Section viewer and select the Import Viewpoint command from the contextual menu. The viewpoint in the Section viewer is set to that of the document wi

14. Continue manipulating the section plane.
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15. Return to a locked 2D view.

The viewpoint in the Section viewer snaps to the nearest orthogonal viewpoint in this v and not to the viewpoint defined by the local axis system of the plane in the document window.

You can also save sectioning results in a variety of different formats using the Export A command in the Result tab of the Sectioning Definition dialog box or the Capture comm (Tools ->Image ->Capture).

16. Click OK in the Sectioning Definition dialog box when done. If you exit the Sectioning command with the Section viewer still active, this window is not closed and filled sectio remain visible.

P2 Functionality - Detecting Collisions

In DMU-P2, You can detect collisions between 2D sections. To do so, click the Clash Detection icon in the Result tab of the Sectioning Definition dialog box.
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Clashes detected are highlighted in the Section viewer.

Collision detection is dynamic: move the section plane and watch the Section viewer display b updated.

Note: Clash detection is not authorized when in the Section Freeze mode.

Displaying the Assembly Mass Properties
This task will show you how to display the assembly mass properties. The mass property of any assembly component is available from its Properties, in the Mechanical tab. The mass property is also available for component in Visualization mode and you can refine the mass to the main body or all the bodies of a Part component. The mass property is set according to the part material. If any material has not been defined, a density of 1 is taken into account. Density can be saved into cgr documents, see Cgr Management for Density. • Be sure that you are working in Design mode, see Cache Management for CATProduct and CATProcess Document.
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•

Open the Assembly_01.CATProduct document.

1. Right-click Assembly_01 in the specification tree and select Properties... from the contextual menu. The Properties dialog box is displayed. 2. Select the Mechanical tab. Three main properties are displayed: • Characteristics: o Volume o Mass o Surface Inertia center Inertia matrix

• •

The Only main bodies option allows you to take into account only the main body of the related parts in the assembly, to determine the mechanical properties.

293

project

3. Redo the two previous steps, working with the Visualization mode. • • The same characteristics and option are displayed. Note that values can be different due that the geometry is not exact in Visualization mode, and has been approximated. A message is displayed in this case.
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4. Click OK.

Managing Constraints
Managing Constraints
This section describes the notions and operating modes you will need to set and use constraints in your assembly structure. Constraints allow you to position mechanical components correctly in relation to the other components of the assembly. You just need to specify the type of constraints you wish to set up between two components, and the system will place the components exactly the way you want. You can also use constraints to indicate the mechanical relationships between components. In this case, constraints are included in the specifications of your assembly.
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project Create a Coincidence Constraint: Click this icon, select the faces to be constrained and enter the properties of the constraint in the dialog box. Create a Contact Constraint: Click this icon and select the faces to be constrained. Create an Offset Constraint: Click this icon, select the faces to be constrained and enter the properties of the constraint in the dialog box. Create an Angle Constraint: Click this icon, select the faces to be constrained and enter the properties of the constraint in the dialog box. Fix a Component: Click this icon and select component to be fixed. Fix Components Together: Click this icon, select the components to be fixed and enter a name for this group in the dialog box. Change Constraint: Select the constraint to be changed, click this icon and select the new type of constraint in the dialog box. Deactivate or Activate Constraints: Select the constraint to be (de)activated and use the Deactivate or Activate contextual command. Select the Constraints of Given Components: Select the components, rightclick and select xxx object -> Component Constraints contextual command. Editing Constraints: you can cut and paste , copy and paste and even delete constraints. Update One Constraint Only: Right-click the constraint to be updated and select the Update contextual command Modify the Properties of a Constraint: Double-click the constraint and enter new properties in the dialog box. Use a Part Design Pattern: Select the pattern, select the component to be repeated, click this icon and enter the specifications in the dialog box. Set a Constraint Creation Mode: Click any of these three constraint creation mode icons Inconsistent or Over-constrained Assembly Search for URLs Associated with Constraints: Click this icon and select the constraint of interest. Reordering Constraints in the Specification Tree

About Assembly Constraints
Constraints
This reference will describe assembly's constraints. About Assembly Constraints Coincidence Constraints Contact Constraints Offset Constraints
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Angle Constraints

Coincidence Constraints
Coincidence Constraints
Coincidence-type constraints are used to align elements. Depending on the selected elements, you may obtain concentricity, coaxiality or coplanarity. The tolerance i.e. the smallest distance that can be used to differentiate two elements is set at 10 -3 millimeters. The following table shows the elements you can select for a coincidence constraint.

Point Line Plane

Sphere Cylinder Axis Tabulated Cone Curve Surface (center) (axis) System Cylinder NA NA

Point

Line

NA

NA

NA

NA

NA

Plane Sphere (center) Cylinder (axis) Cone Axis System Curve NA NA NA NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA
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Surface •

NA

NA

NA

NA

NA

NA

NA

NA

NA

NA: Not Applicable.

To create a coincidence constraint between axis systems, they must have the same direction and the same orientation in the product. You can also create coincidence between an axis system and components of another axis system: • • Origin point. Reference plane, in this case the reference plane must be parallel to the axis system.

Managing Coincidence Constraint
This task consists in applying a coincidence constraint between two faces and modifying the constraint specifications. See Coincidence Constraints reference. Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue-framed and underlined). Open the Constraint1.CATProduct document.

1. Click the Coincidence Constraint icon: 2. Select the face to be constrained, that is the red face as shown.
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3. Select the second face to be constrained, that is the blue circular face in the direction opposite to the red face.

Green arrows appear on the selected faces: • They appear only when the orientation of the selected elements will be taken into account in the coincident constraint and indicate how the selected elements will designed during the assembly update. The arrow on the first selected element is the reference arrow and its orientation cannot be modified. Double-click the any arrows changes the orientation of the arrow on the second selected element. See also constraint

• •
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•

orientation in the Constraint Properties dialog box. Arrow orientations are kept in the constraint and will be displayed as they have been specified when editing the contraint.

The Constraint Properties dialog box appears.

The Constraint Properties dialog box displays the constraints properties: • • The constraint type icon: The status is represented by a traffic lights: o o verified. impossible.
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o • •

not updated.

•

broken. o Name: the constraint name, here Concidence.8 Supporting Elements: components, components geometrical elements involved in the constraint and their status are displayed. Orientation: appear only when the orientation of the selected elements will be taken into account in the coincident constraint: o Undefined (the application computes the best solution) o Same: geometrical element orientations are the same. o Opposite: geometrical element orientations are opposite.

4. Click OK to create the coincidence constraint.

5. Update the assembly if needed.
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•

• •

The application chooses which component is to be moved to adopt its new position. As the assembly is not iso-constrained, any component can be moved. In other words, you cannot control which components will be moved. Green graphic symbols are displayed in the geometry area to indicate that this constraint has been defined. The constraint is added to the specification tree too.

Graphic symbols used for constraints can be customized. For more information, refer to Customizing Constraint Appearance.

Contact Constraints
Contact Constraints
Contact-type constraints can be created between two directed surfaces. Directed means that an internal side and an external side can be defined from a geometrical element, a surface of a pad for example. This definition excludes surfacic element and wireframe surface because they are not directed. The common area between the two surfaces can be a plane (plane contact), a line (line contact) or a point (point contact). The following table shows the elements you can select for a contact constraint. Planar Sphere Cylinder Surface Cone Circle
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Planar Surface Sphere NA

NA

NA

(1) NA

Cylinder

(2)

NA

NA

Cone

NA

NA

Circle • • •

NA

NA

NA

NA: Not Applicable. (1) A sphere-sphere contact is possible when their radius are equal. The contact constraint resulting is equivalent to a coincidence constraint, spheres look like merged. (2) A cylinder-cylinder contact is possible when their radius are equal. The contact constraint resulting is equivalent to a coincidence constraint, cylinders look like merged.

Creating a Contact Constraint
This task consists in applying a constraint between two faces. See Contact Constraints reference. You can create contact constraint between oriented plane. Open the Constraint7.CATProduct document. Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue framed and underlined). 1. Click the Contact Constraint icon: 2. Select the face to be constrained, that is the red face as shown.
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3. Select the second face to be constrained, that is the blue inner face in the direction opposite to the red face. As the contact constraint is created, the red component is moved so as to adopt its new position. Green graphic symbols are displayed in the geometry area to indicate that this constraint has been defined. This constraint is added to the specification tree too.

Graphic symbols used for constraints can be customized. For more information, refer to Customizing Constraint Appearance.

Offset Constraints
Offset Constraints
When defining an offset-type constraint between planar elements, you need to specify how faces should be oriented. The offset value is always displayed next to the offset constraint.
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The unit used is the unit displayed in the Units tab of the Tools -> Options dialog box. If you wish, you can customize it. The following table shows the elements you can select for defining an offset constraint. Point Line Plane Planar Face NA

Point

Line

NA

Plane Planar Face •

NA

NA

NA: Not Applicable.

Positive and Negative Offsets

When setting an offset constraint, you can define positive or negative offset values. For this, remember that: • • • • At least one of the components to be constrained must be a planar element, otherwise you cannot set positive nor negative offset values. The vector normal to the planar element indicates the positive offset value. If the planar element is an oriented plane, the normal vector pointing to the side opposite to material indicates the positive value. If the planar element is a wireframe plane, the application automatically deduces the positive or negative value. Green arrows show the positive value.
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•

If both components are planar elements, the selection order of the elements affects the result when using the orientation option (Same, Opposite, Undefined). The normal to the first selected element gives the positive value.

Creating an Offset Constraint
This task consists in applying an offset constraint between two faces. For information about this type of constraint, see Offset Constraints reference section. Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue-framed and underlined). Open the AssemblyConstraint02.CATProduct document.

1. Click the Offset Constraint icon: 2. Select the face to be constrained, that is the yellow face as shown.
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3. Select the second face to be constrained, that is the blue face in the direction opposite to the yellow face.

Green arrows appear on the selected faces, indicating the orientations. The Constraint Properties dialog box that appears displays the properties of the constraint. The components involved and their status are indicated. You can define the orientation of the faces to be constrained by choosing one of these options: • • • Undefined (the application finds the best solution) Same Opposite

Note that when changing a Same orientation into an Opposite orientation or vice-versa, the application may sometimes position the parts in an unexpected way especially if your system is underconstrained. For the purposes of our scenario, keep the Opposite option.
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4. Enter 38 mm in the Offset field. Affecting a value to an offset constraint, means that the constraint drives the distance between the components. Instead of entering a value, you can check the Measure option. In this case, the value is obtained from the geometry. 5. Click OK to create the offset constraint. A green arrow is displayed in the geometry area to indicate that this constraint has been defined. The offset value is displayed too. This constraint is added to the specification tree too.

Editing Offset Constraints If you decide to make your constraint a measure (for that, just check the Reference option), the offset constraint value displayed in the Value field is the distance between the components at the time you created the constraint. If you wish to modify that value, enter the new value, update the document, then check the Reference option.

Graphic symbols used for constraints can be customized. For more information, refer to Constraint Creation.

Angle Constraints
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Angle Constraints
Angle-type constraints fall into three categories. When defining an angle constraint between planar elements, you need to specify how faces should be oriented. The offset value is always displayed next to the offset constraint: • • • Angle Parallelism (when angle value equals zero), when setting a parallelism constraint, green arrows appear on the selected faces to indicate the orientations. Perpendicularity (angle value equals 90 degrees)

When setting an angle constraint, you will have to define an angle value. Note that this angle value must not exceed 90 degrees. The tolerance i.e. the smallest angle that can be used to differentiate two elements is set at 10-6 radians. The following table shows the elements you can select for an offset constraint. Line Plane Planar Face Cylinder (axis) Cone (axis)

Line

Plane Planar Face Cylinder (axis) Cone (axis)

Creating an Angle Constraint
This task consists in setting an angle constraint between two planes. See Angle Constraints reference. Before constraining the desired components, make sure it belongs to a component defined as active (the active component is blue-framed and underlined). Open the AssemblyConstraint03.CATProduct document.
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1. Click the Angle Constraint icon: 2. Select the face to be constrained, that is the blue face as shown.

3. Select the second face to be constrained, that is the red face in the same direction of the blue face.

The Constraint Properties dialog box is displayed with the properties of the selected constraint and the list of available constraints: • • • • Perpendicularity Parallelism (you then need to define the orientation of the faces. You can choose between Undefined, Same, Opposite options) Angle Planar angle (an axis is to be selected. This axis must belong to both planes)
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Note that when changing a Same orientation into an Opposite orientation or vice-versa, the application may sometimes positions the parts in an unexpected way especially if your system is under-constrained.

4. Keep the Angle option. 5. Enter 40 deg in the Angle field and keep Sector 1. A Sector combo box appears only when you select two geometries for which the orientation can be defined (this rule excludes line or edge). Four angle sectors are available: Direct Angle Angle + 180 deg 180 deg - Angle 360 deg - Angle 6. Click OK to create the angle constraint. As the angle constraint is created, the red component is moved so as to adopt its new position. A green arrow is displayed in the geometry area to indicate that this constraint has been defined. The angle value is displayed too. This constraint is added to the specification tree too.
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Graphic symbols used for constraints can be customized. For more information, refer to Customizing Constraint Appearance.

Changing/Updating/Selecting/Searching Constraints
Deactivating or Activating Constraints
Deactivating or activating constraints means specifying if these constraints must be taken into account during updates or not. This task consists in deactivating then activating a constraint. Open the AnalyzingAssembly04.CATProduct document and make sure the Design Mode is on. 1. Right-click the Coincidence.3 constraint and select the Deactivate command from the contextual menu. The constraint is deactivated. The mask representing a deactivated constraint appears with red parentheses, on the constraint's icon in the specification tree.

The deactivated constraint is now displayed in white in the geometry window.
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2. Right-click the Coincidence.3 constraint and select the Activate command from the contextual menu.

Changing Constraints
Changing a constraint means replacing the type of this constraint by another type. This operation is possible depending on the supporting elements. You can select any constraints, not necessarily in the active component. This task consists in changing the parallelism constraint into an offset constraint. Open the AssemblyConstraint05.CATProduct document. 1. Select the constraint to be changed.

2.

Click the Change Constraint icon:
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The Change Type dialog box that appears, displays all possible constraints.

3. 4. 5.

Select the new type of constraint. For the purposes of our scenario, select Offset. Click Apply to preview the constraint in the specification tree and the geometry. Click OK to validate the operation.

Reordering Constraints in the Specification Tree
This task shows you how to modify the location of assembly constraints in the specification tree to classify them the way you want. The application lets you reorder constraints but also gather them in sets. You can perform these operations within the Constraints node: • • • • • Reordering Constraints Gathering Constraints in a Set Creating a Set Before Gathering Constraints Handling Sets You can move all types of constraints. What is more, the application does not take their status into account: if they are deactivated or
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• •

even broken, you can relocate them. Whatever operation you perform for modifying their locations in the tree, it never affects the geometry of your assembly. You cannot create a set of constraints in a flexible assembly. If you make a rigid sub-assembly as flexible, set of constraints will be removed.

Open the AnalyzingAssembly02 CATProduct document.

Reordering Constraints
1. Select Coincidence.4 as the constraint to be moved and right-click the Coincidence.4 object-> Reorder constraints contextual command.

2. Select Coincidence.10 as the constraint below which Coincidence.4 is to be located. Coincidence.4 has been moved.
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Gathering Constraints in a Set
3. To group Surface contact.5 and Surface contact.6 constraints, multiselect them and use the Selected objects -> Group in new set contextual command. The application has created Set.1 containing both surface constraints. 4. Select Set.1 and right-click to use the Properties contextual command. 5. In the Properties dialog box that appears, rename Set.1 as Surface Contact Constraints in the Feature Name field of the Feature Properties tab. 6. Expand this node. You must obtain this:
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Creating a Set Before Gathering Constraints
7. Select the node Constraints and right-click to use the Constraints object->Add Set contextual command. A new set, Set.2, appears in the tree, at the same level as 'Surface Contact Constraints' set. It has been created at the first level of the Constraints node.

8. Multi-select Coincidence.7, Coincidence.10 and Coincidence.4 and right-click to use the Selected objects -> Reorder constraints contextual commands.
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9. Select Set.2 as the new location for these constraints. 10. Expand the new node to check that Set.2 contains the three constraints:

Handling Sets
11. Right-click Set.2 and select Set.2 object to display the contextual menu available for this node. The following contextual commands are available: • • • • • Add set: creates a set at the level below (in our example, Set.3 would be created below Set.2). Remove set: deletes the set, not the constraints it contained. Group in new set: locates the selected set within a new set. Move Set after: moves the set after the set you select. Move Set inside: moves the set within the set you select.

Refreshing Constraints
This task consists in refreshing constraints. For constraints pointing published element in a missing component, the constraint's masks remain broken after inserting the missing component. Because there is now way to inform these constraints that the component is
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back, they cannot be automatically re-evaluated. This contextual command is available for: • • • A constraint object, only the selected constraint is refreshed. A constraints node in the specification tree, all constraints in the node are refreshed. A set of constraints, all constraints in the set are refreshed.

Open the Assembly_02.CATProduct document. 1. Expand the specification tree. Concidence.3 and Concidence.4 constraints are broken.

2. Right-click Assembly_02 and select Components -> Existing Component... from the contextual menu. Select the Sub_Product1.CATProduct document. Constraint's status still broken.

3. Right-click Constraints and select Constraints object -> Refresh Constraint from the contextual menu. Constraint's status have been modified. Their status have been reevaluated to not up to date.
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Editing Constraints
This task explain how to edit constraints. When you are editing a constraint, you can: • • • Rename the constraint. Change the referenced geometries. Modify its options.

The Copy/Cut/Paste commands are available for valuated constraints only. In this case, only the constraint's value, for the same type of constraint offset or angle, can be pasted. Concerning the Cut command, it deletes the constraint and copy its value. Open the Assembly_01.CATProduct document. 1. Double-click the Surface contact.3 constraint. The Constraint Definition dialog box appears.

2. Click the More>> button to expand the dialog box.
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The traffic lights displays the constraint status: • • • • verified. impossible. not updated. broken.

Two contextual commands improving display are available in the Supporting Elements field: • • Reframe on views the constraint of the selected component at the center of the geometry window. Center Graph zooms in the selected component in the specification tree.

Constraints and Object in Work
When you are setting constraints and designing part in the assembly at the same time, it is possible that you are modifying the referenced geometries of the constraints. In other words, the geometry of the current feature does not contain the original geometry referenced by the constraint. In fact, the constraint references the original geometry which already exists in the history but not for the current object in work. In this case, the application cannot highlighted the geometry or the constraint seems to be wrong. This can happen for Sheet Metal Design features or when you add a transformation feature in Part Design context for example after the constraint's creation.
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The body or the brick-red part has been translated using the translate transformation feature of Part Design, note that its magenta axis system has not been moved. The constraint is already verified although one of its referenced geometry has been moved.

Modifying the Properties of a Constraint
This task consists in modifying the mechanical properties and attributes of a constraint.
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Open the AssemblyConstraint02.CATProduct document and create an offset constraint. 1. Right-click the offset constraint to be modified. You can select the constraint in the specification tree or in the geometry.

2. Select Properties from the contextual menu. The Properties dialog box that appears displays four tabs.

Constraint tab The Constraint tab displays the name of the constraint as well as the name and type of the supporting components. You can rename the constraint if desired. The constraint status is also indicated. In our scenario, the constraint is connected. To find out how to reconnect broken or misconnected constraints. 3. Enter a new value in the Offset field. For example, enter 75 mm. 4. Set the Orientation option to Same so as to reverse the blue component.
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Instead of using the Properties contextual command to edit the properties as described above, you can double-click the constraint to be edited to display the related dialog box: in which you can modify the same properties:

Mechanical tab 5. Click the Mechanical tab. 6. Three attributes characterize constraints: Deactivated: deactivated constraints are not taken into account when updating the assembly To update: the constraint does not reflect the latest changes to the assembly Unresolved: the application detects problems 7. Check Deactivated. The constraint is modified accordingly.

Note that parentheses precede the constraint value, indicating that the constraint is deactivated. These parentheses precede the name of the constraint in the specification tree too. The color of the graphic symbol is modified.

Feature Properties tab 8. Click the Feature Properties tab.
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This tab displays the constraint's name as well as its creation and last modification date. You can edit the constraint's name.

Graphic tab 9. Click the Graphic tab. The Graphic tab lets you define the graphic properties of your constraint. Color Line type (Dotted, Small dotted etc.) Thickness (Different values) Select the color of your choice from the list. You can also define your own colors by selecting the More Colors... command at the bottom of the list. To know more about defining personal colors, please refer to Infrastructure User's Guide. You cannot define a new color for deactivated constraints. For the purposes of our scenario, you need to reactivate the constraint.

If you wish to change the color for a given status (resolved, unresolved, over-contrained, invalid geometry) use the Tools -> Options command. For more, see Customizing Constraint Appearance.

Selecting the Constraints of Given Components
This task consists in selecting all the constraints defined for a component. You can only select child components of the active component. The Component Constraints command allows you to select the constraints linked to one or more selected components. These components are child components of the active component.
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Open the Assembly_01.CATProduct document, use the Show capability if the constraints are not visible, and ensure the design mode is on. 1. Select the component whose constraints are to be selected. Multiselection is also possible.

2. Right-click and select CRIC_FRAME.1 object -> Component Constraints command from the contextual menu. The application highlights two constraints, both in the specification tree and the geometry area.
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Updating One Constraint Only
When you need to update your constraints, either you update all the constraints of the active component or update one or more constraints of the active component. By default, constraints needing an update are displayed in black. To redefine the colors of the constraints, please refer to Customizing Constraint Appearance. This task consists in updating the constraints you explicitly specify. 1. Right-click the constraint to be updated. Constraints needing an update are displayed with specific graphic properties. The Properties dialog box indicates too if constraints need updates or not. For more information, please refer to Modifying the Properties of a Constraint. You can select the constraint in the specification tree or in the geometry. 2. Select Update from the contextual menu. The selected constraint is updated. 3. Click the second constraint to be updated. 4. Control-right-click the third constraint to be updated. 5. Select the Update contextual command. The two selected constraints are updated too. Remember, valid constraints are green by default.
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Inconsistent or Over-constrained Assemblies
This task shows you what happens when the application detects an overconstrained assembly. Open the AssemblyConstraint02.CATProduct document. 1. Create the offset constraints as shown below: • • top face of Part5 and bottom face of CRIC_FRAME top face of Part5 and top face of CRIC_FRAME
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The two constraints are green colored because they are consistent. There is any overconstraint, their values respect the position of the two parts. 2. Set the value of Offset.7 constraint to 45.
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3. Update the assembly if you are in manual update. The update operation detects difficulties to obtain a valid constrained system: the Update Diagnosis dialog box appears providing the diagnosis of the problem.

The constraints involved in the inconsistent or over-constrained system are displayed. The application indicates: • • The constraint causing trouble: Offset.7 Constraint Offset.6, which is valid but involved in the inconsistent or over-constrained system .

To resolve the problem, you can edit, deactivate, isolate or delete the desired constraint. 4. Select Offset.6, click the Deactivate button and click Close.
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5. Close the dialog box, update the assembly if needed. The assembly is now consistent.

Searching for URLs Associated with Constraints
This task shows you how to check that a constraint has been assigned URLs (Universal Resource Locators), then how to search for a given URL. Open the Moving_Components_02 document that contains URLs created in the Knowledge Advisor workbench. 1. Click the Comment and URLs icon: The URLs and Comment dialog box is displayed. 2. Select the constraint "Surface contact.18". The URL field indicates that this constraint has been assigned two URLs: "Dassault Syst mes" and "Delmia".
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3.

Click "Delmia". The associated URL is displayed in the URL field. You just need to click the Go button to access the corresponding web site. Searching for a URL

4. Click the Explore tab. The list of all the URLs assigned to all the constraints defined in this CATProduct document is displayed. 5. Enter the name of the URL to be searched for in the Search field. For example, enter "Delmia".

6. Click Search. If the specified URL is found, "yes" is displayed in the Found column. In the Edit tab, the URL is highlighted.
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Analyzing Constraints
This task shows you how to analyze the constraints of an active component. All the items displayed in the Constraint Analysis dialog box are editable according to their respective behavior (Copy, Cut, Paste, Delete, etc). Open the AnalyzingAssembly02.CATProduct document. 1. Select Analyze -> Constraints. The Constraint Analysis dialog box is displayed. The Constraints tab displays the status of the constraints of the selected component:

The Constraints tab displays the status of the constraints of the selected component: • • • • Active Component displays the name of the active component. Component displays the number of child components contained in the active component. Not constrained displays the number of child components not constrained in the active component. Status displays the status of the constraints: o Verified displays the number of verified constraints. o Impossible displays the number of impossible constraints. "Impossible" means that the geometry is not compatible with the
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constraint. For example, a contact constraint between two cylinders whose diameter is different is impossible. The yellow unresolved symbol is displayed in the specification o tree on the constraint type icon: Not updated displays the number of constraints to be updated. The application has integrated new specifications, which affect constraints. The update symbol is displayed in the specification tree on the constraint type icon: Broken displays the number of broken constraints. A reference element is missing in the definition of these constraints. It may have been deleted for example. You can then reconnect this constraint (see Reconnecting Constraints). The yellow unresolved symbol is displayed in the specification tree on the constraint type icon: Deactivated displays the number of deactivated constraints (see Deactivating or Activating Constraints). The deactivated symbol is displayed in the specification tree. It . precedes the constraint type icon: Measure Mode displays the number of constraints in measure mode. Fixed Together displays the number of fix together operations. Total displays the total number of constraints of the active component.

o

o

o o o

In our scenario, the command displays the status of all constraints defined in AnalyzingAssembly product. The command Analyze -> Constraints. displays the status of constraints defined for sub-assemblies too. What you have to do is set the combo box on top of the dialog box to the sub-assembly name of your choice. In addition to the Constraints tab, the Broken tab and the Deactivated tab provide the name of the broken and deactivated constraints already indicated in the Broken and Deactivated fields. The constraints are clearly identified in these tabs and you can select them. Once selected, they are highlighted both in the tree and in the geometry area.
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Additional tabs may be displayed if one of these constraint status exists: • • • Impossible. Not updated. Measure Mode.

The tab Degrees of freedom also displays if all constraints of a given component are valid. To redefine the colors of the different type of constraints, see Customizing Constraint Appearance. This capability does not show overconstrained systems. The application detects them when performing update operations. For more information, see Inconsistent or Over-constrained Assemblies. You can also use the command Analyze -> Dependence, see Analyzing Dependences. 2. Click OK to exit and delete the following constraints to perform the rest of the scenario: Coincidence.12, Parallelism.15 and Line Contact.16. The document now contains only seven constraints. They all are verified. 3. Select Analyze -> Constraints again. The Constraints Analysis dialog box no longer contains the tabs Broken and Deactivated. 4. Click the Degrees of freedom tab.

335

project

The application displays this tab only if all constraints are verified. The tab displays the components affected by constraints and the number of degrees of freedom remaining for each of them. 5. Double-click CRIC_TOP.1. The Degrees of Freedom Analysis dialog box is displayed.

One rotation as well as one translation remain possible for CRIC_TOP.1. For more information, please refer to Analyzing Degrees of Freedom.
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6. Click Close then OK to exit.

Fixing Components
Fixing a Component
This task shows you how to set the first constraint. This operation consists in fixing the position of a component in space so as to use this component as the base of the assembly. 1. Select CRIC_FRAME in the specification tree or in the geometry area. 2. Click the Fix Component icon in the Constraints toolbar.

The component CRIC_FRAME is immediately fixed. The application indicates this by displaying a green anchor symbol on the component.

Note also that the Constraints branch now displays the new constraint. The anchor symbol is preceded by a lock symbol, to make a distinction between "fix in space" and "fix operations". For more information, pleaser refer to Fixing a Component.
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Fixing Components Together
This task consists in fixing two components together. The Fix Together command attaches selected elements together. You can select as many components as you wish, but they must belong to the active component. Open the Fix.CATProduct document. 1.

Click the Fix Together icon: This command is also available from the Insert menu and works both in design and visualization mode.

2. 3.

Select CRIC_FRAME. Select CRIC_BRANCH_3. You can select the components in the specification tree or in the geometry area.
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4.

The Fix Together dialog box appears, displaying the list of selected components. To remove a component from the list, just click it.

5. 6.

In the Name field, enter a new name for the group of components you want to create. For instance, enter FT1. Click OK. The components are attached to each other. Note Moving one of them (using the compass combined with the Shift key or using the option "With respect to constraints" in the Manipulate dialog box) moves the other one too. The specification tree displays this operation.
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Because you can inadvertently move these components, the application displays the dialog box Move Warning to remind you that you are moving components fixed together. According to the selected options, Move components involved in a Fix Together option is affected.

• •

If you check the Extend selection with all involved component option, these components will be move together as long as the option will be checked. If you check the Do not show this warning next time option, the dialog box will not be displayed and: o If the Extend selection with all involved component option is checked, the Move components involved in a Fix Together option is set to Always. o If the Extend selection with all involved component option is unchecked, the Move components involved in a Fix Together option is set to Never. o To display again this dialog box, check Ask each time option in Move components involved in a Fix Together.

A Few Notes about Fix Together
You can select a set of attached components to apply the Fix Together command between this set and other components. You can set constraints between components belonging to a set of components fixed together. If you set a constraint between a component and a set of attached components, the whole set is affected by the constraint. You can deactivate or activate a set of attached components by using the Deactivate/Activate contextual command available in the specification tree. Red
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parentheses preceding the graphic symbol indicate deactivated sets.

Assemblies, Sub-Assemblies, and Parts
Modifying an Assembly
Modifying an Assembly
Replace Components: click this icon and select a component. Reconnect a Replaced Representation: Right-click a component and select Representations -> Manage Representations from the contextual menu. Reconnect Constraints: Double-click a constraint to edit it,

Replacing Components
This task shows you how to replace components into an assembly. In an assembly you may replace: A component by a component completely different (a jack by a wheel for example). A component by a component from the same family (a gearbox by another for example). Both cases the constraints reconnection is only warranted either: Component's product structure is the same. Instance's names of products in the replacing component are the same. Constraints reference the same published

elements. See Reconnecting Constraints.
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1. Select a component in the specifications tree.

2. Click the Replace Component icon toolbar.

in the Product Structure Tools

Reconnecting a Replaced Representation
This task first consists in replacing a representation then in reconnecting geometrical elements. Open the Reconnect01.CATProduct document.

1. Right-click on SCREW in the specifications tree.

2. Select Representations -> Manage Representations from the contextual menu. The Manage Representation dialog box is displayed.
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3. Click on CRIC_SCREW.model in the Source field. 4. Click Replace... The Associate Representation dialog box is displayed. 5. Navigate to open the CRIC_SCREW_NEW.model. 6. The Reconnect Representation dialog box is displayed.
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A window containing the assembly with the old representation is displayed in the window to the left of the dialog box. A window containing only the new representation is displayed to the right of the dialog box. You are going to reconnect the geometrical elements in this window.

5. To reconnect the highlighted geometric element of the old representation, that is a line, select the axis of the new representation. 6. Select Plane and select the circular face as shown to reconnect the plane.
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Two "Yes" are now displayed in the Reconnect field. 6. Click OK to validate. 7. Click Close to close the Manage Representation dialog box. The representation is replaced and constraints are valid.

Reconnecting Constraints
Reconnecting constraints means defining new supporting elements for these constraints. You perform this operation to correct mistakes you made while assembling components or the mistakes detected by updates. This task shows you how to reconnect two constraints.
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Open the AssemblyConstraint06.CATProduct document. 1. The assembly contains a contact and a coincidence constraint that need to be reconnected. Double-click the contact constraint to be reconnected.

2.

In the Constraint Edition dialog box that appears, click More to access additional information. The names of supporting elements are now displayed.

3. Click CRIC_BRANCH_3 then Reconnect. 4. Select the blue face as shown to specify the new supporting face.
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5.

Click OK. The contact constraint is reconnected:

6. 7. 8. 9.

Now select the coincidence constraint in the geometry or in the specification tree. Select the Properties contextual command. In the Properties dialog box that appears, click CRIC_BRANCH_3. Click Reconnect...
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The window that appears displays the components.
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Advanced Tasks 10. Select the axis passing through the circular faces.

11. Click OK to close the window. 12. Click OK to close the Properties dialog box. Because they are only two constraints defined on this product, the application can compute several results. This is an example of what you can obtain:

Flexible Sub-Assemblies
In the product structure from earlier versions you could only move rigid components in the parent assembly. Now, in addition to this behavior, you can dissociate the mechanical structure of an assembly from the product structure, and this within the same CATProduct document. As a consequence, you can move the components of a sub-assembly in the parent assembly. In a first time, this task recalls the behavior of rigid assemblies, then illustrates how to make sub-assemblies flexible and how constraints defined
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in the reference document affect them. Eventually you learn how to analyze the mechanical definition of an assembly whenever this assembly includes flexible sub-assemblies (and components attached together, see Fixing Components Together). • • When a sub-assembly is flexible, you can apply updates to it, move it when constrained and set constraints to it. What you need to keep in mind is that rigid sub-assemblies are always synchronous with the original product, whatever mechanical modification you perform. Flexible sub-assemblies can be moved individually, without considering the position in the original product. Since Release 7, you can edit the constraints defined for flexible subassemblies. The changes made to these constraints do not affect the constraints defined for the original product contained in the reference document. You can edit the following attributes: o values o orientation o driving/driven properties Set of constraints in a rigid sub-assembly will be removed when you make it flexible.

•

•

Open the Articulation.CATProduct and chain.CATProduct documents. The product Articulation includes one CATProduct and two CATPart documents as follows:

1. Drag and drop the compass onto link (link.1), then select link (link.1) and drag it. The whole chain -and not link.1 only- is moved.
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2. Undo this action to return to the initial state. 3. To make chain (chain.1) flexible, right-click it and select the chain.1 object -> Flexible/Rigid Sub-Assembly contextual command. Alternatively, click the Flexible Sub-Assembly icon .

You can notice that the little wheel to the left corner of the chain icon has turned purple. This identifies a flexible sub-assembly.

4. You can now move link (link.1) independently from link (link.2). For example drag and drop the compass onto link (link.1) and move it in the direction of your choice.
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5. Copy and paste chain (chain.1) within Articulation.CATProduct. You can notice that the property "flexible" is copied too.

6. To make chain (chain.2) rigid, right-click it and select the chain.2 object -> Flexible/Rigid Sub-Assembly contextual command. A message window appears. 7. Drag and drop chain (chain.2) to clearly see both instances of chain.CATProduct.
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8. In chain.CATProduct, move link (link.1) using the compass.

You can notice that because chain (chain.2) is rigid, it inherits the new position of the original chain.CATProduct. Conversely, chain (chain.1) remains unchanged.

What you need to keep in mind is that rigid sub-assemblies are always synchronous with the original product, whatever mechanical modification you perform. Flexible sub-assemblies can be moved individually, without considering the position in the original product. Since Release 7, you can edit the constraints defined for flexible subassemblies. The changes made to these constraints do not affect the constraints defined for the original product contained in the reference document.
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You can edit the following attributes: • • • values orientation driving/driven properties

9. Set an angular constraint between Link 1 and Link 2 in chain.CATProduct. For example, set 80 as the angle value.

You can notice that both instances, chain (chain.2) and chain (chain.1) inherit this constraint.

10. Edit the value of the angle constraint for chain (chain.1). Enter 100 for example. This new value is specific to chain (chain.1). Because chain (chain.1) is a flexible sub-assembly, this value can no longer be affected by changes to the value set in the reference document.
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11. Edit the value of the angle constraint set in chain.CATProduct. For example, enter 50 as the new value: because chain (chain.2) is a rigid sub-assembly, and as the constraint value for chain (chain.1) has been already redefined, chain (chain.2) is the only sub-assembly to inherit this new value.

Mechanical Structure
12. Select the Analyze -> Mechanical Structure... command to display the mechanical structure of Articulation.CATProduct. This mechanical structure looks different from the product structure. In Mechanical Structure Tree dialog box, chain.2 is displayed because it is a rigid sub-assembly. Conversely, chain.1 is not displayed since it is a flexible sub-assembly.

355

project

This display is merely informative. Note that you can use the Reframe graph contextual command and the zoom capability to improve the visualization, but also the Print whole contextual command to obtain a paper document. For information on printing, please refer to Printing Documents.

Selecting Using a Filter
This task will show you how to manage and customize the sub-geometry selection in order to avoid any ambiguity.
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The User Selection Filter toolbar is divided into two sections: • The first section lets you filter elements according to their type: o o o • point type. curve type. surface type.

volume type. o The second section lets you filter elements according to their mode: o o Feature Element Filter selects the whole feature whether it is a sketch, product, pad, join, etc. Geometrical Element Filter enables to sub-elements of a feature such as faces, edges or vertices.

By default, all the icons are deactivated which means that no filter is applied but you can restrict the selection to specific element types by clicking the corresponding icons. Bear in mind that: • • • If you deselect a type, it cannot be selected in the geometry anymore unless all other types are deselected. If you deselect a mode, it cannot be selected anymore for each active type unless other modes are deselected. It is not possible to activate both filter modes simultaneously (it does not make sense anyway). Only two states are available: either Feature Element Filter or Geometrical Element Filter is activated or both modes are deactivated.

By selecting Assembly Design commands, some filtering types turn disabled because they are inconsistent according to the elements allowed in the command. • • You need to activate the User Selection Filter toolbar by selecting the View -> Toolbars command and clicking User Selection Filter. Open the Assembly_01.CATProduct document.

1. Click the Coincidence Constraint icon: Note that the Volume Type icon is disabled according to the Coincidence Constraint specifications.
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2. Click the Surface Type icon: 3. Drag the mouse over any surface assembly. The cursor shape is modified when passing over a selectable element.

4. Un-click the Surface Type icon:

and click Curve Type icon:

5. Drag the mouse over the same surface as previous. The forbidden cursor appears when passing over a selectable element.
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Reusing a Part Design Pattern
This task shows you how to repeat a component reusing a pattern created with the Part Design workbench. There are two work modes according to the Keep link with the pattern option: • • The option is on: you are creating associativities between the geometry and the pattern definition. The option is off: there is no associativity.

Working with associativity, you can decide whether you need to make instances associative with the pattern or generated constraints. This is mean that you can modify a reused pattern through the its definition only: if you delete any instantiated element (geometry or constraint) outside the definition, it will be recreated during the next update of the reuse pattern. Three types of patterns are reusable: • • • Rectangular pattern. Circular pattern. User pattern.

The option Automatic switch to Design mode is available for the Reuse Pattern command. For more about this option, refer to Access to geometry. Open the Pattern.CATProduct document. 1. Select the rectangular pattern in the tree or in the geometry.

2. Control-click to select the component to be repeated, that is Part2.
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Selecting a constraint linking a pattern to a component selects both the pattern and the component. 3. Click the Reuse Pattern icon: The Instantiation on a pattern dialog box appears, indicating; • • • the name of the pattern. the number of instances to be created (for information only). the name of the component to be repeated.

4. Ensure that the option Keep link with the pattern is on and check pattern's definition to make instances associative with the pattern's geometry. To know more about associativity with constraints, refer to Re-using constraints.
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To define the first instance of the component to be duplicated, three options are available: • • • reuse the original component: the original component is located on the pattern, but remains at the same location in the tree. create a new instance: the original component does not move and a new one is created on the pattern. cut & paste the original component: the original component is located on the pattern and moved in the tree.

5. Make sure the option re-use the original component is selected. To control the location of the components in the tree, two options are available: • • You can check the option Put new instances in a flexible component to gather all instances in the same component or conversely uncheck the option to create as many components as there are generated instances.

6. Check the option Put new instances in a flexible component.

7. Click OK to repeat the screw. 31 instances are created on the pattern.

The new component Gathered Part2 on RectPattern.1 is displayed in the tree. An entity Assembly features has been created in the tree. Reused Rectangular Pattern.1 is displayed below this entity.
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The Apply button executes the command but the dialog box remains open so as to let you repeat the operation as may times as you wish. 8. Double-click RectPattern.1 to edit it. Enter 5 instances for both directions. 9. Return to Assembly Design and make sure that the assembly is updated. You can notice that associativity between the pattern and the instances of Part2 has been maintained since the option Keep link with pattern and Pattern's definition were switched on. Only 17 instances have been generated.

Reusing Constraints
If you use the option generated constraints, the Reuse Constraints section displays the constraints detected for the component and makes all original constraints available for selection: You can define whether you wish to reproduce one or more original constraints when instantiating the component.
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To remove a constraint from the list, click on that constraint. To remove all constraints from the list, click Clear. Conversely, Click All to include all constraints in the selection.

Contextual Commands
The following contextual commands are available for Reused Rectangular Pattern.1: • • Definition: displays information on the pattern. If some instantiated components are not verified, you can select them and apply a local update. Deactivate/Activate: deactivates or activates the constraints defined on the instantiated components.

More about Patterns
This task you have just performed shows you that you can reuse constraints set between the part to be duplicated and the pattern: the generated instances are constrained too. You can reuse constraints set between the part to be patterned and other parts. In the following example, two constraints are set between screw.1 to be patterned and Tray.1 (green part) and two other constraints are set between the screw.1 and Bracket.1 (blue part).
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After applying the Reuse Pattern command to the screw, generated instances are constrained too:

Managing Assemblies
Checking Component Position
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Advanced Tasks This task shows you how to reset and check component position. You've created an Enhanced Scene in which you've modified the position attributes. 1. Double-click Scene.1 either in the specification tree or in the geometry area. The context is changed to the Enhanced Scene context. 2. In the specification tree, right-click Scene.1 and select Scene.1 object -> Check Position. All moved items are highlighted in the specification tree and in the geometry area. To reset the position of the moved items, see Applying an Assembly Context to an Enhanced Scene.

Exploding the Assembly
This last task illustrates the use of the Explode capability. Exploding the view of an assembly means separating the components of this assembly to see their relationships. 1. Make sure Product 1 is selected. 2.

Click the Explode icon

in the Move toolbar.

The Explode dialog box is displayed.

Product 1 is the assembly to be exploded. The Depth parameter lets you choose between a total (All levels) or partial (First level) exploded view. 3. Set All levels if not already set. 4. Set 3D to define the explode type.
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The usefulness of this operation lies in the ability of viewing all components separately. Note that you can move products within the exploded view using the 3D compass.

6.

Click OK to validate the operation and then click Yes at the prompt or click Cancel to restore the original view. Well, you have done all the tasks of the Getting Started section. Why not consult the rest of the documentation?

Adding, Replacing and Deleting Components in the Assembly
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Advanced Tasks This task shows you how an Enhanced Scene is affected when you add, replace and delete components in the Assembly. The Add, Replace and Delete functionalities are not available in Enhanced Scene context, only in Assembly context. Insert the following sample model files in the cfyug samples folder: • • • • • • • • ATOMIZER BODY1 BODY2 LOCK REGULATOR TRIGGER VALVE REGULATION_COMMAND

1. Click the Enhanced Scene icon

and create an Enhanced Scene.

You are now in a scene window. The background color has turned to green and Scene.1 is added in the specification tree. to swap to the main window. 2. Click the Exit Scene icon You return to Assembly context.

Adding Components in the Assembly
In Overload Mode Full, components added in Assembly context will have not appear in the Enhanced Scene. In Overload Mode Partial, the behavior will be as described below. You will now add the NOZZLE: 3. Right-click Product1 in the specification tree and select Components -> Existing Component. 4. Shift-select NOZZLE1.model and NOZZLE2.model and then click Open. The added components (NOZZLE_1 _2 and NOZZLE_1_2) are identified in the specification tree and added in the geometry area. 5. In the specification tree, double-click Scene.1 to swap to the Enhanced Scene context. The newly-added components will appear in the specification tree and in the geometry area, assuming that, when they were added in the
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For example, given the following Assembly configuration,

if you created an Enhanced Scene that contained only product P1 and you add a product under product P1 in the Assembly, then the added product will appear under P1 in the Enhanced Scene. However, if you add a product under the Root in the Assembly, it will not appear in the Enhanced Scene. 6. Click the Exit Scene icon to return to Assembly context.

Replacing Components in the Assembly
7. Replace, for example, the BODY1 in the Assembly with the BODY2.model (right-click BODY1 in the specification tree, select Components -> Replace Component from the contextual menu, then, in the File Selection dialog box, select BODY2.model and click Open.) The Assembly is updated accordingly.

8. Double-click Scene.1 in the specification tree to enter the scene. Scene.1 has been updated in the same manner as the Assembly, assuming that the replaced product was previously visible in the Enhanced Scene. 9. Click the Exit Scene icon to return to Assembly context.

Deleting Components from the Assembly
10. Delete, for example, the BODY2 from the Assembly (right-click it in the specification tree and select Delete from the contextual menu.) The Assembly is updated accordingly.
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11. Double-click Scene.1 to enter the Enhanced Scene. Scene.1 has been updated in the same manner as the Assembly, assuming that the deleted product was previously visible in the Enhanced Scene.

Managing Enhanced Scenes
Managing Enhanced Scenes
About Enhanced Scenes Creating an Enhanced Scene Select the products of the Assembly that will define the Enhanced Scene content and click the Enhanced Scene icon. Generating an Enhanced Scene from an Old Scene Select the Old Scene in the specification tree and click the Enhanced Scene icon. Browsing Enhanced Scenes using the Scenes Browser In DMU Review Navigation toolbar, click Scenes Browser icon, then double-click the image of an Enhanced Scene. Activating an Enhanced Scene In the specification tree, double-click the Enhanced Scene or in the Scenes Browser, double-click the image corresponding to the Enhanced Scene. Exploding an Assembly Select the products to be exploded and click the Explode icon. In the Explode dialog box, set parameters and click Apply. Overloading Attributes in Enhanced Scene Context Select products, click the icon corresponding to the attribute to be overloaded. Managing Attribute Overloads, Double-click Scene.1 in the specification tree, in specification tree, right-click Scene.1, select Scene.1 object -> Manage Attributes Overloads in the contextual menu. Adding, Replacing and Deleting Component in the Assembly Checking Component Position Select products, In the specification tree, rightclick Scene.1 and select Scene.1 object -> Check Position. Saving a Viewpoint in Enhanced Scene Context Modify viewpoint and click the Save Viewpoint icon. Creating an Enhanced Scene Macro Applying an Enhanced Scene Context to an Assembly Click Apply Scene on Assembly icon, select attributes to be applied, click OK or in the Scenes Browser, customize settings to apply scene context to assembly and doubleclick the image of the scene to apply.
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Applying an Assembly Context to an Enhanced Scene Click Apply Assembly on Scene icon, select attributes to be applied, click OK. Automating Enhanced Scene Context Application Using User-defined Attributes Saving a Enhanced Scene in ENOVIAVPM Exiting Enhanced Scene Context

About Enhanced Scenes
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Enhanced Scenes
An enhanced scene can be seen as an alternative view of an assembly in a defined state. It enables you to study a variant of your mock-up by defining specific component positions and specific attributes. You can overload the following attributes: • Component Positioning (using compass manipulation, snap or explode commands) • Component Graphical attributes (color, transparency, line type, line thickness) • Node Activation state • Component Hide / show state • Viewpoint One of the major benefits of Enhanced Scenes is that the applicative data container will be available and functionalities associated with the applicative data will also be available in Enhanced Scene context. It will be possible to generate Enhanced Scenes from Old Scenes. Overloading of attributes (graphical, show / no show state, etc.) is limited to Products, i.e. these modifications are not replicated between scene and assembly for Products, however, for parts, models and manikins these modifications will be replicated (modifications on parts, models and manikins are always replicated in both directions).

Overload Modes in Enhanced Scenes
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Advanced Tasks When you work in Enhanced Scenes, there are two Overload Modes, Full and Partial. Overload Mode Full • • • When you create a Enhanced Scene in Overload Mode Full, all attributes are immediately considered overloaded. All subsequent modifications to the Assembly will have no impact on the Enhanced Scene and vice-versa. If you choose to apply the Enhanced Scene context on the Assembly or to apply the Assembly context on the Enhanced Scene, after the operation, all attributes will still be considered overloaded and subsequent modifications to either the Enhanced Scene or the Assembly will continue to be independent, one from the other.

Overload Mode Partial • • When you create a Enhanced Scene in Overload Mode Partial, by default, none of the attributes are considered overloaded. Modifications to the Assembly will impact those attributes of the Enhanced Scene that are not overloaded (so, for example, if you make some modifications to the Assembly immediately following the Enhanced Scene creation, all of these modifications will impact the Enhanced Scene). Modifications to the Enhanced Scene never impact the Assembly, the result of such modifications to the Enhanced Scene is to overload the modified attributes. Attributes in the Enhanced Scene are overloaded implicitly when you modify the attribute in Enhanced Scene context.

• •

Graphical attributes, activation state, hide / show state, and viewpoint, once modified in the Enhanced Scene, will be considered overloaded. The overloaded values do not impact the Assembly. These overloaded attributes will subsequently be independent from the Assembly, i.e. modifications to the corresponding attributes in the Assembly will not impact the values of the attributes in the Enhanced Scene. Position attributes are implicitly overloaded when modified in the Enhanced Scene, however, you can also overload them explicitly by selecting the components for which you wish to overload the position and then clicking the Overload Position icon in the Enhanced Scenes toolbar (see Overloading Product Attributes in Enhanced Scene Context). • If you choose to apply the Enhanced Scene context on the Assembly or to apply the Assembly context on the Enhanced Scene, after the operation, those attributes that were considered overloaded will continue to be considered so (even though they may momentarily have the same value as the corresponding attribute in the Assembly).

Subsequent modifications of these overloaded attributes in either the Enhanced Scene or the Assembly will continue to be independent, one 373
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Applicative Data Available in Enhanced Scene Context
The following applicative data are available in the Enhanced Scene context: • • • • • • • • • • • • • • • • • • • • Annotated Views 3D Annotation Hyperlinks Group Cumulative snap Reset position Init position Current selection Applicative data reordering Apply material Publish Camera Cache content Modify sag DMU Move Measure Section Clash Rendering lights Rendering Environments

Note: The automatic update of Enhanced Scene associated applicative data is managed by a variable in the DMU Navigator Settings. See Customizing DMU Navigator Settings.

The Assembly is the Reference for Enhanced Scene Creation
Enhanced Scene creation always uses the Assembly as the reference. In Overload Mode Partial, any modifications to attributes in the Assembly will affect every Enhanced Scene that does not overload those attributes. Therefore, the command Apply Scene on Assembly will affect all of the Enhanced Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that will be updated in the Assembly.

Propagation of Overloaded Attributes in Enhanced Scene Context
The propagation of attributes in Enhanced Scene context will work exactly as in Assembly context. Note, however, that the propagation of the value of a Product's overloaded attribute to its children will not cause the child Product's attribute to be considered overloaded, with the exception of hide/show, for which all children of a hidden attribute will also be hidden.

Save Command in Enhanced Scene Context
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Restrictions
• • In Enhanced Scene context, only products can be UI-Activated. Enhanced Scene context is NOT intended for assembly edit (add part, delete part, geometry modification), its intent is strictly review-oriented.

Creating an Enhanced Scene
Enhanced Scenes enable you to work on an alternative state of a product. Insert the following GARDENA model documents from the cfyug samples folder: GARDENAATOMIZER.model GARDENABODY12.model GARDENABODY22.model GARDENALOCK.model GARDENANOZZLE12.model GARDENAREGULATOR.model GARDENATRIGGER.model GARDENAVALVE.model GARDENA_NOZZLE22.model GARDENA_REGULATION_COMMAND.model 1. In the specification tree, select the products of the Assembly that will define the Enhanced Scene content.
Selecting Enhanced Scene Content

Note that there are three ways to select Enhanced Scene content: • No selection: the entire Assembly will appear in the Enhanced Scene • One or more products selected (a subset of the Assembly): only the components in the branches leading back to the Assembly root of these selected products will appear in the Enhanced Scene • An existing Scene selected (Enhanced Scene or Old Scene): the
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2. In the DMU Review Creation toolbar, click the Enhanced Scene icon The Create Scene dialog box appears.

.

3. To define the name of the Enhanced Scene, click the Automatic naming radio button to deselect it and enter the name in the Name text-entry field. Note: Automatic naming enables you to automatically attribute names to Enhanced Scenes of the form Scene.1, Scene.2, Scene.3, etc. (The automatic naming mechanism is National-Language Supported.) 4. To define the Overload Mode, click the Partial radio button or click the Full radio button. Overload Mode Partial: The scene will only overload attributes for a few products and modifications to the main assembly of those attributes not overloaded in the scene will impact the scene. Overload Mode Partial favors performance as long as you don't overload too many attributes. An Enhanced Scene created with Overload Mode Partial will be indicated in the specification tree by the symbol .

Overload Mode Full: All attributes supported for overloading of each element of the assembly (under the products selected at scene creation) will be overloaded by the scene. Products overloaded by the scene will henceforth not be impacted by modifications to the main assembly regarding attributes supported for overloading. Overload Mode Full favors Enhanced Scene independence from the Assembly. An Enhanced Scene created with Overload Mode Full will be indicated in the specification tree by the symbol .
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For more information, see Overload Modes in Enhanced Scenes.

Once the scene is created, it is not possible to change the overload mode; nevertheless, it is possible to create a new Enhanced Scene from an existing Enhanced Scene and to affect a different overload mode to the new Enhanced Scene at its creation. 5. Click OK to validate. The Enhanced Scene is created. The Enhanced Scene appears. A background (the color of which you define in the Tools -> Options -> DMU -> DMU Navigator settings) indicates that you are now in Enhanced Scene context. The DMU Scenes toolbar appears.

Applicative Data in Enhanced Scene Context

378

Advanced Tasks If the Assembly from which the Enhanced Scene was created had an Applicative Data container, this container will also be available in the Enhanced Scene. You will be able, therefore, to modify the existing applicative data and to create new applicative data.

Enhanced Scene Contextual Menu

The Enhanced Scene contextual menu is composed of the following commands:

Contextual Menu Entry Definition Check Position

Action activates the Enhanced Scene highlights all components for which the position attribute is different from the corresponding Assembly position attribute (see Checking Component Position) overloads the viewpoint attribute with the current viewpoint (see Saving a Viewpoint in New Scene Context) exits the Enhanced Scene and return to Assembly context applies the overloaded attributes of the Enhanced Scene context on the Assembly (see Applying a Enhanced Scene Context to an Assembly) applies the attributes of the Assembly context on the New Scene (see Applying an Assembly Context to a Enhanced Scene)

Save Viewpoint Exit Scene Apply Scene on Assembly Apply Assembly on Scene

In Assembly context, the available commands are: • • • Definition Apply Scene on Assembly Apply Assembly on Scene

In Enhanced Scene context, when right-clicking an inactive Enhanced Scene, the available command is: • Definition

In Enhanced Scene context, when right-clicking the active Enhanced Scene, the available commands are: • • • • Definition Apply Scene on Assembly Apply Assembly on Scene Check Position
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Generating an Enhanced Scene from an Old Scene
There is currently no formal process for automatically converting Old Scenes to Enhanced Scenes. The available solution consists of selecting the Old Scene in the specification tree and then creating an Enhanced Scene. You have created an Old Scene in which you've modified one or more attributes (e.g. you've modified the color of one of the components and you've modified the viewpoint of the Old Scene). 1. Open the GardenaScene.CATProduct. 2. In the Specification Tree, select the Old Scene. 3. In the DMU Review Creation toolbar, click the Enhanced Scene icon and create the Enhanced Scene with the name and overload mode of your choice (see Creating an Enhanced Scene). Once created, the Enhanced Scene will be displayed and its state (the value of all possibly overloaded attributes) will be the same as that of the Old Scene from which it was created. If you have chosen Overload Mode Partial, each attribute in the Enhanced Scene which is different from the corresponding attribute in the Assembly will now be considered overloaded. The Old Scene will not be destroyed. The Old Scene and the Enhanced Scene will be independent one from the other. Scripts can be written using VBScript for generating Enhanced Scenes from Old Scenes.

Browsing Enhanced Scenes using the Scenes Browser
You can browse your Enhanced Scenes visually using the Scenes Browser. Appropriate customization of the Scenes Browser settings enables you to: • 380 activate a scene by simply double-clicking its image
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1. In the DMU Review Navigation toolbar, click the Scenes Browser icon . The Scenes Browser appears. An image representation of all defined Enhanced Scenes associated to the current Assembly will be found in the Scenes Browser.

2. To change to a list display of the Enhanced Scenes, click the Display List . icon The Enhanced Scenes are now displayed in list format.
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Customizing double-click behavior in the Scenes Browser
3. In the Scenes Browser, click the Customize button.

4. Check the radio button corresponding to the desired double-click behavior:
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• double-clicking will activate the Enhanced Scene • double-clicking will apply the whole Enhanced Scene to the Assembly • double-clicking will apply the user-defined attributes (see Automating Enhanced Scene Context Application Using Userdefined Attributes) 5. Click OK to validate.

Implementing the chosen behavior (Activating an Enhanced Scene or Applying an Enhanced Scene to the Assembly)
6. In the Scenes Browser, double-click the image of an Enhanced Scene to implement the chosen behavior. The Enhanced Scene title associated to each image in the Scenes Browser also indicates whether the Enhanced Scene was created with overload mode Partial or Full.

Activating an Enhanced Scene
An Enhanced Scene can be activated at any time by simply double-clicking its entry in the Specification Tree. 1. In the Specification Tree, expand the Applications node and then expand the Enhanced Scenes node. A list of all Enhanced Scenes will be displayed. 2. In the Specification Tree, double-click the entry of the Enhanced Scene you wish to activate. The Enhanced Scene will be displayed. The background color will change to indicate that you are in Enhanced Scene context. Even if you are working in Enhanced Scene context, you can activate a different Enhanced Scene by double-clicking its entry in the Specification Tree. It is also possible to activate an Enhanced Scene by right-clicking it in the Specification Tree and selecting Scene.X object -> Definition in the contextual menu.

Exploding an Assembly
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1. Double-click Scene.1 either in the specification tree or in the geometry area. The context is changed to the Enhanced Scene context. 2. Select Product.1 and click the Explode icon The Explode dialog box appears. .

Note that if the assembly is assigned coincidence constraints (axis/axis, plane/plane), the Explode can take these constraints into account by use of the Explode type "Constrained". 3. Click the Apply button.
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4. Click the Exit Scene icon

to swap to Assembly context.

For more details about explode functionality, see the DMU Fitting Simulator User's Guide.

Overloading Attributes in Enhanced Scene Context
Overloading attributes enables you to declare independence for the attributes of selected products in an Enhanced Scene with respect to the attributes of the same products in the Assembly. The following attributes can be overloaded: • • • • position hide/show status graphic properties node activation

Overload Mode Impact on Component Positioning

In Overload Mode Partial, repositioning a product in Enhanced Scene context will implicitly overload the position attribute. However, if a modification was first made to the product position in the Assembly, the position would be modified
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1. Either in the specification tree or in the geometry area, select the products for which you wish to overload an attribute. The selected components are highlighted in both the specification tree and the geometry area. 2. To overload the position attributes of the selected products, click the . Overload Positions icon The position attributes of the selected products are now considered overloaded and will be independent from positioning modifications to the Assembly. 3. To overload the hide/show status of the selected products, click the Overload Hide - Show icon . The hide/show attributes of the selected products are now considered overloaded and will be independent from hide/show status modifications to the Assembly. 4. To overload the graphic properties of the selected products, click the . Overload Graphic icon The graphic attributes of the selected products are now considered overloaded and will be independent from graphic properties modifications to the Assembly. 5. To overload the node activation of the selected products, click the . Overload Node Activation icon The node activation attributes of the selected products are now considered overloaded and will be independent from node activation modifications to the Assembly.

When you overload the position attribute using this command: • • all child product position attributes will also be overloaded all ancestor product position attributes will also be overloaded

When you use move a product in Enhanced Scene context: • • the moved product's position attribute will be overloaded all ancestor product position attributes will also be overloaded

After you have overloaded different attributes of an Enhanced Scene, you can still modify the overloading of those attributes. See Managing Attributes Overloads.
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Adding, Replacing and Deleting Components in the Assembly
This task shows you how an Enhanced Scene is affected when you add, replace and delete components in the Assembly. The Add, Replace and Delete functionalities are not available in Enhanced Scene context, only in Assembly context. Insert the following sample model files in the cfyug samples folder: • • • • • • • • ATOMIZER BODY1 BODY2 LOCK REGULATOR TRIGGER VALVE REGULATION_COMMAND

1. Click the Enhanced Scene icon

and create an Enhanced Scene.

You are now in a scene window. The background color has turned to green and Scene.1 is added in the specification tree. to swap to the main window. 2. Click the Exit Scene icon You return to Assembly context.

Adding Components in the Assembly
In Overload Mode Full, components added in Assembly context will have not appear in the Enhanced Scene. In Overload Mode Partial, the behavior will be as described below. You will now add the NOZZLE: 3. Right-click Product1 in the specification tree and select Components -> Existing Component. 4. Shift-select NOZZLE1.model and NOZZLE2.model and then click Open. The added components (NOZZLE_1 _2 and NOZZLE_1_2) are identified in the specification tree and added in the geometry area.
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5. In the specification tree, double-click Scene.1 to swap to the Enhanced Scene context. The newly-added components will appear in the specification tree and in the geometry area, assuming that, when they were added in the Assembly, they were added under the node that was selected for the creation of the Enhanced Scene. Otherwise, they will not appear. For example, given the following Assembly configuration,

if you created an Enhanced Scene that contained only product P1 and you add a product under product P1 in the Assembly, then the added product will appear under P1 in the Enhanced Scene. However, if you add a product under the Root in the Assembly, it will not appear in the Enhanced Scene. 6. Click the Exit Scene icon to return to Assembly context.

Replacing Components in the Assembly
7. Replace, for example, the BODY1 in the Assembly with the BODY2.model (right-click BODY1 in the specification tree, select Components -> Replace Component from the contextual menu, then, in the File Selection dialog box, select BODY2.model and click Open.) The Assembly is updated accordingly.

8. Double-click Scene.1 in the specification tree to enter the scene. Scene.1 has been updated in the same manner as the Assembly, assuming that the replaced product was previously visible in the Enhanced Scene. 9. Click the Exit Scene icon to return to Assembly context.
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Deleting Components from the Assembly
10. Delete, for example, the BODY2 from the Assembly (right-click it in the specification tree and select Delete from the contextual menu.) The Assembly is updated accordingly.

11. Double-click Scene.1 to enter the Enhanced Scene. Scene.1 has been updated in the same manner as the Assembly, assuming that the deleted product was previously visible in the Enhanced Scene.

Checking Component Position
This task shows you how to reset and check component position. You've created an Enhanced Scene in which you've modified the position attributes. 1. Double-click Scene.1 either in the specification tree or in the geometry area. The context is changed to the Enhanced Scene context. 2. In the specification tree, right-click Scene.1 and select Scene.1 object -> Check Position. All moved items are highlighted in the specification tree and in the geometry area. To reset the position of the moved items, see Applying an Assembly Context to an Enhanced Scene.

Saving a Viewpoint in Enhanced Scene Context
This task shows you how to save a viewpoint in Enhanced Scene context. You've created an Enhanced Scene. 1. Modify the viewpoint of the Enhanced Scene.
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2. In the Enhanced Scenes toolbar, click the Save Viewpoint icon

.

to return to the initial document window. 3. Click the Exit Scene icon You return to the main window. 4. Double-click Scene.1 either in the specification tree or in the geometry area to swap to the scene window. The viewpoint you saved is now taken into account in the Enhanced Scene.

Creating an Enhanced Scene Macro
If you perform a task repeatedly, you can take advantage of the macro mechanism to automate it. A macro is a series of functions, written in a scripting language, that you group in a single command in order to perform the requested task automatically. This task will show you how to create an Enhanced Scene macro. You stored your recorded macros in a text format file. For more detailed information about macros, see Recording, Running and editing Macros in the Infrastructure User's Guide.

Here is an example of an Enhanced Scene macro in which you create a Enhanced Scene: ' COPYRIGHT DASSAULT SYSTEMES 2003 Option Explicit ' ' ' ' ' ' ' **************************************** ************** Purpose: Create two new scenes. Assumptions: A CATProduct document should be active. Languages: VBScript Locales: English CATIA Level: V5R12 *******************************************************

Sub CATMain() ' Get the root of the CATProduct Dim RootProduct As Product Set RootProduct = CATIA.ActiveDocument.Product ' Retrieve the ProductScenes collection Dim TheScenes As ProductScenes Set TheScenes = RootProduct.GetTechnologicalObject("ScenesCollection")
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' Create a FULL product-scene on Root-Product Dim xProducts1(0) Set xProducts1(0) = RootProduct Dim oScene1 As ProductScene Set oScene1 = TheScenes.AddProductSceneFull ("", xProducts1) ' Create a PARTIAL product-scene on Root-Product with "PartialScene" persistent name Dim xProducts2(0) Dim oScene2 As ProductScene Set oScene2 = TheScenes.AddProductScenePartial ("PartialScene", xProducts2) End Sub

• • •

Create the scene launches the scene creation. Scene1 corresponds to the to-be-created scene. RootProduct corresponds to Product1.

Applying an Enhanced Scene Context to an Assembly
The command Apply Scene to Assembly enables you to reset the values of selected attributes of the Assembly with the values of the corresponding overloaded attributes in the Enhanced Scene.

You've created an Enhanced Scene in which you've modified at least one of the following: • • • • component component component component position hide / show status graphical properties activation status

Enhanced Scene creation always uses the Assembly as the reference. Therefore, the command Apply Scene on Assembly will affect all of the Enhanced Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that will be updated in the Assembly. 1. Double-click Scene.1 in the specification tree to activate the Enhanced Scene. 2. Click the Apply Scene on Assembly icon . The Apply Scene.1 on Assembly dialog box is displayed.
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3. Select the products for which you wish to apply modifications. The rows corresponding to the products will be highlighted. In the Attributes management area, the attribute types that could potentially be applied as a function of the selected products will be un-grayed (in the above example, only the Position attribute has been modified for the selected products, so only the Position attribute type has been un-grayed). 4. In the Attributes management area, click the attribute types of the modifications you wish to apply. The entry in the table of the corresponding modification will change from "X" to "Apply".

5. Click OK to validate.

Using the Contextual Menu
You can use the contextual menu to:
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• •

select all product rows or to unselect all product rows designate selected attributes as "Apply" or "X" (Do not apply)

As an example: • • in step 3 above you would still select the product rows manually in step 4 above you would right-click the selection, which would display the following contextual menu (because only position attributes are potentially applicable from the Enhanced Scene onto the Assembly):

•

you would select Apply Position (or Apply All) to designate the selected attributes to be applied:

Customizing Displayed Attributes
You can customize the list of attribute types displayed in the Attributes management area: • • • click the Customize button deselect the attribute types you don't wish to appear in the list click OK to validate
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Applying an Assembly Context to an Enhanced Scene
The command Apply Assembly on Scene enables you to reset the values of selected overloaded attributes in the Enhanced Scene with the values of the corresponding attributes in the Assembly.

You've created an Enhanced Scene in which you've modified at least one of the following: • • • • component component component component position hide / show status graphical properties activation status

1. Double-click Scene.1 in specification tree to activate the Enhanced Scene. . 2. Click the Apply Assembly on Scene icon The Apply main assembly on Scene.1 dialog box is displayed. All differences between the Assembly and the Enhanced Scene are indicated by an "X" in the dialog box. You can also access the Apply Scene on Assembly command by right-clicking Scene.1 in the specification tree and selecting Scene.1 object -> Apply on Scene in the contextual menu.
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3. Select the products for which you wish to apply modifications. The rows corresponding to the products will be highlighted. In the Attributes management area, the attribute types that could potentially be applied as a function of the selected products will be un-grayed (in the above example, only the Position attribute has been modified for the selected products, so only the Position attribute type has been un-grayed). 4. In the Attributes management area, click the attribute types of the modifications you wish to apply. The entry in the table of the corresponding modification will change from "X" to "Apply" or vice-versa.

5. Click OK to validate. You can use the contextual menu to: • • select all product rows or to unselect all product rows designate selected attributes as "Apply" or "X" (Do not apply)

As an example: • • in step 3 above you would still select the product rows manually in step 4 above you would right-click the selection, which would display the following contextual menu (because only position attributes are potentially applicable from the Assembly onto the Enhanced Scene):
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•

you would select Apply Position (or Apply All) to designate the selected attributes to be applied:

You can customize the list of attribute types displayed in the Attributes management area: • • • click the Customize button deselect the attribute types you don't wish to appear in the list click OK to validate

Exiting Enhanced Scene Context
You can exit Enhanced Scene context and return to Assembly context at any time.
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1. In Enhanced Scenes toolbar, click the Exit Scene icon You exit the Enhanced Scene context. You will now be back in Assembly context.

.

All modifications to your Enhanced Scenes are implicitly persistent, with the exception of viewpoint modification (see Saving a Viewpoint in Enhanced Scene Context). If you hide the Enhanced Scenes toolbar, you will automatically exit Enhanced Scene context.

Automating Enhanced Scene Context Application Using Userdefined Attributes
This command enables you to streamline the application of an Enhanced Scene context to an Assembly by allowing you to pre-define those attributes that you would like to apply by default and then allowing you to apply those attributes from a contextual menu. You've created an Enhanced Scene in which you've modified at least one of the following: • • • • component component component component position hide / show status graphical properties activation status

Enhanced Scene creation always uses the Assembly as the reference. Therefore, the command Apply Scene on Assembly will affect all of the Enhanced Scenes with Overload Mode Partial that have not overloaded the attributes corresponding to those that will be updated in the Assembly. 1. In the specification tree, right-click Scene.1 and select Scene.1 object -> Set User Defined Attributes in the contextual menu.
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2. Select the products for which you wish to apply modifications. The rows corresponding to the products will be highlighted. In the Attributes management area, the attribute types that could potentially be applied as a function of the selected products will be un-grayed (in the above example, only the Position attribute has been modified for the selected products, so only the Position attribute type has been un-grayed). 3. In the Attributes management area, click the attribute types of the modifications you wish to apply. The entry in the table of the corresponding modification will change from "X" to "Lock".

4. Click OK to validate. The use of the contextual menu is the same as in Applying an Enhanced Scene Context to an Assembly. The customization of displayed attributes in the dialog box is the same as in Applying an Enhanced Scene Context to an Assembly.

Saving an Enhanced Scene in ENOVIAVPM
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Advanced Tasks Enhanced Scenes can be saved in ENOVIAVPM, but only in the context of a DMU Review. See Saving DMU Applicative Data in ENOVIAVPM in the DMU Navigator User's Guide. The Enhanced Scenes saved in ENOVIAVPM cannot be used in a drafting scenario: it is not possible to create a drawing with a view from this scene.

Exiting Enhanced Scene Context
You can exit Enhanced Scene context and return to Assembly context at any time.

1. In Enhanced Scenes toolbar, click the Exit Scene icon You exit the Enhanced Scene context. You will now be back in Assembly context.

.

All modifications to your Enhanced Scenes are implicitly persistent, with the exception of viewpoint modification (see Saving a Viewpoint in Enhanced Scene Context). If you hide the Enhanced Scenes toolbar, you will automatically exit Enhanced Scene context.

Applying Overload Position on Reference during "Rigidification" command

This task consists in applying an overload position first, on a Specific Instance, and finally on all t a reference. Several aspects will be explained below: Propagation No propagation with Multi-Instances

As it was described in the Flexible Sub-Products section, the user can dissociate the mechanical s product from the product structure, and this within the same CATProduct document. Open the 16cubes.CATProduct document:
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Open the 16cubes.CATProduct document:

This document contains two identical CATProducts : 8 cubes (8 cubes.1) and 8 cubes (8 cubes.2) CATProducts have the same CATParts : Cube (Cube.1) and Cube (Cube.2).

Propagation
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1. Right-click 2Cubes.1 in the specification tree and select the 2cubes.1 object -> Flexible/R assembly contextual submenu to make 2Cubes.1 flexible.

2.
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You can notice that several icons in the specification tree have changed: . This identifies a flexible sub-product.

2. Select Cube.1 and move it with the compass. You can now move Cube.1 independently fro cubes of 8Cubes.1. You have modified the position of Cube.1 (instance) within the 8cubes the 16cubes.CATProduct document. Within 2cubes.2, the position of Cube.1 has not chang

3. Right-click 2Cubes.1 and select the 2cubes.1 object -> Propagate position to reference co submenu to propagate the position of Cube.1 instance on the reference.
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The flexible position has been propagated on all the instances of Cube.1. The position of Cube.1 has changed within 2cubes.CATProduct, which explains why its position has been propagated on all the other Cube.1 within the 2cubes instances.
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4. Right-click 8Cubes.1 in the specification tree and select the 8cubes.1 object -> Flexible/R assembly contextual submenu to make 2Cubes.1 and all the elements above rigid. Note that the stiffening command (rigid mode) operates downwards.

And a warning message is displayed, explaining that the operation is transferred on the product's children as well:

Note that the instances of Cube.1 do not have moved back to their initial position. There is synchronization between the first instance of Cube.1 within 2cubes.CATProduct and all the other instances of Cube.1 (for instance the instances in 16cubes.CATProduct: 8cubes\4cubes.1\2cubes.1\Cube.1 and 4cubes\2cubes.1\Cube.1 and 2cubes\Cube.1). 404
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Advice: Do not use propagation with Multi-Instances

1. To make 2cubes.1 flexible, right-click it and select the 2cubes.1 object -> Flexible/Rigid s contextual command to make its children Cube.1 and Cube.2 flexible.

2. To make 2cubes.2 flexible, right-click it and select the 2cubes.2 object -> Flexible/Rigid s contextual command to make its children Cube.1 and Cube.2 flexible. It is possible to make 2cubes.1 and 2cubes.2 flexible simultaneously.

For this, you need to click 2cubes.1 and 2cubes.2 by pressing and holding down the Ctrl key. Rele key, right-click one of these two components and select the Selected objects -> contextual comm
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3. Move Cube.1 in both Cubes.1 and in Cubes.2 (2 instances of Cube.1).

4.

You can apply the propagation of an overload position only on a product's instance but not on a P Product, otherwise the following message is displayed:
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4. Select 8cubes.1, right-click it and select the 8cubes.1 object -> Propagate position to refe contextual command. And the following message appears because 8cubes is the common Cube.1.
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5. Select 4cubes.1, right-click it and select the 4cubes.1 object -> Propagate position to refe contextual command. And the Error Message appears because 4cubes is the common root It is recommended not to use this propagation command with Multi-Instances because you need to have only one flexible instance (Cube.1 for instance) to propagate rigidification.

6. Select 2cubes.1 or 2cubes.2 and the Propagate position to reference contextual command is propagated on all the rigid instances: all the Cube.1 instances within 2cubes, except the (16cubes\8cubes.1\4cubes.1\2cubes.1\Cube.1), adopt the last applied position.

7.
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If you select 8cubes.1 and make it rigid, the other rigid elements are not modified. But Cube.1 in becomes rigid and keeps the same position. And Cube.1 in 2cube.1 becomes rigid and retrieves it position that is to say the position of Cube.1 in 2cubes.2.

Publishing
Publishing Elements

Publishing geometrical elements is the process of making geometrical features available to different users. This operation is very useful when working in assembly design context This task shows you the method for making elements publicly available: you will publish a plane, a sketch then a parameter not visible in the specification tree. In this page, you will also find information about the following subjects: • • • • • • • Publishing Part Design Features Assembly Constraints and Published Generative Shape Design Geometry Publishing in Assembly Design Replacing a Published Element Publishing Parameters Importing and Exporting Published Names What Happens When Deleting a Published Element?

Open the Publish.CATPart document or if you are working in Assembly Design, for example open the AssemblyTools01.CATProduct document, and ensure that the component containing the element you wish to publish is active. 1. Select Tools -> Publication. The Publication command lets you: o o o o o o Publish a geometric element Edit the default name given to the published element Replace the geometric element associated with a name Create a list of published elements Import a list of published elements Delete a published element.

The Publication dialog box appears.
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If you are working in Assembly Design, the dialog box also displays a Browse button. For more information, refer to Publishing in Assembly Design. 2. Select the element to be published. For example, select Plane.1. You can publish the following elements: o o o o o o o

o

points, lines, curves, planes sketches bodies (selecting a feature selects the body it belongs to) Generative Shape Design features (Extrudes Surfaces, Offsets, Joins etc.) Free Style Features (Planar patches, curves etc.) parameters sub-elements of geometrical elements: when switched on, the option Publish a face, edge, vertex or extremity lets you directly select faces, edges, vertices. axes. extremities. Part Design features.

3. To select axes, select cylindrical faces and use the Other Selection contextual command. For more about this command, please refer to CATIA Infrastructure User's Guide. The dialog box displays the name and status of the selected element as well as "Plane.1", that is the default name given to the published element 3. Click Plane.1 in the dialog box. The plane is highlighted in the geometry.

410

Advanced Tasks

4. Rename it as New plane. The plane is published as New plane. However, you can notice that the geometric element Open_body.1/Plane1 has not been renamed.

5. Before publishing another element, click Options to access rename options. When using the Publication command, you can actually decide to rename or not the elements you are publishing. Prior to renaming, you can set one of the three following work modes: o o o Never: the application will not allow you to rename the published element. This is the default option. Always: the application will always allow you to rename the published element Ask: the application will ask you what you decide to do, namely rename or not the published element.

Note that: o o You can rename any element except for axes, edges and faces. Some characters, such as the exclamation mark, are not allowed for renaming elements.

6. Check Ask and click OK to exit. 7. Prior to selecting the element to be published, deselect New plane if not already done. 8. Select Sketch.1 as the new element to be published. 9. Rename it as "New sketch". A message is issued asking you whether you wish to rename the published element "Sketch.1" as "New sketch". 10. Click Yes to confirm. The published element's name is "New sketch" and the geometric element is renamed too. Notes • Pointing at or selecting published elements simultaneously highlights the geometry, the element node and the publication node.
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•

The Publish capability lets you give a specific name to a geometrical element in a given context (for example, in a "defined in work object"). If this geometrical element is to be used in a different context (another "defined in work object"), the application does not recognize this element from its published name. In short, you need to select this object from the geometrical area, not from the Publication node in the specification tree.

Publishing Part Design Features
Publishing Part Design Features requires that the Enable to publish the features of a body capability available in the Options dialog box is on. If your administrator did not lock the option, you can activate the option yourself.

Assembly Constraints and Published Generative Shape Design (GSD) Geometry
Depending on your geometry, there are cases where constraints pointing to a certain type of published GSD features do not reconnect if, for example, you replace constrained parts. What happens is that links between constraints and the geometry do not take advantage of the publication. You can notice this behavior even if you selected the geometry through the Publication node. GSD features concerned are those whose geometrical results depend on the number and type of the parents used for the result. This is the case of features such as Intersect or Project. The solution to this, is to publish the geometrical result, not the feature itself. In concrete terms, rather than publishing the Intersect feature, you recommend you publish the vertex, not the point. The application reminds you of this behavior when you are setting constraints on published features through the following warning message:
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Publishing in Assembly Design
When publishing geometry in the Assembly Design workbench, the Browse button is available in the Publication dialog box. Clicking the button launches the Component Publication dialog box that displays only the published elements belonging to the levels inferior to the active level. In the following example, the user is publishing an element of CRIC_BRANCH_1. When clicking the Browse button, the Component Publication dialog box displays published faces belonging to CRIC_BRANCH_3.
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This capability works as a filter: it does not display the whole publications of the assembly. Thus, you will use it as an help for selecting already published elements whenever you wish to replace published elements.

Replacing a Published Element
11. Click "Geometrical Set.1/Plane.1" to replace it with another geometric element. 12. Select "Plane.2" as the replacing element.

13. The orientation of both elements is displayed. The green arrow indicates the orientation for the new element, the red arrow indicates the orientation of the
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14. Click Yes to confirm. Plane.2 has been published.Plane.1 is not published any more. The dialog now displays the following information:

15.

Publishing Parameters
14. You can publish the parameters of a part that are not displayed in the specification tree. To do so, click the Parameter... button available in the Publication dialog box. This displays a new window listing all parameters defined for the feature previously selected in the specification tree.

16. If the list of parameters is too long, you can filter out the parameters by entering a character string in the Filter Name field. For example, enter "offset". The list now displays only the parameters including the string "offset". 17. Select the parameter of interest. You can also use one of the following filter types: o o o All Renamed parameters Hidden
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o o o o o o

18. Click OK when done. This closes the dialog box. The selected parameter is displayed in the Publication dialog box.

Importing and Exporting Published Names
Published names can be gathered in ASCII .txt files. To export published names to an ASCII .txt file, • • • click the Export button. enter a name for the file you are creating in the Export dialog box that displays. click Save : the file is created: it contains the list of all published elements as specified in the Publication dialog box.

To import published names to an ASCII .txt file, • • • • click the import button. navigate to the file of interest in the Import dialog box that displays. select the file containing the list of published elements. click Open: the names are added to the list of the Publication dialog box

18. Click OK when satisfied. The Publication entity has been added to the specification tree. The three published elements are displayed below Publication node:

What Happens When Deleting a Published Element?
When deleting a published element, the application informs you that this element is published. What you need to do is confirm the deletion (Yes) or cancel it (No).

Defining Contextual Links
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Defining Contextual Links

This task will show you how to change the context of a part in an existing assembly, how to make depend or not on another document). This documentation is divided into 3 scenarios: • • • Defining Contextual Links between 2 Instances of the same Part, Defining Contextual Links between two separate Instances (with no dependences), Defining Contextual Links between two Instances belonging to different Products.

Defining Contextual Links between 2 Instances of the same Part
Open the ChangeCtx.CATProduct document.

1. Copy Pic1.CATPart and paste it in Poteaux.CATProduct. 2. Because it is a copy of Pic1 (1.1), Pic1 (Pic1.2) is hidden behind Pic1 (1.1) in the Geometr compass on Pic1 (Pic1.2) and move it. 3. So that you can more easily recognize both Parts, give Pic1 (Pic1.2) the blue color via the Pic1 (Pic1.1) is the pink cylinder and Pic1 (Pic1.2) is the blue one.
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Pic1.CATPart is a Contextual Part. Pic1 (Pic1.1) is a contextual instance Pic1 (Pic1.2) .

is the second or subsequent instance of this contextual Part.

If you want to be more familiar with the compass manipulation, you can read Manipulating Objec Compass in CATIA - Infrastructure User's Guide. This tutorial will show you how to move and rota objects. 4. In the contextual menu of Pic1 (Pic1.2), select Components -> Define Contextual Links.

5. Pic1 (Pic1.1) is no longer a contextual part. The following dialog box is displayed:
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6. Click OK. For more information about this panel, please refer to the Change Context panel As a consequence, Pic1 (Pic1.2) is now the Contextual Instance, its icon becomes: Pic1 (Pic1.1) is a "regular" instance, its icon is: . :

The Contextual Part Pic1 has to be updated because the Contextual Instance has been chan 6. Select the Update command in the Edit menu and you obtain:

Only Pic1 (Pic1.2) is set between the Upper and Lower surfaces, its keeps link with the Surf Pic1 (Pic1.1) is no longer in contact with the Surface because it is no longer the Contextual

Defining Contextual Links between two separate Instances (with no dependences)

1. This first demonstration is finished, close ChangeCtx.CATProduct without saving and reope

2. Copy Pic1 (Pic1.1), select Poteaux.CATProduct and the command Edit -> Paste Special. Th displayed : select Break link and click on OK.

3. Copy (1) of Pic1 is hidden behind Pic1 (1.1) in the Geometry space, therefore drag and dro and move it. 4. So that you can more easily recognize both Parts, give Pic1 (Pic1.1) the blue color via the Pic1 (Pic1.1) is the blue cylinder and Copy (1) of Pic1 is the pink one.
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5. In the contextual menu of Copy (1) of Pic 1 (Copy (1) of Pic1.1), select Component -> Def

Pic1.1 remains the Contextual Instance of the Contextual Part Copy (1) of Pic1. Its symbol 6. Click OK and you obtain:
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o

Copy (1) of Pic1.1 is now the Contextual Instance of the Contextual Part Copy (1) o .

7. Update the document and you can see Copy (1) of Pic 1 is still green. It adapts itself to th

With the Define Contextual Links functionality, both Pic1 and Copy of Pic1 are contextual: t link with their Instance belonging to ChangeCtx.CATProduct.
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Defining Contextual Links between two Instances belonging to different products
1. Open ChangeCtx.CATProduct. 2. Under Poteaux.CATProduct, insert a new product, Product1 (Product1.1).

3. Copy the contextual Part, Pic1 (Pic1.1), and paste it into Product1. This copy of Pic1 is the this contextual part.

4. This copy of Pic1 is hidden behind Pic1 (1.1) in the Geometry space. Drag and drop the co and move it.

5. So that you can recognize both Parts more easily, give Pic1 (Pic1.1) in Product1 the blue c command). Pic1 in Product1 is the blue cylinder and Pic1 in Poteaux is the pink one.

Pic1.CATPart is a Contextual Part. Pic1 (Pic1.1) is a contextual instance this contextual Part. and Pic1 (Pic1.2)

is the second or subsequen

6. In the contextual menu of Pic1 (under Product1), select Components -> Define Contextua box appears:
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The Instance of Pic1 under Product1 is now the contextual instance of the Part Pic1.

This panel provides information about the context you want to change and the external refe instance Pic1 (in Product1): •

Expected status: To solve, meaning that links have to be restored between Pic1 a (belonging to the Previous pointed element Face and to the Previous pointed instanc and between Pic1 and Surface.3 (belonging to the Previous pointed element Face an Previous pointed instance Lower.1) in External References.

•

the Publication path with Surface.2 is ..!..!Masters.1UpperSurface and the publicat Surface.3 should be ..!..!...!Masters.1LowerSurface.

•

the New pointed elements and instances have not been selected yet. button once, corresponding to the number of the missi

7. Select both lines and press the
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..!..!...!Masters.1UpperSurface.

Click OK and you can see:

The links are converted into ..!..!..!Masters.1UpperSurface and ..!..!..!Masters.1LowerSurfa Pic1 in Product1 becomes becomes the Contextual Part .

8. To make Pic1 (in Poteaux) a contextual part, select the Components -> Define Contextual change context dialog box is displayed:

424

Advanced Tasks

9. To select the New pointed elements and instances, press the levels: ..!..!..!Masters.1UpperSurface. Click OK.

button twice, correspondi

Pic1 (in Poteaux) becomes a contextual part

and you can update your document.

Defining Contextual Links: Editing and Replacing Commands

This command called "Define Contextual Links" uses the existing panel of the "Change Context" c in the Change Context command. New buttons have been created in the Change Context panel: E

The Define Contextual Link command enables to define (change) all the contextual links before an also make the operation on contextual parts, to modify unsolved links. You have the possibility to • • • re-root each link, using the Edit button, pointing in 3D space or in graph re-root links, using the Replace button, changing one or many instance names change the numbers of each link, using Replace.
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Contextual Links: For contextual parts, the reference keeps a link with the Original or Definition Instance (or Origin

For each parts, every instance keeps a link with its reference. But the Contextual Reference (or C instance which is contextual. This unique link allows you to know the name of the document (CAT rests.

There is a distinction between the Original Instance and the subsequent Contextual References be Parts depends on neighboring components (support) in the Assembly. The Geometry of the Conte same Assembly (second link). Three Instances of Contextual Part exist: Definition Instance

This icon shows that the Part Reference is contextual and this gear and the blue chain signify the "original" instance of a pa with another part's data) in a CATProduct.

Instance of the Definition Instance Other Instance of the Contextual Part

This contextual part, represented by the white gear and the g Instance, coming from the Contextual Part. The geometry of Instance (contextual link). Note that you can edit this context

The brown gear and the red flash signify that the Part referen used in the Part Definition. Note that you can edit this Contex / paste or insert a Contextual Part into another CATProduct w

In this case the user needs to resort to the "Define Contextua redefine the context of the Part and this red flash will be turn

For more information, please read the following scenar Replacing Commands, and Isolating a Part in Product S Open the DefineCtxLinks.CATProduct document.
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How to Replace a Part or a Publication

1. In the contextual menu of CtxPart (CtxPart.2), select Components ->Define Contextual Lin
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2. In the Change Context dialog box, select the Publication path of Solid.1 and click the Repla

3. Select another component in the Specification Tree, for instance the Publication: PartBody

And you can immediately visualize the expected status: Connected.

4. Before going to the next task, please close DefineCtxLinks.CATProduct without saving it.
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How to Edit a Part or a Publication First example: Open the DefineCtxLinks.CATProduct document.

1. In the contextual menu of CtxPart (CtxPart.2), select Components->Define Contextual Lin

2. In the Change Context dialog box, select the Publication path of Solid.1 and click the Edit the graphical view of the external references which you can compare with the product stru the external links of a contextual part with other elements.

The part Support2.1 and the publication PartBody are highlighted in red because Support2.1 shou 3. In the contextual menu of Support2.1, select the Insert Node before command to add a n and Support2.1. You can directly select SubCompo2.CATProduct in the Specification Tree.

And you obtain:
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Both the Part and the Publication are no longer highlighted; their links are restored thanks to the

4. Click OK. The Solid.1 is reconnected and it acquires a new pointed element, PartBody, and

5. Click OK. 6. Before going to the next example, please close DefineCtxLinks.CATProduct without saving

Second example: Open the DefineCtxLinks.CATProduct document.

1. In the contextual menu of CtxPart (CtxPart.2), select Components->Define Contextual Lin 2. In the Change Context dialog box, select both Datum.1 and Curve.2 and click the Edit but
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The following panel appears:

The reference of Support4.1 cannot be found under Compo1.1 because it has been renamed: Sup 3. Select Support4.1 and the contextual command Replace Node:

4. Select another component in the Specification Tree: Support1.1, which will be the new poi
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5. Click OK. 6. The other solution is to Edit the node of Support4.1:

7. And you can enter a new name, for instance: Support.1. Click OK.

And you obtain:

8. Click OK. The new pointed instance is Support.1 and the new pointed elements are Sketch

432

Advanced Tasks

9. Before going to the next example, please close DefineCtxLinks.CATProduct without saving

Third example: Open the DefineCtxLinks.CATProduct document.

1. In the contextual menu of CtxPart (CtxPart.2), select Components->Define Contextual Lin 2. In the Change Context dialog box, select Surface.2 and click the Edit button:

The following panel appears:
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The reference of Support1.1 cannot be found under SubCompo2 because its position has changed SubCompo2.1.

3. Select Support1.1 and the contextual command Replace Node: select Support1.1 in the Sp under Support1.1: Extrude2. And you obtain:

The other solution is to delete Subcompo2:

As a consequence, Support1.1 is directly under Compo2.1:
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4. Click OK and the links are reconnected between Support1.1 and Compo2.1. 5. Finally, you can update your document. The Edit functionality is the same with Publications. Always the top most Publication in the scope of the common reference product is used to defined represents the better logical access to a given geometry while the internal path to this geometry exists, the Publication at the Assembly level is then selected.

Managing Objects, Representations and the Tree
Managing Graphic Properties in products

This task shows you what are the effects when changing graphic properties such as Show / No S Opacity, Width and Line Types: About Graphic Properties, Using Instance / Reference Inheritance, Using Parent / Children Inheritance, Combination of Instance / Reference and Parent / Children Inheritance, New behavior of the Show / No Show functionality.

Changes of graphical property on an assembly node (or on a root product) are not propagated on (in the Specification tree).

When an object has a specific graphical property, the property is only set on this object (assembl product) and its children get the property of their father by inheritance, which is visible in the Geo

For more information about this graphical changes, please refer to Displaying and Editing Graphic Infrastructure User's Guide.

About Graphic Properties
Before:

No Instance / Reference Inheritance:

Catia Product Model is a full instance reference model. When inserting a Sub-assembly in a Prod structure is duplicated, and graphical properties are also duplicated. If a graphical property is then modified on the reference, it is not taken into account in instance graphical property is then set on the reference, it is not taken into account in instance. Any changes of graphical properties on an assembly node are propagated on all children nodes.
Now:

Reference / Instance for All:
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Graphical properties are not duplicated during Instantiation, propagated on all children nodes (i Specification tree) and if a graphical property is then set on the reference, it is taken into accou instance (if instance state is unset). Children inherit graphical properties, which is visible in the space. The behavior of all graphic properties is now kept and there is:

• an Instance / Reference Inheritance for all Graphic Properties. • a Parent / Children Inheritance for all Graphic Properties. When an object has the No Show set the property only on this object and its children get the property of its father by Pare inheritance, so they are not visualized but the property has not been set on them (Child • modification of the Show / No Show in order to answer the two previous inheritances. Here are examples with the Show / No Show graphic property but it is also true with the other the following toolbar:

More precisely, these graphic properties are: • • • • Colors, Opacity, Width, Line Types.

Like Show / No Show, these graphic properties have Instance / Reference and Parent / Child and sometimes both. About Layers:

You cannot give a Layer number to a Product. This property is grayed out in the graphic property

Using Instance / Reference Inheritance:

Instance / Reference Inheritance exists when a product (Instance) has been built on another prod the Instance always points to the Reference.
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Open Product1 (Product1bis.CATroduct) and Assembly.CATProduct.

In Assembly.CATProduct, you have a Root Product called Assembly, containing 2 Products (Produ twice) and an Application node.

1. In Product1bis.CATProduct, set the No Show property on Part1.1 in the context of Product this result:
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Product1 (Product1bis.CATProduct) is the Reference of the Instance Product 1 in Assembly.CATProduct. As a consequence, both instances of Part1 (Part1.1) have inherited the No Show property of its Reference. And Part1 (1.2) have inherited the yellow color of the Reference.

2. Set the green color on Part1 (1.2) in Product1 (Product 1.1) and you can notice that the g inherited by the Reference:

3. Now in Product1bis.CATProduct, set the purple color on Part1 (1.2) in Product1 (Product 1 obtain:
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Part1 (1.2) in Product1 (Product1.2) inherits the Color property of the Reference (in Product1bis because no color attributes had already been set on it (Unset state). But it is not the case with Pa (Product1.1): it does not get purple because the green clor had already been set on it.

The No Show property has been propagated in Part1 (visible on its icon, in the Specification Tree be seen in the 3D View. In Assembly, Part1 is also instantiated in the second Product1 (Product1.2), and it is also set in N Part1.1 back in Show in Assembly.CATProduct, Part1.1, and not its Reference (in Product1), will b

There is an Instance-Reference Graphic Properties Inheritance: when the Reference's g are changed, its instances automatically get the same property, only if none Property h Instance (Unset state), and whatever the original graphic property of Product1 (in Asse

Using Parent / Children Inheritance:
Parent / Children Inheritance is when sub-products inherit the graphic property of their root prod Open Assembly.CATProduct.

1. Select Assembly and set it in No Show and you can note that there is no propagation of th property on the children (in Specification Tree).
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2.

The Show / No Show inheritance exists between the product and its sub-products. You cannot bri Children Geometry, if the parent has the No Show property set. If you want to bring 3D in Sho activate the root product (the Product that owns the No Show property) in Show.

Parent / Children Inheritance has priority before the local properties set on the Instance. This is t for the other graphic properties: colors, opacity, etc...

2. Select the first Product.1 and click the Show / No Show icon. You can only give the No Sho product and its geometry remains hidden.
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3. Select Product1 and click the Show / No Show icon or contextual command in order to giv property. You can note that the geometry remains hidden:
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4. If you want to see Product1 and all the sub-products in Show, you need to activate the roo in Show.
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5.

The father's No Show property is not propagated on children (sub-products), including Applicatio you can set the No Show property to the Application node: even if there is no Application icon wit symbol in the Specification Tree, you can see that the No Show property is effective in the 3D vie disappeared in the 3D space).
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Combination of Instance / Reference and Parent / Children Inheritance

This scenario will show you when you can have both an Instance / Reference and a Parent / Child which exist for all Graphic Properties. Open Assembly.CATProduct and Product1bis.CATProduct.

1. In Product1bis (Reference), select Part1 and click the Show / No Show icon or contextual c Product1bis is the Reference of Part1 in Assembly.CATProduct, therefore Part1 is now in N products.
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2.

The Parent / Children Inheritance has always priority before local Properties or before the propert Reference. 2. Set Product1.1 (in Assembly) in No Show and nothing can be seen under Product1.1. Part invisible because there is a Parent / Children Inheritance.
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3. Select Part1.1 under Product1 in Assembly.CATProduct and turn it in Show: the icon of Pa you cannot see its Geometry because there is a Parent / Children inheritance.
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Geometry:

5.

New behavior of the Show / No Show functionality
The possible combinations are: • 3 states: o Unset: (Show by default) allows Instance / Reference Inheritance. o 2 overloaded states: No Show / Hide, Show. 4 possible transitions: o Unset -> Show, o Unset -> No Show, o Show -> No Show, o No Show -> Show. 2 transitions that are not possible: o Show -> Unset,

•

•

447

project

o

No Show -> Unset.

The following table illustrates the result of all possible combinations.

Managing Representations and the Tree
Managing Representations
This task shows you how to use several documents (CATShapes) to describe one part. • Open the ManageRep.CATProduct document.
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•

Managing Representations:

1. Click the Manage Representations icon or right-click Cylindre (Cylindre.1) and select t Representations -> Manage Representations... contextual command. The Manage Represe box appears:

It displays: • • • • • the Name of the representation, the Source file of the representation, the Type of the representation, whether the representation is the Default representation of the product, whether the representation is Activated or not.

In this panel you can see one Shape: Cylindre_s.CATShape. 2. Click the Associate button and the Associate Representation button appears. 3. Select Cylindre_d.CATShape from the C:\Program Files\Dassault Systemes\B04doc\online\pstug\samples directory and click Open.
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A second CATShape appears in the Manage Representation panel:

4. Select the Cylindre_d.CATShape line and click the Associate button. As a result Cylindre_d will be visible in the Geometry space.

5. The rename button becomes active, click this button and enter "Detailed" in the renaming Cylindre_d.CATShape appears with the name "Detailed", in the Manage Representation pa
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6. Cylindre_d.CATShape is still selected, click the Set As Default button. This representation i and set as the default representation. Therefore by default, Cylindre_d.CATShape will be opening Cylindre Product. You can associate as many representations as you need, but only one must be Set As Default. In this case other representations are not displayed in the Specification Tree and in the Geometry area. • •

•

•

•

To change the default representation of a product, select one of its representations an As Default button. To deactivate a representation of a product, select a representation in the Manage Rep dialog box and click the Deactivate button. The representation is deactivated from Product specification tree and in the geometry area and No is displayed in the Activated column of Representations dialog box. To activate a representation of a product, select a representation in the Manage Repres dialog box and click the Activate button. The representation is activated in the specificatio the geometry area and Yes is displayed in the Activated column of the Manage Representa box. To replace a representation, select a representation in the Manage Representations dia click the Replace... button. The Replace Representation dialog box is displayed. Select the document from the chosen directory and click Open. The representation is replaced in Prod Specification Tree, in the geometry area and in the Manage Representations dialog box. When you replace a constrained representation, even if its constraints have been deleted, reconnect representation context. See Reconnecting a Replaced Representation, in CATIA - Assembly User's Guide. When yo deactivated representation, the replacing representation is automatically activated. To rename a representation, select a representation in the Manage Representations dia click the Rename... button. The Rename Representation dialog box is displayed. Define a select an existing name in the combo box. The representation is renamed in the Manage Representations dialog box. However, this has no effect on the feature names in the speci as there is no relation between representation names and feature names.

•

Renaming the instance name of the Part with this character "!" breaks the Publication Lin message appears and you cannot rename it.
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• •

To remove a representation, select a representation in the Manage Representations dia click the Remove button. The representation is removed from the Product in the specificat geometry area and in the Manage Representations dialog box. If you copy / paste a .model As Spec (Paste Special -> As Spec) into a CATProduct in C the same like doing a Add New Representation that is to say adding this model as a New R in the CATProduct. Copying As Spec consists in transferring the solid with the Geometry an tree.

For more information about the Copy / Paste Special -> As Spec, please refer to Cop Version 4 to CATIA Version 5 in the CATIA - V4 Integration User's Guide. • •

.cgr, .model, .CATShape and some other 3D graphic formats can be associated to a produ or a CATProduct cannot be associated as an alternate representation to a product. If you want to know how to manage representations as alternate shapes automatically, in D see Customizing DMU Optimizer Settings in CATIA - Infrastructure User's Guide.

From CATIA V5, new alternate shapes can be saved in ENOVIAVPM, directly in the database dialog box entitled Synchronization is displayed, you can click on OK. For more information alternate shapes in VPM, refer to Managing Alternate Shapes - Saving and Deleting Alternat VPM User's Guide. •

About CATParts and CATShapes
CATPart / CATShape differences? A part contains a "Product" description that does not exist in a CATShape:
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What is a CATShape?

A CATShape is designed to be used as a representation in a Part, product or component, which CA cannot. What is the CATShape's role? The role of a CATShape is to give a description to a product.

You can use several documents to describe a product. These documents can be divided in two gro • • a document describing the geometry, for instance: Cylindre_s.CATShape in our exemple. another document giving other specifications: cf. Cylindre_d.CATShape.

A CATPart contains both:

• the CATProduct's data, that is to say the product definition of the CATPart, • and the CATShape's data or the geometry definition of the CATPart. But there is a constraint: there is always a CATShape set as default. And the CATProduct (produc the CATPart) cannot have sons, it can have other Shapes but cannot set them as default. Moreov CATShape (geometry definition of the CATPart) can be considered as the second half of the CATP priority before the other Shapes.

453

project

Isolating a Part

This task will show you how to isolate a part in an existing assembly in order to move it independ other contextual parts. Contextual Links:

If you remark that there is such a Part with these symbols (brown gear and red flash) in your Ass you can edit this Contextual Part. The brown gear and the red flash signify that the Part reference and that this instance is not used in the Part Definition. This symbol can appear when you copy / a Contextual Part into another CATProduct without taking into account the contextual links.

In this case the user needs to resort to the "Define Contextual Links" or "Isolate Part" commands redefine the context of the Part and this red flash will be turned into a blue chain or green arrow.

For more information about broken contextual links, please refer to Defining Contextual Links: Ed Replacing Commands. Open the IsolateFunction.CATProduct document.

The option "Keep link with selected object" must be selected in Tools -> Options -> Infrastructure Infrastructure.

1. Double-click Sketch1 in Skeleton.CATPart in order to edit it. For instance, move the left sid Ctx1.CATPart. And go back into Product Structure workbench. Before the manipulation of Ctx1.CATPart: After:
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2. Click the Update icon (in Assembly Design Workbench, also available via Edit -> Upda Update contextual command). As a consequence, Part3 (Part3.1) moves in order to follow movement of Ctx1 (Part2.1) and the hole coincides between the two parts. If you modify o other one adapts itself to this change. This is due to the fact that both CATParts depend on document, Skeleton (Part1.1), and the option Keep link with selected object is activated.
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Ctx1 (Part2.1) and Part3 (Part3.1) are contextual parts, they depend on the Sketch1 in Skeleto (Part1.1) in which they were created.

3. If you want to make modifications impacting only on Ctx1 (Part2.1), select in the contextu Ctx1 (Part2.1) Component -> Isolate Part. When Ctx1 (Part2.1) is isolated, its symbol in t Specification Tree changes from to meaning that it is no longer a contextual part:
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4. Modify again the CATPart within the Sketcher and return in the Assembly Workbench. Only (Part3.1) has turned red in the Geometry space.
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5. Update the document. As a result, Part3 (Part3.1) has not moved to adjust to Ctx1 (Part2
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You can move independently Ctx1.CATPart from Part3.CATPart. As a consequence, when CTX1 is Part3 does not move and the hole does not coincide between the two CATParts.

Moving the Components of a Sub-Product in the Parent Product

This task illustrates how to move a component belonging to a rigid structure (the Parent Product is rigid). It implies that the instance of its parent product's reference is moved. Open the Articulation.CATProduct document.

The product "Articulation" includes one CATProduct and two CATPart documents (in rigid mode) as follows:
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1. Edit or double-click Articulation to make it UI Active (User Interface Active, in blue color). 2. Select link.1 and and move it with the compass:

The compass is not positioned on link.1 because the component is rigid and this is its instance within the product, Chain.1, which is taken into account. 3. As a result, you cannot move link.1 independently from link.2; the whole assembly (Chain.1) moves because its sub-components (link.1 and link.2) are rigid:

4. Undo this action to return to the initial state. 5. Edit or double-click Chain.1 to make it UI Active (in blue color) in order to be able to move the instance of the link.1 reference.
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6.
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6. Select link.1 and and move it with the compass: Note that if chain (chain.1) is UI-Active , you cannot move chain from Articulation. You can move the "sons" of the UI-Active object and not the object itself (the UI-Active "father"). You cannot move an object respect to itself.

Note that in this case, the compass is positioned on link.1. 7. You can now move link (link.1) independently from link (link.2).

8. If you double-click link (link.1), it becomes highlighted in blue (UI-Active) and you will not be able to move its "father". Therefore, to move a sub-product in a rigid structure, you need to edit its parent product.
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Using Flexible Sub-Products
In the product structure from earlier versions, you could only move rigid components in the parent product. Now, in addition to this behavior, you can dissociate the mechanical structure of a product from the product structure, and this within the same CATProduct document. As a consequence, you can move the components of a sub-product in the parent product. In a first place, this task recalls the behavior of rigid products, then it illustrates how to make sub-products flexible and eventually shows you how to analyze the mechanical definition of a product whenever this product includes flexible sub-products (and components attached together). For more information about components attached together, see Fixing components together in CATIA Assembly User's Guide). Open the Articulation.CATProduct document. 1. The product "Articulation" includes one CATProduct and two CATPart documents as follows:

2. Drag and drop the compass onto link (link.1), then select link (link.1) and drag it. The whole chain -and not link.1 only- is moved.

3. Undo this action to return to the initial state. 4. To make chain (chain.1) flexible, right-click it and select the Chain.1 object -> 464
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5. You can now move link (link.1) independently from link (link.2). For example drag and drop the compass onto link (link.1) and move it in the direction of your choice.

When a sub-product is flexible, you can apply updates to it, move it when constrained and set constraints to it. 6. Copy and paste chain (chain.1) within Articulation.CATProduct. You can notice that the property "flexible" is copied too.

7. To make chain (chain.2) rigid, right-click it and select the Components -> Flexible/Rigid sub-assembly contextual command. A message window appears. Click
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9. Open chain.CATProduct and move link (link.1) using the compass. The role of the compass is to: • look for the flexible product • move the highest product that is rigid or the first flexible component.

You can notice that because chain (chain.2) is rigid, it inherits the new position of the original chain.CATProduct. Conversely, chain (chain.1) remains unchanged.

What you need to keep in mind is that rigid sub-products are always synchronous with the original product, whatever mechanical modification you perform (new dimensions or new 466

Advanced Tasks positions for the original product). Flexible sub-products can be moved individually, without considering the position of the original product. However, flexible sub-assemblies inherit mechanical modifications to the original product. This command works upwards in the Specification Tree whereas the "stiffening" command (rigid mode) operates downwards. A component's position is borne by its reference. In a rigid mode, the position is carried by the first instance, the father of which is a reference (or a root product). In a flexible mode, the position is carried by the instance. Making a component flexible means that you are overloading its children's position. 10. Go to the Start -> Mechanical Design -> Assembly Design workbench, in the Analyze menu, select the Mechanical Structure... command to display the mechanical structure of Articulation.CATProduct. This mechanical structure looks different from the product structure.

11. This display is merely informative. Note that you can use the Reframe graph contextual command and the zoom capability to improve the visualization, but also the Print whole contextual command to obtain a paper document. For information on printing, please refer to Printing Documents in CATIA Infrastructure User's Guide. You can save the CATProduct with its flexible sub-products and when you re-open the

467

project CATProduct, the modifications are visible, these flexible components are kept in memory. It is a not possible to see Flexible / Rigid Sub-Assembly status (pink gear) in the main Assembly or Root Product if this functionality is applied in a new window, because it is an Instance's property (and not a Reference's Property).

Generating Numbering
This task shows you how to number the components of an assembly. Numbering components is possible provided these components are associated to representations. Open the ManagingComponents01.CATProduct document. 1. In the specification tree, select ManagingComponents01. 2. Click the Generate Numbering icon dialog box is displayed. . The Generate Numbering

There are two ways of numbering components: • • either you check the Integer option or the Letters option

Moreover, if you need to number an assembly with already existing numbers, you can keep or replace these numbers by checking the corresponding options. 3. Click OK to confirm the operation. Note that you can consult these numbers in the Product tab displayed by the Properties command, or in the Listing Report tab and in the Recapitulation of the Bill of Material.
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Reordering the Tree
This task shows you how to reorder components within the specification tree. Open the ManagingComponents01.CATProduct document. 1. Select ManagingComponents01.

2. Click the Reorder Tree icon . A dialog box appears, listing the components constituting ManagingComponents01 and providing three buttons for reordering these components.

The first arrow moves the selected component to the top of the list. The second arrow moves the selected component to the bottom of the list. The third button moves the selected component to the place of another component you need to select.

3. Select CRIC_FRAME and click the second arrow twice. CRIC_FRAME then appears after CR the list. 4. Click Apply to preview the result:
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5. Select CRIC_TOP and click the third button. 6. Select CRIC_AXIS to determine the location of CRIC_TOP. CRIC_TOP is now on top of the 7. Click OK to confirm the operation. The application closes the dialog box and updates the s tree. The tree is reordered as follows:

8.

Deactivating/Activating Nodes
Deactivating / Activating a Node
This task shows you how to deactivate / activate a Node in the Product Structure context. Open the CRIC_TERMINAL_NODE01.CATProduct document. 1. Select the Product CRIC_SCREW.
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2. Either select the command Edit -> Representation -> Deactivate Node or select the Deactivate icon .

This functionality allows you to mask an active representation from a particular node (at the level of CRIC_SCREW) in the specification tree and in the geometry :

3. By re-select the same node, CRIC_SCREW, and the command Edit ->
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Representation -> Activate Node or clicking the Activate icon elements re-appear both in the tree and in the geometry :

, the

By this means, you choose to visualize the geometric representation of CATIA elements, belonging to a CATProduct. With the Deactivate Node functionality, only the selected element is hidden. Whereas with the Deactivate Terminal Node functionality, the last node's elements of the selected node are masked. For more information, see the following chapter Deactivate / Activate Terminal Node. If you close a CATIA document containing deactivated CATParts or CATProducts, when reopening your document the deactivated elements are activated. As opposed to the SHOW / NO SHOW functionality : the entities in the NO SHOW mode remain in this mode when you reopen the document. Both functionalities, Deactivate / Activate Node and SHOW / NO SHOW, are very similar but with the deactivate option you liberate the geometrical space, a deactivated representation is unloaded and it is no longer stored. On the contrary, with the SHOW / NO SHOW mode there is a more important quantity of stored memory. The activate / deactivate functionality allows a more precise selection and deselection, especially with the Terminal Node deactivation. You can activate or deactivate Shape representation in Tools -> Options -> Infrastructure, select the Product Structure tab and check the box entitled Do not activate default shapes on open. The entity representation disappears, it is a profit for memory space and its icon in the specification tree changes into :
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. You can work only on the tree. For more information about activate or deactivate Shape representation, see Specification Tree.

Deactivating / Activating a Terminal Node
This task shows you how to deactivate / activate a Terminal Node in the Product Structure context. Open the CRIC_TERMINAL_NODE01.CATProduct document. 1. Select CRIC_SCREW.

2. Select the command Edit -> Representation -> Deactivate Terminal Node. The representation of Terminal Nodes (of CRIC_BRANCH_3 et CRIC_BRANCH_1) disappears from the specification tree and the geometry, and their icon in the specification tree changes into : .
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3. By re-select the same node, CRIC_SCREW, and the command Edit -> Representation -> Activate Terminal Node, the elements re-appear both in the tree and in the geometry :

By this means, you can choose to visualize or hide CATIA elements. Under a selected node, the elements of the very last node are masked.
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Activating a Terminal Node with a Progress Bar
This task consists in visualizing the activation of shapes (using the Activate Terminal Node Command) with a progress bar that gives the number of activated shapes out of the total deactivated shapes. For more information about the progress bar, please refer to Opening an existing Document with a Progress Bar. Open the AnalyzingAssembly01.CATProduct document. • • Select the root product AnalyzingAssembly01 and the command Edit -> Representation -> Deactivate Terminal Node. All the shapes are deactivated. Or you can deactivate shape representation in the Tools -> Options -> Infrastructure -> Product Structure -> Product Visualization tab, by selecting the Product Structure tab and checking the box entitled Do not activate default shapes on open. Then, open the AnalyzingAssembly01.CATProduct. All the shapes are deactivated:

For more information about this functionality, please refer to Deactivate Terminal Node.

Select the root product AnalyzingAssembly01 and the command Edit -> Representation -> Activate Terminal Node. The shapes are progressively downloaded.
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And you can see the progression of the downloading of the shapes associated to a terminal node:

This operation is activated by default (there is no setting). When this dialog box disappears, the whole geometry (assembly) and the Specification Tree are displayed.
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Project Workbench Description
To enter the project workbench: Project Center -> Project
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Menu Bar
This section presents the main menu bar available when you run the application and before creating or opening a document: Start File Edit View Insert Tools Analyze Windows Help

Edit

For

See

Replace Component...

Replacing a Component

Isolate Part

Isolating a Part

Change Context

Changing Context

Load

Loading Components

Unload

Unloading Components

Graph tree Reordering

Graph Tree Reordering

Manage Managing Representations... Representations Design Mode Using Design Mode
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Manage Managing Representations... Representations Design Mode Visualization Mode Activate Node Deactivate Node Activate Terminal Node Deactivate Terminal Node Using Design Mode Using Visualization Mode Activating Node Deactivating Node Activating Terminal Node Deactivating Terminal Node See

Insert

For

New Component New Product New CDM Component

Inserting a New Component Inserting a New Product Adding a CDM Product to a Product, in ENOVIA/CATIA Interoperability User's Guide. Inserting a New Part Inserting an Existing Component CATIA - Product Knowledge Template User's Guide See

New Part Existing Component... Document Template Creation... For

Analyze
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Bill of Material...

Displaying the Bill of Material (BOM) Managing the Bill of Material (BOM) Capacity not to take into account a Component in BOM Searching on BOM Attributes

Toolbars
Drawing Annotations Toolbar

See Creating a Text With Leader See Creating a Flag Note With Leader

Drawing Views Toolbar
Front View/Annotation Plane Offset Section View/Section Cut Aligned Section View/Section Cut

Scenes Toolbar
See Creating an Enhanced Scene. See Browsing Enhanced Scenes using the Scenes Browser.

Drawing Annotations Toolbar
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See Annotated View See Managing Annotated Views See Adding 3D Annotations See Creating Hyperlinks See Jumping to Hyperlinks

Scene View Toolbar
Previous view -- see Changing Views Next view -- see Changing Views See Magnifying See Setting Depth Effects See Viewing Objects against the Ground See Setting Lighting Effects .

Update Toolbar

See Updating an Assembly See Browsing a Catalog Using the Catalog Browser

Space Analysis Toolbar

See Detecting Interferences See Sectioning

Measure Toolbar
See Measure Between See Measure Edge See Measure Inertia

Apply Material Toolbar
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See Applying a Material Onto Surfaces

Select Toolbar

These commands are all documented in Selecting Using the Selection Traps Selection using the bounding outline Selection Trap Intersection Trap Polygon Trap Paint Stroke Trap Outside Selection Trap Intersecting Outside Trap Selection

Product Structure Toolbar

See Inserting a New Component See Inserting a New Product See Inserting a New Part See Inserting an Existing Component See Replacing a Component See Reordering the Tree See Generating Numbers See Selective Load
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Representation Toolbar
See Managing Representations See Visualization Mode See Design Mode See Activate Node See Deactivate Node

Project Attributes Toolbar

Select Package Show Attributes Attach Package Edit Package Remove Package see Color Geometry and Microsoft Project Simulation Turn Dim Mode On/Off

Color Geometry and Microsoft Project Simulation
Color Geometry Based on Attribute Values Color Geometry Based on Layer Microsoft Project Simulation

Specification Tree
Specification Tree Symbols
Depending on the operations you perform, you may encounter new symbols on your features in the specification tree. This table provides a list with a brief explanation
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Manipulators
This page deals with the options concerning: • The Manipulators.

Manipulators

Defines the manipulator options:

Reference size
Defines the annotation manipulator's size. By default, the reference size is 2mm.

Zoomable
Defines whether the annotation manipulator is zoomable or not. By default, this option is selected.

Customizing External Formats Import
If you have the SolidWorks, SolidEdge or Acis Plug-In license, the following categories of options will be available: • • • • • • visu format unit link mode others output of generated data Ideas ProEngineer
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You imported a CAD Part through the Insert ->Existing Component command.

Visu Format Unit

Millimeters per unit
This setting allows you to specify the number of millimeters per unit of the model. For instance, if you have a file in inch, you need to enter 25.4 in this field. This option is taken into account when you have the following formats: SLP, STL, OBJ, BYU, IFF and _PS. Note: For a file of type _PS, the Visu Format Unit must be set to 10.

Link Mode

Visu
Tesselated data. By default, this option is activated.

Visu Snap
Recovery of CAD's exact geometry to generate V5 CGR. Canonical shape properties are identified. The visualization mode enables part snapping capability. After selecting this option, this message appears: "Please, restart session to take modifications into account".

CATPart
Link with a V5 CATPart. Do not modify this CATPart in CATIA V5.

Others
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Save Coorsys in Cgr
Stores part coordinate systems in .cgr file. It is only supported in the indirect mode. This parameter determines whether coordinate systems present in imported ProE, UG or IDEAS parts will be imported into the resulting CGR files.

Output of generated data

Output Path
Lets you customize the Output File for generated data. It specifies the location where CGR and CATParts will be generated.

If you have the IDEAS, ProEngineer or Unigraphics Plug-In licenses, additional options will appear in the External Formats tab. With the IDEAS Plug-In license, you obtain:

IDEAS (direct mode)

IDI 3D Annotation (CATPart mode only)
Select this option to convert IDI 3D Annotations to V5 (requires one of the following licenses): • • • CATIA: FT1.prd or FTA.prd ENOVIA: DT1.prd DELMIA: MTR.prd or MFT.prd

ProEngineer
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With the ProEngineer Plug-In license:

Quilts Read
Enables to activate the transfer of quilts surfaces inside CGR. This setting does not apply to NCGM or CATPart conversions. By default, this option is not activated.

Simplified Representation
Only part simplified representation is supported. To set the name of the part simplified representation to use before the Assembly conversion, check this box and enter the name. By default, this option is not activated.

Instance Name
When you want to import a specific instance of a generic assembly/part, check this button and specify the name of the instance of your choice. By default, this option is not activated. • • For Simplified Representation and Instance Name, only upper case names are supported with the direct converter. xpr files must be on the disk for proper support of Part Instances conversion.

Customizations
General
This task explains how to customize General DMU settings.
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Accessing General DMU settings
1. In the menu bar, select Tools -> Options. The Options dialog box appears. 2. Click the Digital Mockup category. 3. Click the General tab.

The General settings page concerns the following settings categories: • Preview • Group Preview

Preview

You can customize the automatic display of preview windows. Click preview checkboxes as appropriate to change the automatic display setting of preview windows when creating cameras, manipulating objects, etc. By default, this option is activated.

Group Preview
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You can customize the graphic properties of components displayed in the Group Preview window.

Visualize hidden objects as in main viewer
Click the Visualize hidden objects as in main viewer checkbox to visualize hidden objects in the Group Preview window as in the main window. By default, this option is activated.

Visualize hidden objects with customized graphic properties
Click the Visualize hidden objects with customized graphic properties checkbox to visualize hidden objects in the Group Preview window with customized graphic properties. • • • • To customize the color graphic property, click the Color selection button and choose the desired color from the proposed list. To customize the opacity graphic property, click the Opacity selection button and choose the desired opacity setting from the proposed list. To visualize components in low-intensity, click the Low Intensity checkbox. To visualize components as pickable, click the Pickable checkbox.

By default, this option is not activated.

Confirming chosen options
4. When you have finished customizing options, click OK to confirm.
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DMU Navigator
This task explains how to customize DMU Navigator settings. You can choose to always create imported applicative data in a DMU Review at highest level.

Accessing DMU Navigator settings
1. In the menu bar, select Tools -> Options. The Options dialog box appears. 2. Click the Digital Mockup category. 3. Click the DMU Navigator tab.

The DMU Navigator settings page concerns the following settings categories: • • • • • • • • • • Hyperlink representation Marker Default Properties Text Marker Properties Scene Default Properties Update on Product Structure modifications and Scene activation Publish Spatial Query parameters Import of applicative data Fast Clash detection DMU Review default properties

Hyperlink representation

You can add hyperlinks to your document and then use them to jump to a variety of locations, for example, to a marketing presentation, a Microsoft Excel spreadsheet or a HTML page on the intranet.

Name
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Marker Default Properties

There are three options available for customizing the display of 2D and 3D markers. Defining the Marker default properties in the Tools->Options->DMU Navigator sets the selected properties as default properties and changes how new annotations will look when you create them.

Color
Click the Color selection button and choose the desired color from the proposed list. By default, this option is valuated to Red.

Weight
Click the Weight selection button and choose the desired line weight from the proposed list.

Text Marker Properties

There are five options available for customizing the display of 3D markers. Defining the Marker default properties in the Tools->Options->DMU Navigator sets the selected properties as default properties and changes how new annotations will look when you create them. Note: The options Color, Weight, Dashed, Font and Size only apply to 3D markers, they do not apply to 2D markers.
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There are two additional options concerning special modes available for 2D and 3D markers.

Color
Click the Color selection button and choose the desired color from the proposed list. By default, this option is valuated to Red.

Weight
Click the Weight selection button and choose the desired line weight from the proposed list.

Dashed
Click the Dashed selection button and choose the desired dash pattern from the proposed list.

Font
Click the Font selection button and choose the font from the proposed list.

Size
In the Size text-entry field, enter the desired size value or click the selection buttons to increase or decrease the value.

2D Marker Part Name Recognition
Click the 2D marker part name recognition checkbox in order to activate the option to automatically use a Part's Name as the default for the creation of text annotations. By default, this option is unchecked.

3D Marker with Graphic Message Mode
Click the 3D marker with graphic message mode checkbox in order to activate the mechanism that enables you to transform temporary markers into persistent 3D annotations. By default, this option is unchecked.

Scene Default Properties
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Change the Scene background color as desired.

Color
Click the Color selection button and choose the desired color from the proposed list. By default, this option valuated to Green.

Update

This option manages a publish/subscribe mechanism which will manage the automatic updates of certain events: • • • • • • • • move shape activation insert replace product delete product UI-activation modification graphic attributes modification Enhanced Scene activation

Update on Product Structure modifications and Scene activation
Uncheck the Update on product structure modifications and scenes activation option if necessary. If the option is unchecked, some applicative data will not be automatically updated upon the above events. However, if the option is unchecked, performance will be faster. By default, this option is checked.

Publish
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Browser automatically opened
To activate the automatic launching of Publish results in a browser upon the stopping of the Publish process, in the Publish area, check the Browser automatically opened checkbox . By default, this option is checked.

Spatial Query parameters

The spatial query calculation is based on a cubic representation of each part, the size of the cubes of which is designated by the accuracy parameter. The clearance parameter defines an area around the reference selection within which all products are considered "nearby" and outside of which all products are considered "far away".

Released Accuracy
In the Released accuracy text-entry field, enter the desired released accuracy value. To force users of the Spatial Query command to use the defined Released Accuracy value, check the Force released accuracy in interactive command checkbox. The default value for Released accuracy is 20mm. By default, the Force checkbox is unchecked.

Clearance
In the Clearance text-entry field, enter the desired clearance value. To force users of the Spatial Query command to use the defined Clearance value, check the Force clearance in interactive command checkbox. The default value for Clearance is 0mm. By default, the Force checkbox is unchecked.

Import of applicative data
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Do the Import
To activate the applicative data import, click the Do the Import checkbox. By default, this option is unchecked.

With a user prompt
This option will be available if you have checked the Do the Import option above. In order that a dialog box will appear enabling you to define a subset of applicative data to be inserted, click the With a user prompt radio button.

Automatically
This option will be available if you have checked the Do the Import option above. To automatically insert the applicative data, click the Automatically radio button.

Always create DMU Review at highest level
To always create imported applicative data in a new DMU Review at highest level, click the Always create DMU Review at highest level checkbox. By default, this option is unchecked.

Fast Clash detection

Use Voxelisation for collision detection
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Voxel size
Specifies the voxel size to use for the clash detection. By default, this option is valuated to 5mm.

Sag precision
Specifies the use of the currently defined sag value for the clash detection. By default, this option is unchecked.

View collision feedback
• If you select a voxel size and check the View Collision Feedback button, then you obtain a clash detection with a voxel precision of the specified size, with clashing parts highlighted and the center points of the voxels appearing in red. If you select a voxel size and uncheck the View Collision Feedback button, then you will obtain a clash detection with only the clashing parts highlighted. If you select sag precision and check the View Collision Feedback button, then you obtain a clash detection with the precision of the sag, with clashing parts highlighted and the intersection curve of the clashing parts appearing in red. If you select sag precision and uncheck the View Collision Feedback button, then you obtain clash detection with only the clashing parts highlighted.

• • •

By default, this option is unchecked.

DMU Review default properties

This parameter determines the default name for new DMU Reviews that you will create.

Name
In the Name text-entry field, enter the desired default name for DMU Reviews.

By default, this option is valuated to the string DMU Review.
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Confirming chosen options
4. When you have finished customizing options, click OK to confirm.

Customizing a Toolbar by Dragging and Dropping
This task shows how to customize a toolbar by dragging and dropping a command onto the toolbar to add the command, and dragging a command away from a toolbar to delete the command. Before you begin, note that: • • the View toolbar cannot be customized you cannot drag and drop local commands onto global toolbars (for instance, you cannot drag and drop the Pad command onto the Standard toolbar). If you try to do so, the symbol forbidden. is displayed to indicate that this action is

1. Select the Tools->Customize... command or right-click any icon in any toolbar then click Customize... to open the Customize dialog box:
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The dialog box contains the following tabs: • Start Menu: customizes the Start menu and workbench access icons (as described in "Accessing the Navigation Tools") • User Workbenches: lets you create your own workbenches • Toolbars: lists the currently visible toolbars (default) • Commands: lists the commands you can drag and drop onto a toolbar • Options: contains general customization options. With the Toolbars tab open, double-clicking any icon highlights, in the toolbars list, the toolbar the icon belongs to. Double-clicking any toolbar also highlights the toolbar name, allowing you to identify it. However, note that you must double-click the bottom of the toolbar for toolbars displayed in the bottom part of the workbench (such as the Standard toolbar) and you must double-click the right part of the toolbar for toolbars displayed on the right side of the workbench. Otherwise, double-clicking the toolbar undocks it but does not highlight its name in the list. 2. Click the Commands tab to list the commands available. The Categories list allows you to filter the listed commands by category: the category is the name of the menu in the menu bar. For example, selecting the Edit category in the Categories list displays in the commands list all the commands likely to appear on the Edit menu.
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The category All Commands lists all commands available. You can also select the Select command. If you created macros, the macro names are also listed. You can then add macros to a toolbar. 3. Select a command from the command list. In this example, the Capture... command has been selected. Note that the icon for the command is displayed at the bottom of the dialog box, along with a short help message explaining the role of the icon.

4. Drag the command from the command list to the toolbar to which you want to add the command. 5. Drop the command onto the desired toolbar. In our example, the icon for the Image Capture... command has been added to the standard toolbar: Note that this does not apply to icon boxes which cannot be customized.
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6. To delete a command from a toolbar using the drag-and-drop mechanism, drag the command and drop it back inside the list of commands in the Customize dialog box. You can also drag and drop commands which do not have icons: in this case, the command name appears in the toolbar. Your customization is stored automatically in the FrameConfig.CATSettings file: you recover it if you exit then restart. For more information about settings, refer to About Settings. If you intend to acquire or remove licenses using the Tools->Options>General->Shareable Products tab, do not forget to first exit then restart your Version 5 session before accessing this tab in order to recover your customization. Acquiring or releasing shareable products implies that all the toolbars and menus are regenerated. The user interface is recomputed using the last settings saved and therefore, if your customization has not been previously saved, it will be lost.

More about dragging and dropping icons
It is not recommended to drag and drop a Version 5 icon onto another application (such as Microsoft PowerPoint, Microsoft Word, etc.): in that case, the dropped icon disappears from your Version 5 session and the only way to restore it is to use the Tools->Customize... command then follow the steps detailed in this scenario.

Working with ENOVIA LCA: Optimal CATIA PLM Usability
The Safe Save mode prevents the user from creating or editing data in CATIA that cannot be correctly saved in ENOVIA V5. Working in this mode means that certain commands are unavailable (i.e. grayed out) as you enter the workbench. However, these unavailable commands are not grayed when displaying the list of commands using Tools->Customize.... As a consequence, if you drag and drop one of these commands onto a toolbar then use it, bear in mind that the created data will not be saved in ENOVIA V5. For detailed information on the interoperability between CATIA and ENOVIA, refer to the Version 5 - ENOVIA-CATIA Interoperability User's Guide.

Assembly Design
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This page deals with Assembly Design options in the following tabs: • • The General tab lets you set the general options. The Constraints tab lets you define the constraint options.

Cache Management
Cache Management
Using a cache system considerably reduces the time required to load your data. This task explains how to customize cache settings. The released cache feature requires a DMU license. The timestamp feature requires a DMU license. If you activate the cache using a VB macro, you will not receive a message reminding you to re-launch your session. You must, however, re-launch your session. For information on working with a cache system, see About Working with a Cache System.

A DMU Navigator document must be opened.

It is imperative that any directory designated for use as a cache directory be reserved for this usag this directory. (When necessary, the Check Maximum Size option purges the least-recently-accesse designated Maximum size. As a result, any files that you manually save to this directory could eve

When you are working in Cache mode, a .model or .CATPart is converted to a .cgr format. You can Design Mode command. See the task Design Mode in the Product Structure user guide.

Accessing Cache settings
1. In the menu bar, select Tools -> Options. The Options dialog box appears. 2. Click the Infrastructure -> Product Structure category. 3. Click the Cache Management tab.
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The Cache Management settings page concerns the following settings categories: • • • • • Accessing Cache Settings Cache Activation Cache Location Cache Size Timestamp

Cache Activation

Work with the cache system To activate the cache, check the Work with the cache system checkbox. Note: You must re-start the application in order that the cache activation be taken into account. By default, this option is unchecked.

Cache Location
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Cache Location New features have been added to the Cache Management that render the configuration of the loca • • Local cache - a history of the last five defined paths Released cache - a configuration panel that enables you to:

• select directories from a list of "accessible" directories that have been pre-defined by the ad • reorder the directories list • remove entries from the directories list Note that it is possible to use environment variables to define a local cache or a released cache: • • •

the variable should be defined (using the set command on Windows or the export command file of the interactive application the variable must be correctly valuated to an existing directory the entry in the local cache or released cache text-entry field should be of the form ${varia

Path to the local cache

To define a local cache directory, enter the name of the directory in the Path to the local cache text button and select an entry from the proposed history list.

By default, this variable is valuated to Windows: C:\Documents and Settings\userid\Local Settings\Application Data\Dassault System UNIX: $HOME/CATCache

Path to the released cache To define a released cache directory, enter the name of the directory in the Path to the released ca configuration panel by clicking the Path to the released cache Configure button.

By default, this variable will be a list of the released caches that have been defined by your admi

Configure
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To add one of the Accessible Directories to the list of Current Directories, select the entry in the Ac The entry is added to the Current Directories list.

Note: The list of directories in the Accessible Directories list is defined by the administrator as fol • define a .txt file of which each line contains the path to a directory that will appear in the list of accessible directories • set and export an environment variable AVAILABLE_CACHE_DIR_PATH that points to the above .txt file • the administrator can, of course, manage the access rights to the above-defined directories specific users

To move one of the entries in the Current Directories list to a higher place in the list (remember th

which you see them displayed), select the entry in the Current Directories list and click the Up-arro The entry is moved up in the list.
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To delete an entry from the Current Directories list, select the entry in the Current Directories list a

To enter the paths identifying the cache locations, click the Browse icon . The Browse enables to his own local cache location, and if permitted by the site administrator, one or more paths to rel

The default directory is the user's home directory under UNIX and the USERPROFILE directory unde
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Cache Size

Check maximum size (Optional) Set the maximum size for local cache option.

Check this option to activate the verification that the maximum size of the local cache has not been By default, this option is unchecked.

Maximum size Set the maximum size for the local cache.

When a file needs to be tessellated and the maximum size is exceeded, a sufficient number of .cgr make place for the .cgr file that needs to be calculated. A warning message will appear in the Incid

When inserting a component, the maximum size is checked before tessellation of the component to becomes greater than the maximum size specified in the setting. By default, the maximum size is 500 MB.

Timestamp

Check timestamps
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If clicked, the system checks the original document's date against that of the corresponding cgr file the out-of-date version. If dates are the same, no tessellation is done and the cgr file in the data c Turning this option off means that no check is run and cgr files in the cache are systematically load

By default, this option is unchecked.

GMT timestamp format
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Until now, the cache timestamp has been based on local time. This can lead to unwanted re-tessell different time zones. It is now possible to base your cache on GMT time. The following are the rules for implementing your cache based on GMT time: • • •

a batch job will permit you to migrate old caches to GMT time-based caches once a cache is migrated to or designated as GMT time-based, you can never go back to a l ALL caches (local cache and released caches) must be of the same format

To migrate an old cache, use the following command: CATSysMvCache -o UTC -inputdir input_directory -log file.txt [-outputdir output_directory]

If outputdir is not set, the cache specified in inputdir and the documents it contains are converted t

Once a cache has been migrated to GMT time-based, it is no longer compatible with previous relea be used in V5R11 or below).

To designate all caches specified in Cache Location as GMT time-based, check the GMT timestamp Note: When the GMT timestamp format option is activated: • all new caches will be based on GMT time • all specified caches must have been updated using the provided batch job

If any of the caches specified do not conform to the rule that all caches must be of the same form

By default, this option is unchecked.

Confirming chosen options
4. When you have finished customizing options, click OK to confirm.
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Cgr Management
The cgr settings enable you to define the policy for the generation of cgrs into the cache.

Accessing Cgr settings
• • • In the menu bar, select Tools -> Options. The Options dialog box appears. Click the Infrastructure -> Product Structure category. Click the Cgr Management tab.

The Cgr settings page concerns the following settings categories: • General • Applicative data

General

Save level of details in cgr

Activating this option will cause level of details to be added to generated cgrs. By default, this option is activated.

Save lineic elements in cgr

Activating this option will cause lineic elements to be added to generated cgrs. By default, this option is not activated.

Optimize cgr for large assembly visualization

When this option is activated, only a subset of each cgr data content is loaded, thereby reducing memory consumption and improving loading performance.
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Workbench Description Note the following: • This subset is sufficient for most DMU review scenarios performed on large assemblies • If a DMU command requires more information from some cgrs, the entire data content of the concerned cgrs will be automatically loaded. • This option has an effect during session time only, it has no impact on the persistent content of the cgr. • This option is only compatible with cgrs computed in V5R14 or later. • In order to upgrade old cgrs, see the DMU Navigator User Guide, Running the CATDMUUtility Batch Process, option -force.

By default, this option is not activated.

Applicative data

Save density in cgr

Activating this option will cause density data to be added to generated cgrs. By default, this option is not activated.

Save V4 Comment Pages in cgr

Activating this option will cause V4 comment pages to be added to generated cgrs. By default, this option is not activated.

Save V4 Filter Layers in cgr

Activating this option will cause V4 filter layers to be added to generated cgrs. By default, this option is not activated.

Save FTA 3D Annotation representation in cgr
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Confirming chosen options
• When you have finished customizing options, click OK to confirm.

Cgr Management for 3D Annotation

This page deals with the options concerning: 2. The Applicative data.

Applicative data

Please refer to Infrastructure user's guide to know more about the Product Structure Cgr Management options.
Save FTA 3D Annotation representation in cgr

You need to select this option to add the 3D annotations representation contained in a CATProduct or a CATProcess document to the generated cgr documents. This option is taken into account when the Cache Activation option is selected only. By default, this option is not selected.

Loading of Referenced Document

This page deals with the General options concerning:
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3. The Referenced Documents.

Referenced Documents

Please refer to Infrastructure user's guide to know more about the Product Structure General options.
Load referenced documents

You need to select this option to load the related documents with a CATProduct document. By default, this option is selected.

Design in Assembly Context
Assembly Design can be cooperatively used with Part Design in many ways. If in a CATProduct document you can design parts from scratch or reshape them, you can also create associative links between several parts. These links can be geometrical and are then referred to as External references"or parametrical then referred to as External parameters in the specification tree. Assembly Design provides a large range of commands or options to manage those links. These capabilities are: 2. Keep link with selected object option lets you maintain the links between external references, copied elements for example, and their origins when you are editing these elements. For more information, see Customizing General Settings, External References.

3. Isolate contextual command: cuts the link between external references and their origins. Management of both assembly constraints and design in context: it is possible to set constraints between published geometrical elements. See Constraint Creation in customizing assembly constraints.

4. Edit Links, see Displaying Document Links and Editing Documents Links in Infrastructure User's Guide. 5. Copy of external elements to update parts outside assembly context.
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6. Automatic synchronization during update operations, or manual synchronization. 7. Activate/Deactivate link. 8. Publication: to reuse existing designs and manage links. For more information, see Customizing General Settings, External References. 9. Copy Break/Link/New From to quickly reuse a part.

Assembly Features
This reference will describe Assembly Feature behaviors in assembly document and their Resulting Features in part document.

Visualization Mode
According to the Access to geometry option, part documents in Visualization Mode affected by an Assembly Feature swap automatically or not to the Design Mode: 4. If the Automatic switch to Design mode option is checked: 1. Assembly feature creation: selected part documents swap automatically from Visualization Mode to the Design Mode to create it. 2. Assembly feature edition: affected part documents swap automatically from Visualization Mode to the Design Mode to edit it. 3. Assembly feature deletion: affected part documents swap automatically from Visualization Mode to the Design Mode to delete it. 2. If the Automatic switch to Design mode option is unchecked or if the part document is unloaded: 1. Assembly feature creation: selected part documents are not modified. 2. Assembly feature edition: affected part documents cannot be modified. 3. Assembly feature deletion: the Assembly Feature is deleted in the assembly document, but not the Resulting Features in the affected part documents. The Broken mask will appear on the specification tree Resulting Features icons, when the part will
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be loaded.

Links of Resulting Features
In Part Design context: 3. The Edit -> Links... command show the links of the part's Resulting Features. 4. The Parent/Children... command on a Resulting Feature show the Assembly Feature link. If the link is broken, the Broken mask appears on the specification tree icons.

Isolate Resulting Features
To edit, copy, paste or delete a Resulting Feature, you must isolate it before these operation. In this case the resulting Feature behavior is the same as its Part feature equivalent. Take care that you cannot reconnect an isolated Resulting Feature.

Design in Context
Assembly features are always design in context and the Keep link with selected object option lets you maintain the links between external references only: • • If you wish to isolate a resulting feature, run the Isolate contextual command. If you wish to create a feature on only one part, edit the part directly.

See Design in Assembly Context for more information.
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