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Interacting in Digital Project: Overview
Interacting in Digital Project describes basic features that are used throughout the product to • • • • navigate through a model or part view a model or part and manage the views and the rendering style manipulate and select objects manage and share data: images, documents, and drawings
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What's New?
New Functionalities
Viewing Sub-Trees The Sub-trees command lets you hide or show the sub-trees linked to the current window.

Knowledgeware
Deactivating and Re-activating External Parameters Users can now re-activate and synchronize external parameters previously deactivated.

Enhanced Functionalities
Selecting Objects
Selecting Using the Preselection Navigator Ability to display or not the magnifier. Selecting Using a Filter The mouse cursor is now colored when the Geometrical Element Filter is selected in order to distinguish it from the cursor displayed when the Feature Element Filter is selected.

Manipulating Objects
Using the Paste Special... Command When pasting As Result features with an undetermined dimension i.e. features containing several geometrical domains with a different dimension (such as a point and a line or a line and a plane), the result is a 3DDatum.

Viewing Objects
Activating Viewing Tools The new version of the SpaceMouse developed by 3DConnexion is supported (SpacePilot): this new version is an avanced SpaceMouse with an LCD panel displaying the functions of the device buttons.

Using the Album
Previewing and Printing Images Ability to visualize and print images in SVG format when using the Album.

Customizing Toolbars and Workbenches
Customizing Buttons Ability to create, rename and delete configurations (i.e. set of button functions). Due to the support of the new 3DConnexion SpaceMouse, a new contextual command named Get Driver Command lets you map a 3DxWare function to a command. In addition to that, the calibration state is now shared by Version 5 and the device driver. Customizing Options
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Interacting A new slider lets you change the default size applied to button icons displayed in toolbars.

Customizing Settings
Display A new option lets you activate or deactivate the display of the immersive viewer when using the preselection navigator. Saving All Documents A new option lets you restrict the impact of the Save All command to the current editor. Statistics The new PCS Statistics thematic measures memory and CPU consumption in PCS (performance, capacity and scalability) scenarios.
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Getting Started
The Workbench Concept
A workbench is a set of tools for completing specific tasks. Each type of document can be edited with a document-specific set of tools. The project workbench contains features for managing the structure of a project while the Geometry workbench manages the specification of the geometry of the elements of the project.

Accessing Sample Documents
This task explains how to access sample documents. Sample documents (installed along with the online help library) are provided in many (but not all) cases, to support the topic scenario explaining how a specific command works. 1. Access the online help library using any of the usual methods. 2. Locate a help topic containing a prerequisite step prompting you to open a sample document. For example, the topic "Preselecting and Selecting Using the Pointer" looks like this:

The step highlighted in red prompts you to open the document "Select.CATProduct". The name of the document is a hypertext link. 3. Click the link. If your default browser is Internet Explorer, the browser then prompts you to choose whether to save the file to disk or open it from its current location:
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If your default browser is Netscape, the browser then prompts you to choose whether to save

4. Check the option "Open this file from its current location" if you using Internet Explorer, then click OK. Simply click OK if you are using Netscape because the "Open it" option is already checked. Your session is opened and the sample document is loaded:
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The online documentation is installed by default on Windows in: C: Program Files Dassault Systemes B14doc English

The sample documents are installed in user guide-specific sample folders. In the online documentation filetree, there is one samples folder for each users guide, in the following location: C: Program Files B14doc Dassault English online xxxug_C2 samples

Systemes

where "xxx" represents the three-letter code for the product. For example, the folder: C: Program Files B14doc Dassault English online prtug_C2 samples

Systemes

contains the sample documents for the Part Design User's Guide. Wherever you install the documentation, if you attempt to activate the sample documents from within the online documentation without first installing the code, the samples will not work: the Version 5 document extensions must be registered on a computer where the code is installed. The registering of extensions in the registry is performed automatically on the computer during the installation of the code on Windows.
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Problems Encountered with Sample Documents Containing Links to Other Documents
Sample documents can be either self-contained (for example, CATPart documents), or contain links to other documents (for example, CATProduct documents can contain links to CATPart documents). When you open a document containing links to other documents, note that the document location strategies you set using the Document tab (via the Tools->Options... command) determine where the software looks for the pointed documents. One strategy, "Folder of the pointing document", must be activated. Otherwise, the linked documents will not be located when you open the sample. Furthermore, after installing the samples along with the online documentation, we recommend that you do not copy the samples elsewhere. If you do, do so using the appropriate Version 5 tools (File->Send To->Directory, File->Save Management..., etc) and not operating system tools. For more details about document location strategies, refer to Document.

Problems Encountered with Sample Documents when Using Netscape
Declaring MIMEtypes on UNIX
However, users of Netscape in a UNIX environment who want to open sample documents (for instance .CATProduct documents containing .CATPart documents, .model documents, .CATDrawing documents, and so on) need to register these extensions by setting MIMEtypes using Netscape preferences. If you do not do so, the documents appears as garbage text. On Windows, this step is not necessary because the appropriate extensions are registered in the Windows registry. To do so: 1. Select Edit->Preferences. 2. Click Navigator->Applications in the Category frame of the window that appears. 3. Click the New... button. This displays the Netscape: Application window:
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4. Start declaring the MIMEtypes (begin with CATPart) by entering the following information: • CATPart in the Description field, • "application/catia" in the MIMEType field • CATPart in the Suffixes field. 5. Click the Application button in the Handled By frame. 6. Enter the application path in the field. For a default installation, the application path is: /usr/DassaultSystemes/B14/OS_a/code/command/catstart -object %s 7. Click OK when done. 8. Repeat the same steps for each type of data your sample documents may contain. Note, however, that in the MIMEType field, you should increment the application number like this for each MIMEType created: application/catia2 application/catia3 because specifying "application/catia" for each MIMEType will overwrite the previous application setting.

Problems Encountered on Netscape when Opening Documents Containing Links to Other Documents
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On both Windows and UNIX, you may encounter problems opening certain sample documents (for instance .CATProduct documents containing .CATPart documents, .model documents, .CATDrawing documents, and so on). When you open a .CATProduct, for example, the CATProduct docmuent is successfully opened but a warning dialog box informs you that the documents it points to cannot be located. This is because Netscape copies the documents to a temporary directory before opening them. When this occurs, you can open the sample manually and recover all the links using one of following two recommended solutions: • • use the File->Open... command in Version 5 or, when reading the online documentation containing the link to the sample in the Netscape window: o on UNIX, right-click and select the "Copy Link Location" command, then paste the command in Version 5 in the File ->Open... command dialog box, then remove the characters "File:" (if you don't, you will not be able to open the sample) o on Windows, right-click and select the "Copy Link Location" or "Copy shortcut" command, then paste the command in Version 5 in the File >Open... command dialog box without modifying it.

If you check the option "Save to Disk" instead of "Application", the sample document will be saved on your workstation and will not open directly in a Version 5 session.

Accessing Sample Documents via a HTTP server
When accessing sample documents via a HTTP server, Internet Explorer replaces a file extension containing more than 8 characters by the default extension ".txt". Consequently, it is not possible to open by double-clicking with the mouse any documents whose extension exceeds 8 characters such as: CATProduct, CATAnalysis, ... To open them, you must use the File->Open menu. Furthermore, if you try to use the " Save this file to disk" option, the file will be saved with no extension, rendering the file useless. Consequently, if you want to save the document, you have to type the full name of the document with the appropriate Version 5 extension. For example, if "xxxxx" is proposed by the File->Save dialog, then you must complete it like this: "xxxxx.CATProduct" before saving. These limitations do not apply to Netscape.

The Master Model and the Working Model
10

Getting Started The Master Model concept sits at the heart of CATIA, not just within AEC but (in slightly different flavors) in all industries that use the CATIA family of tools. It can interchangeably be referred to as a Digital Mock-Up (DMU), Digital Model, 3D Model Database, etc. The Master Model as presented here is the evolving result of over 12 years of experience in the Gehry office. It is understood as an integrated 3D Database which contains not only all major project geometries but also added-value information that describes and complements the geometrical information in the model. This information is by-object attribute information that describes each and every component in the model, including how it is made, what material it is, what sequence of the construction process it is part of, and so on. This sophisticated information set is extremely powerful during all phases of a design project. It is a constantly evolving model, continuously being enriched and refined as the project is developed in increasing levels of detail. Its makeup and organization closely reflect the project’s design logic, while its attribute data is particularly useful during query phases such as estimation and bidding. The Model further permits the accurate tracking of project data and volumetric information, allowing Project Managers to maintain a constant overview of the physical status of the project and its cost.

The Master Model – Overview
The Master Model concept sits at the heart of Digital Project, not just within AEC but (in slightly different flavors) in all industries that use the Digital Project. It can interchangeably be referred to as a Digital Mock-Up (DMU), Digital Model, 3D Model Database, etc. The Master Model as presented here is an evolving result. It is understood as an integrated 3D Database which contains not only all major project geometries but also added-value information that describes and complements the geometrical information in the model. This information is by-object attribute information that describes each and every component in the model, including how it is made, of what material it is constructed, the exact sequence of the construction process of which it is a part, and so on. This sophisticated set of information is extremely powerful during all phases of a design project. It is a constantly evolving model, continuously being enriched and refined as the project is developed in increasing levels of detail. Its makeup and organization closely reflect the project’s design logic, while its attribute data is particularly useful during query phases such as estimation and bidding. The Model further permits the accurate tracking of project data and volumetric information, allowing Project Managers to maintain a constant overview of the physical status of the project and its cost.

Master Files vs. Work Files
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Interacting As a starting point, it is very important to differentiate between Master Files, i.e. those that contain the officially-released, current state of the project Model, and Work Files, i.e. any files that are either work-in-progress or individual model files which are not currently associated with the project. In general, Master Files are administrated by the project’s Manager, while Work Files are controlled by the individual user or users responsible for their elaboration. The Manager determines the following, in accordance with the Firm’s established practices and guidelines: • Master File and Work File naming conventions; • Master Model file structuring • Work File submission to the Master Model (“Ready-for-Master”) • Archiving and Model Maintenance
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Basic Tasks
Using the Mouse
The use of the mouse differs according to the type of action you need to perform. You will need a three-button mouse to take advantage of all the features, otherwise you will not be able to move or drag objects using the mouse. Use this Whenever you read... mouse button... Left • • • • • • • • Select (menus, commands, geometry in graphics area, ...) Click (icons, dialog box buttons, tabs, selection of a location in the document window, ...) Double-click Shift-click Ctrl-click Check (check boxes) Drag Drag and drop (icons onto objects, objects onto objects)

Center Right

• • •

Drag Move To select a contextual menu, right-click

Viewing
Examining
Navigating in Examine Mode
Navigating in Examine Mode is the default mode. You can examine your document as you would from the outside by moving around the document's perimeter, or as you would from within, turning your head to view or moving closer (zoom in, zoom out) to different objects. For more information, see Activating Viewing Tools Using the Mouse. You can also access the Examine mode via the Examine icon toolbar, available when using the beginners walk and fly modes. in the View

Panning
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This task explains how to move the current document contents by panning the camera viewpoint. 1. Select the View->Pan command, or click the Pan icon.

2. Drag the left mouse button to a new location, then release the mouse button.

Before

After

Zooming In
This task explains how to zoom in by predetermined increments. 1. Select the View->Modify->Zoom In command, or click the Zoom In icon. You zoom in by one increment each time you click on the icon. To zoom up close (as illustrated), click on the icon several times in succession.

Before

After

You can also use the View->Zoom In Out command and drag (left mouse button) to zoom in progressively, not by increments.

Zooming Out

14

Basic Tasks

This task explains how to zoom out by predetermined increments. 1. Select the View->Modify->Zoom Out command,or click the Zoom Out icon. You zoom out by one increment each time you click on the icon. To zoom out (as illustrated), click on the icon several times in succession.

Before

After

You can also use the View->Zoom In Out command and drag (left mouse button) to zoom out progressively, not by increments.

Zooming In On An Area

This task explains how to zoom in on an area. 1. Select the View->Zoom Area command. 2. Drag (left mouse button) to draw the bounding outline containing the area on which you want to zoom in. The area now viewed is the area you captured inside the bounding outline.

Rotating
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This task explains how to rotate an object. 1. Select the View->Rotate command, or click the Rotate icon.

2. Press and hold down the left (or right) and middle mouse buttons to see the rotation sphere symbol appear around the object. 3. Still holding the buttons down, drag to rotate. Note that do not have to use the viewing tool commands or icons to rotate an object. For quick access, you can also use just the mouse: press and hold down the middle mouse button, then the left (or right) mouse button, and drag (still holding both buttons down).

4. Click to stop rotation.

Before

After

Magnifying
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Basic Tasks

This tasks explains how to obtain a magnified view of your document in a separate window. 1. Select the View->Magnifier... command. The Magnifier window opens containing a magnified section of your document:

The section magnified is defined by the magnifier viewport which appears over the object in your document:

Note that the magnifier viewport has handles:

• the "+" symbol lets you move the viewport
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Interacting • the handles in the corners let you resize the viewport. 2. Point to the + symbol and drag it to move the viewport and magnify another area of the document:

3. Point to one of the handles and drag it to size the magnified area up and down.

While you drag, the

symbol appears.
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All the viewing and manipulations performed in the document window are also reflected in the Magnifier window. For example, rotate the object to see how the object is also rotated in the Magnifier window:

Viewing Along a Normal to a Plane
This task explains how to view an object along a perpendicular to a selected plane 1. Select the View->Modify->Normal View command or click the Normal View icon.

2. Select a plane. The object is projected onto the selected plane so you can now view along a normal to the plane.
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Before

After

Note: if you select an element other than a plane, the object will be projected onto an imaginary plane tangent to the selected element. This plane will be created at the point where you clicked and will be set parallel to the screen.

Displaying Perspective and Parallel Views
This tasks explains how to display objects in perspective or parallel views. 1. Select the Render Style->Perspective command, or the Render Style->Parallel command.
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Perspective view

Parallel View

Perspective is related to the size of the object being viewed, and the distance of the object from the observer. Note that, before using the Walk and Fly navigation modes, you must be in a perspective view.

Fitting All Geometry in the Geometry Area
This task explains how to fit the current document contents into the geometry area. 1. Select the View->Fit All In command, or click the Fit All In icon.

Fit All In zooms the current view out so that all the document contents fit into the space available in the geometry area.
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Interacting Before After

Viewing Objects against the Ground
Ground lets you visually insert a plane at the ground level of your document, thus enabling you to recognize when your document is viewed the right way up. When you first access a document, the plane parallel or tangent to the bottom point of your document is considered to be the ground. This task shows you how to show and hide the ground. Open the document Platform.model. You need a V4 Integration license to open this document. 1. Select View->Ground. The ground plane is displayed in the geometry area. To hide the ground, simply repeat the same step. 2. Drag (left mouse button) the ground up or down to a new location, then release the mouse button. The ground is repositioned as defined.

Activating Viewing Tools
22

Basic Tasks You do not have to use the viewing tool commands or icons to perform all viewing operations. For quick access, you can also use just the mouse, the keyboard or the pen to activate a certain number of viewing tools, as indicated in the table below:

Mouse
To use the mouse Do this... to... Center the display at Click the middle mouse button. a specific location Pan Rotate Zoom Drag using the middle mouse button. Press and hold down the middle mouse button, then the left (or right) mouse button, and drag (still holding both buttons down). Press and hold down the middle mouse button, then click the left (or right) mouse button and drag (still holding the middle mouse button down).

The following example shows how to transform this element

in three steps:
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Interacting Clicking the corresponding icon runs the corresponding command once only. Using the View->Modify command or pressing and holding down the middle mouse button activates a permanent viewing mode for each command, until you click to exit. Note: See Hiding and Showing Objects for information about showing and hiding, and Using Rendering Styles for hidden line rendering. The 3-button mouse is recommended for usability reasons. On Windows computers: • • the IntelliMouse (two buttons plus a wheel) is an alternative to the 3-button mouse: pressing and hold down the wheel the same way as the middle mouse button (but rolling the wheel is not supported) a 2-button mouse may alternatively be used (the third button is emulated using a key combination).

This key combination ... and this key using a 2-button mouse combination on a 3... button mouse... Press ALT and right Press and hold down button, then drag. middle button, then drag.

Do this...

Pan

With ALT and right button Press and hold down the held down, press and hold middle mouse button, then down CTRL or left button, the left (or right) mouse Rotate then drag. button, then drag. (3D/zoom/2D) Then: Release the CTRL or left button. Press and hold down the Zoom middle mouse button, then click the left mouse button, then drag (still holding the middle mouse button down).

Press and hold down CTRL, ALT and the right button, then drag.

Press and hold down CTRL Zoom and the middle mouse button, then drag.

SpacePilot
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Basic Tasks The SpacePilot can be used, in addition to the mouse, to perform graphic viewing manipulations (zoom, pan, rotate, etc.). To download the latest 3DConnexion software, browse the following Internet site: http://www.3DConnexion.com SpacePilot is supported on Windows 2000 and Windows XP. It requires a 3DConnexion driver 3DxWare 5.0.7 (minimum level). To install the appropriate driver, access the 3DConnexion Internet site, click the Download tab then indicate the device you are using and the operating system you are running. This new device developed by 3DConnexion is an advanced SpaceMouse equipped with an LCD panel which labels the functions of the device buttons. You can thus keep track more easily of the current function set just by looking at the information displayed on the LCD panel. It also enables you to control the manipulation calibration from Version 5, whatever the 3DxWare driver configuration on your computer. There is no need anymore to analyze both Version 5 and 3DxWare configurations to figure out the current calibration. Below is a graphic sketch of the new device:

The buttons you can map to a Version 5 command or a 3DxWare function are: buttons 1 to 6, Esc, Shift, Ctrl, Alt, T, L, R, F and Fit buttons. Note that only the functions of buttons 1 to 6 are displayed on the LCD panel. The other buttons cannot be customized:
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Interacting • • • • • the Panel button toggles on/off the 3DxWare device driver panel or the Version 5 Button Customize panel the Config button cycles through the defined button configuration the - and + buttons tune the device sensitivity the DOM button toggles on/off the dominant mode the 3D button toggles on/off the device rotation.

Device buttons are mapped using the dedicated Button Customize dialog box. Whenever you change a button function in the 3DxWare driver, this change appears on the LCD panel and in the Button Customize dialog box. Inversely, whenever a change is made in the Button Customize dialog box, the new button function is displayed on the LCD panel and in the 3DxWare driver. For detailed information on the Button Customize dialog box, refer to Customizing Buttons.

Keyboard
You can use these shortcuts in Examine mode only. This keyboard ... and this keyboard Do this... shortcut shortcut for 3D objects... for 2D objects ... Press CTRL and Press CTRL and arrows Pan arrows : With Shift and left or right Rotate around the arrow vertical axis with respect to the monitor screen (3D only) With Shift and up or down Rotate around the X arrow axis (3D only) Rotate around the Y With CTRL and Shift and axis (3D only) left or right arrow (Auto-repeat when pressing and holding down the keys)

Press CTRL and Page Up Press CTRL and Page Down

Press CTRL and Page Up

Zoom In

Press CTRL and Page Down Zoom Out
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Basic Tasks Then: Press the left arrow Press the right arrow Press the up arrow Press the down arrow Move to the up view (2D only) Move to the down view (2D only) Move to the left view (2D only) Move to the right view (2D only)

Tablet Pen (for Tablet PCs)
When working with a Tablet PC, you can perform viewing operations without the mouse or the keyboard using a Tablet Pen. From now on, you do not need to first activate the corresponding viewing tool command anymore, you can perform actions directly in the geometry area using a specific pad dedicated to Tablet Pens. Prior to using the pad, you have to define some settings in the Tablet Support tab. Drag the pen over... To... Rotate Pan (from left to right) (from right to left) Zoom out Zoom in

Note that the viewing operation performed when double-clicking depends on the option you selected in the "Action on double-click" pulldown list available in the Tablet Support tab.
About text annotations

You can write annotations directly on the 3D viewer using your Tablet PC by icon from the DMU 2D Marker toolbar. clicking the Add Annotation Text From now on, you do not need to activate the text recognition pad anymore, you only need to click OK or Apply. Furthermore, once the automatic recognition starts, the handwritten text is automatically replaced by the recognized text which is placed at the same location:
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Optionally, you can then drag the annotation to another location if needed. For detailed information on how to write annotations, refer to the "Annotating" section in the Version 5 - DMU Navigator User's Guide.

Using Document Windows
This task explains how to use document windows. 1. Select the Window ->New Window command. A new window is opened containing the document you are editing. The remaining commands on the Window menu let you organize your windows horizontally or vertically with respect to each other, so that they do not overlap, (Window->Tile Horizontally and Window->Tile Vertically) or in a cascading arrangement in which they overlap each other (Window->Cascade). Note that you can switch from one document window to another by selecting the window name at the bottom of the Window menu. On the Sun Solaris platform, we recommend that you set the following desktop resource to always keep your Version 5 window on top: Allow primary always on top

Hiding/showing objects
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Hiding Objects
This task explains how to hide objects by transferring them to the No Show space (they are no longer displayed). 1. Select an object. In our example, select the line.

2. Click the Hide/Show icon, or select the View->Hide/Show>Hide/Show command. The object is no longer displayed: it has been transferred into the No Show space. In our example, the line is no longer displayed. Note also that if you have several document windows open containing the same objects, the object is transferred to the No Show space in each document window.
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Note: In case you select multiple elements, only the space of the first selected element will be taken into account by the Hide/Show command. For instance, if the first element of the multi-selection is in the No Show space, the Hide/Show command will transfer all the selected elements to the Show space, whatever their original space. 3. Click the Hide/Show space. icon again to display the object in the Show

After selecting an object, you can also use select the Edit->Properties command, click the Graphic tab, and set the Shown option to achieve the same effect. A component placed in no show in the product structure will appear in low highlighting in the tree.

Displaying Hidden Objects

This task explains how to display objects transferred to the No Show area. 1. Display the same geometry as in the preceding example, In our example, a line which was originally displayed is now in the No Show area.

2. Click the Swap visible space Show area.

icon to display the contents of the No

In our example, you now see only the line. The geometry area changes color to indicate you are now viewing the No Show space.
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Note: In case you select multiple elements, only the space of the first selected element will be taken into account by the Hide/Show command. For instance, if the first element of the multi-selection is in the No Show space, the Hide/Show command will transfer all the selected elements to the Show space, whatever their original space. 3. Click the Swap visible space space. icon again to return to the Show

You can continue working on objects in the No Show space. You can also select objects and transfer them back to the Show space using the Hide/Show icon.

Displaying and Editing Graphic Properties

This task shows you how to display and edit the graphic properties of a selected object using the Properties dialog box. Before you start, note the following general information:
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Inheritance for Assembly objects
The following properties can be inherited: color, transparency, line type and line weight. This inheritance can be deactivated by doing one of the actions below depending on the property you do want to inherit: • • • • select No Color in the Color combo box select No Linetype in the Line Type combo box select No Width in the Thickness combo box uncheck the option next to the Transparency slider.

For detailed information on graphic properties applied to products, refer to "Managing Graphic Properties in Products" in the Version 5 - Product Structure User's Guide.

Inheritance for Mechanical Modeler objects
• When a mechanical object (a pad, for instance) has been assigned a color, this color will used to display the object. Otherwise, the object will be displayed using the color of its father element (i.e. the Part Body). To reset the inheritance from the father to the children, select the Reset properties command from the Edit menu or from the pad contextual menu. Bear in mind that this command cancels any local modification applied to the graphic properties of the pad (including color and transparency) The following properties are set at the Part Body level and cannot be inherited: point symbol, line thickness and line type.

•

Materials
When a material has been applied onto a part with the "Material" option checked in View->Render Style->Customize View (or the Shading with Material icon selected in the View toolbar), the graphic properties defined in the Properties dialog box have no impact on the part display anymore. As a consequence, should you need to modify the transparency, for instance, this should be made in the material properties. For detailed information on modifying material properties and on materials in general, refer to the Version 5 - Real Time Rendering User's Guide. 1. Select the object. The object to be selected when using the Part Design application is the PartBody item in the specification tree.
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2. Select the Edit->Properties command (or the ALT+Enter keyboard shortcut) or select the Properties command on the contextual menu. A Properties dialog box similar to the one below is displayed:

3. Click the Graphic tab to display the graphic properties of the current object:
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In the above dialog box, the graphic properties available for editing are: • • • • • • • Fill Color (colors the current object) and transparency Edge Color, Linetype and Weight Line and Curve Color, Linetype and Weight Point Color and Symbol Show and Pick attributes LowInt Layers.

However, do not forget that the look of the Properties dialog box will vary according to the type of the selected object. When displaying the graphic properties of an Assembly object, the dialog box will look the following way:

4. To set object colors, click the Color combo box for Fill. A list appears containing: • a blank color field (No Name) • a list of sixteen default colors from the color palette, ready for use • the More Colors... option • the No Color option (for Assembly objects only).
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The No Color option lets deactivate the color inheritance for Assembly objects. You can then apply a color onto a face without having to modify the product color. To do so: 1. 2. 3. 4. 5. 6. select the product access the Properties dialog box choose "No Color" in the Color combo box select the face onto which the color should be applied access the face's graphic properties select the desired color from the Color combo box.

5. Select the desired color. The selected color is now displayed in the field in the combo box. Pointing the cursor over the combo box displays the name of the selected color.

Color on Assembly objects
When applying a color onto an Assembly object, any other element located at a lower level in the specification tree inherits this color and the combo box displays the color of the Assembly object. However, the color modification impacts only the display at rendering level and not the graphic properties. This may be useful, for instance, to highlight an object among others without altering its graphic properties. If you want to deactivate the inheritance mechanism, just click the color combo box: all the elements located at a lower level will have their own color back and "No Color" will be displayed in the combo box.
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When working in "Edges and points" + "Shading" mode, the color applied to the product is also applied to the mesh but not to lineic elements (edges, sketches, etc.) which turn black. In this case, it not possible to modify the color of these lineic elements. However, when working in "Edges and points" mode, the color applied to the product is also applied to lineic elements.

Color on surfaces
You can apply a color on surfaces' sub-elements. Let's suppose the following model:

If you select the the sub-element "EdgeFillet.1" then access its graphic properties, you will see that the Fill Color combo box is available:

You can then select the desired color from the combo box and click Apply or OK to confirm. 36

Basic Tasks The color will be applied to the selected face only:

Note: • if you modify the geometry, the sub-element will keep its color when the geometry is updated • if you create a new feature using the sub-element's surface, the color of the sub-element will not be propagated to the new feature.

6. To access more colors, or to create your own colors, click the More Colors... option at the bottom of the list to access the color palette:
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In the Basic Colors area, the first sixteen colors (in the top two rows) are the same as those in the previous list. The remaining four rows contain extra colors. The Custom Colors area contains sixteen free boxes in which you can place your custom colors. 7. Click the Define Custom Colors >> button to display the full color palette and color customization tools:

The colored area with the cross represents a color spectrum. Drag the cross inside the spectrum to instantaneously change the color in the small box below the spectrum. The HSL (Hue, Saturation and Luminance) and RGB (Red, Green and Blue) values vary according to where the cross is located. You can also enter HSL and RGB values in the fields provided to suit your exact color specifications. Move the arrow up or down to vary the brightness of the custom color.
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8. Once you are happy with the color, click one of the free boxes in the Custom Colors area, then Click the Add to Custom Colors button to add the custom color.

9. Click on the custom color, then OK. The color is now displayed in the Color fill field of the Graphic properties tab.
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10. Click Apply in the Properties dialog box. The color of the selected object is changed. 11. To make the part more or less transparent, drag the Transparency slider to set the appropriate value (between 0 and 255). Note that you can set either of two transparency modes: • Screen Door • Alpha Blending with the Performance tab using the Tools->Options command. For more information, refer to Customizing Performance Settings. As far as .asm documents are concerned, you can check or uncheck the Transparency option to apply or not a transparency inheritance independently from the color of the selected object. 12. To set color edges on parts, click the Color combo box for Edges and proceed the same way. 13. To set edge line type and weight, use the appropriate combo boxes. 14. If you have selected a line or a curve, you can set the line and curve color, the linetype and weight the same way as for parts. 15. If you have selected a point, you can set the point color in the same way as for parts. To select the symbol used to represent the point, select the symbol from the Symbol combo box. 16. In the Show, Pick and Layers area, the Shown check box indicates if the object is always visible (i.e. in Show mode) or always hidden (i.e. in No Show mode). This check box is displayed for information only and cannot be modified. For more information about the show and no show modes, refer to Hiding and Showing Objects. 17. Still in the Show, Pick and Layers area, check the Pickable check box if you want the object to always be selectable. 18. The Layer box indicates the number of layers the selected objects are assigned to. Otherwise (when nothing is selected) it indicates the current layer. When pointing to the Layer box, a tootip indicates whether the layer definition location is stored in the document or in the user settings (i.e. the CATSettings directory). However, bear in mind that this tooltip is displayed for information
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Basic Tasks only, you cannot modify the storage location which has been set as explained below: • for CATProduct documents, the definition is stored in the user settings • for CATPart documents, the definition (if there is one) is stored in the document. If no definition is stored in the document, the CATPart documents use the definition stored in the user settings • for CATDrawing documents, the definition is stored in the document. Use the pulldown list to choose among the list of named layers and assign the chosen layer to the selected objects: None, 0 General, 1999 (according to the number of layers in the Layer list). For more information, refer to Assigning Objects to Layers. The Layer box also contains the Other Layers... command which lets you create your own named layers. Refer to Creating New Layers for more details. 19. You can check the Low Intensity option to apply the low-intensity color to the selected object. The color to be applied to low-intensity elements can be modified defined in the Tools->Options->General->Display>Visualization tab. 20. The Rendering Style combo box lets you select the rendering style you want to apply to the selected element, provided that this element supports rendering styles. This rendering style will then be used to visualize the object independently from the rendering style applied to the 3D window when using the Enable object view mode visualization mode. Note that this option is identical to the one provided in the Graphic Properties toolbar. Rendering styles can be applied only on .CATPart documents or on .CATPart documents embedded in .CATProduct documents: • Part Body You can apply a rendering style to each body composing the part body and this, even if a body is embedded into another one. All the elements gathered in the part body or in the body inherit the rendering style of their parent. As a consequence, you cannot apply a rendering style to the child solid features (such as a pad or a fillet) • Geometrical Set You can apply a rendering style to the Geometrical Set as a whole and to each child feature in the graph ; each feature may be applied a different rendering style. If no rendering style has been applied to a feature, this feature will be displayed with the rendering style applied to the father element or, if no father
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Interacting exists, with the rendering style of the viewer used to display the feature • Shape Body The behavior is identical to the one of the Geometrical Set except that different child features may share the same visual representation and therefore, the same rendering style. By default, no rendering style is applied but you can choose among the following styles: • No Specific Rendering This is the default mode. You can use it to remove a rendering style that has been previously applied • Transparent Displays the selected element in transparent mode:

• Wireframe Displays the selected element in wireframe mode:

• Shading Displays the selected element in shading mode:

42

Basic Tasks

• Shading with Edges Displays the selected element in shading with edges mode:

20. Click Apply or OK to confirm.

About Automation
Macros are provided to retrieve and change the following graphic properties: • • • • • • • • color opacity line type line thickness symbol show pick layers.

Refer to "Infrastructure Automation Objects" in the Enterprise Architecture Automation - 3D Visualization documentation for detailed information.

The specification tree and geometry area
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Product Structure Symbols
Product Structure

Product1

A product. For more information, refer to Insert a N Structure User's Guide.

Product2

A component or sub-product. For more information, Component in Product Structure User's Guide.

The purple little wheel to the left corner of the CATP Flexible_product

bar identify a flexible sub-assembly. For more in Sub-Assemblies in Product Structure User's Guide.

Part.1

Instance of a part. This symbol means that ther representation of the part and that it is activated.

Part_with_DeactivatedRepresentation

The representation of this part is deactivated. This s geometric representation is deactivated. Before ope choose the activate or deactivate Shape representat >Infrastructure, select the Product Structure tab an Do not activate default shapes on open. For a particular instance in the document, you can d selecting the Representations -> Deactivate Node / commands.

Component_with_DeactivatedRepresentation

The representation of this component is deactivated
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For contextual parts, the reference keeps a link with the Original or Definition Instance (or Original Part

For each parts, every instance keeps a link with its reference. But the Contextual Reference (or Context link, with a single instance which is contextual. This unique link allows you to know the name of the doc which the part 's external geometry rests.

There is a distinction between the Original Instance and the subsequent Contextual References because of contextual Parts depends on neighboring components (support) in the Assembly. The Geometry of th on another instance in the same Assembly (second link). Three Instances of Contextual Part exist:

_

Definition Instance

This icon shows that the Part Reference is contextua Definition Instance. The green gear and the blue cha instance of a part that is contextual (driven by anot another part's data) in a CATProduct.

_

Instance of the Definition Instance

This contextual part, represented by the white gear an Instance of the Definition Instance, coming from geometry of this instance is connected with the Defi (contextual link). Note that you can edit this contex

_

Other Instance of the Contextual Part

The brown gear and the red flash signify that the Pa and that this instance is not used in the Part Definit this Contextual Part. This symbol can appear when y a Contextual Part into another CATProduct without t contextual links.

In this case the user needs to resort to the "Define "Isolate Part" commands in order to redefine the co red flash will be turned into a blue chain or green ar For more information, please read the following Contextual Links: Editing and Replacing Comma in Product Structure User' Guide.

Part1

Reference of a part. For more information, refer to I Product Structure User's Guide.

Deactivated_Component

A deactivated component. The shape representation geometry is not visible. This functionality can occur documents containing this component, especially wh instance of a reference. This operation is equivalent because the reference of the component no longer e Material.
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Deactivated_Product

A deactivated product.

Unloaded_Product

The geometry of the component disappears. The pr references are missing but the user is able to find th

Opening Sub-Trees
This task explains how to open the sub-tree of the selected item in a specific window. This functionality is not available for all workbenches. For instance, you cannot use it when working with Drafting, V4 Integration, Material Library or Catalog Editor. Open the Seat.CATProduct document. 1. With the specification tree visible, select the part instance named "seat" then rightclick and choose the Open Sub-Tree contextual command. A new window containing the sub-tree of "seat" is displayed:

The window that opens is named after the top-level element contained in the window from which the command has been run. In our example, the top-level element is
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Basic Tasks "Product1". The sub-tree window is just a pop-up window: it is used for visualizing sub-trees during the session but it is not kept from one session to another. You cannot open the same sub-tree several times. If you try to do so, the window of the sub-tree you are trying to re-open will be displayed in foreground. 2. Press the F3 key to hide the specification tree. You notice that the sub-tree window is still visible. 3. Press the F3 key again to show the specification tree again. 4. In "Product1" window, click the + sign next to "Geometrical Set.1" then select "Surface.3": the selected element is highlighted in both the sub-tree window and the specification tree but also in the geometry area.

You can also right-click an element from the sub-tree window then use the contextual commands. The commands available from the contextual menu are identical to those displayed when right-clicking the element directly from the specification tree. 5. In the specification tree, select "PartBody" then right-click and choose Open Sub-Tree: the new window is superposed onto the window you opened previously and appears in foreground. 6. When several sub-trees are open, they are superposed onto one another. To display the desired sub-tree window in foreground, double-click the corresponding element in the specification tree.
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7. To close a sub-tree, click the cross in the top-right corner of the window.

More about the Open Sub-Tree Command
• • • • multi-selection is not supported the standard size of the window is 250x400 pixels but you can resize it if needed. However, this customized size only applies to the current window, each new window you may open afterwards will have the standard size the Window->Tile Horizontally/Vertically and Window->Cascade commands have no effect on the windows displaying the sub-trees when working with several document windows, you need to activate a window to show all the sub-trees that have been opened for this window, the last activated sub-tree being displayed in foreground. Inversely, when a window is not active anymore, all the sub-trees linked to this window are hidden. In the example below, the window named "Seat.CATProduct" is active and so, the subtrees linked to this window are displayed whereas those of the "Seat.CATPart" window are not visible:

Viewing Sub-Trees
This task explains how to hide or show all the sub-trees that have been opened using the Open Sub-Tree contextual command. This command is not available when working with the Drafting or V4 Integration workbench.
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Single window
1. Activate the Select.CATProduct window. 2. With the specification tree visible, select the part instance named "Part1" then rightclick and choose the Open Sub-Tree contextual command. 3. Select the part instance named "Part1.1" then right-click and choose the Open SubTree contextual command. The result should look something like this:

4. Click the View menu. You can see that a check mark is displayed next to the SubTrees command as shown below:
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When the Sub-Trees command is checked, all the sub-trees opened for the current window are displayed. 5. Uncheck the command to hide the sub-trees:

If you select the View menu again, you see that no check mark is displayed anymore which means that all the sub-trees linked to the current window are hidden:

6. Check the Sub-Trees command: the two sub-trees you opened previously are now shown.

Multi-window
7. Activate the Seat.CATProduct window. 8. Select the Window->Tile Vertically command. 9. Activate the Seat.CATProduct window. You notice that the two sub-trees opened for the Select.CATProduct window are not displayed since sub-trees are visible only for the current window, i.e. Seat.CATProduct right now:
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You can also see that when you select the View menu, the Sub-Trees command is grayed out because no sub-tree has been opened yet for this window. 10. With the specification tree visible, select the part instance named "seat" then rightclick and choose the Open Sub-Tree contextual command. A new window containing the sub-tree of "seat" is displayed and the Sub-Trees command is now activated in the View menu:
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11. Activate the Select.CATProduct window. The two sub-trees opened for this window are now displayed:
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12. Still with the Select.CATProduct window active, click the View menu then uncheck the Sub-Trees command to hide the sub-trees in the current window:

13. Now if you activate the Seat.CATProduct window again, you can see that the sub-tree opened for this window is displayed:
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The reason is that the View->Sub-Trees command only affects the current window. Therefore, you can work simultaneously with a window in which sub-trees are shown and with a window in which sub-trees are hidden.

More about the Sub-Trees command
• Running the Open Sub-Tree contextual command for the first time automatically checks the Sub-Trees command and displays a sub-tree window. However, when sub-trees are already hidden, the Sub-Trees command remains unchecked when you run the Open Sub-Tree contextual command and only the last opened sub-tree is visible. The reason is that the Sub-Trees command impacts only sub-trees created at the time the command is run. The View->Specifications command has no effect on sub-trees because this command hides/shows only the specification tree of the current window.

•

Setting Document Window Layout Preferences
This task explains how to set document window layout preferences. 1. Select the View->Specifications command (or the SHIFT+F2 keyboard shortcut). This is the default layout option. It displays both the specification tree and the geometry together:

54

Basic Tasks

2. Select the View->Specifications command again. This removes the specification tree:

You can also use the F3 key to toggle more quickly.
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3. Toggle the View->Geometry command on and off to display and hide 2D and 3D representations of the geometry. When the View->Geometry command is off, the whole geometry is hidden (whether it is in the Show/No Show space) and only the specification tree is displayed. Be careful not to confuse the View->Geometry command with the Swap visible space command which lets you display objects transferred to the No Show area. For detailed information, refer to Displaying Hidden Objects. 4. If you want to swap the focus between the tree and the geometry, select the View->Commands List...->Swap view/tree command or enter c:swap view/tree in the power input field:

This enables you, for instance, to resize the specification tree as desired. To deactivate the command, simply re-select the View->Commands List...>Swap view/tree command or re-enter c:swap view/tree in the power input field. Using this command is equivalent to clicking the axis system displayed in the bottom right corner which is another method to swap the focus between the specification tree and the geometry.

About the font size
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You can also customize the default font size of the tree by exporting the following variable which lets you set the size by yourself: export CATGraphSize=font_size (on UNIX) or set CATGraphSize=font_size (on Windows) where "font_size" is the new default font size in millimeters. For instance, "export CATGraphSize=5". Let's have a look at the two examples below: Example 1 Default font size without exporting the CATGraphSize variable:

Example 2 New default font size after exporting the variable with a size set to "5":
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Using the Overview on the Specification Tree
This task explains how to use the overview to zoom in or out on the specification tree. 1. With the specification tree visible, select the View->Specifications Overview command (or press the Shift and F2 keys) to display the Overview on specifications window containing a view of a portion of the specification tree:

58

Basic Tasks

2. Point to the Overview window to display the This drags the overview viewport through which you view part of the specification tree. While dragging, the cursor changes to :

cursor, and drag.

You can zoom the size of the overview viewport by dragging the handles located in the upper-right and lower-left corners of the viewport. Only that part of the tree you see inside the overview viewport will be visible in the document window.
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Using the Full Screen
This task explains how to make the geometry area fill the whole screen. 1. Select the View->Full Screen command. The geometry area fills the whole area of your screen. 2. To restore the document window to its original size, right-click then uncheck the Full Screen option.

Expanding and Collapsing the Specification Tree
This task explains how to expand and collapse the specification tree. 1. Open a any document with geometrical data, for example:
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2. Select the View->Tree Expansion->Expand First Level command to see the first level of the tree:

3. Select the View->Tree Expansion->Expand Second Level command to see the second level of the tree:
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4. Select the View->Tree Expansion->Expand All command to see all the levels of the tree. 5. When an object is selected in the tree, you can use the View->Tree Expansion->Expand Selection command. A dialog box opens and prompts you to indicate the number of levels to expand:

Note that the dialog box keeps the last selection you made. 6. Select the View->Tree Expansion->Collapse All command to collapse the tree.

Using the Geometry Overview
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This task explains how to use the overview to view the geometry. 1. With geometry visible in the geometry area, select the View->Geometry Overview command. The geometry is displayed in the overview window, but not the specification tree:

2. Point to the Overview window to display the

cursor, and drag.

This drags the overview viewport through which you view the geometry. Only that part of the geometry you see inside the overview viewport will be visible in the document window:
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Note that you can resize the overview window itself to see the whole of the viewport. 3. Zoom the size of the overview viewport by dragging the handles located in the upper-right and lower-left corners of the viewport.

. This lets you zoom the While you drag, the cursor changes to: geometry in and out in the document window:
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Managing and Sharing Data: Documents and Drawings
Opening/creating/closing Documents
Opening Existing Documents
This task shows you how to open an existing document when Version 5 is already running. Several methods are available to open an existing document: • • • • • • • File->Open... command Insert->Existing Component... command Start->Documents command on Windows Windows Explorer or My Computer (Windows) or File Manager (UNIX) drag and drop a document icon Open in New Window contextual command Open the Pointed Document contextual command

What you should know before you start

• •

Bear in mind that Dassault Syst mes guarantees upward compatibility for Version 5 data As far as downward compatibility is concerned, Version 5 data can be reused from one service pack to another, provided that they belong to the same release. If the Version 5 data do not belong to the same release, they can still be reused in case of
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Interacting CATPart documents but this implies the use of a specific process detailed in Using the Version 5 Compatibility Batch You will not be allowed to open a document created using Version 5 if its name contains national characters or forbidden special characters. For a reminder, refer to About Filenames When a .CATPart document containing a Sheet Metal Design feature is opened on a configuration level (i.e. P1, P2 or P3) lower than the level on which the feature was created, all the icons of all the workbenches available in your configuration are grayed out. Note that this may also occur when working with Generative Shape Design or Part Design features.

• •

If you wish to access V4 data such as V4 models, PROJECT files and library objects on Windows or UNIX or access CDMA objects on UNIX you can do so provided you purchase the V4 Integration product. V4 models, PROJECT files or library objects residing on UNIX can be accessed from Windows using the http protocol. (Make sure beforehand that an http server has been installed on the computer where the V4 data resides. The address to be specified should look something like this: http://UNIXserver: port/V4datalocation

Using the File ->Open... Command

1. Click the Open icon keyboard shortcut).

or select the File->Open... command (or the CTRL+O

The following dialog box appears:
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Note: depending on the document environments you allowed in the Document settings, an additional window may appear simultaneously to let you access your documents using an alternate method. For detailed information, refer to Opening Existing Documents Using the Browse Window. 2. In the File Selection box, select the file location. 3. Click the Files of type: list.
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Check the "Show Preview" option to display a preview of the selected file (only on Microsoft Windows workstations).
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4. Select the document type. The list of document types you can open depends on the configurations/products installed and for which you have a license. Note: On UNIX workstations, the File Selection dialog box lets you sort your files by date or size. This dialog box also lets you rename or delete the selected file/folder by clicking the Rename or Delete contextual command. After clicking Delete, a confirmation dialog box appears: just click OK to delete the selected item. When renaming a file or folder, if the new name you entered is already used, the item is not renamed and a warning message is displayed. The following list contains all possible document types (in alphabetical order): • All Bitmap Files Lets you browse raster formats (more than 70 formats are supported) from within a session, without having to use another application • All CATIA V4 Files Lets you open V4 documents such as .model, .session or .library files • All CATIA V5 Files Lets you open V5 documents such as .catalog or .CATAnalysis files, for example • All CATIA CAA Files 69

Interacting Lets you browse CAA files such as .CAABsk or .CAADoc files • All Standard Files Lets you browse files such as .igs, .wrl, .step or .stp files • All Vector Files Lets you browse files such as .cgm, .gl, .gl2 or .hpgl files • 3dmap Lets you browse 3dmap (i.e. spacemap representation) files. Note that you cannot open these files on AIX platforms • act Lets you browse process libraries which contain a number of different classes or types of activities interactively defined by the user. For more information, see "Managing a Process Document with Process Libraries" in the DELMIA - DPM Process Planner User's Guide • asm V4 Assembly Modeling document saved as an Assembly Design document i.e. CATProduct. For more information, see the Version 5 - Assembly Design User's Guide • bdf Allegro specific format. For more information, see the Version 5 - Circuit Board Design User's Guide • brd Mentor Graphics specific format • catalog Catalog documents. For more information, see the Version 5 Component Catalog Editor User's Guide • CATAnalysis Analysis document. For more information, see the Version 5 - Generative Structural Analysis User's Guide • CATDrawing Generative Drafting or Interactive Drafting document. For more information about the Generative Drafting and Interactive Drafting workbenches, see the Version 5 - Generative Drafting User's Guide and Version 5 - Interactive Drafting User's Guide • CATfct Feature Dictionary and Business Knowledge Template files. Refer to Starting the Feature Dictionary Editor and to the Version 5 - Business Process Knowledge Template User's Guide • CATMaterial Material library. For more information, see the Version 5 - Real Time Rendering User's Guide • CATPart Part Design document. For more information about the Part Design workbench, see the Version 5 - Part Design User's Guide • CATProcess Process document. For more information, see the Version 5 - Prismatic Machining User's Guide • CATProduct Assembly Design document. For more information about the Assembly workbench, see the Version 5 - Assembly Design User's Guide • CATShape Physical shape of the part. CATShape files can be exported to STEP or 3D
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Basic Tasks IGES. For more information, refer to "Managing Shapes" in the Version 5 Product Structure User's Guide CATSystem Functional system management file. For more information, refer to the Version 5 - Product Function Definition and Version 5 - Product Function Optimization User's Guides cdd CATIA-CADAM file cgm ANSI/ISO standardized platform-independent format used for the interchange of vector and bitmap data dxf/dwg Autocad DXF and DWG formats. Creates a CATDrawing document. For more information, see "Exporting a CATDrawing into a DXF/DWG File" in the Version 5 - Generative Drafting User's Guide idf Document generated by an IDF application. For more information, see the Version 5 - Circuit Board Design User's Guide ig2 2D IGES file, saved as a CATDrawing document. For more information, see "Importing a 2D IGES File into a CATDrawing" in the Version 5 Data Exchange Interface User's Guide igs IGES file saved as a Part Design document, i.e. a CATPart document. For more information, see the "2D IGES Interface" and the "3D IGES Interface" sections in the Version 5 - Data Exchange Interface User's Guide jpg Lets you browse JPEG files from within a session, without having to use another application library V4 library document storing objects such as details, symbols, NC mill and lathe tools and beam sections. For more information, see the Version 5 - V4 Integration User's Guide model V4 model document. For more information about the V4 Integration workbench, see the Version 5 - V4 Integration User's Guide pdb PDB files picture Lets you browse CATIA Version 4 picture files from within a Version 5 session ps Lets you browse PS (PostScript) and EPS (Encapsulated PostScript) documents. Before opening a .eps document, you need to rename it with the extension ".ps". Note that to be able to modify a .ps document, you need to import it in the Drafting workbench using the Tools->Import External Format... command: this converts the document to a Drafting object which can then be edited and saved as a .CATDrawing document rgb SGI format for pixel images session V4 session document containing several CATIA V4 models converted to a

•

• • •

• •

•

• •

• • • •

• •
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Interacting CATProduct document. For more information about the V4 Integration workbench, see the Version 5 - V4 Integration User's Guide stbom Imports a SmartBOM (Bill Of Material) Briefcase in Version 5. For more information, refer to "Export SmartBOM from Version 5" in the Version 5 Product Structure User's Guide step, STEP, stp and STP Creates a CATProduct document. For more information, see "Importing a STEP AP203 Document" in the Version 5 - Data Exchange Interfaces User's Guide stl Lets you browse stereolithography documents. For more information, see the Version 5 - STL Rapid Prototyping User's Guide and to "Exporting CATPart Data to an STL File" in the Version 5 - Data Exchange Interfaces User's Guide tdg and TDG STRIM/STYLER files tif Lets you browse TIFF files from within a Version 5 session, without having to use another application wrl Lets you browse VRML (Virtual Reality Modeling Language) files. Note that you cannot open these files on AIX platforms.

•

•

•

• • •

5. If you are sure you do not intend to modify the document in any way, you may want to open the document in read-only mode. If so, activate the "Open as read-only" option. The "Open as read-only" option is intended to prevent users from overwriting a document accidentally: when this option is activated for a document, you can read this document in your Version 5 session but you cannot save it unless you change the document path (by selecting another folder or accessing another document environment) or the document name (by entering another name in the File name field). However, keep in mind that this option does not supersede access right management functionalities provided by your operating system. When opening a document pointing to other documents with the "Open as readonly" option activated, the read-only mode only applies to the selected root document. The pointed documents will be loaded in read-write mode and may be loaded independently from the root document. 6. Click Open. In case an error occurs when opening a file (e.g. unknown document name, nonsupported file format, corrupted file, etc.), an Incident Report window opens. It displays the error history and indicates for each error its type, object and description. This history is maintained throughout the whole session, the errors being classified by degree of severity.

Using the Insert ->Existing Component... Command
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Using the Start->Documents Command on Windows

This task shows you how to access an existing document without running a Version 5 session. 1. Before you open a session, click Start and select Documents. 2. Select the document you wish to open. A Version 5 session is opened and your document is displayed.

Using the Windows Explorer or My Computer (on Windows) or the File Manager (UNIX)

This task shows you how to open an existing document via a document icon when no Version 5 session is already running. 1. Before you open a session, click My Computer or run the Windows Explorer and find the location of the document you wish to open. 2. Double-click the document icon. A Version 5 session is opened and your document is displayed. On UNIX, you can use the File Manager.

Dragging and Dropping a Document Icon

This task shows you how to open an existing document via a document icon when a Version 5 session is already running. 1. If a Version 5 session is already open, drag and drop the icon in your Version 5 application window. Your document is opened for editing. Note that this method is not available on IRIX.

Using the Open in New Window Contextual Command

This task shows you how to open an existing document in a new window. 1. If a document is already open in a Version 5 session, select the item you wish to open from the specification tree. 2. Right-click then select the xxx object-> Open in New Window contextual command. The document associated to the selected item is opened in a new window. More about the Open in New Window command
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•

•

In CATIA V5, each window is associated to a document. As far as volatile documents are concerned, they cannot be opened using the Open in New Window command (an error message is issued). For instance, you cannot open in a new CATIA V5 window a Product Root Class created in ENOVIA V5 because a "PRC" is an ENOVIA V5 concept which has no equivalent in CATIA V5 If you modify a document open in a new window then decide not to save the modification when closing the new window, this does not imply that the modification will not appear in the parent window: it only means that the document will not be saved at the end of the session. The reason is that the modification you made has been loaded in memory. Therefore, after closing the new window, the only way to restore the document in the parent window is to use the Undo command.

Using the Open the Pointed Document Contextual Command

This task shows you how to open a pointed document in a new window. 1. If a document is already open in a Version 5 session, select the item pointing to a referenced document from the specification tree. Note: this command is available for geometrical external references and external parameters only. For instance, you will be able to use this command when selecting a geometry pasted "As Result With Link" in a CATPart document different from the one in which it has been copied (the geometry is identified by the following symbol: ). 2. Right-click then select the xxx object-> Open the Pointed Document contextual command. The document pointed to by the selected item is opened in a new window.

Closing Documents
This task shows you how to close a document. 1. Select the File->Close command. 2. If changes have been made since the last save, the Close dialog box appears. Specify whether the file is to be saved or not.
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Closing a document does not always unload its associated documents (whether they are modified or not). In fact, if some documents are pointed to by documents edited in other windows, they will stay in memory and keep their modified status. In this case, when reopening the closed document, a warning message will be displayed to indicate that the document has already been loaded and modified in the current session and that the already loaded document will be edited.

Opening Most Recently Used Documents

This task shows you how to open a recently used file. 1. Select the File command and click, at the bottom of the menu, the name of the file you wish to open:
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The selected file opens.

Creating New Documents
This task shows you how to create a new document when Version 5 is already running.

Using the File -> New Command

1. Click the New icon or select the File->New... command (or the CTRL+N keyboard shortcut):
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The new document types you can create are listed. The list contains only the document types for the configurations/products you installed and for which you have a license. 2. In the New dialog box, double-click the document type or select it then click OK. Choose the document type from the following: • Part A document like this will appear:

Bear in mind that the geometry you create in Version 5 is contained in a "box" whose dimensions are 2.e+6mm (the coordinates can vary from -1,000,000 mm to +1,000,000 mm). Therefore, creating elements exceeding these dimensions may lead to unpredictable results.
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After selection of the standard to be used, a dialog box like this will appear:

For more information about the Generative Drafting and Interactive Drafting workbenches, see the Version 5 Generative Drafting User's Guide and Interactive Drafting User's Guide. • Product

A document like this will appear:
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For more information about the Assembly workbench, see the Version 5 - Assembly Design User's Guide. • Analysis A document like this will appear:

For more information about the Generative Structural Analysis workbench, see the Version 5 - Generative Structural Analysis User's Guide. • CatalogDocument
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• • •

Process ProcessLibrary ZipMill

For more details about the above three document types, refer to the Version 5 - Prismatic Machining User's Guide and the Version 5 - Surface Machinist User's Guide.

Using the New Contextual Command on the Desktop

This task shows you how to create a new document whether or not Version 5 is already running. 1. Either on the Desktop area of Windows or in the appropriate directory of the Windows Explorer (making sure you do not select any items when doing so), right-click once then select the New command.
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2. Select the document type you wish to open:

An empty icon indicating the document type is created (see Starting a Session Using Document Icons). 3. Click in the name field that appears with the icon just created and replace the default name with a name of your own choosing (for example, replace NewPart.CATPart with MyFile.CATPart). 4. Double-click the icon that is created. The new document is created. If you do not have a session running, a session is opened.

Creating a New Document from an Existing One
This task shows you how to create a new document based on a copy of an existing one. 1. You may want to create a new document whose basic characteristics are the same as an existing document. To do this, close the document you want to copy if not already closed and select the File->New from... command. The File Selection dialog box appears:
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2. Select the existing document from which you want to create a new one then click Open. An exact copy of the existing document is displayed with a default name using the following method: • in mono-document mode, a file named "MyPart.CATPart" is renamed to "MyPart_1.CATPart" • in multi-document mode, files named "MyPart.CATPart", "NewPart.CATPart" and "Test.CATDrawing" are renamed to "MyPart_1.CATPart", "NewPart_1.CATPart" and "Test_1.CATDrawing" respectively. Note that in multi-document mode, the new document will be based on a copy of the multiselection as a whole and not of each document individually. If the document(s) you select point(s) to other documents for which the action can be performed, the New From dialog box is displayed:
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The upper frame of the dialog box displays a list of documents to which at least one of the selected documents points to (directly or not). The name, type and location of the files are indicated as well as the status. These documents will not be taken into account by the New From action, i.e. they will just be loaded in your current session and thus, will not be visualized in the new document window. They will be identified by the icon specification tree . in the

The lower frame of the dialog box displays a list of documents for which the New From action will be performed along with file information (name, type, etc.). 3. Use the buttons to transfer documents from one frame to another: moves the whole list to the lower frame moves the selected file to the lower frame moves the whole list (except the CATProduct document) to the upper frame moves the selected file to the upper frame. When a document is selected in the lower frame, the Rename document button is activated. Clicking this button opens the following dialog box:
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Enter the new name of the selected document then click OK to validate. The new file name will be displayed in the New Name column. 4. Click OK to open the new document. 5. Save the new document giving it a name other than the default. You can give the new document the same name as that of the already existing one if you wish but if you do this you must put the new document in another directory.

Saving Documents
Saving Existing Documents
This task shows you how to save an existing document.

1. Click the Save icon or select the File->Save command (or the CTRL+S keyboard shortcut). A message appears in the status bar to confirm that the document is saved. If the document you are trying to save points to parts, a window will be displayed to warn you that these parts will not be saved unless you use the File->Save All command:

If you are trying to save a document that is currently modified and saved by another user, a message will appear to warn that your modifications will be lost if you proceed.
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When a document is saved, it is stored in the UTF8 Unicode format. This ensures that the data contained in it can be read on both Windows and UNIX whatever the session code page used. You can choose to set an automatic save for your file using the General tab of the Tools->Options... command. For more information, see Customizing General Settings.
More about the Save command

• When saving an existing file in another directory without changing the file name (which means that you have now two files), note that you will only be able to open one of these files at a time. If one of them is already open, you will not be able to open the other. The reason is that both files have the same UUID (Unique Universal IDentifier). To avoid this, each file must have its own UUID. This can be done by means of the File->New from... command. For detailed information, refer to Creating New Documents from Existing Documents • If you open a read-only document, make no changes then try to save it, no pop-up message will be displayed to inform you that the document is read-only. On the contrary, if you modify a read-only document then try to save it, a pop-up message will be displayed to inform you that the document cannot be saved with the same name because it is a read-only document.

Saving All Documents

If symbolic links exist between files, for example if a .CATDrawing document has been created from a Part document, the names of each of these files will also appear and will be saved if the Part document is saved. However, if you want to be able to save all files independently regardless of any existing links between files, check the option Enable independent saves at the bottom of the dialog box. Note: Clicking the Save As... 85

Interacting button is mandatory if you want to save your document under another name.

If you did not make any changes to any of the docume nts you want to save or if these docume nts are readonly files, this dialog box will not appear. 2. Click OK to open the Save All dialog box:
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3. Click the Save As... button to specify a name for each read-only or new document. The number of unsaved files is indicated at the bottom of the dialog box and a preview is displayed on the right. 4. Click OK to confirm. If all the documents modified in the session can be saved without further interaction, a warning window appears to indicate the number of documents to be saved and prompts you to confirm or not the save:

Just click Yes to save automatically all the documents or No to cancel the command. If all the documents cannot be saved, the following dialog box will appear when some of the documents are new or read-only:
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1. Select the File->Save All command. These tasks show you how to save some or all of the documents you opened and how to control their names and locations. In addition to this, the Save All command lets you save very easily all modified or read-only documents.

Saving Documents For the First Time or Under Another Name

This task shows you how to save a docum first time or under another name.

1. Select the File->Save As... comma
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2. In the Save As dialog box, specify of the document to be saved as w name and type.

As far as STL format files are concerned they cannot be saved using the Save A command when working in Wireframe mode. The reason is that STL files are generated from the visualization tessel and tesselation triangles are not available when switch to the Wireframe mode.

The "Save as new document" option let you save an existing document under a name but this new document will be giv new UUID (Unique Universal IDentifier) the document to be saved is a new document, this option is not displayed the Save As dialog box. Moreover, the "Save as new document" option is effective only when the docum is saved in its native format, i.e. when document type (displayed in the "Save type" field) has not been modified.
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3. Click Save.

If the name you give the file already ex the following message appears:

You will not be allowed to use national characters or forbidden special characte the document name. For a reminder, re to About Filenames.

On Windows, documents cannot be sto in a folder for which delete authorizatio not set.

Note that the Save As dialog box lets y rename or delete the selected file/folde clicking the Rename or Delete contextu command. After clicking Delete, a confirmation dia box appears: just click OK to delete the selected item. When renaming a file or folder, if the n name you entered is already used, the is not renamed and a warning message displayed.
More about the Save As mechanism

When you save a file by giving it the na of another existing file, this does not m that the new file is identical to the orig one. As a matter of fact, a file is identif by its name but also by its UUID (Uniqu Universal IDentifier) which differs from file to another (except when a file is a c of another one, for instance). To illustrate this, let's suppose a CAPro containing two CATParts, Part1.CATPar Part2.CATPart:
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1. Product1 and the two parts it po to are saved using the Save As.. command then the Product1 is closed 2. A new part is created using the >New... command 3. The new part is saved as "Part2 the same folder then Part2 is clo 4. When re-opening Product1, you informed that Part2 cannot be fo

The reason is that the new document s as "Part2" has been given a new UUID using the New... command and this new UUID is different from the one assigned the original Part2. Therefore, the link between Product1 and Part2 is conside as broken, even if a Part2.CATPart document do exist, because the origina Part2 does not exist anymore. If you want to reroute the link to the ne Part2.CATPart, you need to use the Edi >Links... command then the Replace button.

Printing a Document Quickly without Customizing Print Settings
This task explains how to print a document quickly to the default printer using default print settings. You can only print a document if a default printer has been set up. On Windows, you print using the default printer (declared by your Windows system administrator). However, on UNIX, you will only be able to print once you have set up a printer, as explained in Setting Up Your Printers on UNIX and Windows. 1. Once your document is open, select the Quick Print icon Standard toolbar. from the

The current document is sent to your default printer using the current print settings.

Keyboard Shortcuts
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Use this keyboard key (or combination)... Escape F1 Shift + F1 Shift + F2 F3 Alt + F8 Shift + F3 Home End Page Up Page Down Ctrl + Page Up Ctrl + Page Down Up arrow Down arrow Left arrow Right arrow Ctrl + Tab

To... Exit the current dialog box (when there is one) Get contextual online help Get help on toolbar icons Toggle the specification tree overview on and off Toggle specification tree display on and off Run macros Activate the graph if the model is active and inversely Display the top of the graph Display the bottom of the graph Relocate the graph one page up Relocate the graph one page down Zoom In the graph Zoom Out the graph Relocate the graph 1/10th (one tenth) of a page to the top Relocate the graph 1/10th (one tenth) of a page to the bottom Relocate the graph 1/10th (one tenth) of a page to the left Relocate the graph 1/10th (one tenth) of a page to the right Swap active document windows

Alt + Enter Ctrl + C Ctrl + F Ctrl + G Ctrl + N Ctrl + O Ctrl + P Ctrl + S Ctrl + V Ctrl + X Ctrl + Y Ctrl + Z

Run the Properties... command Run the Copy command Run the Search... command Run the Selection Sets... command Run the New... command Run the Open... command Run the Print... command Run the Save... command Run the Paste command Run the Cut command Run the Redo command Run the Undo command

Another useful shortcut
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Basic Tasks Clicking an icon lets you run the command associated with that icon only once. However, double-clicking an icon lets you use the associated command as many times as you want without having to click on the icon several times.
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Viewing
Walking and Flying
Navigating in Walk Mode
In Walk mode, you can walk forward and backward (backward in advanced mode only) as well as turn right or left as you walk along the horizontal plane. Two walk modes are available: • • Beginner's mode Advanced mode for experienced users.

Before using the Walk navigation mode, you must be in a perspective view (View->Render Style->Perspective). If you attempt to activate Walk mode, you will be prompted to switch to a perspective view.

Beginners Walk Mode
This task shows you how to navigate in beginner's walk mode. Beginner's walk mode commands are single-action commands. Releasing the mouse button means you exit the command. You can only move forward in beginner's walk mode. Open the document Platform.model.

You need a V4 Integration license to open this document. 1. Select View->Navigation Mode->Walk. The icons used in the beginner's walk mode appear in the View toolbar: These commands are also available via the View->Modify command in the menu bar.
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2. Click the Turn Head icon in the View toolbar then drag (left mouse button) to define your starting position (the direction in which you look at the object). 3. Release at the desired location. 4. Click the Walk walking. icon, then click the left mouse button to begin to

You begin to walk straight forward in the chosen direction. A green arrow appears along with a circular target located at the center of the view. The figure below the arrow specifies the speed at which you are walking: The speed at which you first approach the object depends on the initial distance from the object, and is calculated automatically. The speed is optimized so that you reach the point you target in approximately 10 seconds. 5. Still holding the left button down, drag to the right or left, or up or down, to change direction. You walk in the direction in which you drag. The further you drag away from the center of the view (represented by the circular symbol), the greater the change in direction. Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right produces the same effect in the opposite direction. As you drag, the shape of the arrow changes to reflect the direction in which you
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are walking:

6. Drag the cursor back towards the center of the view to continue walking straight forward in the new direction. 7. To modify your speed, click the Accelerate or Decelerate

icon one or more times, then click the Walk icon again followed by the left mouse button to pursue your walk. 8. To return to the default navigation mode, click the Examine mode icon in the View toolbar You can also set mouse sensitivity and collision detection using the appropriate options in the Visualization tab, accessed via the Tools->Options... command.

Advanced Walk Mode
This task shows you how to navigate through a document in Walk mode. Before using the Walk navigation mode, you must be in a perspective view (View->Render Style->Perspective). It is easier to walk through documents in contexts where you would find a virtual ground, i.e. in buildings, planes or ships for example. Open the document Platform.model. You need a V4 Integration license to open this document. 1. Select View->Navigation Mode->Walk. 2. Press and hold down the middle mouse button to define the horizontal view plane. 3. Still holding the button down, drag to the left or to the right to determine the direction in which you wish to walk.
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In the Walk mode, press and hold down the middle mouse button until you have finished navigating. 4. When in the direction in which you wish to walk, click the left mouse button to begin walking. You begin to walk forward in the chosen direction. A green arrow appears along with a circular target located at the center of the view, like when using the beginner's walk mode:

5. Still holding the middle button down, drag left or right to change direction: Dragging to the left lets you view the object as if you had turned your head to the left; dragging to the right produces the same effect in the opposite direction. 6. Drag the cursor back towards the center of the view to continue your walk straight forward in the new direction.
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Pressing the PageUp and PageDown keys modifies your speed. Speed is indicated in the status bar. 7. Click the left mouse button again to reverse the direction. You begin to walk backward, away from the target. Note: The left and right directions are now defined as if you were walking away from the target with your back towards it. When a collision is detected, the green arrow turns red, whether you navigate in beginner's or advanced Walk mode:
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You can also set mouse sensitivity and collision detection using the appropriate options in the Visualization tab, accessed via the Tools->Options... command.

Navigating in Fly Mode

In Fly mode you can move upward or downward on any horizontal view plane as you move forward or backward (backward in advanced mode only). Two fly modes are available: • • Beginner's mode Advanced mode for experienced users.

Before using the Fly navigation mode, you must be in a perspective view (View->Render Style->Perspective). If you attempt to activate Fly mode, you will be prompted to switch to a perspective view.
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Beginner's Fly Mode
This task shows you how to navigate in beginner's fly mode. Beginner's fly mode commands are single-action commands. Releasing the mouse button means you exit the command. You can only move forward in beginner's fly mode. You need a V4 Integration license to open this document. 1. Click the Fly Mode >Fly. icon in the View toolbar or select View->Navigation Mode-

The icons used in the beginner's fly mode appear in the View toolbar:

These commands are also available via the View->Modify command in the menu bar.

2. Click the Turn Head icon in the View toolbar then drag (left mouse button) to define your starting position (the direction in which you look at the object). 3. Release at the desired location.

4. Click the Fly

icon, then click the left mouse button to begin to flying.

You begin to fly forward in the chosen direction. A green arrow appears along with a circular target located at the center of the view:
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The figure below the arrow specifies the speed at which you are flying:

The speed at which you first approach the object depends on the initial distance from the object, and is calculated automatically. The speed is optimized so that you reach the point you target in approximately 10 seconds. 5. Still holding the left button down, drag to the right or left, or up or down, to change direction. You fly in the direction in which you drag. The further you drag away from the

center of the view (represented by the circular

symbol), the greater the

102

Basic Tasks

change in direction. As you drag, the shape of the arrow changes to reflect the direction in which you are flying:

6. Drag the cursor back towards the center of the view to continue flying straight forward in the new direction. 7. To modify your speed, click the Accelerate or Decelerate icon one or more times, then click the Fly icon again, then drag to pursue your fly. Each click on the icon increases or decreases the speed by approximately 40%. When you collide with a solid object when flying, you will slide along the object's surface, and you will no longer fly through the object, providing a more realistic effect. This feature is also available in Advanced Fly mode. Pressing the Shift key and dragging lets you bank left or right. You can also mouse sensitivity and collision detection using the appropriate options in the same Visualization tab.

8. To return to the default navigation mode, click the Examine mode View toolbar.

icon in the

Advanced Fly Mode
This task shows you how to navigate through a document in Advanced Fly mode. Before using the Fly navigation mode, you must be in a perspective view (View->Render Style ->Perspective). Fly is used in exactly the same way as Walk, the only difference being that in Fly mode you can move upward or downward on any horizontal plane as you move forward or backward. However, note that when using a Space Mouse, you can fly with six different degrees of
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freedom, which means that you can navigate through a document in a direction other than the one in which you are looking at the object. Open the document Platform.model. You need a V4 Integration license to open this document. 1. Click the Fly Mode >Fly. icon in the View toolbar or select View->Navigation Mode-

2. Press and hold down the middle mouse button to define the initial horizontal view plane. 3. Still holding the button down, drag to the left or to the right, or up or down, to determine the direction in which you wish to fly. In the Fly mode, press and hold down the middle mouse button until you've finished navigating. 4. When in the direction in which you wish to fly, click the left mouse button to begin flying. You begin to fly straight forward in the chosen direction. A green arrow appears along with a circular target located at the center of the view, like when using the beginner's fly mode. The speed at which you first approach the object depends on the initial distance from the object, and is calculated automatically. The speed is optimized so that you reach the point you target in approximately 10 seconds.

5. Still holding the middle button down, drag left or right to change direction.
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You fly in the direction in which you drag. The further you drag away from the center of the view, the greater the change in direction. 6. Drag the cursor towards the center of the view to continue flying forward in the new direction:

Pressing the PageUp and PageDown keys modifies your speed. Speed is indicated in the status bar. Each press of the key increases or decreases the speed by approximately 40%. 7. Click the left mouse button again to reverse direction: You begin to fly backwards, away from the target. When flying backwards, the up and down are reversed. Note: You can use the option " when navigating" in the Visualization tab, accessed via the Tools->Options... command, to fix the X, Y or Z axis during navigation. While turning in Fly mode, this creates the impression that the user viewpoint tilts or banks with respect to the fixed axis, as in a real plane. You can also set gravitational effects, mouse sensitivity and collision detection using the appropriate options in the same Visualization tab, like when using the beginner's fly mode.
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Navigating using the 3D compass
About the 3D Compass

You can use a graphic manipulator referred to as the 3D compass to perform a certain number of manipulations on certain objects created and managed by certain applications (for example, Product Structure, Assembly, FreeStyle Shaper, DMU Navigator, etc.). You can also use the compass to manipulate viewpoint representations ("cameras") used to capture viewpoints and materials (in P2 mode using the Real Time Rendering application). The 3D compass is always active. You can show and hide the compass by toggling the View->Compass command. Note that hiding the compass does not deactivate it. The compass is displayed by default in the top right corner of the document. The letters X, Y and Z represent the axes. The Z axis is the default orientation. The point close to the Z axis is the free rotation handle used for freely rotating the compass and the document's objects at the same time. The red square is the compass manipulation handle you use to drag the compass and place on objects to be manipulated. You can also rotate objects around this point. The base of the compass, the XY plane, is the privileged plane. This concept is not useful when simply using the Select command. It is only useful when using application commands that use manipulators which require working planes (for example, when creating planar patches or modifying control points using the FreeStyle Shaper).
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What Can You Do With the 3D Compass?

The 3D compass lets you: • • manipulate viewpoints using the mouse and compass: this is just another way of panning and rotating all objects in the document at the same time move and rotate non-constrained objects using the mouse and compass Moving objects in this context means physically moving them so as to redefine their spatial coordinates with respect to the absolute axis system in a document. Moving should not be confused with panning an object, which simply modifies the viewpoint from which you look at an object: the position of the object in the document remains the same. move and rotate non-constrained objects using the Edit... contextual command lock the compass orientation snap the compass automatically onto a selected object set the plane in which you move objects parallel to the screen switch the privileged plane to the XZ or YZ planes of the compass use the privileged plane as a working plane in applications such as the FreeStyle Shaper application, for example, when manipulating control point manipulators on planar patches and curves.

• • • • • •

If you are also using the Assembly application, which provides a number of advanced positioning tools, consider the 3D compass as a preliminary tool for positioning components in space prior to fine positioning of those components within the assembly. If you are using a space mouse, you can also manipulate the 3D compass when it is in the scene, otherwise the space mouse lets you manipulate the viewpoint.
Which Objects Are We Talking About?

You can use the 3D compass to manipulate non-constrained objects, in other words, objects not linked together by constraints. However, you can manipulate groups of objects in assemblies which are linked to each other by constraints.
About Moving Objects with the Compass

When you create a pad, for example, you create it from a sketch which itself is located in a fixed plane, either a reference plane or a plane you create. When you drag and drop the compass onto the pad (refer to Manipulating Objects Using the Mouse and Compass for more details), a message will inform you that certain elements in the pad are fixed (the plane from which the sketch was created), and therefore you cannot move the pad. If you select the sketch, then select the Parent/Children contextual command, you will see that the parent of the sketch is a fixed plane. You cannot move the pad until you have either isolated the fixed element (using the Isolate contextual command).
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Manipulating Viewpoints Using the Mouse and Compass
This task explains how to manipulating viewpoints by simply dragging certain parts of the compass using the mouse. This is just another way of panning and rotating all objects in the document at the same time. You can: • • • • • pan along the direction of any axis (X, Y or Z) of the compass rotate in a plane pan in a plane rotate freely about a point on the compass view the document perpendicular to any of the axes of the compass.

Open the document Manipulators.CATProduct.

Note: the 3D compass and the absolute axis at the bottom right of the document are aligned identically by default. 1. Rotate to see how the objects, 3D compass and the absolute axis are rotated together.
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2. Point to the compass. . You will also notice that the following The cursor shape changes to: parts of the compass are highlighted as you point to them: • compass axes • arcs on the planes of the compass • and the planes themselves. When you drag any part of the compass, the cursor shape changes to: . If you checked the option "Display manipulation bounding box" in the Navigation tab via the Tools->Options->General->Display command, a box will appear around the selected object if it can be manipulated by the compass:
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The edges of the bounding box around a selected object always remain aligned with the compass axes. Note that the manipulation bounding box differs from the manipulation handle which looks like this:

The display of this manipulation handle is controlled by the Manipulation Handle command available in DELMIA products. For more information, refer to "Using the Manipulation Handle" in the Version 5 - 3D Simulation for Manufacturing User's Guide on the DELMIA Documentation CD-ROM. 3. Drag any axis on the compass. The viewpoint is panned along the direction of the axis. For example, dragging the Z axis upwards pans up along the Z axis like this:
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4. Drag an arc on the compass. For example, dragging the arc YZ to the right rotates the objects in the plane subtended by the arc YZ like this:

Dragging close to the red square rotates the objects quickly; dragging further away from the red square rotates more slowly. The rotation axis used is the same as that used when rotating using the other rotation tools. 5. Drag a plane on the compass. For example, dragging to the right the plane subtended by the arc ZY moves the objects on the same plane like this:
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Select the View->Render Style->Perspective command to perceive the effect more easily. 6. Drag the free rotation handle (the point at the top of the compass) to rotate the objects freely like this:
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7. Point to either X, Y or Z to highlight the letter, then click the letter to make that axis perpendicular to your eye-point. Clicking the same letter reverses the point from which you view the objects. For example, clicking the letter Z lets you view the document along the Z axis like this:

Locking the Current Compass Orientation
This task explains how to lock the current compass orientation. Open the document Manipulators.CATProduct. 1. Point to the compass and right-click to display the contextual menu. 2. Select the Lock Current Orientation command.
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3. Drag the compass.

Note that as you drag the compass over objects, the compass symbol remains oriented the same. For example, if the default orientation was current before dragging, the symbol will remain like this while you drag:

When you drop the compass onto an object, this orientation will be kept. When "Lock current orientation mode" is selected, the compass orientation cannot be changed (either manually or automatically) whatever actions are done with the compass. In particular, the compass orientation will be kept even if the "Use Local Axis System" option is selected. 4. To reorient the compass, select the Lock Current Orientation command again.

Locking the Compass to the Local Axis System
This task explains how to lock the compass to the local axis system. This capability is relevant in any workbench defining local axis systems (such as Part Design, FreeStyle, Generative Shape Design, etc.) You need access to a Version 5 - P2 FreeStyle Shaper configuration to follow this scenario. Open the document Manipulators.CATProduct. 1. Create a new local axis system then set it as current. To learn how to define a new three-axis system locally and how to set is as current, refer to Axis System. The result could look the following way, for instance:
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2. Point to the compass and right-click to display the contextual menu:

3. Select the Use Local Axis System command. The compass is oriented according to the local axis system defined as "current". In our scenario, the current axis system is the one created in step 1:
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If no axis system has been defined by the user, the compass is oriented according to the global axis system displayed in the bottom right corner of the screen.

Managing the Compass
This task shows you how to quickly manage the compass orientation. Create a planar surface. Press F5 or click the Quick Compass Orientation icon The Quick compass orientation toolbar is displayed. Here are summarized the main features of its eight icons: • Click the Flip to UV or XY , Flip to VW or YZ or Flip to WU or XZ .

icon to switch the compass base to the three planes of its trihedron. If the compass is "in" the main axes of the model, the icons indicate X, Y and Z otherwise U, V and W. • Click the Most Seen Plane icon Seen Plane mode. to activate and deactivate the Most
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•

Click the Set Compass Orientation icon or press F6 to orientate the compass by selecting either an existing plane or three points (via the Autodetection command). The point selection is based on Autodetection parameters.

Please refer to the chapter called Editing Curves Using Control Points documentation to orientate the compass using control points. • or press F7 to reset the Click the Reset Compass to XYZ icon compass parallel to the main axes (X, Y and Z) of the model. This option is not active when the compass is already set according to the axes. Click the In Model or on Perch icon to switch the compass from the perch to the model or vice versa. The origin is kept in the model until the toolbar remains open. or press F8 to drop the Click the Create Compass Plane icon compass plane, that is to create a plane corresponding to the compass basis. This icon is activated only when the compass is in the model.

•

•

These four shortcuts (F5, F6, F7 and F8) are effective only when the Quick compass orientation toolbar is displayed. Therefore when you first hit one of the keys, the toolbar is displayed and the shortcuts are effective from then on. The Quick compass orientation toolbar remains active until you close it by clicking the cross in the upper-right corner or, if you have activated it with the icon, by clicking the icon again. By default, elements are created in the current active plane as defined using the Current plane orientation toolbar containing the Flip to UV or XY or YZ or Flip to WU or XZ icons. , Flip to VW

Privileged plane
Locking the Privileged Plane Parallel to the Screen
This task explains how to force the privileged plane to be parallel to the screen plane. Open the document Manipulators.CATProduct.
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1. In our example, drag and drop the compass onto the part like this:

2. Point to the compass and right-click to display the contextual menu. 3. Select the command Lock Privileged Plane Orientation Parallel to Screen. This forces the privileged plane parallel to the screen. This works even if you change viewpoints in the document. The compass is now oriented like this:

4. Manipulate the planar patch as desired. The privileged plane will remain parallel to the screen as you manipulate the object.

Swapping the Privileged Plane
This task explains how to swap to a different privileged plane (XZ or YZ).
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This command is not useful when simply using the Select command. It is only useful when using application commands that use manipulators which require working planes, for example, when creating planar patches or modifying control points using the FreeStyle Shaper. You need access to a Version 5 - P2 FreeStyle Shaper configuration to follow this scenario. Open the document Manipulators2.CATProduct. 1. Activate the FreeStyle Shaper workbench. 2. Select the planar patch. 3. Click the Control Points icon: control points appear on the patch, and the Control Points dialog box appears. 4. Point to a control point on the patch. Manipulators appear:

Note that the manipulators, by default, are oriented in the same plane as the privileged plane of the compass, in the XY plane. 5. Drag the compass onto the patch and align it in the following direction:
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6. Drop the compass onto the patch as follows:

The compass has now detected the orientation of the patch.
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7. Drag the compass away from the patch and drop it into empty space (in other words, not on another object). The compass keeps the same orientation:

8. Point to the compass and right-click to display the contextual menu. 9. Select the command Make YZ the Privileged Plane. This means that you now want to orient the manipulators in the YZ plane of the compass. The manipulators are now located in the YZ plane:
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Do not be confused by the fact that the compass axes do not change: the compass is reoriented to make the YZ the privileged plane, even though the axes on the compass still indicate that the privileged plane is XY.

Keeping the Privileged Plane the Most Visible during Viewpoint Manipulations
This task explains how to keep the privileged plane visible during viewpoint manipulations. This command is not useful when simply using the Select command. It is only useful when using application commands that use manipulators which require working planes, for example, when creating planar patches or modifying control points using the FreeStyle Shaper. You need access to a Version 5 - P2 FreeStyle Shaper configuration to follow this scenario. Open the document Manipulators2.CATProduct.

1. Activate the FreeStyle Shaper workbench. 2. Select the planar patch.
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3. Click the Control Points

icon.

Control points appear on the patch, and the Control Points dialog box appears. 4. Point to a control point on the patch. Manipulators appear:

Note that the manipulators, by default, are oriented in the same plane as the privileged plane of the compass, in the XY plane. 5. Drag the compass onto the patch and align it in the following direction:
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6. Drop the compass onto the patch as follows:

The compass has now detected the orientation of the patch. Note that the manipulators, by default, are oriented in the same plane as the privileged plane of the compass.
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7. Drag the compass away from the patch and drop it into empty space (in other words, not on another object). The compass keeps the same orientation:

8. Manipulate the viewpoint by, for example, rotating. Because rotating the viewpoint also rotates the compass, the privileged plane may be more or less visible. When you work with commands that use manipulators which require working planes, it may be difficult to work if the privileged plane is not always clearly visible:
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9. Point to the compass and right-click to display the contextual menu. 10. Select the command Make Privileged Plane Most Visible. This time, the privileged plane is forced to be the most visible: the compass and the manipulators are reoriented accordingly:
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11. Continue to rotate. You will notice that, as you rotate, the privileged plane switches, the compass is reoriented accordingly, so that the privileged plane always remains clearly visible. Each time this happens, the manipulators are also repositioned in the new privileged plane. This function is useful for both creation and modification commands.

Creating Multi-Views
Creating a Multi-View: Automatic Configuration

The multi-view mode is a brand new capability allowing you to customize the multi-view configuration within a 3D viewer. The automatic configuration is defined in the Automatic tab of the Views and Layout dialog box.
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What you should know before you start

In order to take full advantage of this scenario, you need to be familiar with the basic vocabulary: • • • "Viewer" is the screen area in which 3D objects are drawn "View" is a part of the viewer. Usually, the viewer has one single view but it can also be divided into 4 parts representing a different view each. When a viewer is split into several views, it is identified as a "multi-view" viewer "Viewpoint" is the set of parameters required for defining a 3D view volume, i.e. the eye of the user, the view direction, the focus point and the axis system defining the position of the user. It can be defined as the position in model coordinates at which the eye is looking "Layout" defines how the viewer is divided into different areas (= views) and how these areas are located "Configuration" is a layout made up of views, each of them being defined with a viewpoint.

• •

Bear in mind that the multi-view configuration remains active throughout the whole Version 5 session but it is not saved when using the Save As... command. For instance, if you apply a multi-view configuration then save and close your document before reopening it, this document will be displayed in a single-view configuration using the last active view before the save. However, the configuration is stored in the CATSettings directory and therefore, you can reuse it from one session to another by clicking the Create Multi-View has been defined, the default configuration is applied. Open the Views.CATProduct document. 1. Select the View->Navigation Mode-> Multi-View Customization... command to open the Views and Layout dialog box then select the Automatic tab: icon. If no customization
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This dialog box is made up of three areas: • View Selection lets you select a group of views as well as their location and orientation • Viewpoint Manipulation lets you manipulate the viewpoint using the following options: o Rotation Lock: locks the viewpoint rotation o Translation Lock: locks the viewpoint translation o Viewpoint Synchronization: imposes a synchronization between the views when a viewpoint transformation (rotation, translation or zoom) is made in one of them. Note that you cannot activate both Translation Lock and Viewpoint Synchronization • Confirmation: lets you validate or cancel the configuration. For any 3D object, there are six standard views according to the coordinate system of the object. These views mapped onto a cube, each face of this cube being perpendicular to one of the directions of the 3D axis. Whatever the orientation of the cube, the observer can see three faces (i.e. three standard views) as shown below:
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An isometric view can be added to these views. The direction of this isometric view starts from the vertex formed by the three faces towards the center of the cube. The View Selection area represents the unfolded cube of standard views: each square represents a standard view and the one placed at the center is the base view around which adjacent views will be automatically generated. In the default configuration displayed below, the base view is the standard "Left View": ISO = Isometric View TP = Top View BK = Back View LF = Left View FR = Front View BM = Bottom View

2. Select the standard view to be used as base view using one of these two methods: • select directly in the View Selection area the view to be set as the base view: the selected view will be placed at the center and all the adjacent views will be regenerated accordingly. In the example below, the Back View is selected:
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to shift the Back View to the center (or any • click the right translation arrow other translation arrow depending on the standard view you want to set as base view). Clicking a translation arrow shifts the views in the arrow's direction. 3. Click Apply to apply the configuration to the current 3D viewer and keep the Views and Layout dialog box displayed:

As soon as you apply a configuration to the current viewer, the Create Multi-View icon in the View toolbar changes to now active. to indicate that the multi-view mode is

When you manipulate a viewpoint in one of the four views, the other three viewpoints are not modified and you can manipulate them independently:
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4. Select a group of views by clicking an Isometric View in one of the four corners of the View Selection area. This amounts to selecting a vertex of the cube and the user will then see the three adjacent faces. The selected Isometric View will be computed from its three adjacent views and the four views (Isometric + adjacent) will be highlighted:

Another example when the Isometric View in the top-right corner is selected:
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The View Selection area also contains four rotation arrows (such as ) enabling you to change the orientation of the current base view: one click on an arrow rotates the base view by 90 degrees in the arrow's direction. When the base view is rotated, all the adjacent views as well as the isometric view are recalculated. arrow repeatedly and check the result in the View Selection area. Below 5. Click the is an example with starting position displayed to the left:

6. Activate the lock options (+ click Apply) if needed: • Rotation Lock locks the rotation in all the views, except the Isometric View • Translation Lock locks the translation in all the views, except the Isometric View. 7. Activate the Viewpoint Synchronization option then click Apply if you want the other three viewpoints to be modified simultaneously when you manipulate one of them.
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8. When satisfied with your configuration, click OK (or Apply then OK) to validate and close the Views and Layout dialog box. To go back to the standard viewer, just click the Create Multi-View View toolbar. icon from the

Note that when you reselect the View->Navigation Mode-> Multi-View Customization... command, the Views and Layout dialog box the last used tab is activated with the last applied configuration.

Creating a Multi-View: Standard View Customization

The multi-view mode is a brand new capability allowing you to customize the default standard view within a 3D viewer. This customization is defined in the Standard Views tab of the Views and Layout dialog box.

For detailed information on the other tabs provided in this dialog box, refer to Creating a Multi-View Manual Configuration and Creating a Multi-View: Automatic Configuration.
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What you should know before you start

In order to take full advantage of this scenario, you need to be familiar with the basic vocabulary: • • •

"Viewer" is the screen area in which 3D objects are drawn "View" is a part of the viewer. Usually, the viewer has one single view but it can also be divided into 4 parts representing a different view each. When a viewer is split into several views, it is identified as a "multi-view" viewer "Viewpoint" is the set of parameters required for defining a 3D view volume, i.e. the eye of the user, the view direction, the focus point and the axis system defining the position of the user. It can be defined as the position in model coordinates at which the eye is looking.

Bear in mind that the configuration remains active throughout the whole Version 5 session but it is not saved when using the Save As... command. For instance, if you apply a specific configuration then save and close your document before reopening it, this document will be displayed using the last active view before the save. However, the view direction and orientation you define in this tab are stored in the CATSettings directory and therefore, you can reuse your customization from one session to another by clicking

icon. If no customization has been defined for a standard view, the defau the Create Multi-View standard view is applied.

Open the Views.CATProduct document. 1. Select the View->Navigation Mode-> Multi-View Customization... command to open the Views and Layout dialog box then select the Standard Views tab:
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Note that you can also access the Standard Views tab by selecting the View->Named Views... command then choosing a view from the list before clicking the Properties button. This dialog box is made up of six areas: • Standard Views icons let you select the standard view to be customized • View Selection lets you modify the direction and orientation of the selected standard view • View Direction lets you manipulate the viewpoint • Apply to axis lets you specify the axis to which the modification will be applied • Reset All lets you restore all the standard views to their original default direction and orientation • Confirmation: lets you validate or cancel the configuration. 2. Select a standard view to customize by clicking one of the icons displayed to the left. By icon. default, the Front View is selected. In our example, we click the Back View When a standard view is selected, the preview displayed in the View Selection area is updated:
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The standard views displayed in this dialog box are identical to those available in the Quick View toolbar: Isometric View Front View Back View Left View Right View Top View Bottom View 3. Click Apply then OK to apply the Back View to the current viewer:

4. Re-select the View->Navigation Mode-> Multi-View Customization... command to re-open t
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Interacting Views and Layout dialog box: the Back View icon is still selected and we can now start customizing it. 5. Use the four translation arrows (such as degrees in the arrow's direction. ) to shift the selected standard view by 90

arrow Below is an example of the result you can obtain when clicking repeatedly the with the Back View as the selected view and starting position displayed to the left:

Note that if the current standard view is an isometric view, the isometric view's direction changes to one of the eight possible isometric views using predetermined increments. Below is an example using repeatedly the left: arrow with starting position displayed to the

6. Use the four rotation arrows (such as ) to change the orientation of the current view: on click on an arrow rotates the view by 90 degrees in the arrow's direction. Below is an example using repeatedly the left: arrow with starting position displayed to the

Note that if the current standard view is an isometric view, the view will be rotated by 60
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7. Use the three fields displayed in the View Direction area to change the direction of the current view. This area indicates the direction of the selected standard view along the X, Y and Z axis (as shown below):

To change the direction, you can enter one of these three values in the desired field: -1, 0 or 1 before clicking Apply. Note that if the selected view is not an isometric view, you can enter a value only in one of the tree fields: as soon as a value is entered in a field, the other two are automatically filled with the value "0". On the contrary, if the selected view is an isometric view, you can enter a value in the three fields. If you enter a positive value other than "1", it will be changed to "1" and if you enter a negative value other than "-1", it will be changed to "-1". For instance, entering "-1" instead of "1" in the first field to the left will invert the view direction along the X axis:
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8. Use the Apply to axis area to position the selected standard view according to the local axis or to the axis you select: • when "Use local axis" is displayed, it means that the standard view is positioned according to the active (i.e. current) local axis. If no local axis is active, the standard view is positioned according to the global axis system (displayed in the bottom right corner of the screen) of the UI-active object. For instance, if a part is activated, the standard view uses the part's axis as reference. To set an axis as current, just right-click it in the specification tree or in the geometry area then select the xxx object->Set As Current contextual command. • checking the Select axis option lets you position the standard view according to a specific axis: to select the axis to be used, first select the text "No Selection" then click the axis to be used in the geometry area. The name of the selected axis will be displayed in the Select axis field:

The directions of the selected axis will be saved in the CATSettings directory and will be applied to the standard view. As these directions are stored in the settings, this means that the standard view is always positioned according to them and this, whatever the orientation changes you may make afterwards (for instance, if you change the compass orientation). If you want to apply new directions to the standard view, you need to select another axis. Note that the Select axis option remains activated even if you select another standard view. Therefore, do not forget to deactivate the option if you want to use the local axis. In case your current axis sytem is left-handed, the standard views will be positioned according to the global axis system.
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9. When satisfied with your configuration, click OK (or Apply then OK) to validate and close th Views and Layout dialog box.

10. In the View toolbar, click the icon of the standard view you have just customized (Back View in our example). The modified standard view is applied to the current viewer and you see that the result is totally different from the one in step 3 where the original standard Back View has been applied:

Using the Joystick Control Panel
This section provides information about using the Joystick Control Panel in order to set the joystick behavior.
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Interacting If you are running Windows 2000 or Windows XP, you must setup the joystick prior to run the joystick command. To do so, access the Tools->Options>General->Devices and Virtual Reality->Devices tab: • • activate the "Automatic" Virtual reality starting mode click the Joystick icon in the Automatically Started Daemons area.

Otherwise, you can still run the joystick daemon named CATJoystickDriver. Refer to the Joystick Spacestick part to read more on how to run a joystick daemon. 1. In the power input field, key in the following command: c:joystick The Joystick Control Panel opens:

2. Select your Navigation mode by clicking the corresponding radio button: Fly or Walk. Note: these navigation modes are totally independent from the standard Fly and Walk modes available in the View toolbar. 3. Click the More >> button to display detailed information about the joystick:
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4. In the Fly Sensitivity area, use the sliders to define the sensibility when rotating around the X, Y and Z axes. 5. The Speed area lets you choose between the joystick slider or the joystick buttons to set the maximum displacement speed: • Use Slider option enables you to enter a number comprised between 0 to the maximum speed • Use Buttons option activates the Increase and Decrease buttons to let you set the buttons that will increase or decrease speed. 6. Still in the Speed area, enter the Increase rate by which the speed will be increased when pressing the joystick button.
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7. The Button Customization area enables you to assign an action to the button of your choice. First select an action from the pulldown list then click Choose a Button and choose the desired button. 8. In the Navigation Options area, you can check the displayed checkboxes to: • move in the sight direction. This option is used in combination with head tracking • invert the joystick top and bottom • invert the joystick right and left • invert Y axis and Z rotation. When checked, the "Gravitational effects during navigation" option indicates that gravitational effects are enabled while navigating in Walk Mode. This option must be activated (and also deactivated) via the Tools->Options->General->Display->Navigation tab. Note that gravitational effects are not relevant for Fly mode navigation. 9. The TopHat options area lets you use the cursor. First click the "Activates the cursor" checkbox to activate the TopHat options. appears on the screen to simulate the mouse. You can then A cross perform the same interactions as you would do with a mouse. 10. Use the Speed slider to set the cursor speed. 11. Check the "Double speed after a long impulse" to double the cursor speed when making a long impulse. 12. The "Stop at screen border" option enables the cursor to be snapped to the screen border you are getting nearer. Otherwise, the cursor will reappear on the opposite screen border. 13. Click Close when satisfied with your parameters. The Default button lets you reset the TopHat options to the default parameters. The Walk mode options slightly differ from the Fly mode options as shown below:
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The Walk Sensitivity area lets you set the speed while moving along the X and Y axes and while rotating around the Z axis. You can use the Vertical Translation area to choose whether you wish to use the buttons or the slider. In case you use the slider, you can indicate the maximum slider speed in the Max Speed field. If you choose to use the buttons, clicking Go Up or Go Down then a joystick button lets you assign this button to the corresponding direction. Note that all these information are saved in settings files.
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Changing Views
Individual views are created as you navigate through your design in examine, walk and fly modes. Views are stored and can be reviewed. In walk and fly modes, views are created each time you pause during your walkabout or fly around. This task shows you how to change views. Open the document Platform.model. You need a V4 Integration license to open this document. 1. Navigate in Examine mode (zoom, pan, etc.) to create and save several different views. 2. Select the View->Modify->Previous View command. The previous view is displayed in the geometry area. 3. Select the View->Modify->Previous View command again.

4. Select the View->Modify->Next View command. The next saved view is displayed in the geometry area.

Looking At Objects

This tasks explains how to look at the document in a specific direction by targeting through a userviewport. 1. Select the View->Modify->Look At command.
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2. Drag (left mouse button) slowly to display the viewport.

As you begin to drag, a rectangle with two diagonals appears and continues to grow as long as y continue to drag. This rectangle represents the viewing window of the future view.

Before

After

3. Continue dragging to move around, resize and reposition the viewport.

The viewport is then shaped like a pyramid: your eyepoint is located at the vertex of the pyramid resize the viewport by dragging the middle mouse button.

Before 4. Release the button. You now see what is targeted inside the viewport.

After
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You can also press and hold down both Shift then the middle mouse button for a quicker result.

Turning Your Head To View An Object

This tasks explains how to view an object by simulating what happens when you turn your head to

1. Select the View->Modify->Turn Head command, or click the Turn Head 2. Drag (left mouse button). A navigation symbol appears to help you understand what happens as you drag:

icon in the View

Before 3. Release at the desired location.

After

In our example, dragging to the right lets you view the object as if you had turned your head.
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Before

After

Snapping the Viewpoint
This tasks explains how to adjust the viewpoint automatically after rotating it so that it matches the standard view it comes closest to. Open the DragObject.CATProduct document.

1. Select the View->Navigation Mode->Viewpoint Snapping command. 2. Manipulate the current viewpoint by rotating the object using the mouse (press and hold down the middle mouse button then press the left/right button and drag still holding both buttons down):

Note that the viewpoint will not be snapped if you use the compass to manipulate the viewpoint. 3. Release the mouse buttons. The viewpoint is adjusted and snapped to the nearest standard view (Top View in our example) is applied:
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To deactivate viewpoint snapping, uncheck the Viewpoint Snapping command from the View menu.

Using layers and layer filters
Assigning Objects To Layers
This task explains how to assign objects to layers. Once you have assigned objects to layers, you then create visualization filters (refer to Using Visualization Filters) which allow you to display only those objects located on specific layers referenced by the visualization filter. Open the document Layers.CATProduct. The document looks like this when you first open it:
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1. Click the "+" symbol next to Layers, then the "+" symbol next to PadandCylinder, Pad, etc. until you see the following:
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You can now see clearly that the two features are named PadandCylinder and Pad. 2. Select the View->Toolbars->Graphic Properties command to display the Graphic Properties toolbar:

"None" in the Layer box: indicates that there is no current layer, which guarantees that all the contents of your document are visible. You can assign objects to "None": any object assigned to "None" will always be visible. For the moment, you have not yet assigned any objects onto a layer.
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The following layers are always available: • None • 0 General • 1 - 999 (even though they are not visible at first in the Layer list). These layers cannot be deleted. The Layer box also contains the Other Layers... command which lets you create your own named layers. Refer to Creating New Layers for more details. 3. Select PadandCylinder in the tree, click the arrow on the Layer box, then select "0 General" from the list. PadandCylinder is assigned to the layer "0 General". The Layer box now looks like this: . You see only the number because all layers are identified primarily by their number. 4. Click on the "+" symbol next to PadandCylinder. PadandCylinder is expanded. 5. Select the different features in PadandCylinder (Pad.1, Pad.2). Note that these features are also located on the layer "0". This is because the features inside a part body inherit the part body properties. 6. This time, still in PadandCylinder, select any of the sketches. Note, however, that the sketches from which the features are built remain on the current layer "None". 7. Select Pad in the tree. Pad is still located on the current layer: .
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More about layers

• •

• • • •

The current layer is always visible whatever the visualization filter. This implies that objects located on this layer are visible as well If no objects are selected, the current layer is displayed in the Layer box. If an object is selected, the name of the layer on which the object is located is displayed in the box. Consequently, to find out which layer an object is assigned to, select the object and look at the Layer box New objects are always created on the current layer. If you want to create new objects on a specific layer, you can do so by setting the appropriate layer in the Layer box first: any new objects will be created on this new current layer The link between a given feature or object and a given layer is stored with the document To change the current layer, first make sure no object is selected, then enter the layer number in the box When pointing to the Layer box, a tooltip indicates whether the layer definition location is stored in the document or in the user settings (i.e. the CATSettings directory). However, bear in mind that this tooltip is displayed for information only, you cannot modify the storage location which has been set as explained below: o for CATProduct documents, the definition is stored in the user settings o for CATPart documents, the definition (if there is one) is stored in the document. If no definition is stored in the document, the CATPart documents use the definition stored in the user settings o for CATDrawing documents, the definition is stored in the document.

About opening existing documents

When opening existing documents (whatever the release level on which they were created), existing geometry will be migrated to the current layer. To prevent the geometry from being assigned to a layer, set the current layer to "None" before opening existing documents. Furthermore, if you open existing documents with a current layer set to a layer other than "None", then close the document without making any changes, you will be prompted to save the document because the geometry was assigned to the current layer when opening the document. When opening Version 4 documents containing layers, all existing layers are preserved as is: the layers are stored in the Version 4 document. Note: Version 5 does not manage Version 4 layers on which dittos are located.

Using Visualization Filters
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Basic Tasks This task explains how to use visualization filters. A visualization filter is a group of layers. You then apply the filter to visualize (or not) only those objects located on the layers in the filter. Open the document Layers.CATProduct. The document looks like this when you first open it:

1. Select the Tools -> Visualization Filters... command. The Visualization Filters dialog box appears:
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The default current filter "All visible" is applied automatically: it lets you see all the contents of the document. This filter cannot be deleted. 2. Click the New button. The Visualization Filter Editor dialog box appears, allowing you to build the filter from the following building blocks:

• Criterion: this list box contains the operators you can use: =, !=, >, <, <= and >=; The default operator is "=" • the list box to the right lists the named layers (you can type any layer number between 0 and 999) • And and Or buttons provide you with the corresponding logical functions for combining layers: o "And" lets you add criteria (for instance, "Layer>0 & Layer<10" means that objects displayed in layers "1" to "9" will be displayed) o "Or" lets you filter according to at least one of the criteria you define (for instance, "Layer=0 + Layer=1" means that objects contained in layer "0", or in layer "1" will be displayed). • The Filter field specifies the final filter syntax.
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3. Click in the Criterion field (where you see "0"), delete "0" then type "1" so that the filter syntax now looks like this: layer = 1

4. Click OK. This creates a new filter "Filter001" (with the default filter syntax) in the Visualization Filters dialog box:

When pointing to the desired filter name, a tooltip indicates whether the filter definition location is stored in the document or in the user settings (i.e. the CATSettings directory). However, bear in mind that this tooltip is displayed for information only, you cannot modify the storage location which has been set as explained below: • for CATProduct documents, the definition is stored in the user settings. This means that your visualization filters will be kept throughout the whole session and from one session to another • for CATPart documents, the definition (if there is one) is stored in the document. If no definition is stored in the document, the CATPart documents use the definition stored in the user settings • for CATDrawing documents, the definition is stored in the document.
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5. Select the root object PadandCylinder in the tree, then select the View>Toolbars->GraphicProperties command to look at the Graphic Properties toolbar. 6. Click the Layer box, then type "0". The root object is now assigned to the layer number "0". 7. Select Pad.1 in the tree, click the arrow on the Layer box, then select "0 Layer 0" from the list. Pad.1 is assigned to the layer "0". The Layer box now looks like this: . 8. Select Sketch.1 in the tree, click inside the Layer box, then type "1". Pad is assigned to the layer "Layer 1". The Layer box now looks like this: . 9. Select "Filter001" in the Visualization Filters dialog box and click Apply. The objects under PadandCylinder are no longer displayed, and the filter remains active.
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Why are these objects no longer displayed? All the features below the root object in the tree are considered to be on layer "0" if applying the visualization filter makes the objects invisible. This remains the case even if you assign the objects to layers other than layer "0". 10. This time, select the root object PadandCylinder in the tree, click the Layer box, then type "1" to assign it to layer "1". The filter is still active, but this time only the object Sketch.1 becomes visible:

Why is only one object displayed? Both the root object and the Pad object are both on layer "1", but this time applying the visualization filter has the effect of making objects visible, so the Pad object becomes visible. To see all the objects again, select the "All visible" filter then click Apply.

Improving Viewing Performance
Defining the Level of Detail and the Pixel Culling
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This task explains how to define dynamically (in order to improve visualization performance): • • the level of detail you want to view in your geometry while moving using the Define Dynamic Level of Detail command the size in pixels of objects to be hidden/displayed in your geometry while moving using the Define Dynamic Pixel Culling command.

Dynamic level of detail and dynamic pixel culling allow you to modify more quickly the values set in the Performances tab. However, bear in mind that the values you define here apply only to your current Version 5 session, contrary to the values defined via the Performances tab which are stored in your settings files and thus, are kept from one session to another unless they are explicitly modified.

You can use these two commands simultaneously or separately, as needed. However, note that if the Level of detail or the Pixel culling option has been locked by your administrator in the Performances tab, you will not be able to define dynamically the level of detail or the pixel culling because the corresponding command (Define Dynamic Level of Detail or Dynamic Pixel Culling) will be grayed out. Open your sample document. Before you begin, you also need to do the following: • LODs are used in a product context in Visualization mode: as a consequence, you must activate the cache for your LOD settings to be taken into account (check the "Work with the cache system" option in the Tools->Options>Infrastructure->Product Structure->Cache Management tab) check the "Save level of details in cgr" in the Cgr Management tab. activate at least the "Triangles" mode in the Custom View Modes dialog box.

• •

1. Select the Tools->Customize... command. 2. Click the Commands tab to list the commands available. 3. Select the category All Commands that lists all commands available.
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4. Select the Define Dynamic Level of Detail command from the command list. 5. Drag the command from the command list to the toolbar to which you want to add the command. 6. Drop the command onto the desired toolbar. Note that some toolbars (such as the View toolbar) cannot be customized. As a consequence, you will not be able to drag and drop commands onto them. For detailed information on how to customize toolbars, refer to Customizing a Toolbar by Dragging and Dropping. 7. Repeat steps 5 and 6 to drag and drop the Define Dynamic Pixel Culling command. In our example, the two commands have been added to the Standard toolbar:

These commands are identified by two different icons:
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• •

identifies the Define Dynamic Pixel Culling command identifies the Define Dynamic Level of Detail command.

8. Set your own values either by entering them directly in the corresponding field or by using the spin box: • for pixel culling, you can enter a value comprised between 0 and 40. The higher the value, the more quickly you will be able to move large parts • for level of detail, you can also enter a value comprised between 0 and 40. The higher the value, the lower the level of detail. 9. Perform a viewing operation, for instance pan or rotate your model. You can see that your new values have been taken into account.

Testing the Visualization Time
This task explains how to test the visualization time for the 3D document you are currently displaying in your Version 5 session. Open the Select.CATProduct document. 1. In the power input field, enter the following command: c:performance gauges A gauge appears in the lower-left part of the geometry area and displays the visualization time in milliseconds (ms) of the previous frame:
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2. Manipulate your model, for instance by rotating it. The gauge is updated and displays the new visualization time:

3. To exit the command, re-enter c:performance gauges in the power input field.
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Testing the Visualization Performance
This task explains how to test the 3D visualization performance, more precisely the rotation of the 3D document you are currently displaying in your Version 5 session with the rotation angle and step number you defined.

Open the Select.CATProduct document which looks like this:

1. In the power input field, enter the following command: c:TestVisuPerfoDraw The test dialog box opens:
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2. In the Rotate Axis area, select the desired rotation axis, either: • Vertical: corresponds to the default axis which is vertical and parallel to the screen • Horizontal: corresponds to the horizontal axis, parallel to the screen • Sight: corresponds to the axis which is perpendicular to the screen. 3. In the Parameters area, you need to define: • the angle for each rotation step (in degrees) in the Angle field • the number of steps in the Repeat field. 4. In the LOD Selection area, select the desired level of details: • Static Mode • Dynamic Mode. Depending on the mode you select, the test will be performed according to the value you set in Level of Details area available in the Tools->Options>General->Display->Performances tab: • selecting "Static Mode" means that the test will be performed using the value set with the "Static" slider. • selecting "Dynamic Mode" means that the value used for the test will be the one defined with the "While Moving" slider. 5. Click Apply to start testing. The parameters you defined are applied and the corresponding result performance is displayed in the Results area which indicates the total
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6. Click Close to exit the command.

Rendering Styles
Using Rendering Styles

Shading (SHD)

This tasks explains how to display objects in shading mode. 1. Select the View->Render Style->Shading (SHD) command or click the Shading icon.

Setting a part in "Dynamic hidden line removal" mode to "Shading" mode has the following effect:
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"Dynamic hidden line removal"

"Shading"

Shading with Edges
This tasks explains how to display objects in shading mode with all edges, whatever their type (smooth or hidden). 1. Select the View->Render Style->Shading with Edges command or click the Shading with Edges icon.

Setting a model from "Shading" to "Shading with Edges" has the following effect:

"Shading"
More about the Shading with Edges style

"Shading with Edges"

If you modify the element color, bear in mind that in shading mode, lineic elements (such as edges or sketches) do not inherit the new color and turn black as shown by the example below:
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"Shading with Edges" mode: "red" color is not applied to lineic elements

Edges and Points mode: "red" color is applied to lineic elements

For detailed information on color inheritance for Assembly objects, refer to Displaying and Editing Graphic Properties.

Shading with Edges and Hidden Edges

This tasks explains how to display objects in shading mode with edges, whether they are hidden o not. 1. Select the View->Render Style->Shading with Edges and Hidden Edges command or click the Shading with Edges and Hidden Edges icon.

Setting a model from "Shading with Edges" to "Shading with Edges and Hidden Edges" has the following effect:
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Shading with Edges without Smooth Edges
This tasks explains how to display objects in shading mode with edges but without smooth edges using a specific composite rendering style. A smooth edge is an edge that does not define a break in the geometry, contrary to a sharp edge that breaks the continuity of the geometry. Three basic rendering styles are also provided in the Customize View Modes dialog box to let you manage more easily the visualization of edges. Refer to the corresponding documentation for detailed information. 1. Select the View->Render Style->Shading with Edges without Smooth Edges command or click the Shading with Edges without Smooth Edges icon.

Setting a shaded model from "Shading with Edges" to "Shading with Edges without Smooth Edges" has the following effect:

"Shading with Edges"

"Shading with Edges without Smooth Edges"

Wireframe (NHR)

This tasks explains how to display objects in wireframe mode (i.e. only objects' edges are displaye

1. Select the View->Render Style->Wireframe (NHR) command or click the Wireframe (NHR icon.
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Setting a shaded object to "Wireframe" has the following effect:

"Shading"

"Wireframe"

The Version 5 wireframe mode does not correspond to the Version 4 wireframe mode. The full equivalence may be obtained by checking "Edges and points" and "Outline" in the Custom View Modes dialog box. For more information on customizing view modes, refer to Customizing the View Mode in this guide.
More about the Wireframe style

The Wireframe mode shows only edges and lines. As fas as edges are concerned, when displayed in Wireframe mode, they are applied the color of the mesh and not the one of the "edges + mesh" mode. For instance, when you display a blue pad with black edges in Wireframe mode, edges turn blue:

"Shading with Edges"

"Wireframe"

The reason is that for each surface or solid, the visualization algorithm retrieves the color of all the faces the object is made of and looks for the dominant color (i.e. the color that is most used). This dominant color will then be used for the display in Wireframe. Now if we take a more complex example: a pad with one red face and the rest of the pad is in blue. When setting the pad to the Wireframe mode, the pad edges will be displayed in blue which is the dominant color.
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Rendering Style per Object

Usually, rendering attributes are ignored when drawing objects within a 3D window. The "Renderin style per object" option takes into account the rendering styles that have been defined for V5 elements using the Edit->Properties command or the Graphic Properties toolbar. The rendering styles you can apply in the graphic properties are: • • • • Shading Shading with Edges Transparent Wireframe.

When V5 elements have been assigned one of the above-mentioned rendering styles, this style supersedes the one of the 3D window.

Rendering styles are taken into account in the following order: first, the rendering style of the pare document and then, the rendering style of the child document. For instance, if you apply the "Wireframe" rendering style to a product and the "Transparent" rendering style to its part, activati "Rendering style per object" will display the whole object in wireframe. But if you select the produc then set it to "No Specific Rendering", then the object will be displayed as "transparent". This is als true for geometrical sets.

This scenario assumes that at least two different rendering styles have been defined for the variou elements contained in your sample document.

In the example below, two surfaces have been selected and assigned the following rendering style

Surface 1: "Wireframe" rendering style

Surface 2: "Shading with Edges" rendering style

1. Select the View->Render Style->Customize View Parameters command. The Custom View Modes dialog box appears:
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2. Check that the Shading mode is activated and see the result in the geometry area:

The whole object is displayed in "Shading" mode even if some elements have been assigned a different rendering style.

3. Now, activate Rendering style per object in the Options area. This displays each element wi its specific rendering style:
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In our example, Surface 1 is displayed in "Wireframe" mode and Surface 2 in "Shading with Edges" mode. For detailed information on the various rendering styles available in the Custom View Modes dialog box, refer to Customizing the View Mode. 4. When finished, click OK to validate and close the dialog box.

Customizing the View Mode
This tasks explains how to use the customize and apply view parameters.

1. Select the Customize View Parameters

icon in the View toolbar.

Note that you can also select the View->Render Style->Customize View Parameters command. The "Custom View Modes" dialog box appears. If this is the first time you are using the command, the view settings for the current document will be checked in the dialog box.
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In our example, the Shading parameter is checked: this means that the view mode for the current document is "Shading". 2. Customize your own view parameters by checking or unchecking the appropriate options. In certain cases, checking one option may also activate other options. Each time you check or uncheck an option, the current view is updated dynamically to take your settings into account.
Lines and points

Edges and points This area lets you display objects in shading mode with points and edges. You can choose among the following visualization modes:
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• All edges Displays objects with all edges, whatever their type (smooth or not). You can also use the Shading with Edges command. This mode replaces the former "Smooth Edges - visible" mode available in the Tools->Options>General->Display->Visualization tab.

All edges Wireframe: when "All edges" is activated, you can deactivate the "Shading" mode to display the object in Wireframe (NHR) mode. In this mode, only the object's edges are visible. Note that you can also use the Wireframe (NHR) command.

Wireframe • Half visible smooth edges Displays partially smooth edges. This mode replaces the former "Smooth Edges - half-visible" mode available in the Visualization tab. Do not forget to activate "Edges and points" in order to be able to activate "Half visible smooth edges". Note that if the "Shading" mode is not activated, the "Half visible smooth edges" option has no impact (all edges are displayed).
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All edges Note that if the "Shading" is not activated,

Half visible smooth edges

• No smooth edges Hides smooth edges on your objects. You can also use the Shading with Edges without Smooth Edges command. This mode replaces the former "Smooth Edges - invisible" mode available in the Visualization tab. Do not forget to activate "Edges and points" in order to be able to check "No smooth edges":

All edges

No smooth edges

Outlines This option is useful if you always want to display outlines for parts created from surfaces of revolution, for example, shafts, and cylinders. This setting determines whether you see outlines or not.
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"Outlines" off No shading

"Outlines" on No shading

Whereas edge display is computed by your workstation's graphic adapter, outline display is computed by the display software. Note that there is a price to pay in memory usage and, in large assemblies, displaying outlines may affect display performance. You may want to switch outline display off in this case. Line-on-line This option enables you to visualize superimposed lines by displaying them in a different color. It is recommended to set a dark color background for better visibility. Let's have a look at the example below: Example 1 Line-on-line activated with light color background: superimposed lines cannot be distinguished:

Example 2 Line-on-line activated with dark color background: superimposed lines can be distinguished (identified by the red arrows in our example):
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Note that when this option is activated, you cannot activate the Shading mode.

Isoparametrics This option is used in conjunction with the "Enable isoparametrics generation" option available in the Performances tab.

No isoparametrics

Isoparametrics are displayed

Mesh

Shading This area lets you define the type of shading to be used when displaying objects. You can choose among the following modes:
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• Gouraud Displays objects in Gouraud shading. This surface-shading technique interpolates linearly a color or a shade across a polygon in order to make the object appear smoother. This is the default visualization mode:

"Gouraud" shading

• Material Lets you visualize materials that have been applied onto your objects. You can also use the Shading with Material command. Refer to "Applying Materials" in the Version 5 - Real Time Rendering User's Guide for detailed information on how to use materials.

"Gouraud" shading

"Material" shading (with "Roughcast" material)

• Triangles Displays the triangles on the object's faces as shown below:
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"Gouraud" shading

"Triangles" shading

• Transparent Enables you to display the whole object in transparency mode provided that the Shading option is activated.

"Gouraud" shading

"Transparent" shading

Hidden edges and points This option displays objects in shading mode with points and edges, whether they are hidden or not. You can also use the Shading with Edges and Hidden Edges command.
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"Gouraud" shading

"Hidden edges and points"

Dynamic hidden line removal This option displays objects in quick hidden line removal mode. In this mode, 3D faces visually blank out any element located behind them, including 1D elements (such as wireframe elements). This option replaces the former Dynamic Hidden Line Removal command available from the View toolbar and from the View->Render Style menu. Setting a shaded part to "Dynamic hidden line removal" has the following effect:

"Gouraud" shading
Options

"Dynamic hidden line removal"

Rendering style per object This option lets you take into account the rendering style of V5 elements when visualizing them in a 3D window. Refer to Rendering Style per Object for detailed information. 3. Select OK if you want to save your customized view parameters, or Cancel to exit without saving them. When selecting OK, your view parameters are stored with your settings. You can then apply these settings to the current document by selecting the icon in the View toolbar or the View->Render Customize View Parameters Style->Customize View Parameters command: this will re-open the Custom View Modes dialog box with the options you have previously activated. Just click OK to validate and apply the view parameters to your document.

Adding materials to objects
Shading with Material
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This tasks explains how to display materials that have been applied onto objects. Refer to "Applying Materials" in the Version 5 - Real Time Rendering User's Guide for detailed information on how to use materials. 1. Select the View->Render Style->Shading with Material command or click the Shading with Material icon.

Note that you can also select the View->Render Style->Customize View Parameters command then check the "Material" option. Setting a shaded part to "Shading with Material" has the following effect:

"Shading" only

"Shading" + "Material" ("Roughcast" material has been applied)

Modifying the Mapped Material
This task shows you how to edit the material you have just mapped in the previous scenario. You will change some propertiest of the material mapped onto the part. 1. Right-click the mapped material (Honeycomb) in the specification tree and select the Properties command from the contextual menu. The Properties dialog box is displayed:
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Note: The mapping support (in this case a box support) appears in the geometry area. This will assist you later when you interactively position the material. 2. Under the Rendering tab, click the Lighting tab if not already active. 3. Change the color of the material to green: • Click [...] opposite Color beside the Ambient, Diffuse, and Specular parameters. The Color dialog box is displayed:
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• Click in the preview area to select the color you want • Click OK in the Color dialog box. The selected color is displayed in the Color field. 4. Change the material density:
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• Click the Analysis tab in the Properties dialog box • Key in a new density • Click Apply. Note: appropriate licenses are required to use these products.

5. Click OK in the Properties dialog box. 6. Right-click the mapped material in the specification tree and select the Properties item from the contextual menu to modify more material properties. For instance, you can change the material size (in the Rendering tab of the Properties dialog box) so that the texture shrinks in size relative to the part.

Now that you have finished, let's go to taking a closer look at the Real Time Rendering application!

Setting Depth Effects

This tasks explains how to achieve 3D depth effects, namely, clipping geometry between clipping planes and creating fog effects. 1. Select the View->Depth Effect... command to display the Depth Effect dialog
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The orange sphere completely encompasses the objects in your document. The white cross represents the center of the objects in the geometry area. The color of the area behind the orange sphere is the background color of your document. The vertical lines represent the front (near) and back (far) clipping planes. By default, depth effects are deactivated: if you zoom in and out, you will see that for the moment the geometry is not clipped. You can keep the Depth Effect dialog box open and continue working with other commands. You will be able to understand the results obtained by setting depth effects by zooming in and out. 2. Set the Near Limit and Far Limit by checking the Fixed checkbox for each option, entering values and pressing Enter in each case.
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Note that location of the vertical lines representing the clipping planes has changed. You can also drag the vertical lines representing the near and far clipping planes to produce the same effect.
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The back (far) section of the geometry is clipped. You now only see what is located between the near and far clipping planes. 3. Zoom out to see all the geometry. 4. Click the Foggy option. The foggy option introduces a foggy effect.
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5. Zoom out again. As you zoom out, the fog effect is increased. The fog gets thicker as you continue to zoom out beyond the back clipping plane.

Setting Lighting Effects
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This tasks explains how to vary ambient lighting effects. 1. Select the View->Lighting... command to display the Light Source Editor dialog box. The default light source settings look like this...

... and produce a lighting effect, for example, like this:
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Note that the Single Light icon is activated by default. The sphere indicates the current lighting direction. The handle on the sphere indicates the direction from which the light is being projected: by default, the light is coming from the top left. You can drag the handle around (using the left mouse button) to change the lighting direction. The new lighting effect is created instantaneously as you drag the handle. The three sliders at the bottom of the dialog box control respectively (from top to bottom): • ambient coefficient: defines the intensity of light emitted in any direction by the object, even if not lit by any light source. The ambient light is essentially used to show objects or parts of objects that are not illuminated directly by the light source.

Ambient = 0.50

Ambient = 1.00

• diffuse coefficient: defines the intensity of light diffused by the object when lit by a light source:

Diffuse = 0.50

Diffuse = 1.00

• specular coefficient: defines the intensity of light reflected in one particular direction. This coefficient affects the highlight on shiny surfaces. The higher the value, the bigger the the specular spot:
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Specular = 0.50

Specular = 1.00

To define the desired value, you can drag the desired slider or use the spin box next to it either by clicking the up and down arrows or by entering a value directly in the field. 2. Drag the handle down and towards the bottom right: the light is now coming from the bottom right:

3. Click the Two Lights icon

to add another light source.

192

Basic Tasks

In our example, using two light sources means that the lighting is now too bright. 4. Drag the brightness slider (the first slider in the list) to the left or use the spin box next to it to reduce the brightness.
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5. Now drag the lower handle up towards the top left to change the direction of the corresponding light source.

194

Basic Tasks

6. Click the Neon Light icon

to produce a neon light effect.
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7. Click the No Light icon

to switch off all light sources.
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Using the Color Chooser To Color Light Sources
You can also color light sources using the color chooser.
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1. Double-click a light source handle. The Color Chooser appears: The colored area with the cross represents a color spectrum.

2. Drag the cross inside the spectrum to instantaneously change the color in the small box below the spectrum. The HSL (Hue, Saturation and Luminance) and RGB (Red, Green and Blue) values vary according to where the cross is located. You can also enter HSL and RGB values in the fields provided to suit your exact color specifications. Move the arrow up or down to vary the brightness of the custom color.

3. Click Apply or OK to apply the changes.

Cameras
About Cameras
Cameras let you take still shots of views or viewpoints in your document. A series of views showing different viewpoints in succession can be combined to create an animation. Cameras are identified by name in the specification tree and by a symbol in the

geometry area

.

A 3D representation helps you locate the viewpoint of interest by showing what the camera sees through a viewport:
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Cameras are moved using the 3D compass or directly using the green manipulators. You can use cameras in two different modes: perspective or parallel, to obtain either a conical or a cylindrical projection. See Editing Camera Properties.

Perspective mode

Parallel mode

199

Interacting

Creating a Camera

The camera enables you to specify a viewpoint from which a photorealistic image will be computed show you how to create a camera and manage its specifications. Note that some of the adjustments detailed in this scenario can also be performed using the Came toolbar. Open the Lamp.CATProduct document.

1. Click the Create Camera icon

. The camera is created at the current viewpoint.

2. Click the Camera item in the specification tree and rotate the model to see the camera sym

This standard visualization is not affected by any change of scale ("zoom").

In case you wish to hide the camera representation, click the camera in the specification tree the Camera object->Hide/Show Representation contextual command. Inversely, this command lets hidden representation.
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You can create several cameras at different locations to have different viewpoints. The camera which is taken into account to render a given image is said to be active. Any other c inactive.

3. Use the two spheres and the two squares displayed in green on the 3D representation to int manipulate and position the camera.

This visualization is affected by changes of view scale (zoom) and is activated when selecting a c the scene or in the specification tree. Otherwise, all elements are set to the standard visualizatio

Conical camera Pyramid height = focal length and Pyramid base = film dimensions

Cylindrical camera Plane = film dimensions

• • • •

the the the the

source point (1) rotates the camera around its target point target point (2) rotates the camera around its source point source green square translates and rotates the camera around its target point target green square translates and rotates the camera around its source point.

Cameras are needed to render and view a scene. "An image is worth a thousand words": the bet camera is positioned, the more accurate the saying is.

4. Select the camera in the specification tree then right-click and select the Edit->Properties c the ALT+ENTER keyboard shortcut). The Properties dialog box is displayed:
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5. In the Lens tab, select the lens Type: Perspective or Parallel, i.e. to obtain a conical or a cyl The Preview area shows the result of your selection accordingly. A conical camera is equivalent to a standard camera, with a non-zero focal length. Parallel lines in the camera line of view appear to intersect at the same point. Perspective cameras are used in most cases since they are close to the human vision. In the case of a cylindrical camera, parallel lines never appear as intersecting. These cameras are mainly used to define architectural viewpoints. 6. Specify the Focal Length, which determines the field of view, in millimeters. The focal length is the distance between the camera origin and the viewing plane.

In a cylindrical projection, the focal length is replaced by a zoom factor which determines the sca (i.e. "Scale" appears instead of "Focal Length" in the dialog box).
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You can also specify the camera view directly inside the preview window by zooming, rotating or view:

7. Click the Position tab to define the target and origin position.
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You can define the Origin and the Target position in millimeters along the X, Y and Z axes. If you are not satisfied with the values you defined, you can click the parameter to reset its value.

button next to the desire

The Feature Properties tab provides general information on the currently selected camera, e.g. it creation date, etc.

Snapping the compass to the camera lets you modify the camera position and orientation very ea by dragging the arcs of the compass as shown below:

For detailed information about compass manipulation, refer to "Moving Objects Using the 3D Com the Version 5 - Infrastructure User`s Guide. 8. Check the Update camera from View option if you wish to adjust (i.e. center) automatically whenever the viewpoint is modified:
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This avoids selecting the Update from View contextual command each time a viewpoint modificat 9. Click OK when finished.

10. If you want to position yourself behind the camera and observe the captured image, select >Camera Window command: a new window displaying the camera viewpoint is opened. Wh the handler in this window, the camera is simultaneously positioned in the main window.

Note: You can choose three arrangements for the opened windows, i.e. horizontal, vertical and c selecting the following commands from the menu bar: • Window -> Tile Horizontally • Window -> Tile Vertically • Window -> Cascade
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Example of vertical tiling

To close the camera window, you can either click the cross in the top-right corner of the window the Window -> Camera Window->Camera x command.

You can double-click the Camera item in the specification tree to position the camera from the cu of view.

You can also select the camera in the specification tree then the Update From View contextual co update the camera when the viewpoint is modified.

Using Knowledgeware Parameters
The camera shows you how to control camera parameters using Knowledgeware tools. This enables you to link parameters to constraints like formulas in order to, for instance, automatically update the camera position whenever the object is moved. Open the Lamp.CATProduct document. 1. Create a camera by clicking the Create Camera icon current viewpoint. . The camera is created at the

You can refer to Creating a Camera for detailed information on cameras. 2. Make sure that the camera is selected either in the geometry area or in the specification tree then click the Formula icon box: from the Knowledge toolbar to open the f(x) dialog
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The Parameter list displays the parameters related to the camera: • KweType: controls the lens type of the camera. This parameter is an integer and you can choose between "0" for perspective or "1" for parallel. The default value is "0" • KweViewAngle: controls the view angle of the camera. The default value is "15 " • KweFocus: controls the focal length (i.e. the field of view) for perspective cameras. The default value is "420mm" • KweZoom: controls the zoom factor (i.e. the field of view) for parallel cameras. The default value is "1" • KweVisuMode: controls the representation of the camera, i.e. whether the camera is displayed in the geometry area or not. The default value is "1" which means that the camera is displayed • KweUpdateFromView: controls the update mode of the camera. You can choose between "0" to indicate that the camera should not be updated when the viewpoint is modified and "1" to indicate that the camera should be updated. The default value is "0" • KweOriginX: controls the position of the camera origin along the X axis (in mm) • KweOriginY: controls the position of the camera origin along the Y axis (in mm) • KweOriginZ: controls the position of the camera origin along the Z axis (in mm) • KweTargetX: controls the position of the camera target along the X axis (in mm) • KweTargetY: controls the position of the camera target along the Y axis (in mm) • KweTargetZ: controls the position of the camera target along the Z axis (in mm) • KweZenithX: controls the rotation of the camera around the X axis • KweZenithY: controls the rotation of the camera around the Y axis • KweZenithZ: controls the rotation of the camera around the Z axis. 3. To edit a parameter, select it from the list: the selected parameter appears in the "Edit name of the value of the current parameter" field along with the corresponding value in the field to the right. In this scenario, we will select the KweUpdateFromView parameter:

4. Enter the "1" in the field displayed to the right to indicate that the camera should be updated according to the viewpoint. For detailed information on how to use the other fields available from this dialog box, refer to Getting Familiar With the f(x) Dialog Box. 5. Click OK or Apply + OK to validate and close the dialog box. The parameter is modified. 6. Modify the viewpoint (by rotating the object, for instance) and check the result: the camera is updated accordingly as shown below:
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Picture 1 - Camera with original viewpoint

Picture 2 - Camera after viewpoint modification

You can also create formulas to constrain the parameters of your choice. For instance, you could associate the center of a part to the camera target so that the camera position changes according to the the object position. For detailed information on how to create and use formulas, refer to the "Formulas" section in the Version 5 - Infrastructure User's Guide.

Manipulating and Selecting Objects
Selecting objects
Preselecting and Selecting Using the Pointer
This task explains basic selection techniques using the pointer. Whenever you are not using an application command, the Select command is active. Using the Select command, you can select any object in your document. All the selection tools are available using this command. Open the document Select.CATProduct.

1. Select the Select icon activated.

to enter selection mode, if it is not already

2. Point to the part of the object you want to select. As you point to objects, different parts of the objects are highlighted, in the geometry area, and the object name is highlighted in the specification tree:
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The identity of the preselected element is displayed in the status bar:

Highlighting will only be active if you checked the option "Preselect in geometry view" (active by default) using the Visualization tab via the Tools->Options... command. This option is active by default. You can also set the preselected element linetype using the " Preselected element linetype" option in the Visualization tab. The face on the object opposite, for example, is highlighted in red. You can also use the same tab to set a variety of useful selection features including selected element color and pre-selected (highlight) linetype. Note that the selection color and pre-selection color are the same. In the geometry area, you can select the constituent elements of objects, in other words: • • • • • faces vertices edges planes axes.
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Whenever you are using an application command, you can only select objects required as input for the command. For example, when creating a hole in a pad, you are prompted to select a face or a plane: no other elements can be selected. 3. Once the element is highlighted, click on the object to select it. In our example, the selected face now changes color because we changed the selection color:

4. Ctrl-click another face to add it to the initial selection:

Ctrl-clicking can be done in: • the geometry area • the specification tree • lists in dialog boxes. Shift-clicking can be done in: • the specification tree • lists in dialog boxes.
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5. To deselect, click anywhere in the background. Edges are highlighted as you point them and arrows are displayed to indicate to which element the edge belongs to. This is especially useful in case of overlapped elements as shown in our example:

On certain objects, note that hidden faces and edges are also highlighted as you point at them. Hidden faces and edges are displayed in a different color. Refer to Selecting Using the Preselection Navigator for a more powerful method for selecting hidden or coincident elements. Selecting the Esc key deselects all selected elements.

Choosing a Selection Mode
There are three different selection modes available to V5 users:

Feature selection mode

Product selection mode

Device selection mode The initial mode available is Product Selection mode. Clicking on the black arrow at the bottom of the icon reveals the Selection Mode toolbar, which has the three modes listed above. Selecting one of the other modes makes that mode the default setting for all subsequent V5 sessions, unless a new mode is 212
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selected or the CATSettings folder is deleted. The selection mode determines how you select objects in the geometry both before and after you have selected a command. Some general considerations for most commands appear below, as well as considerations unique to the Save Initial Condition and Restore Initial Condition commands.

Feature Selection Mode
The feature selection mode allows users to select specific features on the geometry, e.g., a single hole.

In some cases, the particular feature you want to select can be so close to another feature that you can have trouble selecting the particular feature you want. V5 provides a preview option that enables you to select from among all the features near your mouse. To use this preview option, select any feature in the area where the feature you truIy want is located. Then press the up arrow key, you get a preview of the feature in relation to the geometry. In the example below, the up arrow has a one above it, and the down arrow has a three below it. Thus, there are three features near the selected feature, and the first of the three is selected. The large black circle shows what is selected; the smaller black circle shows the feature in relation to the remaining geometry. Using the up or down arrows will provide previews of the remaining two possible features. Once the correct feature is previewed, hit the Enter key. The preview window goes away and the correct feature is selected.
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The Toggle Manipulation Handle Mode command is not available when using the Feature Mode selection and the manipulation box will not be displayed because there is no manipulation box for the features. While this selection mode is active, users can select features from the geometry. Consequently, users cannot use "drag and drop" to assign items to different activities while selecting from the geometry. They can still select parts from the PPR tree and use "drag and drop" to assign them to different activities. Other commands may work on the selected feature or on the part containing the selected feature. For example, the "Hide/Show" and "Properties" commands use the part containing the selected feature, while the "Reframe On" command uses the selected feature (for some data types) and the part containing the selected feature for other data types.

Product Selection Mode
This selection mode enables the selection of the products (or parts).
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Even if the selected product (part) is driven by a device, only the part will be selected.

While using product selection, the Toggle Manipulation Handle Mode command can be turned on or off, depending on the user's needs. Since this selection mode selects entire parts, the user can "drag and drop" to assign items to different activities while selecting from the geometry.
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Device Selection Mode
This selection mode enables the selection of devices simply by selecting, on the geometry, a portion of the device.

• • •

If a device drives the selected part, the whole device will be selected. If multiple mechanisms drive the selected part, the first one will be selected. If the selected part is not driven by any device, the selection will work the same as for the Product Selection mode.

While using device selection, the Toggle Manipulation Handle Mode command can be turned on or off, depending on the user's needs. The user can "drag and drop" to assign items to different activities while selecting from the geometry. The whole device will be assigned if a part from a device was selected to be dragged.

Impact of Selection Mode on Most Commands
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Most V5 commands allow both action-object and object-action selections; that is, it does not usually matter whether you select a command first and then the object on which it acts, or vice versa. However, in order to select the kind of object for which you have set your selection mode (assuming you are selecting from the geometry and not the PPR tree), you usually must use the object-action scenario. Otherwise, the selection mechanism will work as if the feature selection mode was active. This caveat also applies when users rely on the right mouse button to display a contextual menu. For commands provided only through the contextual menu (e.g. "Reframe On"), you can select the object from the PPR tree in order to apply the command to the whole device.

Impact of Selection Mode on Save or Restore Initial Condition
Only two commands apply the selection mode when a selection is done: Save Initial State and Restore Initial State. They apply the selection mode imposed by the user when the "Selected Products/Resources only" option is used. If the selection mode is "Product Selection" or "Feature Selection," the user is able to save or restore the initial state for the selected parts driven by a device. For "Device Selection," the initial state will be saved or restored for the entire device.

Selecting Using the Preselection Navigator

This task explains how to use the preselection navigator (or the keyboard arrows) for selecting hid coincident elements, or elements located elsewhere in the specification tree. Note: the preselection navigator cannot be used with selection filters. Open the document Select.CATProduct

Displaying the Preselection Navigator

Method 1

1. Click anywhere in the geometry area. 2. Position your pointer over the object you want to select. 3. Press any keyboard arrow (up, down, right or left) or the CTRL+F11 keys.

Note that you can now display the preselection navigator by pressing the Alt key + the left mous button (except when working on Sun Solaris operating systems). The preselection navigator appears.
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Method 2

1. Select the Tools->Options... command. In the General category, select the Display sub-cate the Navigation tab.

2. Check the option "Display the preselection navigator after ... seconds", set the spinner to th delay.

The spinner sets the amount of time, in seconds, which elapses before the preselection navigator appears after pointing at an object. 3. Check that the following three options are activated well: • "Display immersive list for preselection navigator" • "Prehighlight faces for preselection navigator" • "Display immersive viewer for preselection navigator". 4. Click OK to close the Options dialog box. 5. Point to the part of the object you want to select. The selection tool is displayed after the time delay you set in step 2:

About display options

As explained above, a certain number of options are available for customizing the display of your preselection navigator. Below are examples of what you see in the geometry area when these optio activated or deactivated: •

Prehighlight faces for preselection navigator You can activate/deactivate the highlight of preselected face(s) by checking/unchecking the "Prehighlight faces for preselection navigator" option under the Navigation tab. By default, this option is deactivated and in that case, the preselected face looks like this:
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When the "Prehighlight faces for preselection navigator" option is activated, the preselected face looks like this:

•

Display immersive list for preselection navigator You can activate/deactivate the display of the immersive list by checking/unchecking the "D immersive list for preselection navigator" option. The immersive list displays all the stacked you can preselect. By default, this option is activated which means that the immersive list is displayed as show
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Display immersive viewer for preselection navigator You can activate/deactivate the display of the immersive viewer by checking/unchecking the immersive viewer for preselection navigator" option. The immersive viewer provides a visua feedback on the preselected element and lets you validate your selection. By default, this option is activated which means that the immersive viewer is displayed as s below:

When the "Display immersive viewer for preselection navigator" option is not activated, the resul is as follows:

•

Display auxiliary viewer for preselection navigator You can activate/deactivate the display of the auxiliary viewer by checking/unchecking the " auxiliary viewer for preselection navigator" option. The auxiliary viewer lets you perform vie operations with the mouse such as zoom, rotate or pan. By default, this option is cleared. When the option is activated, you see something like this geometry area:
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The use of this option is detailed further in this scenario. •

Color The default color used to highlight selected and preselected elements is "orange" but you ca other colors using the "Selected elements" and "Preselected elements" pulldown lists availab Visualization tab.

Using the Preselection Navigator
The following diagram describes graphic selection tool features:
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The preselection navigator is made up of the following elements: • • • •

•

a circle providing a visual feedback for the pointed object. This circle with an opaque backgr shows the preselected element and displays the surrounding elements in transparency. The keeps the proportions of the current viewer arrow controls to navigate: o "in-depth" using up/down arrows o up and down in the object hierarchy using left and right arrows a cross pinpoints the preselected location. Four arrows are used for navigating or scrolling t the object you point at. These arrows turn black when you reach an extremity a list of all the stacked elements you can preselect. This list indicates the selection path and identity of each element. This information is identical to the one displayed in the status bar. You can choose to display or not the immersive list of elements you can preselect (shown in example below). To do so, check or uncheck the "Display immersive list for preselection nav option under the Navigation tab an auxiliary viewer displaying the preselected object. This viewer also lets you perform view operations with the mouse such as zoom, rotate or pan. By default, this viewer is not displa has to be activated via the Navigation tab as explained further in this task.

An invisible area around the selection tool determines selection tool sensitivity.

1. Once the preselection navigator is displayed, click the up arrow to navigate "in-depth", in ot words, from the front to the back of the object, to highlight hidden, superposed or coinciden elements.

This method is particularly useful for large parts since it lets you select, for example, edges, face etc. which are not visible or accessible near the front of the part.
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The cursor shape changes according to the type of the preselected element as shown below: point... edge...

or face:

The identity of the preselected element is displayed in the status bar:

Note: the preselection navigator lets you use the contextual menu. You can also navigate between different objects, not just inside single objects. When one object hides another, the preselection navigator will also let you select elements belonging to the hidde object. 2. Click the down arrow to navigate in the opposite direction, towards the front of the object. There are two other ways to navigate using the mouse:

• position your cursor over the circle, then click with the middle mouse button to navigate ins the object. As you click, the corresponding element path is highlighted in the list displayed to the right • move the mouse over the list of element paths. As you do this, the element corresponding t each path you point at is pre-highlighted in the circle. Then, click the desired path to selec
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Example 2 - when pointing at a path in the list
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You can also press the up and down arrows to achieve the same effect, and validate your selectio using the ENTER key. Using any of these keys displays the selection tool automatically.

The navigation is cyclic: when you reach the end of the selection path using the up and down key the preselection navigator automatically goes back to the starting point (i.e. the highest element the hierarchy) and you can then re-start navigating. 3. Click the left and right arrows to navigate up and down in the object hierarchy. For example, click the left arrow and look at the specification tree to see each click on the left arrow takes you to the top of the tree, then click the right arrow to navigate downwards.

Similarly, you can also press the left and right keys to achieve the same effect, and validate your selection using the ENTER key or the left mouse button.

A prehighlight of the preselected edge is also provided which is especially useful in case of overlapped elements:

4. Select Tools->Options...->General->Display then access the Navigation tab and check the " auxiliary viewer for preselection navigator" option.

5. Click anywhere in the geometry area, then position your pointer over the object and restart navigating by clicking the up or left arrow. An additional window opens and displays the object with the element you have preselected:
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The Auxiliary Viewer window lets you manipulate the object and perform viewing operations with the mouse such as rotate, zoom or pan as shown below:

Rotate

Zoom

To hide the viewer, simply re-access the Navigation tab then deactivate the "Display auxiliary viewer" option.

6. To validate your selection and exit the preselection navigator, use one of the following meth below, depending on the display options that have been activated: • click the circle in the center of the immersive viewer • or, click the desired item in the immersive list • or, click the element directly on the object. The item is selected:
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The selection tool disappears, in any case, once a selection has been made, or if you point or clic outside the selection activation area around the selection tool.

Selecting Using the Selection Traps
This task explains how to select objects using the selection traps. Note that selection traps do not allow you to select sub-elements (e.g. edges, faces, vertices and so on).
Using the Bounding Outline

1. Select the Select icon activated.

to enter selection mode, if it is not already

2. Drag (using the left mouse button). A bounding outline will appear as you drag. 3. Drag the bounding outline until the object(s) you want to select is(are) completely inside the bounding outline. The objects must be completely inside the bounding outline: if not, they will not be selected.
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4. Release the mouse. The objects will be highlighted to indicate they have been selected.

When using the bounding outline in the Part Design workbench, you can only select the last feature you created, not the whole part.
The Selection Trap

Note that you can also use the Selection Trap icon to perform the same function. You access this icon by clicking the Select icon to see the Select toolbar:

Press and hold down the left mouse key, and slide it to the right to select the icon. The principle is the same: drag (using the left mouse button) to create the trap around the object(s). Furthermore, you can start creating the trap by pointing to an existing object, and then dragging your mouse in the geometry area: as soon as you start dragging your mouse, the selection trap is displayed.
The Intersecting Trap

The Intersecting Trap icon on the Select toolbar also allows selection using a trap. Any objects intersected by the trap will be selected.

The Polygonal Trap

The Polygonal Trap icon works like the other traps, except that the trap you can draw is a closed polygon. Drag to define the polygon around the object to be selected, then double-click to close the polygon.

Paint Stroke Selection

The Paint Stroke icon lets you select objects by simply drawing a paint stroke across them. Drag to create the paint stroke. Any object crossed by the paint stroke will be selected.
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Outside Trap Selection

The Outside Trap Selection icon lets you select objects located strictly outside the trap. Drag using the left mouse button: all objects out of the trap are selected.

Intersecting Outside Trap Selection

The Intersecting Outside Trap Selection icon is different than the abovedetailed Intersecting Trap command since it lets you select objects intersecting the trap as well as objects located outside the trap. Drag using the left mouse button: all objects out of the trap or intersecting the trap are selected.

Selecting Using a Filter
This task shows how to manage and customize the sub-geometry selection in order to avoid any ambiguity. From now on, this toolbar is available in any workbench dealing with .CATPart and .CATProduct documents. Note that this scenario takes the Generative Shape Design workbench as an example but the look and number of icons available from the User Selection Filter toolbar varies according to the workbench you are working in. For detailed information on icons dedicated to a specific workbench, you need to refer to the documentation of this workbench. • • • You need a Version 5 - P2 Generative Shape Design configuration to follow this scenario. A .CATProduct containing a .CATPart must be open and one or more features created. You can also open the SelectionFilter.CATProduct document You need to activate the User Selection Filter toolbar by selecting the View -> Toolbars command and clicking User Selection Filter.
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The toolbar is divided into 4 sections: • the icons on the left let you filter elements according to their type: o o o o • point curve surface volume.

the next two icons correspond to the filter modes: o the Feature Element Filter selects the whole feature whether it is a sketch, product, pad, join, etc. the Geometrical Element Filter enables to sub-elements of a feature such as faces, edges or vertices

o •

this icon is used in conjunction with the Work on Support command and lets you select sub-elements from the grid. Refer to "Working with a 3D Support" in the Version 5 - Generative Shape Design User's Guide for detailed information.

•

lets you perform a quick selection of geometry. Refer to "Quick Selection of Geometry" in the Version 5 - Generative Shape Design User's Guide for detailed information. Reset Selection Filters: you can also use this command anytime to deactivate all the icons that have been previously activated in the User Selection Filter toolbar. To use this command, you can choose between the following three methods: o type c:Reset Selection Filters in the power input field: all the icons are deactivated o select the View->Commands List... command then select Reset Selection Filters from the list before clicking OK to validate: this deactivates all the icons in the toolbar o select Tools->Customize..., access the Commands tab, select "All Commands" in the Categories list then drag and drop the Reset Selection Filters command onto the User Selection Filter toolbar (or any other toolbar):

•

You can then check Reset Selection Filters when needed to deactivate the toolbar icons. By default, all the icons are deactivated which means that no filter is applied but you can restrict the selection to specific element types by clicking the corresponding icons. For instance, if you want to select only points and surfaces, you need to activate the Point Filter and Surface Filter icons as shown below:
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Bear in mind that: • • • If you deselect a type, it cannot be selected in the geometry anymore unless all other types are deselected If you deselect a mode, it cannot be selected anymore for each active type unless other modes are deselected It is not possible to activate both filter modes simultaneously (it does not make sense anyway). Only two states are available: either Feature Element Filter or Geometrical Element Filter is activated or both modes are deactivated.

1. Activate the Feature Element Filter as shown:

Depending on the filter you select, the following cursors are used:

is used and this, whatever • When the selection is forbidden, the shape the filter you select • When a filter other than Geometrical Element (e.g. Feature Element, Point when pointing at an Filter, etc.) is activated , the cursor shape is element and the hourglass is displayed after selecting the element • When the Geometrical Element filter is activated, the cursor shape is when pointing at an element and the hourglass is also displayed after selecting the element.

2. Click the Extrude icon

.

The Extruded Surface Definition dialog box appears:
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3. Select Sketch 1 as the profile and xy plane as the direction. 4. Click OK to create the surface.

5. Click the Offset icon

.

The Offset Surface Definition dialog box appears:

6. Click the Geometrical Element Filter icon: as soon as you click the icon, the Feature Element Filter mode is deactivated in the User Selection Filter toolbar:
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7. Select any face of the extruded surface. 8. Enter 20mm as the offset value. 9. Click OK to create the surface.

10. Double-click the extruded surface. The Extruded Surface Definition dialog box is displayed. The Feature Element Filter mode is still deselected. 11. Select any edge of Sketch 2. The Update Error dialog box appears: an element of the part is no longer recognised and needs to be updated.

12. Click OK. 13. Click OK in the Extruded Surface Definition dialog box to create the surface. The Update Diagnosis: Part1 dialog box appears.
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14. Click Edit. The Offset Surface Definition dialog box is displayed. 15. Select the extruded surface of Sketch 2. 16. Click OK in the Offset Surface Definition dialog box. The offset surface is created for Sketch 2.

Selecting Using the Other Selection... Command

This task explains how to display an object's structure in a separate window to facilitate alternative selections. Open the document OtherSel.CATProduct

1. Select the Select icon activated.

to enter selection mode, if it is not already

2. Point to the object to highlight the element you want to select. In this example, point to the circular face at the end of the cylindrical
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3. Select the Other Selection... contextual command or the Edit->Other Selection... command. The element is selected, and the Other Selections window appears. The window contains the location of the selected element in the specification tree, and describes the path to the top of the tree. The name of the circular face is: "Face".

You can also navigate up and down the tree inside the Other Selections window using the preselection navigator or the keyboard arrows, and select other objects. 4. This time, point to the body of the cylinder to highlight the surface.
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5. Select the Other Selection... contextual command. The element is selected, and the Other Selections window appears. Note that, this time, an additional element (highlighted in blue) has been detected: Axis. This is the axis used when the cylindrical part was created. This type of element is a characteristic element.

The Other Selection... command is the only tool that lets you select characteristic elements. 6. Click "Axis" to select it.
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Selection Sets
Storing Selections Using Selection Sets

This task explains how to group selections and store them in selection sets. Selection sets are saved with your documents. You can then use the Selection Sets Edition... command to add objects, rename the selection set, or delete it. As an example, selection sets are already stored in the sample document but that does not prevent you from creating other sets using the instructions below. Open the document SelectionSets.CATProduct. 1. Select the Edit->Selection Sets Edition... command (or use the CTRL+G keyboard shortcut):

2. Click the Create Set button. A selection set named "Set1" is created. Each time you create a new selection set, the number is incremented. You can also rename the selection set using the text field at the bottom of the Selection Sets Edition dialog box. Once a selection set has been created, just double-click the corresponding line in the list to reuse it.
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3. Point to the selected objects to be included in the set. For example, select two of the lines:

You can use the selection traps to add and remove objects grouped in a selection set. The size (i.e. the number of elements included in the set) is displayed as well as the new name given to the set. In our example, we called it "Lines". Note that the default mode is "Add element" which means that clicking an element
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4. To add more elements to your selection set, click the selection set name in the list, check that the "Add element" mode is active then continue selecting elements. In our example, add the hole to the selection set :
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You can add objects to any selection set. If you want to delete an element from a selection set, click the "Remove element" radio button, select the selection set then select in the geometry area the element to be deleted. If you want to delete selection sets that do not contain any element, click the Delete empty Sets button. 5. Check the "Select a face, edge, axis or vertex" option to be able to store subelements (such as faces or edges) in the selection set. 6. Click the OK button. The "Find owning Sets" radio button lets you find the set an element belongs to. To do so, click the desired element then activate the "Find owning Sets" mode to highlight the corresponding group in the list. Note: you can also find the set an element belongs to by selecting the desired element, then choosing the Edit->Find Owning Selection Sets... command. The Selection Sets Selection dialog box appears and displays the name of the set as shown:

For detailed information on this dialog box, refer to Selecting Selection Sets. About geometries The Selection Sets Edition... command also indicates the number of geometries included in the set, if necessary. This information is given in the Size field and is intended to match the information given in the status bar as well as the number of highlighted elements in the geometry area. This is illustrated in the example below: 1. Let's suppose a pad whose top face is stored in a selection set called "Set1":
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As you can see it, the Size field indicates that "1" element is stored in the set. 2. After clicking OK to close the Selection Sets Edition dialog box, a pocket is created and the pad looks like this:

3. Selecting the Edit->Selection Sets Edition... command then "Set1" now gives the following result:

241

Interacting

The information "(2 geometries)" has been added in the Size field to specify that the top face, however still considered as a single element, is now made of two geometries because of the transformation it underwent in step 2. 4. If we select the Edit->Selection Sets... command then "Set1", we can check that this corresponds to the information displayed in the status bar ("2 elements selected") and to what is displayed in the geometry area: there are two highlighted elements.

Selecting Selection Sets
This task explains how to select groups once they have been stored in selection sets.
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Open the document SelectionSets.CATProduct. 1. Select the Edit->Selection Sets... command (or use the CTRL+G keyboard shortcut):

The above picture shows 3 selection sets: Surfaces, Lines and Group. 2. Click one of the selection sets from the list. You can also use the CTRL key to select more than one selection sets in the list. The elements included in the selection set are highlighted in the geometry area:
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3. Click the Select button or double-click the selection sets to select the highlighted elements. The number of selected elements is displayed in the status bar. If you want to reset the filter, i.e. remove a selection set from the list, just select the set to be removed then click the Reset button. However, note that elements stored in this set will still be highlighted in the geometry area and in the specification tree.

Using selection sets is very useful for identifying very quickly a selected group of elements. For instance, selecting "Group" then clicking the icon (to transfer hidden objects to the No Show space) hides the elements belonging to "Group"...
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... and clicking the No Show space:

icon lets you display the hidden elements in the

The search command
Selecting Using the Search... Command (General Mode)
This task explains how to use the Edit->Search... command to search for and select objects. You can search for:
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Interacting • • • • • objects with a specific name, or of a specific type or color visible or hidden objects, or lines with specific linetypes or thicknesses product properties elements through the value of a specific attribute (material name, dimensions, etc.) objects created using a specific workbench, in the current document or throughout the whole document, in the selection list.

Note that you can perform searches on model documents created using CATIA Version 4.

Open the document Search1.CATProduct.

Performing a Quick Search for a Named Object

1. Select the Edit->Search... command (or use the Ctrl+F shortcut).

The Search dialog box appears. 2. Click the General tab:

246

Basic Tasks

If the Select command was active before you selected the Edit->Search... command, it remains active. The Search... command does not prevent you from running other commands on the search results (once selected). So you can also work with other commands while the Search dialog box remains open. This means that you can: • run commands using the menus and icons • and also apply commands in contextual menus to selected search results using the power input field: for example, you can manipulate selected specification tree elements using the "c:center on", "c:center graph", "c:cut" commands. If you select the Search button now, all items in the specification tree will be found. Include topology When searching for topological objects (by selecting "Topology" in the Workbench list), the "Topology" search criterion can be combined only with an object type. You cannot combine it with a color or a name, for instance. Another method to search for topological objects is to activate the "Include Topology" option. This option includes topological objects (faces, edges, vertices), whatever the query, when performing a search and it also lets you search for objects with a color, contrary to the "Topology" search criterion. The other difference between selecting "Topology" in the Workbench list and activating the "Include Topology" option is that the "Include Topology" option will also search for objects other than topological objects. When the "Include Topology" option is activated, there is no need to select "Topology" in the Workbench list. However, bear in mind that when using this option, the search will take more time. Published elements only If you activate the "Published elements only" option, this will restrict the number of loaded elements and therefore, the number of elements on which the search will be performed. In that case, you will only see the elements that have been published (i.e. elements that have been made available to different users). For detailed information on how to publish elements, refer to "Publishing Elements" in the Version 5 - Part Design User's Guide. Deep search When working in Visualization mode (i.e. when the "Work with the cache system" option is activated in the Tools->Options->Infrastructure->Product Structure->Cache Management tab), the "Deep search" option appears in the Search interface:
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Activating the "Deep search" option lets you take advantage of the geometry selective loading: all the geometry is loaded before performing the search then when the search is over, the elements that are not required anymore are unloaded. Note that the "Deep search" option if activated by default if the "Automatic switch to Design mode" option is checked in the Tools->Options->Mechanical Design->Assembly Design->General tab. For detailed information on the cache system, refer to About Working with a Cache System. 3. Enter the name sketch* in the Name field. Searching using the object name is particularly useful if you renamed objects using the Feature properties tab of the Edit->Properties command, or the Properties contextual command. The list below the Name field stores the names you entered during previous searches so you can select them. The names are stored only as long as the session is active: closing the session clears the list. 4. Click the Search button:
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The Search dialog box is resized to include a list containing the search results at the bottom of the dialog box. You can deselect items in the list by clicking on them. In our example, three objects and the corresponding path are highlighted in the list in the Search dialog box. Click the corresponding column header (i.e. Name or Path) to sort the search results alphabetically. A query is also generated in the Query field and Sketch.3 (which is the only sketch visible, the other two are hidden) is preselected in the geometry area:
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Note: If several elements with the same name are found, whatever their type, a warning message is displayed. 5. Click the Select button to select the sketch. The sketch is selected:
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6. Click OK to exit search mode. Note that clicking OK has the same effect as clicking both the Select and Close buttons. 7. Run the Search... command once again using the Ctrl+F shortcut. 8. Display the Query pulldown list by clicking the black arrow. The Query field displays the search query formulated in the search language. This helps you to become familiar with the search language, which can be used for searching without using the Search... command. For a complete description of the search language, refer to Using the Search Language. Click the down arrow at the end of the Query field to display previous search queries. Simply selecting a search query executes the search (with the same filter). Queries are also stored across sessions because they are stored with your settings. This enables you to recover queries from one session to another. You can also use this language when you are using power input mode. The object found will be directly selected.
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9. Enter the following names in the Name field then click the Search button each time to compare the results: • *sketch gives the following result:

• *sketch* gives the following result:

• sketch* with the Case sensitive option activated gives the following result:

• Sketch* with the Case sensitive option activated gives the following result:
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As you can see it, you can use the asterisk (*) as a wildcard. For example, entering: * and using the default settings for the other options in the Search dialog box will search for and select all objects in the document. Similarly, entering: Sketch* will select all objects whose names begin with the character string "Sketch". Check the "Case sensitive" option if you want the search to be case sensitive. Note, however, that the other options allow you to filter your searches progressively. In case you want to search for a name as it is displayed in the specification tree, check the "As displayed in graph" option. To illustrate this, suppose you have a part named "My_Part_Number"...
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... whose name usually appears the following way in the specification tree:

Let's suppose you customize display in the Infrastructure->Product Structure>Nodes Customization tab by entering the following data:

The name displayed in the specification tree will now look like this:

Searching for the name *part* will give no result...
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... since the search is based on the name displayed in the Instance Name field. Whereas searching for the name *part* with the "As displayed in graph" option checked will give the following result:

You can also sort the results alphabetically by Name and Path in the Search dialog box by clicking the corresponding column header. Double-clicking an element from the search result list enables you to edit this element. For instance, double-clicking an element of type "Pad" will open the Pad Definition dialog box to let you modify its parameters.

Performing a Quick Search for a Color

1. Run the Search... command using the Ctrl+F shortcut. 2. In the Color field, select "From Element" from the pulldown list as shown below:
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As soon as "From Element" is selected, an Acquisition Agent is activated...

... and the Search dialog box disappears. 3. In the geometry area, simply click the color to be searched then click the Search button.
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Inheritance is not taken into account by the Search capability and therefore, when searching for a product with a specific color, the search may return a result which seems to have a color different from the one you specified. The reason is that, for Assembly objects, the color you see is not always the color that has been applied. For detailed information, refer to Displaying and Editing Graphic Properties. 4. Click OK to exit search mode.

Performing a Quick Search for a Type

1. Run the Search... command using the Ctrl+F shortcut. 2. Enter the name line*1 in the Name field then click the Search button to search for lines whose names end with "1":

3. Empty the value entered in the Name field then enter the workbench Sketcher in the Workbench field, the type Line in the Type field. If you select "From Element" in the Type field, the Search dialog box disappears and an acquisition agent is activated:

Just select the type you desired in the geometry area, then click Close to stop the agent and display the Search dialog box. 4. In the Color field, select "From Element" from the pulldown list then select a line from the geometry area before clicking the Search button. In our example, we are searching for lines having the same color than line 2 (i.e. "Dark Grey Green"):
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The result shows that Line.2 is the only line with "Dark Grey Green" color. button to add this query to your favorites. The 5. Click the Add to favorites... Favorites mode is detailed in another task.
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6. Click OK to validate.
More Advanced Searching Using the More... Button

1. Run the Search... command using the Ctrl+F shortcut. 2. In the General tab, click the More... button: The More... button becomes the Less... button and the Search dialog box now looks like this:

3. In the Line field, define the line properties: • Dashed (lets you choose the type of line to be searched for): choose "4" • Weight (lets you choose the line thickness): choose "48" The combo boxes of the general graphic properties are identical to those of the Graphic Properties toolbar. For detailed information, refer to Displaying and Editing Graphic Properties. You can also specify the layer and visibility in the Layer and Visibility fields:
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• in the Layer field, select the layer number in which you want to perform the search • in the Visibility field, choose either "visible" ( searches for visible elements) or "hidden" (searches for elements hidden in the No Show space). For more information about visible and hidden elements, refer to Hiding and Showing Objects. 4. Click the Search button to start the search.

The result shows that only one line matches these criteria:

5. Select the Less... button to return to the original Search dialog box.
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6. Click OK to exit search mode.
Searching Using a Filter

Open the document Search1.CATProduct. 1. Run the Search... command using the Ctrl+F shortcut or by selecting the Edit>Search... command. The Search dialog box appears. 2. Click the General tab:

3. Enter *1 in the Name field. 4. Set the filter option in the "Look:" list box. The filter options are: • Everywhere: searches the whole specification tree from top to bottom, to find objects created using all workbenches; if you are performing the search in a product structure document (in design mode), the search will
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Interacting be performed throughout the whole product structure, inside all the documents integrated in the product structure (if these documents are accessible in design mode) For example, to understand how this option works in our document: o activate "Product" in the specification tree by double-clicking it o use the CTRL+F shortcut o select the "Everywhere" option o enter the name of what you are searching for, *1 in our example to search for all objects whose names end with "1" o click the Search button:

• • • •

Now activate "My Part Number" use the CTRL+F shortcut keep the same filter and name options click the Search button:
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• In "Element": the search will only locate objects belonging to "Element", and those that can be created using the current workbench, where "Element" is the name of the active object. For example, if you are using a Part document, objects created using the Part Design workbench will be searched, but NOT objects created using the Sketcher workbench. For example, to understand how this option works in our document: o activate "My Part Number" in the specification tree o use the CTRL+F shortcut o select the "In Element" option o enter the name of what you are searching for, *1 in our example to search for all objects whose names end with "1" o click the Search button:
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• • • •

now activate "Sketch.1" in the specification tree use the CTRL+F shortcut keep the same filter and name options click the Search button:

Selecting this filter enables you to locate only the objects that can be created in the Part Design workbench and that belong to "Product". The search does not reach the lower levels in the tree: the individual elements that make up the different parts will not be searched. • From "Element" to bottom: searches the elements in the active "Element", to the bottom of the tree, regardless of the workshop used to create them. For example: • • • • • activate "My Part Number" in the specification tree use the CTRL+F shortcut select the "From Element to bottom" option enter the name of what you are searching for, *1 in our example to search for all objects whose names end with "1" click the Search button:
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• • • •

now activate "Sketch.1" in the specification tree use the CTRL+F shortcut keep the same filter and name options click the Search button:

• From current selection: this option will only be available if you already selected objects before selecting the Search... command, and searches inside the selected objects to the bottom of the tree. This is particularly useful when you know the object in which you want to search: you simply select the object, then search inside the object. For example: • • • use the CTRL+F shortcut select the "Everywhere" option enter the name of what you are searching for, *1 in our
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• • • •

now select the "From current selection" option in the result list, select Pad.1 and Hole.1 then click the Select button: Pad.1 and Hole.1 are selected in the specification tree enter the workbench Part Design and the type Hole click the Search button:

In the list box, selecting a workbench filters the list of types in the Type field: for example, if you select the workbench "Part", the Type field will be filtered to contain only the element types available in Part documents and if you select the type " ", the corresponding workbench will be displayed. The same principle applies to the other document or workbench types. If the type belongs to several workbenches, a warning message will be displayed.
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When you leave * in the Workbench field, the Type list box displays all the types corresponding to the workbenches that had been previously selected. If you want the Type list box to display all the types available, you can click the Load all types button. This button provides an exhaustive list of all the types available to you without having to select all workbenches one by one. Note that this button is also available in Advanced mode. When you select a new workbench, by default * remains in the Type field. This means that the search will be performed on all types of elements created by all workbenches. Whichever workbench is selected in the Workbench list box, you can search for element types belonging to any other workbench by typing the name of the type in the Type field. If the element type belongs to only one workbench, the correct workbench name is displayed in the Workbench list box. If you type only the first few characters of an object type, then press ENTER, the system will automatically display the full name of the type. If several types contain the same characters, the first name containing these characters is displayed. Note: the object type is NOT necessarily the name you see in the specification tree. When you choose "From Element" in the Type field then select an element in the geometry area, the system automatically displays the Workbench and Type of the selected element. • From search results: the search is performed on the list of objects preselected in the list at the bottom of the Search dialog box. To illustrate this, let's have a look at the following example: • • • • • activate "Product" in the specification tree use the CTRL+F shortcut select the "Everywhere" option enter the name *e* click the Search button:
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• • • •

now erase the name *e* select a White color select the "From search results" option click the Search button:

By default, * appears in the Color field. This means that the search will be performed on elements of any color. Select the desired color, or click More Colors... at the bottom of the color list to access the color chooser to select basic or previously custom colors, or add new custom colors. The option "From Element" lets you use the color of an existing element. To do so, select the element whose color you want to use in your search. The selected color will be displayed in the Color field.
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Refer to Displaying and Editing Graphic Properties for a full description of how to use the color chooser.

When you apply basic and custom colors to elements, and search for elements using these colors, a search query is generated. However, the RGB code is used instead of the color name for custom colors. This is useful, for example, if you modify your color palette (for example, by deleting the custom color, or deleting the color settings file in your settings folder) then retrieve a search query. Because the query references the RGB values of the color and not the color name, changes to the color palette will not affect the search: the search will always find elements referencing a color expressed using RGB values. The names of basic colors, however, remain the same. 5. Click OK to exit search mode. When the object is selected in the search result list, you can also use the "Center graph" and "Center view" contextual commands.

Selecting Using the Search... Command (Favorites Mode)
This task explains how to use the Favorites mode of the Edit->Search... command. The Favorites mode lets you save your favorite queries in order to reuse them as many times as you wish, without having to reenter your search criteria. Open the document Search1.CATProduct. This scenario assumes that you performed a quick search by type as explained in the General Mode section. 1. Select the Edit->Search... command (or use the Ctrl+F keyboard shortcut).
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The Search dialog box appears.

2. Click the Add to favorites... button then select the Favorites tab. Your query is displayed in the Favorites list. You can click the column headers to sort the queries alphabetically.
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Favorites are stored across sessions because they are stored with your settings in the SearchFavoriteQueries.CATSettings file. This enables you to recover your favorite queries from one session to another. Note that your search queries can be stored independently from the language (they are called "transformat queries"), thus enabling you to run queries created by other users whatever the session language provided that they were not created before V5R9 SP1. You can select a query then use one of the three icons displayed to move up , move down or delete this query.

3. Double-click the query to begin the search. The filter option in the Look list is automatically updated to match your search criteria. The query is also generated in the Generated queries field. Note that the generated query is not editable and is displayed for information only.
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Double-clicking a query in the Favorites mode automatically updates the data displayed under the General tab accordingly and the object is preselected in the geometry area. A query may be modified directly in the Favorites list by clicking its name or its content under the corresponding column. 4. Click the query syntax in the Query column then replace the color. "Dark Grey Green" with "Pink Salmo". 5. Click the Search button to run the search.

A warning message informs you that the color does not exist. 6. Repeat steps 4 and 5 to edit the query syntax once again but, this time,
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8. Click the query syntax in the Query column then enter the following query: NAME=Sketch*,all 9. Click the query name in the Name column then enter "MyQuery1". 10. Click the Search button:
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11. Modify the query syntax once more by entering: (NAME=Sketch* & Color=Black),in This time, we also modify the search filter. 12. Click the Search button:
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13. Click OK to exit search mode.

You can use the power entry field to run a query and modify its syntax. For instance, you can enter: favorite=MyQuery1 or f=MyQuery1

This will give a result but you may need to modify the filter option. This can also be done in the power input field by entering, for instance: favorite=MyQuery1, all or f=MyQuery1, all

The search result (Hole.1) is selected in the specification tree.
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For detailed information on the search language using your favorite queries, refer to Using the Search Language.

Selecting Using the Search... Command (Advanced Mode)
This task explains how to use the Advanced mode of the Edit->Search... command. The Advanced search mode lets you compose more precise queries using a combination of search criteria as well as the "And", "Or" and "Except" operating signs. Any information entered in the General tab is reported in the Advanced tab as well as the name of the last workbench on which you performed a search. You can record and run your search queries using macros. The recorded macro will be stored in a .CATScript file containing a transformat query, which means that the query can be run whatever the session language. For detailed information on macros, refer to Recording, Running, and Editing Macros. Open the document Search1.CATProduct.

Performing an Advanced Search for Specific Attributes

1. Use the CTRL+F keyboard shortcut or select the Edit->Search... command then click the Advanced tab:
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2. Select the workbench "Product Structure".
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3. Select an attribute for the Attribute field. Each workbench corresponds to a list of types and each type corresponds to a list of attributes, among which: • Name: indicate the name of the searched element • Name In Graph: indicate the name of the searched element as it displayed in the specification tree. This attribute is equivalent to the As displayed in graph option available from the General tab • Color: select a color from the color chooser or use the color of an existing element. Note that inheritance is not taken into account and therefore, when searching for a product with a specific color, the search may return a result which seems to have a color different from the one you specified. The reason is that for Assembly objects, the color you see is not always the color that has been applied. For detailed information, refer to Displaying and Editing Graphic Properties • Set: a selection set indicating a numeric value with the corresponding unit of measure • Visibility: indicate if the searched object is visible, shown, invisible or hidden o Visible The visibility attribute is "true". One parent of the searched element can be invisible. An object has the Visible status if the "Shown" option is checked in the Graphic tab of the Properties dialog box o Shown The visibility attribute is "true" and the whole hierarchy of the searched element is also visible. An object has the Shown status if this object and each of its ancestors have the Visible status and if this object is in the visible space. No object can have both Invisible and Shown statuses o Invisible The visibility attribute is "false". (Replaces the former "hidden" attribute). An object has the Invisible status if the "Shown" option is cleared in the Graphic tab of the Properties dialog box o Hidden The visibility attribute is "false" or one parent of the searched element is hidden. An object has the Hidden status if it is in the invisible space, i.e. if this object or at least one of its ancestors has the Invisible status • Layer: indicate the layer of the searched element. Setting this attribute to "None" means that you will search for any object which is not assigned to a layer. Note that Layer and Visibility attributes are identical to those displayed in the Graphic Properties toolbar. The above mentioned attributes are permanent attributes, i.e. associated to any element type.
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Depending on the value you select, the corresponding Attribute Criterion dialog box is displayed. In our example, select the attribute "Name" then enter the following value:

If you are searching for a character string whose value is empty, leave the field in the Attribute's criterion dialog box empty so that the query syntax looks something like this: 'workbench'.type.attribute= where "workbench" is the workbench in which you are performing your search "type" is the type of the object containing the string you are searching for "attribute" is the attribute containing the empty string. For instance: 'Product Structure'.Product.Product Description=

4. Click OK then the Search

button to run the search:
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5. Click the

button to delete your query.

You will now learn how to perform a search on specific attributes. 6. Select the workbench "Part Design" then the type "Hole". 7. Select the attribute "Diameter" then enter the value "10mm".
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8. Select the operating sign in the list box then enter a value in the field. You can also use the default value (*) as a wildcard. In our example, we selected the "=" operating sign and the value "5mm; 10mm" in order to search for any element whose diameter is comprised between "5mm" and "10mm". The number of operating signs displayed in the list depends on the attribute you chose. Here is an exhaustive list of the available operating signs: • • • • • • = ! = (different) < <= > >=

You can check the "Case sensitive" option if you want the search to be case sensitive. The attribute name appears then in capital letters in the query.

9. Click OK to validate then click the Search

button to run the search:
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Depending on the attribute you select, the Attribute Criterion dialog box may display a pulldown list of attributes. The example below shows a list of criteria corresponding to a hole type:
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This dialog box may also let you choose a boolean attribute, in case you are searching for a threaded hole, for instance:

10. Click OK to exit search mode. Note: If you select the Drafting workbench, you can search for specific attributes such as dimensions by selecting the "Dimension" value in the Type field then entering your value or scale of value in the Attribute Criterion dialog box. For example: • Drafting.Dimension.Value<=140mm searched for all objects created using the Drafting workbench, of type Dimension with a value equal to or lower than 140 millimeters • Drafting.Dimension.Value='137mm;138mm' searches for all objects created using the Drafting workbench, of type Dimension with a value between 137 and 138 millimeters. These two values are separated by "-". The Drafting workbench also lets you search for elements of type Geometry such as 2D lines, 2D curves and so on. Refer to "Edit/Search Dimension Status" in the Version 5 - Interactive Drafting User's Guide for detailed information. As far as NC Manufacturing features are concerned, refer to "Select Machinable Features Using the Search Command" in the Version 5 Prismatic Machining Preparation Assistant User's Guide.

Performing an Advanced Search for Dynamic Attributes

1. Use the CTRL+F keyboard shortcut or select the Edit->Search... command then click the Advanced tab:
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The Product Structure workbench lets you search for elements which possess certain properties (dynamic attributes) you defined for a product. You assign properties to products (and parts in products) by selecting an element from the Product property list box. The properties you can search for (the same as those you assigned to the element) are: • • • • • • Part Number Revision Definition Nomenclature Product Description Component Description.

If you type only the first few characters of a property, then press ENTER, the system will automatically display the full name of the property. Once you have chosen the property, type in the value of the property in the "of value" field. For example, if you assigned a description to the element, you must select the "Production Description" property then enter text included in the description. You can also define additional product properties such as Real, Integer, String, etc. by clicking the Define other properties... button. For detailed information, refer to "Modifying Component Properties" in the Version 5 Product Structure User's Guide. 2. Select "Product Structure" in the Workbench field, "Product" in the Type field. The query syntax is displayed in the editor:
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In our example, the Product Structure product has the following userdefined attributes:

These attributes can be visualized by selecting the product in the specification tree then then the Properties... contextual command.
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3. Edit the query manually in the editor to add to search for the attribute Real.2. You can perform your search using these four different queries: • 'Product Structure'.Product.'Real.2'=12.3 means that you will search for an attribute named "Real.2" with a value equal to 12.3 • 'Product Structure'.Product.'Real.2'='10;40' means that you will search for an attribute named "Real.2" with a value comprised between 10 and 40 • 'Product Structure'.Product.'Real.2'!='12;12.25' means that you will search for an attribute named "Real.2" with a value different than 12 and 12.25 • 'Product Structure'.Product.'Real.2'<13 means that you will search for an attribute named "Real.2" with a value lower than 13.

4. Click the Search

button once the query is edited:
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The search result indicates that Real.2 has been found in Product. You can also search for specific attributes such as materials. In our example, the "Steel" material has been applied to My Part Number. To search for this material, enter the following query: 'Product Structure'.Material.Name=Steel 5. Click OK to exit search mode.
Searching Using a Combination of Search Criteria
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1. Use the CTRL+F keyboard shortcut or select the Edit->Search... command then click the Advanced tab: The And, Or and Except buttons lets you combine several search criteria and refine your query. The query is displayed in the Generated queries field and can be modified, for example to add brackets and group queries together. 2. In our example, we are searching for holes and pads created using the Part Design workbench or whose names end with "1". 3. To do so, select "Part Design" in the Workbench field, "Hole" in the Type field then "Name" in the Attribute field (enter the value "1*" for the name). 4. Click the Or button the select "Pad" in the Type field then "Name" in the Attribute field (enter the value "1*" for the name). The query syntax is displayed in the editor:

For more information on the search language, refer to the Using the Search Language task in this guide. 5. Set the filter option in the "Look:" list box. 6. Click the Search button to start the search.

A list containing the search results is displayed at the bottom of the Search dialog box:
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You can add your query to your favorites by clicking the Add to favorites... button.

For more information on favorites, refer to the Searching Using the Favorites Mode. 7. Click the Select button to select the objects in the geometry area.
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8. If you wish to modify the query, you can do it very by typing a new query in the editor as shown below: 'Part Design'.Sketch.name!=*2 or 'Part Design'.Sketch - name=*2 means that you will search for all sketches except those whose names end with "2". Another example: 'Part Design'.Hole.name=*1 & 'Part Design'.Hole.Diameter<50mm means that you will search for all holes whose names end with "1" and whose diameters are lower than 50 mm. You can copy the one of the above-detailed queries, paste it directly to the query editor then start the search.

9. Click the Search

button to start the search.

10. Click OK to exit the search mode.

Deleting, copying, and pasting objects
Copying and Pasting Objects
This task shows you how to copy the selection and paste it to the desired location. 1. Select the object you want to copy. 2. To copy, you can either: • • • • • click the Copy icon select the Edit->Copy command use the CTRL+C keyboard shortcut select the Copy command in the contextual menu or in the geometry area or the specification tree, press and hold down the Ctrl key and drag the selection.
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Note: This places what you copy in the clipboard. 3. To paste, you can either: • • • • • click the Paste icon select the Edit->Paste command use the CTRL+V keyboard shortcut select the Paste command in the contextual menu or in the geometry area or the specification tree, drop what you are dragging (see above).

Note that: • • The application workbenches offer a variety of specific copying and pasting scenarios. Contextual features such as fillets or extracts cannot be pasted if their parent element (edge, face, etc.) has not been previously selected.

More about the Paste command

When pasting several kinds of features simultaneously, these features are be pasted with the first paste format available in the Paste Special list, provided that each of the pasted features accepts this format. Let's suppose you multi-select then paste three features: "Body.1", "Body.2" and "GeometricalSet.1": • • the Paste Special formats available in this case are "As Result With Link" and "As Result" (in order of appearance in the list of the Paste Special dialog box) "GeometricalSet.1" does not accept the "As Result With Link" format.

As a consequence, the features will be pasted "As Result". For more information on pasting object using special formats, refer to Using the Paste Special... Command.

Cutting and Pasting Objects
This task shows you how to remove the selection and paste it to the desired location.
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Keep in mind that the application workbenches offer a variety of specific cutting and pasting scenarios. Contextual features such as fillets or extracts cannot be pasted if their parent element (edge, face, etc.) has not been previously selected. 1. Select the object(s) you want to cut. 2. To cut, you can either: • • • • • click the Cut icon select the Edit->Cut command use the CTRL+X keyboard shortcut select the Cut command in the contextual menu, or in the geometry area or the specification tree, drag the selection (although not a graphical cut, this is equivalent to the cut operation).

Note: This places what you cut in the clipboard. 3. To paste, you can either: • • • • • click the Paste icon select the Edit->Paste command use the CTRL+V keyboard shortcut select the Paste command in the contextual menu, or in the geometry area or the specification tree, drop what you are dragging (see above).

More about the Cut command

When cutting new, modified or pointed documents, a warning message gives you a list of unsaved documents that will be removed and prompts you to: • • • click Yes if you want to edit these modified documents. This opens in a new window each document listed in the warning message click No if you do not want to keep the modifications click Cancel to cancel the cut operation and restore the previous state.

"Pointed documents" implies directly pointed documents as well as documents indirectly pointed by a document about to be cut. For instance, when cutting a sub-product, all the modified CATPart documents included in this sub-product will be listed in the warning. Nevertheless, note that documents may not be listed in the warning message. This is the case when a document is: • edited in another editor. For instance, if you open a CATPart document
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•

Deleting Objects
This task shows you how to delete an object. 1. Select the object(s) you wish to delete, either in the specification tree or in the geometry tree. The object(s) selected are highlighted in both the geometry area and the specification tree. 2. Select the Edit->Delete command or the Delete... command in the contextual menu. Deleting objects may lead to deleting other objects dependent on the object to be deleted. When this is the case, a dialog box appears identifying which features are impacted by the deletion, and prompting you to decide whether to delete the impacted features or not.

For detailed information on the options displayed in this dialog box, refer to "Deleting Features" in the Version 5 - Part Design User's Guide. 3. Click the More>> button when necessary for more advanced deletion possibilities:
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For instance, you can replace "Sketch.1" with another sketch. To do so, click "PartBody\Sketch.1": this displays "Sketch.1" in the Replace field and you can then select the replacing sketch in the geometry area or in the specification tree. The sketch is deleted and the name of the replacing item is now displayed in the With field as shown below:

4. When finished, select OK to confirm.
More about the Delete command

When deleting new, modified or pointed documents, a warning message gives you a list of unsaved documents that will be removed and prompts you to: • • • click Yes if you want to edit these modified documents. This opens in a new window each document listed in the warning message click No if you do not want to keep the modifications click Cancel to cancel the delete operation and restore the previous state.

"Pointed documents" implies directly pointed documents as well as documents indirectly pointed by a document about to be deleted. For instance, when deleting a sub-product, all the modified CATPart documents included in this sub-product will be listed in the warning.
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Nevertheless, note that documents may not be listed in the warning message. This is the case when a document is: • • edited in another editor. For instance, if you open a CATPart document using the Open in New Window contextual command then delete one of its instances, you will not be asked to edit the document pointed by another document edited in another editor.

Using the Paste Special... Command
Pasting Solid Objects Using the Specification Tree Pasting Surface Objects Using the Specification Tree Pasting Contextual Features and Surface Objects Using the Geometry Area General Rules for Managing the Paste Destination How Are Sub-Elements Copied?

This task explains how to use the Paste Special... command. This implies the understanding of the using this command as well as the various formats available for pasting these features. Open the CCP.CATProduct document:
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In our example, the CCP.CATProduct document contains some of the types of features you can pas command. Here is the detailed list of the features: • • • • • • • • Part body Body.n (provided that it contains a solid feature such as a pad) Pad Sketch Geometrical set Points, lines, planes, etc., i.e. surface elements Constraints Parameters.

Depending on the type of object that you are pasting, you will be able to choose between the follow • • •

• •

As specified in Part document: the object is copied as it has been created but generally For instance, surface features cannot be copied with their design specifications whereas pad As Result With Link: the object is copied without its design specifications and is linked to words, whenever the original object is modified, the copied object may be manually updated As Result: the object is copied without its design specifications and without any link with th as an autonomous entity. However, note that as far as ordered geometrical sets, hybrid bodies and part bodies are co copied As Specified in Product Structure: the source instance is duplicated and the link to the s instance of the source is created and it has the same reference as the source. For detailed i Special" in the Version 5 - Product Structure User's Guide As Specified in Assembly
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The following table sums up which feature can be pasted "as special" using which format:
Features Formats As specified in Part document As Result With Link As Result As Specified in Assembly As Specified in Prod. Structure As Result With Link Flat Mode Part body Body.n Pad Sketch Geom. set Surface feature

Para

Now let's go to copying objects!

Pasting Solid Objects Using the Specification Tree

This scenario assumes there are two documents: CCP.CATProduct, containing the elements to be c

1. Select PartBody. 2. Select the Edit->Copy command.

3. Select the Edit->Paste Special... command. The Paste Special dialog box opens and displays hereafter.
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• if you select the As Result option, a solid is created under: a body named "Body.n", n being incremented according to the number of existing bodies: or

under a body with an identical name body has been previously renamed v Edit->Properties->Feature Propertie

When the "In the main object option" is activated in the Tools->Options->Infrastructure->Part >Display tab, a solid is created under a body named "Result of BodyUserName" if the original b renamed:
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This solid can, in turn, be copied on the condition that it is pasted onto a mechanical body and in the mechanical body (in case there is no body to paste the solid, a new body will be created

Note that would you have selected a location for the copied element, the result would have bee

However, if you paste "PartBody" As Result in a new CATPart document, the result is as follows

The reason is that pasting As Result objects such as ordered geometrical sets, part bodies or h that only the final result (a solid named "Solid.1" in the example above) is copied. • if you select the As specified in Part document option:
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The object is copied with its design specifications, each component number being incremented.

In case of a solid with surface features, we recommend that you use the multi-selection to select be copied. In order to make sure to copy all the desired objects, you can use the Tools->Parent >Show Historical Graph... command to display the genealogical relationships between the differe Another method is to use PowerCopies. For more information on using PowerCopies, refer to Vers Design User`s Guide - Managing Power Copies. • if you select the As Result With Link option:

301

Interacting

The object is copied without its design specifications. The pasted object is identified by one of the •

•

a blue arrow indicates that the geometry has been pasted to the same document and is original object. The pasted object can be manually updated whenever the original object is modified. This copy is located under a body named "Body.n", "n" being incremented according to existing bodies. In case the original body has been previously renamed by the user via the Edit->Proper Properties->Feature Name command and if the "In the main object option" is activated >Options->Infrastructure->Part Infrastructure->Display tab, the copy is located under "Result of BodyUserName" a circle indicates that the geometry has been copied from a document different from the which it has been pasted.

For more information on the various referenced geometry symbols, refer to Symbols Used in the
More about solids pasted As Result with Link

• when opening a document containing a body pasted As Result with Link, the corresponding

specification tree will be . This symbol means that the pointed document has been fou correct this, select the object in the tree then the Load contextual command or the Edit-> Load button.

The symbol will then change to to indicate that the object has been copied from a doc document it has been pasted to and that it is synchronized with its reference

• if you deactivate a solid pasted As Result with Link, its symbol in the specification tree will c indicate that the external link is deactivated (the solid is isolated just like a datum) but no • when a feature is pasted As Result with Link, the color (if any) is kept. However, note that t as a synchronizable information: the color is only copied when the feature is pasted and t
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Pasting Surface Objects Using the Specification Tree

This scenario assumes that there are two documents: CCP.CATProduct, containing the elements to document. Open the CCP.CATProduct document. 1. Select Point.1. 2. Select the Edit->Copy command.

3. Select the Edit->Paste Special... command. The Paste Special dialog box opens and displays

Depending on the paste location you select, the result is as follows:

• if you select PartBody, the point is copied under the current body (if suitable), then the first available Geometrical Set if there is one. The number of the copy is incremented, 303
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In case no Geometrical Set exists, a new Geometrical Set will be created to paste the point.

• if no paste location has been previously selected, the result is identical to the one detailed a copied under the current Geometrical Set (if suitable), then the first available Geometrica whatever Paste option you choose: the point is copied under the current body (if suitable), then the first available Geometrical Set if there is one. The number suffixing the name is incremented accordingly or

in case no Geometrical Set exists, Geometrical Set is created to paste the point
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• if you copy the point to a new document using the As specified in Part document option: the point is copied under the current body (if suitable), then the first available Geometrical Set if there is one. The number suffixing the name is incremented accordingly or under a new Geometrical Set if no Geometrical Set exists
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• •

An external reference cannot be pasted As specified. If you want to paste an internal import, make sure that the geometry has been copied w otherwise you will not be able to paste it An element aggregated by a geometrical feature cannot be pasted As specified. In the e you copy Split.2 then paste it onto Geometrical Set.2, the Paste Special... dialog box wi As Result and As Result With Link options. The reason is that Split.2 is not an autonomo belongs to Split.1. However, if you copy Split.1 with Split.2, you will be able to paste both elements As spe the picture to the right) because Split.1 and Split.2 are considered as a single entity:
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If you copy then paste Split.1 As Result (or As Result With Link), only Split.1 is pasted. • if you select the As Result With Link option: the point is copied under a node named "External References" if you select the Part Body, the part itself or no destination at all or

under the Geometrical Set if you sele Geometrical Set

In both cases, the pasted element contains a green symbol indicating that it has been copied fr different from the document it is pasted to and that it is synchronized with its reference. Note: •

the Copy->Paste command is an explicit action. As a consequence, a feature pasted "As may be pasted as an external reference but will always appear in Show mode, even if th references in Show mode" has not been activated in the Tools->Options->Infrastructur
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•

Infrastructure->General tab when a feature is pasted As Result with Link, the color (if any) is kept. However, note t considered as a synchronizable information: the color is only copied when the feature is therefore, you will not be able to update it if the color of the original feature is modified

• if you select the As Result option: the point is copied under the current body (if suitable), then the first available Geometrical Set if there is one. The object number is incremented. or under a new Geometrical Set if no Geometrical Set exists:

In both cases, the pasted element contains a red symbol indicating that the pasted element is no longer be edited.

Note: pasting a geometrical set As Result is recursive, i.e. all the elements located below the g also be pasted. In the following example, when copying then pasting "Geometrical Set.1" As Result onto "Part1 the resulting copy (named "Geometrical Set.1") contains all the elements included in Geometri

308

Basic Tasks

If the "In the main object" option is activated in the Tools->Options->Infrastructure->Part Inf >Display tab, the "Result of" prefix is added to the resulting copy. In our example, it would be Geometrical Set.1".
More about pasting surface objects

•

If a surface or wireframe feature has been renamed via the Edit->Properties->Feature Prop it, this feature will be pasted as "Result of SurfaceUserName" when using the As Result or A "Copy of SurfaceUserName" when using the As Specified in Part Document format only whe is activated in the Tools->Options->Infrastructure->Part Infrastructure->Display tab. This "Copy of ..." or "Result of ..." prefix is used only if the document in which the element feature renamed "SurfaceUserName". If the name "Copy of SurfaceUserName" conflicts with the system will try to name the pasted feature "Copy (2) of SurfaceUserName" and if this n try "Copy (3) of SurfaceUserName" and so on. If the user pastes in an empty CATPart, the name "SurfaceUserName" does not conflict with kept as is. When the "No name check" or "Under the same tree node" option is activated, no prefix is a

•

If you copy then paste As Result a surface element which is not a point, a line, a surface or curve, a circle or a surface according to the geometrical dimension and the type of the elem If the dimension cannot be determined (this is the case for features containing several geom dimension such as a point and a line or a line and a plane), the result will be a 3DDatum. In the example below, when "Split.1" is copied then pasted As Result onto "Part1", the resu ("Surface.2"):
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Pasting Contextual Features and Surface Objects Using the Geometry Area

This scenario aims at explaining how to paste contextual features and surface objects by selecting In our example, we assume there are two documents: CCP.CATProduct, containing the elements to document.

Open the CCP.CATProduct document.

Contextual Features

1. In the CCP.CATProduct document, select EdgeFillet.1. 2. Select the Edit->Copy command. 3. Access the target document.

Three results may occur depending on the paste location and the elements contained in the targe

a. if you try to paste the edge fillet onto a part body with no pad, an error occurs since a fille type "Pad" to be pasted to. The following window appears:
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b. if you try to paste it to a pad with its sketch and you select one or more edges, the edge f

c. if you try to paste it to a pad with its sketch without selecting any paste location, an error edges exist and the following dialog box is displayed:
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• •

Click Edit then OK to close the Feature Definition Error dialog box In the Edge Fillet Definition dialog box opens, select the object(s) to fillet as well as the the propagation. (Refer to the Part Design documentation for more information on creat

Note that if you selected the Edge.1 line the Edit dialog box would have appeared instead of Fillet Definition dialog box to let you select the element to paste the fillet to. • Click OK to validate.

The edge fillet is pasted:

Selecting the Deactivate button results in the deactivation of the edge fillet representation, i.e. specification tree only with the following symbol:
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Selecting the Delete button amounts to clicking the Close button.

Note: As far as contextual features with multiple entries are concerned, we recommend that you copy/paste multiple elements or single elements taking multiple features as entry specifications. using PowerCopies, refer to the Version 5 Generative Shape Design User`s Guide - Managing Pow

Surface Objects

1. In the CCP.CATProduct document, select Line.1. 2. Select the Tools->Parent/Children... command:
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This window displays the dependencies between the elements to be copied.

For detailed information on the Parent/Children... command, refer to the Version 5 Generative Sh - "Parents and Children".

3. Once these dependencies are displayed, you can either select only the necessary elements select the whole Open Body before pasting them using the Edit->Paste Special... command.

General Rules for Managing the Paste Destination

Below are detailed the general rules that are applied when pasting an element using the Paste Spe • • • • •

if the paste destination you select is not appropriate, an error panel will be displayed if the paste destination is a geometrical feature, the element will be pasted after the selecte applicable) if the paste destination is a body (e.g. part body, geometrical set), the application will paste last position if the paste destination is a part o for a geometrical feature, the application will try to find a destination based on the c o for a body or a set, the element will be pasted under the part if no paste destination has been selected or if you are working with power copies, the applic in or after the current feature.

The rules that apply when creating geometrical features also apply when pasting them as shown in

Can be pasted in Geometrical set feature

Part body (created before V5R14) No Yes No

Part body (created from V5R14 onwards) No No Yes

Geometri set No Yes No

Part body Geometrical set Ordered geometrical set

As far as power copies are concerned, the rules that are applied are the following if the feature to b an ordered geometrical set: • •

if the geometrical set was located under the part as defined in the power copy, the feature i if the geometrical set was a sub-geometrical set (i.e. located under a body or under anothe according to the current feature.

How Are Sub-Elements Copied?
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if you select a sub-element such as a face, an edge or a vertex in the geometry then copy it element that can be copied and not only the sub-element itself. For instance, if you copy a face of a pad, the whole pad will be included in the copy you cannot copy a publication of a sub-element (edge, face or vertex). If you try to do so, a

Dragging and dropping icons/objects
Dragging and Dropping Icons and Objects

Dragging and Dropping Objects Onto Objects
This task explains how to drag and drop objects onto objects, which is a quick way to copy objects. Open the document DragObject.CATProduct. 1. Select the Select icon to enter selection mode, if it is not already activated.

You will select a fillet and copy it to another location on the same part. 2. Point to the element to be copied ("EdgeFillet" in our example), so as to highlight it.
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3. Press and hold down the Ctrl key and drag the fillet to another edge on the part. As soon as you point at the pad face, the face is highlighted and the pointer changes to this shape:
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4. Release the Ctrl key and the mouse button. The fillet is copied to the selected edge:
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You can also move the object, instead of copying it. To do so, simply drag the object to the new location. When you drag the object, the following symbol appears: The drag and drop method of running commands is not available everywhere: refer to your workbench documentation for more details.
More about the Drap and Drop capability

•

In certain cases, an object may be copied without pressing and holding down the Ctrl key before dragging, when you were expecting the object to be moved. In this case, you will be informed that a copy is being performed (and not a symbol. This is typically the case when move) by the appearance of the you attempt to drag an object created in one context (in one workshop) onto an object created in another context (workshop). So, within the same document window, the move is only allowed if the object onto which you drop your object can be edited in the current context (workshop). For example, you cannot drag (move) a part onto a line in a sketch: the part and the sketch were created in different workshops The behavior of the drag and drop capability may vary according to the workbench in which you are working. For instance, dragging and dropping within a .CATPart document is equivalent to cutting and pasting whereas

•
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Undoing/Redoing
Undoing Actions
This task shows you how to reverse the last action. 1. Click the Undo icon or select the Edit->Undo xxx command (or the CTRL+Z keyboard shortcut), "xxx" corresponding to the name of the last action performed. This cancels the action. 2. If you want to undo one or more actions preceding the last one you simply have to repeat step 1. Sometimes no action can be undone. When this is the case, the Undo icon is grayed out. By default, a maximum of 10 global undo actions is possible. This maximum can be changed using the Tools->Options->General>Performances setting. 3. If you want to display an history of actions that can be undone in the active document, click the Undo with history icon:
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The name of the document in which you are about to undo actions is displayed at the top of the dialog box (where you can see "Links.CATProduct"). The Undo with history dialog box lets you choose the action(s) you wish to undo from the numbered list displayed in the bottom part, the most recent action being displayed at the top of the list. Each action is identified by its name, for instance "Properties Edition" refers to the Edit->Properties command. Action names corresponding to an internal transition inside a command (e.g. "Select search results...") are followed by ... to distinguish them from global commands. If you want to undo the first action only, you just need to click the Undo button since the first action is already highlighted in the list: the action will be undone and removed from the history. Now, let's suppose you want to remove the first four actions. In that case, all you need to do is click the last action to be undone (i.e. the fourth one in our example): clicking an action implies that all former actions will also be selected and thus, undone in order to keep the history. If you change your mind and decide to undo the first two actions instead, simply click the second action in the list: only the first two actions will be selected and not the first four anymore. Bear in mind that one history is used per document ; the history of actions is not forwarded from one document to another. As a consequence, undoing actions in a document opened several times simultaneously (e.g. when opening a CATPart and a CATProduct containing this CATPart) may corrupt data. It is recommended not to undo actions in a document that has been modified in another window. button to undo all 4. When satisfied with your selection, click the Undo the selected actions. The dialog box stays open and you can keep on undoing actions if needed. 5. To close the Undo with history dialog box, click the Close button.
More about the Undo capability

• The Undo command cancels the last action only (i.e. the last single click) and therefore, if a command has been run by double-clicking, it cannot be undone using the Undo command • You can undo the UI-Activation of an object, however this will also undo any other action performed during the object activation • UI-Activation (User-Interface Activation) means that you edit or double-click an object in order to make it UI-Active (UserInterface Active). The UI-Active object appears in blue color in the specification tree 320

Basic Tasks • The Undo command does not enable you to restore the default settings (after changing them via the Tools->Options... button command). This can only be done using the Reset displayed at the bottom of the Options dialog box. For more information, refer to Resetting Default Settings Without Locks.

Redoing and Repeating Actions

This task shows you how to recover the last action undone, and repeat actions. The Redo can only be used to recover what you have canceled by performing an Undo. It cannot be used to perform actions not canceled by an Undo. 1. Click the Redo icon or select the Edit->Redo xxx command (or the Ctrl+Y keyboard shortcut), "xxx" corresponding to the name of the last action undone. 2. If you want to redo the last action more than once, simply repeat step 1 as many times as required. When there is no action to redo, the Redo command is replaced by the Repeat command, enabling you in the right conditions to restart a command that you just used. However, when a command run in repeat mode is interrupted, it will be automatically restarted afterwards and this, even if you click the Cancel button. The only way to interrupt a command in repeat mode is to select another command (such as Select, for instance). 3. If you want to display an history of actions that can be redone in the active document, click the Redo with history icon:
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The name of the document in which you are about to redo actions is displayed at the top of the dialog box (where you can see "Links.CATProduct"). The Redo with history dialog box lets you choose the action(s) you wish to redo from the numbered list displayed in the bottom part, the most recent undone action being displayed at the top of the list. Each action is identified by its name, for instance "(Paste Special)" refers to the Edit->Paste Special command. Action names corresponding to an internal transition inside a command (e.g. "Select search results...") are followed by ... to distinguish them from global commands. If you want to redo the first action only, you just need to click the button since the first action is already highlighted in the list: Redo the action will be redone and removed from the history. Now, let's suppose you want to redo the first four actions. In that case, all you need to do is click the last action to be redone (i.e. the fourth one in our example): clicking an action implies that all former actions will also be selected and thus, redone in order to keep the history. If you change your mind and decide to redo the first two actions instead, simply click the second action in the list: only the first two actions will be selected and not the first four anymore. Bear in mind that one history is used per document ; the history of actions is not forwarded from one document to another. As a consequence, redoing actions in a document opened several times simultaneously (e.g. when opening a CATPart and a CATProduct containing this CATPart) may corrupt data. It is recommended not to redo actions in a document that has been modified in another window. 4. When satisfied with your selection, click the Redo button to redo all the selected actions. The dialog box stays open and you can keep on redoing actions if needed. 5. To close the Redo with history dialog box, click the Close button. 322
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More about the Redo capability

• Some actions cannot be redone. When this is the case the Redo icon is grayed out • Sometimes, the Redo icon is not grayed out but when you run the command, no action is redone. The reason is that a modification has been registered meanwhile and therefore, no Redo action is allowed. In that case, the Redo stack is emptied after clicking the Redo icon which is then grayed out.

Managing and Sharing Data: Images, Documents and Drawings
Displaying Document Properties

This task shows you how to display properties for a document loaded in Version 5. Note: the properties displayed under the Document tab can also be accessed from the FileDesk workbench by selecting a document then the Properties contextual command. 1. Open a document in your Version 5 session. 2. Select the File->Document Properties command.

The Properti es dialog box opens:
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The following information is displayed under the Document tab: • Name of the document along with a symbol identifying the document type (a CATDrawing in our example) • Path: folder in which the document is saved • Size: size of the document are indicated • Last Change: date and time of the last modifications • Attributes: indicates if the document is read-only or not. In addition to this, the version and release number (including Service Pack number, if applicable) and the build date of the code level used for the last document save are displayed. Note that no version and build date information will be displayed: • if the document has never been saved (i.e. a new document) or if it has been saved prior to V5R10 • if the document is not a Version 5 document (for instance, a V4 model document). Some applications do not display all the properties available when the Properties dialog box is first displayed. You can click the More... button to access any other tabs: a progress bar will appear and you can either wait until more properties are displayed or interrupt the command by clicking the Cancel... button. If interrupted, the Properties dialog box returns to its original state, i.e. as if the More.... button had not been clicked. In both cases (interruption or not), the More... button then disappears. 3. Click the Standards tab to display the standards (if any) that have been defined for the documents. Standards are defined by your administrator in XML (Extensible Markup Language) files and let you set default values for element properties. In our example, we will display the standards applied to a .CATDrawing document and stored in CATDftStdLayerAndFilter.xml:
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4. Click the + sign next to the desired node to display the corresponding structure. In our example, we want to learn more about the current layer applied to the document:
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As you can see it in the above capture, the current layer applied to the document is a new layer named "My New Layer". Should you need to customize some of these parameters, you can make your modifications directly in the Standards tab or using an XML editor, provided that you are logged as administrator. For detailed information on customizing standards for layers and filters, refer to Customizing Standards for Layers and Filters in this guide. For detailed information on customizing drafting and generative standards (ANSI.xml, ISO.xml, etc.), refer to "Standards Administration" in the Version 5 - Interactive Drafting User's Guide. 5. When finished, click OK to close the dialog box.

Saving documents
Saving Documents In Other Formats
This task shows you how to save a document in another format. 1. Select the File->Save As... command. 2. In the Save As dialog box, select the location of the document to be saved. 3. Click the "Save as type:" list.
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The Save As dialog box lets you rename or delete the selected file/folder by clicking the Rename or Delete contextual command but note that: • after clicking the Delete command, a confirmation dialog box appears: click OK to delete the selected item • when renaming a file/folder, if the new name you entered is already used, the item is not renamed and a warning message is displayed. 4. Select the document type from the list displayed. For example, you might wish to save: • a Part Design or Assembly document as a STEP AP203 document (.stp): see "Exporting CATPart or CATProduct Data to a STEP AP203 File" in your Version 5 - Data Exchange Interface User's Guide • a CATDrawing document as a DXF document (.dxf): see "Exporting a CATDrawing into a DXF/DWG File" in your Version 5 - Data Exchange Interface User's Guide • a CATDrawing document as a CGM document (.cgm): see "Exporting a CGM File" in your Version 5 - Data Exchange Interface User's Guide • a CATDrawing document as a TIFF document (.tif). The list of available formats may vary depending on the context you are working in. For detailed information on all possible formats, refer to the list in Opening Existing Documents.

More about other formats
CATDrawing

You can save a CATDrawing document in: • HPGL2 format • JPEG (*.jpg) and PDF (*.pdf) format using the File->Save As... command. By default, saving a CATDrawing document in PDF format generates as many .pdf files as there are sheets. Each file name is suffixed with "_Sheet_sheetnumber.pdf", e.g. "MyDrawing_Sheet_1.pdf", "MyDrawing_Sheet_2.pdf", etc. If you want the Save As... command to generate a single .pdf file containing all the sheets of your CATDrawing document, you need to access the Graphic Formats tab. There is no need to export the "SAVE_AS_ONE_PDF" variable anymore. • as explained above, CATDrawing documents can also be saved in TIFF format using the Save As... command. However, this functionality requires external settings to be defined either by setting or exporting environment variables, or by editing an external configuration file. The environment variables you need to set or export are detailed hereafter:
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NAME

DESCRIPTION VALUE TIFF TIFFINDEX
True color uncompressed Indexed (256 colors) uncompressed Indexed (256 colors) PackBits compressed Bilevel (black and white) PackBits compressed Bilevel G4 Fax compression (default is 150.0) temp".

TIFFTCPB True color PackBits compressed

PRINT_CAPTURE_RASTERFORMAT Raster format

TIFFPB

TIFFGREY Greyscale PackBits compressed TIFFBWPB TIFFG4
PRINT_CAPTURE_DPI DPI value External path name for print/capture settings

0.0 < DPI <= 450.0

PRINT_SETTING_PATH

Set PRINT_SETTING_PATH="e:

The file e: temp CATPrint.ini will be used as configuration file. The file is saved using a print mechanism. For instance, when saving a Drafting document in TIFF format, only the sheet will be saved and not the grid and the elements outside the sheet. The file is saved using a capture mechanism. For instance, when saving a Drafting document in TIFF format, the grid and the sheet border will be saved.

PRINT PRINT_CAPTURE_MODE Save mechanism

TILED

To export a variable, run the following command: set variable_name=variable_value (e.g. "set PRINT_CAPTURE_DPI=200") (on Windows) or export variable_name=variable_value (e.g. "export PRINT_CAPTURE_DPI=200") (on UNIX) To set a variable, refer to Customizing Your Environment on Windows or Customizing Your Environment on UNIX, according to your operating system. The configuration file is named CATPrint.ini and is located by default in a temporary directory. If you wish to modify the default location, use the PRINT_SETTING_PATH environment variable as explained above. The following is a syntax example of the configuration file to save a TIFF CCITT Grp4/T6 compression file at 200.0 DPI from a CATDrawing document:
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// // Print configuration file // -----------------------// <CAPTURE_SECTION> // For RASTERFORMAT (ALL TIFF: Other for internal use) // "TIFF" * True color uncompressed TIFF file.</dd> // "TIFFTCPB" * True color PackBits compressed TIFF file.</dd> // "TIFFINDEX" * Indexed (256 colors) uncompressed TIFF file.</dd> // "TIFFPB" * Indexed (256 colors) PackBits compressed TIFF file.</dd> // "TIFFGREY" * Grey scale PackBits compressed TIFF file.</dd> // "TIFFBWPB" * Bilevel (black and white) PackBits compressed TIFF file.</dd> // "TIFFG4" * Bilevel G4 Fax compression <PRINT_CAPTURE_RASTERFORMAT>TIFFG4</PRINT_CAPTURE_RASTERFORMAT> <PRINT_CAPTURE_DPI> 200.0 </PRINT_CAPTURE_DPI> <PRINT_CAPTURE_MODE_>PRINT</PRINT_CAPTURE_MODE> </CAPTURE_SECTION>

Note: when saving a large CATDrawing format with a high resolution (i.e. > 250.0 DPI), memory and CPU consumption increase very quickly. As a consequence, generating such a raster output may be impossible on low system environments unless you work with an optimized configuration (CPU + memory).
STL

As far as STL format files are concerned, they cannot be saved using the Save As... command when working in Wireframe mode. The reason is that STL files are generated from the visualization tesselation and tesselation triangles are not available when switching to Wireframe mode.

Managing Document Save

•

Click OK to conf irm.

The Save Management... command will automatically save impacted files as well. If there are still unsaved files left when you click OK, the following message will be displayed:
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However, do not forget that two different documents open in session cannot have the same persistent location because the system cannot have two documents with the same identification. In this case, a warning will be issued and you will not be able to save conflicting documents. This may happen, for instance, when a new document has been assigned the location of another document already loaded in session (with overwrite request) either using explicitely the Save As... button, or using implicitely the Propagate Directory button.
More about the Save As mechanism

When you save a file by giving it the name of another existing file (using the Save As... command that lets you overwrite an existing file), this does not mean that the new file is identical to the original one. As a matter of fact, a file is identified by its name but also by its UUID (Unique Universal IDentifier) which differs from one file to another (except when a file is a copy of another one, for instance). To illustrate this, let's suppose a CATProduct containing two CATParts, Part1.CATPart and Part2.CATPart: 2. Product1 and the two parts it points to are saved using the Save As... button then the Product1 is closed 3. A new part is created using the File->New... command 4. The new part is saved as "Part2" in the same folder then Part2 is closed 5. When re-opening Product1, you are informed that Part2 cannot be found. The reason is that the new document saved as "Part2" has been given a new UUID when using the New... command and this new UUID is different from the one assigned to the original Part2. Therefore, the link between Product1 and Part2 is considered as broken, even if a Part2.CATPart document do exist, because the original Part2 does not exist anymore. If you want to reroute the link to the new Part2.CATPart, you need to use the Edit->Links... command then the Replace button.
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Before you start, note the following information: 3. This command is relevant for loaded documents only. For unloaded documents, use the File->Send To command. 4. This command cannot be recorded via Tools->Macro. 4. Select the File->Save Management... command. The following dialog box appears:

The Path column indicates all document that are currently used along with their paths. The State column indicates the original state of each currently used document. For instance, if a document has been modified since last load, the corresponding state (i.e. "Modified") is displayed in the State column. The Action column enables you to check the actions you are performing on your documents (save, modification, etc.). Bear in mind that the State column will keep on displaying the document original state and will not reflect the actions you performed. Below are listed the various states that may be assigned to a document: 5. New: identifies a newly created document. You have to select a file name in order to save it 6. Open: identifies a non-modified document open in your session 7. Modified: identifies a document which has been modified in your session 8. Modified by synchronization: identifies a document modified at opening in order to be synchronized with a modified pointed document 9. Read Only: identifies a modified and read-only document. You have to specify a new name for this document if you want to save it. Below are listed the actions that can be displayed in the Action column:
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4. Open Read Only: identifies a non-modified, read-only document open in your session 5. Save: identifies a document that will be saved 6. Save Auto: identifies a dependent document that will be saved.

Note that modifications made to a CATPart do not propagate to its CATProduct and have no impact on the state of the CATProduct. Therefore, a "dirty" CATPart is identified as "Modified" whereas the CATProduct it is linked to is identified as "Open". The "Enable independent saves" option lets you save documents independently regardless of any existing links between files, i.e. dependent documents will not be automatically saved when the document they are linked to is saved. 5. Select the file you want to save. 6. Click the Save As... button to open the following dialog box:
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• •

Indicate the name and destination folder of the new created file, respectively in the File name and Save in fields. Click the Save button.

When using the Save As... command for a .CATProduct document containing other modified components, these components will be assigned the "Save Auto" state and will be saved when clicking OK. However, some "document-to-document" links will not be taken into account, such as links that are not design prerequisites. For instance, when saving a .CATDrawing document pointing to a modified .CATPart document, the state of the .CATDrawing document remains unchanged. 9. Once you have saved a document in a new directory, you can use the Propagate directory button to save the files linked to this document into the same directory.
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Note that new documents with the "Auto Save" status are saved in the directory of the document selected in the list when clicking Propagate directory, Save or Save As.... If we take the above capture as an example, a new document with the "Auto Save" status would be saved in "E: users" since "Car.CATProduct" is selected.

To go back the document original state, select the document then click the Reset button.

The Save Management... command lets you save all your modified documents under a new name and a new location.

Creating a New Document for a Different Workbench
This task explains how to create a new document and activate the corresponding workbench. 10. Click the Product document in the specification tree to activate the product structure workbench. Note that the document color is blue in the tree.

•

Select the workbench using the Start menu, the "Welcome" dialog box or from the list accessed by right-clicking the current workbench icon. For example, if you select the Part Design workbench,a new Part Design document will be created in a separate window, and the Part Design workbench will be activated:
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Creating a New Workbench Document in the Product Structure
This task explains how to create a new document inside the current product structure document, and activate the workbench for the new document. • Double-click the Product document in the specification tree to activate the product structure workbench and select it.

Selecting it indicates your intention to create a new document inside the product structure. • Select the workbench using the Start menu, the "Welcome" dialog box or from the list accessed by right-clicking the current workbench icon.
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For example, if you select Part Design, a Part Design component is added to the product structure, and the Part Design workbench is activated. Note that the symbol next to "Part1" is a product structure symbol. • Expand the tree (by clicking the "+" symbol) to see the Part document itself:

Managing the image album
About Printing, Capturing Images and the Album
A certain number of identical functions are available in different parts of the software: 2. you can Capture 3. you can album 4. you can album 5. you can album. print documents, capture and print images directly from the toolbar, or print images from the album preview documents prior to printing, or preview images in the save images to other formats using the Capture toolbar or the copy images to the clipboard using the Capture toolbar or the

The fact that these functions are shared make it easy to use the print, capture and album functions together. For more information about capturing images and using the album, refer to Capturing and Managing Images for the Album.

Capturing Images for the album
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