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Ćwiczenie nr 7

Instrukcja do ćwiczeń laboratoryjnych Numeryczne metody analizy konstrukcji
Analiza statyczna obcią onego kątownika

Szczecin 1999
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Opis zadania Jest to kątownik, którego lewy otwór jest przytwierdzony (przyspawany), natomiast dolna połowa prawego, dolnego otworu jest obcią ona ciśnieniem o trapezowym rozkładzie. Zadanie jest o charakterze statycznym, z analizą w granicach liniowej sprę ystości materiału. Przykład ma na celu zademonstrowanie typowej procedury przy analizie konstrukcji z u yciem programu ANSYS.

Kątownik wykonany jest ze stali konstrukcyjnej o module Younga E=2.1·105 MPa i współczynniku Poisona ν=0.27.
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■ PREPROCESOR 1. Nadanie tytułu (maksymalnie 72 znaki) Utility Menu: 1 2 File → Change Title

Wpisz nazwę: Kątownik OK by zatwierdzić i zamknąć okno 1 2

Tytuł będzie wyświetlany w oknie graficznym (ANSYS Graphics) po przerysowaniu okna Utility Menu: Plot → Replot

2. Ustawienia preferencji Okno „Preferences” pozwala wybrać po ądaną dziedzinę analizy (strukturalna, termiczna, mechanika płynów, elektromagnetyczna) oraz jej typ (metoda h, metoda p). Main Menu: 1 2 Preferences

Włącz analizę strukturalną OK by zatwierdzić i zamknąć okno

1

2
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3. Definiowanie typu elementu i opcji W ka dej dziedzinie analizy nale y określić typ elementu (wybrać z biblioteki elementów) stosownie do danej analizy. Ka dy element jest określony przez stopnie swobody (przemieszczenia, obroty, temperatury itp.), charakterystyczny kształt (linia, kostka, belka, czworobok itd.), liczby węzłów, oraz to, czy jest rozpatrywany w przestrzeni dwu- czy trójwymiarowej. Do obecnej analizy (strukturalnej) zastosujemy jeden typ elementu, PLANE 82, który jest elementem: do analizy w przestrzeni 2D, czworobocznym (linie międzywęzłowe są stopnia wy szego), ośmiowęzłowym, stopnie swobody: UX, UY. Main Menu: 1 2 Preprocessor → Element Type → Add/Edit/Delete

Dodaj typ elementu Wybierz Structural Solid

3 4

Wybierz element ośmiowęzłowy, czworoboczny Quad 8node (PLANE 82) OK by zatwierdzić i zamknąć okno

3 2 1
4
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5 6 7 8

Definiowanie opcji elementu PLANE 82 Wybierz Plane stress with thickness OK by zatwierdzić i zamknąć okno Close - zamknij

6 5 8 7

4. Definiowanie geometrycznych cech elementu Geometryczne cechy elementu są niezbędne by w pełni opisać budowę danego elementu. Konstrukcja tylko na podstawie węzłów jest niewystarczająca. Typowymi cechami są grubość elementu (thickness), grubość powłoki (dla elementów powłokowych) i właściwości przekroju poprzecznego (dla elementów belkowych). Main Menu: 1 2 3 Preprocessor → Real Constants

Definiowanie cech OK by wybrać element PLANE 82 By uzyskać więcej informacji o definiowaniu cech elementu kliknij Help

1 8 2 7 6 3

4

Przytrzymując lewy klawisz myszy przewijaj pasek
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5

File → Exit by wyjść z okna pomocy 5 4

6 7 8

Wpisz grubość THK 5 OK by zatwierdzić i zamknąć okno Zamknij okno definiowania cech

5. Definiowanie stałych materiałowych Stałe materiałowe opisują właściwości fizyczne materiału. Zale nie od dziedziny i typu analizy wprowadzane są odpowiednie stałe materiałowe jak: - moduł Younga, - współczynnik Poisona, - współczynnik rozszerzalności cieplnej, - współczynnik przenikania ciepła itp. Stosownie do aplikacji stałe materiałowe mogą być liniowe, nieliniowe, izo- lub ortotropiczne. Mo na stworzyć wiele takich zestawów stałych materiałowych odpowiadających ró nym materiałom u ytym w rozwiązywaniu problemu. W naszym przypadku w statycznej analizie będzie potrzebny tylko moduł Younga E i współczynnik Poisona ν. Main Menu: 1 2 3 4 Preprocessor → Material Props → -Constant- Isotropic

OK dla zatwierdzenia definiowania materiału 1 Wpisz wartość modułu Younga EX = 2.1e5 Wpisz wartość współczynnika Poisona NUXY = 0.27 OK by zatwierdzić i zamknąć okno

Laboratorium z ANSYSa

6

1

2

3

4 6. Zapisanie bazy danych By nie utracić wszystkich nastawów wykonanych dotychczas zapisujemy naszą pracę Utility Menu: File → Save as... → Save Database to

Wpisz nazwę katownik.db i kliknij OK by zatwierdzić i zamknąć okno
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7. Rysowanie kątownika Istnieje kilka sposobów kreowania modelu geometrycznego. Pierwszym krokiem będzie dostrze enie w kątowniku połączenia prostokątów, okręgów i łuku. Konstrukcje te mogą być definiowane przez powierzchnie, linie i punkty bazowe. Najpierw określimy poło enie początku globalnego układu współrzędnych. Poło eniem tym będzie środek lewego górnego otworu jak na rysunku. Nie musimy definiować lokacji początku układu współrzędnych – zaczniemy definiowanie prostokąta stosownie do potrzeb. Main Menu: Preprocessor → -Modeling- Create → -Areas- Rectangle → By Dimensions

1

Wpisz X1 = 0 (u ywaj klawisza Tab do przełączania między okienkami) X2 = 60 Y1 = -10 Y2 = 10 Kliknij Apply by stworzyć pierwszy prostokąt

2

1 2 3 Wpisz X1 = 4 0 X2 = 60 Y1 = -10 Y2 = -30 OK by stworzyć drugi prostokąt i zamknąć okno

4

3 4
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8. Zmiana ustawień okna graficznego Obszary, które utworzyliśmy wyświetlane są jako dwa prostokąty (powierzchnie) o jednakowym kolorze. Aby łatwiej je rozró niać, uruchomimy opcję ich numeracji i ró nicowania kolorów. Okno Plot Numbering Controls rozwijane z Utility Menu ukazuje mo liwość zastosowania podobnych ustawień dla punktów bazowych, linii, brył, węzłów i elementów. Utility Menu: 1 2 File → Change Title

Włącz numerowanie powierzchni OK by zmienić nastawy, zamknąć okno i odświe yć ekran

1

2
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9. Zmiana układu współrzędnych z prostokątnego na biegunowy i stworzenie pierwszego okręgu Zanim zaczniemy, wykorzystajmy opcję zoom dla lepszego uwidocznienia zmian. Dokonujemy tego z u yciem „pilota” do kontroli obszaru graficznego. Utility Menu: 1 2 PlotCtrls → Pan, Zoom, Rotate

Kliknij małą kropkę by oddalić widok OK by zatwierdzić i zamknąć okno

1

2 Utility Menu: WorkPlane → Display Working Plane

Ekran graficzny jest natychmiast odświe any a główny układ współrzędnych jest wyświetlany przez symbole WX i WY. Teraz zmienimy układ prostokątny na biegunowy, zmienimy ustawienia siatki i ją włączymy. Utility Menu: 3 4 5 6 7 WorkPlane → WP Settings

Kliknij Polar (biegunowy ukł. współrzędnych) Kliknij Grid and Triad (siatka i symbol początku ukł. współrzędnych) Wpisz 1 dla przyrostu przyciągania Wpisz 1 dla przyrostu siatki Wpisz 10 dla określenia promienia siatki
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8

OK by zatwierdzić i zamknąć okno

3 4

5 6 7 8

Utility Menu:

Preprocessor → -Modeling- Create → -Areas- Circle → Solid Circle

9 10 11

Kliknij środek okręgu w WP X = 0, WP Y = 0 Przenieś kursor na początek układu współrzędnych i klikając lewy klawisz myszy narysuj okrąg o promieniu 10 OK by zamknąć okno

10 9

11
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10. Przeniesienie układu współrzędnych i stworzenie drugiego okręgu By stworzyć okrąg w ten sam sposób jak poprzednio musimy przenieść układ współrzędnych w miejsce przyszłego środka okręgu. Najprostsze będzie podanie połowy odległości między punktami bazowymi le ącymi w dolnych rogach drugiego prostokąta. Utility Menu: 1 2 3 WorkPlane → Offset WP to → Keypoints

Wybierz punkt bazowy w lewym dolnym rogu prostokąta Wybierz punkt bazowy w prawym dolnym rogu prostokąta OK dla zakończenia wybierania i przesuwania ukł. współrzędnych

1

2

4

5

Main Menu: 4 5 6

Preprocessor → -Modeling- Create → -Areas- Circle → Solid Circle

Kliknij środek okręgu w WP X = 0, WP Y = 0 Przenieś kursor na początek układu współrzędnych i klikając lewy klawisz myszy narysuj okrąg o promieniu 10 OK by zamknąć okno
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11. Łączenie powierzchni Main Menu: Preprocessor → -Modeling- Operate → -Booleans- Add → Areas

1

Wybierz Pick All by połączyć wszystkie powierzchnie

1 12. Zapisanie bazy danych Utility Menu: File → Save as Jobname.db

13. Zaokrąglenie linii Utility Menu: 1 2 PlotCtrls → Numbering

Włącz numerowanie linii OK by zmienić nastawy, zamknąć okno i odświe yć ekran

1

2
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3

OK dla zakończenia wybierania i przesuwania ukł. współrzędnych WorkPlane → Display Working Plane Preprocessor → -Modeling- Create → -Lines- Line Fillet

Utility Menu: Utility Menu: 3 4 5 6

Wybierz linie 17 i 8 OK by zakończyć wybieranie i zamknąć okno Wpisz 4 jako promień zaokrąglenia OK by utworzyć zaokrąglenie i zamknąć okno

3 3

5

6

Laboratorium z ANSYSa

14

Utility Menu:

Plot → Lines

14. Tworzenie powierzchni z linii Utility Menu: 1 2 PlotCtrls → Pan, Zoom, Rotate

Kliknij na Box Zoom Przesuń mysz w rejon zaokrąglenia, kliknij lewy klawisz i przeciągnij

1

3

2

3

3

5 6

3 4

Wybierz linie 4,5 i 1 OK by utworzyć powierzchnię i zamknąć okno
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5 6

Kliknij Fit by dopasować wielkość powiększenia Kliknij Close by zamknąć pilota Plot → Areas

Utility Menu:

15. Zapisanie bazy danych Utility Menu: File → Save as Jobname.db 16. Łączenie wszystkich powierzchni Main Menu: Preprocessor → -Modeling- Operate → -Booleans- Add → Areas

1

Wybierz Pick All by połączyć wszystkie powierzchnie

1
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17. Tworzenie otworu Utility Menu: WorkPlane → Display Working Plane

Main Menu: 1 2 3

Preprocessor → -Modeling- Create → -Areas- Circle → Solid Circle

Kliknij środek okręgu w WP X = 0, WP Y = 0 Narysuj okrąg o promieniu 10 OK by zatwierdzić i zamknąć okno

18. Tworzenie drugiego okręgu Utility Menu: Main Menu: 1 2 3 WorkPlane → Offset WP to → Global Origin Preprocessor → -Modeling- Create → -Areas- Circle → Solid Circle

Kliknij środek okręgu w WP X = 0, WP Y = 0 Narysuj okrąg o promieniu 10 OK by zatwierdzić i zamknąć okno WorkPlane → Display Workin Plane Plot → Replot

Utility Menu: Utility Menu:
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Utility Menu:

Plot → Lines

19. Zapisanie bazy danych Utility Menu: File → Save as Jobname.db

20. Odejmowanie powierzchni Main Menu: Areas 1 2 3 Preprocessor → -Modeling- Operate → -Booleans- Subtract →

Wybierz kątownik jako powierzchnię bazową Kliknij Apply Wybierz oba okręgi do odjęcia
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4

OK by odjąć powierzchnie

3

1

3

21. Zapisanie bazy danych Utility Menu: File → Save as Jobname.db

22. Tworzenie siatki sztywnych elementów skończonych Kreowanie siatki to jeden z najwa niejszych etapów rozwiązywania problemu. U ytkownik ma do dyspozycji szeroki wachlarz opcji generacji siatki. Na tym etapie wykorzystamy jednak automatyczne tworzenie siatki elementów. Main Menu: 1 2 Preprocessor → -Meshing- Shape & Size → -Global- Size

Wpisz długość boku elementu 4 OK by zatwierdzić i zamknąć okno

1

2
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Main Menu: 1

Preprocessor → -Meshing- Mesh → -Areas- Free

Kliknij Pick All

1 23. Zapisanie bazy danych Utility Menu: File → Save as Jobname.db
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■ SOLVER SOLVER jest blokiem, w którym definiuje się obcią enia (siły skupione, momenty, obcią enia ciągłe, temperatury, prędkości płynu itp.), odbiera się stopnie swobody (utwierdzanie) i rozwiązuje się zadanie. 24. Utwierdzanie kątownika Main Menu: Solution → -Loads- Apply → -Structural- Displacement → On Keypoints

1 2 3 4 5 6

Wybierz cztery punkty bazowe wewnątrz lewego górnego otworu OK by zakończyć wybieranie Wybierz All DOF (wszystkie stopnie swobody – pełne utwierdzenie) Wpisz 0 w polu wartości przemieszczenia Zaznacz rozszerzenie przemieszczenia do węzłów yes OK by zatwierdzić i zamknąć okno 1 1 1 1

3

5 6

4

Zaznaczenie rozszerzenia przemieszczenia do węzłów (KEXPND) pozwala na utwierdzenie nie tylko wybranych 4 punktów bazowych, lecz tak e wszystkich węzłów zawartych między tymi punktami (w tym przypadku na całym obwodzie otworu).
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Utility Menu:

Plot → Lines

25. Definiowanie obcią enia Prawy dolny otwór (jak ka dy okrąg) jest zdefiniowany przez 4 łuki. Zmienne liniowo ciśnienie zaaplikujemy zatem na dwóch dolnych liniach tworzących otwór (jest to wygodniejsze ni aplikowanie na elementach czy węzłach). Main Menu: 1 2 3 4 5 Solution → -Loads- Apply → Pressure → On Lines

Wybierz lewą dolną linię wewnątrz dolnego prawego otworu (linia 6) Kliknij Apply Wpisz 0.1 by określić wartość ciśnienia po lewej stronie Wpisz 1 by określić wartość ciśnienia po prawej stronie Kliknij Apply

3 4 2 5
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1

6 7 8 9 10

Wybierz prawą dolną linię wewnątrz dolnego prawego otworu (linia 7) Kliknij Apply Wpisz 1 by określić wartość ciśnienia po lewej stronie Wpisz 0.1 by określić wartość ciśnienia po prawej stronie OK by zatwierdzić i zamknąć okno

8 9 7
10

6
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26. Rozwiązanie problemu Main Menu: 1 Solution → -Solve- Current LS

Ogólne informacje o zadaniu dostępne są w oknie statutowym. By zamknąć okno kliknij File → Close

2 3

OK by rozpocząć rozwiązywanie Close by zamknąć okno informacyjne po zakończeniu rozwiązywania

2 1

3
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■ POSTPROCESOR W bloku POSTPROCESOR oglądamy rozwiązania naszego zadania. Wyniki są przedstawiane w formie graficznej, w formie tabeli lub z u yciem wykresu. 27. Wczytanie rezultatów Main Menu: General Postproc → -Read Results- First Set

28. Oglądanie wyników a) kształt kątownika Main Menu: General Postproc → -Plot Results- Deformed Shape...

1 2

Wybierz kształt okształcony i nieodkształcony OK by zatwierdzić i zamknąć okno

1 2 b) naprę enia zastępcze Main Menu: 1 2 3 General Postproc → -Plot Results- → -Contour Plot- Nodal Solution

Wybierz naprę enia Stress Wybierz naprę enia zastępcze von Mises SEQV OK by zatwierdzić i zamknąć okno
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1

2

3

c) lista reakcji podpory Main Menu: 1 2 General Postproc → -List Results- → Reaction Solution

OK by wybrać wszystkie reakcje By zamknąć okno kliknij File → Close 1

1 2
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29. Wyjście z programu ANSYS Wychodząc z programu mo na zapisać kształt geometryczny, wszystkie zadane obcią enia i dane rozwiązania zadania. Utility Menu: File → Exit 1 2 Wybierz Save Geo + Ld + Solu OK by wyjść z programu

1

2
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