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Drawing Viewer: Overview
The Drawing Viewer workbench enables you to: • • • • • • insert 2D documents manipulate 2D documents (translate, zoom, rotate) create annotated views manage annotated views export and import annotated views compare 2D documents of the following type: • cgm format (CATIA, ENOVIA-DMU Navigator and DMU Viewer) • V4 model (ENOVIA-DMU Navigator only) • dxf/dwg format (ENOVIA-DMU Navigator only) • • measure distance, angle and radius on 2D documents save and print image captures

Some functionalities depending on the type of document you open. When you open a document of one of the following types:: • • • • raster (bmp, tiff, jpeg, etc.) cdd model CATDrawing

insert, manipulate and annotated views are not available The tiff multi-page format is not supported.

Specific Toolbar Commands
Entering the 2D Workshop: In the menu bar, select File ->Open , select a document and click Open button. Inserting 2D Documents: Click the icon. In the File Selection dialog box, select a file and click the Open button. Manipulating 2D Documents: Click the document (the manipulators appear). To translate, press Left Mouse Button and drag. To zoom, click one of the corner manipulators (little squares) and drag. To rotate, click one of the arrow manipulators and drag. Creating an Annotated View: Click the icon. Using the DMU 2D Marker toolbar, create your annotations (lines, circles, rectangles, text, etc.). Click the Exit icon. Managing Annotated Views: Click the icon. In the Annotated Views dialog box, double-click the View you wish to re-invoke.
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drawingViewer Exporting and Importing 2D Annotations: Click icon. Define file name to export or import. Click save button. Comparing Drawings: Open a drawing and click the Compare Drawing icon. Select the drawing you want to compare with the reference, the second drawing is opened and compared with the first one. Measuring Distance, Angle and Radius on 2D Documents: Click the 2D Measure icon, calibrate, then make your measure. Publishing 2D Documents: Click the icon. Identify the path where you want to save the report as well as the report name then click Save.

Specific Menu Commands
Saving and Printing Image Captures In the menu bar, select Tools -> Image -> Capture. Saving a 2D Document In the menu bar, select File -> Save As. Click the selection button, select a file type and click OK to validate.

Additional Actions
Overlaying 2D Drawings: Open a .model document, click the Browse button in the Overlay dialog box, select documents and click Open.

2

What's New?
There is no enhancement.
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User Tasks
Managing Documents
Opening Existing Documents
This task shows you how to open an existing document when Version 5 is already running. Several methods are available to open an existing document: • • • • • • • File->Open... command Insert->Existing Component... command Start->Documents command on Windows Windows Explorer or My Computer (Windows) or File Manager (UNIX) drag and drop a document icon Open in New Window contextual command Open the Pointed Document contextual command

What you should know before you start
• • Bear in mind that Dassault Syst mes guarantees upward compatibility for Version 5 data As far as downward compatibility is concerned, Version 5 data can be reused from one service pack to another, provided that they belong to the same release. If the Version 5 data do not belong to the same release, they can still be reused in case of CATPart documents but this implies the use of a specific process detailed in Using the Version 5 Compatibility Batch You will not be allowed to open a document created using Version 5 if its name contains national characters or forbidden special characters. For a reminder, refer to About Filenames When a .CATPart document containing a Sheet Metal Design feature is opened on a configuration level (i.e. P1, P2 or P3) lower than the level on which the feature was created, all the icons of all the workbenches available in your configuration are grayed out. Note that this may also occur when working with Generative Shape Design or Part Design features.

• •

If you wish to access V4 data such as V4 models, PROJECT files and library objects on Windows or UNIX or access CDMA objects on UNIX you can do so provided you purchase the V4 Integration product. V4 models, PROJECT files or library objects residing on UNIX can be accessed from Windows using the http protocol. (Make sure beforehand that an http server has been installed on the computer where the V4 data resides. The address to be specified should look something like this:
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http://UNIXserver: port/V4datalocation

Using the File ->Open... Command
1. Click the Open icon keyboard shortcut). or select the File->Open... command (or the CTRL+O

The following dialog box appears:

Note: depending on the document environments you allowed in the Document settings, an additional window may appear simultaneously to let you access your documents using an alternate method. For detailed information, refer to Opening Existing Documents Using the Browse Window. 2. In the File Selection box, select the file location. 3. Click the Files of type: list.
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User Tasks

Check the "Show Preview" option to display a preview of the selected file (only on Microsoft Windows workstations).
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4. Select the document type. The list of document types you can open depends on the configurations/products installed and for which you have a license. Note: On UNIX workstations, the File Selection dialog box lets you sort your files by date or size. This dialog box also lets you rename or delete the selected file/folder by clicking the Rename or Delete contextual command. After clicking Delete, a confirmation dialog box appears: just click OK to delete the selected item. When renaming a file or folder, if the new name you entered is already used, the item is not renamed and a warning message is displayed. The following list contains all possible document types (in alphabetical order): • All Bitmap Files Lets you browse raster formats (more than 70 formats are supported) from within a session, without having to use another application • All CATIA V4 Files Lets you open V4 documents such as .model, .session or .library files • All CATIA V5 Files Lets you open V5 documents such as .catalog or .CATAnalysis files, for example • All CATIA CAA Files 8

User Tasks Lets you browse CAA files such as .CAABsk or .CAADoc files • All Standard Files Lets you browse files such as .igs, .wrl, .step or .stp files • All Vector Files Lets you browse files such as .cgm, .gl, .gl2 or .hpgl files • 3dmap Lets you browse 3dmap (i.e. spacemap representation) files. Note that you cannot open these files on AIX platforms • act Lets you browse process libraries which contain a number of different classes or types of activities interactively defined by the user. For more information, see "Managing a Process Document with Process Libraries" in the DELMIA - DPM Process Planner User's Guide • asm V4 Assembly Modeling document saved as an Assembly Design document i.e. CATProduct. For more information, see the Version 5 - Assembly Design User's Guide • bdf Allegro specific format. For more information, see the Version 5 - Circuit Board Design User's Guide • brd Mentor Graphics specific format • catalog Catalog documents. For more information, see the Version 5 Component Catalog Editor User's Guide • CATAnalysis Analysis document. For more information, see the Version 5 - Generative Structural Analysis User's Guide • CATDrawing Generative Drafting or Interactive Drafting document. For more information about the Generative Drafting and Interactive Drafting workbenches, see the Version 5 - Generative Drafting User's Guide and Version 5 - Interactive Drafting User's Guide • CATfct Feature Dictionary and Business Knowledge Template files. Refer to Starting the Feature Dictionary Editor and to the Version 5 - Business Process Knowledge Template User's Guide • CATMaterial Material library. For more information, see the Version 5 - Real Time Rendering User's Guide • CATPart Part Design document. For more information about the Part Design workbench, see the Version 5 - Part Design User's Guide • CATProcess Process document. For more information, see the Version 5 - Prismatic Machining User's Guide • CATProduct Assembly Design document. For more information about the Assembly workbench, see the Version 5 - Assembly Design User's Guide • CATShape Physical shape of the part. CATShape files can be exported to STEP or 3D
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drawingViewer IGES. For more information, refer to "Managing Shapes" in the Version 5 Product Structure User's Guide CATSystem Functional system management file. For more information, refer to the Version 5 - Product Function Definition and Version 5 - Product Function Optimization User's Guides cdd CATIA-CADAM file cgm ANSI/ISO standardized platform-independent format used for the interchange of vector and bitmap data dxf/dwg Autocad DXF and DWG formats. Creates a CATDrawing document. For more information, see "Exporting a CATDrawing into a DXF/DWG File" in the Version 5 - Generative Drafting User's Guide idf Document generated by an IDF application. For more information, see the Version 5 - Circuit Board Design User's Guide ig2 2D IGES file, saved as a CATDrawing document. For more information, see "Importing a 2D IGES File into a CATDrawing" in the Version 5 Data Exchange Interface User's Guide igs IGES file saved as a Part Design document, i.e. a CATPart document. For more information, see the "2D IGES Interface" and the "3D IGES Interface" sections in the Version 5 - Data Exchange Interface User's Guide jpg Lets you browse JPEG files from within a session, without having to use another application library V4 library document storing objects such as details, symbols, NC mill and lathe tools and beam sections. For more information, see the Version 5 - V4 Integration User's Guide model V4 model document. For more information about the V4 Integration workbench, see the Version 5 - V4 Integration User's Guide pdb PDB files picture Lets you browse CATIA Version 4 picture files from within a Version 5 session ps Lets you browse PS (PostScript) and EPS (Encapsulated PostScript) documents. Before opening a .eps document, you need to rename it with the extension ".ps". Note that to be able to modify a .ps document, you need to import it in the Drafting workbench using the Tools->Import External Format... command: this converts the document to a Drafting object which can then be edited and saved as a .CATDrawing document rgb SGI format for pixel images session V4 session document containing several CATIA V4 models converted to a

•

• • •

• •

•

• •

• • • •

• •
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User Tasks CATProduct document. For more information about the V4 Integration workbench, see the Version 5 - V4 Integration User's Guide stbom Imports a SmartBOM (Bill Of Material) Briefcase in Version 5. For more information, refer to "Export SmartBOM from Version 5" in the Version 5 Product Structure User's Guide step, STEP, stp and STP Creates a CATProduct document. For more information, see "Importing a STEP AP203 Document" in the Version 5 - Data Exchange Interfaces User's Guide stl Lets you browse stereolithography documents. For more information, see the Version 5 - STL Rapid Prototyping User's Guide and to "Exporting CATPart Data to an STL File" in the Version 5 - Data Exchange Interfaces User's Guide tdg and TDG STRIM/STYLER files tif Lets you browse TIFF files from within a Version 5 session, without having to use another application wrl Lets you browse VRML (Virtual Reality Modeling Language) files. Note that you cannot open these files on AIX platforms.

•

•

•

• • •

5. If you are sure you do not intend to modify the document in any way, you may want to open the document in read-only mode. If so, activate the "Open as read-only" option. The "Open as read-only" option is intended to prevent users from overwriting a document accidentally: when this option is activated for a document, you can read this document in your Version 5 session but you cannot save it unless you change the document path (by selecting another folder or accessing another document environment) or the document name (by entering another name in the File name field). However, keep in mind that this option does not supersede access right management functionalities provided by your operating system. When opening a document pointing to other documents with the "Open as readonly" option activated, the read-only mode only applies to the selected root document. The pointed documents will be loaded in read-write mode and may be loaded independently from the root document. 6. Click Open. In case an error occurs when opening a file (e.g. unknown document name, nonsupported file format, corrupted file, etc.), an Incident Report window opens. It displays the error history and indicates for each error its type, object and description. This history is maintained throughout the whole session, the errors being classified by degree of severity.

Using the Insert ->Existing Component... Command
11
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This command is only available in DMU Navigator. Refer to "Setting Up Your Session" and "Inserting Components" in the Version 5 - DMU Navigator User's Guide.

Using the Start->Documents Command on Windows
This task shows you how to access an existing document without running a Version 5 session. 1. Before you open a session, click Start and select Documents. 2. Select the document you wish to open. A Version 5 session is opened and your document is displayed.

Using the Windows Explorer or My Computer (on Windows) or the File Manager (UNIX)
This task shows you how to open an existing document via a document icon when no Version 5 session is already running. 1. Before you open a session, click My Computer or run the Windows Explorer and find the location of the document you wish to open. 2. Double-click the document icon. A Version 5 session is opened and your document is displayed. On UNIX, you can use the File Manager.

Dragging and Dropping a Document Icon
This task shows you how to open an existing document via a document icon when a Version 5 session is already running. 1. If a Version 5 session is already open, drag and drop the icon in your Version 5 application window. Your document is opened for editing. Note that this method is not available on IRIX.

Using the Open in New Window Contextual Command
This task shows you how to open an existing document in a new window. 1. If a document is already open in a Version 5 session, select the item you wish to open from the specification tree.
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2. Right-click then select the xxx object-> Open in New Window contextual command. The document associated to the selected item is opened in a new window. More about the Open in New Window command

•

•

In CATIA V5, each window is associated to a document. As far as volatile documents are concerned, they cannot be opened using the Open in New Window command (an error message is issued). For instance, you cannot open in a new CATIA V5 window a Product Root Class created in ENOVIA V5 because a "PRC" is an ENOVIA V5 concept which has no equivalent in CATIA V5 If you modify a document open in a new window then decide not to save the modification when closing the new window, this does not imply that the modification will not appear in the parent window: it only means that the document will not be saved at the end of the session. The reason is that the modification you made has been loaded in memory. Therefore, after closing the new window, the only way to restore the document in the parent window is to use the Undo command.

Using the Open the Pointed Document Contextual Command
This task shows you how to open a pointed document in a new window. 1. If a document is already open in a Version 5 session, select the item pointing to a referenced document from the specification tree. Note: this command is available for geometrical external references and external parameters only. For instance, you will be able to use this command when selecting a geometry pasted "As Result With Link" in a CATPart document different from the one in which it has been copied (the geometry is identified by the following symbol: ). 2. Right-click then select the xxx object-> Open the Pointed Document contextual command. The document pointed to by the selected item is opened in a new window.

Saving a 2D Document
You can save 2d documents in any of the following formats: • cgm
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drawingViewer • • • gl gl2 hpgl

You must have opened a 2d document. See Entering the 2D Workshop. 1. In the menu bar, select File -> Save As. The File Selection dialog box appears. 2. Optionally modify the name of the document. 3. Click OK to validate. The file is saved. Note: The file can only be saved with the same file type as the opened document.

Inserting 2D Documents
The Insert 2D Document command enables you to load a 2D document into the current session. It is also possible to insert multiple documents. 1. In the DMU 2D Tools toolbar, click the Insert 2D Document icon The Insert Document dialog box appears.

14

User Tasks 2. Select the CompleteDrawing.cgm file from samples folder and click the Open button. The document is loaded into your session. You can insert multiple 2D documents of the following types: • • • • • • cgm dxf, dwg GL, GL2 HPGL CATDrawing (DMU Navigator only) V4 Drawing (.model) (DMU Navigator only)

Publishing
A number of tools let you prepare html reports that you can publish on the enterprise intranet or the Internet for collaborative communication. You can for example take a snapshot of a clash conflict detected during your review, add appropriate comments or annotations and even select parts to insert as a VRML link. This task explains how to publish reports. Insert all the cgr files from the samples folder. 1. In the menu bar, select Tools -> Publish -> Start Publish. The Select Publish File dialog box appears.

2. Identify the path where you want to save the report as well as the report name then click Save. The Publishing Tools toolbar appears. Note: Reports are published in html format. The date created and the person who created the report are indicated.

.
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3. Click the Feature Publish icon publish in the specification tree.

, then select the feature you want to

The DMU features you can publish are the following: • • • simulations interferences URL

in the Publishing Tools 4. When done, click the Stop Publish icon toolbar or select Tools -> Publish -> Stop Publish. You can use other Publishing Tools commands to add a comment or take snapshots, for example. 5. Click the Snapshot icon to insert a screen capture into your report.

to add a comment. 6. Click the Text icon The Publish Text dialog box appears. 7. Enter your comment then click OK.

8. Take other snapshots. 9. Select one or more products then, in the Publishing Tools toolbar, click the VRML icon to insert selected components as a VRML link.

Note: In the DMU Mock-up 2D Workshop, the VRML command is not available. 10. When done, in the Publishing Tools toolbar, click the Stop Publish icon or select Tools -> Publish -> Stop Publish. The published report is automatically displayed if you set the Browser automatically opened option in the DMU Navigator Settings (Tools -> Options -> Digital Mockup -> DMU Navigator).

16
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Clicking the images in the html page enlarges them.

Publishing 2D Documents
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drawingViewer You can publish the results of your annotated views and your comparisons icon in the DMU 2D Tools between documents using the Start Publish toolbar. All publishing commands, except the VRML link command, are available.

1. In the DMU 2D Tools toolbar, click the Start Publish icon For details on using the Publish functionality, see Publishing.

.

Saving and Printing Image Captures
You can save and print image captures of your 2D documents. This enables you to save and eventually communicate your annotated views and your comparisons between 2D documents to other users. 1. In the menu bar, select Tools -> Image -> Capture.

2. The Capture toolbar appears.

18
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2. To save in pixel format, click the Pixel Mode icon Save As icon

and then click the

3. To save in vectorial format, click the Vectorial Mode icon click the Save As icon 4. To print your 2D document, click the Print icon

and then

For detailed information on using the Capture toolbar, including the save and print functionalities, see Capturing and Managing Images for the Album in the Infrastructure User's Guide.

Annotating 2D Drawings
Creating an Annotated View
You create an annotated view by: • • • invoking the dedicated toolbar creating the desired annotations exiting the dedicated toolbar

1. In the DMU 2D Tools toolbar, click the Create an Annotated View icon . The DMU 2D Marker toolbar appears.

and drag a 2. To create a line annotation, click the Draw Line icon straight line in the 2D document from one endpoint to the other of the line you wish to create. and 3. To create a free-line annotation, click the Draw Free Line icon drag freely in the 2D document along the path of the line you wish to
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drawingViewer create. 4. To create a circle annotation, click the Circle icon and drag a straight line in the 2D document from the point that will be the center of the circle you wish to create to a point that will be on the circle's circumference. and drag a 5. To create an arrow annotation, click the Arrow icon straight line in the 2D document from one endpoint to the other of the arrow you wish to create (the arrow's head will appear at the terminal point of the line you drag). and drag 6. To create a rectangle annotation, click the Rectangle icon a straight line in the 2D document whose endpoints will designate the diagonal of the rectangle you wish to create. and click in the 2D 7. To create a text annotation, click the Text icon document at the point at which you wish to insert the text. The Annotation Text dialog box and the Text Properties toolbar appear:

• Enter the desired text in the 2D text box and click Apply. • Change the size and style of annotation text if desired and click Apply. • When done click OK. The text is added at the designated point. and click in the 8. To insert a picture annotation, click the Picture icon 2D document at the point at which you wish to insert the picture. The Select Picture File dialog box appears. • Browse to the desired images folder. 20

User Tasks • Select the desired document from the images folder and click OK.

The picture is inserted at the designated point. For more details, see Adding Pictures. 9. To create an audio annotation, click the Audio icon The Select audio File dialog box is displayed. • Browse to the desired folder. • Give a meaningful name to the to-be recorded file and click Open. The Audio attributes dialog box and Audio Recorder dialog boxes appear. • Select the audio quality and click OK. • To start recording, in the Audio Recorder dialog box , click the red button. • To stop recording, click the stop button. • When done recording, click OK. • To replay the audio annotation, click the Audio icon and click the Play button in the Audio Recorder dialog box. For more details, see Adding Audio Markers. 10. To erase all annotations, click the Erase icon . . .

11. To exit your annotated view, click the Exit Annotated View icon An new annotated view is created. You can access all previously created annotated views by hitting the Manage Annotated Views icon . See Managing Annotated Views.

Managing Annotated Views
At any time, you can access the different annotated views you've associated to your 2D document. Open the CompleteDrawing.cgm from the samples folder. You've already created one or more annotated views.
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1. In the DMU 2D Tools toolbar, click the Manage Annotated Views icon The Annotated Views dialog box appears.

2. Double-click the view you wish to work with. The chosen view becomes the active view. All of the annotations that you previously created in that view will be visible.
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Creating Annotated Views
You can draw straight lines, freehand lines, circles, arrows and rectangles. You can create complex annotations by combining several objects as well as include text in document views. You can even insert pictures (tiff, jpg, bmp, rgb) and audio markers. This task explains how to annotate your documents. Insert all the cgr files from the samples folder: ATOMIZER.cgr BODY_1_2.cgr BODY_2_2.cgr LOCK.cgr NOZZLE_1_2.cgr NOZZLE_2_2.cgr REGULATION_COMMAND.cgr REGULATOR.cgr TRIGGER.cgr VALVE.cgr To annotate documents, you must be in an active view. Objects drawn are associated with the active view and , by default, will no longer be visible if the view is changed via rotate (translate and zoom are not considered changes to the view and therefore they do not impact the visibility of annotations). However, there is a new option that allows you to "Unlink" the annotations of an annotated view, thereby enabling you to rotate the view without losing the associated annotations: • • Select the view in the Specification Tree Right-click and select Link / Unlink in the contextual menu.

You can also add 2D annotations in active views in the Section viewer for example. Annotations are no longer visible if you change viewer.
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1. Click the Create an Annotated View toolbar.

icon in the DMU Review Creation

The 2D view is created and identified in the specification tree. The DMU 2D Marker toolbar is activated. You can now annotate your view.

2. Click the appropriate icon in the DMU 2D Marker toolbar to draw straight lines, freehand lines, circles, arrows or rectangles. 3. Put the cursor where you want to start the object, then click and drag to draw the object: • • • • To draw a straight line, click at the start of the line and drag from the beginning to the end of the line. To draw a circle or a rectangle, click at the start of the object and drag diagonally across the area in which you want the object to appear. To draw an arrow, click at the start of the arrow and drag from the beginning to the end of the arrow. To draw a freehand line, click at the start of the line and drag the cursor along the path of the line.

You can move and resize 2D markers easily. All you need to do is drag the green manipulators attached to the marker selected.
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4. In the Specification Tree, right-click View.1 and select View.1 object -> Link / Unlink in the contextual menu. The annotations you just created will no longer be linked to the view.

25
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5. Rotate the view. The annotations you created will still be visible. 6. To link the annotations once again to the view, repeat step 4.

7. Click the Text

icon to annotate your view with text.

8. In the view, click where you want to place the text. The Annotation Text dialog box and the Text Properties toolbar appear:
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You can configure your DMU Navigator so that, when creating 2D text annotations, the Part name will automatically be the default annotation. • • • In the menu bar, select Tools -> Options and then select the DMU Navigator tab. Click the 2D Marker Part Name Recognition radio button to activate the option. icon to add a text In your DMU Navigator session, click the Text annotation and click on a Part on which you wish to place the annotation (e.g. NOZZLE_1_2(NOZZLE_1_2.1).

That Part's name will automatically be the default annotation.

27

drawingViewer Inserting Symbols in Annotated Views (on Windows only) You can insert symbols in annotated views. Click the arrow in Text Properties dialog box and select a symbol from those proposed:

9. Enter the desired text in the 2D text box and click Apply. 10. Change the size and style of annotation text if desired and click Apply. 11. When done click OK. The text is added at the desired position. 12. To edit existing text, simply double-click. 13. To change the Text properties, right-click the 2D text in the geometry and select Properties from the contextual menu displayed. You can add more than one line of annotation text. Double-clicking the Text icon in step 7 above will cause the first annotation text that you define to be conserved by default at each successive point at which you click. You exit from the loop by clicking the Text icon with a simple-click.
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13. Make the desired changes, e.g. add a frame or change the text orientation. Line thickness can only be modified for font type STROKE. For all other font types, modifying the line thickness will have no effect.

Rotating 2D Text Annotations Define the Angle parameter to be the number of degrees you wish to rotate the text annotation by entering the value in the Angle text-entry field or by clicking the value selection buttons. 14. When satisfied, click OK. Modifying Annotation Properties

29
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15. Select the Select

icon to enter the selection mode.

16. Right-click another object you've already drawn and select Properties from the contextual menu, or click the object then select Edit -> Properties from the menu bar. The Properties dialog box appears. Note: Dynamic highlighting as you move your cursor over objects helps you locate them.

17. Click the Graphic tab to display the graphic properties of the current object. 18. Make desired changes (You can change the color, line type and line weight of the selected object.) 19. Click OK when done.

Defining the 2D default markers properties in the Tools->Options->DMU Navigator sets the selected properties as default properties and changes how new annotations will look when you create them.
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User Tasks Exporting and Importing 2D Annotations in an XML file 20. To export 2D annotations, in the Specification Tree, right-click View.1 and select View.1 object -> Annotated Views file export in the contextual menu. The Annotated Views file export dialog box appears.

21. Browse to the folder in which you wish to save the xml file containing the annotations. 22. In the File name text-entry field, enter the name of the file. 23. Click the Save button. 24. To import 2D annotations, in the menu bar, select Insert -> Annotated Views file import. 31

drawingViewer The Annotated Views file import dialog box appears.

25. Browse to the folder from which you wish to import an xml file containing annotations. 26. Select the desired file and click the Open button. The annotated view contained in the xml file will be added to the annotated views listed in the Specification Tree. Copying an Annotated View 27. To copy an annotated view, right-click the annotated view, select Copy in the contextual menu, right-click on the object in the specification tree under which you wish to copy the annotated view and select Paste in the contextual menu. Note: The copy of the annotated view will have the same name as the original annotated view. Deleting Annotations 28. To delete all annotations in the current view, select the Delete All Annotations icon .

You can also delete individual markers by right-clicking the object and then selecting Delete from the contextual menu.

Exporting and Importing 2D Annotations

32

User Tasks You can export your 2D annotations to other users in an XML file. Likewise, you can import 2D annotations that other users have sent you. You have opened a 2D document and created an annotated view. To export 2D annotations
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1. In the DMU 2D Annotations toolbar, click the Import icon The Annotated Views file export dialog box appears.

.

2. Browse to the folder in which you wish to save the xml file containing the annotations. 3. In the File name text-entry field, enter the name of the file. 4. Click the Save button.

To import 2D annotations

1. In the DMU 2D Annotations toolbar, click the Import icon The Annotated Views file import dialog box appears.

.
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2. Browse to the folder from which you wish to import an xml file containing annotations. 3. Select the desired file and click the Open button. The annotated view contained in the xml file will be added to the annotated views listed in the Specification Tree.
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Analyzing 2D Drawings
Comparing Drawings
The Digital Mock-up 2D workshop lets you run a 2D comparison on the following: • • • • • cgm format (CATIA, ENOVIA-DMU Navigator and DMU Viewer) CATDrawing format (ENOVIA-DMU Navigator only) V4 model (ENOVIA-DMU Navigator only) dxf/dwg format (ENOVIA-DMU Navigator only) raster formats (bmp, jpg, tiff, rgb, pcx, etc.)

This task explains how to compare two versions of the same drawing to highlight the differences and check for changes.

You can now compare and calibrate raster drawings. You can now compare vectorial drawings using resizing and offset values. You can now also compare raster drawings using resizing and offset values. You can now modify the colors used when comparing vectorial drawings. Open the Comparedrawings1.cgm from the samples folder. 1. Select File ->Open and open Comparedrawings1.cgm. The Digital Mock-up 2D workshop is opened and displays the selected drawing. This is the reference to which the second drawing will be compared.
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2. Click the Compare Drawing icon in the DMU 2D Tools toolbar. The Select Drawing dialog box appears letting you choose the drawing you want to compare with the reference drawing. 3. Select the drawing you want to compare, for example Comparedrawings2.cgm and click Open. The second drawing is opened and compared to the first. The Compare Drawing dialog box appears. Selected drawings are identified in the dialog box.
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Color coding: • • • Elements in drawing 1 only appear in red Elements in drawing 2 only appear in green Elements common to both drawings appear in blue

These colors can be modified: • • click the corresponding selection button of the color you wish to modify choose a color from the proposed list

Note: Colors cannot be modified for raster format drawings.

4. Click appropriate options in the dialog box to visualize drawing 1 or drawing 2 only, or to compare drawings. 5. (Optional) Click Calibrate to align drawings for easier comparison. In our example, this is not necessary. Note: You need to return to the Compare Drawing option before calibrating. The Calibrate dialog box appears.
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To calibrate by superimposing: • • • • • Click the Calibration by superimposing radio button. Select a reference line or axis in one of the drawings. Select a line or axis in the other drawing that you want aligned to the reference. Click Reverse to change the direction. Click OK.

The two drawings are aligned as defined.
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To calibrate by resizing: • • • Click the Calibration by resizing radio button. Modify the width and height of the drawings as desired. Click OK.

The two drawings are resized as defined.
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To calibrate by offset: • • • Click the Calibration by resizing radio button. Enter offset values for the X-axis and the Y-axis. Click OK.

Drawing 2 is offset as designated.
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6. Click Close in the Compare Drawing dialog box when done.

Measuring Distance, Angle and Radius on 2D Documents
This task explains how to measure distances, angles and radii on 2D documents of both vector and pixel type. Note: In the No Show space, this command is not accessible. No sample document is provided. 1. Select File -> Open and open a 2D document. The Digital Mock-Up 2D workshop is opened and displays the selected document. You can measure distance, angle and radius on documents in vector formats such as cgm, hpgl as well as in raster formats such as jpeg, bmp. For more information on: • • 2. 2D documents you can open, see Inserting Components in the DMU Navigator User's Guide. DMU 2D workshop, see the DMU Navigator User's Guide.

Click the 2D Measure

icon in the DMU 2D Tools toolbar.
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User Tasks The 2D Measure dialog box appears. An automatic calibration, based on the width of the drawing, is proposed for vector type documents. The dialog box opens directly in the Measure mode. Click Calibration to visualize the reference distance (green arrow) and adjust the calibration if necessary. All measures will be made with respect to this reference. For pixel type documents, calibrating is necessary to make measures and the dialog box opens in the Calibration mode. • To calibrate, click two points to define the reference, then enter a distance in the Calibration field. Click the Measure check box to make your measure.

•

Note: The appearance of the cursor has changed to assist you. A number also helps you identify where you are in your measure or calibration. Calibration and distance measure cursor: Angle and arc measure cursor:

3.

Set the desired Measure type in the Measure type drop-down list box.
Defining Measure Types

• • •

Distance: measures the distance between two points. Angle: measures the angle defined by three points. Arc: measures the angle and radius of an arc fitted through three points.

43

drawingViewer

4.

Click to define the points between which the measure is made. The cursor snaps to vector elements in vector-type documents. The dialog box is updated and gives the appropriate information depending on the type of measure made.

5.

Click Close when done. The calibration value and reference distance are stored in memory and are re-proposed if you enter the command again whilst in the same document.
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DMU Navigator Menu Bar
This section presents the menu bar tools and commands dedicated to the DMU Navigator workbench Start File Edit View Insert Tools Analyze Windows Help

View
For... See... Selecting standard views using the Viewpoint Palette Viewpoint Palette... Panning, zooming, rotating and turning head using the Viewpoint Palette

Scene specification... Modify -> Previous View Modify -> Next View

Creating Scenes Changing Views

Changing Views

Modify -> Look At Looking At Objects Named Views... Using Camera Capabilities Using Standard Views Creating, Modifying and Deleting UserDefined Views Navigation Mode - Navigating in > Examine Mode
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For...

See...

Navigation Mode - Navigating in Walk > Walk mode Navigation Mode - Navigating in Fly > Fly Mode Lighting... Depth Effect... Ground Setting Lighting Effects Setting Depth Effects Viewing Objects against the Ground Magnifying

Magnifier...

Insert
For... See...
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For... Review Annotated View 3D Annotation Hyperlink Group Enhanced Scene Presentation

See... Creating a Review Annotating Adding 3D Annotations Creating Hyperlinks Defining Groups Creating an Enhanced Scene DMU Presentation

Sectioning Simulation Annotated Views file import Import Applicative Data New Technological Package New Component New Product New CDM Component

Sectioning Recording Animations Creating Annotated Views Importing Applicative Data

Product Structure User's Guide Product Structure User's Guide Integration User's Guide
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New Part... Existing Component...

Product Structure User's Guide Inserting Components

Tools
For... Options See... General DMU Navigator Product Visualization Multiprocess Settings Cache Management Product Structure Navigation External Formats

Conferencing Conferencing Backbone Connection Initializing Backbone Driver

Publish

Publishing Loading Products into DMU Navigator

Cache Content

Managing the Cache Content
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Move

Translate or Rotate

Translating components Rotating components Snapping Components Assembly and component mirroring Reset component position

Snap

Create symmetry

Reset position Simulation Convert Simulation Generate Replay Generate Video Replay Gantt Chart

Converting a Simulation Recording Animations Generating a Video Replaying Animations

Import N4D Scene

Importing N4D Scenes in a DMU Navigator Session Modifying the Sag Value Visualizing CATIA V4 Layer Filters

Modify Sag CATIA V4 Layers Filters

Analyze
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For...

See...

Graphic Messages Using Temporary Markers Measure Between Measuring Between Measure Item Measure Inertia Measuring Properties Measuring Inertia

Toolbars
DMU 2D Annotated Views Toolbar

See Creating an Annotated View See Managing Annotated Views See Export 2D Annotations See Import 2D Annotations

DMU 2D Move Toolbar

See Manipulating 2D Drawings See Manipulating 2D Drawings

DMU 2D Viewing Toolbar
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See Changing Views See Changing Views See Magnifying
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DMU 2D Workshop

This task explains how to customize the background color of your 2D Workshop session.

Accessing DMU 2D Workshop settings
1. In the menu bar, select Tools -> Options. The Options dialog box appears. 2. Click the Digital Mockup category. 3. Click the DMU 2D Workshop tab.

The DMU 2D Workshop settings page concerns the following settings categories: • Background

Background

Graduated color background
If you wish the background color to be graduated, click the Graduated color background selection box. By default, this option is unchecked.

Background color
Click on the combo-box selection button and choose the desired standard color from the proposed list.
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drawingViewer By default, this option is valuated to White.

Confirming chosen options
4. When you have finished customizing options, click OK to confirm.
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