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Overview
This book is intended for the user who needs to become quickly familiar with Knowledge Advisor. This overview provides the following information: • • • • • Knowledge Advisor in a Nutshell Before Reading this Guide Getting the Most out of this Guide Accessing sample documents Conventions Used in this Guide

Knowledge Advisor in a Nutshell
CATIA - KNOWLEDGE ADVISOR is a CATIA product which allows users to embed knowledge within design and leverage it to assist in engineering decisions, in order to reduce errors or automate design, for maximum productivity. Users can embed knowledge in design such as formulas, rules and checks and leverage it when required at any time. Knowledge is then taken into account and acts according to its definition. Its meaning is also accessible: For example a check intent can highlight the parameters involved in a verification, it is easy and immediate to understand in what way a standard has been violated. In short, Knowledge Advisor enables users to: • Capture corporate engineering knowledge as embedded specifications allowing complete consistency. • • • • • • • • Easily define and share know-how among all users. Automate product definition. Ensure compliance with corporate standard. Increase productivity. Increase Knowledge management for sharing and understanding intents. Build Knowledge components management for customization and reuse. Allow early attention to final design specifications preventing costly redesigns. Guide and assist users through their design tasks.

1

knowledgeware

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 and the interoperability between workbenches.

Getting the Most out of this Guide
To get the most of this guide, we suggest that you start performing the step-by-step Getting Started tutorial. Once you have finished, you should move on to the User Tasks section. The Workbench Description section, which describes the Knowledge Advisor workbench, and the Customizing section, which explains how to set up the options, will also certainly prove useful.

Accessing sample documents
To perform the scenarios, you will be using sample documents contained in either the online/kwrug/samples folder. For more information about this, please refer to Accessing Sample Documents in the Infrastructure User's Guide.

Conventions Used in this Guide
To learn more about the conventions used in this guide, refer to the Conventions section.
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What's New?
New Functionality
Assigning a Comment to a Knowledge Feature This new functionality enables you to edit the text displayed in the contextual bubbles when you drags your mouse over a Knowledge Feature.
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User Tasks
Parameters
Introducing Parameters
• • • • • Displaying Parameters in the Specification Tree Parameters and National Support Languages Editing a Parameter Hiding a Parameter Working with External Parameters

When you create a part like a hollow cylinder, you often start by creating a sketch, then you create a pad by extruding the initial sketch, then you add other features to the created pad. The final document is made up of features which define the intrinsic properties of the document. Removing one of these features results in a modification of the document. These features are called parameters. Parameters play a prominent role in Knowledgeware applications. They are features that can be constrained by relations and that can also be used as the arguments of a relation. In addition to these parameters, CATIA allows you to create user parameters. These user parameters are extra pieces of information added to a document. User parameters are very handy in Knowledgeware applications: • They can be used to add specific information to a document • • They can be defined or constrained by relations They can be used as the arguments of a relation.

A given relation may take as its arguments both types of parameters (intrinsic and user).

Displaying Parameters in the Specification Tree
The user parameters are displayed in the specification tree provided you check the Parameters box in the Display tab in the Tools->Options->Infrastructure->Part Infrastructure dialog box. The user parameter list contains at least the Material parameter. The initial value of the Material parameter is set to None. In addition, parameters can be displayed with their values provided you check the With Value box below the Parameter Tree View settings in the Tools->Options->General->Parameters and Measure dialog box

Parameters and National Support Languages
CATIA users working with non-Latin characters should check the Tools->Options->General>Parameters and Measure->Parameter Names->Surrounded by' option. Otherwise, parameter names should have to be renamed in Latin characters when used in formulas.
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Editing a Parameter
You can access a parameter contextual menu by right-clicking this parameter in the specification tree. The Definition... command enables you to access the Edit Parameter window where you can edit the parameter value. The Edit formula... command enables you to access the formula editor to add a formula to the parameter. The Hide command enables you to hide the parameter. In this case, it will not display in the specification tree. The Reorder... command enables you to reorder parameters. The Lock... command enables you to lock the parameter. When working with parameters of Length and Angle type, you can also use the Create Equivalent Dimensions command. To know more about this command, see Getting Familiar with the Equivalent Dimensions Interface or Using the Equivalent Dimensions Feature.

Hiding a Parameter
You can hide a parameter by right-clicking this parameter in the specification tree and by selecting the Hide command. • A visual indicator located at the parameters set level indicates that the set contains hidden parameters. Note that this indicator is not recursive. If you try to delete a parameters set containing hidden parameters, a message is displayed asking if you want to delete the parameters set that contains hidden parameters. Note that if you try to delete a parameters set containing another parameters set with hidden parameters,

•
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the message will be displayed.

Working with External Parameters
External parameters are parameters that point parameters located in another document. There are 2 types of external parameters depending on their links: • • Reference link type: Both parameters are located in 2 different documents. Contextual link type: Both parameters are located in 2 different documents located in the same assembly.

External Parameters Contextual Menu
You can access the external parameters contextual menu by right-clicking the external parameter in the specification tree. Note that these functionalities can also be accessed in the Edit links dialog box. Hide: Enables you to hide a parameter. In this case, it will not display in the specification tree Reorder: Enables you to reorder parameters (if you have created more than 1 external parameter.) Lock: Enables you to lock an external parameter. Open the Pointed Document: Enables you to open the pointed parameter. Isolate: Enables you to isolate the parameter. Activate/Deactivate: Enables you to activate/deactivate the parameter. To know more, see Deactivating and
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Activating External Parameters.

Creating a Parameter
This task explains how to create a Time type parameter and assign a value to it. 1. Open the KwrStartDocument.CATPart document. 2. Click the icon. The f(x) dialog box is displayed.

3. Select the Time item with Single Value in the New Parameter of type list, then click New Parameter of type. The new parameter appears in the Edit name or value of the current parameter field. 4. Replace the Time.1 name with Machining_Time and assign the 1000s value to this parameter. Then click Apply. The Machining_Time parameter is added to the specification tree. The dialog box is modified as follows:

5. 6. Click OK when done to close the dialog box. • You can add properties to a .CATPart or a .CATProduct document by using the Properties command from the contextual menu. You just have to click the Define other properties... button in the Product tab then click New parameter of type. The dialog is similar to the f(x) dialog. See the Product Structure User's Guide for more information. The properties you define that way are also displayed in the parameter list of the f(x) dialog box. You can specify that a parameter is constant by using the Properties command from the contextual menu. This command

•
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also enables you to hide a parameter.

Copy/Pasting Parameters
The Tools->Options->General->Parameters and Measure check boxes allow you to: • Paste a parameter without the formula which defines it. For example: Holeplus= 15 = Diameter + 10 will be pasted as Real.i = 15 (if the With Value box is checked)

•

Paste a parameter as well as the formula which defines it, but only if the parameters referred to in the formula are also selected in the copy. For example: Holeplus= 15 = Diameter + 10 will be pasted as Real.i = 15 if the Diameter parameter does not belong to the items selected for the copy but HolePlus will be pasted as Real.i = 15 = Real.j + 10 if Diameter is selected in the copy (use multi-selection).

•

Paste a parameter as well as the formula. Holeplus= 15 = Diameter + 10 will be pasted as Real.i = Diameter + 10 When copying parameters sets containing hidden parameters, these parameters are automatically pasted when pasting the parameters sets and appear as hidden parameters.

Specifying the Material Parameter
Whatever your document, the Material parameter is always displayed in the specification tree. The Material parameter is created only after a material is applied to a Part or a Product. The Mechanical_Property features are calculated from the Material value. Specify a material to set the values of the Mechanical_Property features. 1. Open the KwrStartDocument.CATPart document. The Material parameter is displayed by default in the specification tree. Its value is set to None. 2. Double-click the Material feature in the specification tree to edit the parameter. The dialog box below is displayed.
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3. Click OK and select the root feature in the specification tree. icon in the standard toolbar to display the available material 4. Click the library. Select the Metal->Iron material. 5. Click Apply Material and OK. This is what you should see now in the specification tree. The Iron feature is added to the specification tree and a new material is added under the Parameters node.

6. Remember: To display parameter values, check Tools->Options>General->Knowledge->Parameters and Measure->With value. 7. Keep your document open and proceed to the next task.

Valuating the Mechanical Property Parameters
Once the Material value has been specified, the Mechanical_Property parameters are automatically updated when the Properties option is selected in the contextual menu. 1. Select the root item in the specification tree and open the Properties dialog box from the contextual menu. 2. Select the Mass tab. The document mechanical properties have been updated from the value assigned to the Material parameter. 3. Click OK to go back to your document.

Specifying a Parameter Value as a Measure
This scenario shows how to assign a value to a parameter deducing it from a graphic selection. In this scenario, you deduce the value assigned to the Thickness parameter by selecting 2 circular edges. A common way to assign a value to a parameter is to use the Edit name or value of the current parameter field of the Formulas dialog box. But there is another way to proceed.
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The value you assign to a parameter can be deduced from a graphic selection. 1. In Tools->Options->General->Parameters and Measure, check the Load extended language libraries box of the Language tab. 2. Open the KwrStartDocument.CATPart document. 3. Click the icon. The f(x) dialog box is displayed.

4. Select the Length item with Single Value in the New Parameter of type list, then click New Parameter of type. The new parameter appears in Edit name or value of the current parameter. 5. Replace the Length.1 name with Thickness, then right-click in the value field of Edit name or value of the current parameter.

6. 7. Select the Measure Between... command from the contextual menu. The Measure Between dialog box is displayed. Select Edge only as Selection 1 mode and Edge only as Selection 2 mode. 8. In the document geometry area, select successively one of the inner circular edge of the part, then the outer circular edge located on the same face. The 17.5 mm value is displayed in the Measure Between dialog box.
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8. Click OK when done in the Measure Between dialog box. The 17.5 mm value is displayed in the Formulas dialog box. 9. Click OK to close the Formulas dialog box. The parameter is displayed below the Measure node in the specification tree and below the Parameters node. To edit this parameter: • • • Double-click it in the specification tree. The Edit Parameters dialog box is displayed. icon located next to the value field. The Click the Measure between dialog box is displayed. Edit the parameter and click OK when done.
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Importing Parameters
This scenario shows how to import parameters from an excel or a .txt file into a CATPart document. • Parameters and parameter values can be imported from a text file or from an Excel file (Windows) into documents (CATPart, CATProduct, Drawings...). If imported parameters already exist in the document, the import process automatically updates the document. Note that if 2 parameters have the same name in the import file, no clone is created and the parameters are not renamed. Make sure that the parameters have different names before importing them. Identical parameters names are not supported.

•

•

Please find below the formatting rules the external file should comply with: • Column 1 Parameter names Column 2 Parameter values. Multiple values are allowed. Values should then be separated by a ";". The imported value is the one delimited by the "<" and ">" tags. Use the Tab key to skip from one column to the other in a tabulated text file. Column 3 Formula. If no formula is specified, the third column should be left empty. In a tabulated text file, just press the Tab key twice from column 2 to leave column 3 empty. Column 4 Optional comment.

•

•

•

1. Open the KwrStartDocument.CATPart document. 2. Click the icon. The f(x) dialog box is displayed.

3. Click Import.... A file selection dialog box is displayed. 4. Select the ExCompanyFile0.xls file (Windows only) or the TxCompanyFile0.txt file, then click Open. The list of parameters to be imported into the KwrStartDocument.CATPart document is displayed.
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5. Click OK to import the parameters from the input file into the KwrStartDocument.CATPart document. The imported parameters are now displayed in the parameter list of the f(x) dialog box and in the specification tree.

6. Click OK to terminate the dialog.

Creating Points, Lines... as Parameters
The scenario below explains how to determine the position of the inertia axis of a pad. To do so, start from a pad, then: ) 1. Create a line by using either method ('datum' or 2. Use the inertiaAxis line constructor to specify that this line is to be the inertia axis of the pad. 3. Retrieve the coordinate of the point located at the intersection of the inertia axis and the pad extrusion plane.

To create elements such as Points, Lines, Curves, Surfaces, Planes or Circles and use them in knowledgeware relations, you can: • Create these elements as 'Isolate' elements in the Generative Shape Design workbench. 'Isolate' elements also called Datum are elements that have no link to the other entities that were used to create them. For information on 'Datum' type elements, see the Generative Shape Design User's Guide. Create these elements by using the f(x) capabilities and select the right type of element in the New parameter of type list.

•
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1. Access the Part Design workbench, create any sketch in the yz plane, then extrude this sketch to create a pad. If need be, refer to the Part Design User's Guide. 2. Create a line intended to be used as an inertia axis afterwards. 3. To do so, click the Formulas icon , select the Line item in New Parameter of type, then click New Parameter of type. 4. Click the Formulas icon. In the parameter list, select the line you have just created (Geometrical Set.1 Line.1).

5. Click Add Formula and add the formula below in the editor: Geometrical Set.1 Line.1 = inertiaAxis(3,PartBody) The inertiaAxis function is accessible through the Line constructors. The axis number 3 is the one which is in the extrusion direction (normal to yz). Click OK in the Formulas dialog box. The inertia axis is displayed in the geometry area. 6. Back to . Create three length type parameters: X, Y and Z.

7. Retrieve the coordinates of the point located at the intersection of the inertia axis and the 'yz plane'. To do so, create the formulas below: X=intersect(Geometrical Set.1 plane').coord(1) Y=intersect(Geometrical Set.1 plane').coord(2) Z=intersect(Geometrical Set.1 plane').coord(3) Line.1, 'yz Line.1, 'yz Line.1, 'yz

8. You get the intersect function from the Wireframe constructors and the point.coord method from the Measures item of the dictionary. 9. Check the value displayed in the specification tree as well as in the Formulas dialog box. The KwoGettingStarted.CATPart document used as a sample for the Product Engineering Optimizer User's Guide illustrates this scenario.

Applying Ranges to Parameters by Using a Rule
This task explains how to apply ranges to parameters by using a rule.

1. Open the KwrRangesParameters.CATPart. 2. Click the icon and select Real in the scrolling list to create two parameters of Real type: Real.1 and Real.2. 3. Select Real.1 and right-click the field next to the Edit name or value of the
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current parameter box. 4. Select Add Range The Range of Real.1 dialog box opens.

5. Specify the Minimum and the Maximum bounds (-5 and 5 for example), and click OK twice. 6. Access the Knowledge Advisor workbench and click the Rule icon ( Rule editor opens. 7. Enter the following rule: Real.2 =Real.1 .InferiorRange and click OK: Real.2 value changes to -5. ). The

8. Double-click the rule under the Relations node and replace the existing script with Real.2 =Real.1 .SuperiorRange and click OK: Real.2 value changes to 5.
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Activating and Deactivating a Component
This task explains how to activate and deactivate a component. In the scenario described below, the CATProduct file contains two CATPart files that you will activate and deactivate alternatively after creating user parameters and a rule based on these parameters. Note that: • • Relations located at the product level are not integrated to the product update. If your relation drives the parameters of a Part, create the relation at the Part level. Parameters driven by rules are designed to enable you to control components activities at assembly level.

When working in a Japanese environment, remember to check the Surrounded by the Symbol' option (Tools->Options->General->Parameters and Measure->Knowledge tab).

17

knowledgeware

1. Open the KwrSyringe.CATProduct file and save the following files in the same directory (SyringePiston.CATPart, HollowSyringePiston.CATPart, and SyringeContainer.CATPart): This file contains a syringe made up of three different parts: A barrel, and two different plungers. 2. Create a multiple value parameter of string type. • • Click the icon. The Formulas Editor opens.

Select String in the scrolling list with Multiple Values. Click the New Parameter of type button. The Value List dialog box opens. Enter two different values, Hollow and Full, and click OK. Edit the name of the new parameter (SyringeType in this scenario) in the Edit Name or value of the current parameter and click OK. The new parameter is displayed under the Parameters node of the Specification tree.

• •

3. Access the Knowledge Advisor workbench and click the Rule icon to create a rule. The script of this rule will allow you to enable or disable one of the plungers. 4. Enter the code below in the Rule Editor, and click OK. if (SyringeType == "Hollow") { `S3\Component Activation State` `S2\Component Activation State` } else { `S2\Component Activation State` `S3\Component Activation State` }

= false = true

= false = true
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Note that Japanese users should enter the following rule.

6. Double-click the SyringeType parameter under the Parameters node and select Hollow in the Edit Parameter window. The SyringeBarrel CATPart and the HollowSyringePlunger CATPart are displayed.

7. Double-click the SyringeType parameter and select "Full" in the Edit Parameter window. The SyringeBarrel CATPart and the SyringePlunger
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CATPart are displayed.
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Creating an Associative Link Between Measures and Parameters
This scenario explains how to create a persistent and associative link between a measure created using the Measure Item or Measure Between command and a parameter. • Measure Item allows you to get the length of a curve (edge, line, curve), radius or angle depending on the parameter magnitude. Measure Between allows you to get the minimal distance or angle between two elements, depending on the parameter magnitude.

•

This link can be created only if the Keep measure option is checked in the Measure Item and Measure Between dialog boxes (if not the result is copied as a simple value.) • No formula is created when using the Measure Item or the Measure Between commands. The icon located on the right of the editor field is a measure between or item icon. Note that you will be able to edit the measure.

•

•

The parameters located below the Parameters node are directly linked to the measures. You can invert the sign of the parameter using the Invert value command in the Measure Item or Measure Between window. The sign concerns only the valuated parameters and not the parameter of the measure.

•

• • • •

To have an associative link, you must make an associative measure. If you select the Picking point mode and the Measure between function, the measure will not be associative. As a result, there will be no associative geometry. When a measure is not associative, the value is displayed in the value field. Even in the case of an associative measure, if you only want to get the result of the measure, uncheck the Keep measure check box. To create a "smart" customization, click the Customize... button in the Measure
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Item dialog box to see the properties the system can detect for the various types of item you can select.
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1. Open the KwrPlaneWing.CATPart file. The following image is displayed.

Using the Measure Item... command
2. Add a parameter of Length type. o Click the Formula icon ( o ). The Formulas dialog box is displayed.

In the New parameter of type scrolling list, select Length and click the New parameter of type button. Length.1 is displayed in the Edit name or value of the current parameter field. Right-click the value field of Length.1 and select the Measure Item... command. The Measure Item dialog box is displayed.

o

o

Make sure the Keep measure option is checked in the Measure Item dialog box. In the specification tree, expand the Sketch.1 node, and select Spline.2. The selected item is highlighted in the geometry and its measure is displayed in green.

o
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o

Click OK in the Measure Item dialog box and OK in the Formulas dialog box. A new parameter is added below the Parameters node and below the Measure node. The Length.1 parameter is now linked to the result of the measure.

Using the Measure Between... command
1. Add a parameter of Angle type. o Click the Formula icon ( ). The Formulas dialog box is displayed.

24
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o

In the New parameter of type scrolling list, select Angle and click the New parameter of type button. Angle.1 is displayed in the Edit name or value of the current parameter field. Right-click the value field of Angle.1 and select the Measure Between... command. The Measure Between dialog box is displayed.

o

o o

In the Selection 2 mode scrolling list, select the Edge only option. In the specification tree, select Plane xy then select the geometry as shown below.

The selected items are highlighted in the geometry and the measure is displayed in green.

o

Click OK in the Measure Between dialog box and OK in the Formulas dialog box. An angle parameter is added below the Parameters node and the measure is displayed below the Measure node.
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o

Click here to display the result sample.

2.

Note that: • • if several characteristics of the measure are computed and have the same magnitude, the system will choose the most convenient according to predefined rules. To remove the link to the measure, right-click the measure item in the specification tree and select the measure object->Remove the link with measure command.

Using Relations based on Publications at the Product Level
This scenario explains how to use relations based on publications at the product level. The scenario described below is divided into the following steps: • Add a parameter to the KwrScrew.CATPart called Screw_Volume, add a formula to calculate the volume of the screw and publish the Screw_Volume parameter. Add a parameter to the KwrScrew1.CATPart called Screw_Volume, add a formula to

•
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calculate the volume of the screw and publish the Screw_Volume parameter. • • • Create a CATProduct file called Bolt and import the KwrScrew.CATPart Import KwrNut.CATPart. In the context of the Bolt product, create a formula calculating the bolt volume based on the screw and the nut publications. In the context of the bolt, replace KwrScrew.CATPart by KwrScrew1.CATPart. The volume is recomputed.

•

Before you start, make sure that the Keep link with selected object check box is checked (Tools->Options->Infrastructure->Part Infrastructure->General). Note that this function can be used with: • • • • • Design Tables Formulas Rules and Checks Set of Equations The optimization

1. Open the KwrNewScrew.CATPart document. The following image is displayed.

2. Add a Volume parameter to the part. icon. The Formula Editor opens. In the New parameter of type scrolling

o

Click the
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list, select Real and click the New parameter of type button. o In the Edit name or value of the current parameter field, enter the name of the parameter: Screw_Volume. Click Apply and click the Add Formula button. The Formula Editor opens. Enter the following formula by using the Dictionary: Screw_Volume=smartVolume(PartBody Pad.2 ). Click OK three times. 3. Publish the Screw_Volume parameter. To do so, select the Tools>Publication command and click the Screw_Volume parameter under the Parameters node in the specification tree. Click OK. The published parameter appears in the specifications tree below the Publication node. Save your file and close it. Pad.1)+smartVolume(PartBody

o

4. Open the KwrNewScrew1.CATPart and repeat the steps listed above (steps 1 to 3 included). The part should be identical to the one below. Save your file and close it.
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5. Create a CATProduct file named KwrBolt.CATProduct. 6. Click the Root product and select the Insert->Existing Component... command. The File selection box is displayed. Select the KwrNewScrew.CATPart file and click Open. The screw is imported. 7. Select the Insert->Existing Component... command, select the KwrNewnut.CATPart file and click Open. The nut part is inserted.

8. Add a Bolt_Volume parameter to the product to compute the volume of the bolt.

o

Click the Root product and click the icon. The Formula Editor opens. In the New param of type scrolling list, select Real and click the New parameter of type button.

o

In the Edit name or value of the current parameter field, enter the name of the paramet
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Bolt_Volume. Click Apply and click the Add Formula button. The Formula Editor opens. o

Enter the following formula by using the Dictionary and by clicking the published parameters i specification tree: Bolt_Volume=`..!screw.2!Screw_Volume` +`..!Nut!Nut_Volume` Click OK, and OK. The Bolt volume is displayed

9. Replace the screw to compute a new volume: Double-click, then right-click the Screw.2 component in the specification tree and select the Components->Replace Component... command. The File Selection window opens. Select the KwrNewScrew1.CATPart file and click Open. 10. Click Yes and OK in the Impacts on Replace window. The new screw is inserted and the bolt volume is updated.

11.
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Parameters: Useful Tips
• You can add properties to a .CATPart or a .CATProduct document by using the Properties command from the contextual menu. You just have to click the Define other properties... button in the Product tab then click New parameter of type. The dialog is similar to the f(x) dialog. See the Product Structure User's Guide for more information. The properties you define that way are also displayed in the parameter list of the f(x) dialog box. Parameters belonging to a parameter set can be reordered by using the Reorder... command from the contextual menu. Parameters added by using the Parameters Explorer are displayed right below the feature they are assigned. CATIA users working with non-latin characters should check the Tools>Options>Knowledge->Parameter Names->Surrounded by' option. Otherwise, parameter names should have to be renamed in latin characters when used in formulas. You can specify that a parameter is constant by using the Properties command from the contextual menu. This command also enables you to hide a parameter. When copying parameters sets containing hidden parameters, these parameters are automatically pasted when pasting the parameters sets and appear as hidden parameters. Parameters have 2 different names: The local one and the global one. o The local name is the name attributed to the parameter when it was created in the Formula Editor or in the Parameters Explorer. Note that this name will not be modified if you perform a Reorder using the contextual menu.

•

•

•

• •

•

This name can be modified using the Parameters Explorer and the Edit>Properties command. o The global name (name) is the name attributed to the parameter by Knowledge Advisor. It is the path of the parameter + its type. If you select the parameter and reorder it, the path contained in the name will be modified. If you double-click the parameter in the specification tree, and enter a new name in the Edit Parameter dialog box, the global name will be changed. If, after renaming the parameter in the Edit Parameter dialog box, you reorder the parameter the path will not appear any more. This name can be modified in the Edit Parameter dialog box. •
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•

When renaming parameters using the Edit->Properties command, do not apply names similar to the parameters types available in the Formula Editor. For example, if you rename a Length parameter into Time, the name will be converted into Time.1. Deleting parameters used in a relation: If you delete a parameter used in a relation, a "clone" parameter will be created. Applying the same formula to several parameters: If you want to apply the same formula to several parameters, use the Equivalent Dimensions feature and value this feature by a formula. To know more, see Using the Equivalent Dimensions Feature. External parameters created at a product level are not integrated to the update process.

•

•

•

Formulas
Introducing Formulas
Formulas are features used to define or constrain a parameter. A formula is a relation: the left part of the relation is the parameter to be constrained, the right part is a statement. Once it has been created, a formula can be manipulated like any other feature from its contextual menu. The formula language uses operators and functions of all types whereby you can perform operations on parameters.

Displaying Formulas in the Specification Tree
Formulas are relations and as such they can be displayed below the Relations node provided you check the 'Relations' box below the 'Specification tree' settings in the Tools->Options>Infrastructure-> Part Infrastructure->Display dialog box. In addition, formulas can also be displayed below the Parameters node provided you check: • the 'Parameters' box below the 'Specification tree' settings in the Tools>Options->Infrastructure-> Part Infrastructure->Display dialog box • as well as the 'With Formula' box below the Parameter Tree View settings in the Tools->Options->General->Parameters and Measure dialog box
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The Activity Parameter
A formula is a feature which is assigned a parameter called the activity. The activity value is a boolean. If the activity is set to true, the parameter value cannot be calculated from the formula. If a formula is created for a parameter which is not already constrained by another formula, the activity of the new formula is set to true by default. A parameter can be constrained by several formulas, but only one formula can be active at a time. Before activating a formula on a given parameter, you must deactivate the other formulas defined on the same parameter. Activity value Relation icon in the specification tree false true

Importing Formulas
Parameters as well as the associated formulas can be imported from an external file. Refer to Introducing Parameters and Importing Parameters for more information on how to import formulas.

Getting Familiar With the f(x) Dialog Box
The f(x) dialog box is displayed when you click the box allows you to: • Display the list of parameters • • Create parameters and formulas Import external files. icon in the standard tool bar. This dialog
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The parameter list

Basically, the parameter list displays the parameters related to the feature selected either in the specification tree or in the geometry area. If no feature has been selected, all the document parameters are displayed. The dialog box being open, you can select a given feature either in the tree or in the geometry area and display its related parameters. You can restrict the list of displayed parameters by using the Filter Name and Filter Type capabilities as well as the Incremental check box.
The Filter Name filter

This filter allows you to narrow the list of displayed parameters by specifying a substring. If you specify *Limit* as filter, only the parameter with Limit as sub-string will be displayed, for example: PartBody PartBody PartBody PartBody Pad.1 Pad.1 Hole.1 Hole.1 FirstLimit SecondLimit HoleLimit.1 HoleLimit.1 Length Length Depth Angle

The Filter Type filter

This filter allows you to restrict the list of parameters by specifying a type. Selecting User parameters will display only the parameters created by the New Parameter of type button.
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Selecting Hidden parameters will display only the list of parameters which have been declared as hidden by using the Hide command from the value field contextual menu. The Hide command is only available for user parameters.

The Incremental check box

Selecting a feature in the specification tree or in the geometry area is displayed in the editor only the first level of features right below the selected feature. The parameter list on figure above displays all the parameters related to the Pad.1 and Hole.1 features. Selecting Pad.1 in the tree (Incremental unchecked) will display the parameters below: PartBody PartBody PartBody Pad.1 Pad.1 Sketch.1 FirstLimit SecondLimit Radius.3 Length Length Radius

Checking Incremental restricts the list of parameters to the one below: PartBody PartBody Pad.1 Pad.1 FirstLimit SecondLimit Length Length

The 'Edit name of value of the current parameter' field

This field displays the parameter which has been selected in the parameter list. The value field on the right-hand side is grayed out when the parameter is constrained by a formula, a design table or any type of relations. Right-clicking this value field provides you with a number of commands whereby you can refine the parameter definition.
The New Parameter of type button

This button allows you to create a user parameter. This user parameter can be assigned a single value or multiple values (akin to the enum idea).
The Delete Parameter button

This capability operates only for user parameters.
The Add Formula button

When you create a formula, you specify that a parameter, whatever its type, is to be constrained by a relation. Clicking the Add Formula button displays the Formula editor. The formula which is created is displayed in the parameters list as well as its activity. To know more about the Dictionary available in the Formula editor, see Using the Dictionary.
The Delete Formula button

When a parameter which is constrained by a formula is selected in the parameter list, clicking Delete Formula removes the formula.
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The Import button

This capability allows you to import parameters and parameter values from a text file or from an Excel file (Windows).

Using the Dictionary
Design Table Methods
CloserSupConfig Method LocateInColumn Method CellAsReal Method Sheet.CloserConfig CloserInfConfig Function CloseValueSupInColumn Method MaxInColumn Method CellAsBoolean Method LocateInRow Method CellAsString Function SetCell Method CloseValueInfInColumn Method MinInColumn Function

CloserSupConfig Method
Applies to a design table sheet. Returns the configuration which contains the smallest values greater or equal to the values of the given arguments. When several configurations meet this condition, the method sorts out the possible configurations with respect to the column order as it is specified in the argument list.
Syntax

sheet.CloserSupConfig(columnName: String, minValue: Literal, ...): Integer The CloserSupConfig function takes the following arguments: Arguments Description Should be put in quotes. At least, one couple of arguments columnName columnNamei/minValuei is required minValue Required. You should specify the units.
Example

Given the design table below: SketchRadius(mm) PadLim1(mm) 1 120 60 2 130 50 3 120 60 4 140 50 The expression below:

PadLim2(mm) 10 30 25 40

Relations DesignTable1 sheet_name.CloserSupConfig("PadLim1", 60mm, "SketchRadius", 120mm, "PadLim2", 20mm) returns 3

CloserInfConfig Method
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Syntax

sheet.CloserInfConfig(columnName: String, maxValue: Literal, ...):Integer The CloserInfConfig method takes the following arguments: Arguments Description Should be put in quotes. At least, one couple columnName columnName/maxValue is required maxValue Required. You should specify the units.
Example

Given the design table below: SketchRadius(mm) PadLim1(mm) 1 120 60 2 130 50 3 120 60 4 140 50 The statement below

PadLim2(mm) 10 30 20 40

Relations DesignTable1 sheet_name.CloserInfConfig("PadLim1", 60mm, "SketchRadius", 130mm, "PadLim2", 40mm) returns 3. Explanations The values of lines 1 , 2 and 3 are all less or equal to the values specified in the method arguments. • As the first parameter specified in the argument list is "PadLim1", the method scans the lines 1, 2 and 3 and searches for the largest "PadLim1" value which is less or equal to 60 mm. Two configurations meet the condition: configuration 1 and configuration 3. As the second parameter specified is "SketchRadius", the method scans the configurations 1 and 3 and searches for the largest "SketchRadius" value less or equal to 130 mm. Again, the function finds two configurations meeting the criteria. Then it rescans lines 1 and 3 and searches for the largest "PadLim2" value less or equal to 40mm. The result is line 3.

•

•

CloserValueSupInColumn Method
Applies to a design table sheet. Scans the values of a column and returns the greatest cell value which is the nearest to a specified one. Returns 0 if no value is found or if the method arguments are not properly specified.
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Syntax

sheet.CloserValueSupInColumn(columnIndex: Integer, Value: Real) The CloserValueSupInColumn method takes two arguments: Arguments Description columnIndex Required. Index of the table column. Integer from 1 to n. Value
Example

Required. Value searched for. Should be a real.

ValueSup=Relations 80mm)

DesignTable1

sheet_name.CloserValueSupInColumn(1,

Message("Closest sup value is # (0.08 is expected)", ValueSup)

CloserValueInfInColumn Method
Applies to a design table sheet. Scans the values of a column and returns the smallest cell value which is the nearest to a specified one. Returns 0 if no value is found or if the method arguments are not properly specified.
Syntax

sheet.CloserValueInfInColumn(columnIndex: Integer, value: Real): Real The CloserValueInfInColumn function has two arguments: Arguments Description Required. Number or index of the table column. Integer columnIndex from 1 to n. value Required. Value searched for. Should be a real.
Example

Message("Closest inf value is # ", Relations DesignTable1 sheet_name.CloserValueInfInColumn(2,41mm))

MinInColumn Method
Applies to a design table sheet. Returns the smallest of a column values. Returns 0 if the column specified is out of range.
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sheet.MinInColumn(columnIndex : Index): Real where columnIndex is the column number.
Example

MinimumValue=MinInColumn(3) Message("Minimum value is # (0 is expected)", MinimumValue) /* you can use also */ Message("Minimum value is # (0 is expected)", MinInColumn(3))
Sample

KwrProgramDT.CATPart

MaxInColumn Method
Applies to a design table sheet. Returns the greatest of a column values. Returns 0 if the column does not contain numerical values or if the method arguments are not properly specified.
Syntax

sheet.MaxInColumn(columnIndex: Integer): Real
Example

MaximumValue=Relations

DesignTable1

sheet_name.MaxInColumn(1)

Message("Maximum value is # (0.150 is expected)", MaximumValue)

LocateInColumn Method
Applies to a design table sheet. Returns the index of the first row which contains a specified value. Returns zero if the value is not found or if the method arguments are not properly specified.
Syntax

sheet.LocateInColumn(columnIndex: Integer, value: Literal) : Integer
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Example

Description Required. Number or index of the table column. Integer from 1 to n. Required. Value searched for. Can be a string or a boolean

Line=Relations if (Line == 0) {

DesignTable1

sheet_name.LocateInColumn(4,11mm)

Message("No value found !!!") }

CellAsString Method
Applies to a design table sheet. Returns the contents of a cell located in a column. Returns an empty string if the cell is empty or if the method arguments are not properly specified.
Syntax

sheet.CellAsString(rowIndex: Integer, columnIndex: Integer): String where rowIndex is the configuration number and columnIndex the column number.
Example

CString=Relations DesignTable1 if (CString == "") { Message("No value read !!!") }

sheet_name.CellAsString(1,5)

CellAsBoolean Method
Applies to a design table sheet. Returns the contents of a cell located in a column intended for boolean values. Returns false if the cell does not contain a boolean or if the method arguments are not properly specified.
Syntax
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columnIndex Required. Index of the table column. Integer from 1 to n.
Example

Boolean2=Relations if (Boolean2 <> true) { Message("Error !!!") }

DesignTable1

sheet_name.CellAsBoolean(1,5)

CellAsReal Method
Applies to a design table sheet. Returns the contents of a cell located in a column intended for real values. Returns zero if the cell does not contain a real or if the method arguments are not properly specified.

Syntax
sheet.CellAsReal(rowIndex: Integer, columnIndex: Integer): Real where rowIndex is the configuration number (integer from 1 to n) and columnIndex the column number.

SetCell Method
Enables you to add a cell at a given position in an Excel file or a tab file. Note: the index should start at 1 for the (1,1) cell to be located at the left top corner.
Syntax

sheet.SetCell(IndexRow:Integer, IndexColumn:Integer, CellValue:Literal): Void

LocateInRow
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Syntax

sheet.LocateInRow(rowIndex: Integer, value: Literal) : Integer The LocateInRow method has two arguments: Arguments Description RowNumber Required. Number or index of the table row. Integer from 1 to n. Value Required. Value searched for. Can be a string or a boolean

Sheet.CloserConfig(string columnName1, string sortMethod1, any value1, columnName2, sortMethod2, value2, ...)
Method enabling you to find the closest configuration of a design table according to criteria that mix greater than (or equal to) and smaller than (or equal to). Where: • • • The columnName<index> arguments match the columns names in the design table source file. The sortMethod<index> are strings that can only take the following values : < , <= , > , >= , == , != The value<index> arguments can be either numerical values (the magnitude should correspond to the magnitude of a given column), or string values. If string values are used, the exact value is retrieved from the cells (the sortMethod is used only if it is not Example: Sheet.CloserConfig( column1 , , < != , 10mm, , column2 , == or != , == == or != .) If sortmethod is

is assumed.

>= , 20deg, column3 interpreted as follows: Find the configuration where: • • •

standard

) that can be

the value in column1 is strictly smaller than 10mm, where the value in column2 is greater than or equal to 20deg where the value in column3 is different from the standard string.

Note that:

42

User Tasks • If several configurations are valid, you will find the configuration whose values are as close as possible to the bounds . If still several configurations are valid, the first valid one is returned. If no configuration is valid, the returned value is 0.

•

Operators
Arithmetic operators
+ Addition operator (also concatenates strings) - Subtraction operator * Multiplication operator / Division operator () Parentheses (used to group operands in expressions)

= Assignment operator ** Exponentiation operator

Logical Operators
and or Logical conjunction on two expressions Logical disjunction on two expressions

Comparison Operators
<> == >= <= < > Not equal to Equal to Greater or equal to Less than or equal to Less than Greater than

Constructors
Point Constructors
Sample: KwrPointConstructors • point (x: Length, y: Length, z: Length): Point 43
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Creates a point from its three coordinates. Values or parameter names can be used to pass the arguments. Examples: Specifying values: Geometrical Set.1 Point.1 = point(10mm,10mm,10mm) Specifying parameter names: Geometrical Set.1 point(0mm,L3,L1) • Point.4 =

pointbetween(pt1: Point, pt2: Point, ratio: Real, orientation: Boolean) : Point Creates a point between another two points. If true is specified in the fourth argument, the third parameter is the ratio of the distance pt1-new point to the pt1-pt2 distance. If false is specified in the fourth argument, the ratio expresses the distance pt2-new point to the pt1-pt2 distance (to create a point at the middle between pt1 and pt2, specify a ratio of 0.5).

Example: Geometrical Set.1 Point.5 = Point.1, Geometrical Set.1 Point.2, 0.6, pointbetween(Geometrical Set.1 true) •

pointoncurve(crv:Curve, pt:Point, distance:Length, orientation: Boolean) : Point Creates a point on a curve. The point is to be created at a given curvilign distance from a reference point specified in the second argument. The boolean specified in the fourth argument allows you to reverse the direction in which the point is to be created. If the point specified in the second argument is not on the curve, the projection of this point onto the curve becomes the actual reference point.

Example: Geometrical Set.1 Point.6 = Spline.1, Geometrical Set.1 Point.5, 5mm, pointoncurve(Geometrical Set.1 true) •

pointoncurveRatio(crv:Curve, pt:Point, ratio:Real, orientation: Boolean) : Point Creates a point on a curve. The location of the point to be created is determined by the real which is specified in the third argument. This real is the ratio of the distance [point to be created->reference point] to the distance [point to be created->curve extremity]. The boolean specified in the fourth argument allows you to reverse the direction in which the point is to be created. If the point specified in the second argument is not on the curve, the projection of this point onto the curve becomes the actual reference point.

Example:
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Geometrical Set.1

Point.7

= Spline.1,Geometrical Set.1 Point.3,

pointoncurveRatio(Geometrical Set.1 0.4,true) •

pointonplane(pln:Plane, pt:Point, dx:Length, dy:Length): Point Creates a point on plane. The location of the point to be created on the plane is determined by the coordinates (H,V system) passed in the third and fourth arguments. These values are specified with respect to the reference point passed in the second argument.

Example: Geometrical Set.1 Point.8 = Plane.1,Geometrical Set.1 Point.1, pointonplane(Geometrical Set.1 10mm,10mm) •

pointonsurface(sur:Surface, Pt:Point, Dir:Direction, dist:Length): Point Creates a point on surface. The location of the point to be created on the surface is determined by its distance (fourth argument) to a reference point (second argument) along a direction (third argument).

Example: Geometrical Set.1 Point.9 = Extrude.1,Geometrical Set.1 Point.3, pointonsurface(Geometrical Set.1 direction(Geometrical Set.1 •

Line.1),10mm)

center(circle): Point Creates a point from a circle. The circle can be of any type (sketch or GSM circle). The point which is created is the circle center.

Example: Geometrical Set.1 • Point.10 = circle(Geometrical Set.1 Circle.1)

pointtangent(curve,direction): Point Creates the tangency point between a curve and a direction.

Example: Geometrical Set.1 • Point.11 = Spline.1, direction(`yz plane`))

pointtangent( Geometrical Set.1

centerofgravity(Body): Point Constructs the center of gravity of a solid (i.e. a PartBody type feature).

Example: Geometrical Set.1 Point.12 centerofgravity(PartBody) • =

curvaturecenter(crv: Curve, pt: Point): Point
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Constructs the curvature center of a curve for a given point. Example: Geometrical Set.1 • Point.13 = Circle.1, Geometrical Set.1 Point.6) curvaturecenter(Geometrical Set.1

extremum(Curve, Direction, Boolean, Direction, Boolean, Direction, Boolean) Constructs an extremum point. The inputs are a curve, 3 directions, and 3 booleans.

Example: Geometrical Set.1\Point.2= extremum(`Geometrical Set.1\Circle.1` ,direction(`xy plane` ) ,FALSE,direction(`xy plane` ),TRUE,direction(`xy plane` ),TRUE) • extremum(Surface, Direction, Boolean, Direction, Boolean, Direction, Boolean) Constructs an extremum. The inputs are a surface, 3 directions, and 3 booleans. extremum(Solid, Direction, Boolean, Direction, Boolean, Direction, Boolean) Constructs an extremum. The inputs are a solid, 3 directions, and 3 booleans.

•

Line Constructors
Sample: KwrLineConstructors • line(Point, Point): Line Creates a line from two points.

Example: Geometrical Set.1 Line_Point_Point = line( `Geometrical Set.1\Point.1` , `Geometrical Set.1\Point.2` ) • line(pt: Point, dir: Direction, start: Length, end: Length, orientation: Boolean) : Line Creates a line passing through a point and parallel to a direction. The third and fourth arguments are used to specify the start and end points. The last argument allows you to reverse the line direction.

Example: Geometrical Set.1 Line.13 = line( `Geometrical Set.1\Point.2` , direction( `zx plane` ) , 0mm , 20mm , false)
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•

lineangle(crv: Curve, sur: Surface, pt: Point, geodesic: Boolean, start: Length, end: Length, angle: Angle, orientation: Boolean) : Line Creates a line passing through a point, tangent to a surface and making a given angle with a curve. When the geodesic argument is set to true, a geodesic line is created(projected) onto the surface.

Example: Geometrical Set.1 Line.1 = Spline.1 , Geometrical Set.1 Extrude.1 , lineangle( Geometrical Set.1 Geometrical Set.1 •

Point.4 , false, 0mm , 50mm , 80deg , false)

linetangent(crv: Curve, pt:Point, start:Length, end:Length, orientation:Boolean) : Line Creates a line tangent to curve at a given point.

Example: Geometrical Set.1 Line.11 = linetangent( `Geometrical Set.1\Spline.1` , `Geometrical Set.1\Point.6` ,0mm , 30mm , true ) • linenormal(sur:Surface, pt:Point, start:Length, end:Length, orientation:Boolean) : Line Creates a line normal to a surface at a given point.

Example: linenormal= linenormal(`Geometrical Set.1\Extrude.1` ,`Geometrical Set.1\Point.2` ,10mm,16mm,true) • mainnormal(crv: Curve, pt: Point) : Line Creates a line normal to a curve at a given point. The line is created in the plane which contains the tangent vector.

Example: Geometrical Set.1\Line.10= mainnormal( `Geometrical Set.1\Spline.1` , `Geometrical Set.1\Point.6` ) • binormal(crv: Curve, pt: Point) : Line Creates a line normal to a curve at a given point. The line is created in plane which is orthogonal to the tangent vector.

Example: Geometrical Set.1\Line.8= binormal( `Geometrical Set.1\Spline.1` , `Geometrical Set.1\Point.6` ) • InertiaAxis(rank: Integer, Body, ...):Line Enables you to determine the inertia axis of a body.

Example: Geometrical Set.1\Line.9= inertiaAxis( 1 , `PartBody` )
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Circle Constructors
Sample: KwrCircleConstructors.CATPart • circleCtrRadius (center: Point, support: Surface, radius: Length, limits: Integer, start: Angle, end: Angle): Circle

Creates a circular arc from its center and radius. If the argument 4 is 0, the arguments 5 and 6 are taken into account. Otherwise, a circle is created. • circleCtrPt(center: Point, point: Point, support: Surface, radius: Length, limits: Integer, start: Angle, end: Angle): Circle

Creates a circular arc from its center and another point located on the circle. If the argument 4 is 0, the arguments 5 and 6 are taken into account. Otherwise, a circle is created. • circle2PtsRadius(point1: Point, point2: Point, support: Surface, radius: Length, orientation: Boolean, limits: Integer): Circle

Creates a circular arc. The points specified in the arguments 1 and 2 are located on the arc to be created and define the arc limits when the integer specified in the argument 6 is 0. When 0 is specified in the argument 6, modifying the argument 5 boolean value allows you to display the alternative arc. • Circle3Pts (pt1: Point, pt2: Point, pt3: Point, Limits: Integer) : Circle

Creates one or more circular arcs passing through three points. When 0 is specified in the argument 4, the first and third points define the arc limits. When 1 is specified in the argument 4 the whole circle is defined. When 2 is specifies in the argument 4 the direct circle is defined. When 3 is specified in the argument 4, the complementary circle is defined. • circleBitgtRadius(crv1:Curve, crv2:Curve, support: Surface, radius: Length, orientation1: Boolean, orientation2: Boolean, Limits: Integer) : Circle

Creates one or more circular arcs tangent to two curves. When 0 is specified in the argument 7, the tangency points define the arc limits. Modifying the orientation1 argument value allows you to reverse the arc orientation with respect to the crv1 curve (there may be no solution). Modifying the orientation2 argument value allows you to reverse the arc orientation with respect to the crv2 curve.
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•

circleBitgtPoint(crv1:Curve, crv2:Curve, pt:Point , support: Surface, orientation1: Boolean, orientation2: Boolean, Limits: Integer) : Circle

Creates one or more circular arcs tangent to two curves and passing through a point on the second curve. When 0 is specified in the argument 7, the tangency points define the arc limits. Modifying the orientation1 argument value allows you to reverse the arc orientation with respect to the crv1 curve (there may be no solution). Modifying the orientation2 argument value allows you to reverse the arc orientation with respect to the crv2 curve. • circleBitgtradius(curve: Curve, point: Point, support; Surface, radius: Length, orientation1: Boolean, orientation2: Boolean, limits: Integer : Circle

Creates one or more circular arcs tangent to two curves. • circleTritgt(curv11:Curve, curve2:Curve, curve3:Curve, support: Surface, orientation1: Boolean, orientation2: Boolean, orientation3: Boolean, Limits: Integer) : Circle

Creates one or more circular arcs tangent to three curves. When 0 is specified in the argument 8, the tangency points define the arc limits. Modifying the value of an orientation argument allows you to reverse the arc orientation with respect to the curve which has the same order in the argument specification (orientation1 to be associated with crv1). • circleCtrAxis(axis: Line, point: Point, radius: Length, start: Angle, end: Angle, projectionmode: Boolean , limits: Integer)

Creates a circle using a point and axis/line as input elements and corresponds to `Center and axis` type of circle in the user interface. • • • • • • • axis: Circle created on a plane perpendicular to this axis. point: Element used for center computation. radius: Radius of the circle created. start: Start angle of circle. Used only if limits value is 0. end: End angle of circle. Used only if limits value is 0. projectionmode: ProjectionMode = True implies that the point specified will be projected on to axis/line and will be used as center of the circle, projectionMode = False implies that point will be center of the circle. limits: Circle limitation type. 0 for Angles i.e Part arc, 1 for whole circle
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"Point and axis" with projection •

"Point and axis" without projection

circleCtrtgt(point: Point, curve: Curve, curve orientation: Boolean, tangent orientation: Boolean, support: Surface)

Creates a circle using center, curve and support and corresponds to `Center and tangent` type of circle in the user interface. Orientations are needed to select the proper circle in case of multiple solutions. • • • • • point: center of the circle curve: curve to which the created circle will be tangent. curve orientation: Tangent curve orientation for circle computation. tangent orientation: Tangent orientation of tangent curve for circle computation. support: support surface.

•

circleCtrtgt(curve1: Curve, curve2: Curve, curve2 orientation: Boolean, curve2 tgt orientation: Boolean, support: Surface, radius: Length, curve1
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orientation: Boolean, curve1 tgt orientation: Boolean) This is used to create a circle using center, curve and support and corresponds to `Center and tangent` type of circle in the user interface. Orientations are needed to select the proper circle in case of multiple solutions. • • • • • • • • curve1: Center element on which the center of circle lies. It is a curve curve2: Curve to which the created circle will be tangent. curve2 orientation: Tangent curve orientation for circle computation. curve2 tgt orientation: Tangent orientation of tangent curve for circle computation. support: support surface. radius: Radius of the circle created curve1 orientation: Center element's orientation for circle computation. curve1 tgt orientation: Tangent orientation of center element for circle computation.

Plane Constructors
Sample: KwrPlaneConstructors.CATPart • plane(point, point, point) : Plane Creates a plane through 3 points. plane(a:Real, b:Real, c:Real, d:Length) : Plane Creates a plane from its equation aX+bY+cZ=d. plane(line, line) : Plane Creates a plane through 2 lines. plane(point, line) : Plane Creates a plane through a point and a line. plane(curve) : Plane

•

•

•

•
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Creates a plane through a planar curve. • planetangent(surface, point) : Plane Creates a plane tangent to a surface at a point. planenormal(curve, point) : Plane Creates a plane normal to a curve at a point. planeoffset(plane, length, boolean) : Plane Creates an offset plane from another at a given distance. Set orientation boolean to false to change the side of the created plane regarding the reference plane. planeoffset(plane, point) : Plane Creates an offset plane from another passing through a point. planeangle(plane, line, angle, boolean) : Plane Creates an angle plane. Set orientation boolean to false to change the side of the created plane regarding the reference plane. planemean(Point,...): Point Computes a mean plane from a set of points.

•

•

•

•

•

Wireframe Constructors
spline curveparallel assemble near intersect project corner near intersect project split extrude intersect project trim revolve

Sample: KwrWireFrameConstructors.CATPart • spline(pt: Point, ...): Curve Creates a spline from several points. intersect(crv: Curve, crv: Curve) : Point Constructs the point where two curves intersect intersect(crv: Curve, su: Surface) : Point Constructs the point where a curve and a surface intersect. intersect(su: Surface, su: Surface) : Curve Constructs the curve where two surfaces intersect.

•

•

•
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•

curveparallel(crv: Curve, su: Surface, offset: Length) : Curve Constructs the curve parallel to another curve. The surface specified in the second argument is the support. project(toproject: Point, support: Curve): Point Projects a point on a curve. project(toproject: Point, support: Surface): Point Projects a point on a surface. project(toproject: Point, support: Surface): Surface Projects a curve on a surface. assemble(Curve,...):Curve Creates a join of several curves. corner(crv1: Curve, crv2: Curve, support: Surface, radius: Length, orientationcrv1: Boolean, orientationcrv2: Boolean, trim: Boolean : Curve Constructs a corner between two curves. The arguments 5 and 6 should be used to scan the possible solutions. See the Generative Shape Design User's Guide for more information on corners. split(tosplit:curve, splitting: Wireframe, orientation:Boolean):Curve Enables you to split a surface. trim(crv1: Curve, orientationCrv1: Boolean, orientationCrv1: Boolean, crv1: Curve, orientationCrv2, Boolean): Curve Enables you to trim two two wireframe elements. near(crv:Curve, near:Wireframe): Curve Creates the nearest entity of several sub-element. The result is a curve. near(crv:Point, near:Wireframe): Point Creates the nearest entity of several sub-element. The result is a point. extrude(Point, Direction, length1: Length, length2: Length, orientation: Boolean): Line Creates a line. Extrusion of a point depending on a direction. revolve(Point, axis, Line: angle1, Angle: angle2, Angle): Circle Enables you to create a circle by revolving a point according to a given direction.

•

•

•

•

•

•

•

•

•

•

•
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Surface Constructors
Offset split (surface, curve, boolean) extrude(curve, direction, length, length, boolean) : Surface revolve(surface, line, angle, angle) : Surface assemble trim(surface, boolean, surface, boolean) extrude(surface, direction, length, length, boolean) : Surface loft(sections: list, orientations: list) split (surface, surface, boolean) near(surface, wireframe) : Surface revolve(curve, line, angle, angle) : Surface loft(sections: list, orientations: list, guides: list)

Sample: KwrSurfaceConstructors • offset(surface, length, boolean) : Surface Creates an offset surface.Set orientation boolean to false to change the side of the created surface regarding the reference surface. assemble(surface, ...) : Surface Creates a join of several surfaces. split(surface, surface, boolean) : Surface Creates a split of one surface by another. Use the third argument to choose the side to keep. split(surface, curve, boolean) : Surface Creates a split of one surface by a curve. Use the third argument to choose the side to keep. trim(surface, boolean, surface, boolean) : Surface Creates a trim of one surface by another. Use the Booleans to choose the side to keep on each surface. near(surface, wireframe) : Surface Extracts a connex sub element of a non connex entity which is the nearest from another element. extrude(curve, direction, length, length, boolean) : Surface Extrudes a wireframe profile in a given direction. extrude(surface, direction, length, length, boolean) : Surface Extrudes a surface in a given direction. The result is the skin of the generated volume. revolve(curve, line, angle, angle) : Surface

•

•

•

•

•

•

•

•
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Revolves a wireframe profile around a given axis. • revolve(surface, line, angle, angle) : Surface Revolves a surface around a given axis. The result is the skin of the generated volume. loft(sections: list, orientations: list) Creates a loft from several sections. loft(sections: list, orientations: list, guides: list) Creates a loft from several sections and several guides.

•

•

Evaluate Method

Allows you to compute a law whether a KnowledgeAdvisor or a Generative Shape Design Law and use the resulting data within another law.
Syntax

law.Evaluate(Real): Real where the argument is the parameter to which the law is applied.
Example

1. Create a Generative Shape Design line. 2. Create a first law by clicking the icon in the standard tool bar. 3. In the law editor, create two real formal parameters. 4. Enter the law (Law.1) below into the editor: FormalReal.1 = 5*sin(5*PI*1rad*FormalReal.2)+ 10 5. Click OK to add the law to the document. 6. Repeat the same operation and enter the law (Law.2) below: FormalReal.1 = 3* FormalReal.2*Relations Law.1.Evaluate(FormalReal.2) 7. In the Generative Shape Design workbench, create a line parallel to the line created in step 1. Specify the law which is defined just above in the Offset
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Sample

KwrObject.CATPart

String
Search Method ToString Method ToUpper Method Extract Method ToReal Method ToLower Method Length Method ReplaceSubText Method BuildMessageNLS

Search Method
Searches for the first occurrence of a sub string in a String type parameter. Returns the index of the start of the substring. Returns -1 is the substring specified is not found.
Syntax

string.Search(StringToBeSearchedFor): Integer where StringToBeSearchedFor is the name of the SubString parameter.
Example

Responsible = Cilas Evans = ...
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SEvans = Evans I1Search = 6 = Responsible.Search(SEvans)
Sample

KwrString.CATPart

Extract Method
Returns the sub string starting at a given position with a specified length.
Syntax

string.Extract(StartIndex: Integer, Length: Integer) : String where StartIndex is the index of the substring first character and Length the sub string length.
Example

Message (Responsible.Extract(2,2))
Sample

KwrString.CATPart

Length Method
Applies to a string type parameter. Returns the string length.
Syntax

string.Length(Integer
Sample

KwrString.CATPart

ToString Method
Converts an integer into a string.
Syntax

ToString(Real) : String
Sample

57

knowledgeware KwrString.CATPart

ToReal Method
Converts a string into a real.
Syntax

String.ToReal(Real): Real

ReplaceSubText Method
Replaces a sub string with another substring within a character string.
Syntax

ReplaceSubText(InputString: String, SubStringToBeReplaced: String, ReplacingSubString: String): String Arguments 2 and 3 can be specified either with their parameters names or with the string itself between quotes.
Sample

KwrString.CATPart

ToUpper Method
Changes all lower-case letters of a string to upper-case.
Syntax

ToUpper(StringTobeConverted: String): String where StringTobeConverted is name of the string type parameter.
Sample

KwrString.CATPart

ToLower Method
Changes all upper-case letters of a string to lower-case.
Syntax

ToLower(StringTobeConverted: String): String where StringTobeConverted is name of the string type parameter.
Sample
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BuildMessageNLS
Enables you to send messages or ask questions through the Message and Question functions in the language of your choice. The BuildMessageNLS function can build a NLS message (a message in a given language) by finding it in a CATXXX.CATNls file. Note that this function is useful when used together with the Message and Question functions. To know more about these 2 functions, see the Knowledge Advisor documentation.
Syntax

BuildMessageNLS(MessageCatalog:String, MessageKey: String, argument: Literal, ...):String where: • • •
Example

MessageCatalog:String is the name of the CATXXX.CATNls file where we will find the NLS message (it is the CATXXX name without the CATNls extension). MessageKey: String is the key name in this catalog argument: Literal, ... are values that will be replaced in the message.

The KwrCATCatalog.CATNls file contains the following text. Zero = "Zero"; Un = "Un /P1"; Deux = "Deux /P1 /P2"; Zero, Un and Deux are the messages. The first message has no arguments, the second has 1 argument, the third, 2 arguments. To display those messages in a Knowledge Advisor rule for example, write the following rule body: Message (BuildMessageNLS("KwrCATCatalog","Zero")) OR Message (BuildMessageNLS("KwrCATCatalog","Un",x)) Where x is a parameter. OR
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Message (BuildMessageNLS("KwrCATCatalog","Deux",y,z)) Where y, and z are parameters. • • • • Note that if the function does not find the key or the .NLS catalog, it will return an empty string. If there are too many parameters compared to the number of arguments of the message, the parameters will be ignored. If there are too few parameters compared to the number of arguments of the message, the parameters will be replaced by a "???" string. Note that the .NLS file is to be stored in the runtime view (in the msgcatalog directory)

Sample

KwrCATCatalog.CATPart (See Rule.2)

Electrical User Functions
About the Electrical User Functions...

• • • • • •

Elec_DistanceCommon DistanceWireProduct ListAllOuterLayerObjects ListDirectlyCoveredObjects ListDirectlyOuterLayerObjects VisualMode

To be able to use these functions, you need to activate the ElectricalMeasure package. To do so: 1. Select Tools -> Options... -> General -> Parameters and Measures and go to the Language tab. 2. Choose the ElectricalMeasure package and click the right arrow:

3. Click OK to validate.
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Elec_DistanceCommon
Syntax Elec_DistanceCommon(Wire1: Wire, Wire2: Wire):Length Returns the common length of the two wires given as input arguments. The type of Wire1 and Wire2 is ElecWire. Example 1 The Elec_DistanceCommon user function can be used in Knowledge Expert to find all the couples of wires in the session that have a common length greater than a given value.

Example 2 In Knowledge Advisor, it can be used to define a rule giving the common length of two specific wires sharing properties.
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Applying the rule displays the following message if the condition is met:

Example 3 Still in Knowledge Advisor, to verify that two wires selected in the specification tree have a common length, the following action can be defined:
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then ran: select two wires in the specification tree and click OK to validate.

The following message displays:

DistanceWireProduct
Syntax DistanceWireProduct(Wire1: Wire, Object: Product):Length Returns the minimum length between a wire and a product in session. The product must contain at least one part. Example 1 The DistanceWireProduct user function can be used with the f(x) command to display the distance between a wire and a component in the session.
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This formula returns the following value:

Example 2 The DistanceWireProduct user function can be used in Knowledge Expert to find all the wires in the session that have a minimum distance to defined components smaller than a critical value chosen by the user. The components can be defined as heat-resistant. Properties have been added to the product:
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and to the wires:

A check is defined as follows:
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Updating the session displays green/red light on the check: A report is generated showing the check result: some wires verify the condition, other not.
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User Tasks Example 3 The DistanceWireProduct user function can be used in Knowledge Advisor to define a rule that displays a warning message if a minimum distance between a wire and an object is smaller than a critical value chosen by the user.

Running this rule displays the following message:

Example 4 Still in Knowledge Advisor, an action can be defined using the DistanceWireProduct user function, to know the distance between a wire and an object selected in the specification tree:

Run the action using the Action.1 contextual menu:
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This message displays:

ListAllOuterLayerObjects
Syntax

ListAllOuterLayerObjects (ElecBundleSegmentExtremity:Feature,Offset:Real,ListOfAllCoveringProducts(Protections/Supports):out List):Boolean Returns an ordered list of protective coverings and supports that cover the bundle segment at the point of interest. The point of interest is defined by specifying from which end of the bundle segment and entering an offset in mm. Example A check (in KWE advanced language) to determine the protective coverings and supports at 150 mm from end 1 (Extremity 1) of the bundle segment is written as follows:
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ListDirectlyCoveredObjects
Syntax ListDirectlyCoveredObjects((Protection/Support):Feature, ListOfCoveredProducts(BundleSegments/Protections/Supports): out List):Boolean Returns the list of bundle segments, protective coverings and/or supports directly under the component (protective covering or support) you want to analyze. If the component you want to analyze is not a protective covering or a support, the list returned will be empty. Example
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• • •

Tape A is placed directly over the bundle segment Corrugated tubes B and C are linked to the bundle segment, and corrugated tube B covers tube C Standard support D is linked to the bundle segment.

A check (in KWE advanced language) to determine the list of bundle segments, protective coverings and supports under corrugated tube C is written as follows:

Running this check returns: • • The name of the component analyzed, in our case, corrugated tube C The number of objects covered by corrugated tube C:
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•

Followed by the name of this component: the bundle segment.

ListDirectlyOuterLayerObjects
Syntax ListDirectlyOuterLayerObjects ((BundleSegment/Protection/Support):Feature, ListOfCoveringProducts(Protections/Supports): out List):Boolean Returns the list of outer layers of protective coverings and/or supports directly over the component (bundle segment, protective covering or support) you want to analyze. If the component you want to analyze is not a bundle segment, protective covering or a support, the list returned will be empty. Example

• • •

Tape A is placed directly over the bundle segment Corrugated tubes B and C are linked to the bundle segment, and corrugated tube B covers tube C Standard support D is linked to the bundle segment

A check (in KWE advanced language) to determine the list of outer layers that directly cover the bundle segment in the example is written as follows:
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Running this check returns: • • The name of the component analyzed, in our case, the bundle segment. The number of outer layers over the bundle segment:

Only 3 are found because corrugated tube B does not directly cover the bundle segment since it covers corrugated tube C. • Followed by the names of these components:
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•

VisualMode
Syntax VisualMode (BundleSegment: Feature, Visualization Mode (LIGHT/FULL): String): Boolean Description This function is useful to minimize the size of the harness in LIGHT mode. It simplifies the visualization, the curve and the diameter only are represented, the rib being deleted. This function is only available for bundle segments belonging to multi-branchable documents. Example Create a rule in Knowledge Expert:

Running this rule displays the harness in LIGHT mode:
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The rule is reversible: you can load a harness in LIGHT mode and reload the geometry by applying the rule with the FULL parameter:

The harness is displayed in FULL mode: the rib is recreated:

Working in LIGHT mode allows you to modify the route and route wires but the split, transfer and add branch point commands are not supported. To know more about these commands, refer to Electrical Harness Installation - Working with
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List
List methods are used to manage lists of parameters, pads ...: They enable the user to create lists, to add items to the list, to remove items from the list, to retrieve values from the list, to move elements of the list to another position, to filter, and to copy the content of a list into another one. • List.Size () : Integer Method used to return the number of items contained in the list. List.AddItem (Object: Objecttype, Index: Integer):VoidType Method used to add an item to the list.

•

let list (List) list.AddItem(PartBody list.AddItem(PartBody Message("#",list.Size()) • Hole.2 ,1) Hole.3 ,2)

List.RemoveItem (Index: Integer) :VoidType Method used to remove an item from the list. List.GetItem (Index: Integer) :ObjectType Method used to retrieve a value/item from the list List.ReorderItem (Current: Integer, Target: Integer ) :ObjectType Method used to move an element of the list to a new position. Copy (List: List) : List Method used to copy the content of a list and paste it in another list. List (Next: ObjectType, ...): List Method used to create a list. List.Sum (): Real Computes the sum of the items contained in the list.. List.IndexOf (Element: ObjectType, StartIndex:Integer):Integer Returns the index of a list item. Compute() Function used to compute the result of an operation performed on the attributes supported by the features contained in the list.

•

•

•

•

•

•

•

75

knowledgeware

• • • • •

Example: List.1 .Compute("+","Hole","x.Diameter",Length.1) Where: List.1 is the name of the list on which the calculation will be performed + is the operator used. (Supported operators are: -, min, and max.) Hole is the type of the list items used for the calculation (to calculate the diameter, the type to be indicated is Hole, to calculate the volume, the type to be indicated is Solid) x stands for the list items. Note that the type of the items contained in the list should be identical. Length.1 is the output parameter.

Note that this method is available for Actions only. • Filter() Method used to filter a list of objects by extracting the objects that fulfill a Boolean expression. This method has the following signature: List.Filter(String TypeName,String Expression) : List TypeName is the type of the objects that the user wants to extract (in can be o . In this case, no filtering is done on types)

o

The second string Expression corresponds to the Boolean expression that must fulfill the objects of this given type. In this expression x is used as the variable name of type TypeName. This string . In this case, no expression is checked.

can be equal to

Example: I = (List.Filter( I = (List.Filter( Hole Hole , , x.Diameter > 3mm )).Size() )).Size()

Note that this method is available for Actions only.

Measures
Measures are functions that compute a result from data captured from the geometry area. Measures are application-related objects and they won't be displayed in the dictionary if you don't have the right product installed (Part Design or Generative Shape Design for example).
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User Tasks Sample: KwrMeasuresWiz.CATPart • distance(Body1, Body2) : Length Returns the distance between two bodies of a part. minimumCurvatureRadius(Curve):Length For an item of dimension 1 (a curve), enables the user to measure its minimum radius of curvature. nbDomains(Body): Integer For all types of items, enables the user to compute the number of domains. length(GSMCurve) :Length Returns the total length of a curve. length(GSMCurve, Point1, Point2) : Length Returns the length of a curve segment delimited by Point1 and Point2. length(GSMCurve,Point1,Boolean): Length Returns the length of a curve segment located between Point1 and one of the curve ends. Modifying the boolean value allows you to retrieve the length from the specified point to the other end. area(Surface): Area Returns the area of a surface generated by the Generative Shape Design product (an extruded surface for example). area(Curve) : Area Returns the area delimited by a curve. perimeter(Surface,...):Length Returns the perimeter of a surface. It can take several surface features in input. The perimeter function sums up the perimeter of each surface. The returned value is a length. point.coord(Integer): Length Returns the coordinate of a point. Returns X if 1 is specified, Y if 2 is specified, Z if 3 is specified. Body.centerofgravity(x: out length, x: out length, z: out length): Void Type Enables the user to compute the center of gravity. volume(Volume geometry,...) : Volume Returns the volume of a volume. volume(closedSurface) : Volume

•

•

•

•

•

•

•

•

•

•

•

•
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Returns the volume of a closed surface. • angle(Center: Point1, Pt1: Point2, Pt2) : Angle Returns the angle between the lines "C-Point1" and "C-Point2". angle(Direction,Direction) : Angle Returns the angle between two directions. angle(Line, Line) : Angle Returns the angle between the Line1 and Line2 lines. angle(Plane, Plane) : Angle Returns the angle between 2 planes. angleoriented(Direction, Direction, Direction): Angle Returns the angle between 2 directions and oriented by a third direction. angleoriented(Line, Line, Direction): Angle Returns an angle between 2 lines and oriented by the direction. angleoriented(Plane, Plane, Direction): Angle Returns an angle between 2 planes and oriented by the direction. curvature(crv: Curve, pt: Point): Real Returns the curvature of a curve in a given point. distancedir (Body, Body, Direction): Length Returns the distance between two bodies of a part and oriented by the direction.

•

•

•

•

•

•

•

•

Part Measures
smartVolume and smartWetarea refer to intermediate states of a solid. smartVolume does not compute the volume of each pad contained in a PartBody but the total volume. Example: Given a PartBody containing 3 pads: The volume of Pad.1 = 0.1m3, The volume of Pad.2=0.1m3 and the volume of Pad.3=0.1m3. The Volume of Pad.3 displayed will be Pad.3=0.3M3. The volume of Pad.3=the Volume of Pad.1+ the volume of Pad.2+ the volume of Pad.3. Note that this applies also to smartWetarea (the total wet area is computed). • smartVolume(elem: Solid, ...): Volume Returns the volume of a solid. Example
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Total_Volume= smartVolume(PartBody) • smartWetarea(elem: Solid, ...) : Area Returns the wet area of a solid. Example Total_Area= smartWetarea(PartBody Pad.1 )

Mathematical Functions
Sample (illustrates interpolations): KwrInterpolations.CATPart Note that the input of the cosine function should be an angle despite its signature that allows real numbers. As a consequence, cos(3.14) for example is equivalent to cos (3.14 * 1rad) in the formula editor. However a warning is displayed. Note that this applies also to the sinus and the tangent functions.

•

abs(Real): Real Calculates the absolute value of a number. ceil(Real): Real Returns the smallest integer value that is greater than or equal to the value specified in the argument. floor(Real):Real Returns the largest integer value that is less than or equal to the value specified in the argument. int(Real):Real Returns the integer value of a number. let Assigns a value to a temporary variable ( let x = 30 mm ) min(Real,Real):Real, max(Real,Real) Returns the minimum or maximum of a set of values specified in the argument. sqrt(Real):Real Returns the square root. log(Real):Real Returns the logarithm.

•

•

•

•

•

•

•
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•

ln(Real):Real Returns the natural logarithm. round(Real):Real Returns a rounded number. round(Real, String, Integer):Real Returns a rounded number. o o o For Real = 13.552mm String = m (for meter) Integer = 2

•

•

The returned number is 13 mm • • exp(Real):Real Returns the exponential. LinearInterpolation(arg1:Real, arg2:Real, arg3:Real) : Real Should be used when creating a parallel curve from a law. Example: 1 - Create a line in the Generative Shape Design workbench 2 - Access the Knowledge Advisor workbench and create the law below: FormalReal.1 = LinearInterpolation(1,9,FormalReal.2) 3 - Back to the Generative Shape Design, create a parallel curve. Select the Law mode and specify the law above as the one to be applied. CubicInterpolation(arg1:Real, arg2:Real, arg3:Real) : Real Should be used when creating a parallel curve from a law. Example: 1 - Create a line in the Generative Shape Design workbench 2 - Access the Knowledge Advisor workbench and create the law below: FormalReal.1 = CubicInterpolation(1,50,FormalReal.2) 3 - Back to the Generative Shape Design, create a parallel curve. Select the Law mode and specify the law above as the one to be applied. mod(Real,Integer): Real Enables the user to retrieve the rest of the division of the integer part of the real by the integer. Syntax: mod(Real,Integer):Real Sample: Mod.CATPart

•

•

•
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•

Cos(Real):Real, cosh (Real): Real Calculates the cosine(cos) or hyperbolic cosine(cosh). Example Real.1 = cos(PI*1rad/4) Real.1 = cos(45deg) tan(Real): Real, tanh(Real): Real Calculates the tangent(tan) or hyperbolic tangent (tanh). sin(Real):Real, sinh(Real):Real Calculates the sine or hyperbolic sine. asin(Real):Real, asinh(Real):Real Calculates the arcsine or hyperbolic arcsine. acos(Real):Real, acosh(Real):Real Calculates the arccosine or hyperbolic arccosine. atan(Real):Real, atanh(Real):Real Calculates the arctangent or hyperbolic arctangent. max(arg1: Real, arg2: Real, ...):Real Returns the highest parameter. min(arg1: Real, arg2: Real, ...):Real Returns the smallest parameter. not(Boolean):Boolean Verifies the contrary of the expression between parentheses. Example: not(A==B) is the equivalent of A<>B. For these methods to be efficient, you should use real numbers only.

•

•

•

•

•

•

•

•

Creating a Formula
This task explains how to create a formula specifying that the external radius of a hollow cylinder is twice its internal diameter. Note that the radius of a sketch can be defined by a formula provided it is declared as a constraint. Make sure the Relations option is active in the Tools->Options...>Infrastructure->Part Infrastructure->Display tab. 1. Open the KwrStartDocument.CATPart document. 2. Click the icon to display the f(x) dialog box. Make sure that the

81

knowledgeware

Incremental box is unchecked. Method 1 o Double-click the PartBody Sketch.1 Radius.3 Radius parameter in the parameter list. The Formula Editor is displayed. Enter the PartBody Hole.1 HoleLimit.1 Depth*2 relation in the formula field. Go to Tips and Techniques for information on how to manipulate parameters and formulas. Click OK in the Formula Editor.

o

o

Method 2 o Select the PartBody parameter list. Sketch.1 Radius.1 Radius in the

o o

Click Add Formula. The Formula Editor is displayed. Enter the PartBody Hole.1 HoleLimit.1 Depth*2 relation in the formula field. Go to Tips and Techniques for information on how to manipulate parameters and formulas. Click OK in the Formulas Editor.

o

3. Click Apply to update the document. 4. Click OK to close the dialog box.

Creating Formulas based on Publications
This task explains how to create a formula based on publications in a CATProduct file.

1. Open the Screw1.CATPart document. 2. Add a Volume parameter to the part. o Click the icon. The Formula Editor opens. In the New parameter of type scrolling list, select Volume and click the New parameter of type button. In the Edit name or value of the current parameter field, enter the

o
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name of the parameter: ScrewVolume1. Click Apply and click the Add Formula button. The Formula Editor opens. o Enter the following formula by using the Dictionary to access the smartVolume operator: ScrewVolume1=smartVolume(PartBody times. Pad.1). Click OK three

3. Create another Volume parameter called ScrewVolume2 based on Pad.2. 4. Create another Volume parameter called Volume_Total. Click OK when done to exit the Formula editor. 5. Access the Tools->Publication menu, and select the 3 parameters that display below the Parameters node. Assign them new names (see graphic below):

6. Click OK when done. The parameters, the formulas, and the publications are created (see graphic below).
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7. Save your file and close it. 8. Open the Screw2.CATPart document. Repeat the above steps (2 to 7).

9. Create a new product (File->New menu). Click OK when done. 10. Select the Insert->Existing Component... command to insert Screw1.CATPart into the product. 11. In the File Selection window, select the Screw1.CATPart file that you have just saved. Click Open. 12. Create a formula that will compute the volume of the screw. o Click the Root product and click the icon. The Formula Editor

84

User Tasks

opens. o Enter the following formula into the editor by selecting the publications in the specification tree:

o o Click OK when done. The screw volume is displayed below the parameters node.

13. Double-click screw.1 in the specification tree, right-click it, and select the Components>Replace Component command. 14. In the File Selection window, select the screw2.CATPart file that you have just saved and click Open. 15. Click OK in the Impacts On Replace window. The new screw is inserted into the product and its volume is computed.
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Specifying a Measure in a Formula
The purpose of this task is to explain how to specify that the value of a Length type parameter is equal to the curvilign abcissa of a point located on a curve. Measures, i.e. values captured from the geometry area can be used in formulas. Here are some examples of measures that can be used in formulas: • • • Distance between two points. Total length of a curve. Length of a curve segment - between a point and the origin or between a point and the curve extremity. Length of a curve segment - between two points. Area of an extruded surface.

• •

1. Check the Load extended language libraries box in the Tools>Options->General->Parameters and Measure->language tab. 2. Open the KwrMeasure.CATPart document. The whole document has been created using the Generative Shape Design product. The Extrude.1 and Extrude.2 surfaces are extruded from the Spline.1 and Spline.2 curves. The point whose abscissa is to be measured is Point.5. The origin of the curve where Point.5 is located on is Point.8

3. Click the Formula icon. The f(x) dialog box is displayed. 4. Create the CurveLengthFromOrigin parameter.

86

User Tasks

o

Select the Length item with Single Value in the New Parameter of type list, then click New Parameter of type. The new parameter appears in Edit name or value of the current parameter. Replace the Length.1 name with CurveLengthFromOrigin, and click Apply.

o

5. Specify that the value of CurveLengthFromOrigin is the abscissa of Point.5: 4. a. Select the CurveLengthFromOrigin parameter in the parameters list, then click Add Formula. The Formula editor is displayed. b. Select the Measures item from the Dictionary list. c. In the list of measures, double-click the length(Curve,Point,Boolean) item. The length function is added to the Formula Editor.

d. Fill in the Formula editor field as indicated below. 1. The three arguments are: a curve to be selected from the geometry area, a point to be selected from the geometry area and a boolean. 2. Position the cursor where the first argument is intended to be typed. Then double-click the Spline.2 feature in the specification tree. The curve argument is added to the length definition. 3. Position the cursor where the second argument is intended to be typed. Then double-click the Point.5 feature in the specification tree. The point argument is added to the length definition. 4. Type a boolean for the third argument: True if the length is to be calculated from the origin, False if the length is to be calculated from the curve end.

5. Click OK to confirm the formula definition. You are
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back to the Formulas dialog box. The CurveLengthFromOrigin formula and value(47.5mm) are added to the parameter list. e. Click OK to add the parameter as well as its formula to the document.

Using Geometry to Create a Formula
This task explains how to use geometry to create a formula. Before performing this scenario, make sure you have checked the Keep link with selected object option (Tools->Options-> Infrastructure->Part Infrastructure->General tab.) 1. Create a Product and add 2 parts to this product. 2. From the Start->Shape menu, access the Generative Shape Design workbench. Select the first part. 3. Add a line to the part. 4. Select the second part and add a Length parameter to the part as well as a formula that will be based on the line. o Click the icon. The Formula Editor opens. In the New parameter of type scrolling list, select Legnth and click the New parameter of type button. In the Edit name or value of the current parameter field, enter the name of the parameter: LineLength. Click Apply and click the Add Formula button. The Formula Editor opens. Enter the following formula by using the Dictionary to access the length(Curve,...) operator: LineLength=length(). Position the cursor between the parenthesis and double-click the Line in the geometry or in the specification tree. The External parameter selection window is displayed. Select Line.1 and click OK. The formula is displayed as follows: LineLength=length(`External References\Line.1` ) Click OK when done. Click Yes in the Automatic update window.

o

o o

o o
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5.

Refering to External Parameters in a Formula
This scenario shows how to use external parameters in a formula. In a formula, you can use parameters defined in external documents. This works between any types of document. For example, in a CATPart document, you can specify a formula referring to parameters defined in a CATDrafting document. External parameters can also be used when working within an assembly. Prior to performing this scenario, make sure that the Keep link with selected object option is checked (Tools->Options...->Infrastructure->Part Infrastructure->General).
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1. Open the KwrStartDocument.CATPart document as well as the KwrImportParameter.CATPart document. Select the Window->Tile Vertically command from the standard menu bar. Both documents are displayed. 2. Make active the KwrImportParameter document. Click the icon to display the f(x) dialog box. 3. Create a parameter of Length type and click the Add Formula button. The formula editor is displayed. 4. In the KwrStartDocument specification tree, select the Hole.1 feature. The External parameter selection dialog box is displayed.

5. In the External parameter selection dialog box, select the Diameter object in the external parameter list. Then click OK. The Length.1 definition is carried forward to the formula editor. (Click the picture below to enlarge it.)

6. Complete the formula definition as indicated below: Length.1 = Diameter*0.45 7. Click OK in the formula editor. You are back to the Formulas dialog box. In the parameter list, the Length.1 parameter value is modified according to the formula specified. In the KwrImportParameter specification tree, the External Parameters node is added. Expand this node to display the Diameter parameter.
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8. Click OK to add the formula to the KwrImportParameter.CATPart document and exit the dialog. 9. Select the Edit->Links command from the standard menu bar. The displayed dialog box confirms that there is a link between the KwrImportParameter KwrStartDocument Length.1 object and the PartBody Hole.1 Diameter object.

10. Click Isolate in the Links dialog box, then click OK. In the KwrImportParameter.CATPart specification tree, the External Parameters node can no longer be expanded and the Diameter parameter is added below the Parameters node.

11. Select the Edit->Links command from the standard menu bar. A message box informs you that the active document has no external links.

12.
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Using the Equivalent Dimensions Feature
This scenario explains how to use the Equivalent Dimensions Feature. The scenario described below is divided into the following steps: • • you apply constraints to an existing sketch. you use the Equivalent Dimensions feature to create a list of Length type parameters that will have the same value.

To know more about the Equivalent Dimensions feature, see Getting Familiar with the Equivalent Dimensions Interface. 1. Open the KwrEquivalentDimensions.CATPart. The following image is displayed:

2. In the specification tree, expand the PartBody node and double-click Sketch.1 to access the sketcher. 3. Double-click the Constraint icon ( graphic below). ) to constraint some lines of the sketch (see
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4. In the Knowledge toolbar, click the Equivalent Dimensions icon ( Equivalent Dimensions Edition window is displayed.

). The

5. Click the Edit List... button. In the opening window, use the arrow key to select the following parameters and click OK when done. o o o Length.34 Length.36 Length.37

6. In the Equivalent Dimensions Edition window, set the value to 150mm and click OK. 7. Exit the Sketcher. The sketch is modified accordingly and the EquivalentDimensions.1 feature is displayed below the Relations node.
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8. Double-click Value=150mm twice in the specification tree. The Edit Parameter window is displayed. 9. Enter 140mm and click OK.

Getting Familiar with the Equivalent Dimensions Interface
• • The Equivalent Dimensions Interface The Equivalent Dimensions Contextual Menu

The Equivalent Dimensions Interface
You can create an Equivalence Dimensions feature. This feature can be accessed by clicking the ) in the Knowledge toolbar. It is the equivalent of a formula Equivalent Dimensions icon ( applied to Length and Angle parameters. It is designed to enable you to apply the same value to selected parameters. It can be used with the following parameters: • • 3D parameters Sketch parameters Note that this new command cannot be used in association with parameters valuated by a formula. To create this feature: • click the Equivalent Dimensions icon ( window is displayed. ). The Equivalent Dimensions
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A new scrolling list enables you to select the type of the Equivalent Dimensions Feature: Length or Angle if no parameter is already selected in the specifications tree. Note that this field is grayed out if a parameter is already selected.

•

Click the Edit List... button. The following image is displayed: • Note that only the parameters having the same type as the one selected in the Type: scrolling list display in the Parameters column. (The Length parameters are selected in the opposite picture.) Note that the Apply Filter Name function enables you to perform a search on a given string. The result of your search is displayed in the Parameters list. Note that if you select a 3D feature in the document, only the parameters of this feature will display in the Parameters list.

•

•

In the Parameters list, use the arrow key to select the parameters that will have the same value.
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The Equivalent Dimensions feature can be edited by double-clicking it in the specification tree so that you can: • • • Display the list of parameters belonging to the equivalent dimensions feature. Add or remove parameters from the equivalence list. Modify the value of the parameters.

Note that: • • The value of the parameters belonging to the equivalence list changes when you change the value of one of the parameters of the list. If you want (for example in a reaction) to modify the parameters used in an equivalent dimensions feature, and want this modification to be propagated to the equivalent dimensions feature itself, you should modify the "Value" parameter of the equivalent dimensions feature and not one of the parameters of this equivalent dimensions feature.

The Equivalent Dimensions Contextual Menu
You can access the Equivalent Dimensions contextual menu by right-clicking the equivalent dimensions feature in the specification tree. The Definition... command enables you to access the Equivalent Dimensions Edition window. The Deactivate... command enables you to deactivate the equivalent dimensions feature. In this case an icon indicates that the feature is disabled. To enable it, rightclick it and select the Activate... command. The Hide command enables you to hide the equivalent dimensions feature. In this case, it will not display in the specification tree. The Reorder... command enables you to reorder the equivalent dimensions features (if you have created more than one of these features.)

Controlling Relations Update
This topic provides you with 2 short examples showing you how to work with relations in Synchronous and in Update relation at global update command
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modes. • • In the first example, you update a formula. In the second example, you update an equation.

•

For a given relation, it is possible to determine that it only executes in Synchronous mode using the Edit->Properties command. Its evaluation can then be launched manually. The Synchronous mode enables you to create synchronous relations, that is to say relations that will be immediately updated if one of their parameters is modified. Relations based on parameters are the only ones that can be synchronous.

•

For a given relation, it is also possible to decide that its evaluation will be launched when the part is updated (Update relation at global update command). The relations can be asynchronous for 2 reasons: o You want the relation to be asynchronous o The relation contains geometry.

It is possible to change the update mode of a relation after it is created. • • Right-click the relation in the specification tree and select the Properties command. Check the Synchronous or the Update relation at global update command check box.

To know more about the Synchronous or the Update relation at global update command options, see the description of the Knowledge tab in the Infrastructure User's Guide.

Updating a Formula
In this example, the document contains 2 parameters of Length type: • Length.1 is valuated by you. Length.2 is valuated by a formula computing

•

97

knowledgeware

the distance between 2 points + Length.1.

1. Open the KwrUpdatingaFormula.CATPart file. The following image is displayed.

2. Expand the Relations node (if need be), right-click Formula.1 and select the Properties command. 3. In the Properties window, uncheck the Update relation at global update command check box. Click OK to validate. 4. Double-click Length.1. The Edit parameter window is displayed. Enter 50 in the value field. Click OK to validate. The value of Length.2 is updated automatically and an update icon is displayed indicating that it will also be updated at the global update. 5. Right-click Formula.1 and select the Properties command. 6. In the Properties window, uncheck the Synchronous check box and check the Update relation at global update command check box. Click OK to validate. 7. Double-click Point.2 in the specification tree or in the geometry. 8. Enter the following values in the Point Definition window and click OK when done:
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The Formula is not updated and an update icon is displayed next to the formula. 9. Right-click Formula.1 and select the Local Update command. The formula and Length.2 are updated.

Updating an Equation
In this example, you change 3 parameters, a, b and c before solving the equation. If you use the Synchronous mode, an error is displayed when modifying the parameters values since the update is launched at each modification. To ensure the stability of the equation, the update must be launched after the 3 parameters are changed. Thus you need to select the Update relation at global update command mode. 1. Open the KwrUpdatinganEquation.CATPart file. The following image is displayed: This document contains 4 parameters. x is a parameter valuated by an equation based on the other 3 parameters (a, b, and c).

2. Expand the Relations node (if need be), right-click Equations.2 and select the Properties command. 3. In the Properties window, check the Synchronous check box and uncheck the Update relation at global update command check box. Click OK to validate. 4. Double-click a in the specification tree. The Edit Parameter window is displayed. Enter 2 in the value field. A message is displayed indicating that the equation cannot be solved and click OK.
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5. Click Close. 6. Right-click Equations.2 and select the Properties command. 7. In the Properties window, uncheck the Synchronous check box and check the Update relation at global update command check box. Click OK to validate. 8. Double-click a in the specification tree. The Edit parameter window is displayed. Enter 2 in the value field. Click OK. 9. Double-click b in the specification tree. The Edit parameter window is displayed. Enter 5 in the value field. Click OK. 10. Double-click c in the specification tree. The Edit parameter window is displayed. Enter 2 in the value field. Click OK. 11. Right-click the equation in the specification tree and select the Local udpate command.
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The equation is updated as well as the x value. For the equation to be solved, the Update relation at global update command option must be checked and the relation must be either integrated to the global update or updated manually using the Local Update command.

Associating URLs and Comments with Parameters or Relations
Associating URLs & Comments with Features
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Assigning a Comment to a Knowledge Feature
This tasks shows how to add comments to parameters and formulas using the URLs & Comment toolbox as well as the Properties dialog box. You can now edit the text that is displayed in the contextual bubbles when dragging your mouse over a relation or a parameter so that you can assign a text to a particular feature. There are 2 ways to edit the text that is displayed in the contextual bubbles: 1. Select the feature to which you want to add a comment. 2. Click the Comment & URLs icon ( ).

3. Enter the text you want to display in the Comment field. 4. Click OK when done. - Or 1. Right-click the relation in the specificatio n tree. 2. Select the Properties command. 3. Enter the comment in the
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Comment field of the Properties dialog box. Note that: • • if you want the value of the parameter/formula to display, the "\V" combination should be used (see example below). if no comment is added to the feature, the default name of the feature will be displayed.

1. Open the KwrComment.CATPart file. This file contains 3 Length type parameters and a formula that computes the length of a line. 2. From the Start->Knowledgeware menu, access the Knowledge Advisor workbench. 3. Click the Length.1 parameter in the specification tree and click the Comment & URLs icon ( ). 4. In the Comment field, enter Length.1 is equal to Length.2: \V. Click OK when done. 5. Right-click Formula.1 in the specification tree, and select the Properties command. 6. In the Comment field of the Properties dialog box, enter the following text: Formula that computes the length of the line. 7. Drag your cursor over Length.1 and Formula.1: The bubbles text is modified (see picture below.)

8.

Design Tables
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Introducing Design Tables
A design table: • provides you with a means to create and manage component families. These components can be for example mechanical parts just differing in their parameter values. is a tool mainly intended to ease the definition of mechanical parts. It is provided to all CATIA users. But you will make the best use of it in a Knowledge Advisor application. A design table can be created from a CATIA document, the document data is then exported to the design table. It can also be applied to a document, the document data is then imported from the design table. is designed to drive the parameters of a CATIA document from external values. These values are stored in the form of a table either in a Microsoft Excel file on Windows or in a tabulated text file. When using a design table the trick is to associate the right document parameters with the right table parameters. The design table columns may not all correspond to your document parameters and you may decide to apply only part of the design table values to your document. By creating associations, you declare what document parameters you want to link with what table columns. • becomes a more powerful tool when it is used with the Knowledge Advisor. You are provided with functions to read the design table parameters. These design table functions can be used when programming your checks and rules. Using these functions spares you all the association operations. To know more, click here.

•

•

Example

Screws are a good example of mechanical parts that can be described by a design table. To simplify, imagine they are all described by four parameters: the head width, the head height, the body width and the body height. The sets of four parameter values that can be assigned to a screw can be easily regrouped in a design table. This design table has as many columns as screw parameters and as many rows as sets of parameter values. In a design table, a set of parameter values is called a configuration and it is registered in a row. Design Table Formats • • The Excel Sheet Format (under Windows) The Tabulated Text File Format
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•

The CATIA Design Table

Design Table Status

Design Tables Formats
The Excel Sheet Format (under Windows)
The values mentioned in the sheet cells have to be expressed in appropriate units. Otherwise, the right values won't be associated with the document parameters. Only Excel sheets created with Excel 97 and subsequent versions are supported.

If no unit is mentioned within a cell: • the unit taken into account is the one mentioned in the first row • and if no unit is specified in the first row, the unit taken into account is the relevant SI unit.

Here is an example of an Excel sheet: When a configuration which contains empty cells is selected, the parameters associated with the empty cells are not modified. This property enables you to modify parameters but only under certain conditions.

column name

column unit
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Within a given column, you can change the units.

Units can be specified in cells. No unit = SI

Note that it is highly recommended to choose the General format and not the Cells format in Excel.

The Tabulated Text File Format
Here is an example of a tabulated file format. You can use your favorite text editor to create this design table. Use the Tab key to skip from one column to the other. Unit rules are the same as for the Excel sheets.

106

User Tasks

Under UNIX, it is possible to change the default design table editor. To do so, type: export CATTextEditorDT=... (indicate the path of the editor.)

The CATIA Design Table
Once it has been read and processed by CATIA, the design table looks something like this: No units in column Check box to modify the activity
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Displays the design table raw Values with units data.

Duplicates the design table external data into the CATIA document. Check this box whenever you intend to re-access your design table on another platform.

Design Tables Status:
Design tables can have different statuses: Synchronized: The Design Table is copied into the model ("Duplicate data in CATIA model" option checked) and the data stored in the model are synchronized with the content of the file. Not synchronized: The Design Table is copied into the model ("Duplicate data in CATIA model" option checked) and the data stored in the model are synchronized with the content of the file. (The .xls or .txt file was modified outside CATIA.) Inactive: The Design Table is deactivated. The associated parameters are not driven by the design table any longer. Broken: The Design Table is functionally KO because it cannot be used to valuate the associated parameters (data cannot be accessed because the file is lost or there are 2 columns with the same name ...). Light Broken: The filter is not compatible with the current configuration, or if the current configuration value does not correspond to one of the rows of the file.

Getting Familiar with the Design Table Dialog Box
Here is the dialog box sequence you get onscreen when you click the standard toolbar. icon in the

Creation of a design table
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"Create a design table from a pre-existing file" check box Check this option whenever you want to create a design table from the values of an external file. In this case, the created design table is made up of: • either only the columns whose name is a document parameter name. If the external file contains a "Length" column but no such "Length" parameter is defined in the document, the "Length" column will not appear in the created design table. This is the "automatic" association process. • or only the columns that have been associated one-by-one with a document parameter. If the external file contains a "Length" column but no so-called parameter in the document, you can choose to associate the "Length" column of the external with a parameter of the same type (a sketch radius for example).

"Create a design table with current parameter values" check box Check this option whenever you want to create a design table from a subset of the document parameters. You just have to select among all the document parameters the ones you want to be included as columns in the design table. In this case, the created design table only contains a single row. The Orientation check boxes These options allow you to choose the design table orientation. A vertical orientation is recommended when the design table contains many parameters.
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knowledgeware The sheet index You can specify an Excel or Lotus sheet number. The Destination field All knowledgeware relations such as design tables, rules, checks or formulas, are created by default below the Relations node. Creating a relation below a given feature may help you organize your document. To specify a destination, select the default destination in the Destination field, then click the feature intended to be the new destination either in the specification tree or in the geometry area.

Selection of the parameters to insert
This dialog box pops up when you check the "Create a design table with current parameter values" check box.

There are two ways to restrict the list of parameters to be displayed in the 'Parameters to insert' list. You can use the: 1. Filter Name field Use the * character to specify any string to be included in a parameter name. Specifying *Len* will display in the "Parameters to insert" part of the dialog box all the parameters having the Len substring in their name. 2. and the Filter Type field. When you click OK in the dialog box above, the "Select the pathname of the file to be created" window is displayed.

Selection of the file to be created
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Use this dialog box to specify the .xls (Windows) or .txt file to be created. Specify the .xls extension when filling out the 'File name' field. Then click Open to display the design table dialog box. When working in a french environment, make sure that the decimal numbers contained in the text file linked to the design table are not written with a comma "," but with a decimal point. (This way you will be able to move to an english environment easily.)

Design table dialog box
The 'Configurations' tab
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knowledgeware The current configuration as well as its number (< configuration number >) are highlighted. To change the current configuration, you just have to click the new configuration in the design table. A single row design table is created when you generate a design table with the current parameter values. • The Filter The filter is a means to help you query for a configuration meeting specific criteria. Click the "Edit... " button to display the "Design Table Request Editor". See Using the Dictionary for information on how to use the syntax provided by the dictionary. In a query, you can specify a condition referring to the design table parameters as well as the parameters external to the design table. • The "Activity" check box A design table is created active by default. The activity check box provides you with a way to deactivate the design table to be created. The "Edit table..." push button Click this button to display the edit table to be created. Depending on whether you have selected a .xls extension or not, you will launch a Microsoft Excel application or your default text editor for a .txt file. The "Duplicate data in CATIA model" check box Check this box whenever you intend to reuse your document on an operating system different from the one used to create the design table. That way, your design table data will be duplicated into your document.

•

•

The "Associations" tab
This tab provides you with a way to associate the document parameters with the columns of the external design table. The left part of the dialog box allows you to associate parameters with the design table columns while the right part displays the list of associated parameters.
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•

The "Create parameters..." push button When a parameter is referred to in the design table but has not been created in the document, clicking this button allows you to create a parameter in the document and associate it with the right column of the design table. The "Rename associated parameters" push button If a parameter does not have the same name as the column it is associated with, you can rename this parameter so that it has the same name as the column. Clicking the "Rename associated parameters" push button displays a dialog box which asks you whether you want to rename all the parameters or only a few of them.

•

Creating a Design Table from the Current Parameters Values
A design table is a feature that you create from your document parameters or from external data. No matter the existence of external data, you must create the design table in CATIA. There are two ways to create a design table: • • From the current parameter values From a pre-existing file.

The scenario described below explains how to proceed in the first case. The design table creation process includes the following steps:
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a. Create a table from the document parameters. b. Select the parameters to add to the design table. c. Specify a file to contain the generated design table. d. Edit the generated CATIA design table. e. Apply the design table to your document. For information on how to use the different dialog boxes related to the design table, see The Design Table Dialog. 1. Open the KwrStartDocument.CATPart document. 2. Click the Design Table icon in the standard toolbar. The Creation of a Design Table dialog box is displayed. See The Design Table Dialog for further information. 3. If need be replace the default name and comment for the design table. 4. Check the Create a design table with current parameter values option. 5. Click OK. The Select parameters to insert dialog box is displayed. 6. In the Parameters to insert list, select the PartBody Pad.1 FirstLimit Length and the

PartBody Pad.1 SecondLimit Length items. Then click the right arrow to add both items to the Inserted parameters list. 7. Click OK. A file selection box is displayed. 8. Specify the pathname of the design table to be created. Click OK in the file selection dialog box. The design table feature is added to the specification tree and a dialog box displays the newly created design table. This design table contains only one configuration. By default it is active. If the file specified already exists, the Creation of a Design Table dialog box is re-displayed as well as a message box asking you whether you want to overwrite the existing file. 9. Click Edit table... to start an Excel application (under Windows) or open the text editor under Unix. Replace the PartBody value with 80mm. Pad.1 FirstLimit Length parameter

10. Save your Excel or .txt file and close your application. Some information messages are displayed in a dialog box warning you about events related to the design table. Click Close. 11. Click Apply into the CATIA design table dialog, the document is updated as well as the CATIA design table. Click OK to exit the dialog and add the design table to the document.
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Creating a Design Table from a Pre-existing File
A design table is a feature that you create using your document parameters or external data. No matter the existence of external data, the design table must created in CATIA. There are two ways to create a design table: • • Using the current parameter values Using a pre-existing file

The scenario below describes how to proceed in the second case. Here are the main steps to follow: a. Select the pre-existing file containing the raw data. b. Create the associations between the document parameters and the external table columns. You can choose to create these associations automatically. c. Edit the generated CATIA design table. d. Select a configuration in the generated design table. You can modify the default configuration proposed by CATIA. e. Apply the design table feature to your document. For information on how to use the different dialog boxes related to the design table, see The Design Table Dialog. It is now possible to select a Design Table external file from a VPDM (ENOVIA LCA, ...). To do so, make sure you have enabled the desired environment in the Document Environments field (Tools->Options>General->Document.) Your documents will be accessible via the Document Chooser. 1. Open the KwrStartDocument.CATPart document. 2. Click the Design Table icon ( ) in the standard toolbar. The Creation of a Design Table dialog box is displayed. Enter a name (DesignTable1 for example) and a comment. 3. Check the Create a design table from a pre-existing file option. Click OK. 4. Select the KwrBallBearing.xls file, and click Open. A dialog box asks you whether you want to perform automatic associations between the design table columns and the document parameters which have the same name. 5. Click Yes. The Material parameter is the only one which is common to the document parameters and to the external design table. A multi-row design table is created. The '<' and '>' symbols denote the current configuration. 6. Select the configuration you want to apply to the document (line 4 for
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example). Click Apply. The Iron parameter value is displayed in the specification tree. 7. Click OK to end the design table creation.

The scenario below illustrates how to create a design table by associating one by one the document parameters with the input file columns. 1. Open the KwrStartDocument.CATPart document. Design Table icon in the standard toolbar. 2. Click the The "Creation of a Design Table" dialog box is displayed. Enter a name (DesignTable2 for example) and a comment. 3. Check the Create a design table from a pre-existing file option. Click OK. A file selection window is displayed. 4. Select the KwrBallBearing.xls file. Click Open. The Automatic associations dialog box is displayed. 5. Click No. The design table dialog box informs you that there is no associations between parameters and columns. Now, you have to associate one by one the document parameters with the design table columns. 6. Click the Associations option. The table design dialog box now displays side by side the document parameter list and the input file columns. 7. In the Parameters list, select the PartBody Hole.1 Diameter item. In the Columns list, select the d1 parameter. Then click Associate. A parameter couple is now displayed in the Associations between parameters and columns list. 8. Repeat the same operation for the Material parameter. Selecting a parameter or an association in the list highlights the corresponding values in the geometry area. The parameter list can be filtered: o By clicking on a feature (either in the specification tree or in the geometry area). All the parameter values of the selected feature (and children) are highlighted in the geometry area. The parameter list displays only the parameters of the selected features (and children). By specifying a string in the Filter Name field. For example, typing *ength* enables you to display all Length parameters By specifying a type in the Filter Type field.

o o

The Create parameters... button allows you to create automatically parameters and associations for items of the Columns list. The Rename associated parameters button replaces the parameter name with the

116

User Tasks

column name. 9. Click OK to end the DesignTable2 creation dialog. The DesignTable2 feature is added as a relation to the specification tree. Double-click DesignTable2 in the specification to edit the table. By default, the configuration 1 is applied to the document. A new material (Aluminum) is applied to the document and the hole diameter is modified.You can select another configuration and apply it to your document.

Interactively Adding a Row To a Design Table External File
The task described below explains how to add a row to a design table external file. The scenario is divided into the following steps: • • • • You open the CATPart file and inserts the design table You deactivate the design table and creates a new configuration You add the configuration to the design table external file You activate the design table and implements the new configuration

This new function enables you to add a contextual menu on design table feature (in the tree) which appears only: • • • If the design table is deactivated If the design table external file exists and is read/write If at least one parameter is associated.

The behavior of this command is to add a row at the end of the design table file with associated parameters values. For not associated columns, an empty cell is added. To perform this scenario, you will need the following files: KwrAddARow.CATPart KwrAddARow.xls Note that this task can only be performed in an english environment.
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Prior to performing this scenario, make sure the With value and With formula options are checked in the Tools->Options->General->Parameters and Measure->Knowledge tab. 1. Open the KwrAddARow.CATPart file. The following image is displayed.

2. Click the Design Table icon (

).

3. Click the Create a design table from a pre-existing file radio button and click OK. 4. In the opening File Selection window, select the KwrAddARow.xls file and click Open. 5. Click Yes in the Automatic associations window: The design table opens. Click OK to close it. 6. Click the Measure update icon to update Formula.1. 7. Under the Design Tables node, double-click Configuration=1. The Edit Parameter dialog box is displayed. 8. Click the Design table icon in the Edit Parameter dialog box: The Design Table window is displayed. 9. In the dialog box, select the second configuration (line 2), click Apply, and OK twice. 10. Right-click Formula.1 in the specification tree and select the Local Update command. 11. In the Specification tree, right-click DesignTable.1 and select the DesignTable.1 object->Deactivate command. The design table is deactivated. 12. Modify the spline: • Double-click Point.1 twice in the specification tree or in the Geometry. Enter the coordinates indicated below into the Point Definition dialog box.
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•

Modify the coordinates of X Point.2 and Point.3 (see Y table Z opposite) Click OK when done.

Point 1 0 0 0

Point 2 100 100 -100

Point 3 50 50 -226

•

13. Add the new configuration to the design table. To do so, right-click DesignTable.1 in the specification tree and select the DesignTable.1 object>Add row with current values command.

14. Right-click DesignTable.1 and select the DesignTable.1 object->Activate command. 15. Double-click Configuration=1 under DesignTable.1 and click the Design Table icon ( ).

16. In the DesignTable.1 window select the configuration that you have just added and click Apply and OK twice. The spline is updated accordingly.
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Generating a File From a Design Table
This topic explains how to regenerate an external file (.XLS or .txt format) using the data contained in the model. The data contained in the model come from an external file that was previously deleted. There are 2 ways to regenerate the file: • Using the Create New File command: This command is available in the Manage Design Tables window which is displayed only if the Interactive Synchronization at Load option is checked in the Knowledge tab (Tools>Options...->Parameters and Measure). Using the Export Content to file command

•

Using the Create New File Command

1. From the Tools->Options...->Parameters and Measure command, access the Knowledge tab and make sure the Interactive Synchronization at Load option is checked. 2. Open the KwrBallBearing1.CATPart file. The following image is displayed.

3. Click the Design Table icon ( ) in the Knowledge tool bar. The Creation of a Design Table window is displayed. 4. Click the Create a design table from a pre-existing file option and click OK. The File Selection dialog box opens. 5. Select the KwrBearingDesignTable.xls file and click Open. Click Yes when prompted to associate the columns of the table with the parameters. 6. In the DesignTable.1 window, Check the Duplicate data in CATIA model option. Note that if this option is not checked, you will not be able to generate a new file.
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7. Click OK to apply the default configuration. DesignTable.1 is displayed below the Relations node. 8. Save your file and close it. 9. Delete the KwrBearingDesignTable.xls file from its current location. 10. Open the KwrBallBearing1.CATPart file that you have just saved. The Manage Design Tables window is displayed indicating that the external file has been deleted.
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11. Click the Create New File ... button to generate a file from the data contained in the .CATPart document. The Save As dialog box is displayed. 12. Enter the name of the file that you want to create: DT2 in this scenario. .XLS is the default file type. The text format is also available in the Save as type: list. Keep the default settings. 13. Click Save and Close when done. The DT2.xls containing the design table data is created.
Using the Export content to file... command

14. From the Tools->Options...->Parameters and Measure command, access the Knowledge tab and make sure the Manual Synchronization option is checked. 15. Repeat steps 2 to 9. 16. Right-click DesignTable.1 in the specification tree and select the DesignTable.1 object->Export content to file... command.

17. The Save As dialog box is displayed. 18. Enter the name of the file that you want to create: DT3 in this scenario. .XLS is the default file type. The text format is also available in the Save as type: list. Keep the default settings. 19. Click Yes when asked if you want this file to become the new design table source file. The DT3.xls containing the design table data is created.

Controlling Design Tables Synchronization
This topic aims at providing you with short examples when working with design tables in the following modes: • • • Automatic Synchronization At Load Interactive Synchronization At Load Manual Synchronization
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Automatic Synchronization At Load
When loading a model containing user design tables, if the design table files have been modified and the external file data is contained in the model, the design table will be synchronized automatically if this radio button is checked. 1. Open the KwrBallBearing1.CATPart file. The following image is displayed.

2. Click the Design Table icon ( is displayed.

). The Creation of a Design Table dialog box

3. Click the Create a design table from a pre-existing file option and click OK. The File Selection dialog box opens. 4. Select the KwrBearingDesignTable.xls file and click Open. Click Yes when prompted to associate the columns of the tables with the parameters. 5. Click OK to apply the default configuration. 6. Save your file and close it. 7. Open the KwrBearingDesignTable.xls file. Change the material of row 2 to Gold. Save your file and close it. 8. Go back to Catia. Open the part: The Part is updated accordingly to your changes.

Interactive Synchronization At Load
When loading a model containing user design tables whose external source file was deleted, this option enables you to select a new source file or to save the data contained in the design tables in a new file. 1. From the Tools->Options... menu, select General->Parameters and Measure and check the Interactive Synchronization At Load option in the Knowledge tab. 2. Open the KwrBallBearing1.CATPart file. The following image is displayed.
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3. Click the Design Table icon ( is displayed.

). The Creation of a Design Table dialog box

4. Click the Create a design table from a pre-existing file option and click OK. The File Selection dialog box opens. 5. Select the KwrBearingDesignTable.xls file and click Open. Click Yes when asked if you want to associate the columns of the tables with the parameters. 6. Click OK to apply the default configuration. 7. Save your file and close it. 8. Go to the directory containing the KwrBearingDesignTable.xls file and delete it. 9. Go back to Catia. Open the KwrBallBearing1.CATPart file: A dialog box is displayed asking you if you want to select a new file. Click the Select button and select a new Excel file.

Manual Synchronization
When loading a model containing user design tables, if the design table files have been modified and the external file data is contained in the model, the design table will be synchronized if this option is checked. To synchronize both files, right-click the design table in the specification tree and select the DesignTable object->Synchronize command or the Edit->Links command. 1. From the Tools->Options... menu, select General->Parameters and Measure and check the Manual Synchronization At Load in the Knowledge tab. 2. Open the KwrBallBearing2.CATPart file. This file already contains a design table whose values are identical to those contained in the KwrBearingDesignTable.xls file (Note that the KwrBearingDesignTable.xls file and the KwrBallBearing2.CATPart file should be located in the same directory.)
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3. Select the Edit->Links command to edit the Excel file path and select the appropriate KwrBearingDesignTable.xls file. Save the file and close it. 4. Open the KwrBearingDesignTable.xls file and modify the material values for example. Close the file. 5. Go back to CATIA. Open the KwrBallBearing2.CATPart file. 6. Select the Edit->Links command and click the Synchronize button to synchronize both files. If the Duplicate data in CATIA model option is checked, and if you choose another design table file without using the Edit Table command in the CATIA session, the following message is displayed whatever the settings:

If the Duplicate data in CATIA model option is unchecked, the synchronization occurs automatically.

Storing a Design Table in a Power Copy
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This task shows how to store a design table in a power copy for later use. In this scenario, you want to instantiate the inner and the outer cages of a ball bearing in a different context. To do so, you create a power copy only containing the outer and the inner cages of an already existing ball bearing. This scenario is divided into the following steps: • Inserting the Design Table into the CATPart file • • Creating the Power Copy Instantiating the Power Copy containing the Design Table

To perform this scenario, the Product Knowledge Template license is required. To perform this scenario, you will need the following files: • • KwrBallBearing1.CATPart KwrBearingDesignTable.xls

To store a design table in a Power Copy, do not forget to select the parameters pointed by the design table. 1. Open the KwrBallBearing1.CATPart file. The following image is displayed.

Inserting the Design Table into the CATPart file

2. Click the Design Table icon ( ) in the Standard toolbar. The Creation of a Design Table dialog box is displayed. 3. Check the Create a design table from a pre-existing file radio button and click OK. The File Selection dialog box is displayed. 4. Select the KwrBearingDesignTable.xls and click Open. 5. Click Yes when asked for automatic associations and click OK. The Design
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table is displayed below the Relations node.

Creating the Power Copy

6. From the Start->Knowledgeware menu, access the Product Knowledge Template workbench (if need be) and click the Create a PowerCopy icon. The Power Copy Definition dialog box is displayed. 7. In the Specification tree, select the following items: o o o o o o o o o DesignTable.1 Shaft.1 Shaft.2 Shaft.3 Sketch.1 Sketch.2 Sketch.3 the Material Parameter. Click OK when done. The Power Copy is displayed below the PowerCopy node in the specification tree.

8. Save your file and close it.
Instantiating the Power Copy

9. From the File->New menu, select Part in the List of Types and click OK. 10. If need be, from the Start->Knowledgeware menu, access the Product Knowledge Template workbench and click the Instantiate From
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Document icon. The File Selection dialog box is displayed. 11. Select the KwrBallBearing1.CATPart file and click Open. The Insert Object dialog box is displayed. 12. Select the yz plane in the specification tree and click OK. The Design Table is instantiated

Design Tables: Useful Tips and Restrictions
• A design table can only be created from non-constrained parameters, i.e. from parameters which are neither referred to in an active design table nor used in any other active relation. If you keep the Activity option checked for DesignTable0 and you try to create another design table, you will have to select the parameters to add to your second design table among a restricted parameter list. Uncheck the Activity option if you want to deactivate a design table and reuse its parameters in another design table.

•

Anytime you modify a design table, the relations that refer to this design table detect the modification and turn to a to-be-updated status.

•

As long as a design table is active, the parameters which are declared in it are constrained parameters and you are not allowed to modify them. Double-clicking a design table in the specification tree displays the design table with its set of configurations and allows you to select a new configuration.

•

Only parameters which are not already constrained by any other relation or by any other design table can be used to create a design table. If a parameter is already constrained, it does not appear in the Parameters to insert list in the design table dialog box.
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•

Selecting the parameters to be inserted in a design table The Filter Name and Filter Type filters can be used to restrict the display of a parameter list. If you specify x in the Filter Name field of the Select parameters to insert dialog box, you will display all the parameters with the letter x in their name (xA, xB, xC, xD, xE). If you select the Renamed Parameters in the Filter Type list, you will display all the parameters you have renamed in the Formulas dialog box (yA, xB, xA, yC, xC, yB, yD, xD, yE, xE, TangE). Parameters to be inserted can be multi-selected. You just have to keep on pressing the Ctrl key while you select parameters. If you do this, the group of multi-selected parameters will be carried forward onto the Inserted parameters list in the order in which they are displayed in the initial list. When the design table is created, the rank of the columns fits the rank of the parameters in the Inserted parameters list. If you want to have columns ordered in a given way in the design table, you must insert the parameters one by one.

•

Accessing the functions related to the design table Once in the formula (rule or check) editor, select the Design Table item in the dictionary, the list of the methods that can be applied to a design table is displayed. Select a method, then click F1 to display the associated documentation. When opening the file (CATPart, CATProduct ...) which contains the Design Table, the file (.txt, .xls) content is parsed and stored in memory. To avoid reading the file completely (there are many cells in an Excel file), we stop parsing after the first empty cell of the first row (= row containing titles), which determines the number of columns of the Design Table. Then: o if the first cell of the first column is empty, the Design Table is supposed to have no column and no association can be made. if the first 3 cells of the 3rd column are empty, the Design Table is supposed to have 2 columns and only the first two ones can be associated.

•

o

• • When working in a french environment, make sure that the decimal numbers contained in the text file linked to the design table are not written with a comma "," but with a decimal point. (This way, you will be able to move to an english environment easily.)

Working Through Knowledgeware Capabilities
Introduction: Design Intent
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Configuration 1 of KwrProfilesDesignTable.xls applied to KwrBottleProfiles.CATPart

The bottle above is used to demonstrate the major knowledgeware techniques that can be used in CATIA Version 5 to help you design a product. Throughout this section, most facets of the CATIA knowledgeware capabilities are examined, from relations such as formulas and rules to optimization algorithms. A scenario is developed in every chapter around a specific theme, and for each scenario tips and techniques are given. This part is intended for advanced users. Before you tackle the scenarios defined in this guide it is better to have previous knowledge of the products listed below and have an idea of the basic tasks you can carry out with them: • CATIA Infrastructure • • • • CATIA Part Design CATIA Generative Shape Design CATIA Knowledge Advisor CATIA Product Engineering Optimizer.

Design Intent
When developing a product, you must first of all define your product requirements. These requirements may be the result of mechanical, manufacturing or style considerations. The approach you follow in knowledge-based design consists in
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Design Requirements
Suppose you are designing a new bottle and you are required to make proposals to your marketing department. Leaving aside style considerations, you are free to do what you want except for the following restrictions: • the thickness of the bottle is determined by manufacturing considerations. This is not a parameter you can modify. • you can propose any bottle shape as long as, for a first estimate, the internal volume remains in the [230 cm3 - 280 cm3] range. This is the only requirement as regards geometrical properties.

The trick for you now is to determine the volume of the bottle, have this volume updated whenever you change the bottle's shape and be warned should the calculated volume be out of range. The approach followed to capture this design intent relies on measures. The "measure" capabilities provide you with a function which calculates the volume of a body. There is no real means to prevent you from designing bottles that are too small or too large, but using Knowledge Advisor checks is a good way to be warned whenever the volume is out of range. This is explained in Calculating and Checking a Volume. Having on hand a series of bottles' shapes fulfilling all requirements, you are required to be able to refine your result and search for a design so that the exact volume of the bottle is 250 cm3. To achieve this goal, we use the Product Engineering Optimizer capabilities and both available algorithms to design the final bottle shape. This is explained in Optimizing a Volume.

Assembly Requirements
It is planned to provide the bottle with a cap. After reviewing development plans with the marketing department, it has been decided that selling this new perfume brand with an already existing cap would be a saving. The cap they plan to reuse is the one below:
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Reusing this cap affects the bottle neck design which must allow for a certain section as well as a certain depth. Although it is planned to re-design this cap, the marketing department would like to have an idea of the assembly made up of the bottle and the cap. To check the overall design of the product, the marketing people want to be able to generate the bottle assembly automatically on screen each time a bottle shape meets the requirements.

A CATIA Knowledgeware answer to this problem is a Knowledge Advisor rule which can be triggered whenever certain conditions are fulfilled and generate automatically the global assembly from a VB macro. This is explained in detail in About Rule Firing. How you record, replay or modify a macro is discussed in CATIA Knowledgeware Automation.

Style Requirements
The Marketing Department already has an idea about the shapes they would like to study. The proposed shapes should be revolution bodies. The longitudinal view of the product should exhibit no edges. In other words, all contours are intended to be smooth. Stylists want you to provide them with a flexible design, they want profiles that are easy to be deformed by controlling one or more parameters. They want an immediate result on screen and they also want a clue as to whether they are still working within the authorized limits. Our initial feature is a five-point spline. The points making up the bottle neck are fixed as they must accommodate the cap. The other points are those providing the required flexibility. You alter them to create a new bottle shape. To create a bottle, you must create the spline, then rotate this spline. At this stage you obtain a revolution surface open at both ends. Then you have to create a fill at the aperture which is assumed to be the bottom of the bottle, join all the faces and thicken the resulting joined surface. All this is described in Appendix: Creating a Deformable Revolution Body. After a new shape has been designed and satisfies the requirements, you can store its parameters in a design table. The design table is a way to gather in an external file all the profiles satisfying the requirements. How to create a design table storing the data of all profiles and how to use a design table are explained in Working with a Design Table.

Calculating and Checking a Volume
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Configuration 2 of KwrProfilesDesignTable.xls applied to KwrBottleProfiles.CATPart The bottle we start from is described in Appendix: Creating a Deformable Revolution Body. First of all, we want to be able to measure the bottle's volume, then each time the bottle's profile is modified, we want to be warned about whether the resulting volume is still in the [230 cm3 - 280cm3] range. To achieve this goal, we will be using two CATIA Knowledgeware capabilities, the measures and the checks. Measures are functions provided by various applications such as Part Design or Generative Shape Design to compute data. These functions can be used in formulas as well as in rules and checks. They can be accessed from an interactive dictionary. Checks are relations that don't modify the document but just tell you whether certain specified criteria are fulfilled.

Specifying the Proper Settings
Before going any further in the scenario developed in this Part, check the settings below: • • In Tools->Options->General->Parameters and Measure. In the Language tab, the Load extended language libraries box must be checked otherwise you won't be able to access the Measures in the knowledgeware dictionary. In the Knowledge tab, check the With Value and With Formula check boxes. In the Units tab, specify cm3 as the default volume unit. In Tools->Options->Infrastructure->Part Infrastructure->Display, check at least the Relations and Parameters boxes. But it is recommended to check

• • •
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all the options below the specification tree settings. Click OK to validate.

Calculating the Bottle Volume
1. Open the KwrThickSurface.CATPart document. icon or select the Tools->Formula command from the standard 2. Click the menu bar. The "Formula" dialog box is displayed. 3. Select the Volume item in the New Parameter of type list. Then click New Parameter of type. A parameter called Volume.1 is displayed and highlighted in the parameters list. 4. In the Edit name or value of the current parameter field, replace the Volume.1 name with BottleVolume. Click the Add Formula button. 5. In the dictionary, select the Measures item, then double-click Volume in the measure list. If need be, add parentheses after the function name in the formula editor. At this stage the formula must be: BottleVolume = volume() 6. Position the cursor between the parentheses and capture the joined surface (Join.1) definition from the specification tree. To do this, just double-click the Join.1 feature. The formula definition you should get in the editor is something like: BottleVolume = volume (Geometrical Set.1\Join.1) 7. Click OK in the Formula Editor. You are back to the Formulas dialog box. The new formula is displayed in the parameter list opposite the BottleVolume parameter. It is also displayed in the specification tree under the Parameters and Relations nodes. Click OK again in the Formulas dialog box to exit the Formulas dialog.

Checking the Volume Value
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User Tasks 1. Select the document root feature, then access the Knowledge Advisor workbench. To do this, select the Start->Knowledgeware->Knowledge Advisor command from the tool bar. icon to display the Check Editor. In the first dialog box, replace 2. Click the the default name with VolumeCheck. Click OK. The Check Editor is displayed. 3. Define your check. To do this: a. Select Information or Warning in the Type of Check list. b. Enter the string "Volume out of range" in the message field. c. Enter the statement below in the edition window: (BottleVolume > 230 cm3) and (BottleVolume < 280 cm3) 4. Click OK to exit the dialog box and add the check to the document. In the specification tree, the check icon is green.

The resulting document is KwrVolumeCheck.CATPart.

Working with a Design Table
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Configuration 3 of KwrProfilesDesignTable.xls applied to KwrBottleProfiles.CATPart

You now have a preliminary document. How are you going to warp the profile of the bottle and search for other shapes? How can you capture all the data fulfilling the requirements? If need be, how are you going to proceed to refine your design in order to obtain a given volume? Using a design table is a way to capture your design intent and modify your document through an external file. In the scenario below, we first deform the bottle shape interactively by manipulating the control points of the spline, then we create and enrich a design table from the data of the documents fulfilling the requirements.

Searching Interactively for Valid Shapes
1. Open the KwrVolumeCheck.CATPart document. 2. Double-click the Sketch.1 feature and manipulate the D and E control points to deform the spline. See Appendix: Creating a Deformable Revolution Body for a definition of the D and E control points. As soon as you deform the spline: a. The document color changes (by default it turns to red). b. In the specification tree, an update icon is displayed on the root feature and on the formula. 3. Update the Part by double-clicking the root feature in the specification tree or in the geometry area. 4. Access the Knowledge Advisor workbench by double-clicking the formula in the specification tree. ) to update the formula. If the 5. Click the Measure Update icon ( recalculated volume does not satisfy the requirements, a message box is displayed informing you that the volume is out of range and the check icon turns red. Otherwise, the check icon turns green. Redo these interactions until you obtain a bottle satisfying both your style criteria and your volume requirements. As soon as you find the right profile, follow the method below to create a design table intended to store the data related to this profile as well as the data corresponding to other profiles.
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Initializing and Enriching a Design Table
1. Open the KwrVolumeCheck.CATPart document and save it under a new name. 2. In the renamed document, access the Sketch.1 feature and add the xD,yD, xE and yE offset constraints on the D and E control points. The constraints named x are defined along H while those named y are along V. Add a tangency constraint on E with respect to H as on the figure below and name it TangE. Refer to Appendix: Creating a Deformable Revolution Body for the definition of the control points. The figure below is an example of a valid shape.

3. If need be, update the document and the formula. 4. In the standard toolbar, click the Design Table icon ( table. ) to create a design

5. In the Creation of a Design Table dialog box, check the Create a design table with current parameter values box. Click OK. The Select parameters to insert dialog box is displayed. 6. Select the xD, yD, xE, yE and TangE parameters in the Parameters to insert list. Use the right arrow to move them to the Inserted parameters list. Click OK. 7. In the Select the Pathname of the File to be Created dialog box, specify the pathname of an .xls file to store the design table, and click Open. A single row design table similar to the one below is displayed.
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8. Edit the created design table by clicking the Edit table... button. The Microsoft Excel application is started. A single row table with the xD, yD, xE and yE and TangE parameter values is displayed. Click OK in the design table dialog box to add the created design table to your document. Save and close this document. 9. Go back to KwrVolumeCheck.CATPart, edit the sketch and search for another profile. As soon as you think a profile is worth saving, edit the control points and carry forward the edited values to the Excel table you have just created. Each time you do this, you add a new row to the design table. 10. After the data of all the profiles to be stored have been added to the Excel table, close this .xls file and re-open the renamed document. Re-edit the design table, select one by one each design table configuration in order to display the various shapes on screen. If you enrich the created design table with the data below:

This is what you get on screen when this design table is edited in the renamed document.
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The design table above is provided in the KwrProfilesDesignTable.xls sample. The bottle shape corresponding to each configuration of this design table is depicted by the figure which starts each chapter of this part.

About Rule Firing

Configuration 4 of KwrProfilesDesignTable.xls applied to KwrBottleProfiles.CATPart

This scenario explains how to write rules and gives some tips about the process which is behind the rule firing. Two rules are created. One launches a macro which updates and saves the document whenever the design table configuration results in a valid check. The other starts a macro which generates an assembly with constraints.

Writing the Rules
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knowledgeware 1. Open the KwrBottleProfiles.CATPart document. ). In the dialog box which is displayed, check 2. Click the Design Table icon ( the Create a design table from a pre-existing file box. Click OK. In the file selection dialog box, select the KwrProfilesDesignTable.xls sample. Click OK in the box which asks you whether you want to associate automatically columns with parameters. Select Configuration 2 as the active configuration. Save the document under the KwrTipCreateAssembly.CATPart name. 3. Check that the KwrTipSave.CATScript and KwrTipCreateAssembly.CATScript macros are downloaded in your environment as well as the KwrCap1.CATPart document. In the KwrTipCreateAssembly.CATScript macro, replace the path defining the assembly components in the var1(0) and var2(0) definitions. 4. Deactivate the design table from the contextual menu. 5. Access the Knowledge Advisor workbench to create the UpdateAndSaveRule rule. To do this: a. Click the Rule icon ( ).

b. In the first dialog box which is displayed, enter the UpdateAndSaveRule name. Click OK to display the main rule editor. c. In the rule editor, enter the rule below:

if Relations\DesignTable.1\Configuration < 7

{ Message("Document update and save") LaunchMacroFromFile("e:\users\...\KwrTipSave.CATScript") }

else Message("Configuration # is invalid", Relations\DesignTable.1\Configuration) Prior to clicking OK, replace the path specified in the LaunchMacroFromFile function with the path where you have downloaded the KwrTipSave.CATScript macro. d. Click OK to add the rule to the document. A message box is displayed (Document update and save). This message box is generated by the Message function in the rule. Two Visual Basic boxes are also displayed. They are generated by the KwrTipSave.CATScript macro. e. Deactivate the rule.
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if Relations\UpdateAndSaveRule\Activity == true LaunchMacroFromFile("e:\...\KwrTipCreateAssembly.CATScript") Prior to clicking OK, replace the path specified in the LaunchMacroFromFile function with the path where you have downloaded the KwrTipCreateAssembly.CATScript macro. 7. Deactivate all the features located below the Relations node of the specification tree then save your document.

Firing the Rules
1. Reactivate UpdateAndSaveRule. The message boxes warning about the update and save operations are displayed. 2. Reactivate DesignTable.1 and modify the design table configuration. To do this, double-click the design table icon in the specification tree then select a new row among the displayed configurations (from 1 to 6). 3. Reactivate AssemblyRule. The macro which creates the assembly is launched. You get on screen a message warning you that an assembly is going to be created. Click OK in the Visual Basic message box. The assembly is generated. You can see the different steps on screen.

4. Once the macro has finished running, close the product which has been generated, then deactivate AssemblyRule. 5. Go back to the initial document. Modify again the design table configuration. The UpdateAndSave macro is launched but not the AssemblyRule macro which is deactivated. To create the assembly corresponding to the new configuration, reactivate AssemblyRule.

About Automation
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Configuration 5 of KwrProfilesDesignTable.xls applied to KwrBottleProfiles.CATPart A macro is a way to store instructions intended to be repeated many times. It can also be a good means to store intricate interactions or describe a document in a clear text file easy to edit and requiring less memory than a document. Knowledgeware automation provides you with a way to store operations in the form of a .CATScript file. In this chapter we discuss the macro used to create the assembly in About Rule Firing, then we introduce the knowledgeware automation objects. We will not dwell on the part which consists in creating an assembly as this guide deals more specifically with knowledgeware techniques. If you need a brush up on how to create an assembly, see the Assembly User's Guide.

Creating an Assembly using a CATScript Macro
A CATScript macro is written in a language similar to the Visual Basic language. You can record a CATScript macro, then replay it later on or write it from scratch. The recommended method is to start from a record then, depending on your needs, edit and modify the pre-recorded macro.

Recording the CATScript Macro
To record the macro used in About Rule Firing: 1. Close all the documents open in your session. 2. Select the Tools->Macro->Start Recording... command from the standard menu bar then in the Record Macro dialog box displayed, specify the path of an external file. Press the Start button to start the macro recording. From now on, all the interactions are recorded in the CATScript file you have just specified.
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Startof recording

a. Select the Start->Infrastructure->Product Structure command from the standard tool bar. The product1 root product is created. b. Select the Components->Existing Component... command from the root product contextual menu to add the KwrTipCreateAssembly.CATPart component then the KwrCap1.CATPart component. c. In the Assembly Design workbench, specify an offset constraint of 1 mm between the Plane.1 plane of the bottle and the Pad.2 surface. Refer to the figure below to see how to select the elements to be constrained.

d. Specify a coincidence constraint to make the cap and the bottle axes coaxial. For more information, refer to the Assembly User's Guide. If need be, update the document.
End of recording

3. Select the Tools->Macro->Stop Recording command from the standard tool bar. This closes the file which records all the interactions described above.

Taking a Look at the Macro
The CATScript macro you have just recorded is similar to the one below. For the sake of clarity and to make lines shorter: • Some objects have been declared while others have been renamed • The arguments passed in functions using the generic naming method are written in italics.

Before replaying this macro, you should replace the path specified as the argument of the AddComponentsFromFiles method.

Dim PrDoc0 As Document

143

knowledgeware

Set PrDoc0 = CATIA.Documents.Add("Product")

Dim Prod1 As Product Set Prod1 = PrDoc0.Product

Dim var1 ( 0 ) ' Replace the path below before replaying the macro var1 ( 0 ) = "E:\...\KwrCap1.CATPart" Prod1.Products.AddComponentsFromFiles var1, "*"

Dim var2 ( 0 ) ' Replace the path below before replaying the macro var2 ( 0 ) = "E:\...\KwrTipCreateAssembly.CATPart" Prod1.Products.AddComponentsFromFiles var2, "*"

Dim CstS1 As Collection Set CstS1 = Prod1.Connections("CATIAConstraints")

Dim Ref1 As Reference Set Ref1 = Prod1.CreateReferenceFromName(Plane.1)
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Dim Ref2 As Reference Set Ref2 = Prod1.CreateReferenceFromName(Pad.2 face)

Dim Cst2 As Constraint Set Cst2 = CstS1.AddBiEltCst(1, Ref1, Ref2) Cst2.Dimension.Value = 1.000000 Cst2.Orientation = 2

Dim Ref3 As Reference Set Ref3 = Prod1.CreateReferenceFromName(Bottle axis)

Dim Ref4 As Reference Set Ref4 = Prod1.CreateReferenceFromName(Cap axis)

Dim Cst3 As Constraint Set Cst3 = CstS1.AddBiEltCst(2, Ref3, Ref4)

Prod1.Update This macro can be started from a rule (see About Rule Firing) or directly by selecting the Tools->Macro->Run command from the standard menu bar.
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About CATIA Automation Learning
There is a lot to be learned before you can write a complete macro in Visual Basic, but once you understand the basics of the language, you can be up and running in no time at all. Visual Basic is based on objects which have their own methods and properties. To set the value of a property, you follow the reference to an object with a period, the property name, an equal sign (=), and the new property value. At first sight, it is simple. The tedious thing when you have no previous programming skills is that the macro you record is a raw macro with objects and properties chained in one statement as in the extract below:

Dim ProductDocument0 As Document Set ProductDocument0 = CATIA.Documents.Add ( "Product" ) Dim var1 ( 0 ) var1 ( 0 ) = "E:\...\KwrTipCreateAssembly.CATScript" ProductDocument0.Product.Products.AddComponentsFromFiles var1, "*" When you tackle automation, there are two ways to proceed: • You already have a background in Visual Basic and you can refer to the list of Programming Interfaces provided with the CATIA documentation to write a macro or interpret a pre-recorded macro • You are a beginner and just record a scenario. You must replay it to check whether the scenario has been actually recorded.

About Generic Naming
Generic naming is a CATIA technique which creates a label whenever an element has been selected interactively. This label is a coded description of the selected element. This generic naming label appears when you record a .CATScript macro by using the Tools->Options->Macros command. If you perform interactions such as selecting an edge or a face, the value specified for the arguments of some methods are written using generic naming. When you take a look at the macro, you can see arguments which are neither Visual Basic objects nor usual data. These arguments are written in a form similar to the simple example below: Brp:(Pad.1:0(Brp:Sketch.1;1)). You don't have to worry much about generic naming as the definitions relying on this technique are automatically inserted in CATIA macros.

Knowledgeware Automation
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User Tasks The objects below can be created and managed in a .CATScript macro: • Parameters • • • Formulas Design tables Rules and checks

Creating Knowledgeware Objects
The knowledgeware features are created from the collection which refers to their type. For example, to create a relation in a Part type feature, you must first retrieve the collection object containing the Part relations by using the Relations method on the Part object. To create a parameter in a Part, you must retrieve the collection object containing the Part parameters by using the Parameters method on the Part object.

Modifying Knowledgeware Objects
To manipulate a knowledgeware object, you just have to use the methods and properties of the relevant object.

An Example
Open the KwrTipCreateAssembly.CATPart document and run the KwrRelations.CATScript macro.

Sub CATMain()

' Retrieve your active document CATIA is your application ' You get the active document by using the ActiveDocument property ' on your application object Dim myDoc As Document Set myDoc = CATIA.ActiveDocument

' Check whether the document is a
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CATPart ' Analyse the pathname of the document ' If the extension .CATPart is not found, a message is displayed ' but you exit the procedure ' InStrRev is a standard VB function Dim strPartName, strCATPart, myPos strPartName = myDoc.Name if (InStrRev(strPartName,".CATPart",1) = 0)_ then MsgBox("Your document should be a .CATPart") : Exit Sub

' Retrieve the collection object which contains ' all the document relations ' Activate all the relations ' Display the relation names in a message box ' Note: Statements below could not be applied to a CATProduct Dim strRel0 As String Dim strRel1 As String strRel1 = "Here is the list of relations" & vbCrLf & strRel0 Dim myRelCol As Relations Set myRelCol = myDoc.Part.Relations
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For Each myRel in myRelCol myRel.Activate() strRel1 = strRel1 & vbCrLf & myRel.Name Next Msgbox strRel1

' Make the configuration 4 active Dim des1 As Relation For Each myRel in myRelCol if myRel.Name = "DesignTable.1"_ then Set des1 = myRelCol.Item("DesignTable.1"): des1.Configuration = 4 Next CATIA.ActiveDocument.Part.Update End Sub This macro displays the list of relations within the document, changes the design table configuration and updates the document.

Tips
Operations that Cannot be Recorded There are some operations that cannot be recorded but that can be programmed in a macro (the activation or deactivation of a relation for example). The list of objects, methods and properties you can actually use when writing a macro is given in the Programming Interfaces. Access to this documentation is provided on the CATIA documentation home page. Retrieving Collections Collections such as the Relations and Parameters objects can only be retrieved from a CATPart document. Prior to retrieving these collections, it
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knowledgeware is better to check the document type in your script, otherwise the macro crashes. Retrieving a Collection Object When retrieving a collection object by its name, it is better to check whether the object exists, otherwise the macro crashes.

Optimizing a Volume

Configuration 6 of KwrProfilesDesignTable.xls applied to KwrBottleProfiles.CATPart You now have a number of valid configurations. They are all stored in the form of a design table. Among the valid configurations, there is one that catches your attention. Configuration 2 is neat, but you would like to modify slightly its dimensions so that its internal volume is exactly 250 cm3. In the scenario below, we explain how to use the Product Engineering Optimizer to refine the results obtained for one of the bottles' shapes.

The Gradient Algorithm
1. Open the KwrTipCreateAssembly.CATPart document. 2. Access the Product Engineering Optimizer workbench and click the Optimize icon ( ). The Optimization dialog box is displayed.

3. Fill in the fields with the data below: Optimization type Optimized parameter Target value Target value BottleVolume 250cm3
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Free parameters

xD initial value 82 mm lower bound: 0mm; upper yD initial value 53mm lower bound: 0mm; upper xE initial value 91 mm lower bound: 0mm; upper yE initial value 26 mm lower bound: 0mm; upper Don't specify any step. Default values

bound: 200mm bound: 200mm bound: 200mm bound: 200mm

Algorithm Termination criteria

Gradient Algorithm Without Constraint

4. Click the Save Optimization data check box, otherwise you won't be able to save your optimization data. 5. Click Run Optimization to launch the algorithm. Don't intervene to stop the process. After the process has finished running, the target value is reached or almost reached. The values of the free parameters are displayed in the optimization box. Note that the results depend on the platform.

The Simulated Annealing Algorithm
1. Click Cancel in the Optimization dialog box. icon or double click the optimization feature in the specification 2. Click the tree to display the optimization dialog box. 3. Fill in the fields with the values below: Optimization type Optimized parameter Target value Free parameters Target value BottleVolume 250cm3 xD initial value 82 mm lower bound: 0mm; upper bound: 200mm yD initial value 53mm lower bound: 0mm; upper bound: 200mm xE initial value 91 mm lower bound: 0mm; upper bound: 200mm yE initial value 26 mm lower bound: 0mm; upper bound: 200mm Specify a 0.1mm step for each free parameter. Simulated Annealing Algorithm Default values

Algorithm Termination criteria

4. Click the Save Optimization data box, otherwise you won't be able to save your optimization data. 5. Click Run Optimization to launch the algorithm. Don't intervene to stop the process.

Appendix: Creating a Deformable Revolution Body

151

knowledgeware

The bottle to be designed will be a five point spline rotated around an axis, and thickened. Once it is created, the spline is rotated, the open end corresponding to the bottom of the bottle is closed and the resulting shape is thickened.

Creating the Initial Spline
1. Create a new part. 2. In the Part Design workbench, access the Sketcher by clicking the Sketcher icon ( ). ) to draw a five point spline looking something like

3. Click the Spline icon ( the curve below.

4. Specify the constraints given in the table below. Location on spline Offset along Offset along Tangency H V constraint Control point Extremity on the xA = 0mm yA = 12 mm none specified
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A

neck xB = 7mm yB = 10.5mm none specified horizontal horizontal none specified

Control point Next to A on the B neck Control point Next to B on the C neck Control point Next to C D Control point Other extremity E

xC = 14mm yC = 10 mm none specified none specified none specified none specified

5. Use the Constraint icon ( ) to specify offset constraints on the three control points making up the bottle neck. 6. Use the Edit Multi Constraint icon ( points C and D. ) to specify an horizontal tangency on

At this stage, don't specify any offset on point D and E otherwise you won't be able to modify the bottle profile. But if you wish to start from a spline similar to the one below, you can set the D coordinates to 59 mm (along H) and 50 mm (along V) and the E coordinates to 77 mm and 17mm. ) to access the formulas dialog box, then modify 7. Click the Formula icon ( the offset names according to the names given in the table above. The resulting document is KwrInitialSketch.CATPart

Creating the Revolution Surface
1. Access the Generative Shape Design workbench and click the Revolve icon ) to rotate the spline created above around the H axis. Do a complete ( rotation (0deg - 360deg). The generated surface is opened a both ends. This is what your revolution surface looks like from the bottom.
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2. Access the Generative Shape Design workbench and click the Fill icon ( ) to close the bottle lower part. This is now what you should get onscreen.

3. Use the Join icon (

) to join the Revolute and Fill type features.

Thickening the Revolution Surface
1. Access the Part Design workbench and click the Thick Surface icon ( ) to thicken the joined surface. Specify a 1.5 mm as First Offset and 0 mm as Second Offset. This thickness should be an external thickness. The arrows displayed on screen when you apply the offset values should be directed toward the outside of the bottle (see the figure below).

2. Save the resulting document. The resulting document is KwrThickSurface.CATPart

154

User Tasks When applying a thickness to the joined surface, we could specify a first offset as well as a second offset. But this would make things a bit more complicated as later on we want to measure the internal volume of the bottle. This internal volume is to be calculated from the "Volume" measure of a surface. Adding an internal thickness entails subtracting the volume resulting from this internal thickness to the one calculated for the joined surface. Now you can select the sketch feature in the specification tree to access the sketcher, drag the D and E points and see how the global shape reacts.
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Knowledgeware Toolbar
Knowledgeware Toolbar

See Using Knowledgeware Capabilities See Using Knowledgeware Capabilities See the Knowledge Advisor User's Guide
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This page deals with these categories of options: • • • • Parameter Tree View Parameter names Relations update in part context Design Tables

Parameter Tree View

There are 2 types of items that you can display in the specification tree.

With value
Displays the parameter values in the specification tree. By default, this option is unchecked.

With formula
Displays the formulas constraining the parameter in the specification tree. By default, this option is unchecked.

Parameter names

This option should be checked if you work with non-Latin characters. If this option is unchecked, parameter names should have to be renamed in Latin characters when used in formulas. By default, this option is unchecked.
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Relations update in part context

Before V5R12, Knowledge relations (formulas, rules, checks, design tables, and sets of equations) used to execute as soon as one of their inputs was modified. The user can now choose, when creating the relation, if it will be synchronous (i.e. the evaluation will be launched as soon as one of its parameters is modified) or asynchronous (i.e. the evaluation will be launched when the Part is updated). Each relation can therefore be synchronous or asynchronous. The 2 following options enable the user to create synchronous or asynchronous relations.

Creation of synchronous relations
Enables the user to create synchronous relations, that is to say relations that will be immediately updated if one of their parameters/inputs is modified. Relations based on parameters are the only one that can be synchronous. By default, this option is unchecked

Creation of relations evaluated during the global update
Enables the user to associate the evaluation of asynchronous relations with the global update. The relations can be asynchronous for 2 reasons: • • • • • The user wants the relations to be asynchronous The relation contains measures. Relations based on parameters: These relations can be synchronous or asynchronous. Relations based on geometry: These relations can only be asynchronous. Relations based on parameters and on geometry: For the part of the relations containing parameters, the user decides if he wants the update to be synchronous or not. For the other part of the relations, the update occurs when the global update is launched. Note that the user can also decide if already existing relations are synchronous or asynchronous. To know more, see Controlling Relations Update in the Infrastructure User's Guide. •
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Design Tables

There are 2 types of items that you can set up.

Automatic Synchronization at Load
When loading a model containing user design tables, if the design table files have been modified and the external file data is contained in the model, the design table will be synchronized automatically if this radio button is checked. By default, this option is checked.

Interactive Synchronization at Load
When loading a model containing user design tables whose external source file was deleted, this option enables the user to select a new source file or to save the data contained in the design tables in a new file. By default, this option is unchecked.

Manual Synchronization
When loading a model containing user design tables, if the design table files have been modified and the external file data is contained in the model, the design table will be synchronized if this radio button is checked. To synchronize both files, rightclick the design table in the specification tree and select the DesignTable object>Synchronize command or the Edit->Links command. By default, this option is unchecked.

Default Mode: Copy Data Into Model
If checked, the data contained in the external source file will be copied into the model. By default, this option is unchecked.
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Default Mode: Do Not Copy Data Into Model
If checked, the data contained in the external source file will not be copied into the model. By default, this option is checked.
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