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Overview
Welcome to the Interactive Drafting User's Guide. This guide is intended for users who need to become quickly familiar with the Interactive Drafting Version 5 product. This overview provides the following information: • • • • • Interactive Drafting in a Nutshell Before Reading this Guide Getting the Most Out of this Guide Accessing Sample Documents Conventions Used in this Guide

Interactive Drafting in a Nutshell
Version 5 Interactive Drafting is a new generation product that addresses 2D design and drawing production requirements. Interactive Drafting is a highly productive, intuitive drafting system that can be used in a standalone 2D CAD environment within a backbone system. It also expands the Generative Drafting product with both integrated 2D interactive functionality and an advanced production environment for the dress-up and annotation of drawings. This provides an easy and smooth evolution from 2D to 3D-based design methodologies. Interactive Drafting offers upward compatibility with Version 4, making it possible to browse or complete, in Version 5, drawings started with Version 4. The Interactive Drafting User's Guide has been designed to show you how to create drawings of varying levels of complexity. There are several ways of creating a drawing and this documentation aims at illustrating the different stages of creation you may encounter.

Before Reading this Guide
Before reading this guide, you should be familiar with basic Version 5 concepts such as document windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that describes generic capabilities common to all Version 5 products. It also describes the general layout of V5 and the interoperability between workbenches. You may also like to read the following complementary product guides, for which the appropriate license is required: • • • Generative Drafting User's Guide: explains how to generate drawings from 3D parts and assembly definitions. Sketcher User's Guide: explains how to sketch 2D elements. Data Exchange Interface User's Guide: describes how to import and export external files in miscellaneous formats, including DXF/DWG and
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InteractiveDrafting CGM. V4 Integration User's Guide: presents interfaces with standard exchange formats and most of all with V4 data.

•

Getting the Most Out of this Guide
To get the most out of this guide, we suggest that you start reading and performing the step-by-step Getting Started tutorial. This tutorial will show you how to create a basic drawing from scratch. Once you have finished, you should move on to the Basic Tasks section, which deals with handling drawings and sheets, then creating and modifying the various types of features comprised in complex drawings. The Advanced Tasks section describes more advanced product functions. If you are an administrator, the Administration Tasks section is specifically aimed at you. You will see how to manage and customize standards. The Workbench Description section, which describes the Interactive Drafting workbench, and the Customizing section, which explains how to customize the Interactive Drafting workbench, will also certainly prove useful.

Accessing Sample Documents
To perform the scenarios, you will be using sample documents contained in the online cfysm_C2 samples Drafting folder for CATIA and online cfysm_D2 samples Drafting for DELMIA. For more information about this, refer to Accessing Sample Documents in the Infrastructure User's Guide.
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What's New?
There is no new or improved capability.
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Getting Started
Before getting into the detailed instructions for using Interactive Drafting workbench, the following tutorial aims at giving you a feel of what you can do with the product. It provides a step-by-step scenario showing you how to use key functionalities. You just need to follow the instructions as you progress along. The main tasks described in this section are the following:

Before discovering this scenario, you should be familiar with the basic commands common to all workbenches. These are described in the Infrastructure User's Guide. All together, the tasks should take about 30 minutes to complete. The final drawing will look like this:

Setting the options in Tools -> Options -> Mechanical Design -> Drafting is recommended to improve the software performances. For more information, refer to the Customizing section.
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Entering the Interactive Drafting Workbench
This first task shows you how to enter the Drafting workbench and start a new drawing. 1. Select File -> New (or click the New icon).

The New dialog box is displayed, allowing you to choose the type of the document you need. 2. Select Drawing in the List of Types field and click OK.

OR 1. Select Start -> Mechanical Design from the menu bar. 2. Select the Drafting workbench.

OR 1. Select Tools -> Customize (Start Menu tab) and define the Favorites (Drafting) and Accelerator (F12) options as shown below and click the Close switch button.

2. Press the F12 key or select Start -> Drafting from the menu bar.
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Whichever method you used for entering the Drafting workbench you used, the New Drawing dialog box is displayed, allowing you choosing the type of Standard, Sheet Style, Orientation you need. The sheet style defines among other things the sheet format, scale and orientation.

3. Select the ISO standard and click the Landscape option. If you activate the Hide when starting workbench option, the next time you enter the Drafting workbench via Start -> Drafting or by pressing the F12 key, the New Drawing dialog box will not appear any more and the last selected standard, sheet style and orientation will be used by default to create the drawing. You will always be able to reactivate this dialog box by unselecting the Hide when starting workbench option available via Tools -> Options -> Mechanical Design -> Drafting -> General tab, or to access it by selecting File -> New Drawing from the menu bar. 4. Click OK.

•

•

You can add an unlimited number of customized standards using Standard files that you will create and/or, if needed, modify. Once created, this standard will appear in the New Drawing dialog box. For more details on standards, see the Standards Administration section. Care that any userdefined standard is based on one of the four international standards (ANSI, ISO,ASME or JIS) as far as basic parameters are concerned. You can add an unlimited number of customized sheet styles using Standard files, see Sheet Styles.

The Drafting workbench is loaded and an empty drawing sheet opens. The drawing specification tree is displayed to the left of the sheet.
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Pressing the F3 key lets you show or hide the specification tree as desired. Make sure you customized the units accordingly. For this: 1. Select the Tools -> Options command to display the Options dialog box. 2. Click General > Parameters and Measure in the list of objects to the left of the Options dialog box. 3. Select the Units tab and set Length to Inch and then click OK. To visualize better your drawing, tile the windows horizontally from the menu bar. The commands for creating and editing features are available in the workbench toolbar. Now to fully discover the Interactive Drafting workbench, let's perform the following tasks.

Creating a New View
In this task you will learn how to create a new view in the empty drawing you just opened using the Drafting Interactive workbench. 1. Click the New View icon .
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Getting Started 2. Click to position the new view. The view is created. By default, it is a front view.

The drawing specification tree is updated to show the newly created view. A specific icon is used to identify the view as a front view.

If you change your system's regional settings to use another language, the default view name will be translated according to the language used by your system. Of custom, custom view names will not be translated. In the following tasks, you will learn how to draw geometry in the empty view displayed which is by default a front view. In other words, you will draw geometry in this empty view and create both annotations and dimensions on this geometry.

Creating a Rectangle
This task shows you how to define geometry in the newly created empty view which is by default, the front view. In this particular case, let's create a rectangle. 1. Click the Rectangle icon from the Geometry creation toolbar (Profiles sub-toolbar).
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The Tools Palette automatically appears, displaying two value fields: horizontal value (H) and vertical value (V). The Tools Palette appears whenever you select a command for which specific options or value fields are available. This enables you to know immediately when tools are available for a command. 2. Enter the First Point coordinates. For example, H: 0in and V: 0in.

3. Press Enter. At this step, you can either enter the rectangle second point or width and height values. 4. Enter the Second Point coordinates. For example, H: 3.5in and V: 2.5in.

5. Press Enter to end the rectangle creation.

The rectangle appears in the empty view.

You can also move the cursor for directly positioning the second point. The corresponding values similarly appear on the Tools Palette. Note that the grid is not necessarily displayed throughout this documentation. Still, in the Generative Drafting workbench, the grid is set by default. If you need to hide or display the grid, go to Tools -> Options -> Mechanical Design -> Drafting -> General tab and check the Display option.

Creating Corners
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This task shows you how to create corners on an existing rectangle by multiselecting points. 1. Multi-select the rectangle endpoints. 2. Click the Corner icon from the Geometry Modification toolbar (Relimitations subtoolbar). The Tools Palette is displayed with a Radius field:

3. Enter a radius value in the Tools Palette. For example, Radius: 0.25in. 4. The four corners are automatically created with the same radius value.

If you want to create the corners one after the other, you can also select the Corner icon first and then click the geometry.

Creating Lines
In this task you will learn how to create a line. You will need to display the Horizontal (H) and Vertical (V) fields in the Tools palette, as they are displayed optionally. To do this, go to Tools > Options > Mechanical Design > Drafting > Geometry tab and select the Show H and V fields in the Tools Palette option. 1. Click the Line icon from the Geometry creation toolbar. The Tools palette appears, displaying the Start Point value fields:
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2. Enter the line start point coordinates. For example, H: 1.625in and V: 0in. 3. Press Enter. 4. Drag the cursor to the desired location for creating the second line point. For example, drag the line end point to the top rectangle horizontal line.

In this particular case, smartpicking is used for creating the line. In other words, you want the line to be parallel with one of the rectangle lines. The parallelism symbol shown here. appears as

Translating Lines
This task shows you how to translate a line. In this particular case, we will also duplicate the line to be translated. 1. Select an element. For example, a line. 2. Click the Translate icon from the Geometry Modification toolbar (Transformations sub-toolbar).
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The Translation Definition dialog box appears and the Start Point value fields (H and V) appear in the Tools Palette.

3. The Duplicate mode option (Translation Definition dialog box) is activated, by default. If not, activate this mode.

4. Enter the duplicated line Start Point coordinates in the Tools Palette. For example, H: 1.7in and V:0in.

5. Press Enter. EITHER 6. Enter the duplicated line End Point coordinates in the Tools Palette. For example, H: 2in and V:0in.

7. Press Enter. A second line is created and translated according to the existing one. OR

6. Enter a length for the line in the Value field. For example, Value: 0.3in. The Snap Mode is automatically deactivated. 7. Click OK to validate. 8. Once you are satisfied with your operation, click in the drawing to end the translation. A second line is created and translated according to the existing one.
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This is the resulting translated line.

Proceed in the same manner to create the third, fourth, fifth and sixth lines. The process described above is valid for any other line to be created with the Translation command in our context. Select two lines at a time to perform your translation, it is time-saving. Your final drawing will look like this:

You can also select the Translate icon

first and then the geometry to be translated.

Creating Circles
This task shows you how to create circles and circle centers using coordinates.
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1. Select the Circle icon from the Geometry creation toolbar.

The Tools Palette appears, displaying circle value fields.

2. Enter the Circle Center coordinates. For example, H: 0.75in and V: 2in. 3. Press Enter.

4. Enter the circle radius. For example, R: 0.375in. 5. Press Enter.

6. Repeat the scenario to create the second circle using the same circle radius values.
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Now, let's create inner circles. For this: 7. Click again the Circle icon .

8. Select the existing circle center.

9. Enter the center circle radius.

10. Press Enter.

11. Repeat the scenario to create the second inner circle. This is what you obtain:
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You can also select the geometry to be translated first and then the Translate command .

You can then translate the circles newly created and get the following result:

Creating Dimensions
This task shows you how to add dimensions to the geometry you previously created. 1. Click the Dimension icon from the Dimensioning toolbar.
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2. Click a first element in the view. For example, the rectangle top line.

At this step, a dimension appears (length dimension). This dimension is defined according to the element first selected. You can either accept the dimension (click in the free space) or select another element (for creating a distance dimension). 3. Click a second element in the view. For example, the rectangle bottom line.

4. If needed, drag the dimension to the desired location.

At this step, you can apply various modifications to the dimension you are creating. You can: • 18 modify the dimension overrun/blanking using manipulators or the Ctrl key to modify only one extension line.

Getting Started

• •

add text before or after by double-clicking the dimension redefine the dimension properties using the required toolbar:

Creating Annotations
This task shows you how to add annotations on your drawing. In this particular case, we will add text to existing 2D elements. For the purpose of this scenario, create a diameter dimension on one of the outer circles. 1. Click on an icon from the Annotations toolbar. For example, click the Text icon .

2. Click an element. For the purpose of this scenario, click the diameter dimension that you created previously. The text will be positioned according to this element.

3. Enter the required text in the Text Editor dialog box.

As you type in, the text appears in the graphic Text Editor window.
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4. Click OK. 5. If needed, drag the text to the desired location.

The annotation will now remain associated to the selected 2D element. In other words, each time you move the 2D element, the associated annotation moves accordingly.
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Basic Tasks
The basic tasks you will perform in the Interactive Drafting workbench mainly deal with creating and modifying 2D elements and their related attributes on a predefined sheet. The tasks documented in this section explain and illustrate how to create various kinds of features to obtain a complete CATDrawing document. The information you will find in this section is listed below:

Using Tools
You will find below information on helpful tools for creating any interactive element. Using multi-selection can also be very useful.

Tools Toolbar
The Tools toolbar displays a number of options. This toolbar is situated at the bottom right of screen. If you cannot see it properly, just undock it.
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The Tools toolbar provides the following options: • • • • • • • Grid Snap to Point Analysis Display Mode Show Constraints (See chapter on Constraints) Create Detected Constraints (See chapter on Constraints) Filter Generated Elements Dimension system selection mode (See Creating Chained Dimension Systems, Creating Cumulated Dimension Systems, Creating Stacked Dimension Systems)

Grid
Activate this option to display the grid in your session. The grid will help you draw geometry in given circumstances. For example, the grid will make it easier to draw profiles requiring parallel lines. Note that this option is also available via Tools -> Options -> Mechanical Design -> Drafting -> General tab.

Snap to Point
If activated, this option makes your geometry (as well as 2D components) begin or end on the points of the grid. As you create geometry, points are forced to the intersection points of the grid. Note that this option is also available via Tools -> Options -> Mechanical Design -> Drafting -> General tab.

In this example, the black spline was created with the Snap to Point option activated. The points are on the grid. Conversely, the highlighted spline was created with the option deactivated. The points are not necessarily on the grid. You can use autodetection even if this option is activated.
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From V5 R15 onwards, the Snap to Point option no longer applies to annotations. Now, only the Snap by default (Shift toggles) setting in Tools -> Options is used to specify whether snapping should be activated by default for annotations. For more information, refer to Annotation and Dress-up in the Customizing Settings chapter.

Analysis Display Mode
This option allows visualizing the colors assigned to the different types of dimensions. These displayed colors correspond to the colors customized in the Options dialog box. To modify these colors, go to Tools -> Options -> Mechanical Design -> Drafting (Dimension tab). Then check Activate analysis display mode and, if needed, click the Types and colors switch button to assign the desired color(s) to the desired dimension types.

Filter Generated Elements
This option lets you differentiate 2D elements (Interactive Drafting workbench) from the geometrical elements generated from the 3D (Generative Drafting workbench) within the same view. This can prove very helpful when you need to add purely interactive elements onto generated views. Open the GenDrafting_part.CATDrawing document.
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1. Click the Filter Generated Elements icon from the Tools toolbar. The generated geometrical elements appear in gray (all other elements including generated dress-up elements remain black).

2. Create 2D elements in the front view. For instance, create a diameter dimension and a datum feature. The 2D elements appear in black.

This command is active provided you installed a Generative Drafting license.
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Tools Palette
The Tools palette appears whenever you select a command for which specific options or value fields are available. This enables you to know immediately when tools are available for a command.

The options or fields available in the Tools Palette depend on the command you selected. Only a few examples are provided here.

Example when creating dimensions
For example, if you select the Dimensions command, the Tools Palette may provide the following options:

Projected/Forced/True Length Dimension
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Projected Dimension (according to the cursor position)

Force Dimension on Element

Force Horizontal Dimension in View

Force Vertical Dimension in View

Force Dimension along a direction True Length Dimensions (for isometric views only)

Remember that as you create the dimension in one mode, you can use the contextual menu and select another mode.
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Example when creating geometry
Another example would be when creating a line. The values of the elements you are sketching appear in the Tools Palette as you move the cursor. In other words, as you are moving the cursor, the Length (L) and Angle (A) fields display the coordinates corresponding to the cursor position. The Horizontal (H) and Vertical (V) fields are optionally displayed, depending on whether the Show H and V fields in the Tools Palette option is selected in Tools > Options > Mechanical Design > Drafting > Geometry tab.

You can also use these fields for entering the values of your choice. In the following scenario, you are going to sketch a line by entering values in the appropriate fields. 1. Click the Line icon from the Geometry creation toolbar.

The Tools Palette displays information on value fields.

2. Enter the length (L) of the line and press enter. 3. Enter the value of the angle (A) between the line to be created and the horizontal axis and press enter. The line is created.

Make the Most of Multi-selection
When you need to create and/or modify an element, you can either select the element or the command first. Multi-selection can only be used for given commands. You are therefore allowed to select element(s) before these given commands. Open the Brackets_views06.CATDrawing document. 1. Multi-select 2D elements. For example, four circles.
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2. Click the desired command. For example, the Threads icon .

Four threads are automatically applied to the selected circles.

Copying and Pasting Elements
This task will show you how to copy and paste drafting elements. 1. Select the element you want to cut or copy. 2. To copy, you can either: • • • click the Copy icon select the Edit->Copy command select the Copy command in the contextual menu

This places what you copy in the clipboard. 3. To paste, you can either: • • • click the Paste icon select the Edit->Paste command select the Paste command in the contextual menu.

• • •

• • •

Drafting elements cannot be pasted to a part or to a sketch. They can only be pasted within a drawing. If you delete an element after copying it, you will not be able to paste it anymore. When copying and pasting views, positioning links between the views (i.e. links which exist between a parent view and its child view, for example) will not be kept. The only way you can keep positioning links between views is by copying and pasting the sheet. Unlike usual views, detail views cannot be copied to a part. Views containing 2D components cannot be copied to a part. Should you need to, you should first explode the 2D component and then copy the view. When copying and pasting a text, two things may happen depending on whether you changed the feature name of the text (Edit -> Properties -> Feature Properties tab): o If you did not change the feature name, and copy a text whose feature name is Text.1, for example, then the feature name of the copy will be Text.2 (then Text.3, etc. if you make several copies). o If you did change the feature name, and copy a text whose
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User Tasks customized feature name is Custom Text, for example, then the feature name of the copy (or copies) will remain Custom Text. In case you copy and paste a view axis, infinite lines are displayed in your view. Those lines are designed to keep constraints on the axis that were created in the first view.

•

•

•

You cannot copy and paste not-up-to-date dimensions (displayed in fuchsia by default or according to the color defined for Not-up-to-date dimensions in the Types and colors of dimensions dialog box available via Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, Analysis Display Mode area, Types and colors... button). When pasting elements from a drawing to another drawing which uses a different standard: some elements (such as dimensions) may not be supported by this standard. In this case, such non-supported elements will not be created.

Styles and Default Values
Styles and Default Values
The Interactive Drafting workbench lets you use and modify the default values of element properties. Note that there are two different behaviors, depending on the versions with which the drawing was created: • • Drawings created with version V5 R11 and later, or pre-R11 drawings whose standard has been updated or changed in V5 R11 and later. These drawings use the styles which are defined in the standard used by the drawing. Pre-R11 drawings, i.e. drawings created with versions up to V5 R10 included whose standard has not been updated in version V5 R11 and later.

Use standard-defined styles: Use and modify styles in drawings created with version V5 R11 and later, or pre-R11 drawings whose standard has been updated or changed in V5 R11 and later. Styles are defined in the standard used by the drawing. Standards are managed by the administrator. Set properties as default in pre-R11 drawings: Set graphical properties to elements to be created in drawings created with versions up to V5 R10 whose standard has not been updated in version V5 R11 and later. Use properties set as default in pre-R11 drawings: Use properties set as default in drawings created with versions up to V5 R10 whose standard has NOT been updated in version V5 R11 and later. Migrate pre-r11 drawings to drawings using standard-defined styles: Using a batch utility, migrate CATDrawing documents created with versions up to V5 R10 (which use properties "set as default"), to V5 R12 CATDrawing documents using standarddefined styles.
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Using Standard-Defined Styles
This task will show you how to use styles in drawings created with version V5 R11 and later, or pre-R11 drawings whose standard has been updated or changed in V5 R11 and later. Styles are defined in the standard used by the drawing. Standards are managed by the administrator.

Create a new drawing. Don't forget to specify the standard that you want to use. 1. Start creating a circle, for example. In the Style toolbar, the styles available for the type of element you are creating are displayed. In our example, two Default styles are available: one, the current style, is to be used for curves and the other one is to be used for construction curves.

The styles available in the toolbar depend on what your administrator specified in the standards. 2. If you want to apply the current style to the circle, you don't need to do anything. If you want to apply the other style, you can select it from the Styles toolbar. 3. Click to validate and end the circle creation. The circle is created with the selected style, as defined in the standard used by the drawing. (Consequently, you may obtain a different result than the one shown here).

4. Now, start creating a radius dimension for this circle. Once again, the Style toolbar displays the styles available for radius dimensions. In our example, only one style is available, therefore it will be used by default (you don't need to select it).
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5. In the Graphic Properties toolbar, select another color, red, for example.

In the Style toolbar, an asterisk appears in front of the selected style: this asterisk indicates that the style of the element you are creating has been overloaded compared to the style which is defined in the standards.

•

•

Depending on the type of style selected (curve, dimension, etc.), only the relevant fields are available in the various properties toolbars. For example, if you select a curve style, text and dimension properties will be disabled from the associated toolbars. In the case of dimensions, note that if you use the generic Dimensions command, all default dimension styles (i.e. length, radius, etc.) are available in the Style toolbar. In this case, make sure that you first select the style corresponding to the type of dimension that you are about to create, i.e. before overloading it. Otherwise, you will be overloading the current dimension style (which is Length by default); if you subsequently select an element that does not match the current dimension style, the style will change to match the selected element (e.g. if you then select a circle, a radius dimension will be created) and you will lose your style modifications (i.e. the style for the selected element will not be overloaded).

6. At this point, you have two options: • You can either revert to the standard-defined values (i.e. reset the toolbar properties to their original values) by re-selecting this style from the Styles toolbar, and then clicking to validate and end the dimension creation. The asterisk will disappear. Or you can apply the modified style by clicking to validate and end the dimension creation. For the purpose of this scenario, do this. The dimension is created with the selected style, as defined in the

•
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standard and overloaded by the properties you changed. (Once again, as the result depends on the parameters defined in your standard, you may obtain a different result than the one shown here.)

Styles are used as default values when creating elements. However, after an element has been created, no link remains between this element and the style used to create it.

When you select an element, no style is displayed in the Style toolbar. However, if you expand the list, you will see the list of styles that you can apply to this element (according to the styles that your administrator defined in the standard for this type of element). You can change the properties of the element by selecting another style from the list.

Setting Properties As Default in Pre-R11 Drawings
This functionality is only available with drawings created with versions up to V5 R10. This functionality is not available with drawings created with version V5 R11 and later, nor with drawings created with older versions and whose standard has been updated or changed in V5 R11 and later. These drawings use the styles which are defined in the standard used by the drawing. Standards are managed by the administrator.

This task shows you how to set graphical properties to elements to be created. Open the Brackets_views03.CATDrawing document.
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1. Right-click the element to be set as default when creating other elements of the same kind. For example, Text01. 2. Select the Set as default option from the contextual menu.

The options displayed in the Properties toolbars (top of the screen) are automatically updated and display the properties corresponding to the selected element. 3. Select the Only User Default Properties option from the style toolbar to specify that from now on, you do not want to use the options in the Properties toolbar as defaults.

The fields in the Properties toolbars are deactivated and therefore cannot be modified. 4. Create a new text. For example, Text02. The new text is automatically assigned the same graphical properties as the text set as default. At any time, you can edit (double-clicking) and modify one element that was applied graphical properties. There are no links between the default element and the elements that are applied graphical defaults.

•

You can reset all the values assigned to all the elements via the Reset All Defaults command. For this, select Tools -> Reset All Defaults from the menu bar.

•

Only one text color can be taken into account when setting a text as default. For this reason, if you set as default a text which includes strings in different colors, only the global color will be taken into account. The global color is the color defined when selecting the text (without editing it) and applied via the toolbar or via Edit -> Properties.
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Be careful: you can apply graphical properties only to dimensions/annotations which are of the same type. For example, properties set as default for angle dimensions will only apply to angle dimensions. • • Dimensions: chamfer, thread, angle, cumulate angle, diameter (all types), distance (length included), cumulate distance (cumulate length included), radius. Annotations: text, text with leader, balloon, datum target, datum feature, geometrical tolerances.

Using Properties Set as Default in Pre-R11 Drawings
This functionality is only available with drawings created with versions up to V5 R10.

This functionality is not available with drawings created with version V5 R11 and later, nor with dr whose standard has been updated or changed in V5 R11 and later. These drawings use the styles by the drawing. Standards are managed by the administrator.

This task shows you how to use default values. To understand how to set as default an element p Properties. 1. Create the following text, see Creating a Free Text

2. Select Properties in the contextual menu (right-click). In font tab, select the bold italic style an 5 mm.
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Click ok. The text looks like this

3. Select the Set as default option from the contextual menu.

The values you set are stored.
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Click in the drawing to finish the creation. 4. Select the font SSS1 in the Text Properties Toolbar.

5. Select the Original Properties option from the style toolbar to specify that from now, you want apart from the Text Properties toolbar settings.

6. Create a new text.

The line spacing is equal to 0 mm and the font is regular.

Original Properties (that is to say the settings defined in the Text Properties toolbar) ar

7. Select the User Default Properties option from the style toolbar to specify that you want to use apart from options set in the Text Properties toolbar.

8. Create a new text.

In this example you have modified the font in the Text Properties toolbar, the new text will be cre apart from the font.

User Default Properties (that is to say the settings set as default, apart from those defin are taken into account.

9. Select the Only User Default Properties option from the style toolbar to specify that you want t (see step 2).
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10. Create a new text.

Only User Default Properties (that is to say only the settings set as default) are taken in

•

If you selected the Lock "Only User Default" style in Tools -> Options -> Mechanical Design using Only User Default Properties is compulsory (the Styles drop-down list is set to Only U Original Defaults or User Defaults cannot be selected). In this case, when creating new ele deactivated to indicate that toolbar values will not be taken into account. If you select an e are activated to let you change its properties. If you don't want the properties toolbars to b elements, simply uncheck the Lock "Only User Default" style option.

•

When creating elements, the values of properties toolbars are taken into account only whe Default Properties style is selected. In this case, you can reset the Font Name, Font Size, T Format toolbar properties to the values which are defined in the standard of the drawing. T

1- Make sure that Original Properties or User Default Properties is activated in the Style to 2- Make sure that no element is currently selected. 3- Right-click the Style toolbar and scroll down the contextual menu if necessary.

4- Select Reset with standard properties. The current values of the Font Name, Font Size, Tolerance Format and Numerical Display F immediately reset to the values which are defined in the standard of the drawing.

Note that if Only User Default Properties is activated in the Style toolbar, or if an element i the Reset with standard properties command.

The table below lists all the objects that can be taken into account when using the Painter or copying th another.

Object

Properties

Are these taken
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Painter

Original Properties

Use Pro

Spline

Name Color Linetype Thickness Pickable

n y y y n n y y y n Cartesian coordinates Polar coordinates n n n n n n

Original properties Toolbar Toolbar Toolbar Original properties Original properties Toolbar Toolbar Toolbar Original properties -

Line

Name Color Linetype Thickness Pickable End Point 1

End Point 2

Cartesian coordinates Polar coordinates

Length Angle

Construction element

n

Toolbar

Point

Cartesian coordinates

n

-
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Symbol

y

Toolbar

Pickable

n

Original properties

Circle

Center Point

Cartesian coordinates Polar coordinates

n n n n n y y y

-

Radius Construction Element Name Color Linetype Thickness

Toolbar Original properties Toolbar Toolbar Toolbar

Pickable

n

Original properties

Ellipse

Center Point

Cartesian coordinates Polar coordinates

n n n n n n n y y y

Toolbar Original properties Toolbar Toolbar Toolbar

Major Radius Minor Radius Angle Construction element Name Color Linetype Thickness

Pickable

n

Original properties

Hyperbol

Focus Point

Cartesian coordinates Polar

n n

-
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coordinates Center Point Cartesian coordinates Polar coordinates Excentricity Construction Element Name Color Linetype Thickness Pickable Parabola Focus Point Cartesian coordinates Polar coordinates Apex Point Cartesian coordinates Polar coordinates Construction Element Name Color Linetype Thickness Pickable Conic Cartesian coordinates Polar coordinates Major Radius Minor Radius Angle Construction element Name Color Linetype n n n n n y y y n n n n n n n y y y n Toolbar Original properties Toolbar Toolbar Toolbar Original properties Toolbar Original properties Toolbar Toolbar Toolbar Original properties

Center Point

n n n n n n n y y

-
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Thickness Pickable Text String Name Font Font Style Size UnderLine Color Ratio Strikethrough Superscript Subscript Overline Text Frame Color Thickness Line Type Anchor point X Y Anchor Line Line Spacing Line Spacing Mode Justification Word wrap Reference Orientation Angle Mirroring Auto flip Graphic Thickness Linetype Color Pickable Text with leader String Name

y n n n y y y y y y y y y y y y y y y y y y y y y y y y y y y y y y n n n

Original properties Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Original properties Original properties Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Toolbar Original properties Original properties

T

T

T

T

T

Use

T

T

T

T

T

T

T

T

T

T

T

Origina

Use

Use

T

Origina

Use

Use

Use

Use

Use

T

T

T
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Font

Font Style Size UnderLine Color Ratio Strikethrough Superscript Subscript Overline

y y y y y y y y y y y y y y y y y y y y y y y y y y y y n n n

Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Original properties Original properties Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties

T

T

T

T

T

Use

T

T

T

T

Text

Frame Color Thickness Line Type Anchor point Anchor Line Line Spacing Line Spacing Mode Justification Word wrap Reference Orientation Angle Mirroring Auto flip

T

T

T

T

T

Use

Use

Use

Use

Use

Use

Use

Use

Use

Use

Graphic

Color Linetype Thickness Pickable

T

T

T

View

Scale Rotation View Name Prefix Ident Suffix Dressup Hidden Lines Axis Center Line Thread

Use

Use

n n n n n n n

Origina

Origina

Origina

Origina

Use

Use

Use
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Boundary fillet Uncut spec 3D Wireframe Visualization Display View and Frame Behaviour Lock View Color Linetype Thickness Pickable Sheet Name Global Scale Projection method first angle standard second angle standard Drawing Axis Line Name Name Color Linetype Thickness Pickable Center Line Name Color Linetype Thickness Pickable Thread Name Color Linetype Thickness Pickable Dimension Drive Geometry Value Value Driving Value Orientation Reference

n

Original properties Original properties Original properties

Origina

Origina

Origina

n n y y y n n y y y n n y y y n n y y y n n n n y

Original properties Original properties Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Original properties Original properties Original properties Original properties Toolbar Original properties Original properties Original properties Original properties Toolbar Original properties Original properties Original properties Original properties Original properties Original properties

Use

Use

T

T

T

Origina

Use

Use

Use

T

Origina

Origina

T

Origina

Origina

T

Origina

Origina

Origina

Origina

Use
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Orientation Angle Dual Value Format Fake Dimension Tolerance Main value Show dual value Main Value Dual Value Numerical Alphanumerical Upper Value Lower Value First Value Second Value Dual value Upper Value Lower Value First Value Second Value Dimension Line Representation Orientation Reference Angle Thickness Color Symbol 1 Shape Color Thickness Symbol 2 Shape Color Thickness Reversal Foreshortened Text Position Orientation Angle Ratio Point scale Extension Line Extremities Overrun Blanking Color

y y y n n n n y y y y n n n n y y y y y y y y y y y y y n n n n n n n y

Original properties Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties

Use

Use

Use

Origina

Use

Use

Use

T

T

T

T

Use

Use

Use

Use

Origina

Origina

Origina

Origina

Use

Use

Use

Use

Use

Use

Use

Use

Use

Origina

Origina

Origina

Origina

Origina

Use

Use

Use
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Thickness Display first extension line Display second extension line Funnel Height Angle Width Funnel mode Funnel side Dimension Text Prefix - Sufix Symbol Main Value Associated texts Dimension score options Main Value Dual Value Main Dual Dimension Element frame options Group Font Font Style Size UnderLine Color Strikethrough Overline Text Frame Color Thickness Line Type Graphic Color Linetype Thickness Pickable Area Fill Name Color Linetype

y y y n n n n n y y y n y y y y n y y n y n n y y y y y y y y n -

Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Toolbar

Use

Use

Use

Use

Use

Use

Use

Use

T

T

T

T

T

T

T

T

T

T

T

T

T

Use

Use

Use

Use

Use
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Thickness Pickable Type Dotting Pitch Zigzag Color Coloring Hatching Color Number of hatching n-th hatching properties 2D Name Component Color Linetype Thickness Pickable Angle Scale X Y Roughness Font Symbol Font Style Size Color Text Color Thickness Line Type Anchor Point Anchor Line Reference Orientation Angle Graphic Color Line Type Thickness Rugosity type Contact rugosity Rugosity mode Name

n y y y y y y n y y y n n n n y y y n n n n n n y y y n n n n

Toolbar Original properties Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Toolbar Original properties Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Original properties

Use

Use

Origina

T

T

T

T

T

T

T

T

T

Use

Use

Use

Use

Origina

Use

Use

Use

Use

Use

Use

Origina

Origina

Origina

Use
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Welding Symbol

Length of weld side 1 size of weld side 1 weld type side 1 Length of weld side 2 size of weld side 2 weld type side 2 field weld symbol weld-allaround symbol Font Font Style Size Color Text Frame color Frame Thickness Frame Line Type Reference Orientation Angle Graphic Color Line Type Thickness Name

n n n n n n n n y y y y

Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Toolbar Toolbar Toolbar

Use

Use

Use

Use

Use

Use

Use

Use

Use

T

T

T

T

y y n n y y y n n

Toolbar Toolbar Original properties Original properties Original properties Toolbar Toolbar Toolbar Original properties Toolbar Toolbar Toolbar Toolbar Original properties Toolbar Toolbar

T

T

Use

Use

Use

T

T

T

Use

Balloon String Font Font Style Size Color Text Frame color Thickness Frame Line n n n n y y y

T

T

T

T

T

T

T
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Type Anchor Point Anchor Line Reference Orientation Angle Graphic Color Line Type Thickness Name Datum Feature String Name Font Font Style Size Color Text Frame color Thickness Frame Line Type Anchor Point Anchor Line Reference Orientation Angle Graphic Color Line Type Thickness Datum Target String Diameter Name Font Font Style Size Color Text Frame color Thickness Frame Line 48 n n n n n y y y n n n n n n n y y y n n n n n y y y n y n y y y y y y y Toolbar Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Original properties Original properties Toolbar Toolbar Toolbar Toolbar Original properties Toolbar Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Toolbar Toolbar Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties

T

Origina

Origina

Origina

Origina

T

T

T

Use

Use

T

T

T

T

Use

T

T

T

Origina

Use

Origina

Origina

Use

T

T

Origina

Use

Use

Use

Use

Use

Use

Use

Use

User Tasks

Type Anchor Point Anchor Line Reference Orientation Angle Graphic Color Line Type Thickness Geometrical Tolerance Name Primary Geometric Characteristic Diameter Zone Tolerance Value tolerance Feature Modifier Primary Datum Text Primary Datum Feature Modifier Secondary Datum Text Secondary Datum Feature Modifier Tertiary Datum Text Tertiary Datum Feature Modifier Font Font Style Size Color Text Frame color y n n n n y y y n n n n n n Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties -

Use

Origina

Use

Origina

Origina

Use

Use

Use

n

-

n

-

n

-

n

-

n n n n n y

Toolbar Toolbar Toolbar Toolbar Original properties
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Thickness Frame Line Type Anchor Point Anchor Line Reference Orientation Angle Graphic Color Line Type Thickness

y y n n n n n y y y

Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties Original properties

Migrating Pre-R11 Drawings to Drawings Using Standard-Defined Styles
This task will show you how to migrate CATDrawing documents created with versions up to V5 R10 (which use properties "set as default"), to V5 R12 CATDrawing documents using standard-defined styles. The migration is performed using a batch utility. For each object which uses properties "set as default" (i.e. each default object created using the Set as Default contextual command), a new style will be created in the standard file, with the same specifications as the default object. For more information on styles, refer to Setting Standard Styles and Using Standard-Defined Styles.

The version of a drawing that is taken into account for the migration is the version of the embedded standard. For example, if you created a drawing in V5 R7, and modified and saved it in V5 R10, the version of the embedded standard is V5 R7. On the other hand, if you created a drawing in V5 R7, and updated its standard in V5 R10 (using the Update button in the Page Setup dialog box), then the version of the embedded standard is V5 R10. The migration is handled differently, depending on the version of the standard embedded in the CATDrawing document: up to V5 R8, or V5 R9 to V5 R10.
Migration process for drawings with an embedded standard up to V5 R8

If you want to keep your customized parameters, you must provide the CATDrwStandard file associated to the drawing. Otherwise, you can provide a customized XML file (from V5 R9), which will be updated and used in the updated drawing.
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Migration process for drawings with a V5 R9 to V5 R10 embedded standard

Standard output values are the values of the old drawing (except for new V5R12 standard values). This is available only for V5 R9 or V5 R10 drawings, which contain standards parameters.

1. Operate as described below, depending on whether you are on Windows or on UNIX: • On Windows: open an MS-DOS Window. Change to the folder in which you installed the product. The default folder is C: Program Files Dassault Systemes B_XX intel_a code bin where B_XX is B followed by the release number (e.g. B12 in the
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case of V5R12). • On UNIX: open a shell command window. Change to the directory in which you installed the product. The default directory is /usr/DassaultSystemes/B_xx/OS_a/code/command/ where B_XX is B followed by the release number (e.g. B12 in the case of V5R12) and where OS_a is: - aix_a - hpux_a - irix_a - solaris_a 2. Run the following command: CATAnnDefaultStyleMigration [-h] DrawingName.CATDrawing [-X] [-d OutputDirectory] [-n NewName] [-STDFile StandardFile] • DrawingName.CATDrawing: Specifies the name of the drawing to migrate • -h: Displays online help • -d OutputDirectory: Indicates the directory where the new migrated drawing is saved. If not specified, the new migrated drawing will be saved in the DrawingName.CATDrawing directory. • -n NewName: Specifies the name of the migrated drawing. If not specified, the new migrated drawing will use the same name as the old drawing prefixed by STD_. Example: DrawingName.CATDrawing will become STD_DrawingName.CATDrawing. • -X: Generates the XML file associated to the upgraded drawing. The XML file is put in the same directory as the output drawing. Its name is composed of the standard name and the drawing name with the .XML extension, e.g. ISO_DrawingName.XML. • -STDFile StandardFile: Specifies the external standard file to use. This file can either be a CATDrwStandard or an XML file. This step is mandatory for drawings created with versions up to V5 R8 (as they contain an embedded standard); this step is optional in other cases. If a file is specified, the embedded standard will be ignored whatever the drawing version is. 3. Wait until a message indicates that the migration process is finished and that the new CATDrawing and XML file have been generated.

Sheets
Sheets
The Interactive Drafting workbench provides a simple method to manipulate a sheet. A sheet contains:
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User Tasks • • • a main view: a view which supports the geometry directly created in the sheet, a background view: a view dedicated to frames and title blocks, interactive or generated views.

Define the sheet: Define the sheet using commands and dialog boxes. Modify the sheet: Modify the sheet orientation using the Page Setup dialog box. Delete the sheet: Delete a sheet. Switch a drawing to another standard: Switch a drawing to another standard when several standards have been defined by an administrator. Update the standard of a drawing: Update the standard used by a drawing. Create a frame title block: Edit a background sheet and insert a frame and a title block into it.

Defining a Sheet
This task will show you how to define a sheet. For more information about accessing the Interactive Drafting workbench, see Entering the Interactive Drafting Workbench. 1. Click the New icon displayed. or select File -> New. The New dialog box is

2. Select the Drawing workbench from the List of Types field, and click OK. 3. From the New Drawing dialog box, select the ANSI standard. Among other things, the sheet style defines the sheet format, size, scale and default orientation. 4. Select the A ANSI sheet style. 5. Optionally change the default orientation. 6. Optionally select the Hide when starting workbench option, if you do not want the New Drawing dialog box to appear the next time you enter the 2D Layout for 3D Design workbench via the Start menu. In this case, the last selected standard, sheet style and orientation will be used by default when creating a drawing. You will always be able to reactivate this dialog box by unselecting the Hide when starting workbench option available via Tools -> Options -> Mechanical Design -> Drafting -> General tab. 7. Click OK.
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What you need to know when defining a sheet
• Standards and sheet styles are defined by the administrator in the Standards Editor, who can add an unlimited number of them. Care that any customized standard is based on one of the four international standards (ANSI, ISO,ASME or JIS) as far as basic parameters are concerned. For more details, see Sheet Format Definition and Sheet styles in the Administration Tasks chapter. You can create your own user-defined sheet formats, defined locally for a given drawing, via the sheet properties. Refer to Editing Sheet Properties > Format properties for more information. Note that sheet styles are listed in alphabetical order in the New Drawing dialog box, which is not the case in the Standards Editor. The global scale is a scaling factor which applies to all views in a given sheet. It does not determine the position of the views (or any other object) contained in the sheet. When the grid is displayed, the position of the view in the sheet is not determined by the grid, which only deals with what is drawn directly in the sheet. To see the real position of a given view in a sheet, you need to use the ruler. It is the only way to see the real coordinates in a sheet referential. At any time after defining a sheet, you can change the standard (which you can update), sheet style or orientation. To do this, click File -> Page Setup to display the Page Setup dialog box. Refer to Modifying a Sheet for more information. You can also change the standard and the sheet properties in the Properties dialog box. To do this, right-click the sheet, and select Properties... from the contextual menu. Refer to Editing Sheet Properties for more information. If you select a new standard, the value in the Apply to field becomes All sheets and the new standard is applied to all drawing sheet annotations. To add a new sheet, click the New Sheet icon . The new sheet

• • •

•

•

•

•
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automatically appears as follows:

To activate a sheet once you have created more than one, doubleclick this sheet from the specification tree.

Modifying a Sheet
This task will show you how to modify the standard, sheet style and orientation of a sheet. Doing this amounts to modifying the options you selected in the New Drawing dialog box when defining the sheet. Refer to Defining a Sheet for more information on the various options and on what you need to know when defining or modifying a sheet. Create a sheet using the ISO standard, the A0 ISO format, and the Landscape orientation in the New Drawing dialog box. 1. Select File -> Page Setup from the menu bar. The Page Setup dialog box appears.
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2. From the Page Setup dialog box, select the ANSI standard, and the A ANSI sheet style. (Note that this action cannot be undone.) Among other things, the sheet style defines the sheet format, size, scale and default orientation. You can update the current standards by clicking the Update button. This copies the most recent version of the standard file in the drawing, thus reflecting the latest changes an administrator or user may have performed in the standard file. 3. Select the Portrait orientation, and then click OK. The sheet is modified.

4.

Deleting a Sheet
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This task will show you how to delete a sheet. When a CATDrawing document is opened, one sheet is necessarily displayed. You created more than one sheet. 1. Select the sheet from the specification tree. For example, Sheet 2. 2. Right-click the selected sheet and display the contextual menu. 3. Select the Delete option from the contextual menu. A dialog box is displayed. 4. Click OK to confirm the deletion.

Sheet 2 is deleted.

Deleting a sheet is irreversible.

Updating the Standard of a Drawing
When a standard file is modified, there is no automatic update of the drawings which use this standard. Each drawing contains a copy of the standard it uses,
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In this task, you will learn how to update the standard used by a drawing.

Open any existing CATDrawing file. 1. Select File -> Page Setup from the menu bar. The Page Setup dialog box opens, displaying the standard currently used by the drawing. 2. Click the Update button to update the current standard.

The most recent version of the updated standard is copied into the drawing and the previous standard parameter values are replaced by the latest ones, reflecting the latest changes an administrator or user may have performed in the standard file. This may have an immediate impact on the appearance of the elements inside the drawing. Note that styles are not affected by this update, i.e. styles modified in the updated standard file will not be re-applied to existing elements. Indeed, styles are applied when creating elements (as they define the default values to be used for creation). If needed, new style parameters can be re-applied to an element using the Style toolbar: simply select the element whose style you want to update and select the updated style in the Style toolbar. 3. Click OK to close the dialog box. Since there is no automatic update of drawings when a standard file is modified, you need to update the standard of drawings created before V5 R9 if
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Switching a Drawing to Another Standard
Each drawing contains a copy of the standard it uses, and retains this version until you explicitly switch the drawing to another standard or update this copy. In this task, you will learn how to switch a drawing to another standard when several standards have been defined by an administrator. Open any existing CATDrawing file. 1. Select File -> Page Setup. The Page Setup dialog box opens, displaying the standard currently used by the drawing. 2. From the Standard drop-down list, choose another standard.

3. Click OK to validate and close the dialog box. The parameters of the chosen standard are copied into the drawing and replace the previous parameters. This may have an immediate impact on the appearance of the elements inside the drawing. Note that styles are not affected by this change, i.e. styles in this standard file that are different from the previous standard file will not be re-applied to existing elements. Indeed, styles are applied when creating elements (as they define the default values to be
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used for creation). If needed, style parameters can be re-applied to an element using the Style toolbar: simply select the element whose style you want to update and select the updated style in the Style toolbar. Note that sheet styles are re-applied to existing sheets when you are switching to another standard.

Views

Views
Interactive Drafting elements necessarily need to be positioned in a view. In other words, you will first create a view on a sheet and then add 2D geometry, dimensions, annotations and/or dress-up elements in this view.

Create views: Create a front view and then projection views. Define the view plane: Define the plane of a view (a front view, an isometric view or an auxiliary view). Create views using folding lines: Add geometry in views using folding lines as an assistant. Create a multiple view projection: Generate geometry in a view by projecting geometry from previously defined views. Reframe a view: Reframe a view so as to display only part of it.

Creating Views
This task will show you how to create views. If the sheet is active, the first view you create is by default a front view. 1. Click the New View icon .

2. Click in the drawing to position the new view. The empty view is created, displaying a blue axis in a red frame, as well as the view name and scale.

The drawing specification tree is updated to show the
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If you change your system's regional settings to use another language, the default view name will be translated according to the language used by your system (both in the view and in the specification tree). Of course, this only applies to default view names; custom view names are not translated.

You can now create 2D geometry in this view. again and select a projection direction to create 3. Click the New View icon more views. The views are created. As they are linked to the front view, they are projection views. The drawing specification tree is updated again to show the newly created views.

From an active front view, you can create: • • • • a a a a top view bottom view left view right view
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If you need to switch to the Third angle projection method, modify the Sheet Properties. 4. Activate one of the projection views by double-clicking it. For example, doubleclick the contour of a bottom view. 5. Click the New View icon for creating the rear view.

The following table lists the types of views that you can create depending on the active view:

Active View

Resulting Projection Views (linked to the active view) Bottom view Top view Right view Left view Rear views Auxiliary views

Front view

Left view
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Right view Rear view

Rear views Auxiliary views Auxiliary view

Defining the View Plane
This task will show you how to define the plane of various kinds of views: • • • Define the front view plane Define the auxiliary view plane Define the isometric view plane

Any created view lies on a 3D plane. In other words, a view lies on some kind of a 3D plane whose definition can be accessed using the View Plane dialog box. The view plane can be defined and if n modified in this dialog box. The view plane will be defined in accordance with two vectors and an o point.

This view plane definition will be used, via the View Plane dialog box for acknowledging the 3D rela between views. This will be the case when creating a multiple view projection or when creating view folding lines.

Define the front view plane
Open the IntDrafting_Viewplane_Front.CATDrawing document. Activate the view in which you want to change the plane definition, by double-clicking on this view

1. Click the View Plane Definition icon from the Multi View toolbar (not displayed by default). OR 1. Select the Tools -> Multi View -> View Plane Definition command from the menu bar.

The View Plane dialog box appears with options on the view plane definitions for front views auxiliary views and isometric views.
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2. Select the desired options from the View Plane Definition area. In this case, enter 1 as the X and 0 as the Y and Z values for Vector1; enter 1 as the Y value and 0 as the X and Z values Vector2. 3. Click OK. The front view plane definition is updated.

Define the auxiliary view plane:
Open the IntDrafting_Viewplane.CATDrawing document.

For creating an auxiliary view, you need to create any view first and then modify the view plane yo In this case, we created an auxiliary view. Make sure the view in which you want to change the plane definition is active. If it is not, double-c activate it.
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1. Click the View Plane Definition icon from the Multi View toolbar (not displayed by default). OR 1. Select the Tools -> Multi View -> View Plane Definition command from the menu bar. The View Plane dialog box appears.
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2. In another orthogonal view, click the line that you want to use to define the auxiliary view p

The View Plane dialog box automatically displays the corresponding vectors and origin point. 3. Select the Rotate Auxiliary View Axis option to rotate the auxiliary view axis.
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4. Click OK.

The axis automatically rotates in accordance with the dialog box values applied to the selected plan

Define the isometric view plane:
Open the IntDrafting_Viewplane_Isom.CATDrawing document. Click the New View icon create an isometric view.

in order to create an empty view. In this case, position the cursor so a

Activate the newly created view, in which you want to change the plane definition, by double-clicki
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1. Click the View Plane Definition icon from the Multi View toolbar (not displayed by default). OR 1. Select the Tools -> Multi View -> View Plane Definition command from the menu bar. The View Plane dialog box appears. 2. Enter the desired values in the dialog box (Isometric). OR

2. Select the desired pre-defined isometric view vectors. In this case, select YZX (center of the in the Isometric Views area).

3. Click OK. The isometric view plane definition is updated.

Creating Views Using Folding Lines
This task will show you how to add geometry in views using folding lines as an assistant. This is true for any kind of view, as long as the planes they correspond to are not parallel. For example, you cannot have folding lines between a front view and a rear view.
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User Tasks Open the IntDrafting_Views_FoldingLines.CATDrawing document. Go to Tools -> Options -> Mechanical Design -> Drafting, click on the General tab and deactivate the Grid display option from the dialog box. Make sure the view in which you are going to create geometry using folding lines is active. 1. Right-click the view to used as reference. In this particular case, right-click the bottom view (which is not active and therefore squared in blue). 2. Select the Bottom View Object -> Show Folding Lines option from the displayed contextual menu.

In the case of more complex geometry, you can select one or more element(s) in the reference view and display the corresponding folding lines. As a result, the views are not overloaded with folding lines. This is also true in the case of 2D components. The folding lines appear.
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At any time, you can right-click the view and delete these folding line using the Hide Folding Lines option from the contextual menu. and create geometry in the top view using 3. Click the Profile icon autodetection on folding lines.
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You are now going to create geometry in the left view, using folding lines.

4. Right-click the left view in which you are going to create geometry and select the Activate View option from the contextual menu.

The folding lines disappear. 5. Right-click both non active views one after the other and select the Show Folding Lines option from the displayed contextual menu on each of these views.
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The folding lines now appear as shown here:

6. Click the Profile icon and create geometry in the left view using autodetection on folding lines.

7. Click a view and move it. Even when views are not aligned, folding lines remain associative.
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• •

All the above described functionalities are also true in the case of views with a different scale. In a Generative Drafting context, folding lines are not fully supported in the case of an aligned section view.

Creating a Multiple View Projection
This task will show you how to generate geometry in a view by projecting geometry from previously defined views. Selected objects are projected onto a plane or ruled surface defined by the user, and then transformed into the receiving view. Projected geometry retains the same attributes it had in the original multi-view. 1. You will first add elements to an existing view, using the Action-Object mode. 2. You will then create an isometric view from scratch, using the ObjectAction mode.

Open the Combivu_views01_CATDrawing document. Activate the view you want to create the new geometry in.

MAKE SURE THE PLANES WERE PROPERLY INITIALIZED.

Add elements to an existing view, using the Action-Object mode
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2. Select the object defining the target plane or surface to be used. This element can be any mono-parametered elements (line, circle, ellipse, parabola, hyperbola, curve). In this case, select an arc of a circle in the front view. 3. Select, in another view, the object to be projected. In this case, select a circle in the top view. 4. Select more elements to be projected, if needed, or click in the open space or still another command if you want to terminate this command.

Create an isometric view from scratch, using the Object-Action mode

1. Make the isometric view active (double-click).
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2. Multi-select the elements to be projected into the isometric empty view. In this case, select the whole front view. 3. Click the Multiple View Projection icon from the Multi View toolbar.

4. Select the object defining the view to be created. All the elements are automatically projected onto the active view.

5. Repeat the steps above (Object-Action) with the various elements to be projected that will allow generating the isometric view.
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The projected element keep the same graphical attributes as the selected element to be projected.

Reframing a View
In this task, you will learn how to reframe a view so as to display only part of it. Open the Visual_clipping.CATDrawing document. 1. Select the view and right-click the view frame. 2. In the contextual menu, choose Properties. 3. Click the View tab. 4. In the Visualization and Behaviour area, select the Visual Clipping check box.
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5. Click OK. The new frame appears as a rectangle in the view. You can now define the position and size of your frame on the view.

6. Click on the frame to select it.

7. Drag the manipulators to resize the frame as you want. For example, resize the frame so as to display about a quarter of the view.
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8. Now, drag one of the boundaries of the frame to specify its position on the view. For example, move the frame so as to display only the upper left area of the view.

The frame is now displayed in the view as you defined it.

• • •

The frame can only be rectangular. You can reframe any type of view: front views, isometric views, details views, clipping views, etc. To remove the frame and display the view as it was originally before you reframed it, simply unselect the Visual Clipping check box.

You cannot reframe a 2D component reference. In such a case, the Visual Clipping check box is disabled.

2D Geometry
The Interactive Drafting workbench enables you to create 2D geometry. As 2D geometry commands work exactly as in the Sketcher workbench, this section of the documentation actually points to the Sketcher User's Guide. As
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User Tasks such, the information detailed in this section is presented in a Sketcher context. You should note that the Sketcher User's Guide contains images that correspond to the Sketcher workbench and therefore illustrate geometry in an environment that is different from the Interactive Drafting environment (symbols, background color, for example).

Before you begin creating 2D geometry
Before you begin creating 2D geometry, make sure you are familiar with such concepts as: • • • • The Tools toolbar and the Tools Palette. SmartPick. SmartPick is an easy-to-use tool designed to assist you when creating 2D geometry. Construction elements. For more information, refer to Creating Standard or Construction Elements in the Sketcher User's Guide. Multi-selection. For more information, refer to the Selecting Objects chapter in the Infrastructure User's Guide.

Remember the following points: • • Construction elements contained in 2D geometry are displayed only in the active view. In order to help ensure that 2D geometry is not altered once it has been created, geometry edition is only allowed in the active view. Therefore, if you want to edit or move 2D geometry, you need to activate the view which contains the geometry. You can prevent 2D geometry from being inopportunely moved (and distorted) in active views by unselecting Allow direct manipulation from Tools -> Options -> Mechanical Design > Drafting - > Geometry tab. You can create as many 2D geometry elements of a given type as needed by double-clicking the appropriate icon (instead of single-clicking it). While creating 2D geometry, you can create detected constraints in automatically by activating the Create Detected Constraints icon the Tools toolbar. You can view the created constraints by activating the Show Constraints icon.

• •

In this case, note that if you create 2D geometrical elements with a common point, no constraint will be detected for this construction point, as it is unique. For example, say you create a circle and a line starting from the circle center as shown in the example below, the circle center point and the line end point is actually a single point. This is why no coincidence constraint will be created.
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No coincidence constraint on Coincidence constraint as there is no common point common point •

Create a point: Use the Tools Palette or click the point horizontal and vertical coordinates. Create a point using coordinates: Enter in the Point Definition dialog box cartesian or polar coordinates. Create an equidistant point: Enter in the Equidistant Point Definition dialog box the number and spacing of the points to be equidistantly created on a line or a curve-type element. Create a point using intersection: Create one or more points by intersecting curve type elements via selection. Create a point using projection: Create one or more points by projecting points onto curve type elements. Create a line: Use the Tools Palette or click the line first and second points. Create an infinite line: Use the Profile toolbar or click the infinite line first and second points. Create a bi-tangent line: Click two elements one after the other to create a line that is tangent to these two elements. Create a bisecting line: Click two lines. Create a line normal to a curve: Click a point and then the curve. Create a circle: Use the Tools Palette or click to define the circle center and then one point on the circle. Create a three point circle: Use the Tools Palette or click to define the circle start point, second point and end point one after the other. Create a circle using coordinates: Use the Circle Definition dialog box to define the circle center point and radius. Create a tri-tangent circle: Click three elements one after the other to create a circle made of three tangent constraints. Create an arc: Use the Tools Palette or click to define the arc center and then the arc start point and end point. Create a three point arc: Use the Tools Palette or click to define the arc start point, end point and second point one after the other.
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Create a three point arc with limits: Use the Tools Palette or click to define the arc start point, end point and second point one after the other. Create an ellipse: Use the Tools Palette or click to define the ellipse center, major semi-axis and minor semi-axis endpoints one after the other. Create a profile: Use the Tools Palette or click to define lines and arcs which the profile may be made of. Create a rectangle: Use the Tools Palette or click the rectangle extremity points one after the other. Create an oriented rectangle: Use the Tools Palette or click to define a first side for the rectangle and then a point corresponding to the rectangle length. Create a parallelogram: Use the Tools Palette or click to define a first side for the parallelogram and then a point corresponding to the parallelogram length. Create an elongated hole: Use the Tools Palette or click to define the center to center axis and then a point corresponding to the curved oblong profile length and angle. Create a cylindrical elongated hole: Use the Tools Palette or click to define the center to center circular axis and then a point corresponding to the curved oblong profile length and angle. Create a keyhole profile: Use the Tools Palette or click to define the center to center axis and then both points corresponding to both radii. Create an hexagon: Use the Tools Palette or click to define the hexagon center and dimension. Create centered rectangles: Use the Tools palette to define the rectangle center and dimensions. Create centered parallelograms: Use the Tools palette to define a first side for the parallelogram and then a point corresponding to its length. Create a spline: Click the points through which the spline will go. Connect elements: Click the points through which the spline will go. Create a parabola by focus: Click the focus, apex and then the parabola two extremity points. Create a hyperbola by focus: Click the focus, center and apex, and then the hyperbola two extremity points. Create a conic: Click the desired points and excentricity for creating an ellipse, a circle, a parabola or a hyperbola, using tangents, if needed.

2D Geometry Operations
The Interactive Drafting workbench enables you to modify 2D geometry, as well as perform a number of operations on it. As 2D geometry operation commands work exactly as in the Sketcher workbench, this section of the documentation actually points to the Sketcher User's Guide. As such, the information detailed in this section is presented in a Sketcher context. You should note that the Sketcher User's Guide contains images that correspond to the Sketcher workbench and therefore illustrate geometry in an environment 81
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Modify elements coordinates: Use the Line Definition dialog box to modify element coordinates. Create a corner: Create a rounded corner (arc tangent to two curves) between two lines using trimming operation. Create a chamfer: Create a chamfer between two lines using trimming operation. Trim elements: Trim a line or a circle (either one element or all the elements). Break elements: Break any type of curves. Quick trim: Quickly deletes elements intersected by other Sketcher elements using breaking and trimming operation. Close elements: Closes circles, ellipses or splines using relimiting operation. Complement an arc (circle or ellipse): Creates a complementary arc. Create mirrored elements: Repeat existing elements using a line, a construction line or an axis. Move elements by symmetry: Moves existing Sketcher elements using a line, a construction line or an axis. Translate elements: Perform a translation on 2D elements by defining the duplicate mode and then selecting the element to be duplicated. Rotate elements: Rotate elements by defining the duplicate mode and then selecting the element to be duplicated. Scale elements: Resize a profile to the dimension you specify. Offset elements: Duplicate a line, arc or circle type element.

2d Components

2D Components
At any time, you can create a component or a component catalog. You will then instantiate this component, or detail, on a detail sheet (be this component from a catalog or not).

Before you begin : You should be familiar with important concepts. Create a 2D component: Create a detail sheet and then create and position a detail on this sheet (local). Re-use a 2D component: Instantiate 2D components from a detail previously created on a detail sheet (local). Explode a 2D component: Individually explode an 2D component that you will then possibly modify.
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Create a component catalog: Create a catalog referencing 2D components from a drawing (external). Re-use a 2D component from a catalog: Instantiate a 2D component previously referenced in a catalog (external). Expose a 2D component from a catalog: Expose a 2D component to cut any existing link between this 2D component and its reference in a catalog.

Before You Begin
What is a 2D Component?
A 2D component is a re-usable set of geometry and annotations. This component is located in a sheet and can be edited like a view. This is why we call this component a detail view. The 2D component can be instantiated several times, each instance providing a component with a specific orientation, position and scale. The detail view can be either in the same drawing as the CATDrawing of the corresponding instances or in a separate CATDrawing.

What is a Component Catalog?
The catalog is a separate file which references the detail views, enabling to group the components, to classify them and to add information and attributes to these components. This allows overall management of the components. Moreover, the catalog browser can be used to choose a component and instantiate it in a drawing document.

You can synchronize external catalog components. In other words, you may update a component (or ditto) that is external to the 2D. Note that associativity is kept. For this, go to Edit -> Links and click the Synchronize button from the displayed dialog box.

By default, a 2D component (as a whole) can be moved or scaled using the mouse. If you want to make this impossible, go to Tools -> Options -> Mechanical Design -> Drafting -> Annotation and Dress-up tab and select Prevent direct manipulation and/or Prevent direct scaling.

General Concepts For Using Catalogs
Creating a 2D component in a detail sheet

You will find below a reminder on how to instantiate a component from a reference element that is internal to the document.
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1: reference component

2: instantiated component

Saving a 2D Component in a Catalog

You will find below how to instantiate a component from a reference element that is external to the document.
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1: local copy of reference component 2: instantiated components 3: catalog entry 4: external reference component

•

•

When you create a 2D component in a detail sheet, store this component into a catalog and you can perform modifications to this component on the detail sheet. There are two ways for updating the catalog file: - you can make a Save As Catalog on the same catalog. Be careful: in this case, the catalog is re-generated not updated. In other words, any modification applied to the catalog will be lost. - you can manually modify the catalog using the catalog editor. For more information, refer to the Component Catalog Editor User's Guide. When you instantiate a component from a catalog, this component appears on the sheet. In addition, this component definition is locally copied but you cannot visualize this copy. In that way, the instantiated component becomes a component which references this locally copied component. As a result, if the origin component disappears, the link between the locally copied component and the origin component is broken BUT the component can still
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InteractiveDrafting be used. If the image of the component in the catalog is modified and therefore different from the instantiated component, you can go to Edit>Links option from the menu bar and click the Synchronize switch (Links of Document dialog box). The Links of Document dialog box shows all the local copies and the states of the copies links. So, synchronizing amounts to updating the local copy based on the origin component modifications. Once the local copy is synchronized, all the instantiated components referencing this local copy are simultaneously updated. When you save a component in a catalog, you actually make a photo of the image of this component and also create a link which allows to find the origin component. As a result, if you modified the origin component and now try to instantiate this component from the catalog, the instantiated component will result different from what you expected.

•

•

You will find here two possible scenarios which will help you get what you expected: Scenario 1: if a component in a detail sheet and in a catalog are different from each others and if you update the catalog (Save As from the detail sheet), be careful: you will loose the catalog modifications. Scenario 2: suppose both the detail sheet and the catalog are similar (Save As from the detail sheet). When you instantiate the component from the catalog into the drawing, if the instantiated component is different from the component that was saved in the catalog, please go to Edit->Links command from the menu bar and click the Synchronize switch button. In fact, the origin reference component was locally copied and can only be updated using the Links of Document dialog box. For more information on this topic, refer to Creating a Component Catalog and to ReUsing a 2D Component from a Catalog.

Creating a 2D Component
This task will show you how to create a detail sheet and then position a 2D component on this sheet. This 2D component will then be instantiated on a design drawing sheet. Differentiating the design sheet from the detail sheet allows assigning a structure to the document. This means separating the drawing elements from the re-usable components.

1. Click the New Detail Sheet from the Drawing icon toolbar (Sheets sub-toolbar).
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3. Create a 2D component inside this new view. For example, create two circles on the detail sheet.

Note that you can customize both the design and the detail sheet background colors. For more information, see Infrastructure User's Guide.

Re-Using a 2D Component

This task shows you how to re-use a 2D component. In this particular case, we will instantiate a 2D component previously created on a detail sheet. Select a task: • Creating a 2D Component instance • • Positioning a 2D Component instance during creation Adding a leader to a 2D Component
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Open the Position_Component.CATDrawing document.

Creating a 2D Component instance
1. Double-click the view in which you want to instantiate the 2D component. This view is now active. . 2. Click the Instantiate 2D Component icon Note that to position several 2D components on the sheet and keep the scale and angle properties for all these components, you need to double- click the Instantiate 2D Component icon .

3. Go to the detail sheet Sheet2(Detail) and click the component.

You can select the 2D component from the design tree. You can also select a component that already exists on the drawing sheet.

The drawing sheet automatically displays the sheet containing the starting view. 4. Position the component using smartpick. You can use the Tools toolbar for positioning the component either before or after you instantiate the 2D component.
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5. If needed, select the component and use the displayed manipulators to modify the component.

Remember that if you selected Prevent direct manipulation and/or Prevent direct scaling from Tools -> Options -> Mechanical Design -> Drafting - > Annotation and Dress-up tab, you will not be able to move and/or scale the component. You can also modify a group of objects including a 2D component. For this, multi-select the group of object and perform the desired modification(s).

To easily find and edit the reference 2D Component, double-click or right-click on the 2D component you have instantiated, and choose Edit 2D reference option in the contextual menu.

Positioning a 2D Component instance during creation
Open the Position_Component02.CATDrawing document.

1. At any time as you instantiate a component, you can re-position it using the Position button bar that appears.

2. Click the Change the component origin option

from the Position dialog box.

3. On the component, click the point which you want to use as the component origin: this makes it easier to position this component.
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You can also flip the component according to either the x axis or the y axis. If you click the Flip component horizontally option

, the component flips on the horizontal axis of the detail. If you , the component flips on the vertical axis of its

click the Flip component vertically option reference .

Adding a leader to a 2D component
Create a 2D component following the scenario Creating 2D component instance. 1. Right-click the 2D component and select Add Leader. 2. Select the element you want to associate to the 2D component, or click in empty space.

Automating 2D component instance creation with VB script
Open the Position_Component.CATDrawing document. 1. Go to Tools -> Macro and select Start recording. 2. Key in the macro name and click on start button.
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3. Create a 2D component instance using the Instantiate Detail icon

.

4. Stop the recording clicking the following icon Recording.

or go to Tools -> Macro and select Stop

Now you can create this 2D component instance automatically. 5. Delete the previous 2D Component instance. Go to Tools -> Macro -> Macros, select the macro and click the run button

This macro will be available only in this drawing. 6. A 2D component instance will be created at the same place as the previous one.

Modifying text in 2D Component Instances
This functionality allows you to modify 2D component texts. Open the Position_Component.CATDrawing document.

1. Click the detail sheet tab, activate the 2D component view (double-click this view), insert a text in the 2D component and create a 2D component instance. 2. Right-click on the 2D component reference text:
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3. Check Modifiable in instance. The text will be modifiable in existing instances as well as in newly-created instances. 4. Once again, create a 2D component instance.

5. In Sheet.1, double-click on the first 2D component instance text you have created, modify it and click to validate. Then, double-click on the second text, modify it and click to validate. Both texts are modifiable.

• • •

•

Attribute links may be added in the text content. Once a text becomes modifiable, it is not possible to make it non-modifiable. For 2D component instances created with a catalog, if a text becomes modifiable in the catalog, you have to synchronize the external reference to make the 2D component instanc text modifiable too (refer to Creating and Editing a Catalog in the Component Catalog Editor User's Guide). If you create a 2D component reference (called MYREF for example) containing a 2D component instance with a modifiable text, the text will not be modifiable in instances of
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If you want to use as symbols 2D components with text, activate both the Apply Scale property for the text (in Edit -> Properties -> Text tab) and the Create with a constant size setting (in Tools -> Options -> Mechanical Design -> Drafting -> Annotation and Dress-up tab): the size of both the 2D component and its text will then be independent from the view scale. Remember that if you unselected Allow direct manipulation from Tools -> Options -> Mechanical Design -> Drafting - > Annotation and Dress-up tab, you will not be able to manipulate the component. In particular, you cannot modify the text strings in 2D component instances.

•

Replacing the Reference of a 2D Component Instance
Create a 2D component instance. 1. Right-click on an instance, and from the contextual menu, select Replace Reference for this instance.

2. Select another instance (this instance reference will be taken into account) or a 2D component i a local sheet of detail. The 2D component instance reference is replaced.

You cannot use a catalog to replace a 2D component instance reference. To bypass this, use an instance created with this catalog.

When replacing the reference of a 2D component instance, any existing text in the original 2D component instance is also replaced, even if this existing text had been previously modified (see Modifying text in 2D Component instances for more information on this point).

Specifying annotation orientation in 2D Component Instances

This functionality allows you to fix the text orientation in the 2D Component. In the 2D Component Instances, the text will keep the same orientation even if the 2D component instance is rotated or flipped.
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Open the Position_Component04.CATDrawing document. 1. Right-click on the text. Select Properties and Text tab. Choose to orientate the text horizontally relating to the sheet.

2. Create two 2D Component Instances, one without modifying the orientation and one orienting a 2D Component instance during creation. For the second instance, set the angle with the sheet to: 130deg.

The 2D Component Text orientation in relation to the sheet is kept. Not available for tables. Text oriented view, summary table: Original orientation Text rotate with 2D component instance Flip Horizontal

Horizontal

Vertical

Flip Vertical Rotate

Text orientation is fixed and independent from 2D component instance orientation
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Exploding a 2D Component
This task shows you how to individually explode an 2D component that was instantiated from a detail sheet. You will then modify as desired this component.

Open the Explode_Component.CATDrawing document.

1. Right-click the component that was previously instantiated from the detail sheet and select Reference 2DComponent.x.x object > Explode 2D Component from the contextual menu. The component is now exploded. You can therefore modify the geometry and/or graphical properties on one or more elements of this component. 2. Click the text and re-position it. 3. Select one line on the top of the hexagon and use the Graphical Properties toolbar to change the color into red.

The component now appears as desired:

When you explode a 2D component, there is no more associativity with the detail sheet and the exploded component behaves as an independent geometry. After an explode, all dress-up elements added on the instance are deleted, texts loose their associativity with the detail sheet and dimensions turn to fuchsia by default (or according to the color defined for Not-up-to-date dimensions in the Types and colors of dimensions dialog box available via Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, Analysis Display Mode area, Types and colors... button. For more information, refer to Analysis Display Mode). When you instantiate a 2D component, made of 2D components and perform an 95
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Editing 2D Component Instance Properties
This task explains how to access and, if needed, edit information on instantiated 2D component properties. Open the Position_Component03.CATDrawing document. 1. Right-click on the 2D component instance to access the contextual menu. 2. Select Properties and click the 2D Component Instance tab. You can modify the 2D component instance position and orientation: You can also select the instance, go to Edit -> Properties and click the 2D Component Instance tab.

• •

Location: It allows you to access the instance location and the origin of the 2D component it was instantiated from. Position and orientation: you can modify detail instantiated 2D component coordinates, angle with horizontal reference axis and scale.

3. Click OK to validate and exit the dialog box.

Dimensions
Dimensions
The Interactive Drafting workbench provides a simple method to create and modify given types of dimensions.

Before you begin: You should be familiar with basic concepts.
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Create dimensions: Create dimensions by clicking elements. Create half-dimensions: Create half dimensions on distance, angle, diameter, cylinders, diameter edges and diameter tangents but not on cumulate dimensions. Create cumulated dimensions: Create cumulated dimensions on a view using selection. Create stacked dimensions: Create stacked dimensions using selection.

Create explicit dimensions: Create dimensions using explicit selection both of the desired icon and of the required geometrical elements.

Create/modify angle dimensions: Create an angle dimension and perform the following kinds of modifications: new angle sector or turn an angle sector into a supplementary sector. Creating Fillet Radius Dimensions: Create a fillet radius dimension in a projected view. Create chamfer dimensions: Create a chamfer dimension using selection. Create thread dimensions: Create associative thread dimensions. Create/modify coordinate dimensions: Automatically create coordinate dimensions on elements. Create a holes dimensions table: Create a table containing holes dimensions (diameter and center coordinates). Create points coordinates table: Create a table containing 2D and 3D points coordinates. Create/modify radius curvature dimensions: Create and modify a radius curvature dimension. This lets you know the curvature radius at a given point on a curve (spline, ellipse, etc.). Create overall curve dimensions: You can create dimensions on the overall size of any kind of curve, whether it is canonical or not (e.g.: line, circle, ellipse, spline, etc.). You can also create dimensions on the overall size between 2 curves, or between a curve and a line, for example. Create curvilinear length dimensions: You can create dimensions for the curvilinear length of a curve, i.e. measure the overall length of a curve. Create curvilinear length dimensions: You can create dimensions for the curvilinear length of a curve portion, i.e. measure the partial length of a curve. Create dimensions along a reference direction: You can create dimensions along a direction of measure. In other words, you can measure the projection of a segment/distance onto a direction. Create dimensions between intersection points: You can create dimensions between an intersection point and an element or between two intersection points. Create dimensions between an element and a view axis: Create dimensions
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between an element and a view axis (one of the two axes or the origin). Modify the dimension type: Modify the dimension type as you create a dimension. On other words, you modify the dimension attributes. Re-route dimensions: Re-route dimensions, i.e. recalculate dimensions taking into account new geometry elements. Interrupt one or more extension lines: Interrupt manually one or more extension lines of one or more dimensions, either using the contextual menu or the Insert menu bar option. Modify the dimension line location: Use the mouse to modify dimension line location either before or after creating dimensions. Modify the dimension value text position: Use the cursor to modify dimension value text position. Specify the dimension value position: Automatically or explicitly position the dimension value inside or outside the area between extremity symbols. Add text before/after the dimension value: Insert text before or after the dimension value. Modify the dimension overrun/blanking: Use the Blanking Edition dialog box to modify dimension overrun or blanking. Line up dimensions (free space): Line up dimensions relatively to a point in the free space. Line up dimensions (reference): Line up dimensions according to a given reference. Create a datum feature: Use the Datum Feature Creation dialog box to create a datum feature. Modify a datum feature: Modify a datum feature by editing it. Create a geometrical tolerance: Use the Geometric Dimensioning And Tolerancing Parameters dialog box to create geometrical tolerances. Modify a geometrical tolerance: Use the Geometric Dimensioning And Tolerancing Parameters dialog box to modify geometrical tolerances. Copy a geometrical tolerance: Copy an existing geometrical tolerance and then edit the content for creating a new one. Create driving dimensions: Create dimensions that will drive associated constrained geometry. Scaling a Dimension: Apply or not a scale to the dimension text when a scale is applied to the object containing the dimension.

Before You Begin
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Creating Dimensions
You can create (and therefore modify) the following types of dimensions:
Dimensions created on one element:

• • • •

Length dimensions Diameter dimensions Radius dimensions Radius curvature dimensions

Dimensions created on two elements:

• • •

Distance dimensions Angle dimensions Diameter/Radius Cylinder dimensions

Note that you can create half-dimensions on distance, angle, diameter cylinder, diameter edge and diameter tangent dimensions but not on cumulate dimensions.

Modifying the Dimension Attributes
You can modify the following attributes at any time before you click to validate the dimension creation:
Modify while creating:

• • • • •

Type Measure direction Angle sector One symbol Diameter/Radius center

Modify while or just after creating:

• • • • •

Value position Extension line overrun/blanking (either one or both) Text before/after Properties (see further down) Swap to diameter/radius
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Manipulating Dimensions
By default, when manipulating dimensions, you will use the following functionalities: • • • dimension following the cursor: go to Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, to use automatic positioning global move: go to Tools -> Options -> Mechanical Design -> Drafting > Dimension tab, to move precisely dimension line, dimension value, secondary part of a dimension line. blanking manipulators (available when modifying a dimension): go to Tools -> Options -> Mechanical Design -> Drafting -> Manipulators tab, not to visualize blanking manipulators or to visualize other manipulators either when creating or when modifying a dimension (Overrun, Blanking, Insert text before, Insert text after, Move value, Move dimension line, Move DimLine Secondary Part). value snapped between the dimension lines symbols: go to Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, if you do not want to have the possibility to snap the dimension value between both symbols of the dimension line and/or you want to snap the dimension position on the grid. during creation: to switch temporarily the Dimension following the cursor option, hold on the ctrl key. during creation and edition: to switch temporarily the Activate Snapping option, hold on the shift key. Clicking on the dimension symbols will invert them. during angle dimension creation: if the Dimension following the cursor option is activated, you can swap the angle sector according to the mouse position holding on the ctrl and shift keys. If the Dimension following the cursor option is not activated, you can swap to the complementary angle sector holding on the ctrl key and clicking on the dimension line.

•

• • •

Dimension Tools
The Tools palette appears whenever you select a command for which specific options or value fields are available. This enables you to know immediately when specific tools are available for a command. The options or fields available in the Tools Palette depend on the command you selected. Only a few examples are provided here. For example, if you select the Dimensions command, the Tools Palette may provide the following options:

Projected/Forced/True Length Dimension
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Force Dimension on Element Projected Dimension (according to the cursor position)

Force Horizontal Dimension in View

Force Vertical Dimension in View
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Force Dimension along a direction True Length Dimensions (for isometric views only)

Remember that as you create the dimension in one mode, you can use the contextual menu and select another mode.

Dimension Properties
You can apply given properties to all the dimensions you are going to create. For this, use the Dimension Properties toolbar. • • • • • Line type (regular, two parts, one part leader, or two parts leader) Tolerance type Tolerance value Numerical Display Format Precision.

•

For the ISOCOMB combined tolerance, use the following type of syntax in the tolerance value field: H6 (+0.5 / -0.3)
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User Tasks • When creating a new drawing, the Unit field (here: NUM.DIMM) drives the unit of the dimensions to be created. The value which is used by default in this field for each type of dimension is usually defined by the dimension styles (Tools -> Standards -> Styles > [dimension style] -> ValueDisplayFormat -> MainValue -> Name). However, if no value is defined by the styles, the one which will be used by default is that defined as your default unit choice in Tools -> Options > General -> Parameters and Measure -> Units tab. When editing an existing drawing, if you change your default unit choice in Tools -> Options -> General -> Parameters and Measure -> Units tab, then the numerical display format which best corresponds to the selected unit is automatically selected in the toolbar instead of the current default value.

•

Using Styles
You can use styles (i.e. a set of default values for each kind of element) when creating dimensions in drawings created with version V5 R11 and later (or preR11 drawings whose standard has been updated or changed in V5 R11 and later). Styles are defined in the standard used by the drawing and managed by the administrator. When creating a dimension, the Style toolbar displays the styles available for this type of dimension. (By default, the Style toolbar is situated at the top left of screen.) If only one style is available, it will be used by default.

If several styles are available for this type of dimension, you can choose the style that you want to use to create this dimension by selecting it from the Style toolbar. Refer to Using Styles for more information.

In drawings created with versions up to V5 R10, you can create dimensions using default values. Refer to Setting Properties As Default in Pre-R11 Drawings and to Using Properties Set as Default in Pre-R11 Drawings for more information.

Dimension Systems
Dimension Systems
The Interactive Drafting workbench provides a simple method to create and modify given types of dimension systems. To edit dimension system properties, see Editing 103
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Before you begin: You should be familiar with basic concepts. Create chained dimension systems: Create a chained dimension system using selection. Create cumulated dimension systems: Create a cumulated dimension system using selection. Create stacked dimension systems: Create a stacked dimension system using selection. Modifying a dimension system: Modify a dimension system or a dimension within a dimension system. Line-up dimension systems: Line up dimensions according to a given reference.

Before You Begin
A dimension system is a set of dimensions which can be handled either globally or individually.
Creating Dimension Systems

You can create (and therefore modify) the following types of dimension systems: • • • Chained Dimension Systems Cumulated Dimension Systems Stacked Dimension Systems

Note that you can create half-dimensions on stacked dimension systems only.
Manipulating Dimension Systems

• •

By default, when manipulating dimension systems, Dimension following the cursor is activated. Go to Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, to use or not automatic positioning. A click over a dimension system enables you to select the whole dimension system. However, you may want to reverse this behavior to select a single dimension. Click on the Dimension system selection mode icon in the Tools toolbar to deactivate the dimension system. Selections will be now focused on dimensions rather than on the whole dimension system. Click again on the icon to activate the dimension system.
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Modifying the Dimension System Attributes

You can modify the following attributes while you have no more than one dimension in the dimension system: Modify while creating: • • • Type Measure direction Angle sector

Modify after creating: • • • • Properties (see further down) When creating: to activate temporarily the Dimension following the cursor option, hold on the ctrl key. When creating and editing: to activate temporarily the Activate Snapping option, hold on the shift key. When creating an angle dimension: if the Dimension following the cursor option is activated, you can swap the angle sector of the first dimension according to the mouse position holding on the ctrl and shift keys. If the Dimension following the cursor option is not activated, you can swap to the complementary angle sector holding on the ctrl key and clicking on the dimension line.

Dimension System Properties

You can apply given properties to dimension systems. For this, use the edit Properties, see Editing Dimension System Properties. Note, chained dimension systems have no specific system properties.
Using Styles

You can use styles when creating dimension systems in drawings created with version R14 and later (or pre-R14 drawings whose standard has been updated or changed in R14 and later). Styles are defined in the standard used by the drawing and managed by the administrator. When creating a dimension system, the Style toolbar displays the styles available for this type of dimension system and the styles available for its dimensions. (By default, the Style toolbar is situated at the top left of screen.) If only one style is available, it will be used by default.

If several styles are available for this type of dimension system, you can choose the style that you want to use to create this dimension system by selecting it
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Creating Chained Dimension Systems
This task will show you how to create a chained dimension system. Open the Brackets_views03.CATDrawing document. 1. Click the Chained Dimensions icon (Dimensions sub-toolbar). from the Dimensioning toolbar

2. Click a first point on the view. 3. Click a second point on the view. You just created a first dimension within the chained dimension system.

4. Click a third point on the view. You now created a second chained dimension in the system. You can create as many chained dimensions as desired.
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Note that if you move one dimension line as you create a chained dimension, all the lines will move accordingly. In the same way, clicking on one dimension line highlights all the lines showing the whole system is selected. 5. Click in the free space to end the chained dimension system creation. The Chained Dimension System works for distance and angle dimensions only. You can interrupt manually extension lines on both single dimensions of a system and the whole system. For more information, refer to the Interrupting Extension Lines section.

Creating Stacked Dimension Systems
This task will show you how to create a stacked dimension system on a view. Stacked dimensions are parallel lines with a common extension line. Open the Brackets_views03.CATDrawing document. 1. Click the Stacked Dimensions icon (Dimensions sub-toolbar). from the Dimensioning toolbar

2. Click a first point on the view. 3. Click a second point on the view. You just created a first dimension within the stacked dimension system.
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4. Click a third point on the view. You now created a second stacked dimension in the system.

5. Click a third point on the view. You now created a third stacked dimension in the system. Note that this stacked dimension is inserted properly into the system.
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You can create as many stacked dimensions as desired.

6. Click in the free space to end the stacked dimension creation. The Stacked Dimension System works for distance and angle dimensions only. You can interrupt manually extension lines on both single dimensions of a system and the whole system. For more information, refer to the Interrupting Extension Lines section.

Creating Cumulated Dimension Systems
This task will show you how to create a cumulated dimension system on a view. Open the Brackets_views03.CATDrawing document. 1. Click the Cumulated Dimensions icon (Dimensions sub-toolbar). from the Dimensioning toolbar

2. Click a first point on the view. 3. Click a second point on the view. You just created a first dimension within the cumulated dimension system.
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4. Click a third point on the view. You now created a second cumulated dimension in the system. You can create as many cumulated dimensions as desired.

Note that if you move one dimension line as you create a cumulated dimension, all the lines will move accordingly. In the same way, clicking on one dimension line highlights all the lines, thus showing that the whole system is selected. 5. Click in the free space to end the cumulated dimension system creation. If the cumulated dimensions are set with the value oriented along dimension line, set the CUMLTxtReference dimension parameter in the standards. The Cumulated Dimension System works for distance and angle dimensions only. 110
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Modifying a Dimension System
This task will show you how to modify a dimension system or a dimension within a dimension system. In our example we chose to create a stacked dimension system and to perform the following actions: • • • • • • • Moving a dimension system Moving a dimension Aligning a dimension system Restoring a value position Adding a dimension into a system Deleting a dimension from a system Copying a dimension system

Open the Brackets_views03.CATDrawing document. 1. Create a stacked dimension system including several dimensions as shown below.

Moving a Dimension System

1. Click over the dimension system to select it. The whole system is highlighted.
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2. Drag the whole system below the drawing.

3. Click in the free space to end the stacked dimension system selection.
Moving a Dimension

1. Right-click on the Dimension system and select Properties in the contextual menu. 2. In the System tab, set the Offset mode to Free, then click on OK.
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User Tasks See Editing Dimension System Properties for further information on the Properties' panel. 3. In the Tools toolbar, click on the Dimensions system selection mode icon to deactivate the dimension system. 4. Select several dimensions and drag them above the dimension system. 5. Click in the free space to end the dimension selection.

Moving a dimension can be performed only on stacked dimension system.
Aligning a Dimension System

1. Make sure Dimensions system selection mode icon Tools toolbar. 2. Click over the dimension system to select it. Align into System. 3. Right-click and select The dimensions are aligned into the system as before.

is activated in the
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You can perform an Align into System on a whole system as well on several dimensions after multi-selecting them. To do so, set the system's offset mode to free (see Editing Dimension System Properties), then click on the Dimensions system selection mode icon to deactivate the dimension system. The dimensions you selected are aligned into a system of their own as shown below.
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Restoring a Value Position

1. Make sure Dimensions system selection mode icon Tools toolbar.

is activated in the

2. Right-click on the Dimension system and select Properties in the contextual menu. 3. In the System tab, set the Dimension values alignment at 10mm from the Reference line.

4. Click on Apply to visualize the Dimension values alignment.
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5. Click on the Dimensions system selection mode icon the dimension system. 6. Move some of the dimensions.

to deactivate
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7. Click on the Dimensions system selection mode icon dimension system again.

to activate the

8. Right-click on the dimension system and select Restore Value Position. The dimensions' values are back to their initial position.

9. Click on the Dimensions system selection mode icon the dimension system. 10. Drag several dimension values to modify their position.

to deactivate

117

InteractiveDrafting

11. Multi-select the dimensions. 12. Right-click and select Restore Value Position in the contextual menu. The dimensions' values are centered back in the system.
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Adding a Dimension into a System

You have to select the icon corresponding to create the dimension system you would like to modify i.e. a chained, cumulated or stacked dimension system. 1. Make sure Dimensions system selection mode icon Tools toolbar. is activated in the

2. In the System tab, set the Offset mode to Constant, then click on OK. See Editing Dimension System Properties for further information on the Properties' panel. 3. Go to menu Insert->Dimensioning->Dimensions and select Stacked dimensions. 4. Select the system you want to insert a dimension to. 5. Select the geometry to dimension.

119

InteractiveDrafting

The new dimension is inserted into the system and is automatically aligned into the system.

Deleting a Dimension from a System
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1. Make sure Dimensions system selection mode icon the Tools toolbar.

is deactivated in

2. Select a dimension. Note that only the selected dimension is highlighted, not the whole system.

3. Press Del key. The dimension system is updated accordingly automatically aligned.
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Should you want to delete the whole dimension system, make sure Dimensions system selection mode icon key.
Copying a Dimension System

is activated in the Tools toolbar and press Del

1. Make sure Dimensions system selection mode icon Tools toolbar.

is activated in the

2. Select the geometry and its associated dimension system and click on the Copy icon. 3. Create a new view and select it. 4. Click on the Paste icon: The geometry and its dimension system is pasted in the view. If the dimension system offset mode is set to Free, modifying one or several dimensions of the system will not impact the system 's alignment. If the dimension system offset mode is set to Constant, an automatic line-up is applied to dimension lines and values in case you perform any of the following action: • • • • Adding a dimension to a system Deleting a dimension to a system Updating the 3D geometry Applying a style to a system

For more information on the Constant and Free Offset mode, refer to the Editing Dimension System Properties section.
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Lining Up Dimension Systems
This task will show you how to line-up a dimension system. Open the Brackets_views03.CATDrawing document. 1. Create a cumulated dimension system including several dimensions as shown below.

2. Click on the Dimension icon

to create a dimension.

3. Right-click on your dimension system and select Line-up in the contextual menu. 4. Position the mouse on the dimension you just created to align the dimension system on it. 123
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The Line Up dialog box is displayed.

For a dimension system only Offset to reference, Align stacked dimension values and Align cumulated dimension values are taken into account. 5. Modify the Offset to reference value to 5mm. 6. Click on OK. The dimension system is aligned on the dimension with an offset of 5mm.
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Basic Dimension Operations
Creating Dimensions
In this task, you will learn how to create dimensions. When creating dimensions on elements, you can preview the dimensions to be created.
Creating Dimensions

Open the Brackets_views02.CATDrawing document. 1. On the Dimensioning toolbar, click the Dimensions icon.

2. Click a first element in the view. For example, a circle. 3. If needed, click a second element in the view. The dimension type is automatically defined according to the selected elements ( Palette). or in the Tools

) At this step, the command options in the Tools Palette ( allows you to position the dimension using one of the modes below: Projected or Forced modes. These options are also available in the contextual menu. This toolbar is situated at the bottom right of screen. If you cannot see it properly, just undock it.

125

InteractiveDrafting

4. Click the Force Dimension on element command option from the Tools Palette.

5. Right-click to access the contextual menu and select 1 symbol.

The dimension becomes a one-symbol dimension:
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During the dimension creation step, you can switch between one-symbol or twosymbols dimension by selecting or deselecting 1 symbol in the contextual menu. Once the dimension has been created, you must use the Properties menu to specify whether you want to use one or two symbols. Right-click the dimension and in the contextual menu, choose Properties. Click the Dimension Line tab and then check Symbol 2 to display two-symbols dimension, or uncheck this option to display one-symbol dimension.

6. Click in the drawing window to validate the dimension creation.
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8. Select the two dimensions with the Ctrl key (you can move them both). 9. Start creating another dimension: click the command icon another circle: and select

Click in the drawing to validate the creation. 10. Right-click the dimension you just created and in the contextual menu, choose Dimension.3 Object and select Swap to Radius:
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The diameter dimension has swapped to radius dimension:

11. Right-click the dimension again, and in the contextual menu, choose Dimension.3 Object, and uncheck Extend to Center: the radius extension line is not extended until the center anymore.
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•

You can use this functionality through the Properties menu: right-click on the dimension and choose Properties. On the Dimension Line tab, select the type of extension you want from the Extension list: From standard, Till center or Not till center.

•

This functionality works with radius dimension and one-symbol diameter dimension. When you create a dimension between a generated element in a broken view and a sketched element, the dimension value may be false to let the user set a fake dimension value. When you create a dimension between an axis and another element, the dimension created by the software is automatically an half dimension. To bypass this problem, during creation, uncheck Half Dimensions in the contextual menu (right-click). You can generate errors when refreshing the dimensions in the following cases: o In this drawing the dimension "80.14" is measured from the line B to the line C:

• •

•
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If the corresponding part is modified and the chamfer removed, when the drawing is refreshed the dimension is colored in fuchsia because the line B was removed with the chamfer:

o

If the two elements separated by the dimension value are moved then merged, an error is generated and the dimension turns to fuchsia by default (or according to the color defined for Not-up-to-
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Note that in this case, it is not possible to create a null value. Should you need to, you should create a driving dimension and set its value to 0.
Properties

If you right-click the dimension before creation, a contextual menu lets you modify the dimension type and value orientation as well as add funnels. Using this contextual menu once the dimension is created, you can also access the Properties options.
Associativity

If one parent element of the dimension is deleted or deactivated, as soon as you update the drawing (either 3D Generative or 2D Interactive drawing), the orphan dimension becomes purple on the condition you activated the Analysis Display Mode option from the Tools toolbar.

Ensure that if you key in "c: Force Update" in the Power Input field to synchronize the drawing with the 3D, any non-associative dimension will disappear. from the Colors can be customized using the Analysis Display Mode option Tools toolbar or via Tools -> Options -> Mechanical Design -> Drafting, Dimension tab).
Driving Dimensions

You can create dimensions that will, by default, drive the geometry. For this: • Go to Tools -> Options-> Mechanical Design -> Drafting, Dimension tab, and activate the Create driving dimension option.
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For more information, refer to Creating Driving Dimensions.
True Dimensions

True Length dimensions can be created using the True Length Dimensions from the Tools Palette or using the contextual menu. option Before using true dimensions, make sure that you have not set the only create non-associative dimensions option in Tools -> Options -> Mechanical Design -> Drafting, Dimension tab, Associativity on 3D. In order to work, this functionality must be applied to an associative dimension.
Half-Dimensions

You can create half-dimensions. For this, right-click the dimension as you create it and select the Half-dimension option from the contextual menu.
Extension Line Anchor

As you create a dimension between two elements, one of these elements being a circle, you can select the extension line anchor, for this, you can : • use the contextual menu (positioned on the dimension) and select one of the available Extension Line anchor options.

You will thus position the extension line: • • • • at one extremity of the circle (First Anchor) at the center of the circle (Second Anchor) at one extremity of the circle (Third Anchor)

drag the yellow symbol to the one of the anchors (anchors appear when the cursor is over the yellow symbol):
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If in Tools -> Options -> Mechanical Design -> Drafting -> Dimension, you have checked Dimension following the mouse option, then to move the extension line anchor you must press the Crtl key before selecting the yellow symbol (to switch temporarily the option).

Creating Half-Dimensions
Half-Dimensions are useful in the case of revolved features or elements using a plane symmetry. Actually it allows to create the dimensions only on half the geometry.

This task will show you how to create a half-dimension. You can create halfdimensions on distance, angle, diameter cylinders, radius cylinders made out of two selections, diameter edges and diameter tangents but not on cumulate dimensions.

The dimension value is doubled when they are made out of two selections (distance, angle, 2D diameter cylinder, radius cylinder) but not for dimensions made out of one selection (angle on cone, 3D diameter cylinder, diameter edge, diameter tangent).

Open the Brackets_views05.CATDrawing document.
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1.

Click the Dimensions icon Dimensioning toolbar.

from the

2 Click a first element in the view. For . example, an edge. 3 If needed, click a second element in the . view. For example, another edge. 4 Right-click the dimension and select the . Half Dimension option from the contextual menu.

The half-dimension appears. Only one extension line is displayed. The dimension line is shortened with specific overrun, gap and length. The value is not centered on the dimension line. The attributes mentioned in Dimension parameters drive the dimension graphic display.

•

•

Once you select the half-dimension option from the contextual menu, all the following dimensions you create will be assigned the halfdimension mode. If you want to create dimensions in the standard mode, go back to the contextual menu and de-activate the Half Dimension option. You can create a half-dimension directly by selecting first an axis line and then an other element (which is not an axis). The half-dimension value will be the double of the measured value between the elements. If you don't want a half-dimension to be created when selecting such elements, uncheck Half Dimensions from the contextual menu (rightclick) when creating the dimension.
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InteractiveDrafting Associativity in the case of half-dimensions is different from associativity in the case of standard dimensions. For example, the half distance dimension below is associated to the axis and the element, whereas a standard dimension is associated to both symmetrical elements. Standard distance dimension: Half distance dimension:

Diameter and radius dimension are usually created with one selection in 3D. If the dimension is created with two selections, for instance an edge coming from a 3D revolution and another element, the dimension will be not associative. To create the dimension below, you must select only the left or the right side of the cylinder and then right-click on the dimension and select Half Dimension.

Half diameter dimension:

Creating Explicit Dimensions
This task will show you how to create a dimension you explicitly decide to be:

• • •

a length/distance dimension an angle dimension a radius dimension
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You will select the required elements. Note that when entering the command dedicated to the creation of a given type of dimension, the default orientation will be the orientation most adequate.

Open the Brackets_views02.CATDrawing document.

1. Click the desired icon from the Dimensioning toolbar (Dimensions subtoolbar).

length/distance dimension angle dimension radius dimension diameter dimension 2. Click as many elements as required in the view. The Tools Palette automatically appears, displaying dimension modes, except in the case of angle dimensions. 3. If needed, define the dimension mode in the Tools Palette ( ) using one of the modes below: Projected, Forced or True Length modes. These options are also available in the contextual menu.

Length/Distance

Angle
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Radius

Diameter

For radius dimensions, you can activate the Foreshortened option in the contextual menu Properties -> Dimension Line.

It allows you to transform a radius dimension line into a foreshortened radius dimension line. Then you can choose the text position (on long segment or short segment), the dimension text orientation according to the dimension line ( parallel or convergent), the angle value, the ratio value (short segment/long segment), and the point scale value. You can also specify whether you want to position manually the extremity point of the foreshortened dimension line (in this case, you will be able to
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Curve and Angle Dimensions
Creating/Modifying Angle Dimensions
This task will show you how to create an angle dimension and perform the following kinds of modifications: new angle sector or turn an angle sector into a supplementary sector. Create two lines.

1. Select the Dimension icon

from the Dimensioning toolbar.

2. Select both lines to be dimensioned, one after the other. The angle dimension appears in the sector associated to both selected lines.

3. Drag the angle dimension line to the desired quadrant (or sector).

You can move the dimension to a new sector by using the contextual menu:

139

InteractiveDrafting

•

Right-click the angle dimension and from the contextual menu, Dimension.x object > Angle Sector, either select a given angle sector or the Complementary Angle sector.

•

You can also CTRL-click the dimension line.

4. Click anywhere to create angle dimension.

You can edit the angle sector of an existing angle dimension, by right-clicking the angle dimension and selecting the Dimension_name object -> Angle Sector command from the contextual menu. 5. Create a rectangle. 6. Select the Angle Dimensions icon from the Dimensioning toolbar.

7. Select two lines in the rectangle to create an angle dimension.
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8. Click to create the angle dimension, then right click on the dimension and select Half Dimension in the contextual menu.

9. Click in a free space to create the dimension.

Note that the half angle dimension's orientation depends on the order of selection of the lines to be dimensioned. Had you selected the vertical line first, then the horizontal one, the orientation of the dimension would had been the following:
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In case you should need to modify the dimension, use the Re-route dimension icon .

Creating Chamfer Dimensions
This task will show you how to create a chamfer dimension. You can use two different methods: • • create chamfer dimensions manually, create chamfer dimensions using chamfer detection.

Creating chamfer dimensions manually

Open the IntDrafting_Dim_Chamfer.CATDrawing document. 1. Go to Tools -> Options -> Mechanical Design -> Drafting -> Dimensions tab and make sure the Detect chamfer option is not selected.

2.

Click the Chamfer Dimensions icon (Dimensions sub-toolbar).

from the Dimensioning toolbar
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User Tasks 3. In the Tools Palette which is displayed, you can choose: • The format of the dimension: o Length x Length (19,1 x 19,1 in our example) o Length x Angle (19.1 x - 46deg84'8" in our example) o Angle x Length (- 46deg84'8" x 19.1 in our example) o Length 19,1. The representation mode: o o One symbol Two symbols

•

Choose the Length x Length format and the One symbol mode

.

You can also access these options using the contextual menu: at any time during the chamfer dimension creation, you can right-click to display the contextual menu.

4. Select the element to be dimensioned.

5. Select a reference line or surface.

6. You have two options: • Click on the sheet to end the dimension creation. The chamfer dimension is computed with an implicit second reference line that is perpendicular to the first one.
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OR • Select a second reference line or surface. In this case, the chamfer dimension is computed according to both reference lines you selected.

In a Generative Drafting context (i.e. in the case of a generative view), you must do this, i.e. you must explicitly select the second reference line.

In any case, the dimension is associated to all the elements you selected.

Creating chamfer dimensions using chamfer detection

Please note that chamfer detection is provided as a help in selecting chamfers. However, depending on the geometrical configuration, it may not detect all chamfer types. If your chamfer is not detected, you can still create the chamfer dimension manually as explained below. Open the IntDrafting_Dim_Chamfer.CATDrawing document.
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2. Click the Chamfer Dimensions icon (Dimensions sub-toolbar).

from the Dimensioning toolbar

3. In the Tools Palette which is displayed (as well as in the contextual menu), you can choose the format of the dimension and the representation mode. For more information, refer to Step 2 in Creating chamfer dimensions manually. Choose the Length x Length format and the One symbol mode .

4. Fly the mouse over the element to be dimensioned. You can notice that, depending on where you position the cursor, the auto-detection agent indicates a different order for taking elements into account when creating the chamfer dimension: • • • 1 indicates the element to be dimensioned, 2 indicates the line which will be used as the first reference, 3 indicates the line which will be used as the second reference.

5. Click when you are satisfied with the order offered by the auto-detection agent. For example, click to accept the 3 - 1 - 2 order. The chamfer dimension is computed according to the first and the second auto-detected reference lines.
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At this stage, if you are not satisfied with the order you just accepted, or if your chamfer is not detected, you can still click to select the first reference line, and, optionally, the second reference line. This amounts to creating the chamfer dimension manually.

6. Click to end the chamfer dimension creation.

The dimension is associated to all auto-detected elements.

Remarks about chamfer dimensions

•

In a Generative Drafting context, you can create chamfer dimensions for the following types of cylindrical shapes: cylinder/cone/cylinder, plane/cone/cone, plane/cone/cylinder, plane/plane/plane.

146

User Tasks

•

• •

When creating chamfer dimension on cylindrical shapes in a Generative Drafting context, remember that: o in the case of projection views, the projection plane needs to be parallel to the cylinder axis. o in the case of section views or section cuts, the section plane needs to to be parallel to, and to go through, the cylinder axis. o the sketched profile on which the cylinder (or the cone) is based must be a circle. All settings defined in Tools->Option->Mechanical Design->Drafting (Dimensions and Manipulators tabs) are taken into account when creating chamfer dimensions. When editing chamfer dimension text properties (Edit > Properties command, Dimension Texts tab), any information (e.g. associated text, fake dimension, tolerance, text before/after, etc.) added to the main value, will actually be positioned according to the first value (excluding the "x" symbol, e.g. "19,1"). This information will be positioned in the following order: Text Before/Prefix/first value/Tolerance/Suffix/Text After/second value (including the "x" symbol, e.g. "x 20,37"). An example is provided below, with a Text After.
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•

In an Interactive Drafting context, creating chamfer dimensions is possible only if the lines making up the chamfer are incident.

Creating Partial Curvilinear Length Dimensions
This task will show you how to create dimensions for the curvilinear length of a curve portion, i.e. to measure the partial length of a curve. Partial curvilinear length dimensions are defined using points. You can use two different methods: • • Creating partial curvilinear length dimensions using existing points Creating partial curvilinear length dimensions using points created onthe-fly

Creating partial curvilinear length dimensions using existing points

Open the CurvilinearDimension.CATDrawing document. Create two points on a curve, for example. These points will be used to define the extremities of the curve portion to dimension.

You can also use spline control points (but there is none in the sample provided for this scenario), or points created in free space. In the case of points in free space, the partial curvilinear length dimension will be computed according to the normal projection of these points on the curve. So, when creating such points, you need to make sure that they will be projected on the curve, as shown below for example.
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1. Click the Dimension icon

from the Dimensioning toolbar.

2. Select the curve on which you created the points. A preview of the dimension is displayed. By default, this preview shows an overall curve dimension. 3. Right-click to display the contextual menu and select Partial Curvilinear Length instead of Overall. 4. Still in the contextual menu, select a representation mode for the dimension line: • Offset displays the dimension line as an offset of the measured curve. • Parallel displays the dimension line as a translation of the measured curve. • Linear displays the dimension line as linear. For the purpose of this scenario, select Parallel. 5. On the curve, select the existing point that defines the first extremity of the curve portion to dimension.

6. Select the point that defines the second extremity of the curve portion to dimension.
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7. Optionally drag the dimension line and/or the dimension value to position them as wanted. 8. Click elsewhere in the drawing to validate the dimension creation. The semi-arc symbol displayed over the dimension value symbolizes a curvilinear length dimension (whether partial or not). You can now handle the dimension just like any other dimension.

9. Move one or both points, on the line or in free space. The dimension is re-computed (if you moved the point in free space, it is recomputed according to the normal projection of the points on the curve.)

If you move a point in such a way that it cannot be projected on the curve anymore, the dimension becomes not-up-to-date.

Creating partial curvilinear length dimensions using points created on-the-fly
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2. Select a curve. A preview of the dimension is displayed. 3. Right-click to display the contextual menu and make sure Partial Curvilinear Length is selected. 4. Still in the contextual menu, select a representation mode for the dimension line: for the purpose of this scenario, select Offset. 5. On the curve, select the point that defines the first extremity of the curve portion to dimension. You can click on the curve, or in the free space. Note that the indicated point cannot go further than the extremity of the curve itself.

6. Select the point that defines the second extremity of the curve portion to dimension.
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Note that two points, as well as two coincidence constraints, have been created on the curve, at the projection point of where you clicked. 7. Optionally drag the dimension line and/or the dimension value to position them as wanted. 8. Click elsewhere in the drawing to validate the dimension creation. The semi-arc symbol displayed over the dimension value symbolizes a curvilinear length dimension (whether partial or not). You can now handle the dimension just like any other dimension.

More About Partial Curvilinear Length Dimensions

General remarks • Partial curvilinear length dimensions can be created using the Dimensions and Length/Distance Dimensions commands; they cannot be created using the Stacked Dimensions and Cumulated Dimensions commands. You can create partial curvilinear length dimensions for all types of curves: splines, circles, arcs of circle, conics, etc. Note that in the case of circles and arcs of circle, they will be called partial circular length dimensions. You can create partial length dimensions for lines. The curvilinear length symbol is defined by the administrator in the standards. The same symbol is used for partial curvilinear dimensions and for curvilinear dimensions. Partial curvilinear length dimensions cannot be True Length dimensions.

•

• • •
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User Tasks • If you delete a point that defines a dimension, the dimension becomes not-up-to-date, and its color changes to fuchsia by default (or according to the color defined for Not-up-to-date dimensions in the Types and colors of dimensions dialog box available via Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, Analysis Display Mode area, Types and colors... button). If you delete both points, the dimension becomes a regular curvilinear dimension.

Restrictions • • You cannot change the dimension line representation mode or orientation after the dimension has been created. In the case of the parallel and offset representation modes, the dimension value cannot be moved out of the curve limits, except for circles and arcs of circle. As a result, you cannot specify the dimension value position (Inside, Outside, Auto). In some cases, depending on the curve and on the offset value, the offset representation mode cannot be computed. In the case of partial curvilinear length dimensions in offset mode, it is recommended to activate the Constant offset between dimension line and geometry setting in Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab. This will ensure that the dimension remains associative if the geometry is moved. Partial curvilinear dimensions cannot be measured along a direction. However, partial length dimensions can be measured along a direction. Partial curvilinear dimensions cannot be driving dimensions. When creating partial circular length dimensions on circles, you cannot select a circular sector.

• •

• • •

Creating Radius Curvature Dimensions
This task will show you how to create and modify a radius curvature dimension. A radius curvature dimension lets you know the curvature radius at a given point on a curve (spline, ellipse, etc.).

Create a spline.
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1. Select the Dimension icon

from the Dimensioning toolbar.

2. Move the cursor over the spline. You can notice that the cursor changes to indicate that you are going to create a dimension on a spline.

3. On the spline, click the point where you want to create the radius curvature dimension. A preview of the radius curvature dimension is displayed. 4. Click to validate the dimension creation.

5. Move the dimension over the spline to modify the dimension.

Creating Overall Curve Dimensions
This task will show you how to create overall dimensions on curves. You can create dimensions on the overall horizontal or vertical size of any kind of curve, whether it is canonical or not (e.g.: ellipse, spline, etc.). You can also
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create dimensions on the overall size between 2 curves, or between a curve and a line, for example. Go to Tools -> Options -> Mechanical Design -> Drafting. On the Dimension tab, uncheck Dimension following the cursor (CTRL toggles). Open the Dimension_Spline.CATDrawing document. 1. Click the Dimension icon from the Dimensioning toolbar.

2. In the Tools Palette, click the Force horizontal dimension in view icon to specify that you want to create the dimension based on the horizontal direction. The direction of overall curve dimensions can only be horizontal or vertical. 3. Select a spline. A preview of the dimension is displayed.

If the preview shows a curvilinear length dimension instead of an overall curve dimension, right-click to display the contextual menu and select Overall instead of Curvilinear Length. 4. Click elsewhere in the drawing to validate the dimension creation. The dimension you created indicates the overall horizontal size of the spline.
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5. Again, click the Dimension icon

.

6. In the Tools Palette, click the Force vertical dimension in view icon to specify that you want to create the dimension based on the vertical direction. 7. Select the bottom line and the other spline. A preview is displayed. Yellow manipulators and point indicators appear: these let you select precisely the points that you want the dimension to take into account.

8. Move the spline dimension manipulator to point 7 on the spline, for example.
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The preview is updated.

9. Click in the drawing to validate the dimension creation. The dimension you created indicates the overall vertical distance between the bottom line and point 7 of the spline. You can edit the dimension representation of an existing dimension, by rightclicking the dimension and selecting the Dimension_name object -> Dimension Representation command from the contextual menu.

Creating Curvilinear Length Dimensions
This task will show you how to create dimensions for the curvilinear length of a curve, i.e. to measure the overall length of a curve. Open the CurvilinearDimension.CATDrawing document. 1. Click the Dimension icon from the Dimensioning toolbar.

2. Select a curve. A preview of the dimension is displayed. By default, this preview shows an overall curve dimension.
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3. Right-click to display the contextual menu and select Curvilinear Length instead of Overall. 4. Still in the contextual menu, select a representation mode for the dimension line: • Offset displays the dimension line as an offset of the measured curve. • Parallel displays the dimension line as a translation of the measured curve. • Linear displays the dimension line as linear. Select Parallel, for example. 5. Optionally drag the dimension line and/or the dimension value to position them as wanted. 6. Click elsewhere in the drawing to validate the dimension creation. The semi-arc symbol displayed over the dimension value symbolizes a curvilinear length dimension. You can now handle the dimension just like any other dimension.

7. Again, click the Dimension icon

.

8. Select another curve. This time, the preview of the dimension shows a curvilinear length dimension (your previous selection was memorized). 9. Once again, right-click to display the contextual menu and select Offset as
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11. Repeat steps 7 to 9, this time selecting Linear as the representation mode for the dimension line. 12. Still in the contextual menu, select Dimension Representation -> Force Horizontal Dimension in View to specify the dimension line orientation. 13. Click in the drawing to validate the dimension creation.

More About Curvilinear Length Dimensions

General remarks • • • Curvilinear length dimensions can be created using the Dimensions and Length/Distance Dimensions commands; they cannot be created using the Stacked Dimensions and Cumulated Dimensions commands. You can create curvilinear length dimensions for all types of curves: splines, circles, arcs of circle, conics, etc. Note that in the case of circles and arcs of circle, they will be called circular length dimensions. The curvilinear length symbol is defined by the administrator in the
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•

Restrictions • • You cannot change the dimension line representation mode or orientation after the dimension has been created. In the case of the parallel and offset representation modes, the dimension value cannot be moved out of the curve limits, except for circles and arcs of circle. As a result, you cannot specify the dimension value position (Inside, Outside, Auto). In some cases, depending on the curve and on the offset value, the offset representation mode cannot be computed: o In certain cases, when switching from another representation mode to the offset mode, the dimension will be previewed as being not-upto-date (i.e. using the color configured in Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, Analysis Display Mode): try to move the cursor closer to the dimension.

•

o

In other cases, you will not be able to position the dimension further than a certain limit. The examples below show the limits for positioning a curvilinear length dimension in offset mode for a spline.
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•

•

•

• •

In the case of curvilinear length dimensions in offset mode, it is recommended to activate the Constant offset between dimension line and geometry setting in Tools > Options > Mechanical Design > Drafting > Dimension tab. This will ensure that the dimension remains associative if the geometry is moved. When dimensioning a 3D curve that is not planar, the extension line of the curve will extend to the projection of the endpoints of the curve in the view plane of the dimension. As a result, the dimension may seem to point nowhere. Curvilinear dimensions cannot be measured along a direction. Curvilinear dimensions cannot be driving dimensions.

Creating Thread Dimensions
This task will show you how to create thread dimensions. Open the intthread.CATDrawing document. 1. Click the Thread Dimension icon (Dimensions sub-toolbar). from the Dimensioning toolbar

2. In the front view, select the thread to be dimensioned. The thread diameter dimension appears.

3. Click the Thread Dimension icon

again.
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4. In the section view, select the two lines representing the thread to be dimensioned.

5. Two thread dimensions appear, representing the thread diameter as well as the thread depth.

In top views, you can modify the orientation of threads dimensions.

Creating/Modifying Coordinate Dimensions
This task will show you how to automatically create 2D or 3D coordinate dimensions on elements. Coordinate dimensions allow you to define the coordinates of a point relative to the X, Y, and possibly Z, axes.

Open the PointSketch.CATDrawing document.

1. Click the Coordinate Dimension icon (Dimensions sub-toolbar).

from the Dimensioning toolbar
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The Tools palette appears with two options: 2D Coordinates

lets you create

2D (x, y) coordinate dimensions for interactive geometry, 3D Coordinates lets you create 3D (x, y, z) coordinate dimensions for generative geometry. • These options are also available via the contextual menu. • This choice of options is valid for generative geometry only. In the case of a generative drawing, or in the case of a drawing containing a mix of generative and interactive elements, both options will be available, but if you select sketched (i.e. interactive) geometry, the 2D Coordinates option will be applied automatically (even if you selected the 3D Coordinates option). In the case of a purely interactive drawing, the options will not be displayed at all, and only the 2D Coordinates option will be applied.

option in the Tools Palette, as you will be 2. Select the 3D Coordinates dimensioning elements generated from the 3D.

3. Select the element for which you want to create the 3D coordinate dimension. The coordinate dimension is created immediately.

• •

At this point, you can right-click to display the contextual menu, which allows you add a breakpoint to the leader, or to choose the leader symbol. You can also select a set of elements by trapping them with the mouse, to create several coordinate dimensions in one shot.

4. Click in the free space to end the dimension creation. 5. Select the coordinate dimension to modify its position. The dimension is
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• • •

Coordinates are relative to the absolute axis system except for views created by selecting a 3D local axis system. The yellow anchor point is associative and is linked to the element you dimensioned. If you create a coordinate dimension on the origin, this dimension is invariably non-associative. In this case, the leader symbol may be different from the leader symbol used for associative coordinate dimensions. Refer to Dimension Styles > Coordinate Dimension Styles for more information. If you need to hide the coordinate dimension's unit, you can do so by editing the properties of the coordinate dimension (via Edit -> Properties): select the Text tab and uncheck the Display Units option.

•

Then click OK to update the view: the units should not be displayed anymore.

Creating Tables
Creating a Hole Dimension Table
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User Tasks This task will show you how to create a hole and center line dimension table (containing diameter and center coordinates).

Open the alesage.CATDrawing document. 1. Select one or more holes and center lines (only center lines not associated with a hole) in the drawing.

Do not select arcs of circles, as it is impossible to include them in a hole and center line dimension table. 2. Click the Hole Dimension Table icon launch the table creation command. on the Dimensioning toolbar to

165

InteractiveDrafting 3. The Axis System and Table Parameters dialog box is displayed. Axis system: Indicate the holes coordinates 2D reference axis system. In this example, click on the view origin (you can also select two lines or click anywhere in the drawing, or enter the origin coordinate). Two reference axis appear:

You can rotate or flip the axis using the Flip horizontally and Flip vertically icons and choose to represent the axis system by checking the Create representation box. Title: Type the table title. Columns: • Choose a label (A, B, C... or 1, 2, 3...). If you want column numbering to start with values other than A or 1, click the icon start value. Select and name the column to display. and specify the

•

Table format: • • • Check Transpose table to invert columns and rows. Check Sort table content to sort the table elements. Check Split table to split the table into several tables. For more information on splitting tables, see Creating/Modifying a table.

4. Choose 2D reference axis system for the axis system from the associated drop-down list.

166

User Tasks

5. Type the table name in the Title field. 6. Select Label: A, B, C from the Column drop-down list (you can also choose the Index naming mode) to give a label to the selected points in the drawing. 7. Check X, Y and Diameter to have four columns corresponding to the hole labels and to the Cartesian coordinates. Then enter a title for each column. 8. Check Transpose table to invert columns and rows in the table.

9. Check Sort table content and then click the icon parameters. to define the sorting

10. To sort the table by descending X coordinates, choose X in the Sort by combo box, and select Descending. Then, click Close.

11. Click OK to validate your settings and then click in the drawing to define the location of the table. The table is generated.
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Creating a Points Coordinates Table
This task will show you how to create a table containing coordinates of points from 2D and 3D. Open the PointSketch.CATDrawing document. 1. Multi-select the points on one of the views or on all views.

2. Click the Coordinate Dimension Table icon to launch the table creation command.

on the Dimensioning toolbar
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User Tasks 3. The Axis system and table parameters dialog box is displayed. Axis system: You can choose to use the 2D axis system. It can be either the one of the view or user-defined. In this case, it can be defined interactively by either: • • • indicating a point by clicking in the view, selecting a point, selecting two lines.

Or it can be defined by typing the origin coordinates in the X and Y fields. You can rotate or flip the axis using the Flip horizontally and Flip vertically icons and choose to represent the axis system by checking the Create representation box. Or you can choose to use the 3D axis system. In this case, it is the absolute axis of the 3D model, or, if the model is a single part, a local axis. Title: Type the table title. Columns: • Choose a label (A, B, C... or 1, 2, 3...). If you want column numbering to start with values other than A or 1, click the icon and specify the start value. Select and name the column to display,

•

Table format: • • • Check Transpose table to invert columns and rows. Check Sort table content to sort the table elements. Check Split table to split the table into several tables. For more information on splitting tables, see Creating/Modifying a table.

4. Choose Axis system.1 for the axis system from the associated drop-down
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InteractiveDrafting list. 5. Type the table name in the Title field. 6. Select Label: A, B, C from the Column drop-down list (you can also choose the Index naming mode) to give a label to the selected points in the drawing. 7. Check X, Y and Z to create four columns corresponding to the points labels and to the Cartesian coordinates. Then enter a title for each column in the associated field. 8. Check Transpose table to invert columns and rows in the table.

9. Check Sort table content and click the to define the sorting icon parameters. 10. To sort the table by descending X coordinates, choose X in the Sort by combo box, and select Descending. Then, click Close.

11. Click OK to validate your settings and then click in the drawing to define the location of the table. The table is generated.

Creating a Hole Dimension Table
This task will show you how to create a hole and center line dimension table (containing diameter and center coordinates).

Open the alesage.CATDrawing document. 1. Select one or more holes and center lines (only center lines not associated
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Do not select arcs of circles, as it is impossible to include them in a hole and center line dimension table. 2. Click the Hole Dimension Table icon launch the table creation command. 3. The Axis System and Table Parameters dialog box is displayed. Axis system: Indicate the holes coordinates 2D reference axis system. In this example, click on the view origin (you can also select two lines or click anywhere in the drawing, or enter the origin coordinate). Two reference axis appear: on the Dimensioning toolbar to

You can rotate or flip the axis using the 171

InteractiveDrafting Flip horizontally and Flip vertically icons and choose to represent the axis system by checking the Create representation box. Title: Type the table title. Columns: • Choose a label (A, B, C... or 1, 2, 3...). If you want column numbering to start with values other than A or 1, click the icon start value. Select and name the column to display. and specify the

•

Table format: • • • Check Transpose table to invert columns and rows. Check Sort table content to sort the table elements. Check Split table to split the table into several tables. For more information on splitting tables, see Creating/Modifying a table.

4. Choose 2D reference axis system for the axis system from the associated drop-down list. 5. Type the table name in the Title field. 6. Select Label: A, B, C from the Column drop-down list (you can also choose the Index naming mode) to give a label to the selected points in the drawing. 7. Check X, Y and Diameter to have four columns corresponding to the hole labels and to the Cartesian coordinates. Then enter a title for each column. 8. Check Transpose table to invert columns and rows in the table.
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9. Check Sort table content and then click the icon parameters. to define the sorting

10. To sort the table by descending X coordinates, choose X in the Sort by combo box, and select Descending. Then, click Close.

11. Click OK to validate your settings and then click in the drawing to define the location of the table. The table is generated.

Creating a Points Coordinates Table
This task will show you how to create a table containing coordinates of points from 2D and 3D. Open the PointSketch.CATDrawing document. 1. Multi-select the points on one of the views or on all views.
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2. Click the Coordinate Dimension Table icon to launch the table creation command. 3. The Axis system and table parameters dialog box is displayed. Axis system: You can choose to use the 2D axis system. It can be either the one of the view or user-defined. In this case, it can be defined interactively by either: • • • indicating a point by clicking in the view, selecting a point, selecting two lines.

on the Dimensioning toolbar

Or it can be defined by typing the origin coordinates in the X and Y fields. You can rotate or flip the axis using the Flip horizontally and Flip vertically icons and choose to represent the axis system by checking the Create representation box. Or you can choose to use the 3D axis system. In this case, it is the absolute axis of the 3D model, or, if the model is a single part, a local axis.
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Title: Type the table title. Columns: • Choose a label (A, B, C... or 1, 2, 3...). If you want column numbering to start with values other than A or 1, click the icon and specify the start value. Select and name the column to display,

•

Table format: • • • Check Transpose table to invert columns and rows. Check Sort table content to sort the table elements. Check Split table to split the table into several tables. For more information on splitting tables, see Creating/Modifying a table.

4. Choose Axis system.1 for the axis system from the associated drop-down list. 5. Type the table name in the Title field. 6. Select Label: A, B, C from the Column drop-down list (you can also choose the Index naming mode) to give a label to the selected points in the drawing. 7. Check X, Y and Z to create four columns corresponding to the points labels and to the Cartesian coordinates. Then enter a title for each column in the associated field. 8. Check Transpose table to invert columns and rows in the table.
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9. Check Sort table content and click the to define the sorting icon parameters. 10. To sort the table by descending X coordinates, choose X in the Sort by combo box, and select Descending. Then, click Close.

11. Click OK to validate your settings and then click in the drawing to define the location of the table. The table is generated.

Creating Dimensions using Elements
Creating Dimensions between Intersection Points
This task will show you how to create dimensions between an intersection point and an element or between two intersection points. Open the GEAR-REDUCER2.CATDrawing document. 1. Click the Dimension icon from the Dimensioning toolbar.

2. In the Tools Palette, click the Intersection Point Detection icon

.

3. Position the mouse over the first intersection point. An intersection point is the meeting point of: • 2 extensions lines (as shown in this example) • 2 lines • a line and an extension line
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A preview of the intersection point is displayed.

• In the case of drawings with many elements displayed on screen, intersection points may sometimes be difficult to detect. If this happens (i.e. if the intersection point is not previewed or if the previewed intersection point is not the one you want), simply position the mouse over the first and then the second reference element. The proper intersection point will then be previewed. • In the case of a generative view created with the Approximate generation mode, detection of intersection points is not available. In this case, you need to position the mouse over the first and then the second reference element. 4. Click to create the intersection point. The point is created, as well as construction lines and coincidence constraints between the point and its reference elements. The display and behavior of intersection points is defined by the administrator in the standards. Indeed, the administrator can specify the style that should be applied to the intersection point and construction line, whether the intersection point can be printed or not, and whether construction lines should be displayed and/or printable. 5. Now, position the mouse over the second intersection point.
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6. Click to create the intersection point. A preview of the dimension is displayed. By default, this dimension is a distance dimension.

At this point, if you want to create a diameter dimension or a radius dimension rather than a distance dimension, you can right-click to display a contextual menu in which you will be able to change the dimension type from the default Distance to Diameter Edge or Radius Edge.
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For the purpose of this scenario, leave the default option, Distance, selected. 7. Using the mouse, position the dimension as wanted. 8. Click to validate and end the dimension creation.

Creating Dimensions between an Element and a View Axis
In this task, you will learn how to create dimensions between an element and a view axis (one of the two axes or the origin).
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InteractiveDrafting Open the IntDrafting_Viewplane_Front.CATDrawing document. Go to Tools -> Options -> Mechanical Design -> Drafting -> General and check Display in the current view to display the view axis.

1. Click the Dimensions icon

from the Dimensioning toolbar.

2. Click a first element in the view.

3. Select one of the two view axes or the origin.

4. Click anywhere in the drawing window to confirm the dimension creation.
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The dimension is created.

Creating Dimensions along a Reference Direction
This task will show you how to create dimensions along a reference direction, i.e. measure the projection of a segment/distance onto a direction. This direction is determined using either a linear element, a fixed angle in the view or a combination of both. Dimensions along a reference direction can be created for length, distance, diameter tangent, radius tangent, and overall curve dimensions, as well as on linear (i.e. not angular) cumulated or stacked dimensions. Open the GEAR-REDUCER2.CATDrawing document. 1. Click the Dimension icon from the Dimensioning toolbar.

2. In the Tools Palette, click the Intersection Point Detection icon . Refer to Creating dimensions between intersection points for more information about this functionality. 3. Click the first element, in this case, an intersection point.
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4. Click the second element.

The dimension to be created is previewed. In the Tools Palette, click the Force dimension along a direction icon: Several options are then displayed in the Tools Palette:

•

Dimension along a direction creates the dimension using a linear element (line, axis line, center line) as the reference direction, or using an angle to define the reference direction relatively to a linear element. In the latter case, key in a value
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User Tasks in the Angle field. • • Dimension perpendicular to a direction creates the dimension perpendicularly to a linear element. Dimension along a fixed angle in view creates the dimension using a fixed angle in the view. In this case, key in a value in the Angle field. Note that such a dimension follows the view rotation. Thus, a dimension line with a 30 deg angle in a view which is set at 45 deg (relatively to the sheet) will be equivalent to a dimension line with a 75 deg angle relatively to the sheet.

These options are also available in the contextual menu that you can display during the dimension creation. 5. Click the Dimension along a direction icon scenario, leave the Angle field set to 0 deg. . For the purpose of this

6. Select a linear element to use as the reference direction. Once created, the dimension will be associative to this element.

The dimension is updated so as to measure the distance between the selected points once projected onto the reference direction. 7. Drag the mouse to position the dimension as wanted. 8. Click to validate the dimension creation.
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More About Dimensions Along a Reference Direction

•

In the case of a dimension along or perpendicular to a direction, if you delete the linear element used as the reference direction, the dimension will be automatically converted into a dimension along a fixed angle in view (the angle being that of the reference element in the view before its deletion). The behavior of a dimension along or perpendicular to a direction will actually depend on whether the Only create non-associative dimensions option is activated in Tools > Options > Mechanical Design > Drafting > Dimension tab, Associativity on 3D button: If it is activated, then the dimension will actually be a dimension along a fixed angle in the view (the angle being that of the reference element in the view). o If it is not activated, then the dimension will always match the direction of the element defining the reference direction. Once a dimension along a reference direction has been created, you cannot modify the elements that define the direction of measure, i.e. either the linear element used as the reference direction or the fixed angle in view. The reference direction will not be taken into account when re-routing dimensions (Re-route Dimension command). Dimensions along a reference direction cannot be driving dimensions. So, if the Create driving dimension option is activated in Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, you will not be able to drive dimensions when dimensioning along a direction. Dimensions created in a shot (i.e. cumulated/stacked dimensions, or dimensions sharing the same type as the first one) all have the same reference direction. o

•

•

• •

•
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Modifying/Annotating Dimensions
Re-routing Dimensions
This task will show you how to re-route dimensions, i.e. to recalculate dimensions taking into account new geometry elements which are compatible with the re-routed dimension type.

Re-routing dimensions can be particularly useful in the case of isolated dimensions resulting from V4 to V5 migration. Indeed, re-routing isolated dimensions to the geometry enables you make them associative.

Open the Reroute_Dimensions.CATDrawing document. You can notice that the dimension properties are customized.

1. Select the Re-route Dimension icon Line Interruptions sub-toolbar).

from the Dimensioning toolbar (Extension

2. Select the angle dimension. You can notice that the cursor indicates the type of dimension you are selecting.

3. Select the first element you want to take into account for the dimension re-routing, and then the second element. Select the first element. Then, select the second element.
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During this operation, the cursor gives a graphic preview of what type of element you are selecting (in this case, lines).

A preview of the re-routed angle dimension is displayed.

4. Click to validate the dimension creation.
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•

• • •

Always make sure that the element(s) to which you are re-routing dimensions are compatible with the re-routed dimension type. For example, when re-routing a radius dimension, you need to select a curved element. You cannot re-route chamfer dimensions. In a Generative Drafting context, you cannot re-route dimensions generated via the Generate Dimensions command. Re-routing dimensions preserves dimension properties when you customized them.

Modifying the Dimension Type
This task will show you how to modify the dimension type as you create a dimension. In other words, you modify the dimension attributes. In this particular example, we will apply a Radius Center dimension type to a hole. Open the Brackets_views02.CATDrawing document. 1. Click the Dimensions icon and then select a hole, for example. Make sure you do not click in the drawing or on the dimension, as this would validate the creation. 2. Right-click the dimension. 3. Select the required dimension type from the displayed contextual menu. For example, Radius Center. The diameter dimension is automatically turned into a radius dimension. 4. Click in the drawing to validate the dimension creation. If needed, you can modify the dimension location.
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•

When you display the contextual menu during the dimension creation, you can define the value orientation with the screen, view or dimension line as reference, or still horizontal, vertical or according to a fixed angle. These options are available in the Value Orientation dialog box.

Interrupting Extension Lines
This task will show you how to interrupt manually one or more extension lines of one or more dimensions.

Open the Interruption_ExtLine01.CATDrawing document.
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User Tasks 1. You have several possibilities: • • Right-click a dimension and select the Dimension.1 Object -> Create Interruption(s) option from the contextual menu. Select a dimension and click Insert -> Dimensioning -> Dimension Edition -> Create Interruption(s) from the menu bar. Select a dimension and click on the Create Interruption(s) icon the Dimensioning toolbar (Dimension Edition sub-toolbar). in

•

• •

You can also select the interruption command first, and then the dimension. You can multi-select several dimensions either using the Ctrl key or by trap.

2. In the Tools Palette, indicate if you want to create the interruption on one extension line or on both extension lines.

3. Click to indicate the first point defining the interruption to be created. 4. Click to indicate the second point defining the interruption to be created.

189

InteractiveDrafting

If you have chosen to create the interruption on one extension line, the interruption is automatically created on the extension line which is closest to where you click.

5. To remove the interruption you created, you have several possibilities: • • Right-click the dimension and select Dimension.1 Object -> Remove Interruption(s) from the contextual menu. Select the dimension and click Insert -> Dimensioning -> Dimension Edition -> Remove Interruption(s) from the menu bar. Select the dimension and click on the Remove Interruption(s) icon the Dimensioning toolbar (Dimension Edition sub-toolbar). in

•

6. In the Tools Palette, indicate if you want to remove a single interruption on an extension line, all interruptions on an extension line, or all interruptions on both extension lines. In this case, leave the Remove One Interruption icon selected.

7. Click to indicate the extension line from which you want to remove the interruption. The interruption is removed from the extension line which is closest to where you click.

• • 190

When creating or removing interruptions, you can select the dimension either before or after selecting the appropriate command. If you move the dimension, the interruption will remain as you created it.

User Tasks • • If you modify either the overrun and / or the blanking, the interruption also remains the same. You can perform interruptions on dimension systems, both on single dimensions of a system and the whole system. However, for stacked and cumulated dimension systems, the reference line cannot be interrupted. You can apply a maximum of eight interruptions to an extension line. Extension lines with funnels cannot be interrupted. Likewise, you cannot add funnels to extension lines with interruptions.

• •

Modifying the Dimension Value Text Position
This task will show you how to modify the position of the dimension value text using the mouse. Open the Brackets_views02.CATDrawing document. Create a distance dimension, for example.

1. Click the Select , if icon needed. 2. Select the dimension value text.

3. Drag the value text to the new position. 4. Click to validate the position. Note that as a useful help, you can press the Shift key to use Snapping temporarily (as long as you keep the button pressed).
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Modifying the Dimension Line Location
This task will show you how to modify dimension line location either as you create or after creating dimensions. Open the Brackets_views02.CATDrawing document. Create a distance dimension, for example. 1. Click the Select , if icon needed. 2. Select the dimension to be modified. For example, a distance dimension. The distance dimension is highlighted.

3. Select the dimension line. 4. Drag the dimension line to the new position.

• •

You can also modify the dimension line location using the extension line. As a useful help, you can press the Shift key to temporarily activate/deactivate snapping (depending on whether the Snap by default option is selected in the Annotation and Dress-up settings).

Modifying the Dimension Value Text Position
This task will show you how to modify the position of the dimension value text using the mouse.
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1. Click the Select , if icon needed. 2. Select the dimension value text.

3. Drag the value text to the new position. 4. Click to validate the position. Note that as a useful help, you can press the Shift key to use Snapping temporarily (as long as you keep the button pressed). At any time, you can restore the original value text position. To do this, rightclick the dimension you positioned and select Restore Value Position from the contextual menu.

Adding Text Before/After the Dimension Value
This task will show you how to insert text before or after the dimension value. Open the Brackets_views02.CATDrawing document. Create a distance dimension, for example. Go to Tools -> Options -> Mechanical Design -> Drafting -> Manipulators tab, and check the Modification box for the Insert text before and the Insert text after options.
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1. Click the Select icon

, if needed.

2. Click the dimension to be modified. The dimension is highlighted and two manipulators appear, both before and after the dimension value. 3. Click the manipulator before the dimension value, for example.

The Insert Text Before dialog box is displayed. 4. Enter the text that you want to add before the dimension value, L= for instance.

5. Click OK. The text is automatically inserted before the dimension value.

194

User Tasks

Note that any created Text Before is automatically added to the dropdown list in the dialog box and can therefore be selected again from this list. 6. Click in the free space.

Modifying the Dimension Overrun/Blanking
This task shows how to modify dimensions extension line overrun and/or blanking either together or separately. Open the Brackets_views02.CATDrawing document. Create a distance dimension, for example. Go to Tools -> Options -> Mechanical Design -> Drafting -> Manipulators tab, and check the Modification box for the Modify overrun and the Modify blanking options.

1. Click the Select icon

, if needed.

2. Drag the overrun manipulator(s) to a new position, as shown below:
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If you want to modify one extension line only, press the Ctrl key and drag the desired manipulator. 3. Drag the blanking manipulator(s) to a new position, as shown below:

4. If you need to be more precise, doubleclick the manipulator. The Blanking Edition dialog box is displayed. 5. Enter the desired value to modify the blanking. You can also modify the overrun/blanking of only one extension line of the dimension. 6. Double-click the overrun manipulator(s).

The Overrun Edition dialog box appears. 7. Enter the desired overrun value and uncheck the Apply to both sides option from the Overrun Edition dialog box.
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Note that you can also right-click the dimension and select the Edit -> Properties option from the displayed contextual menu. The Properties dialog box appears. Select the Extension Line tab and modify the desired value(s) of the Overrun / Blanking Extremities option(s).

Overrun is the overrun minimum value. As an example, for a cumulated dimension (for ISO Standard):

You can increase the overrun size.

You cannot decrease it below the minimum value.

To set Cumulate dimension extension line length and text position, customize the following parameter in the standards: CUMLExtMode in Dimension parameters.

Lining up Dimensions (Reference)
This task will show you how to line up the following dimensions according to a
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Open the LineUp_Dimensions02.CATDrawing document. 1. Select the dimensions to be lined-up. When selecting the dimensions, make sure that they belong to a single, coherent system (if you select dimensions which could form two different systems, you could get unexpected results). 2. Right-click and select Line-up from the contextual menu, or select Tools -> Positioning -> Line-up from the menu bar. 3. Select the element that will be used as reference for positioning dimensions, as show here:

The Line Up dialog box appears. 4. Enter the desired value for the offset to reference. For example, 20 mm. 5. Enter the desired value for the offset between dimensions. For example, 30 mm.
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Two fields are available for both these options: the first field is dedicated to length, distance and angle dimensions and the second field (grayed out in our example) is dedicated to radius and diameter dimensions. Whether a field is active depends on the type of dimension selected. 6. Optionally, select Align stacked dimension values to align all the values of a group of stacked dimensions on the value of the smallest dimension of the group. 7. Optionally, select Align cumulated dimension values to align all the values of a group of cumulated dimensions on the value of the smallest dimension of the group. 8. Make sure the Only organize into systems option is not selected. 9. Click OK to validate. The smallest dimension is positioned with an offset of 20 mm according to the selected element. The offset between each dimension is equal to 30mm.
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Datums
Creating a Datum Feature
This task will show you how to create a datum feature. Open the Brackets_views08.CATDrawing document. 1. Click the Datum Feature icon from the Dimensioning toolbar.

2. Select the point at which you want the datum feature to be attached (attachment point). 3. Select the point at which you want the datum feature to be anchored (anchor point).

The Datum Feature Creation dialog box is displayed with A as default value (incremental value). 4. Change the value, if needed.

5. Click OK. The datum feature is created, and an extension line is automatically created on the datum feature. • • The character string that is edited in the Datum Feature Creation dialog box is simultaneously previewed on the drawing. When you create more than one datum feature, the character string of this datum feature is automatically incremented.
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TXTDatumMode = 1 (Normal)

ANSI

TXTDatumMode = 2 (Flag)

•

Modifying a Datum Feature
This task shows you how to modify a datum feature by editing it. Open the Brackets_views03.CATDrawing document. Create a datum feature with a value of A. 1. Double-click the datum feature you want to modify. The Datum Feature Modification dialog box is displayed. 2. Modify the datum feature value. For example, enter B instead of A.

3. Click OK. The datum feature is modified. 4. Optionally drag the datum feature to move it.
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Note that depending on the type of element to which the datum feature is attached, you may not be able to move the datum feature as wanted. For example, if the datum feature is attached to a dimension line, you will only be able to move the datum feature along the dimension line direction.

Creating a Datum Target
This task will show you how to create a datum target on a right projection view. You can set text properties either before or after you create the datum target. Open the Brackets_views03.CATDrawing document. 1. Click the Datum Target icon from the Annotations toolbar (Text subtoolbar).

2. Select the attachment point of the datum target leader. 3. Select a point to be used to position the datum target (anchor point).

The Datum Target Creation dialog box is displayed. 4. Enter the required values in the fields. For example, 1 and A.
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Click the button if you want to specify that the datum target provides information on the diameter of the selected element. 5. Click OK. The datum target is created.

The character string that is edited in the Datum Target Creation dialog box is simultaneously previewed on the drawing.

Geometrical Tolerances
Creating a Geometrical Tolerance
This task shows you how to create a geometrical tolerance (annotation). You can also copy an existing geometric tolerance. You can set text properties either before or aft create the text. • • • Creating a geometrical tolerance Leader orientation Geometrical tolerance orientation

Creating a Geometrical Tolerance

Open the Brackets_views03.CATDrawing document. 1. Click the Geometric Tolerance icon from the Dimensioning toolbar (Tolerancing sub-too

2. Select an element (geometry, dimension, dimension value, text or point) or click in the free position the anchor point of the geometrical tolerance.
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•

If you select an element, the anchor point will be an arrow. Note that you can modify this symbol by editing the annotation leader.

•

If you select a point in the free space, the anchor point will be a small balloon.

•

If you select a dimension, the anchor point will be at the intersection of the dimension line and the extension line.

•

If you press the Shift key and select the extension line, the leader is perpendicular to the extension line and the anchor point corresponds to the position of the cursor when you click to create the geometrical tolerance.
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•

If you select a dimension value or a text, no leader will be created. The geometric tolerance will be displayed just below and parallel to the element you selected.

3. Move the cursor to position the geometrical tolerance and then click at the chosen location. Geometrical Tolerance dialog box appears.

• •

At this step, you can apply the parameter values of an existing geometric tolerance to the t you are creating: to do this, simply select the existing geometric tolerance. If you have selected the Use style values to create new objects option in Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, the Geometrical Tolerance dialog box filled with custom style values (as defined in the Standards Editor). In this case, Properties and the Tools Palette are disabled during the creation of the geometrical tolerance. On the other hand, if you have not selected this option, the Geometrical Tolerance dialog bo
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•

filled with the last entered values (if any). In this case, Properties toolbars and the Tools Pa active during the creation of the geometrical tolerance. You can reset the current style values in the Geometrical Tolerance dialog box at any time u Reset button.

4. Select the Filter Symbol option to filter the available tolerance symbols according to the typ geometrical element you selected (if any). If you did not select any geometrical element, the tolerance symbols will not filtered.

5. Specify the tolerance type by clicking the Tolerance Symbol button and selecting the approp symbol. 6. Type the tolerance value in the Tolerance value field, adding symbols as needed. To do this the cursor at the proper location in the field, and click the Insert Symbol button to choose t appropriate symbol. You can add symbols to the tolerance and reference value as well as to the upper and lower text. 7. Type the reference values in the Reference value fields, adding symbols as needed.

8. To add a new geometrical tolerance, click the Next line arrow button and repeat steps 4 to 5

9. Type the upper and lower texts in the appropriate fields. You may also add symbols if you w

The geometric tolerance is updated as you define values for each field. 10. Click OK when you're done. The geometrical tolerance is created.
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11. You can add an all-around symbol to the leader. To do this, select the geometrical tolerance click the yellow manipulator on the arrow and select All Around from the contextual menu.

Specifying Leader Orientation You can orient the geometrical tolerance leader perpendicularly to the element to which it is associ example, if the leader is associated to a dimension, you can position the leader parallel to the dime line and orthogonal to the extension line). For this, you have two different possibilities: •

•

Either go to Tools -> Options -> Mechanical Design -> Drafting -> Annotation and Dress-up check Activate snapping (SHIFT toggles). Then, click the Configure button and select either orientation or Both. To orient directly the geometrical tolerance leader perpendicularly to th associated element, press the Shift key before clicking in the drawing to position the toleran previous scenario, step 3). Or go to Tools -> Options -> Mechanical Design -> Drafting -> Annotation and Dress-up tab check Geometrical tolerance in Annotation Creation. The leader will be oriented perpendicul the geometry by default. In this case, pressing the Shift key will let you orient it differently.

Specifying Geometrical Tolerance Orientation To make the tolerance vertical, hold the ctrl key before clicking in the drawing to position the tolera (previous scenario, step 3).
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Modifying Geometrical Tolerances
This task shows you how to modify a geometrical tolerance. Open the Brackets_views03.CATDrawing document. Create a geometrical tolerance.

1. Double-click the geometrical tolerance you want to modify.

The Geometrical Tolerance dialog box is displayed, with the existing values pre-entered.
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You can reset the current style values in the Geometrical Tolerance dialog box at any time using th button.

2. Modify the values as desired, as explained in Creating a Geometrical Tolerance. 3. Click OK.

4. Click in the free space to validate the geometrical dimension modification.

5. Create a dimension, then create a geometrical tolerance on it.
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6. Click on the extension line and move the dimension. You can see that the geometrical tolerance follows the dimension.

7. Click on the geometrical tolerance and move it. You can see that it has not impact on the position of the dimension.

The behavior is the same if a geometrical tolerance is created on the dimension value. Associativity between the dimension and the geometrical tolerance 1. Create a dimension. 2. Create a geometrical tolerance on it, selecting the dimension line.

3. Move the dimension. You will note that the positioning and the length of the tolerance leader remain constant when mov dimension, whatever the dimension type.
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5. Create a dimension. 6. Create a geometrical tolerance on it, selecting the extension line.

7. Move the dimension. You will note the length of the tolerance leader is recomputed as long as the dimension is moved. This is due to the fact that the ratio between the lengths of the leader's projection and the extensio projection remain constant.

The positioning of the leader is also recomputed so that the distance between the anchor point of t tolerance and the extension line remain constant.

When a tolerance is created on an angle dimension, the positioning and the length of the leader re constant if the dimension is moved.

Copying Geometrical Tolerances
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InteractiveDrafting This task will show you how to copy an existing geometrical tolerance and then edit the content for creating a new one. Open the Brackets_views03.CATDrawing document. Create a geometrical tolerance. 1. Click on the geometrical tolerance you want to copy.

2. Right-click and select Copy from the contextual menu. 3. Select the element to which you want the geometrical tolerance to be associated. 4. Right-click and select Paste from the contextual menu. 5. Move the copied geometrical tolerance to position it as desired. 6. Double-click the copied geometrical tolerance. The Geometrical Tolerance dialog box is displayed, with the existing values pre-entered.

7. Make sure the Filter Tolerance box is selected. This will display only those tolerance symbols generally considered appropriate for the type of geometrical element selected. 212 Unselecting this box displays all symbols, regardless of the selected type

User Tasks of element. 8. Modify the values as desired, as explained in Creating a Geometrical Tolerance. 9. After you are done entering values in a given field, press the Tab key to move to the next field. The geometrical tolerance is updated as you define values for each field. 10. Click OK to confirm your operation and close the dialog box. 11. Click anywhere in the drawing to validate.

Creating Driving Dimensions
This task shows you how to create dimensions that will drive associated constrained geometry. Go to Tools -> Options -> Mechanical Design -> Drafting -> Dimension and select Activate analysis display mode. Then, click the Types and colors button to define the characteristics that will be assigned to constrained geometry. The Types and colors of dimensions dialog box lets you select the color you want to assign to driving dimensions. Select the color shown below, for example.

Click the Dimensions icon from the Dimensioning toolbar and create a dimension on the geometry previously selected. In this example, create a length dimension on a line.

1. Double-click the dimension.

2. Modify the dimension via the displayed Dimension Value dialog box. For example, enter 40 millimeter as the new length. This dimension will now drive the geometry.
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If the Drive geometry option is selected, the double-clicked dimension becomes a constraint and behaves as a dimension constraint. The geometry is updated in order to reflect the new driving dimension. Let's call it driven geometry. In addition, this geometry is assigned the characteristics previously defined in the Types and colors of dimensions dialog box via Tools -> Options. In this particular case, the driving dimension is visualized as follows:

More about driving dimensions
If you create driving dimensions between a geometrical element and a 2D component instance that is constrained, then the 2D component instance becomes fixed because the driving dimension makes it over-constrained. You cannot create driving dimensions in the following cases: • • Between a generated element and an interactive element, horizontal and vertical dimensions are not available. If you double-click on the dimension, the Drive geometry option is deactivated. Between an interactive element and a generated circle center, no type of dimensions is available. If you double-click on the dimension, Drive geometry option is deactivated: To bypass this problem, create a point that is concentric with the center of the circle and create the dimension between this new point and the other element. Between two elements (a generative one and an interactive one) that are not parallel, no type of dimensions is available. If you double-click on the dimension, Drive geometry option is deactivated:

•
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To bypass this problem, create a point that will be coincident with line A and line B at the same time and create the dimension between this new point and the other element. • Between two semicircles (apart from dimensions between the semicircles centers). If you double-click on the dimension, the Drive geometry option is deactivated:

• •

Between two axislines and two centerlines. If you double-click on the dimension, the Drive geometry option is deactivated. Between two 2D component instances. If you double-click on the dimension, the Drive geometry option is deactivated.
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Technological Feature Dimensions
Technological Feature Dimensions
The Interactive Drafting workbench lets you create dimensions for technological features such as electrical harness, or between technological features such as structural plates.

Before you Begin: You should be familiar with basic concepts. Creating Intra-Technological Feature Dimensions: Create dimensions for technological features such as electrical harness. Creating Inter-Technological Feature Dimensions: Create dimensions between technological features such as structural plates.

Before you Begin
There are a few things you should know before you begin creating technological feature dimensions. Technological feature dimensions let you create dimensions for technological features such as electrical harness or structural stiffeners, or between technological features such as structural stiffeners. Technological feature dimensioning relies on the fact that technological features can specify the way they should be dimensioned, which allows you to create only realistic and customized dimensions, based on the know-how of a given discipline. Depending on the type of feature that you will be dimensioning, you need specific product licenses to create technological feature dimensions. For more information on the availability of technological feature dimensioning for a given workbench, refer to the related documentation.

Action/object and Object/action Mode
Technological feature dimensioning is available in action/object mode (i.e. selecting the command first and then the feature to dimension) and in object/action mode (i.e. selecting or multi-selecting the feature(s) to dimension
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and then selecting the command).

Technological Feature Dimensions icons
Several Technological Feature Dimensions icons are available from the Technological Feature Dimensions sub-toolbar. • creates any type of technological Technological Feature Dimensions feature dimension (intra or inter) specified by the feature, depending on the option selected in the Tools palette. create either Multiple Intra Technological Feature Dimensions icon the intra-technological feature dimension type specified by the feature when only one is specified, or the preferential intra-technological feature dimension type specified by the feature when several are specified. Chained Technological Feature Dimensions icon create either the inter-technological feature dimension type specified by the feature when only one is specified, or the preferential inter-technological feature dimension type specified by the feature when several are specified. Length Technological Feature Dimensions Feature Dimensions , Angle Technological

•

•

•

, Radius Technological Feature Dimensions

and Diameter Technological Feature Dimensions create a specific dimension type when the feature specifies several dimension types. Using one of these options is particularly useful when you want to create a dimension type other than the preferential type specified by the feature.

Contextual menu
At any time during the dimension creation, you can right-click a technological feature to display a contextual menu.

This contextual menu is particularly useful when several dimension types can be created for a given feature. This depends on what is specified by the feature. • • Optional choices, available when several dimension types are available for the selected feature or features, let you specify a single dimension type that you want to create, out of all the types available. The All option creates all available dimensions for all selected features.
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• •

The None option creates none of the available dimensions for all selected features. The Show Panel option lets you display the Technological Feature Dimensioning Selection dialog box.

Technological Feature Dimensioning Selection dialog box
The Technological Feature Dimensioning Selection dialog box lets you select precisely the types of dimensions that you want to create for a given feature. This dialog box is particularly useful when several dimension types are available for a given feature (especially when creating inter-feature dimensions). • • From the list area, you can select the types of dimension that you want to create for a given feature or de-select those that you want to delete. You can also use the Create drop-down list. The default option, (Selected), creates the dimension types selected from the list area above. The All option creates all available dimensions for all selected features. The None option deselects all available dimensions for all selected features. The Hide button lets you hide the Technological Feature Dimensioning Selection dialog box.

•

When a feature is checked and grayed out as shown below, it means that not all dimensions available for this feature have been selected.

You can also show or hide the Technological Feature Dimensioning Selection dialog box using the Show Panel icon available in the Tools Palette.

Limitations
You cannot create coordinate, stacked and curvilinear dimensions for technological features.

218

User Tasks

Creating Intra-Technological Feature Dimensions
This task will show you how to create dimensions for technological features such as electrical harness. You need an Electrical Harness Assembly license for the purpose of this scenario as we will be dimensioning Electrical Harness Assembly features. Intratechnological feature dimensioning is also available for other applications such as Structure Functional Design or Ship Structure Detail Design. For more information on the availability of technological feature dimensioning for a given workbench, refer to the related documentation. Refer to Before you Begin for general information about technological feature dimensions. Open the ElectricalAssembly.CATProduct document and make sure it is loaded in the Electrical Harness Assembly workbench (if necessary, select Start -> Equipment & Systems -> Electrical Harness Assembly to launch the workbench). Open the ElectricalAssembly.CATDrawing document. 1. Click the Multiple Intra Technological Feature Dimensions icon from the Dimensioning toolbar, Technological Feature Dimensions sub-toolbar.

You can also click the Technological Feature Dimensions icon and then select the Multiple Intra Technological Feature Dimensions icon from the Tools Palette.

2. Select the feature that you want to dimension. Note that the name of a feature is displayed as a help as you move the cursor over it.
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The dimension is created as specified by the feature. In this specific example, the bundle segment specifies that the dimension should provide its overall length. The dimension creation command remains active.

3. Repeat step 2 for each additional feature that you want to dimension. 4. End the dimension creation by clicking anywhere in the drawing (but not on a technological feature) or by lining-up the dimension. The intrafeature dimensions are created as specified by the feature. You can now handle the dimension(s) just like any other dimension.
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Creating Inter-Technological Feature Dimensions
This task will show you how to create dimensions between technological features such as structural stiffeners. You need a Structure Functional Design or a Ship Structure Detail Design license for the purpose of this scenario as we will be dimensioning Structure features. Intertechnological feature dimensioning may also be available for other applications. For more information on the availability of technological feature dimensioning for a given workbench, refer to the related documentation. Refer to Before you Begin for general information about technological feature dimensions. Open the MemberForDim.CATDrawing document. For your information, this document references the MemberForDim.CATProduct document. You do not need to open this product. 1. Click the Chained Technological Feature Dimensions icon from the Dimensioning toolbar, Technological Feature Dimensions sub-toolbar.

You can also click the Technological Feature Dimensions icon select the Chained Technological Feature Dimensions icon Palette.

and then from the Tools
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2. Select Ref_FunStiffener_002 as the first feature for dimensioning. Note that the name of a feature is displayed as a help as you move the cursor over it. 3. Select Ref_FunStiffener_001 as the second feature.

A preview of the dimension is displayed. The dimension creation command remains active. 4. Right-click to display the contextual menu. 5. Select Angle between supports (true dimension). The next dimension will be created between the previously selected feature (i.e. the second feature you selected) and the next feature you select. 6. Select the third feature.
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You can also right-click to view the various types of dimensions you can create between the features. For the purpose of this scenario, leave Distance between parallel supports (true dimension) selected. 7. Optionally move the dimension to position it as wanted. 8. When done, click in the drawing (but not on a technological feature) to create the dimension. The inter-feature dimensions are created as specified by the feature. You can now handle the dimensions just like any other dimension.

Note that the dimension arrow is automatically oriented according to the direction of material (in this case, the stiffener's molded side), which is the case when dimensioning structural features.
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Constraints
Constraints
The Interactive Drafting workbench lets you create geometrical constraints, which specify explicitly how the geometry should behave. A constraint applies to up to three elements. In the Interactive Drafting workbench, constraints are created either through the constraints creation command or via SmartPick. Note the following points: • when you use SmartPick, you detect geometric constraints dynamically. But SmartPick can simply be used to automatically detect constraints without necessarily creating them. For information on creating constraints using SmartPick, see Creating Constraints via SmartPick in the SmartPick chapter. In the Interactive Drafting workbench, dimensional constraints do not exist as such. It is by creating driving dimensions that you can drive constrained geometry. If you want constraints to be created, make sure the Show Constraints icon , and optionally the Create Detected Constraints icon Tools toolbar, before you start creating constraints. , are active in the

• •

Before you begin: You should be familiar with important concepts. Creating quick constraints: Quickly set geometrical constraints. Create constraints via a dialog box: Set geometrical constraints via a dialog box. Create constraints between 2D and generated elements: Create associative constraints between 2D elements and generated elements (Generative Drafting workbench).

Before you Begin
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What Is a Constraint?
A constraint is a kind of relationship that lets you specify explicitly how the geometry should behave. In other words, if you modify the geometry afterwards via the geometry itself, these relations will be taken into account. In the Interactive Drafting workbench, you can create geometrical constraints. Geometrical constraints set a relationship that forces a limitation between one or more geometrical elements. The various geometrical constraints are the following: • • • • • • • • • • • • support lines and circles alignment parallelism perpendicularity tangency concentricity horizontality verticality fix middle point equidistant point symmetrical

In the Interactive Drafting workbench, dimensional constraints do not exist as such. It is by creating driving dimensions that you can drive constrained geometry. It is impossible to modify the definition of a geometrical element (via the Definition dialog box) in a view which contains inconsistent or over-constrained geometry. In such a case, you first need to solve the inconsistencies or remove the extra constraints, and you will then be able to modify the definition of the geometrical element.

What Does Creating Constraints Mean?
You can create constraints using the Tools toolbar:

• •

Explicitly, via the existing Show Constraints command (detected constraints). Via Autodetection, if you activate the Create Detected Constraints
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command

to automatically create detected constraints.

Creating Quick Constraints
This task shows you how to create geometrical constraints quickly. Create two lines.

Make sure the Show Constraints icon

is active in the Tools toolbar.

For the purpose of this scenario, also make sure that the Create Detected is active in the Tools toolbar: this option creates lasting Constraints icon constraints (if you do not activate this icon, the constraints you create are temporary: the geometry is only temporarily constrained, which means that it can subsequently be moved without being constrained.).

1. Select the geometrical elements to be constrained to each other. For the purpose of our scenario, select the two lines you created.

2. Click the Geometrical Constraint icon toolbar.

from the Geometry Modification
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Based on the elements you selected, the software automatically offers to create a parallelism constraint, as shown at the tip of the cursor.

3. At this time, you can right-click on the drawing, to display a contextual menu offering the other types of constraints available for the selected elements.

For the purpose of the scenario, simply click on the drawing to accept the parallelism constraint. Both lines are now constrained as parallel to each other.

4. Modify the position of one of the lines, by moving one of its end points, for example.

As you can see, the lines are constrained so as to remain parallel to each other, whatever the new position and/or length you assign to one of them.

Even though you set a constraint relation between two elements, constraints are not necessarily visualized. If you cannot visualize constraints even though the Show Constraints option is active in the Tools toolbar, go to Tools ->
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Creating Constraints via a Dialog Box
This task shows you how to set geometrical constraints via a dialog box. Create two lines.

Make sure the Show Constraints icon

is active in the Tools toolbar.

For the purpose of this scenario, also make sure that the Create Detected is active in the Tools toolbar: this option creates lasting Constraints icon constraints (if you do not activate this icon, the constraints you create are temporary: the geometry is only temporarily constrained, which means that it can subsequently be moved without being constrained.).

1. Select the geometrical elements to be constrained to each other. For the purpose of our scenario, select the two lines you created.

2. Click the Constraint with Dialog Box icon Modification toolbar.

from the Geometry

The Constraint Definition dialog box appears. The options corresponding to the
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You can preview the result.

4. At this time, you can still select another option from the dialog box if you decide to apply another type of constraint. For the purpose of the scenario, simply click OK to validate. Both lines are now constrained as parallel to each other. 5. Modify the position of one of the lines, by moving one of its end points, for example.

As you can see, the lines are constrained so as to remain parallel to each other,

229

InteractiveDrafting whatever the new position and/or length you assign to one of them.

•

•

It is impossible to create constraints between 2D and generated elements via the Constraint Definition dialog box. In the Constraint Definition dialog box, you can only create constraints between similar elements. In other words, you can create constraints either between 2D elements, or between generated elements, but not between a mix of these. Even though you set a constraint relation between two elements, constraints are not necessarily visualized. If you cannot visualize option is active in the constraints even though the Show Constraints Tools toolbar, go to Tools -> Options -> Mechanical Design -> Drafting -> Geometry tab and select Display Constraints. (You can also modify the constraint color and/or width.)

Creating Constraints Between 2D and Generated Elements
This task shows you how to create associative constraints between 2D elements and generated elements (Generative Drafting workbench). Open the GenDrafting_part_Broken_View.CATDrawing document. Make sure both the Show Constraints active in the Tools toolbar. and the Create Detected Constraints icons are

It is impossible to create constraints between 2D and generated elements via the Constraint Definition dialog box. In the Constraint Definition dialog box, you can only create constraints between similar elements (either between 2D elements, or between generated elements, but not between a mix of these).

1. Create a line in the opened drawing. 2. Select this line. 3. Click the Geometrical Constraint icon Modification toolbar. from the Geometry

The software offers to create the most logical constraint (if you want to apply this constraint, click in the drawing to validate).
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Select a generated edge from the drawing you have opened.

The software offers to create a parallelism constraint by default. If you want to apply this constraint, click in the drawing, otherwise... 4. ...right-click and select Perpendicularity in the contextual menu.

A constraint is created between the generated element and the 2D element.

You can delete this constraint by right-clicking the created constraint and selecting Delete in the contextual menu.

Annotations
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Annotations
The Interactive Drafting workbench lets you manipulate annotations. Note that in order to be consistent with the way commands have been grouped in toolbars and sub-toolbars, the following tasks are documented in the Manipulating Dimensions chapter: • • Datum Feature Creation and Modification Geometrical Tolerance Creation, Modification and Copy

You can associate an annotation to a 2D or 3D element. Yet, in case the element is deleted, the annotation remains in the drawing even when performing an update.

Before you begin: You should be familiar with basic concepts such as setting the properties of a text (font style, size, justification, etc.), using default values, and specifying the position and/ or orientation of a text. Create a free text: Create a text that either wraps or not, that is assigned an unlimited width text frame, even though this text may reach the frame boundary. Create an associated text: Create a text which you want to be and remain associated to an existing element. Make an existing annotation associative: At any time and once an annotation has been created, you can add a link between an annotation and another element. Create a text with a leader: Create a text with a leader either in the free space or associated with an element. Add a leader to an existing annotation: Add a leader to an annotation that was previously created. Handle annotation leaders: Add or remove breakpoints, extremity or interruptions. Move and position leader breakpoints. Add frames and sub-frames to existing text: Add a frame or a sub-frame to a text that was previously created. Replicate a text and attribute: Replicate text as well as the corresponding text attribute. Copy text graphical properties: Copy the text graphical properties of an annotation or element to other elements. Create a datum target: Create a datum target on a view. Modify a datum target: Modify a datum target by editing it in a dialog box. Create a balloon: Create a balloon using a dialog box. Creating an associative balloon on a generated product view: Create associative balloons on views generated from a product. Modify a balloon: Modify a balloon using a dialog box.
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Create a roughness symbol: Create a roughness using a dialog box. Create a welding symbol: Create a welding symbol using a dialog box. Create a geometry weld: Create a geometry weld symbol. Modify annotation positioning: Assign new positioning to existing annotations. Create/modify a table: Create, edit and modify a table. Find/replace text: Locate and then, if needed, replace strings of characters. Perform an advanced search: Use the advanced search command. Query object links: Query object links in a drawing. Adding attribute links to text: Add one or more attribute links between text that was previously created.

Creating Annotations
Creating a Free Text
This task explains how to create a text, with possible line wrapping. This text is assigned a frame of unlimited width, even though it may reach the frame boundary. You can set the properties of a text (anchor point, font size, justification, etc.) either before or after creating it. You will learn how to perform the following operations: • • Creating a Free Text Specifying Text Orientation

Creating a Free Text

Open the Brackets_views02.CATDrawing document. 1. Click the Text icon from the Annotations toolbar.

2. Click where you want to insert the free text on the drawing. A green frame appears, as well as the Text Editor dialog box. 3. If you want to specify the horizontal boundary of the text, drag the frame to where you want to place the boundary. If you want the horizontal boundary to adjust to your text, proceed with the following step.
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The drawing is automatically updated with the text you are typing in the Text Editor dialog box.

• •

•

You can copy and paste text from another application. Its layout and properties will not be preserved. When copying/pasting an engineering symbol (such as φ Phi for example) in the text editor, note that the symbol is pasted as a plain character. As a result, if the symbol does not exist in the current font, the resulting character in the drawing may be different. You cannot copy complex objects (such as tables) from another application.

5. When you are done typing your text, click OK in the Text Editor dialog box, click anywhere on the drawing, or click any command. You can also click the Select icon : in this case, the text will remain selected so you can change its properties for example. You can now start setting the properties of the text you just created using the Text Properties toolbar. Although you can create a text in a view that is not up-to-date, you cannot associate it to geometry. If you try to do so, a message appears, indicating that the selected or active view is not up-to-date.
Specifying Text Orientation

You can associate the text to an element and make it parallel to it. To do this, you can do the following: • Go to Tools -> Options-> Drafting -> Annotation and Dress-Up tab and check Text in the Annotation Creation area. From then on, any text you create after having selected an element will be automatically associated to this element.

OR • When the above option is not activated, you can specify when you want
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to associate a text to an element. To do so, click the Text icon and then press the shift key while selecting the element you want the text to be associated to. You can then type your text. You can also make the text vertical. To do this, click the Text icon and then press the ctrl key while clicking in the drawing where you want to create your free text.

Creating an Associated Text
This task shows you how to create a text which you want to be associated to an existing element. This text will remain associated with this element. You can set text properties either before or after you create the text. Open the Brackets_views03.CATDrawing document. Create two diameter dimensions, for example. 1. Click the Text icon Annotations toolbar. from the

2. Select the element to which you want to associate a text. Here, we will use a dimension. You can associate the text either to the dimension line or to the extension line by clicking the appropriate element. Click the dimension line as in our example. The green text frame is displayed as well as the Text Editor dialog box. 3. Enter the text to be created in the Text Editor dialog box or directly on the drawing. For example, enter "diameter".
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4. Click in the free space or click the Select icon to end the text creation.

5. If needed, select the dimension and move it to the desired location. The text remains associated to the dimension.

•

Note that the text is associative to the whole selected element. In other words, in the case of a dimension, if you move the dimension text exclusively, the associated text will not move accordingly.

• •

When creating associated texts, pressing the SHIFT key lets you change the orientation of the text as regards the element to which it is associated. You can associate text to the following elements: o Annotations: text, datum feature, datum target, balloon, GD&T, roughness symbol, weld symbols. o Dimensions o 2D elements: point, circle, ellipse, parabola, hyperbola. o Generative edges

Finding And Replacing Text
This task explains first how to locate a string of characters and then how to replace it. Strings can be found and replaced in the following elements: • • • • balloons datum features datum targets dimensions
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Open the IntDrafting_Text_Replace.CATDrawing document.

1. Select the Edit->Find item from the menu bar. The Find dialog box appears. 2. Select any of the optional settings. For example, enter First as the Find what text. 3. Select .

The following message appears in the dialog box: Searching All Current Sheet Views. If you previously selected a given number of sheets or elements in the document, the message will be Searching All Current Elements. The first instance found is red colored.

4. If needed, select search for other instances.

to
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5. Select

.

The Replace dialog box now appears. 6. Enter the text you want to use as replacement text and select again. For example, enter Second as the Replace with text. To replace all instances of the text, select .

You can also match case, find whole words only or re-frame the window. 7. Select .

Note that you can directly access the Replace dialog box by selecting the Edit>Replace item from the menu bar.

Creating a Text With a Leader
This task shows you how to create a text with a leader either in the free space or associated with an element. You can set text properties either before or after you create the text.

• • • •

Creating a Text with a Leader Specifying Leader Orientation Specifying Text Orientation Elements that can be Assigned Text with a Leader

Creating a Text With a Leader

Create a rectangle. Note that leader lines are displayed in either of the following ways based on the standard currently set in defining the sheet.

238

User Tasks

1. Click the Text With Leader icon toolbar).

from the Annotations toolbar (Texts sub-

2. Click the point on the element you want the leader to begin (arrow end). A red frame appears. 3. Click in the free space to define a location for the text.

The Text Editor dialog box is displayed. 4. Enter the text in the Text Editor dialog box or directly on the drawing: "text with a leader", for example.

5. If needed, re-position or modify the text.

239

InteractiveDrafting

6. To end the text creation, click again in free space or select a command icon.

The leader is associated with the element you selected. If you move either the text or the element, the leader stretches to maintain its association with the element. If you change the element that is associated with the leader, both the new element and the text with leader remain associative to each other. 7. Create a circle. 8. Drag the text with leader (using the yellow manipulator at the leader's extremity) to associate it with the circle instead of the rectangle.

Although you can create a text in a view that is not up-to-date, you cannot associate it to geometry. If you try to do so, a message appears, indicating that the selected or active view is not up-to-date. 240

User Tasks Specifying Leader Orientation When creating a text with leader, you can orient the leader perpendicularly to the element to which it is associated. To do this, you have two different possibilities: • Either go to Tools -> Options -> Drafting -> Annotation and Dress-up tab and check Activate snapping (SHIFT toggles). Then, click the Configure button and select either On orientation or Both. To orient directly the leader perpendicularly to the associated element, press the Shift key while clicking on the element to which you want to associate the text with leader (previous scenario, step 3). Or go to Tools -> Options -> Drafting -> Annotation and Dress-Up tab, and check Text in the Annotation Creation area. The text leader will be oriented perpendicularly to the geometry by default. In this case, pressing the Shift key will let you orient it differently.

•

Specifying Text Orientation When creating a text with leader, you can make the text vertical. To do this, hold the Ctrl key while clicking in the drawing to position the text (previous scenario, step 3). • • You can also add a leader to existing text. To learn how to do this, refer to Adding a Leader to Existing Text. You can perform a number of operations on a leader. To learn more, refer to Editing Annotation Leaders.

Elements that can be Assigned Text with a Leader • 2D elements: o lines o points o circles o curves Generative Edges

•

Creating/Modifying a Table
This task shows you how to create and edit a table. In this table, you can add text, insert columns, rows, merges cells, invert lines, invert columns, switch lines and columns, and insert views. You can also split a table, import a table, and insert a view in a table.
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Choose a task: • • • • • creating a table, editing and modifying a table, splitting a table, importing a table, inserting a view in table.

Creating a table

Create a new sheet and a new view. 1. Click the Table icon to launch the command.

2. Click a point in the drawing to choose the table position. The table cannot be associative, do not select an element in the drawing to make the table associative. 3. The following panel allows you to set the number of columns and rows you want for the table.

• •

The line height corresponds to the height of a string. The line width corresponds to 5 times a string height.

4. Click ok to validate the creation.
Editing and modifying a table

5. Click on the table to select it and drag it to another position. 6. Double-click the table to edit it:
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• •

To select a column, click just above the column when the symbol appears. To select a line, click on the left of the row .

•

To leave edition, click outside the table.

When the table is in edition mode, you cannot move it anymore. 7. Right-click on the corner of the frame around the table to access the general contextual menu.

This contextual menu allows you to: • • • • • invert columns, invert rows, turn rows into columns and columns into rows, fit the text in the cells by automatically defining the optimal cell size, extend the table by adding columns and/or rows to it.
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8. Choose Invert rows in the contextual menu. Rows are inverted, i.e., the last row becomes the first one, the first row becomes the last one, etc.

9. Choose Invert Columns in the contextual menu. Columns are inverted.

10. Select Invert Columns / Rows in the contextual menu. Rows and Columns are inverted:

11. Select a column and right-click to get the contextual menu, it allows you to: • • 244 Insert a column, Delete a column,

User Tasks • • Clear the content of a column, Modify the size of a column: o either set a new column size, o or autofit the size, i.e. fit the text in the cells by automatically defining the optimal cell size.

The same functionalities are available for rows. The size of a column or a row depends on the insertion point in the table: • • if you insert a column/ row in the middle of a table, the size is the same as the preceding column/ row, if you insert a column/ row at the beginning of the table, the size is the same as the first column/ row.

The text properties are different depending on the point of insertion in the table: • • when you add a column/ row in the middle of a table, the text properties are the same as the preceding column/ row, when you insert a column/ row at the beginning of the table, the text properties are the same as the current text style.

12. Select two cells and right-click them, then choose Merge in the contextual menu. 13. Then select the new cell formed by the two cells you have merged and choose Unmerge to split them in two cells again. 14. Double-click on the text of a cell. The Text Editor appears: modify the text and click OK to validate. 15. To choose vertical and horizontal text alignment, use the Anchor point tool . Align the text of a cell on the right using .

16. Right-click a cell, and select Properties from the contextual menu. The properties available are the same as those available for texts. 17. On the Font tab, specify a color, red for example, and click OK. The text in the selected cell is now red.
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When editing cell properties, note that a number of properties do not apply to the selected cell, but to the table and all its cells. • On the Text tab: o X and Y position o (Orientation) Reference o Orientation o Blank Background On the Graphic tab (Lines and Curves section): o Color o Linetype o Thickness

•

Splitting a table

Open the Split_tables.CATDrawing document. It contains a table that you will split into several tables.

1. Right-click the table and choose Split Table from the contextual menu. The Table Split dialog box appears.
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It contains the following options: • • • • • • Max. number of rows: if you want to split the table so that each new table contains a maximum number of rows, select this option and enter the wanted number of rows in the associated field. Max. height: if you want to split the table so that each new table has a maximum height, select this option and enter the wanted height in the associated field. Vertical: check this option to create the new tables one below the other. Horizontal: check this option to position the new tables one next to the other. Distance: indicate the distance you want between each new table. Duplicate first row: check this option if you want to duplicate the first row in each new table.

2. Select Max. number of rows, and enter 5 in the corresponding field. 3. Select Vertical. 4. In the Distance field, type 5 mm. 5. Select Duplicate first line. 6. Click OK. The table is split into several tables, according to the criteria you specified.
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Importing a table

You can import a table (only .csv). 1. Click the Import Table icon and select the table you want to import.

Inserting a view a in table

Open the GenDrafting_part.CATDrawing file. Create a table in the front views.
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1. Double-click on the table to edit it and right-click in the cell you want to fill. Select Insert Object.

2. Choose the view you want to insert by clicking the view in the drawing or in the tree. Choose the Top view:

The top view is inserted in the table, and it is resized so as to fit the cell. You can resize the cell if you want to enlarge the view in the table.
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• • •

You cannot select the view containing the table, The view must be in the same drawing. If you modify the 3D part and update the drawing, the view in the table will be updated as well.

Modifying Annotations
Making an Existing Annotation Associative
This task explains how, at any time and once an annotation has been created, you can add a link between an annotation and another element. You can add two different types of links: • • positional links orientation links

The elements that can be linked to annotations are listed below: • Annotations o text o datum feature o datum target o balloon o geometrical tolerance o roughness symbols o weld symbols Dimensions 2D elements o points o circles o ellipse o parabola o hyperbola

• •

And, in a Generative Drafting context:
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•

Generative edges

Positional link

You can create positional links for every type of annotation. Open the Brackets_views03.CATDrawing document. Create a text. 1. Click the Select icon .

2. Right-click any part of the text (text itself, frame or leader). 3. Select Positional Link -> Create from the contextual menu. 4. Select the element to which you want the text's position to be linked. The positional link is created. If you now select the linked element and drag it in the drawing, you can notice that the text follows this element. 5. To remove the positional link, right-click the text again, and select Positional Link -> Delete from the contextual menu.
Orientation link

You can create orientation links for texts, texts with leader and roughness symbols. 6. Right-click the text. 7. Select Orientation Link -> Create from the contextual menu. 8. Select the element to which you want the text's orientation to be linked. The orientation link is created. If you now select the linked element and modify its orientation, you can notice that the text's orientation is modified simultaneously. • • If you create a link between an annotation and a dimension system, remember that the link can only be made on a single dimension of the system. In a Generative Drafting context, certain types of generated elements (such as Pipe elements) are not associative. For this reason, positional links or orientation links between an annotation and such elements are not taken into account.

Adding a Leader to an Existing Annotation
This task shows you how to add a leader to an annotation that was previously created. Leaders can be positioned freely, or using snapping (the leader is oriented perpendicular to the reference element). For the purpose of this scenario, you will learn how to add a leader to an existing text, but this functionality is available with other annotation types as
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Go to Tools -> Options-> Mechanical Design -> Drafting -> Annotation and Dress-Up tab . Make sure the Activate snapping (Shift toggles) option is selected. Then, click on the Configure button and select either On orientation or Both. Create a hexagon. Create an annotation, a free text for example.

1. Right-click the annotation to which you want to add a leader.

2. Select the Add Leader command that appears in the contextual menu.

3. You have two possibilities:

•

If you want to position the leader freely: Click where you want to position the leader head. The leader is created. You can then move it to the desired location using the mouse. You can position the leader breakpoint anywhere on the reference element, and snapping is not used.
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User Tasks • If you want the leader to be oriented perpendicular to the reference element: Press the Shift key while clicking where you want to position the leader head. The leader is created: it is snapped, and oriented perpendicular to the element to which it is attached. Release the Shift key and the mouse.

To create as many leaders as required for an existing text, go to Tools -> Customize and create the Add Leader command in a separate toolbar. You will then be able to double-click the Add Leader command and click to locate the leader(s) to be created.

If several text elements are selected as you activate the Add Leader command, the selection is cleared. Make sure you select one annotation only. If you modify the text associated with the leader, associativity between the text and the leader is kept.

Handling Annotation Leaders
This task shows you how to do the following: • handle annotation leaders, by performing such operations as adding or
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•

Depending on the type of annotation the leader is associated with, not all operations described in this section will be available. Multi-selection restrictions: • For all operations described in the Handling Leaders section below (except for changing the symbol shape - see next comment), multiselection is not taken into account. The operation will be performed only on the leader you right-click in the selection. Changing the symbol shape behaves differently depending on whether one or several annotations in the selection have more than one leader: o if the leader you right-click is the only one in the annotation, then the symbol is applied to this leader and to all annotations which have only one leader. o if the leader you right-click is not the only one in the annotation, then the symbol is applied to this leader only.

•

About associative and non-associative annotations: When you create an annotation, a type of leader is automatically set, provided the standard files have not been modified. If you choose the Automatic option, a default symbol will be used, depending on the standard type, on the annotation type, and on whether the leader is associated to an element or not: • • If the o o If the o o leader is associated to an element: Unfilled arrow for ANSI / ASME Open arrow for ISO / JIS leader is not associated to an element: Unfilled circle for ANSI / ASME Filled circle for ISO / JIS

Handling Leaders

Create a text with a leader.

1. Right-click the yellow control point at the end of the leader. The leader's contextual menu is displayed.
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2. Choose from the available options. • To add a breakpoint, select Add a Breakpoint. Then, to remove this breakpoint, right-click on the breakpoint and select Remove a Breakpoint.

•

To add an extremity to an existing breakpoint, right-click on the breakpoint, select Add an extremity, and then click where you want to position the extremity.

Then, to remove this extremity, right-click on the additional extremity and select Remove Leader/Extremity.

You can add an extremity only in the case of

Clicking on the main leader extremity will remove
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•

To add an interruption, select Add an Interruption and then, on the leader, click the two points between which you want to add the interruption.

Then, to remove this interruption, right-click on the leader yellow control point and select Remove Interruptions.

Any existing interruption will be removed from the leader if you subsequently add or remove a breakpoint.

•

To remove the leader, select Remove Leader/Extremity.

•

To add an all around symbol, select All Around.

•

To modify the leader symbol shape, point to Symbol Shape. Then, select No Symbol if you do not want a symbol for the leader, or select the symbol you want from the available symbols.

256

User Tasks

You can remove the leader extremity symbol for all annotations.

3. You can also move the leader or any existing breakpoints by clicking a yellow control point and moving it using the mouse.

•

To move the annotation but not the leader, click the annotation and move it using the mouse.
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•

To move the leader along with the annotation while making sure the leader keeps its original shape, select Rigid and then move the annotation.

• •

This functionality is available for texts, welding symbols, 2D components, tables and geometrical tolerances, but not for other annotation types. This functionality also applies when rotating the annotation text using the Free Rotation icon .

Moving and Positioning Leader Breakpoints

You can move and position leaders breakpoints easily, for all types of annotations. Leader breakpoints are moved and positioned using snapping (the leader is oriented perpendicular to the reference element).
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User Tasks Go to Tools -> Options-> Drafting -> Mechanical Design -> Annotation and Dressup tab. Make sure the Activate snapping (Shift toggles) option is selected. Then, click on the Configure button and, in the dialog box which is displayed, select either Leader orientation or Both. Open the Move_Leaders.CATDrawing document. This document contains a text with leader and a balloon. Add a breakpoint to both annotations, as explained in the previous section.

1. Move the text leader breakpoint with the mouse. You can position the leader breakpoint anywhere, and snapping is not used.

2. Now, press the Shift key while moving the leader breakpoint with the mouse. The leader is snapped, and is positioned vertically or horizontally, or perpendicular to the element to which it is attached.

3. Release the Shift key and the mouse when you are satisfied with the position
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5. Now, press the Shift key while moving the leader breakpoint with the mouse. The leader is snapped, and is positioned vertically or horizontally, which happens to be the same orientation as the element to which the leader is attached.

6. Release the Shift key and the mouse when you are satisfied with the position of the leader. Both leaders are now positioned properly.
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Adding Frames or Sub-Frames
This function allows you to add frames and sub-frames to texts and texts with leader.

Create a free text.

1. Select the text you have created and click the Frame icon Text Properties toolbar. The Frames sub-menu is displayed.

in the

You can choose to create each frame with either a variable or a fixed size. For a rectangular frame, for example, the icon frame, and the icon represents the variable-size

(with the padlock) represents the fixed-size frame.

•

Variable-size frames adapt to the text length, whereas fixed-size frames always remain as is, no matter what the text length is. So if you choose a fixed-size frame and the length of you text exceeds the frame size, then the text will extend beyond the frame.

•

Fixed frame sizes are defined in the standards.
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2. Choose a frame in the menu, scored circle, for example, and click to select it.

3. Right-click on the text and in the contextual menu choose the Add leader command and click in the free space to end the leader creation.

You can zoom to make it easier to move the leader round the text. 4. Right-click the hanged point. A contextual menu is displayed, in which Standard Behavior is selected by default. Selecting or deselecting this option drives how many anchor points are available when moving the leader around the frame (refer to the Frames Anchors Table below, Standard Behavior OFF or Standard Behavior ON columns).

Frames Anchors Table Type of frame Rectangle Scored 262 1 2 o-------o-----Standard Behavior OFF Standard Behavior ON
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3 o-------o------o /

-o /

1 o o 2

Square

4 o 5

o / o-------o------

/ o-------o------o Circle Scored Circle Set Fixed Support Sym Part __o__ 2 o | 1 o Sym Set | 8 o o 4 | o 5 | o 6 3

-o

__o__

/ | 1 o | | o 2 |

/ --o---o-7 Diamond
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3 o-------o------o / | 4 o o 5

-o / | 1 o o 2

| o-------o------

| o-------o------o 6 8 Both Flag Oblong 3 o-------o------o / 1 2 7
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o-------o------o /
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1 o---------o
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3 5

4 o-------o------

o-------o------ -o -o / / / o 2 o 6 / o-------o-------o 1 8 7 / o / o-------o-------o 1 2 / o /

5. Drag the leader hanged point and see how it behaves depending on whether Standard Behavior is selected or not. 6. Select a part of the text, as an example "Te", for this: o o Double-click on the text to edit it, the Text Editor appears. Select "Te" in the Text Editor or in the drawing.

7. Apply the Both Flag frame to the text.

You cannot use the following types of frames as sub-frames: Sticking, Nota, Scored Rectangle, and all types of fixed-size frames.

The size of frames depends on: • • • whether you use them as frames or sub-frames, the height between the characters top and bottom or cap and base, margins.

Thus, a frame or a sub-frame might look different although the text to which it is applied is identical.
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Example of frame.

Example of sub-frame.

Modifying Annotation Positioning
This task will show you how to assign new positioning to existing annotations. You can also modify the position of the views using the same dialog. Open the IntDrafting_Annotations_Positioning.CATDrawing document. 1. Multi-select the annotations to be newly positioned. In this example, multi-select text. 2. Select the Tools -> Positioning -> Element Positioning command from the menu bar. The Positioning dialog box appears:

3. Select the Align to top option

.
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Align to the left The reference text is the text, among the selected texts, that is positioned the most at the left. The text anchor point is moved to the left (for example, from the bottom center to the bottom left). The texts are aligned vertically relatively to the reference text origin point (same x abscissa as for the reference text).

Align to the center The reference text is positioned at the middle of both left and right extremity points. The text anchor point is moved to the center (for example, from the top left to the top center). The texts are aligned vertically relatively to the reference text origin point (same x abscissa as for the reference text).

Align to the right

The reference text is the text, among the selected texts, that is positioned the most at the right. The text anchor point is moved to the right (for example, from the middle center to the middle right). The texts are aligned vertically relatively to the reference text origin point (same x abscissa as for the reference text).
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Align to the top

The reference text is the text, among the selected texts, that is positioned the most at the top. The text anchor point is moved to the top (for example, from the bottom left to the top left). The texts are aligned horizontally relatively to the reference text origin point (same y coordinate as for the reference text).

Align to the middle

The reference text is positioned at the middle of both top and bottom extremity points. The selected texts are assigned the middle attribute as text origin (for example, from the top left to the middle left). The texts are aligned horizontally relatively to the reference text origin point (same y coordinate as for the reference text).

Align to the bottom The reference text is the text, among the selected texts, that is positioned the most at the bottom. The text anchor point is moved to the bottom (for example, from the top left to the bottom left). The texts are aligned horizontally relatively to the reference text origin point (same y coordinate as for the reference text).

4. Select the Space from left to right option

and set the Space value to 30mm.
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Note that when you select a Space option, the modification does not appear similarly on the drawing. This modification only appears when you enter the new Space value in the Positioning dialog box or when you select a Space value.

5. Select the Distribute horizontally option

.

6. Select the Move vertically to top option

and set the Move value to -10mm.
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Note that when you select a Move option, the modification does not appear similarly on the drawing. This is only the case once you enter the new Move value in the Positioning dialog box or when you select a spacing option.

Editing Annotation Font Properties
This task explains how to access and edit annotation font properties. Open the Brackets_views03.CATDrawing document. Create a free text, for example. 1. Double-click the text to switch it to edit mode. 2. Select the whole text (you can also select only part of the text) and then select Edit -> Properties. You can also right-click the selected text and then choose Properties from the contextual menu. 3. In the Properties dialog box that appears, click the Font tab. The associated panel is displayed.

271

InteractiveDrafting

• •

Font, Style, Size, Underline and Color: choose the font, size, style and color of the text, and underline it. Attributes: draw a line through (Strikethrough) or above (Overline) the selected text, and make it superscript or subscript.

You can either underline or overline a text, but you cannot do both. When you are using a font stroke for annotations, the character's thickness is set to 1 for regular style and 3 for bold style. You can customize standard files in order to remove this parameter from the thickness' combo box so that it cannot be applied to annotations' characters.

•

Character: o Ratio: modify character width. o Slant: modify character slant (for italic text, slant=15 deg). o Spacing: change the spacing between characters. o Pitch: set a fixed or a variable pitch. As an example, create the free text "Tools" and apply the font ROM1.

Fixed Pitch

Variable Pitch
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• The Slant and Pitch options are available only for stroke fonts. The pitch of some stroke fonts cannot be modified. In that case, the Pitch combo list is disabled. In case you use characters in some fonts that have no or very little spacing (i.e. i or l), you should not set the spacing to 0 mm, otherwise they would look as if they are superimposed and only one character would seem to be displayed in your annotation. Clicking the More button displays extra options, if any are available. 4. Modify the available options as required. 5. Click OK to validate and exit the dialog box. For more information on font properties, refer to the Infrastructure User's Guide.
Changing Character Ratio and Spacing

In this task, you will learn how to change the character ratio and spacing of a portion of text, but it is also possible to change these for a whole text. Create a free text. 1. Double-click the text to switch it to edit mode. 2. Select a portion of text and right-click it.

3. Click Properties in the menu that appears. The Properties dialog box appears. 4. Click the Font tab. 5. In the Character area, increase or decrease the value in the Ratio field to change the character ratio.

6. Modify the value in the Spacing field to change the character spacing. 7. Click OK to validate your changes. The text is updated.
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Making Text Superscript or Subscript

In this task, you will learn how to make a text superscript, how to make a text subscript, and how to specify their position. Create a free text. 1. Double-click the text to switch it to edit mode. 2. Type a text, "subscript" for example, after the text you created previously.

3. Select the piece of text you just typed and right-click it.

4. Click Properties in the menu that appears. The Properties dialog box appears. 5. Click the Font tab. 6. In the Attributes area, select the Subscript check box.

7. Click OK to validate your changes. The selected text is made subscript. 8. Now type another text, "superscript" for example, after the existing text. For the moment, the new text takes on the properties of the subscript text in front of it. 9. Select the piece of text you just typed and right-click it.
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10. Repeat steps 4 and 5. 11. In the Attributes area, select the Superscript check box (instead of Subscript) and click OK. The selected text is made superscript.

12. For the purpose of this exercise, you will now align the subscript and superscript texts and set their offset and size. To do this, select the whole text and right-click it. The offset defines the vertical position of the superscript or subscript text from the baseline of the text. The size defines the height of the superscript or subscript text. Both values are expressed as a percentage of the font size. 13. Click Properties in the menu that appears. 14. In the Properties dialog box, click the Text tab. 15. In the Options area, select the Back Field check box to align the texts. 16. Increase or decrease the values for the superscript and subscript texts in the Offset and Size fields to set the offset and size. 17. Click OK to validate. The subscript and superscript texts are now aligned and set as defined.

This functionality does not always work when the text is wrapped.

Copying Annotations/Properties
Replicating Text and Attribute
This task shows you how to replicate text as well as the corresponding text attribute. Open the GenDrafting_part_02.CATPart document. Open the GenDrafting_part_03.CATDrawing document.

1. Click the hole to be assigned text on the part. For example, on GenDrafting_part_02.CATPart, select Hole.1.
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3. Select the text to be replicated. The new replicated text automatically appears under the cursor. 4. Click where you want the new text to be positioned. The hole diameter automatically corresponds to the diameter of Hole1 you selected on the part.
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Copying Graphic Properties
This task shows you how to copy the graphic properties of a text element to existing texts. This is true for any type of Interactive Drafting element. In this task, we will take free text as an example. Create free texts. 1. Multi-select the free texts to be modified graphically speaking.

2. Click the Copy Object Format icon

from the Graphic Properties toolbar.
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3. Select the text to be used as a graphical reference for selected texts.

The graphical properties assigned to the text used as a reference are now copied onto the multi-selected free texts to be modified.

Datums
Creating a Datum Target
This task will show you how to create a datum target on a right projection view. You can set text properties either before or after you create the datum target. Open the Brackets_views03.CATDrawing document. 1. Click the Datum Target icon from the Annotations toolbar (Text subtoolbar).
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2. Select the attachment point of the datum target leader. 3. Select a point to be used to position the datum target (anchor point).

The Datum Target Creation dialog box is displayed. 4. Enter the required values in the fields. For example, 1 and A.

Click the button if you want to specify that the datum target provides information on the diameter of the selected element. 5. Click OK. The datum target is created.

The character string that is edited in the Datum Target Creation dialog box is simultaneously previewed on the drawing.

Modifying a Datum Target
This task shows you how to modify a datum target by editing it. Open the Brackets_views03.CATDrawing document. Create a datum target.
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1. Double-click the datum target you want to modify.

The Datum Target Modification dialog box is displayed. 2. Modify any of the datum target values. For example, enter B instead of A. 3. Click OK.

The datum target is modified.

Balloons
Creating a Balloon
This task will show you how to create a balloon. You can set text properties either before or after you create the text. Open the Brackets_views03.CATDrawing document. 1. Click the Balloon icon toolbar). from the Annotations toolbar (Text sub-

2. Select an element. For example, select the bottom line of the rectangle.
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3. Click to define the balloon anchor point.

The Balloon Creation dialog box appears, with the value 1 pre-entered in the field. 4. You can enter another string or value as needed. For the purpose of this exercise, leave the pre-entered value as is.

5. Click OK.

•

The value that is edited in the Balloon Creation dialog box is simultaneously previewed on the drawing. When you create more than one balloon, the value of this balloon is automatically incremented.

•
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Modifying a Balloon
This task shows you how to modify a balloon. Open the Brackets_views03.CATDrawing document. Create a balloon.

1. Right-click the balloon you want to modify.

2. From the contextual menu, select Properties. 3. In the Properties dialog box, click the Text tab.

4. You will now define the balloon frame properties from the Frame drop-down list. By default, balloons are assigned a variable-size circle the balloon text length. You have other options: • • which adapts to

You can display the balloon without a frame by selecting the None icon . You can assign a fixed-size frame to the balloon by selecting the fixedsize Circle icon .

For more information about fixed-sized frames, refer to Adding frames or subframes. For the purpose of this exercise, select the fixed-size Circle icon .
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5. Click OK to validate and close the Properties dialog box. The balloon size is modified.

6. Now, double-click the balloon. The Balloon Modification dialog box is displayed. The Autofit option is active when the size of the balloon frame is fixed.

7. Modify the balloon value. 8. Select the Autofit option to adapt the size of the text to that of the balloon frame.

9. Click OK. The text is enlarged to fit within the balloon frame.

In the case of large texts, the Autofit option reduces the text size. 10. You can also modify the anchor point and thereby the position of the
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Creating Associative Balloons on Generated Product Views
This task will show you how to create associative balloons on views generated from a product. Open the Product_Balloon.CATProduct document. On this CATProduct document, Product Structure subproducts have already been assigned numbers (Generate Numbering icon). For more details, see the Product Structure User's Guide.

1. Go to the Generative Drafting workbench by opening Product_Balloon.CATDrawing document.

2. Click the Balloon icon from the Annotations toolbar (Texts sub-toolbar).

3. Go over one of the part with your cursor. All the edges on all the views extracted from the part are highlighted.
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4. Create a balloon by selecting an edge. The number of the balloon corresponds to the number of the sub-product created in the product which the views were generated from. In this particular example, even though the balloon you are creating is the first one, it is assigned number four as it is applied to sub-product number four.

Note that if you modify the numbering in the product and then regenerate the product, the balloon modification will be applied to the generated views only after you perform a view update.

Roughness and Welds
Creating a Roughness Symbol
This task will show you how to create a roughness symbol. Open the Roughness.CATDrawing document. 1. Click the Roughness Symbol icon from the Annotations toolbar.

2. Select the attachment point of the roughness symbol. The roughness symbol position and orientation will be associative to this point.
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The Roughness Symbol dialog box is displayed. The fields available in the Roughness Symbol dialog box depend on the standard used by the drawing, as defined by the administrator.
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Symbols Definition Surface texture Surface texture and all surfaces around Basic All surfaces around Lay approximately parallel to the line representing the surface Lay approximately perpendicular to the line representing the surface
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Lay angular in both directions Lay multidirectional. Lay approximately circular Lay approximately radial Lay particulate, non-directional, or protuberant Basic surface texture

Material removal by machining is required

Material removal by machining is prohibited.

3. Enter the required values in the various field(s). 4. Click OK. The roughness symbol is created.

5. If needed, modify the roughness symbol position by dragging it to the required location. Note that an extension line may be displayed between the roughness symbol and the element to which it is attached (providing this element is linear), depending on where you drag the roughness symbol.
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• • •

• • • •

By default, there is a 1 millimeter space between the geometry and the extension line, as well as a 1 millimeter space between the end of the extension line and the roughness symbol. Those spaces cannot be customized. The roughness symbol default parameters are 1 for thickness and solid for line type. They cannot be customized. If you have selected the Use style values to create new objects option in Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, the Roughness Symbol dialog box is pre-filled with custom style values (as defined in the Standards Editor). In this case, Properties toolbars and the Tools Palette are disabled during the creation of the roughness symbol. On the other hand, if you have not selected this option, the Roughness Symbol dialog box is pre-filled with the last entered values (if any). In this case, Properties toolbars and the Tools Palette are active during the creation of the of the roughness symbol. If you have selected the Use style values to create new objects option, you can reset the current style values in the Roughness Symbol Editor dialog box at any time using the Reset button. At any time, you can modify the roughness symbol. For this, double-click the roughness symbol to be modified and enter the desired modifications in the displayed Roughness Symbol dialog box. By default, the roughness symbol's orientation is determined according to the orientation of the line it is associated with. You can modify this orientation using the Invert button available in the Roughness Symbol dialog box. When this is not already the case, you can link roughness symbol position and orientation to another element, see Making an Existing Annotation Associative.

Creating a Welding Symbol
This task will show you how to create a welding symbol. You can set text properties either before or after you create the text. Welding symbols Square butt weld Singe V butt weld Single bevel butt weld Flare V butt weld Flare bevel butt weld Single U butt weld Single J butt weld Fillet weld Spot weld
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Back weld Steep-flanked single-bevel butt weld Steep-flanked single-V weld Plug weld Removable backing strip used Permanent backing strip used Surfacing weld V flare weld Spot weld Complementary symbols Weld with flat face Weld with convex face Weld with concave face Flush finished weld Fillet weld with smooth blended face Finish symbols C finish symbol F finish symbol G finish symbol H finish symbol M finish symbol R finish symbol Complementary indications

Field weld Weld-all-around Weld text side (up or down) Indent line side (up or down) Weld tail
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Reference Open the Brackets_views03.CATDrawing document. 1. Click the Welding Symbol icon from the Annotations toolbar (Symbols sub-toolbar).

2. Select an element or click in the free space to position the anchor point of the welding symbol, and then click to validate. The welding leader will appear. 3. Move the cursor to position the welding symbol and then click at the chosen location. The Welding creation dialog box is displayed.

4. Type the desired values in the upper and/or lower field(s). 5. Click the symbol buttons to choose the welding symbol, complementary symbols and/or finish symbols. The welding symbols available depend on your standard. 6. If you want to add complementary indications like a field weld or a weld tail, for example, click the appropriate button.
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7. Click OK. The welding symbol is created.

8. If needed, modify the welding symbol position by dragging it to the required location. 9. Double-click on the welding symbol to edit it, and change the weld text side for example by clicking the Up/Down switch button.

•

If you have selected the Use style values to create new objects option in Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, the Welding creation dialog box is pre-filled with custom style values (as defined in the Standards Editor). In this case, Properties toolbars and the Tools Palette are disabled during the creation of the welding symbol. On the other hand, if you have not selected this option, the Welding creation dialog box is pre-filled with the last entered values (if any). In
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User Tasks this case, Properties toolbars and the Tools Palette are active during the creation of the welding symbol. You can reset the current style values in the Welding creation dialog box at any time using the Reset button. You can close the tail (reference) using a rectangle variable-size . For more information about adding frames, refer to Adding frame Frames or Sub-Frames. At any time, you can modify the welding symbol. To do this, double-click the welding symbol to be modified and enter the modifications in the displayed dialog box. You can import a plain text file (.txt) to use as a reference (specification, process or other) by clicking the Import File button.

• •

• •

Creating a Geometry Weld
This task will show you how to create a geometry weld. Open the Brackets_views03.CATDrawing document. 1. Click the Weld icon toolbar). from the Annotations toolbar (Symbols sub-

2. Select a first element. For example, a line. 3. Select a second element. For example, another line. The geometry default weld symbol automatically appears on the drawing.

The Welding Editor dialog box is displayed. 4. If needed, modify the geometry welding symbol. For example, modify the thickness from ten to five millimeters.
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5. If needed, modify the type of the geometry welding symbol by selecting the Change Type option from the Welding Editor dialog box.

6. Click OK.

The geometry welding symbol is created.

• •

The area fill corresponding to the geometry weld cannot be modified. Geometry welds are not associative, which means that moving the view does not move the weld accordingly.

Querying and Replacing
Finding And Replacing Text
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User Tasks This task explains first how to locate a string of characters and then how to replace it. Strings can be found and replaced in the following elements: • • • • • balloons datum features datum targets dimensions texts

Open the IntDrafting_Text_Replace.CATDrawing document.

1. Select the Edit->Find item from the menu bar. The Find dialog box appears. 2. Select any of the optional settings. For example, enter First as the Find what text. 3. Select .

The following message appears in the dialog box: Searching All Current Sheet Views. If you previously selected a given number of sheets or elements in the document, the message will be Searching All Current Elements. The first instance found is red colored.

4. If needed, select search for other instances.

to
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5. Select

.

The Replace dialog box now appears. 6. Enter the text you want to use as replacement text and select again. For example, enter Second as the Replace with text. To replace all instances of the text, select .

You can also match case, find whole words only or re-frame the window. 7. Select .

Note that you can directly access the Replace dialog box by selecting the Edit>Replace item from the menu bar.

Performing an Advanced Search
This task will show you how to use the advanced search command in the Drafting workbench. First, refer to the Infrastructure User's Guide to learn more about advanced search. 1. Select the Edit->Search... command then click the Advanced tab:
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2. Choose Drafting as the workbench. Any element type has the following attributes: • • • Name: indicate the name of the searched element Color: select a color from the color chooser or use the color of an existing element Set: a selection set indicating a numeric value with the corresponding unit of measure.

Some elements have additional types: Type Balloon Datum Feature Datum Target Additional attributes Part name Reference name Reference name Size Dimension Type value Not updateable Fake Driving dimension True Geometrical tolerance value Value to select or to key in name of the searched element name of the searched element name of the searched element size indicated in the searched element type of dimension (angle, diameter, radius, length, etc.) searched dimension value searched Yes/No Yes/No Yes/No Yes/No tolerance value searched

Not associative on 3D Yes/No
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type Text

having attribute links Yes/No text string

3. Select an operating sign in the first combo box. 4. Select (if there is a combo box) or key in the value you are looking for.

Querying Annotation Links
This task explains how to query annotation links in a drawing (this lets you know what object an annotation is linked to) and how to zoom on the linked object. Open the query_link.CATDrawing document. 1. Right-click on the text "Front view Scale: 1:1" and select Query Object Links in the contextual menu.
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The Query Link Panel appears:
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It displays the linked objects name and specifications. In our example, the view name and scale are linked to the front view. 2. Click the Close button to close the Query Link Panel.
Zoom on the linked object

1. Right-click on the text "Note 1: Circle..." and select Query Object Links in the contextual menu. 2. In the Query Link Panel, check Re-frame the window and select the linked object you want to zoom (in this specific case, you can only select Circle.2).

The application zooms on the object to which the text is linked, i.e. the circle. 3. Click the Close button to close the Query Link Panel.

Dress-up Elements
Dress-Up Elements
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Create center lines (no reference): Apply a center line to one or more circles. Create center lines (reference): Apply a center line to one or more circles with respect to a reference (linear or circular). Modify center lines: Modify one or more center lines at one or more ends of this/these center lines. Create threads (no reference): Create a thread without a reference. Create threads (reference): Create a thread with a reference, either circular (circle or point) or linear (line). Create axis lines: Create an axis line by selecting lines. Create axis lines and center lines: Create an axis line by selecting lines. Create an area fill: Create an area fill, i.e. a closed area on which you will then apply graphical dress-up elements called patterns (these can be hatching, dotting or coloring). Patterns can be applied to area fills created from both sketched and generated elements. Create arrows: Create an arrow.

Creating Center Lines (No Reference)
This task will show you how to apply a pair of center lines to a circle or an ellipse. Open the Brackets_views06.CATDrawing document. 1. Click the Center Line icon sub-toolbar). from the Dressup toolbar (Axis and Threads

2. Select a circle. Center lines are automatically applied to the circle
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. 3. Click in the drawing to confirm the creation and select the center lines. 4. Use manipulators to modify center lines size. • You can apply this scenario to an ellipse. • When creating a center line on a generative view, a message will be displayed if the center line cannot be associative to the 3D.

Creating Center Lines (Reference)
This task will show you how to apply a pair of center lines to a circle or an ellipse with respect to a reference (linear or circular). Open the Brackets_views02.CATDrawing document. 1. Click the Center Line with Reference icon from the Dressup toolbar (Axis and Threads sub-toolbar). You can multi-select circles before you enter the command to create center lines for all selected circles. 2. Select the circle to be applied a pair of center lines. 3. Select the reference line. The center line created is associative with the reference line.

You can create a pair of center lines according to a circular reference (a point or a circle): 4. Click the Center Line with Reference icon from the Dressup toolbar
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When creating a center line on a generative view, a message will be displayed if the center line cannot be associative to the 3D. In this case, the center line is neither linked to the 3D nor to 2D drawing elements. For example, a nonassociative center line with a reference line will not be updated when the reference line is moved.

Modifying Center Lines or Axis Lines
This task will show you how to modify a pair of center lines at one or more end(s) of this/these center lines. You can use the same method to modify axis lines. Open the Brackets_views08.CATDrawing document. 1. Click a center line. End points appear.

2. Select any end point and drag to move all the center line extremities to a new position.
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3. Press the Ctrl key while selecting any end point and drag the selected extremity to a new position.

Multi-selection can be performed to modify center lines. You can also modify the center line using the contextual menu (Properties) and displayed Properties dialog box (Graphic tab).

Creating Threads (No Reference)
This task will show you how to create a thread without a reference. In this particular case, you will apply a thread to a hole. Open the Brackets_views06.CATDrawing document. 1. Click the Thread icon sub-toolbar). from the Dress-up toolbar (Axis and Threads

You can also multi-select holes before clicking the Thread icon. Activating this command displays two options in the Tools Palette which is
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2. Select the Thread type option The thread is created.

3. Select the hole (or circle) to which you want to apply the thread.

4. Select an axis line manipulator and drag it along a direction. Thread axis lines are modified symmetrically. If you want to move only one axis line, hold on the Ctrl key while you are dragging the manipulator. If you delete the thread axis line, the external circle is also deleted and vice versa. • The thread that appears on the hole is assigned a standard radius and representation (compliant with the selected standard). • When creating a thread on a generative view, a message will be displayed if the thread cannot be associative to the 3D.

Creating Threads (Reference)
This task shows you how to create a thread with a reference, either circular (circle or point) or linear (line). In this particular case, you will apply a thread to a hole with a line as reference. Open the Brackets_views06.CATDrawing document. 1. Click the Thread with Reference icon (Axis and Threads sub-toolbar). from the Dress-up toolbar
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You can also multi-select holes before clicking the Thread icon. Activating this command displays two options in the Tools Palette which is automatically displayed: • • The Reference Tap type option The Reference Thread type option , which is activated by default. .

2. Select the Reference Thread type option 4. Select a reference line. The thread is created according to this reference.

.

3. Select the hole (or circle) to which you want to apply the thread.

5. Select a manipulator and drag it along a direction. Thread axis lines are modified symmetrically. If you want to move only one axis line, hold on the Ctrl key while you are dragging the manipulator. When creating a thread on a generative view, a message will be displayed if the center line cannot be associative to the 3D. In this case, the thread is neither linked to the 3D nor to 2D drawing elements. For example, a nonassociative thread with a reference line will not be updated when the reference line is moved.

Creating Axis Lines
This task will show you how to create an axis line. Open the Brackets_views07.CATDrawing document.
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1. Click the drawing window, and click the Axis Line icon Dress-up toolbar (Axis and Threads sub-toolbar).

from the

2. Select two lines.

The axis line is created.

• •

If needed, you can select two non-parallel lines that are not co-linear. Both in the case of center lines and axis lines, a default overrun is created. When creating an axis line in a Generative Drafting context, a message will be displayed if the axis line cannot be associative to the 3D. In a Generative Drafting context, you can create axis lines between symbolic fillet edges or fillet representation. Note that these axis lines will not be associative (a message will be displayed). In a Generative Drafting context, depending on the type of element selected, the axis line is sometimes created directly after you select a single element. If you are not satisfied with the axis line thus created, you can force the selection of a second element by pressing the Ctrl key prior to making your selection: you will then be able to select the first and then the second element.

• • •

If you need to modify an axis line, refer to Modifying a center line as the method is similar. Note that multi-selection can be performed when modifying axis lines.
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Creating Axis Lines and Center Lines
This task will show you how to create simultaneously axis and center lines on several circles. Open the Brackets_views02.CATDrawing document. 1. Click the drawing window, and click the Axis Line and Center Line icon from the Dress-up toolbar (Axis and Threads sub-toolbar).

2. Select two circles.

The axes and center lines are created.

3. Select an axis line manipulator and drag it along a direction. You can notice that thread axis lines are modified symmetrically. If you want to move only one axis line, hold on the Ctrl key while you are dragging the manipulator. When creating axes and center lines in a Generative Drafting context, a message will be displayed if axes and center line cannot be associative to the 3D.
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Creating an Area Fill
An area fill is a closed area on which you then apply graphical dress-up element called patterns (these can be hatching, dotting or coloring). You can create area fills on the following elements: • • • sketched elements, generative elements part-sketched, part-generative elements

In this task, you will learn how to create an area fill on a drawing containing a mix of sketched and generative elements. Open the GenDrafting_Area_Fill.CATDrawing document. This drawing is a generative one. Define your area fill profile by creating lines so that your drawing looks like the figure shown here. In this example, sketched elements (the ones you create) are selected (they are shown in red), and generative elements are shown in black. The area fill profile will therefore consist of both sketched and generative elements. You do not need to activate the view in which you are going to create an area fill.

1. In the Graphic Properties toolbar, click the down arrow besides the Pattern

icon.

2. In the Pattern dialog box, select a pattern for your area fill and click OK. 3. Click Insert -> Dress Up -> Area Fill. OR Click the Area Fill icon from the Dress Up toolbar.

309

InteractiveDrafting

The Area Detection dialog box appears.

4. Click the Automatic option (the other option is described in the remarks section below) and then click inside the area for which you just defined the profile, under the line which represents the fillet edge.

The software automatically detects the area to fill based on where you clicked and fills this area with the selected pattern. The Areas to Fill dialog box disappears.

A few remarks
Area to Fill dialog box

The two options available in the Area to Fill dialog box are described below. You can specify the area you want to fill before or after choosing the option in the Area to Fill dialog box. For each option, examples illustrate what kind of area fill you will get depending on where you click. Note where the cursor is located on the figures. • Automatic automatically detects the area to fill based on where you click: just click inside the area you want to fill. You get this area fill:

If you click in this area:
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•

With profile selection lets you specify the area to fill: select all the 2D elements that make up the profile of the area you want to fill, and then click inside this area.

As you select elements on a view, intersection symbols (stars) appear where elements intersect. This enables you to know where the profile is open: in this case, intersection symbols do not appear. As you cannot apply an area fill to an open profile, make sure all elements intersect. If you select these elements: You get this area fill:
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Miscellaneous remarks about applying area fills

• •

• • • • • •

Whichever option you choose in the Areas to Fill dialog box, make sure the profile you select is closed, i.e. that all elements that make up its profile intersect. An error message will appear if you select a profile which is not closed. When you create an area fill on sketched elements, or on part-sketched, partgenerative elements, extra sketched elements are added over the generative elements which make up the profile of the area fill. Also, coincidence constraints are created between the original generative elements and the added sketched elements. On generative drawings, the area fill is not associative with the 3D part. If you modify the original 3D part and then update the generative drawing, the area fill will not be changed. When a view is isolated, any area fill on the view is isolated as well. Consequently, there is no longer any relationship between the area fill and its profile. Select elements carefully: the area will be filled according to the elements you selected. If you apply modifications to the filled area, the pattern will be modified accordingly. In the case of superposed views, the area fill will be created on the active view (provided the active view is one of the superposed views). If you create text in a filled area, the background of the text will be blanked as shown here. For more information about hatching or dotting patterns, refer to the General remarks

•
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What you have before applying the pattern:

What you get if the pattern cannot be displayed:

Creating Arrows
This task will show you how to create an arrow. For the purpose of this exercise, you will use an arrow to illustrate the kind of hole you want to apply to a circle. Open the Brackets_views06.CATDrawing document. 1. Click the Drawing window, and select Insert->Dress Up->Arrow from the menu bar.

2. Click a point or select an object to define the arrow starting point (the tail). For example, select a circle. 3. Click another point or select another object to define the arrow extremity
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The arrow and the selected object are associative. • To modify the position of the arrow, click the arrow and use the yellow manipulators to drag it to its new location.

•

To modify the general appearance of the arrow, either click the arrow and then use the Graphic Properties toolbar, or right-click the arrow and then use the Properties dialog box (select Properties and click the Graphic tab).

4. You will now add a breakpoint to the arrow. Select the arrow and right-click on a yellow manipulator. A contextual menu appears. 5. Select Add a Breakpoint. A breakpoint is added to the arrow; you can drag it to change the arrow path.
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6. You will now choose a symbol for the arrow tail. To do this, right-click on the yellow tail manipulator. 7. In the contextual menu, point to Symbol Shape and select a symbol, Filled Circle for example.

The symbol you choose now appears on the arrow tail. You can also change the symbol used for the arrow head by repeating steps 6 and 7.
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8. You will now create an interruption on the arrow tail. Right-click on the yellow tail manipulator again. 9. In the contextual menu, select Add an Interruption. An interruption is added to the arrow.

• •

You cannot add another extremity to an arrow. Arrow angle and length are defined by standards. For more information, see Dimension Parameters.

SmartPick

SmartPick
316

User Tasks The Interactive Drafting workbench provides SmartPick as a useful and easy-touse tool designed to make all your geometry or constraint creation as simple as possible. Information regarding the use of SmartPick is documented in the Sketcher User's Guide. As such, the information detailed in this section is presented in a Sketcher context. You should note that the Sketcher User's Guide contains images that correspond to the Sketcher workbench and therefore illustrate geometry in an environment that is different from the Interactive Drafting environment (symbols, background color, for example).

Create constraints via SmartPick: Learn how to detect, create and visualize constraints using SmartPick. Use SmartPick: Learn how to be more productive by using SmartPick.

Creating Constraints via SmartPick
This task shows you how to detect, create and visualize constraints. For example, let's create two constrained parallel lines. SmartPick dynamically detects the following geometrical constraints: • • • • • • • • • support lines and circles alignment parallelism perpendicularity tangency concentricity horizontality verticality middle point

Note that when you use SmartPick, you do NOT necessarily create constraints. 1. Click the Create Detected Constraints icon 2. Create a first line. 3. Create a second line. SmartPick can be used to create certain elements on the drawing. More precisely, only the elements which the cursor last went over will be used to apply SmartPick constraints. In other words, you simply need to move the cursor over the element you want to use as reference for a constraint. No element is picked: from the Tools toolbar.
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To detect parallelism constraints, go over the line to be used as reference.

As a result, a parallelism constraint is detected and created.

To visualize detected and created constraints, make sure the Show Constraints command is on, or that the Create detected and feature-based constraints setting is active in Tools -> Options -> Mechanical Design -> Drafting -> Geometry tab.

When a constraint is detected by smartpicking, you can temporarily deactivate this constraint by maintaining the Shift key pressed. When a constraint is detected by smartpicking, you can temporarily lock this constraint by maintaining the Ctrl key pressed.

Properties
Properties
This section discusses how to quickly access and edit information on 2D geometry, dress-up elements, annotations and dimensions in a single dialog box. This dialog box is available via the Edit -> Properties contextual command. The data you can access (tabs) depends on the element you select. Note that clicking the More button gives you access to more tabs. The tasks described in this section are listed below.

Edit sheet properties: Access and edit sheet properties.
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Edit view properties: Access and edit view properties. Edit 2D geometry feature properties: Access and edit information on 2D geometry features (name and stamp). Edit graphic properties: Access and edit graphic properties. Edit pattern properties: Access and edit pattern properties. Edit annotation font properties: Access and edit annotation font properties. Edit text properties: Access and modify text color, position and/or orientation. Editing picture properties: Access and modify picture position, size, scale and compression. Edit dimension text properties: Access and edit dimension text properties. Edit dimension value properties: Access and edit dimension value properties. Edit dimension tolerance properties: Access and edit dimension tolerance properties. Edit dimension extension line properties: Access and edit dimension extension line properties. Edit dimension line properties: Access and edit information on dimension line properties. Editing dimension system properties: Access and edit information on dimension system properties. Edit 2D component instance properties: Access and edit 2D component instance properties.

Editing Sheet Properties
This task explains how to edit sheet properties. Define a new sheet. 1. Right-click the sheet in the specification tree (press F3 to display it). 2. Select Edit -> Properties. 3. Click the Sheet tab. It contains a number of properties: • • • • • General properties Format properties Projection Method Generative Views Positioning Mode Print Area

General properties
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Name Enter a meaningful name for the sheet. Global scale Specify the scale (i.e. the scaling factor) which applies to all views in the sheet. The scale does not determine the position of the views (or any other object) contained in the sheet. When the grid is displayed, the position of the view in the sheet is not determined by the grid, which only deals with what is drawn directly in the sheet. To see the real position of a given view in a sheet, you need to use the ruler. It is the only way to see the real coordinates in a sheet referential.

Format properties

Format This list contains the format names defined by the administrator in the Standards Editor. For more details, see Sheet Format Definition in the Administration Tasks chapter. You may also create your own user-defined formats, defined locally for a given drawing. To create your own format, proceed as follows: 1. Type a name for the format in the Format field. The name of the newly created format must be different from those in the user-defined and in the standard lists of formats. If not, a warning message is displayed to inform you the format name you chose is not valid. 2. Use the tab key to access the Width and Height fields and set their values. Display
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Display the frame representing the format of the sheet. Width Width of the selected format. This field is available for user-defined formats only. Height Height of the selected format. This field is available for user-defined formats only. Orientation Orientation of the selected format. Available only if the selected format allows you to modify the orientation type. For more information, refer to Sheet Format Definition.

Projection Method

Note that properties in this section apply to all generative views available in the sheet (i.e. in a Generative Drafting context). First angle standard Select this option if you want all views in the sheet to be created using the first angle standard. The first angle standard is an orthographic representation comprising the arrangement, around the principal view of an object, of some of all of the other five views of that object. With reference to the principal view, the other views are arranged as follows: - the view from above is placed underneath - the view from below is placed above - the view from the left is placed on the right - the view from the rear is placed on the left or on the right, as convenient. (Ref. No. ISO 10209-2:1993) Third angle standard Select this option if you want all views in the sheet to be created using the third angle standard. The third angle standard is an orthographic representation comprising the
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arrangement, around the principal view of an object, of some of all of the other five views of that object. With reference to the principal view, the other views are arranged as follows: - the view from above is placed above - the view from below is placed underneath - the view from the left is placed on the left - the view from the rear is placed on the left or on the right, as convenient. (Ref. No. ISO 10209-2:1993)

Generative Views Positioning Mode

Note that properties in this section apply to all generative views available in the sheet (i.e. in a Generative Drafting context). The chosen property will be taken into account next time you update the sheet. This property is also defined in the Sheet Styles. Part center of gravity Select this option if you want generative views to be positioned according to the center of gravity of the 3D geometry. This mode ensures that the center of gravity of the 3D geometry remains at a fixed position on the sheet, when views are updated. Part 3D axis Select this option if you want generative views to be positioned according to the 3D axis system. This mode ensures that the projection of the 3D axis remains at a fixed position on the sheet, when views are updated (even if the center of gravity of the 3D geometry has changed).
Example

Take this original view, for example:
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Now, imagine you modify the 3D geometry in such a way that the center of gravity of the 3D changes. You then update the view on the sheet. • If Part center of gravity is selected: the center of gravity of the 3D geometry remains at a fixed position on the sheet after the update.

•

If Part 3D axis is selected: the projection of the 3D axis remains at a fixed position on the sheet after the update.
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Print area

Activate Check this box to specify that only a specific area of the sheet should be printed. Doing this will activate the associated fields so that you can define the print area. Note that on top of checking this box, you must select Document area option as the Print area in the Print dialog box in order for the print area to be printed. If you do not select the Document area option, the whole document will be printed. Refer to Printing Sheets for more information. X Specify the X coordinate of the lower left-hand corner of the print area. Y Specify the Y coordinate of the lower left-hand corner of the print area. Width Specify the width of the print area. Height

324

User Tasks

Specify the height of the print area. Format Select a format if you want to define the print area using the width and height specified for that format. A specific contextual command lets you visualize the print area (providing it is activated), so as to re-position or re-dimension it for example. To do so, either right-click the sheet item in the specification tree and select Sheet.X object -> Visualize Print Area, or activate the sheet and select Edit -> Sheet.X object -> Visualize Print Area. This zooms onto the print area, which is outlined as a purple dashed box, with an X cross at its center. Use the manipulators at the corners of the box to re-dimension the print area. Drag the dashed box or the central X cross to re-position the print area.

You can then exit the print area visualization mode by pressing the Escape key or by clicking elsewhere in the drawing. You can check the sheet properties to make sure that the coordinates, width or height have been updated. 4. Change the sheet properties as wanted, and then click OK to validate.

Editing View Properties
This task explains how to edit view properties. Open the PointSketch.CATDrawing document. 1. Right-click the front view and select Edit -> Properties. 2. Click the View tab. You can notice that a number of options are disabled,

325

InteractiveDrafting as they apply to generative views only. 3. Choose your options. Visualization and behavior

• • •

Display View Frame: shows/hides the view frame, Lock View: locks the view so that it cannot be modified anymore. Visual Clipping: lets you reframe a view so as to display only part of it.

Scale and Orientation

• • •

Angle: defines the angle between the view and the sheet, Scale: defines the scale of the view. =: displays the decimal value with respect to the fraction. This field is read-only.

The view scale and angle are computed according to the view origin (which is visualized thanks to the view axis), not according to a center of gravity. View Name

Allows you to modify the name of the view (or of the 2D component when pertinent), and to enter a prefix, an ID or a suffix. Among other things, you can create a formula for the view name. For more information, refer to the Knowledge Advisor User's Guide. 4. Click OK to validate and exit the Properties dialog box.

Properties available on Generative Views

In the case of generative views (Generative Drafting workbench), a number of additional properties will be available. The properties described below apply to generative views only, and will be active in a Generative Drafting context.
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Dress-up Specifies the dress-up elements that should be displayed in the view: • • • Hidden Lines: generates hidden lines. Center Line: generates center lines. 3D Spec: specifies whether, in an assembly, the properties assigned to given parts (also called components) will be applied in the view. The following 3D specifications may be defined for components in the Product Structure workbench: o o o The component will, or will not, be cut when projected in section views (Do not cut in section views). The component will, or will not, be projected in views (Do not use when projecting). The component will, or will not, be represented with hidden lines (Represented with hidden lines).

For more information, refer to Modifying Component Properties in the Product Structure User's Guide. • • • • 3D Colors: specifies that the colors of a part should be automatically generated onto the views. Axis: generates axis lines. Thread: generates threads. Fillets: generates fillets. You can choose to view Boundaries, Symbolic, Original Edges, Projected Original Edges:

Boundaries Thin lines, representing the mathematical limits of the fillets. Boundaries will not be projected if they correspond to two faces which are continuous in curvature. They will be projected only if they correspond to a smooth edge which is situated between two faces whose curvature radii vary. This mode will be used automatically to represent
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Symbolic Original edges, projected in a direction that is normal to each corresponding surface.

Approximated Original Edges Original edges, at the intersection of the two surfaces joined by the fillet.

Projected Original Edges Original edges, projected on fillet surfaces in the direction of the view projection. This projection mode is equivalent to the CATIA V4 fillet projection mode. The following restrictions apply to Symbolic, Approximated Original Edges and Projected Original Edges: • • Dimensions on such fillets are not associative. Such fillets cannot inherit 3D colors. Likewise, when using generative view styles, such fillets cannot inherit the 3DInheritance view dress-up parameters (defined in Tools -> Standard -> generativeparameters -> *.XML file, Drafting -> ViewDressup -> 3DInheritance). Always have in mind that those fillets representations are only a symbolical preview of the 3D.

•

•

3D Points: projects points from 3D (no construction elements). You can choose from the following options:

3D symbol inheritance: keeps the symbol from the 3D. Symbol: displays the symbol you choose from the drop-down list. • 3D Wireframe: displays both the wireframe and the geometry on generated views. You can choose whether projected 3D wireframe can be
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Note that if you delete generated center lines, threads or axis lines, you will NOT be able to generate them again (by updating the drawing), even if you select the appropriate dress-up options in the Properties dialog box. It is impossible to restore generated center lines, threads or axis lines that have been deleted.

Generation Mode • Only generate parts larger than: specifies that you only want to generate parts which are larger than the size indicated (in millimeters) in the appropriate field. Enable occlusion culling: saves memory when generating exact views from an assembly (or a part or product) which is loaded in Visualization mode (i.e. when the Work with the cache system option is active). This will load only the parts which will be seen in the resulting view (instead of loading all of them, which is the case by default), which optimizes memory consumption and CPU usage. View generation mode: lets you change how the view is generated. For more information on the various view generation modes, refer to View Generation Settings in the Customizing chapter. o Exact view: turns the view into a exact view (the geometry becomes available). o CGR: turns the view into a CGR view (only the external appearance of the component is used and displayed; the geometry is not available). o Approximate: turns the view into an approximate view. Although approximate views are not as high in precision and quality as exact views, this generation mode dramatically reduces memory consumption. Performances may also be improved, depending on how you fine-tune precision (click the Options button). Therefore, the approximate mode is particularly well-adapted to sophisticated products or assemblies involving large amounts of data. o Raster: turns the view into an image view. You can configure a number of options such as the level of detail or the type of image

•

•
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If you select a mix of exact, CGR, approximate and/or raster views, the options will be disabled. To activate these options, make sure you select views which use the same generation mode.

Generative view style

• •

The Generative view style area shows the generative view style which is applied to the view. If you have modified the values of the properties defined in the selected generative view style by editing some dress-up properties, for example, you can use the Reset to style values button to reset these values to the original style values. (To let you know when properties have been changed compared to the original generative style, an asterisk is displayed in front of them.)

The Generative view style properties are only available on generative views, when generative view style functionalities are activated (i.e. when the Prevent generative view style creation option is de-selected in Tools -> Options -> Mechanical Design -> Drafting -> Administration tab).

Editing 2D Geometry Feature Properties
This task shows you how to access and edit information on 2D geometry features (name and stamp). Open the Brackets_views03.CATDrawing document. 1. Select a 2D element on the CATDrawing you opened. 2. Select Edit->Properties and click the Feature Properties tab. You can also right click the 2D element and then select Properties from the displayed contextual menu.
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3. If needed, click the More button. 4. Enter a new name for the element in the field. The information displayed concerns the creation of the elements. 5. Click the Graphic Tab. A number of properties are available. For more information, refer to Editing 2D Element Graphic Properties. 6. Click OK to validate and exit.

Editing Graphic Properties
This task explains how to access and edit graphic properties for elements, such as geometry, annotations, etc. Open the Brackets_views03.CATDrawing document. For the purpose of this scenario, you will be editing the graphic properties of a 2D geometrical element. 1. Select a 2D element on the CATDrawing you opened. 2. Select Edit -> Properties and click the Graphic tab. You can also right click the 2D element and then select Properties from the displayed contextual menu. 3. If needed, click the More button. 4. If needed, modify the available properties. Depending on the element you selected, not all properties will be available.

•

Fill: o

you can color the selected element and set the filling transparency.
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InteractiveDrafting • Edges: o you can define the color, linetype (dotted, dashed, etc.) and thickness that will be used for edges. See Graphic Properties Toolbar. Lines and Curves: o you can define the color, linetype (dotted, dashed, etc.) and thickness that will be used for lines and curves. See Graphic Properties Toolbar. Points: o you can define the color and the symbol that will be used for points. Global Properties: o you can choose if the element will be shown or not (check/uncheck Shown option) o you can activate or deactivate Pickable mode. If you uncheck it, geometry will not be selectable anymore. See Pick/No Pick mode. o you can choose to display the selected element using a lower intensity. o you can choose a layer for the selected geometry.

•

• •

In some cases, changing the color of an element provides unexpected results, as the color of related elements will be changed as well. For example, if you change the color of a table frame, the font color of the table's text will also be changed. In this case, a workaround is to change the font color after having edited the graphic properties. 5. Click OK. For more information on graphic properties, refer to the Infrastructure User's guide.

Pick/No Pick mode
When you create elements using the No Pick mode (Pickable option unchecked), • If you want to make one or several elements pickable back again, perform as follows: 1. Select Edit -> Search from the menu bar and select the element(s) to be modified from the Search dialog box. 2. Select Edit -> Properties from the menu bar and check the Pickable option from the Properties dialog box. • If you want to make all the elements on a sheet or in a view pickable back again, perform as follows: 1. Click the sheet or the view(s) to be applied the Pick mode from the specification tree.
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2. Select Force Pick Mode from the contextual menu.

Graphic Properties Toolbar
You can also modify graphic properties using the Graphic Properties toolbar.

The Graphic Properties toolbar lets you modify the following graphical options: • • • • • • • the line color the line thickness the linetype the symbol to be used for points a layer for the selected geometry copying objects (Copy Object Format icon )

). This option display the Pattern Chooser the pattern (Pattern icon dialog box, from which you can select a pattern.

Care when you assign graphic attributes to a line (for example, make it thick and red). When you turn this red thick line into a construction line (from the contextual menu: Object.Line -> Definition..., Construction line option in the Line Definition dialog box), the line will become a dotted gray line. Even though you then decide to make it a standard line back again (by un-checking the Construction line option), the line will have lost its "red" and "thickness" attributes and will be assigned its original attributes.

Editing Pattern Properties
This task explains how to access and edit pattern properties. Patterns are used for area fills or, in a Generative Drafting context, when cutting through material in section views/cuts or breakout views, for example.

Open the GenDrafting_Edit_Pattern_Properties.CATDrawing document.

1. Select the pattern be modified. For the purpose of our scenario, select the hatching pattern in the Section view.
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2. Select Edit-> Properties. You can also right-click the pattern and then select Properties from the displayed contextual menu. 3. In the Properties dialog box that appears, click the Pattern tab.

4. If you want to define your own pattern, choose a pattern type from the Type drop-down list. The types of patterns available in this list depend on the standard used by the drawing. Or if you want to choose from the various patterns available, click the [...] button. This will display the pattern chooser, from which you can make your selection. 5. Select your options as required. • • 334 The options available in the dialog box depend on the type of pattern you selected, as well as on the standard used by the drawing. When editing the properties of a pattern associated with a part material,

User Tasks the software offers its own selection of patterns, and not the patterns defined in the standard. Hatching • Number of hatchings: Defines the number of different hatchings to use in this pattern. A tab will be created for each hatching, to let you define each one individually. This option is unavailable with the current drawing standard. • Angle: For each hatching this pattern, specifies the angle value in degrees. • Pitch: For each hatching in this pattern, specifies the pitch in millimeters. • Offset: For each hatching in this pattern, specifies the offset in millimeters. • Color: For each hatching in this pattern, specifies the color. This option is unavailable with the current drawing standard. • Linetype: For each hatching in this pattern, specifies the linetype. This option is unavailable with the current drawing standard. • Thickness: For each hatching in this pattern, specifies the linetype thickness. This option is unavailable with the current drawing standard. • Preview: Lets you preview the resulting hatching pattern.

The Color, Linetype and Thickness options can be modified, provided the EditAvailability parameter is set to Yes under the Pattern node in the Standards editor. For more information, refer to Pattern Definition. Dotting • • • • Pitch: Specifies the dotting pitch in millimeters. Color: Specifies the dotting color. Zigzag: Specifies whether dotting should zigzag. Preview: Lets you preview the resulting dotting pattern.

Coloring • Color: Specifies the color. • Preview: Lets you preview the resulting coloring pattern. Image • Browse button: Lets you select the image to use for this pattern. This option is unavailable with the current drawing standard. You can only use the images defined by the administrator. These images are available from the pattern chooser (click the [...] button). • Angle: Specifies the angle value in degrees. • Scale: Specifies the scale. • Preview: Lets you preview the original image (not the result after
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6. Click OK to validate and exit.

Graphic Properties Toolbar

You can also modify pattern properties using the Pattern icon Graphic Properties toolbar.

on the

This option display the Pattern Chooser dialog box, from which you can select a pattern.

Editing Text Properties
This task explains how to access and modify text color, position and/or orientation. You will also learn how to specify the text display mode. Open the Brackets_views02.CATDrawing document. Create an annotation such as a free text, for example. 1. Select the annotation you just created. (For the purpose of this exercise, you select a free text, but you could also select any other type of annotation.) 2. Select Edit-> Properties. You can also right-click on this dimension and then choose Properties from the contextual menu. 3. Click the Text tab. The associated panel is displayed.

336

User Tasks

• •

Frame: you can choose a frame type for the selected text that is to say rectangle, triangle, circle, etc. You can specify the color, line thickness and line type for the frame in the associated fields. Position: o Anchor Point: you can change the text position in relation to the anchor point. o Justification: you can specify a justification for the text: left, center or right. o X, Y: you can modify anchor point coordinates. o Anchor Mode: it allows you to position the anchor line to the character Top and Bottom or to the character Cap or Base.

•

Line Spacing Mode: you can choose the spacing mode between to line of characters. As an example, create the following free text:
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Now, select base to cap option in the combo box. The spacing between the two lines will be between the base of first line characters and cap of second line characters:

• •

Line spacing: you can increase or decrease the spacing between two lines of characters. Word wrap: allows you to wrap the text in a width you specify.

When you create a free text, the anchor point is the point you click in the free space to define a location for the free text. • Orientation: specify a text orientation. o Reference: choose Sheet to use the sheet as the reference for the text orientation, or View / 2D Component to use the view or 2D component as the reference for the text orientation. o Orientation: the text is oriented according to the chosen reference; choose Horizontal to position it horizontally, Vertical to position it vertically or Fixed Angle to position it using a fixed angle. o Angle: if you choose Fixed Angle for Orientation, you can define the orientation angle according to the chosen reference. o Mirroring: specify whether you want to mirror the selected text, and what kind of mirroring, or if the text should flip automatically in such a way that it will always be in a readable position. • Options: o Display Units: in a text containing parameters with units, displays these units. o Apply scale: applies the scale of the view or of the 2D reference component to the display of the text or to the value of a dimension.

If you want to use as symbols 2D components with text, activate both the Apply Scale property and the Create with a constant size setting (in Tools -> Options -> Mechanical Design ->
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User Tasks Drafting -> Annotation and Dress-up tab): the size of both the 2D component and its text will then be independent from the view scale. o o Back Field: aligns superscript and subscript texts above one another. Blank Background: specifies that the text background should be blanked when the text is displayed over a pattern or over a picture. Superscript: increase or decrease the values for the superscript texts. The Offset parameter specifies the distance of the superscript text from the base line according to the font size of the text. The Size parameter specifies the size of the superscript text according to the font size of the text. Subscript: increase or decrease the values for the subscript texts. The Offset parameter specifies the distance of the subscript text from the base line according to the font size of the text. The Size parameter specifies the size of the subscript text according to the font size of the text. Display: specifies a display mode for the text: Show Value, Show Box or Hide Value. Refer to Specifying the Text Display Mode below for more details.

o

o

o

4. Modify the available options as required. 5. Click OK to validate and exit the dialog box.

Specifying the Text Display Mode
In this task, you will learn how to specify the display mode for the text. For the purpose of this exercise, you will use a text with a leader and a frame, but this feature is also available with text only, as well as with dimension texts. Create a text with a leader and a frame.

1. Select the text and right-click it. 2. Click Properties in the menu that appears. The Properties dialog box appears. 3. Click the Text tab. 4. In the Options area, choose the display mode you want for your text from the Display list. You have the following options:
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•

Show Value: displays the text, and (when applicable) its leader and its frame. This option is selected by default.

•

Show Box: replaces the text and (when applicable) its frame by a rectangular box and displays its leader.

•

Hide Value: hides the text and (when applicable) its frame but (when applicable) displays its leader.

5. Click OK to validate. The text is now displayed using the mode you set.

If you select Hide Value as the display mode for a text with no leader, the text will not be visible at all on your drawing. You can find all hidden texts in a drawing using advanced Search options. To do this, choose Edit -> Search, click the Advanced tab. Select Drafting from the Workbench list, Text from the Type list, Display from the Attributes list. In the dialog box that appears, select = and Hide Value and then click OK. Click the Search icon. All hidden texts are listed.

In the case of dimensions, the display modes are as shown below: • Show Value: displays the dimension and its leader. This option is selected by default.

•

Show Box: replaces the dimension by a rectangular box and displays its leader.
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•

Hide Value: hides the dimension but displays its leader.

Editing Dimension Properties
Editing Dimension Text Properties
This task explains how to access and, if needed, edit dimension text properties. Open the Brackets_views02.CATDrawing document. Create a diameter dimension, for example. 1. Select a dimension (whatever the type) on the CATDrawing you opened. 2. Select Edit -> Properties and click the Dimension Texts tab. You can also right click the current element and then select the Properties command from the displayed contextual menu. 3. If needed, modify the available options.
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•

Prefix - Suffix: you can insert either a symbol or a text before the dimension text or a text after the dimension text.

You cannot insert a prefix and a suffix. If you want to remove the symbol before the dimension text, click the Insert Symbol icon and, from the list of symbols that appears, select this symbol:

•

Associated Texts: you can insert texts before, after, below and above the main and the dual value.

Dimension texts positioning:

• •

Dimension score options: you can choose to score only the value, all dimension texts or not to score (for Main Value and/or Dual Value). Dimension frame options: you can choose to include in the frame Value+tolerance+texts or Value+tolerance or Value for Main Value, Dual
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Editing Dimension Font Properties
This task explains how to access and edit dimension font properties. Open the Brackets_views03.CATDrawing document. Create a dimension (of whatever type). 1. Select the dimension. 2. Select Edit -> Properties. You can also right-click the dimension and then select Properties from the displayed contextual menu. 3. In the Properties dialog box that appears, click the Font tab. The associated panel is displayed.

• • • • •

Font: choose the font. Style: choose the font style. Size: choose the font size. Underline: underline the dimension text. Color: choose the font color. 343

InteractiveDrafting • Strikethrough: draw a line through the dimension text. • Overline: draw a line above the dimension text. You can either underline or overline a text, but you cannot do both. • Ratio: modify the character width. • Spacing: change the spacing between characters. 4. Modify the available properties as required. 5. Click OK to validate and exit the dialog box. For more information on font properties, refer to the Infrastructure User's Guide.

Editing Dimension Value Properties
This task explains how to access and edit dimension value properties. Open the Brackets_views03.CATDrawing document. Create a diameter dimension, for example. 1. Select a dimension (whatever the type) on the CATDrawing you opened. 2. Select Edit -> Properties and click the Value tab. You can also right-click the dimension and then select Properties from the displayed contextual menu. 3. If needed, modify the available options.
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Dimension Type: check Driving if you want projected dimensions to drive geometry. If you want to key in a value for the driving dimension, you must close Properties dialog box, double-click the dimension in the drawing, check Drive geometry and key in a value.

Value Orientation: you can choose: • • • • • the the the the the value orientation reference (Screen, View or Dimension Line), value orientation (Parallel, Perpendicular or Fixed Angle), orientation angle if Fixed Angle is selected in orientation, value position (Auto, Inside or Outside), value offset in relation to the dimension line.

Dual Value: you can show dual value by checking Show dual value and choosing its location: Below, Fractional or Side-by-Side. Format: you can set Main value and Dual value format. • • Description: select a type of format. Display: choose to display one, two or three factors.
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For chamfers, you can set Description, Display and Format in the chamfer tab.

Fake Dimension: check this option to display fake dimensions, you can choose to display numerical or alphanumerical fake dimensions. Texts for numerical fake dimensions are restricted to six characters. If you need to insert a text containing more than six characters, simply use the alphanumerical fake dimension. 5. Click OK to validate and exit the dialog box.

Editing Dimension Tolerance Properties
This task explains how to access and edit dimension tolerance properties. There are different types of tolerances: • • Numerical tolerances Alphanumerical tolerances

•

Combined tolerances (an alphanumerical value and two numerical values): ISOCOMB tolerance.

Open the Brackets_views02.CATDrawing document. Create a diameter dimension, for example. 1. Select the diameter dimension. 2. Select Edit-> Properties and click the Tolerance tab. You can also right-click the dimension and then select Properties from the displayed contextual menu. 3. You can associate a tolerance to the selected dimension. In this example, choose ISOALPH1 in the Main Value field. The First value field is enabled and displays an alphanumerical value. The corresponding numerical equivalents are displayed in the Upper value and Lower value fields. (These equivalents are defined by standards.)
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4. Assign the desired tolerance to this dimension by selecting another alphanumerical value. In this example, select H9 in the First value field. The corresponding numerical equivalents are automatically displayed. 5. In some cases, you may wish to display another tolerance. In this case, select a tolerance type in the Dual Value field. • • If you choose the same tolerance type for main and for dual value, then the values for this tolerance will also be the same. For a full description of the tolerance type selected in the Main Value and Dual Value fields, click the information (i) icon in front of each field.

6. Click OK to validate and exit the dialog box. • For dimensions with alphanumerical tolerances, you can display the corresponding numerical equivalents in the drawing, simply by selecting the dimension and placing the cursor over the tolerance in the drawing. The numerical equivalents are displayed in a tooltip. For dimensions with tolerance js and JS, there is no correspondence between the numerical and alpha numerical value. The numerical value displayed is +-0 or the previous numerical value applied to the dimension.

•

Editing Dimension Extension Line Properties
This task explains how to access and, if needed, edit dimension extension line properties. Open the Brackets_views02.CATDrawing document. Create a diameter dimension, for example. 1. Select the dimension you created (whatever the type). 2. Select Edit -> Properties. You can also right-click on this dimension and then choose Properties from the contextual menu. 3. In the Properties dialog box that appears, click the Extension Line tab.
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• • • • •

Color: choose a color for the extension line. Thickness: specify the thickness for the extension line. Display first extension line: check to display or uncheck to hide the first extension line, when applicable. Display second extension line: check to display or uncheck to hide the second extension line, when applicable. Slant: set the slant angle for the extension line. This angle is set between 90 degrees and -90 degrees excluded, the default angle being 0 degree.

This functionality works only on linear dimension line and the line linking extension line anchor points (blanking excluded) has to be parallel to the dimension line, as shown

below.

•

Extremities: it allows you to increase or decrease extension line Overrun and Blanking.

Overrun is the overrun minimum value. As an example, for a cumulated dimension (for ISO Standard):
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You can increase the overrun size

You cannot decrease it below the minimum value

To set extension line length and text position for cumulated dimensions, use the CUMLExtMode dimension parameter in the standards. • Funnel: to insert a funnel, you must check this option. You can configure the funnel: o the Height, o the Angle, o the Width, o the funnel mode: external or internal

External Funnel Mode o

Internal Funnel Mode

the Funnel side allows you to apply a funnel only on one extension line (Left or Bottom, Right or Top) or both of them (Both Sides).

You cannot create interruptions on funneled dimension lines. 4. Modify the available options as required. 5. Click OK to validate and exit the dialog box.
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Editing Dimension Line Properties
This task explains how to access and, if needed, edit dimension line properties. Open the Brackets_views02.CATDrawing document. Create a dimension. 1. Select the dimension you just created (whatever the type). 2. Select Edit-> Properties. You can also right-click on this dimension and then choose Properties from the contextual menu. 3. In the Properties dialog box that appears, click the Dimension Line tab. The associated panel is displayed. Not all fields are active: their activation depends on your choice of options.

Representation Specify how you want the dimension line represented: Regular, Two Parts, Leader one Part, Leader two Parts. Color Choose a color for the dimension line. Thickness
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Specify the thickness for the dimension line. Second part If you chose Two parts or Leader two Parts for the representation, you need to provide information about the second leader part: • • • the Reference for positioning the second part of the dimension line, the Orientation for the secondary part of the dimension line in relation to its reference, the Angle for the secondary part of the dimension line in relation to its reference (if you selected Dimension Line in the Orientation field and Fixed Angle in the Reference field).

Extension Choose an extension type for your dimension line. Leader Angle Specify the angle you want for the extension line. Symbols Choose the properties you want to apply to Symbol 1, Symbol 2 (you may need to check this box to specify you want to the dimension to display two symbols), and Leader Symbol (if you chose to represent the dimension line with a leader). • • • • Shape: you can choose the dimension line shape (arrow, circle, plus, etc.). Color: you can choose the symbols color. Thickness: you can define the symbol thickness. Reversal: you can set the position of the symbols (inside or outside) in relation to the extension line.

In the case of two-symbols dimensions, you can specify a different position for each symbol (i.e. symbol 1 inside and symbol 2 outside, or vice-versa). You can also do this interactively using the Ctrl key. You can apply different kinds of modifications between arrow symbol 1 and symbol 2 on the condition the drawing was created from version 5 release 5 on. Foreshortened For radius dimensions, you can activate the Foreshortened option.
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It allows you to transform a radius dimension line into a foreshortened radius dimension line. You can then choose from the following options: • • • • • • Text position: specify whether the text should be positioned on the long segment or on the short segment of the dimension. Orientation: define the orientation of the text associated to the dimension line (parallel or convergent). Angle: specify the angle value. Ratio: specify the ratio for the short segment and the long segment of the foreshortened dimension. Point scale: specify the point scale value. Unfix extremity position: check this box to unfix the extremity point of the foreshortened dimension line. You will then be able to move the extremity point using a yellow manipulator.

For foreshortened radius dimensions, you can define the appearance of the extremity point by making sure the Symbol 2 box in the Symbols area is checked, and then choosing the appropriate options.

Clicking the More button displays extra options, if any are available. 4. Modify the available options as required. For example, from the Representation drop-down list, choose Leader two Parts.

5. In the Leader Angle field, specify the angle you want between the two parts of the leader.

352

User Tasks

This angle is applied to the first segment:

You can also drive the second segment from the options in the Second Part area: it can be horizontal, vertical, parallel, perpendicular, fixed angle with screen, view, or dimension horizontal and vertical. 6. Change the Leader symbol in Symbols-> Shape. Choose Double Filled Arrow, for example.

7. Transform this two parts leader into a one part leader: from the Representation drop-down list, choose Leader one Part.
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8. Click OK to validate and exit the dialog box.

Editing Dimension System Properties
This task explains how to access and edit dimension system properties. Note that chained dimension system have no specific properties. 1. Right-click on any stacked or cumulated dimension system you created. 2. In the contextual menu, select Properties and click on the System tab. You can also select Edit -> Properties and click on the System tab. 3. If needed, modify the available options.
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Dimension lines alignment. Two offset modes are available for stacked dimension systems: • Constant: the offset between dimensions of a system remains constant and equal to the value defined in the Offset between dimensions field.

The offset between dimensions remains constant to the scale of the view as well. Consequently, in case you modify the scale of a view and perform an alignment on the dimension system, the offset between dimensions is also modified so as to remain constant to the view's scale. • Free: the dimensions of a system can be moved independently.

Only the Free offset mode is available for cumulated dimension systems. Dimension values alignment. Chained dimension systems can only be centered. Three dimension values alignment are available for cumulated/stacked dimensions systems: • • • Reference line Center Opposite.

Where d is the Values Offset properties. If the cumulated dimensions are to be set with value oriented along dimension line or extension lines, set the CUMLTxtReference dimension parameter in the standards accordingly. Remember that only some dimension system styles are activated depending on
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whether you chose the dimension or extension line as value orientation reference. Add funnel automatically. Funnels can be automatically added to cumulated/stacked systems whenever a dimension value line-up is performed. If automatic funnels are not required, they can also be added manually via Edit>Properties or when creating the dimension system.

Editing 2D Component Instance Properties
This task explains how to access and, if needed, edit information on instantiated 2D component properties. Open the Position_Component03.CATDrawing document. 1. Right-click on the 2D component instance to access the contextual menu. 2. Select Properties and click the 2D Component Instance tab. You can modify the 2D component instance position and orientation: You can also select the instance, go to Edit -> Properties and click the 2D Component Instance tab.

• •

Location: It allows you to access the instance location and the origin of the 2D component it was instantiated from. Position and orientation: you can modify detail instantiated 2D component coordinates, angle with horizontal reference axis and scale.

3. Click OK to validate and exit the dialog box.

Images
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Images
The Interactive Drafting workbench lets you add images to Drafting sheets as well as edit them.

Insert images: Insert raster or vector images in a drawing. Edit images: Edit raster images using the raster editor, or view information about vector images.

Inserting Images (Raster or Vector)
This functionality allows you to insert images on every operating system. It is useful for V4 Drawings translation. In this task, we will see how to insert raster (*.bmp, *.jpg, *.tif, etc.) or vector images (*.cgm. *.gl, *.gl2) as native V5 Drafting elements. The scenario below provides an example using a raster image, but the procedure is the same for vector images.

• • •

Define a new sheet and a view. Insert a frame title block, choose the Drawing_Titleblock_Samples1. Save the logo.tif document on your computer (to do this, right-click on "logo.tif" and choose Save Target As in the contextual menu).

1. Select the Insert -> Picture command.

A dialog box appears, allowing you to browse your disk. 2. Select the file "logo.tif" you have previously imported. The image is imported in
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You get this:

The image is a native V5 Drafting element, it is positioned by default at the origin of the view. The anchor point of the picture corresponds to its lower left-hand corner. • In the Properties dialog box available from the image's contextual menu, on the Picture tab, check the Lock aspect ratio option to make sure images will keep their ratio aspect. • If the previous option is unchecked, use the Ctrl key to keep the picture ratio aspect. • Use the Shift key to snap to the grid.

4. Drag the image to the required position.

Editing Raster Images
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User Tasks In this task, you will learn how to edit raster images (*.bmp, *.jpg, *.tif, etc.) inserted in a drawing. Save the logo.tif document on your computer (to do this, right-click on "logo.tif" and choose Save Target As in the contextual menu) and insert it in your drawing. 1. Double-click on the raster image. The Image Editor dialog box is displayed.

2. Edit the image as wanted. For more information on how to edit images, refer to Editing Images in the Album in the Infrastructure User's Guide. 3. When you are done, click OK. The image is updated in the drawing.

Viewing information about vector images You cannot edit vector images (*.cgm. *.gl, *.gl2) inserted in a drawing, but you can, however, view information about them. To do this, simply double-click on a vector image in a drawing. This will display the Image information dialog box. To exit the dialog box when you are done reviewing the image-related information, click OK.
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File Export and Import

The Generative Drafting workbench lets you export and import different types of files. Note that these tasks, which deal with data exchange, are actually documented in the Data Exchange Interfaces User's Guide.

DXF/DWG: Import: Import or insert the 2D geometric data contained in a DXF or DWG file into a CATDrawing document. DXF/DWG: Export: Export the data contained in a CATDrawing document into a DXF file. DXF/DWG: Report File: Learn more about the report file. DXF/DWG: Trouble Shooting: Learn how to troubleshoot DXF/DWG import and export. DXF/DWG: Best Practices: Learn best practices for DXF/DWG import and export. DXF/DWG: FAQ: Get answers to Frequently Asked Questions about DXF/DWG import and export. DXF/DWG: VBScript Macros: Learn about DXF/DWG import and export macros.
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CGM: Insertion: Insert a CGM file into a CATDrawing document. CGM: Export: Export the data contained in a CATDrawing document into a CGM file.

Print
Print
The Interactive Drafting workbench provides a simple method to print one or more sheets inserted in your document. See the Printing Documents chapter in the Infrastructure User's Guide for detailed information about printing.

Print a sheet: Print a given sheet. Print using a clipping operator: Print using a clipping operator with scaling support. Lets you print only a part of a drawing.

Printing a Sheet
This task will show you how to print a given sheet. Note that you may also print several sheets if a drawing contains several of them. When printing a sheet, the current filter and layers (those used for screen display) are taken into account. For more details on layers and filters, see the Using Layers and Layer Filters chapter in the Infrastructure User's Guide.

Open the Product_Balloon.CATDrawing document. 1. Select File -> Print from the menu bar. The Print dialog box is displayed.
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2. Choose your print options as required: • The Printers area lets you choose the printer you want to use or specify whether you want to print to a file. • The Layout tab lets you define the sheet orientation, position and size. • The MultiDocuments tab lets you specify additional choices if the current document contains several sheets. • The Print Area area lets you define whether you want to print: o the entire sheet: Whole Document o the sheet as seen on screen: Display button: Selection. Refer to Printing using o the area selected using the a Clipping Operator for more information. o the print area previously defined for the sheet: Document area. This print area is defined (and activated) in the sheet properties. Refer to Editing Sheet Properties for more information. Note that the Document area option appears only if you activated the print area in the sheet properties prior to accessing the Print dialog box. • The Copies field lets you specify the number of copies to print. • The Tiling option lets you tile the sheet and print it on several pages. • The Page Setup... button lets you define the page setup. • The Options... button lets you define additional options. • The Preview... button lets you preview the document to be printed. For detailed information, refer to the the Printing Documents chapter in the Infrastructure User's Guide. The Customizing Print Settings Before Printing Your Documents and Printing Multi-Documents tasks should prove particularly helpful. 3. Click OK to print the sheet and close the Print dialog box.
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Printing using a Clipping Operator
This task will show you how to print using a clipping operator with scaling support. Open the Product_Balloon.CATDrawing document. 1. Select File -> Print. 2. Choose your print options as required. 3. In the Print dialog box, choose Selection in Print Area.

This activates the selection mode button and allows you to select the area to print. 3. Click the selection mode button print area. and drag the cursor on the drawing to define the
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4. Click OK to print this area.

Advanced Tasks
Advanced Tasks
Advanced tasks deal with using Knowledgeware tools in the Interactive Drafting workbench. The information you will find in this section is listed below:

Deactivating Annotations
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User Tasks This task explains how to deactivate/activate annotations using Knowledgeware tools. This feature enables you to specify whether an annotation should be active or not, using what is known as an Activity parameter. Deactivated annotations are not taken into account anymore. Deactivating dimensions, for example, enables you to avoid problems when some dimensions cannot be computed anymore (e.g. when geometry has been deleted). In this scenario, you will see how to deactivate dimensions, but you can also deactivate texts, balloons, welding symbols and geometrical tolerances. For more information on using Knowledgeware capabilities, refer to the Knowledge Advisor User's Guide. Open the Deactivating_annotations.CATDrawing document. It contains three views, each of which shows a number of dimensions.

1. Click the Design Table icon in the Knowledge toolbar. The Creation of a Design Table dialog box is displayed. 2. If needed, replace the default name and comment for the design table. 3. Check the Create a design table with current parameter values option.

365

InteractiveDrafting

4. Check the Horizontal orientation option.

5. Click OK. The Select parameters to insert dialog box is displayed. 6. In the Parameters to insert list, you can notice that there are Activity parameters for a number of annotations (dimensions and texts, in this specific case). For the purpose of this scenario, select all of the Activity parameters for dimensions: the Sheet.1 Sheet.1 Front view Top view DrwDressUp.1 Dimension.# Activity, DrwDressUp.1 Dimension.# Activity and

Sheet.1 Left view DrwDressUp.1 Dimension.# Activity items. Then, click the right arrow to add these items to the Inserted parameters list.
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7. Click OK. A Save As dialog box is displayed. 8. Specify a path and filename for the design table to be created. Click OK in the file selection dialog box. The design table feature is added to the specification tree and a dialog box displays the newly created design table. This design table contains only one configuration, on line 1. By default, all dimensions are active (their Activity parameters are set to "true").

9. Click the Edit table... button to start an Excel application (under Windows) or open the text editor (under Unix). 10. In column C, set each item to "false". 11. In column D, set each Sheet.1 view view DrwDressUp.1 DrwDressUp.1 Front Activity item to Sheet.1 Activityand Sheet.1 Left Top

Dimension.# Dimension.#

view DrwDressUp.1 Dimension.# Activity item to "true". This will enable you to deactivate some of the dimensions while keeping other dimensions active.
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12. Save your Excel or .txt file and close your application. An information message is displayed to let you know that the design table was updated; click Close. The design table now contains 3 configurations. 13. You can now select another configuration in the Design table dialog box. Select line 3, for instance, and click Apply. You can notice that the dimensions in the front view are deactivated, while the dimensions in the other views remain active.

14. Click OK to exit the dialog box and add the design table to the document.
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User Tasks • • The only way you can display deactivated annotations is by reactivating them through Knowledgeware (i.e. by setting their Activity parameter to "true"). You can also deactivate/activate annotations using formulas. For more information about formulas, refer to the Knowledge Advisor User's Guide. You can also see Deactivating Table Rows in this User's Guide for a scenario on using formulas to deactivate rows in a table.

Deactivating Table Rows
This task explains how to deactivate/activate (i.e. hide or display) table rows using Knowledgeware tools. This feature enables you to specify whether a row should be active or not, using what is known as an Activity parameter. For more information on using Knowledgeware capabilities, refer to the Knowledge Advisor User's Guide.

Open the Gear-Reducer-with-BOM.CATDrawing document. It contains three tables (actually, three bills of material).

1. Select the table called "Bill of Material: GEAR REDUCER". 2. Click the Formula icon in the Knowledge toolbar. The Formulas:Table.1 dialog box is displayed. It displays the formula parameters and the Activity parameters corresponding to the selected table (Table.1). 3. In the parameters list, select the following Activity parameter: the Sheet.1 item. Isometric view DrwDressUp.1 Table.1 Text.1 Activity

4. In the Edit name or value of the current parameter field, change the parameter value to "false".
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The table is immediately updated: its title row is hidden. 5. Repeat this operation for the next Activity parameter in the list: the Sheet.1 item. Isometric view DrwDressUp.1 Table.1 Text.6 Activity

The table is immediately updated: its header row is hidden.

7. Using the same method, reset the Activity parameters you just modified to their original value "true", in order to display the table title row and header row again.

8. Now, set the Sheet.1

Isometric
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view DrwDressUp.1 Table.1 Text.21 Activity item to "false", and click Apply. The table is updated and the corresponding row is hidden.

9. Click OK to exit the dialog box and validate your latest changes.

• •

The only way you can display deactivated rows is by reactivating them through Knowledgeware (i.e. by setting their Activity parameters to "true"). You can also deactivate/activate rows using design tables. For more information about design tables, refer to the Knowledge Advisor User's Guide. You can also see Deactivating Annotations in this User's Guide for a scenario on using design tables to deactivate annotations.

Adding Attribute Links to Text
This task shows you how to add one or more attribute links to text. You will learn how to: • • create an attribute link between a hole on the 3D part and the corresponding text in a drawing view assign an attribute link to a view

Creating an attribute link between a hole on the 3D part and the corresponding text in a drawing view
Open the GenDrafting_part.CATPart document and the GenDrafting_part_02.CATDrawing document.

1. On the active view, double-click the text to which you want to add a link.
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An empty text is created in the drawing. Also, the Text Editor dialog box is displayed. Do not pay attention to this dialog box yet. 2. In the drawing, right-click on the text and select the Attribute Link option from the contextual menu. 3. Select the object which you want the text to be linked to, from the specification tree (either from the 3D or from the CATDrawing document). For example, select Hole 2 from the CATPart specification tree.

The Attribute Link Panel dialog box is displayed in the Drafting window:

4. Select the "Part1 PartBody from the list displayed.

Hole.2

Diameter 8.5mm" attribute

The 8.5mm attribute automatically appears both in the Text Editor dialog box and on the CATDrawing.

372

User Tasks

5. Click OK to validate and exit the dialog box. 6. Modify the diameter of Hole 2 on the CATPart. For example, change the hole diameter to 13.5mm.

This modification is automatically updated on both the views generated on the CATDrawing and the linked text attribute inserted inside the text, on the condition you select automatic update mode in the Options dialog box (Tools -> Options -> Infrastructure -> Part Infrastructure, General tab).

At this step, you can perform a query on the link (s) you just created. For this, click the view and select the Query Objects Links option from the contextual menu. The Query Link Panel dialog box appears, displaying a list of the existing links.

Of course, you can only modify the text that is not of the text attribute type. To modify the text attribute, you need to isolate it. To do this, right-click the text attribute and then select the Isolate Text option from the contextual menu.
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Assigning an attribute link to a view
The GenDrafting_part_02.CATDrawing document is still open from the previous task.

Creating a parameter
1. Click the Formula icon from the Standard toolbar.

The Formulas: Drawing dialog box is displayed. 2. In the drop-down lists next to the New Parameter of type button, choose the String with Single Value type. 3. Click the New Parameter of type button. 4. In the Edit name or value of the current parameter fields, replace String.1 by UserName in the first field, and enter the value, i.e. NameOfUser in the second field.

374

User Tasks

5. Click Apply and then click OK. The parameter is created, and it is displayed in the Drafting specification tree, under the Parameters node. If the Parameters node in no displayed in the Drafting specification tree, go to Tools -> Options -> General -> Parameters and Measure, Knowledge tab, and check the With value and With formula options.

Defining the Text Attribute
6. Click the Text icon from the Annotations toolbar and click in the free space (under the Front View - Scale:1 text, for example).

An empty text is created in the drawing (in the active view). Also, the Text Editor dialog box is displayed. Do not pay attention to this dialog box yet. 7. In the drawing, right-click on the empty text and select the Attribute Link option from the contextual menu. 8. From the specification tree, select the object which you want the text to be linked to. For example, select the CATDrawing document (GenDrafting_part_02 item at the very top of the specification tree). The Attribute Link Panel dialog box is displayed. 9. Scroll down the list and select UserName in the Attribute List.
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10. Click OK. The value assigned to UserName, i.e. NameOfUser, is displayed in the Text Editor dialog box as well as on the drawing view. 11. Click OK to close the Text Editor dialog box.

Modifying the Text Attribute
12. Double-click the UserName parameter in the specification tree. The Edit Parameter dialog box is displayed. 13. Change the parameter name (NameOfUser) to NewNameOfUser. 14. Click OK. The parameter name is automatically updated on the view.

Setting Relations Between Dimensional Constraints
This task shows you how to set constraints between dimension using formulas. As a result, if you modify one of these dimensions (the driving dimension), all the other dimensions as well as the geometry will be modified accordingly. Open the Brackets_views04.CATDrawing document. 1. Click the Formula icon from the Standard toolbar.

The Formulas dialog box appears.
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You will now select, one after the other, the dimensions to be constrained and then enter in the dialog box the formulas to be used.

2. Select a first dimension (1). 3. Press the Add Formula switch in the Formulas dialog box. The Formula Editor dialog box appears.
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4. Select a second dimension (3) and add "/4". Then, click OK (Formula Editor dialog box). 5. Select a first dimension (2).

6. Press the Add Formula switch in the Formulas dialog box. The Formula Editor dialog box appears.

7. Select a second dimension (3) and add "*3 /4". Then, click OK (Formula Editor dialog box).

8. Select a first dimension (4). 9. Press the Add Formula switch in the Formulas dialog box. The Formula Editor dialog box appears.

10. Select a second dimension (1) and then, click OK (Formula Editor dialog box).
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13. Select a second dimension (2) and then, click OK (Formula Editor dialog box). 14. Click OK ( Formulas dialog box).

Note that the specification tree is modified accordingly.

15. Double-click the dimension to be set as driving dimension (3). The Dimension Value dialog box appear.
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16. If needed, activate the Drive geometry option. 17. Enter 100mm as dimension new length and press OK. All the dimensions which you previously constrained using formulas are automatically updated.
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Workbench Description
This section contains the list of the icons and menus which are specific to Interactive Drafting workbench. You may read these pages whenever you need to know greater details on these commands documented in other parts of the guide.
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Interactive Drafting Menu Bar
This chapter describes the various menus, submenus and items specific to the Interactive Drafting workbench. General menu commands are described in the Infrastructure User's Guide. Start File Edit View Insert Tools Windows Help

File
Save the document to the required format, customize the sheet and print it after modifying the settings if needed. Refer to the Infrastructure User's Guide. For... New See... Entering the Interactive Drafting workbench

Page Setup Print

Modifying a Sheet Printing
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Edit
Manipulate selected objects. Also refer to the Infrastructure User's Guide. For... See...

Background

Creating a Frame Title Block

Insert
Insert various types of elements. For... Views... Drawing Dimensioning... Annotations... Dress Up... Geometry creation See... Views Sheets Dimensions Annotations Dress-Up Elements 2D Geometry
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For... Views... Drawing Dimensioning... Annotations... Dress Up... Geometry creation Geometry modification Picture

See... Views Sheets Dimensions Annotations Dress-Up Elements 2D Geometry 2D Geometry Operations Images

Tools
Set user preferences. Also refer to the Infrastructure User's Guide. For... See...

Visualization Filters Options Standards Positioning Multi View (2.5D) Reset All Defaults Import External Format

Infrastructure User's Guide Customization Standards Administration Lining up Dimensions Views Setting Properties as Default File Export and Import
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Interactive Drafting Toolbars
This section describes the various icons of the Interactive Drafting workbench. The toolbars are located on each side of the workbench in the default set-up, except for the Tools palette which appears only when specific tools are available for a given command.

Toolbar Geometry Creation Geometry Modification Drawing Annotations Dress-Up Dimensioning Tools Tools Palette Properties Text Properties Graphic Properties Dimension Properties Style Create geometry

Purpose Transform existing 2D elements and add constraints to elements on the drawing Create sheets, views, 2D components and frame title blocks Add annotations to existing views by creating them Add dress-up elements on the drawing Create all types of dimensions needed for your drawing Activate display and positioning tools Use specific options or value fields available for a given command Modify the text properties Modify the graphic properties of all kind of features Modify the dimensions properties Set the style that will be used to create a new object

CATDrawing Specification Tree Icons
This section describes the various icons of the Interactive Drafting and Generative Drafting workbenches. Current drawing Design sheet Detail sheet 2D component View. Applies to interactive views only (whatever the view type is). Front view. Applies to generative views only. Projection view. Applies to generative views only. Auxiliary view. Applies to generative views only.
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InteractiveDrafting Isometric view. Applies to generative views only. Section view. Applies to generative views only. Section cut. Applies to generative views only. Detail view. Applies to generative views only. Unfolded view. Applies to generative views only.

Masks Specific to Drafting Applications
Unreferenced drawing. The link between the drawing and the 3D part or product is broken. Does not apply to drawings which contain only interactive views. Unreferenced sheet. The link between the sheet and the 3D part or product is broken. Does not apply to sheets which contain only interactive views. Unreferenced view. The link between the view and the 3D part or product is broken. Does not apply to interactive views. Locked view. (Note that a locked view cannot be updated. Therefore, locked views which are not up-to-date will not be applied the corresponding mask.)
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Administration Tasks
In the Interactive Drafting workbench, administration tasks deals with the administration of standards. These tasks must be performed by an administrator. Administrators can manage and customize standards such as ISO, JIS, ANSI, ASME, etc. or company standards. The Standards Editor lets administrators set the standards used for dress-up, dimensions, annotations, etc. as well as set the styles that will be used as defaults for element properties in the Interactive Drafting workbench.

The format of the standard file has been changed from V5 R9 onwards. If you were using a customized CATDrwStandard file on a release up to V5 R8, you need to upgrade the standard file to the new XML format.

Before You Begin
About Drafting Standards
When users modify the properties of an element in the Interactive Drafting workbench, the modifications are only applied to the selected element, in the current drawing. Standard files let administrators set the properties of an element so that they will be applied to all elements of the same type in a drawing, as well as in all drawings which use a given standard. A standard file is an XML file which makes it possible to customize globally, for a CATDrawing, the appearance and behavior of drafting elements. With standard files, administrators can:

•

set standard styles that will be used as default values when creating new elements, i.e.: o define sheet styles o define geometry styles o define annotation styles o define dimension styles o define dress-up and dress-up symbols styles
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o •

set standard parameters, i.e.: o control the user interface, with general parameters to restrict the values of some element properties o customize dimensions o customize annotations o customize dress-up elements o define new dimension tolerance formats o define new dimension value formats o control pre-defined formats for tolerance and dimension values o control view generation parameters o customize fixed-size frames o customize line thickness o customize patterns

Once defined, a format is applied to elements as a property.

The format of the standard file has been changed from V5 R9 onwards. If you were using a customized CATDrwStandard file on a previous release (up to V5 R8), you need to upgrade the standard file to the new XML format.

Management of Drafting Standards
Standalone drawings
When users create a CATDrawing document (File -> New), they specify the standard that will be associated with this document. The values of the parameters in the specified standard file are then copied into the CATDrawing document. Each drawing contains a copy of the standard and is therefore standalone. This makes it possible for users, projects, or companies to exchange CATDrawing documents without needing to send the standard file along.

Administrator-controlled access and modification
The administrator defines and controls the location of the standard files as well as the ability to define new standards, or to modify existing standards. For example, the administrator can define a single standard, and prevent users from modifying it.

Seven standard files available by default
By default, seven standard files are provided: four for each of the international standards available when creating a new CATDrawing file, and three for use with other workbenches. These files are located in install_root/resources/standard/drafting. • Some are specifically intended for Drafting:
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Workbench Description o ISO.xml o ANSI.xml o JIS.xml o ASME.xml • Some are specifically intended for the 2D Layout for 3D Design and Functional Tolerancing and Annotation workbenches. They are based on the Drafting standards and are suffixed with _3D. In these specific standards, the colors, for example, have been customized for optimized display. o ASME_3D.xml o ISO_3D.xml o JIS_3D.xml Administrators can add as many standard files as needed. Refer to Administering Standards for more information.

Editing the standard file
The standard files can be edited using an interactive editor. This editor provides an easy-to-use graphic interface to let administrators customize the parameters included in the standard files. For information on how to customize these parameters, refer to Setting Standard Parameters. The interactive editor is available in Tools -> Standards. (It is the same editor with which you can customize generative view styles). For more information on how to use this editor, refer to the Customizing Standards chapter in the Infrastructure User's Guide.

Make sure you use the Standards editor available in Tools -> Standards when modifying and customizing the XML standard files. Using other editors (such as text editors) may alter the consistency of the standard file, and may make the standards XML files unusable.

Switching to another standard
When several standards are defined, users can switch a drawing to another standard. Refer to Switching to Another Standard.

Updating the standard of a drawing
When a standard file is modified, users need to explicitly update the drawings which use this standard. Note that only standard parameters are affected by this update, not styles. Refer to Updating the Standard of a Drawing.

Administering Standards and Generative View Styles
This task documents the administration of both standards (Interactive Drafting workbench) and generative view styles (Generative Drafting workbench), as the procedure is basically the same whether you are administering standards or generative view styles. When applicable, differences will be notified. The examples provided in this task specifically deal
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Location of standard or generative view style files
The location of standard files or generative view style files is defined by two environment variables which can be set during installation or modified afterwards: Variable name CATCollectionStandard Description Path and name of the directory (or directories) which contains: • the drafting sub-directories (which themselves contain the customized drafting standards). It is in these drafting sub-directories that you should add the drafting standards customized for a company, project or user. the generativeparameters subdirectories (which themselves contain the customized generative view styles). It is in these generativeparameters subdirectories that you should add the generative view styles customized for a company, project or user.

•

CATDefaultCollectionStandard Path and name of the directory (or directories) which contains: • the drafting sub-directories (which themselves contain the predefined drafting standards delivered by Dassault Systemes). the generativeparameters subdirectories (which themselves contain the predefined generative view styles delivered by Dassault Systemes).

•

The default location for this directory (set during the installation process) is the installation directory install_root resources standard.
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Setting the location of standard files
Refer to the Administration Tasks chapter in the Generative Drafting User's Guide for specific information on how to set the location of generative view style files. There are two possibilities: • If you want to place all customized drafting standards in a custom directory, named mydirectory for example, you need to proceed as follows: 1. Create a directory named as you like (mydirectory, for example). 2. Create a sub-directory under this directory, which needs to be named drafting. 3. Place the XML files containing your customized drafting standards in mydirectory • drafting.

If you have not yet customized your XML standard files, then proceed as follows: 1. Create a directory named as you like (mydirectory, for example). 2. Create a sub-directory under this directory, which needs to be named drafting. 3. Set the CATCollectionStandard variable to mydirectory. After you have customized the XML standard files, the standard editor will then save them in mydirectory drafting.

• •

If the CATDefaultCollectionStandard and the CATCollectionStandard variables both contain an identically-named standard, it is always the standard found in CATCollectionStandard which will be used. If two directories referenced by the CATCollectionStandard and/or CATDefaultCollectionStandard variables contain identically-named standard files, it is always the standard in the directory listed first which will be used.

Customizing and defining standards or generative view styles
To edit and save standard files or generative view style files in Tools -> Standards, you must be running the V5 session in administrator mode (admin). The recommended method for customizing standard files or generative view style files is the following: 1. You need to work in administrator mode. To do this, proceed as
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InteractiveDrafting follows: a. Set up the CATReferenceSettingPath variable. b. Start a V5 session using the -admin option. For more information, refer to the Managing Environments chapter in the Infrastructure Installation Guide. 2. Set up the CATCollectionStandard environment variable as explained above. If none of the conditions are respected, a warning message will appear to let you know that you will neither be able to modify nor save the XML files. 3. Modify the Drafting standards or the generative view styles as appropriate. 4. Use the Save As or the OK button to store your modifications. 5. To exit, use the Cancel button. Once the standard files or the generative view style files have been customized and saved, they can be used in a V5 session in normal mode.

Availability of standard switch and update
Note: The information provided below does not apply to generative view styles. Using the settings available in Tools -> Options -> Mechanical Design -> Drafting -> Administration, administrators can forbid or allow users to: • • switch a drawing to another standard (via File -> Page Setup), update the standard used by a drawing (via File -> Page Setup).

Moreover, administrators can lock these settings so that other users running a session with the same environment inherit those settings and cannot change them. This feature is described in the Locking Settings section, in the Infrastructure Installation User's Guide.

Upgrading Standard Files from Previous Releases
Depending on your needs, you can: • • Upgrade CATDrwStandard files (i.e. standard files customized in releases up to and including V5R8) to the current level for XML standard files Upgrade XML standard files from previous releases (i.e. XML standard files customized in releases starting from V5R9) to the current level for
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Upgrading CATDrwStandard Files to the Current XML Standard Files
Up to and including V5R8, the standard file defining standard XXX was a file named XXX.CATDrwStandard, located in install_root/reffiles/Drafting. In V5R9, the format of the standard file was changed to XML. The standard file defining standard XXX is now a file named XXX.xml, located in install_root/resources/standard/drafting. If you have customized or defined a CATDrwStandard file, and wish to re-use this customization in the current release, you need to convert your CATDrwStandard file into a XML file. There are 2 ways of doing this:

Manual upgrade
If the degree of customization of the standard file is small, you can start from one of the 4 pre-defined standard files (ISO, ANSI, JIS or ASME), and modify it using the standards editor (Tools -> Standards). You will need to modify the parameter values, and add the styles that you had defined in the CATDrwStandard file.

Automatic upgrade
A batch utility is provided in order to automatically generate the XXX.xml file starting from a XXX.CATDrwStandard file. All the customization done on the CATDrwStandard file will be reproduced in the XML file, and all styles defined in CATDrwStandard file will be added. The utility will also add to the XML file the new standard parameters (with default values), as well as the new pre-defined styles. • • If you want to convert a single CATDrwStandard to the current XML format, use: CATAnnStandardTools MIGRATE XXX [dir] If you want to convert all CATDrwStandard files to the current XML format, use: CATAnnStandardTools MIGRATE_ALL [dir]

For more information on using these commands on Windows and on Unix, see below.

The tasks below will show you how to use the standard automatic upgrade tool on Windows and on Unix.
Using the standard automatic upgrade tool on Windows

1. Open an MS-DOS Window. 2. Change to the folder in which you installed the product.
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The default folder is \intel_a\code\ 3. You have two options:

bin

• To generate XML files for all the CATDrwStandard files located in reffiles Drafting, enter this command: CATAnnStandardTools MIGRATE_ALL [dir] where [dir] is an optional directory in which to write the resulting XML files. Local directory is the default. • To generate the XML file corresponding to one single standard, enter this command: CATAnnStandardTools MIGRATE XXX [dir] where XXX is the name of the standard you want to convert (ISO, ANSI...) and [dir] is an optional directory in which to write the resulting XML file. Local directory is the default.
Using the standard automatic upgrade tool on UNIX

1. Open a shell command window. 2. Change to the directory in which you installed the product. The default directory is /OS_a/code/command/ where OS_a is: • aix_a • hpux_a • irix_a • solaris_a 3. You have two options: • To generate XML files for all the CATDrwStandard files located in reffiles Drafting, enter this command: ./catstart -run "CATAnnStandardTools MIGRATE_ALL [dir]" where [dir] is an optional directory in which to write the resulting XML files. Local directory is the default. • To generate the XML file corresponding to one single standard, enter this command: ./catstart -run "CATAnnStandardTools MIGRATE XXX [dir]" where XXX is the name of the standard you want to convert (ISO, ANSI...) and [dir] is an optional directory in which to write the resulting XML files. Local directory is the default.

Upgrading XML Standard Files from Previous Releases to the Current Level
394

Workbench Description The XML standard file has evolved in each release since V5R9. New standard parameters have been added, some have been modified, and new functionalities (such as styles) have been introduced. If you have customized or defined an XML standard file in a previous release (i.e. a release starting from V5R9), and wish to re-use this customization in the current level, you need to upgrade your XML file. There are 2 ways of doing this:

Manual upgrade
If the degree of customization of the standard file is small, you can start from one of the 4 pre-defined standard files (ISO, ANSI, JIS or ASME), and modify it using the standards editor (Tools -> Standards). You will need to modify the parameter values and customize new parameters and/or styles.

Automatic upgrade
A batch utility is provided in order to automatically generate the current XML file starting from an XML file from a previous release. All the customization done on the starting file will be reproduced in the upgraded XML file. The utility will also add the new parameters and styles introduced in the current release (with default values) in the XML file. • • If you want to upgrade a single XML file to the current version, use: CATAnnStandardTools UPGRADE XXX [dir] If you want to upgrade all XML files to the current version, use: CATAnnStandardTools UPGRADE_ALL [dir]

For more information on using these commands on Windows and on Unix, see below.

The tasks below will show you how to use the standard automatic upgrade tool on Windows and on Unix.
Using the standard automatic upgrade tool on Windows

1. Open an MS-DOS Window. 2. Change to the folder in which you installed the product. The default folder is \intel_a\ 3. You have two options: • To upgrade standard files for all the XML files located in install_root command: resources standard drafting, enter this code\ bin

CATAnnStandardTools UPGRADE_ALL [dir] where [dir] is an optional directory in which to write the resulting XML files. Local directory is the default.
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• To upgrade the XML file corresponding to one single standard, enter this command: CATAnnStandardTools UPGRADE XXX [dir] where XXX is the name of the standard you want to convert (ISO, ANSI, MY_ISO...) and [dir] is an optional directory in which to write the resulting XML file. Local directory is the default. The batch will first search the standard file in the directory defined by the exported variable CATCollectionStandard (e.g. set CATCollectionStandard=e: tmp), and then, if not found, in the resources standard drafting.

following directory: install_root

Using the standard automatic upgrade tool on UNIX

1. Open a shell command window. 2. Change to the directory in which you installed the product. The default directory is /OS_a/code/command/ where OS_a is: • aix_a • hpux_a • irix_a • solaris_a 3. You have two options: • To upgrade standard files for all the XML files located in install_root command: resources standard drafting, enter this

./catstart -run "CATAnnStandardTools UPGRADE_ALL [dir]" where [dir] is an optional directory in which to write the resulting XML files. Local directory is the default. • To upgrade the XML file corresponding to one single standard, enter this command: ./catstart -run "CATAnnStandardTools UPGRADE XXX [dir]" where XXX is the name of the standard you want to convert (ISO, ANSI...) and [dir] is an optional directory in which to write the resulting XML files. Local directory is the default. The batch will first search the standard file in the directory defined by the exported variable CATCollectionStandard (e.g. export CATCollectionStandard=d/tmp), and then, if not found, in the following
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directory: install_root

resources

standard

drafting.

Setting Parameters and Standards
Setting Standard Parameters
The Interactive Drafting workbench lets administrators set standard parameters and create standard formats. About Standard parameters: Learn more about the management of standard parameters. General parameters: Customize the parameters that let you control and restrict the values that are available for some element properties. Dress-up parameters: Customize the parameters that deal with the appearance of dress-up elements, such as markup arrows. Dimension parameters: Customize the parameters that deal with the appearance of annotation and dimension elements. Annotation Parameters: Customize the parameters that deal with the position of text leaders. Tolerance Formats: Customize the dimension tolerance formats, which are userdefined formats to be applied to dimension tolerances. Value Formats: Customize the dimension value formats, which are user-defined formats to be applied to dimension values. Pre-defined Formats for Tolerance and Dimension Values: Customize the predefined formats for tolerance and dimension values. Pre-defined Styles Definitions: Customize the pre-defined non-modifiable styles and their definition, which you can use as a reference when defining new formats. View Generation Definition: Define view generation, i.e. customize settings that should be applied when generating views. Frame Definition Parameters: Define customizable fixed-size frames. A frame is a property which can be applied to texts as well as certain types of annotations and dress up elements. Line Thickness Definition: Define line thickness. Line thickness is a property which can be applied to, and drives the representation of, almost all elements in a drawing, such as lines, curves, dimension lines, etc. Pattern Definition: Define patterns. Patterns are used for area fills or when generating section views/cuts or breakout views. Linetype Definition: Define linetypes. Linetypes can be applied to, and drive the representation of, almost all elements in a drawing, such as lines, curves, dimension lines, etc.
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InteractiveDrafting Sheet Format Definition: Define sheet format. Sheets contain a view that supports the geometry when creating a drawing. Layout Views Customization - for the 2D Layout for 3D Design workbench: Define the 2D Layout for 3D Design view box, which gathers all the data needed to fully define the layout of a view set in the 2D window, as well as the position of each view in the 3D space.

Before You Begin
Structure of the Standard
Standards are defined by the administrator. A drafting standard file is structured as a tree, as it appears in the Standards Editor (available via Tools -> Standards). It contains several main sections, each dealing with a specific aspect of drafting customization: • Styles • General parameters • Dress-up parameters • Dimension parameters o Company-defined dimension tolerance formats o Company-defined dimension value display formats o Pre-defined formats for tolerance and dimension values • Annotation parameters • Company-defined view generation • Company-defined frame formats • Company-defined line thickness • Company-defined patterns • Company-defined linetypes • Company-defined sheet format
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General Syntax for the Standard Editor Values
Fractions and operations

The standards editor can handle basic numerical operations to help you enter the values for the parameters. You can enter your value as a set of operations, and let the program compute the result when you validate the field. For example, for each parameter of the "real" type, you can specify the value using a fraction: NDFact_1 = 1/60. You can also use units or trigonometric functions in your operations: NDSepPos_1 = 1 in + 1 mm + cos(0.12)
Special characters

For each parameter of the "string" type, you can enter special characters using the following keywords:
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• • •

[DEGREE] will be displayed as deg [MINUTE] will be displayed as ' [SECOND] will be displayed as "

A special character can be used alone or combined with other characters (the special character only counts as 1 character): NDSepar_1 , [DEGREE] or NDSepar_1 , " in [DEGREE]"

DBCS Restriction
Double-byte character sets are not supported when creating new standard parameters and styles (i.e. corresponding to new nodes in the standards editor tree). However, double-byte character sets are supported when setting values for standard parameter and styles.

For More Information
• • Refer to About Standard Parameters for more information on how to customize standard parameters, how to define new standard formats, and on the general syntax for the standard editor values. Refer to About Styles for more information on setting default values for elements using styles, and on how to customize standard styles.

Setting Standard Parameters and Styles
Setting Standard Parameters and Styles
The Interactive Drafting workbench lets administrators set and create standard parameters and standard styles.

Before you Begin: You should be familiar with important concepts: structure of the standards, general syntax for the standard editor values, DBCS restriction. Setting Standard Parameters: Set standard parameters and create standard formats. Setting Standard Styles: Set standard styles that will be used as default values when creating new elements.
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Parameters
About Standard Parameters

Customizing Standard Parameters In this scenario, administrators will learn how to customize standard parameters using an example. This scenario provides an example of dimension customization, but the procedure is the same when customizing other standard parameters (dimensions, annotations, dress-up elements, etc.) The procedure differs when customizing styles. For more information, refer to About Styles. With the pre-defined ISO standard, a radius dimension extension lines reaches the center of the circle. You will modify the extension line so that it does not reach the center of the circle.

Select Tools -> Standards to launch the standards editor. Choose the Drafting category, and then open the ISO.xml file from the drop-down list. 1. Select the Dimensions node in the editor. 2. Modify the DIMLRadiusExtReachCenter parameter value from Yes to No. 3. Set the DIMLRadiusExtLength parameter value to 2. 4. Click OK to save your modifications and exit the standards editor. 5. Create an ISO drawing using the File - > New command. 6. Create a circle, and add a radius dimension to it. The dimension extension line does not reach the center, as it would have with the pre-defined ISO standard.

Defining a New Format In this scenario, administrators will learn how to create a new format using an example. This scenario shows how to create a dimension tolerance format as an example, but the procedure is the same for other formats (dimension value, line thickness, etc.). Specific differences are indicated in the course of this scenario.

You want to create this new dimension tolerance format, with superimposed tolerance values and parenthesis as separators.
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Select Tools -> Standards to launch the standards editor. Choose the Drafting category, and then open the ISO.xml file from the drop-down list. 1. Select the Tolerance Formats node in the editor.

2. Click on the Add Instance button. A format called TOLXXX is created. 3. Rename this format TOL_USER. 4. Customize the values as follows:
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• •

Make sure you set every parameter. You must use the symbol used by the computer system to set a parameter to a real value ("," or "."). Note: you can use a fraction to set a parameter.

5. Click OK to save the ISO.xml file and exit the standards editor. 6. Create a new ISO drawing. The new tolerance style will appear in the tolerance combo box.
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General Parameters

This section deals with general parameters. These let you control and restrict the values that are available for some element properties, by controlling the values in the Properties toolbar or in the element properties. Changing these values will not have an impact on already existing elements, since they control the user interface and not directly the drafting elements. Defining General Parameters General parameters are located in the General node of the Standards editor, available via Tools -> Standards.
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Lists allowed text fonts. Only the listed fonts will be available to users in the text Text Properties toolbar or via Edit -> Properties. Strings: list of font names, spelled exactly as they appear in the Text Properties toolbar or in Edit -> Properties blank = all installed fonts will be available

AllowedTextFonts

DefaultTextFont

Deprecated Now managed in Annotation Styles Lists allowed text font sizes (in mm). Only the listed sizes will be available to users in the Text Properties toolbar or via Edit -> Properties.

-

AllowedTextFontSizes

List of values in mm

Deprecated Now managed in Annotation Styles Specifies whether some annotations (roughness symbol, geometrical tolerance and balloon) should be migrated StandardUpdateMigration Yes/No when updating the standard of a drawing. Setting this parameter to Yes is recommended if you want to DefaultTextFontSize
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benefit, when applicable, from any new functionality implemented for such annotations since they were created on a previous release. Annotation customization will not be lost. Specifies the default color for: • The Sheet background: o The Working view color, graduated or not. o The Background view color, graduated or not. The Detail background: o The Working view color, graduated or not. o The Background view color, graduated or not.

• Sheet Colors

Specifies the default value for: • • • • The The The The Numerical Tolerance Values. Alphanumerical Tolerance Values. Bi-Alphanumerical Tolerance Values. Multiple Tolerance Values.

Tolerance Values

You can modify, add, remove or organize tolerance values. The check symbol indicates the default tolerance value.
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Parameter Name

Description Lists tolerance styles allowed on dimensions. Only the listed styles will be displayed and available to users through the Dimension Properties toolbar or via Edit -> Properties.

Value

List of strings AllowedToleranceFormats empty list = all defined tolerance styles are available
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DefaultToleranceFormat

Deprecated Now managed in Dimension Styles Lists value display styles allowed on dimensions. Only the listed styles will be available to users through the Dimension Properties toolbar or via Edit -> Properties.

-

AllowedNumericalFormats

Strings: list of Value Display styles, spelled exactly as they appear in the Dimension Properties toolbar or in Edit -> Properties empty list = all Value Display styles are available

DefaultNumericalFormatLength DefaultNumericalFormatAngle

Deprecated Now managed in Dimension Styles Deprecated Now managed in Dimension Styles

-

Dress-Up parameters

This section deals with dress-up parameters. These let you define the appearance of dress-up elements, such as markup arrows and threads.
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Parameter Name

Description

Value Circle

ThreadRepresentation

Specifies how threads should be represented.

ArcCircle
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Symbols Note that symbol parameters apply only to arrows, and not to leaders (annotation leaders, dimension leaders, etc.). If you want to modify dimension and annotation leader symbols, refer to the Dimension Parameters > Dimension and Annotation Leader Symbols section. Parameter Name Description Defines simple arrow length Value

SimpleArrow > Length

mm

Defines simple arrow angle

SimpleArrow > Angle

Degrees

Defines closed arrow length

ClosedArrow > Length

mm

ClosedArrow > Angle

Defines closed arrow angle

Degrees
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Defines filled arrow length

FilledArrow > Length

mm

Defines filled arrow angle

FilledArrow > Angle

Degrees

Defines symetric arrow length

SymetricArrow > Length

mm

SymetricArrow > Angle

Defines symetric arrow angle

Degrees
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Defines circle size

Circle > Diameter

mm

Defines filled circle size

FilledCircle > Diameter

mm

Defines symetric (crossed) circle size

SymetricCircle > Diameter

mm

CrossCircle > Diameter

Defines cross circle size

mm
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Defines slash size

Slash > Length

mm

Defines triangle size

Triangle > Length

mm

Defines filled triangle length

FilledTriangle > Length

mm

WhiteFilledSquare > Length

Defines white filled square length

mm
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Defines black filled square length

BlackFilledSquare > Length

mm

Defines plus length

Plus > Length

mm

Defines cross length

Cross > Length

mm

DoubleArrow > Length

Defines double arrow length

mm
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Defines double arrow angle

DoubleArrow > Angle

Degrees

Defines wave arrow size

WaveArrow > Diameter

mm
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Annotation Parameters

The annotation parameters are located in the Annotation node of the standard editor. They deal with the position of text leaders. Note: The parameters which allow you to customize annotation leader symbols are located in the Dimension node of the standard editor. The parameters located in the DressUp node let you customize the appearance of dress-up elements, such as markup arrows and threads.

These parameters depend on a given parent standard.

Annotation Texts Parameter Parent standard Parameter Name Value Description

Horizontal offset between the text and the leader extremity

ANSI only

Text > LeaderGap

(mm)

Vertical offset between the bottom of the text and the horizontal part of the leader

ISO and JIS only

Text > (mm) LeaderVertSpace

Roughness Symbols Parent Parameter standard Layout of the All roughness standards symbol

Parameter Name Roughness > Layout

Value

Description

Specifies whether a given field should be displayed (Authorized) Authorized / or hidden (Not authorized) in the Not authorized Roughness Symbol dialog box
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Horizontal offset between the ANSI Roughness > roughness only LeaderGap and the leader extremity Vertical offset between the bottom of ISO and Roughness > the JIS only LeaderVertSpace roughness and the horizontal part of the leader

(mm)

(mm)

Setting Dimension Parameters, Styles, and Tolerances
Dimension Parameters

The dimension parameters are located in the Dimension node of the standard file. They deal with t of annotation and dimension elements. • • • • • • • • • • • •

Dimension and Annotation Parameters Dimension and Annotation Leader Symbols Dimension Value Chamfer Dimension Parameters Half Dimensions Dimension Associated Texts Annotations Fake dimensions Dual Dimensions Cumulate Dimensions (Ordinate Dimensions): General Parameters Cumulate Dimensions: Parameters applying only if value orientation reference is Dimension (CUMLTxtReference = 1) Cumulate Dimensions: Parameters applying only if the value orientation reference is Extens
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• •

These parameters are global, which means that changing their value will have an impact on all elem drawing.

This section lists all the parameters which were contained in CATDrwStandard files up to V5 R9.

Dimension and Annotation Parameters Parameter International standard Value Description

Each user-defined standard is based on one o [ISO/ANSI/JIS] international standards: ISO, ANSI, JIS. This basic parameters.

[Yes/No] Dimension Line: Extension on radius dimensions (value Yes = till center inside circle), Reach center No = till value

[Yes/No] Dimension Line: Extension on radius dimensions (value Yes = till center outside circle), Reach center No = constant overrun Dimension Line: Extension on radius dimensions (value outside circle), Overrun length (mm)

[Yes/No] Dimension Line: Extension on one-symbol diameter dimensions (value inside Yes = till center circle), Reach center No = till value Dimension Line: Extension on one-symbol diameter dimensions (value inside circle), Overrun length (mm)

[Yes/No] Dimension Line: Extension on one-symbol diameter Yes = till center dimensions (value outside No = constant circle), Reach center overrun Dimension Line: Extension on one-symbol diameter dimensions (value outside 418 (mm)
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circle), Overrun length

Dimension Line: Display and extent (for non-flipped symbols), Overrun length

(mm)

[Yes/No] Dimension Line: Display and extent (for non-flipped symbols), Show Yes = displayed No = not displayed

Dimension Line: Display and extent (for flipped symbols), Overrun length

(mm)

[Yes/No] Dimension Line: Display and extent (for flipped symbols), Show Yes = displayed No = not displayed
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[2/1] Dimension Line: Length for one-symbol dimensions (distance and angle), Underline 2 = Length relative to value 1 = Constant length

The dimension line may either have a given le automatically adjust to reach the dimension v

if Dimension Line: Length for one-symbol dim (distance and angle), Underline = 1 Dimension Line: Length for one-symbol dimensions (distance and angle), Constant length

(mm)

Dimension Line: Gap around unframed value

(mm)

Dimension Line: Gap around framed value

(mm)

DEPRECATED

[2/3]

Old parameter DIMTYPos is deprecated

Dimension Value: Vertical justification

2 = center 3 = bottom

[No/Yes] Dimension tolerance: Multitolerance with associative numerical value No = not associative Yes = associative

Specifies whether the numerical definition of a tolerance is associative to the dimension valu case it is automatically updated when the dim is changed).
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Dimension and Annotation Leader Symbols Note that dimension and annotation leader symbols do not apply to arrows. If you want to mo parameters for arrows, refer to the Dress-up Parameters > Symbols section.

Parameter

Value

Descr

Dimension and Annotation Leader Symbols: Arrow size

(mm)

Dimension and Annotation Leader Symbols: Arrow angle

(degrees)

Dimension and Annotation Leader Symbols: Closed arrow size

(mm)

Dimension and Annotation Leader Symbols: Closed arrow angle

(degrees)

Dimension and Annotation Leader Symbols: Filled arrow size

(mm)
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Dimension and Annotation Leader Symbols: Filled arrow angle

(degrees)

Dimension and Annotation Leader Symbols: Symmetric arrow size

(mm)

Dimension and Annotation Leader Symbols: Symmetric arrow angle

(degrees)

Dimension and Annotation Leader Symbols: Slash size

(mm)

Dimension and Annotation Leader Symbols: Circle size

(mm)

Dimension and Annotation Leader Symbols: Filled circle size

(mm)
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Dimension and Annotation Leader Symbols: Scored circle size

(mm)

Dimension and Annotation Leader Symbols: Crossed circle size

(mm)

Dimension and Annotation Leader Symbols: Triangle size

(mm)

Dimension and Annotation Leader Symbols: Filled triangle size

(mm)

Dimension and Annotation Leader Symbols: Plus size

(mm)

Dimension and Annotation Leader Symbols: Cross size

(mm)

Dimension and Annotation Leader Symbols: Symbol reversal limit

(mm)
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Dimension Value Parameter Dimension Value: Underlining size, Left tail Dimension Value: Underlining size, Right tail (mm) Dimension Value: Underlining size, Vertical space Value Descripti

Chamfer Dimension Parameters Parameter Value

Descripti

Chamfer Dimension: Separator font height

(mm)

Chamfer Dimension: Value framing

[1/2] 1 = separately 2 = as a whole

Half-Dimensions Parameter Value [1/2/3 ] 1 = till Axis 2 = under value 3 = over axis Description

Half-Dimension: Dimension line extent (with value inside), Overrun mode
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Half-Dimension: Dimension line extent (with value inside), Overrun length

(mm)

if Half-Dimension: Dimension line exten inside), Overrun mode = 3

Dimension Associated Texts Parameter Dimension Associated Texts: Reference for positioning Before text Value 7 = top 8 = center 9 = bottom Descr

reference for
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Annotations Parameter Value [ No / Yes ] Annotation: Text angle No = 0 to 360 degrees Yes = -90 to 90 degrees Warning: parameter used only for roughness V5R12. Description

Annotation: Text leader size, Leader side Annotation: Text leader size, Opposite leader side Annotation: Text leader size, Vertical space

(mm) (mm)

(mm)

Annotation: Text leader size, Leader gap

(mm)

For compatibility with V4 Annotation: Text thickness (mm)

Warning: does not work on bold text (set at 0 complex text and roughness annotations.
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[1/2] Annotation: Datum feature leader representation mode 1 = Normal 2 = Flag

Fake dimensions Parameter Fake Dimension: Underline, Tail length Value

Description If Fake Dimension: Value display mo

Fake Dimension: Underline, Vertical offset

(mm)

Dual Dimensions Parameter Value Descr

Dual Dimension: Side-by-side dual display mode, Separator height

(mm)

Dual Dimension: Values above-one-another display mode, Above offset Dual Dimension: Values above-one-another display mode, Above space Dual Dimension: Values above-one-another display mode, Position reference

(mm) (mm) [1 / 2 / 3] 1 = top 2 = center 3 = bottom
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[1 / 2 / 3] Dual Dimension: Values above-one-another display mode, Justification 1 = left 2 = center 3 = right

Cumulate Dimensions (Ordinate Dimensions): General Parameters Table 1 Parameter Value Description

[1/3] Cumulate Dimension: Sign 1 = no sign display 3 = positive sign on all values

Cumulate Dimension: Origin symbol shape

[ 0 / ... / 13 ] 0 = none 1-13 = refer to "dimension line symbols" table

Cumulate Dimension: Origin symbol scale

(real)

Cumulate Dimension: Extension line display

[ Yes / No ] Yes = display No = no display
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Cumulate Dimension: Display of origin zero

[ Yes / No ] Yes = display No = no display

Cumulate Dimension: Value orientation reference

[1/2] 1 = dimension line 2 = extension line

Cumulate Dimension: Value orientation

[1/2/3] 1 = Parallel to Reference (specified by Cumulate Dimension: Value orientation reference) 2 = Perpendicular to Reference (specified by Cumulate Dimension: Value orientation reference) 3 = Angle to reference

Cumulate Dimension: Value orientation angle

(degrees)

if Cumulate Dimensio orientation=3
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Cumulate Dimensions: Parameters applying only if value orientation reference is "Dimension Line" Dimension: Value orientation reference = 1) Table 2

[ 2/3/4 ] 2 = Dimension Line to origin 3 = Length is relative to value text 4 = Length is constant

Cumulate Dimension: Dimension line length mode

[1/2] Cumulate Dimension: Value vertical 1 = Edge positioning, Justification 2 = Center

Deprecated

-

Old parameter was CUMLTxtDecalY. It is by the Value > OffsetY parameter availab Dimension Style.

If Dimension Line goes to origin (Cumulate Dimension: Dimension line length mode = 2):
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[1/2] Cumulate Dimension: Value 1 = Edge horizontal positioning, Justification 2 = Center

Cumulate Dimension: Value positioning reference

[1/2/3] 1 = Extension line 2 = Dim line center 3 = Origin

Cumulate Dimension: Value H/V positioning, Offset from orientation reference

(mm)

If Dimension Line is relative to value (Cumulate Dimension: Dimension line length mode = 3): [1/2] 1 = Edge 2 = Center

Cumulate Dimension: Value horizontal positioning, Justification

Cumulate Dimension: Value H/V positioning, Offset from orientation reference

(mm)

If Dimension Line has a constant length (Cumulate Dimension: Dimension line representation = 4):
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Cumulate Dimension: Dimension/Extension line length

(mm)

Cumulate Dimension: Value horizontal positioning, Justification

[1/2] 1 = Edge 2 = Center

Cumulate Dimension: Value positioning reference

[1/2/3] 1 = Extension line 2 = Dim line center 3 = Origin

Cumulate Dimension: Value H/V positioning, Offset from orientation reference

(mm)

Cumulate Dimensions: Parameters applying only if the value orientation reference is "Extension Lin Dimension: Value orientation reference = 2) Table 3
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Cumulate Dimension: Dimension line representation

[1/2/4] 1 = no display 2 = full display 4 = partial length

if Dimension Line has a partial leng (Cumulate Dimension: Dimension li representation=4)

Cumulate Dimension: Dimension line length

(mm)

433

InteractiveDrafting

[3/4] Cumulate Dimension: 3 = relative to text box Extension line length mode 4 = constant

If extension line is relative to value text (Cumulate Dimension: Extension line length mo

Cumulate Dimension: Extension line overrun

(mm)

Cumulate Dimension: Value [1/2] vertical positioning, 1 = Edge Justification 2 2 = Center

Cumulate Dimension: Value HV positioning, offset from orientation reference

(mm)

Cumulate Dimension: Value horizontal positioning, Justification

1 = Edge 2 = Center

[1/2]
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Deprecated

-

Old parameter was CUMLExtLTxtHP managed by the Value > OffsetX pa available for each Dimension Style

If extension line is constant (Cumulate Dimension: Extension line length mode = 4):

Cumulate Dimension: Dimension/Extension line length

(mm)

Cumulate Dimension: Value [1/2] vertical positioning, 1 = Edge Justification 2 2 = Center

[1/2/3] 1 = Dimension line 2 = Middle of extension line Cumulate Dimension: Value 3 = Extension line end point positioning reference (opposite to dimension line)

Cumulate Dimension: Value HV positioning, offset from orientation reference

(mm)

Cumulate Dimension: Value [1/2] horizontal positioning, 1 = Edge Justification 2 = Center
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Deprecated

(mm)

Old parameter was CUMLExtLTxtHP managed by the Value > OffsetX pa available for each Dimension Style.

Curvilinear Length Symbol Option Description

Display Symbol Specifies whether the curvilinear length symbol should be displayed. Height Indicates the height (in mm) of the curvilinear length symbol. Indicates the spacing (in mm) between the curvilinear length symbol and the di Spacing value. Underline value Specifies whether the dimension value should be underlined. Length Indicates the length (in mm) of the curvilinear length symbol. Minimum Indicates the minimum length (in mm) of the curvilinear length symbol. Length Minimum Indicates the maximum length (in mm) of the curvilinear length symbol. Length

Intersection Point Option Print intersection points

Point style Show construction lines Print construction lines

Description Specifies whether the intersection point should be printed. If you leave this optio then the intersection point will be a construction point and its style will be the de construction point style as defined in the Styles > Point > Default section of the you check this option, then the intersection point will not be a construction point can be chosen among the various point styles defined in the Styles > Point sectio standard. Indicates the style that should be used to represent the point (as defined in the S section of the standard). Specifies whether construction lines should be displayed.

Specifies whether construction lines should be printed. This option is available wh construction lines option is checked.
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Line style

Specifies the style that should be used to represent the construction line (as defi LineTypes section of the standard).

Dimension Tolerance Formats

Format Definitions This section deals with dimension tolerance descriptions, which are userdefined formats to be applied to dimension tolerances. To create a new tolerance format, you must use the Standards editor. Select the Tolerance Format type in the standards editor, and then click the Add Instance button to add a new instance of a format. This will create a sample format definition that you will then customize to suit your needs, by modifying one or several values of the parameters defining the format. Once defined, a format can be applied to dimensions just as any dimension attribute, either via Edit -> Properties, or using the Dimension Properties toolbar. Dimension Tolerance Formats These parameters are located in the Tolerance formats node of the standard file. The tolerance format parameters drive the representation of a dimension tolerance, and include parameters such as: • Type of tolerance (numerical/alphanumerical) • Separator between values • position relatively to dimension value • font size for tolerance • trailing zeros display for numerical type • and so forth. Parameter Name TolName Value (8 char string) Description User-defined name that will be used as the description identifier.

Parameter Tolerance Format Name
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Tolerance Format Type

Toltype

[1/2/3/4/5/ 6/7] 1 = Numerical side by side 2 = Numerical super-imposed 3 = Resolved Numerical side by side 4 = Resolved numerical superimposed 5 =Alphanumerical Single Value 6= Alphanumerical side by side 7= Alphanumerical super-imposed

Separators for superimposed After tolerances TolSepar_2

Before TolSepar_1

[0...18 ] separator number as described in the Separator Character Table

Separators for side-by- Between side TolSepTo_2 tolerances After TolSepTo_3

Before TolSepTo_1

[0...18 ] separator number as described in the Separator Character Table

Fraction line on superimposed tolerances

TolFractLine

[2/1] 2= Fraction line 1= No fraction line
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Separator Character Size (Ratio between Separator Character and Value Text font sizes) Tolerance Size (Ratio between Tolerance Text and Value Text font sizes) Tolerance Position Anchor Point (for offset computing)

TolSymbolH

(real) = separator height / value height (=B/A)

TolScale

(real) = tolerance height / value height (=C/A)

TolPtOnValue

[7/8/9] 7 =Top 8 = Middle 9 = Bottom [1/2/3] 1 =Top 2 = Middle 3 = Bottom

TolAnchorPt TolExtX

Offset between dimension value and tolerance

TolExtY

(mm)

TolIntX Offset between the 2 tolerance values

TolIntY

(mm)

439

InteractiveDrafting

[0/1/2] 0 = Display (number of digits specified in the value precision) 1 = No Display 2 = Same "display" mode as the dimension value

Display of tolerance trailing zeros

TolTrailing

Display of identical Tolerance Values ( for numerical tolerances only) Display of null Tolerance Values ( for numerical tolerances only)

[1/2] TolMergeSame 1 = Display common value 2 = Display separate values [1/2/3] 1 = Display null value with sign 2 = Display null value without sign 3 = No Display of null value

TolShowNull

Separator Character Table This table lists the characters that can be used as separators before, between or after the tolerance values. 04 05 06 07 08 09 10 11 12 ) " , < > X * . ;
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13 14 15 16 17

+ [ ] _

18 (space)

Separators Symbol # Character 00 01 02 03 (none) / : (

Dimension Value Formats

Format Definitions This section deals with dimension value descriptions, which are user-defined formats to be applied to dimension values. To create a new dimension value display format, you must use the Standards editor. Select the Value Formats type in the standards editor, and then click the Add Instance button to add a new instance of a format. This will create a sample format definition that you will then customize to suit your needs, by modifying one or several values of the parameters defining the format. Once defined, a format can be applied to dimensions just as any dimension attribute, either via Edit -> Properties, or using the Dimension Properties toolbar. Dimension Value Display Formats These parameters are located in the Value Formats node of the standard file. The dimension value display style parameters drive the representation of a dimension value, and include parameters such as: • multiplying factor • separators for thousands • position relatively to dimension line • display of fractional values • trailing zeros display • and so forth. 441
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Parameter Value Format Name Value Magnitude (type)

Parameter Name NDName

Value (8 char string) [1/2]

Description User-defined name that will be used as the description identifier

NDType

1 = length (for length/distance/radius/diameter dimensions) 2 = Angle (angle dimensions) [1/2/3/4/5] 1 2 3 4 5 = = = = = mm inch radian degree grade Unit used to display the dimension value

Value Units

NDUnit

The dimension measured value is multiplied by this factor prior to being displayed. Global Multiplying Factor For example, to display a distance in kilometers with units set to mm (NDUnit=1), use: NDGlobFact = 0.000001

NDGlobFact

(real)

Separator Characters for Decimal Decimal Separator and Thousands NDSepNum

Display of separator [1 / 2] 1 = No display of separator for Thousands 2 = Display of separator NDExise

[0...18 ] separator number as described in the Separator Character Thousands Table Separator NDSep1000
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Display of Trailing Zeros

[1 / 2] 1 = No display of trailing zeros NDFinZer 2 = Display of trailing zeros (number of digits specified in the value precision)

Fractional Rest NDAlignFrac Not yet implemented Justification

[1 / 2] Fractional 1 = Side by side Rest Display NDTypFrac 2 = Super-imposed Mode

Fractional Rest Height Ratio

NDResScl

(real) = Unit height / value height (=B/A)

Fractional Rest Positioning Offsets (the horizontal offset also applies to decimal rests)

NDRestX (real) This value is a ratio to the NDRestY character height

Offset between Fractional (real) Rest NDOperY This value is a ratio to the Numerator character height and Denominator
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Position of Last Term Unit

[1 / 2] NDSepDen 1 = Before fractional rest 2 = After fractional rest

Number of Terms in the Value

NDFact

[ 1...3 ]

Definition of each of the value terms A value can be made of up to three terms plus a rest. All of the following parameters, suffixed by the term number, apply to each of the possible 3 terms. The numbering of the terms goes from right to left, #1 being the right-most term.

Parameter

Parameter Name

Value [1 / 2] 1 = No display of zeros 2 = Display of zeros

Description

Display of Null Terms

NDNulFac_1
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Display of Leading Zeros in Last Factor

NDNulFac_2

[1 / 2] 1 = No display of zeros 2 = Display of zeros [1 / 2] 1 = No display of zeros 2 = Display of zeros The term measured value is multiplied by this factor prior to being displayed (the global multiplying factor is also used). All 3 values must have increasing and distinct values. ( real ) Example: to display a value with a term in centimeters and a term in millimeters, with NDUnit=mm and NDGlobFact=1, set NDFact_1 = 1 NDFact_2 = 10 -

DEPRECATED

NDNulFac_3

Display of Null Terms

NDNulOther

Term Multiplying Factor

NDFact_1 NDFact_2 NDFact_3

Term Unit Suffix

NDSepar_1 NDSepar_2 NDSepar_3

(16 char string)

Term Unit Height Ratio

NDSepScl_1 NDSepScl_2 NDSepScl_3

(real) = Unit height / value height (=B/A)
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Term Vertical Positioning Offset (relatively to the left-most term)

NDValPos_1 NDValPos_2 NDValPos_3

(mm)

Term Unit Vertical Positioning Offset (relatively to its term)

NDSepPos_1 NDSepPos_2 NDSepPos_3

(mm)

Dimension System Styles

This section deals with dimension system styles. These let you define the default values that will be used when creating different types of dimension systems. Defining Dimension System Styles Dimension system styles are located in the following nodes of the Standards editor, available via Tools -> Standards: • Styles -> Dimensions System

By default, a style called Default is available for each geometry style. All parameters are taken into account both at creation time (i.e. when creating a dimension system), and at modification time (i.e. when reapplying a style to a dimension system).
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Workbench Description Dimensions System Styles Parameter Name Description Specifies the dimension lines alignment mode for stacked dimension systems: • • Constant: the offset between dimensions of a system remain constant and equal to the value defined in the Offset between dimensions field. Free: the dimensions of a system can be moved independently.

Offset mode

Offset between dimensions

Specifies the distance between two consecutive dimension lines for stacked dimension systems. Specifies the dimension values alignment mode for cumulated dimension systems:

Aligned cumulated dimension values

• • •

Reference line Center Opposite

Values Offset

Specifies the distance between the alignment reference and the dimension value for cumulated dimension systems. Specifies the dimension values alignment mode for stacked dimension systems:

Aligned stacked dimension values

• • •

Reference line Center Opposite

Values Offset

Specifies the distance between the alignment reference and the dimension value for stacked dimension systems.

Pre-defined Formats for Tolerance and Dimension Values

Some basic formats are provided by default for dimension tolerance and value display. Some of these pre-defined formats can be modified while others cannot. All predefined formats can be de-activated (i.e. taken out of the list of available styles). Modifiable formats
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company defined style would appear. They can be modified or deleted using the Standards Editor, or de-activated (i.e. taken out of the list of available styles) using the Allowed* parameters described in the General Parameters section. For Tolerance styles TOL_RES1 For Value Display styles micron mm cm m km in ftinch grade

Non-modifiable formats They are not defined in the standard file, but in the code itself. They cannot be modified, but can be de-activated (i.e. taken out of the list of available styles) using the Allowed* parameters described in the General Parameters section. All styles provided up to V5R8 are of this type. For Tolerance styles For Value Display styles TOL_NUM2 ANS_NUM2 DIN_NUM2 SGL_NUM2 INC_NUM2 TOL_RES2 TOL_ALP1 TOL_ALP2 TOL_ALP3 TOL_0.7 TOL_1.0 ISONUM ISOALPH1 ISOALPH2 CPL_FLA1 CPL_FLA3 CPL_50A1 CPL_50A3 CPL_75A1 CPL_75A3 NUM.DIMM NUM,DIMM NUM.DINC NUM.DIMP ANS.DIMM DISTMM DISTINCH FEET-INC NUM.ADMS NUM,ADMS INC.ADMS NUM.ARAD ANGLEDEC ANGLEDMS

The following tables list these non-modifiable styles, along with an example of the result when applied on a dimension. The right-most column contains a link to the style definition, from which you can derive new formats, simply by copying all or part of their definition.
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Tolerance Formats Name Display Description Link to the style definition

TOL_NUM2

Numerical superimposed (small)

Click here

ANS_NUM2

Numerical superimposed with trailing zeros (large)

Click here

DIN_NUM2

Numerical superimposed (small)

Click here

SGL_NUM2

Numerical superimposed with trailing zeros and parentheses (small)

Click here

INC_NUM2

Numerical superimposed (large)

Click here

TOL_RES2

Numerical resolved

Click here

TOL_ALP1

Alphanumerical single value (large)

Click here
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TOL_ALP2

Alphanumerical double value side-by-side (large)

Click here

TOL_ALP3

Alphanumerical double value superimposed (small)

Click here

TOL_0.7

Numerical superimposed (small)

Click here

TOL_1.0

Numerical superimposed (small)

Click here

ISONUM

Numerical superimposed with trailing zeros and parentheses (large)

Click here

ISOALPH1

Alphanumerical single value (large)

Click here

ISOALPH2

Alphanumerical double value superimposed (small)

Click here
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CPL_FLA1

Alphanumerical single value (large)

Click here

CPL_FLA3

Alphanumerical double value superimposed (large)

Click here

CPL_50A1

Alphanumerical single value (small)

Click here

CPL_50A3

Alphanumerical double value superimposed (small)

Click here

CPL_75A1

Alphanumerical single value (medium)

Click here

CPL_75A3

Alphanumerical double value superimposed (medium)

Click here

Value Display Formats Name Display Description Link to the style definition
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NUM.DIMM

Millimeters with dot

Click here

NUM,DIMM

Millimeters with comma Click here

NUM.DINC

inches with trailing zeros Click here

NUM.DIMP

inches with unit display

Click here

ANS.DIMM

Millimeters with trailing zeros

Click here

DISTMM

Millimeters with dot

Click here

DISTINC

inches with unit display

Click here

FEET-INC

feet and inch with unit display

Click here
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NUM.ADMS

Degrees/minutes/seconds Click here with dot

NUM,ADMS

Degrees/minutes/seconds Click here with comma

INC.ADMS

Degrees/minutes/seconds Click here with dot and trailing zeros

NUM.ARAD

radians

Click here

ANGLEDEC

Degrees with decimal format

Click here

ANGLEDMS

Degrees/minutes/seconds Click here with dot

Pre-defined Styles Definition
This section lists pre-defined non-modifiable styles along with their definition. You can use these styles as a reference when defining new formats, simply by copying all or part of their definition.

TolName= TOL_NUM2 TolType= 2
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InteractiveDrafting TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 2 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 2 TolScale= 0.7

TolName= ANS_NUM2 TolType= 2 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 2 TolScale= 1.0

TolName= DIN_NUM2 TolType= 2 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 2 TolFractLine= 1 TolPtOnValue= 8 454

Workbench Description TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 3 TolScale= 0.7

TolName= SGL_NUM2 TolType= 2 TolSepar_1= 3 TolSepar_2= 4 TolSymbolH= 2.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 2 TolScale= 0.7

TolName= INC_NUM2 TolType= 2 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 2 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 1 TolScale= 1.0
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TolName= TOL_RES2 TolType= 4 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 2 TolFractLine= 1 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.0 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 2 TolScale= 1.0

TolName= TOL_ALP1 TolType= 5 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 0 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.0 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 1.0

TolName= TOL_ALP2 TolType= 6 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 1 456

Workbench Description TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 0 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.6 TolIntY= 0.0 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 1.0

TolName= TOL_ALP3 TolType= 7 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.6 TolExtX= 0.6 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 0.7

TolName= TOL_0.7 TolType= 2 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 2 TolFractLine= 1 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.250000 TolExtX= 0.5 TolExtY= 0.0 457

InteractiveDrafting TolMergeSame= 1 TolShowNull= 3 TolScale= 0.715000

TolName= TOL_1.0 TolType= 2 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 2 TolFractLine= 1 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.5 TolExtX= 0.5 TolExtY= 0.0 TolMergeSame= 1 TolShowNull= 2 TolScale= 1.0

TolName= ISONUM TolType= 2 TolSepar_1= 3 TolSepar_2= 4 TolSymbolH= 2.5 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.5 TolExtX= -0.5 TolExtY= 0.0 TolMergeSame= 2 TolShowNull= 2 TolScale= 1.0

TolName= ISOALPH1 TolType= 5 TolSepar_1= 0 458

Workbench Description TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 0 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.5 TolExtX= 0.5 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 1.0

TolName= ISOALPH2 TolType= 7 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.250000 TolExtX= 0.5 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 0.715000

TolName= CPL_FLA1 TolType= 5 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 25.4 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 0 TolPtOnValue= 9 TolAnchorPt= 3 459

InteractiveDrafting TolIntX= 0.0 TolIntY= 0.0 TolExtX= 0.285714 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 1.0

TolName= CPL_FLA3 TolType= 7 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.5 TolExtX= 0.285714 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 1.0

TolName= CPL_50A1 TolType= 5 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 25.4 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 0 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.0 TolExtX= 0.214286 TolExtY= 0.250000 TolMergeSame= 0 TolShowNull= 0 TolScale= 0.5
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TolName= CPL_50A3 TolType= 7 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 1.0 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.250000 TolExtX= 0.214286 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 0.5

TolName= CPL_75A1 TolType= 5 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 25.4 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 TolTrailing= 0 TolFractLine= 0 TolPtOnValue= 9 TolAnchorPt= 3 TolIntX= 0.0 TolIntY= 0.0 TolExtX= 0.250000 TolExtY= 0.125000 TolMergeSame= 0 TolShowNull= 0 TolScale= 0.750000

TolName= CPL_75A3 TolType= 7 TolSepar_1= 0 TolSepar_2= 0 TolSymbolH= 25.4 TolSepTo_1= 0 TolSepTo_2= 0 TolSepTo_3= 0 461

InteractiveDrafting TolTrailing= 0 TolFractLine= 1 TolPtOnValue= 8 TolAnchorPt= 2 TolIntX= 0.0 TolIntY= 0.375000 TolExtX= 0.250000 TolExtY= 0.0 TolMergeSame= 0 TolShowNull= 0 TolScale= 0.750000

NDName= NUM.DIMM NDType= 1 NDUnit= 1 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5

NDName= NUM,DIMM NDType= 1 NDUnit= 1 462

Workbench Description NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 6 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5

NDName= NUM.DINC NDType= 1 NDUnit= 2 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 1 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 463

InteractiveDrafting NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 2 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 2 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5

NDName= NUM.DIMP NDType= 1 NDUnit= 2 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 12.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= ' NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 1.0 NDSepScl_3= 0.0 NDSepPos_1= 0.2 NDSepPos_2= 0.2 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 2 NDResScl= 1.0 NDFact= 2 NDRestX= 0.5

NDName= ANS.DIMM 464

Workbench Description NDType= 1 NDUnit= 1 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 2 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 2 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5

NDName= DISTMM NDType= 1 NDUnit= 1 NDGlobFact= 1.0 NDNulFac_1= 2 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 465

InteractiveDrafting NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5

NDName= DISTINC NDType= 1 NDUnit= 2 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5
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NDName= FEET-INC NDType= 1 NDUnit= 2 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 1 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 12.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= ' NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 1.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 1 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 2 NDRestX= 0.5

NDName= NUM.ADMS NDType= 2 NDUnit= 4 NDGlobFact= 1.0 NDNulFac_1= 2 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1/3600 NDFact_2= 1/60 NDFact_3= 1.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= ' 467

InteractiveDrafting NDSepar_3= deg NDSepScl_1= 1.0 NDSepScl_2= 1.0 NDSepScl_3= 1.0 NDSepPos_1= 0.2 NDSepPos_2= 0.2 NDSepPos_3= 0.2 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 3 NDRestX= 0.5

NDName= NUM,ADMS NDType= 2 NDUnit= 4 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1/3600 NDFact_2= 1/60 NDFact_3= 1.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= ' NDSepar_3= deg NDSepScl_1= 1.0 NDSepScl_2= 1.0 NDSepScl_3= 1.0 NDSepPos_1= 0.2 NDSepPos_2= 0.2 NDSepPos_3= 0.2 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 6 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 3 NDRestX= 0.5 468
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NDName= INC.ADMS NDType= 2 NDUnit= 4 NDGlobFact= 1.0 NDNulFac_1= 1 NDNulFac_2= 1 NDExise= 1 NDSep1000= 0 NDFact_1= 1/3600 NDFact_2= 1/60 NDFact_3= 1.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= ' NDSepar_3= deg NDSepScl_1= 1.0 NDSepScl_2= 1.0 NDSepScl_3= 1.0 NDSepPos_1= 0.2 NDSepPos_2= 0.2 NDSepPos_3= 0.2 NDRestY= 0.0 NDFinZer= 2 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 2 NDResScl= 1.0 NDFact= 3 NDRestX= 0.5

NDName= NUM.ARAD NDType= 2 NDUnit= 3 NDGlobFact= 1.0 NDNulFac_1= 2 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 469

InteractiveDrafting NDSepar_1= NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 1 NDRestX= 0.5

NDName= ANGLEDEC NDType= 2 NDUnit= 4 NDGlobFact= 1.0 NDNulFac_1= 2 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1.0 NDFact_2= 0.0 NDFact_3= 0.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= deg NDSepar_2= NDSepar_3= NDSepScl_1= 1.0 NDSepScl_2= 0.0 NDSepScl_3= 0.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 470

Workbench Description NDFact= 1 NDRestX= 0.5

NDName= ANGLEDMS NDType= 2 NDUnit= 4 NDGlobFact= 1.0 NDNulFac_1= 2 NDNulFac_2= 2 NDExise= 1 NDSep1000= 0 NDFact_1= 1/3600 NDFact_2= 1/60 NDFact_3= 1.0 NDValPos_1= 0.0 NDValPos_2= 0.0 NDValPos_3= 0.0 NDSepar_1= " NDSepar_2= ' NDSepar_3= deg NDSepScl_1= 1.0 NDSepScl_2= 1.0 NDSepScl_3= 1.0 NDSepPos_1= 0.0 NDSepPos_2= 0.0 NDSepPos_3= 0.0 NDRestY= 0.0 NDFinZer= 1 NDSepNum= 11 NDTypFrac= 2 NDSepDen= 2 NDOperY= 0.5 NDNulOther= 1 NDResScl= 1.0 NDFact= 3 NDRestX= 0.5

Frame Definition
This section deals with fixed-size frame definition. A frame is a property which can be applied to texts as well as certain types of annotations and dress up elements. Defining Frames Fixed-size frame definitions are located in the Frame node of the Standards editor, available via Tools -> Standards. They specify the geometrical definition of fixed-size frames (as opposed to variable-size frame).
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Frame definitions available in the Standards editor are pre-defined, and their number is fixed. You cannot add additional instances of frame definitions. You can customize these definitions to suit your needs, by modifying one or several values of the parameters defining the style. Once defined, a fixed-size frame can be applied to any element which supports it, either via Edit -> Properties, or using the Text Properties toolbar. The fixed-size frame definitions include the following parameters: • Name: identifies the frame - DO NOT EDIT • Type: defines the geometrical type of the frame - DO NOT EDIT • Behavior - DO NOT EDIT • Length • Height • Radius • Offset • Vertical Margin - NOT YET IMPLEMENTED • Horizontal Margin - NOT YET IMPLEMENTED

• • •

The Name, Type and Behavior parameters MUST NOT BE EDITED, and are listed for information and compliance purposes only. The Vertical Margin and Horizontal Margin parameters are not implemented yet, and are listed for compliance purposes only. For each frame definition, all parameters are listed. However, depending on the frame type, not all parameters are used to define the frame, but only some of them.

Parameter

LengthHeight Radius Offset

Description

Rectangle

Yes

Yes

N/A

N/A

Square

Yes

N/A

N/A

N/A
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Circle

N/A

N/A

Yes

N/A

ScoredCircle

N/A

N/A

Yes

N/A

Diamond

Yes

N/A

N/A

N/A

Triangle

Yes

Yes

N/A

N/A

RightFlag

Yes

Yes

N/A

Yes

LeftFlag

Yes

Yes

N/A

Yes
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BothFlag

Yes

Yes

N/A

Yes

Oblong

Yes

Yes

N/A

N/A

Ellipse

Yes

Yes

N/A

N/A

RightOblong

Yes

Yes

N/A

N/A

LeftOblong

Yes

Yes

N/A

N/A

Sticking

N/A

N/A

Yes

N/A
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Set

N/A

N/A

Yes

Yes

Fixed support

N/A

N/A

Yes

N/A

Nota

Yes

Yes

N/A

N/A

SymPart

N/A

N/A

Yes

N/A

SymSet

N/A

N/A

Yes

Yes

ScoredRectangle

Yes

Yes

N/A

N/A

475

InteractiveDrafting

Parallelogram

Yes

Yes

N/A

Yes

View Generation Definition
This section deals with view generation definition. This lets you customize settings that should be applied when generating views in a Generative Drafting context. Defining View Generation Parameters The view generation definition parameters are located in the View -> Generation node of the Standards editor, available via Tools -> Standards. There are two parameters: • ThicknessIndex: this parameter lets you customize the line thickness for geometry which is automatically generated in views (this includes all geometry except fillet edges). Specify the number of the line thickness definition parameter, as specified in the Line Thickness node of the Standards editor. For more information, refer to Line Thickness Definition.
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•

MaterialCutPattern: this parameter is used when generating views from parts which use a material to which a specific pattern is associated. o Select Material to use the pattern associated to a given material (instead of the patterns defined in the standards), even if this pattern is not defined in the standards. o Select Standard to use standard patterns only, instead of the pattern associated to a given material. Refer to Pattern Definition for more information on defining standard patterns.

Line Thickness Definition
This section deals with line thickness definition. Line thickness is a property which can be applied to, and drives the representation of, almost all elements in a drawing, such as lines, curves, dimension lines, etc. (Line thickness cannot be applied to fonts
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•

•

In releases up to V5 R9 SP2, line thickness used to be defined in Tools -> Options -> General -> Display -> Thickness & Font for the Drafting workbench as well as for other workbenches. For Drafting, line thickness is now defined in standards. Therefore, line thickness in drawings does not depend on the options defined in Tools -> Options, but on what is defined in the standards. When opening a drawing created with releases up to V5 R9 SP2 (i.e. a drawing which does not contain its own line thickness parameters), the line thickness options defined in Tools -> Options will be used. You can upgrade a CATDrawing document to this new standard format at any time, by performing the following operations in File -> Page Setup: - changing the standard to another standard (ISO -> ANSI for instance) - updating the current standard to the new format.

The information below is specifically intended for administrators customizing standards for the 2D Layout for 3D Design workbench: • When displaying line thicknesses in the 2D Layout for 3D Design window: the line thicknesses which are used are those defined in standards. This is the case of all elements displayed in the 2D or 3D background of a view in the 2D Layout for 3D Design window, whether they are: o layout elements (geometry, annotations and so on), o 3D wireframe elements (lines, points and so on). When displaying line thicknesses in the 3D window (Part Design, for example): the line thicknesses which are used are those defined in the settings (through Tools -> Options -> General -> Display -> Thickness & Font). This is the case of all layout elements (geometry, annotations and so on), when displayed in the 3D window. When printing a layout: the line thicknesses which are used are those defined in standards. When editing part layouts in the context of a product: the line thicknesses which are used are those defined in the standards of the current layout (even when visualizing elements which belong to another layout). For example, take the following scenario, where: o the layout of Part.1 uses ISO_3D o the layout of Part.2 uses JIS_3D o the line thickness definitions are different in ISO_3D and JIS_3D. In this case, when visualizing Part.2 in the background of the Part.1 layout, Part.2 will be displayed using the line thickness definitions of Part.1. Therefore, if you want the visualization of elements to be homogeneous in the 2D and 3D windows, you need to make sure that line thickness definitions in the standards match line thickness definitions in the settings. Defining Line Thickness Line thickness definitions are located in the Line Thickness node of the Standards

•

• •
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Workbench Description editor, available via Tools -> Standards. There are 55 line thickness definitions in the Standards editor. You cannot add additional instances of line thickness definitions. Out of these 55 definitions, • • line thickness definitions ranging from 1 to 8 are pre-defined with different parameters for each, and available. line thickness definitions ranging from 9 to 55 are pre-defined with the same parameters for all, and unavailable.

You can customize these definitions to suit your needs, by modifying one or several values of the parameters defining the style. Once defined, a thickness can be applied to any element which supports it, either via Edit -> Properties, or using the Graphic Properties toolbar.

Parameter

Description Indicates whether this definition is available for users to choose from: 1 = available 0 = unavailable. Specifies the size in pixels, with a maximum of 16; reflects the result displayed on screen. Specifies the size in millimeters; corresponds to the printed version.

Availability

Pixels mm

The Availability parameter specifies whether or not a given line thickness should be available in the thickness list for users to choose from, when creating or editing elements. Users will only be able to assign "available" line thickness definitions to these elements. However, existing element properties in drawings will not be affected: if an existing element is assigned a line thickness which is flagged as "unavailable" in the Standards editor, then this line thickness will be used for this element but it will not be available in the thickness list, so that users cannot apply it to other elements.

Line Type Definition
This section deals with line type definition. Line types can be applied to, and drive the representation of, almost all elements in a drawing, such as lines, curves, dimension lines, etc. (Line types cannot be applied to fonts and points).

•

In releases before V5 R11, line types used to be defined in Tools -> Options > General -> Display -> Line Types for the Drafting workbench as well as for other workbenches. For Drafting, line types are now defined in standards.
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InteractiveDrafting Therefore, line types in drawings do not depend on the options defined in Tools -> Options, but on what is defined in the standards. When opening a drawing created with releases before V5 R11 (i.e. a drawing which does not contain its own line type parameters), the line type options defined in Tools -> Options will be used. You can upgrade a CATDrawing document to this new standard format at any time, by performing the following operations in File -> Page Setup: - changing the standard to another standard (ISO -> ANSI for instance) - updating the current standard to the new format.

•

The information below is specifically intended for administrators customizing standards for the 2D Layout for 3D Design workbench: • When displaying line types in the 2D Layout for 3D Design window: the line types which are used are those defined in standards. This is the case of all elements displayed in the 2D or 3D background of a view in the 2D Layout for 3D Design window, whether they are: o layout elements (geometry, annotations and so on), o 3D wireframe elements (lines, points and so on). When displaying line types in the 3D window (Part Design, for example): the line types which are used are those defined in the settings (through Tools -> Options -> General -> Display -> Line Types). This is the case of all layout elements (geometry, annotations and so on), when displayed in the 3D window. When printing a layout: the line types which are used are those defined in standards. When editing part layouts in the context of a product: the line types which are used are those defined in the standards of the current layout (even when visualizing elements which belong to another layout). For example, take the following scenario, where: o the layout of Part.1 uses ISO_3D o the layout of Part.2 uses JIS_3D o the line type definitions are different in ISO_3D and JIS_3D. In this case, when visualizing Part.2 in the background of the Part.1 layout, Part.2 will be displayed using the line type definitions of Part.1. Therefore, if you want the visualization of elements to be homogeneous in the 2D and 3D windows, you need to make sure that line type definitions in the standards match line type definitions in the settings. Defining Line Types Line type definitions are located in the Line Types node of the Standards editor, available via Tools -> Standards. Line types can either be mono-dimensional, i.e. defined by a sequence of non-continuous segments, or bi-dimensional, i.e. defined by a polyline. Once defined, a line type can be applied to any element which supports it, either via Edit -> Properties, or using the Graphic Properties toolbar. There are 63 line type definitions in the Standards editor. You cannot add additional instances of line type definitions. Out of these 63 definitions,

•

• •
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• • •

line type definitions ranging from 1 to 8 are pre-defined with different parameters for each and cannot be customized. line type definitions ranging from 9 to 19 are pre-defined with different parameters for each and can be customized. line type definitions ranging from 20 to 63 are not pre-defined and can be customized.

Note that it is impossible to assign line types greater than line type 7 to spline geometry, and greater than line type 8 to circle geometry. You can customize the definitions of line types ranging from 9 to 63. To do this, proceed as follows: 1. Click on the Line Types node of the Standards editor.

2. In the right-hand panel, double-click on the line type you want to define. The line type editor appears for you to set the line type properties. For more information on using the line type editor, refer to Line Type in the Infrastructure User's Guide. 3. For each line type definition, you can also specify whether or not a given line type should be available in the line types list for users to choose from. In the right-hand panel, double-click on the number of the line type you want to make unavailable. Perform the same operation to make an unavailable line type available. Users will only be able to assign "available" line type definitions when creating or editing elements. However, existing element properties in drawings will not be affected: if an existing element is assigned a line type which is flagged as "unavailable" in the Standards editor, then this line type will be used for this element but it will not be available in the line types list, so that users cannot apply it to other elements.

Pattern Definition
This section deals with pattern definition. Patterns are used for area fills or in a Generative Drafting context when cutting through material in section views/cuts or breakout views, for example. Defining Patterns Pattern definitions are located in the Patterns node of the Standards editor, available via Tools -> Standards. There are a number of pre-defined pattern definitions available in the Standards editor. You can customize these definitions to suit your needs, by modifying one or
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InteractiveDrafting several values of the parameters defining the pattern. You can also add additional instances of pattern definitions. To create a new pattern definition, you must use the Standards editor. Select the Patterns type in the standards editor, and then click the Add Instance button to add a new pattern instance. This will create a sample pattern definition that you will then customize to suit your needs, by modifying one or several values of the parameters defining the pattern. Once defined or customized, a pattern can be applied to area fills (either via Edit -> Properties, or using the Graphic Properties toolbar), or it can be used when cutting through material in generative section views/cuts or breakout views, for example. General remarks about patterns • If no pattern is defined in the standard XML file (i.e. if all instances of pattern definitions are removed from the standards editor), the software will automatically use its own selection of patterns. In this case, you will be able to edit all the properties of these patterns via Edit -> Properties or the Graphic Properties toolbar. • You need to define at least one pattern for each type of pattern (hatching, dotting, coloring, image) if you want this specific pattern type to be available from Edit -> Properties or from the Graphic Properties toolbar. • If you modify the standard of a drawing which already includes patterns (in area fills, sections or breakouts, for example), existing patterns will not changed, even when updating the drawing. However, if you create new area fills or if you create section views/cuts or breakout views from new parts in this drawing, the newly-defined patterns will be used. • Some parts may use a material to which a specific pattern is associated. In this case, you can either choose to use the pattern associated to this material (instead of the patterns defined in the standards) even if this pattern is not defined in the standards, or you can choose to use standard patterns only, instead of the pattern associated to this material. Refer to View Generation Definition for more information. • When editing the properties of a pattern associated with a part material (via Edit -> Properties or the Graphic Properties toolbar), the software offers its own selection of patterns, and not the patterns defined in the standard XML file. • With hatching or dotting patterns, the spacing between each hatch or dot is sometimes larger than the area to fill. This makes it impossible to display the pattern properly. In such a case, the area fill contour is made bold and is turned into the same color as the pattern color. This enables you to identify items with area fills even if the pattern is not visible. The figures below illustrate what the sketched element will look like in such a case. • Hatching patterns are a combination of the angle and hatching lists available in the standard XML file: newly created patterns are based on the first hatching standard referencing successively the four values of the angle list, then the second hatching standard referencing successively the four values of the angle list, and so on, and so forth.

Specific remarks about Image patterns • It is recommended that you place images that you want to use for the
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Workbench Description Image pattern in either one (or in both) of the directories set by the following variables: - CATStartupPath (images used by materials) - CATGraphicPath (images and icons). Make sure you do not remove the files which are present in these directories when placing your images there. For more information on the CATStartupPath and on the CATGraphicPath variables, refer to the Infrastructure Installation Guide. Make sure that images referenced in the standard XML file are present on the computer of each user who will use this standard. Once an Image pattern is used in a drawing, the corresponding file is embedded inside it. You do not need to export the image files used in a given drawing. Images used as patterns must be bitmap images (not vector).

• • •

Parameter

Parameter Name

Description

Specifies whether users can modify all or only some pattern properties via Edit -> Properties. If Yes, all pattern properties can be modified in the Properties dialog box. If No: only some pattern properties will be available from the Properties dialog box, namely: EditAvailabilityEditAvailability - Hatching: users can only modify the angle, the pitch and the offset, and choose a new pattern. - Dotting: users can modify all properties. - Coloring: users can modify all properties. - Image: users can only use the images defined in the standards. They can modify the image angle and scale. Specifies preferred angle values that will be used when creating section views/cuts or AngleList Angle breakout views. These values will be available via Edit -> Properties. Name Specifies the name of this pattern. hatching Shows the current pattern type, in this case, Type hatching. Defines the number of different hatchings to use in this pattern. A tab will be created for Number of Hatching each hatching, to let you define each one individually. For each hatching used in this pattern, Angle specifies the angle value in degrees. For each hatching used in this pattern, Pitch specifies the pitch in millimeters. For each hatching used in this pattern, Offset specifies the offset in millimeters.
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Color Linetype Thickness Preview Name Type dotting Pitch Color Zigzag Preview Name Type Color Preview Name Type image Browse button Angle Scale Preview

coloring

For each hatching used in this pattern, specifies the color. For each hatching used in this pattern, specifies the linetype. For each hatching used in this pattern, specifies the linetype thickness. Lets you preview the resulting hatching pattern. Specifies the name of this pattern. Shows the current pattern type, in this case, dotting. Specifies the dotting pitch in millimeters. Specifies the dotting color. Specifies whether dotting should zigzag. Lets you preview the resulting dotting pattern. Specifies the name of this pattern. Shows the current pattern type, in this case, coloring. Specifies the color. Lets you preview the resulting coloring pattern. Specifies the name of this pattern. Shows the current pattern type, in this case, image. Lets you select the image to use for this pattern. Refer to Specific remarks about Image patterns for more information. Specifies the angle value in degrees. Specifies the scale. Lets you preview the original image (not the result after modifying the angle and scale).

Sheet Format Definition
This section deals with sheet format definition.
Defining Sheet Formats

Sheet format definitions are located in the Sheet Formats node of the Standards editor, available via Tools -> Standards, according to specified normalized standards such as ISO, ASME, etc. The list of available sheet formats can be extended, reduced or modified by the administrator. For a specific sheet format, you can:
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• • • •

Change its name. Modify the orientation width. Modify the orientation height. Modify the orientation type: o PortraitByDefault: Portrait will be the default orientation, but Landscape will be available. o LandscapeByDefault: Landscape will be the default orientation, but Portrait will be available. o PortraitOnly: Portrait will be the only available orientation. Landscape will not be available. o LandscapeOnly: Landscape will be the only available orientation. Portrait will not be available.

A sheet format is referenced by a sheet style. For more information, refer to Sheet Styles. 1. Click on the Sheet Formats node of the Standards editor. You can create or delete a sheet format from this node only.

Note that sheet formats are not listed in alphabetical order. However, in the New Drawing or Page Setup dialog box, they will be listed alphabetically. 2. For instance, click on the A0 ISO node and modify the desired parameters as needed.

Setting Standard Styles
Setting Standard Styles
The Interactive Drafting workbench lets administrators set standard styles that will be used as default values when creating new elements. About styles: Learn more about style management. Sheet styles: Define the styles that will be used by default when creating sheets. Geometry styles: Define the styles that will be used by default when creating geometry. Annotation styles: Define the styles that will be used by default when creating annotations.
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Dimension styles: Define the styles that will be used by default when creating dimensions. Dimension System Styles: Define the styles that will be used by default when creating dimension systems. Dress-up and dress-up symbols styles: Define the styles that will be used by default when using dress-up elements or dress-up symbols. View callout styles: Define the styles that will be used by default when using callouts.

About Styles
Setting default values for elements using styles

Styles enable administrators to set the default values that will be applied to all properties of such elements as sheets, geometry, annotations, dimensions, dress-up and dress-up symbols, callouts, etc. The default values are defined and stored in the standard XML file, where a set of new parameters are defined, one parameter for each element property whose default value can be set. Default values are applied to elements as they are created. After creation, the user can modify element values as required. If you modify styles in the standard itself and then update the standard file used by the drawing, the elements which have already been created will NOT be modified (i.e. their default values will remain as previously). Updating the standard will only have an impact on the next elements to be created.

Styles replace the former management of default values (which was performed using the Set as Default / Use Default functionalities), for drawings: • • created with version V5 R11 and later created with versions up to V5 R10, whose standard has been updated in V5 R11

For drawings created with versions up to V5 R10 and NOT updated, default values still use the Set as Default / Use Default functionalities. For more information, refer to Setting Properties As Default and Using Properties Set as Default.
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Defining default values

The default values for all element properties are stored in a specific Styles section of the standard XML file, and are defined by the administrator. Styles are defined for all Drafting element types. By default, one style named Default is predefined in the standard files for each type of element. In this Default style, all element properties are pre-defined, enabling the administrator to set the value for this property. This Default style cannot be renamed. You can create your own styles (based on existing styles), as well as delete styles (providing there remains at least one style for each type of element).
Using default values

When creating a Drafting element, default values are automatically used. So, when users select a command that creates a specific type of element, the Style toolbar displays the current style for this type: • • If only one style is defined for this type of element, then this style is displayed in the toolbar. If several styles are defined for this type of element, then a style is defined as the current style and is displayed in the toolbar. Users can use the toolbar to select another style of the same type before creating the element.

The toolbar reflects the value of the style, but users can always modify the value of specific elements.
Re-applying a style to an object

When a Drafting element is selected, the Style toolbar displays the list of the styles that can be applied to it. If the user selects one of these, this style is re-applied to the element. This enables users to reset to its default values an element whose properties have been modified.
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Customizing Styles

In this scenario, administrators will learn how to customize styles. This scenario provides an example of style customization. The procedure differs when customizing standard parameters (dimensions, annotations, dress-up elements, etc.). For more information, refer to About Standard Parameters. Note that a new style is always based on an existing style.

You want to create a new text style that you will use for adding notes. You want to use the Verdana font, and you want a frame around the text. You then want to delete the Default style.

Select Tools -> Standards to launch the standards editor. Choose the Drafting category, and then open the ISO.xml file from the drop-down list. 1. Expand the Styles node in the editor. 2. Select the Text node. 3. Click on the Create style button in the right-hand pane. The Create style dialog box is displayed. 4. Type the name of the new style in the appropriate field.

The Duplicated from list is used when several styles exist for a given type of element to specify which existing style the new style should be based on. In our example, only the Default style exists. Therefore, the new style will be created based on this Default style. You cannot create styles containing characters such as < > . / : ; " ' \ | as well as spaces at the beginning and/or at the end of the style's name. 5. Click OK. A new style called Note is added under the Text node in the
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6. Expand the Note -> Font node in the editor, and then select the Name node. 7. Type Verdana in the Name field in the right-hand pane.

8. Expand the Text node in the editor, and then select the Frame node. 9. Choose Rectangle from the Frame drop-down list in the right-hand pane.

10. Click OK to save your modifications and exit the standards editor. 11. Now, start creating a new text in a sheet. In the Style toolbar, you can notice that two styles are now available: Default and Note.

11. Choose the Note style, click on the sheet to indicate where you want to position the note, type your note in the text editor and then click OK. The note is creating using the values you specified.
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12. You will now delete the Default style. To do this, launch the standards editor again. 13. Expand the Styles node and then select the Text node. 14. Click on the Delete style button in the right-hand pane. The Delete style dialog box is displayed.

15. Select Default as the style that you want to delete, and click OK. The Default style is deleted from the Text node in the editor.

Sheet Styles
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Defining Sheet Styles

Sheet styles are located in the Styles -> Sheet node of the Standards editor, available via Tools -> Standards. By default, a sheet style called Default is available. All the parameters associated to a given sheet style are listed in the table below. The Description column provides a description of each parameter.

Parameter Name

Description Real number that specifies the global scale that should be applied to the sheet. For example, if you want a global scale of 1:2, you should enter 0.5 and if you want a global scale of 1:1, you should enter 1. Specifies whether projection views should be created using the first angle standard, or the third angle standard. Choose a projection method from the list. Specifies the sheet format defined in the Standard editor and the corresponding paper size that should be applied to the sheet. Specifies the orientation that should be applied to the sheet, that is portrait or landscape. Specifies whether the frame representing the format of the sheet is displayed.

GlobalScale

ProjectionMethod

Format

Orientation DisplayFormat

Specifies whether generative views should be positioned according to the center of gravity of the 3D geometry (which ensures that the center of gravity of the 3D geometry remains at a fixed position at update), or GenViewsPosMode according to the 3D axis system (which ensures that the projection of the 3D axis remains at a fixed position at update, even if the center of gravity of the 3D geometry has changed).

Geometry Styles
This section deals with geometry styles. These let you define the default values that will be used when creating geometry.
Defining Geometry Styles

Geometry styles are located in the following nodes of the Standards editor, 491

InteractiveDrafting available via Tools -> Standards: • • • • Styles Styles Styles Styles -> -> -> -> ConstructionPoint ConstructionCurve Point Curve

By default, a style called Default is available for each geometry style. All the parameters associated to a given geometry style are listed in a dedicated table. The Description column provides a description of each parameter. All parameters are taken into account both at creation time (i.e. when creating a geometrical element), and at modification time (i.e. when reapplying a style to a geometrical element). ConstructionPoint Style Parameter Name Color PointType Description Specifies the color that should be used to represent construction points. Specifies the type (e.g., cross, dot, etc.) that should be used to represent construction points.

ConstructionCurve Style Parameter Name Color Description Specifies the color that should be used to represent construction curves. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent construction curves. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent construction curves. Specifies the color that should be used to represent control points in construction curves. Specifies the type (e.g., cross, dot, etc.) that should be used to represent control points in construction curves.

LineType

Thickness ControlPoints > Color ControlPoints > PointType
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Workbench Description Point Style Parameter Name Color PointType Description Specifies the color that should be used to represent points. Specifies the type (e.g., cross, dot, etc.) that should be used to represent points.

Curve Style Parameter Name Color Description Specifies the color that should be used to represent curves. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent curves. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent curves. Specifies the color that should be used to represent control points in curves. Specifies the type (e.g., cross, dot, etc.) that should be used to represent control points in curves.

LineType

Thickness ControlPoints > Color ControlPoints > PointType

Annotation Styles
This section deals with annotation styles. These let you define the default values that will be used when creating annotations.
Defining Annotation Styles

Annotation styles are located in the following nodes of the Standards editor, available via Tools -> Standards: • • • • • • • • Styles Styles Styles Styles Styles Styles Styles Styles -> -> -> -> -> -> -> -> Text Table DatumFeature DatumTarget Tolerance Balloon RoughnessSymbol WeldingSymbol

By default, a style called Default is available for each geometry style.
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All the parameters associated to a given annotation style are listed in a dedicated table. The Description column provides a description of each parameter. Certain parameters are only taken into account at creation time (i.e. when creating the annotation), and not at modification time (i.e. when reapplying a style to an annotation): the Applies at modification column indicates whether this parameter is taken into account at modification time.

Text Styles Parameter Name Description Specifies the name of the font that should be used for texts. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not texts should be displayed in bold. Indicates whether or not texts should be displayed in italic. Indicates the font size that should be used for texts. Indicates whether or not texts should be underlined. Specifies the color that should be used to display texts. Specifies the ratio that should be used to display texts. Specifies the slant that should be used to display texts. Specifies the spacing that should be used to display texts. Specifies the pitch (fixed or variable) that should be used to display texts. Indicates whether or not strikethrough should be used for texts. Yes Applies at modification

Font > Bold Font > Italic Font > Size Font > Underline Font > Color Font > Ratio Font > Slant Font > Spacing Font > Pitch Font > Strikethrough

Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes
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Font > Overline

Indicates whether or not texts should be overlined. Specifies the type of frame that should be used to represent texts. Note that fixed-size frames are defined in the Frame node of the current standard. Accepted value: any

Yes

Text > Frame

Yes

Text > AnchorPoint

Specifies the text position in relation to the anchor point (e.g., top left, middle left, etc.). Specifies the text position in relation to the anchor line (e.g., top or bottom, cap or base, etc.). Specifies the spacing that should be used between two lines of text. Specifies the spacing mode between two lines of text (e.g., bottom to top, base to cap, etc.). Specifies a justification for the text. Specifies a width to wrap the text.

Yes

Text > AnchorLine

Yes

Text > LineSpacing Text > LineSpacingMode Text > Justification Text > WordWrap

Yes

Yes Yes Yes

Specifies whether the sheet, or whether Text > the view or 2D component should be OrientationReference used as the reference for the text orientation. Text > Angle Text > Mirroring Specifies the text orientation angle according to the chosen reference. Specifies whether a symmetry, and which one, should be applied to the text. Specifies whether or not superscript and subscript texts should be aligned above one another. Specifies the offset value (as a percentage of the font height) for superscript texts. Specifies the size (as a percentage of the font height) of superscript texts. Specifies the offset value (as a percentage of the font height) for subscript texts. Specifies the size (as a percentage of the font height) of subscript texts.

Yes

Yes Yes

Text > Backfield

Yes

Text > SuperscriptOffset Text > SuperscriptSize Text > SubscriptOffset Text > SubscriptSize

Yes

Yes

Yes

Yes
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Text > DisplayUnit

Specifies whether or not texts should be displayed. Specifies whether or not the scale of the view or of the 2D reference component scale should be applied to the display of the text. Indicates whether or not blanking should be used. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent text frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent text frames and leaders. Specifies the color that should be used to represent text frames and leaders. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for text leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type: • • Filled arrow for ANSI / ASME Simple arrow (a.k.a. Open arrow) for ISO / JIS

Yes

Text > ApplyScale

Yes

Text > Blanking

Yes

Graphic > Thickness

Yes

Graphic > Linetype

Yes

Graphic > Color

Yes

Leader > Symbol

Yes

Leader > Delta

Specifies the length of the first leader segment (i.e. the segment which is located before the first leader breakpoint). Specifies the leader position in relation to the anchor point of the text frame. When the Leader > StandardBehavior parameter is set to Yes: - 0 positions the leader automatically on the closest anchor point. - 1 positions the leader on the left-hand anchor point. - 2 positions the leader on the righthand anchor point.

Yes

Leader > AnchorPoint

Yes
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When the Leader > StandardBehavior parameter is set to No: - 0 positions the leader automatically on the closest anchor point. - 1 to 8 position the leader on a specific anchor point. Open the TextLeaderAnchorPoints.CATDrawing document to know the value you should assign to the Leader > AnchorPoint parameter, depending on where you want to position the leader in relation to the anchor point, and on the type of frame used. Leader > StandardBehavior Table Styles Parameter Name Description Specifies the name of the font that should be used for text in table cells. If no font name is specified, the system's default font will be used. Cells > Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not texts in table cells should be displayed in bold. Indicates whether or not texts in table cells should be displayed in italic. Indicates the font size that should be used for texts in table cells. Indicates whether or not texts in table cells should be underlined. Specifies the color that should be used to display texts in table cells. Specifies the ratio that should be used to display texts in table cells. Yes Applies at modification Specifies whether or not the position of text leaders can be different than left or right. Yes

Cells > Font > Bold Cells > Font > Italic Cells > Font > Size Cells > Font > Underline Cells > Font > Color Cells > Font > Ratio

Yes Yes Yes Yes Yes Yes
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Cells > Font > Slant Cells > Font > Spacing Cells > Font > Pitch

Specifies the slant that should be used to display texts in table cells. Specifies the spacing that should be used to display texts in table cells. Specifies the pitch (fixed or variable) that should be used to display texts in table cells. Indicates whether or not strikethrough should be used for texts in table cells. Indicates whether or not texts in table cells should be overlined. Specifies the spacing that should be used between two lines of text in table cells. Specifies the spacing mode between two lines of text in table cells (e.g., bottom to top, base to cap, etc.). Specifies whether or not superscript and subscript texts in table cells should be aligned above one another. Specifies the offset value (as a percentage of the font height) for superscript texts in table cells . Specifies the size of superscript texts (as a percentage of the font height) in table cells . Specifies the offset value for subscript texts (as a percentage of the font height) in table cells . Specifies the size of subscript texts (as a percentage of the font height) in table cells. Specifies whether or not texts in table cells should be displayed. Specifies the horizontal alignment for the contents of table cells. Specifies the vertical alignment for the contents of table cells. Specifies the horizontal space between the contents and the inside border of a cell.

Yes Yes

Yes

Cells > Font > Strikethrough Cells > Font > Overline Cells > LineSpacing

Yes

Yes

Yes

Cells > LineSpacingMode

Yes

Cells > Backfield

Yes

Cells > SuperscriptOffset Cells > SuperscriptSize Cells > SubscriptOffset

Yes

Yes

Yes

Cells > SubscriptSize

Yes

Cells > DisplayUnit Cells > HorizontalAlignment Cells > VerticalAlignment Cells > HorizontalMargin

Yes Yes Yes

Yes
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Specifies the vertical space between Cells > VerticalMargin the contents and the inside border of a cell. AnchorPoint Specifies the position of the table in relation to the anchor point (e.g., top left, middle left, etc.). Specifies whether the sheet, or whether the view or 2D component should be used as the reference for the orientation of the table. Specifies the orientation angle of the table according to the chosen reference. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent table frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent table frames and leaders. Specifies the color that should be used to represent table frames and leaders. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for table leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type: • • Filled arrow for ANSI / ASME Open arrow for ISO / JIS

Yes

Yes

OrientationReference

Yes

Angle

Yes

Graphic > Thickness

Yes

Graphic > Linetype

Yes

Graphic > Color

Yes

Leader > Symbol

Yes

Leader > Delta

Specifies the value of the delta that should be applied between a table and its leader. Indicates whether or not blanking should be used.

Yes

Blanking

Yes
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Specifies whether the sheet, or whether the view or 2D component OrientationReference should be used as the reference for the orientation of datum features. Angle Specifies the orientation angle of datum features according to the chosen reference. Specifies the position of datum features in relation to the anchor point (e.g., top left, middle left, etc.). Choose the display mode you want for the datum feature: - Show value: displays the datum feature, its leader and its frame. - Show box: replaces the datum feature and its frame by a rectangular box and displays its leader. - Hide value: hides the datum feature and its frame but displays its leader. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for datum feature leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type: • • • None (a.k.a. No symbol) for ANSI Filled Triangle for ASME Blanked triangle (a.k.a. Triangle) for ISO / JIS

Yes

Yes

AnchorPoint

Yes

Display

Yes

Leader > Symbol

Yes

Specifies the name of the font that should be used for datum feature texts. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Yes
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Font > Bold Font > Italic Font > Size

Indicates whether or not datum feature texts should be displayed in bold. Indicates whether or not datum feature texts should be displayed in italic. Indicates the font size that should be used for datum feature texts. Indicates whether or not datum feature texts should be scaled according to the view or the 2D reference component's scale. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent datum feature frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent datum feature frames and leaders. Specifies the color that should be used to represent datum feature frames, leaders and texts.

Yes Yes Yes

Font > ApplyScale

Yes

Graphic > Thickness

Yes

Graphic > Linetype

Yes

Graphic > Color

Yes
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InteractiveDrafting DatumTarget Styles Parameter Name Diameter Description Indicates whether or not the surface is plane on a disk. Applies at modification Yes

Specifies whether the sheet, or whether the view or 2D component OrientationReference should be used as the reference for the orientation of datum targets. Angle Specifies the orientation angle of datum targets according to the chosen reference. Specifies the position of datum targets in relation to the anchor point (e.g., top left, middle left, etc.). Choose the display mode you want for the datum target: - Show value: displays the datum target, its leader and its frame. - Show box: replaces the datum target and its frame by a rectangular box and displays its leader. - Hide value: hides the datum target and its frame but displays its leader. Specifies the name of the font that should be used for datum target texts. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not datum target texts should be displayed in bold. Indicates whether or not datum target texts should be displayed in italic. Indicates the font size that should be used for datum target texts. Indicates whether or not datum target texts should be scaled according to the view or the 2D reference component's scale.

Yes

Yes

AnchorPoint

Yes

Display

Yes

Yes

Font > Bold Font > Italic Font > Size

Yes Yes Yes

Font > ApplyScale

Yes
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Graphic > Thickness

Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent datum target frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent datum target frames and leaders. Specifies the color that should be used to represent datum target frames, leaders and texts. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for datum feature leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type: • • • None (a.k.a. No symbol) for ANSI Closed arrow (a.k.a. Unfilled arrow) for ASME Open arrow for ISO / JIS

Yes

Graphic > Linetype

Yes

Graphic > Color

Yes

Leader > Symbol
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InteractiveDrafting Tolerance Styles Parameter Name Type Value UpperText LowerText Description Specifies the tolerance type (e.g. straightness, circularity, etc.) Specifies the tolerance value. Specifies the tolerance upper text. Specifies the tolerance lower text. Specifies the name of the font that should be used for tolerances. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not tolerances should be displayed in bold. Indicates whether or not tolerances should be displayed in italic. Indicates the font size that should be used for tolerances. Specifies the ratio that should be used to display tolerances. Specifies the spacing that should be used to display tolerances. Specifies the tolerance text position in relation to the anchor point (e.g., top left, middle left, etc.). Specifies whether the sheet, or whether the view or 2D component should be used as the reference for the tolerance text orientation. Specifies the tolerance text orientation angle according to the chosen reference. Indicates whether or not blanking should be used. Specifies whether a symmetry, and Yes Applies at modification No No No No

Font > Bold Font > Italic Font > Size Font > Ratio Font > Spacing

Yes Yes Yes Yes Yes

Text > AnchorPoint

Yes

Text > OrientationReference

Yes

Text > Angle

Yes

Text > Blanking Text > Mirroring

Yes Yes
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which one, should be applied to the tolerance. Text > Blanking Indicates whether or not blanking should be used. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent text frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent tolerance frames and leaders. Specifies the color that should be used to represent tolerance frames and leaders. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for tolerance leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type and on whether the leader is associated to an element or not: Leader > Symbol • If the leader is associated to an element: o Filled arrow for ANSI / ASME o Open arrow for ISO / JIS If the leader is not associated to an element: o Symmetric circle (a.k.a. Unfilled circle) for ANSI / ASME o Filled circle for ISO / JIS Yes Yes

Graphic > Thickness

Yes

Graphic > Linetype

Yes

Graphic > Color

Yes

•

Leader > Delta

Specifies the value of the delta that should be applied between a tolerance and its leader.

Yes

Specifies the leader position in relation to the anchor point of the tolerance Leader > AnchorPoint frame. - 0 positions the leader automatically on the closest anchor point.

Yes
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- 1 positions the leader on the middleleft anchor point. - 2 positions the leader on the middleright anchor point. Balloon Styles Parameter Name Description Specifies the name of the font that should be used for balloons. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not balloons should be displayed in bold. Indicates whether or not balloons should be displayed in italic. Indicates the font size that should be used for balloons. Indicates whether or not balloon fonts should be underlined. Specifies the ratio that should be used to display balloons. Specifies the slant that should be used to display balloons. Specifies the spacing that should be used to display balloons. Specifies the pitch (fixed or variable) that should be used to display balloons. Indicates whether or not strikethrough should be used in balloons. Indicates whether or not overline should be used in balloons. Specifies the type of frame that should be used to represent balloons. Note that fixed-size frames are defined in the Frame node of the current Yes Applies at modification

Font > Bold Font > Italic Font > Size Font > Underline Font > Ratio Font > Slant Font > Spacing

Yes Yes Yes Yes Yes Yes Yes

Font > Pitch

Yes

Font > Strikethrough Font > Overline

Yes Yes

Text > Frame

Yes
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standard. Accepted values: none, circle, fixedsize circle Text > AnchorPoint Specifies the balloon position in relation to the anchor point (e.g., top left, middle left, etc.). Specifies the balloon position in relation to the anchor line (e.g., top or bottom, cap or base, etc.). Specifies whether the sheet, or whether the view or 2D component should be used as the reference for the balloon orientation. Specifies the balloon orientation angle according to the chosen reference. Specifies whether a symmetry, and which one, should be applied to the balloon. Specifies whether or not the scale of the view or of the 2D reference component scale should be applied to the display of the balloon. Choose the display mode you want for the balloon: - Show value: displays the balloon, its leader and its frame. - Show box: replaces the balloon and its frame by a rectangular box and displays its leader. - Hide value: hides the balloon and its frame but displays its leader. Indicates whether or not blanking should be used. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent balloon frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent balloon frames and leaders. Yes

Text > AnchorLine

Yes

Text > OrientationReference

Yes

Text > Angle

Yes

Text > Mirroring

Yes

Text > ApplyScale

Yes

Text > Display

Yes

Text > Blanking

Yes

Graphic > Thickness

Yes

Graphic > Linetype

Yes
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Graphic > Color

Specifies the color that should be used to represent balloon frames, leaders and texts. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for balloon leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type and on whether the leader is associated to an element or not: • If the leader is associated to an element: o Closed arrow (a.k.a. Unfilled arrow) for ANSI / ASME o Open arrow for ISO / JIS If the leader is not associated to an element: o Blanked circle for ANSI / ASME o Filled circle for ISO / JIS

Yes

Leader > Symbol

Yes

•
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Workbench Description RoughnessSymbol Styles Parameter Name Description Specifies the roughness symbol type (e.g. basic, machining required, machining prohibited) Specifies the roughness surface pattern (e.g. M, C, orthogonal, etc.) Indicates whether or not the specification line should be displayed. Indicates whether or not an all-around symbol should be added. Specifies the first requirement. Specifies the second requirement. Specifies another requirement. Specifies the production method. Specifies the machining allowance. Specifies the cutoff value. Specifies the maximum value. Specifies the minimum value. Specifies the position of roughness symbol texts in relation to the anchor point (e.g., top left, middle left, etc.). Specifies the position of roughness symbol texts in relation to the anchor line (e.g., top or bottom, cap or base, etc.). Indicates whether or not blanking should be used. Specifies the color that should be used to represent roughness symbols. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent roughness symbol Applies at modification No

Values > Type

Values > Mode Values > SpecificationLine Values > AllAround Values > FirstRequirement Values > SecondRequirement Values > OtherRequirement Values > ProductionMethod Values > MachiningAllowance Values > CutOff Values > Max Values > Min Text > AnchorPoint

No No No No No No No No No No No Yes

Text > AnchorLine

Yes

Text > Blanking Graphic > Color

Yes Yes

Graphic > Linetype

Yes
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leaders. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent roughness symbol leaders. Specifies the name of the font that should be used for roughness symbols. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not roughness symbol fonts should be displayed in bold. Indicates whether or not roughness symbol fonts should be displayed in italic. Indicates the font size that should be used for roughness symbols. Specifies the ratio that should be used to display roughness symbols. Specifies the spacing that should be used to display roughness symbols. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for roughness symbol leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type and on whether the leader is associated to an element or not: • If the leader is associated to an element: o Closed arrow (a.k.a. Unfilled arrow) for ANSI / ASME o Open arrow for ISO / JIS If the leader is not associated to an element: Yes

Graphic > Thickness

Yes

Font > Bold

Yes

Font > Italic

Yes

Font > Size Font > Ratio Font > Spacing

Yes Yes Yes

Leader > Symbol

Yes

•
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o

o

Symmetric circle (a.k.a. Unfilled circle) for ANSI / ASME Filled circle for ISO / JIS

Leader > Delta

Specifies the value of the delta that should be applied between a roughness symbol and its leader. Specifies the leader position in relation to the anchor point of the roughness symbol. - 0 positions the leader automatically on the closest anchor point. - 1 positions the leader on the middleleft anchor point. - 2 positions the leader on the middleright anchor point.

Yes

Leader > AnchorPoint

Yes

WeldingSymbol Styles Parameter Name Length1 Size1 Description Specifies the length of the first welding symbol. Specifies the size of the first welding symbol. Specifies the type (e.g. SquareWelding, UGrooveWelding, etc.) of the first welding symbol. Specifies the surface shape (e.g. flat, convex, etc.) of the first welding symbol. Specifies the finishing method (e.g. grinding, hammering, etc.) of the first welding symbol. Specifies the length of the second welding symbol. Specifies the size of the second welding symbol. Specifies the type (e.g. SquareWelding, UGrooveWelding, etc.) of the second welding symbol. Specifies the surface shape (e.g. flat, convex, etc.) of the second welding Applies at modification No No

WeldingType1

No

SurfaceShape1

No

FinishingMethod1

No

Length2 Size2

No No

WeldingType2

No

SurfaceShape2

No
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symbol. FinishingMethod2 Specifies the finishing method (e.g. grinding, hammering, etc.) of the second welding symbol. Specifies the reference of the welding symbol. Indicates whether or not a field weld should be added. Indicates whether or not a weld-allaround symbol should be added. Indicates whether the reference line should be up or down. This parameter works only for the ISO standard. Specifies the type of frame that should be used to represent welding symbols. Note that fixed-size frames are defined in the Frame node of the current standard. Accepted values: none, rectangle Text > OrientationReference Specifies whether the sheet, or whether the view or 2D component should be used as the reference for the welding symbol orientation. Specifies the welding symbol orientation angle according to the chosen reference. Specifies the spacing that should be used between two lines of text. Specifies the spacing mode between two lines of text (e.g., bottom to top, base to cap, etc.). Specifies the name of the font that should be used for welding symbols. If no font name is specified, the system's default font will be used. Font > Name Make sure that the text font specified here belongs to the list of allowed text fonts, as defined in the General > AllowedTextFonts node of the Standards editor. Indicates whether or not welding Yes No

Reference FieldWeld AllAround

No No No

ReferenceLine

No

Text > Frame

Yes

Yes

Text > Angle

Yes

Text > LineSpacing Text > LineSpacingMode

Yes

Yes

Font > Bold

Yes
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symbols should be displayed in bold. Font > Italic Font > Size Font > Ratio Font > Spacing Indicates whether or not welding symbols should be displayed in italic. Indicates the font size that should be used for welding symbols. Specifies the ratio that should be used to display welding symbols. Specifies the spacing that should be used to display welding symbols. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent welding symbol frames and leaders. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent welding symbol frames and leaders. Specifies the color that should be used to represent welding symbol frames and leaders. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for welding symbol leaders. If you choose the Automatic option, filled arrow will be used by default. Yes Yes Yes Yes

Graphic > Thickness

Yes

Graphic > Linetype

Yes

Graphic > Color

Yes

Leader > Symbol

Yes

Dimension Styles
This section deals with dimension styles. These let you define the default values that will be used when creating different types of dimensions. Defining Dimension Styles Dimension styles are located in the following nodes of the Standards editor, available via Tools -> Standards: • • • • • Styles Styles Styles Styles Styles -> -> -> -> -> DistanceLengthDimension AngleDimension RadiusDimension DiameterDimension ChamferDimension 513
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By default, a style called Default is available for each dimension style. All parameters are taken into account both at creation time (i.e. when creating a dimension), and at modification time (i.e. when reapplying a style to a dimension). DistanceLengthDimension Styles Parameter Name Value > OrientationReference Description Specifies whether the screen, the view or the dimension line should be used as the reference for the distance length dimension value orientation. Specifies the distance length dimension value orientation angle according to the chosen reference. Specifies the distance length dimension value position. Specifies the horizontal offset value for distance length dimension values. Specifies the vertical offset value for distance length dimension values. Choose the display mode you want for the distance length dimension: - Show value: displays the dimension, its leader and its frame. - Show box: replaces the dimension and its frame by a rectangular box and displays its leader. - Hide value: hides the dimension and its frame but displays its leader. Indicates whether or not distance length dimensions should be driving dimensions. Specifies whether there will be a dual value display for the distance length dimension, and, if any, what kind (e.g. fractional, side-by-side, etc.). Specifies the name of the main value display format. ValueDisplayFormat > MainValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor.

Value > Angle

Value > Position Value > OffsetX Value > OffsetY

Value > Display

Driving

DualValueDisplay
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ValueDisplayFormat > MainValue > DisplayedFactorNumber ValueDisplayFormat > MainValue > PrecisionMode ValueDisplayFormat > MainValue > Precision

Specifies the number of factors displayed for the main value, according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the main value will be decimal or fractional. Specifies the precision for the main value. Specifies the name of the dual value display format, if any.

ValueDisplayFormat > DualValue > Name

Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the dual value (if any), according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the dual value (if any) will be decimal or fractional. Specifies the precision for the dual value, if any. Indicates whether distance length dimensions will be fake dimensions, and, if yes, of what type (e.g. numerical or alphanumerical). Specifies the fake main value for distance length dimensions. Specifies the fake dual value for distance length dimensions. Specifies the tolerance main value format for distance length dimensions. Specifies the first alphanumerical value for the tolerance main value. Specifies the second alphanumerical value for the tolerance main value. Specifies the lower numerical for the tolerance main value. Specifies the upper numerical for the tolerance main value.

ValueDisplayFormat > DualValue > DisplayedFactorNumber ValueDisplayFormat > DualValue > PrecisionMode ValueDisplayFormat > DualValue > Precision Fake > Mode

Fake > MainValue Fake > DualValue Tolerance > MainValue > Format Tolerance > MainValue > AlphanumericalValue1 Tolerance > MainValue > AlphanumericalValue2 Tolerance > MainValue > NumericalLower Tolerance > MainValue > NumericalUpper
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Tolerance > DualValue > Format Tolerance > DualValue > AlphanumericalValue1 Tolerance > DualValue > AlphanumericalValue2 Tolerance > DualValue > NumericalLower Tolerance > DualValue > NumericalUpper DimensionLine > Representation DimensionLine > Color

Specifies the tolerance dual value format for distance length dimensions. Specifies the first alphanumerical value for the tolerance dual value. Specifies the second alphanumerical value for the tolerance dual value. Specifies the lower numerical for the tolerance dual value. Specifies the upper numerical for the tolerance dual value. Specifies how the dimension line should be represented (e.g. regular, one-part leader, etc.) Specifies the color that should be used to display dimension lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent dimension lines. In the case of Two parts or Leader two parts for the representation, specifies the Reference for positioning the second part of the dimension line. In the case of Two parts or Leader two parts for the representation, specifies the angle for the second part of the dimension line in relation to its reference. Specifies the angle for the dimension line leader.

DimensionLine > Thickness

DimensionLine > SecondPartReference

DimensionLine > SecondPartAngle DimensionLine > LeaderAngle

Specifies the type of the first symbol (e.g. arrow, filled circle, etc.) that should be used for Symbols > Symbol1 > Type distance length dimensions. If you choose the Automatic option, simple arrow will be used by default. Symbols > Symbol1 > Color Specifies the color of the first symbol. Symbols > Symbol1 > Thickness Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the first symbol.

Specifies the type of the second symbol (e.g. arrow, filled circle, etc.) that should be used for Symbols > Symbol2 > Type distance length dimensions. If you choose the Automatic option, simple arrow will be used by default.
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Symbols > Symbol2 > Color Specifies the color of the second symbol. Symbols > Symbol2 > Thickness Symbols > SymbolMode ExtensionLine > Color Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the second symbol. Specifies the symbol mode (e.g. inside, outside, etc.). Specifies the color of the distance length dimension extension line. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the distance length dimension extension line. Specifies the slant angle for the extension line. This angle is contained between 90 degrees and -90 degrees excluded, the default angle being 0 degree. Indicates whether or not the left extension line should be hidden. Specifies the overrun for the left extension line. Specifies the blanking for the left extension line. Indicates whether or not the right extension line should be hidden. Specifies the overrun for the right extension line. Specifies the blanking for the right extension line. Indicates whether or not the extension line should be displayed as a funnel. Specifies the funnel height. Specifies the funnel width. Specifies the funnel angle. Specifies the funnel mode (external or internal). Specifies whether the funnel should be applied on the left or bottom, on the right or top, or on both sides.

ExtensionLine > Thickness

ExtensionLine > SlantAngle

ExtensionLine > Left > Hide ExtensionLine > Left > Overrun ExtensionLine > Left > Blanking ExtensionLine > Right > Hide ExtensionLine > Right > Overrun ExtensionLine > Right > Blanking ExtensionLine > Funnel > Display ExtensionLine > Funnel > Height ExtensionLine > Funnel > Width ExtensionLine > Funnel > Angle ExtensionLine > Funnel > Mode ExtensionLine > Funnel > Side
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AssociatedTexts > MainValue > Prefix AssociatedTexts > MainValue > Suffix AssociatedTexts > MainValue > Before AssociatedTexts > MainValue > After AssociatedTexts > MainValue > Upper AssociatedTexts > MainValue > Lower AssociatedTexts > DualValue > Before AssociatedTexts > DualValue > After AssociatedTexts > DualValue > Upper AssociatedTexts > DualValue > Lower Framing > FramedSubpart

Specifies the prefix for the main value of the associated text. Specifies the suffix for the main value of the associated text. Specifies the text that should be displayed before the main value of the associated text. Specifies the text that should be displayed after the main value of the associated text. Specifies the text that should be displayed above the main value of the associated text. Specifies the text that should be displayed below the main value of the associated text. Specifies the text that should be displayed before the dual value of the associated text. Specifies the text that should be displayed after the dual value of the associated text. Specifies the text that should be displayed above the dual value of the associated text. Specifies the text that should be displayed below the dual value of the associated text. Specifies whether the frame subpart should display the value, the value and tolerance, etc. Specifies whether the framed group should display the main value, the dual value, both values separately, etc. Specifies the type of frame that should be used for distance length dimensions. Note that fixedsize frames are defined in the Frame node of the current standard. Accepted values: none, circle, fixed-size scored circle, fixed-size diamond, fixed-size square, rectangle, oblong, right flag, fixed-size triangle

Framing > FramedGroup

Framing > Frame

Framing > MainValueScoring Framing > DualValueScoring

Specifies the main value scoring. Specifies the dual value scoring. Specifies the name of the font that should be used for distance length dimension texts. If no font name is specified, the system's default font will be used.

Font > Name
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Font > Bold Font > Italic Font > Size Font > Color

Indicates whether or not distance length dimension texts should be displayed in bold. Indicates whether or not distance length dimension texts should be displayed in italic. Indicates the font size that should be used for distance length dimension texts. Specifies the color that should be used to display distance length dimension texts. Indicates whether or not distance length dimension texts should be underlined (in this case, overline cannot be applied). Indicates whether or not strikethrough should be used for distance length dimension texts. Indicates whether or not distance length dimension texts should be overlined (in this case, underline cannot be applied). Specifies the character width. Specifies the spacing between characters. Indicates whether or not distance length dimension texts should be scaled according to the view or the 2D reference component's scale.

Font > Underline

Font > Strikethrough

Font > Overline Font > Ratio Font > Spacing Font > ApplyScale

519

InteractiveDrafting AngleDimension Styles Parameter Name Value > OrientationReference Value > Angle Value > Position Value > OffsetX Value > OffsetY Description Specifies whether the screen, the view or the dimension line should be used as the reference for the angle dimension value orientation. Specifies the angle dimension value orientation angle according to the chosen reference. Specifies the angle dimension value position. Specifies the horizontal offset value for angle dimension values. Specifies the vertical offset value for angle dimension values. Choose the display mode you want for the angle dimension: - Show value: displays the dimension, its leader and its frame. - Show box: replaces the dimension and its frame by a rectangular box and displays its leader. - Hide value: hides the dimension and its frame but displays its leader. Indicates whether or not angle dimensions should be driving dimensions. Specifies whether there will be a dual value display for the angle dimension, and, if any, what kind (e.g. fractional, side-by-side, etc.). Specifies the name of the main value display format. ValueDisplayFormat > MainValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the main value, according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the main value will be decimal or fractional. Specifies the precision for the main value.

Value > Display

Driving

DualValueDisplay

ValueDisplayFormat > MainValue > DisplayedFactorNumber ValueDisplayFormat > MainValue > PrecisionMode ValueDisplayFormat > MainValue > Precision
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Specifies the name of the dual value display format, if any. ValueDisplayFormat > DualValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the dual value (if any), according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the dual value (if any) will be decimal or fractional. Specifies the precision for the dual value, if any. Indicates whether angle dimensions will be fake dimensions, and, if yes, of what type (e.g. numerical or alphanumerical). Specifies the fake main value for angle dimensions. Specifies the fake dual value for angle dimensions. Specifies the tolerance main value format for angle dimensions. Specifies the first alphanumerical value for the tolerance main value. Specifies the second alphanumerical value for the tolerance main value. Specifies the lower numerical for the tolerance main value. Specifies the upper numerical for the tolerance main value. Specifies the tolerance dual value format for angle dimensions. Specifies the first alphanumerical value for the tolerance dual value. Specifies the second alphanumerical value for the tolerance dual value. Specifies the lower numerical for the tolerance dual value.

ValueDisplayFormat > DualValue > DisplayedFactorNumber ValueDisplayFormat > DualValue > PrecisionMode ValueDisplayFormat > DualValue > Precision Fake > Mode

Fake > MainValue Fake > DualValue Tolerance > MainValue > Format Tolerance > MainValue > AlphanumericalValue1 Tolerance > MainValue > AlphanumericalValue2 Tolerance > MainValue > NumericalLower Tolerance > MainValue > NumericalUpper Tolerance > DualValue > Format Tolerance > DualValue > AlphanumericalValue1 Tolerance > DualValue > AlphanumericalValue2 Tolerance > DualValue > NumericalLower
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Tolerance > DualValue > NumericalUpper DimensionLine > Representation DimensionLine > Color

Specifies the upper numerical for the tolerance dual value. Specifies how the dimension line should be represented (e.g. regular, one-part leader, etc.) Specifies the color that should be used to display dimension lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent dimension lines. In the case of Two parts or Leader two parts for the representation, specifies the Reference for positioning the second part of the dimension line. In the case of Two parts or Leader two parts for the representation, specifies the angle for the second part of the dimension line in relation to its reference. Specifies the angle for the dimension line leader.

DimensionLine > Thickness

DimensionLine > SecondPartReference

DimensionLine > SecondPartAngle DimensionLine > LeaderAngle

Specifies the type of the first symbol (e.g. arrow, filled circle, etc.) that should be used for Symbols > Symbol1 > Type angle dimensions. If you choose the Automatic option, simple arrow will be used by default. Symbols > Symbol1 > Color Specifies the color of the first symbol. Symbols > Symbol1 > Thickness Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the first symbol.

Specifies the type of the second symbol (e.g. arrow, filled circle, etc.) that should be used for Symbols > Symbol2 > Type angle dimensions. If you choose the Automatic option, simple arrow will be used by default. Symbols > Symbol2 > Color Specifies the color of the second symbol. Symbols > Symbol2 > Thickness Symbols > SymbolMode ExtensionLine > Color ExtensionLine > Thickness Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the second symbol. Specifies the symbol mode (e.g. inside, outside, etc.). Specifies the color of the angle dimension extension line. Specifies the line thickness index (as defined in the LineThickness node of the current standard)

522

Workbench Description

of the angle dimension extension line. Specifies the slant angle for the extension line. This angle is contained between 90 degrees and -90 degrees excluded, the default angle being 0 degree. Indicates whether or not the left extension line should be hidden. Specifies the overrun for the left extension line. Specifies the blanking for the left extension line. Indicates whether or not the right extension line should be hidden. Specifies the overrun for the right extension line. Specifies the blanking for the right extension line. Specifies the prefix for the main value of the associated text. Specifies the suffix for the main value of the associated text. Specifies the text that should be displayed before the main value of the associated text. Specifies the text that should be displayed after the main value of the associated text. Specifies the text that should be displayed above the main value of the associated text. Specifies the text that should be displayed below the main value of the associated text. Specifies the text that should be displayed before the dual value of the associated text. Specifies the text that should be displayed after the dual value of the associated text. Specifies the text that should be displayed above the dual value of the associated text. Specifies the text that should be displayed below the dual value of the associated text. Specifies whether the frame subpart should display the value, the value and tolerance, etc.

ExtensionLine > SlantAngle

ExtensionLine > Left > Hide ExtensionLine > Left > Overrun ExtensionLine > Left > Blanking ExtensionLine > Right > Hide ExtensionLine > Right > Overrun ExtensionLine > Right > Blanking AssociatedTexts > MainValue > Prefix AssociatedTexts > MainValue > Suffix AssociatedTexts > MainValue > Before AssociatedTexts > MainValue > After AssociatedTexts > MainValue > Upper AssociatedTexts > MainValue > Lower AssociatedTexts > DualValue > Before AssociatedTexts > DualValue > After AssociatedTexts > DualValue > Upper AssociatedTexts > DualValue > Lower Framing > FramedSubpart
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Framing > FramedGroup

Specifies whether the framed group should display the main value, the dual value, both values separately, etc. Specifies the type of frame that should be used for angle dimensions. Note that fixed-size frames are defined in the Frame node of the current standard. Accepted values: none, circle, fixed-size scored circle, fixed-size diamond, fixed-size square, rectangle, oblong, right flag, fixed-size triangle

Framing > Frame

Framing > MainValueScoring Framing > DualValueScoring

Specifies the main value scoring. Specifies the dual value scoring. Specifies the name of the font that should be used for angle dimension texts. If no font name is specified, the system's default font will be used. Indicates whether or not angle dimension texts should be displayed in bold. Indicates whether or not angle dimension texts should be displayed in italic. Indicates the font size that should be used for angle dimension texts. Specifies the color that should be used to display angle dimension texts. Indicates whether or not angle dimension texts should be underlined (in this case, overline cannot be applied). Indicates whether or not strikethrough should be used for angle dimension texts. Indicates whether or not angle dimension texts should be overlined (in this case, underline cannot be applied). Specifies the character width. Specifies the spacing between characters. Indicates whether or not angle dimension texts should be scaled according to the view or the 2D reference component's scale.

Font > Name

Font > Bold Font > Italic Font > Size Font > Color

Font > Underline

Font > Strikethrough

Font > Overline Font > Ratio Font > Spacing Font > ApplyScale
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RadiusDimension Styles Parameter Name Value > OrientationReference Value > Angle Value > Position Value > OffsetX Value > OffsetY Description Specifies whether the screen, the view or the dimension line should be used as the reference for the radius dimension value orientation. Specifies the radius dimension value orientation angle according to the chosen reference. Specifies the radius dimension value position. Specifies the horizontal offset value for radius dimension values. Specifies the vertical offset value for radius dimension values. Choose the display mode you want for the radius dimension: - Show value: displays the dimension, its leader and its frame. - Show box: replaces the dimension and its frame by a rectangular box and displays its leader. - Hide value: hides the dimension and its frame but displays its leader. Indicates whether or not radius dimensions should be driving dimensions. Specifies whether there will be a dual value display for the radius dimension, and, if any, what kind (e.g. fractional, side-by-side, etc.). Specifies the name of the main value display format. ValueDisplayFormat > MainValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the main value, according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the main value will be decimal or fractional. Specifies the precision for the main value.

Value > Display

Driving

DualValueDisplay

ValueDisplayFormat > MainValue > DisplayedFactorNumber ValueDisplayFormat > MainValue > PrecisionMode ValueDisplayFormat > MainValue > Precision
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Specifies the name of the dual value display format, if any. ValueDisplayFormat > DualValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the dual value (if any), according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the dual value (if any) will be decimal or fractional. Specifies the precision for the dual value, if any. Indicates whether radius dimensions will be fake dimensions, and, if yes, of what type (e.g. numerical or alphanumerical). Specifies the fake main value for radius dimensions. Specifies the fake dual value for radius dimensions. Specifies the tolerance main value format for radius dimensions. Specifies the first alphanumerical value for the tolerance main value. Specifies the second alphanumerical value for the tolerance main value. Specifies the lower numerical for the tolerance main value. Specifies the upper numerical for the tolerance main value. Specifies the tolerance dual value format for radius dimensions. Specifies the first alphanumerical value for the tolerance dual value. Specifies the second alphanumerical value for the tolerance dual value. Specifies the lower numerical for the tolerance

ValueDisplayFormat > DualValue > DisplayedFactorNumber ValueDisplayFormat > DualValue > PrecisionMode ValueDisplayFormat > DualValue > Precision Fake > Mode

Fake > MainValue Fake > DualValue Tolerance > MainValue > Format Tolerance > MainValue > AlphanumericalValue1 Tolerance > MainValue > AlphanumericalValue2 Tolerance > MainValue > NumericalLower Tolerance > MainValue > NumericalUpper Tolerance > DualValue > Format Tolerance > DualValue > AlphanumericalValue1 Tolerance > DualValue > AlphanumericalValue2 Tolerance > DualValue >
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NumericalLower Tolerance > DualValue > NumericalUpper DimensionLine > Representation DimensionLine > Color DimensionLine > Thickness DimensionLine > SecondPartReference

dual value. Specifies the upper numerical for the tolerance dual value. Specifies how the dimension line should be represented (e.g. regular, one-part leader, etc.) Specifies the color that should be used to display dimension lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent dimension lines. In the case of Two parts or Leader two parts for the representation, specifies the Reference for positioning the second part of the dimension line. In the case of Two parts or Leader two parts for the representation, specifies the angle for the second part of the dimension line in relation to its reference. Specifies the angle for the dimension line leader. Indicates whether or not the dimension line should reach the center. Indicates whether or not the extension of the dimension line should be driven by the standards. If set to Yes, then the DimensionLine > TillCenter parameter is not taken into account; in this case, the extension is performed as defined by the DIMLRadiusIntReachCenter and the DIMLRadiusExtReachCenter standard parameters. Refer to Dimension Parameters for more information. Specifies the type of the first symbol (e.g. arrow, filled circle, etc.) that should be used for radius dimensions. If you choose the Automatic option, simple arrow will be used by default. Specifies the color of the first symbol. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the first symbol. Specifies the type of the second symbol (e.g. arrow, filled circle, etc.) that should be used for radius dimensions. If you choose the Automatic option, simple arrow will be used by default.

DimensionLine > SecondPartAngle DimensionLine > LeaderAngle DimensionLine > TillCenter

DimensionLine > ExtensionFromStandard

Symbols > Symbol1 > Type Symbols > Symbol1 > Color Symbols > Symbol1 > Thickness

Symbols > Symbol2 > Type
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Symbols > Symbol2 > Color Symbols > Symbol2 > Thickness Symbols > SymbolMode Foreshortened > IsForeshortened Foreshortened > ValuePosition Foreshortened > Orientation Foreshortened > Angle Foreshortened > Ratio Foreshortened > SymbolScale Foreshortened > MoveEndPoint ExtensionLine > Color

Specifies the color of the second symbol. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the second symbol. Specifies the symbol mode (e.g. inside, outside, etc.). Indicates whether or not the radius dimension should be foreshortened. Specifies whether the foreshortened dimension value should be positioned on the long segment or on the short segment. Specifies whether the foreshortened dimension orientation should be parallel or convergent. Specifies the foreshortened dimension angle. Specifies the foreshortened dimension ratio. Specifies the scale that should be used for the foreshortened dimension symbol. Indicates whether or not the foreshortened dimension end point can be moved. Specifies the color of the radius dimension extension line.

Specifies the line thickness index (as defined in ExtensionLine > Thickness the LineThickness node of the current standard) of the radius dimension extension line. ExtensionLine > SlantAngle ExtensionLine > Left > Hide ExtensionLine > Left > Overrun ExtensionLine > Left > Blanking ExtensionLine > Right > Hide ExtensionLine > Right > Overrun ExtensionLine > Right > Specifies the slant angle for the extension line. This angle is contained between 90 degrees and 90 degrees excluded, the default angle being 0 degree. Indicates whether or not the left extension line should be hidden. Specifies the overrun for the left extension line. Specifies the blanking for the left extension line. Indicates whether or not the right extension line should be hidden. Specifies the overrun for the right extension line. Specifies the blanking for the right extension line.
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Blanking ExtensionLine > Funnel > Display ExtensionLine > Funnel > Height ExtensionLine > Funnel > Width ExtensionLine > Funnel > Angle ExtensionLine > Funnel > Mode ExtensionLine > Funnel > Side AssociatedTexts > MainValue > Prefix AssociatedTexts > MainValue > Suffix AssociatedTexts > MainValue > Before AssociatedTexts > MainValue > After AssociatedTexts > MainValue > Upper AssociatedTexts > MainValue > Lower AssociatedTexts > DualValue > Before AssociatedTexts > DualValue > After AssociatedTexts > DualValue > Upper AssociatedTexts > DualValue > Lower Framing > FramedSubpart Indicates whether or not the extension line should be displayed as a funnel. Specifies the funnel height. Specifies the funnel width. Specifies the funnel angle. Specifies the funnel mode (external or internal). Specifies whether the funnel should be applied on the left or bottom, on the right or top, or on both sides. Specifies the prefix for the main value of the associated text. Specifies the suffix for the main value of the associated text. Specifies the text that should be displayed before the main value of the associated text. Specifies the text that should be displayed after the main value of the associated text. Specifies the text that should be displayed above the main value of the associated text. Specifies the text that should be displayed below the main value of the associated text. Specifies the text that should be displayed before the dual value of the associated text. Specifies the text that should be displayed after the dual value of the associated text. Specifies the text that should be displayed above the dual value of the associated text. Specifies the text that should be displayed below the dual value of the associated text. Specifies whether the frame subpart should display the value, the value and tolerance, etc. Specifies whether the framed group should display the main value, the dual value, both values separately, etc.

Framing > FramedGroup
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Framing > Frame

Specifies the type of frame that should be used for radius dimensions. Note that fixed-size frames are defined in the Frame node of the current standard. Accepted values: none, circle, fixed-size scored circle, fixed-size diamond, fixed-size square, rectangle, oblong, right flag, fixed-size triangle

Framing > MainValueScoring Framing > DualValueScoring

Specifies the main value scoring. Specifies the dual value scoring. Specifies the name of the font that should be used for radius dimension texts. If no font name is specified, the system's default font will be used. Indicates whether or not radius dimension texts should be displayed in bold. Indicates whether or not radius dimension texts should be displayed in italic. Indicates the font size that should be used for radius dimension texts. Specifies the color that should be used to display radius dimension texts. Indicates whether or not radius dimension texts should be underlined (in this case, overline cannot be applied). Indicates whether or not strikethrough should be used for radius dimension texts. Indicates whether or not radius dimension texts should be overlined (in this case, underline cannot be applied). Specifies the character width. Specifies the spacing between characters. Indicates whether or not radius dimension texts should be scaled according to the view or the 2D reference component's scale.

Font > Name

Font > Bold Font > Italic Font > Size Font > Color

Font > Underline

Font > Strikethrough

Font > Overline Font > Ratio Font > Spacing Font > ApplyScale
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Workbench Description DiameterDimension Styles Parameter Name Value > OrientationReference Description Specifies whether the screen, the view or the dimension line should be used as the reference for the diameter dimension value orientation. Specifies the diameter dimension value orientation angle according to the chosen reference. Specifies the diameter dimension value position. Specifies the horizontal offset value for diameter dimension values. Specifies the vertical offset value for diameter dimension values. Choose the display mode you want for the diameter dimension: - Show value: displays the dimension, its leader and its frame. - Show box: replaces the dimension and its frame by a rectangular box and displays its leader. - Hide value: hides the dimension and its frame but displays its leader. Indicates whether or not diameter dimensions should be driving dimensions. Specifies whether there will be a dual value display for the diameter dimension, and, if any, what kind (e.g. fractional, side-by-side, etc.). Specifies the name of the main value display format. ValueDisplayFormat > MainValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the main value, according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the main value will be decimal or fractional. Specifies the precision for the main value.

Value > Angle Value > Position Value > OffsetX Value > OffsetY

Value > Display

Driving

DualValueDisplay

ValueDisplayFormat > MainValue > DisplayedFactorNumber ValueDisplayFormat > MainValue > PrecisionMode ValueDisplayFormat > MainValue > Precision

531

InteractiveDrafting

Specifies the name of the dual value display format, if any. ValueDisplayFormat > DualValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the dual value (if any), according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the dual value (if any) will be decimal or fractional. Specifies the precision for the dual value, if any. Indicates whether diameter dimensions will be fake dimensions, and, if yes, of what type (e.g. numerical or alphanumerical). Specifies the fake main value for diameter dimensions. Specifies the fake dual value for diameter dimensions. Specifies the tolerance main value format for diameter dimensions. Specifies the first alphanumerical value for the tolerance main value. Specifies the second alphanumerical value for the tolerance main value. Specifies the lower numerical for the tolerance main value. Specifies the upper numerical for the tolerance main value. Specifies the tolerance dual value format for diameter dimensions. Specifies the first alphanumerical value for the tolerance dual value. Specifies the second alphanumerical value for the tolerance dual value. Specifies the lower numerical for the tolerance

ValueDisplayFormat > DualValue > DisplayedFactorNumber ValueDisplayFormat > DualValue > PrecisionMode ValueDisplayFormat > DualValue > Precision Fake > Mode

Fake > MainValue Fake > DualValue Tolerance > MainValue > Format Tolerance > MainValue > AlphanumericalValue1 Tolerance > MainValue > AlphanumericalValue2 Tolerance > MainValue > NumericalLower Tolerance > MainValue > NumericalUpper Tolerance > DualValue > Format Tolerance > DualValue > AlphanumericalValue1 Tolerance > DualValue > AlphanumericalValue2 Tolerance > DualValue >
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NumericalLower Tolerance > DualValue > NumericalUpper DimensionLine > Representation DimensionLine > Color DimensionLine > Thickness DimensionLine > SecondPartReference

dual value. Specifies the upper numerical for the tolerance dual value. Specifies how the dimension line should be represented (e.g. regular, one-part leader, etc.) Specifies the color that should be used to display dimension lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent dimension lines. In the case of Two parts or Leader two parts for the representation, specifies the Reference for positioning the second part of the dimension line. In the case of Two parts or Leader two parts for the representation, specifies the angle for the second part of the dimension line in relation to its reference. Specifies the angle for the dimension line leader. Indicates whether or not the dimension line should reach the center. Indicates whether or not the extension of the dimension line should be driven by the standards. If set to Yes, then the DimensionLine > TillCenter parameter is not taken into account; in this case, the extension is performed as defined by the DIMLDiameterIntReachCenter and the DIMLDiameterExtReachCenter standard parameters. Refer to Dimension Parameters for more information. Specifies the type of the first symbol (e.g. arrow, filled circle, etc.) that should be used for diameter dimensions. If you choose the Automatic option, simple arrow will be used by default. Specifies the color of the first symbol. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the first symbol. Specifies the type of the second symbol (e.g. arrow, filled circle, etc.) that should be used for diameter dimensions. If you choose the Automatic option, simple arrow will be used by default.

DimensionLine > SecondPartAngle DimensionLine > LeaderAngle DimensionLine > TillCenter

DimensionLine > ExtensionFromStandard

Symbols > Symbol1 > Type Symbols > Symbol1 > Color Symbols > Symbol1 > Thickness

Symbols > Symbol2 > Type

533

InteractiveDrafting

Symbols > Symbol2 > Color Symbols > Symbol2 > Thickness Symbols > SymbolMode ExtensionLine > Color

Specifies the color of the second symbol. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the second symbol. Specifies the symbol mode (e.g. inside, outside, etc.). Specifies the color of the diameter dimension extension line.

Specifies the line thickness index (as defined in ExtensionLine > Thickness the LineThickness node of the current standard) of the diameter dimension extension line. ExtensionLine > SlantAngle ExtensionLine > Left > Hide ExtensionLine > Left > Overrun ExtensionLine > Left > Blanking ExtensionLine > Right > Hide ExtensionLine > Right > Overrun ExtensionLine > Right > Blanking ExtensionLine > Funnel > Display ExtensionLine > Funnel > Height ExtensionLine > Funnel > Width ExtensionLine > Funnel > Angle ExtensionLine > Funnel > Mode ExtensionLine > Funnel > Side Specifies the slant angle for the extension line. This angle is contained between 90 degrees and 90 degrees excluded, the default angle being 0 degree. Indicates whether or not the left extension line should be hidden. Specifies the overrun for the left extension line. Specifies the blanking for the left extension line. Indicates whether or not the right extension line should be hidden. Specifies the overrun for the right extension line. Specifies the blanking for the right extension line. Indicates whether or not the extension line should be displayed as a funnel. Specifies the funnel height. Specifies the funnel width. Specifies the funnel angle. Specifies the funnel mode (external or internal). Specifies whether the funnel should be applied on the left or bottom, on the right or top, or on both
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sides. AssociatedTexts > MainValue > Prefix AssociatedTexts > MainValue > Suffix AssociatedTexts > MainValue > Before AssociatedTexts > MainValue > After AssociatedTexts > MainValue > Upper AssociatedTexts > MainValue > Lower AssociatedTexts > DualValue > Before AssociatedTexts > DualValue > After AssociatedTexts > DualValue > Upper AssociatedTexts > DualValue > Lower Framing > FramedSubpart Framing > FramedGroup Specifies the prefix for the main value of the associated text. Specifies the suffix for the main value of the associated text. Specifies the text that should be displayed before the main value of the associated text. Specifies the text that should be displayed after the main value of the associated text. Specifies the text that should be displayed above the main value of the associated text. Specifies the text that should be displayed below the main value of the associated text. Specifies the text that should be displayed before the dual value of the associated text. Specifies the text that should be displayed after the dual value of the associated text. Specifies the text that should be displayed above the dual value of the associated text. Specifies the text that should be displayed below the dual value of the associated text. Specifies whether the frame subpart should display the value, the value and tolerance, etc. Specifies whether the framed group should display the main value, the dual value, both values separately, etc. Specifies the type of frame that should be used for diameter dimensions. Note that fixed-size frames are defined in the Frame node of the current standard. Accepted values: none, circle, fixed-size scored circle, fixed-size diamond, fixed-size square, rectangle, oblong, right flag, fixed-size triangle Framing > MainValueScoring Framing > DualValueScoring Font > Name Specifies the main value scoring. Specifies the dual value scoring. Specifies the name of the font that should be used for diameter dimension texts. If no font name is specified, the system's default font will be used.

Framing > Frame
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Font > Bold Font > Italic Font > Size Font > Color

Indicates whether or not diameter dimension texts should be displayed in bold. Indicates whether or not diameter dimension texts should be displayed in italic. Indicates the font size that should be used for diameter dimension texts. Specifies the color that should be used to display diameter dimension texts. Indicates whether or not diameter dimension texts should be underlined (in this case, overline cannot be applied). Indicates whether or not strikethrough should be used for diameter dimension texts. Indicates whether or not diameter dimension texts should be overlined (in this case, underline cannot be applied). Specifies the character width. Specifies the spacing between characters. Indicates whether or not diameter dimension texts should be scaled according to the view or the 2D reference component's scale. Indicates whether or not diameter dimensions should be displayed as one-symbol dimensions (as opposed to two-symbols).

Font > Underline

Font > Strikethrough

Font > Overline Font > Ratio Font > Spacing Font > ApplyScale

OneSymbolDiameter
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Workbench Description ChamferDimension Styles Parameter Name Description Specifies whether the screen, the view or the dimension line should be used as the reference for the chamfer dimension value orientation. Specifies the chamfer dimension value orientation angle according to the chosen reference. Specifies the chamfer dimension value position. Specifies the horizontal offset value for chamfer dimension values. Specifies the vertical offset value for chamfer dimension values. Choose the display mode you want for the chamfer dimension: - Show value: displays the dimension, its leader and its frame. - Show box: replaces the dimension and its frame by a rectangular box and displays its leader. - Hide value: hides the dimension and its frame but displays its leader. Not available for chamfer dimensions. Specifies whether there will be a dual value display for the chamfer dimension, and, if any, what kind (e.g. fractional, side-by-side, etc.). Specifies the name of the main value display format. ValueDisplayFormat > MainValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the main value, according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the main value will be decimal or

Value > OrientationReference

Value > Angle

Value > Position Value > OffsetX Value > OffsetY

Value > Display

Driving

DualValueDisplay

ValueDisplayFormat > MainValue > DisplayedFactorNumber ValueDisplayFormat > MainValue > PrecisionMode
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fractional. ValueDisplayFormat > MainValue > Precision Specifies the precision for the main value. Specifies the name of the dual value display format, if any. ValueDisplayFormat > DualValue > Name Make sure that the display format specified here belongs to the list of Value Display styles allowed on dimensions, as defined in the General > AllowedNumericalFormats node of the Standards editor. Specifies the number of factors displayed for the dual value (if any), according to the number of factors available for the value display format used by this style. Specifies whether the precision mode for the dual value (if any) will be decimal or fractional. Specifies the precision for the dual value, if any. Indicates whether chamfer dimensions will be fake dimensions, and, if yes, of what type (e.g. numerical or alphanumerical). Specifies the fake main value for chamfer dimensions. Specifies the fake dual value for chamfer dimensions. Specifies the tolerance main value format for chamfer dimensions. Specifies the first alphanumerical value for the tolerance main value. Specifies the second alphanumerical value for the tolerance main value. Specifies the lower numerical for the tolerance main value. Specifies the upper numerical for the tolerance main value. Specifies the tolerance dual value format for chamfer dimensions.

ValueDisplayFormat > DualValue > DisplayedFactorNumber

ValueDisplayFormat > DualValue > PrecisionMode ValueDisplayFormat > DualValue > Precision

Fake > Mode

Fake > MainValue Fake > DualValue Tolerance > MainValue > Format Tolerance > MainValue > AlphanumericalValue1 Tolerance > MainValue > AlphanumericalValue2 Tolerance > MainValue > NumericalLower Tolerance > MainValue > NumericalUpper Tolerance > DualValue > Format
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Tolerance > DualValue > AlphanumericalValue1 Tolerance > DualValue > AlphanumericalValue2 Tolerance > DualValue > NumericalLower Tolerance > DualValue > NumericalUpper DimensionLine > Representation

Specifies the first alphanumerical value for the tolerance dual value. Specifies the second alphanumerical value for the tolerance dual value. Specifies the lower numerical for the tolerance dual value. Specifies the upper numerical for the tolerance dual value. Specifies how the dimension line should be represented (e.g. regular, one-part leader, etc.) Specifies the color that should be used to display dimension lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent dimension lines. In the case of Two parts or Leader two parts for the representation, specifies the Reference for positioning the second part of the dimension line. In the case of Two parts or Leader two parts for the representation, specifies the angle for the second part of the dimension line in relation to its reference. Specifies the angle for the dimension line leader. Specifies the type of the first symbol (e.g. arrow, filled circle, etc.) that should be used for chamfer dimensions. If you choose the Automatic option, simple arrow will be used by default. Specifies the color of the first symbol. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the first symbol. Specifies the type of the second symbol (e.g. arrow, filled circle, etc.) that should be used for chamfer dimensions. If you choose the Automatic option, simple arrow will be used by default. Specifies the color of the second symbol.

DimensionLine > Color

DimensionLine > Thickness

DimensionLine > SecondPartReference

DimensionLine > SecondPartAngle

DimensionLine > LeaderAngle

Symbols > Symbol1 > Type

Symbols > Symbol1 > Color Symbols > Symbol1 > Thickness

Symbols > Symbol2 > Type

Symbols > Symbol2 > Color
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Symbols > Symbol2 > Thickness

Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the second symbol. Specifies the symbol mode (e.g. inside, outside, etc.). Specifies the color of the chamfer dimension extension line. Specifies the line thickness index (as defined in the LineThickness node of the current standard) of the chamfer dimension extension line. Specifies the slant angle for the extension line. This angle is contained between 90 degrees and -90 degrees excluded, the default angle being 0 degree. Indicates whether or not the left extension line should be hidden. Specifies the overrun for the left extension line. Specifies the blanking for the left extension line. Indicates whether or not the right extension line should be hidden. Specifies the overrun for the right extension line. Specifies the blanking for the right extension line. Indicates whether or not the extension line should be displayed as a funnel. Specifies the funnel height. Specifies the funnel width. Specifies the funnel angle. Specifies the funnel mode (external or internal). Specifies whether the funnel should be applied on the left or bottom, on the right or top, or on both sides. Specifies the prefix for the main value of the associated text. Specifies the suffix for the main value of

Symbols > SymbolMode ExtensionLine > Color

ExtensionLine > Thickness

ExtensionLine > SlantAngle

ExtensionLine > Left > Hide ExtensionLine > Left > Overrun ExtensionLine > Left > Blanking ExtensionLine > Right > Hide ExtensionLine > Right > Overrun ExtensionLine > Right > Blanking ExtensionLine > Funnel > Display ExtensionLine > Funnel > Height ExtensionLine > Funnel > Width ExtensionLine > Funnel > Angle ExtensionLine > Funnel > Mode

ExtensionLine > Funnel > Side AssociatedTexts > MainValue > Prefix AssociatedTexts > MainValue >
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Suffix AssociatedTexts > MainValue > Before AssociatedTexts > MainValue > After AssociatedTexts > MainValue > Upper AssociatedTexts > MainValue > Lower AssociatedTexts > DualValue > Before AssociatedTexts > DualValue > After AssociatedTexts > DualValue > Upper AssociatedTexts > DualValue > Lower

the associated text. Specifies the text that should be displayed before the main value of the associated text. Specifies the text that should be displayed after the main value of the associated text. Specifies the text that should be displayed above the main value of the associated text. Specifies the text that should be displayed below the main value of the associated text. Specifies the text that should be displayed before the dual value of the associated text. Specifies the text that should be displayed after the dual value of the associated text. Specifies the text that should be displayed above the dual value of the associated text. Specifies the text that should be displayed below the dual value of the associated text. Specifies whether the frame subpart should display the value, the value and tolerance, etc. Specifies whether the framed group should display the main value, the dual value, both values separately, etc. Specifies the type of frame that should be used for chamfer dimensions. Note that fixed-size frames are defined in the Frame node of the current standard.

Framing > FramedSubpart

Framing > FramedGroup

Framing > Frame

Accepted values: none, circle, fixed-size scored circle, fixed-size diamond, fixedsize square, rectangle, oblong, right flag, fixed-size triangle Specifies the main value scoring. Specifies the dual value scoring.

Framing > MainValueScoring Framing > DualValueScoring
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Font > Name

Specifies the name of the font that should be used for chamfer dimension texts. If no font name is specified, the system's default font will be used. Indicates whether or not chamfer dimension texts should be displayed in bold. Indicates whether or not chamfer dimension texts should be displayed in italic. Indicates the font size that should be used for chamfer dimension texts. Specifies the color that should be used to display chamfer dimension texts. Indicates whether or not chamfer dimension texts should be underlined (in this case, overline cannot be applied). Indicates whether or not strikethrough should be used for chamfer dimension texts. Indicates whether or not chamfer dimension texts should be overlined (in this case, underline cannot be applied). Specifies the character width. Specifies the spacing between characters. Indicates whether or not chamfer dimension texts should be scaled according to the view or the 2D reference component's scale. Specifies whether chamfer dimensions should be displayed with one extension line or with two extension lines. Specifies the value format for the chamfer dimension (e.g. length/length, angle/length, etc.) Specifies the name of the secondary value display format for the main value. Specifies the number of factors displayed for the main value, according to the number of factors available for the value display format used by this style.

Font > Bold

Font > Italic

Font > Size Font > Color

Font > Underline

Font > Strikethrough

Font > Overline Font > Ratio Font > Spacing

Font > ApplyScale

Chamfer > DisplayType

Chamfer > ValueFormat Chamfer > SecondaryValueDisplayFormat > MainValue > Name Chamfer > SecondaryValueDisplayFormat > MainValue > DisplayedFactorNumber
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Chamfer > SecondaryValueDisplayFormat > DualValue > Name Chamfer > SecondaryValueDisplayFormat > DualValue > DisplayedFactorNumber

Specifies the name of the secondary value display format for the dual value. Specifies the number of factors displayed for the dual value (if any), according to the number of factors available for the value display format used by this style.

CoordinateDimension Styles Parameter Name Description

Specifies whether the screen, the view or the OrientationReference dimension line should be used as the reference for the coordinate dimension orientation. Angle AnchorPoint Specifies the coordinate dimension orientation angle according to the chosen reference. Specifies the coordinate dimension position in relation to the anchor point (e.g., top left, middle left, etc.). Choose the display mode you want for the coordinate dimension: - Show value: displays the dimension, its leader and its frame. - Show box: replaces the dimension and its frame by a rectangular box and displays its leader. - Hide value: hides the dimension and its frame but displays its leader. Specifies the name of the font that should be used for coordinate dimension texts. If no font name is specified, the system's default font will be used. Indicates whether or not coordinate dimension texts should be displayed in bold. Indicates whether or not coordinate dimension texts should be displayed in italic. Indicates the font size that should be used for coordinate dimension texts. Indicates whether or not coordinate dimension texts should be scaled according to the view or the 2D reference component's scale. Indicates whether or not coordinate dimension texts should be underlined (in this case, overline cannot be applied).

Display

Font > Name

Font > Bold Font > Italic Font > Size

Font > ApplyScale

Font > Underline
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Font > Strikethrough Font > Overline

Indicates whether or not strikethrough should be used for coordinate dimension texts. Indicates whether or not coordinate dimension texts should be overlined (in this case, underline cannot be applied). Specifies the color that should be used to represent coordinate dimension texts frames and leaders. Specifies the symbol (e.g. arrow, filled circle, etc.) that should be used for coordinate dimension leaders. If you choose the Automatic option, a default symbol will be used, depending on the standard type and on whether the leader is associated to an element or not: • If the leader is associated to an element: o Symmetric arrow (a.k.a. Unfilled arrow) for ANSI / ASME o Simple arrow for ISO / JIS If the leader is not associated to an element: o Symmetric circle (a.k.a. Unfilled circle) for ANSI / ASME o Filled circle for ISO / JIS

Graphic > Color

Leader > Symbol

•

DisplayUnit

Indicates whether or not units for coordinate dimension texts should be displayed.

Dress-up and Dress-up Symbols Styles
This section deals with dress-up and dress-up symbols styles. These let you define the default values that will be used when applying dress-up to elements. Defining Dress-up and Dress-up Symbols Styles Dress-up and dress-up symbols styles are located in the following nodes of the Standards editor, available via Tools -> Standards: • • • • • Styles Styles Styles Styles Styles -> -> -> -> -> AreaFill AxisLine CenterLine Thread Arrow

By default, a style called Default is available for each dress-up/dress-up symbol style. All the parameters associated to a given dress-up or dress-up symbol style are 544

Workbench Description listed in a dedicated table. The Description column provides a description of each parameter. All parameters are taken into account both at creation time (i.e. when creating the dress-up element or dress-up symbol), and at modification time (i.e. when reapplying a style to a dress-up element or dress-up symbol). Area Fill Style Parameter Name Pattern Description Specifies the name of the pattern (as defined in the Patterns node of the current standard) that should be used for area fills.

Axis Line Style Parameter Name Graphic > Color Graphic > LineType Graphic > Thickness Description Specifies the color that should be used to represent axis lines. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent axis lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent axis lines. Indicates whether or not the overrun between the element and its axis line is computed automatically. When set to Yes, this parameter overrides any value set for OverRunLength, and the overrun makes up 10% of the axis length. When OverRunAuto is set to No, specifies the length of the overrun between the element and its axis line.

OverRunAuto

OverRunLength
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InteractiveDrafting Center Line Style Parameter Name Graphic > Color Graphic > LineType Graphic > Thickness Description Specifies the color that should be used to represent center lines. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent center lines. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent center lines. Indicates whether or not the overrun between the element and its center line is computed automatically. When set to Yes, this parameter overrides any value set for OverRunLength, and the overrun makes up 30% of the radius. When OverRunAuto is set to No, specifies the length of the overrun between the element and its center line.

OverRunAuto

OverRunLength

Thread Style Parameter Name Graphic > Color Graphic > LineType Graphic > Thickness Description Specifies the color that should be used to represent threads. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent threads. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent threads. Indicates whether or not the overrun between the element and its thread is computed automatically. When set to Yes, this parameter overrides any value set for OverRunLength, and the overrun makes up 30% of the radius. When OverRunAuto is set to No, specifies the length of the overrun between the element and its thread.

OverRunAuto

OverRunLength

Thread styles only apply to threads viewed along their axis, whether in Interactive or Generative views. As a result, thread styles do not apply to such views as section views for example.
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Workbench Description Arrow Style Parameter Name Graphic > Color Graphic > LineType Graphic > Thickness Description Specifies the color that should be used to represent arrows. Specifies the number of the linetype (as defined in the LineTypes node of the current standard) that should be used to represent arrows. Specifies the line thickness index (as defined in the LineThickness node of the current standard) that should be used to represent arrows. Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for arrow heads. If you choose the Automatic option, a default symbol will be used, depending on the standard type: • • Filled arrow for ANSI / ASME Open arrow for ISO / JIS

HeadSymbol

TailSymbol

Specifies the symbol (e.g., simple arrow, circle, etc.) that should be used for arrow tails. If you choose the Automatic option, by default, no symbol will be used.
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