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Overview
Welcome to the Structure Design User's Guide. This guide is intended for users who need to become quickly familiar with the Structure Design product. This overview provides the following information: • • • • Structure Design in a nutshell Before reading this guide Getting the most out of this guide Conventions used in this guide

Structure Design in a Nutshell
Structure Design provides a set of tools for structure detailing and for designing small structure assemblies. This product addresses the detail design requirements of various industries. In particular it lets you: • • • • • • • Create planar plates and curved plates. Create linear shapes, bent shapes and twisted shapes. Split and merge shapes and plates. Define cutbacks and trim shapes. Place features such as cutouts, slots, end cuts, holes, etc., all of which can be in a central catalog. Create parametric assemblies such as brackets, collars, complex steel plates with numerous parts made of plates and shapes, all of which are in a central catalog. Include complete section catalogs covering DIN, AISC, EN and OTUA standards.

Structure Design uses the capabilities of Knowledgeware to create design features and to automate the generation of sketch-based profiles, pads and thick surfaces. It is the ideal tool for quickly designing steel assemblies for the construction, tooling and plant design industries. All commands share a consistent Windows graphical interface which reduces training time and is easy to use. As a scalable product Structure Design can be used with other products such as Drawing Generation and Project workbench.

Before Reading this Guide
Before reading this guide, you should be familiar with basic concepts such as document windows, standard tool bars, and view tool bars. We therefore recommend that you read Interacting in Digital Project User's which describes the capabilities common to all workbenches.

1

StructureDesign

Getting the Most Out of this Guide
To get the most out of this guide, start with the tutorial in the Getting Started section. The user task section of this book describes in detail the procedures for using all of the features of the Structure Design product. The procedures are divided into sections.
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What's New?
New Functionality
The recommended methodology for moving shapes, especially when they are part of a design, has been described.

Enhanced Functionality
The recommended methodology for applying offsets from the end of a shape has been added to the task.
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Getting Started
Getting Started
Before getting into the detailed instructions for using Structure Design, here is a short step-by-step tutorial that is intended to give you a feel of what you can accomplish with the product and will show you how to use some of the key functionalities. You will need a Version 5 session and should be familiar with basic concepts such as document windows, standard and view toolbars. You should be able to complete this tutorial in about 20 minutes.

Setting Up Your Session
This first task shows you how to enter the Structure Design workbench and set up your session. In this task, you will: • • • • Selecting the Project Resource Management (PRM) file Manage associativity Customize settings for parameters and relations Create a grid defining the overall dimensions of your project, or as a small foundation.

1.

Select Start -> Engineering -> Structure Design The Structure Design workbench is displayed.

Project resource Management
To use this product, you need to select the PRM file to access the various catalogs. For more Information about the PRM file, click here. 2. Select Tools -> Project Management -> Select/Browse Select the relevant project file and click OK.

Associativity
To ensure that you link the structure you are going to create with the grid
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StructureDesign used as a construction aid, set the following options. 3. Select Tools -> Options. 4. Click Tools -> Project Management in the left-hand box of the Options dialog box, then select the General tab. 5. Check Keep link with selected object and Synchronize all external references for update.

Visualizing Parameters and Relations
To display parameters and relations in the specification tree, set the following options. 6. Still in the Geometry category, select the Display tab. Check Parameters to visualize parameters in parts. 7. Click Project Center -> Project in the left-hand box of the Options dialog box, then select the Tree Customization tab. Set both Parameters and Relations options to Yes to visualize parameters and relations in products. 8. Click General -> Parameters and Measure in the left-hand box, then the Knowledge tab. Check With value to display parameters with values.

Creating a Grid
You will create a simple 3D grid defining the overall dimensions of your foundation. 9. Click the Grid icon.

The Grid Definition dialog box appears.
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10. Enter a name for the grid you want to create in the Name box: The grid will be identified by this name in the specification tree. 11. Specify Cartesian grid coordinates to define the grid: Enter the distance between grid points in Spacing boxes (1000 X 1500 X 750 mm respectively) as well as the number of points along x, y and z axes, 1 in each case.

12. Click OK to create the grid. The grid is created and is identified in the specification tree.
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Creating Shapes on Existing Supports
This task shows you how to create a first series of shapes making up the structural frame of your foundation. These shapes will all be created by selecting existing support elements, i.e. grid lines. To create shapes, you also need to define the shape section. Our scenario uses only one section which you will load from a catalog into your document. 1. Double-click the Shape icon.

The Shape dialog box appears.
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Note that the Section field is blank. 2. In the Section list, select Other section... The Catalog Browser dialog box is displayed and the catalog setup in the PRM file is opened. 3. Browse the list of families of available sections and double-click Equal_Angles (equal leg angle shapes): All the shapes in this family are listed.
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4. Browse the listed shapes, select L5x5x0.5, then click OK. The Section list in the Shape dialog box is updated.

5. Set the Type to Select support to create shapes on existing support elements. 6. Set the anchor point, anchoring the section along the support axis, to Bottom left. 7. Define the member support: select one of the grid lines.
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8. Set Orientation to 270 degrees, then click OK in the dialog box to create the shape. The dialog box appears again, ready for you to create the other shapes.

9. Create the other three shapes in the same way, taking care to orient them properly.
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StructureDesign Do not forget to check section orientation before clicking OK! Right-clicking the shape in the specification tree gives you access to the contextual menu and lets you make any necessary adjustments to the definition of your shape.

You will now create one vertical shape using the Select support type. 10.Set the Anchor point to Top right and orientation to 180 degrees, then select a vertical support line. 11.Click the Shape icon when done.

This scenario will show you how to perform the following tasks: • • Creating Point-to-Point Shapes Creating Cutbacks

Creating Point-to-Point Shapes

This task shows you how to create more shapes to complete the structural frame of your foundatio

This second series of shapes will all be created using the point to point method. To help define poi use the Point Definition command. 1. Double-click the Shape icon.

The Shape dialog box appears. If needed, click the right-hand icon in the status bar to show th Definition dialog box. 2. Set the Type to Point to point in the Shape dialog box.
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Getting Started 3. Click Point on member in the Point Definition dialog box, then select the appropriate shape, at the end nearest to which you want to create the current shape. The Start and End points of the section are identified in the geometry area; an offset of zero with respect to the selected end is displayed. An offset field also appears in the Point Definition dialog box. 4. Enter an offset of 200mm in the Point Definition dialog box, then click OK.

5. Define the other end of the shape by entering X,Y,Z coordinates (0, 1300, 0) in the Point Defin box. The shape is positioned but not yet correctly oriented. 6. In the Shape dialog box, set the Anchor point to Top right and enter an orientation of 270 deg click OK.

You will now create an assembly made of three shapes.
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8. Select a grid point as starting point, then define the second point 200 mm from this point using Definition dialog box. Note: The coordinates of the selected point are shown in the Point Definition dialog box.

This is shape 1. 9. Create the bottom shape using the point-to-point method, with the following criteria: • • • • Start coordinate 900, 1500, 300 End coordinate 900, 1500, 0 mm Anchor point: Bottom left Orientation: 180 degrees

10. Click the Shape

icon.

The shape (shape 3) you will now create will be defined with respect to points on existing shap 1 and 2). 11.Click the Point on member option in the Point Definition dialog box, then select a first shape at one end of the shape.
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Getting Started 12.Keep the default offset and click OK in the Point Definition dialog box.

13.Click Point on member to define the second point and select the end of the second shape, then click OK.

14.Check the anchor point and orientation and, if necessary, adjust, then click OK in the Shape dialog box.

• •

Anchor point: Bottom left Orientation: 0 degrees
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Creating Cutback
This task explains how to trim shapes to make smooth transitions.

To do so, you will need construction geometry to assist you. Construction geometry will be cre dedicated part. This geometry however must be created without any links to existing shapes s also be used to trim these very same shapes.

1. Uncheck the Keep link with selected object option in the General tab page of the Options dialog -> Options -> Project Center -> Geometry). 2. Insert a new part using Insert -> New Part from the menu bar and select Product1 in the spec tree. A new part is added to the specification tree. Expand the part instance and double-click on the part to switch to Geometry workbench.

3. Create two planes offset by 0mm from shape section surfaces of shapes 2 and 3.

4. Intersect the two planes. The intersect will be used as rotation axis in the next step.

5. Create a plane at half the angle between the above two planes. This is the plane to which we w shapes 2 and 3.
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Getting Started Use the Measure Between command to measure the angle.

6. In a new geometrical set (Insert -> Geometrical set), create another trim plane as above to tri and the other end of shape 3. 7. Recheck the Keep link with selected object option. You can now trim the shapes. 8. Double-click the root product to return to the Structure Design workbench. 9. Double-click the Cutback icon.

The Cutback dialog box appears.

10 Select Trim to plane in the Type list. .

11.Select one of the shapes (shape 3) to trim, then the trim plane and click OK in the Cutback dia
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StructureDesign 12.Repeat for shape 2.

13.Trim shape 1 and the other end of shape 3 to the other trim plane.

14.Repeat to create an identical assembly comprising three shapes, starting 200 mm in the Y dire the corresponding horizontal shape. Shape 4: • • Anchor point: Bottom left Orientation: 270 degrees

Shape 5: • • • •

Anchor point: Bottom left Orientation: 180 degrees Start coordinates: 900, 200, 0 End coordinates: 900, 200, 30

Shape 6: • • Anchor point: Bottom left Orientation: 0 degrees

Note: You can use the same trim plan the shapes of this assembly.
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Creating Plates
This task shows you how to create and place two plates. Plates are positioned with respect to existing structures and the plate contour is sketched. First, however, you must define the planes on which you will create the plates. You can continue to create construction geometry in the same part. 1. Activate the part containing the construction geometry to open the Geometry workbench, then insert a new geometrical set (Insert -> Geometrical set). Don't forget to work without links when creating construction geometry. 2.

Double-click the Plane

icon.

The Plane Definition dialog box appears. 3. Set Plane type to Through two lines. 4. Select an edge on the first shape.
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StructureDesign 5. Select an edge on the second shape, then click OK in the dialog box. The first plane is created.

6. Define the other plane you need.

7. Click the Plane icon again when done and reset links with selected objects. 8. Double-click the root product to return to the Structure Design workbench.
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Click the Plate

icon.

The Plate dialog box appears.

10.Set Type to Support and contour, then select one of the planes just created as support. 11.Click the Design table icon and set plate thickness to 10mm. 12 Define the plate contour: . • icon Click the Sketcher opposite the Contour field. The Sketcher workbench opens.

• • •

Click the Rectangle icon and sketch the plate contour. Constrain the sketch to correctly position the plate. Click the Exit Workbench icon to return to the Structure Design workbench.

The system previews the plate. 13.Click OK in the Plate dialog box to create the plate.
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14.Repeat to create the second plate.

15.Click the Plane icon when done.

Placing Cutouts
This task shows you how to place cutouts in the two plates just created. You will first sketch the cutout contour. You can do this be creating a new geometrical set in the Part containing the construction geometry. 1. Activate the Part containing the construction geometry to switch to the Geometry workbench, and insert a new geometrical set
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Getting Started Insert -> Geometrical set Don't forget to work without links when creating construction geometry. 2. Click the Sketcher icon, then select the plane in which you want to sketch the contour. The Sketcher workbench opens. 3. Using Sketcher tools, sketch the contour.

4. 5.

Double-click the root product to return to the Structure Design workbench. Click the Cutout icon.

The Cutout dialog box opens. 6. Select the two plates in which you want to place cutouts.

7.

Click the Contour field and select the contour you sketched, then a grid line in the Y direction to define the angle of the cutout. Note: When you make a multi-selection of plates, the After Forming cutting mode only is available.

8.

Click OK in the Cutout dialog box to place the cutout. Cutouts are visible in the geometry area.
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Placing Contextual Endcuts
This task shows you how to place a contextual endcut. A contextual endcut is a feature with multiple inputs that depends on external objects, in our case, another shape, to be placed.

1.

Click the Contextual Endcut

icon.

The Catalog Selection for Endcut dialog box opens listing the various shape section types for which endcuts have been defined.
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2. Double-click the Angle chapter, then Contextual Endcuts and select the endcut 'Getting_Started' in the lower part of the dialog box. The selected endcut is displayed in the preview. 3 Click OK to validate your selection. . The Instantiate Feature dialog box opens. The Feature field lists the selected endcut.

4 Select the active object, i.e. the . shape on which the endcut will be placed.
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5 Select the second shape from which . information is obtained before placing the endcut. 6 Click OK in the Instantiate Feature . dialog box to place the endcut. Note: The endcut is identified in the specification tree under the shape on which it is placed.

7.Place other endcuts as needed to connect the top four shapes.
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Placing Small Assemblies

This task shows you how to reinforce shapes with chocks -- small assemblies that are defined once catalog and replicated throughout the document as needed. The chock used is in the sample catalo supplied with the product.

Before placing the chock, you will need to create appropriate support planes to properly position th chocks you will create.

1. Activate the Part containing the construction geometry to switch to the Geometry workbench, a insert a new geometrical set Insert -> Geometrical Set Don't forget to work without links when creating construction geometry. 2. Create as many planes as needed to position your chocks.

3. Double-click the root product to return to the Structure Design workbench. 4. Click the Small Assemblies icon.

The Catalog for Small Assemblies dialog box lists the available types.
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5. Double-click the Chocks chapter, then select Chock for Getting Started in the lower part of the dialog box. The selected small assembly is displayed in the preview. 6. Click OK to validate your selection. The Insert Object dialog box appears.

7. First select the plane on which to position the chock, then select the shape you want to reinforce. Selected objects are identified in the Insert Object dialog box.
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The Parameters button becomes available. 8. Click Parameters to view chock parameters. The Parameters dialog box appears.

You can change Chock\length and Chock\length1. The small assembly was defined such that bo toe lengths as well as both chock lengths L1 are identical.
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StructureDesign 9. Close the Parameters dialog box by clicking Close and then in the Insert Object dialog box click OK to create the small assembly. The chock is created and an entry is added to the specification tree. You will now edit chock parameters to increase Chock\Length1. 10.Double-click the Length1 parameter in the specification tree.

The Edit Parameter dialog box appears. 11.for example, change the value to 60mm , click OK then update and watch the chock change size.

12.Repeat to create other chocks as needed.

Saving Documents
This task contains recommendations on saving your documents.
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Getting Started Ways in which documents are saved are explained in the Interacting in Digital Project-> Basic Tasks-> Managing and Sharing Data->Creating, Opening and Saving Documents. You must read that documentation because the various methods are not explained here. This task simply suggests the methodology you should follow in specific circumstances. 1. If you are saving a document to a local machine or network drive it is recommended that you use the "Save Management" command initially. The Propagate Directory command (which is in the Save Management dialog box) should not be used routinely. It is meant to be used in specific circumstances, such as when you want to place all the contents of a document in one directory before sending it to another location. 2. If you are saving a document to another site or network you should use the "Send To" command. In this case, you should be careful about the links for documents such as resolved parts folder or line ID. These links could change to reflect the local network drive to which the documents have been sent. You should make sure they point to the original location - using the Reset button in the Save Management dialog box is one way of doing this. 3. You should check the active document before you execute the Save command . The root product must be the active document if you want to save everything under it.
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Creating a Grid
Using grids lets you position structures more easily as well as design in context. You can create structures referencing geometrical grid elements. Design changes can then be introduced by modifying the grid and updating the structure in consequence. This task shows how to create a new grid that you can then use as a construction aid to create members. A grid is made of wireframe elements (lines, points and planes) and is identified in the specification tree. It can be created using either the Cartesian or Polar coordinate system. 1. Click the Grid icon.

The Grid Definition dialog box appears.

2. Enter a name for the grid you want to create in the Name box: The grid will be identified by this name in the specification tree. 3. Select Relative or Absolute in the Mode list to define the grid construction mode. • • In the absolute mode, grid planes are positioned with respect to the grid origin. Planes can be repositioned independently of one another. In the relative mode, grid planes are positioned with respect to each other. Moving a
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4. Enter absolute coordinates in the Origin box or select a point in the geometry area to define the grid origin. If you select a point, the point is identified in the dialog box. The grid origin is now linked to this point. 5. In the First direction in XY plane box: • • • In the Cartesian tab, enter H and V coordinates to define the local x-axis. Or, Click the Polar tab and enter an angle to define the polar axis. Or, Select a line in the geometry area.

Note: By default, the local x-axis is positioned along the absolute x-axis. If you select a line, the line is identified in the dialog box. The first direction is now linked to this line. 6. Specify grid coordinates: • In the Cartesian tab, specify the distance between grid points and number of points along x, y and z axes. Or, In the Polar tab, specify the radius, amplitude and spacing along the z-axis as well as the number of grid points in each case.
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Note: Clicking More expands the dialog box and lets you enter up to three more different combinations to define your grid.

7. Click OK to create the grid. The grid is created and is identified in the specification tree.
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Grid planes are associative: moving a plane will update the grid. This is useful when modifying a structure: move a plane (double-click to edit) and see the structure defined using the grid updated when you double-click the root product in the specification tree if the following options were set in the General tab in the Options dialog box (Tools -> Options, Infrastructure -> Part Infrastructure): • • Keep link with selected object Synchronize all external references for update.

36

User Tasks

Creating Plates and Shapes
Creating Plates and Shapes
Create plates: set parameters in the dialog box then select a support plane or surface, and if necessary define a contour. Create end plates: set parameters in the dialog box then select the end of the shape at which you want to place the end plate. Create shapes: set parameters in the dialog box then select an existing support or define where the shape starts and ends. Create small assemblies: select a catalog assembly then existing shapes or plates to position it.

Creating Plates
This task shows you how to create plates. Typically plates making up bulkheads, decks and floor plates are planar (flat), while those making up cylindrical or curved walls, sheer and camber decks, and corrugated walls are non-planar (curved) plates. Both planar and non-planar plates can be created using this command. Plates can be created by selecting: • Or, • 1. A support and a contour (planar plates only). . A support (both planar and non-planar plates)

With your product open, click the Plate icon
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2.

Specify how you want to create your plate from the Type drop-down list: • • Support Support and contour. In our first scenario, we have chosen this option.

Only planar plates can be created using the Support and contour option. 3. Set plate properties: • • Select a material and grade in the Material drop-down list. Click the Design Table icon and select a thickness from the design table, then click OK.

Material and thickness are managed as project resources. 4. Select the support plane to which the plate will be applied. The selected plane appears in the Support field.
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5.

Define the plate contour: You can define the contour: • By selecting points in sequence and closing the loop. An arrow normal to the support and identifying the direction of extrusion is displayed. As you select elements, a preview appears to guide you. Elements you select are projected onto the support plane. The distance the plate is offset from the support is also displayed.

• Or, • 6.

By selecting an existing contour

Using the Sketcher to define a contour (see below).

Click Apply when done. The Plate is created. You can still make changes to the Material and Thickness settings.
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7.

In the Offset box, type the distance to offset the plate from the support or use the arrows to set the distance. Offsetis calculated in the direction opposite that of the material throw orientation. In this example we have opted to use the Centerline. This enters a value for the offset corresponding to half the thickness of the material.

8.

Click the Reverse Direction option in the dialog box or the arrow in the geometry area to extend the plate in the opposite direction from that shown.
Using the Sketcher

Alternatively, you can use the Sketcher to sketch the plate contour. • • Click the Sketcher icon opposite the Contour field to open the Sketcher workbench. Use the Sketcher tools to create the profile for the plate.
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A sketch must not contain more than one external plate contour. • Exit the sketcher when done. The plate will be created.

9.

(Optional) Valuate custom attributes in the Custom Attributes tab. Any attributes added to the feature dictionary are proposed in this tab and can be valuated as you create your shapes. By default, no attributes are specified and this tab is blank. These attributes can also be browsed and edited via the Properties dialog box.

10. Click OK when done.

Selecting a Support Surface to Create a Plate
41
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You can create both planar and non-planar plates using this option. The following scenario illustrates a non-planar plate. The support geometry includes a spline and a sweep to create the support surface. 1. With your product open, click the Plate icon The Plate dialog box opens. 2. 3. 4. Set the Type to Support. Make the necessary changes to the Material, Thickness and Offset settings. Select the support surface to which the plate will be applied. The support surface can be planar or non-planar, and can be the existing face of a structure. The plate is immediately created on the support surface. .

5.

Click OK to close the Plate dialog box.

Creating End Plates
This task shows how to create a special type of plate called an end plate.
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User Tasks 1. With your product open, click the End-Plate icon. The End Plate Definition dialog box appears.

2. In the Material list, select the desired material. Note: Material is managed as a project resource. 3. Define the length, width and thickness of the plate using arrows to change the values or entering values directly in boxes. The length and width are defined with respect to the local axis system of the shape, for example, in the case of an I shape, the width is defined along the x-axis parallel to the flange and the length along the y-axis parallel to the web.

4. Select the end of the shape at which you want to place the end plate: A preview appears. An arrow identifies the direction of extrusion.

• •

To reverse the direction of extrusion, click the arrow or click Reverse direction in the dialog box. You can adjust all plate characteristics in the dialog box, then click Apply to preview the results.

5. Click OK when satisfied. The end plate is created as defined and is added to the specification tree.

Creating Several Identical End Plates by Multiple Selection
Simply Cntrl-click to select more than one shape end and have several identical end plates created in one go.
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Changing the direction of extrusion or other plate characteristics applies to all end plates.

Creating Shapes
This task shows how to create shapes. The Shape command allows you to create shapes of different sections, including curved or twisted shapes. There are two methods for placing a shape: • • selecting an existing support element (e.g., line, spline, arc, etc.) point-to-point

1. With your product open, click the Shape icon The Shape dialog box opens.

.
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2.To place a shape on an existing support element, choose Select Support in the Type field. 3.In the Section field, select the section you want to create for a specific location in the design. In this task we will create a steel I-beam shape. If there are no other choices in the Section field, click Other section..., and browse to the sections catalog. You have several choices of standard section types including: • • • • • • • I-beam Channel Tee Angle Square (tubes) Rectangular (tubes) Round (pipes)
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As sections are created in your model (or product), copies of the sections are added to a resolved directory. This resolved sections directory (or folder) is the source for the list of available sections when you click the drop-down arrow opposite Section in the Shape dialog box. The path for this resolved directory is managed in transparent fashion for the user. It can be managed by the administrator as a project resource. You can view the geometrical and mechanical properties of a section. To do so, right click in the preview window, or in any of the Properties fields in the Shape dialog box, and select Section properties from the contextual menu.

4.Click the drop-down arrow opposite the Material field to select the desired material-grade combination. Material-grade combinations are managed as a project resource. 5.Click the drop-down arrow opposite the Anchor point field to select the desired anchor point for the shape you are creating, or click a green dot in the section preview window to change the anchor point (red when selected). This sets the point on the section that contacts the support line.
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6.Use the arrows in the Orientation field to rotate the section in 90 degree increments. (This is the default rotation increment or step). You can change the rotation increment. Right click in the Orientation field to open the contextual menu and select Change step. Select 1deg or select new one and set the step value you want to use. 7 Select the support line on which you want to create the . shape. The shape is created directly. Note: Multi-selection of supports is available. To visualize selected supports, click the List icon or rightclick in the Support field and select Elements list from the contextual menu. The Elements list dialog box opens showing selected supports.

Shape Orientation
If the support line is vertical, the web of the shape (local Vaxis of section) is oriented toward the Y-axis of the document coordinate system.
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If the support line is non-vertical, the web is oriented toward the Z-axis of the document coordinate system. In the Shape dialog box, the selected support line will display in the Support field under Placement. • • You can change the section, material, anchor point and orientation and the view will update immediately to show the new settings. Use the Flip button to flip the section about its vertical axis.

•

Use the Reset button to return the section to the original orientation. (Reset is limited to the Flip and Orientation settings).

8.(Optional) Valuate custom attributes in the Custom Attributes tab. Any attributes added to the feature dictionary are proposed in this tab and can be valuated as you create your shapes. For example, a 'Type' attribute with discrete values beam, column, brace, etc.

By default, no attributes are specified and this tab is blank. These attributes can also be browsed and edited via the Properties dialog box. 9.Click OK when done.
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Similarly, you can create a shape on a curved support line. Using the Select Support method, simply select a curved line.

Creating Curved or Twisted Shapes
In the case of a swept or lofted surface in a design where a shape may curve or twist, you can create the shape normal to the surface. This is done using the Reference option in the Shape dialog box. • In a product utilizing a sweep or loft in the design, create a shape on a support line as described in the previous steps. In the Shape dialog box, click in the Reference field. Select the surface of the sweep as the reference. The name of the object appears in the Reference field and the shape becomes normal to the surface.

• •
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Using Point-to-Point to Create a Shape
This method requires no support. It lets you place shapes using points, a plane or an axis, and lets you define shape limits in different ways, for example by specifying a length. 1. With your product open, click the Shape icon The Shape dialog box opens. 2.To create a shape using the point-to-point selection method, select Point-topoint in the Type field. The Point Definition dialog box will open. 3.Make the necessary changes to the Section, Material, Anchor Point and Orientation settings, and (optional) valuate any attributes. 4.In the Direction list, select how you want to place the shape. You can place shapes using points, a plane or an axis. .
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Unspecified Planes and Lines
• When placing parallel to or on an unspecified plane, you must select a plane before defining shape limits. The plane is identified in the Direction support field and the shape is placed parallel to or projected onto the selected plane. Similarly, when placing parallel to an unspecified line, you must select a line before defining shape limits. The line is identified in the Direction support field and shape is placed parallel to the selected line.

•

Specifying an Offset to the XY, YZ or XZ Plane
Specifying an offset is particularly useful when creating shapes between existing structures. The offset is computed along the normal to the defined plane. • • Select the Offset checkbox and enter a value or use the arrows to change the value in the Offset field that appears. You can enter a positive or a negative value. Select wireframe elements or two existing structures.

This option is only available when the selected direction is parallel to the XY, YZ or XZ plane. 5. Define the limits of the shape you want to create. You can define the start and end points of a shape in different ways, by: • • • • • • Selecting 3D points Entering coordinates Retrieve coordinates using the 3D compass Creating a point on an existing structure using the Point on member option in the Point Definition dialog box. Specifying a length Selecting the end of an existing structure: The shape starts or ends at the end point of the support axis of the
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Entering Coordinates
• Enter the XYZ coordinates in the Point Definition dialog box or in the power input field in the status bar. You can combine coordinates and selection of 3D points when defining start and end points for shapes.

Retrieving Coordinates using 3D Compass
You can use the 3D compass in the Point Definition dialog box to retrieve point coordinates: • • • Drag the 3D compass to the location of interest. Select the 3D compass icon in the Point Definition dialog box. The compass coordinates are retrieved and taken as the start point. Repeat again if desired to define the end point.
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Creating a Point on a Existing Shape
You can also use the Point on member option in the Point Definition dialog box to define a point on an existing shape: • Click the Point on member option and select the existing section, or shape, of interest. The Start and End points of the section are identified and Offset will display a zero value. • Enter the value for the Offset. Or you can move your pointer over Offset. When it highlights red, click and drag the dot (Start or End point) to set the desired offset.

• •

Click OK in the Point Definition dialog box. Now, select the terminating point for the shape you are creating and click. The shape is created.
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Specifying a Length
• • • Enter XYZ coordinates or select a 3D point to define the start point. Select the Length checkbox and enter a value or use the arrows to change the value in the Length field that appears. Indicate in the geometry area to identify the direction.

6.Click OK when done.

Placing Features
Placing Features
Place and modify standard endcuts: select a shape, then standard endcuts at the start and end of the shape. Place contextual endcuts: select a contextual endcut, then inputs to define how it is positioned. Place and modify standard slots: select a plate, then the shape(s) penetrating the selected plate and a catalog slot. Place contextual slots: select a contextual slot, then inputs to define how it is positioned. Place cutouts: select a plate or shape, a cutting mode and a contour for the cutout. Remove and modify cutouts: select a plate or shape then the cutout and click Remove or Modify. Cope plates and shapes: select the strategy, the plate or shape to trim and then limiting elements. Note: This command is not directly available in the workbench.
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Placing and Modifying Standard End Cuts
An end cut is created on a shape to configure the mating ends for proper connection with another shape or profile and prior to applying a weld connection. A sample feature catalog containing end cuts is provided with the product. An end cut is a parametric object and, when you place one, it will size itself based on the formulas you defined when creating it. This task shows you how to create a standard end cut, i.e. a feature with no contextual inputs. This end cut feature does not depend on any external objects (other plates, shapes, planes, etc.) to be placed. You can also modify an existing end cut - see Step 8 to learn how to do it.

You can also place end cuts with contextual inputs:

1. With your product open, click the Standard Endcut which you want to apply an end cut.

icon and select the shape to

The End Cut Type dialog box opens and the Begin and End points of the shape will be indicated.
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You can select more than one shape, with the selected shapes displaying in the List of Shapes window. If you want to remove a shape from the list select it and click Remove. NOTE: You will not be able to select a shape that has end cuts at both ends. If the shape you selected already has end cuts they will display in the At Beginning and At End fields. In that case, you have to use the Modify command to change parameters of an existing end cut. 2.Select the Catalog Browser button to define the Beginning end cut type in the At Beginning field. The Catalog Selection for Endcut dialog box opens.
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3.In the Catalog Selection for Endcut dialog box, double-click Standard Endcut, then navigate to the chapter and family that contains the appropriate end cut type for the shape being used. Standard end cut refers to end cuts with one input. Contextual refers to end cuts with more than one input. Use the Filter button to narrow your search. Use the wild card (*) symbol at the end of the keyword (e.g., ENDCUT*) to include all entries with the keyword "endcut". The selected end cut type will preview in the Catalog Selection for Endcut dialog box. Zoom in to enlarge the image in the preview and to visualize the surface and edge parameters.
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If the parameters of the end cut do not match those of the shape you will be advised of mismatched or undefined parameters. An end cut is a feature that resides in a CATPart; therefore this condition must be corrected using Part Design.

4.Click OK in the Catalog Selection dialog box when you have selected the end cut. 5.Click Parameters... in the End Cut Type dialog box. The Parameters dialog box will open. This displays the default parameters for the end cut you selected. The number of parameters will differ depending on the end cut type. Change the parameter values as necessary, then click OK.
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This will return you to the End Cut Type dialog box.

6.Repeat to define the end cut type at the other end of the shape (at End field). 7.Click OK in the End Cut Type dialog box when done. The end cut is created.

Removing & Modifying Endcuts

59

StructureDesign

To modify endcut parameters or delete an endcut: • Right click the shape in the specifications tree. Select the shape in the drop down menu that displays and, in the next menu displayed, select Modify/Delete EndCut.

The Modify A Standard End Cut dialog box displays.

•

Click Parameters... to make your changes as needed, or click Delete to remove the displayed endcut.

Placing Contextual End Cuts
An end cut is created on a shape to configure the mating ends for proper connection with another shape or profile and prior to applying a weld connection. A sample feature catalog containing end cuts is provided with the product. An end cut is a parametric object and, when you place one, it will size itself based on the formulas you defined when creating it.
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This task shows you how to create a contextual end cut, i.e. a feature with multiple inputs. This feature depends on external objects (other plates, shapes, planes, etc.) to be placed. In our example, you will place an end cut on a large T-beam that must accommodate the smaller T-beam (input - shape1) to make a proper join. The end cut is placed on just one of the objects (called the active object).

You can also place a standard end cut feature:

It is important to know that this task describes only one behavior, based on the end cut "gatormouth" that is provided with this application. Most users will create their own end cuts (see Creating Catalog End Cuts) and the behavior will depend on how they define those end cuts. For instance, a user could define an end cut such that it places at both ends of a beam, instead of one end as described here. The image below shows two beams on which end cuts are to be placed.
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1. With your document open, click the Contextual Endcut Selection dialog box displays.

icon. The Catalog

2.Double click on the type of object on which you want to place the end cut, in this case a tee. You will be asked to select standard or contextual end cuts.
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Standard end cut refers to end cuts with one input. Contextual refers to end cuts with more than one input. 3.Double click on Contextual Endcut to display the different types of end cuts available to you in the catalog for this type of object (tee). In this case only a GatorMouth end cut is in the catalog. If there is only one end cut available then it will display in the window, as shown here.

4.Click OK and the Instantiate Feature dialog box displays.
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The Feature field lists the end cut you have selected. 5.Select the active object on which the end cut will be placed, in our example the large T-beam. The Active Object field displays displays the part number of the beam selected. 6.Select external inputs from which information will be obtained before placing the end cut on the active object, the smaller beam. In our example, there is only one external input: the small T-beam. The part number of the smaller beam displays next to the Shape1 field. These are the only inputs required by this end cut. Other end cuts you create may require more inputs, in which case you will be prompted to select them. 7.Click OK in the Instantiate Feature dialog box to place the end cut.
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Placing and Modifying Standard Slots
This task shows you how to create standard slots. Slots are added where necessary to allow passage of structural members, e.g. shapes or plates. 1. With your product open, click the Standard Slot The Slot dialog box opens. 2. Select the plate in your product through which shapes are penetrating and click the Add button. icon.

The Create A Slot dialog box appears. 3. Select one or more shapes. The shape identity will appear in the dialog box.
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To remove (deselect) a shape, select it in the list of Intersecting Objects and click the Remove button. 4. Click the Catalog Browser available slot types. icon to open the catalog containing the

In the Catalog Selection for Slot dialog box, navigate to the chapter and family that contains the appropriate slot type for the shape being used.
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User Tasks 5. Use the Filter button to narrow your search. Use the wild card (*) symbol at the end of the keyword (e.g., slot*) to include all entries beginning with "slot". Select the slot you need. The slot will preview in the Catalog Selection for Slot dialog box. Zoom in to enlarge the image in the preview window and to visualize the surface and edge parameters for the slot.

6.

If the parameters of the slot do not match those of the shape you will be advised of mismatched or undefined parameters. A slot is a feature that resides in a CATPart; therefore this condition must be corrected using Part Design.
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StructureDesign 7. 8. 9. Click OK in the Catalog Selectionfor Slot dialog box when you have selected the slot. This will return you to the Create a Slot dialog box. Click the Preview button to see the slot you created. In the Create a Slot dialog box, click the Parameters button. The Parameters dialog box opens. This displays the default clearance parameter for the slot you selected. The number of parameters will differ depending on the slot type. Change the parameter values as necessary, then click OK. This will return you to the Create a Slot dialog box.

10. Click OK in the Create a Slot dialog box. The slot is created. The Slot dialog box will open displaying the identities of the slot or slots created. If you want to remove a slot, click the Remove button. To modify a slot, click the Modify button. This will return you to the Parameters dialog box. Edit the values as necessary and click OK . 11. Click OK in the Slot dialog box when done.

Removing and Modifying Slots
You can remove or modify slots you create on plates and shapes. • Right-click the plate or shape in the specification tree and select Modify / Delete Slot from the contextual menu.

The Slot dialog box appears listing all slots created on the selected plate or shape. • • Click the Remove button to remove a slot Click the Modify button to modify a slot, then edit values in the
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Placing Contextual Slots
This task shows you how to create a contextual slot in a shape to allow passage of another shape.

Slots are added where necessary to allow passage of structural members, e.g. shapes or plates. Generic slots are features with multiple inputs. They depend on external objects (other plates, shapes, planes, etc.) to be placed. A sample feature catalog containing slots is provided with the product. You can also place a standard slot feature. 1. With your document open, click the Contextual Slot Selection for Slot dialog box displays. icon. The Catalog
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2.Navigate to the chapter and family that contains the appropriate slot type for the shape being used. Use the Filter button to narrow your search. Use the wild card (*) symbol at the end of the keyword (e.g., slot*) to include all entries beginning with "slot". 3.Select the slot you need.

70

User Tasks

4 Click OK and the Instantiate . Feature dialog box displays. The Feature field lists the slot you have selected. 5 Select the active object on which . the slot will be placed, in our example the larger shape. The Active Object field displays displays the part number of the shape selected. 6 Select external inputs from which . information will be obtained before placing the slot. In our example, there is only one external input: the smaller shape. The part number of the smaller shape displays next to the Shape1 field. 7.Click OK in the Instantiate Feature dialog box to place the slot.
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Creating Small Assemblies
This task shows you how to create a knee bracket. Small assemblies are defined as parts used in connecting together other structural parts (plates or shapes) in order to locally spread or transmit the loads. Small assemblies include brackets, doublers, diamond plates, transitions, etc. For the purposes of this scenario, create a simple model of two shapes approximating the image below.

1.

With the sample document open, click the Small Assemblies

icon.

The Catalog Selection for Small Assemblies dialog box opens. This catalog is
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2. Double-click to navigate in the lower panel of the dialog box and select the small assembly of interest. The selected assembly displays in the preview window. In our example, we have selected a knee bracket from the Brackets chapter.
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StructureDesign 3. Click OK to close the Catalog Selection for Small Assemblies dialog box. The Insert Object dialog box will then open. 4. Select the one of the shapes (STRMember) to position the small assembly, either in the specification tree or in the geometry area. The name will appear in the Selected column. Note: As you move your pointer over the selection, it will highlight in the tree and in the geometry area.

5. Repeat the process to select the other shape (STRMember). 6. Click OK when done. The small assembly, T-KneeBracket_1, is added.
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Placing Cutouts

This task shows you how to create cutouts. Cutouts are created in parts and are used for routing o like pipes through the part. 1. With your document open click the Cutout icon. The Cutout dialog box opens.

2.

Select the part in which you want to make a cutout.

Multi-selection of parts: you can select more than one part (click on the parts in the geome or specifications tree) if you want to create cutouts in all selected items at the same time. The Mode is limited to "After Forming" and the contour must exist in the document.
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If you select a shape or curved plate, click the Contour support field and select a plane to defin support for the sketcher or catalog contour, depending on your choice of contour. If you select a planar plate, this field is automatically filled.

Note: For a multi-selection of parts, the contour must exist in document. Neither sketched no catalog contours are available. 4. Define the contour: • • • Select an existing contour Using the Sketcher From a catalog.

Using the Sketcher
• Click the Sketcher icon to define a contour

For more information on the Sketcher, see the Sketcher User's Guide.

From a Catalog
•

Ensure that the Create new reference for each instantiation option in the Catalogs tab i selected (Tools -> Options, Infrastructure -> Catalog Editor).

•

Click the catalog icon to select a catalog contour.

A sample catalog of contours is provided with the product. This catalog is a project resource and as such is managed by the system administrator. The Catalog Browser opens letting you browse and preview the contents of the current catalog.
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•

Navigate through the list of families and the list of contours to select the contour of inte then click OK in the Catalog Browser.

The contour is positioned at the center of the selected support plane.

•

Use the 3D compass to position it as desired.
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The Contour field shows the contour you have selected or sketched. 4. Keep the default cutting mode to create an After Forming cutout. Two cutting modes are available: •

After forming (default mode): the cutout (in yellow below) will be directional (red arrow you can define the angle at which you want the cutout created.

By default, the normal to the selected contour is automatically proposed. •

Before forming: the cutout (in yellow below) will be created normal to the support surfa this case, you must select a support surface.

5.

Select a line that represents the angle you want the cutout to assume.

You can select a line in the part geometry to show this angle. You can also select a line in anot object, and the cutout will assume the angle that the other object has to the plate you are wo
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The cutout direction is associative which means that if you move the line, the cutout will updat automatically.

In the image below the user selected a line to indicate the angle of the cutout. You can see tha cutout angle matches that of the line.

The Reverse Direction option lets you project the contour used to create your cutout in the opposite direction. In our illustration of the passageway in an elevator cage, the contour (in blue) can be projected in one of two directions depending on where you want to locate the doorway.

7.

Click OK to place the cutout. The cutout will be given a name that will display in the Cutout dia

You can add more cutouts or click OK to exit. Each cutout that you create will be given a uniqu

Before Forming Cutting Mode
The cutout you create will be normal to a support surface. To create this type of cutout follow thru' 3 above, then:

4.

Set the cutting mode to Before forming. The Surface field becomes available.

5.

Select the support surface.

In the Before forming mode, you must select a support surface. The cutout will be created nor this surface.
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Removing & Modifying Cutouts
This task shows you how to remove and modify cutouts via the Cutout dialog box. Cutouts are created in parts and are used for routing objects like pipes through the part. Cutouts are part features and can also be deleted by activating the part and selecting Delete from the contextual menu. 1.In the specification tree, right click the plate, select PlateXXX in the drop down menu that shows, and then Modify/Delete Cutout.

The Cutout dialog box opens. Existing cutouts in your part are displayed in the box.
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2.Select a cutout in the Cutout dialog box. The Modify and Remove buttons become available.

Modifying a Cutout
3.To modify a cutout, click the Modify button. The Modify A Cutout dialog box displays.

4.Click in the field that you want to modify, in this case the Contour field. The cutting mode cannot be changed but you can modify other attributes if they were defined when the cutout was created. 5.Select the contour you want to use to replace the existing contour. You can use an existing contour, or you can use the Sketcher to draw a new profile. If you are using the Sketcher, you can draw on top of our existing contour (as shown in the image below) or draw elsewhere in the part.
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6.Exit the Sketcher, and click OK in the Modify A Cutout and Cutout dialog boxes. The cutout is modified.

Removing a Cutout
3.To remove a cutout, click the Remove button, then OK to exit. The selected cutout is deleted.

Modifying Plates and Shapes
Modifying Plates & Shapes
Define cutback: select a shape then a plane. Split plates and shapes: select one or more plates and/or shapes, then a wireframe element. Merge plates and shapes: select two plates or two shapes. Modify shapes: right-click the shape in the specification tree and select Definition, Extend or Stretch, then make appropriate changes.

Defining Cutback
The Cutback command lets you define how shape ends are cut. If you modify the shape, the cutback is automatically recomputed.
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No sample document is provided. 1. Click the Cutback icon.

The CutBack dialog box appears. None is the default cutback type.

Other types available are: • • • • • None: no cut. This option lets you remove a previously applied cutback. Normal cut: ends of shapes are cut perpendicular to the support axis. Weld cut: a cutting plane is used to cut the shape you want to trim. Miter cut: shapes are perpendicular with ends cut at an angle. Remove: material is removed from the shape you want to trim to accommodate the other shape.

The result differs depending on the first shape selected.
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Offset
The Offset option is available for Normal cut, Weld cut and Miter cut types. Use the arrows to change the offset value or enter a value directly in the box to offset the shape you want to trim from the trimming plane. 2. 3. Select the shape you want to trim. Select the plane to which you want to trim the shape: The plane can be a plane, face, surface, plate or another shape. 4. Click OK to create the cutback. Shapes are trimmed to the plane defined by the trimming member and the cutback is identified in the specification tree.

Curved Shapes
Curved shapes cannot be trimmed because the cutting plane may intersect the curve at more than one location.

Normal & Weld Cuts
To apply normal or weld cuts to all shape ends in the following configuration:
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• •

Join shapes 1 & 2, 2 & 3 and 3 & 4 using normal or weld cuts. When joining shapes 4 & 1, select shape 1 as the shape to trim. Note: The cut cannot be made if shape 4 is selected as the shape to trim.

Miter Cut
You cannot apply a miter cut to a shape that is already mitered. If the shape (shape 1) you want to cut is already mitered:
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•

Apply a miter cut to shapes 1 and 3.

Note: You can apply a normal or weld cut to a shape that is already mitered.

Splitting Plates & Shapes
You can split one or more plates and shapes by one or more wireframe elements (surfaces and curves).
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This task shows how to split a shape. No sample document is provided. 1. Click the Split icon.

The Split dialog box appears.

2.

Select the shape. You can select one or more plates and/or shapes. icon becomes active when you select more than one item. The List Click this icon to view selected plates and shapes in the Elements list dialog box.

3.

Click the By field and select the wireframe element used as cutting element: You can select a surface or a curve. Note: Multiple-selection of wireframe elements is also possible.

4.

Click OK to split selected plates and/or shapes. The original element is redefined according to split specifications, and a new element is added. Features and attributes of the original element are copied to the new element.
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You can also select the plates and/or shapes you want to split before clicking the Split icon. The Split dialog box opens and you can then select the cutting element. Click OK when done.

Merging Plates & Shapes
This task shows how to merge two plates or two shapes. To be merged, specifications (guiding curves, references, molded surfaces) of plates and shapes must be matching in tangency. 1. Click the Merge icon. The Merge dialog box appears.

2. Select the two plates or shapes you want to merge.

The first item selected is the reference. 3. Click OK to merge selected plates and/or shapes. The reference element is redefined according to merge specifications. Any features defined on the second item selected are lost.

88

User Tasks

You can also select both plates or shapes before clicking the Merge icon. The first item selected is the reference.

Modifying Shapes
You can: • • • Modify shape properties and placement (Definition). Add a positive or negative offset at shape ends (Extend). Stretch unconstrained linear shapes (Stretch).

All modifications are done via the contextual menu on the shape selected in the specification tree. Note: You cannot select the shape you want to modify in the geometry area. This task shows how to modify individual shapes. No sample document is provided. 1. In the specification tree, right-click the shape you want to modify and select the type of modification you want to make from the contextual menu.

If you have created a large number of shapes, right-click the shape of interest in the geometry area then select the Center Graph
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You can modify shape properties and placement. You can change the method used to place a shape from Point to point to Select support, but not vice-versa.

•

Extend: the Limits Definition dialog appears. o Set new values in offset boxes, and/or o Click the Limit text
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o

•

Stretch: a graphic manipulator is displayed letting you stretch the unconstraine d linear shape along the main axes of the section. Stretch your shape and click OK in the Point Definition dialog box when done.

Important: This command is only available for unconstrained shapes, i.e. those created by entering coordinates or with the Keep link with selected object
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Modifying Designs
This task explains ways of modifying a design. This function allows you to move a single stand-alone shape, or one that is already part of a design. When the shape is part of a design then the rest of the design will update to accommodate the modification you make. 1. With your document open, double click the grid to make it active, and then double click the plane that corresponds to the direction in which you want the shape to move. The plane becomes active, and the Plane Definition dialog box opens.

.

The Offset value in the Plane Definition dialog box is measured from the 2. Reference plane, as shown above. Enter a new value in this field and click Preview.

3. Click OK to accept the changes, or Cancel to begin again. After clicking OK you must make the Product in the specifications tree active, and click the Update Summary button to update the document.
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Managing Sections
Managing Sections
Sections must be resolved before being placed. Users can use the methodology described here for creating parametric catalogs to store sections in. However, sections must be resolved before actually being placed. A tool is being provided to convert parametric parts to resolved sections (included in this section). Also, administrators need to note that the name of the structure sections catalog and the default location where sections are stored has changed, as noted in the Project Resource Management file.

Sketching Profiles for User Sections
This task shows how to sketch profiles for user sections using Sketcher capabilities. No sample document is provided. 1. Start the Geometry workbench (Start ->Project Center ->Geometry). 2. Select the sketcher command and click on the xy working plane in the geometry area or specification tree. The Sketcher workbench is displayed.
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StructureDesign User sections created using Sketcher capabilities must be created in the xy plane. 3. Sketch your profile, for example use the Circle icon to sketch a simple circle that will give a round bar or circular tubing section: • • • Point where you want to place the center of the circle. Drag to set the radius. Click when satisfied.

Note: It is recommended that profile dimensions match actual section dimensions. 4. If desired, set constraints. 5. Exit the sketcher. 6. Using File -> Save, save the sketch as a CATPart document in the folder dedicated to storing available sections defined in your settings (see the Customizing section of this guide). Your sketch now appears as a resolved section in the Section list of the appropriate dialog box. You are now ready to use it to create a structure.

For more information on sketching profiles and setting constraints, see the Sketcher User's Guide.

Naming Section Characteristics
Naming section characteristics is typically a setup task. This involves identifying all sketch features explicitly with a user name in accordance with a pre-defined naming convention. The

94

User Tasks

advantage of such a naming convention in which user names (web flange1 edge, molded web edge, molded flange1 face, etc.) are standardized is that designers can then easily replace one structural shape by another. Before naming section characteristics, you will need to draw shapes using the Sketcher. Sections of structural shapes thus named are then stored in a catalog for the designer. This task shows you how to identify section characteristics. Have sketched a structural section. For more information on sketcher capabilities, see the Sketcher User's Guide. 1. Click the Name Section Characteristics The Section dialog box appears. icon:

2.Specify the location of the folder containing user sketches. You now have access to any sketches stored in the selected folder. A sample set of named sketches are supplied with the product and are located in folder install_folder/startup/Catalogs/Structural Steel/Sketches.
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4.Name sketch edges using the contextual menu: • Right-click a line and select the name from the list of pre-defined names in the contextual menu.

Note: Names in the contextual menu have been filtered and correspond to the type of shape (I, L, C, or T) you want to identify. A sample set of all user names are defined in a table supplied with the product. This table, CATStrSectionNamingKeys.CATNIs, is located in folder install_folder/resources/msgcatalog. The file mapping user names to different categories of shape is managed as a project resource.

96

User Tasks

5.Repeat to identify all sketch edges.

6.Click OK when done. Examples below show default names for typical shapes.
Typical I Shape: Typical L Shape:
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Typical T Shape:

Typical C Shape:

You can create a catalog of these sections that designers will use when creating stiffening and beaming systems.

Defining Anchor Points for Sections
Anchor points can be defined on user-defined parametric sections. Note: All resolved sections automatically inherit the defined anchor point. This task shows how to define an anchor point. No sample document is provided.
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User Tasks 1. 2. Edit the sketched section. If the anchor point you want to define does not correspond to an existing point of the sketch, create an appropriate construction point. Rename the point: • • • Right-click the point and select Properties from the contextual menu. Select the Feature Properties tab in the Properties dialog box. Rename the point using the prefix catStr, for example catStrUserAnchorPoint.

3.

4. 5.

Exit the sketcher, then save the sketch as a CATPart document (File ->Save). Return to the Structure Design workbench: The new anchor point is automatically added to the Anchor point list. All user anchor points are accompanied by the following symbol: to distinguish them from standard anchor points. Anchor points WebSideLeft, WebSideRight and WebCenter are supplied with the product for L, T and bulb sections. These anchor points are considered user anchor points and share the same anchor point symbol:

Generating Resolved Parts from Parametric Parts
This task shows you how to generate resolved parts from parametric parts. Each parametric part that you use to generate resolved parts must refer to a design table. The design table must have a column called "PartNumber", which should have a value. This value is used to name the generated resolved part. Structure parts must have a parameter called "ProfileType". New or existing parameters "PartNumber" and "SectionName" will be valuated with the part number from the design table. New parameters called "FamilyName" and "CatalogName" will be created unless they exist already (the name of the parametric part will be used to valuate these parameters if they do not exist, using the following naming convention: catalogname_familyname.CATPart). The "FamilyName" parameter is used by the automatic catalog creation
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StructureDesign function (Create/Modify Catalog) to place parts under different catalog families. 1. Create a directory and place in it the parametric CATPart documents and associated design table documents. 2. Create a directory in which output resolved CATPart documents will be placed after the program finishes executing. 3. Open a command prompt window and change to the directory ...intel_a\code\command. Type the following and press Enter: CATCloGenerateResolvedParts.bat <directorypath1> <directorypath2> appl Structure where: <directorypath1> is the full path name of the input directory you created in Step 1, including the drive letter, e.g. C:\ParametricParts. <directorypath2> is the full path name of the output directory you created in Step 2, e.g. C:\ResolvedParts. If no output directory is specified, resolved parts are placed in the input directory <directorypath1>. -appl Structure is an argument that ensures the proper migration of applicative parametric parts. 4. After the program finishes executing, the parts are placed in the output directory created in Step 2. Each part has as its name the entry from the part number column of the design table. The design table association is removed from the generated resolved part. 5. Add the parts to a catalog. Your resolved parts have a valuated parameter called "FamilyName" and you can take advantage of the new Create/Modify Catalog function available in the Catalog Editor: • • • • • Open a new catalog document Select the Create/Modify Catalog icon Define an Application (e.g. StructureDesign) Define the Parts directory Click OK.

New families are added to your catalog and your parts are added under the appropriate family. You can also modify an existing catalog that may already have the families defined.

Renaming Nodes in the Specification Tree
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Overview
The Rename Tree Nodes tool allows for quick product and part name changes. This tool can be accessed as: in the Structure Tools toolbar

The Dialog Box
This is the dialog box for the renaming tree nodes command.

The fields (they have been filled in as an example): • • • • Replace textbox: Enter the old name to replace (Column). With textbox: Enter the new name (VerticalMember to replace Column). Products checkbox: When this is checked, then all products will be affected. Parts checkbox: When this is checked, any parts and their instances will be affected.

Example Specification Tree
Before Renaming After Renaming
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Notes / Basic Concepts
Not Necessarily the Entire Name
Note that only the portion of the name that matches the Replace field is replaced by the With field.

Entire Tree
Searching begins from the root product. A product or part is checked on whether its name should be changed regardless of its Hide/Show property.

Part Instances
As you may have noticed in the Example Specification Tree section, part instance names are searched if the Parts option is selected.

Spaces
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Then nothing in the image below would be replaced.

If spaces are in fact needed, be sure to include the correct number.

Case-Sensitivity
The renaming tool is case sensitive. This means "Part" does not equal "part", does not equal "PART", etc.

Multiple Occurrences
The first occurrence of the value entered in Replace will be changed in a name. This may mean the Rename Tree Nodes command will need to be run more than once if all instances need to be replaced. It also indicates a more specific value may need to be entered in Replace.

103

StructureDesign Take the example below. Say given the original tree, we want to say Steel A100 instead of Steel A36. If we are not explicit enough in the Replace field such as in Case 1, we do not get the intended outcome because the first instance of 36 in the name of a product or part is replaced. To get the results we want, we will have to do something similar to Case 2.

The Original Tree

Case 1

GIVES US :

Case 2
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GIVES US :

Reporting the Specification Tree
Overview
The Tree Reporter reports products and parts in the specification tree. This tool is available as: in the Structure Tools toolbar

The Dialog Box
The dialog appears as follows:

The File field in the dialog is the directory and filename where you choose to export the file.

Report Fields
The following fields appear in the exported report: • • Path : The directory the product or part is stored. This field is empty if the product or part has not been saved yet. Name : The filename of the product or part.
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Example
Example Tree Structure

Resulting Output (Opened in a Spreadsheet Application)
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Notes
• • • • • The output of the Tree Reporter is in CSV (Comma Separated Values) format. To view it, open the file in a spreadsheet application. Product and part objects are reported regardless of their Hide/Show property. The tree reporter generates information an all products and parts in the tree. The tree report starts from the root product. Part instances are not reported. The Tree Structure field attempts to mimic the specification tree hierarchy. Hence the waterfall-like output for the Tree Structure as seen in the Example on this page.
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Workbench Description
The Structure Design Version 5 application window looks like this: Click the hotspots to see related documentation.

Toolbars
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Physical Plates and Shapes

Creating plates Creating end plates Creating shapes Creating small assemblies Placing cutouts Placing and modifying standard endcuts Placing contextual endcuts Placing and modifying standard slots Placing contextual slots Defining cutback Splitting plates and shapes Merging plates and shapes

Tools

Creating a grid Naming section characteristics
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Managing Your Project
Working with a Cache System
To improve system performance when working with very large documents, it is recommended that you activate the cache. This means that documents will be loaded in visualization mode, however, when editing structural items such as stiffeners, shapes or molded forms, the item is automatically switched to design mode. Any entities used to define the item you want to edit are also switched to design mode. Any new structures are created in design mode in the document. The cache system is managed via the Cache Management tab in the Options dialog box (Tools -> Options -> Project Center -> Project). For more information see Customizing Cache Settings in the Customizing section of the Infrastructure User's Guide.

Managing Project Resources
Managing Project Resources

Project resources are managed by a system administrator. Typically a system administrator enter paths for resources, like user dictionaries such as the feature dictionary). You can see what the ad dialog box (Tools -> Project Management -> Select/Browse...), but it cannot be changed there.
Setting up the Environment

To enable access to various resources (e.g. the Catalogs), you must set the variable in the Enviro Start -> Programs -> Digital Project -> Tools -> Environment Editor This will open the dialog box in which you can enter for the line containing CATDisciplinePath, the

A sample project resource management (PRM) file is provided [Project.xml]. By default, the applic copy to suit the requirements for a particular project.
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Project Resources

A resource entry looks like this:

<Resource Name="StructureDesignIDSchema" Description="Structure Design ID Schema Direc <ID Type="Path" Driver="File" Location="..\Catalogs\Structural Steel\DataDictionary"/ </Resource> • • • •

You should not change the Resource Name, even if you replace a resource with a different You can change the Description if you want to - this is a brief explanation of the resource. The Type field refers to file type. For the type Path, the Location field will only contain the d You can define the Location field using the code above as a guide. In the resource example in the Environment Editor as shown in 'Setting up the Environment'. The entry in the loca and that is where the application will look for the resource. NOTE: This is why it is preferable to enter absolute paths - including the drive letter - in • Some resources have the entry Visible = yes. If you set the value to no then this particular Tools -> Project Management dialog box.
Structure Discipline Resources

The following Structure Design-related resources are managed in this file. •

ID schema resource: The location lists the directory where the rules for naming objects a

• Feature dictionary: The CATfct file that manages object classes and in particular, lets the u CATStructureDesignUserDictionary. • Discrete values for attributes: Directory used to store discrete values of attributes.

• ID Sequence Number: The IDSequenceNumber directory contains the last sequence num it..

• Reference grid system: Location of the CATPart that contains the reference grid definitio location of the CATPart or rename it. • Naming section characteristics: Location of the NLS file that lists names of sections whose change anything in this entry.

• Structure sections catalog: contains structure sections identified in accordance with use resolved sections.)

• Structure sections path: The directory where resolved structure sections are located bef
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• Structure materials catalog: Defines all materials and grades available to the structural Note: No tiffs letting you view objects in the Materials mode have been delivered. • Thickness table: Defines all plate thicknesses available to the structural engineer. A sam or add to the sample thickness table, or, if needed, create a new table.

Note: If you change a thickness value in an existing design table, all plates of this thickn in mind, you may prefer to add a row for the new thickness or create a new table.

• Structure drawing symbols catalog: Location of the catalog with drawing symbols for u • Detailing features catalog: Contains Slots, Endcuts and Assembly templates. • Structure openings catalog: Contains a sample catalog for cutouts.

• •

If there is more than one project at your site, then a project resource management (PRM) session using the PRM command (Tools -> Project Management -> Select/Browse...). To check the required and optional resources in the PRM file for errors, see Checking a PRM

Using the PRM Command
This task shows how you can select a project for your session. 1. From the Structure Design workbench, launch the project resource management (PRM) command by selecting Tools -> Project Management -> Select/Browse from the menu bar. The Project Resource Management dialog box appears:
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Note: when the dialog box appears, by default the last project that you used is selected. The Select tab lists all the XML project setups found in the directory defined by the environment variable CATDisciplinePath. 2. Select the project of your choice, for example, Project. The corresponding PRM file is read and the disciplines it contains are listed. 3. Select the corresponding discipline, here Structure. Click OK to use the project and discipline you have selected. 4. The following optional step enables you to list resources for a particular discipline.

Select the Browse tab. Once a project and a discipline have been selected, the dialog box lists all the resources defined for the chosen project and discipline.

When the Project Resource Management dialog box first appears. It may contain a third tab - XML Parsing Error. This indicates that there is an XML syntax error in the file

114

Project Standards

corresponding to the Project you have chosen.

Click the XML Parsing Error tab to display the error.

You will need to correct the PRM file to get remove the error. Checking a PRM File for Errors explains errors in defining resources in the PRM file.
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Checking a PRM File for Errors
This task shows how to check a project resource management (PRM) file for certain errors. See Using the PRM Command for information about syntax errors in the PRM file. The environment variable CATDisciplinePath should be defined to point to the directory where your PRM files are stored. 1. Click Tools -> Project Management -> Validation in the menu bar to bring up the Project Management Validation dialog box. When the dialog box opens, the active project, discipline and application will be selected by default. 2. Select a Project, Discipline and Application as necessary. If you select ALL in the Discipline and Application fields then the entire project resource management file will be checked (required and optional resources only). 3. Click Apply after you have made your selection. The dialog box will display any of the resources with errors. • • • • If there are no errors then a message will state that all required - or optional - resources are OK, in the Status column. Select a resource to see more information about the error in the Selected Resource field below. Click on the column headings to sort by that heading. A Y in the Required column shows if a resource is required. No entry means it is an optional resource.

4. The errors are explained below: • • • Resource definition has incorrect type: The value of the 'Type' field in the resource's PRM entry is incorrect. The Type field refers to file type. See the PRM task for more information. Resource not found in the project management xml file: There is no entry for the resource in the PRM file. Resource Data not found: The file or directory corresponding to the resource
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•

cannot be found at the location defined in the PRM file. Access specified for location for resource is not correct: Some entries have a field called 'Access'. This refers to the permissions set for the file corresponding to the resource. One common error is that some files need to have access set to allow both read and write (RW) and not read only (R).

5. To save the report, click the Export button and enter a file name and location in the Save dialog box. The file must be saved in .htm format and have an htm extension (e.g. errors.htm).

About the Feature Dictionary
The feature dictionary manages object classes. Object classes are classifications under which you create various objects, like components, for storing in the catalog. In the sample dictionary provided with the application, CATStructureDesignSample.CATfct file, two basic classes are managed: plates and shapes. Note: You cannot add subclasses under plates or shapes, but you can add attributes and their values. For example, you may want to specify an attribute 'Type' for shapes with a list of discrete values like beam, column, brace, etc. Any attributes defined in the feature dictionary are proposed to the user in an Attributes tab when creating plates and shapes and can be valuated by the user directly in this tab. Values can also be added to attributes using the Edit Properties function. To view the sample dictionary, open the CATStructureDesignSample.CATfct file, which is located, by default, in the install_folder under /resources/graphic. The Feature Dictionary Editor opens showing the sample dictionary.

You can also define or modify object naming rules using the Define ID Schema command in the Feature Dictionary Editor workbench.
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Starting the Feature Dictionary Editor Adding Properties to an Object Class Defining Discrete Values for a Property Modifying the Object Naming Rules

Query or Modify the Properties of and Object
Querying or Modifying the Properties of an Object
This section explains ways of querying and modifying the properties of objects.

Edit or Display Properties of an Object
This task shows you how to edit or display the properties of an object. 1. Select the component. 2. Click Edit - Properties or, as an alternative, right-click and select Properties. The Properties dialog box appears with the properties displayed under various tabs. Some of these properties are computed and cannot be modified. To see which properties are computed click the Filter button.
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If the object cannot have derived values, the Derived checkboxes will not display. If a Derived checkbox is selected, it means the value is derived. If it is not checked the values are not derived. A value is considered to be derived when it is obtained from another object. For instance, a piping route may derive the values of some properties from the line of which it is a member. The Properties dialog box displays several tabs: • • • • The Graphic tab allows you to change the looks. The Object tab displays information about the object such as ID, Function Class, Parent Group or Group Members, depending on the object being queried. Under the Product tab you can make changes to the basic Product in the specifications tree, such as renaming. You can include additional descriptive and historical data. One or more application tab - such as Piping or Equipment - lists various properties. They will display depending on the class of object whose
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StructureDesign properties you are editing. Click the More button if one of these tabs does not display, or if you want to see other tabs. More than one tab may display for some objects, such as Piping and Equipment, if the object has properties in more than one domain. The filter button lets you use the filter function. See Filter the Properties of an Object.

•

See Infrastructure documentation (Basic Tasks - Manipulating Objects Displaying and Editing Graphic Properties) and Product Structure documentation (User's Tasks - Modifying Component Properties) for more information. 3. Enter values in the fields as desired and click OK. The properties will be edited. 4. You can override derived values by modifying the values as outlined in Step 3. The Derived checkbox will become unchecked. You can also override derived values by unchecking the Derived checkbox. To revert to derived values check the Derived checkbox. 5. Click OK to end. Some objects have discrete values - which means you may only select certain values. In that case you will be able to display a drop-down box and select one of the values in it.

Filter the Shown Properties of an Object
This task shows how you can filter the properties of an object. Filtering the properties means you can choose to display or hide any of the properties shown in the Properties dialog box. You can only filter properties for objects that are unique to the Design application you have open. Note that any changes you make will apply to all objects that have this property. To make changes for a class or subclass only see Changing the Display Order of Properties. The following scenario features Hanger Design, but the process applies to all applications, including Diagrams. 1. Click the Filter button on the Properties dialog box (Edit or display properties of an object). The Attribute Filter box displays.

120

Project Standards

An X in the column Show means the attribute is displayed in the Properties dialog box. An X in the column Computed means the attribute is computed. If you check the checkbox Show Only Attributes with Value, then only attributes that have a value will display in the Properties dialog box. 2. Click on each property to toggle between Display and Hide. An X next to a property means it is displayed. The settings will be retained when you open the Properties dialog box again.

Catalogs
Creating & Completing Parametric Section Catalogs
This task shows how to create a user catalog for parametric sections. There are three ways to create user catalogs:

1. Using the Catalog Editor with one sketch corresponding to one family and linked to one des 2. With a Part Family in Batch Mode with one sketch corresponding to one family and linked to 3. In Batch Mode where one sketch is used for several families and design tables are not linke the same way as the sample catalogs supplied with the product.

Sample CatScript documents are provided to illustrate the batch mode and will be mentioned below are in the online documentation. If you installed the documentation in documentationPath where path to the folder Then the samples will be in documentationPath/English/online/cfysm/samples

Creating a Catalog using the Catalog Editor
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This first task introduces the Catalog Editor workbench by creating your own catalogs. 1.

Make a USER directory with the same name as your catalog and sub-directories for sketches a • • USER/Sketches USER/DesignTables

2.

Sketch the profiles for your user sections and store in the USER/Sketches directory.

Standard sketches of parametric sections (I, U, L, T, double U, double L, bulb and tube shapes directory install_folder/startup/Catalogs/Structural Steel/Sketches where install_folder is t Project. 3. Create design tables, naming the header in the first column PartNumber. Note: You can create design tables in two ways:

1. Independently of sketches. In this case you must link tables to sketches (ensuring tha to sketch parameters). 2. Based on the sketches. No linking is necessary. Design tables contain the geometric parameters used to generate the section.

4.

Use the Catalog Editor to create your catalog: • • From the Start menu, select Project Standards -> Catalog Editor to open the Catalog E Use Add Part Family for Structure Design catalogs.

For more information, see Creating a Catalog using the Catalog Editor in the Catalogs User's G

Creating a Catalog with a Part Family in Batch Mode
1.

Make a USER directory with the same name as your catalog and sub-directories for sketches, Variable) files that can be read by spreadsheet programs. In this example all sub-directories a • • • USER/Sketches USER/DesignTables USER/CSVFiles
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Sketch the profiles for your user sections and store them in the USER/Sketches directory.

Standard sketches of parametric sections (I, U, L, T, double U, double L, bulb and tube shapes directory install_folder/startup/Catalogs/Structural Steel/Sketches where install_folder is the folder where you installed Digital Project. 3. Create design tables, naming the header in the first column PartNumber. Note: There are two ways to create design tables:

1. Independently of sketches, in which case you must link tables to sketches (ensuring th to sketch parameters). 2. Based on the sketches, in which case no linking is necessary. Design tables contain the geometric parameters used to generate the section.

4.

Create a CSV-type file for Chapters. CSV files map family names to appropriate family catalogs.

Chapters correspond to the first level in a catalog and provide a way of classifying other chapt Typical CSV file:

CHAPTER;DIN;I_SectionCatalogDIN; Keywords;Family; Types;String; ;Quadrat_Hohlprofile;e:\users\jcm\StructuralCatalogs\USER\Quadrat_Hohlprofile.ca ;Rechteck_Hohlprofile;e:\users\jcm\StructuralCatalogs\USER\Rechteck_Hohlprofile.cata 5. Create ENDCHAPTER and CHAPTER CATScripts. Sample CATScripts are given below. They are to be found in the online documentation filetree
ENDCHAPTER

•

Open the file USER_EndChapterswithPartFamily.CATScript. In our example, the content
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'// COPYRIGHT DASSAULT SYSTEMES 1999 '//========================================================= '// '// Language="VBSCRIPT" '// To build catalog from a parametric part '// '//========================================================= '// Major interface used: '// '// interface VB Name Remarks '// ----------- ------------ -------------'// CATIACatalogDocument CatalogDocument create catalog '// '//========================================================= Option Explicit '*************************************************************************** ' GLOBAL variable declarations section '*************************************************************************** Dim strGInputPath Dim strGOutputPath '@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ '// User customizable sections '@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Const NBEndChapter = 2 Dim strArrayEndChapter (2) Dim strArrayModelFile (2) Dim strArrayCatalogFile (2) '-----------------------------------------------------------------------------Sub InitEndChapterArray () '-----------------------------------------------------------------------------' Name of the description displayed in the catalog browser '-----------------------------------------------------------------------------strArrayEndChapter(1) = "Tees" strArrayEndChapter(2) = "Equal Angles" '-----------------------------------------------------------------------------' Name of the .CATPart defining the sketches '-----------------------------------------------------------------------------strArrayModelFile(1) = "TShape" strArrayModelFile(2) = "LShape" '-----------------------------------------------------------------------------' Name of the generated files .catalog used in the USER.CATScript '-----------------------------------------------------------------------------strArrayCatalogFile(1) = "USER_Tees" strArrayCatalogFile(2) = "USER_Equal_Angles" End Sub '------------------------------------------------------------------------------
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Project Standards Sub GetPath () '-----------------------------------------------------------------------------strGInputPath = InputBox("Path of the models directory:", _ "Input path for model files", _ "e:\users\jcm\USER\Sketches\") strGOutputPath = InputBox("Path of the catalog output directory:", _ "Output path for Catalogs", _ "e:\users\jcm\USER\") End Sub ' '-----------------------------------------------------------------------------Sub CATMain() '-----------------------------------------------------------------------------Dim objCatalogDoc As Document Dim intK As Integer Dim strChapterName As String Dim strModelName As String Dim strCatalogName As String ' InitEndChapterArray ' GetPath ' On Error Resume Next For intK = 1 to NBEndChapter strModelName = strGInputPath & strArrayModelFile (intK) & ".CATPart" strChapterName = strArrayEndChapter (intK) strCatalogName = strGOutputPath & strArrayCatalogFile (intK) & ".catalog" Set objCatalogDoc = CATIA.Documents.Add("CatalogDocument") ' Calls the method on Catalog to create inside the catalog document ' a chapter from the Design Table objCatalogDoc.CreateChapterFromDesignTable strChapterName , strModelName ' Saves the catalog document objCatalogDoc.SaveAs strCatalogName ' Closes the catalog document objCatalogDoc.Close Next 'For intK MsgBox "Press OK to quit", 0, "CATALOG CREATION COMPLETED" End Sub '/////////////////////////////////////////////// CATMain •

If you want to use it, copy it and change the User customizable sections to adapt them CATScript from one of the standard catalogs supplied with the product and then change
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CHAPTER

•

Open the file USER_Chapter.CATScript. In our example, the content looks like this:

'// COPYRIGHT DASSAULT SYSTEMES 1999 '//========================================================= '// '// Language="VBSCRIPT" '// To build catalog '// '//========================================================= '// Major interface used: '// '// interface VB Name Remarks '// ----------- ------------ -------------'// CATIACatalogDocument CatalogDocument create catalog '// '//========================================================= Option Explicit '*************************************************************************** ' GLOBAL variable declarations section '*************************************************************************** Dim strGInputPath Dim strGOutputPath '@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ '// User customizable sections '@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Const NBGCSVFile = 1 Dim strArrayGCSVFile (1) '-----------------------------------------------------------------------------Sub InitCSVFileArray () '-----------------------------------------------------------------------------strArrayGCSVFile(1) = "USER" End Sub '/////////////////////////////////////////////// InitCSVFileArray '-----------------------------------------------------------------------------Sub GetPath () '-----------------------------------------------------------------------------strGInputPath = InputBox("Path of the catalog input directory:", _ "Input path for CSV files", _ "e:\users\jcm\USER\CsvFiles\") strGOutputPath = InputBox("Path of the catalog output directory:", _ "Output path for Catalogs", _ "e:\users\jcm\USER\") End Sub '/////////////////////////////////////////////// GetPath '-----------------------------------------------------------------------------Sub CATMain () '------------------------------------------------------------------------------
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Dim objCatalogDoc As Document Dim intK As Integer Dim strCSVFile Dim strCatalogFile InitCSVFileArray GetPath On Error Resume Next For intK = 1 to NBGCSVFile strCSVFile = strGInputPath & strArrayGCSVFile (intK) & ".csv" strCatalogFile = strGOutputPath & strArrayGCSVFile (intK) & ".catalog" Set objCatalogDoc = CATIA.Documents.Add("CatalogDocument") '---------- Generate catalog objCatalogDoc.CreateCatalogFromcsv strCSVFile,strCatalogFile Next 'For intK MsgBox "Press OK to quit", 0, "CATALOG CREATION COMPLETED" End Sub '/////////////////////////////////////////////// CATMain •

If you want to use it, copy it and change the User customizable sections to adapt them CATScript from the one of the standard catalogs supplied with the product and change

6.

You are now ready to run the batch operation: • • • Start a session Select Tools ->Macro ->Macros... -> Select. Select the appropriate CATScript, then click Run.

Note: It is important to run the CATScript generating the families (END CHAPTERS) before ge chapter references the families.

Creating a Catalog in Batch Mode
1. Make a USER directory with the same name as your catalog and sub-directories for sketches, • • • • 2. USER/Sketches USER/DesignTables (this sub-directory must be named DesignTables) USER/CSVFiles USER/VBScript

Sketch the profiles for your user sections and store in the USER/Sketches directory.

Standard sketches of parametric sections (I, U, L, T, double U, double L, bulb and tube shapes the directory iinstall_folder/startup/Catalogs/Structural Steel/Sketches where install_folde Project. 3. Create design tables. Note: Do not link design tables to sketches. Design tables contain the geometric parameters used to generate the section.
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END CHAPTER Conventions

End chapters correspond to catalog families. A family is a set of components. For example, ENDCHAPTER: Name;Icon;DesignTable; • • •

If the design table is not linked to a sketch, the name of the design table must be the l ENDCHAPTER. The first keyword must be Section The full path name of documents must be given.

Typical CSV file: ENDCHAPTER;HEA;I_SectionStructureI;OTUA_HEA; Keywords;Section; Types;String; HEA100;HEA100;e:\users\jcm\StructuralCatalogs\Sketches\IShape.CATPart HEA120;HEA120;e:\users\jcm\StructuralCatalogs\Sketches\IShape.CATPart HEA140;HEA140;e:\users\jcm\StructuralCatalogs\Sketches\IShape.CATPart
CHAPTER Conventions

Chapters correspond to the first level in a catalog and provide a way of classifying other chapt Typical CSV file: CHAPTER;DIN;I_SectionCatalogDIN; Keywords;Family; Types;String; ;Quadrat_Hohlprofile;e:\users\jcm\StructuralCatalogs\USER\Quadrat_Hohlprofile.catalog ;Rechteck_Hohlprofile;e:\users\jcm\StructuralCatalogs\USER\Rechteck_Hohlprofile.catalog 5. Create ENDCHAPTER and CHAPTER CATScripts.

Sample CATScripts are given below. They are to be found in the online documentation file-tree folder, cfysm/samples.
ENDCHAPTER

•

Open the file USER_EndChaptersStandard.CATScript. In our example, the content looks

'// COPYRIGHT DASSAULT SYSTEMES 1999 '//========================================================= '// '// Language="VBSCRIPT" '// To build catalog '// '//========================================================= '// Major interface used: '// '// interface VB Name Remarks '// ----------- ------------ --------------
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'// CATIACatalogDocument CatalogDocument create catalog '// '//========================================================= Option Explicit '*************************************************************************** ' GLOBAL variable declarations section '*************************************************************************** Dim strGInputPath Dim strGOutputPath '@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ '// User customizable sections '@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ Const NBGCSVFile = 2 Dim strArrayGCSVFile (2) '-----------------------------------------------------------------------------Sub InitCSVFileArray () '-----------------------------------------------------------------------------strArrayGCSVFile(1) = "Equal_Angles" strArrayGCSVFile(2) = "Tees" End Sub '/////////////////////////////////////////////// InitCSVFileArray '-----------------------------------------------------------------------------Sub GetPath () '-----------------------------------------------------------------------------strGInputPath = InputBox("Path of the catalog input directory:", _ "Input path for CSV", _ "e:\users\jcm\USER\CsvFiles\") strGOutputPath = InputBox("Path of the catalog output directory:", _ "Output path for CSV", _ "e:\users\jcm\USER\") End Sub '/////////////////////////////////////////////// GetPath '-----------------------------------------------------------------------------Sub CATMain () '-----------------------------------------------------------------------------Dim objCatalogDoc As Document Dim intK As Integer Dim strCSVFile Dim strCatalogFile InitCSVFileArray GetPath On Error Resume Next For intK = 1 to NBGCSVFile strCSVFile = strGInputPath & strArrayGCSVFile (intK) & ".csv" strCatalogFile = strGOutputPath & strArrayGCSVFile (intK) & ".catalog" Set objCatalogDoc = CATIA.Documents.Add("CatalogDocument") '---------- Generate catalog 129

StructureDesign objCatalogDoc.CreateCatalogFromcsv strCSVFile,strCatalogFile Next 'For intK MsgBox "Press OK to quit", 0, "CATALOG CREATION COMPLETED" End Sub '/////////////////////////////////////////////// CATMain •

If you want to use it, copy it and change the User customizable sections to adapt them CATScript from the one of the standard catalogs supplied with the product and change

CHAPTER

• •

Open the file USER_Chapter.CATScript. In our example, the content is as illustrated ab If you want to use it, copy it and change the User customizable sections to adapt them CATScript from the one of the standard catalogs supplied with the product and change

6.

You are now ready to run the batch operation: • • • • Start a Version 5 session Select Tools ->Macro ->Macros... In the Macro dialog box, set Macro in to External File Select the appropriate CATScript, then click Run.

Note: It is important to run the CATScript generating the families (END CHAPTERS) before the since the chapter references the families.

Completing Parametric Section Catalogs
This task shows how to add sections to existing catalogs.

To add sections to existing catalogs, you must rename the path of linked documents in CSV files b name. To do so, one Excel file per sample catalog containing an appropriate macro is provided. Fo catalog is OTUA_hierarchy.xls. Excel files are located in the CsvFiles directory. 1 Edit the Commands sheet of the appropriate Excel file, entering the necessary information. Note: The first sheet named Data contains all CSV files in the catalog. 2. 3. 4. Click Modify absolute path of pointed CATPart in CSV files to rename the path. Add new sections. Generate the catalog as above.

Creating Catalogs of Slots, Endcuts and Small Assemblies
More About Slots, Endcuts and Small Assemblies
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Project Standards Catalog slots, endcuts and small assemblies are managed by an administrator. Typically this involves enriching and updating the sample catalog of industry-specific features provided with the product. This is the catalog users access when placing features on physical plates and shapes and creating small assemblies.

As system administrator, you will need to publish faces and edges, etc. of plates and shapes in order to create catalog slots, endcuts and small assemblies. This is done using a dedicated command, Manage Structure Publication, available in the Customize dialog box (Tools -> Customize..., Commands tab).

Note that, when placing features, publishing is done in transparent fashion for the user.

Creating Catalog Slots
This task shows you how to build a catalog slot. This is usually done by an administrator. Main steps are: • • • Defining input geometry Sketching and constraining the slot contour in a positioned sketch Creating the slot template.

A catalog slot is a user feature (UDF) based on sketched contour.
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2. Set the Keep link with selected object option (Tools -> Options -> Infrastructure -> Part Infrastructure -> General).

Defining Input Geometry
3. Insert a new part in which you will define your slot input geometry (Insert > New Part). 4. Import the plate and shape surfaces or edges you will need: • • Switch to the Wireframe and Surface workbench (Start -> Mechanical Design -> Wireframe and Surface Design) Using the Intersection command , create the intersection geometry between planes of the new part and surfaces or edges of the plate and shape and/or reference planes. Surfaces/edges are imported under an External References entry in the specification tree. Note: Our example shows surfaces only.
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•

When done, delete the geometrical set containing the intersect entries and rename the External References entry, for example, Inputs. Rename imported surfaces/edges under Inputs as follows:

•

Plate/shape in which slot will be located: Plate_(name of published plate surface or edge) Shape_(name of published shape surface or edge) For example, Plate_Face_Standard Other plate/shape surfaces: Platen_(name of the published plate surface or edge) Shapen_(name of the published shape surface or edge) where n is a number identifying the number of parts to be selected by the user when instantiating the slot feature. For example, Shape1_Face_MoldedFlange1 Do not use input geometry in knowledgeware rules or formulas [F(x)]. If or Extract you need to do so, duplicate the geometry using Offset commands and reference the duplicated geometry in the rule or formula. Note: the user feature creating stable construction geometry integrates rules and formula.
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Sketching & Constraining the Slot Contour in a Positioned Sketch
Using a positioned sketch lets you explicitly define the position of the absolute axis of the sketch. To create a positioned sketch, you must specify a reference plane, an origin and the orientation of the absolute axis. The new body inserted below will contain the geometry needed to define a positioned sketch as well as the slot contour. 6. Insert a new body (Insert -> Geometrical Set), and rename if desired, for example, Construction Geometry. 7. to create two lines between the imported Use the Intersection command plate surface and imported shape surfaces. Since the orientation of intersect lines is not known, you will now create stable geometry from them. This is done by instantiating a user feature supplied with the product. Stable lines are lines whose orientation is known and whose orientation will be kept when the slot feature is instantiated. 8. Create stable construction geometry: • Select Insert -> Instantiate from Document... from the menubar to instantiate the user feature CurveOrientation.CATPart located in folder ..\installl_dir\startup\Catalogs\Structural Steel\DetailingFeatureCatalogs\SampleData.

CurveOrientation.CATPart has two inputs and one parameter: a. a curve or line (can be an intersect) b. a reference surface c. a parameter determining whether or not the starting point of the line is the nearest element to the reference surface. The Insert Object dialog box opens. • Select one of the wireframe lines just created then select a reference surface.
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•

•

If necessary, click Parameters in the Insert Object dialog box to define the starting point of the stable line. By default, the starting point is the point nearest the reference surface. Click Preview to visualize the stable line. The user feature generates a line (in bold blue) oriented as defined by the parameter and two points, one at each end of the line. The start point is represented by a green circle and the end point by a white cross.
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StructureDesign • • Check Repeat in the dialog box then click OK when done. The user feature is automatically re-instantiated when the Repeat option is checked. Repeat to create other stable line. Do not forget to uncheck the Repeat option before clicking OK. Create a plane from the two stable lines. Note: Any of the stable points created by the user feature can be used to specify the origin of the sketch.

•

9.

Use the Sketch with Absolute Axis definition position the contour you will sketch. The Sketch Positioning dialog box opens.

command to correctly
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• • • • • •

Keep Type set to Positioned. Select the plane created above as the reference plane for the sketch support. Define the sketch origin as follows: Set Type to Projection point then select one of the points created above. Define sketch orientation as follows: Set Type to Parallel to line then select one of the two lines defined above. Use dialog box options to orient the H,V axis system correctly. Click OK.

The Sketcher workbench opens. If needed, hide stable construction geometry.

10. Sketch the contour of the slot and constrain sketch elements, then exit the sketcher.
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StructureDesign • • • • • Sketch the contour well below the MoldedFlange2 of the shape. Do not apply vertical or horizontal constraints. Constrain the sketch to stable construction geometry. A green sketch means your contour has been properly constrained. You are advised to change values of parameters that the user will be required to enter to ensure that the contour behaves correctly.

11. Create a formula using shape section parameter Tw that you will include in the slot template definition: • Click the Formula command. The Formulas dialog box opens. Create a new parameter of type length and named Shape1_Tw. You can set the value of this parameter to 50mm.

•

When the slot feature is instantiated, the true shape section parameter TW will be accessed and used. • • • Click Add Formula. The Formula Editor dialog box opens. Create a formula that makes the offset twice the parameter Shape1_Tw. Click OK in the Formula Editor then the Formulas dialog boxes when done.
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Taking advantage of shape section parameters rather than creating appropriate input geometry is recommended. You are now ready to define your slot template.

Creating the Slot Template
11. Select Insert -> UserFeature -> UserFeature Creation... The Userfeature Definition dialog box opens.
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• • •

Give the slot template a meaningful name. Select the geometrical set containing the construction geometry and sketched contour. Select components in the Inputs of components column to have them included in the definition. Selected components move to the Components column. You must select everything except imported surfaces/edges. Do not forget to include formula and rules.
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•

Click OK when done. The slot template is created under the Knowledge Templates entry in the specification tree.

12. Save the document. 13. Store the slot template in the sample catalog, DetailingFeatures.catalog.

Creating Catalog Endcuts
This task shows you how to build a catalog endcut. This is usually done by an administrator. Main steps are:
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• • •

Defining a positioned sketch in which to sketch the endcut contour Sketching the contour and creating the endcut feature Creating the endcut template.

A catalog endcut is a user feature (UDF) based on a sketched contour and a removetype boolean operation. Both Wireframe and Surface Design and Part Design workbenches are used to create the endcut. A GKT license is required. CATPart STARTER_MODEL_FOR_TEE_SHAPE located in folder: OS/startup/Catalogs/Structural Steel/ DetailingFeatureCatalogs/EndCuts/Tee 1. Open the starter CATPart and save it in the same folder as a dedicated endcut template.

2. Set the Keep link with selected object option (Tools -> Options -> Project Center -> Geometry -> General).

Defining a Positioned Sketch
Using a positioned sketch lets you explicitly define the position of the absolute axis of the sketch. To create a positioned sketch, you must specify a reference plane, an origin and the orientation of the absolute axis. 3. Switch to the Wireframe & Surface Design workbench (Start ->Project Center -> Geometry) and insert an geometrical set to define a positioned sketch in which you will sketch the endcut contour (Insert -> Geometrical Set...). 4. Rename the geometrical set Endcut_Internal_Feature for example. 5. command, create a point on curve in the middle of the molded Using the Point flange1 edge.
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6.

Using the Plane web face.

command, create a plane through the point and parallel to the

7.

Using the Circle command, create a 120mm radius circle with the point as origin and the plane as support.
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8.

Using the Intersection • •

command, create intersections between:

The molded flange1 face and the circle The cross-section face and the circle.

9.

Using the Line command, create two point-to-point lines, one vertical and the other horizontal, from the circle origin to each of the two intersection points created above.
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10. Click the Sketch with Absolute Axis definition contour you will sketch.

command to correctly position the

The Sketch Positioning dialog box opens. • Keep Sketch Support Type set to Positioned. • Select the two lines just created as Reference for the sketch support. • Keep Origin and Orientation Types set to Implicit. • Click OK. The Sketcher workbench opens.

Sketching Contour & Creating the Endcut
You will first sketch the contour then create corresponding Part Design features. 11.Sketch the contour of the endcut and constrain sketch elements as follows:
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• •

A green sketch means your contour has been properly constrained. You are advised to change values of parameters that the user will be required to enter to ensure that the contour behaves correctly.

12.Exit the Sketcher when done. 13.Switch to the Part Design workbench (Start -> Mechanical Design -> Part Design). 14. command, create a pocket of the Up to next type for both Using the Pocket limits and selecting the sketch as profile.
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You are now ready to define your endcut template, but before we do so, a word about naming conventions.
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Naming Conventions for Section Characteristics

Structure applications have standardized user names for stiffening features (surfaces and edges). The advantage of such a naming convention is that designers can then easily replace one structural shape by another without having to re-instantiate the endcut. Naming conventions used can be found in table, CATStrSectionNamingKeys.CATNIs, located in the install folder under resources/msgcatalog. 15.To visualize naming conventions for the Tee: • • De-activate the pocket feature via the contextual menu. Select Tools -> Publication... The Publication dialog box opens.

•

Identify names for faces and edges impacted by the endcut definition. In our example:

Edge_MoldedFlange1_Start Face_WebInner+ Face_Start Face_MoldedFlange1 Edge_MoldedFlange2_Flange2Toe+ Edge_WebInner+_Start* Note: Faces and edges impacted depend on those selected when constraining the endcut contour. • Activate the pocket feature via the contextual menu.

Creating the Endcut Template
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Project Standards 16.Select Insert -> UserFeature -> UserFeature Creation... from the menu bar to define the endcut template. The Userfeature Definition dialog box opens. • Give the endcut template a meaningful name. This is the name the user will see when he instantiates the endcut in his design. Select the pocket and the Endcut_Internal_Feature in the specification tree.

•

•

Click the Inputs tab and overwrite component names as per naming conventions above.

Shape to which endcut will be applied: Shape_(name of published shape surface or edge)
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For example, Shape_Edge_MoldedFlange1_Start Other shape surfaces: Shapen_(name of the published shape surface or edge) where n is a number identifying the number of parts to be selected by the user when instantiating the slot feature. In our example, there are no such shape surfaces.

•

Click the Parameters tab to publish parameters for which you expect user input.
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•

Click OK when done. The endcut template is created under the Knowledge Templates entry in the specification tree.

17.Apply the standard isometric view to your document, place all 3D construction geometry in No-Show and the save the document. Note: This is the view that will be shown in the Catalog Selection dialog box when instantiating the endcut. 18.Store the endcut template in the sample catalog, DetailingFeatures.catalog.

Creating Catalog Small Assemblies
This task shows you how to build a catalog small assembly. This is usually done by an administrator. Main steps are: • • • Defining input geometry Sketching the contour in a positioned sketch Creating the small assembly
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•

Creating an assembly template.

Catalog small assemblies are document templates. Templates created reference the shapes and plates making up the assembly. A GKT license is required. 1. Open the CATProduct document containing the plates and shapes that will assist you build the small assembly. 2. Set the Keep link with selected object option (Tools -> Options -> Project Center -> Geometry -> General).

Defining Input Geometry
3. Insert a new product (Insert -> New Product), and rename it, for example Assembly Template. Assembly templates must be created at product level. 4. Insert a new part under the new product (Insert -> New Part), and rename it, for example, Skeleton. This part will contain input geometry, i.e. imported plate and shape surfaces or edges. 5. Import the plate and shape surfaces or edges you will need: • • Switch to the Wireframe and Surface workbench (Start -> Project Center -> Geometry). , create the intersection Using the Intersection command geometry between planes of the new part and surfaces/edges of the plates and shapes and/or reference planes. Surfaces/edges are imported under an External References entry in the specification tree. When done, delete the geometrical set containing the intersect entries. Rename imported surfaces/edges as follows:

•

•

Plate surfaces/edges: Platen_(name of the published plate surface or edge) Shape surfaces/edges: Shapen_(name of the published shape surface or edge) where n is a number identifying the number of parts to be selected by the user when instantiating the assembly template.
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For example, Plate1_Face_Standard, Shape1_Face_MoldedFlange1 • Isolate imported surfaces/edges and rename the Isolated External References entry, for example, Isolated Inputs. This breaks the link between imported surfaces/edges and referenced shapes.

Do not use input geometry in knowledgeware rules or formulas [F(x)]. If you need to do so, duplicate the geometry using Offset or Extract commands and reference the duplicated geometry in the rule or formula. Note: The user feature creating stable geometry uses rules and formula. 6. Hide the axis system planes and click to clear the Pickable checkbox in the Graphic tab of the Properties dialog box making them unselectable. You must not use these planes when creating construction geometry.

Sketching the Contour in a Positioned Sketch
Using a positioned sketch lets you explicitly define the position of the absolute axis of the sketch. To create a positioned sketch, you must specify a reference plane, an origin and the orientation of the absolute axis. The new body inserted below will contain the geometry needed to define a positioned sketch as well as the small assembly contour. 7. Insert a new body (Insert -> Geometrical Set), and rename it, for example, Construction Geometry.
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8.

Use the Intersection command to create two construction lines between the imported surfaces. Since the orientation of intersect lines is not known, you will now create stable geometry from them. This is done by instantiating a user feature supplied with the product. Stable lines are lines whose orientation is known and whose orientation will be kept when the small assembly template is instantiated.

9. Create stable construction geometry: • Select Insert -> Instantiate from Document... from the menubar to instantiate the user feature CurveOrientation.CATPart located in folder ..\install_dir\startup\Catalogs\Structural Steel\DetailingFeatureCatalogs\SampleData.

CurveOrientation.CATPart has two inputs and one parameter: a. a curve or line (can be an intersect) b. a reference surface c. a parameter determining whether or not the starting point of the line is the nearest element to the reference surface.
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Project Standards The Insert Object dialog box opens. • Select one of the wireframe lines just created then select a reference surface. The reference surface must be an offset or an extract of the imported external reference. If necessary, click Parameters in the Insert Object dialog box to define the starting point of the stable line. By default, the starting point is the point nearest the reference surface. Click Preview to visualize the stable line. The user feature generates a line (in bold blue) oriented as defined by the parameter and two points, one at each end of the line. The start point is represented by a green circle and the end point by a white cross. Check Repeat in the dialog box then click OK when done. The user feature is automatically reinstantiated when the Repeat option is checked. Repeat to create other stable line. Do not forget to uncheck the Repeat option before clicking OK.

•

•

•

•
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StructureDesign • Create a plane from the two stable lines. Note: Any of the points created by the user feature can be used to specify the origin of the sketch. 10. Use the Sketch with Absolute Axis definition position the small assembly you will sketch. The Sketch Positioning dialog box opens. • • • • • • Keep Type set to Positioned. Select the plane created above as the reference plane for the sketch support. Define the sketch origin as follows: Set Type to Projection point then select one of the points created above. Define sketch orientation as follows: Set Type to Parallel to line then select one of the two lines defined above. Use dialog box options to orient the H,V axis system correctly. Click OK.

command to correctly

The Sketcher workbench opens. 11.Sketch the small assembly and constrain sketch elements. • • • • Do not apply vertical or horizontal constraints. Constrain the sketch to stable construction geometry. A green sketch means your contour has been properly constrained. You are advised to change values of parameters that the user will be required to enter to ensure that the small assembly behaves correctly.

12.Create as many sketches as plate and shapes making up the assembly. 13.Publish construction geometry you will use to create your shapes and plates: • Switch to the Part
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•

14.Check the Only use published elements for external selection keeping link option in the Options dialog box (Tools -> Options -> Project Center -> Geometry -> General). This will ensure that you select only published geometry when creating plates and shapes.

Creating the Small Assembly
15. Switch to your structure workbench and use Shape and Plate commands to create the shapes and plates making up your assembly based on published construction geometry. For a plate, use the Support and contour mode, selecting the plane created as support. 16.Save your document. 17.Load the Assembly Template CATProduct only. The template document must be standalone, i.e. it contains all that is needed for the assembly template. It must not contain external links. You are now ready to build your template.

Creating an Assembly Template
18.Select Insert -> Document Template Creation... The Document Template Definition dialog box opens, listing CATParts in the document. • • • Any documents referenced must have New document Action status. Click the Inputs tab and then select isolated surfaces/edges. Enter roles for these surfaces/edges using the following naming conventions:

SHAPEn _(name of published shape surface or edge) where n is a number identifying the number of parts to be selected by the user when instantiating PLATEn_(name of published plate surface or edge) where n is a number identifying the number of parts to be selected by the user when instantiating For example, SHAPE1_Edge_MoldedFlange2
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The assembly template is created under a Knowledge Templates entry in the specification tree.

19.Save the document. 20.Store the assembly template in the sample catalog.

Storing Slots, Endcuts & Small Assemblies in a Catalog
A sample catalog, DetailingFeatures.catalog, of slots, endcuts and small assemblies is provided with the product. This catalog is managed as a project resource. Enriching and updating the sample catalog is recommended. This task shows you how to store new features in the sample catalog. This is usually done by an administrator. 1. Open the sample catalog DetailingFeatures.catalog. The Catalog Editor workbench opens showing the contents of the sample catalog. 2. If necessary, expand the chapters to view their contents. Three chapters have been defined: Endcuts, Slots and SmallAssemblies. Each chapter corresponds to a folder containing the associated parts and features.
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Project Standards Sub-chapters have also been defined. In the case of endcuts and slots, these correspond to the various types of shape on which the endcut or slot will be applied. It is important to respect the endcut and slot sub-chapter naming. This will ensure that the Catalog Selection dialog box proposes appropriate endcuts or slots to the user for the type of shape selected. In the case of assembly templates, it is important to respect the naming of chapters SmallAssemblies and UserTemplates. Tile the catalog with the document containing the slot, endcut or assembly template you want to add. 3. Make the family to which you want to add your slot, endcut or small assembly active, then select the Reference tab. 4. Click the Add Component command to associate the appropriate part or feature. The Description Definition dialog box appears. 5. Click Select external feature in the Description Definition dialog box, then select the slot, endcut or small assembly template in the specification tree of the document containing your template.

6. Click OK in the Description Definition dialog box. The slot, endcut or small assembly is added to the catalog. 7. Save the catalog when done. Use the Add Family command to enrich the sample catalog with new families.

Rules and Recommendations
This section lists the rules and recommendations to remember when creating catalog slots, endcuts and small assemblies.
General

• •

Always explicitly define points and never use implicit points, for example those at the ends of lines. Wherever possible, make selections in the specification tree.

Oriented Planes and Lines

•

Never invert the orientation of a plane without first checking whether or
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StructureDesign not the plane has children. In general, plane orientation must be known. This applies in particular to planes tangent to surfaces, planes offset or parallel to oriented planes, planes at an angle or normal to an oriented plane if the axis of rotation is a line of known direction. Instantiate user feature SurfaceOrientation.CATPart to force plane orientation. Always work with oriented lines, especially when used as axes of rotation. When creating lines via the Intersection command, instantiate user feature CurveOrientation.CATPart to force line orientation. User features are to be found in folder ..\install_dir\startup\Catalogs\Structural Steel\DetailingFeatureCatalogs\SampleData.
Input Geometry

• •

•

Do not use input geometry in knowledgeware rules or formula [F(x)]. If you need to do so, duplicate the surfaces using Offset (0 offset) or Extract commands and reference duplicated geometry in the rule or formula.

Taking Advantage of Shape Section Parameters

Using main geometric characteristics of shape sections rather than creating appropriate input geometry is recommended. This simplifies the definition of the catalog template and reduces data size of both the template definition and the features you place. The following shape section parameters can be employed: • • • • • • • D: shape height Bf: Flange width Tf: flange thickness Tw: web thickness Radius1 Radius2 Slope

To include section parameters in your template definition, you must: • Create a knowledgeware parameter of the desired type and named as below

Shapen_(name of section parameter) where n is a number identifying the numbre of parts to be selected by the user when instantiating the feature. For example, Shape1_Bf
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•

Create a knowledgeware formula [F(x)] that uses the parameter you defined.

Shape section parameters are then accessed directly when the user instantiates the feature.
Sketching

•

Always sketch using the Sketch with Absolute Axis definition command: 1. Set the sketch support type to Positioned and select a plane of known orientation as Reference. 2. Set the origin type to Projection point and select a stable geometric point. Do not select a vertex. 3. Set the orientation type to Parallel to line and select an oriented line.

• •

Never set distance constraints in the Sketcher. To dimension distances, create offset planes in the Wireframe and Surface Design workbench, then set coincidence constraints based on these planes in the Sketcher. Avoid creating circles constrained in tangency. Defining as much as possible using the Wireframe and Surface Design workbench is recommended.

Creating Slots, Endcuts and Small Assemblies

• • • • • •

Always reference input geometry and never part document planes. Aways select input surfaces and not surfaces of starter model plates and shapes. Always ensure that the geometric entities are properly ordered, for example an intersection of two lines must be placed after the two lines. Use the Reorder command if necessary. For slots and endcuts, always reference at least one entity of the plate or shape that will contain the feature. For endcuts, ensure that Split cutting planes are oriented with respect to geometric elements. For endcuts, ensure that the first Part Design feature (pocket, split, etc.) describing the endcut is the active feature. Select this component first when creating the template.

Migrating V4 Structure Elements
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Migrating V4 Structure Elements
In order to migrate the V4 structure elements to V5 you need to take four basic steps: • Make sure all resources are pointed to correctly in the project resource management file. The value of the entry "Migrate Structures" must be set to True. Also, you must enter the values correctly if you change the name or location of the structures sections catalog (StructureSectionsCatalog), the resolved parts directory (StructureSectionsPath) and mapping tables (StructuresMigrationMappingTable; StructuresMaterialMigrationMappingTable) mentioned later in this section. This is usually done by a system administrator. Customize the feature dictionary to add V4 attributes that will be automatically detected when you migrate V4 structure elements. Any new attributes that were added to the feature dictionary must also be added to the mapping table. Update or create new mapping tables for sections. Sample mapping tables are included with this application but if you have a V4 section that does not exist in V5 then you must create the section and add it to the catalog. Execute a batch file that migrates the sections from V4 to V5.

•

• •

This section further explains these tasks.

Updating the Mapping Table

This task shows you how to update the mapping tables necessary for migrating V4 sections to V5. have a V4 section but no equivalent section in V5 then you must create it in V5 and place it in the structures sections catalog. See Managing Sections to learn how to create a section. You will need to update two types of mapping tables. One contains a list of the V4 sections name a name of the equivalent section in V5. The other contains a list of the V4 materials and the equivale material code in V5. You may also choose to create or modify mapping tables by standard. Sample these types of mapping table are included with this application. They are in the directory:

...intel_a startup EquipmentandSystems MigrationDirectory Dictionary STRMappi 1. The default name of the mapping table that contains section names is V4toV5StructureMapping Open the file using MS Excel and enter V4 section names and their equivalent in V5. You must s the file as a .csv file.
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This table is referenced in the project resource management (PRM) file (StructuresMigrationMappingTable). If you decide to use another table or change its location yo change the entry in the PRM file accordingly. This is usually done by a system administrator. 2. The mapping table that contains material codes is named StructuresMaterialMappingTable. Aga this file with Excel, make your changes and be sure to save it in .csv format.

This table is referenced in the project resource management (PRM) file (StructuresMaterialMigrationMappingTable). If you decide to use another table or change its loc you must change the entry in the PRM file accordingly. This is usually done by a system adminis

Migrating the V4 Structure Model
This task shows how to migrate the V4 structure model to V5. This task should only be attempted after the other tasks in this section have been completed. Before performing this task you should make sure that options are correctly set in your project resource management file. If you have more than just sections in a model then these options help you control which portions of a model you want to migrate. If your V4 model has data from Piping and Instrumentation Diagrams, Piping Design, HVAC Design, Structures and Equipment Arrangement, you can decide which type of data you want to migrate by setting these options. If you choose to only migrate Equipment data, then you can do so. See Understanding Project Resource Management, AEC V4 V5 Migration section, on how to set the options. Note: The sample PRM file references "Big Scale" structures catalogs. Because of this, you have to set the CATCGMBigScale variable to 1 before migrating structures models, shown below. 1. Move your V4 model (by ftp or any other means) to the same platform as V5, in this case Windows. 2. Set the following varaibles. In Windows, open a command prompt window and change to the directory ..intel_a code command. Enter the following: set CATDisciplinePath=XXX intel_a startup EquipmentandSystems ProjectData where XXX is the directory path to your installation. In Unix, use the command "export" instead of "set". For Structures models, you need to set the following: set CATCGMBigScale=1 (in Unix, replace set with export). The batch shells CATAECV4ToV5Migration.bat (Windows) and CATAECV4ToV5Migration.sh (Unix) assume you edited the project resource management
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StructureDesign (project.xml) file. If you copied and renamed it, then you must edit this batch shell and replace "Project" with your own file name (as referenced by AECMIGR_PROJECT variable). For Tubing Design, use the batch shell CATAECV4ToV5MigrTubing.bat (.sh for Unix). For all other applications, use the batch shell named above. 3. At the ..intel_a code command prompt, enter CATAECV4ToV5Migration.bat (.sh for Unit) to execute a bat file. (For Tubing use the file named in step 2). This will bring up the Migration Batch dialog box.

4. In the Target Directory field enter (or navigate to by clicking the button) the directory where the migrated V4 model will be stored. 5. Click the Browse File button and, in the box that displays, navigate to the directory where you stored your V4 models. Select (you can select more than one if you want to) a model and click Open. The V4 model will display in the V4 Documents to Migrate window of the Migration Batch dialog box. You can use the Remove button to remove files you do not want to migrate.
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Project Standards 6. If you are migrating a 2-D model then you need to set the path for certain files by clicking the Options button. The process is explained in the Infrastructure User Guide: Customizing - Customizing Settings - General - Compatibility - V4/V5 Infrastructure Opening V4 models referencing an external PROJECT file. 7. Click the Migrate button. When the process is complete the Migrate Report will display. You can also click the Report button to see the report. If the migration was successful you will get an OK message. If you get a message that says "Error during migration" then you must check for mistakes and repeat the process. Your V4 model is migrated as several documents, as explained below. 8. The V4 model will be migrated as several documents, and each one will display in the specifications tree when you expand it. Each object in the document will be in a separate document. To open the document click File - Open on the application menu bar and navigate to the directory you specified in the Target Directory field. The document with the same name as the V4 document is the "master" document, which contains (references to) all the components. Other documents underneath it will have identifying letters - such as STR for Structures - to indicate what they contain. The document will contain references to all plates and shapes. You need all the files to recreate the document.

Copying a V4 Section Geometry
This task shows you how to copy the geometry from a V4 section into V5. This process makes it easier to create a V4 section in V5. You need to create a V5 section when you want to migrate a V4 section to V5 but have no equivalent in your V5 catalog. You can create the section in V5 from scratch. But you can save a few steps by copying the V4 section geometry into V5 - which is explained here - and then following the procedure for building the section. All the steps explained here are taken in your V5 environment. 1. Open the V4 model from which you want to migrate the section.
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If you don't already have it, you can obtain the names of the V4 sections that do not exist in V5 by migrating the model. The errors list will identify the sections by name. 2. Locate the section in the V4 model by expanding the specifications tree. Copy the section geometry (STR) using the standard Copy-Paste process. If you have not performed this step before then see Copying V4 Geometry to V5 for more information. 3. Create a new CATPart document (File - New - Part) and paste the section geometry into the PartBody. Before you paste the geometry delete any "geometrical set" entries in the specifications tree. A "geometrical set" entry in the specifications tree could be created if you have been working with the Wire Frame product, for instance. 4. Delete the pad from the section you pasted so that only the geometry (Sketch.1) remains. You can do this by highlighting the pad in the specifications tree and deleting it. In the image below STR6 is the pad.
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Project Standards 5. Reposition the geometry so that the support plane is on the XY plane. There are a number of ways of doing this but one way is to select the geometry, right click on the Sketch.1 entry in the tree and click on Selected Objects Change Sketch Support.

In the Sketch Positioning dialog box that displays select Positioned for Type

.

and select the XY plane in your viewer. Click OK. The geometry will be placed at the XY plane. 6. Use Sketcher to position the geometry on or near the origin. This is not essential but is recommended.
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7. Build your section using processes explained in Managing Sections.
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