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STL Digitized Surfaces: Overview
Welcome to the STL Digitzed Surfaces User's Guide! This guide is intended for users who need to become quickly familiar with the product. This overview provides the following information: • • • • • STL Digitized Surfaces in a Nutshell Before Reading this Guide Getting the Most Out of this Guide Accessing Sample Documents Conventions Used in this Guide

STL Digitized Surfaces in a Nutshell
STL Digitized Surfaces helps the stereo-lithography specialist to build and manage STL files. The STL Rapid Prototyping User's Guide has been designed to show you how to do that. While knowledge of stereo-lithography is not mandatory, we recommend that you have some technical background in the area.

Before Reading this Guide
Before reading this guide and if you have not already done so, it will be easier if you familiarize yourself with the basic concepts - document windows, standard and view toolbars, etc. Interacting in Digital Project describes the conventions of interacting in Digital Project and how the workbenches are structured. Collaboration describes how to share information between the workbenches.

Getting the Most Out of this Guide
To make the most out of this book, we suggest that a beginning user reads the Getting Started chapter first of all and the Workbench Description to find his way around the STL Rapid Prototyping workbench.

Accessing Sample Documents
To perform the scenarios, you will be using sample documents in the folder: online/books/digitizedSurfaces/samples When samples belong to features that are common to different products, those samples will be found in the online/commonFn/samples folder. For more information on accessing sample documents follow that link to the page in 1

STLPrototyping Interacting in Digital Project.
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What's New?
No enhancements in this release.
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Getting Started
Getting Started
The following tutorial aims at giving you a feel of what you can do with STL Rapid Prototyping. It provides a step-by-step scenario showing you how to use key capabilities. The main tasks proposed in the chapter are:

All together this scenario should take 15 minutes to complete. The final cloud element will look like this:

Creating a Basic Surface Tessellation
The first task will show you how to enter the STL Rapid Prototyping workbench and create a basic surface tessellation. The only pre-requisites for this task is to have a current session running. 1. Choose STL Rapid Prototyping from the Start/NC Manufacturing menu. The STL Rapid Prototyping workbench is displayed and ready to use.

5
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2. Open the GettingStartedSTL.CATPart from the samples directory. It is a hairdryer, made of surfaces, with a gap and a hole in it.

6
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3. Click the Surface Tessellate icon OK.

and select the hairdryer. Click Apply and
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You can see clearly the hole and the gap in the tessellation.

Repairing the Mesh
This task will show you how to repair a mesh. Use the mesh you have created in the previous task. Repairing the hole: 1. Click the Fill Holes icon and select the mesh.

8
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The exterior edge of the model is displayed in red, with an "x" meaning this edge is not candidat filling. The two other edges in green with a "v" surround holes candidates for the filling.

2. Place the cursor over the label of the long hole and call the contextual menu. Choose Not se
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3. Click Apply and OK. The hole is filled:

Repairing the gap: 1. Click the Define a Mesh Area icon and select the mesh (Tessellation.1).

2. Draw a trap around the gap and check the Inside Trap option.

10
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Click Apply and OK. A portion of the mesh is activated:

3. Click the Mesh Regeneration icon

and select the mesh (Tessellation.1). Check the Cons

Click Apply and OK. A MeshCreation.1 element is created in the specification tree: the mesh on t has been regenerated.
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4. Select the Tessellation.1 element in the specification tree and click the Activation icon. Push button. Both meshes are now active (we have changed MeshCreation.1 to pink). From the can see that they are complementary:

12
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5. Click the Merge icon

and select the two meshes:
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6. Click OK. A Meshes Merge.1 element is created in the specification tree. You have now a fla

Checking the Mesh Quality
14
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This task will show you how to quickly check the quality of the mesh. Use the mesh you have created in the previous task. 1. Click the Display icon and select the Meshes Merge.1 mesh. The Cloud Display Options dialog box is displayed.

The default option is Smooth. You can check : • the Triangles option:

• the Free Edges option:

15
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• the Non-manifold Edges option: (none in our example) • the Flat option:

You can combine all of them too.

16
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Opening the STL Rapid Prototyping Workbench
The first task will show you how to enter the STL Rapid Prototyping workbench and create a basic surface tessellation. The only pre-requisites for this task is to have a current session running.

17

STLPrototyping

1. Choose STL Rapid Prototyping from the Start/NC Manufacturing menu. The STL Rapid Prototyping workbench is displayed and ready to use.

2. You can then either import an STL file, or open a CAD model, or standard IGES or STEP data.

Using the Keyboard
18
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Key Shift

Command Activation Remove (Pick or Brush), Split

Action Deselects selected elements

STL Files
Importing Files

This task shows how to import digit files describing a cloud of points (scanned or computed) or a m

Use the MultiImport1.cgo_ascii, MultiImport2.cgo_ascii, MultiImport3.cgo_ascii from the samples d Available formats depend on the workbench you are working in. Files import from ENOVIA is not yet implemented.

Digitized Shape Editor
• • • • • • • • • Ascii free, Atos (the quality of the points can be taken into account), Cgo, Gom-3d (as points, scans, grids or meshes, the quality of the points can be taken into acco Hyscan,

IGES (IGES Entities 116 are processed. If the cloud to import is made of Entities 116 only, t cloud of points. Otherwise, the result is made of scans). Kreon Steinbichler (as points, grids or scans), Stl (bin or ascii, with creation of free edges and facets, if requested).

STL Rapid Prototyping
• • • • • • • STL files (bin or ascii, with creation of free edges and facets, if requested) (default option), Cgo, Ascii free,

IGES (IGES Entities 116 are processed. If the cloud to import is made of Entities 116 only, t cloud of points. Otherwise, the result is made of scans).

In Cgo, Ascii and IGES formats, you can not process more than 10,000 points at each impo several files, e.g. you can not import 4 files of 3,000 points each in one shot but you can im separately. This limitation applies to the input files (before Sampling or resizing with the bounding box) If you try to import over 10,000 points in one shot, a fatal error panel is displayed: Too ma 19
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•

this configuration. o If the Grouped option is active, no file is imported. o If the Grouped option is not active, files are imported as long as the sum of their poi exceed 10,000 points. Mesh Regeneration is not available on those files.

Shape Sculptor
• STL files (bin or ascii, with creation of free edges and facets, if requested).

1. Click the Import icon

. The Cloud Import dialog box is displayed.

2. In the Format field, select the file format. 3. In the Selected File area, use the button ... to browse your directories and select a file.

4. Check the box Statistics to display information about the model you are importing. If you w several files in one shot, please refer to the Grouped explanations. 5. In the Options field:

• Enter the Sampling percentage to apply; The sampling value determines the percentage of points or scans or grids that will be read the digit file. • Enter the Scale factor to apply to the model, as well as the Unit used in the file.

•

If the extension of the file you have selected is consistent with the list proposed, the Forma updated automatically. Otherwise, be careful to enter the correct format in that field.

20
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Once you have performed an import operation, V5 proposes the last entered file path and fo default. If you click on ..., the last entered directory is proposed as default. The File unit option is not relevant to the Steinbichler format, nor the Sampling percentage format.

6. For some digit file formats, you may want to enter additional data that are displayed by clic More>> For Ascii: For Atos and Gom-3d: For Iges: For Stl:

Direction and Delimitors apply to scans. Enter these data whenever you know them.

Minimal Point Quality is used to clean Atos file from invalid points. The quality value of a point lie between 0 and 255 (low to high). Choose a value to ignore points below that value: • Minimal Point Quality value is 125:

• Minimal Point Quality value is 75:

System applies to the operating system (Unix or Windows NT) used to generate the binary data Same if you know you are using the same operating system as the one used to generate the bina data, Other for the other way, Unknown if you have no indication. Free Edges is used to create or not the scans representing the free edges of a mesh:

or
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Facets is used to create or not the facets of the imported mesh:

or 7. Click Apply to display the cloud of points or mesh:

8. Push the button Update to display the bounding box of the cloud of points or mesh. Use the to resize it in order to import only a part of the cloud of points or mesh.

• • •

The bounding box appears every time the cursor passes over a cloud of points or a mesh. It corresponds to that of the visible points. If a local axis system is set as current, the file will imported in this axis systems and not in axis system as previously. If no local axis system is set as current, the file will be imported axis system. Moreover, if a local axis system is set as current, the axis system of the dynamic box used t portion of the imported file when the Update button is pushed is parallel to the local axis sy
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The check box Replace is used to replace the current cloud of points or mesh by a new one.

9. Once you are satisfied with the preview, click Apply and OK to finish the import of the cloud mesh.

• • •

The name of the element created in the specification tree is the name of the original file, wi extension. Undo and Redo are available. V5 memorizes the data of the last imported file and proposes them at the next import actio

Importing a Set of Files
1. Click the Import icon . The Cloud Import dialog box is displayed. The operating mode is the same as for one file.

23
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The Selected File field looks like this:

•

If you check the Grouped option (this is the default status): All the files are imported as one single cloud of points instead of several:

The three digit files have been imported together, resulting in one cloud of points or mesh.

24

User Tasks One cloud of points Element Cloud Import.x is created in the specification tree, with the icon of the Import command. • If you do not check the Grouped option: The files are imported separately.

The three digit files have been imported separately, resulting in three clouds of points. One cloud of points element is created in the specification for each input file, with the icon of the Import command and the name of the input file (MultiImport1.1, MultiImport2.1, MultiImport3.1) . • You can also merge several clouds of points into one whenever necessary, using the Merge Clouds command.

Exporting Polygons to STL
This task shows how to export a mesh to binary Stl format. Other formats available are: • • ASCII, cgo.

Open the Cloud.CATPart from the samples directory.
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1. Select the Polygon.1 and then the export icon The export dialog box is displayed.

.

2. One export format is available: Stl. 3. Browse your directories and enter the target directory and file name. Then click Save. • The selection is exported with the current local axis system if any, with the absolute axis system otherwise. You can export only one element at a time. In STL Rapid Prototyping, only the Stl format is available.

• •

STL Edition
Editing Meshes
This chapter deals with the edition of meshes, i.e. Selection, Remove actions. Although the dialog boxes look similar, the operating mode of the Select and Remove actions are slightly different: • • • De-activated triangles can be recalled using Activate all and Invert in a new activation action. Removed triangles can not be recalled! Activate all and Invert apply only to the current removal action. They can not be used to recall removed triangles, once you have clicked OK. The Activation action displays only triangles that are fully selected (i.e. the whole triangle is inside the selection trap, or all its vertices have
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User Tasks been picked). If you select only one or two vertices of a triangle, or if the selection trap intersects the triangle, it is not displayed. As a consequence, when you push the button Swap, the triangles displayed are not the exact complement of the previous selection. The Remove action takes into account triangles that are at least partially selected (at least one vertex has been picked, or the selection trap intersects the triangle).

• •

Activating a Portion of a Cloud of Points
This task shows how to select a portion of a cloud of points or of mesh in order to create a work area, either: • • • by picking directly elements of the cloud (points, scans, grids, cells, clouds) or by defining a portion of the cloud or mesh with a 2D or 3D trap, by moving a brush over a portion of a mesh.

The free edges displayed are those of the complete mesh: • if you activate only a portion of a mesh, the free edges of that portion are not displayed.

Open the Cloud.CATPart model the from the samples directory. Click here for more information on the dialog box. 1. Click the Activate Areas icon is displayed. and the mesh. The Activate dialog box
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2. Draw a rectangle by dragging the mouse over the portion you want to select.

As you release the mouse, the triangles selected are highlighted in red. When you move the mouse over one corner of the rectangle, dimensioning arrows are displayed, enabling you to resize the rectangle.
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3. Push the Valid Trap button that is now available and draw a second rectangle. Push Valid Trap again.

4. Push the Swap button. The selection is inverted.

5. Click OK to validate and exit the action.

Removing Elements

29

STLPrototyping

This task shows you how to remove a elements from a cloud or a mesh. • • • • The deleted elements are those that appear in red during selection. By default, the trap is displayed in the view plane (2D trap). You can rotate the model to display the trap as a 3D trap. Within one removal action, use Activate all to recall all the points of the original cloud of points, or Swap to invert the selection (the complement of the current selection becomes active whereas the current selection is hidden). The Remove action takes into account triangles that are at least partially selected (at least one vertex has been picked, or the selection trap intersects the triangle).

• •

Undo/Redo are not available on the global action. Although the dialog boxes look similar, the operation mode of the Activate and the Remove actions are slightly different: • Removed elements can not be recalled ! • Activate all and Swap apply only to the current removal action. They can not be used to recall removed elements once you have validated the action. • All free edges may be displayed.

Open the Cloud.CATPart model from the samples directory. Click here for more information on the dialog box. 1. Click the Remove icon and the mesh. The Remove dialog box is displayed.

2. Check the Pick option, then the required element type (Level) to remove elements using the hierarchical selection. According to your choice and the application you are working in, only points, or triangles, or scan/grid, or cells (sub-cloud) or clouds (global cloud) will be removed. Select the unwanted elements on the cloud, then Click OK to confirm their removal and close the dialog box.
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Or check the Trap option then the required Trap Type and the portion of cloud to remove (Inside or Outside Trap) to remove elements using a graphical trap. You can draw either one single trap, or several traps.

In that case, valid each trap with the Valid Trap push button before drawing the next one. If you draw a trap, push Valid Trap, then Swap, you will remove the complement of the original selection.

Click OK when all traps have been defined to remove the unwanted elements and close the dialog box. The traps may be either rectangular :
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In that case, you can modify the trap using the green manipulators. or polygonal :

or spline:

32
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In those cases, you can modify the trap using the green manipulators or use the Undo action on each segment of the trap as long as you have not double-clicked to end the polygonal trap.

STL Mesh
Tessellating an Object
This task shows how to create a tessellation from a surface or a solid. Inside this action, you may specify the maximum size of the triangles and the maximum distance (sag) between the geometry and the triangles. Open the SurfTessellation1.CATPart model from the samples directory.

1. Click the Surface Tessellation icon displayed.

. The Tessellation dialog box is

2. Select the surface or the solid to tessellate. Clik Apply.
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3. You can modify the Sag value, that is the maximum distance between the geometry and the triangles:

it has been increased to 1 4. You can also check the Step box to control the length of triangles:

34
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5. Click OK to validate. A Tesselation.x element is created in the specification tree. • • The free edges of the tessellation are those of the surfaces or solids. To avoid free edges between the tessellations of several contiguous faces, you can join them with the Join action of Quick Surface Reconstruction or Generative Shape Design. They will then be processed as a single surface.

Offsetting a Mesh
This task shows how to offset a mesh and create a watertight mesh. Open the Offset1.CATPart model from the samples directory.

1. Select the Offset icon

. The Offset Mesh dialog box is displayed.

2. Select the mesh. 3. Enter an Offset value. The offset mesh is displayed, together with a 35

STLPrototyping green vector representing the offset. The direction of the offset is given by the sign of the value.

4. Check the Create shell option to create a watertight offset::

Create shell unchecked

Create Shell checked

5. Click Apply to check or update the result. Then click OK to confirm the result and exit the action. The element Mesh Offset.x is created in the specification tree.

• •

The offset is computed in the direction of the weighted normals of the points. For better results, you should avoid to enter a high offset value.

36
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Display Options and Graphic Properties
This task shows how to change the display option of clouds of points. Open the Visu1.CATPart model the from the samples directory. It consists of four clouds of points: • • • • a a a a mesh, cloud of points, set of scans, set of grids.

Their default colors are respectively: • • • • orange, green, cyan, cyan.

The display options are available from the Cloud Display Options box. Further graphic properties are available from the Edit/Properties menu, in the Graphic tab. From the Cloud Display Options box, you can: • • • Choose the sampling of clouds of points (N of 100 points are displayed). Choose to display scans or grids as polylines, points, or both. Choose to display triangles, free edges, non-manifold edges of meshes. You can also choose their display mode: flat or smooth.

From the Edit/Properties menu, you can: • • • • Choose Choose Choose Choose the fill color of the mesh and its transparency level, the color and symbol of the points of a cloud, the color, type and thickness of scans and grids, to elements pickable or not.

Cloud Display Options box The images below are only examples. 1. Click the Cloud Display icon Option dialog box is displayed. at the bottom of the screen. The Cloud Display
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2. Select the cloud to modify. Display options are proposed according to the type of the cloud selected:

Following options are not yet available: • • • • Protected, Orientation, Shrink, Normal.

3. For the cloud of points, you can choose to display only a percentage of the points making the cloud, using the Sampling option. By default, 100% of the points are displayed. You can change this value with the associated spinner.

Sampling=100

Sampling=25

38
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The Symbol options are not available in that box, but in the Graphic Properties menu. For the sets of scans or grids, you can display them as line of points or points or both:

For the mesh, you can: • display the triangles,

•

visualize only the vertices for a lighter display (do not forget to de-activate the Smooth, Flat or Triangles options)

39
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instead of

• •

the free edges in yellow, the non-manifold facets and their vertices in bold white lines.

•

If you choose the display of triangles, the triangles accepting a non-manifold edge

40

User Tasks have their edges displayed as regular white lines.

•

display the mesh as a smooth or a flat mesh.

or

The free edges displayed are those of the complete cloud of points: • if you activate only a portion of a cloud of points, the free edges of that portion are not displayed.

41
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•

if you remove a portion of a cloud of points, the free edges of the remaining portion are displayed.

• •

If you move a cloud of points or a mesh, its graphic display options (not the graphic properties) are lost. The display options are not saved in the CATPart while the graphic properties are.

Edit/Properties menu (Graphic tab) For more information about this menu, please refer to the Displaying and Editing Graphic Properties chapter in the CATIA Infrastructure user's guide. The images below are only examples. You can access this menu through Edit/Properties, or through the contextual menu of the element, or display the Graphic Properties toolbar (View/Toolbars/Graphic Properties).

42
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or

• • •

The color displayed in the Graphic Properties toolbar applies to meshes only. The graphic properties are saved in the CATPart. Use Fill/Color and Transparency to modify the color and transparency of meshs:
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Please note that : • • • the color of mesh free edges is yellow, and is not editable, the color of non-manifold edges is white, and is not editable, the default color of scans has changed to cyan.

For a higher transparency quality, go to Tools/Options/Display/Performances and check the High (Alpha blending) option. • Use Edges/Color, Line type and Thickness to modify the display of scans and grids or of the triangles of a mesh :

•

Use Points/Color and Symbol to modify the display of clouds of points:
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•

Use the Pickable check box to make an element pickable or not, and choose the pick option in the list below.

Information
This task shows you how to get information on a cloud of points. Open Info1.CATPart from the samples directory.

1. Click the Information icon

and select a cloud of points.

2. An information box is displayed, with the statistics about the selected cloud: o o o Bounding box ,and active bounding box, Number of points, of active points, of selected points, of filtered points, Total number of triangles and of active triangles.

3. If you select another cloud, the information box is updated with the statistics of that cloud. 4. Push the Close button when you are finished to exit the action.
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Interoperability
Updating Your Design
This task explains how and when you should update your design. The point of updating your design is to make the application take your last operation into account. Indeed some changes to geometry or a constraint may require rebuilding the part. To warn you that an update is needed, CATIA displays the update symbol next to the part name and displays the corresponding geometry in bright red. To update a part, the application provides two update modes: • automatic update, available in Tools -> Options -> Mechanical Design > Assembly Design -> General tab. If checked, this option lets the application update the part when needed. manual update, available in Tools -> Options -> Mechanical Design -> Assembly Design -> General tab, it lets you control the updates of your part. You simply need to click the Update icon integrate modifications. whenever you wish to

•

Non-updated wireframe and surface elements are displayed in red. 1. To update the part, click the Update icon .

A progression bar indicates the evolution of the operation.
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You can cancel the undergoing update by clicking the Cancel button available in the Updating... dialog box. • Keep in mind that some operations such as confirming the creation of features (clicking OK) do not require you to use the update command. By default, the application automatically updates the operation. • The Update capability is also available via Edit -> Update and the Update contextual command. To update the feature of your choice, just select that feature and use the Local Update contextual command. Besides the update modes, you can also choose to visualize the update on the geometry as it is happening by checking the Activate Local Visualization option from the Tools -> Options -> Infrastructure -> Part Infrastructure, General tab. In this case, as soon as you have clicked the Update icon :

• •

1. the geometry disappears from the screen 2. each element is displayed as it is updated, including elements in No Show mode. Once they have been updated, they remain in No Show mode.

Interrupting Updates
This task explains how to update a part and interrupt the update operation on a given feature by means of a useful message you previously defined. Open any document containing geometric elements. 1. Right-click an element from the specification tree and choose the Properties contextual menu item. The Properties dialog box is displayed. 2. From the Mechanical tab, check the Associate stop update option.
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3. Enter the text to be displayed when the updating process will stop when reaching this element. 4. Click OK to confirm and close the dialog box. The Stop Update.1 feature is displayed in the specification tree, below the element for which it was defined.

5. Whenever it is needed, click the Update icon part.

to update the whole

The updating process stops after having updated the element selected above, and issues the message as has been defined earlier:

6. Click Yes or No, depending on what you intend to do with the geometry created based on the selected element. Would you no longer need this capability, you can: • right-click the element for which the stop was defined, choose the Properties contextual command and check the Deactivate stop update option from the Mechanical tab: the update will no longer at this element. You notice that when the capability is deactivated, the Stop Update icon in the specification tree. changes to: right-click Stop Update.1 from the specification tree, and choose the Delete contextual command.

•
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Creating Datums
This task shows how to create geometry with the History mode deactivated. In this case, when you create an element, there are no links to the other entities that were used to create that element. 1. Click the Create Datum icon to deactivate the History mode.

It will remain deactivated until you click on the icon again. If you double-click this icon, the Datum mode is permanent. You only have to click again the icon to deactivate the mode. A click on the icon activates the Datum mode for the current or the next command. The History mode (active or inactive) will remain fixed from one session to another: it is in fact a setting.

Points in Generative Shape Design
This task shows you how to use points from a cloud of points in Generative Shape Design. Open the Cloud1.CATPart from the samples directory. We used the Line Definition for our example, but the operating mode is the same for all creation action requiring points. 1. Select the type of creation from the combo list of the dialog box. 2. Go to the next Point field and choose Create Point from the contextual menu.

3. The Point Definition dialog box is displayed.
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4. Click a point on the cloud. Its coordinates are displayed in the Point Definition dialog box. Click OK to confirm the creation of this point. 5. In the main dialog box, go to the next Point field and repeat the above steps as many times as necessary. 6. If necessary, push the Point icon on the right of the Point field to modify the point you have created: the Point Definition dialog box is displayed and updated according to your pick on the cloud.

Managing Geometrical Sets
Geometrical sets enable to gather various features in a same set or sub-set and organize the specification tree when it becomes too complex or too long. You can put any element you wish in the geometrical set, it does not have to be structured in a logical way. The order of these elements is not meaningful as their access as well as their visualization is managed independently and without any rule.
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User Tasks This task shows how to manage geometrical sets within the specification tree. This involves: • • • • • inserting a geometrical set removing a geometrical set changing body sorting the contents of a geometrical set reordering elementts

You will find other useful information in the Managing Groups and Hiding/Showing chapters. • You can insert and manipulate geometrical sets in the specification tree in much the same way as you manage files in folders. For instance, you can copy/paste elements from a geometrical set to a target geometrical set. • These management functions have no impact on the part geometry. • When loading the Generative Shape Design workbench, a Geometrical Set automatically becomes the current body. This also means that only the results of the Hybrid Body, i.e. the result of all the operations performed on geometry, is visible and not any intermediate state of the Hybrid Body. • You can define the Generative Shape Design feature that is to be seen when working with another application, such as Generative Structural Analysis for example. To do this, while in the Generative Shape Design workbench: 1. Choose the Tools -> External View... menu item The External View dialog box is displayed. 2. Select the element belonging to a Geometrical Set that should always been seen as the current element when working with an external application. 3. Click OK in the dialog box.

The selected element will be the visible element in other applications, even if other elements are created later in the .CATPart document, chronologically speaking. To check whether an external view element has already been specified, choose the Tools -> External View... menu item again. The dialog box will display the name of the currently selected element. This also allows you to change elements through the selection of another element. Note that you cannot deselect an external view element and that only one element can be selected at the same time.
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Inserting a Geometrical Set
1. In the specification tree, select an element as the location of the new geometrical set. This element will be considered as a child of the new geometrical set and can be a geometrical set or a feature. 2. Select the Insert -> Geometrical Set menu command. The Insert Geometrical Set dialog box is displayed. The Features list displays the elements to be contained in the new geometrical set. 3. Enter the name of the new geometrical set. 4. Use the Father drop-down list to choose the body where the new geometrical set is to be inserted. All destinations present in the document are listed allowing you to select one to be the father without scanning the specification tree. They can be: o geometrical sets o parts 5. Select additional entities that are to be included in the new geometrical set.

If all selected entities belong to the same geometrical set, the father of the new geometrical set is automatically set to the father of these entities. 6. Click OK to create the geometrical set at the desired location. The result is immediate. CATIA displays this new Geometrical Set.x, incrementing its name in relation to the pre-existing bodies, in the specification tree. It is created after the last current geometrical set and is underlined, indicating that it is the active geometrical set. The next created element is created within this geometrical set. You cannot create a geometrical set within an ordered geometrical set and vice versa. • This Insert Geometrical Set dialog box is only available with the Generative Shape Design 2 product. You can check the Create a Geometrical Set when creating a new part option in Tools -> Options -> Infrastructure -> Part Infrastructure -> Part Document tab if you wish to create a geometrical set as soon as you create a new part. For •
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Removing a Geometrical Set
Two methods are available: • If you want to delete the geometrical set and all its contents:

1. Right-click the geometrical set then select the Delete contextual command. • If you want to delete the geometrical set but keep its contents: This is only possible when the father location of the geometrical set is another geometrical set. This is not possible when the father location is a root geometrical set.

1. Right-click the desired geometrical set then select the Geometrical Set.x object -> Remove Geometrical Set contextual command. The geometrical set is removed and its constituent entities are included in the father geometrical set. You cannot delete a feature within a geometrical set created on the fly. Indeed this geometrical set is considered as private and can only be deleted globally.

Moving Elements of a Geometrical Set to a New Body
1. From the specification tree, select the element then choose the Geometrical Set.object -> Change Geometrical Set... item from the contextual menu.

Multi-selection of elements of different types is supported. However, note that in this case, the contextual menu is not available, and that you can access this capability using the Edit menu item. The Change geometrical set dialog box is displayed, listing all the possible destinations.
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2. Select the Destination body where the geometrical set is to be located. Here we selected GeometricalSet.3. You can do so by selecting the body in the specification tree, or using the drop-down list from the dialog box. By default, if you select a body, the geometrical set is positioned last within the new body. However, you can select any element in the new body, before which the moved geometrical set will be located. 3. Select the element above which the one you already selected is to be inserted.

You can directly select this positioning element. In this case the Destination field is automatically updated with the Body to which this second element belongs. 4. Click OK to move the geometrical set to the new body. The element selected first is moved to its new location in the specification tree, but geometry remains unchanged.
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•

•

Check the Move unshared parents option to move all parents of the first selected element to its new location, provided these parents are not shared by any other element of the initial body. In this case, all the unshared parents are highlighted prior to the move. Check the Move all parents option to move all parents of the first selected element to its new location, regardless of whether these parents are used (shared) by any other element of the initial body. In this case, all the parent elements are highlighted prior to the move.

•

You can move a whole branch, i.e. a whole body and its contents, at a time. Here we moved GeometricalSet.3 last in GeometricalSet.1.
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You cannot move some elements of a multi-output alone to another body: only the whole multi-output can be moved.

Sorting the Contents of a Geometrical Set
You may need to sort the contents of a Geometrical Set, when the geometric elements no longer appear in the logical creation order. In that case, use the Auto-sort capability to reorder the Geometrical Set contents in the specification tree (geometry itself is not affected). The GeometricalSet.1 contains two extruded surfaces based on point-point lines. The specification tree looks like this:

1. Right-click the GeometricalSet.1 from the specification and choose the GeometricalSet.1 object -> AutoSort command. Instantly, the contents of the Geometrical Set are reorganized to show the logical creation process. The geometry remains unchanged.
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Reordering Elements within a Geometrical Set
This capability enables you to reorder elements inside the same geometrical set. 1. Right-click the GeometricalSet.1 from the specification tree and choose the Ordered Geometrical Set.1 object -> Reorder Children command. The Reorder Children dialog box is displayed. 2. Select an element. 3. Use the arrows to move an element up or down.

Reordering Features
The Reorder command allows you to move a feature in a Geometrical Set. These features can be: • • • solids shape features sketches

Replacing Features
This capability is only available on shape features. Please refer to the Replacing or Moving Elements chapter in the Part Design User's Guide. To manage this capability, the Do replace only for elements situated after the In Work Object option is available in Tools -> Options -> Part Infrastructure -> General tab. It allows you to make the Replace option possible only for features 57
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Workbench Description
This chapter describes the menus, sub-menus, items and toolbars of the workbench.

Menu Bar
This chapter describes the menus available in the workbench. Other menus are documented in the Infrastructure User's Guide. Start SmarTeam File Edit View Insert Tools Windows Help

Start
Starts the STL Rapid Prototyping Workbench

Insert
For STL Import STL Export Edition: See Importing Files Exporting Meshes to STL

Activating a Portion of a Cloud of Points Removing Elements Mesh: Mesh Regeneration Tessellating an Object Offsetting a Mesh
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Flip Edges Smoothing Meshes Mesh Cleaner Filling Holes on Meshes

Decimating Meshes

Operation :

Merging Meshes Splitting Meshes Trim/Split Information

Analysis

For the other menu items, please refer to the Infrastructure User's Guide.

Toolbars
STL Files
For See ImportImporting Files Export Exporting Meshes to STL

STL Edition
For See ActivationActivating a Portion of a Cloud of Points Remove Removing Elements

Tessellation
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For Mesh Regeneration Surface Tessellation Offset Flip Edges Mesh Smoothing Mesh Cleaner Filling Holes Decimation

See Mesh Creation Tessellating an Object Offsetting a Mesh Flip Edges Smoothing Meshes Mesh Cleaner Filling Holes on Meshes Decimating Meshes

Interactive Triangle Creation Interactive Triangle Creation

Analysis
For See Information Information

Specification Tree
The specification tree portion specific to STL Rapid Prototyping looks like this:

Geometrical Sets

Groups

Output of Import Output of Mesh Regeneration Output of Surface Tessellation Output of Offset Output of Polygon Smoothing Output of Meshes Merges Output of Split Output of Mesh Cleaner
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Output of Trim/Split
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