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Drawing Generation: Overview
Welcome to the Drawing Generation User's Guide. This guide is intended for users who need to become quickly familiar with Digital Project's Drawing Generation workbench. This overview provides the following information: • • • Drawing Generation in a Nutshell Before Reading this Guide Getting the Most Out of this Guide

Drawing Generation in a Nutshell
Drawing Generation is a Digital Project workbench that provides the user with functions and tools to create 2D drafting documents directly from the 3D model. Plans, sections, and elevations as well as more specialized orthographic and axonometric drawings can be created quickly and efficiently with Drawing Generation. The Drawing Generation User's Guide has been designed to show you how to generate drawings of varying levels of complexity, as well as apply dimensions, annotations and dress-up elements to these drawings. This section also outlines how to split drawings into layers based on attributes, part names, or layer numbers of the corresponding 3D geometry, and it explains how to center views for export to AutoCAD.

Before Reading this Guide
Before reading this guide, you should be familiar with basic Digital Project concepts such as document windows, standard and view toolbars. Therefore, we recommend that you read the Infrastructure User's Guide that describes these generic capabilities. You may also like to read the following complementary guides: • • Interactive Drafting User's Guide: explains how to create drawings of varying levels of complexity. Data Exchange Interface User's Guide: describes how to import and export external files in miscellaneous formats, including DXF/DWG and CGM.

Getting the Most Out of this Guide
To get the most out of this guide, we suggest that you start reading the Getting Started and then perform the Basic Tasks. If you are an administrator, the Administration Tasks section is specifically aimed at you. You will see how to manage and customize generative view styles.
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What's New?
New Functionalities
Breakout views in Approximate mode You can now generate breakout views using the Approximate generation mode. Associative dimensions on Approximate views When creating a dimension in an Approximate view, the dimension can now be created associative to the part. This capability is optional, so as to enable the creation of non-associative dimensions on approximate views. Edit 3D Attributes In Drawing workbench, the user can view and edit the attributes of a 2D item's corresponding 3D geometries. Coloring Geometry by Attributes The Color Filter can color the 2D items based on the attributes on the 2D items' corresponding 3D geometries. Insert Attribute Link An attribute link is a text whose content is the value of an attribute. Digital Project maintains the link between the text and the attribute. So when the value of the attribute changes, the text's content can be updated to reflex new attribute value.
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Getting Started
Before getting into the detailed instructions for using Generative Drafting, the following tutorial aims at giving you a feel of what you can do with the product. It provides step-by-step scenarios showing you how to use basic capabilities and key functionalities. First, you will learn how to define a drawing sheet for use in the subsequent scenarios. Then, the Part Drawing section explains how to generate various types of views from a part, while the Assembly Drawing section shows how to generate views from an assembly and illustrates other generative functionalities. Simply follow the instructions as you go along. Note that you can perform each section of this tutorial independently, depending on your specific drawing needs. To learn how to create basic architectural drawings, see Creating an Architectural Plan in Creating Architectural Drawings and for more complete information about drawing generation see the User Tasks section. All together, this tutorial should take about 20 minutes to complete. Before discovering this tutorial, you should be familiar with the basic commands common to all workbenches, which are described in the Infrastructure User's Guide.
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Creating an Architectural Plan
This task explains how to generate a 2D architectural plan from a a 3D Digital Project model.

Prerequisites. • • • • Familiarity with drawing generation Understanding of Interactive Drafting Ability to work with layers and graphic properties Ability to create simple geometry such as axis systems and reference planes

1. Open the model that will have plans cut.

2. Create an axis system with the XY plane at elevation 0 of the model, and the Z axis of this coord

3. Create a reference plane to indicate the level of each plan cut. Create each plane by clicking on For Reference select the XY plane of the new axis system. For Offset type the elevation of the pl
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The result should be similar to the image below.

To preview the plan in 3D, see Using Dynamic Sectioning to Preview Drawings.
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4. Add annotation planes to each plan reference plane. In order for the plan to be extracted to the reference plane. The annotation tools are in Start -> Project Center -> Project In the Project workbench, make sure that the root product is selected by double-clicking on it.

From the Project tools, select Section View have created.

. Select one of the support planes you created in

5. Open the Drawing Generation workbench or open an existing drawing template. To open the Drawing Generation workbench, select Start -> Drawings -> Drawing Generation. When you select Drawing Generation, the New Drawing Creation dialog appears.

To alter any of these settings click drawing extraction.

. If you use the default UDS (Uniform Drawing Syste
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Click

to return to New Drawing Creation, and then click

to create the drawing
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6. Add a new sheet to the current drawing for each plan to be extracted. You may add a sheet by c -> New Sheet from Insert -> Drawing -> Sheets -> NewSheet

7. In the drafting workbench, select View from 3D

. It appears in the tear-off toolbar under F

8. After you select view from 3D, Digital Project, a Generative View Style drop-down appears, allow drawing generation style, DefaultGenerativeStyle is the default.

9. Then, Digital Project waits for you to select the appropriate view from the 3D model in the Proje you want to create in 2D from the specification tree.

When you select this view, a schematic projection of this view is positioned on the current drawing
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To extract the drawing, click within the green square.
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10. By default, the extracted drawing is centered in the middle of the sheet. To position the drawin of the root product in 3D, click Position view at origin of sheet .
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11. You may want to set the graphic properties of your drawing by attributes, part names, or 3D la Based on Rules .

The layers and graphic properties used by Set Graphic Properties Based on Rules are defined in pro information about customizing these rules, see Modifying Layer Extraction Rules.

Creating an Architectural Section
14
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This task explains how to generate a 2D architectural Section from a a 3D Digital Project model.

Prerequisites. • • • Familiarity with drawing generation and Interactive Drafting Ability to work with layers and graphic properties Ability to create simple geometry such as axis systems and reference planes

1. Open the model that from which you want to cut the sections.

2. Create the reference planes for the section cuts. A simple way to do this is to first that contains section lines and then create planes through create a sketch these lines that will be used as reference geometry for the sections. Make sure that the plane type is Angle/Normal to plane, select the absolute origin xy plane as the reference, and provide the sketch as the rotation axis. Set the angle to 90 degrees.
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3. Add annotation planes and annotations to each section reference plane. In order for the plan to be extracted to the 2D drawing, at least one annotation plane must appear on each reference plane. The annotation tools are in Project Center -> Project

In Project, make sure that the root product is selected by double-clicking on it.

From the Project tools, select Section View . Select one of the support planes you created in step 2. In the tree, an annotation set will appear with the view(s) you have created.

16

Creating Architectural Drawings 4. Open the Drawing Generation workbench or open an existing drawing template. To open the Drawing Generation workbench, select Start -> Drawings -> Drawing Generation When you select Drawing Generation, the New Drawing Creation dialog appears.

To alter any of these settings (such as paper size, scale, or drafting standard) click . Otherwise click .
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5. In the drafting workbench, select View from 3D toolbar under Front View .

. It appears in the tear-off

6. After you select view from 3D, a Generative View Style drop-down appears, which allows you to select a drawing generation style. If you do not select a drawing generation style, the default is DefaultGenerativeStyle .

7. Digital Project thenwaits for you to select the appropriate view from the 3D model in the Project workbench. Switch to the 3D view of the model and select the view you want to create in 2D from the specification tree.

When you select this view, a schematic projection of this view is positioned on the current drawing sheet.
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To extract the drawing, click within the green square.
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8. By default, the extracted drawing is centered in the middle of the sheet. To position the drawing so that (0,0) in the drawing coincides with the absolute axis system of the root product in 3D, click Position view at origin of sheet .

9. You may want to set the graphic properties of your drawing by attributes, part names, or 3D layers. To set these properties automatically, click Set Graphic Properties Based On Rules .

The layers and graphic properties used by Set Graphic Properties Based On Rules are defined in project standards and managed by the administrator. For more information about customizing these rules, see Modifying Layer Extraction Rules.
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Using Dynamic Sectioning to Preview Drawings
This task explains how to preview 2D drawings using dynamic sectioning.

Prerequisites. • Basic understanding of workbenches, tools, and manipulating geometry.

1. Open the model that will have plans or sections cut. This model should already have reference planes for the proposed plan and section cuts.
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2. Click on the Sectioning icon . A second window will open next to the first, which shows the section (initially it is blank).
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3. In Sectioning Definition, click Geometrical Target , and select the reference plane of the plan or section that you wish to preview. This will align the dynamic section plane with this reference plane and show the cut in the section window.
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In order to view the section properly, you may need to zoom extents the section. Also, you should right click on the section window and turn 2D Lock on. This ensures that you are always viewing the section from the proper projection.

4. You may also view the 3D model sectioned at the plane by selecting Result -> Volume Cut .
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5. If you want to save this section for later viewing, click OK. Otherwise click Cancel.

Edit 3D Attributes
In Drawing workbench, the user can view and edit the attributes of a 3D geometries corresponding to the 2D item.
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Prerequisites. • Familiarity with attributes

1. Select the current dictionary, such as Uniformat, in the Dictionaries combo box. 2. Select the current package, such as B2010 Exterior Walls, in the Packages combo box.

3. Click the Edit 3D Attributes

button.

4. Move the mouse cursor over the 2D drawing items. Notice the 2D item will be highlighted if its corresponding 3D geometries have the current package or are aggregated by the current group.
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5. Click on a highlighted 2D item. The Edit Attributes dialog will pop up.

6. View or edit the attributes. Click OK or Cancel to finish.
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Filtering 2D Items Using Attributes
This documentation explains how to use color filter in the Drawing workbench. The Color Filter can color the 2D items based on the attributes on the 2D items' corresponding 3D geometries.

Prerequisites. • Familiarity with attributes

1. Select the current dictionary, such as Uniformat, in the Dictionaries combo box. 2. Select the current package, such as B2010 Exterior Walls, in the Packages combo box.
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3. Click the Color by Attributes

button.

4.Set the parameters in the Color Filter dialog:

5. Click Apply button to apply the filters.
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Note: For detail explanations of each UI components in the Color Filter dialog, please refer to Filtering Geometry Using Attributes in the Assigning Attributes to Geometry book.

Linking a text to an attribute
An attribute link is a text whose content is the value of an attribute. Digital Project maintains the link between the text and the attribute. So when the value of the attribute changes, the text's content can be updated to reflex new attribute value. This documentation explains how to create or insert an attribute link and how to update the attribute link after modifying the attribute.
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Prerequisites. • Familiarity with attributes

1. Select Uniformat in the Current Dictionary combo box and select B2010 Exterior Walls in the Current Package combo box.

2. Create a text, such as the Text with Lead with "The value of Detail Element is " as its content.
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3. Click the Insert Attribute Link toolbar.

button in the Generation Utilities

4. Select the text created in the Step 2.

5. Move the mouse cursor and find a 2D item whose 3D geometry has the current package or is aggregated by the current group. Hint: if a 2D item's 3D geometry has the current package or is aggregated by the current group, the item will be highlighted. Otherwise, the cursor will become a stop sign to indicate the item is not selectable.

6. Click a highlighted 2D item and the Select an Attribute dialog will pop up.

This dialog will list all the attributes and their values of the packages attached to the corresponding 3D geometry or of the groups that aggregate the corresponding 3D geometry.
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Creating Architectural Drawings 7. Select the attribute whose value you like to insert into to the drawing text and click OK. Note the value of the Detail Element attribute is inserted in the drawing text selected in Step 1.

8. Now we will modify the attribute and show how to update the drawing text.

Click the Edit 3D Attributes

button.
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10. Change the value of Detail Element to B2015 Balcony Walls & Handrails.

11.Click OK to commit the change.

12. Click the Update Active Sheet toolbar.

button in the Generation Utilities

13.Note the content of the drawing text is updated and has the new value of the Detail Element attribute: B2015 Balcony Walls & Handrails.

34

Creating Architectural Drawings

Setting Layers and Graphic Properties based on rules
This task explains how to assign the points, lines, and curves in a drawing to specific layers, line weights, and line types based on preset rules.
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Prerequisites. • • • Familarity with drawing generation Understanding of Interactive Drafting Ability to work with layers and graphic properties.

1. Create a generated view in the drafting workbench.

2. After you have created a view, click Set Graphic Properties Based on Rules .

Project standards define the layers and graphic properties used by Set Graphic Properties Based on Rules are defined in. The administrator manages these standards. For more information about customizing these rules, see Modifying Layer Extraction Rules.
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Entering the Interactive Drafting Workbench
This first task shows you how to enter the Drafting workbench and start a new drawing. 1. Select File -> New (or click the New icon).

The New dialog box is displayed, allowing you to choose the type of the document you need. 2. Select Drawing in the List of Types field and click OK.

OR 1. Select Start -> Mechanical Design from the menu bar. 2. Select the Drafting workbench.

OR 1. Select Tools -> Customize (Start Menu tab) and define the Favorites (Drafting) and Accelerator (F12) options as shown below and click the Close switch button.
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2. Press the F12 key or select Start -> Drafting from the menu bar.

Whichever method you used for entering the Drafting workbench you used, the New Drawing dialog box is displayed, allowing you choosing the type of Standard, Sheet Style, Orientation you need. The sheet style defines among other things the sheet format, scale and orientation.
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3. Select the ISO standard and click the Landscape option. If you activate the Hide when starting workbench option, the next time you enter the Drafting workbench via Start -> Drafting or by pressing the F12 key, the New Drawing dialog box will not appear any more and the last selected standard, sheet style and orientation will be used by default to create the drawing. You will always be able to reactivate this dialog box by unselecting the Hide when starting workbench option available via Tools -> Options -> Mechanical Design -> Drafting -> General tab, or to access it by selecting File -> New Drawing from the menu bar. 4. Click OK.

•

•

You can add an unlimited number of customized standards using Standard files that you will create and/or, if needed, modify. Once created, this standard will appear in the New Drawing dialog box. For more details on standards, see the Standards Administration section. Care that any userdefined standard is based on one of the four international standards (ANSI, ISO,ASME or JIS) as far as basic parameters are concerned. You can add an unlimited number of customized sheet styles using Standard files, see Sheet Styles.

The Drafting workbench is loaded and an empty drawing sheet opens. The drawing specification tree is displayed to the left of the sheet.
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Pressing the F3 key lets you show or hide the specification tree as desired. Make sure you customized the units accordingly. For this: 1. Select the Tools -> Options command to display the Options dialog box. 2. Click General > Parameters and Measure in the list of objects to the left of the Options dialog box. 3. Select the Units tab and set Length to Inch and then click OK. To visualize better your drawing, tile the windows horizontally from the menu bar. The commands for creating and editing features are available in the workbench toolbar. Now to fully discover the Interactive Drafting workbench, let's perform the following tasks.

Basic Tasks
User Tasks
The Generative Drafting workbench provides a simple method to create and modify views on a predefined sheet. You may also add, modify and/or delete dress-up and 2D elements to these views. All this is performed on a sheet which may include a frame and a title block and will eventually be printed.

Before you begin, we recommend you de-activate the Grid icon Tools toolbar.
 Link Bar 0

from the

Managing Drawings
Drawing Management
The Generative Drafting workbench lets you manage CATDrawing documents.

Create a new drawing: create a CATDrawing document. Open a drawing: open a CATDrawing document. Edit drawing links: edit the links which exist from a CATDrawing document to an existing CATPart document, CATProduct document, sheet metal part or a .model V4/V5 document. Update drawings via the batch monitor: update a list of CATDrawing documents
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using the batch monitor.

Creating a New Drawing
This task will show you how to create a new drawing with pre-defined views generated from a part. Open the GenDrafting_part.CATPart document. Make sure no drawing is already open. 1. From the menu bar, select Start -> Mechanical Design. 2. Select the Drafting workbench. The New Drawing Creation dialog box appears with information on views that can possibly be created, as well as information on the drawing standards. You can modify the drawing standards. For this, click the Modify button. The New Drawing Creation dialog box will not appear if you did not previously open a CATPart or a CATProduct document.

3. Select the views to be automatically created on your drawing from the New Drawing Creation dialog box, for example the Front, Bottom and Right icon.
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4. Click OK. A progress bar appears while the views are being generated from the opened CATPart.

If the color of the part is white and the Inherit 3D Colors option is checked in Tools -> Options -> Mechanical Design -> Drafting -> View tab, the generated views will result white and therefore not necessarily properly visualized.

The resulting view position will depend on the CATPart you loaded before starting the Drafting workbench. In other words, the views will be positioned according to: • • • a plane you possibly selected in the part. a planar surface you possibly selected in the part. xy coordinates, in case you did not open a CATPart beforehand. In this case, you will only be able to define the drawing standards via the New Drawing dialog box.

Opening a Drawing
This task will show you how to open a CATDrawing document. For more details on opening documents, refer to the Infrastructure User's Guide.

1. Click the Open icon

from the Standard toolbar, or select File -> Open.

2. Select the document to be opened. In this case, open GenDrafting_part.CATDrawing.
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The GenDrafting_part.CATDrawing document opens as shown below:

Editing Drawing Links
43

drawingGeneration This task will show you how to edit the links which exist from a CATDrawing document to an existing CATPart document. Use the same methodology for links to a CATProduct, a sheet metal part or a V4/V5 .model document. There are two possibilities: • • Editing drawing links with the reference document loaded Editing drawing links with the reference document not loaded

Editing drawing links with the reference document loaded
Go to Tools -> Options -> General, click on the General tab, and make sure the Load referenced documents option is checked (this option is set by default). Then, click OK to validate.

When opening a drawing, if the referenced CATPart does not exist, a message will appear, mentioning that the links could not be found or contain wrong information.

1. Open the GenDrafting_part_links.CATDrawing document.
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2. Select Edit -> Links. The Links dialog box appears with the existing links between the CATDrawing and its related CATPart. In our example, this corresponds to links applied to the front, top and right views which are found and loaded (currently displayed in our session).

3. Click OK to validate and exit the dialog box.

Editing drawing links with the reference document not loaded
Go to Tools -> Options -> General, click on the General tab, and uncheck the Load referenced documents option (this option is set by default). Then, click OK to validate. 1. Open the GenDrafting_part.CATDrawing document.
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2. Select Edit -> Links. The Links dialog box appears, showing the existing links between the CATDrawing and its related CATPart. In this example, this corresponds to links applied to the front, rear, top, bottom, left, right and isometric views, which are found but not loaded (although currently displayed in our session). Note that when the reference document is not loaded, a number of commands can no longer be used, such as projection, dress-up and dimension commands. You can still modify the graphic properties of the elements in the views.

3. You can perform the following operations:

46

User Tasks

• use the Load button to load parts (and parts only) that are not loaded. The status will change from "Document not loaded" to "OK". • use the Replace button to replace the selected link with another one. This button opens the File Selection dialog box to let you navigate to the desired file. Once the link has been replaced, the new element name is displayed along with its status in the Links dialog box. The views whose link has been replaced are considered as being notup-to date in all cases, no matter what document you chose for replacement. • use the Refresh button to update the links related to the document without having to close then re-open the Links panel. This is especially useful when trying to re-access pointed documents that are not found (for instance, after a network disconnection): in that case, clicking the Refresh button avoids you to re-select the Edit->Links... command to display an updated view of the links. Note that the Synchronize, Activate/Deactivate and Isolate are unavailable when editing a .CATDrawing document's links. For more details: • For information on the other capabilities available with the Links dialog box (such as selecting a feature and opening or changing the corresponding source (CATPart)), refer to Editing Document Links in the Infrastructure User's Guide. The Search Order capability allows you to solve links. For more details, see Infrastructure User's Guide.

•

Updating Drawings Via the Batch Monitor
This task will show you how to update a list of CATDrawing documents. To do this, you will use the batch monitor. The batch monitor lets you create as many batch configurations as required, and follow the progress of an update. Updating drawings via the batch monitor will be particularly helpful if you need to update a great number of drawings (but do not need to visualize them while doing so), or drawings which require large CPU resources. For more details on using the batch monitor, refer to Using the Batch Monitor in the Infrastructure User's Guide. 1. Run the CATUTIL command, using one of the methods described in the Infrastructure User's Guide. For example, from a V5 session, choose Tools -> Utility. The batch monitor appears, listing available batches. At this point, you either need to define the batch parameters that will be used to
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launch drawing update (this is the case if this is the first time you are using the batch monitor for drawing update), or you can run the batch directly (this is the case if you already defined all the necessary data).

Defining the batch parameters
Defining the update batch parameters consists in selecting the files to update, optionally specifying the files for which you want to force the update, and indicating the directory where the updated files should be saved. 2. From the list of available batches, double-click UpdateBatch (you can also rightclick UpdateBatch and select New parameters file). The UpdateBatch dialog box is displayed.

3. Click the Choose Files button to select the files that you want to update by batch. A selection dialog box is displayed. 4. Browse to the directory (on your computer or on your network) which contains the files that you want to include, select these files, and click Open. The selected files are now listed in the UpdateBatch dialog box. 5. Repeat steps 3 and 4 if you want to include files from another directory. You can remove files from the list of the files to update. To do so, select the unwanted file and click the Remove Files button.
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6. By default, the files which do not need to be updated will not be. However, you can decide to force the update for certain files, or for all of them. To do this, doubleclick on No in the Force Update colum for each file for which you want to force the update. The value is now set to Yes, which means the update will be forced. 7. Click the [...] button next to the Target field to select the directory in which you want the updated files to be saved. A dialog box is displayed. 8. Browse to the directory in which you want to save the updated files, select it and click OK. Your update batch parameters are now defined. Each time you run the update batch, updated files present in this target directory will be overwritten by the newly updated files.

9. Click the Save button to specify where you want to save your batch parameters. A dialog box is displayed. 10. Browse to the directory in which you want to save the batch parameters file, specify a file name in the appropriate field, and click Save. Your parameters are saved in an xml file. 11. You can now either click Run to run the batch immediately or click Cancel to close the UpdateBatch dialog box and run the batch later. For the purpose of this scenario, click Cancel. You can now exit the batch monitor. To play the scenario below, however, you will need to re-open the batch monitor.

Running the batch
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Once you have defined batch parameters in an xml file, you can run the batch. 2. From the list of available batches, right-click UpdateBatch and select Associate a parameters file.

A selection dialog box is displayed. 3. Browse to the directory in which you previously saved the xml batch parameters file, select this file, and click Open to validate. 4. Access the Start tab which now displays the name and location of the file you just associated to the batch.

5. Right-click the batch and select Run. The batch execution starts. 6. During or after the batch execution, you can get more information on the process in the Processes tab: the batch name, the batch identification number, the status (in progress or ended) as well as the start and end time. When the batch execution is over, you can exit the batch monitor.

Managing Sheets
Sheets
The Interactive Drafting workbench provides a simple method to manipulate a sheet. A sheet contains: • a main view: a view which supports the geometry directly created in the sheet,
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User Tasks • • a background view: a view dedicated to frames and title blocks, interactive or generated views.

Define the sheet: Define the sheet using commands and dialog boxes. Modify the sheet: Modify the sheet orientation using the Page Setup dialog box. Delete the sheet: Delete a sheet. Switch a drawing to another standard: Switch a drawing to another standard when several standards have been defined by an administrator. Update the standard of a drawing: Update the standard used by a drawing. Create a frame title block: Edit a background sheet and insert a frame and a title block into it.

Defining a Sheet
This task will show you how to define the sheet for a new CATDrawing document and, if needed, add more sheets. This task is divided into the following sub-sections: • • Defining a new sheet Adding a sheet

Defining a new sheet
1. Click the New icon from the menu bar. from the Standard toolbar or select File -> New...

2. Select Drawing, and click OK. The New Drawing dialog box is displayed.
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3. From the New Drawing dialog box, select the ISO standard, and the A0 ISO format. 4. Select the Landscape orientation and then click OK. • The sheet scale is a scaling factor which applies to all views in a given sheet. It does not determine the position of the views (or any other object) contained in the sheet. When the grid is displayed, the position of the view in the sheet is not determined by the grid, which only deals with what is drawn directly in the sheet. To see the real position of a given view in a sheet, you need to use the ruler. It is the only way to see the real coordinates in a sheet referential. The sheet size depends on the standard type. For example, if you choose the ISO standard, the sheet will automatically be assigned the A0 format. You can choose another format if you want. At any time, you can change the standard (which you can update), sheet format, orientation and/or scale. To do this, select File -> Page Setup from the menu bar. If you select a new standard, the value in the Apply on field becomes All sheets and the new standard is applied to all drawing sheets.

• •

Adding a sheet
You can add new sheets at any time. These new sheets will be assigned the same standard, format and orientation as the sheet first created and defined using the New Drawing dialog (default setting). 6. Click the New Sheet icon from the Drawing toolbar.
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The new sheet automatically appears as follows:

• • •

If you now delete Sheet.1, the newly created sheets will keep the same name. In other words, even if Sheet.1 has been deleted, Sheet.2 will remain named Sheet.2. The F3 key lets you show/hide the specification tree. Once you have created more than one sheet, you can activate one of the sheets by selecting it from the Drawing window or from the specification tree.

Modifying a Sheet
This task will show you how to modify the standard, format, orientation and/or scale of a sheet. Doing this amounts to modifying the options you selected in the New Drawing dialog box when defining the sheet.

Create a sheet using the ISO standard, the A0 ISO format, and the Landscape orientation.

1. Select File -> Page Setup from the menu bar. 2. From the Page Setup dialog box, select the ANSI standard, and the A ANSI format. You can update the current standards by clicking the Update button.
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This copies the most recent version of the standard file in the drawing, thus reflecting the latest changes an administrator may have performed in the standard file. If no new standard file is available, the Update button is disabled.

3. Select the Portrait orientation, and then click OK.

At this step, you can also insert a background view into the sheet you are currently modifying. For more information, refer to Managing a Background View. The Page Setup dialog box also let you modify the sheet format and set it to the printer format. For more information, refer to Printing a Document.
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Creating a Frame and a Title Block
This task shows you how to insert a frame and a title block in the background of a sheet. This operation is performed using a macro. A few macros are provided by default. You can customize frames and title blocks by either modifying the default macros (to add actions) or creating your own macros (to add specific formats). For more information on how to do this, refer to Creating a Frame and a Title Block in the Interactive Drafting User's Guide. Open the GenDrafting_part.CATDrawing document.

1. Select Edit -> Background from the menu bar. 2. Click the Frame Creation icon from the Drawing toolbar.

OR 2. Select the Insert -> Drawing -> Frame and Title Block items from the menu bar. The Insert Frame and Title Block dialog box is displayed:

3. Choose a macro from the Style of Titleblock drop-down list. For the purpose of this exercise, choose Drawing_Titleblock_Sample1. A preview of the
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frame and title block is displayed in the dialog box. 4. Indicate the action you want to perform in the Action list. • Creation: creates the frame and the title block • Deletion: deletes the frame and the title block • Resizing: resizes and updates the frame and the title block (if you change the page format in File -> Page Setup) • Update: updates the frame and title block, as well as the fields in the title block (part-related and sheet-related information) • CheckedBy: completes the "Checked by" field and automatically update the verification date • AddRevisionBlock: adds a revision block Information which is not available in the part will be substituted by "XXX" in the drawing. 5. Click OK in the Insert Frame and Title Block dialog box.

When the Frame Creation icon is activated, you cannot edit the views. Use Edit -> Working Views when you need to work on views. When adding sheets, if you want the frame and title block to appear in newly created sheets, go to Tools -> Options -> Mechanical Design -> Drafting -> Layout tab. Check the Copy background view option and the First sheet option. This will insert the frame and title block from the sheet you previously created on the current drawing.

Inserting an Image Into a Frame and Title Block
This task will show you how to insert a .gif image into a frame and title block.

Open the GenDrafting_part_titleblock_insert.CATDrawing document. Make sure you are in the background view (go to Edit -> Background from the menu bar). Make sure you have a .gif file at your disposal. Otherwise, you may use logoCATIA.gif.
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1. Select Insert -> Object from the menu bar. The Insert Object dialog box appears. You can either create a new object or re-use an existing file. 2. Activate the Create from File option from the Insert Object dialog box.

3. Browse your disk and select a .gif image from the Insert Object dialog box. 4. Click OK to validate and exit the dialog box. The image is inserted and positioned according to the sheet's origin. 5. If needed, modify the position of the newly inserted object by dragging it with the cursor, and/or resize it using the manipulators. Remember that you can move and resize the image as long as you remain in the background view. Depending on the image you used, you can get something like this, for example:
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To go back to the working views and create a front view, for example, go to Edit -> Working views before clicking the Front View icon. If you want the frame and title block to appear in the newly created sheets when adding sheets, go to Tools -> Options -> Mechanical Design -> Drafting > Layout tab. Check the Copy background view option and the First sheet option. This will insert the frame and title block from the sheet you previously created on the current drawing. If you have a viewer installed with the gif type associated to the viewer, you will not visualize the inserted image properly (an icon appears instead). If so, click on the displayed icon to get the image.

Managing a Background View
This task will show you how to add to a sheet the background view (title block plus elements) from the sheet of another drawing.

Before you begin, de-activate the Grid icon right).

from the Tools toolbar (bottom

1. Select the Tools -> Options command to display the Options dialog box. 2. Click Mechanical Design -> Drafting -> Layout tab, and check the Copy background view and Other drawing options.

58

User Tasks

• • •

If you un-check Copy background view, only the sheet properties will be copied from one sheet to another. If you check the First sheet and the Copy background view options, the background view of the first sheet will become the reference. If you check the Other drawing and the Copy background view options, the background view of the sheet you will select later will become the reference.

3. Click OK in the Options dialog box. from the Drawing toolbar. The Insert 4. Click the New Sheet icon Elements into a Sheet dialog box appears. 5. Click the Browse button in the Insert Elements into a Sheet dialog box. The File Selection dialog box appears. 6. Browse to select the drawing which you will use the background view from. In this particular case, select the GenDrafting_part_frame_titleblock.CATDrawing document. 7. Activate the Show Preview option in order to preview the selected CATDrawing document.
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8. Click Open in the File Selection dialog box. The preview of the frame and title block of the selected CATDrawing is now displayed in the Insert Elements into a Sheet dialog box.
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At any time you can decide that you do not want the preview to appear. For this, de-activate the Preview On or Off button 9. Click the Insert button. The title block now appears on a new sheet named Sheet 2. .
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Each time you need to insert a new sheet with a given frame and title block, go to Tools -> Options -> Mechanical Design -> Drafting -> Layout tab, and check the Copy background view option and the Other drawing option.

Creating Views
View Creation
The Generative Drafting workbench provides a simple method to create views on a predefined sheet.

In this chapter, most of the tasks illustrate how to create views from parts. These views can also be created from assemblies (exploded or not). Views created from assemblies are illustrated only whenever specific points need to be mentioned.

Before you begin: You should be familiar with important concepts. Create a front view: Use a reference plane on the 3D part to create a front view. If needed, use the manipulator to assign the right position to the view. Create an advanced front view: Create advanced front views to configure such elements as the view name, view scale, etc. Whenever possible, a pertinent projection plane is automatically offered.
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Create projection views: Use the green frame to automatically generate the projection views as desired. Create an unfolded view: Create an unfolded view from a Sheet Metal part. Create a view from 3D: Generate a view and the associated annotations from the 3D. Create an auxiliary view: Define a plane that will be used to generate the auxiliary view. Create an offset section view: Use a cutting profile to define and position the offset section view. Create an offset section cut: Use a cutting profile to define and position the offset section cut. Create a section view (Planar Surface): Use a cutting profile to define and position the offset section view. Create a section cut (Planar Surface): Use a cutting profile to define and position the offset section view. Create an aligned section view: Use a cutting profile to define and position the aligned section view. Create an aligned section cut: Use a cutting profile to define and position the aligned section cut. Create a section view with profile defined in 3D: Create a section view using a 3D profile as cutting plane. Create a section cut with profile defined in 3D: Create a section cut using a 3D profile as cutting plane. Create a detail view: Use a callout to create a detail view via a boolean operator from the 3D. Create a detail view profile: Use a polygon to create a detail view via a boolean operator from the 3D. Create a quick detail view: Use a callout to create a detail view by computing the view directly from 2D projection. Create a quick detail view profile: Use a polygon to create a detail view by computing the view directly from 2D projection. Create a clipping view: Create a clipping view with a circle as callout. Create a clipping view profile: Create a clipping view with a sketched profile as callout. Create an isometric view: Create an isometric view using a 3D part. Generate an exploded view: Create an isometric view, and then, projected views from an assembly previously exploded via Digital Mock-up workbench (DMU Navigator). Create a broken view: Create a broken view from an active and up to date generative view using two profiles corresponding to the part to be broken from the view extremities. Create a breakout view: Remove locally material from a left generated view, in order to visualize the remaining visible internal part. Create views via the wizard: Create views using a wizard by defining options in the Pre-Defined Configurations dialog box.
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Create views via the wizard: Automatically create front, bottom and right views using a wizard. Create views via the wizard: Automatically create front, left and top views using a wizard. Create views via the wizard: Automatically create all the views using a wizard.

Before You Begin
Before you start creating views, this section provides you with information on the following topics: • • • • • • • • • • What is the active view? Defining the view orientation Generated geometry/dress-up settings Generated geometry/dress-up properties Constraints 2D/3D associativity 3D elements generated in views Dress-up generated in views Callout representation Warm Start and views

Note: Views as discussed in this section are created on a pre-defined sheet, and should not be con working views and background views, which are components of the sheet. For more information on Sheets.

What is the Active View?

The active view is the view from which other views will be generated. This is also the view in which modifications will be performed. For instance, all the 2D geometry and dress-up elements that will the draft views to be created. Open the GenDrafting_part.CATDrawing document.
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The active view is framed in red. Non-active views are framed in blue.

When you create a view, until you click at the desired view location, the view to be created is fram If you click this view, it becomes the active view and is framed in red.

The active view is underlined in the Drafting specification tree, and specific icons are used to repre type (Front view, Projection view, Isometric view, etc). Refer to CATDrawing Specification Tree Ico information.

Activating a view

1. Double-click the frame of the view you want to activate. OR 1. Right-click the view you want to activate. The contextual menu appears. 2. Select Activate View.

Axes are taken into account on active views. As a result, the frame of an active view will adapt to t included in this view.
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Defining the View Orientation

You can redefine the reference plane orientation of a view to be created using the available blue ar the case when generating a front view, an isometric view or when generating views using the wiza Open the GenDrafting_part.CATPart document and start creating a front view. 1. Start creating the view. 2. Click the right or left arrow to visualize the right or left side, respectively.

3. Click the bottom arrow to visualize the bottom side.

4. Click the counterclockwise arrow to rotate the reference plane.
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5. Drag the green knob to redefine the rotating angle. The default increment value is 30 degrees.

6. You can modify the increment value using the green knob contextual menu. To do this, right-clic and select the desired option from the contextual menu.

• • •

Free hand rotation: Rotation is not snapped to a given increment but totally free. Incremental hand rotation: This is the default value: the rotation is snapped to a given incr 30 to 30 degrees, between zero and 330). Set increment...: The Increment Setting dialog box is displayed. Enter the Increment value example 5 deg (5 degrees).

•

Set current angle to: If you select the Set angle value... option, the Angle Setting dialog bo
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Enter the current angle (deg) you need. For example, 30.

Remember that there is no associativity between the selected plane/face in the 3D part and the pro of the generated views.

Yet, you can modify the view projection plane if you change the 3D part orientation. For more infor to the Modifying the View Projection Plane section.

Generated Geometry/Dress-Up Settings

You can generate a number of geometry or dress-up elements, depending on the options you selec Options -> Mechanical Design -> Drafting -> View tab.

For example, if you want the colors of a part to be automatically generated onto the views, check t colors option.
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If the color of the part is white and the Inherit 3D colors option is checked, the generated views wi you may not be able to visualize them properly.

•

• •

Note that if you modify the graphical properties (color, line type, line thickness, layer) of ge geometry or dress-up elements, such modifications are associative, i.e. they are kept when view later on. Also note that once you have overloaded the original properties of a geometry element, you cannot reset it to its original properties. Note that threads are generated on the condition they are defined on 3D holes. To project sketches, you need to select the Project 3D wireframe option. However, note tha cannot be projected if it is currently being edited in the Sketcher workbench. To project ske need to exit the Sketcher workbench before launching the view creation.

Generated Geometry/Dress-Up Properties

You can change the properties of some geometry and dress-up elements after the view has been g provided you check the desired options from the Properties dialog box. To display it, choose Prope contextual menu and select the View tab.

The graphical properties of generated geometry and dress-up elements are kept after you update v also true if you delete one or more elements.

•

•

•

•

Note that if you modify the graphical properties of (color, line type, line thickness, no show) generated geometry or dress-up elements, such modifications are persistent at update, i.e. when updating the view later on. Also note that, once you have overloaded the original grap properties of a geometry or a dress-up element, you cannot reset it to its original properties hand, you can restore all deleted elements in a view using the Restore Deleted command. Note that the persistency of this graphical dress-up/delete: o is only available in exact views. In views other than exact (CGR, Approximate or Ras operation will reset the elements to their original properties. o creates additional specifications in the drawing, which increases the file size and requ computing during the update process. As far as layers are concerned, when you select a layer and modify the graphical properties elements, the properties will be applied only when you update the selected layer. By default, the view and its elements are created in the layer None, as displayed in the Gra Toolbar. Yet, if you modify your view and add elements, they will be created in the active la be layer 0, 1, 2 or any layer you select in the toolbar. Since generated items are deleted and recreated each time the view is updated, when edite graphical properties of the item are stored according to its 3D origin. This way, the right pro applied to each new item according to its 3D origin. Thus, once updated, the generated item inherits the graphical properties corresponding to t previously stored.

In the following example, two generated items are modified. After performing an update, four item graphical properties of the 3D origin.
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3D part.

Modified Generated Item.

Generated item w 3D origin.

3D part.

Modified Generated Item. Generated item with the same Overloaded graphical properties are not kept for the following generated items: • • • •

Generated shapes (hatching in sections and breakout views) Edges corresponding to symbolic visualization of fillets Edges representing limits of clipping, detail or broken views (this does not include the callou which is not a generated element) Annotations generated from 3D annotations or 3D application elements (structure, piping)

Definition of Generated geometry and dress-up properties
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Views Parameters

• • • • •

Front view Unfolded view View from 3D Isometric view Advanced front view

• • • • •

Projection view Auxiliary view Section view Section cut Detail view

• • • • • •

Hidden lines Center lines Axis lines Threads Fillets 3D colors

Properties defined via Tools -> Options -> Mechanical Design - Properties generated in the > Drafting -> View.

• • • •

3D specifications 3D points 3D wireframe Generation mode

Properties defined via Properties defined via Tools -> Options -> Mechanical Design - Tools -> Options -> Mecha Drafting -> View. > Drafting -> View.

Constraints
Constraints detected when views are generated from the 3D do not appear on the drawing.

2D/3D Associativity
... On Views

A generative view results from specifications in a 3D document. This specification corresponds eith document or to a feature in the document. This feature can be: 1. a .model document 2. a part document (the whole document or still one or more bodies) 3. a product document (the whole document or still one or more assemblies)
... And View Positioning

Generative views are positioned according to the center of gravity of the 3D part. If you modify a 3 a way that the center of gravity of the part changes, then, when updating the view, the position of be re-computed according to the new center of gravity of the part and will be modified accordingly

For more information on View Positioning properties, refer to the Generative Views Positioning Mod
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... And Update

Any modification applied to the specifications, before the generated view(s) is/are updated, is dete perform an update. You can update all views or a selection of views: •

is active in the Update toolbar when a sheet (or drawing) contains view The Update icon be updated (this can be all views in the sheet or some of them only). You can update all vie active sheet by clicking this icon.

•

appears in the specification tree for the views that need to be update An update symbol update a selection of views by selecting and right-clicking the view(s) you want to update a

Update Selection from the contextual menu. Only the items you select are Update symbols remain in the specification tree for the items that have not been updated, s know which items are up-to-date and which are not. •

•

Update symbols also appear in the specification tree to indicate drawings and sheets views that need to be updated. You can update all views in a given sheet (or in a selection o selecting and right-clicking the sheet(s) and then choosing Update Selection. You can also u method for a drawing: this will update all sheets (and therefore all views) in the drawing. During an update process, a dialog box is displayed to show the progress of the update. When the update involves several views, a Cancel button is available in this dialog box. This interrupt the update. The view that is being processed at the time you click this button will (i.e. the update of the current view will finish), and then the update will stop. The subseque not be updated.

... After Updating

Use the following commands to update views: • • Click the Update icon to update all views in the active sheet.

Select and right-click the views you want to update and choose Update Selection contextual menu to update a selection of views.

•

in the Power Input field to update the drawi Type C:Force Update accordance with the 3D. Be careful when doing this, as you may loose manual modifications drawing.

During view update, the following operations are performed: • • • •

associative section/auxiliary view profiles are re-computed the geometry is re-generated any annotation/dimension/dress up element linked to the generated geometry is re-comput in the case of elements (one or more) that have been graphically modified or deleted, these modifications/deletions are preserved, on the condition the view was up-to-date when you d modified it.
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•

Note that you can restore deleted elements at any time by selecting the Restore Deleted op contextual menu and then updating the view. You can either use the Update icon if you mod part, or key in C:Force Update if you did not modify the 3D part.

•

If you delete a generated item and subsequently perform an update, all items that have the origin as the deleted item will not be generated. Likewise, if you transfer a generated item t subsequently perform an update, all items that have the same 3D origin as the item in No S transferred to No Show.

... On Generated Dimensions

Generated dimensions are associative with the 3D part constraints on the condition you checked th dimensions when updating the sheet option from the Options dialog box (Tools -> Options -> Mech > Drafting -> Generation tab).

Note that these dimensions will be re-generated in accordance with the other options checked/un-c Options dialog box.
... And Color

When you refresh a generated view you have modified, the colors are re-generated with the geome information from the part, and you might obtain unexpected results. As an example, if you create this part...

...and then modify an element in the following generated view, such as the color of line "a" as in th

73

drawingGeneration

...then, when updating the generated view, lines a and b will be red:

The reason is that the view is refreshed with the part information and a and b lines are considered intersection of two planes and not as two different elements of the generative view.

Note that modifications performed on the graphical properties (color, line type, line thickness) of a geometrical element (as is the case in our example above) are associative, i.e. such modifications updating the view later on. Also note that once you have overloaded the original properties of an e cannot reset it to its original properties.
... And Operations Performed on Parts

Operations performed on parts, and that can be saved with the part itself (such as Show/No Show, Deactivate, Visualization Filters, etc.), are taken into account when generating the view.

For example, if you swap a part body to invisible space (No Show), this body will not be represente generated view. If you then swap this part body to visible space (Show), you can update the corres views; this time, the body will be represented on the generated view.
... And Part Infrastructure Settings

Settings used for a given part, and that only have an impact on the current session but cannot be s part itself (such as the Display in Geometry Area category of settings available via Tools > Options Infrastructure > Part Infrastructure > Display), have no impact on how or whether the part will be on the generated view.

3D Elements Generated in Views
3D elements are handled differently depending on their type and on the type of view you are gene
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Section cuts, section views, and breakout views

All CATPart elements, as well as Exact Solid and Skin elements from .model documents are suppor mode.
Projections, quick detail views, clipping views and broken views

Exact mode • • All CATPart elements are supported. Exact Solid and Skin elements from .model documents are supported.

CGR and raster mode • • • All CATPart elements except wireframe and 3D points are supported. All elements from .model documents are supported. External MultiCAD components are supported.

Dress-up generated in views

You can automatically create center lines, axis lines and threads according to the criteria described that this criteria also apply to isometric views.)

Center lines • • The view plane must be perpendicular to the rotation face axis. The representation of the rotation face in the view must exceed 180 degrees.

Axis lines • • The view plane must be parallel to the rotation face axis. Rotation faces made out of fillets are not taken into account when generating axis lines.

Threads (represented from the front and rear) • • • The view plane must be perpendicular to the rotation face axis. The face should be a threaded hole or a thread. The representation of the rotation face in the view must exceed 180 degrees.
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Threads will be represented from the front AND from the rear, whether or not the hole is threaded along its whole depth.

Threads (represented from the side) • • The view plane must be parallel to the rotation face axis. The face should be a threaded hole or a thread.

Callout Representation

You can specify that the size of callout elements should not be dependent on the view scale. You h of doing this: •

After callout creation, right-click on the callout, select Properties in the contextual menu and not dependent on view scale on the Callout tab.

or •

Before callout creation, in Tools -> Options -> Mechanical Design -> Drafting -> Layout tab, not dependent on view scale option. This option will apply to newly created callouts, i.e. sel option will not have any impact on existing callouts.

Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. ver V5 R10).

Warm Start and views

In Tools -> Options -> General -> General tab, you can specify that you want a backup to be autom performed on your data, which would allow you to recover your data (partially or entirely) should t crash. If you selected the Incremental backup option (which stores all open documents in a temporary di modifications to the document are logged in a log file), Generative Drafting views may be restored after a crash. However, you need to be aware of the following facts: • •

When recovering a drawing after a crash, all views which need to be restored in the drawing automatically updated. For this reason, the drawing will contain up-to-date views, even tho necessarily the case prior to the crash. Due to this automatic update operation, any view which was locked prior to the crash and w be restored will be empty after the restore operation (remember that locking a view means cannot update it).
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View Basics
Defining the Drawing Sheet
This task shows you how to define the drawing sheet that will be used for creating the views described in the next tasks. 1. Select File -> New... from the menu bar, or click the New icon toolbar. from the Standard

The New dialog box is displayed. 2. Select Drawing from the List of Types, and click OK. 3. From the New Drawing dialog box, select the ISO standard, and the A0 ISO format.

We will use the ISO standard for the purpose of this tutorial, as well as all along the guide. You can add an unlimited number of customized standards using Standard files that you will create and/or, if needed, modify. Once created, this standard will appear in the New Drawing dialog box. For more details on standards and particularly generative view styles, see the Standards Administration section in this guide. For more details on standard, standard parameters and styles, see the Standards Administration section in the Interactive Drafting User's Guide. Care that any userdefined standard is based on one of the four international standards (ANSI, ISO,
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ASME or JIS) as far as basic parameters are concerned. 4. Click OK. 5. In the Generative Drafting workbench, a grid is set by default. For the purpose of this tutorial, you will not use the grid. To hide it, de-activate the Grid icon Tools toolbar (bottom right). The drawing sheet appears as shown here: from the

From now on, you will work on the created sheet. You can now either learn how to create part drawings or assembly drawings. Note that you can define a new, additional sheet at any time.

Part Drawing
Part Drawing

In this first section of the Getting Started tutorial, you will learn how to generate various types of views from a part, on the drawing sheet you previously defined. You can also go directly to the second section of the tutorial and learn about assembly drawings.
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 Link Bar 1

At the end of this tutorial, you will be able to print the following sheet:

Opening a Part

This task will show you how to open the 3D part from which you will create views in the Generative Drafting workbench. Note that you may create views from both 3D parts and assemblies. Refer to the Assembly Drawing section of this tutorial for information on how to use assemblies. 1. Select File ->Open... from the menu bar, or click the Open icon Standard toolbar. from the

The File Selection dialog box appears. 2. Select the part to be opened, the GenDrafting_part.CATPart document. Note that this sample documents is to be found in the C: Files Dassault Program
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Systemes Bxxdoc English online cfysa samples Drafting folder (where xx in Bxxdoc stands for the current release number). 3. Click Open. The part is opened and a message appears, informing you that it is read-only. Simply close it. The part will remain displayed in the window, whatever views you create from it.

Creating a Front View

This task will show you how to create a front view on the sheet you defined, from the 3D part you opened. At this step, it will be more convenient if you tile the drawing and the part windows horizontally. To do this, click Window -> Tile Horizontally from the menu bar. In the Generative Drafting workbench, the view name, scaling factor and view frame are set by default in views. Throughout this section of the Getting Started, we decided not to display view names and scaling factors. To deactivate them, go to Tools -> Options -> Mechanical Design -> Drafting, click 80

User Tasks on the Layout tab and un-check the View name and Scaling factor options. You can also specify what geometrical and dress-up elements should be generated on views, such as axes, center lines, fillets, 3D points, etc. Still in Tools -> Options -> Mechanical Design -> Drafting, click on the View tab and choose your options in Geometry generation / Dress-up. For example, check Generate center lines, and un-check Generate fillet. If you do not want to have the specification tree displayed, press the F3 key. 1. Click the drawing window to activate it. 2. Click the Front View icon toolbar). from the Views toolbar (Projections sub-

3. Now, in the part window, select the desired planar surface of the 3D part.

On the sheet, a blue knob appears, as well as a green frame containing a preview of the view to be created. The knob lets you define the location and orientation of the view to be created, using the blue manipulators: top, bottom, left, right or rotated according to a given snapping, or according to a specified rotation angle. 4. Click on the drawing sheet or at the center of the blue knob to generate the view.
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A progress bar appears temporarily, showing the view creation progress. The front view is created.

Creating a Projection View

This task will show you how to create projection views on the sheet.

1. Click the Projection View icon sub-toolbar).

from the Views toolbar (Projections
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A preview of the view to be created appears. By default, the projection view is aligned to the front view. As you move the cursor, a preview of the view to be created appears, as long as you keep the cursor positioned at a possible projection view location (at the left, right, top or bottom of the red frame).

2. Define the projection view position, for example the right view position, using the cursor.

Note that the left view shown here was created and therefore positioned according to ISO standards and the First Angle Projection method. For more information, refer to Creating Views via the Wizard. 3. Click to generate the view. A progress bar appears while the view is being created.
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4. Click the Projection View icon

once again.

5. Use the cursor to define the projection view position, for example the bottom view position, and click to generate the view. Once again, a progress bar appears during the view creation process. The views result as shown here.

Creating a Section View

This task will show you how to create a section view using the front view you previously generated. Section views make drawings more readable by replacing the hidden elements of parts, including holes, with filled areas. To perform this scenario, it is recommended that you tile the drawing and the part windows horizontally.
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1. In the drawing window, click the Offset Section View icon Views toolbar (Sections sub-toolbar).

from the

2. Select the holes and points to define the cutting profile on the view. SmartPick assists you when creating the profile. Note that selecting a circular edge, a linear edge, an axis line or a center line (for example, a hole) makes the view callout associative by default to the corresponding 3D feature. If you select a circle, the callout will go through the circle center. If you select an edge, the callout will be parallel to the selected edge.

If you are not satisfied with the profile you create, you can, at any time, use the Undo or Redo icons.

As you select the second point, the section plane appears and moves dynamically on the 3D part while you define the profile on the drawing. This section plane will automatically disappear when you double-click to end the callout definition.
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3. Double-click to end the cutting profile creation. A preview is displayed. 4. Define the section view position using the cursor. Positioning the view also defines the section view direction, as if it were a left or a right projection view. The direction of the callout blue arrows changes as you change the cursor position.

87

drawingGeneration

5. Click to generate the view. A progress bar appears while the view is being created. Using the cursor, you can then position the section view in order to align it, or to not align it, to the front view.

• •

The patterns which are used to represent sections are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide. You may modify the pattern (hatching, dotting, coloring or motif). For more information, refer to Modifying a Pattern.

Creating a Detail View

This task will show you how to create a detail view from the front view you previously generated.
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1. Click the Detail View icon toolbar).

from the Views toolbar (Details sub-

2. Click where you want to position the callout center. 3. Drag the cursor to define the callout radius, and click when you are satisfied.

A dashed, blue circle appears at the position of the cursor. 4. Move this circle to where you want to position the detail view, and click to generate the view.

A progress bar appears while the view is being created. 5. If you are not satisfied with the position of the detail view, you can drag it to a new position.
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Simply drop it to its new position.

90

User Tasks

As in step 4, the scale is, by default, twice that of the active view. You can modify this scale. 6. To do so, right-click the detail view, select Properties from the contextual menu and then click the View tab. 7. Enter 4 in the Scale field and click OK.

For the purpose of this exercise, you will now add a dimension to the detail view. 8. To do so, click the Dimension icon from the Dimensioning toolbar.

9. Click two elements in the view, as shown here.
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The dimension is created. Move your cursor to where you want to position the dimension, and click to generate the dimension. If you are not satisfied with the position of the dimension, you can drag and drop it to a new position.

Creating a Section Cut

92

User Tasks This task will show you how to create a section cut from the detail view you just created. The scale of the section cut will depend on the scale of the view this section cut is generated from. In this case, the section cut is generated from a detail view with a scale 4, so the section cut scale will also be 4. 1. Right-click the detail view and select the Activate View option from the contextual menu. 2. Click the Aligned Section Cut icon sub-toolbar). from the Views toolbar (Sections

3. Select the holes and points to define the cutting profile.

Note that selecting a circular edge, a linear edge, an axis line or a center line (for example, a hole) makes the cutting profile associative by default to the 3D feature. If you select a circle, the profile will go through the circle center. If you select an edge, the profile will be parallel to the selected edge.
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Also note that SmartPick assists you when creating the profile. For more information, refer to Using SmartPick.

If you are not satisfied with the profile you create, you can, at any time, use the Undo or Redo icons.

4. Double-click to end the cutting profile creation. A preview of the view to be created appears. Positioning the section cut either to the right or to the left defines the section cut direction (as if it were a projection view). 5. Click to generate the section cut. A progress bar appears while the view is being created.
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•

•

•

Once the section cut has been generated, you can modify its position relatively to the detail view: right-click the section cut and select View Positioning -> Position Independently of Reference View from the contextual menu. Selecting an existing edge within the view lets you define automatically the direction of the cutting profile. You can also select a reference plane in 3D or a 3D wireframe plane. For more information, refer to Creating an Offset Section Cut/Section View. The patterns which are used to represent the section cut are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide.

For the purpose of this tutorial, you will now add a dimension to the section cut. 6. To add a diameter dimension to the section cut, click the Dimension icon and click one edge only.
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In our example, a larger font size has been applied to the dimension value. The resulting sheet now appears similar to what is shown here. Note that in this case, we re-positioned the views.

7. You can now print this sheet. To do so, select File -> Print from the menu bar. Make sure the print format you set when defining the sheet is the same as the print format of the printer. You have reached the end of the first section of this tutorial. Now that you have learned about part drawings, you can go to the second section of this tutorial and learn about assembly drawings. 96
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Assembly Drawing
Assembly Drawing

In this second section of the Getting Started tutorial, you will learn how to generate views from an assembly, on the drawing sheet you previously defined. Additionally, you will learn how to use other generative functionalities. You can also go back to the first section of the tutorial and learn about part drawings.
 Link Bar 2

At the end of this tutorial, you will be able to print the following sheet:

Opening an Assembly

This task will show you how to open the 3D assembly from which you will create views in the Generative Drafting workbench, as well as perform other operations. Note that you may create views from both 3D assemblies and parts. Refer to the Part Drawing section of this tutorial for information on how to use parts. 1. Select File -> Open... from the menu bar, or click the Open icon from the
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Standard toolbar.

The File Selection dialog box appears. 2. Select the assembly to be opened, the GEAR-REDUCER_GS.CATProduct document. Note that this sample documents is to be found in the C: Files\Dassault \Program \Drafti

Systemes\ Bxxdoc\ English\ online\ cfysm_C2\samples ng folder (where xx in Bxxdoc stands for the current release number).

3. Click Open. The assembly is opened and a message appears, informing you that it is read-only. Simply close it. The assembly will remain displayed in the window, whatever views you create from it.

Creating a Frame and a Title Block
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User Tasks This task will show you how to insert a frame and a title block in the background of the sheet you defined. If you do not want to have the specification tree displayed, press the F3 key. 1. Click the drawing window to activate it. 2. Select Edit -> Background from the menu bar to switch to the background. 3. Click the Frame Creation icon from the Drawing toolbar.

The Insert Frame and Title Block dialog box is displayed:

4. Choose a style from the Style of Titleblock drop-down list. For the purpose of this exercise, choose Drawing_Titleblock_Sample1. You can notice that a preview of the frame and title block is displayed in the dialog box. 5. Click the action you want to perform from the list of actions; in this case, click Creation. 6. Click OK. Wait while the frame and title block are being created.
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7. Select Edit -> Working Views from the menu bar to switch back to the working views.

Creating Views via the Wizard

This task will show you how to create a number of views on the sheet you defined, from the 3D assembly you opened. At this step, it will be more convenient if you tile the drawing and the assembly windows horizontally. To do this, click Window -> Tile Horizontally from the menu bar. If you performed the Part Drawing section of the Getting Started, you deactivated the view name and scaling factor (they are set by default). You now need to reactivate them so that they are displayed in views. To do this, go to Tools -> Options -> Mechanical Design -> Drafting, click on the Layout tab and check the View name and Scaling factor options. Also, you need to specify what geometrical and dress-up elements should be generated on views. Still in Tools -> Options -> Mechanical Design -> Drafting, click on the View tab. Make sure Generate center lines is selected (it should be if you performed the Part Drawing section of the Getting Started) and check Generate axis. 1. Click the View Creation Wizard icon sub-toolbar). from the Views toolbar (Wizard

100

User Tasks

The View Wizard (1/2): Predefined Configurations dialog box is displayed.

2. Select the Configuration 3 using the 1st angle projection method icon to create a front, a top and a left view using the ISO standard/first angle projection method. 3. Click Next > to go to the second step of the wizard. The View Wizard (2/2): Arranging the Configuration dialog box is now displayed with a new set of view buttons. 4. Simply click Finish to validate and exit the dialog box. For more in-depth information on projection methods and the various possibilities offered by the wizard, refer to Creating Views via the Wizard in the User Tasks chapter. 5. Now, in the assembly window, select the Slow Speed sub-assembly from the specification tree. Note that you can also select the whole assembly.
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6. Then, click on the desired plane on the 3D assembly to define the reference plane.

On the sheet, a blue knob appears, as well as three green frames containing a preview of the views to be created. The knob lets you define the location and orientation of the views to be created, using the blue manipulators: top, bottom, left, right or rotated according to a given snapping, or according to a specified rotation angle. 7. Click on the drawing sheet or at the center of the blue knob to generate the views. A progress bar appears temporarily, showing the view creation progress. The front, top and left views of the selected sub-assembly are created.
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You may need to move the views to position them properly on the drawing. To do this, simply drag the front view (i.e. the active view with a red frame) with the cursor and drop it when you are satisfied with the position of the views.

Creating a Section View

This task will show you how to create a section view using a view you previously generated. Section views make drawings more readable by replacing the hidden elements of parts, including holes, with filled areas. 1. Double-click the view from which you want to create the section view, to activate it. In this particular case, double-click the left view. 2. In the drawing window, click the Offset Section View icon (Sections sub-toolbar). from the Views toolbar

3. Select the axis line in the left view. Note that selecting this axis line makes the view callout associative by default to the corresponding 3D feature.

103

drawingGeneration

The first point of the cutting profile is automatically created on the view. The section plane appears and moves dynamically on the 3D sub-assembly while you define the profile on the drawing.

4. Double-click the last point of the cutting profile to end its creation.

The section plane automatically disappears, and a preview is displayed. 5. Define the section view position using the cursor. Positioning the view also defines the section view direction, as if it were a left or a right projection view. The direction of the callout blue arrows changes as you change the cursor position. 6. Click to generate the view. A progress bar appears while the view is being created.
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•

•

In our example, the various parts use a material to which a specific pattern is associated. In this case, it is the pattern associated to this material which is used. For more information, refer to View Generation Definition in the Interactive Drafting User's Guide. You may modify the pattern (hatching, dotting, coloring or motif). For more information, refer to Modifying a Pattern.

Overloading Element Properties

This task will show you how to overload the properties of elements in the section view you created previously. A number of the properties that you can overload are originally defined as properties of the 3D product component in the Product Structure workbench. 1. Right-click the section view A-A. 2. In the contextual menu, select Section view A-A object -> Overload properties. The Characteristics dialog box is displayed. Select the elements (part instances) that you want to edit, in this case, the slow speed shaft and the two bearings.
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These elements are highlighted as you select them in the drawing, and listed in the dialog box.

3. In the dialog box, select Slow speed shaft as the first element to edit, and click the Edit button. The Editor dialog box is displayed.

4. Uncheck Cut in section views to specify that the 3D element should not be cut in the section view. 5. Click OK to validate and exit the dialog box. 6. Back in the Characteristics dialog box, select the two bearings elements to edit them simultaneously, and click the Edit button. 7. In the Editor dialog box, choose another color in the appropriate box of the Graphic Properties area.
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8. Click OK to validate and exit the dialog box. In the Characteristics dialog box, you can notice that the listed characteristics have been updated for each element.

9. Click OK again. A dialog box is displayed while the view is being re-computed. The selected elements are updated in the view: the slow speed shaft is not cut anymore, and the bearings are displayed with a different color.

For more in-depth information on overloading properties, refer to Overloading Element Properties in the User Tasks chapter.

Generating Balloons and a Bill of Material

This task will show you how to do the following:
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• •

generate balloons in the active view. Balloons correspond to references defined on the different components of an assembly. insert a Bill of Material into the active view. The Bill of Material provides information on the product element from which the view was generated.

The left view, in which you will generate the balloons and the Bill of Material, should still be active from the previous task. If not, double-click it to activate it. Generating Balloons Note that the assembly components have previously been numbered in the Product Structure workbench using the Generate Numbering 1. Select the Generate Balloons icon command.

on the Dimension Generation toolbar.

The balloons are automatically generated onto the active view.

Generating a Bill of Material For more in-depth information on Bills of Material, refer to Generating a Bill of Material in the User Tasks chapter. 2. Select Insert -> Generation -> Bill of Material. 3. Click on the drawing sheet to specify where the Bill of Material should be inserted. In this particular case, click at the bottom right of the left view. The Bill of Material is created.
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You can zoom the drawing to take a closer look at the balloons and/or the Bill of Material.

Standard Views
Creating a Front View
This task will show you how to create a front view either from a part or from the sub-part of a product. You will use a reference plane. You will also learn how to create a front view with local axis system, and how to create a front view from specific sub-bodies/sub-products.

109

drawingGeneration

A front view is a projection view obtained by drawing perpendiculars from all points on the edges of the part to the plane of projection. The plane of projection upon which the front view is projected is called the frontal plane.

Creating a front view

Open the GenDrafting_part.CATPart document. Define a new drawing sheet. 1. Click the Front View icon from the Views toolbar.

2. Select one plane of the 3D part or a plane surface, to define the reference plane. Blue arrows appear.

If you select a plane surface, the reference orientation will be the external normal of the planar surface. To define the reference plane, you can also select: • • Two edges: these edges correspond to both axes defining the reference plane according to which the front view will be generated. The first edge determines the horizontal axis. A point and an edge, or three points: you will thus define a plane.

In other words, you will select, in the geometry, one of the followings: • • • • • • a plane a point and then an edge an edge and then a point two edges two points and then an edge three points
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Note that you can redefine the projection plane using the arrows at any time before the view generation. 3. Click inside the sheet to generate the view.

Right-click the frame of the view, select the Properties option from the contextual menu, View tab and check the required options in the Properties dialog box. By default, the axis and center lines are generated. You can also view hidden lines, threads, fillets, project 3D points, etc.

• •

In the case of an assembly view, you can insert Bill of Material information into the active view. In a Product Structure context, if you create a front view from a scene of a product, you can directly select the Scene object in the specification tree. You do not necessarily need to select the Product and sub-products any more.

Creating a front view with a local axis system

This functionality allows you to take into account a local axis system when creating a view. That way, the origin of the generated view is the projection of the origin of the local axis system selected in the view plane.
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Open the Axisprojection.CATPart document. Define a new drawing sheet. 1. Select the drawing to activate it and click the Front View icon Views toolbar. 2. In the Part tree, select the local axis system, i.e. Axis System.1. Remember that you have to select the axis sytem in the specification tree and not in the 3D part. Otherwise it would be like selecting a line in the 3D part instead of the axis system. 3. Select one plane of the 3D part or a plane surface, to define the reference plane. from the

4. Click in the drawing to end the view creation. The part local axis system
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appears in the view.

When creating views with a local axis system, only the origin of the axis system is taken into account and respected in the generated view. The orientation is not taken into account.

Create a front view from specific sub-bodies/sub-products

You can multi-select specific sub-products in a product and/or several subbodies in a part to create front views displaying the selected elements only. These multi-selected 3D elements will be previewed and then used as reference planes for generating several front views. Open the Product_Balloon.CATProduct document. Double-click Scene1 at the down left of the screen. 1. Click the Front View icon from the Views toolbar.

2. Select one body or press the Ctrl key and then multi-select the desired elements in the specification tree.
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3. In the 3D, point to the geometry to choose a projection plane. As you go over the geometry with the cursor, the oriented preview automatically appears on the 3D document.
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Be careful: once you multi-select bodies or sub-products, and go further into the procedure, you cannot select or de-select any more bodies or subproducts. • • • As you highlight a 3D element (going over it with the cursor), you can preview and then select the plane corresponding to this highlighted element. As you highlight and select one or more elements defining the final plane, you can preview and assign a given orientation to this final plane. Once you defined the plane, you can preview the front view within the 3D document.

Note that once an element is selected, this element becomes gray colored. In addition, you can only work in one 3D document. If you try selecting another document, you automatically leave the Front View command.

4. When the oriented preview corresponds to the projection plane you want, click on the plane to validate. The front view is previewed. At this point, you can still modify its orientation:
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5. Click on the drawing to generate the view.

Creating a front view using selection sets

You can also use selection sets to select the sub-bodies and/or sub-products from which you want to generate the front view. Selection sets let you gain in productivity, particularly in the case of large assemblies, when generating several views with numerous common features: you can select and store these features once and reuse the selection set as
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often as necessary without having to select the features again.

Open the Product_Balloon.CATProduct document.

1. Before you start creating views from selection sets, you first need to create one or more selection sets for this product. For more information, refer to Storing Selections Using Selection in the Infrastructure User's Guide. For example, create a selection set to store the product screws. 2. Click the Front View icon from the Views toolbar.

3. Activate the CATProduct document and select Edit -> Selection Sets... 4. In the Selection Sets Selection dialog box that is displayed, select a selection set and click the Select button. The selection set items are highlighted in the 3D and in the specification tree. For more information, refer to Selecting Selection Sets in the Infrastructure User's Guide.

Once you have selected a selection set, you can use the Ctrl key to select additional sub-bodies or sub-products.

5. In the 3D, point to the geometry to choose a projection plane. As you go over the geometry with the cursor, the oriented preview automatically appears on the 3D document.
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6. When the oriented preview corresponds to the projection plane you want, click on the plane to validate. The front view is previewed. At this point, you can still modify its orientation:

7. Click on the drawing to generate the view.
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• •

You can also use selection sets when creating isometric views and advanced front views. Views created from selection sets are not associative with the selection sets themselves: if you modify a selection set after having created a view from it, the view will not be seen as needing an update, and if you do update the view, its definition will not change. You have to create the view over again in order for your modifications to be taken into account.

Creating an Advanced Front View

This task will show you how to create an advanced front view. Creating advanced front views lets you configure such elements as the view name, view scale, etc. Whenever possible, a pertinent projection plane is automatically offered. For more information on front views in general, refer to Creating Front Views. Open the Pinmounting.CATPart document. Define a new drawing sheet. Activate the drawing by selecting the drawing window.
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1. Click the Advanced Front View

icon. A dialog box appears:

2. Name the view in the associated field:

3. Modify the scale value in 1:2

4. Click OK to validate your settings. 5. Select one plane of the 3D part or a plane surface, to define the reference plane.
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Blue arrows appear, you can still choose a plane and an orientation before view generation. 6. Click inside the sheet to generate the view.

The DMU Space Analysis workbench lets you create section boxes in 3D. When generating advanced views from the DMU Space Analysis workbench, you can select this section box to generate a view displaying only the box content. If you then modify the section box in 3D, the view will be shown as needing an update in the drawing. If you destroy the section box in 3D, the box definition will remain in the drawing. For more information on section boxes, refer to Creating Section Boxes in the DMU Space Analysis User's Guide.

You can use selection sets to generate advanced front views displaying a selection of elements only. Selection sets let you select the sub-bodies and/or sub-products from which the view will be generated. Refer to Creating a front view using selection sets for more information.

Creating a Projection View
This task will show you how to create projection views on the sheet, relatively to the front view previously generated. Projection views are views conceived to be drawn or projected onto planes known as planes of projection. A transparent plane or pane of glass representing a plane of projection is located parallel to the front surfaces of the part.

Open the GenDrafting_front_view.CATDrawing document.

1. Click the Drawing window, and double-click the Projection View icon from the Views toolbar (Projections sub-toolbar).
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As you move the cursor, a previewed projection view in a green frame appears on the sheet. 2. Define the projection view position by positioning the cursor at the desired view location, for example the right view position. 3. Click inside the green frame to generate the view.

Note that the right view above was created and therefore positioned according to the first projection method. Projection methods are described in Creating Views via the Wizard. 4. Define the bottom view position. 5. Click inside the sheet to generate the view.
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6. Click on the Projection view icon to end the projection view creation. To have information about generated geometry and dress-up properties, refer to Definition of Generated geometry and dress-up properties section.

Creating an Unfolded View
This task shows how to create an unfolded view from a sheet metal part. An unfolded view is a projected view that is created from a sheet metal part in order to include in a section certain angled elements. As a result, the cutting plane may be bent so as to pass through those features. In other words, you will extract drawings from the SheetMetal Design or the Generative Sheetmetal Design workbench or the Aerospace SheetMetal Design workbench. For more information, refer to the appropriate user's guide. The Unfolded View command is active in the Generative Drafting workbench with a Version 5 SheetMetal Design, Generative Sheetmetal Design or Aerospace SheetMetal Design license.

Open the GenDrafting_sheet_metal.CATPart document. Tile the windows horizontally to see both your drawing sheet and your sheet metal part at the same time.

1. From the Drafting workbench, click the Unfolded View icon

from the
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Views toolbar (Projections sub-toolbar).

2. Select a surface on the part. This will automatically use the sheet metal reference wall plane. If you prefer to specify which plane should be used, select the plane in the Sheet Metal specification tree. 3. Click on the sheet. The unfolded view is displayed. It shows the axis lines resulting from bend axes, as well as bend limits. These axis lines and bend limits are represented as dashed lines. With sheet metal parts containing holes, the hole axes (center line) are also represented on the view.

The unfolded view looks like this:
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4. Select one of the axis lines. Manipulators appear, allowing you to modify this line.
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Creating a Clipping View / Clipping View Profile
This task will show you how to create a clipping view using a circle as callout. You can also use a roughly sketched profile. A clipping view is a partial view that shows only what is necessary in the clear description of the object. This operation is applied directly onto the active view.

Open the GenDrafting_clipping_view.CATDrawing document.

1. Click the Drawing window, and click the from the Views Clipping View icon toolbar (Clippings sub-toolbar). If you create a clipping view using a sketched profile, you will select the Clipping View Profile icon .

2. Select the center of the circle, or select the required points for sketching a polygon if you are creating a clipping view using a sketched profile.

3. To end the clipping profile creation, release the mouse in the case of a circle, or double-click in the case of a polygon.
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When Put in Now show dimension on non-visible geometry is activated in Tools->Options, the generated dimensions that are not in the clipping view and the annotations that are not linked to the generated clipping view anymore are automatically turned into the NoShow mode. For this go to Tools -> Options -> Mechanical Design -> Drafting -> View and check the Put in Now show dimension on non-visible geometry option in the Clipping view section. If it is not activated, the dimension is displayed in the generated clipping view in light blue. A generative dimension does not turn into light blue. For more information, refer to the Dimension on geometry without 2D representation section in the Interactive Drafting User's Guide. 4. Click the Swap visible space icon from the View toolbar.

You can now visualize the dimensions and annotations that do not appear on the clipping view anymore and, if needed, make them appear again on the clipping view.
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5.

Click the Hide/Show icon

from the View toolbar.

6. Select the dimension you want to display on the clipping view.

7.

Click the Swap visible space icon

from the View toolbar.

The selected dimension now appears on the clipping view again.

• •

You can insert Bill of Material information into the active view. Once a clipping has been applied onto a view, it is impossible to create detail views, breakout views and broken views from this view.

Creating an Isometric View
This task will show you how to create an isometric view from a 3D part.
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The Isometric View command enables you to create a 2D view with any orientation, this orientation being the same as the one in the 3D viewer. Among other results, and depending on how the 3D viewer is oriented when you create the view, you can obtain a regular X-Y-Z isometric view. Isometric means "equal measure". To produce an isometric projection, it is necessary to place the object so that its principal edges make equal angles with the plane of projection and are therefore foreshortened equally. Note that an isometric view created from a product can be re-used for generating an exploded view.

Open the GenDrafting_part_02.CATPart document. Start creating a new drawing (and this case, create an empty sheet). Tile your windows vertically to visualize the 3D part and the sheet at the same time.

In a Product Structure context, if you create a front view from a scene of a product, you can directly select the Scene object in the specification tree. You do not necessarily need to select the Product and subproducts.

Scenes of products created with versions prior to V5R14 will be displayed as shown above. For any scene of products created in V5R14, the specification tree is updated as follows:

1. Click the Drawing window, and click the Isometric View icon the Views toolbar (Projections sub-toolbar).

from
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2. Define the 3D viewer orientation according to the result you want to obtain in the view. For this, you can either manipulate the viewer directly, or use the View > Named Views command in 3D to define your orientation precisely. Prior to defining your orientation, it may be useful to use different canonical points of view by defining the corresponding local axis systems in 3D. For more information, refer to Axis System in the Part Design User's Guide.

3. Click the 3D part. A green frame with the preview of the isometric view to be created, as well as blue manipulators, appear. You can re-define the reference plane orientation of the view to be created using these manipulators: to the bottom, the left, the right, the top, or rotated using a given snapping or according to an edited rotation angle. For more information, refer to Before you begin.

4. Click on the sheet to generate the view. You can use selection sets to generate isometric views displaying a selection of elements only. Selection sets let you select the sub-bodies and/or sub-products from which the view will be generated. Refer to Creating a front view using selection sets for more information.

Creating an Exploded View
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This task will show you how to create an isometric view, and then, projected views from an assem previously exploded via Digital Mock-up workbench (DMU Navigator).

Open Gun_Body.CATProduct.

1. Go to the Digital Mock-up workbench (DMU Navigator) and define the Scene with the adeq orientation and with the instances properly positioned.

Scenes of products created with versions prior to V5R14 will be displayed as shown above. For any scene of products created in V5R14, the specification tree is updated as follows:

2. Explode the view as shown here:
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3. Go to the Drafting workbench and click the Isometric View icon (Projections sub-toolbar).

from the Views toolbar

4. Select the scene (Scene 1) either in the specification tree or in the geometry area, and the select a plane on the product. 5. Click in the drawing to position the resulting exploded view. Non exploded product: Exploded product:
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You can insert Bill of Material information into the active view.

Remember that you must select the scene before creating a view, otherwise you will create a view the whole assembly.

Projection Views and Section Views/Cuts
Creating an Offset Section View / Cut

This task will show you how to create an offset section view/cut using a cutting profile as cuttin plane. In sectioning through irregular objects, it is often desirable to show several features that do not lie in a straight line by offsetting or bending the cutting plane.

Open the Gun_Body.CATProduct and the GenDrafting_section_view02.CATDrawing documents. Make sure the front view is active (use double-clicking). Delete the text assigned to the front view (right-click on the text and select Delete option from the contextual menu).

1.

Click the Drawing window, and click the Offset Section View icon icon from the Views toolbar (Sections sub-toolbar).

or the Offset Section Cut
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2. Select the elements required for sketching the cutting profile: points, edges (linear or circular), center lines, axes. If you are not satisfied with the profile you create, you can, at any time, use Undo icons. Note that SmartPick assists you when creating this profile. The section plane appears on the 3D part and moves dynamically on the part. Associativity between the 3D part and the generated section view is created when selecting edges, center lines and axes. Yet, constraints detected by SmartPick are not created. 3. Double-click to end the cutting profile creation. Offset section view Positioning the section view using the cursor amounts to defining the section view direction. Th cutting profile is hole associative.

or Redo

4. Click to define the section view direction and to position the view on the sheet. The view name and scale appear on the generated view if you checked the View name and
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Scaling factor options in the Options dialog box, available via Tools -> Options -> Mechanical Design -> Drafting -> Layout.

Even when the view is generated, you can edit and modify the section profile. For this double-c this profile and either invert or replace it.

Offset Section Cut Positioning the section cut using the cursor amounts to defining the section cut direction. The cutting profile is hole associative. For the purpose of this scenario, select a circular edge and double-click when you are satisfied with the position of the rotating profile that automatically appears on the 3D view.
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5. Click to define the section cut direction and to position the view on the sheet.
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The view name and scale appear on the generated view as you checked the View name and Scaling factor options in the Options dialog box.

• • •

The frame of the active view adapts to the length of the cutting profile. You can insert Bill of Material information into the active view. You can assign a line type to the view to be generated. For this, go to Tools -> Options Mechanical Design -> Drafting -> View tab, click the Configure button next to View Linetype and select the desired option from the dialog box.

About Patterns The patterns which are used to represent the section are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide.

You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern a selecting Properties from the contextual menu. This will display the Properties dialog box in wh you may either select a new pattern or modify some graphical attributes of the existing pattern For more information, refer to Modifying a Pattern. Patterns will not be applied to offset sections which are tangent to 3D faces.

For information about generated geometry and dress-up properties, refer to Definition of Generated geometry and dress-up properties section. About the Cut in section views capability

In an assembly, you can define that given parts will or will not be sectioned when generated int section views. (This capability is not available for section cuts.)

In the Assembly Design workbench, select one part, then the Edit -> Properties command from the menu bar from and either activate or de-activate the Cut in section views option. You can a do this when overloading element properties in a view generated from a CATProduct.

If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that if the cutting profile intersects an uncut part, then this part will not be cut an will be entirely projected. About section views or section cuts generated using the Approximate generation mode

You can now generate section views or section cuts using the Approximate generation mode. Fo more information on the approximate generation mode, refer to Customizing Settings: View.

When generating section views or section cuts using the Approximate generation mode, or whe switching a section view/cut from exact mode to approximate mode (i.e. via Edit > Properties), aware of the following information:
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Patterns

In the case of parts which use a material to which a specific pattern is associated, section views/cuts in Approximate mode do not inherit the material properties from the 3D, and therefo do not use the pattern associated to this material. Pattern properties are not persistent: for instance, after switching an exact view to the approximate mode, and vice versa, the pattern may change. The Cut in section views capability

If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that this capability does not work for section views generated using the Approxim generation mode: selected elements will be cut nonetheless. Likewise, if you switch an exact vi to the approximate mode, the elements for which you unselected the Cut in section views optio will be cut in the view nonetheless.

Creating a Section View / Cut (Planar Surface)
This task will show you how to create a section view / section cut using a planar surface or a wireframe plane in the 3D. A section view / section cut is a view that allows sectioning through irregular objects, and thereby allows showing several features that do not lie in a straight line by offsetting or bending the cutting plane.

Open the GenDrafting_part.CATPart and the GenDrafting_front_view.CATDrawing documents. Make sure the front view is active on the drawing (double-click to activate it). Tile your windows vertically to see both your part and the related drawing.

1. Click the Drawing window, and click the Offset Section View icon or the Offset Section
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Cut icon from the Views toolbar (Sections subtoolbar). 2. Select a planar surface on the 3D part. This planar surface need to be perpendic ular to the projection plane of the active view. The section plane appears on the 3D part and moves dynamicall y on the part. The cutting profile is automatic ally displayed on the front view as well as a preview of the view to be generated .
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3. Click to generate the view.

About Patterns The patterns which are used to represent the section are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide. You may modify the pattern (hatching, dotting, coloring or motif) by rightclicking the pattern and selecting Properties from the contextual menu. This will display the Properties dialog box in which you may either select a new pattern or modify some graphical attributes of the existing pattern. For more information, refer to Modifying a Pattern. About the Cut in section views capability In an assembly, you can define that given parts will or will not be sectioned when generated into section views. (This capability is not available for section cuts.) In the Assembly Design workbench, select one part, then the Edit -> Properties command from the menu bar from and either activate or de-activate the Cut in section views option. You can also do this when overloading element properties in a view generated from a CATProduct. If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that if the cutting profile intersects an uncut part, then this part will not be cut and will be entirely projected. About section views or section cuts generated using the Approximate generation mode You can now generate section views or section cuts using the Approximate generation mode. For more information on the approximate generation mode, refer to Customizing Settings: View. When generating section views or section cuts using the Approximate 140
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generation mode, or when switching a section view/cut from exact mode to approximate mode (i.e. via Edit > Properties), be aware of the following information: Patterns In the case of parts which use a material to which a specific pattern is associated, section views/cuts in Approximate mode do not inherit the material properties from the 3D, and therefore do not use the pattern associated to this material. Pattern properties are not persistent: for instance, after switching an exact view to the approximate mode, and vice versa, the pattern may change. The Cut in section views capability If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that this capability does not work for section views generated using the Approximate generation mode: selected elements will be cut nonetheless. Likewise, if you switch an exact view to the approximate mode, the elements for which you unselected the Cut in section views option will be cut in the view nonetheless. About planar faces belonging to the section profile When a planar face belongs to the section profile, you may get unexpected results (i.e. the section edge may or may not be displayed, and the section may or may not be represented by a pattern). Indeed, as the cutting profile can be considered as being either inside or outside the part, the result largely
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depends on computing tolerances. Consequently, when defining the section profile, we advise that you avoid getting into such a geometrical configuration. The example here shows what kind of results you may get for a given section:

Creating an Aligned Section View / Cut
This task will show you how to create an aligned section view and/or aligned section cut using a cutting profile as cutting plane. An aligned section view / cut is a view created from a cutting profile defined from non parallel planes. In order to include in a section certain angled elements, the cutting plane may be bent so as to pass through those features. The plane and feature are then imagined to be revolved into the original plane.

Open the GenDrafting_aligned_view02.CATDrawing document.

1. Click the Drawing window, and click the Aligned Section Cut .

If desired, you can also click the Aligned icon from the Views Section View toolbar (Sections sub-toolbar).

2. Select the elements required for sketching the cutting profile: points, edges (linear or circular), center lines, the axis. If you are not satisfied with the profile you create, you can, at any time, use Undo or Redo icons. Note that SmartPick assists you when creating
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this profile.

The section plane also appears on the 3D part and moves dynamically on the part.

3. Double-click to end the cutting profile creation.

Positioning the section view amounts to defining the section cut direction. The cutting profile is hole associative.

4. Click to generate the view.
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About Patterns The patterns which are used to represent the section are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide. You may modify the pattern (hatching, dotting, coloring or motif) by rightclicking the pattern and selecting Properties from the contextual menu. This will display the Properties dialog box in which you may either select a new pattern or modify some graphical attributes of the existing pattern. For more information, refer to Modifying a Pattern. Patterns will not be applied to aligned sections which are tangent to 3D faces. About the Cut in section views capability In an assembly, you can define that given parts will or will not be sectioned when generated into section views. (This capability is not available for section cuts.) In the Assembly Design workbench, select one part, then the Edit -> Properties command from the menu bar from and either activate or de-activate the Cut in section views option. You can also do this when overloading element properties in a view generated from a CATProduct. If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that if the cutting profile intersects an uncut part, then this part will not be cut and will be entirely projected. About section views or section cuts generated using the Approximate generation mode You can now generate section views or section cuts using the Approximate generation mode. For more information on the approximate generation mode, refer to Customizing Settings: View.
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When generating section views or section cuts using the Approximate generation mode, or when switching a section view/cut from exact mode to approximate mode (i.e. via Edit > Properties), be aware of the following information: Patterns In the case of parts which use a material to which a specific pattern is associated, section views/cuts in Approximate mode do not inherit the material properties from the 3D, and therefore do not use the pattern associated to this material. Pattern properties are not persistent: for instance, after switching an exact view to the approximate mode, and vice versa, the pattern may change. The Cut in section views capability If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that this capability does not work for section views generated using the Approximate generation mode: selected elements will be cut nonetheless. Likewise, if you switch an exact view to the approximate mode, the elements for which you unselected the Cut in section views option will be cut in the view nonetheless.

Creating a Section View / Cut with Profile Defined in 3D
In this task, you will learn how to create a section view or a section cut using a 3D profile as cutting plane. Section views / section cuts are usually created using a cutting profile as the cutting plane; such a profile is typically driven using concentricity or parallelism constraints. Defining a profile in 3D to create a section view / section cut enables you to make the profile associative with the geometry, and therefore to drive this profile using dimensional constraints, for example.

Open the GenDrafting_part.CATPart and the GenDrafting_front_view.CATDrawing documents. Tile your windows vertically to see both your part and the related drawing.

1. In the Part window, click the Sketch icon and select the xy plane as the reference plane. You are now in the Sketcher workbench.

145

drawingGeneration

2. Click the Profile icon and sketch the profile you will use as cutting plane. For the purpose of this exercise, make sure you sketch your profile using orthogonal lines.

3. You can now create dimensional constraints between your profile and other elements. Click the Constraint icon .

4. Now, click a vertical line and the edge of the part to create a dimensional constraint between them.

5. Exit the Sketcher workbench. 6. In the Drawing window, click the Update icon 7. Click the Offset Section View icon toolbar). to update the view.

from the Views toolbar (Sections sub-
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Depending on the type of profile you sketched and on the type of section (offset or aligned) you want, you can select another icon on the Sections sub-toolbar. If the 3D profile is not valid for generating the appropriate view, you will not be able to select it. In this case, you will need to select another icon.

8. Select the profile on the 3D part. The cutting profile is automatically displayed on the front view as well as a preview of the view to be generated. Positioning the section view amounts to defining the section view or the section cut direction.

9. Click to generate the view.

• •

•

You can modify the section view / section cut by editing the 3D profile. After doing so, don't forget to update the drawing. When editing a 3D profile, make sure that you modify it in accordance with the type of section (offset or aligned) you created: if an edited profile is invalid when you update a drawing, the associated section view / section cut will not be displayed (an error symbol will appear instead). If you delete the 3D profile and then update the drawing, the section view / section cut will not be deleted. The profile will no longer be associated with the geometry. You can subsequently edit the profile directly in the drawing by double-clicking it.

About Patterns
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The patterns which are used to represent the section are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide. You may modify the pattern (hatching, dotting, coloring or motif) by rightclicking the pattern and selecting Properties from the contextual menu. This will display the Properties dialog box in which you may either select a new pattern or modify some graphical attributes of the existing pattern. For more information, refer to Modifying a Pattern. Patterns will not be applied to aligned sections which are tangent to 3D faces. About the Cut in section views capability In an assembly, you can define that given parts will or will not be sectioned when generated into section views. (This capability is not available for section cuts.) In the Assembly Design workbench, select one part, then the Edit -> Properties command from the menu bar from and either activate or de-activate the Cut in section views option. You can also do this when overloading element properties in a view generated from a CATProduct. If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that if the cutting profile intersects an uncut part, then this part will not be cut and will be entirely projected. About section views or section cuts generated using the Approximate generation mode You can now generate section views or section cuts using the Approximate generation mode. For more information on the approximate generation mode, refer to Customizing Settings: View. When generating section views or section cuts using the Approximate generation mode, or when switching a section view/cut from exact mode to approximate mode (i.e. via Edit > Properties), be aware of the following information: Patterns In the case of parts which use a material to which a specific pattern is associated, section views/cuts in Approximate mode do not inherit the material properties from the 3D, and therefore do not use the pattern associated to this material. Pattern properties are not persistent: for instance, after switching an exact view to the approximate mode, and vice versa, the pattern may change. The Cut in section views capability
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If you choose to not cut elements in section views (i.e. if you uncheck the Cut in section views option), note that this capability does not work for section views generated using the Approximate generation mode: selected elements will be cut nonetheless. Likewise, if you switch an exact view to the approximate mode, the elements for which you unselected the Cut in section views option will be cut in the view nonetheless.

Creating a View from 3D
This task shows how to generate views and the associated annotations from the 3D (Functional Tolerancing and Annotation workbench). A view from 3D is extracted from a 3D part, product or process that is assigned 3D tolerance specifications and annotations. The master document is the 3D part, product or process, which means that everything is handled at the 3D level: view definition (projection view, section view, section cut), annotation content and graphism. For this reason, it is recommended to perform modifications directly in 3D. You can generate the following types of view from 3D: • • projection views, section views, section cuts aligned section views, aligned section cuts, offset section views, offset section cuts

With a 2D Layout for 3D Design license, you can now use the view from 3D functionality to create a drawing view from a layout design view or isometric view. Refer to Creating Drawings and Drawing Views from a Layout in the 2D Layout for 3D Design User's Guide for specific information.
Creating projection views, section views, section cuts

Open the 3DViews.CATPart document and open a new Drawing sheet. Tile the screen horizontally by selecting Window -> Tile Horizontally from the menu bar. In addition, make sure that the parent standard used in the CATDrawing document and in the CATPart (annotations) is the same. Otherwise, both the view and the annotations may not be generated. In our scenario, the parent standard used in the 3DViews.CATPart document is ISO. Therefore, the parent standard used in the CATDrawing document should be ISO.

1. Click the View From 3D icon from the Views toolbar (Projections sub-toolbar).
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2. Select a view from the 3D, either in the specification tree or on the part. In this case, select Projected View.1 in the specification tree.

The view to be created is previewed (included annotations) on the sheet. You cannot modify the view orientation, but you can modify the view position by dragging it using the left mouse button. 3. Click on the sheet to create the new view.

You can notice that one of the extracted annotations (datum B) bears a red cross mark, which indicates that the leader cannot be extracted linked to the geometry. This is because the 3D annotation leader is linked to 3D geometry which is not visible in the 2D view (i.e. hidden geometry). Such a red cross mark will be used for any annotation or dimension with a leader linked to hidden geometry (i.e. 3D geometry which is not visible in a 2D view). You can either change the properties of the view from 3D (Edit -> Properties) to display hidden lines, or transfer the marked annotations to a 3D view where the associated
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geometry will be visible when extracted. 4. Repeat the first three steps, this time selecting Projection View.2 as the view to be created. 5. Once again, repeat the first two steps, this time selecting Section Cut View.1. The preview is displayed on the sheet. 6. On the sheet, click Projection View.2 to specify that the callout for the section cut should be positioned in that view. Note that it works the same for section views.

In views from 3D, the axis can only be that of the sheet: the H and V axis of the view must correspond to X and Y axis of the sheet. For this reason, the choice of the view in which to add a section cut callout is limited. In particular, the profile of the section cut must be horizontal on the chosen view. In the case of extraction views, the first line of the profile (i.e. corresponding to the first compounding view) must be horizontal.
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Creating aligned section views/section cuts and offset section views/section cuts

Open the 3DViews_AlignedSectionView.CATPart document. Tile the screen horizontally by selecting Window -> Tile Horizontally from the menu bar. Make sure that the parent standard used in the CATDrawing document and in the CATPart (annotations) is the same. 1. Click the View From 3D icon from the Views toolbar (Projections sub-toolbar).

2. Select the aligned section view from the 3D, either in the specification tree or on the part. In this case, select Aligned Section View.1 in the specification tree.
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The view to be created is previewed (included annotations) on the sheet. You cannot modify the view orientation, but you can modify the view position by dragging it using the right mouse button. 3. Click on the sheet to create the new view.

More About Views from 3D

•

Only the elements visualized in the 3D (i.e. in Show mode) at the time of extraction are extracted in the view from 3D. In other words, any element hidden in the 3D will
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• • • • • •

•

not appear in the view. If you then show this element in the 3D part, it will be displayed in the view from 3D after you update it. You can move or modify annotations in views from 3D. However, if the part is modified and you subsequently update the view, any modification applied to the annotations in the drawing will be lost. We advise you perform modifications on the 3D part directly. Extracted annotations are not associative to the geometry. 2D annotations can be added to views from 3D. Views from 3D can be rotated. In other words, when you edit the properties of this view (Edit -> Properties), the Angle field can be edited and customized according to your needs. In views from 3D, the horizontal axis of the view is parallel to the horizontal axis of the sheet. You can create views from 3D from a part (Functional Tolerancing and Annotation workbench), a product (Product Functional Tolerancing and Annotation workbench) or a process (Process Tolerancing and Annotation workbench). It is currently impossible to extract views from part, product and process at once. However, you can superpose views as a bypass (using the View Positioning -> Superpose contextual command). Views from 3D are not associative to the geometry of the 3D view. So, if you modify the geometry of a 3D view, the definition of the corresponding 2D view will not be modified at the next update, even if the 3D view is associative to the geometry. The Note Object Attribute (NOA) from a ditto (2D component) is now extracted in views from 3D. However, some restrictions apply: o If a frame is defined in 3D, this frame is not displayed in the 2D view. To work around this, do not use the 3D annotation frame when defining the NOA reference; instead, have your administrator define the frame as part of the 2D component geometry. o Information regarding the documents used to create the ditto (drawing, parts, catalogs) will be lost. Hidden texts and URLs on flag notes and Note Object Attributes will be lost during extraction.

•

•

Creating an Auxiliary View
This task will show you how to create an auxiliary view. Many objects are of such shape that their principal faces cannot always be assumed parallel to the regular planes of projection. Creating an auxiliary view allows showing the true shapes by assuming a direction of sight perpendicular to planes that are perpendicular of the curves. This auxiliary view, together with the top view, completely describes the object.

Open the GenDrafting_part.CATDrawing document. Make sure the right view is active (double-click to activate it).
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1.

from Click the Auxiliary View icon the Views toolbar (Projections subtoolbar).

2. Sketch the representation of the plane. In this case, click an edge on the right view. You could also click a point and then an edge. Both the 3D surface and the sketched plane are associative. The selected edge becomes a line that you can position where desired using the cursor. This line/callout will be automatically used as the plane. 3. Click to position the callout. The reference plane is automatically positioned according to the selected edge. Positioning the auxiliary view callout amounts to defining the auxiliary view direction.

.
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4. Click to position the auxiliary view. Before clicking, as you move the cursor within a zone perpendicular to the plane, a preview of the auxiliary view to be created appears. This view will be automatically positioned accordingly. This is also true when creating a section view or a section cut. You can also move the cursor outside the zone perpendicular to the plane and position the view where you want. Note that the callout can be inverted or graphically modified.

•

You can move the view freely after it has been created, providing you position it independently of its reference view. For this:

1. Right-click the frame of the view you want to move. 2. Select the View Positioning -> Position Independently of Reference View from the displayed contextual menu. 3. Drag the view to the desired location. • You can choose the auxiliary view axis orientation. For this go to Tools -> Options -> Mechanical Design -> Drafting -> Layout and check the Auxiliary and/or section views orientation according to profile option. To have information about generated geometry and dress-up properties, refer to Definition of Generated geometry and dress-up properties section.

•

Other Views
Creating a Detail View / Detail View Profile
This task will show you how to create from the 3D a detail view using either a circle as callout or a sketched profile. Note that the procedure varies slightly
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depending on the method you choose. A detail view is a partial generated view that shows only what is necessary in the clear description of the object. Note that the Detail view command uses a Boolean operator from the 3D whereas the Quick Detail view command computes the view directly from the 2D projection. The representation is therefore different.

Open the GenDrafting_isometric_view.CATDrawing document.

To create a detail view (this is the method illustrated here): 1. Click the Drawing window, and click the from the Views toolbar Detail View icon (Details sub-toolbar). 2. Click the callout center. 3. Drag to select the callout radius and click a point to terminate the selection.

OR To create a detail view using a sketched profile: 1. Click the Drawing window, and click the Detail View Profile icon Views toolbar (Details sub-toolbar). 2. Create the points required for sketching a polygon used as profile. 3. Double click to end the cutting profile creation. from the

• •

SmartPick assist you when sketching the profile. You do not necessarily need to close the profile: the profile will automatically be closed.
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The dress-up elements generated from the 3D are identified and represented in the generated detail view whereas it is not when generating quick detail views. 4. Click to generate the detail view. The default scale is 2 (twice the scale of the active view). You can modify this scale. 5. Right-click the detail view and select the Properties option from the contextual menu, View tab. Enter the desired Parameters Scale, for example 3 and then click OK in this Properties dialog box.

158

User Tasks

• •

• •

•

You can also modify the detail view boundary (Properties dialog box). You can assign a line type to the view to be generated. For this, go to Tools -> Options -> Mechanical Design -> Drafting -> View tab, click the Configure button next to View Linetype and select the desired option from the dialog box. In the isometric view, you can move the detail text ("A" in this example) after detail view creation. If you create a detail view from a section view and subsequently modify the cutting profile in the section view, in such a way that the detail view is no longer accurate, the detail view cannot be updated so as to take into account the changes in the cutting profile. If you create a broken view from a view which contains a detail view callout, the detail view callout will not be broken in the broken view. In other words, the circular shape of the callout will not be modified, even if the callout overlaps the break profile. As for the detail view, it will not modified by the break operation.

To have information about generated geometry and dress-up properties, refer to Definition of Generated geometry and dress-up properties section.

Creating a Broken View
This task will show you how create a broken view from an active and up-todate generated view. You will define two profiles corresponding to the part to be broken from the view extremities. A broken view is a view that allows shortening an elongated object.

Open the GenDrafting_part_Broken_View.CATDrawing document.

1. Click the Broken View icon Views toolbar.

from the
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2. Click a first point corresponding to the first extremity of the first profile. A green dotted profile appears which allows you to position the profile either vertically or horizontally. 3. Click a second point corresponding to the profile second extremity. In this example, click a point so that the profile appears horizontally. OR 3. Drag the cursor over the green horizontal profile that appears as you create a first point and, if needed, click to locate the second point on this first profile.

4. If needed, translate the profile. Red zones appear. These red zones correspond to the zones out of which the view cannot be broken. Note that the orientation of the second profile is the same as the orientation of the first profile. 5. Click a point for defining the position of the second green profile that appears. 6. Click on the sheet. The broken view appears.

• • •

You can create new breaks in a broken view, but in the same direction and providing the two breaks do not overlap. You can remove created breaks via the contextual menu: right-click the callout and select Callout (Broken View).1 object-> Unbreak in the contextual menu. It is impossible to create breakout views, offset section views, detail views and clipping views from a broken view.

More on Broken Views

Propagating a broken specification
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To propagate the broken specification during the creation of a projection or auxiliary view, go to Tools -> Options -> Mechanical-> Drafting from the menu bar (Layout tab) and activate the Propagation of broken and breakout specifications option. Propagating a specification means generating a view (B) from another view (A) on which you previously performed an operation, and obtaining a view (B) which includes this operation. For example, (i) you create a broken view (view A) and activate the Propagation of broken and breakout specifications option, you then (ii) generate a projection view (view B). As a result, the projected view (view B) will appear with the broken area. You can only perform a propagation from a broken view if the projection direction is perpendicular to the direction of the broken view. About line types You can assign a line type to the view to be generated. For this, go to Tools -> Options -> Mechanical Design -> Drafting -> View tab, click the Configure button next to View Linetype and select the desired option from the dialog box.

Creating a Breakout View
This task will show you how to create a breakout view. In other words, you will remove locally material from a generated view in order to visualize the remaining visible internal part.

A breakout view is one not in direct projection from the view containing the cutting profile. In othe words, it is not positioned in agreement with the standard arrangement of views. A breakout view often a partial section.

Open the GenDrafting_part.CATDrawing document. For the purpose of this scenario, you will creat the breakout on the left view: therefore, make sure the left view is active by double-clicking it. 1. Click the Drawing window, and click the Breakout View icon (Break View sub-toolbar). from the Views toolbar

2. Click the first point of the breakout profile. 3. Click as many points as desired for creating the profile.
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4. If needed, double-click to end the profile creation and close this profile automatically. OR 4. Click on the profile first point to close and end the profile creation.

The 3D Viewer window appears, displaying the 3D part corresponding to the generated view. A green arrow indicates in which direction the breakout will be created. This window lets you position the 3D part according to a view you go over (on the drawing), provided the Animate option is checked. This window also lets you visualize a view plane and use it to define the depth of the breakout. You can move this plane using one of these methods: • directly in the 3D Viewer window, drag the plane to the desired location. This method does not let you define the depth of the breakout precisely. The breakout will not be associative with any element. • in the drawing, place the cursor over an axis, a center line or an edge (circular or linear) of a perpendicular view. The plane will be moved accordingly. This method lets you break the view through a hole or a face, for example. The breakout will be associative with the selected element. • in the drawing, select the edge which corresponds to the face that you will use as a reference element to define the depth of the breakout, and enter the depth in the appropriate 3D Viewer field. This method lets you define the depth of the breakout precisely. The breakout will be associative with the selected reference element and with the depth value.
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5. Check the Animate option to visualize the 3D part in accordance with the position of the cursor on a generated view. 6. In the CATDrawing document, place the cursor over the front view (which is perpendicular the left view). 7. In the CATDrawing document, place the cursor over the center line that will be used as an extremity plane, as shown below.

OR

7. In the 3D Viewer window, click the Reference element field to select it. Then, in the CATDrawing document, select the edge which corresponds to the face that will be used as a reference element, and enter the breakout depth in the Depth (in mm) field (you can also define the depth by moving the red plane with the mouse).

163

drawingGeneration

8. Then, click OK in the 3D Viewer window. The breakout view is created.

More on Breakout Views
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• •

Once created, the breakout view profile cannot be modified. You cannot apply a breakout and a break to the same view.

You can create breakout views on: • • • • projection views, auxiliary views, section views a view that already contains breakouts.

You cannot create breakout views on: • • • section cuts, detail/ clipping views, broken views.

Removing a breakout To remove a breakout, choose either of the following methods: • •

Once the breakout view is created, right-click the view, and select the Remove Breakout option. All the breakouts will be removed. Or right-click on the edge of a resulting breakout and select Generated item object, then Remove breakout. Only this breakout will be removed.

Propagating a breakout specification manually

Right-click the view, select the Apply Breakout To option and click another view you want to apply the breakout to. Propagating a breakout specification automatically Propagating a specification means generating a view (B) from another view (A) on which you previously performed an operation and including this operation in the generated view (B).

To generate views (projection, auxiliary, section, section cut and detail) from a breakout view, go Tools -> Options -> Mechanical Design -> Drafting from the menu bar, click on the Layout tab, an activate the Propagation of broken and breakout specification option. For example, (i) you create a breakout view (view A) and activate the Propagation of broken and breakout specification option, you then (ii) generate a projection view (view B). As a result, the projected view (view B) will display this breakout area. You can add a clipping or a breakout view but you cannot create a broken view. About line types You can choose the line type you want to assign to the breakout view. To do this, go to Tools -> Options -> Mechanical Design -> Drafting -> View tab, click the Configure button next to View
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Linetype and select the desired option from the dialog box.

If you choose the zigzag linetype (linetype #8), note that this linetype is just a graphical dress-up of the view. This means that if one line is relimited on the breakout line, then it will be relimited on the theoretical line as shown here, and not on the visualized zigzag line.

About patterns The patterns which are used to represent the breakout are defined in the standards. For more information, refer to Pattern Definition in the Interactive Drafting User's Guide.

You may modify the pattern (hatching, dotting, coloring or motif) by right-clicking the pattern and selecting Properties from the contextual menu. This will display the Properties dialog box in which you may either select a new pattern or modify some graphical attributes of the existing pattern. Fo more information, refer to Modifying a Pattern. About patterns in breakouts from isometric views

In versions prior to V5 R13, when creating breakouts on isometric views, in the case of overlappin faces, the pattern area used to go over the projected faces and edges. From R13 onwards, the pattern area is now limited to the face sectioned on the part, as shown below. Previous behavior New behavior

About the Cut in section views capability In an assembly, you can define that given parts will or will not be sectioned when generated into section views or breakout views.

In the Assembly Design workbench, select one part, then the Edit -> Properties command from th menu bar from and either activate or de-activate the Cut in section views option. You can also do this when overloading element properties in a view generated from a CATProduct.
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About breakout views generated using the Approximate generation mode You can now generate breakout views using the Approximate generation mode. For more information on the approximate generation mode, refer to Customizing Settings: View. When generating breakout views using the Approximate generation mode, or when switching a breakout view from exact mode to approximate mode (i.e. via Edit > Properties), be aware of the following information: Breakout direction The breakout propagation direction must be perpendicular to the view plane. In other words, the breakout profile must be parallel to view plane. Patterns

In the case of parts which use a material to which a specific pattern is associated, breakout views Approximate mode do not inherit the material properties from the 3D, and therefore do not use th pattern associated to this material. Pattern properties are not persistent: for instance, after switching an exact view to the approxima mode, and vice versa, the pattern may change. The Cut in section views capability

If you choose to not cut elements in section views or breakout views (i.e. if you uncheck the Cut in section views option): note that this capability does not work for breakout views generated using the Approximate generation mode: selected elements will be cut nonetheless. Likewise, if you swit an exact view to the approximate mode, the elements for which you unselected the Cut in section views option will be cut in the view nonetheless.

Creating Views via the Wizard
This task will show you how to create views using a wizard. These views are views that are generated automatically once the CATDrawing document is opened. These views can then be modified as if they had been manually created one after the other.

Open the GenDrafting_part.CATPart document. Start creating a new drawing (and this case, create an empty sheet).

Before you begin, make sure you select the projection mode you need. If you want to change the method you use as you pre-define your configurations, what
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•

•

First angle standard: Orthographic representation comprising the arrangement, around the principal view of an object, of some of all of the other five views of that object. With reference to the principal view, the other views are arranged as follows: - the view from above is placed underneath - the view from below is placed above - the view from the left is placed on the right - the view from the rear is placed on the left or on the right, as convenient. (Ref. No. ISO 10209-2:1993) Third angle standard: Orthographic representation comprising the arrangement, around the principal view of an object, of some of all of the other five views of that object. With reference to the principal view, the other views are arranged as follows: - the view from above is placed above - the view from below is placed underneath - the view from the left is placed on the left - the view from the rear is placed on the left or on the right, as convenient. (Ref. No. ISO 10209-2:1993)

1. Click the Drawing window, and click the View Creation Wizard icon from the Views toolbar (Wizard sub-toolbar).

2. Select the desired view configuration from the View Wizard (1/2) : Predefined Configurations dialog box.
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In this case, ISO standard / First angle projection method is used and the following configurations are available: • • • • • • front, bottom and left front, bottom and right front, top and left front, top and right projection and isometric projection, rear and isometric

If you use the ANSI standard (Third angle projection method), in the dialog box the configuration symbol displayed , as well as the configuration options will

be different. To have the projection views linked to the main view click the option. You can can define the Minimum distance between each view. For this, enter the desired value in the modifiable field available in the View Wizard dialog box.
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A preview is available: • The main view corresponds to the view which any other view will be linked to. This main view can be either a front or an isometric view. It is framed in the green color. This is the view that will become the active view when you will generate the desired views. Any other view (front and/or isometric view) that can possibly become the main view is framed in the black color. To make a view become the main view, right-click this view and select the Set as main view option from the contextual menu. At any time, you can delete one view you inserted. For this, right-click the desired view and select the Delete option from the contextual menu. Once you generate the views, if you move the main view, all the child views will move accordingly. You can right-click one view and select the View Positioning->Position Independently of Reference View option from the contextual menu, if you need to move one child view independently from the reference view.

•

•

3. Click the Next > button from the View Wizard (1/2) : Predefined Configurations dialog box.

The View Wizard (2/2) : Arranging the Configuration dialog box is now displayed with a new set of view buttons: • • • • • • • • front view rear view top view bottom view left view right view isometric view clear preview
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4. Click the Isometric View button

.

5. Position the isometric view onto the Preview window by dragging and clicking it as desired. 6. Click the FINISH button from the View Wizard (2/2) : Arranging the Configuration dialog box.

7. Select the CATPart document.
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8. Click on the desired 3D part plane to be used as reference plane. If the plane can be computed, the Oriented Preview of the 3D part appears as you move the cursor over the 3D part (planes). The views now appear on the CATDrawing document: they are previewed in green frames and can be re-oriented thanks to the blue arrows that appear. 9. Go over the view frames with your cursor to have these views visualized.

172

User Tasks

10. Use the blue arrows to have the views re-oriented as desired and then go over the views with the cursor, if you need to check the preview of the other views. For more details, refer to Before You Begin.
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You can also modify the increment value using the green knob contextual menu. For this, right-click on the knob and select the desired option from the contextual menu. For more details, refer to Before You Begin.
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11. Once you are satisfied, click on the sheet to create the views. The front view is actually the main view and the isometric view is added to the predefined configuration.

The ISO and ANSI standards are independent from the angle projection method.

View Update Reporting
This task will show you how you can solve the problems encountered during view generation and view update thanks to a view update report. Open the GEAR-REDUCER_GS.CATProduct and the GEARREDUCER_RasterView.CATDrawing documents.
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1. Click on the Update icon to update the view. The View Update Report dialog box of the impacted views is displayed.

2. Close the dialog box. 3. Right-click on the Front View where a red cross is displayed and select Front View Object->Update Report. The View Update Report dialog box of the impacted views is displayed.

The View Update Report dialog box displays: • • • all the errors encountered when the view is generated, the names of the impacted views and sheets a solution to solve the problem following the update of the view.
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The View Update Report is displayed, among other things, when a boolean operation fails.

View Modification
View Modification
The Generative Drafting workbench provides a simple method to modify previously created views.

Before you begin: Learn how to edit the properties of multi-selected views. Move a view: Drag a view to a new location. Position a view: Position Generative or Interactive views either by aligning them, superposing them and setting relative view position. Position a view independently of its reference view: Position a view independently of its reference view. Locate reference/resulting views: Navigate easily between reference/resulting views in the case of section views, section cuts, auxiliary views or detail views. Isolate generated views: Remove associativity between an existing CATPart (or CATProduct or CATModel) and the corresponding generated views. Restore deleted generated elements: Restore generated elements that have been deleted from a view. Lock a view: Use the contextual menu (Properties option) to lock a view. Scale a view: Modify the scale of a view. Rename a view: Give a new name to an existing view. Modify a view projection plane: Modify the projection plane of any generated view. Add a generative bill of material: Insert Bill of Material information into the active view. Generating balloons on a view: Generate balloons on the active view. Show geometry in views: Visualize geometrical elements in all viewpoints as well as in a 3D viewer corresponding to the views analyzed. Modify a callout graphism: Modify the graphical attributes of one or more callout used when generating auxiliary, section or detail views. Modify a callout geometry: Modify the geometrical properties of a callout used when creating detail views, section views and section cuts. Overloading element properties: Overload the properties of generated elements in a view. Modify a pattern: Modify the pattern of a view and apply a material to this pattern. Duplicating generative geometry: Duplicate a generative view sub-element in order to modify a generated view sub-part independently from the part linked to the drawing. Modify a view's links: Modify the list elements pointed by a view. Apply a view's links to another view: Apply the links of a view to another one.
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Moving Views
Moving a View
This task will show you how to move one or more views by dragging them.

Moving One View
You can move one view by selecting or more views (implicitly) by dragging the parent view.

Open the GenDrafting_part_Move_View.CATDrawing document.

1. Click the frame of the view to be moved. 2. Drag the clicked view to the new location.
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3. Release the mouse button when you want to position the view. The view is re-positioned.

Moving More Than One View Explicitly
You can move more than one view explicitly (generative and interactive views). These views can be: • • child views that are linked to a single parent view (and constrained to this parent view) child views that are linked to different parent views (be careful: constrained views remain so by default ; not constrained views move in accordance with the position of the cursor)

Open the GenDrafting_part_Move_View02.CATDrawing document. 1. Multi-select the views to be moved. 2. Drag the selected views to the new location.
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3. Release the mouse button when you want to position the views. There are different cases: • You multi-select views that are independent (not linked to a parent view): When you move the views with the cursor, all these views are translated into the same direction. You multi-select views that are linked to different parent views which are not selected: When you move the views with the cursor, all these views are translated into a direction that depends on the constraints between the parent and the child views. In other words, two child views may be moved into two new locations which are not synchronized (for example, one according to x, the other according to y). You multi-select views that are linked to different parent views which are also selected: When you move the views with the cursor, all these views are translated into a direction that depends on the constraints between the parent and the child views. As a result, all the child views (with an active link), be they selected or not,are translated into the same direction as the parent views.

•

•
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Positioning a View
The purpose of this task is to position Generative or Interactive views: you will learn how to align views, superpose views and set relative view position.

Aligning Views Using Elements
You will learn how to align a view with another one using geometrical elements (lines, circles or points). Open the GenDrafting_part_Align_Views.CATDrawing document. Go to Tools -> Option -> Mechanical Design -> Drafting -> General tab and in the View axis area, unselect Display in the current view. 1. Right-click the view that you want to re-position, the unfolded view for example. A contextual menu is displayed. 2. Select View Positioning -> Align Views Using Elements. 3. On this view, select the first geometrical element that you want to align.

4. On the other view, select the second geometrical element that you want to align.
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The first view is moved, and both views are aligned according to the elements you selected. 5. Click in the drawing, outside the views, to validate the alignment.

When aligning views, remember that: • • if you select a circle as one of the elements to align, this circle will be aligned according to its center. if you select lines as the two elements to align, these lines must be parallel.

If you want to align two views which are not directly linked to each other (i.e. which are not a parent view and its child view), you will first need to position a view independently of its reference view. For example, if view A (a front view) is the reference for view B (a projection view), and if view B is the reference
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for view C (a section view), then to align view A and view C, you first need to position view C independently of view B. Refer to Positioning a View Independently of its Reference View for more information.

Superposing Views
You will learn how to superpose a view with another one according to their origins. Open the GenDrafting_Superpose_Views.CATDrawing document. 1. Right-click the view that you want to superpose, the front view with dressup, for example. A contextual menu is displayed. 2. Select View Positioning -> Superpose. 3. Click the view on which you want to superpose the first view. The first view is moved and superposed to the second one.

4. Click in the drawing, outside the views, to validate the superposition. If you want to superpose two views which are not directly linked to each other (i.e. which are not a parent view and its child view), you will first need to position a view independently of its reference view. For example, if view A (a front view) is the reference for view B (a projection view), and if view B is the reference for view C (a section view), then to superpose view A and view C, you first need to position either view B independently of view A, or view C independently of view B. Refer to Positioning a View Independently of its
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Reference View for more information.

Setting Relative View Position
You will learn how to re-position a view relatively to various elements (a line/callout, a point or the frame of a view). Open the GenDrafting_part_positioningview.CATDrawing document.

1. Right-click the view frame that you want to re-position, the isometric view for example. A contextual menu is displayed. 2. Select View Positioning -> Set Relative Position.

A direction positioning line appears that is related to the isometric view. This isometric view can be positioned as desired and relatively to the front view. Note that the isometric view is assigned anchor points. 3. Select the direction positioning line end black square point. Once you have clicked the end square point, this point becomes a blinking red end point and remains so until you select a point or a view frame. You can also click the direction positioning line. In this case, the positioning line becomes a blinking line and remains so until you select a line (callout line).
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Press the Ctrl key to move the positioning line according to a direction that is parallel to the positioning line.

4. Click the edge according to which you want the isometric view to be aligned. 5. Click one anchor point, for example, the bottom right one. The view anchor point is aligned according to the green point and thereby to the direction positioning line. 6. As you move the cursor over the direction positioning line, the position and length coordinates of the line appear.
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Note that you may also select the front view frame and align the isometric view to the front view according to the barycenter.

7. Using the green point, you can rotate the isometric view around the front view.
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8. Using the direction positioning line, translate the isometric view along the direction line and locate it at the desired distance.
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If you happen to modify the length of the direction positioning line, this new length will be kept whatever positioning modifications you may apply to the isometric view. Note that if you had previously positioned this isometric view according to a point, not only the line length but also the line angle will be kept. 9. Click in the free space to validate and leave the relative positioning mode.

As you use relative positioning, do not try to move the view outside of the anchor point frame. If you do so, you will leave the relative positioning mode.

You can also align a view relatively to one of the edges that are within this view. To do this, first select the direction positioning line, and then select an edge on the view to be aligned. As a result, the manipulators automatically align according to this selected edge.

Positioning a View Independently of its Reference View
At creation, views are by default positioned according to the parent (reference) view. This task will show you how to position a right projection view independently of its parent front view.
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This functionality was called Do not align view up until V5 R10.

Open the GenDrafting_part.CATDrawing document. 1. Right-click the frame of the view that you want to position independently of its reference view. A contextual menu is displayed. 2. Select View Positioning -> Position Independently of Reference View.

3. Drag the view to the required location.

• •

The Position Independently of Reference View command can be performed on one particular view at a time (you cannot multi-select views in this case). If you want to reposition independently-positioned views according to their reference view, repeat the scenario described above, this time selecting the Position According to Reference View command from the displayed contextual menu.
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Managing Views
Locating Reference/Resulting Views
This task shows how to navigate easily between reference/resulting views in the case of section views, section cuts, auxiliary views or detail views: • • You can locate the reference (i.e. parent) view of a resulting view. You can locate the resulting (i.e. child) view of a reference view.

Open the GenDrafting_view_navigation.CATDrawing document.

Locating a Reference View
1. Right-click the detail view.

2. In the contextual menu, select Locate Reference View. The application window is reframed on the view where the detail view callout is defined.
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Locating a Resulting View
1. Right-click the detail view callout.

2. In the contextual menu, select Locate Resulting View. The application window is reframed on the detail view.

Isolating Generated Views
This task will show you how isolate either a selection of generated views (one or more), or all views in the drawing. Isolating a view amounts to: • • suppressing associativity between an existing CATPart (or CATProduct or CATModel) and the corresponding generated view, transforming a generated view into an interactive view.
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Open the GenDrafting_part.CATDrawing document.

Isolating a selection of views
1. Select the views you want to isolate (for example, the Top view, Bottom view, Left view and Right view), and right-click them. 2. From the contextual menu, select Selected objects -> Isolate. In this particular case, we selected several views but if you select only one view, the left view for example, then you need to select Left view object -> Isolate from the contextual menu.

The selected views are now isolated. If you perform one or more modifications on the CATPart, you will not be able to update the isolated views.
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Isolating all views in the drawing
1. From the specification tree, right-click the drawing object (GenDrafting_part in this case). 2. From the contextual menu, select Drawing object -> Isolate.

All views in the drawing are now isolated. If you perform one or more modifications on the CATPart, you will not be able to update the drawing. • • • • A view that has been isolated cannot be de-isolated. Center lines in isolated views are no longer associated to geometry, but just to a point. Axis lines in isolated views are no longer associated to geometry, but just to 2 points. Dimensions in isolated views are no longer associated to geometry.

Restoring Deleted Generated Elements
In this task, you will learn how to restore generated elements that have been deleted from a view.
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Open the GenDrafting_Restore_Deleted.CATDrawing document. The view in this drawing was generated from a 3D part, GenDrafting_Restore_Deleted.CATPart. You do not need to open the part.

1. In the Drawing window, select the circle shown on the view and press the Del key. The circle is now deleted from the view. For the purpose of this exercise, you will now immediately restore the circle you deleted, but you could perform other operations before doing this (like save and close the drawing, or add annotations, for example).

2. Select the view and right-click the view frame. 3. In the contextual menu, choose Object Front View -> Restore Deleted. Remember that this is applicable only in exact views. If the view you are working in is not an exact one, the elements you deleted will be displayed again when updating the view. 4. You now have two possibilities: • If you did not modify the part between the moment you deleted the circle and now (which is the case in this exercise): in the Power Input Field on the status bar, type the following command: c:force update. This updates the drawing in accordance with the 3D part, and restores the deleted item on the view.

•

If you modified the part between the moment you deleted the circle and now: click the . This updates the drawing Update icon with the latest changes on the part, and restores the deleted item on the view.
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Locking a View
This task will show you how to lock views. This may be useful if you need to modify a part without modifying the generated views. For example, when you need to modify a constraint in the 3D but not the generated views.

Locking a view means you are not allowed to: • • • create views from a locked view create either annotations or dimensions on this locked view update, delete or cut the locked view.

The move command is still available when views are locked.

Open the GenDrafting_front_view.CATDrawing document.

1. Right-click the view to be modified (either the view frame or the view itself). 2. Select the Properties option from the contextual menu.

The Properties dialog box appears: 3. Select the View tab and select the Lock View check box. The other fields appear in gray indicating that you can no longer edit them.
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Use the OK, or Apply+Close buttons in the Properties dialog box to close the dialog box and lock the view.

4. The view is locked. This is indicated in the specification tree:

Renaming a View
This task will show you how to rename an existing view. Open the GenDrafting_part_Rename_View.CATDrawing document. 1. Right-click the frame of the view to be modified. 2. Select the Properties option from the displayed contextual menu.

3. Enter the new View Name in the Properties dialog box. For example, B as identifier (Ident). 4. Click OK.

196

User Tasks

• •

You can also access the Properties dialog box selecting the Edit>Properties commands. Note that the callout in the mother view also is now assigned a new identifier (B-B).

Scaling a View
This task will show you how to modify the scale of a view.

Open the GenDrafting_detailview_scale.CATDrawing document.

1. Right-click the frame of the view to be modified. In this case, right-click the detail view.
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2. Select the Properties option from the displayed contextual menu. 3. Enter the new Scale value in the Properties dialog box. For example, 3.

4. Click OK. The detail view is updated. Note that only the generative elements (axes included) are scaled, neither the view name nor the dimension.

198

User Tasks

Modifying a View Projection Plane
This task will show you how to modify the projection plane of generated views. Open the GenDrafting_part.CATPart document. Tile your windows vertically to see both your part and the related drawing. 1. Create a front view of the part. 2. Create a right, left, bottom and top projection view. 3. Then create an auxiliary view of the top view. This type of auxiliary view created from the Projection view icon should not be mixed up with auxiliary views created thanks to the Auxiliary view icon. 4. Create a detail view on the front view.

5. In the Specification tree, right click and select Front view object-> Modify Projection plane. The front view and all the projection views are highlighted, showing the modification will impact all the views.
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6. Select an edge of the part as your new reference plane.

The front view with the new reference plane is previewed in the drawing.

7. Click on the drawing sheet to create the front view according to the reference plane you selected. The front view is updated and an update icon is displayed under each projection view.
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• •

The update is made in two steps: first the front view, then the views linked to the front view, that is, the projection views and the detail view. You will note that the detail view callout has become red because there is an inconsistency between the referring view and the detail view.

8. Right-click on each projection view and select Update selection in the contextual menu to update the view according to the new reference plane. or Right click on Drawing1 and select Update selection in the contextual menu. The right, left, bottom, top and auxiliary views are updated, as well as the detail view. The detail view callout turns black again since there is no inconsistency left.
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The Modify Projection Plane option cannot be applied to the following views: • • • • top, bottom, right, left, auxiliary, detail, locked, isolated, interactive

You cannot propagate the modification of a projection plane on a section or auxiliary view created from the Auxiliary view icon. You have to recreate them in order to take into account the new reference plane.

You can modify the projection plane of views that do not have a referring view such as: • • isometric views, views from 3D.

1. Create an isometric view of the part.
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2. Modify the part position.

3. In the Specification tree, right click and select Isometric view object-> Modify Projection plane. 4. Click on the part. The isometric view with the new reference plane is previewed in the drawing.

The isometric view is modified in the drawing.
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5. Open the 3DViews.CATPart document. Tile the screen horizontally by selecting Window -> Tile Horizontally from the menu bar. 6. Create a new drawing in ISO standard. 7. Create a view from 3D on the FrontView.1 You can notice that one of the extracted annotations (datum B) bears a red cross mark, which indicates that the leader cannot be extracted linked to the geometry. This is because the 3D annotation leader is linked to 3D geometry which is not visible in the 2D view (i.e. hidden geometry).

8. In the drawing specification tree, select Front View.1 object->Modify Projection plane. A message asking you if you want to synchronize the view projection plane is displayed.

9. Click on OK. The behavior of dress-up elements and callouts remain the same even when modifying a projection plane. For more information on dress-up elements, refer to the Dress-Up Elements section and the Modifying a Callout Geometry section.
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Generating Balloons on a View
This task will show you how to generate in the active view balloons corresponding to references defined on the different parts of an assembly. Note that the assembly components have previously been numbered in the Product Structure workbench using the Generate Numbering command. For more information, refer to Generating Numbering in the Product Structure User's Guide. Open the Product_Balloon_Gen.CATProduct and Product_Balloon_Gen.CATDrawing documents. 1. Double-click the view in which you want to generate the balloons. In this particular case, double-click Bottom view. This view is now active.

2. Select the Generate Balloons icon

on the Dimension Generation toolbar.

The balloons that were previously created on the CATProduct are automatically generated onto the active view. 3. If needed, multi-select these balloons and modify the font size from the Text Properties toolbar. You can also select and drag a balloon to change its position.

4. If needed, create a circle around the text of the balloons: right-click a balloon (or multi-select several and right-click) and select Properties->Text-
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>Frame->Circle. Press OK. A circle is created around the texts. Balloons generated

Balloons after the font size and position were modified:

4. If needed, insert a bill of material into the active view (Insert -> Generation -> Bill of Material from the menu bar).
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The part numbers appear in the bill of material on the condition you specified it previously (Product Structure workbench: Analyze -> Bill of Material -> Listing Report from the menu bar).
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Generating a Bill of Material
This task will show you how to insert Bill of Material information into the active view. The Bill of Material corresponds to information on the product element which the views were generated from. The Bill of Material, or parts list, consists of an itemized list of the parts of a structure shown on a drawing or on an assembly. The Bill of Material can also include a recapitulation of the total number of parts used in a product. Choose a task: • • generating a bill of material, modifying a bill of material: o modifying the contents, o modifying the contents visualization, o updating a Bill of Material after part modification.

Generating a Bill of Material
Open the Product_Balloon.CATDrawing document. Open the Product_Balloon.CATProduct document.

208

User Tasks • • • If the active view has no link with the product, a message will state whether the insertion is all right. If the active view has a link with a product, the Bill of Material can be inserted. Whether the active view has a link with a product or not, you can go into an open product and click on this product before clicking on the CATDrawing in which you want to insert the Bill of Material. Note that you can perform this as often as you need.

You are in the background view
You first selected Edit -> Background View from the toolbar. 1. Click the Insert Bill of Material icon from the Drawing toolbar.

2. Click the Product from the specification tree in the CATProduct document. 3. Position the Bill of Material by clicking the point where you want to insert it.

OR You are in the working views
You first selected Edit -> Working Views from the toolbar. 1. Select Insert -> Generation -> Bill of Material. 2. Position the Bill of Material by clicking the point where you want to insert it. In our example, click at the bottom right of the isometric view.

Whether you are in the background view or in the working views: • Before positioning the Bill of Material, you can pre-define the anchor point position: this will determine the position of the Bill of Material in relation to the anchor point. For this, use the Text Properties toolbar and select either one of the top or one of the bottom anchor points. When positioning the Bill of Material, you can select a line, in a title block for example. In this case, the Bill of Material will be inserted according to the position and orientation of this element, and without including a recapitulation table.

•
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Note that, if no Product is or several Products are opened, you will first select the Product source. The Bill of Material automatically appears:
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Modifying a Bill of Material
Modifying the contents
To modify the contents of the Bill of Material and display given properties, go to the Product Structure workbench, and select Analyze->Bill of Material ->Listing Report from the menu bar.

Modifying the contents visualization
To modify the way you visualize the contents, modify the file called CATAsmBOM.CATRsc. It allows you to modify the columns size:
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•

•

Note that the number of characters authorized in a line can be set precisely for fonts with a fixed-size case only. In the case of fonts with a variable-size case, it is not possible to know exactly how many characters will fit on a line (because the size of the text depends on the characters entered). In this case, the specified number corresponds to the minimum number of characters that you can enter on a line. Bill Of Material cells are associated to the Product Structure Attributes.

Updating a Bill of Material after Part Modification
Open the Product_Balloon.CATDrawing document. Open the Product_Balloon.CATProduct document. Add a bill of material. You obtain the following Bill of Material:
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1. Replace the Part Number "pm6-7b-1e shunt to body washer" by "New Name" (for this edit Part Properties in the Part contextual menu, and change the Part Number in Product tab). 2. Update the drawing. The Bill of Material has changed, "pm6-7b-1e shunt to body washer" is replaced by "New Name".

3. Add a new product and a new part in this product (see Part Design user's guide and Assembly Design User's Guide):
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4. Update the drawing, the Bill of Material is updated:

The New product and its part appear in the Bill Of Material.

5. Remove the Product you have added in step 3 and update the drawing one more time:
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As Bill of Material-related information is retrieved from the 3D, if you update a Bill of Material after having modified it directly in the drawing (e.g. if you changed the column size, edited text, etc.), all manually-applied changes are lost.

Callouts
Modifying a Callout Graphism
This task will show you how to modify the graphical attributes of one (or more) callout used when generating auxiliary, section or detail views.

Callouts represent an operation that has been performed on a generative view (such as a section cut for example) and consequently do not behave as geometry. As a result, you cannot isolate callouts, nor can you apply transformation or symmetry operations to callouts.

Open the GenDrafting_part_Callout.CATDrawing document. 1. Multi-select the callout to be modified. In this example, we select both a section view callout and a detail callout. 2. Right-click these callout and select the Properties option from the contextual menu. 3. Select the Callout tab.
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The preview displays both selected callouts with attributes corresponding to the generated views.

The options you select in the Graphic Properties toolbar also influence the graphical attributes you apply to the selected callout (line color, line type, line weight, Copy Object Format icon, Pattern Chooser option).
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In this dialog box, you can set the following parameters: • Auxiliary/Section Views: o Switches for pre-defined types: continuous lines, mixed lines, elbows and extremities only or one arrow only. o Line thickness o Line type o Extremity thickness o Length o Anchor point (head or tail) Detail Views: o Thickness o Type Arrows on Auxiliary/Section Views and Detail Views: o Arrow length o Head type o Head length o Head angle

• •

You can specify that the size of callout elements should not be dependent on the view scale. For this: • After callout creation, check Size not dependent on view scale in the previous dialog box.

or • Before callout creation, in Tools -> Options -> Mechanical Design -> Drafting -> Layout tab, check the Size not dependent on view scale option. This option will apply to newly created callouts, i.e. selecting this option will not have any impact on existing callouts. Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. versions up to V5 R10). 4. Modify the callout graphical attributes as shown above. 5. Click OK.
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Modifying a Callout Geometry
This task will show you how to modify the geometrical characteristics of a callout used when creating detail views, section views and section cuts. For modifying the detail and section callout, you will go through some kind of a sub-workbench and modify the existing callout geometry, reverse the callout direction or replace the callout.

Callouts represent an operation that has been performed on a generative view (such as a section cut for example) and consequently do not behave as geometry. As a result, you cannot isolate callouts, nor can you apply transformation or symmetry operations to callouts.

Open the GenDrafting_part_Callout.CATDrawing document.

1. Double-click the callout to be modified. The Edit/Replace toolbar appears.

218

User Tasks

2. Drag one of the element components to the desired location. In this particular case, drag one segment extremity of the callout. By default the segment extremities are not fixed. To constrain one segment, rightclick this segment and select the Line.object -> Fix option from the contextual menu. To free one segment, right-click this segment and select the Line.object -> Unfix option from the contextual menu. 3. Click the End Profile Edition from icon the Edit/Replace toolbar. The callout arrow is now properly positioned and the section view (B-B) is automatically updated.
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Open the GenDrafting_part_Callout.CATDrawing document.

1. Double-click the callout to be 2. reversed. Click the Invert Profile Direction icon from the Edit/Replace toolbar that now appears.

The callout is automatically inverted. • At any time, you can stop editing the callout. For this, click the End Profile Edition icon from the Edit/repl ace toolbar. You cannot reverse the callout of a detail.

•
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•

If after modifying a view containing a callout, the projection planes of the defining and the resulting views are inconsistent, the callout becomes red to show that there is an inconsistency in the drawing.

To have further information about red callouts, refer to the More about red callouts section below. 3. Click the Replace Profile icon from the Edit/Replace toolbar now appears.

4. Start creating the new profile.

5. Double-click to end the new profile creation. The new profile automatically appears and the old one disappears.

More about red callouts
Modification of callouts

If you modify an auxiliary or a section callout in a way that the plane of the resulting view is not parallel anymore compared to the previous plane view or if you invert the profile:
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• • •

all the callouts of the resulting view are displayed in red, you cannot edit them, the change is not propagated to detail view.

Translation of section callouts

If you translate a section callout, the plane of the resulting section view is modified. It remains parallel to its previous orientation, yet there is a an inconsistency between the section view and the detail view defined on the previous plane view. As a consequence: • • • the detail callout becomes red, other callouts remain unchanged, all callouts can be edited.

If you create a detail view on the section view and translate the section callout without any visible impact on the resulting section view, the detail callout becomes red anyway and is editable.
Resizing of callouts

If you resize a section callout constrained by the supporting lines of the profile: • • any detail callout does not turn into red, it can be edited

Overloading Element Properties
This task will show you how to overload the properties of elements in a view generated from a CATProduct. A number of the properties that you can overload are originally defined as properties of the 3D product component, in the Product Structure workbench. For more information on specifying the properties that should be used for a 3D component when generating views, refer to Modifying Component Properties in the Product Structure User's Guide. Open the GEAR-REDUCER_GS.CATProduct document and the GEAR-REDUCER.CATDrawing document. 1. Right-click the section view A-A. 2. In the contextual menu, select Section view A-A object -> Overload properties. The Characteristics dialog box is displayed.
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Select the element (part instance) that you want to edit. This element is highlighted in the drawing and listed in the dialog box.

• • •

You can also select several elements, if you want to overload their properties in the same way. In the case of several elements generated from a single part instance, all these elements are highlighted when you select one. You can select the elements in the 3D document, either by selecting a node in the specification tree or by multi-selecting the elements in the specification tree.

3. Select the element you want to edit (as there is just one in our example, it is already pre-selected) in the dialog box and click the Edit button. The Editor dialog box is displayed.
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You can modify the following parameters: • Cut in section views: specifies that the 3D element will be cut in the section view, section cut or breakout view. Uncheck this option if you do not want an element to be cut in the view. • Use when projecting: specifies that the 3D element will be projected in the view. Uncheck this option if you do not want an element to be represented in the view (other 3D elements possibly hidden by this element in the view will then be visible in the view). • Represented with hidden lines: specifies that 3D hidden lines will be represented. • Shown: specifies that the dress-up (color, line type, etc.) associated to the 2D generated element will be shown. The view is not re-computed. • Graphic Properties area: lets you modify graphic properties such as element color, line type and line thickness. The Cut in section views, Use when projecting and Represented with hidden lines properties are originally defined as properties of the 3D product component. So it is actually the properties of the 3D component that you are overloading. In this case, the view is recomputed. If Graphic Properties only are modified, the view is not re-computed. 4. Uncheck Cut in section views. 5. Click OK to validate and exit the dialog box. 6. Back in the Characteristics dialog box, click Apply. A dialog box is displayed while the view is being re-computed. The selected element is not cut anymore.
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7. In the product's specification tree, select the Slow speed node. Back to the Drawing, the elements have been added to the Characteristics dialog box.

8. Select the last three elements in the list and click on the Edit button. 9. In the Editor dialog box select the red color in the Graphic properties drop down list. 10. Click OK to validate and exit the dialog box. 11. Back in the Characteristics dialog box, click Apply. A dialog box is displayed while the view is being re-computed.
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12. In the product's specification tree, press the Ctrl key and multi-select Motor adaptator and Roller bearing (Roller bearing.2) Back to the Drawing, the elements have been added to the Characteristics dialog box. 13. Select the last two elements in the list and click on the Edit button

14. In the Editor dialog box uncheck Shown. 15. Click OK to validate and exit the dialog box. 16. Back in the Characteristics dialog box, click OK again. A dialog box is displayed while the view is being re-computed.
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•

In the Characteristics dialog box, the Reset button allows you to recover the values you had before changing information in the Editor dialog box. In versions prior to V5 R13, in the case of faces overlapping with un-cut elements, the pattern area used to go over the projected faces and edges. From R13 onwards, the pattern area is now limited to the face sectioned on the part, as shown below. Previous behavior New behavior

•

You can also set the Drafting properties in the 3D document so that they are propagated in the 2D view. 17. In the 3D document, right-click on the Bearing (Part1.1) instance.

18. Select Properties in the contextual menu and click on the Drafting tab. The Drafting properties are displayed.
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19. Check Represented with hidden lines. . 20. In the CATDrawing, click on the Update icon The element is represented with hidden lines in the view.

There is two ways to activate the Drafting properties: • or • right-click the view and select Properties, then check 3D spec in the View tab. go to Tools->Options and check Apply 3D specifications in the View tab

Modifying a Pattern
This task will show you how to modify the pattern of a view. Patterns are used for area fills or, as is the case in this scenario, when cutting through material in section views/cuts or breakout views, for example.

Open the GenDrafting_exploded_isometric.CATDrawing document.
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1. Right-click the pattern to be modified. For the purpose of our scenario, select the hatching pattern in the Section view.

2. Select Properties from the displayed contextual menu. The Properties dialog box displays the view current pattern. 3. In the Properties dialog box that appears, click the Pattern tab.
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4. If you want to define your own pattern, choose a pattern type from the Type drop-down list: • • • • Hatching Dotting Coloring Image

Or if you want to choose from the various patterns available, click the [...] button. This will display the pattern chooser, from which you can make your selection. For the purpose of this scenario, select Dotting from the Type drop-down list. 5. In the Pitch field, type 5 mm. 6. From the Color drop-down list, select black, for example. 7. Uncheck the Zigzag field, and then click OK. The pattern is modified.
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•

•

Each part is assigned a specific pattern. Therefore, each time you modify a pattern using the Properties dialog box, all the patterns of the views generated from this part will be modified. These modifications will be applied to all existing sheets. Pattern properties are not persistent: for instance, after switching an exact view to the approximate mode, and vice versa, the pattern may change.

About part material patterns
• In the case of parts which use a material to which a specific pattern is associated, and depending on the standard used by the drawing, you may be able to recover the pattern which is associated to the part material on a section view, section cut or breakout view. However, note that this is not the case for section views, section cuts or breakout views generated using Approximate mode, as they do not inherit the material properties from the 3D, and therefore do not use the pattern associated to this material. For more information about associating a pattern to a material, please refer to the Real Time Rendering User's Guide. When editing the properties of a pattern associated with a part material, the software offers its own selection of patterns, and not the patterns defined in the standard. When editing the properties of a pattern associated with a part material, a specific button is available in the Properties dialog box: Reset using Part Material Pattern. When the original properties of the part material are modified, this button is activated to let you revert to the original part material pattern. For example, if you replace a pattern associated with a

• •
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part material by a pattern from the standard, then the generated pattern is considered as overloaded, and will not be updated if you modify the properties of the part material. In this case, you can always revert to the original part material pattern using the Reset using Part Material Pattern button. Hatching patterns are a combination of the angle and hatching lists available in the standard XML file: newly created patterns are based on the first hatching standard referencing successively the four values of the angle list, then the second hatching standard referencing successively the four values of the angle list, and so on, and so forth.

View Links
Modifying a View's Links
This task will show you how to modify the list of pointed elements for a view and resolve broken links. Open the GEAR-REDUCER_GS.CATProduct document. 1. Create a new drawing sheet and tile windows horizontally using the Window -> Tile Horizontally menu item. 2. Create a front view of the part.

3. Right click and select Front view object > Modify Links in the contextual menu. Link Modification dialog box is displayed. You can see the whole assembly is selected.
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4. In the 3D product, press the Ctrl key and select the following parts: • • • • • Roller bearing 1 Roller bearing 2 Slow speed shaft High speed shaft Motor adaptator

5. Back in the drawing, the parts have been added in the Link Modification dialog box.
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6. Click on Add all. 7. Check Preview to see what the 3D product looks like according to your selection.
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8. Click on OK. You can see that an update icon is displayed in the specification tree of the drawing.

9. Click on Update. The selected parts are displayed in the front view.
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10. Right click and select Front view object > Modify Links. Link Modification dialog box is displayed with links related to the parts.

11. Select Motor adaptator and click on Remove. 12. Click on Preview to visualize your 3D product.

13. Press the Ctrl key, then click on High speed shaft and Roller bearing 1.
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14. Click on Remove. The preview is updated.

15. Click on OK, then on Update. The front view is updated.

If you remove all the pointed elements, you are back to the step when you first created the front view of your product or your part.
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You can start selecting links again. 16. In the 3D product, press the Ctrl key and select the following parts: • • • Roller bearing 1 Roller bearing 2 High speed shaft

17. Back in the drawing, the parts have been added in the Link Modification dialog box.
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18. Click on OK, then on Update. 19. In the 3D product, delete Roller bearing 1. Broken links are displayed in the drawing specification tree.

20. Right click and select Front view object > Modify Links. A warning is displayed advising you to remove broken links.

21. Click on OK. The Link Modification dialog box is displayed with the broken link highlighted so that you can remove it.

22. Click on Remove. 23. Click on OK, then on Update: the drawing is updated accordingly. • As long as you do not remove broken links, you cannot modify the view at all. 239

drawingGeneration • If all links are broken and removed, you are back in the Link Modification dialog box, the whole assembly being selected.

• • •

All views must have the same 3D associated document. You can select products or subproducts if it is an assembly view, and bodies if it is a part view. If you want to modify links in your view when the related 3D document is not opened, you can only remove links.

• • •

Undo and Redo are disabled. If you perform a Modify Links on an exploded view, all the views generated from the assembly will be modified. For more information on exploded mode, refer to the Creating an Exploded View section. If you perform a Modify Links on a scene, you can select the scene only. Would you need to select products in your assembly, you need to remove the scene's link in the Link Modification dialog box, then select products or parts' links only. Remember you cannot mix scene links and products or parts' links.

Applying a View's Links to Another View
This task will show you how to apply a view's links to another view. Open the GEAR-REDUCER_GS.CATProduct document. Make sure no drawing is already open. 1. From the menu bar, select Start -> Mechanical Design. 2. Select the Drafting workbench. The New Drawing Creation is displayed with information on sheets that can possibly be created:

: empty sheet

: sheet containing all views,
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: sheet containing the front, bottom and right views,

: sheet containing the front, top and left views, as well as information on the drawing standards. 3. Select the All Views icon as shown below and click on OK.

4. Right click on the front view.

5. Select Front View object > Modify Links. The Link Modification dialog box is displayed.
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6. In the 3D product, press Ctrl key, then select Worm gear and Motor adaptator parts. Back in the drawing, the parts are both displayed in the Link Modification dialog box.

7. Click on Add all and then on OK to close the Link Modification dialog box. An update icon is displayed in the specification tree under the front view node.
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8. Click on Update. The front view is updated accordingly.

9. Right-click on the front View and select Front View object > Apply Links To. 10. Select the Bottom view.

An update icon is displayed in the specification tree under the bottom view node.

243

drawingGeneration

11. Click on Update: the view is updated accordingly.

• • •

Only one view can be selected. If you try to apply the same links to the view = warning. The view must have the same 3D associated document.

Generative View Styles
Generative View Style

See Creating a View using Generative View Styles

Creating a View using Generative View Styles
This task will show you how to create a view using generative view styles. Generative view styles are defined by an administrator and specify the appearance and behavior of a generated view.
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For the purpose of this scenario, you will create a front view using generative view styles, but you can use generative view styles to create any type of view. Open the GenDrafting_part.CATPart document. Define a new drawing sheet. 1. Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and uncheck the Prevent generative view style creation option. This activates the generative view style functionalities.

2. Click the Front View icon from the Views toolbar. The Generative View Style toolbar is automatically displayed.

3. Select one of the generative view styles available from the list. For example, select DefaultGenerativeStyle. The parameters defined in this file will be used when creating the view.

• The generative view styles available in the list refer to the external files that can be found in specific directories as explained in Administering Generative View Styles and Standards, as well as the generative view style files embedded in the drawing, but in case those files have the same name, only the embedded file is taken into account. • The Generative View Style toolbar is displayed when creating most view types. However, when creating advanced front views, this toolbar is not displayed. Instead, the View Parameters dialog box (which is displayed when creating advanced front views) features an additional list, which enables you to select a generative view style.
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4. In the 3D window, select a plane of the 3D part or a plane surface, to define the reference plane. 5. Click inside the sheet to generate the view.

The view is created using the selected generative view style. In our example, vidid edges are projected in black. Note that you may obtain a different result. This result depends on the parameters defined in the generative view style you selected.

Using the standards editor, you can check the parameters defined in the generative view style you selected. To do this, go to Tools -> Standards. In the standards editor, choose the generativeparameters category, and then open the DefaultGenerativeStyle.xml file from the drop-down list. Then, for example, go to DefaultGenerativeStyle -> Drafting -> ViewDressup -> GeneratedGeometry -> VividEdges, and select the Color parameter. You will see the what color is specified in your generative view style for the projection of hidden edges.
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Applying a Generative View Style to a View
In this task, you will learn how to apply a generative view style to a view which was created without one. Generative view styles are defined by an administrator and specify the appearance and behavior of a generated view.

Open the GenDrafting_front_view.CATDrawing document. This view was created without a generative view style.

1. Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and uncheck the Prevent generative view style creation option. This activates the generative view style functionalities.

2. Right-click the front view to display the contextual menu. 3. Select Front view object -> Generative View Style -> Set View Style. The Choose a style dialog box appears, displaying the list of generative views styles available.

The generative view styles available in the list depend on what your administrator specified. 4. Select a style and click OK. 5. Update the view by clicking the Update icon , for example.
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The view is updated. However, the selected style is not visible in the view yet. For the moment, the geometry is displayed in a specific color, because the original parameters of the view "overload" the generative view style parameters. (This means that the parameters of the selected generative view style have taken on the value of the parameters that were defined in the view before you applied the style to it.) You now need to reset the parameters of the generative view style to their original values in order for the new style to be visible in the view.

6. Right-click the front view to display the contextual menu once again. 7. Select Properties. The Properties dialog box is displayed. 8. On the View tab, in the Dress-up area, an asterisk * appears in front of the parameters which are considered as being overloaded.

The list in the Generative view style area shows the generative view style which is applied to the view.

9. Click the Reset to style values button, and then click OK to validate and exit the Properties dialog box.
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The view is updated once again and the parameters defined in the selected generative view style are reset to their original values and are applied to the view. In our example, hidden edges are projected in orange, with a different linetype and thickness than previously. Note that you may obtain a different result. This result depends on the parameters defined in the generative view style you selected.

Applying a Generative View Style to a View
In this task, you will learn how to apply a generative view style to a view which was created without one. Generative view styles are defined by an administrator and specify the appearance and behavior of a generated view.

Open the GenDrafting_front_view.CATDrawing document. This view was created without a generative view style.

1. Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and uncheck the Prevent generative view style creation option. This activates the generative view style functionalities.

2. Right-click the front view to display the contextual menu. 3. Select Front view object -> Generative View Style -> Set View Style. The Choose a style dialog box appears, displaying the list of generative views styles available.
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The generative view styles available in the list depend on what your administrator specified. 4. Select a style and click OK. 5. Update the view by clicking the Update icon , for example.

The view is updated. However, the selected style is not visible in the view yet. For the moment, the geometry is displayed in a specific color, because the original parameters of the view "overload" the generative view style parameters. (This means that the parameters of the selected generative view style have taken on the value of the parameters that were defined in the view before you applied the style to it.) You now need to reset the parameters of the generative view style to their original values in order for the new style to be visible in the view.

6. Right-click the front view to display the contextual menu once again. 7. Select Properties. The Properties dialog box is displayed. 8. On the View tab, in the Dress-up area, an asterisk * appears in front of the parameters which are considered as being overloaded.
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The list in the Generative view style area shows the generative view style which is applied to the view.

9. Click the Reset to style values button, and then click OK to validate and exit the Properties dialog box.

The view is updated once again and the parameters defined in the selected generative view style are reset to their original values and are applied to the view. In our example, hidden edges are projected in orange, with a different linetype and thickness than previously. Note that you may obtain a different result. This result depends on the parameters defined in the generative view style you selected.

Applying a Generative View Style to a View
In this task, you will learn how to apply a generative view style to a view which was created without one. Generative view styles are defined by an administrator and specify the appearance and behavior of a generated view.
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Open the GenDrafting_front_view.CATDrawing document. This view was created without a generative view style.

1. Go to Tools -> Options -> Mechanical Design -> Drafting -> Administration tab, and uncheck the Prevent generative view style creation option. This activates the generative view style functionalities.

2. Right-click the front view to display the contextual menu. 3. Select Front view object -> Generative View Style -> Set View Style. The Choose a style dialog box appears, displaying the list of generative views styles available.

The generative view styles available in the list depend on what your administrator specified. 4. Select a style and click OK. 5. Update the view by clicking the Update icon , for example.
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The view is updated. However, the selected style is not visible in the view yet. For the moment, the geometry is displayed in a specific color, because the original parameters of the view "overload" the generative view style parameters. (This means that the parameters of the selected generative view style have taken on the value of the parameters that were defined in the view before you applied the style to it.) You now need to reset the parameters of the generative view style to their original values in order for the new style to be visible in the view.

6. Right-click the front view to display the contextual menu once again. 7. Select Properties. The Properties dialog box is displayed. 8. On the View tab, in the Dress-up area, an asterisk * appears in front of the parameters which are considered as being overloaded.

The list in the Generative view style area shows the generative view style which is applied to the view.

9. Click the Reset to style values button, and then click OK to validate and exit the Properties dialog box.

253

drawingGeneration

The view is updated once again and the parameters defined in the selected generative view style are reset to their original values and are applied to the view. In our example, hidden edges are projected in orange, with a different linetype and thickness than previously. Note that you may obtain a different result. This result depends on the parameters defined in the generative view style you selected.

Dimension Generation
Dimension Generation
The Generative Drafting workbench provides a simple method for generating dimensions. Generated dimensions are associative to the elements created from a part or an assembly.

Before you begin: All you need to know before you start generating dimensions. Generate dimensions in one shot: Generate dimensions in one shot from the constraints of a 3D part (distance, length, angle, radius and diameter constraints). Filter dimensions to be generated: Set filters before dimension generation using the Dimension Generation Filters dialog box. Generate dimensions semi-automatically: Generate dimensions step by step from the constraints of a 3D part (distance, length, angle, radius and diameter constraints). Analyze generated dimensions: Perform an analysis of generated dimensions via the Generated Dimensions Analysis dialog box. Position dimensions: Position dimensions (either generated dimensions or interactive dimensions) in a better way and on the active view exclusively. Analyze interfering dimensions: Analyze dimensions that were generated and possibly re-positioned (Positioning icon) on the active view. Driving 3D constraints via generated dimensions: Drive a 3D constraint via a 2D dimension that was generated from it.
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Before you begin
This section provides the relevant information you need when performing dimensions generation, whichever command you activate to do so. In other words, the rules described in the following section are valid either when performing a Dimension Generation in One Shot or a Semi-Automatic Dimension Generation.

First of all, make sure you customize the dimension generation settings settings via Tools -> Options -> Mechanical Design -> Drafting -> Generation tab.

How are Generated Dimensions Positioned?
Generated dimensions are positioned according to the views that are most representative. In other words, a dimension will appear on a view so that this dimension needs not be also created on another view. Generated dimensions will be positioned according to the following criteria: 1. on the view on which the dimension may be generated. 2. on the view on which the dimension is better visualized. For example, a view on which elements are visualized in non-hidden lines instead of hidden lines. 3. on the view with a bigger scale. 4. on views including more dimensions. The dimensions are generated on the views on the condition the appropriate settings were previously activated in Tools -> Options -> Mechanical Design -> Drafting -> Generation tab.

What About the Dimensions that may be Generated from Constrained 3D Elements?
To make sure the dimensions you need to handle in your session are those expected, here is a list presenting the constrained 3D elements and the resulting associated dimensions after generation. Note that for views that are generated from surfaces, only sketched constraints are generated.

Constrained 3D Elements Sketcher 3D part Features:

Generated Dimension Types All dimensions: angle, distance, radius, diameter Angle, distance The dimensions below:
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User-defined Pad Pocket Shaft/Groove Hole: - Simple

All published dimensions of elements included in the user-defined feature Distance Distance Angle Constraints and associated dimensions:

- Tapered

- Counterbored

- Countersunk

- Counterdrilled

- Threaded Fillet constraint variable Shell Thickness Stiffener Assembly constraints

Radius/Radii Distance Distance Distance All assembly dimensions

About threaded hole dimensions A fractional dimension is generated for threads/taps defined in a 3D part which use standards with fraction as a symbolic representation (e.g. G1/8). This dimension is a fake dimension. It will be displayed using the
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color configured for fake dimensions in Tools -> Options -> Mechanical Design -> Drafting -> Dimension tab, Analysis Display Mode category. Note that although it is a fake dimension, it always updates properly. When using ISO standard values, the dimension displayed is a real one (displayed as Mxx) and is based on a key. When using personal standards including a thread description field, a fake dimension is displayed. If the description field does not contain any value, a real dimension is used, based on the key and the value of the nominal diameter. For more information about Threaded Holes and standards, refer to the Creating Threaded Holes section in the Part Design User's Guide.

Generating Dimensions in One Shot
Before you begin, make sure you customized the following settings: Dimension generation: Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the Analysis after generation option.

This task will show you how to generate dimensions in one shot from the constraints of a 3D part. Only the following constraints can be generated: distance, length, angle, radius and diameter. Constraints may be of three kinds: created manually (i) via the sketcher or (ii) via the 3D part, or else (iii) automatically created via internal parameters.

Open the GenDrafting_front_view.CATDrawing document. Open the GenDrafting_part.CATPart document.

1. Click the Generate Dimensions icon (Dimension Generation sub-toolbar).

from the Generation toolbar

The dimensions are automatically generated on the front view, which in this particular case, is the only view in the drawing. In the case of drawings with several views, by default, dimensions are generated on all the views. To generate dimensions on specific views, simply select these views prior to generating dimensions. The selected views will be automatically highlighted, and dimensions will be generated on the selected
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views only.

Drawing view with generated 3D part with displayed dimension dimensions and one selected dimension: corresponding to the dimension selected on the drawing view:

The Generated Dimensions Analysis dialog box showing the dimensions and constraints generated for each part (in this case, there is only one) is automatically displayed.
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2. Click OK to close the dialog box.

The generated dimensions are positioned according to the most representative views. In other words, a dimension will appear on a view so that this dimension needs not be also created on another view.

Filtering Dimension Generation
This task will show you how to set filters before dimension generation using the Dimension Generation Filters dialog box.

Open the GEAR-REDUCER.CATProduct and the GEAR-REDUCER.CATDrawing documents. Tile your windows horizontally to view both your drawing and the related part. To do this, select Window -> Tile Horizontally from the menu bar. Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the Filters before generation option. This automatically launches the dimension generation filters before generating dimensions.
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1. By default, dimensions will be generated on all views. If you want to generate dimensions on a specific view, select this view. 2. Click the Generate Dimensions icon Generation sub-toolbar). from the Generation toolbar (Dimension

The Dimension Generation Filters dialog box is automatically displayed.
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The Dimension Generation Filters dialog box displays the parameters and filters that you can use for dimension generation, lists the elements for which dimensions will be generated, and specifies how many constraints there are for each listed element. Let's describe the dialog box more precisely: Type of constraint These options let you specify what type of constraints you want to generate dimensions from in your drawing. • • • • Sketcher constraints: generates dimensions from constraints created in the Sketcher workbench. 3D constraints: generates dimensions from 3D constraints (for instance an Offset between two planes). Assembly constraints: generates dimensions from assembly constraints. This option is active only in the case of products or assemblies. Measured constraints: generates dimensions from measured constraints.

Options These options let you generate additional dimension types. • ...associated with un-represented elements: generates dimensions from
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drawingGeneration constraints associated with elements that are not represented on the drawing (i.e. which are not visible in the various views your drawing may contain). In this case, the generated dimensions will appear as not attached to any element in the drawing. ...with design tolerances: generates dimensions from constraints with design tolerances, and applies the constraint tolerance to the corresponding generated dimension.

•

Other • Retrieve excluded constraints: retrieves all the constraints which you when previously excluded (either using the Not Generated icon performing a step by step generation, or by removing a generated dimension from the drawing), and re-generates the dimension. This icon is active only when there are dimensions to retrieve. • • Add all parts: adds all parts that belong to the selected product or assembly to the list. This button is active only in the case of products or assemblies. Remove: removes the selected element from the list. Dimensions will not be generated for this element.

By default, only the product is displayed in the list of elements for which dimensions will be generated, and only the Assembly constraints and Measured options are active: if you left the dialog box as is, dimensions would only be generated from the product assembly constraints and measured constraints. 3. You will now add additional elements to generate dimensions for. You have two possibilities: • If you want to generate dimensions for specific elements only: in the drawing, select each element for which you want to generate dimensions. The elements you select are added to the list.

•

If you want to generate dimensions for all elements, click the Add all parts
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When the same part is used several times within a given product (as is the case for Bearing (Part1.1) in this scenario), generations for this part are generated only once, for a single part instance (instead of being generated for all part instances). By default, dimensions are generated on the part instance which is the first in the product specification tree. If you want to generate dimensions on a specific part instance, you need to select this instance. 4. Unselect the 3D constraints option to specify that dimensions from 3D constraints should not be generated. You can notice that the list is updated with the proper number of constraints for each element.
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5. Click OK. The dimensions are generated on the drawing.

Depending on whether the Analysis after generation option was selected in Tools-
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5. Click OK to close the Generated Dimension Analysis dialog box.

Generating Dimensions Semi-Automatically
Before you begin, make sure you customized the following settings: Dimension generation: Go to Tools->Options->Mechanical Design->Drafting, and click on the Generation tab. Check the Analysis after generation option. This task will show you how to generate dimensions step by step from the constraints of a 3D part. Only the following constraints can be generated: distance, length, angle, radius and diameter. Constraints may be of three kinds: created manually (i) via the sketcher or (ii) via the 3D part, or (iii) automatically created via internal parameters. Open the GenDrafting_part.CATDrawing. In this sample, constraints were manually created.

1. Select the views on which you want to generate dimensions. For example,
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the front view. 2. Click the Generate Dimensions Step by Step icon toolbar (Dimension Generation sub-toolbar). from the Generation

The Step-by-step generation dialog box displays and will remain displayed until the end of the dimension generation.

3. Check the Visualization in 3D button to see the constraints corresponding to the dimensions to be created on the views. 4. Check the Timeout option. The default timeout is set to two seconds (2s). Enter the timeout value you need for example, three seconds (3s). 5. Click the Next Dimension Generation switch button dimension generation. Dimensions appear one after the other on the views. Now, you might need to pause the generation for modifying the dimension position for example. 6. Click the Pause in Dimension Generation switch button is paused. 7. Select the dimension to be modified. . The generation to start the
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8. Drag the dimension to its new position.

Note that, at this step (pause), you can perform all kinds of modifications, not only on the current dimension but also to other dimensions, before the dimension generation. You can select not only the current dimension but also other dimensions.

•

You want the dimension last generated before you clicked the Pause in Dimension Generation switch not to be generated on the view? Perform as follows: 1. Click the Not Generated option dialog box. in the Step by Step Generation

The constraint is automatically excluded and the dimension will not
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generated.

•

You want the currently generated dimension to be transferred (via Transfer icon)? Perform as follows: 1. Click the Transfer icon from the Step-by-Step Generation dialog box. 2. Select the frame of the view in which the current dimension, or the dimension last created, is to be pasted.

•

You want to modify the graphical attributes of the current dimension? Perform as follows:

You simply need to apply the desired attributes in the required Properties toolbar. 9. Click again the Next Dimension Generation switch button the process. The dimensions are automatically generated on all the views. The dimensions appear as shown, for example, on the front view documented in this particular case. and continue
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The Generated Dimensions Analysis dialog box showing the dimensions and constraints generated for each part (in this case, there is only one) is automatically displayed. This dialog box is described in detail in Dimension Generation Analysis.
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Note that you can stop at anytime the generation by clicking contrary, accelerate the process by clicking .

or, on the

Positioning Dimensions (View per View)
This task will show you how to position distance and length dimensions (either generated dimensions or interactive dimensions) in a better way. These dimensions will be positioned on the active view exclusively.

Open the GenDrafting_part_ positioningdim.CATDrawing document.

In addition, select the View -> Toolbar -> Positioning option from the menu bar in order to have the necessary toolbar (Positioning toolbar) displayed in the workbench.

1. Click the Dimension Positioning icon Positioning toolbar. OR

from the

1. Select Tools -> Positioning -> Dimension Positioning... from the menu bar. The dimensions are automatically re-positioned.
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If you want to have dimension interferences analyzed, use the Dimension Analysis icon (or select Tools->Analyze->Dimension Analysis from the menu bar). You will thus be able to visualize and manage interfering dimensions.

Analyzing Interfering Dimensions
This task will show you how to analyze dimensions that were generated and possibly re-positioned (Positioning icon) on the active view.

Open the GenDrafting_part_ positioningdim02.CATDrawing document. In addition, select the View -> Toolbar -> Analyze option from the menu bar.

1. Click the Dimension Analysis from the Analyze icon toolbar. OR 1. Select Tools -> Analyze -> Dimensions Analysis from the menu bar.
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The Analyze dialog box appears with the following options:

•

List with all the annotations badly placed/Optimized list with the annotations badly placed You can choose to have either a whole or a filtered list with the interfering elements Total number of elements in the current list As you choose the above list type, the total number of interfering elements is automatically updated Number of the pointed element You are provided a number for the element currently pointed as an interfering element Scanner (Start, Before, Update, Next, End) You can navigate among the list of interfering elements

• • •

The interfering dimensions are automatically displayed in the red orange color. Small circles allow visualizing the interference location.
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2. Select Optimized list with the annotations badly placed option. 3. Click the Next switch .

4. Start modifying the dimension positions one after the other. Note that you may either reposition one dimension or either delete or copy this dimension, if needed. View with interfering dimension View once the interfering dimension has been (Number 3): deleted:

The Analyze tool is designed to analyze basic interfering elements, thus it does not take into account advanced dimension manipulation such as leaders lines that might have been interrupted previously.

Driving 3D Constraints via Generated Dimensions
In this task, you will learn how to drive 3D constraints via generated dimensions.
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The Types and colors of dimensions dialog box lets you select the colors you want to assign to driving dimensions. Select the colors shown below, for example.

On the Administration tab, make sure that the Prevent dimensions from driving 3D constraints option is not selected.

Open the Pinmounting.CATPart document.

Open the GenDrafting_drive_3dconstraints.CATDrawing document.
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1. On the front view, double-click the dimension which defines the top radius (Dimension.5 object). The Constraint Definition dialog box appears.

2. Type 30 in the radius field to change the radius definition, and click OK. The dimension is edited.
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3. On the top view, double-click the dimension which defines the rounded corner radius (Dimension.1 object). The Parameter Definition dialog box appears.

4. Type 30 in the value field, and click OK. The dimension is edited.

5. In the CATPart window, click the Update button part is updated and reflects your modifications:

to update the part. The

6. In the CATDrawing window, click the Update button to update the drawing. The drawing is updated with the latest modifications in the part:
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Dimension Manipulation
Dimension Manipulation
The Generative Drafting workbench enables you to create and modify dimensions. Note that dimension commands are actually provided with the Interactive Drafting workbench. Therefore, this section of the documentation actually points to the Interactive Drafting User's Guide. As such, the information detailed in this section is presented in an Interactive Drafting context.

If you want to manipulate dimensions in a Generative Drafting context, you can openthe GenDrafting_part.CATDrawing document. These dimensions will be associative to the elements created from a part or an assembly. When created, these elements are associated with a view. Note that for views that are generated from surfaces, only sketched constraints are generated.

Before you begin: You should be familiar with basic concepts. Create dimensions: Create dimensions by clicking elements.
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Create half-dimensions: Create half dimensions on distance, angle, diameter, cylinders, diameter edges and diameter tangents but not on cumulate dimensions. Create cumulated dimensions: Create cumulated dimensions on a view using selection. Create stacked dimensions: Create stacked dimensions using selection.

Create explicit dimensions: Create dimensions using explicit selection both of the desired icon and of the required geometrical elements.

Create/modify angle dimensions: Create an angle dimension and perform the following kinds of modifications: new angle sector or turn an angle sector into a supplementary sector. Create chamfer dimensions: Create a chamfer dimension using selection. Create associative thread dimensions: Create associative thread dimensions. Create/modify coordinate dimensions: Automatically create coordinate dimensions on elements. Create a holes dimensions table: Create a table containing holes dimensions (diameter and center coordinates). Create points coordinates table: Create a table containing 2D and 3D points coordinates. Create/modify radius curvature dimensions: Create and modify a radius curvature dimension. This lets you know the curvature radius at a given point on a curve (spline, ellipse, etc.). Create overall curve dimensions: You can create dimensions on the overall size of any kind of curve, whether it is canonical or not (e.g.: line, circle, ellipse, spline, etc.). You can also create dimensions on the overall size between 2 curves, or between a curve and a line, for example. Create curvilinear length dimensions: You can create dimensions for the curvilinear length of a curve, i.e. measure the overall length of a curve. Create dimensions along a reference direction: You can create dimensions along a direction of measure. In other words, you can measure the projection of a segment/distance onto a direction. Create dimensions between intersection points: You can create dimensions between an intersection point and an element or between two intersection points. Create dimensions between an element and a view axis: Create dimensions between an element and a view axis (one of the two axes or the origin). Modify the dimension type: Modify the dimension type as you create a dimension. On other words, you modify the dimension attributes. Re-route dimensions: Re-route dimensions, i.e. recalculate dimensions taking into account new geometry elements.
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Interrupt one or more extension lines: Interrupt manually one or more extension lines of one or more dimensions, either using the contextual menu or the Insert menu bar option. Modify the dimension line location: Use the mouse to modify dimension line location either before or after creating dimensions. Modify the dimension value text position: Use the cursor to modify dimension value text position. Specify the dimension value position: Automatically or explicitly position the dimension value inside or outside the area between extremity symbols. Add text before/after the dimension value: Insert text before or after the dimension value. Modify the dimension overrun/blanking: Use the Blanking Edition dialog box to modify dimension overrun or blanking. Line up dimensions (free space): Line up dimensions relatively to a point in the free space. Line up dimensions (reference): Line up dimensions according to a given reference. Create a datum feature: Use the Datum Feature Creation dialog box to create a datum feature. Modify a datum feature: Modify a datum feature by editing it. Create a geometrical tolerance: Use the Geometric Dimensioning And Tolerancing Parameters dialog box to create geometrical tolerances. Modify a geometrical tolerance: Use the Geometric Dimensioning And Tolerancing Parameters dialog box to modify geometrical tolerances. Copy a geometrical tolerance: Copy an existing geometrical tolerance and then edit the content for creating a new one. Create driving dimensions: Create dimensions that will drive associated constrained geometry.

Creating Associative Thread Dimensions
This task will show you how to create associative thread dimensions. Open the thread.CATDrawing document.

1. Click the Thread Dimension icon sub-toolbar).

from the Dimensioning toolbar (Dimensions
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2. In the front view, select the thread to be dimensioned. The thread diameter dimension appears.

If necessary, you can modify the orientation of this dimension: right-click it and select Dimension1.object->Dimension Representation->Force Horizontal Dimension in View

(or Force Vertical Dimension in View 3. Click the Thread Dimension icon again.

).

4. In the section view B-B, select just one of the two lines representing the thread to be dimensioned.

5. Two thread dimensions appear, representing the thread diameter as well as the thread depth.

6.
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User Tasks • • In top views, you can modify the orientation of threads dimensions. The dimension prefix (M in this example) is issued from the thread description, defined when creating the hole in the 3D part. Be aware that de-selecting the Thread option from the Properties dialog box (available via Edit -> Properties) will make the thread dimension loose its associativity. It will appear as being not up-to-date (using the color defined for Not up-to-date dimensions in the Types and colors dialog box, available via Tools -> Options -> Mechanical Design -> Drafting -> Dimension tabTypes and colors... button in the Analysis Display Mode area, and provided the Activate analysis display mode option is checked.) Subsequently re-selecting the Thread option from the Properties dialog box will not make the thread dimension associative again and it will still appear as being not up-to-date. You will need to re-create the dimension.

•

Technological Feature Dimensions
Before you Begin
There are a few things you should know before you begin creating technological feature dimensions. Technological feature dimensions let you create dimensions for technological features such as electrical harness or structural stiffeners, or between technological features such as structural stiffeners. Technological feature dimensioning relies on the fact that technological features can specify the way they should be dimensioned, which allows you to create only realistic and customized dimensions, based on the know-how of a given discipline. Depending on the type of feature that you will be dimensioning, you need specific product licenses to create technological feature dimensions. For more information on the availability of technological feature dimensioning for a given workbench, refer to the related documentation.

Action/object and Object/action Mode
Technological feature dimensioning is available in action/object mode (i.e. selecting the command first and then the feature to dimension) and in object/action mode (i.e. selecting or multi-selecting the feature(s) to dimension and then selecting the command).

Technological Feature Dimensions icons
Several Technological Feature Dimensions icons are available from the Technological Feature Dimensions sub-toolbar.
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•

creates any type of technological Technological Feature Dimensions feature dimension (intra or inter) specified by the feature, depending on the option selected in the Tools palette. create either Multiple Intra Technological Feature Dimensions icon the intra-technological feature dimension type specified by the feature when only one is specified, or the preferential intra-technological feature dimension type specified by the feature when several are specified. Chained Technological Feature Dimensions icon create either the inter-technological feature dimension type specified by the feature when only one is specified, or the preferential inter-technological feature dimension type specified by the feature when several are specified. Length Technological Feature Dimensions Feature Dimensions , Angle Technological

•

•

•

, Radius Technological Feature Dimensions

and Diameter Technological Feature Dimensions create a specific dimension type when the feature specifies several dimension types. Using one of these options is particularly useful when you want to create a dimension type other than the preferential type specified by the feature.

Contextual menu
At any time during the dimension creation, you can right-click a technological feature to display a contextual menu.

This contextual menu is particularly useful when several dimension types can be created for a given feature. This depends on what is specified by the feature. • • • • Optional choices, available when several dimension types are available for the selected feature or features, let you specify a single dimension type that you want to create, out of all the types available. The All option creates all available dimensions for all selected features. The None option creates none of the available dimensions for all selected features. The Show Panel option lets you display the Technological Feature Dimensioning Selection dialog box.
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Technological Feature Dimensioning Selection dialog box
The Technological Feature Dimensioning Selection dialog box lets you select precisely the types of dimensions that you want to create for a given feature. This dialog box is particularly useful when several dimension types are available for a given feature (especially when creating inter-feature dimensions). • • From the list area, you can select the types of dimension that you want to create for a given feature or de-select those that you want to delete. You can also use the Create drop-down list. The default option, (Selected), creates the dimension types selected from the list area above. The All option creates all available dimensions for all selected features. The None option deselects all available dimensions for all selected features. The Hide button lets you hide the Technological Feature Dimensioning Selection dialog box.

•

When a feature is checked and grayed out as shown below, it means that not all dimensions available for this feature have been selected.

You can also show or hide the Technological Feature Dimensioning Selection dialog box using the Show Panel icon available in the Tools Palette.

Limitations
You cannot create coordinate, stacked and curvilinear dimensions for technological features.

Creating Intra-Technological Feature Dimensions

283

drawingGeneration

This task will show you how to create dimensions for technological features such as electrical harness. You need an Electrical Harness Assembly license for the purpose of this scenario as we will be dimensioning Electrical Harness Assembly features. Intratechnological feature dimensioning is also available for other applications such as Structure Functional Design or Ship Structure Detail Design. For more information on the availability of technological feature dimensioning for a given workbench, refer to the related documentation. Refer to Before you Begin for general information about technological feature dimensions. Open the ElectricalAssembly.CATProduct document and make sure it is loaded in the Electrical Harness Assembly workbench (if necessary, select Start -> Equipment & Systems -> Electrical Harness Assembly to launch the workbench). Open the ElectricalAssembly.CATDrawing document. 1. Click the Multiple Intra Technological Feature Dimensions icon from the Dimensioning toolbar, Technological Feature Dimensions sub-toolbar.

You can also click the Technological Feature Dimensions icon and then select the Multiple Intra Technological Feature Dimensions icon from the Tools Palette.

2. Select the feature that you want to dimension. Note that the name of a feature is displayed as a help as you move the cursor over it.

The dimension is created as specified by the feature. In this specific 284
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example, the bundle segment specifies that the dimension should provide its overall length. The dimension creation command remains active.

3. Repeat step 2 for each additional feature that you want to dimension. 4. End the dimension creation by clicking anywhere in the drawing (but not on a technological feature) or by lining-up the dimension. The intrafeature dimensions are created as specified by the feature. You can now handle the dimension(s) just like any other dimension.

Creating Inter-Technological Feature Dimensions
This task will show you how to create dimensions between technological features such as structural stiffeners. You need a Structure Functional Design or a Ship Structure Detail Design license for the purpose of this scenario as we will be dimensioning Structure features. Inter-
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technological feature dimensioning may also be available for other applications. For more information on the availability of technological feature dimensioning for a given workbench, refer to the related documentation. Refer to Before you Begin for general information about technological feature dimensions. Open the MemberForDim.CATDrawing document. For your information, this document references the MemberForDim.CATProduct document. You do not need to open this product. 1. Click the Chained Technological Feature Dimensions icon from the Dimensioning toolbar, Technological Feature Dimensions sub-toolbar.

You can also click the Technological Feature Dimensions icon select the Chained Technological Feature Dimensions icon Palette.

and then from the Tools

2. Select Ref_FunStiffener_002 as the first feature for dimensioning. Note that the name of a feature is displayed as a help as you move the cursor over it. 3. Select Ref_FunStiffener_001 as the second feature.

A preview of the dimension is displayed. The dimension creation command
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remains active. 4. Right-click to display the contextual menu. 5. Select Angle between supports (true dimension). The next dimension will be created between the previously selected feature (i.e. the second feature you selected) and the next feature you select. 6. Select the third feature.

You can also right-click to view the various types of dimensions you can create between the features. For the purpose of this scenario, leave Distance between parallel supports (true dimension) selected. 7. Optionally move the dimension to position it as wanted. 8. When done, click in the drawing (but not on a technological feature) to create the dimension. The inter-feature dimensions are created as specified by the feature. You can now handle the dimensions just like any other dimension.
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Note that the dimension arrow is automatically oriented according to the direction of material (in this case, the stiffener's molded side), which is the case when dimensioning structural features.

Annotations
The Generative Drafting workbench lets you manipulate annotations. Note that annotation commands are actually provided with the Interactive Drafting workbench. Therefore, this section of the documentation actually points to the Interactive Drafting User's Guide. As such, the information detailed in this section is presented in an Interactive Drafting context.

If you want to manipulate annotations in a Generative Drafting context, you can openthe GenDrafting_part.CATDrawing document.
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In order to be consistent with the way commands have been grouped in toolbars and sub-toolbars, the following tasks are documented in the Manipulating Dimensions chapter: • • Datum Feature Creation and Modification Geometrical Tolerance Creation, Modification and Copy

See Before you begin to learn about important concepts, including setting text properties.

Before you begin: You should be familiar with basic concepts such as setting the properties of a text (font style, size, justification, etc.), using default values, and specifying the position and/ or orientation of a text. Create a free text: Create a text that either wraps or not, that is assigned an unlimited width text frame, even though this text may reach the frame boundary. Create an associated text: Create a text which you want to be and remain associated to an existing element. Make an existing annotation associative: At any time and once an annotation has been created, you can add a link between an annotation and another element. Create a text with a leader: Create a text with a leader either in the free space or associated with an element. Add a leader to an existing annotation: Add a leader to an annotation that was previously created. Handle annotation leaders: Add or remove breakpoints, extremity or interruptions. Move and position leader breakpoints. Add frames and sub-frames to existing text: Add a frame or a sub-frame to a text that was previously created. Replicate a text and attribute: Replicate text as well as the corresponding text attribute. Copy text graphical properties: Copy the text graphical properties of an annotation or element to other elements. Create a datum target: Create a datum target on a view. Modify a datum target: Modify a datum target by editing it in a dialog box. Create a balloon: Create a balloon using a dialog box. Creating an associative balloon on a generated product view: Create associative balloons on views generated from a product. Modify a balloon: Modify a balloon using a dialog box. Create a roughness symbol: Create a roughness using a dialog box. Create a welding symbol: Create a welding symbol using a dialog box. Create a geometry weld: Create a geometry weld symbol. Modify annotation positioning: Assign new positioning to existing annotations.
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Create/modify a table: Create, edit and modify a table. Find/replace text: Locate and then, if needed, replace strings of characters. Perform an advanced search: Use the advanced search command. Query object links: Query object links in a drawing. Adding attribute links to text: Add one or more attribute links between text that was previously created.

Dress-Up Elements
The Generative Drafting workbench enables you to create a number of view dress-up elements on existing 2D elements. Note that dress-up commands are actually provided with the Interactive Drafting workbench. Therefore, this section of the documentation actually points to the Interactive Drafting User's Guide. As such, the information detailed in this section is presented in an Interactive Drafting context.

Still, you can openthe GenDrafting_part.CATDrawing document and thus manipulate dress-up elements in a Generative Drafting context. This dress-up will be associative to the elements created from a part or an assembly. When created, these elements are associated with a view.

• •

If you delete generated center lines, threads or axis lines, you will be able to generate them again thanks to the Restore deleted option from the contextual menu. If you delete in 3D the geometry on which dress-up elements are based, these dress-up elements will be permanently deleted when you update the drawing (an update operation cannot be undone). This has a consequence on existing annotations or dimensions (i.e. annotations or dimensions that were created on such a dress-up element prior to its deletion): o annotations will be no longer be linked to anything. o dimensions will appear as being not-up-to-date. Note that you can re-route dimensions to geometry when relevant.

Create center lines (no reference): Apply a center line to one or more circles. Create center lines (reference): Apply a center line to one or more circles with respect to a reference (linear or circular). Modify center lines: Modify one or more center lines at one or more end(s) of this/these center lines. Create threads (no reference): Create a thread without a reference.
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Create threads (reference): Create a thread with a reference, either circular (circle or point) or linear (line). Create axis lines: Create an axis line by selecting lines. Create axis lines and center lines: Create an axis line by selecting lines. Create an area-fill: Create an area fill, i.e. a closed area on which you will then apply graphical dress-up elements called patterns (these can be hatching, dotting or coloring). Patterns can be applied to area fills created from both sketched and generated elements. Create arrows:Create an arrow.

Properties
This section discusses how to quickly access and edit information on 2D geometry, dress-up elements, annotations and dimensions in a single dialog box, provided you use the Edit -> Properties contextual command. The data you can access (tabs) depends on the element you select. Note that clicking the More switch gives you access to more tabs. Note that properties are actually documented in the Interactive Drafting User's Guide. As such, the information detailed in this section is presented in an Interactive Drafting context. When information specific to Generative Drafting is introduced, this will be specified.

Edit sheet properties: Access and edit sheet properties. Editing view properties: Access and edit view properties. Editing 2D geometry feature properties: Access and edit information on 2D geometry features (name and stamp). Editing 2D element graphic properties: Access and edit graphic properties. Edit pattern properties: Access and edit pattern properties. Editing annotation font properties: Access and edit annotation font properties. Editing text properties: Access and modify text color, position and/or orientation. Editing dimension text properties: Access and edit dimension text properties. Editing dimension value properties: Access and edit dimension value properties. Editing dimension tolerance properties: Access and edit dimension tolerance properties. Editing dimension extension line properties: Access and edit dimension extension line properties. Editing dimension line properties: Access and edit information on dimension line properties. Editing dimension system properties: Access and edit information on dimension system properties. Editing 2D component instance properties: Access and edit 2D component instance properties.
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Collaboration
Interoperability
The Generative Drafting workbench provides a simple method to create and modify views from a .model.

Create and modify views from a .model: Use a master model exact solid to create and modify views from a .model.

Images
The Generative Drafting workbench lets you add images to Drafting sheets as well as edit them. Note that image commands are actually provided with the Interactive Drafting workbench. Therefore, this section of the documentation actually points to the Interactive Drafting User's Guide. As such, the information detailed in this section is presented in an Interactive Drafting context.

Insert images: Insert raster or vector images in a drawing. Edit images: Edit raster images using the raster editor, or view information about vector images.

Printing
The Generative Drafting workbench provides a simple method for printing one or more sheets inserted in your document. Note that print is actually documented in the Interactive Drafting User's Guide.

Print a sheet: Quickly print a given sheet. Print using a clipping operator: Print using a clipping operator with scaling support. Lets you print only a part of a drawing.

Creating and Modifying Views from a .Model
This task will show you how to create and modify views from a .model document on the condition this model contains Exact Solids, Skins or Faces in the master workspace.

Open pm6-7b-1e_gun_body_draw.model. This model contains an Exact Solid in the master workspace. Tile the windows vertically to see your drawing sheet and your model at the same time.
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1. Create a front view from the .model document. 2. Create projection views. The views are generated.

• • •

The only modifications you can perform on views generated from .model documents are dress-up modifications. In certain cases, dress-up modifications applied to .model documents are not associative. When creating views from .model documents, you can only select a V4 Face element (*FAC) if it lies on a V4 plane. You cannot select a V4 Face element which lies on a V4 surface (even if this surface is planar).

Elements from .model documents are handled differently depending on their type and on the type of view you are generating: • In section cuts and section views: Exact Solid, Dittos, Face and Skin elements from .model documents are supported in exact mode. • In breakout views: Exact Solid and Dittos elements from .model documents are supported in exact mode. • In projection views, quick detail views, clipping views and broken views: Exact Solid, Dittos, Face and Skin elements from .model documents are supported in exact mode. All elements from .model documents are supported in CGR, approximate and raster mode.
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File Export and Import
The Generative Drafting workbench lets you export and import different types of files. Note that these tasks, which deal with data exchange, are actually documented in the Data Exchange Interfaces User's Guide.

DXF/DWG: Import: Import or insert the 2D geometric data contained in a DXF or DWG file into a CATDrawing document. DXF/DWG: Export: Export the data contained in a CATDrawing document into a DXF file. DXF/DWG: Report File: Learn more about the report file. DXF/DWG: Trouble Shooting: Learn how to troubleshoot DXF/DWG import and export. DXF/DWG: Best Practices: Learn best practices for DXF/DWG import and export. DXF/DWG: FAQ: Get answers to Frequently Asked Questions about DXF/DWG import and export. DXF/DWG: VBScript Macros: Learn about DXF/DWG import and export macros. CGM: Insertion: Insert a CGM file into a CATDrawing document. CGM: Export: Export the data contained in a CATDrawing document into a CGM file.
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Workbench Description
This section contains the list of the icons and menus specific to Generative Drafting workbench. You may read these pages whenever you require more detailed information on these commands which have been documented in other parts of the guide.
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Menu Bar Generative Drafting Toolbars CATDrawing Specification Tree Icons

Menu Bar
In this chapter we will describe the various menus, submenus and items specific to the Generative Drafting workbench.

File
For... Page Setup... Print... Printer Setup... See... Defining the Drafting Sheet Printing a Sheet Printing a Sheet

Edit
For... See...

Links

Editing Drawing Links Positioning a View Independently of its Reference View
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Properties

Background

Access and edit information on 2D geometry, dress-up elements, annotations and dimensions in a single dialog box Creating a Frame Title Block

Insert
For... Views Drawing Dimensioning Generation Annotations Dress Up See... Creating Views Creating Sheets Creating Dimensions Generating Dimensions Annotations Dress-Up Elements

New sheet New Detail Sheet

Define a Drafting Sheet Create a 2D component
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New View Instantiate 2D Component

Create views Re-use a 2D component

Dimensions Chained Dimensions Cumulated Dimensions Stacked Dimensions

Create dimensions Create chained dimension systems Create cumulated dimension systems Create stacked dimension systems

Length/Distance Dimensions

Create explicit dimensions

Angle Dimensions

Create explicit dimensions

Radius Dimensions

Create explicit dimensions
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Diameter Dimensions

Create explicit dimensions

Chamfer Dimensions Thread Dimension

Create chamfer dimensions Creating Associative Thread Dimensions

Coordinate Dimensions

Create coordinate dimensions

Hole Dimension Table

Creating a Hole Dimension Table

Coordinate Dimension Table

Creating a Points Coordinates Table

Technological Feature Dimensions

Before you Begin
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Re-route Dimension

Re-routing Dimensions

Create Interruption

Interrupt one or more extension lines

Remove Interruption

Interrupt one or more extension lines

Datum Feature Geometrical Tolerance

Create a datum feature Create a geometrical tolerance
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Generate Dimensions Generate Dimensions Step by Step

Generate dimensions in one shot Generate dimensions semi-automatically

Balloon generation Bill of Material

Generating Associative Balloons Generating a Bill of Material

Text Text with Leader

Create a free text Create a text with a leader
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Text Replicate Balloon Datum Target

Replicate a text attribute Create a balloon Create a datum target

Text Template Placement

Annotating Drawings Using Text Templates

Roughness Symbol Welding Symbol Weld

Create a roughness symbol Create a welding symbol Create a geometry weld
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Table Table From CSV Add Leader

Creating/Modifying a Table Creating/Modifying a Table Adding a Leader to an Existing Annotation

Center Line Center Line with Reference Thread Thread with Reference Axis Line Axis line and Center line

Create center lines (no reference) Create center lines (reference) Create threads (no reference) Create threads (reference) Create axis lines Create axis lines and center lines

Tools
For... See...
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drawingGeneration Positioning Analyze Multi View (2.5 D) Dimension generation Import a generative view style Reset All Defaults Import External Format Further down Further down Further down Further Down Before you begin Before You Begin: Exporting and Importing a File

Element Positioning Line-up Align into System Dimension Positioning

Modifying annotation positioning Line up dimensions (free space) Line up dimensions (reference) Aligning a Dimension System Position dimensions
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Show Geometry in All Viewpoints Dimensions Analysis

Showing Geometry in Views Analyzing Interfering Dimensions
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Multiple View Projection View Plane Definition

Creating a Multiple View Projection Defining the View Plane
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Filters Analysis

Filtering Dimension Generation Analyzing Generated Dimensions

Generative Drafting Toolbars
Generative Drafting Toolbars
This section describes the various icons of the Generative Drafting workbench. The toolbars are located on each side of the workbench in the default set-up. A number of toolbars available in the Generative Drafting workbench are actually part of the Interactive Drafting workbench. These toolbars are also listed below but they are documented in the Interactive Drafting User's Guide.

Annotations Dress-Up Tools Tools Palette Geometry Creation

Add annotations to existing views by creating them Add dress-up elements on the drawing Activate display and positioning tools Use specific options or value fields available for a given command Create geometry
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drawingGeneration Transform existing 2D elements and add constraints to elements on the drawing Modify the text properties Modify the graphic properties of all kind of features Modify the dimensions properties Set the style that will be used to create a new object

Geometry Modification Properties Text Properties Graphic Properties Dimension Properties Style

Generative Drafting Toolbar Drawing Views Generative View Style Dimension Generation Interactive Drafting Toolbar Dimensioning

Purpose Create sheets, views, 2D components and frame title blocks Create different kinds of views Specify the generative view style that should be used when creating views Generate dimensions and balloons Purpose Create all types of dimensions needed for your drawing

Drawing

See Manipulating the Drafting Sheet See Creating a 2D Component See Re-using a 2D component See Creating a 2D Component See Add a generative Bill of Material

308

Workbench Description

Views

See Creating a Front View See Creating an Advanced Front View See Creating an Unfolded View See Creating Projection Views See Creating an Auxiliary View See Creating an Offset Section View/Offset Section Cut See Creating an Offset Section View/Offset Section Cut See Creating an Aligned Section View/Aligned Section Cut See Creating an Aligned Section View/Aligned Section Cut
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See Creating a Quick Detail View/Quick Detail View Profile See Creating a Detail View/Detail View Profile See Creating a Detail View/Detail View Profile See Creating a Clipping View See Creating a Clipping View See Creating an Isometric View See Creating a Broken View See Creating a Breakout View See Creating Views via the Wizard See Creating Views via the Wizard

Generative View Styles
The Generative Drafting workbench lets you use generative view styles, which are administrator-defined and specify the appearance and behavior of a generated view. For more information on the administration of generative view styles, refer to the Administration Tasks chapter in the Generative Drafting User's Guide.

Create views using generative view styles: Create views using generative view styles. Switch a view to another generative view style: Switch a view which uses a given generative view style to another style. Apply the generative style of a view to another view: Apply the generative view style used to create a given view to another view. Apply a generative view style to a view: Apply a generative view style to a view which was created without one.

Dimension Generation

See Dimensions Generation in One Shot See Semi-automatic Dimension Generation
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See Generating Balloons

Generation Utilities

See Edit 3D Attributes See Color Geometry by Attributes See Linking a text to an attribute See Update the Current Sheet from Attribute Changes See Setting Layers and Graphic Properties Based on Rules See Position a View at the Origin

CATDrawing Specification Tree Icons
This section describes the various icons of the Interactive Drafting and Generative Drafting workbenches. Current drawing Design sheet Detail sheet 2D component View. Applies to interactive views only (whatever the view type is). Front view. Applies to generative views only. Projection view. Applies to generative views only. Auxiliary view. Applies to generative views only. Isometric view. Applies to generative views only. Section view. Applies to generative views only. Section cut. Applies to generative views only. Detail view. Applies to generative views only. Unfolded view. Applies to generative views only.

Masks Specific to Drafting Applications
Unreferenced drawing. The link between the drawing and the 3D part or product is broken. Does not apply to drawings which contain only
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drawingGeneration interactive views. Unreferenced sheet. The link between the sheet and the 3D part or product is broken. Does not apply to sheets which contain only interactive views. Unreferenced view. The link between the view and the 3D part or product is broken. Does not apply to interactive views. Locked view. (Note that a locked view cannot be updated. Therefore, locked views which are not up-to-date will not be applied the corresponding mask.)
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Modifying Layer Extraction Rules

Administrators can customize the rules used by the set graphic properties based on rules or 3D layers map to 2D drawing layers, line weights, and line types. This taks will show you how to

Layer extraction rules, like all project standards, can be modified interactively within Digital Projec This task shows how to modify the rules interactively while providing enough information about the files directly. Prerequisites. • • • Familarity with attributes Facility with XML Understanding of XML Project Standards files

1. Open the project standards window by selecting Tools -> Standards... from the menu.
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2. In the project standards window, select generativeparameters from the category dropdown. F modify. These styles are always XML files. Select Standard -> GenerativeStyleName -> Drafti

Under 2D to 3D rules, there are three distinct lists of rules. 3D Layers Part Names Attributes

Transfer 3D layers to 2D layers. Map all geometry in a particular part to a specific layer. Map all geometry with a certain attribute package or with certain attribute
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3D to 2D rules assign drafting geometry to layers by layer number. These layer names should be c Category: General, File:CATDftStdLayersAndFilters.xml within the project standards. For inst layers as the default layers defined in this XML file. Similarly, all lineweights and linetypes correspo drafting standard (e.g. UDS, ANSI).

3. Select one of the rule lists to modify. If you select the list in the left panel, two buttons appear i

Click Add instance to add a rule.

4. Each rule type has slightly different parameters to modify. Below are the types of rules that you 3D Layers Part Names

2D layer number that this rule maps geometry to 3D layer number that this rule 3D Layer Number maps geometry from number of line weight of Line Weight resulting geometry (per drafting standards -> linethicknesses) number of line type of resulting Line Type geometry (per drafting standards -> Line Types) Number

Number Part Name

Line Weight

Line Type

2D layer number that this rule maps geometry to Part name appearing in the sepcification tree that this rule maps from number of line weight of resulting geometry (per draftin standards -> linethicknesses) number of line type of resulting geometry (per drafting standar -> Line Types)
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5. After you have modified these rules, click OK. Digital Project will save these standards and you

Administration Tasks
Before you begin
About Generative View Styles
Generative view styles let you customize the appearance and behavior of a generated view via a set of pre-defined parameters and options. Administrators can create one or several generative view styles from which users can choose when creating a generative view. Generative view styles are defined in an XML file.

Some workbenches (such as the Structure Design workbench, for example) also offer the possibility of configuring generative view styles. These styles will be specific to views generated from this workbench, and will specify the appearance of the geometry to be generated. To know if a given workbench supports generative view styles, refer to its documentation.
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Management of Generative View Styles
One generative view style per view
When you create a view using a generative view style, you specify the XML file that will be associated with this view. Within a drawing, you can only associate one generative view style to a given view, but you can use several generative view style files by associating different files to different views.

Standalone drawings
The values of the parameters in the specified XML file are embedded into the CATDrawing document when a generative view style is applied to a view. Each drawing contains an embedded copy of the generative view style(s) it uses. The drawing is therefore standalone. This makes it possible for users, projects, or companies to exchange CATDrawing documents without needing to send the generative view style file along.

Administrator-controlled access and modification
The administrator defines and controls the location of the generative view style files as well as the ability to modify existing ones. For example, the administrator can define a single generative view style, and prevent users from modifying it.

Administrator-controlled authorized styles
The administrator defines the list of authorized generative view styles, in the Drafting standards XML file.

A generative view style file available by default
By default, a pre-defined generative view style file is delivered. This file is located in install_root/resources/standard/generativeparameters/DefaultGenerativeStyle.xml. Administrators can customize this file to define their default generative view styles. They can also use this file as a template for creating new generative view styles. They can add as many generative view style files as needed. Refer to Administering Generative View Styles for more information.

Do not delete the DefaultGenerativeStyle.xml file: it contains all generative view style parameters. Furthermore, it is used as a default if a parameter happens to be missing from a custom view style file (in this case, the corresponding parameter defined in DefaultGenerativeStyle.xml will be used instead). In case the DefaultGenerativeStyle.xml file cannot be found, then the application will use its own default parameter instead.

Editing the generative view style file
The generative view style files can be edited using an interactive editor. This editor
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drawingGeneration provides an easy-to-use graphic interface to let you customize the parameters included in the generative view style file. For information on how to customize the parameters included in the generative view style file, refer to Setting Generative View Style Parameters. The interactive editor is available in Tools -> Standards. (It is the same editor with which you can customize the Drafting standards). For more information on how to use this editor, refer to the Customizing Standards chapter in the Infrastructure User's Guide.

Make sure you use the Standards editor available in Tools -> Standards when modifying and customizing the XML generative view style files. Using other editors (such as text editors) may alter the consistency of the generative view style XML files, and may make them unusable.

Import of a newer version of a generative view style file
Once a generative view style has been assigned to a view, it is embedded into the drawing. This means that if you update the generative view style file that was used to create the view, the style of the view itself will not be modified and will remain as it was when the view was created. To modify the style used by the view, you need to import the newer version of the generative view style XML file into the drawing. To do so, select Tools -> Import a generative view style. In the dialog box which is displayed, select the generative view style to import and click OK. Note the following points: • • The newer, imported generative view style will completely override the older version of the generative view style in all views which use this generative view style. If the drawing contains views which use other generative view styles, these views will not be affected by the import.

Importing a newer version of a given generative view style file will be useful to ensure that views created on a previous release using the generative view styles provided by default with the application benefit from the new styles parameters that were added in the latest release.

To sum-up
Creation of a view with a generative view style is as follows: 1. You create View 1 using the generative view style defined in Style1.xml. 2. As a consequence, Style1.xml is embedded into the drawing. 3. Then, when a given parameter cannot be retrieved from Style1.xml, DefaultGenerativestyle.xml is embedded into the drawing.
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4. Finally, the missing parameter is retrieved from DefaultGenerativestyle.xml If a given parameter cannot be retrieved from the default xml file, a pre-defined and non modifiable value is used instead.

Import of a generative view file is as follows: 1. View 1 has been created using the generative view style defined in Style1.xml that was embedded into the drawing. 2. You import External Style1.xml and the current xml file is removed. 3. As a consequence View1 refers to imported Style1.xml.
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Using Generative View Styles
Creating views using generative view styles
When generating a view from the 3D, users can choose to use one of the styles defined by the administrator. Refer to Creating Views Using Generative View Styles.

Switching a view to another generative view style
Once a view has been created using a specific generative view style, it is possible to switch this view to another view style. Refer to Switching a View to Another Generative View Style.

Applying the generative style of a view to another view
You can apply the generative view style used to create a given view to another view. Refer to Applying the Generative Style of a View to Another View.

Applying a generative view style to a view
You can apply a generative view style to a view which was created without one. Refer to Applying a Generative View Style to a View After its Creation.

Administering Generative View Styles and Standards
This task documents the administration of both generative view styles (Generative Drafting workbench) and standards (Interactive Drafting workbench), as the procedure is basically the same whether you are administering generative view styles or standards. The examples provided in this task specifically deal with the administration of generative view styles. For more information on customizing and administering standards, refer to the Administration Tasks chapter in the Interactive Drafting User's Guide.

Location of generative view style files or standard files
The location of generative view style files or standard files is defined by two environment variables which can be set during installation or modified afterwards: Variable name CATCollectionStandard Description Path and name of the directory (or
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directories) which contains: • the generativeparameters subdirectories (which themselves contain the customized generative view styles). It is in these generativeparameters subdirectories that you should add the generative view styles customized for a company, project or user. the drafting sub-directories (which themselves contain the customized drafting standards). It is in these drafting sub-directories that you should add the drafting standards customized for a company, project or user.

•

CATDefaultCollectionStandard Path and name of the directory (or directories) which contains: • the generativeparameters subdirectories (which themselves contain the predefined generative view styles delivered by Dassault Systemes). the drafting sub-directories (which themselves contain the predefined drafting standards delivered by Dassault Systemes).

•

The default location for this directory (set during the installation process) is the installation directory install_root resources standard.

Setting the location of generative view style files
Refer to the Administration Tasks chapter in the Interactive Drafting User's Guide for specific information on how to set the location of generative view style files. There are two possibilities: • If you want to place all customized generative view styles in a custom directory, named mydirectory for example, you need to proceed as follows: 1. Create a directory named as you like (mydirectory, for
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drawingGeneration example). 2. Create a sub-directory under this directory, which needs to be named generativeparameters. 3. Place the XML files containing your customized generative view styles in mydirectory • generativeparameters.

If you have not yet customized your XML generative view style files, then proceed as follows: 1. Create a directory named as you like (mydirectory, for example). 2. Create a sub-directory under this directory, which needs to be named generativeparameters. 3. Set the CATCollectionStandard variable to mydirectory. After you have customized the XML generative view style files, the standard editor will then save them in mydirectory generativeparameters.

•

•

If the CATDefaultCollectionStandard and the CATCollectionStandard variables both contain an identically-named generative view styles, it is always the style found in CATCollectionStandard which will be used. If two directories referenced by the CATCollectionStandard and/or CATDefaultCollectionStandard variables contain identically-named generative view style files, it is always the style in the directory listed first which will be used.

Customizing and defining generative view styles or standards
To edit and save generative view style files or standard files in Tools -> Standards, you must be running the V5 session in administrator mode (admin). The recommended method for customizing generative view style files or standard files is the following: 1. You need to work in administrator mode. To do this, proceed as follows: a. Set up the CATReferenceSettingPath variable. b. Start a V5 session using the -admin option. For more information, refer to the Managing Environments chapter in the Infrastructure Installation Guide. 2. Set up the CATCollectionStandard environment variable as explained above. If none of the conditions are respected, a warning message will appear
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Project Standards to let you know that you will neither be able to modify nor save the XML files. 3. Modify the generative view styles or the Drafting standards as appropriate. 4. Use the Save As or the OK button to store your modifications. 5. To exit, use the Cancel button. Once the generative view style files or the standard files have been customized and saved, they can be used in a V5 session in normal mode.

Setting Generative View Style Parameters
Setting Generative View Style Parameters
The Generative Drafting workbench lets you set generative view style parameters that are specific to Drafting applications.

Before you begin: You should be familiar with important concepts such as the structure of generative view styles, how to customize generative view style parameters, and what type of restrictions apply to generative view styles. Generate parameters: Specifies whether the elements will be projected in the view or not. View dress-up parameters: Defines the style of the various parameters which deal with the dress-up of the view.

Before you begin
This section deals with the following subjects: • • • Structure of the Generative View Styles Generative View Styles and View Generation Customizing Generative View Style Parameters

Structure of the Generative View Styles

A generative view style file is structured as a tree, as it appears in the Standard Definition dialog box (available via Tools -> Standards). It contains several main sections, one of which is specifically devoted to customizing generative view styles for Drafting: Standard -> DefaultGenerativeStyle -> Drafting.
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This section contains sub-sections, each dealing with a specific aspect of drafting customization: • • Generate parameters: specifies whether the elements will be projected in the view or not. View dress-up parameters: defines the style of the various parameters which deal with the dress-up of the view.

The other sections are specific to certain workbenches. For more information about these, refer to the corresponding documentation (e.g. for information regarding the parameters under the SheetMetal node, see the Generative Sheetmetal Design User's Guide).

Generative View Styles and View Generation
All generative view styles apply to views generated in exact mode. On top of that, when creating other view types (CGR, Approximate and Raster), some generative view style parameters also apply, as detailed below: • Generate parameters: HiddenLines and Using3DSpec apply to CGR,
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Project Standards Approximate and Raster view types. View Dress-Up parameters: o Operators: all parameters under Detail and Break apply to CGR, Approximate and Raster view types. o 3DInheritance: all parameters under Solid apply to Raster view types. o GeneratedGeometry: all parameters under VividEdges and HiddenEdges apply to CGR and Approximate view types.

•

Customizing Generative View Style Parameters
In this scenario, you will learn how to customize generative view style parameters using a specific example. The pre-defined DefaultGenerativeStyle.xml file specifies that hidden edges should be displayed in black, using a specific linetype and thickness. You will modify these parameters so that hidden edges are displayed in orange, for example, and using a different linetype and thickness.

Open the GenDrafting_part.CATPart document. Select Tools -> Standards to launch the Standard Definition dialog box. Choose the generativeparameters category, and then open the DefaultGenerativeStyle.xml file from the drop-down list.

1. In the editor, expand the following nodes successively: Standard -> DefaultGenerativeStyle -> Drafting -> ViewDressup -> GeneratedGeometry -> HiddenEdges. 2. Select the Color parameter. 3. Set the color to orange, for example by choosing another color from the drop-down list in the right-hand pane. 4. Select the Linetype parameter. 5. Set the linetype to 4, for example by choosing another linetype number from the drop-down list in the right-hand pane. Note: Linetypes are defined in Tools -> Options -> General -> Display -> Linetype tab. 6. Select the Thickness parameter. 7. Set the thickness to 2, for example by choosing another thickness number from the drop-down list in the right-hand pane. Note: To define a thickness, select Tools -> Standards to launch the Standard Definition dialog box. Choose the drafting category, and then open the [StandardFile].xml file from the drop-down list. In the editor, expand the following nodes successively: Standard -> [StandardFile] -> Line Thicknesses. 8. Click OK to save your modifications and exit the standards editor. 9. Define a new drawing sheet.

325

drawingGeneration

10. Create a front view. The view is generated, taking into account the parameters you defined.

Generate Parameters
Generate parameters are located in the Drafting -> Generate nodes of the generative view style XML file. They specify whether the elements should be projected in the view.

Parameter

AxisLines

CenterLines

Fillets

HiddenLines

Remark For more information on axis lines, please refer to Properties available on Specifies whether Yes/No axis lines should be Generative Views in the Editing View Properties projected. section of the Interactive Drafting User's Guide. For more information on center lines, please refer to Properties available on Specifies whether Yes/No center lines should be Generative Views in the Editing View Properties projected. section of the Interactive Drafting User's Guide. For more information on fillets, please refer to Properties available on None / Boundaries / Defines the fillet Generative Views in the OriginalEdges / representation mode. Editing View Properties ProjectedOriginalEdges section of the Interactive Drafting User's Guide. Specifies whether For more information on Yes/No hidden lines should hidden lines, please refer be projected. to Properties available on

Value

Description
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Project Standards Generative Views in the Editing View Properties section of the Interactive Drafting User's Guide. For more information on threads, please refer to Properties available on Specifies whether Generative Views in the threads should be Editing View Properties projected. section of the Interactive Drafting User's Guide. For more information on 3D points, please refer to Specifies whether 3D Properties available on Generative Views in the points should be Editing View Properties projected. section of the Interactive Drafting User's Guide. For more information on wireframe, please refer to Properties available on Specifies whether wireframe should be Generative Views in the Editing View Properties projected. section of the Interactive Drafting User's Guide. Replaced by 3DInheritance parameters in styles provided since V5R12. Specifies whether colors defined in 3D should be kept. For more information on 3D colors, please refer to Properties available on Generative Views in the Editing View Properties section of the Interactive Drafting User's Guide. For more information on Specifies whether 3D Spec, please refer to Drafting specifications Properties available on applied to assembly Generative Views in the instances (cut, use, Editing View Properties hidden lines) should section of the Interactive be used. Drafting User's Guide.

Threads

Yes/No

3DPoints

Yes/No

Wireframe

Yes/No

Using3DColors

Yes/No

Using3DSpec

Yes/No

View Dress-Up parameters
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View dress-up parameters are located in the Drafting -> ViewDressup nodes of the generative view (available in Tools -> Standard -> generativeparameters category -> *.XML file). They define the style of the various parameters which deal with the dress-up of the view. There are various kinds of dress-up parameters: • • • Operators 3D Inheritance GeneratedGeometry

When computing dress-up parameters, they are either retrieved from the 3D graphic attributes, or projected element. Refer to How are dress-up parameters computed? below for more information o

Operators
Parameter Parameter Name Visible Color Linetype Thickness Value yes/no color integer integer Description

Section

Specifies whether or not the section profile sh Determines the color of the section profile. Determines the linetype used for the section p Determines the line thickness used for the sec

Section -> SkinSection

Color Linetype Thickness

The section profile parameter is displayed in red. color Determines the color of the skin section profile integer Determines the linetype used for the skin sect integer Determines the line thickness used for the ski
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Section -> SolidSection

Color Linetype Thickness

color integer integer

Determines the color of the solid section profil Determines the linetype used for the solid sec Determines the line thickness used for the sol

Detail

Visible Color Linetype Thickness

yes/no color integer integer

Specifies whether or not the detail profile shou Determines the color of the detail profile. Determines the linetype used for the detail pro Determines the line thickness used for the det
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Break

Visible Color Linetype Thickness

yes/no color integer integer

Specifies whether or not the break profile sho Determines the color of the break profile. Determines the linetype used for the break pr Determines the line thickness used for the bre

Breakout

Visible Color Linetype Thickness

yes/no color integer integer

Specifies whether or not the breakout profile s Determines the color of the breakout profile. Determines the linetype used for the breakout Determines the line thickness used for the bre

3DInheritance
Parameter Wireframe Parameter Name Color Linetype Thickness Color Linetype Thickness Value Description

yes/no Specifies whether wireframe color should be inherite yes/no Specifies whether wireframe linetype should be inhe yes/no Specifies whether wireframe thickness should be inh

Solid

yes/no Specifies whether solid color should be inherited from yes/no Specifies whether solid linetype should be inherited f yes/no Specifies whether solid thickness should be inherited
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3D Points

Color Symbol

yes/no Specifies whether 3D points color should be inherited yes/no Specifies whether 3D points symbol should be inheri

GeneratedGeometry
Parameter VividEdges Parameter Name Color Value color Description Determines the color of vivid edges. 331

drawingGeneration Linetype Thickness

integer Determines the linetype used for vivid edges. integer Determines the line thickness used for vivid e

HiddenEdges

Color Linetype Thickness

color Determines the color of hidden edges. integer Determines the linetype used for hidden edge integer Determines the line thickness used for hidden

Fillets

Color Linetype Thickness

color Determines the color of fillets. integer Determines the linetype used for fillets. integer Determines the line thickness used for fillets.
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Wireframe

Color Linetype Thickness

color Determines the color of wireframe. integer Determines the linetype used for wireframe. integer Determines the line thickness used for wirefra

3DPoints

Symbols

integer Determines the symbol used for 3D points.
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How are dress-up parameters computed?

Dress-up parameters, when computed, are either retrieved from the 3D graphic attributes, or depe projected element. The graph below explains this in detail:
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Inheritance versus 3D type

Inheritance versus fillets and hidden lines

Inheritance versus wireframe
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Properties versus "functional" role (1)
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Properties versus "functional" role (2)

Customizing Settings
Customizing Settings
Before you start your first working session, you can customize the way you work to suit your habits. This type of customization is stored in permanent setting files: these settings will not be lost if you end your session. Note that some settings apply to Generative Drafting only, while others apply to Interactive Drafting only. Such cases are specified.
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1. Select Tools -> Options. The Options dialog box is displayed. 2. Choose the Mechanical Design category in the left-hand box. 3. Select the Drafting sub-category. Various tabs are displayed.

o o o o o

General lets you set general settings to be used in the Generative Drafting workbench. Layout lets you customize options that will be used when creating views or when adding sheets. View lets you customize geometry, dress-up and view generation options that will be used when generating views (Generative Drafting workbench only). Generation lets you customize options for controlling dimension and annotation generation (Generative Drafting workbench only). Geometry lets you customize options that will be used when creating 2D geometry, whether using autodetection (or SmartPick) or not, or still adding constraints to this geometry. Dimension lets you customize options that will be used when creating or repositioning dimensions. Manipulators lets you visualize options that will be used for manipulators whenever creating or modifying dimensions (Interactive Drafting workbench only). Annotation and Dress-Up lets you customize options that will be used when creating annotations. Administration lets you customize options for the management of drawings.

o o

o o

4. Set options in these tabs according to your needs. 5. Click OK in the Options dialog box when done.

General

This page deals with the following categories of options in the General tab: • • • • • • • Ruler Grid Rotation Colors Tree View Axis Start Workbench
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Ruler

Show ruler
Select this option to display the ruler in your sheet. It means you visualize the cursor coordinates as you are drawing. By default, this option is not selected.

Grid

Display
Select this option to display the grid in your session. Note that this option is also available via the Tools toolbar. By default, this option is selected.

Snap to point
Select this option if you want geometry (as well as 2D components) to begin or end on the various intersection points of the grid. Note that this option is also available via the Tools toolbar. By default, this option is selected. From V5 R15 onwards, this option no longer applies to annotations. Now, only the Snap by default (Shift toggles) setting is used to specify whether snapping should be activated by default for annotations. For more information, refer to Annotation and Dress-up.

Allow Distortions
Select this option to apply different graduations and spacing between H and V. By default, this option is selected.
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Primary spacing: H & V
The Primary spacing field lets you define the spacing between the major lines of the grid. To define your grid, enter the values of your choice in the H and/or V fields. By default, primary spacing is set to 100 mm.

Graduations / H & V
The Graduations field lets you set the number of graduations between the major lines of the grid, which actually consists in defining a secondary grid. To define your grid, enter the values of your choice in the H and/or V fields. By default, graduations are set to 10.

Rotation

Rotation Snap Angle
Specify the angle that should be used when rotating text elements (text, frame, or leader) using snapping. In other words, this option defines the snapping value used when rotating an element using the Select or Rotate commands. By default, rotation snap angle is set to 15 deg.

Automatic Snapping
Select this option to use snapping automatically when rotating an element. By default, this option is not selected.

Colors (for pre-V5R14 drawings)

These options apply to drawings created with versions prior to V5R14. For drawings created with V5R14 onwards, sheet and detail backgrounds colors are
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defined in the standard file, under the node Sheet colors of General node.

Sheet background
Choose the color that will be used for the sheet background. By default, the color is white.

Detail background
Choose the color that will be used for the background of 2D components. By default, the color is white.

Graduated color
If you want the sheet background and/or the detail (i.e. 2D component) background to be graduated, select the associated box. By default, these options are not selected.

Tree

Display parameters
Select this option to display in the specification tree the formula parameters used in the drawing. By default, this option is selected.

Display relations
Select this option to display in the specification tree the relation parameters used in the drawing. By default, this option is selected.

View axis
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Display in the current view
Select this option if you want the view axis to be displayed when you activate a view. By default, this option is selected.

Zoomable
Select this option if you want to be able to zoom view axes (as you can do with geometry). By default, this option is selected.

Reference size
Enter the size that you want to use as a reference to display view axes size. By default, the reference size is 30 mm.

Start Workbench

Hide new dialog box when starting workbench
Select this option if you want to hide the New Drawing dialog box (in the case of Drafting) and the New Layout dialog box (in the case of 2D Layout for 3D Design) when you start the workbench. By default, this option is not selected.

Layout

This page deals with the following categories of options in the Layout tab: • • View Creation New Sheet
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• •

Background View Section / Projection Callout

View Creation

View name
Select this option if you want the view name to be created automatically when creating views. By default, this option is selected.

Scaling factor

Select this option if you want the scaling factor to be created automatically when creating views. By default, this option is selected.

View frame

Select this option if you want the view frame to be created automatically when creating views. By default, this option is selected.

Propagation of broken and breakout specifications
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Select this option if you want broken and breakout specifications to be reproduced. By default, this option is not selected.

Auxiliary and section views orientation according to profile

Select this option if you want auxiliary and section views to be oriented according to the profile. In this case, the X axis will be parallel to the profile. Be aware that this setting is a default value, i.e. the setting used when creating the view is stored by the view and cannot be edited via the view's properties (available via Edit > Properties). This setting drives the angle of the view in the sheet. So if the auxiliary/section view profile is modified, the view rotation angle will be modified accordingly. By default, this option is not selected.

View axis system based on 3D axis system
Select this option if you want the axis system of the generated view to be based on the axis system of the 3D part. This enables you to create views with the same orientation if, when creating two views in the same projection plane by selecting two different faces, the axis systems which are specific to these faces are different. For example, take the following part:

With the View axis system based on 3D axis system option not checked, the view orientation will be different depending on the element selected in the 3D when creating the view:
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View orientation when a face of the rectangular pad is selected

View orientation View orientation when the when a face of absolute XY plane is the elliptic pad is selected selected

With the View axis system based on 3D axis system option checked, the view orientation will always be the same, no matter what element is selected in the 3D when creating the view: View orientation when either a face of the rectangular pad, a face of the elliptic pad, or the absolute XY plane is selected

By default, this option is not selected.

New sheet

Copy background view
Select this option if you want a background view to be copied into newly created sheets. By default, this option is selected.

Source sheet

Specify whether you want the source sheet for the background view to be the first sheet of the current drawing, or a sheet from another drawing by selecting the appropriate option.
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By default, the option is First sheet.

Background view

Directory for frame and title block
You can specify the path to the directory containing the frame and title block macros. By default, the path is install_root/VBScript/FrameTitleBlock.

Section/Projection Callout

Size not dependent on view scale
Select this option if you do not want the size of projection and section callout elements to be dependent on the view scale. This option will apply to newly created callouts, i.e. selecting this option will not have any impact on existing callouts. Note that this option only applies to drawings created with versions prior to V5 R11 (i.e. versions up to V5 R10). By default, this option is selected.

View
This page deals with the following categories of options in the View tab: • • • • Geometry generation / Dress-up View generation Clipping view View from 3D

These options do not apply to the Interactive Drafting workbench.
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Geometry generation / Dress-up
This category of options lets you specify what kind of geometry and dress-up elements you want to generate when generating views.

Generate axis
Select this option to generate axis lines. By default, this option is not selected.

Generate threads
Select this option to generate threads. By default, this option is not selected.

Generate center lines
Select this option to generate center lines. By default, this option is not selected.

Generate hidden lines
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Select this option to generate hidden lines. By default, this option is not selected.

Generate fillets

Select this option to generate fillets. By default, this option is selected. Additionally, click the Configure button to configure fillet generation. You can choose to generate either of the types of fillets described below. By default, Boundaries is selected.

Boundaries Thin lines, representing the mathematical limits of the fillets. Boundaries will not be projected if they correspond to two faces which are continuous in curvature. They will be projected only if they correspond to a smooth edge which is situated between two faces whose curvature radii vary. This mode will be used automatically to represent a connection between two faces which are not joined by a fillet, no matter what option you select.

Symbolic Original edges, projected in a direction that is normal to each corresponding surface.

348

Project Standards

Approximated Original Edges Original edges, at the intersection of the two surfaces joined by the fillet.

Projected Original Edges Original edges, projected on fillet surfaces in the direction of the view projection. This projection mode is equivalent to the CATIA V4 fillet projection mode. The following restrictions apply to Symbolic, Approximated Original Edges and Projected Original Edges: • • Dimensions on such fillets are not associative. Such fillets cannot inherit 3D colors (see below). Likewise, when using generative view styles, such fillets cannot inherit the 3DInheritance view dress-up parameters (defined in Tools -> Standard -> generativeparameters > *.XML file, Drafting -> ViewDressup -> 3DInheritance).

Inherit 3D colors
Select this option if you want the colors of a part to be automatically generated onto the views. In the case of white parts, the views generated with this option selected will be white, and will therefore not be displayed properly. By default, this option is not selected.

Project 3D Wireframe
Select this option to visualize both the wireframe and the geometry on generated views. By default, this option is not selected. Additionally, click the Configure button to configure the 3D wireframe projection mode. You can choose whether projected 3D wireframe can be hidden (in some cases, depending on the projection angle, part or all of 3D wireframe will possibly be hidden) or is always visible (3D wireframe will be
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Project 3D Points
Select this option to project points from 3D (no construction element). By default, this option is not selected. Additionally, click the Configure button to select the type of points visualized in the projected drawing. In the 3D Point Projection dialog box, you can choose between keeping the symbols that are used in the 3D or using a new symbol.

By default, the X symbol is selected.

Apply 3D specification
Select this option to specify whether, in an assembly, the properties assigned to given parts (also called components) will be applied in the view. The following 3D specifications may be defined for components in the Product Structure workbench: • The component will, or will not, be cut when projected in section views (Do not cut in section views). • The component will, or will not, be projected in views (Do not use when projecting). • The component will, or will not, be represented with hidden lines (Represented with hidden lines). For more information, refer to Modifying Component Properties in the
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View Linetype
Click the Configure button to configure linetypes and thicknesses for specific types of views: section view, detail view, broken view, breakout view, skin section view (in the case of wireframes and surfaces). In the Linetype and thickness dialog box, select the line type and the thickness you want for each type of view, from the associated fields. Click Close when you are done.

By default, linetypes and thicknesses are configured as shown above. If you choose the zigzag linetype (linetype #8), note that this linetype is just a graphical dress-up of the view. This means that if one line is relimited on the breakout line, then it will be relimited on the theoretical line as shown here, and not on the visualized zigzag line.

View generation

View generation mode
From this list, select how you want to generate views.
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By default, Exact view is selected. Exact view Generates exact views from the Design mode, i.e. views for which the geometry is available. The exact generation mode will be the best option in most cases: • This is the fastest generation mode. • All types of views can be generated using this option. • All functionalities (dress-up, dimensions, annotations, etc.) are available. However, there are a few cases in which choosing the exact generation mode will not be appropriate: • In the case of sophisticated products or assemblies involving large amounts of data, generating exact views may consume too much memory. • Polyhedral elements (such as dittos, surfaces, etc.) from V4 .model documents are not supported. When generating exact views for assemblies containing clashing bodies, some geometrical elements may not be generated.

CGR Generates views using the CGR format (CATIA Graphical Representation). CGR corresponds to a data format containing a graphical representation of the geometry only, which is available with the Visualization mode (as opposed to the exact geometry, which is available with the Design mode). With CGR, only the external appearance of the component is used and displayed; the geometry is not available. The corresponding .cgr file, if it exists, is inserted from the cache system. CGR views are not as high in quality as exact views, but they consume much less memory during the generation. This may be useful when dealing with sophisticated products or assemblies involving large amounts of data. However, this generation mode is rather slow. For more information about the advantages and restrictions associated with the CGR generation mode, see Advantages and restrictions common to CGR and Approximate modes below. Approximate Generates views in Approximate mode. Although Approximate views are not as high in precision and quality as exact views, this generation mode dramatically reduces memory consumption. Performances may also be improved, depending on how you fine-tune precision. Therefore, the Approximate mode is particularly well-adapted to
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Project Standards sophisticated products or assemblies involving large amounts of data. The Approximate mode offers about the same advantages and restrictions than the CGR generation mode (see above). However, there are some differences: • • • • Approximate consumes even less memory than CGR. Approximate is faster than CGR, but performances largely depend on finetuning. Approximate provides more approximate results than CGR, but these results largely depend on how you fine-tune precision. Approximate lets you generate section views, section cuts and breakout views. However, note that certain restrictions apply, which are documented in other parts of this user's guide, when appropriate.

You can fine-tune the generation options according to your needs. Click the Configure button. In the dialog box, move the cursor to set the precision (i.e. the level of detail - LOD) with respect to the performances (i.e. generation time - Time). The level of detail corresponds to the precision with which the application determines which edges are hidden and which are not. As a result, decreasing this precision may lead to smaller geometry being visible whenever it should not be, and vice-versa. The higher the precision, the lower the performances. In any case, memory consumption will not be impacted. Click Close when you are done. For more information about the advantages and restrictions associated with the Approximate generation mode, see Advantages and restrictions common to CGR and Approximate modes just below. Advantages and restrictions common to CGR and Approximate Using CGR or Approximate to generate views offers the following advantages: • • Optimize memory consumption when generating and handling projection views for large products or assemblies. Generate views from third-party data (such as MultiCAD), as well as from polyhedral elements (such as dittos, surfaces, etc.) in V4 .model documents.

However, the CGR or Approximate generation mode involves a number of restrictions: • You cannot generate the following types of views: o For CGR: section views, section cuts, detail views, detail view profile, breakout views, unfolded views and views from 3D. o For Approximate: detail views, detail view profile, unfolded views and views from 3D. The following types of elements are not associative on CGR or Approximate views: o For CGR: Auxiliary view profiles, annotations, dimensions, etc. o For Approximate: Auxiliary view profiles, annotations, etc. Dimensions may now be associative, depending on whether you select the Allow the creation of associative dimension in approximate views option in the Dimensions

•
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drawingGeneration associativity on 3D dialog box (see Dimension settings). • • • • You cannot project 3D elements such as wireframe, points, etc. on CGR or Approximate views. CGR or Approximate views cannot contain dress-up elements (axis, center lines, threads). Persistency of graphical properties edition (color, line type, line thickness, no show) and Delete operations performed on generated elements are not available on CGR or Approximate views. CGR or Approximate views being only a graphical representation of the geometry, only line segments are generated in such views. In the case of non-associative dimensions (as is always the case for CGR views, and may be the case for Approximate views when the Allow the creation of associative dimension in approximate views option is not selected), the only elements that can be dimensioned are these line segments. As a result, you may not be able create certain types of radius or diameter dimensions in such views.

As a consequence of these restrictions, selecting either the CGR or the Approximate option disables a number of other options on the View and on the Generation tab.

Raster Generates views as images. This enables you to quickly generate overall views for large products or assemblies, regardless of drawing quality. Such views are associative to the 3D geometry and can be updated when the part or product changes. Raster views offer a number of restrictions: • • • • • You cannot generate the following types of views using this option: view from 3D, section views, section cuts, detail views, breakout views, unfolded views. Raster views cannot contain dress-up elements (axis, center lines, threads). Creating dimensions is impossible. Generally speaking, all commands requiring the selection of geometry are not available. Raster views cannot be edited (you can work around this by isolating the view: double-clicking the image will then launch an image editor).

As a consequence of these restrictions, selecting this option disables a number of other options on the View and on the Generation tab. To optimize disk space and memory consumption, it is recommended that you do not select the Inherit 3D colors option when generating views as images. Click the Configure button to configure the raster mode options. From the Mode list, select the mode that you want to use: Dynamic Hidden Line Removal, Shading, Shading with edges. These modes are equivalent to
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Project Standards the 3D rendering styles. For more information, refer to Using Rendering Styles in the Infrastructure User's Guide. Now, set the level of detail (i.e. the definition, in dpi) that will respectively be used to visualize and to print the drawing. You can choose between three pre-defined modes (Low quality, Normal quality and High quality) and a custom mode (Customize). If you choose to customize the definition yourself, set the dpi for visualization and for print in the appropriate fields. Click Close when you are done.

The level of detail applies to the scale of the view. In some cases (when the view would print with a considerable height or width), there may be too many pixels to generate the view. In this case, the view will be displayed as a red cross-mark. If this happens, try to reduce the scale of the view and/or the level of detail. If you want the colors of a part to be used when generating Raster views using the Shading or Shading with edges mode, remember to select the Inherit 3D Colors option. Otherwise, the view will be generated using shades of grey. To further improve performance when generating Raster or CGR views, we recommend you work in Visualization mode: to do this, in the Options dialog box, go to Infrastructure -> Product Structure -> Cache Management tab and select Work with the cache system. (For more information, see Customizing Cache Settings in the Infrastructure User's Guide and Visualization mode in the Product Structure User's Guide.)

By default, this option is not selected.

Exact preview for view generation
Make sure this option is selected if you want an exact preview when
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drawingGeneration generating views. As a result, the part or product will be loaded in Design mode when previewing the view to generate, even if you are working in Visualization mode. Deselect this option to get a quick preview of the 3D document when generating views. In this case, a part or product open in Visualization mode will not be loaded in Design mode for the preview, which optimizes memory consumption. By default, this option is selected.

Only generate parts larger than
To specify that you only want to generate parts which are larger than a certain size, select this option and indicate the appropriate size by providing a value in millimeters in the appropriate field. By default, this option is not selected.

Enable occlusion culling
Select this option if you want to save memory when generating exact views from an assembly which is loaded in Visualization mode (i.e. when the Work with the cache system option is active). This will load only the parts which will be seen in the resulting view (instead of loading all of them, which is the case by default), which optimizes memory consumption and CPU usage. To ensure the efficiency of this option, make sure that the Exact preview for view generation option is not selected. In the case of an assembly which is loaded in Design mode, or in the case of a part, the Enable occlusion culling option will help increase performance by reducing CPU usage. Keep the following restrictions in mind when selecting the Enable occlusion culling option: • The Project 3D points option will be disabled. • The only option available for Project 3D wireframe is Can be hidden. • If you choose to project 3D wireframe, you will need to make sure that your wireframe elements have been taken into account when the CGR data was created: this is the case if you activated the Save lineic elements in cgr option from Tools -> Options -> Infrastructure -> Product Structure -> Cgr Management before the creation of CGR data (i.e. before you launched the part or product in Visualization mode). If not, you need to activate the Save lineic elements in cgr option and then re-create the CGR data. To do this: 1. Close all open parts and products and exit the application. 2. Delete your CGR data from the cache. (The cache location is specified in Tools -> Options -> Infrastructure -> Product Structure > Cache Management tab, Path to the local cache field.)
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Select body in assembly
Select this option if you want to be allowed to create a view selecting one or several bodies in an assembly. By default, the box is not checked and the following error message is displayed if you try to generate a view from a body.

Once Select body in assembly is checked, a warning is displayed when creating the view as you are strongly advised not to use this option. Actually, generating a view on a body from a .CATProduct prevents many features from working properly: • • • • • • Positioning of the different parts in the assembly is not taken into account in the resulting view and parts might be superimposed, Changes such as rotation or translation in the assembly are not taken into account, Modification of an instance properties such as visibility or colors are not taken into account, Overload properties is disabled as it is linked to the assembly's properties, Creation of balloons is not possible, Edit/ Links option references only two parts.

Moreover, multi-selecting a body in two different parts modifies the behavior of the Modify links and Modify Projection Plane according to the order of selection, since the .CATPart of the first selected body will be used as reference document and not the .CATProduct.

Clipping view

Select this option if you want dimensions to be put automatically in no show mode for non-visible geometry in clipping view. Dimensions are put in no show mode only if both parent elements of the dimension are in the non-visible geometry. If only one parent element is impacted, the dimension turns to light blue. For more information, refer to the description of the
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View From 3D

Keep layout and dress-up of 2D extracted annotations
Select this option if you want the layout and dress-up applied to 2D extracted annotations to be preserved when updating a view from 3D (Functional Tolerancing and Annotation workbench). • 2D dress-up modifications are kept when updating design changes from 3D. • Associativity of the annotations or their leader with the 3D geometry is taken into account. • Associativity between annotations is taken into account. By default, this option is not selected.

Generate 2D geometry
Select this option if you want to generate 2D geometry (i.e. wireframe and 2D points) when generating a view from 3D from a layout view (2D layout for 3D Design workbench). By default, this option is selected.

Generation
This page deals with the following categories of options in the Generation tab: • • Dimension generation Balloon generation

These options apply to the Generative Drafting workbench only.

Dimension generation
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Generated dimensions are positioned according to the most representative views. In other words, a dimension will appear on a view so that it does not need to be created on another view. The dimensions are generated on the views on the condition the settings were previously switched to the dimension generation option.

Generate dimensions when updating the sheet

Select this option to generate dimensions automatically each time you update the sheet. By default, this option is not selected.

Filters before generation

Select this option to display the Dimension Generation Filters dialog box before generation. This enables you to specify what type of dimensions you want to generate. Also, in assembly or product views, this lets you indicate what parts you want to generate dimensions for. By default, this option is not selected.

Automatic positioning after generation

Select this option if you want the dimensions to be automatically positioned after generation.
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By default, this option is not selected.

Allow automatic transfer between views

Select this option if you want dimensions to be automatically transferred to the most appropriate view when regenerating dimensions. By default, this option is not selected.

Analysis after generation

Select this option to display the Generated Dimension Analysis dialog box after generation. By default, this option is selected.

Generate dimensions from parts included in assembly views

Select this option to extract 3D part constraints (on top of assembly constraints) when generating product dimensions. This option is particularly useful if you want to generate dimensions for all parts included in assembly or product views, without displaying the Dimension Generation Filters dialog box before dimension generation. Note that if you display the Dimension Generation Filters dialog box before generating dimensions, you will need to indicate what parts you want to generate dimensions for (whether this option is selected or not). By default, this option is not selected.

Delay between generations for step-by-step mode
Specify the delay between each dimension generation when generating dimensions step by step.
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By default, this option is not selected.

Balloon generation

Creation of a balloon for each instance of a product
If you select this option, a balloon will be generated for each instance of a component: therefore, if a component is used two times within a product, then the balloon will be generated twice. If you leave this box unselected, a single balloon will be generated for all instances of the same component, when a component is used several times within a part or product. By default, this option is not selected.

Geometry

This page deals with the following categories of options in the Geometry tab: • • • • Geometry Constraints creation Constraints Display Colors

Geometry

Create circle and ellipse centers
You can decide whether or not you want to create centers when creating circles or ellipses. Click to clear this option if you do not need to create circle and ellipse centers. By default, this option is selected.
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Allow direct manipulation
Select this option to be able to move geometry using the mouse. When moving geometry, you can move either the minimum number of elements, the maximum number of elements, or still the minimum number by modifying the shape of elements, if needed. By default, this option is selected. Additionally, click the Solving mode... button to configure manipulation.

The dialog box that appears offers the following options as regards the solving mode: Standard mode You move as many elements as possible and also respect existing constraints. Minimum move You move as few elements as possible and also respect existing constraints. Relaxation You move elements by re-distributing them over the sketch, globally speaking. This method solves element moving by minimizing energy cost. Furthermore, you can choose to drag elements along with their end points by selecting Drag elements end points included. By default, Minimum move and Drag elements end points included are selected.

Show H and V fields in the Tools Palette
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You can show the H and V fields in the Tools Palette when creating 2D geometry or when offsetting elements. Leaving the option unselected enables you to directly enter the value corresponding to the type of element you are creating: for example, the length when creating a line, the radius when creating a circle or the offset value when offsetting elements. When a command (such as the Point creation command) does not have any parameters other than H and V, then these two fields will remain in the Tools Palette, whether you select this option or not. By default, this option is not selected.

Create end points when duplicating generated geometry
When duplicating geometry that was generated from the 3D, you can choose to create end points for these geometrical elements. By default, this option is not selected.

Constraints creation

Create detected and feature-based constraints
Select this option if you want to create the geometrical or dimensional constraints detected by the SmartPick tool. If all of the detection options are unselected, this option is not available. If this detection option is unselected, the Create detected constraints option will be inactive by default in the Tools toolbar. You will be able to activate it at any time. By default, this option is not selected.

SmartPick... (button)

As you create more and more elements, SmartPick detects multiple directions and positions, and more and more relationships with existing elements. This may lead to confusion due to the rapid
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highlighting of several different detection possibilities as you point the cursor at different elements in rapid succession. Consequently, you can decide to filter out undesired detections by clicking the SmartPick... button.

The SmartPick dialog box provides these options: • • • • Support lines and circles Alignment Parallelism, perpendicularity and tangency Horizontality and verticality

Click to clear the elements you do not wish to detect when sketching. Disabling SmartPick completely (i.e. clearing all options in the SmartPick dialog box) is particularly useful when your screen is full of elements: in this case, it may be a good idea to disable SmartPick to concentrate only on the geometry. By default, all options are selected.

Constraints Display

Display constraints
Select this option to visualize the logical constraints specific to the elements. Note that if the Display constraints option is cleared, the other options in this category are not available.
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By default, this option is selected.

Reference size

Specify the size that will be used as a reference to display constraints symbols. Changing this reference size will modify the size of all constraints representations. By default, the reference size is 2 mm.

Constraints color

Choose the color that will be used to display constraints. By default, the color for constraints is blue.

Constraints types... (button)

Click this button to define which types of constraints you will visualize as you create the geometry.

The Constraints types dialog box provides these options: • Horizontal • Vertical
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• • • • • •

Parallelism Perpendicularity Concentricity Coincidence Tangency Symmetry

Click to clear the types of constraints you do not want to visualize as you create the geometry. By default, all options are selected.

Colors

Two types of colors may be applied to sketched elements. These two types of colors correspond to colors illustrating: • Graphical properties Colors that can be modified. These colors can therefore be modified using the Tools->Options dialog box.

OR • Constraint diagnosis Colors that represent constraint diagnoses are colors that are imposed to elements whatever the graphical properties previously assigned to these elements and in accordance with given diagnoses. As a result, as soon as the diagnosis is solved, the element is assigned the color as defined in the Tools -> Options dialog box.

Visualization of diagnosis

Select this option if you want over-constrained, inconsistent, notchanged or iso-constrained elements to be identified using specific colors. By default, this option is selected. Then, click the Colors... button to configure these colors.
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In the dialog box that appears, you can configure colors for the following types of elements: Over-constrained elements The dimensioning scheme is over-constrained: too many dimensions were applied to the geometry. Inconsistent elements At least one dimension value needs to be changed. This is also the case when elements are under-constrained and the system proposes defaults that do not lead to a solution. Not-changed elements Some geometrical elements are over-defined or not-consistent. As a result, geometry that depend(s) on the problematic area will not be recalculated. Iso-constrained elements All the relevant dimensions are satisfied. The geometry is fixed and cannot be moved from its geometrical support. By default, colors are configured as shown above.

Other color of the elements

Click the Colors... button to configure the colors of other elements.
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In the dialog box that appears, you can configure colors for the following types of elements: Construction elements A construction element is an element that is internal to, and only visualized by, the sketch. This element is used as positioning reference. It is not used for creating solid primitives. SmartPick Colors used for SmartPick assistant elements and symbols. By default, colors are configured as shown above. When opening a drawing, colors are not recomputed. Colors will not be displayed until you create another element or move the geometry.

Dimension

This page deals with the following categories of options in the Dimension tab: • • • • Dimension Creation Move Line-Up Analysis Display Mode

Dimension Creation
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Dimension following the mouse (ctrl toggles)
Select this option to specify that the dimension line should be positioned according to the cursor, following it dynamically during the creation process. By default, this option is selected.

Default dimension line/geometry distance

If you position the dimension according to the cursor, you can define the value at which the dimension is created. If you create associativity between the dimension and the geometry, you can define the value at which the dimension will remain positioned. By default, this option is set to 5 mm.

Constant offset between dimension line and geometry

Select this option to specify that the distance between the created dimension and the geometry should remain the same when moving the geometry. By default, this option is not selected.

Associativity on 3D... (button)
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If you click the button, the Dimensions associativity on 3D dialog box appears. These options are used in a Generative Drafting context, and specify how associativity between dimensions and the 3D part or product is handled. When they are associative, dimensions are linked to the 3D part or product. As a result, when you update the drawing, the dimension is automatically re-computed. When dimensions are not associative, you need to re-create them after performing an update.
Associativity on 3D

When creating dimensions in a Generative Drafting context, specify whether and how dimensions should be associative with the 3D part/product: • Only create non-associative dimensions: dimensions will never be associative with the 3D. • Allow non-associative dimensions: dimensions are associative with the 3D whenever possible, but dimensions that cannot be associative with the 3D are also created. • Never create non-associative dimensions: only dimensions that can be associative with the 3D are created. By default, Allow non-associative dimensions is selected.
Associativity in "Approximate" mode views

Select the Allow the creation of associative dimension in approximate views option if you want the option chosen in the Associativity on 3D section above to be applied to dimensions in Approximate views (i.e. views generated using the Approximate view generation mode). This option only applies to the following dimension creation commands: Dimensions, Chained Dimensions, Cumulated Dimensions, Stacked Dimensions, Distance/Length Dimensions, Angle Dimensions, Radius Dimensions, Diameter Dimensions, Chamfer Dimensions, Dimension Systems. It does not apply to other dimension types, nor to driving dimensions. If this option is not selected, dimensions will not be associative in Approximate views (as was the case prior to V5R15), which minimizes memory requirements. By default, this option is not selected.
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Create driving dimensions
Select this option if you want newly created dimensions to drive the geometry. A new field will appear in the Tools Palette during the creation process, allowing you to enter the driving dimension value.

By default, this option is not selected.

Detect chamfer
Select this option to activate chamfer detection: this will lets you create chamfer dimensions in a single click. As chamfer detection may slow performance down, you may want to deactivate this option for large products or assemblies. By default, this option is selected.

By default, create dimensions on circle's
Specify whether the dimension you will create between a circle and another element should be on the circle center or on the circle edge. By default, the Center option is selected.

Move

371

drawingGeneration

Configure snapping
Click the Configure snapping button to define how snapping should be performed. In the dialog box that appears, specify whether the dimension should be snapped on the grid, whether the dimension value should be located at its default position between symbols (it will work only if the cursor is between the symbols), or both. By default, Value between symbols is selected.

Snap by default (SHIFT toggles)
Select this option to activate snapping by default when creating or handling dimensions. Pressing the Shift key will enable you to temporarily deactivate snapping. Note that snapping is performed according to the options set in the Configure snapping dialog box. With this option unselected, snapping is not active. In this case, pressing the Shift key will enable you to temporarily activate it. By default, this option is selected. Before V5 R15, this option used to be called Activate Snapping (SHIFT toggles).

Move only selected sub-part
Select this option if you want to move only a dimension sub-part (text, line, etc.). By default, this option is not selected.
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Line-Up

You can organize dimensions into a system with a linear offset. The offset will align the dimensions to each other as well as the smallest dimension to the reference element.

Default offset to reference

This allows you to set the offset between the smallest dimension and the reference element. By default, the offset is 0 mm and 0 deg.

Default offset between dimensions

This allows you to set the offset between dimensions. By default, the offset is 10 mm and 15 deg.

Align stacked dimension values

Lets you align all the values of a group of stacked dimensions on the value of the smallest dimension of the group. By default, this option is not selected.

Align cumulated dimension values
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Lets you align all the values of a group of cumulated dimensions on the value of the smallest dimension of the group. By default, this option is selected.

Automatically add a funnel

Whenever the value of a cumulated dimension requires a funnel to be displayed correctly, lets you have one added automatically. By default, this option is selected.

Analysis Display Mode

Activate analysis display mode
Select this option to display dimensions using different colors according to their status (not-up-to-date, isolated, fake, etc.). By default, this option is selected. Additionally, click the Types and colors button to customize the colors that will be used. The Types and colors of dimensions dialog box lets you assign the desired color(s) to the selected dimension types. You will then be able to visualize the different types of dimensions using their assigned colors.
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By default, colors are configured as shown above.

Manipulators
This page deals with the following categories of options in the Layout tab: • • Manipulators Dimension Manipulators

Manipulators

These settings can be used for any type of manipulator (texts, leaders, center lines, dimensions and so forth).

Reference size
Specify the reference size that should be used for manipulators. In the case of texts, for example, this reference size corresponds to the diameter of the rotation manipulators.
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By default, the reference size is set to 2mm.

Zoomable
Check this box if you want to make manipulators zoomable. By default, this option is selected.

Dimension Manipulators

These options let you define which manipulators you will visualize and therefore use when creating and/or modifying dimensions:

Modify overrun
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If you drag select one overrun manipulator, both overrun extension lines are modified. To modify only the selected overrun extension line, use the Ctrl key. You can also double-click on the manipulator and enter the new value in the dialog box that appears. By default, the Creation and Modification options are not selected.

Modify blanking

If you drag select one blanking manipulator, both blanking are modified. To modify only the selected blanking, use the Ctrl key. You can also double-click on the manipulator and enter the new value in the dialog box that appears. By default, the Creation option is not selected, and the Modification option is.

Insert text before

Allow inserting a text before, without using the Properties dialog box. For this, you will click on the manipulator and enter the new text in the dialog box that appears. By default, the Creation and Modification options are not selected.

Insert text after

Allows inserting a text after, without using the Properties dialog box. For this, you will click on the manipulator and enter the new text in the dialog box that appears. By default, the Creation and Modification options are not selected.

Move value

377

drawingGeneration

Lets you move only the dimension value. By default, the Creation and Modification options are not selected.

Move dimension line

Lets you move only the dimension line by dragging it to the new location. By default, the Creation and Modification options are not selected.

Move dimension line secondary part

Lets you move only the dimension line secondary part by dragging it to the new location. By default, the Creation and Modification options are not selected.

Annotation and Dress-Up

This page deals with the following categories of options in the Layout tab: • • • • • Annotation Creation Move 2D Component Creation Balloon Creation Table

Annotation Creation
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In order for these options to be taken into account, the Snap by default (SHIFT toggles) box must be selected. Note that the option selected in the Snapping Configuration for Annotations dialog box will be taken into account. See the Move section. These options are taken into account only when creating annotations, not when adding a reference line, for example.

Create text along reference

Select this option if you want to create annotation texts along a reference direction. For example, if you select a line when creating a text, the text will be oriented parallel to the line. By default, this option is not selected.

Text

Select this option if you want to create the extremity of text leaders normal to a reference direction. For example, if you select a line when creating a text with leader, the leader will be normal to the line. By default, this option is not selected.

Geometrical tolerance

Select this option if you want to create the extremity of geometrical tolerance leaders normal to a reference direction. For example, if you select a line when creating a geometrical tolerance, the leader will be normal to the line. By default, this option is not selected.

Move
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Configure snapping
Click the Configure snapping button to define how snapping should be performed. In the dialog box that appears, specify whether you want annotations to be snapped on the grid, according to the leader orientation, or both. This will apply to the annotations selected in the Annotation Creation area. By default, Both is selected.

Snap by default (SHIFT toggles)
Select this option to activate snapping by default when creating or handling annotations. Pressing the Shift key will enable you to temporarily deactivate snapping. Note that snapping is performed according to the options set in the Snapping Configuration for Annotations dialog box. With this option unselected, snapping is not active. In this case, pressing the Shift key will enable you to temporarily activate it. By default, this option is selected. • From V5 R15 onwards, the Snap to Point option on the General tab no longer applies to annotations. Only this option is taken into account. • Before V5 R15, this option used to be called Activate Snapping (SHIFT toggles). It has been renamed for clarity reasons.

2D Component Creation
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Create with a constant size
Select this option if you want all 2D component instances to have the same size when you create them, no matter what the view scale is. This lets you create 2D component instances whose size is independent from the view scale so that they always look the same. You can use them as symbols, for example. If you want to use as symbols 2D components with text, activate both the Create with a constant size setting and the Apply Scale property for the text (in Edit -> Properties): the size of both the 2D component and its text will then be independent from the view scale. By default, this option is not selected.

Prevent direct manipulation
Select this option to make it impossible to move 2D components using the mouse. By default, this option is not selected.

Prevent direct scaling
Select this option to make it impossible to scale 2D components using the mouse. By default, this option is not selected.

Balloon Creation

You can specify what kind of balloons you want to create (using the Balloon command from the Annotation toolbar) or to generate (using the Generate Balloons command from the Generation toolbar).

3D associativity
Select this option to indicate that you want to associate balloons with
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information from the 3D. By default, this option is selected. Additionally, select from the list the kind of balloons you want to create or generate: the numbering of parts within an assembly (default option), the instance name or the part number. By default, Numbering is selected.

Table

Recompute table when editing cell
Select this option if you want a table to be resized while you are editing a cell. If it is not selected, the table is resized after closing the Text Editor. By default, this option is selected.

Do not split table on several sheets
This option is available only when certain licenses are installed. With certain licenses, tables are split automatically on several sheets. Unselect this option if you want to keep tables on a single sheet. By default, this option is not selected.

Administration

This page deals with the following categories of options in the Administration tab: • • • • Drawing management Style Generative view style Dress-up

Drawing management
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Prevent File>New
Select this option to make it impossible to create drawings using the File > New command. All drawings will be created using the File -> New From... command instead. By default, this option is not selected.

Prevent switch of standard

Select this option to make it impossible to change standards, i.e. to use a standard other than the one currently defined in the Page Setup dialog box. By default, this option is not selected.

Prevent update of standard

Select this option to make it impossible to update standards for the current document in the Page Setup dialog box. By default, this option is not selected.

Prevent background view access

Select this option to make it impossible to access the background view. By default, this option is not selected.
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Style

Use style values to create new objects
Select this option if you want dialog boxes, Properties toolbars and the Tools Palette to be pre-filled with custom style values (as defined in the Standards Editor) when creating new annotations. In this case, Properties toolbars and the Tools Palette will be disabled during the creation of the annotation. If you leave this box unchecked, annotation dialog boxes, Properties toolbars and the Tools Palette will be pre-filled with the last entered values (except for Texts, Texts with leader, Balloons and Datum features). In this case, Properties toolbars and the Tools Palette will be active during the creation of the annotation. If you select this option, you will be able to reset the current style values in dialog boxes at any time using the Reset button unless it is disabled. By default, this option is not selected.

Create new sheet from (for pre-V5R14 drawings)
This option lets you specify if the properties used for creating new sheets should be those defined in the standards or those defined in the first sheet of a drawing. These properties are the scale and the projection method (first or third angle). Select Style if you want the sheet to use the style defined in the standards (in Tools -> Standards -> Drafting -> [StandardName] -> Styles -> Sheet). Select First sheet if you want the sheet to use the properties defined in the first sheet of a drawing. For example, you can use this option if you use an existing drawing to create a new one (i.e. when you want the new drawing to have the same properties as the existing drawing). This option applies only to drawings created with versions prior to V5R14.
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By default, First sheet is selected.

Lock "User Default" Style
Select this option to make it compulsory to use User Defaults (i.e., userdefined values set as default). The Styles drop-down list will be set to Only User Defaults and will be inactive so that Original Defaults or User Defaults cannot be selected. This option applies only to drawings created with versions up to V5 R10 whose standard has NOT been updated or changed in V5 R11 and later. By default, this option is not selected.

Prevent "Set As Default" and "Reset All Defaults"

Select this option to use the current defaults and to make it impossible to create, change and reset user defaults (i.e. user-defined values). This disables the Set as Default and the Reset All Defaults commands. This option applies only to drawings created with versions up to V5 R10 whose standard has NOT been updated or changed in V5 R11 and later. By default, this option is not selected.

Display Reset button in dialog boxes

Select this option to display the Reset button in dialog boxes. Deselecting this option hides the Reset button in dialog boxes and disables the Reset functionality. By default, this option is selected.

Generative view style

Prevent generative view style usage
Select this option if you do not want to use generative view styles when creating or updating views. In this case, you will not be able to select a
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generative view style after having selected a view creation command, which means that the Generative View Style toolbar will not be displayed. (In the case of advanced front views, it is the Generative view style list in the View Parameters dialog box which will not be displayed). Note that this option also drives view generation parameters when updating views, whether the view was created using generative view styles or not. In this case, there are two possibilities: • If you created the view using generative view styles (i.e. with this option selected) and then de-select this option, then, at the next update, the view properties (available via Edit -> Properties) will be used for all overloaded parameters (an asterisk * appears in the Properties dialog box in front of the parameters which are considered as being overloaded) and the view settings (available via Tools -> Options -> Mechanical Design -> Drafting - > View tab) will be used for the others. If you created the view without generative view styles (i.e. without this option selected) and then select this option, then, at the next update, all parameters available in the view properties (available via Edit -> Properties) will be considered as being overloaded and will be used. To make sure that generative view styles are used in this case, click the Reset to style values button in the Properties dialog box.

•

For more information, refer to the Generative View Styles chapter in the Generative Drafting User's Guide. By default, this option is selected.

Dress-up

Prevent dimensions from driving 3D constraints
Select this option to make it impossible to modify a 3D constraint via a 2D dimension that was generated from it. By default, this option is selected.

Customizing Toolbars
You can customize the appearance of some fields in the following properties toolbars: Styles, Graphic Properties, Text Properties and Dimension Properties.
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1. Right-click the toolbar field you want to customize. A contextual menu is displayed. 2. If necessary, scroll down this contextual menu to display the toolbar customization options.

The customization options that you can apply to the selected field are displayed.

The options available depend on the selected field. For more information on what options are available for each field, see the table below. 3. Click the option you want. Depending on the option you selected, the corresponding dialog box appears. 4. Enter the appropriate value in the dialog box. • • • • • Set text width: sets the width used to display the field in the toolbar, in number of characters to be displayed (based on 'W'). Set list width: sets the width used to display the drop-down list, in number of characters to be displayed (based on 'W'). Set list height: sets the height used to display the list, in number of lines to be displayed (up and down arrows will make it possible to scroll within the list). Icons display: defines whether icons should be displayed in this field, or only in the list, when the list is collapsed. Precision: sets the precision used to display a numerical value in this field, in number of digits after the separator.

5. Click OK to validate.

The table below indicates which fields you can customize in each toolbar, along with what you can customize for each field.
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Set text width Style toolbar Style Yes

Set list width

Set list height

Icons display

Set precision

Yes

Yes

Yes

No

Text Properties toolbar Font Name Font Size Yes Yes Yes Yes Yes Yes Yes No No Yes

Dimension Properties toolbar Tolerance Description Tolerance Numerical Display Description Precision Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes No No No No No No Yes

Graphic Properties toolbar Color Thickness Linetype Point type Yes Yes Yes Yes No No No No No Yes Yes Yes No No No No No No No No

388



        

			

		

		
		
			


Podobne pliki
	InteractiveDrawing (ang)
	drawingViewer (ang)
	3D modeling in AutoCad - tutorial (ang)
	Rendering and Materials (ang)
	Prawie wszystko o EDM (ang)
	tutorial3 Using Matlab in linear algebra (ang)
	Creating a Footprint Map Using AutoCAD tutorial (ang)
	Manufacturing-tolerances (ang)
	TOLERANCE ANALYSIS OF COMPLIANT ASSEMBLIES (ang)
	Manual Autocad 2008 (ang)


Ostatnio dodane
	Skrypt - Zadania miarowe
	Skrypt - Wzajemne Polożenie dwoch prostych
	Skrypt - Rzeczywista dlugosc odcinka
	Skrypt - Przebieg Prostej
	Skrypt - Odwzorowanie plaszczyzny
	Skrypt - Odwzorowanie elementow geometrycznych
	Skrypt - Elementy wspólne
	Skrypt - Elementy równoległe i prostopadłe
	Skrypt - Elementy przynależne
	katowniki nierownoramienne


		

		
		 

	

	




	
		© 2009-2012 mechanics.pl     polityka prywatności     sitemap

	

	
	
	











